MSD 高效化学工作站概述

MSD Productivity ChemStation（MSD 高效化学工作站）控制着 6890 GC 或 GC/MSD 的数据采集，进行谱库检索和定量分析，并通过处理方法或序列生成所选的文件。它提供了很多用于数据处理的高效率工具，如 QEdit、DOSCAN、DOLIST 和 EasyID ，以及访问系统的两个安全级别。

在软件中，仪器系统由一组"视窗"来表示：

  • Top（顶部）视窗

  • Instrument Control（仪器控制）视窗

  • Enhanced Data Analysis（增强型数据分析）

  • Manual Tune（手动调谐），Diagnostics（诊断）— 质谱用户在校准、排除仪器故障时需要用到的视窗。这些视窗必须在 Instrument Control（仪器控制）中的 View（查看）菜单中进行调用。

MSD 高效率化学工作站软件通过配置，能支持两种类型的仪器：只存在气相色谱 (GC) 和气相色谱/质谱系统(GC/MS) 。只配置 GC 仪器的系统与同时还配置有质谱的仪器，它们的菜单与菜单项存在一些差异。这些差异将在有关菜单的在线帮助中指出。MSD 高效化学工作站还可以采集和检验复合模式（GC/检测器和 GC/MS）的数据。

此外，由于一些屏幕是 GC 和 MS 系统所共有的，一些专指质谱的信息字段并不适合于 GC 的数据分析。在这些情况下，帮助文件中标记的特定字段仅对质谱有效。

该软件由用户定制的处理方法进行驱动，处理方法应指定了数据采集和分析的参数。

另见

使用方法

使用序列

目录结构

仪器控制设计

顶部菜单

安全控制概述

Top（顶部）视窗

在 Top（顶部）视窗中可以编辑方法，设立和启动一次运行或序列，对质谱进行调谐，进入 Data Analysis（数据分析）软件。此外，实验室管理员还可以设立两级安全系统，控制对化学工作站的访问。

运行方法或序列时，Top（顶部）显示所有视窗的状态。Top（顶部），Instrument Control（仪器控制），Data Analysis（数据分析）。直到处理方法运行完毕，显示才结束。

这个显示对于监测序列进程很有帮助。在序列运行时，如果要在样品日志表中修正或添加项目，请选择 Edit Samp Log Tbl（编辑样品日志表）。在序列运行时，如果要检查数据文件，请选择 View / Data Analysis（查看/数据分析）。若要中止处理方法或序列，请选择 Abort（中止）。

Instrument Control （仪器控制）视窗

大多数工作都从 Instrument Control（仪器控制）视窗开始。在 Top（顶部）视窗中，可以编辑方法，设立和启动一次运行或序列，对质谱进行调谐，进入 Data Analysis（数据分析）软件。您可以进行微调，监测 GC 和/或 MSD 的离散部件，显示不同的状态监测器。软件安装好后，这个视窗出现在 Top（顶部）菜单条的正下方。

Enhanced Data Analysis（增强型数据分析）

Data Analysis（数据分析）视窗是一个脱机"视窗"，相对其他视窗独立工作。要打开 Data Analysis（数据分析）视窗，您可以选择 Top（顶部）的 View（查看） 菜单或在 Windows Programs 菜单里进行选择。用 Data Analysis（数据分析）视窗对数据进行积分、定量和鉴定。

它还包含有各种高效的数据处理工具，如 QEdit、DOSCAN、OLIST 和 EasyID 。


使用帮助

使用化学工作站中的 Help（帮助）菜单访问联机帮助时，将显示 Help Topics（帮助主题）窗口。此窗口具有下列文件夹标签：

Contents（目录）

显示有关可用帮助主题的列表。此列表使用帮助图标，有助您查找信息。

Help Topics（帮助主题）窗口中使用下列图标：

表示一本包含更多帮助主题的书。要打开一本书，请选中该书，然后双击。

表示一本已打开的具有帮助主题的书。要合上一本书，请选中该书，然后双击。

表示一个帮助主题。要跳过一个帮助主题，请选中该主题，然后双击。

Index（索引）

当您需要查找联机帮助中的某个特定主题时，请使用 Index（索引）选项卡。特定主题是通过使用关键字和词来设定的。当检索窗口显示时，请键入主题的前几个字符，例如，对于 tuning，键入“tu”。将显示所有以“tu”开头的项。

使用滚动条扫描这些项。双击所需的关键字。在线帮助中的相关主题标题列表将显示在窗口底部。双击所需主题，将出现在线帮助。

Search（检索）

键入关键字或词，然后将显示联机帮助中所有包含这些字的主题。

按钮

Help Topics（帮助主题）窗口具有下列按钮：

Hide/Show （隐藏/显示） | 用来打开或关闭帮助目录面板的显示。
Back/Forward （前进/后退） | 前进或后退至前面显示过的帮助主题。
Print （打印） | 用于打印当前的书或帮助主题。


访问我们的网站

要获取有关 Agilent 5973N MSD　的更多的信息，请访问我们的网站 www.agilent.com/chem/msd。

注 您可能需要启动您的网络浏览器（如 Netscape Navigator、Windows Internet Explorer 或 America Online），然后建立互联网连接才能访问这个网站。


系统认证声明

兹此声明下列软件产品/系统

G1701DA，G1710DA

产品编号

MSD 高产率化学工作站

产品名称

D.00.00 依此类推直到更换为止

修订号

根据安捷伦科技公司化学分析组运作周期进行开发和测试。交付的运作周期检测点由管理层检查和批准。产品在放行出货前已达到其功能和性能规格以及放行标准。

该证书用于协助我们的用户达到 GLP 要求。为了支持这些要求，我们将为授权政府机构或管理机构对安捷伦科技公司 (California Avenue Site, Palo Alto, California) 的检查提供下列文件。

  • 产品说明

  • 周期阶段的检查批准文档

  • 测试文档

  • 缺陷文档

  • 设计文档

  • 修订状况

安捷伦科技公司保留对所有文档及其复制品的所有权，并可要求需要使用这些文档的使用者提供保密协定。

2001 年 11 月 1 日

日期

工程经理

质量经理

产品说明

    用户文档

    外部参考规格

周期阶段的检查批准文档

    提案阶段

    调查阶段

    设计阶段

    实施阶段

    测试阶段

测试文档

    测试计划

    测试原本

    验收标准

    测试结果

缺陷文档

    缺陷报告

    缺陷的量度标准

设计文档

    软件开发环境

    构造说明

    内部设计文档

    源代码

修订状况

    每一修订版的更改文档

    软件配置管理系统


采集数据

Instrument Control（仪器控制）视窗在启动 MSD 化学工作站时显示。此处可以设定和监测仪器参数。如果正处于其他窗口，当您准备好设定数据采集系统后在菜单栏选择 View / Instrument Control（查看/仪器控制）。


采集 GC/MS 数据（概述 - 6890）

如何采集数据取决于您是否希望改变方法。单击您希望采取的数据采集类型：

使用现有方法开始运行

编辑整个方法并且开始运行

改变当前加载的方法并且开始运行

另见

使用方法

使用序列


使用现有方法开始运行

  1. 从菜单栏中选择 Method / Load（方法/加载）并选择这次采集要使用的 *.M 文件并单击 OK（确定）。如果已经加载了方法，进行步骤 2。

    注意 当在一个配置了 5973 MSD（仅适用于 6890 GC）的系统上加载方法时，软件比较实际源/四极杆温度与存储在调谐文件（调谐文件为方法的一部分）中的设定值。如果它们不在三摄氏度公差内，您将被询问是否下载新的设定值。

  2. 选择 Method / Run（方法/运行）将显示 Start Run（开始运行）面板。

  3. 在 Start Run（开始运行）面板中输入信息并单击 Run Method（运行方法）按钮。

    Top（顶部）视窗在采集开始时图标化。要在状态显示上监测方法的进程，双击该图标。

    注意 在 5973 MSD 系统（仅适用于 6890 GC）上，当开始运行时，运行将直到源和四极杆温度在三摄氏度公差内平衡时才能开始。可以越过这段等待时间并且如果这段平衡时间被越过，将在日志文件中生成一个注释。

  4. 可以使用 Instrument Control（仪器控制）面板查看系统监测器或进行任何运行时间的改变。


编辑整个当前方法并开始运行 (6890)

编辑整个方法并开始运行

此程序对 6890 GC 而言。

  1. 在菜单栏中选择 Method/ Load（方法/调用）。

  2. 选择您希望进行编辑的 *.M 文件，然后单击 OK（确定）。

注意 向配置有 5973 MSD 的系统调用方法时，软件将对实际离子源/四极杆温度和存储在该方法的调谐文件中的设定值进行对比。如果它们超过三摄氏度的公差范围，系统将询问您是否希望下载新的设定值。

  3. 在菜单条中选择 Method/ Edit Entire Method（方法/编辑整个方法）。如果您选择编辑方法中的 Instrument/ Acquisition（仪器/采集）部分，系统提示您进行如下操作：

  4. 设定进样口和进样参数。

  5. 设定所需的 GC 参数：将显示 GC Instrument| Edit（GC 仪器| 编辑）屏幕。

  • 选择您想修改的 GC 控制（单击图标条中对应的图标）。

  • 依您的意愿修改项目。

  • 如有必要，从图标条中选择另一图标。当您还没有在 Instrument（仪器）| Edit（编辑）图标条中选中所有您想修改的图标之前，一定不要单击 OK（确定）。

  • 当您已经完成了对所有仪器控制的修改，单击 OK（确定），继续编辑整个方法过程。

  6. 可选。显示 GC 实时图。

  7. 选择质谱调谐文件 (*.U)。

  8. 设定 MS SIM 或扫描参数

  9. 在新的文件名下保存方法。

  10. 若要启动采集，在菜单条中选择 Method/ Run（方法/运行），填写 Start Run（启动运行）面板，然后单击 Run Method（运行方法）按钮。

当采集启动后，Top（顶部）视窗将变成图标。若要在状态显示中监测方法的进程，请双击该图标。

注意 在 5973 MSD 系统中，只有当离子源和四极杆温度在三摄氏度的公差范围内达到平衡时，运行才会开始。您可以跳过该等待时间，记录文件中将注明平衡被越过。

  11. 使用 Instrument Control（仪器控制）面板来查看系统监测器或进行运行过程中的改变。


改变当前方法并开始运行 (6890)

改变当前方法并开始运行

该程序用于 6890 GC。

  1. 选择 Method / Load（方法/加载）。

  2. 选择您希望用于采集的 *.M 文件，然后单击 OK（确定）。

注意 向配置有 5973 MSD 的系统加载方法时，软件将对比实际离子源/四极杆质量过滤器温度和存储在该方法的调谐文件中的设定值。如果它们超过三摄氏度的公差范围，系统将问您是否希望下载新的设定值。

  3. 设定进样口和进样参数。

  4. 设定所需的 GC 参数：

单击该按钮，在弹出的菜单中选择 Edit GC Oven（编辑 GC 柱箱）。根据要求编辑参数表，然后单击 OK（确定）。

  5. 显示 GC 实时图。

  6. 可选：

单击该按钮，选择 Select MS Tune File（选择 MS 调谐文件）为当前方法选择一个不同的调谐文件。

  7. 可选。在菜单栏中选择 Instrument / Edit MS Tune Parameters（仪器/编辑 MS 调谐参数）改变当前调谐文件中的采集和显示参数。

单击该按钮，选择 MS SIM/Scan（MS SIM/扫描）为 MSD　设置扫描参数。

  9. 可选。设置采集中将出现的任何 MS 时间事件。

  10. 可选。设置您希望使用的 GC 监测器或 MS 监测器。

  11. 开始采集：

单击该按钮，显示 Sample Information（样品信息）对话框，填入必需的信息，单击 Start Run（开始运行）按钮。

注意 在 5973 MSD 系统中开始运行时，只有当离子源和四极杆温度在三摄氏度的公差范围内达到平衡时运行才会开始。您可以忽略该等待时间，日志文件中将注明平衡被越过。

  12. 监测采集过程，在运行时根据需要改变仪器参数。


编辑采集参数

为数据采集设置参数可选用：

  • Instrument Control（仪器控制）面板上的按钮

  • Instrument Control（仪器控制）面板中的 Instrument（仪器）菜单。

  • Method（方法）菜单的 Edit Entire Method（编辑整个方法）。

这些参数是用于获取数据的方法的组成部分。单击面板上的 OK（确定）时，所有更改将保存到内存中。离开 Instrument Control（仪器控制）时，除非进行保存，否则所作更改不会自动存储。


进样口/进样类型

进样口和进样参数

从 Instrument Control（仪器控制）视窗菜单条选择 Instrument / Inlet/Injection Type（仪器/进样口/进样类型），设定进样口和进样参数。Inlet and Injection Parameters（进样口和进样参数）框将提示下列信息：

Inlet（进样口）

GC, Other/None（GC，其他/无）

Injection Source（进样方式）

Injection Location（进样位置）

Front, Rear,Dual（前、后、双）

Use MS（使用 MS）

如果想从质谱仪采集数据必须选择此框。如果仅希望收集 GC 数据，不选择该框。


启动 EMF 实用程序

EMF（早期维护反馈）实用程序用于对各种极限值与计数器进行选择或复位。当达到某极限值或应进行某项维护作业时，如 GC 密封隔垫的更换，这些参数值用于提醒您注意。仅当在线配置时，这些实用程序方才有效。

  1. 选择 Instrument/ EMF Utilities（仪器/EMF 实用程序）。

  2. 选择 Set Limits（设定极限值）。在 EMF Parameters（EMF 参数）对话框中将显示 Enter Limits（输入极限值）菜单。

在您第一次使用此功能时，将显示缺省值。任意字段中的 A -1 表示此参数已经失效。

  3. 设定要使用的极限值，单击OK（确定）。

  4. 单击 Done（完成）。现在，极限值已经设定好了，一旦方法开始运行，计数器就开始递增计数。

另见

EMF 极限值示例

EMF 实用程序

在 EMF Parameters（EMF 参数）对话框中输入参数


采集混合模式数据

人们对同时采集和分析 GC 检测器和 MSD 信号的兴趣日益浓厚。该混合数据可用于几方面。可由质谱进行鉴定，而由非选择性的 GC (FID/TCD) 检测器完成定量分析。用选择性 GC 检测器确认质谱指认，例如可用氮磷检测器或电子捕获检测器。最后可使用两个 GC 检测器加上 MSD 实现结合使用前两种技术。

要采集混合模式数据，请选择下列配置之一：

单个 GC 检测器和单柱配置的 MSD

双塔配置和序列


在目录中添加新色谱柱型号

使用该对话框可以在目录中添加新色谱柱类型或“型号”，包括色谱柱制造商及这种类型的色谱柱规格。

色谱柱规格 [image] 通过指定色谱柱的标识长度、直径和膜厚来定义色谱柱。利用这些信息，GC 可以计算通过色谱柱的流量。这在使用毛细管色谱柱时可以提供很大的便利，它可以实现：

  • 直接输入分流比，使仪器计算和设定适当流速。

  • 输入流速或柱头压力，或平均线速度。仪器计算和设定达到流速或速度所需的压力，报告出所有 3 个值。

  • 在不分流进样时不测定流速。

对于填充色谱柱和未定义标识尺寸的毛细管色谱柱，选择是有限的，并且随进样口变化而变化。

确认制造商及这种色谱柱的色谱容量规格。有关详细信息，请单击下面各项：

Manufacturer（制造商）

Model Number（型号）

Description（说明）

Column Type（色谱柱类型）

Max Temperature（最高温度）

Length（长度）（仅对于毛细管色谱柱）

Diameter（直径）（仅对于毛细管色谱柱）

Film Thickness（膜厚）（仅对于毛细管色谱柱）

在目录中添加新色谱柱类型后，返回（单击“确定”）Add New Column to Inventory（在目录中添加新色谱柱）对话框，把新色谱柱添加到目录中。

确定/取消/帮助按钮


在目录中添加新色谱柱

给新色谱柱指定一个目录号后，化学工作站会提示您确认其制造商和色谱柱类型或“型号”的制造商规格。该对话框中显示的两个列表组成了一个目录，从中可选择制造商和色谱柱类型规格。

要在目录中添加新色谱柱，请：

  • 在下拉式列表框中选择 Manufacturer（制造商），然后

  • 从色谱柱类型列表中选择 Model Number（型号）。

如果未显示色谱柱的 Manufacturer（制造商）和 Model Number（型号） [image] 由安捷伦制造的色谱柱型号已经在目录中。如果添加到目录中的色谱柱是由其他制造商生产的，则需要先把它添加到目录中。单击 Add New Column Model To Catalog（在目录中添加新色谱柱型号）按钮：

要从目录中删除某种色谱柱类型，将其选定后单击 Delete Column Model From Catalog（从目录中删除色谱柱型号）按钮。（由安捷伦制造的色谱柱型号不能从目录中删除。）

确定/取消/帮助按钮


校准色谱柱

请遵循如下步骤指定校准色谱柱的条件和数值：

  1. 打开 Column 1/2 Calibration（色谱柱 1/2 校准） 对话框。

a. 打开 Columns（色谱柱）对话框。

    查看/方法和运行控制

    仪器/编辑参数.../色谱柱

b. 单击 Change...（更换...）按钮。

b. 单击 Calibrate...（校准...）按钮。

  2. 确定您可提供哪些信息来计算新的校准值，单击适当的按钮输入信息：

化学工作站将提示您输入计算新规格所需的所有条件信息。长度变化限制在 5 米以内，直径变化限制在 20 微米以内。（如果计算得出的数值不合理，化学工作站将提示您重新进行校准。）

  3. 计算新的校准值 — 单击 OK（确定），返回 Column 1/2 Calibration（色谱柱 1/2 校准）对话框。

  4. 下载校准值 — 单击 OK（确定），返回 Change Column 1/2（更改色谱柱 1/2）对话框。再次单击 OK（确定），返回 Columns（色谱柱）对话框，然后再单击一次下载 GC 的新设置。

有关补充的步进说明，请参见下列任务：

更换色谱柱


更换色谱柱

在 6890 系列 GC 中安装一根不同的色谱柱时，请遵循如下步骤。开始运行前：

  1. 打开 Install Column 1/2（安装色谱柱 1/2） 对话框。

a. 打开 Columns（色谱柱）对话框。

    View / Method and Run Control（视图/方法和运行控制）

    Instrument / Edit Parameters.../ Columns（仪器/编辑参数.../色谱柱）

b. 单击 Change...（更换...）按钮。

b. 单击 Install...（安装...）按钮。

  2. 从您的产品目录中的色谱柱列表为该色谱柱选择目录号，将显示该色谱柱的规格。

若目录号在列表中不存在，返回 Change Column 1/2（更换色谱柱 1/2）对话框（单击 Cancel（取消））。单击 Add...（填加...）按钮，然后请见添加新色谱柱目录号。

  3. 下载所安装的色谱柱规格 — 单击 OK（确定）返回 Columns（色谱柱）对话框，重新将新设置下载到 GC。

有关补充的步进说明，请参见下列任务：

校准色谱柱


运行时间

您可以使用 Runtime（运行时间）对话框来预定在一次运行中多达 25 个事件自动发生的时间。您能预定其发生时间的项包括：

  • 阀状态

  • 用于流路编号选择的阀位置（仅对多位阀）

  • 信号说明

  • 信号归零

  • 信号范围

  • 信号衰减

  • 信号存储值

  • 归零信号下限值

  • 辅助通道压力

  • TCD 极性

  • NPD 氢气流量

注意：在运行过程中，改变信号归零、零点补偿、信号范围、信号衰减等设定值仅能控制模拟信号输出到数据处理设备（如连接到 GC 上的积分器或检测器）。输出到化学工作站的数字信号不受影响。（为获得有关模拟信号与数字信号输出的信息，请参见信号。）

阀门切换等操作导致系统扰动后，使用 Store Value（信号存储值）与 Zero Signal less Value（归零信号下限值）一道来重新进行基线的校准。Store Value（信号存储值）存储了当前信号级数值。Zero Signal less Value（归零信号下限值）对信号进行补偿，将信号漂移至 Store Value（信号存储值）级。这些运行时间参数的使用同时影响 6890 输出到化学工作站的模拟信号与数字信号。在运行结束时，保留新的信号归零值。

运行结束时，化学工作站自动将所有的设定值返回为初始值，阀状态的改变除外。

  • 如果您旋转某阀作为运行时间表的一个事件，在运行结束时，化学工作站不会自动将该阀返回初始设定位置。作为运行时间事件，您必须另外指定复位操作。

Editing the Run Time Table（编辑运行时间表）

使用鼠标或键盘来移动光标，编辑运行时间表。按向上或向下的箭头在表中移动。

  • 若要按时间顺序向运行时间表中添加运行时间事件，请指定事件的 Time（时间）、Specifier（分类符）、Parameter（参数）和 Setpoint（设定值），并按 Add（添加）按钮：

  • 若要从该表中删除事件，请选中该事件，并使用 Delete（删除）按钮：

  • 若要用当前已经指定 Time（时间）、Specifier（分类符）、Parameter（参数）和 Setpoint（设定值）的事件来替换某一事件，请选中您想进行替换的事件，并使用 Replace（替换）按钮：

  • 若要从该表中删除所有的事件，请使用 Clear All（清除所有事件）按钮：

如果您为辅助通道编制压力设定值同时采用运行时间表和梯度压力程序，并要求显示该通道的压力设定值图形，化学工作站将绘制您所设定程序的共同作用的结果。（为获取更多信息，请参见压力梯度与设定值图形。）

要获得逐步指令，请参见以下任务：

编辑方法

要获得其他信息，单击以下任意一项：


优化数据采样频率

单击 Calc（计算）按钮，化学工作站将自动计算运行过程中对来自检测器的分析数据的采样速率，并自动设定其最优值。

注意：化学工作站会在一次运行时间内采用这些数值（基于当前的色谱注设定值和流量）。重复这一过程，优化另一次运行的数据采样频率。

在启动一次运行之前：

  1. 请指定信号输出源：

a. 打开 Signals（信号）对话框。

    View / Method and Run Control（查看/处理方法和运行控制）

    Instrument/ Edit Parameters.../ Signals（仪器/编辑参数.../信号）

b.指定信号类型 (Det)。

c. 指定信号 Source（源）（在下拉式列表框中）。

  2. 单击 Calc（计算）按钮。

化学工作站会根据当前的色谱柱设定值和流量自动计算并设定期望的 Minimum Peak Width（最小峰宽）和 Data Rate（数据采样频率）值。

  3. 下载最优值 - 单击 OK（确定）。


准备使用载气节省的等压运行

可应用此任务的仪器与下列部件一起工作：

  • 电子压力控制（EPC）模块，和

  • 已定义的色谱柱。

按下面的步骤准备使用载气节省的等压（恒定压力）运行的梯度色谱柱压力程序，并将它下载到 GC。样品进到色谱柱后载气节省降低分流口的载气流量。化学工作站保持色谱柱头压力和色谱柱流速，同时吹扫和分流口流量降低。运行 1 分钟后的任意时间都可以打开载气节省。

  1. Activate the Gas Saver（激活载气节省）— 打开 Inlets（进样口）对话框。

    VIEW / METHOD AND RUN CONTROL（查看/方法和运行控制）

    INSTRUMENT / EDIT PARAMETERS... / INLETS（仪器/编辑参数.../进样口）

  • 在 GasSaver（载气节省）复选框中加上 X。

  • 指定需要的分流口流量。

  • 指定运行开始后需要化学工作站降低分流口流量的时间（以分钟为单位）。（缺省时间为 1 分钟。）

  2. 打开 Columns（色谱柱） 对话框并选择要使用的色谱柱（1 或 2）。

  3. 设定色谱柱的操作 Mode（模式）为 Const Pressure（恒定压力）。

  4. 指定下列色谱柱参数：

    • Inlet（进样口）

    • Detector（检测器）

    • Outlet psi/kPa/bar（出口 psi/kPa/bar）

  5. 指定下列梯度参数：

    • Next psi/kPa/bar（初始） = 要求的色谱柱压力

    • Hold min（保持时间，初始） = 等压运行应该持续的时间长短（以分钟为单位）

    • Next psi/kPa/bar（运行后） = 同 Next psi/kPa/bar（初始）

有关梯度色谱柱压力程序的进一步信息请参见梯度。

  6. 下载色谱柱设定 — 单击 OK（确定）。


准备等温运行

等温（恒定温度）运行由单一梯度升温程序组成。这就是说，一个程序以指定速率升高柱箱温度并将它保持一定的时间。

要进入等温运行的柱箱设定：

  1. 打开 Oven（柱箱） 对话框。

    VIEW / METHOD AND RUN CONTROL（视图/方法和运行控制）

    INSTRUMENT / EDIT PARAMETERS... / OVEN（（仪器/编辑参数.../柱箱）

  2. 指定 Oven（柱箱） ， Oven Configuration（柱箱配置） 和 Cryo Configuration（低温配置） 参数。

  3. 完成初始柱箱梯度设定：

    a. 在 Initial Next [image] C列中输入要使柱箱保持的度数（以 [image] C 为单位）。

    b. 在 Initial Hold min（初始保持时间）列中输入要使运行持续的时间长短。

  4. 在 [image] C/min 列中设定梯度 1 为每分钟 0 度来禁用任何梯度柱箱升温程序。

  5. 下载等温温度设定 - 单击 OK（确定）。

有关步进说明，请参见下列任务：

Prepare a Ramped Oven Temperature Program（准备梯度柱箱升温程序）


准备梯度柱箱升温程序

按下列步骤来准备一个顺序执行的最多 6 级（或“梯度”）的程序在运行中控制 GC 柱箱温度：

单一梯度升温程序以指定速率将初始柱箱温度升高到指定最终温度并将最终温度保持一定的时间。

多梯度升温程序也类似。可以程序设定柱箱从初始温度到最终温度，但在不同梯度之间速率、时间和温度都不同。也可以将温度的多梯度编程为降低，和升高类似。

  1. 打开 Oven（柱箱） 对话框。

    VIEW / METHOD AND RUN CONTROL（视图/方法和运行控制）

    INSTRUMENT / EDIT PARAMETERS... / OVEN（仪器/编辑参数.../柱箱）

  2. 指定柱箱梯度程序的初始 Next（下一） [image] C 和 Hold min（保持时间）设定。

  3. 对于每个梯度，指定下列参数：

  • C/min

  • Next [image] C

  • Hold min（保持时间）

  4. 指定下列运行后参数：

  • Next（下一） [image] C = 最终柱箱温度（以 [image] C 为单位）

  • Hold min（保持时间） = GC 应该保持最终柱箱温度的时间长短（以分钟为单位）

  5. 下载梯度柱箱升温程序 — 单击 OK（确定）。

有关步进说明，请参见下列任务：

准备等温运行


GC 柱箱按钮 (6890)

GC 柱箱按钮

GC 就绪后，右上方的小方块为绿色。GC 未就绪时，方块为红色。单击此按钮弹出一个菜单：

Edit GC Oven （编辑 GC 柱箱） | 显示一个可以设定柱箱和其他 GC 参数的面板。
Edit GC Monitors （编辑 GC 监测器） | 显示一个面板，您可在其中设定用于监测选定参数的 Instrument Control（仪器控制）窗口。


设定分流比

为在分流或脉冲分流模式下工作的 EPC（电子压力控制）分流 — 不分流进样口设定分流比。化学工作站将调整分流流量和色谱柱流量以达到指定的设定值。

遵循下列步骤：

  1. 打开 Inlet（进样口） 对话框并指定 Split Ratio（分流比）设定值 — 有关详细信息，单击任何绿色区域：

  2. 下载新的设定值 - 单击 OK（确定）。

有关步进说明，请参见下列任务：

设置脉冲压力进样口


设置脉冲压力进样口

为 EPC（电子压力控制）分流 — 不分流进样口设定一个脉冲压力，请遵循下列步骤：

  1. 设定进样口的操作 Mode（模式） 为 Pulsed Split（脉冲分流）或 Pulsed Splitless（脉冲不分流） — 打开 Inlet（进样口）对话框。

  2. 指定 Injection Pulse Pressure（进样脉冲压力）的设定值。

  3. 下载新的设定值 — 单击 OK（确定）。

有关步进说明，请参见下列任务：

设定分流比


PTV 脉冲分流模式操作（w/ 色谱柱已定义）

开始前，确定色谱柱、载气和流量或压力程序（如果使用的话）都已正确配置。

  1. 打开用于 PTV 进样口的 Inlet（进样口）对话框。

  2. 设定进样口的操作模式为 Pulsed Split（脉冲分流）。

  3. 设定进样口温度和任何需要的梯度。

  4. 指定 Injection Pulse Pressure（进样脉冲压力）设定值。

  5. 如果需要指定分流比，输入需要的 Split Ratio（分流比）并输入该数值。分流流量会被计算出并为您设定。如果想指定分流流量，输入该数值。会计算出并为您显示分流比。

  6. 需要的话，打开载气节省。设定 Saver（节省）时间大于脉冲时间。

有关进一步说明，请参见 Split Ratio（分流比）。


PTV 脉冲分流模式操作（w/o 色谱柱已定义）

PTV 脉冲分流模式操作（w/ 色谱柱未定义）

开始前，确定色谱柱、载气和流量或压力程序（如果使用的话）都已正确配置。

  1. 打开用于 PTV 进样口的 Inlet（进样口）对话框。

  2. 设定进样口的操作模式为 Pulsed Split（脉冲分流）。

  3. 设定进样口温度和任何需要的梯度。

  4. 指定 Injection Pulse Pressure（进样脉冲压力）设定值。

  5. 设定进入进样口的 Total Flow（总流量）。使用流量计测量流出分流口和隔垫吹扫口的流量。

  6. 从 Total Flow（总流量）中减去 Septum Purge Flow（隔垫吹扫流量）得到 Split Flow（分流流量）。

  7. 从 Total Flow（总流量）中减去 Septum Purge Flow（隔垫吹扫流量）和 Split Flow（分流流量）得到 Column Flow（色谱柱流量）。

  8. 使用下列方程来计算分流比：

  9. Split Ratio（分流比） = Split Flow/Column Flow（分流流量/色谱柱流量）

  10. 重复步骤 5 到 8 来按需要调节 Split Ratio（分流比）。


PTV 脉冲不分流模式操作（w/ 色谱柱已被定义）

开始前，确定色谱柱、载气和流量或压力程序（如果使用的话）都已正确配置。

  1. 打开用于 PTV 进样口的 Inlet（进样口）对话框。

  2. 设定进样口的操作模式为 Pulsed Splitless（脉冲不分流）。

  3. 设定进样口温度和任何需要的梯度。

  4. 指定 Injection Pulse Pressure（进样脉冲压力）设定值。

  5. 设定进入进样口的 Total Flow（总流量）。

  6. 输入Purge Time（吹扫时间）和 Purge Flow (to Split Vent)（分流口吹扫流量）设定值。

  7. 需要的话，打开载气节省。确认节约时间设定在吹扫时间之后。


PTV 脉冲不分流模式操作（w/o 色谱柱已定义）

PTV 脉冲不分流模式操作（w/ 色谱柱未定义）

开始前，确定色谱柱、载气和流量或压力程序（如果使用的话）都已正确配置。

  1. 打开用于 PTV 进样口的 Inlet（进样口）对话框。

  2. 设定进样口的操作模式为 Pulsed Splitless（脉冲不分流）。

  3. 设定进样口温度和任何需要的梯度。

  4. 指定 Injection Pulse Pressure（进样脉冲压力）设定值。

  5. 设定进入进样口的 Total Flow（总流量）。

  6. 输入 Purge Time（吹扫时间）和 Purge Flow (to Split Vent)（分流口吹扫流量）设定值。确定将总流量设定为大于色谱柱流量与隔垫吹扫流量（约 3 至 6 mL/min）之和以保证足够的色谱柱流量。


PTV 溶剂放空模式操作（w/ 色谱柱已定义）

开始前，确定色谱柱、载气和流量或压力程序（如果使用的话）都已正确配置。

色谱柱已定义时在溶剂放空模式下操作

  1. 打开用于 PTV 进样口的“Inlet（进样口）”对话框。

  2. 设定进样口的操作模式为 Solvent Vent（溶剂放空）。

  3. 设定进样口温度和任何需要的梯度。

  4. 输入 “Vent Pressure（放空压力）、Vent Flow（放空流量）和 Vent End Time（放空结束时间）参数。

  5. 输入 Purge Time（吹扫时间）和 Purge Flow (to Split Vent)（分流口吹扫流量）设定值。确定将总流量设定为大于色谱柱流量与隔垫吹扫流量（约 3 至 6 mL/min）之和以保证足够的色谱柱流量。

  6. 需要的话，打开载气节省。确认节约时间设定在吹扫时间之后。

注： 为取得最好的结果，设定 Vent End Time（放空结束时间）< Purge Time（吹扫时间）< Saver Time（节省时间）。


PTV 溶剂放空模式操作（w/o 色谱柱已定义）

PTV 溶剂放空模式操作（w/ 色谱柱已定义）

开始前，确定色谱柱、载气和流量或压力程序（如果使用的话）都已正确配置。

  1. 打开用于 PTV 进样口的“Inlet（进样口）”对话框。

  2. 设定进样口的操作模式为 Solvent Vent（溶剂放空）。

  3. 设定进样口温度和任何需要的梯度。

  4. 输入 Vent Pressure（放空压力）、Vent Flow（放空流量）和 Vent End Time（放空结束时间）参数。

  5. 输入 Purge Time（吹扫时间）和 Purge Flow (to Split Vent)（分流口吹扫流量）设定值。确定将总流量设定为大于色谱柱流量与隔垫吹扫流量（约 3 至 6 mL/min）之和以保证足够的色谱柱流量。

注： 为取得最好的结果，设定 Vent End Time（放空结束时间）< Purge Time（吹扫时间）< Saver Time（节省时间）。


PTV 分流模式操作（w/ 色谱柱已定义）

开始前，确定色谱柱、载气和流量或压力程序（如果使用的话）都已正确配置。

  1. 打开用于 PTV 进样口的 Inlet（进样口）对话框。

  2. 设定进样口的操作模式为 Split（分流）。

  3. 设定进样口温度和任何需要的梯度。

  4. 指定需要的分流比。分流流量会被计算出并为您设定。如果想指定分流流量，输入该数值。会计算出并为您显示分流比。

  5. 需要的话，打开载气节省。设定节省时间在进样时间之后。


PTV 分流模式操作（w/o 色谱柱已定义）

PTV 分流模式操作（w/ 色谱柱未定义）

开始前，确定色谱柱、载气和流量或压力程序（如果使用的话）都已正确配置。

  1. 打开用于 PTV 进样口的 Inlet（进样口）对话框。

  2. 设定进样口的操作模式为 Split（分流）。

  3. 设定进样口温度和任何需要的梯度。

  4. 设定进入进样口的 Total Flow（总流量）。使用流量计测量流出分流口和隔垫吹扫口的流量。从 Total Flow（总流量）中减去 Septum Purge Flow（隔垫吹扫流量）得到 Split Flow（分流流量）。

  5. 从 Total Flow（总流量）中减去 Septum Purge Flow（隔垫吹扫流量）和 Split Flow（分流流量）得到 Column Flow（色谱柱流量）。

  6. 使用下列方程来计算分流比：

Split Ratio（分流比） = Split Flow/Column Flow（分流流量/色谱柱流量）

  7. 重复步骤 4 到 6 ，按需要调节 Split Ratio（分流比）。


PTV 不分流模式操作（w/ 色谱柱已定义）

开始前，确定色谱柱、载气和流量或压力程序（如果使用的话）都已正确配置。

  1. 打开用于 PTV 进样口的 Inlet（进样口）对话框。

  2. 设定进样口的操作模式为 Splitless（不分流）。

  3. 设定进样口温度和任何需要的梯度。

  4. 设定进入进样口的 Total Flow（总流量）。

  5. 输入 Purge Time（吹扫时间）和 Purge Flow (to Split Vent)（分流口吹扫流量）设定值。

  6. 需要的话，打开载气节省。确认节省时间设定在吹扫时间之后。


PTV 不分流模式操作（w/o 色谱柱已定义）

PTV 不分流模式操作（w/o 色谱柱未定义）

开始前，确定色谱柱、载气和流量或压力程序（如果使用的话）都已正确配置。

  1. 打开用于 PTV 进样口的 Inlet（进样口）对话框。

  2. 设定进样口的操作模式为 Splitless（不分流）。

  3. 设定进样口温度和任何需要的梯度。

  4. 设定进入进样口的 Total Flow（总流量）。

  5. 输入 Purge Time（吹扫时间）和 Purge Flow (to Split Vent)（分流口吹扫流量）设定值。确定将总流量设定为大于色谱柱流量与隔垫吹扫流量（约 3 至 6 mL/min）之和以保证足够的色谱柱流量。


使用 GC 石化增强

石油化工中执行的应用程序通常要求具有比一般的收集、分析和报告数据控制更高的控制级别。化学工作站已经增强，其功能现已扩展至此附加级的控制。

这些增强包括：

将第 3 个和第 4 个信号添加至 GC

按校准表中的信号排序

允许每个信号的唯一响应因子

手动校准

将定制报告打印到文件


为 MSD 操作设定 6890 GC

欲在 GC/MS 模式中运行 6890 系列体系，仪器必须被 MS Configuration Editor（MS 配置编辑器）正确配置。在系统被安装时进行。也必须设定其他几个参数。（如果需要证实仪器配置，单击窗口的 Start（开始）按钮，指向 Programs（程序），然后指向MSD ChemStation（MSD 化学工作站）并单击 Config（配置）。）

  1. 从 Instrument Control（仪器控制）中选择 Instrument / Inlet/Injection Types（仪器/进样口/进样类型）。将显示 Inlet and Injection Parameters（进样口和进样参数）框。

  2. 如果正在使用一个 ALS，选择 GC ALS 为 Injection Source（进样方式）。

  3. 确定 Use MS（使用 MS）复选框被选择，然后单击 OK（确定）。

  4. 确定辅助通道 2 被设定作为 MSD 的被加热的传输线。

  • 单击 Aux（辅助通道）按钮以显示 Aux（辅助通道）对话框。

  • 确定 MSD 被选择作为 Type（类型）并且 Heater（加热器）为启动状态并被设定到目标温度。

  • 如果想改变辅助通道的名称，在 Description（说明）框输入新名字。例如 MSD X-fer line。

  • 如果您进行了任何改变，单击 OK（确定）。否则，单击 Cancel（取消）由于方法已经有了那个信息。

  5. 单击 Columns（色谱柱）按钮以显示 GC Columns（GC 色谱柱）对话框。

    确定 Detector（检测器）为 MSD 并且 Vacuum（真空）被选择作为 Outlet psi（出样口压力）。


自动调谐

Autotune（自动调谐）使用 PFTBA 作为校准化合物，自动调节 MS 参数达到 EI 模式下操作的预定标准。这称为调谐。

可以从 Instrument Control（仪器控制）中的 Instrument / Perform MS Autotune（仪器/进行 MS 自动调谐）菜单项或 Manual Tune（手动调谐）的 Tune（调谐）菜单中选择几种自动调谐方式。菜单中可用的自动调谐方式取决于所使用的 MSD 型号。

5973 | 5972 / 6890
Autotune （自动调谐） | Max Sensitivity （最大灵敏度）
Low Mass Autotune （低质量自动调谐） | Autotune （自动调谐）
Standard Spectra Tune （标准谱图调谐） | Standard Spectra Autotune （标准谱图自动调谐）
QuickTune （快速调谐） | QuickTune （快速调谐）
Enter CI Tune Panel （进入 CI 调谐面板） |

另见

检查发射电流 (5972A MSD)

电子能量设定 (5973 MSD)


MS SIM/扫描参数

这个对话框让您设置质谱仪在 Scan（扫描）或 SIM 模式下采集数据。这些模式之间的差别是在每次扫描中：

  • Scan（扫描）模式在整个选定扫描范围内每隔 0.1 amu 监测丰度。在正常 Scan（扫描）模式中，得自平均数据的峰保存到磁盘上。

  • SIM 模式只监测指定离子。

要在此取得，从 Instrument Control（仪器控制）菜单栏中选择 Instrument / MS SIM/Scan（仪器/ MS SIM /扫描）或单击

并从弹出的菜单中选择 Edit MS SIM/Scan（编辑 MS SIM /扫描）。

对话框有三部分：

  • MS Instrument Parameters（MS 仪器参数）

  • Real Time Plot Parameters（实时图形参数）

  • MS SIM 或 Scan Parameters（扫描参数）

Timed Events Button（时间事件按钮）

Zones button（区域按钮）显示 MS Temperatures（MS 温度）对话框，在其中可以查看 MS Source（MS 源）和 MS Quad（MS 四极杆）的设定值和实际值。这是一个只读对话框。


显示 GC 监测器

用鼠标或 Tab、Shift-Tab、上箭头和下箭头等键在表中进行移动。使用按钮添加、删除或替换项目。

  1. 在表的顶端的 Type（类别）下，选择您要监测的项目（如 Oven（柱箱））。

  2. 用 Tab 键移动光标到下一字段，选择 Location（位置）（如果可用）。（这一字段对 Oven（柱箱）无效。）

  3. 移至 Parameter（参数）字段，选择显示列表中的任意选项。（Oven（柱箱）下仅有一个选项。）

  4. 移至 Display（显示）字段并选择模/数显示。

  5. 单击 Add（添加）按钮。您指定的监测器将显示在表中。

  6. 若您已经添加了您想要的所有监测器，请单击 OK（确定）。Instrument Control（仪器控制）面板中将显示所有这些监测器。若要在面板中对所有的监测器进行重排，请单击监测器，拖至您想要的位置。

另见

设置监测器警铃


显示 MS 监测器

在 Edit MS Monitors（编辑 MS 监测器）对话框中，用鼠标或 Tab ，Shift-Tab ，Up 和 Down 箭头等键在表中进行移动。使用按钮添加、删除或替换项目。

  1. 在表的顶端的 Type（类别）下面，选择您要监测的项目（如 Parameters（参数））。

  2. 用 Tab 键移动光标到下一字段，选择您想监测的 MS Parameter（参数）。

  3. 移至 Display（显示）字段并选择模或数显示。

  4. 单击 Add（添加）按钮。您指定的监测器将显示在表中。

  5. 若您已经添加了您想要的所有监测器，请单击 OK（确定）。Instrument Control（仪器控制）面板中将显示所有这些监测器。若要在面板中对所有的监测器进行重排，请单击监测器，拖至您想要的位置。

另见

设置监测器警铃


设定监测警报

可以为每个显示在 Instrument Control（仪器控制）面板上的 GC 和 MS 监测器设定一个彩色码警报以便能检查一个事件的状态。在操作范围内的数值使用绿色。

为一个特定监测设定一个警报，单击监测器并且一个对话框将提示下列信息：

  • 警告级（红色）

  • 警告级（黄色）

  • 下限（蓝色）

可以为级设定选择的任意值。确定选择了 Set Alarm（设定警报）复选框。然后单击 OK（确定）。

如果指定一个模拟信号监测器，将会提醒您显示的最大和最小值。


GC 实时图形

在 Instrument Control（仪器控制）中选择 Instrument / GC Plot（仪器/ GC 图形）会显示此对话框。使用这个对话框来显示或从 Instrument Control（仪器控制）面板去掉实时信号监测器。

Show（显示）

如果想让指定信号的图形显示在 Instrument Control（仪器控制）面板上，则选择此对话框。如果想去掉图形则取消选定。

Attn（衰减）：

在实时显示中以乘方形式以完全坐标显示的检测器信号的范围。衰减值可以在实时显示的运行中改变。

Offset（补偿值）：

从窗口底部到图形开始的距离。以 % 格式输入值，窗口底部为 0，顶部为 100。补偿值在运行中不能改变。

Time（时间）：

运行中某次显示的色谱时间范围（以分钟为单位）。时间值在运行中不能改变。

另见

调节实时 GC 图形的坐标


调节 MS 实时图的 Y 坐标轴

单击放大的 Total Ion（总离子）或 Extracted Ion（提取离子）窗口中的坐标轴按钮，显示对话框，可在其中输入最小值（下限值 = 0）或最大值（上限值 = 2E9）。您也可以单击旁边的箭头按钮，将最小或最大值乘以或除以二的指数。

时间事件，如打开校准阀，在实时 MS 图上标出。这些事件在 MS Timed Events Parameters（MS 时间事件参数）对话框中设定。


显示实时 MS 图

  1. 设定 MS 参数：

单击该按钮，并选择 Edit MS SIM/Scan（编辑 MS SIM /扫描）设定扫描参数。

  2. 在 MS SIM/Scan（MS SIM/扫描）对话框中，设置 Real Time Plot（实时图形）部分来显示中意的数据。在下面的示例中，指定了扫描运行的两个窗口，一个显示总离子流色谱，而另一个显示提取离子色谱。

  3. 单击图形窗口（鼠标左键）得到一个放大的视窗。

  4. 调节 Y 坐标轴至满意为止。

另见

实时图形参数


使用 MS 时间事件表

使用鼠标或 Tab、Shift-Tab、Up 和 Down 箭头键在表格周围移动。使用按钮添加、删除或替换项目。

  1. 在表格上部，在 Time（时间）下,输入采集开始后的时间（分钟数）。

  2. 跳到下一个字段并从列表中选择事件类型。

  3. 移动到 Parameter 1（参数 1）字段并选择显示在列表中的一个选项。

    如果正在设定一个 EMV Delta 事件，输入调谐文件设定值和新的设定值的电压差值。调谐文件设定值将显示在 MS SIM/Scan Parameters（MS SIM/扫描 参数）面板上。

  4. 如果是有效的，移动到 Parameter 2（参数 2）字段，并选择一个选项。

  5. 单击 Add（添加）按钮。事件将显示在列表中。

  6. 当已经添加所有希望的事件后，单击 OK（确定）。


日志簿
日志簿按钮显示一个弹出菜单：

Current Logbook （当前日志簿） | 显示当前日志簿。每项包括消息的类型、内容、时间和日期。
Open Logbook （打开日志簿） | 显示目录中所有日志簿的列表。
Clear Logbook （清除日志簿） | 删除当前显示日志簿。
Save As Logbook （另存为日志簿） | 将显示的日志簿保存到一个新名称下。
Print Logbook （打印日志簿） | 打印显示的日志簿。


使用方法

方法用于：

  • 使用 6890 GC 附带的化学工作站软件进行单次分析

  • 按批或按序列进行分析。

如何使用

将化合物添加到现有方法中

创建新方法

在顶部加载方法

将其他信息添加到方法中

参见

方法菜单


使用序列

使用序列可以自动分析一个或多个样品。安装 ALS 后，可以自动进行从进样到报告结果的完整分析。有关更高级的自动，可以使用条形码读出机。

使用 Top（顶部）视窗中的 Sequence（序列） 菜单可以进行所有序列操作。

如何

设定序列

测试（模拟）序列

定位和运行序列

保存/加载序列

启动序列

恢复序列

打印序列

将一个序列附加在另一个序列上

重排数据文件序列

重排样品瓶序列

更改方法

从 CSV 文件中导入序列信息

参见

样品日志表

关键字/关键字字符串

序列日志文件

GC 仪器的序列模式

序列菜单


仪器控制面板样式 (6890)

仪器控制面板样式

从菜单条选择 View / Instrument Control（视窗/仪器控制）显示该视窗。从该面板可设定 GC、调谐 MSD、编辑方法、采集数据和访问数据分析软件。单击图片中项目了解它们的使用。如果系统配置为仅使用 GC，质谱仪按钮将不出现。


编辑参数

每个仪器控制选项出现在 Instrument Control（仪器控制）屏幕的图标栏中。图标的颜色和外观在编辑不同的仪器控制时会改变。有关其设定值的详细信息，请单击下面各图标：

为当前方法改变设定值：

  1. 单击代表希望更改的仪器控制的图标。

  2. 更改必要的参数。

  3. 如有必要重复步骤 1 和 2。完成后，单击 Apply（应用）或 OK（确定）下载更改：

有关补充信息，请单击下列各项：

有关步进说明，请参见下列任务：

编辑方法


EMF 实用程序

EMF（早期维护预告）实用程序用于选择或重新设定不同的极限值和计数器。这些值用于提醒一个极限值已达到和需要执行一项维修任务，比如更换 GC 隔垫。这些实用程序仅用于在线配置。

每次一个方法运行时，就会检查极限值。如果 EMF 检查表明达到了极限值，就会显示警示框。如果系统正在运行一个序列，任何 EMF 警告将记录在序列日志中。

在 Instrument Control（仪器控制）视窗中选择 Instrument / EMF Utilities（仪器/ EMF 实用程序）访问这些实用程序。Select EMF Action（选择 EMF 操作）对话框即被显示。选择下列各项：

Set Limits （设置极限值） | 显示一个对话框可以为 GC（隔垫、衬管和总进样）和 MS（泵油、调谐时间和 EM 电压）设置极限值。
Set Counters （设置计数器） | 显示一个对话框可以为 GC 隔垫、衬管和总进样数设置计数器。该对话框仅当一个计数器不必要的增加时才使用。例如，如果 ALS 注射器出现故障在一个序列中未进行实际进样，而 GC 隔垫计数器仍然增加。在此情况下，可使用该对话框将 GC 隔垫计数器重新返回故障前的数值。
Reset Counters （重置计数器） | 显示一个对话框可以为隔垫、衬管、总进样数和泵油重新设定计数器。

这些对话框中可用选项依赖于仪器配置。对于一个仅用于 MS 的系统，隔垫、衬管和总进样数选项不可用。对于仅用于 GC 的系统，泵油、调谐时间和 EM 电压选项不可用。被检查的 EMF 项目也依赖于方法。例如，一个 GC/MS 配置中被设置为不用于 MS 的方法在检查 EMF 参数时将跳过 MS 值（泵油、调谐时间和 EM 电压）。


仪器控制菜单 (6890)

仪器控制菜单 (6890 GC)

Method （方法） | 加载、保存、运行和编辑方法。以及退出化学工作站。
Instrument （仪器） | 设定 GC/MS 参数、更改调谐文件或运行自动调谐。
View （查看） | 切换视窗（Top（顶部）、Data Analysis（数据分析）、Diagnostics（诊断）、Manual Tune（手动调谐））。
Abort （终止） | 停止运行。
Window （窗口） | 排列显示的面板。
Qualify （认证） | 仅用于 5973 系统。允许您执行系统检查并查看几个检查列表。


采集 － 样品信息

要显示该对话框，请选择：

您在该对话框中提供的信息将与所有后续过程数据相关。

硬盘空间

检查是否有足够的硬盘空间用于数据采集。

数据文件路径

显示当前路径。要改变路径，可以在 Data File Name（数据文件名称）字段中指定。

操作者姓名

可选。包含在数据文件头中。

样品瓶数目

对于手动进样，设置为 1。如果已安装 ALS，且在方法或序列中使用托盘，则输入所需的样品瓶数目 (1-100)。如果仅使用转动架，输入 1 - 3。如使用排列紧密的转动架可输入 1-8。如果用 6890 GC 的多位阀进样，保留样品瓶数 1-32 指定阀位置。如果用阀进样，确认您在此处指定了正确位置。

数据文件名称

必须。输入所用的名称（最多 8 个字符）。如果没有指定则使用缺省路径。

样品名称

可选。包含在数据文件头中。

其他信息

可选。包含在数据文件头中。此项在此处和 Sample Log Table（样品日志表）中可用。也可在 Data Analysis（数据分析）中选择 File / Edit File Info.（文件/编辑文件信息）来修改。

开始运行按钮

单击此按钮仅开始数据采集。这一操作不会将方法复制到数据目录中，也不会启动 Data Analysis（数据分析）。


色谱柱 1/2 校准

请使用本对话框校准色谱柱尺寸（例如，截断色谱柱末端后）。

化学工作站将同时显示制造商标识规格：

  • Model Number（型号）

  • Max Temperature（最高温度）

  • Description（说明）

  • Length（长度）

  • Diameter（直径）

  • Film Thickness（膜厚）

以及色谱柱的当前校准规格，包括：

  • 色谱柱上次校准的日期和时间，

  • 校准长度和直径值，根据它们将标识规格调节至 6890 系列 GC 和化学工作站在计算中使用的实际值，以调节压力来获得理想的流量（或调节流量来获得理想的压力），以及

  • 化学工作站的校准所依据的任何滞留时间测量结果。

要更新 Calibration Data（校准数据），请确定您可提供下列哪些数据用于计算。单击指定按钮输入数值：

如果您能估计色谱柱长度，使用 Set Length...（设定长度...）按钮根据所估计的色谱柱长和标识直径进行校准：

如果您已将色谱柱截短，测量所截下部分的长度。使用 Adjust Length...（调节长度...）按钮根据所截断的色谱柱长度和色谱柱标识直径进行校准：

如果您已测量了 一个非保留峰的停留时间，则可以：

  • 使用 Calc Length...（计算长度...）按钮根据测量结果和色谱柱标识直径进行校准：

  • 或使用 Calc Diameter...（计算直径...）按钮根据测量结果和色谱柱标识长度进行校准：

注意：校准还基于标识膜厚和当前方法中柱箱温度、载气和进口/出口压力的设定值。（有关这些设定值的更多信息，请参见 Oven（柱箱）、Inlet（进样口）和 Outlet psi/kPa/bar（出口 psi/kPa/bar）。）

化学工作站将提示您输入计算新规格所需的所有条件信息。长度变化限制在 5 米以内，直径变化限制在 20 微米以内。（如果计算得出的数值不合理，化学工作站将提示您重新进行校准。）

如果您想采用标识值用于 6890 系列 GC 和化学工作站的压力和流量计算，使用 Reset to Original Manufacturer's Specs（重新设定到原始的制造商规格） 按钮用制造商规格代替当前校准数据：

注意：GC 前面板的显示总是反映安装的色谱柱的校准尺寸。然而，运行一种方法时使用的所需类型的色谱柱可为任意数目，则化学工作站在方法中保存的色谱柱尺寸是该类色谱柱的标识尺寸，而不是一根特定色谱柱的校准尺寸。因此，化学工作站计算的压力/流量计算值可能与 GC 前面板上显示的对应压力/流量值不同。

确定/取消/帮助按钮


辅助通道对话框

把 Aux（辅助）对话框用于：

  • 配置多达两个加热辅助通道和三个压力辅助通道。

  • 配置可选的 Cryo Focus（低温冷凝）热阱（选项不可用）

  • 准备梯度辅助通道温度和压力程序。

本对话框内容：

Aux Channel（辅助通道）

Description（说明）

Heater (thermal channels)（加热器（热通道））

Cryo Focus Configuration (option not available)（低温冷凝配置（选项不可用））

Type (thermal channels)（类型（热通道））

Pressure (pressure channels)（压力（压力通道））

Gas (pressure channels)（气体（压力通道））

Ramps（梯度）

有关步进说明，请参见下列任务：

编辑方法

有关进一步说明，请单击下述任意项：


色谱柱

使用 Columns（色谱柱）对话框来：

  • 配置最多两根色谱柱，并

  • 准备色谱柱流量和压力梯度程序。

选择 1 或 2 显示指定色谱柱的设定值。

只要：

  • 安装一根不同的色谱柱或

  • 校准当前已安装的色谱柱（例如，在截断其末端后），单击 Change...（更换...）按钮指明新规格：

本对话框内容：

Mode（模式）

Inlet（进样口）

Detector（检测器）

Outlet psi/kPa/bar（出口 psi/kPa/bar）

Flow（流量）

Installed Column（已安装的色谱柱）

Manufacturer's Specifications/Column Dimensions（制造商规格/色谱柱尺寸）

Ramps（梯度）

有关步进说明，请参见下列任务：

校准色谱柱

更换色谱柱

编辑方法

有关补充说明，请单击下述任意项：

进样口


检测器

化学工作站根据 6890 GC 上已安装的检测器数目和类型来显示检测器对话框。可以从下拉菜单中选择 Front（前）或 Back（后）进样口。

下面是所有有效的检测器类型。有关详细信息，请单击任何一项：

Flame Ionization Detector（火焰离子化检测器）

Electron Capture Detector（电子捕获检测器）

Micro-Cell Electron Capture Detector（微池电子捕获检测器）

Thermal Conductivity Detector（热导检测器）

Nitrogen Phosphorus Detector（氮磷检测器）

Flame Photometric Detector（火焰光度检测器）

Single Channel Analog Input Board（单通道模拟输入板）

No Detector（无检测器）（同 MSD 一起使用）

有关步进说明，请参见下列任务：

编辑方法

有关进一步说明，请单击下列任何一项：


进样口

化学工作站根据安装在 GC 上的进样口数量和类型给出 Inlets（进样口）对话框。可从位于 Apply（应用）按钮上面的下拉菜单中选择 Front（前）或 Back（后）进样口。

下列是可用的进样口类型。有关详细信息，请单击下列各项：

Cool On-Column Inlet（冷柱头进样口）

Purged Packed Inlet（吹扫填充进样口）

Split - Splitless Inlet（分流 — 不分流进样口）

Volatiles Interface（挥发物接口）

Pneumatics Control Module（气动控制模块）(PCM)

Programmed Temperature Vaporization (PTV) Inlet（程序升温挥发进样口）

进样口概述

进样口 类型 | 色谱柱 类型 | 模式 | 样品 类型 | 注释 | 进入色谱柱 样品
分流/ 不分流 | 毛细管色谱柱 | 分流 | 高 浓度 | 无 | 非常少，大部分放空
 |  | 脉冲 分流 | 高 浓度 | 新技术； 对于大（>2 [image] l）的进样有用 | 非常少，大部分放空
 |  | 不分流 | 低 浓度 | 无 | 所有
 |  | 脉冲 不分流 | 低 浓度 | 对于大量 （>2 [image] l）进样有用 | 所有
冷 柱头 | 毛细管色谱柱 | n/a | 低 浓度 或热 不稳定 | 最小的样品 歧视和分解 | 所有
吹扫填充色谱柱 | 填充色谱柱； 1/8- 和 1/4-in.（英寸）金属，1/8-in.（英寸）玻璃 | n/a | 任何 | 无 | 所有
 | 大口径毛细管色谱柱 | n/a | 任何 | 令人满意的 如果分离度 不成问题 | 所有
PTV | 毛细管色谱柱 | 分流 | 高 浓度 | 无 | 非常少，大部分放空
 |  | 脉冲 分流 | 高 浓度 | 新技术； 对于大（>2 [image] l）的进样有用 | 非常少，大部分放空
 |  | 不分流 | 低 浓度 | 无 | 所有
 |  | 脉冲 不分流 | 低 浓度 | 对于大 （>2 [image] l）的进样有用 | 所有
 |  | 溶剂放空 | 低 浓度 | 对于大 （>25 [image] l）的进样有用 | 所有
挥发物接口 | 毛细管色谱柱 | 分流 | 高 浓度 | 气体样品 | 非常少，大部分放空
 |  | 不分流 | 低 浓度 | 气体样品 | 可转换到不分流
 |  | 直接 | 低 浓度 | 气体样品， 接口必须改造 | 最大样品回收率

有关步进说明，请参见下列任务：

编辑方法

准备使用载气节省的等压运行

设定分流比

设置脉冲压力进样口

有关补充信息，请单击下列任意项：


冷柱头进口

该进口将液体样品直接导入毛细管色谱柱中。要做到这一点，注射时进口和柱箱必须冷却到溶剂的沸点或沸点以下。由于样品没有在进口中立即汽化，样品歧视和样品变更的问题减到最低程度。如果操作正确，冷柱头进样也会获得准确和精密的结果。

您可在柱箱跟踪模式下操作进口，这时进口温度随柱箱变化，您也可程序设置多达三个温度梯度。还有一个低温冷却选项可用液体使进口达到室温以下的温度。

使用 Cool On-Column Inlet（冷柱头进口）对话框：

  • 设定进口参数，指定设定值，并

  • 可选择为当前方法准备一个进口温度梯度程序。

柱箱跟踪模式

参数 | 设定值范围
COC 进口温度 | 3比柱箱温度高 3 [image] C，最高温度为 450 [image] C，对于 CO2 最低温度为 -60 [image] C，对于 N2 最低温度为 -80 [image] C。

梯度温度模式

参数 | 设定值范围
COC 进口温度 | -60 [image] C 对于 CO2，-80 [image] C 对于 N2，最高 450 [image] C
 | 无低温冷却时，操作范围为 24 [image] C 至 450 [image] C
 | 有低温冷却时，操作范围为 -40 [image] C 至 450 [image] C

本对话框内容：

Heater（加热器）

Gas（气体）

Mode（模式）

Ramps（梯度）

Pressure（压力）


吹扫填充进样口

使用此对话框来设定 Purged Packed Inlet（吹扫填充进样口）参数并指定当前方法下的设定值。

当不需高效分离时，这一进样口用来与填充柱分析一起使用。如果流量大于 10 mL/min 可以接受的话，也可以同大口径的毛细管色谱柱一起使用。进样口与填充柱一起使用时由流量控制，而与毛细管色谱柱一起使用时由压力控制。

如果安装了 EPC 且色谱柱：

  • 已被定义，进样口为压力控制。

  • 未定义，进样口为流量控制。

如果未安装 EPC（手动控制进样口），压力和总流量参数均为灰色。

本对话框内容：

Heater（加热器）

Gas（气体）

Pressure（压力）（如果色谱柱已被定义）

Total Flow（总流量）（如果色谱柱已被定义）


分流 － 不分流进样口

使用对话框设定分流 — 不分流进样口参数并为当前方法输入设定值。

如果安装了 EPC（电子流量控制）并且色谱柱：

  • 已定义，进样口可以为压力或流量控制。

  • 未被定义，进样口由压力控制。

如果未安装 EPC（电子流量控制）（手动控制进样口），压力控制和总流量控制均不能使用。

本对话框内容：

Mode（模式）

Gas（气体）

Heater（加热器）

Pressure（压力）

Total Flow（总流量）

GasSaver（载气节省）（如果色谱柱已被定义）


挥发物接口

挥发物接口提供一个简单可靠的方法来从一个外部进样装置如顶空、吹扫和捕集或空气污染物进样器来进样到 6890 GC。接口体积很小且是高度惰性，这样保证需要痕量级检测的应用的高灵敏度和分辨率。

流向接口的总流量由一个流量传感器测量然后分为两个气流。一股气流连接到隔垫吹扫调节器；另一股连接到一个沙芯过滤块。在沙芯过滤块处，气流进一步分流。一股气流进入气相进样器然后流向接口。另一股称作压力传感线的气流通过沙芯过滤块然后被压力传感器测量。这个气流也提供一个细流流到接口。

要工作在不分流或直接模式下，或在分流模式下使用载气节省的话，如果没有使用任何自动操作必须在 6890 GC 键盘打开 Auto Prep Run（自动预运行）或按下 [Prep Run]（[预运行]）。

使用这个对话框来设定挥发物接口参数和设定值为当前方法。

有 3 种有效操作模式：


气路控制模块 (PCM)

Pneumatics Control Module（气路控制模块，PCM）提供一个流量或压力控制通道，取代该通道的标准电路控制模块 (ECM)。

PCM 能控制许多应用程序的气体流量和压力，包括：

  • 非安捷伦标准进样口。例如，使用安捷伦系统合伙人的专有 PTV 进样口的 SIMDIS 应用。*

  • 任何不用进样口时阀的应用，如向气体进样阀提供流量或压力。

  • 样品准备装置如 Headspace Sampler（顶空进样器）和 Purge and Trap（吹扫和捕集）通常需要一个吹扫气体控制源。

  • 催化剂管或其他转换装置通常需要反应气或尾吹气控制源。镍催化剂管附件是这种装置的一个好例子。

  • 有关进一步信息，请看见 AC SIMDIS 操作手册 (G2131-90310)。

本对话框内容：

Gas（气体）

Air Cooling On（空气冷却开启）

Heater（加热器）

Ramps（梯度）

Pressure（压力）

Total Flow（总流量）


程序升温挥发 (PTV) 进样口

程序升温挥发进样口

使用此对话框来设定 PTV 进样口参数和对于当前方法的设定值。

关于程序升温挥发 (PTV) 进样口

程序升温挥发 (PTV) 进样口系统与具有可处理大体积进样的额外操作模式（溶剂放空模式）的分流 — 不分流进样口相似。

  • 分流模式通常用于主要组分分析。

  • 脉冲分流模式与分流模式类似，但有一个在进样过程中用于进样口的压力脉冲来加速物质向色谱柱的传输。

  • 不分流模式用于痕量分析。

  • 脉冲不分流模式允许在进样过程中使用压力脉冲。

  • 溶剂放空模式用于大体积进样。对于每次运行一次进样或多次进样都可以进行。

计算值

化学工作站计算并显示两个参数，为用户指明在运行中 PTV 进样口如何工作。

  • 在 Injector（进样器）屏幕上显示了对分析进行多次进样的 Total Time（总时间）。通过将每次进样体积与每次运行进样次数相乘而计算出（进样 <x> uL <y> 次)。

  • 在 Inlets（进样口）屏幕上，进行多次分析进样的 Estimated total injection time（估计总进样时间）是根据输入的参数和 GC 进样器的机械循环时间计算而得的。计算包括参数 Delay between injections（进样间延迟）。

本对话框内容：

Mode（模式）

Gas（气体）

Cryo Config（冷却配置）

Heater（加热器）

Ramps（梯度）

Pressure（压力）

Total Flow（总流量）

GasSaver（载气节省）（如果色谱柱已被定义）


注射器

如果自动液体进样器是您仪器配置的一部分，Injector（注射器）对话框中的参数才有效。（否则参数将显示为灰色。）

有关详细信息，请单击 注射器。

有关步进说明，请参见下列任务：

编辑方法

有关补充信息，请单击下列各项：


安装色谱柱 1/2

使用该对话框通过 Inventory#（目录号）确定已经安装的色谱柱。

该对话框中显示的列表给出了目录中的色谱柱，还给出了制造商规格：

Model Number（型号）

Max Temperature（最高温度）

Description（说明）

Length（长度）

Diameter（直径）

Film Thickness（膜厚）

以及当前所选色谱柱的校准规格。（有关详细信息，请参见色谱柱 1/2 校准。）

要鉴别已安装的色谱柱，只需选择该柱即可。

如果色谱柱未显示 [image] 首先将其添加到目录中。返回（单击 Cancel（取消））到 Change Column 1/2（更换色谱柱 1/2）对话框，单击 Add...（添加...）按钮：

注意：当两根色谱柱安装到一个进样口，实际色谱柱流量和分流比可能与期望值不同。

要从目录中删除一根色谱柱，请选择它并使用 Delete Column（删除色谱柱）按钮。

确定/取消/帮助按钮


选项

使用 Options（选项）对话框作下列选择：

  • 在当前处理方法中，您想采用的压力单位，

  • 在 6890 系列 GC 仪器中，您是否想锁定来自 GC 键区的设定值项目，

  • 以及您想运行的色谱柱补偿检测器。

本对话框内容：

Pressure Units（压力单位）

Lock Keyboard（锁定键盘）

Column Compensation Detector（色谱柱补偿检测器）

要获得逐步指令，请参见以下任务：

编辑方法

要获得其他信息，请单击以下任意一项：


柱箱

柱箱性能

  • 温度范围：-80 [image] C（液体 N2 ）或 -60 [image] C (CO2) 至配置极限

  • 最高温度：70 [image] C 至 450 [image] C

  • 温度程序：最多六级温度梯度

  • 最大运行时间：999.99 分钟

  • 温度调节速度：0 至 120 [image] C/min，取决于仪器配置

使用 Oven（柱箱）对话框来设定柱箱参数，指定设定值，或者还可以为当前处理方法准备柱箱温度梯度程序。

无分流模式进样操作的柱箱参数

参数 | 允许的 设定值范围 | 建议的 启动值
柱箱温度 | 无低温冷却时，24 [image] C 至 450 [image] C 或最大值。 CO2 低温冷却时，-60 [image] C 至 450 [image] C 或最大值。 N2 低温冷却时，-80 [image] C 至 450 [image] C 或最大值。 | 10 [image] C 低于 溶剂沸 点
柱箱 初始时间 | 0 到 999.9 分钟 | 进样口吹扫时间
进样口 吹扫时间 | 0 至 999.9 分钟 | （衬管体积/ 色谱柱流量）x 2
载气节省 运行时间 | 0 至 999.9 分钟 | 后吹扫时间
载气节省 流量 | 15 至 1000 mL/min | 15 mL/min 大于 最大色谱柱 流量

本对话框内容：

Oven（柱箱）

Oven Ramp（柱箱温度梯度）

Oven Configuration（柱箱配置）

Cryo Configuration（低温配置）

有关步进说明，请参见以下任务：

编辑方法

准备梯度柱箱升温程序

准备等温运行

有关其他信息，请单击以下任意一项：


信号

信号为输出到数据处理设备的模拟或数字输出。它可能是检测器的输出或温度、流量或压力传感器的输出。

  • 模拟输出在下列两种速度下有效，适合最小峰宽为 0.004min（快速数据采样频率）或 0.01min（正常采样频率）。

  • 对化学工作站的数字输出在范围为 0.1Hz 到 200Hz 的 11 种速度下有效，能处理峰宽为 0.001 到 2min 的峰。

化学工作站可以为两个独立的信号采集并保存数据：信号 1 和信号 2。

对于每个信号，使用 Signals（信号）对话框：

  • 指定信号数据的源、

  • 指定数据采集参数和

  • 指定是否在运行时将数据保存到文件。

可以将信号类型设定为运行时间事件。

本对话框目录：

Source（源）

Data Rate（数据采样频率）

Minimum Peak Width（最小峰宽）

Calc Button（计算按钮）

Save Data（保存数据）

有关步进说明，请参见下列任务：

编辑方法

优化数据采样频率

有关更多信息，单击下列之一：


阀

使用 Valves（阀）对话框来：

  • 配置一个阀为切换、气体进样、多位或其他用途。

  • 控制阀的初始（预运行）和即时（运行中）开/关状态。

  • 指定多位阀的即时位置。

除低温和分流/不分流阀外可以配置并控制多达八个阀：

阀
编号

类型

伏

功率或电流

使用

1, 2, 3 和 4

电流源

24 V 直流

13 瓦

气路阀控制

5 和 6

电流源

24 V 直流

100 mA

延迟和
low-power devices（功率装置）

7 和 8

触点开关

48 V 直流或
48 V 交流 rms

外部电流源控制

要在运行中安排阀事件，使用 Runtime（运行时间）对话框。

该对话框内容：

Valve（阀）

Configure（配置）

有关步进说明，请参见下列任务：

编辑方法

有关进一步说明，请单击下列任何一项：


编辑 GC 监测器 (6890)

编辑 GC 监测器 (6890 GC)

欲显示该对话框，请单击

然后从弹出的菜单中选择 Edit GC Monitors（编辑 GC 监测器）。或者选择 Instrument / GC Monitors（仪器/ GC 监测器）。使用该对话框指定希望显示在 Instrument Control（仪器控制）面板上的监测器类型。

Type（类型）

希望监测的项目：柱箱、进样口、检测器、色谱柱、辅助设备

Location（位置）

适合于所选类型。

Parameter（参数）

柱箱 — 温度

进样口 — 温度、压力、总流量

检测器 — 温度、燃料流量、有效流量、尾吹流量

色谱柱 — 流量计算

辅助设备 — 温度

Display（显示）

数字信号或模拟信号

6890 Status（6890 状态）

如果希望监测 GC 前面板上的显示，请选择该复选框。

另见

显示 GC 监测器


时间事件

MS Timed Events Table（MS 时间事件表）是您希望在数据采集过程中发生的时间程序设置事件的列表。通过 MS SIM/Scan Parameters（MIS SIM/扫描参数）对话框中的 Timed Events（时间事件）按钮访问该表。MS 的下列部件可在数据采集过程中进行控制：

  • 检测器（给所有的质谱仪通电和断电）

  • EMV Delta 为电子倍增器电压相对于调谐文件中电子倍增器电压的变化。允许值范围为 EMV（Delta EMV 与 Tune EMV 的和）在 0 到 3000 伏特之间。输入值被自动调节为最接近的步长（MSD 上为 11.76 伏特）。

  • 阀

另见

使用 MS 时间事件表


编辑 MS 监测器

欲显示该对话框，请单击

然后从弹出的菜单中选择 Edit MS Monitors（编辑 MS 监测器）。或者选择 Instrument / MS Monitors（仪器/MS 监测器）。使用该对话框指定希望显示在 Instrument Control（仪器控制）面板上的监测器类型。

Type（类型）

希望监测的项目：Parameter, Valve, Zone（参数、阀、区）

Parameter（参数）

Parameter（参数） | AMU Gain（AMU 增益） AMU Offset（AMU 补偿） Emission（发射） Repeller（推斥极） Ion Focus（离子聚焦） Entrance Lens（入射透镜） X-Ray（X-射线） (5973 无) EMVolts（发射电压） DC Pol（DC 极性） Filament（灯丝） TTI (5973 无) Wid219 Ent Lens Offset（入射透镜补偿） Ion Pol（离子极性）（正或负） Electron Energy（电子能量） ( HED Enable（HED 启用）（开或关）
Valve（阀） | 校准 Out1 (5973 无) Out2 (5973 无)
Zone（区） | MS Source（MS 源）（仅用于 5973） MS Quad（MS 四极杆）（仅用于 5973） Foreline（前级）（仅用于 5973） TurboSpd（涡轮速度）（仅用于 5973） MS Temp（MS 温度）

Display（显示）

数字信号或模拟信号

另见

显示 MS 监测器


给显示作注释

添加注释

  1. 把鼠标指针移到您希望出现注释的位置，同时单击鼠标左右键。

  2. Annotate（注释）对话框出现后，键入需要的文本。

  3. 选择文本在选定点居中、左对齐还是右对齐。

  4. 然后按 Enter 键或单击 Add（添加）按钮。

删除注释

  1. 把鼠标指针移到要删除的注释上的任何位置，然后同时单击鼠标的左右键。

  2. 出现对话框后，按 Enter 键或单击 Delete（删除）按钮。

有关进一步信息，请单击 Annotate（注释）对话框中的 Help（帮助）。注意：该信息未被存储。

另见

MS 化学工作站中的字体选择

注释


复制窗口

  1. 选择 Tools/ Copy Window（工具/复制窗口）。

  2. 系统提示您输入想复制的图形窗口数目，做出回答。

  3. 单击 OK（确定）。图形窗口的内容就复制到剪贴板上了。

您可以使用 Paste（粘贴）将剪贴板上的内容复制到另外的应用程序中。


打印色谱和光谱

  1. 选择File / Print（文件/打印）并选择要打印的项目：

    — 选定的窗口

    — TIC 和光谱

    — 方法

  2. 单击 OK（确定）。


放大

  1. 将鼠标指针移动到欲放大区域的一角。

  2. 按住鼠标左键并拖动形成一个方框定义放大区域。

当释放鼠标键时，方框中的区域放大到填充整个窗口。


缩小

将鼠标指针放在要缩小窗口的任意位置并双击鼠标左键。


使用 DOLIST

DOLIST 是以相同方式处理一批文件的工具。欲使用 DOLIST，遵循下列步骤：

  1. 从菜单中选择 Tools / DOLIST。将显示一个 Report Option（报告选项）对话框。

  2. 选择目标报告，并单击 OK（确定）。显示 Multiple File Select（多个文件选择）对话框。

  3. 从 Directories（目录）列表中选择数据目录。

  4. 从 Data Files（数据文件）列表中选择一个将被处理的文件。

  5. 单击箭头将文件移动到 Files Selected for Processing（被选择要处理的文件）列表。

  6. 为要处理的所有文件重复步骤 5。

  7. 单击 Process（处理）开始处理文件。

另见

使用 DOSCAN


使用 DOSCAN-GC/MS

使用 DOSCAN

DOSCAN 是批处理用户从数据文件中选择的光谱的一个工具。例如，可以使用它为数据文件中的 10 个光谱形成一个详细的谱库检索报告。

为调用 DOSCAN，从菜单中选择 Tools / DOSCAN（工具/DOSCAN）。将提醒您是否生成一个详细的谱库检索报告或在选择的光谱上运行一个宏。在这个选择之后，鼠标将对注释操作有不同的响应。（单击鼠标左右键）

将光标定位在总离子流色谱的目标位置上并同时按下鼠标的两个键。一个“＋”被画在色谱上。使用相同的鼠标操作，继续选择将要报告的光谱。使用鼠标放大和缩小仍然有效。

一旦目标光谱被选择，从菜单中选择 Tools / Process Scan List（工具/处理扫描列表）。这将初始化整个过程。

另见

DOSCAN 命令

DOLIST 命令


EasyID

EasyID 是一个以逐个化合物方式（不是总体确定）更新定量数据库中保留时间的工具。一次性改变所有化合物的保留时间，请使用 Calibrate / Update/Global Update（校准/更新/全局更新）。

EasyID 允许您手动选择一个峰。积分峰获得的保留时间将成为化合物新的预期保留时间。化合物原积分面积将不会改变。提取信号的起始和结束时间相对于新的预期保留时间将会移动。如果对当前选定化合物未进行积分，那么该化合物的校准表不会被修改。

对于内标 (ISTD) 化合物保留时间的任何改变都将提示用户自动更新相对于该内标的目标化合物的保留时间。新的保留时间根据内标的保留时间和目标化合物的原保留时间的差值进行计算。

EasyID 也可以用于为任一或所有目标化合物更新参比谱。这是对于共洗脱化合物所最经常使用的。EasyID 也可以用于选择和存储一个新的参比谱或“整理”和存储当前参比谱。

EasyID 通过选择 View / EasyID（查看/ EasyID）打开。用于保留时间更新的菜单的一个新设置就会被加载。

EasyID

Spectrum（谱图）

Integrate（积分）

ChromEval（色谱评价）

在 EasyID 模式下，所有编辑保存在一个临时文件中。当退出 EasyID 模式时，实际结果可被更新（选择 Exit and Save Changes（退出并保存更改））或放弃临时编辑（选择 Abort Changes and Exit（终止更改并退出）)。

选择 EasyID 也会调出 Quick Qedit 窗口。该窗口提供一个快捷方式查找并选择定量数据库中的特定化合物。

另见

EasyID 鼠标操作

使用 EasyID 更新保留时间


定量编辑定量结果/定量模式

QEdit 是定量结果编辑器。它用于查看和编辑定量结果。一系列新的菜单和鼠标操作用于 QEdit 模式。菜单有：

Qedit（定量编辑）

Spectrum（谱图）

ChromEval（色谱评价)

Display（显示）

另见

使用 Qedit 查看定量结果

QEdit 鼠标操作


检查峰纯度 — GC/MS

峰纯度检查工具能帮您检测色谱中的重叠峰（多组分峰）。重叠峰会干扰谱库检索和定量。

好的色谱对于峰纯度工具的校正功能十分重要。如果色谱很糟糕，峰纯度工具就可能会将单组分峰识别为多组分峰。

另见

使用峰纯度工具

峰纯度显示

峰纯度模式下的鼠标操作


校准视窗

Alignment（校准）视窗在 Data Analysis（数据分析）中的 View / Align GC（查看/校准 GC） 菜单中。显示四个色谱窗口。显示区上半部分的两个窗口包含 MS 信号，下半部分的两个窗口包含 GC 信号。显示区左边的两个窗口用来选定 MS 和 GC 信号的起始校准点。显示区右边的两个窗口用来选定 MS 和 GC 信号的结束校准点。

在 Alignment 视窗中有两个菜单：

校准菜单

Show current method alignment points （显示当前方法的校准点） | 显示当前存储在 GC 和 MS 数据校准方法中的起始和结束校准点。
Perform Alignment （进行校准） | 基于当前 GC 和 MS 数据中的选定点进行校准。
Restore Alignment Chromatograms （恢复校准色谱） | 恢复 GC 和 MS 中原来未校准的色谱。
Abort （异常中止） | 停止操作，不保存校准点，返回 Data Analysis（数据分析）主视窗。您有机会改变原定想法。
Exit/Save （退出/保存） | 保存当前校准点并返回 Data Analysis（数据分析）主视窗。

查看菜单

Return to DA
（返回 DA）

提示您在返回 Data Analysis（数据分析）主视窗前保存校准点。

另见

检查混合模式数据文件

根据 MS 保留时间校准 GC 信号

定量混合模式数据


文件菜单

Load Data File （加载数据文件） | 调用一个用户指定的数据文件和显示该文件的总离子流色谱 (TIC)。
Next Data File （下一数据文件） | 调用紧跟同一目录下当前数据文件的文件。
List Header （列出文件头） | 显示数据文件头的信息和使用该数据文件的操作历史记录。
Edit File Info （编辑文件信息） | 显示一个可以改变当前数据文件的文件头信息的对话框。
Take Snapshot （抽点打印） | 显示在激活 Snapshot（抽点打印）前采集的数据。这一功能对只适用于 GC 的数据无效。
Subtract Background (BSB) （扣除本底） | 运行本底扣除。这一功能对只适用于 GC 的数据无效。
Select Signals （选择信号） | 允许从包含多信号的数据文件选择加载信号。如果仅选择 MS 信号（例如），下次加载数据文件时，仅加载 MS 信号，并且提示行说明所有信号都没有加载。
Printer Setup （打印机设置） | 允许选择纵向（垂直）或横向（水平）方向
Print （打印） | 打印色谱和/或光谱。
Abort （异常中止） | 中止已经不需使用的 Data Analysis（数据分析）例程。
Export Data to CSV File （将数据导出到 CSV 文件） | 允许以 CSV 形式保存数据。然后 CSV 文件可以被输入一个电子制表程序，例如 Microsoft Excel。
Export Data to AIA Format （以 AIA 格式导出数据） | 允许以 AIA(*.CDF) 格式保存数据。可以输出一个或一批文件。 ALA 格式是质谱和 GC 数据在各种制造商的数据系统之间的交换的企业标准。
Import AIA Raw Data Files （导入 AIA 原始数据文件） | 允许您输入一个标准 AIA (*.CDF) 文件。
Exit （退出） | 关闭 Data Analysis（数据分析）程序。确定先保存对方法的所有更改。


方法菜单（数据分析）

方法菜单

Run Method （运行方法） | 仅进行当前方法的 Data Analysis（数据分析）部分。
Load Method （加载方法） | 弹出一个可以选择加载另一个方法的对话框。
Save Method （保存方法） | 保存对当前方法的任何改变。
Edit Method （编辑方法） | 允许编辑当前方法。
Generate AutoSIM Method （生成自动 SIM 方法） | 显示 Automatic SIM Setup（自动 SIM 设定）对话框，可以在其中从一个定量方法自动设定一个 SIM 采集方法。
Batch Mode （批模式） | 切换到 Batch Mode Data Analysis（批模式数据分析）。Method（方法）菜单将转换到 Batch Method（批模式）菜单。


色谱菜单

仅在 GC/MS 模式下有效的项目标记为 (GC/MS)。仅在 GC 模式下有效的项目标记为 GC only。

Chromatogram Scaling （色谱图坐标设定） | 通过指定的坐标设定因子为选定的色谱图设定坐标。
Draw Chromatogram - No Labels （画色谱图 — 无标记） | 重画当前数据文件的原始色谱图，不带标记或积分记号。
Draw Chromatogram With Labels （画带标记的色谱图） | 重画当前数据文件的原始色谱图，带有指定标记。
Select Chromatogram Labels （选择色谱图标记） | 显示 Select Labels and Redraw TIC（选择标记并重画 TIC）对话框，可选择您希望使用的标记类型。
Extract Ion Chromatograms （提取离子色谱） (GC/MS) | 从当前数据文件的总离子流色谱（TIC）中提取并显示提取离子色谱（EIC）。
Display Ion Chromatograms in Merged Format （显示合并形式的离子色谱） (GC/MS) | 使提取离子色谱彼此重叠显示。
Select Integrator （选择积分器） | 允许您临时选择一个积分器（RTE 或化学工作站），而不用方法中指定的积分器。
MS Signal Integration Parameters （MS 信号积分参数） (GC/MS) | 根据所选的积分器，允许您对质谱编辑化学工作站的积分事件或 RTE 积分器参数。
GC Signal Integration Parameters （GC 信号积分参数） (GC/MS) | 除非在混合模式下运行,否则该选项显示为灰色。根据所选的积分器，允许您对 GC 编辑化学工作站的积分事件或 RTE 积分器参数。
Signal 1 Integration Parameters （信号 1 的积分参数） (GC only) | 允许您对信号 1 编辑积分事件。
Signal 2 Integration Parameters （信号 2 的积分参数） (GC only) | 允许您对信号 2 编辑积分事件。
AutoIntegrate （自动积分） | 设法为当前色谱图查找最佳积分参数并积分色谱图。如果在方法中当前设置了 RTE 积分器，该选项显示为灰色。
Integrate （积分） | 使用当前积分器设定的参数积分当前色谱图。
Integration Results （积分结果） | 显示与当前数据文件关联的一份积分结果列表。
Percent Report （百分比报告） | 为当前数据文件生成一个百分比报告。如果当前数据文件是在 5973 MSD 的 PCI 模式下获得的，将提示您选择加合离子用于分子量的计算。


谱图菜单

Spectrum（谱图）菜单仅在 GC/MS 模式下出现并可以访问 PBM 谱图库查找特征。它同时可允许使用软件的参数检索功能。

Add （添加） | 添加两个谱图并显示它们的加和。
Subtract （扣除） | 从一个谱图中扣除另一个谱图并显示其差值。
Tabulate （列表） | 以列表格式 显示质谱。
Select Library （选择谱库） | 打开 Library Search Parameters（谱库检索参数）对话框，可以选择将在当前选定谱图的 PBM 检索中使用的谱库。
Edit Strategy （编辑策略） | 打开 Search Strategy（检索策略）对话框，可以查看、编辑影响 PBM 检索匹配程度的参数。
Edit Library （编辑谱库） | 允许创建谱库，编辑用户创建的谱库，或查看商业谱库项。
Library Search Report （谱库检索报告） | 积分当前的 TIC（总离子流色谱）, 为每个峰的匹配检索当前谱库，并生成一个报告。
NIST Output （NIST 输出） | 在 NIST中保存谱图数据（ASCII 格式）到一个文件。
Change Spectral Display （改变谱图显示） | 显示 Spectral Manipulations（谱图处理）对话框。这个对话框可以让您调整谱图如何显示。


校准菜单 — 数据分析

校准菜单

仅在 GC/MS 模式下有效的项目标记为 (GC/MS)。仅在 GC 模式下有效的项目标记为 GC only。

Set Up Quantitation （设置定量） | 允许您通过指定全局定量数据库并向数据库中输入化合物来设置定量数据库。
AutoQuant Setup （自动定量设置） (GC/MS) | 提供了一种建立定量数据库的半自动方法。
Edit Compounds （编辑化合物） | 允许您逐个查看和编辑定量数据库中的化合物信息。
Update （更新） | 允许您添加、删除或更新当前定量数据库中的校准级。
Batch Recalibrate （批重新校准） | 该菜单选项仅在 Batch Mode Data Analysis（批模式数据分析）中有效。它允许可不重新计算基线而重新进行校准。如果您已用 Qedit 修正了定量结果中的积分异常并希望使用手动响应，该菜单项是很有用的。
List （列表） | 显示 Select Method Reports（选择方法报告）对话框，其中可选择查看校准历史记录、校准报告和其他报告。
Clear （清除） | 显示 Select Clear Option（选择清除选项）框
Create Quant DB Entries for Second Signal （将第二个信号收录到定量数据库中） (GC only) | 将 Signal 1（信号 1）的化合物清单项目复制到 Signal 2（信号 2）（用于确认运行的信号）。


定量菜单

仅在 GC/MS 模式下有效的项目标记为 (GC/MS)。仅在 GC 模式下有效的项目标记为 GC only。

定量当前文件并生成一个定量报告。
Generate Report （生成报告） | 为已经被定量的文件生成一份定量报告。
Manual Int Calc/Gen Report （手动积分计算/生成文件） | (GC only) 定量手动积分数据文件并生成一份定量报告。
Use Classic Reports （使用经典报告） | 允许您选择 Standard（标准）模式中使用的原始 G1034A/B 类型定量报告。
Report Options （报告选项） | 允许您控制哪些信息被包含于定量报告中以及它们如何显示。
Report Non Target Peaks （报告非目标峰） | 允许您生成非目标峰的 LSC 报告。 该选项仅当选择 Quantitation Report Options（定量报告选项）对话框的 Include Non Target Peaks（包括非目标峰）时有效。
Use Method Aligned GC Trace （使用校准 GC 跟踪的方法） | (GC/MS) 允许您在已执行了校准并将数据点保存到当前方法的情况下，定量 GC 信号。
Trace Mode Quant （跟踪模式定量） | (GC/MS) 生成一份报告其中包含定量数据库中一个单独化合物的所有定量信息。
Custom Reports （定制报告） | 启动 Custom Reports（定制报告）软件。如果方法没有定量数据库或没有加载数据文件，您可以使用缺省值。
Print Report （打印报告） | 使用当前数据文件打印方法指定的自定义报告样式。
Update Database （更新数据库） | 用当前数据文件的定量结果更新方法指定的数据库（在 Custom Reports（定制报告）中创建的）。
Select Template / Database （选择模板/数据库） | 允许您选择定制报告模板和与当前方法一同使用的定制报告数据库。


工具菜单

仅在 GC/MS 模式下有效的项目标记为 (GC/MS)。仅在 GC 模式下有效的项目标记为 GC only。

DOLIST | 允许您选择一批数据文件一起处理。
DOSCAN (GC/MS) | 允许您从数据文件 (TIC) 中选择一组谱图一起处理。
Process Scan List （处理扫描列表）(GC/MS) | 与 DOSCAN 命令使用。用 DOSCAN 选择谱图后，选择这一菜单项即开始进行处理。
Export 3-D Data （输出 3-D 数据） | 使您将指定质量和扫描范围输出到 CSV 文件。
Locate a Compound （定位一个化合物）(GC/MS) | 确定当前数据文件中是否存在当前定量数据库中的特定目标化合物。
Locate All Compounds （定位所有化合物）(GC/MS) | 确定当前数据文件中是否存在当前定量数据库中的所有目标化合物。
Set Overlay Parameters （设定覆盖参数） | 使您确定如何显示被覆盖的色谱图。
Overlay Chromatograms （覆盖色谱） | 使您选择多个色谱图叠加显示。
Signal to Noise Check （信噪比检查） | 进行信噪比检查。
Change Data State （改变数据状态） | 使您为显示的数据文件附加状态。
Options （选项） | 您可以选择 Label Spectral Peaks（标记谱峰）(GC/MS)、Autoscale（自动设定）Y 轴坐标、使用 Command Line（命令行）、浏览 Stack（堆栈）窗口，并进行 Manual Integration（手动积分）(GC/MS)。
Create Screen Results for Current File （创建当前文件的筛选结果） | 用于 RTL（保留时间锁定）。 使用当前加载的数据文件和当前指定的方法 筛选数据库 (SCD) 来执行筛选操作。
Generate Screen Report for Current File （生成当前文件的筛选报告） | 用于 RTL（保留时间锁定）。 创建当前加载的数据文件的筛选报告，结果显示在屏幕上。
Generate/Print Screen Report for Current File （生成/打印当前文件的筛选报告） | 用于 RTL（保留时间锁定）。 创建当前加载的数据文件的筛选报告。结果发送到打印机。
Generate/Print Screen Report for Multiple Files （生成/打印多个文件的筛选报告） | 用于 RTL（保留时间锁定）。 创建所选数据文件的筛选报告。结果发送到打印机。
Specify Method Screen Database （指定方法筛选数据库） | 用于 RTL（保留时间锁定）。 使您可选择或改变筛选过程中用到的筛选数据库。
Change Screen Database Parameters （改变筛选数据库参数） | 用于 RTL（保留时间锁定）。 使您可为当前方法的筛选数据库改变参数。如果未指定方法筛选数据库，您将会被提示选择一个。
List Screen Database （列表筛选数据库） | 用于 RTL（保留时间锁定）。 显示选定的筛选数据库的内容（化合物名称、预计保留时间和目标离子）。
Exclude Zero Qualifiers （排除零特征项） | 用于 RTL（保留时间锁定）。 （仅适用于 MS)。菜单项可选中或不选中。它决定筛选报告过程如何评价一个缺少一个或多个特征离子的化合物。如果该菜单项被选中，任何只要缺少一个特征离子的化合物都会从报告中排除。
Copy Window （复制窗口） | 将窗口复制到剪贴板。
Reset Windows （重置窗口） | 将图形窗口重新安排到缺省位置。


查看菜单（数据分析）

仅在 GC/MS 中有效的条目由 (GC/MS) 指定。仅在 GC 模式中有效的条目由 GC only 标记。

EasyID | 让您以逐个化合物方式升级已存在于定量数据库中的 MS 数据的期望保留时间和离子比。
QEdit Quant Result （QEdit 定量结果） | 一旦数据文件已被定量后，允许查看和编辑定量结果。
Edit Non Target Peaks （编辑非目标峰） | 让您编辑 Non Target Peak（非目标峰）的结果，这些结果由比较从数据得出的质谱与谱库中的可能匹配项的质谱而检索得出。
Parametric Retrieval （参数检索） (GC/MS) | 进入 Parametric retrieval（参数检索）视窗，有助于在质谱谱库中查找化合物。
Align GC （校准 GC） (GC/MS) | 进入 Alignment（校准）视窗，在其中可以校准由混合模式数据文件得出的色谱峰。除混合模式外其他情况为灰色。
Review Peak Purity （检查谱峰纯度） (GC/MS) | 帮助在色谱中检测重叠峰（多元峰）。
Results Screener （结果筛选器） | Results Screener（结果筛选器）用于评估在锁定情况下采集的任何数据文件中的锁定化合物的期望保留时间/离子（仅适用于 MS）。
RTLock Setup （RTLock 设置） | 进入 RTLock Setup（RTLock 设置）视窗，用于保留时间锁定任务。


百分比报告

这一菜单项目产生当前数据的百分比报告。报告以 MultiVu 格式显示，这种格式可以打印到或复制到剪贴板。对于每个谱峰提供的信息包括：

  • 保留时间

  • 首、尾和最大扫描次数

  • 峰高

  • 峰面积（原始）

  • 峰面积（校正后）

  • 相对最大峰的峰高

  • 对所有峰总面积的百分比贡献


谱库检索报告选项

Library Search Report Options（谱库检索报告选项）对话框允许您为谱库检索报告指定：

类型

输出格式

对于从 TIC 自动选择的积分峰的谱库检索，也可指定：

积分参数文件

使用的谱图


生成定量报告

从菜单上选择 Quantitate / Generate Report（定量/生成报告）时出现 Quant Report Options（定量报告选项）对话框。使用这个对话框来指定定量报告的结构和对象。

要交互性地生成已计算过的定量报告，请从菜单选择 Quantitate / Generate Report（定量/生成报告）。使用当前数据文件。

要自动生成一个定量报告作为当前方法的一部分，请选择 Method / Edit Method（方法/编辑方法），并在 Select Reports（选择报告）对话框中选择 Quant Report（定量报告）。保存方法或更改无效，而且不会自动生成报告。

另见

定量报告选项


使用经典报告

允许您在化学工作站软件 (G1034A/B) 前一版本的 Standard（标准）模式下选择原来的定量报告格式。

  1. 在 Data Analysis（数据分析）中选择 Quantitate / Use Classic Reports（定量／使用经典模式）。

  2. 将提示您与方法一起保存该报告样式。单击 Yes（是）。

    报告格式与方法一起保存后，Report Options（报告选项）菜单项变灰，复选标记出现在 Use Classic Reports（使用经典样式）菜单项旁边，表明该方法使用 Classic Reports（经典报告）。

要取消选定该报告格式，选择 Quantitate / Use Classic Reports（定量／使用经典报告）, 单击 Yes （是）保存方法。Report Options（报告选项）菜单项现在生效。


以合并样式显示离子色谱 - GC/MS

选择该菜单项后，由 Ion Chromatograms（离子色谱）菜单项产生的色谱会在同一个窗口中重叠显示。当在这个菜单项后出现一个选中标记时该项被选中。


显示 TIC

显示总离子流色谱 (TIC)

选择 File / Load（文件/调用）菜单项。然后选择您想查看的数据文件。总离子流色谱 (TIC) 显示在标号为 [2] 的窗口中。接下来的操作将会用其他显示屏替换 TIC（总离子流色谱）。

重绘总离子流色谱 (TIC)

在菜单中选择 Chromatogram/ Draw Chromatogram（色谱/绘制色谱）。

扣除本底并显示 TIC

选择要扣除本底的光谱，然后从 File（文件）菜单中选择 Subtract Background（扣除本底）(BSB)。

显示当前采集数据的 TIC

从 File（文件）菜单中选择 Take Snapshot（抽点打印）。


抽点打印 — GC/MS

抽点打印用于在数据采集过程中显示激活 Snapshot（抽点打印）前所采集的数据。它显示 TIC。可从 TIC 中提取质谱数据。抽点打印通过选择 File / Take Snapshot（文件/抽点打印） 来激活。

溶剂延迟时间结束前，不能进行抽点打印。抽点打印显示前可能会有短暂的延迟。延迟时间长短取决于要求的扫描长度以及 Instrument Control（仪器控制）和 Data Analysis（数据分析）之间通讯的同步性。等待过程中有信息显示已运行时间：

Waited x seconds for Acq to take snapshot.（Acq 抽点打印需等待 x 秒。） Use Abort to stop.（使用 Abort 停止。）

要在抽点打印完成前取消抽点打印，请选择 File / Abort（文件/异常中止）。


扣除本底值的色谱

选择 File / Subtract（文件/扣除）本底 (BSB) 时，最新被选定的质谱（在堆栈窗口中名为 X ）从当前色谱的每一点中扣除。结果数据保存在（DATA 目录的）BSB 子目录下，是与原数据文件同名的数据文件。

这个新数据文件成为当前数据文件，显示扣除本底值的色谱。本底扣除次数的记录保存在数据文件头的 Operator（操作者）项目中。


提取离子色谱

从当前数据文件中，能够提取离子色谱，与总离子流色谱一样进行显示和积分。

  1. 选择 Chromatogram/ Extract Ion Chromatograms（谱图/提取离子色谱）。出现 Extracted Ion Chromatograms（提取离子色谱）对话框。

  2. 选择离子色谱的时间范围。最初显示的是该数据文件的整个时间范围。您可以输入您想要的更小的时间范围。

  3. 输入您想生成的每一个离子色谱的质量。离子色谱生成时，每一个质量将转换为一个从（该质量 - 0.3）到（该质量 + 0.7）amu 的范围（自动对质量缺陷进行补偿）。如果仪器条件允许，您还可以修改质量缺陷设定。

  4. 单击 OK（确定）。离子色谱经提取后显示在 2 号图形窗口中。提取离子色谱可以单个显示，也可以以合并形式显示。


积分

选择 Chromatogram / Integrate（色谱图/积分）使用当前所选积分器和积分参数积分当前数据文件。

Data Analysis（数据分析）软件包括两个积分器： RTE 积分器和化学工作站积分器。积分器可以从 Chromatogram（色谱图）菜单或 Quantitation Database Globals（全局定量数据库）对话框（Calibration / Set Up Quantitation（校准/设定定量））中选择。如果选择 Use RTEINT（使用 RTE 积分器）复选框，则使用 RTE 积分器。如果未选择该复选框，则使用化学工作站积分器。

积分通过可被查看和编辑的积分参数来控制。RTE 积分器参数可从 RTE Integrator Parameters（RTE 积分器参数）对话框进行编辑并保存在一个参数文件（*.P）中。化学工作站积分器参数可从 Edit Integration Events（编辑积分事件）对话框进行编辑并保存在一个事件文件（*.E）中。积分参数可被保存在一个积分参数文件（.P）中。该文件即可用于积分特定化合物的目标或特征离子，或作为一个整个方法的缺省积分。


手动积分

手动积分 TIC 中的峰：

  1. 在 Data Analysis（数据分析）菜单中选择 Tools /Options/Manual Integration（工具/选项/手动积分）。这一项目旁边的复选标记表明它已经被启动 鼠标光标在 TIC 窗口中变成一个十字。

  2. 单击并拖动鼠标左键来放大色谱中要积分的峰。

  3. 单击并拖动鼠标右键来在峰上绘制一条积分基线。放开鼠标后，峰就会被选定的积分器积分。

如果要删除一个已积分峰，把光标移到上面并双击鼠标右键。


使用峰纯度工具

使用峰纯度工具 － GC/MS

峰纯度工具用于检查一个完整的色谱或检查一个单峰的纯度。

整个色谱

单峰


根据 MS 保留时间校准 GC 信号

如果混合模式数据文件中的洗提物在 MS 和 GC 信号中的保留时间不同，可以校准 GC 信号与 MS 信号的保留时间匹配。

  1. 调用一个混合模式数据文件，对峰积分。

  2. 选择 View / Align GC（查看/校准 GC） 进入 Alignment（校准）视窗。

  3. 将出现提示信息告诉您“Zoom windows until the integrator selects desired alignment peaks（选定坐标窗口直至积分器选择所需的校准峰）”。单击 OK（确定）。

  4. 用鼠标左键放大窗口左上方的起始要处理的色谱峰（MS 数据）。在窗口左下方进行同样操作（GC 数据）。在提示栏中校验您的选择。

  5. 在窗口右上方，放大您希望用于结束校准的 MS 峰。在窗口右下方进行同样操作。

  6. 要与方法一起保存校准因子，在菜单中选择 Alignment / Exit/Save（校准/退出/保存）。

校准因子将与方法一起保存，在选择 Quantitate / Use Method Aligned GC Trace（定量/使用方法校准的 GC 曲线）的情况下，可自动校准由该方法处理的任何后续文件。


选择谱图

将行光标移到色谱中要查看的质谱位置。双击鼠标右键。光谱显示在窗口 1 并存储在（堆栈窗口中的）X 中。

使用鼠标还可以显示选定扫描的平均质谱。


添加谱图

  1. 在希望添加的色谱图上的第一个扫描图形上双击鼠标右键，将显示谱图。

  2. 然后双击第二个扫描图形。

  3. 选择 Spectrum / Add（谱图/添加）。图形总和显示为名称后标有 [+] 号的谱图。


扣除光谱

  1. 在希望从中扣除一个光谱的色谱扫描图上双击鼠标右键。光谱将被显示并命名为“X”。光谱 X 的说明将显示在堆栈窗口。

  2. 现在双击第二个扫描图。现在它将被命名为“X”。前面被命名为“X”的光谱被重命名为“Y”。

  3. 然后选择 Spectrum / Subtract（光谱/扣除）。差值（Y－X）将被作为光谱显示出来，光谱标签后面被加上一个 [-]。

注意 欲从 Parametric Retrieval（参数检索）模式中扣除光谱，选择 Spectrum / Normalized Subtract（光谱/归一化扣除）。欲从 EasyID 模式中扣除光谱，选择 Spectrum / Subtract（光谱/扣除）。


平均谱图

  1. 将行光标移至色谱图中您希望进行光谱平均的起始点上。

  2. 按下鼠标右键，拖动形成一条线或一个框。线（框）的长度规定了松开鼠标后将被平均的扫描次数。光谱图显示为所选范围的平均值，在其名称后带有 [+,*]。


检索谱库

如何

检索质谱库来查找未知谱图的匹配项（PBM 谱库检索）

根据化合物属性查找谱库化合物（参数检索）

使用化学结构数据库

参见

关于 PBM

编辑 PBM 谱库

您可以对商用谱库进行检索，或使用为特殊用途在自己的实验室中创建的用户谱库。


DOSCAN

DOSCAN ["宏名称"]

在扫描列表上执行宏。

在运行宏前，必须选择要由该宏处理的扫描。为此，将光标置于期望的保存时间上，同时按下两个鼠标按钮。该时间将被标记为 +。您可以一直选择，直到队列填满或是所有期望的扫描都选定了。

要启动扫描处理，请在命令行上键入 PROCESSSCAN。一旦已开始执行宏，就会连续处理列表中的每个扫描。如果在执行中存在错误，则不处理列表中剩余的扫描。

"宏名称"

用于处理扫描列表的宏的名称。如果未指定名称，就会显示宏文件列表。如果选择宏文件 xxx.mac，将会运行文件中最后一个宏（如同已经输入了命令 macro xxx.mac,g 一样）。

示例

DOSCAN "REPORT_TIC 2"

提示您选择扫描。

PROCESSSCAN

为选定的扫描生成 Library Search Compound（谱库检索化合物）报告。


运行 PBM 检索

可以检索个别峰（光谱）或 TIC 中的所有积分峰。

检索个别光谱

  1. 选择一个要检索的谱图；会显示在窗口 #1 中并记录在（堆栈窗口中的）变量 X 中。

  2. 选择 Spectrum / Select Library（谱图/选择谱库）并指定要检索的谱库。

  3. 选择 Spectrum / Edit Strategy（谱图/编辑策略）并设定检索策略。

  4. 在谱图上双击鼠标右键。会激活 PBM 检索且显示结果。

  5. 检查结果。

检索 TIC 中的谱峰

选择 Spectrum / Library Search Report（谱图/谱库检索报告）后进行的检索。

  1. 选择 Spectrum / Library Search Report（谱图/谱库检索报告）。

  2. 选择合适的 Library Search Report Options（谱库检索报告选项），并单击 OK（确定）。会立即进行检索和报告。要停止检索，在它结束前，选择 File / Abort（文件/中止）。

  3. 检查 Summary or Detailed Report（摘要或详细报告）。

运行检索并自动将报告作为方法的一部分生成

  1. 选择 Method / Edit Method（方法/编辑方法）。

  2. Select Reports（选择报告）对话框出现时，如果没有选中则选择 LibSearch Report（谱库检索报告）。提示输入 Library Search Parameters（谱库检索参数）和报告选项。

  3. 结束编辑方法并保存修改过的方法。

  4. 运行方法。


使用参数检索

使用参数检索可以根据特定的准则定位谱库中的化合物。检索针对谱库中符合指定准则的化合物生成一个列表。您可以查看这些化合物的光谱，也可以将其与样品光谱进行比较。

要访问 Parametric Retrieval Mode（参数检索模式），请执行下列操作：

  • 在 Enhanced Data Analysis（增强型数据分析）中选择 View / Parametric Retrieval（视图/参数检索）。

  • 在 EnviroQuant 中选择 Lib / Parametric Retrieval（谱库/参数检索）。

  • 在 Drug Analysis（药物分析）软件中选择 Library / Parametric Retrieval（谱库/参数检索）。

要切换回 Data Analysis（数据分析）窗口，请选择 View / Standard Menu（视图/标准菜单）。

如何使用

比较未知和谱库谱图

创建子集谱库

在谱库中查找化合物

查看检索结果

仅查看谱库项目

查看 TIC 和谱库项目

查看未知光谱和谱库项目

查看未知光谱、谱库项目和差分光谱

参见

参数检索模式菜单

参数检索参数对话框

谱库检索参数对话框

检索策略对话框

谱库检索报告对话框

参数检索结果面板

关于归一化扣除

关于参数检索中的谱库选择

仅当某窗口具有焦点（如灰色标题栏所示）时，才可在其中进行键盘输入。例如，当您单击 Parametric Retrieval Result（参数检索结果）面板时，焦点就会出现在该面板上，快捷键（按钮上的下划线字母，如 Alt+t，用于 Text（文本）显示）就会起作用，但是定位 Parametric Retrieval（参数检索）窗口中菜单栏的快捷键（如 Alt+f，用于 File（文件））则不起任何作用。要切换焦点，请单击您希望在其中键入焦点的窗口，或按 Alt-F6 直至该窗口出现焦点。


关于 PBM

PBM 是根据概率匹配 (probability-based matching) 算法。它是由 Fred McLafferty 教授及其合作者在 Cornell 大学开发的一种谱库检索程序。

这种算法使用反向检索来检验未知谱中是否含有参照谱中的峰。未知谱中多余的峰被忽略，因此可以进行多种化合物的混合物谱图解析。

由于质谱中各种质荷比 (m/z) 值出现的几率不同，PBM 算法同时利用质量数和丰度值来确认参照谱中最显著的峰。谱图加入谱库后，这些峰用来产生用于 PBM 检索例程的压缩参照谱。

然后检索例程中的预过滤器给未知谱中每个峰赋以显著的值，用来查找压缩参照谱库中最可能的匹配。接着使用上述的反向检索将所选的压缩谱同完整的未知谱进行对比。预过滤器可以立即排除数据库中约 95% 的化合物，从而大大加快了检索速度（使用默认策略参数时）。

另见

影响匹配质量的因素

提高匹配质量


编辑 PBM 谱库

当从菜单中选择 Spectrum / Edit Library（谱图/编辑谱库）时，Edit PBM Library（编辑 PBM 谱库）框就会出现。.要执行下列任务，请选择相应的按钮：

选择谱库（缺省）

添加新项目

编辑已有项目；允许查看、修改或排除项目

创建谱库

删除谱库


定量数据分析

在定量分析中包括两个步骤：

  • 校准，在这里由校准标准的分析设定一个定量数据库。该分析用于为每个计划定量的化合物生成一条校准曲线。

  • 定量，在这里运行未知样品并生成关于样品中存在多少特定化合物的报告。

如何

就绪

创建定量数据库

查看定量数据库

保存定量数据库

全局更新定量数据库

定量未知物

定量异构体

生成定量报告

发现时间参比峰

使用 QEdit 工具编辑定量结果

定量混合模式数据

参见

校准概述

定量概述

设定全局数据库

关于目标化合物分析

目标化合物定量

校准菜单

定量菜单


就绪 - 定量

就绪

在进行目标化合物分析之前，必须：

  1. 明确要定量的化合物。

  2. 明确要使用的仪器条件（加热区温度、压力等），即设置一个 Acquisition（采集）方法。

  3. 明确对每个化合物（仅适用于 GC/MS）要使用的目标离子和特征离子（如果有的话）。

  4. 准备校准样品。

  5. 至少从上面校准样品之一的分析中获取一个数据文件，其中的仪器条件即是要用于定量分析中的条件（例如，保留时间正确）。


创建定量数据库

定量数据库包含生成定量报告所需的所有信息。

  1. 将校准数据文件加载到 Data Analysis（数据分析）（参见就绪）。自动显示 TIC（总离子流色谱）。

  2. 选择 Calibrate / Set Up Quantitation（校准/安装定量），在此菜单中定义您想应用到数据库中所有化合物的参数。如果您已经完成设定，请单击 OK（确定）。

  3. 当出现 Edit Compounds（编辑化合物）对话框时，请在化合物列表中单击您想插入化合物的位置。

    例如，若要将一个化合物与已经在列表中的内标化合物相关，单击内标化合物下面的项目。（如果您刚刚才新建数据库，列表为空，请单击 END OF COMPOUND LIST（化合物列表末尾）。）然后单击 Insert Above（插入上方）按钮。

  4. Quant Setup（定量安装）框显示在 TIC 或 EIC 的下方。对每一个您想添加到数据库的化合物，应在此对话框中选择其目标图标和特征峰图标。

  5. 当您已经完成了化合物的添加，请单击 Quant Setup（定量安装）对话框中的 Exit（退出）按钮。Edit Compounds（编辑化合物）对话框将自动显示，以备您数据库中的化合物进行查看/编辑。

  6. 退出 Edit Compounds（编辑化合物）对话框。为生成校准曲线的响应数据，选择 Calibrate / Update /Update One Level（校准/更新/更新一个浓度）。

  7. 输入化合物和内标物（如果有的话）的浓度。然后选择 Add New Level（添加新的浓度），输入 Calib Level ID（校准浓度 ID）。单击 Do Update（执行更新）。数据文件将进行定量处理。

    Edit Compounds（编辑化合物）对话框将再次自动显示，以备您查看/编辑化合物项目第 3 页的浓度/响应数据。

  8. 要向校准曲线添加浓度，您可以定量额外的校准文件，或者选择 Calibrate / Update / Quick Levels Update（校准/更新/快速级数更新），更新对话框中的信息，然后单击 Do Update（执行更新）。

  9. 将数据库保存在方法中。务必在离开 Data Analysis（数据分析）之前进行上一步操作。如果不保存，刚才往数据库输入的信息就会丢失。

现在，在这个数据库中，您就可以对包含一个或多个化合物的未知浓度的质谱数据文件进行定量了。


检查定量数据库

为了要每一次检查（或编辑）定量数据库中的一个化合物，请选择 Calibrate/ Edit Compounds（校准/编辑化合物）。

为了要每一次查看一个化合物的校准曲线，请在检查化合物项目时单击 Plot（绘图）。显示列表给出了所有校准浓度下化合物的浓度与响应，显示与内标无关化合物的相关系数、拟合曲线的类型及响应。

与内标相关的化合物，则不显示浓度与响应，而是绘制、列出浓度比、响应比。

浓度比 = 分析物浓度/内标浓度。

响应比 = 分析物响应/内标响应。


保存定量数据库

在离开 Data Analysis（数据分析）之前，保存定量数据库：

  1. 选择 Method/ Save Method（方法/保存方法）。

  2. 当前方法的名称显示在 Save Method（保存方法）对话框中。您可以：

  • 保留当前方法的名称。

  • 输入一个不同的名称。

  3. 单击 OK（确定）来保存方法（包括定量数据库）到指定文件名。

当您想离开 Data Analysis（数据分析）时，系统会提醒您保存所作的修改：

  • 如果您想保存所作的修改，请单击 Yes（是），系统会提示您输入方法名称。

  • 如果您不想保存所作的修改，请单击 No（否）。


全局更新数据库

  1. 选择 Calibrate/ Update/Global Update（校准/更新/全局更新）。这个对话框允许您对整个定量数据库的选中项进行更新，而不是每次更新一个化合物。（方法中必须存在至少一个数据库，才会出现该框）

  2. 选择与有关项目相邻的按钮，单击 OK（确定）。系统提示您输入必要的信息来进行修改。

    Shift Retention Times（改换保留时间）和 Resize Extraction Windows（重新定义提取窗口大小）影响化合物数据库的 Retention Time Information（保留时间信息）。

    Set Curve Fit（设定曲线拟合）影响 Calibration Information（校准信息）。

    Set Identification Method（设定鉴别方法）和 Set Subtraction Method（设定本底扣除方法）影响 Quantitation Parameters（定量参数）。

    Set Other (via command)（通过命令设定其他参数）显示一个对话框，可以通过命令来更新参数。参见示例 线性回归时的数据点权重。


自动定量设置 — GC/MS 指南

使用自动定量设置

AutoQuant Setup（自动定量设置）提供了一种给定量数据库创建化合物列表的半自动方法。下列指南可引导您使用 AutoQuant Setup（自动定量设置）的全部步骤。该指南使用化学工作站随附的演示文件。在该指南中使用 default.m 和 evaldemo.d 之前，请先复制一份。

  1. 在 Data Analysis（数据分析）中，加载示范方法 C:\MSDCHEM\1\METHODS\DEFAULT.M 和示范数据文件 C:\MSDCHEM\1\DATA\EVALDEMO.D。

  2. 在 Spectrum / Select Library（谱图/选择谱库）下选择 DEMO.L。

  3. 选择 Calibrate / AutoQuant Setu（校准/自动定量设置）。

  4. 出现 Quantitation Database Globals（全局定量数据库）对话框时，进行如下更改：

校准标题 — 键入 AutoQuant Tutorial

使用 RTEINT — 选中该对话框来使用 RTE 积分器（不选则使用化学工作站积分器）。

单击 OK（确定）。

  5. 出现 Dodecane（十二烷）的 Choose Compound Name（选择化合物名称）对话框时，单击 Skip（跳过)。为了示范，您可以先跳过这个化合物，以后再把它添加到数据库中。

  6. 接下来出现 Biphenyl（联苯）。保持缺省名称，单击 Add（添加）。

  7. 接着出现 4-Chlorobiphenyl（4-氯联苯）。保持缺省名称，单击 Add（添加）。

  8. 接着出现 Methyl palmitate（十六酸甲酯）。要将它指定为内标，单击 ISTD（内标）。单击 ISTD 同时把化合物添加到数据库中。

  9. 当软件提示 Quantitate now?（现在定量？）时，单击 Yes（是）。文件量化后，出现 Update Calibration（更新校准）对话框。

  10. 选择 Add New Level（添加新校准级），输入如下内容：

Calib Level ID = 50

Cmpd Conc = 50

ISTD Conc = 50

然后单击 Do Update（执行更新）。

  11. 显示 Edit Compounds（编辑化合物）对话框时，注意十六酸甲酯处于列表顶端的正确位置，在其名称旁边有一个星号说明它是内标。

  12. 单击 Exit（退出）关闭对话框，或单击 View（查看）检查第 1 页、第 2 页和第 3 页中的各化合物参数。

  13. 要了解怎样向定量数据库中插入化合物，请选择 AutoQuant Setup（自动定量设置）。

  14. 选择 Insert Compounds in Database（在数据库中插入化合物），单击 OK（确定）。

  15. 出现 Quantitation Database Globals（全局定量数据库）对话框时，不要更改参数。单击 OK（确定）。软件会再次开始鉴定峰。出现 Choose Compound Name（选择化合物名称）对话框。

  16. 对话框中出现 Dodecan（十二烷）时，保持缺省名称并单击 Add（添加）。出现 Edit Compound（编辑化合物）对话框。

  17. 选中 Biphenyl（联苯），选择一个插入点并单击 Insert Above（插入上文）。

  18. Choose Compound Names（选择化合物名称）对话框中留存的 3 个化合物已经存在定量数据库中，因此单击 Skip（跳过）。跳过这 3 个化合物后，软件将问您是否 Stop Now?（现在停止?）单击 Yes（是）。这一特点在对大量化合物进行数据库操作时非常有用。

  19. 系统问您是否希望定量数据库时，单击 Yes（是）。

  20. 出现 Update Calibration（更新校准）对话框时，选择 Recalibrate（重新校准）并对 Responses（响应）和 Retention Times（保留时间）字段选择替换。单击 Do Update（进行更新）。

  21. 出现 Edit Compounds（编辑化合物）对话框时，单击 View（查看）并检查数据库中 4 个化合物中每个化合物的第 3 页。注意您加入的 Dodecane（十二烷）没有浓度值。

  22. 在 Concentratio（浓度）字段对校准级 50 键入 50。单击 OK（确定），然后单击 Yes（是）保存更改后的数据。

  23. 单击 Exit（退出）。

另见

自动定量设置


定量未知物

在设置定量数据库和校准曲线后，您可以分析未知物：

  • 每个被定量地化合物必须有一条数据来自至少一个校准样品的校准曲线。

  • 未知物样品必须在使用校准样品的相同条件下分析。

当您将要准备一份定量结果报告时，请选择 Quantitate / Generate Report（定量/生成报告）；这会将您带到 Quant Report Options（定量报告选项）对话框。


定量异构体

异构体通常具有相同的保留时间和目标信号。无法保证未知物分析中发现的峰组与数据库中的异构体正确地匹配。总是使用 View / QEdit Quant Result（查看/定量编辑定量结果）检查峰的选择并进行必要的修改。


查找时间参比峰

许多定量分析要求在被分析化合物鉴定之前对内标峰进行鉴定，其中一些被指定为时间参比峰。如果通常定量过程未能正确鉴定出一个 ISTD 峰，下面的策略之一可能会有帮助。

  • 可以对 ISTD 和 Time Reference peaks（时间参比峰）将 Maximum number of hits（匹配最大数目）设定为 1。将 Ident by（识别对象） 选择为 Largest area/height（最大面积/峰高）。

  • 对于 Ident by（识别对象）仅使用 Largest area/height（最大面积/峰高）。

  • 如果时间参比和内标峰预期为它们各自的保留时间区域内的最显著峰，而且如果在分析中使用了 RTE 积分器，可以提供一个积分参数文件来过滤掉除最显著峰外的其他峰。当 ISTD 自身正在运行时这可以排除（由于临近小峰引起的）错误的峰形选择。

如果正在使用化学工作站积分器，要可靠的限定对一个峰的积分会更难。可以使用一个 AREAREJECT 时间事件或初始面积截除参数。

因为所讨论的定量分析常常涉及较大的数据库，推荐使用 RTE 积分器以获得最佳效果。


定量混合模式数据

当选择一个校准的定量数据库时，可能使用 MS 信号或 GC 信号定量。如果 GC 信号用于定量，选择Calibrate / Edit Compounds（校准/编辑化合物）以将定量信号改变为 GC1 或 GC2。

  1. 根据 MS 信号调整 GC 并将点保存在当前方法中。

  2. 选择Quantitate / Use Method Aligned GC Trace (GC/MS)（定量/使用 GC 曲线调整的方法）。

  3. 选择 Quantitate / Generate Report（定量/生成报告）。


校准概述

  1. 就绪。 这是校准的预备步骤，包括搜集程序信息、制备校准样品、制定并运行采集数据的方法。

  2. 设置定量数据库。选择 Calibrate / Set Up Quantitation（校准/设置定量） 按顺序调用向数据库输入数据所需的每一个对话框：

    a) Quantitation Database Globals（全局定量数据库）设定可适用于新数据库中或添加到现有数据库中的所有化合物参数。

    b) Edit Compounds（编辑化合物）显示数据库中化合物的当前顺序、查看数据库中的化合物项目，以及插入新谱库项目。

    c) Quant Setup（定量设置）用鼠标为每个化合物选择目标离子和特征离子。

    d) Update Calibration（更新校准）向校准级添加、删除或重新校准浓度/响应数据。该数据用于生成校准曲线。

您可以使用 Calibrate / Update（校准/更新）/ Global Update（全局更新）一次性对数据库中的所有项目进行选择的更改。


定量概述

一旦创建了一个定量数据库，在进行目标化合物分析中有两个步骤。

  1. 定量未知物。含有未知浓度目标化合物的样品仅当校准完成后方可被分析。

  2. 生成报告。可以使用 Custom Reports（定制报告）打印或查看一份标准报告或一种特殊格式的定量结果。


自动定量设置

AutoQuant Setup（自动定量设置）提供了一种给定量数据库创建化合物列表的半自动方法。AutoQuant Setup（自动定量设置）可在下列条件下使用：

  • 有一个包含目标化合物的库。

  • 校准标准物不含有共洗脱化合物。

选择 AutoQuant Setup（自动定量设置）后，软件会对 Total Ion Chromatogram（总离子流色谱）进行积分，然后显示一系列对话框。

前两个：

<FILENAME.M> has XX compounds（<FILENAME.M> 含有 XX 化合物）

Quantitation Database Globals（全局定量数据库）

可让您选择将找到的化合物添加到已有数据库还是创建新数据库，也可让您创建通用定量标准。

接下来对于每个积分峰，检索指定谱库并选定谱图的基峰作为目标离子。然后在下列对话框中操作：

Choose Compound Name（选择化合物名称）

Update Calibration（更新校准）

Edit Compounds（编辑化合物）


设定定量数据库共用

Data Analysis（数据分析）中的 Calibrate / Set Up Quantitation（校准/建立定量）菜单项是为创建定量数据库提供所需信息和数据的起点。使用 AutoQuant Setup（自动定量设置）功能时，也会显示该对话框。完成下列项目；

定量报告信息

校准标题

缺省乘数 ＝ 1.00000

缺省样品浓度 ＝ 1.00000

查找峰

参比窗口 ＝ 1.00000

非参比窗口 ＝ 1.00000

相关窗口 ＝ 1.00000

使用 RTEINT

新化合物信息

积分参数文件

测量

缺省值 +/-

浓度单位

ISTD 浓度

曲线拟合

线性回归数据点的权重

完成整个对话框后，单击 OK（确定）。Edit Compounds（编辑化合物）对话框自动显示。

在方法中保存这条信息（在离开“数据分析”之前）（否则，信息将会丢失）。


关于目标化合物分析

目标化合物分析可以帮助您确定样品中某化合物的含量。必须能够在存在其他可能干扰的化合物的情况下发现、鉴定并且定量测定某一特定化合物。

GC/MS 系统是进行这类分析的强大分析工具，因为每一点（扫描）的 TIC 图的色谱图同时包括了质谱信息。您可以用这些信息为每种化合物选择一个目标离子和一个或者更多的特征离子。

目标化合物分析包含三个主要部分：

鉴定目标化合物

定量目标化合物

报告结果


目标化合物的定量分析

依据第 1 页和第 3 页上 Compound Entry（化合物项目）框中输入的信息进行定量分析：

  • 校准级浓度和响应

  • 面积校正质量和因子

  • 面积/峰高选择（第 1 页）

  • 校准曲线拟合方法（第 1 页）

进行定量分析前，有两次机会调节观察到的峰响应。

  • Area Sum 选项。各特征信号可分别设置成启用或禁用 Area Sum（面积加和）。所有特征信号中，在峰组中有一个峰匹配而且被选中，启用 Area Sum（面积加和）选项，观察到的峰响应随特征峰的响应而增强。

    注意未调节的（目标）峰响应用于计算特征信号比例。此外，Area Sum（面积加和）仅在选择的 Subtraction Method（扣除方法）为 Extended Area Quant（扩展面积定量）时有效。最后，建议对选择了 Quant by Height（根据峰高定量）选项的目标化合物项目不要使用 Area Sum（面积加和）。

  • Area Correction.与 Area Sum（面积加和）类似，该选项仅在选择的 Subtraction Method（扣除方法）为 Extended Area Quant（扩展面积定量）时有效。在讨论信号提取时已经说明，如果已指定该化合物的 Area Correction m/z（面积校正 m/z），则在范围 R 内提取 EIC。这是 EIC 的应用之处。

如果 EIC 中出现峰，将其响应值乘以 Area Correction Factor（面积校正因子），将一个非负值存储在目标化合物项目中。乘以校正因子的信号将从目标峰响应中扣除。如果该差值非负，则将其作为新的目标峰响应。否则目标峰响应为 0！和 Area Sum（面积加和）一样, 未调节的目标峰响应用于合格比的计算。

现在对所有被认为与各自的非内标目标化合物项匹配的峰组进行定量分析。最终报告给用户的目标化合物项目浓度是目标化合物项的 Best Match（最佳匹配）项浓度，但是所有匹配的浓度均会被保存。如果目标化合物没有匹配，则不计算浓度，就会告诉用户目标化合物 "not found"。下面的讨论仅适于至少有一项匹配的目标化合物。

如果化合物标注为“内标”，则不对其进行定量分析。认为其确定的“浓度”是该内标物的标识浓度（称为 Sample ISTD Concentration（样品内标浓度））。

如果 Target Compound（目标化合物）与 Internal Standard（内标）不相关（如 Edit Compounds（编辑化合物）列表所示), 则仅参考 Target Compound（目标化合物）的校准表。校准表中包含 0 个或更多从校准标准浓度到对应的标识峰响应的映象。这些映象称为 Calibration Level（校准级）。

考虑到笛卡儿数据点，对该目标化合物定义了所有的浓度（即标准浓度为 0 或更高）。从五种算法中应用专用于该化合物的曲线拟合方法。

如果得不到有效方程，则确定的 Concentration（浓度）为 0。否则，如果曲线上存在峰响应组分与观察到的目标化合物峰响应相等的点（对于斜率非 0 的线性校准曲线一定存在这样的一个点，但是对于非线性校准曲线不一定存在），则检测对应浓度的组分。

注意对非线性曲线来说，在曲线上可能有几个这样的点！如果没有正浓度的组分，则确定的浓度为 0。否则，确定的浓度是所发现的点中最小的正浓度组分。

如果目标化合物 i 与“内标”相关，则在校准表中同时检索目标化合物和相关的“内标”化合物。生成笛卡儿数据点集合，使第一组分等于目标化合物和 Internal Standard（内标）化合物的标准浓度比值，第二组分等于目标化合物和 Internal Standard（内标）化合物对应标识峰响应的比值。

注意该数据集合仅包括目标化合物和 Internal Standard（内标）化合物中均已定义的 Level（级数），而且 Internal Standard（内标）化合物的级浓度与响应均不为 0。

按照上述方法对该数据点集合进行曲线拟合，以找到“确定的浓度比”而不是确定的浓度。非内标相关的目标化合物情况下（确定浓度必须为零）的所有特殊条件也适用于此处。对于归一化情况，“确定的浓度比”应乘以相关 Internal Standard（内标）的 Sample ISTD Concentration（样品内标浓度）值。得到与内标相关的目标化合物的确定浓度。


比较未知样谱图与谱库谱图

Parametric Retrieval（参数检索）软件允许您从谱库中检索谱图，并与您从数据文件中选择的谱图进行比较。使用这一功能来确认样品中已知组分的特性，或者帮助您鉴定样品中的未知组分。

  1. 调用您感兴趣的数据文件。

  2. 如在谱库中检索化合物所述，使用适宜的标准如 CAS 号或离子检索，从谱库中检索谱图。

  • 在 Search Parameters（检索参数）对话框中选择 CAS 号字段，然后键入未知样谱图中您感兴趣组分的 CAS 号。您能键入带有破折号或没有破折号的 CAS 号。对其他任何参数不进行选择。

  • 在 Search Parameters（检索参数）对话框中的 Ion Search（离子检索）域中最多选择三个离子，并选择紧接每一个离子的相对丰度范围。由于在参比谱库中，离子检索使用压缩谱图，请您不要用普通离子如 质荷比 28 和质荷比 43 进行检索，因为它们没有包含在压缩谱图中，因此在谱库中找不到这些离子。对其他任何参数不进行选择。

  • 如果怀疑在谱图中出现分子离子，也可以输入分子量范围。若使用分子量作为检索参数，请一定要选中与 Mol. Weight（分子量）字段毗邻的复选框（X 出现在框中）且指定分子量的范围。

  3. 在 Search Parameters（检索参数）对话框中单击 Search（检索）按钮，初始化谱库检索。若已经检索了指定的检索匹配项数目或已经对整个谱库进行了检索，Parametric Retrieval Results（参数检索结果）对话框就会出现。在列表中选中感兴趣的化合物。

  4. 选择 View / TIC and Library Entry（查看/ TIC 和谱库项目），在谱库谱图上显示总离子流色谱。

  5. 在 TIC 的目标扫描图形上双击鼠标右键，选择谱图。未知样谱图将显示在谱库谱图的上方。

  6. 从视图上比较两个谱图。

  7. 若要查看两个谱图的差分谱图，请选择 Spectrum / Normalized Subtract（谱图/归一化扣除）。从未知样谱图中扣除谱库谱图的结果显示在谱库谱图的下方。您能够通过鼠标右键双击显示窗口的任何位置来检索差分谱图。

  8. 若要重新显示总离子流色谱，请选择 View / TIC and Library Entry（查看/ TIC 和谱库项目）。

  9. 对每一个数据文件中您想与谱库谱图进行比较的谱图，重复第 5 - 8 步。

  10. 若要选择另外的谱库谱图，在 Parametric Retrieval Results（参数检索结果）对话框中单击另一化合物。如果是当前显示谱图，谱库谱图和差分谱图将自动进行更新。

  11. 在 Parametric Retrieval Results（参数检索结果）对话框中单击 Search Next（检索下一个） 按钮，从谱库中检索下一组匹配化合物。当整个谱库检索完毕时，Search Next（检索下一个）按钮呈灰暗色。

  12. 如果检索完毕，请在 Parametric Retrieval Results（参数检索结果）对话框中单击 Close（关闭）按钮。

  13. 若要在谱库中查找其他离子或 CAS 号，请选择 Retrieve / Set Parameters（检索/设定参数）并重复 2 — 12 步。


创建子集谱库 (PR)

  1. 在 Parametric Retrieval（参数检索）窗口选择 Library / Subset Library（谱库/子集谱库）。出现 Search Parameters（检索参数）面板。

  2. 输入您想添加到一个新的或已经存在的谱库项参数。然后单击 Search（检索）按钮。

  3. 显示 Edit PBM Library（编辑 PBM 谱库）的对话框，提示您选择 Create Library（创建谱库）或 Append to Library（添加到谱库）。如果您选择 Create Library（创建谱库），系统提示您为谱库命名。如果您选择 Append to Library（添加到谱库），请在已经存在的谱库列表中选择一个谱库。

通过参数检索选定的项目将添加新的谱库或一个已经存在的谱库。


在谱库中寻找化合物

使用下面的程序寻找根据不同的性质包含在一个光谱库中的化合物。检索类型也称作参数检索。

  1. 在 Data Analysis（数据分析）窗口选择 Lib / Parametric Retrieval（谱库/参数检索）。Search Parameters（检索参数）框将会出现，菜单栏改变。

  2. 在显示检索结果之前，输入希望系统找到的命中数。如果整个光谱在指定检索数前没找到，系统允许继续检索（请参见步骤 8）。一次总共可以检索 100 个命中项。

  3. 选择检索中使用的标准（在复选框内加入 X），然后指定参数的值或值的范围。总之，指定的标准越多，检索到的化合物越少。如果没有指定参数，要检索整个谱库。

  4. 单击 Search（检索）按钮开始检索。当步骤 3 中指定的命中项的数目被检索到或整个谱库被查找时，Parametric Retrieval Results（参数检索结果）框会出现。

    如果选择了结构库而且结构库中包含当前的参比化合物（如上例所示）的项目时，就显示出参比化合物的化学结构来。

  5. 查看其他信息，单击列表中的化合物查看这个化合物的信息。单击 Text（文本）按钮查看当前命中化合物的标题信息。

  6. 单击 Print（打印）按钮开始打印检索到的结果。

  7. 单击 Parametric Retrieval Results（参数检索结果）对话框中的 Search Next（检索下一个）按钮，从谱库中检索下一组匹配的化合物。

  8. 重复步骤 8 直至检索到所有结果为止。当整个谱库被使用当前参数检索过，Search Next（检索下一个）按钮为灰色。

  9. 单击 Close（关闭）按钮退出 Parametric Retrieval Results（参数检索结果）对话框。


查看检索结果

  1. 单击 Search Parameters（检索参数）面板中的 Search（检索）按钮，或如果未显示该面板，请选择 Retrieve / Continue Results（检索/继续结果）。

  2. 出现 Parametric Retrieval Results（参数检索结果）面板出现时，从面板下部匹配列表中一次选择每个匹配。显示每项匹配的 CAS 号、分子量 (MW)、分子式 (MF)、项目号和谱库谱图。

  3. 有关更多文本信息，请单击 Text（文本）按钮。

  4. 欲检索并显示下一组命中物，单击 Search Next（检索下一个）按钮。（或选择 Retrieve / Continue Results（检索/继续结果）。）

  5. 要关闭 Parametric Retrieval Results（参数检索结果）面板，请单击 Close（关闭）按钮。


仅查看谱库项目

有三种方式可以仅查看参数检索谱库项目：

  • 在检索结束时显示 Parametric Retrieval Results（参数检索结果），还自动显示谱库项目。

  • 当显示多于一个项目时，选择 View / Library Entry Only（查看/仅谱库项目）。

  • 扩大包含谱库项目的窗口。


查看 TIC 和谱库项目

  • 选择 File/Load（文件/加载）。在窗口的上部将显示 TIC，谱库光谱在下面。

  • 相反，如果数据文件已被加载并且选择了不包含 TIC 的视窗，选择 View（查看） / TIC and Library Entry（TIC 和谱库项目）。


查看未知光谱和谱库项目

  1. 选择 File/Load（文件/加载）。在窗口的上部将显示 TIC，谱库光谱在下面。

  2. 在 TIC 峰上双击鼠标右键选择一个要显示的光谱。在窗口的上部将显示未知光谱，谱库光谱在下面。

相反，如果切换到了下一个窗口，然后想返回未知光谱和谱库项目显示面板，选择 View / Unknown and Library Entry（查看/未知光谱和谱库项目）。


查看未知光谱、谱库项目和差值光谱

  1. 选择 File/Load（文件/加载）。在窗口的上部将显示 TIC，谱库光谱在下面。

  2. 双击峰选择要显示的光谱。在窗口的上部将显示未知光谱，在下面显示谱库光谱。

  3. 选择 Spectrum / Normalized Subtract（光谱/归一化扣除）。谱库项目将从未知光谱中扣除，所得差值显示在窗口下部。注意在结果列表中，每个谱库项目和每个新未知光谱将循环进行扣除。

如果切换到下一个视窗，然后想返回此选项查看三个谱图，请选择 View / Unknown，Library Entry，and Difference（查看/未知、谱库项目和差值光谱）。


使用化学结构

通过 Data Analysis - Parametric Retrieval View（数据分析 — 参数检索查看）中的 Structures（结构）菜单并通过在 PBM 或参数检索检索后执行鼠标/键盘操作，可以访问化学结构软件。通过 Structures（结构）面板上的 Help（帮助）按钮可以访问该软件的联机帮助部分。结构软件将 MS 化学工作站的功能扩展至执行下列任务：

  • 显示谱库检索和参数检索结果的结构

  • 在质谱绘制窗口中绘制结构

  • 加载结构文件

  • 在质谱窗口中绘制剪贴板图元文件。

  • 创建个人结构谱库

  • 检索多个结构谱库数据库

对于上述多种任务，也可以使用命令。

要显示随同谱库检索结果的结构，您需要购买并安装化学结构谱库。同样，您可以使用 Molecular Design（或其他生成 Mol 文件的程序）中的 ISIS Draw* 软件绘制结构，并创建自己的谱库。MS 化学工作站软件随附有一个具有 16 个结构的示范谱库。

* Molecular Design Limited, 2132 Farallon Drive, San Leandro, CA 94577, 是一个生产集成科学信息系统的公司，其产品包括商标为 ISIS 的软件，用户可以用该软件绘制化学结构。ISIS Draw 可以生成描述化学结构关系表的 ASCII 文本文件。此类文件称作 “Mol 文件”。


参数检索模式菜单

Parametric Retrieval Mode（参数检索模式）让您从光谱谱库中检查光谱并把这些光谱在多方面使用。

File（文件）

Spectrum（光谱）

Library（谱库）

Retrieve（检索）

Structures（结构）

Options（选项）

View（查看）


参数检索参数

说明所查找的谱库化合物

谱库

检索命中项数

检索参数

检索匹配所有指定参数的项目

单击 Search（检索）按钮。显示 Parametric Retrieval Results（参数检索结果）面板来查看结果。

查找这个面板

当您从标准 Data Analysis（数据分析）菜单栏中选择 Lib / Parametric Retrieval（谱库/参数检索）时，Data Analysis - Parametric Retrieval Mode（数据分析 — 参数检索模式）窗口中的 Search Parameters（检索参数）面板会自动打开。也可以通过在 Parametric Retrieval Mode（参数检索模式）窗口中的菜单选择 Retrieve / Set Parameters（检索/设定参数）来实现。

关闭参数面板

单击 Cancel（取消）。Parametric Retrieval Mode（参数检索模式）窗口中的菜单被激活。

重新打开面板

从菜单中选择 Retrieve / Set Parameters（检索/设定参数）。


谱库检索参数

在每个峰的检索中最多可使用三个谱库。第二个谱库仅当没有命中质量等于或大于为第一个谱库输入的值（在 Search Next Library（检索下一个谱库）栏中）的匹配时使用。第三个谱库仅当第二个谱库的匹配标准也未满足时使用。

欲显示谱库列表从中选择谱库，请在 Library Name（谱库名称）栏中键入 ?。

在此处选择的谱库不影响选择进行编辑的谱库。


设定检索策略

Search Strategy（检索策略）对话框中的参数已经过仔细选择，以便得到在大多数情况下的最佳检索结果。建议使用的缺省值为：

U + A = 2

Tilting（倾斜） = on

Flag Thrshold（标识阈） = 3

Cross-correlation sort（交叉相关排列） = off

Minimum Estimated Purity（最小估计纯度） = 50%

下列参数均不对检索本身或检索速度产生影响。它们均在检索完成后从结果列表中剪除项目。

Low report MW（最低报告分子量） = 0

High report MW（最高报告分子量） = 9999

Max hits（最大命中项） = 20

Remove duplicate CAS numbers（删除重复的 CAS 号） = off

在调整这些参数前，您必须非常熟悉 PBM 检索过程。

U+A

控制 PBM 预过滤确定哪个光谱可以从谱库中重新找到并可以被检索算法检测的一个参数。

U + A 的值的范围为 1 到 9，这里 1 代表最快检索，9 是迫使算法检索整个数据库（即不使用预过滤）。缺省值为 2。

将参数值设定为 1 将会加快检索但是如果未知光谱与参比光谱不同，会增大漏掉正确结果的可能性。将 U + A 的值改为 3 可能对于在参比和未知光谱由于仪器或仪器条件的不同而不同时允许算法重新检索是必需的。

倾斜

打开倾斜时，检索尽量通过选定坐标参比光谱适应未知光谱来提高匹配的可信度。想这样做，首先检索在参比光谱上完成正常的不合适的比较算法，然后将参比光谱使用二次函数选定坐标并用比较算法对其进行重新检测。二次函数由参比和未知光谱间的最佳拟合决定。

缺省值为打开。这可以帮助数据库从大的 NIST 和 Wiley 质谱数据库中重新检索。当检索用户创建的数据库时，可以接受的结果可能在“倾斜”关闭时获得。

标识阈

当每个参比光谱的重要的峰与未知光谱中对应的离子质量进行比较时，一些离子质量如果在未知光谱中相对丰度较低的话，可能被不正确的标识。标识阈设定一个丰度阈，低于此丰度阈的标识是不应该发生的。

例如，数值 3 意味着相对丰度小于 3％ 的任何离子均不被标识为不匹配。如果数据采集阈被设定的足够高以排除相对强度小于 5％ 的离子，则建议将“标识阈”调整到 5％。

范围为 0-99％：缺省值为 3。

标识阈可以用来调整 PBM 对相对丰度较低的离子的灵敏度。PBM 算法对低强度的离子非常灵敏并且在几个低强度离子在未知光谱中漏掉或出现在不正确的强度比时可能得不到正确的匹配。

交叉相关排列

打开交叉相关排列开时，由 PBM 检索的最可能的命中物被正向检索算法评价并且生成一个交叉相关排列。此系数用于确定在命中物列表中出现的顺序。

前检索算法要求未知光谱中所有重要的离子应该出现在参比光谱中。

初始值为关闭，这样将引起结果按 PBM 匹配质量排列。

最小估计纯度

未知光谱的纯度通过比较谱库光谱的基峰与相应的未知峰来计算的。对于检索中考虑的参比光谱，未知峰必需具有等于或大于指定纯度的丰度。

范围为 20-80％：缺省值为 50％。

“最小估计纯度”(MEP) 参数在预过滤已经从谱库中重新找到参比光谱以后而在实际检索进行之前应用。这个光谱要求参比光谱中的基峰以用户指定的百分比在未知光谱中来发现。

例如，在当前参比中基峰（m/z 和 100% 相对丰度）为m/z 224 并且 MEP 设定为 50%, 则 MEP 检测将在未知光谱中迅速检测m/z 224。如果m/z 224 在未知光谱中的丰度大于 50% 相对强度，将进行实际的 PBM 检索比较；否则，参比光谱被取消并对下一个参比光谱进行检测。

对于大多数 GC/MS 分析，缺省值为 50％ 的 MEP 成功的消除了错误并仍然保持 PBM 可以在多组分混合物的光谱中重新找到一个或多个组分的能力。

将 MEP 设定为 80 将会加速数据库检索但如果未知光谱与参比光谱相比有重要不同时也可能漏掉正确结果。

最低报告分子量

输入的数字设定分子量阈。任何分子量低于输入值的检索结果将会从结果列表中删除并不予报告。

有效范围为 0 到 9999。缺省为 0。

最低报告分子量是报告分子量的最小值，而最高报告分子量是报告分子量的最大值。（如果最低与最高相同，仅报告有此分子量的化合物。如果最低大于最高，就没有报告结果。)

最高报告分子量

这里输入的数字设定一个限制。任何分子量高于输入值的将结果将被从结果列表中删除并不予报告。

有效范围为 0 到 9999。缺省为 9999。

最大命中项

一次检索正常情况下返回共 20 个命中物。改变这个数字将改变报告的命中数。检索和检索速度不受影响。最大命中数只影响在报告的命中数中排除的数目。

有效范围为 1 到 20。缺省为 20。

删除复制的 CAS 号

当选择此复选框时，仅报告特定化合物（由其 CAS 号标识）的最佳匹配。低匹配率的复制匹配将从结果列表中删除并不被报告。由于删除重复项是根据 CAS 号进行，没有 CAS 号的谱库项即使为相同的化合物也不删除。


参数检索结果

在此面板中可查看每项检索结果，每次查看一个匹配项。每个匹配项的 CAS 号、分子量 (MW)、分子式 (MF)、项目号和化合物名称和质谱一起显示。如果化合物名称超出了它的字段中的行数，将出现一个滚动条。

匹配项列表中的命中数目不会超过在 Parametric Retrieval Parameters（参数检索参数）面板中指定的数值。如果大于 5 个命中项，将出现一个滚动条。

Search Next（检索下一个）按钮在谱库中检索下一个命中物的匹配。

Text（文本）按钮允许查看所有同谱库项目有关的信息 — 其他信息、熔点、沸点、保留指数、公司 ID。如果熔点或沸点无效，则显示值 -300。

Print（打印）按钮给出打印报告的选项，包括 Current Entry Text Only（仅当前项目文本）、Current Entry Graphics and Text（当前项目文本和图形）、All Entries Text Only（仅所有项目文本）和 All Entries Graphics and Text（所有项目文本和图形），使用您选择的文本结果显示。

Close（关闭）按钮关闭此面板。


关于归一化扣除

归一化扣除的算法是：

差值 = 未知 -（丰度比 * 谱库丰度）

其中

  • 差值 = 峰 A （给出的任何峰）的差值谱中所示

  • 未知 = 未知样中峰 A 的丰度

  • 丰度比 = 谱库标准谱基峰在未知样中的丰度/标准谱基峰在标准谱中的丰度

  • 谱库丰度 = 峰 A 在谱库中登录的丰度

  • 基峰 = 谱图中丰度最大的峰

以下示例说明归一化如何进行，将谱库标准谱中的下面两个离子相减将得到如下结果：

峰的丰度： | 谱库中基峰 m/z 54 | 峰 A m/z 157
未知 | 5000 | 20000
谱库项目 | 10000 | 2000
固定扣除 | -5000 | 18000
归一化扣除 | 0 | 19000

以 m/z 54 的峰为目标峰：

固定扣除后：

差值 = 谱库基峰在未知样中的丰度 - 谱库标准谱的基峰丰度

差值谱显示 m/z 54 的峰的丰度为负值

差值 = 5000 - 10000 = -5000

归一化扣除后：

差值 = 未知 -（丰度比 * 谱库丰度）

差值谱显示 m/z 54 的峰的丰度为零

差值 = 5000 - [(5000 / 10000) * 10000]

以 m/z 157 的峰为目标峰：

固定扣除后：

差值 = 峰 A 在未知样中的丰度 - 峰 A 在谱库中登录的丰度

差值谱显示 m/z 157 的峰的丰度为 18000。

差值 = 20000 - 2000

归一化扣除后：

差值 = 未知 -（丰度比 * 谱库丰度）

差值谱显示 m/z 157 的峰的丰度为 19000。

差值 = 20000 - [(5000 / 10000) * 2000]

此例表明在进行固定扣除时，过多的 m/z 157 的峰如何被扣除。通过使未知样归一化为标准谱，可按比例扣除 m/z 157 的峰。

有时候未知样峰并非只来源于标准谱的基峰。这时，可以使用其他离子在从未知样中扣除标准谱前对标准谱进行归一化。

另见

选择归一化离子


参数检索模式中的谱库选择

关于谱库选择

在 Parametric Retrieval Mode（参数检索模式）中，可作出三种不同的谱库选择：

  • Parametric Retrieval Library（参数检索谱库）用于进行参数检索时。在选择 Retrieve / Select Library（检索/选择谱库）时出现的 Parametric Retrieval Library（参数检索谱库）中选择该谱库。当 Search Parameters（检索参数）对话框出现时也可更改该谱库。

  • PBM Search Library（PBM 检索谱库）（或一个最多三个谱库的列表）用于进行 PBM 检索时。选择 Library / Select Library（谱库/选择谱库）更改 PBM 谱库的列表。

  • Edit Library（编辑谱库）缺省用于编辑谱库时。有四种方式选择该谱库：

  1. 选择 Library / Edit Library（谱库/编辑谱库）并选择一个新库。

  2. 选择 Library / Read JCAMP File（谱库/读取 JCAMP 文件）。指定作为转化目的地的谱库将成为当前编辑谱库。

  3. 选择 Library / Subset Library（谱库/子集谱库）。放入子集的谱库将成为当前编辑谱库。

  4. 选择 Library / Add Current Entry（谱库/添加当前项目）。如果当前编辑谱库不存在，会要求您选择一个谱库。否则，将自动使用当前编辑谱库。


改变结构绘制属性

光标位于结构图内时，双击鼠标左键。该操作会显示Chemical Structure Options（化学结构选项）对话框，可在其中改变结构图的各种属性：

Text （文本）选项

Display （显示）选项

该对话框让您自定义任意或以后所有化学结构的格式。如果您是通过双击鼠标左键进入此对话框的，那么所作的修改只应用到该结构中。

如果您是通过 CSDRAWOPTS 命令进入此对话框的，并且没有选定结构对象的参数，则以后所有结构都具有所列的设定。


创建您个人的结构库

  1. 鼠标位于结构图上时，双击鼠标左键选定该结构。这一操作会显示 Chemical Structure Options（化学结构选项）对话框。

  2. 单击 Add（添加）按钮。对话框提示输入 ID 号、结构名和用户结构库名。

    在每个结构库中，每个结构的 ID 必须是唯一的（因此通常使用 CAS 号）。ID 号必须以数字开头。如果您指定的 ID 在给定的数据库中已经存在，系统会问您是否要覆盖已有的项目。注意覆盖像正常添加一样把给定的结构附加到结构库的末端，但会覆盖该 ID 号的索引文件。这意味着原有的结构仍在结构库中，但没有索引附注，只能通过登记号进行访问。

  3. 输入您的结构库名。文件后缀为 .sdb。如果所选择的数据库存在，则附加该结构，否则将创建一个新的数据库。

  4. 单击 Add Structure to Library（向结构库中添加结构）按钮。如果选定的文件不存在但存在该目录，则创建一个新的结构库。

请注意尽管可任意选择配置好的数据库，但不能向标准库中（如 molstruct.sdb 和 subset.sdb）添加结构。


在质谱窗口内绘制剪贴板图元文件

  1. 将结构复制到剪贴板（例如从绘图程序中复制）。

  2. 用 Shift + 鼠标右键单击、拖动等一系列操作来定义图元文件的绘制区域。确保在整个操作过程中始终按住 Shift 键（例如，鼠标右键应比 Shift 键先松开）。

要移动图元文件或调整图元文件的大小，请重复以上操作。


在质谱窗口内绘制结构

  1. 对谱图进行谱库检索，选择一个合适的命中对象。

  2. 用鼠标右键单击、拖动序列来定义结构绘制区域。要移动结构或重新调整结构大小，请重复以上操作。

另见

改变结构图属性


显示从结构谱库检索到的结构

一旦加载化学结构软件包后，如果这些结构包含在先前指定的结构库中，谱库检索就会自动显示各种命中的结构。

如果没有结构显示, 用 CSLIBS 命令检查结构库列表。您可在 Parametric Retrieval（参数检索）窗口的菜单中选择 Structures / Select Structure Database（结构/选择结构数据库）。


调用 Mol 结构文件

  1. 用 Ctrl + 鼠标右键单击、拖动系列操作来定义结构的绘制区域。确保在整个操作过程中始终按住 Ctrl 键（例如，鼠标右键应比 Ctrl 键先松开）。

  2. 在弹出的 file selection（文件选择）对话框中选择一个 Mol 文件。结构将显示在光谱中。

要移动结构或重新调整结构大小，请重复以上操作。

注意包含芳香环的 Mol 文件将芳香键显示为定位双键。当这些文件添加到用户结构库中时，双键保留。在理想的化学结构数据库中，芳香键的表示为芳环内加一个圈。


检索多个结构库

如果已经在 Chemical Structure Databases（化学结构数据库）对话框中配置了多个结构数据库的文件名，则可以进行多个结构库的检索。


化学结构命令和函数

安装 Chemical Structures（化学结构）选项后，下列命令和函数可用于 Data Analysis（数据分析）的命令行中。

CREATEWINDOW（结构对象，窗口名，xlow:xhigh，ylow:yhigh）

CSADDSTRUCT“数据库文件名”，结构对象[，结构名[，“结构标题”]]

CSATTACH 结构对象，ms 对象，xlow:xhigh，ylow:yhigh

CSCOPY 结构对象

CSCOPY 结构窗口对象

CSCOPY 结构名

CSCOPY“cas 数字字符串”

CSCREATE（结构名，“数据库文件名”）

CSCREATE（“cas 数字字符串”，“数据库文件名”）

CSDRAWOPTS [结构对象]

CSEXISTS（结构名，“数据库文件名”）

CSEXISTS（“cas 数字字符串”，“数据库文件名”）

CSLIBS

CSMFATTACH 图元文件对象，ms 对象，xlow:xhigh，ylow:yhigh

CSMFATTACH 图元文件对象，gcms 对象，xlow:xhigh，ylow:yhigh

CSMFCREATE ( )

CSMOLCREATE（“mol 文件名”）

CSSUBSET “结构名列表文本文件”，“源结构数据库文件名”

GETWINDOWTEXT$（结构窗口对象）

SETWINDOWLOC 结构窗口对象，x，y

SETWINDOWLOC“窗口标题”, x, y

SETWINDOWTEXT 结构窗口对象，“窗口文本字符串”

SHOWWINDOW 结构窗口对象，显示模式


化学结构数据库

该对话框可以通过选择 Parametric Retrieval（参数检索）窗口中的 Structures / Select Structure Database（结构/选择结构数据库）进入。您也可从 Data Analysis（数据分析）中的 CSLIBS 命令进入。

该对话框用于配置由不同结构命令进行检索的结构数据库。结构数据库中列出的次序也是检索的次序。

改变次序

或是选中希望成为首选的项目，然后单击 Move to Top（移到顶部）按钮，或是双击该项。

向数据库中添加结构库

请单击 Add New File（添加新文件） 按钮，然后从列表框中选择 .sdb 文件。注意这些文件通常保存在 c:\database\*.l 目录下。


化学结构选项

当光标落在一个结构图上时，双击鼠标左键选择该结构可进入本对话框。Chemical Structure Options（化学结构选项）对话框能执行两项任务：

  • Change Attributes of Structure Drawings（改变结构图属性） — 定制任意或以后所有的化学结构图版面。

  • Create Your Own Libraries of Structures（建立您个人的结构谱库）


保留时间锁定

保留时间锁定概述

保留时间是色谱中一种基本的定性测定方法。大多数峰的鉴定是通过比较未知样峰与标准样峰的保留时间来进行的。如果每一个分析物都没有保留时间的偏差，则鉴定各峰、证实方法正确都要容易得多。

然而，保留时间经常发生漂移。日常维护程序如色谱柱的修整，将会改变保留时间。] 在一个拥有多台仪器的实验室运行相同的方法，各个仪器的保留时间会有差异，即使是在完全相同的标识条件下，也是如此。保留时间存在的差别表明每一个仪器必须有它自己的校准、积分事件表，要将处理方法从一个仪器移到另一个仪器上将很费时。保留时间存在的差别还使得仪器间随时间的数据的比较变得更加困难。

保留时间锁定 (RTL) 能让有相同标识色谱柱的两个系统进行很好的保留时间匹配。通过调整进样口压力，给定系统的保留时间能够与另一个系统的保留时间匹配得很好。RTL 正是基于以上原理。RTL 过程就是要确定进样口压力需作的调节，以便获得最佳保留时间的匹配。

为建立和保持锁定方法，RTL 应在出现以下情况时进行：

  • 更换了色谱柱或色谱柱进行了修整

  • 方法载入到新的仪器上

  • 使用不同出口压力检测器

  • 系统性能生效

  • 色谱的故障排除

如果是首次锁定某方法，或者因为以下原因，您应该首先建立保留时间 — 压力 (RT - P) 的校准曲线。即使是使用具有相同部件号（id 、固定相种类、两相比、标识长度均相同）的色谱柱，在以下情况下也应该采用独立或不同的锁定校准曲线。

  • 系统采用不同的色谱柱出口压力（MSD/真空，FID/大气压，AED/加压）

  • 色谱柱长度与标识长度相差超过 15%（如，由于修整的原因）

  • 系统的预测锁定压力落在当前校准范围之外

必须指定一个溶液（通常是在正常方法校准标准中找到的），然后用它来建立校准曲线，锁定将来的所有系统。该溶液或目标溶液的色谱峰，应该易于鉴定、对称、并且应当在色谱的最严格的条件下洗脱。应避免采用极性很大或易于降解的溶液。

一旦已经选择好目标溶液，设定了方法的所有其他参数，就可以进行五次校准实验了。五次实验的操作条件与标识方法的操作条件相同，只是其中 4 次实验是在不同压力下进行的。使用的典型压力为：

  • 目标压力 - 20%

  • 目标压力 - 10%

  • 目标压力（标识方法压力）

  • 目标压力 +10%

  • 目标压力 +20%

确定每一次实验时目标化合物的保留时间。化学工作站软件将生成五次实验的进样口压力和相应保留时间及 RTL 校准曲线。

此校准曲线仅需生成一次。不管仪器的位置如何，在相同仪器设定下运行方法时，接下来使用此方法的用户都能够使用该校准曲线。

另见

锁定 MS 处理方法

锁定 GC 处理方法

RTLock 设置视窗


锁定 MS 方法

  1. 从 Instrument Control（仪器控制），加载想要锁定的方法。如果需要，编辑方法参数。

  2. 对于 ALS 进样，将瓶放在位置 1。

  3. 选择 Instrument / Acquire RTLock Calibration Data（仪器/采集 RT 锁定校准数据）。这开始 RTL 校准文件的收集。

    对校准范围 -20％、-10％、+10％ 和 +20％ 自动进行 5 个正常压力下的评价。并提示您 5 次测试，如果前面的校准数据存在，也会提示您注意。5 个数据文件将被存储在方法目录中的名为 RTLOCK 的文件夹下，文件名为 RTLOCK1-RTLOCK5。

  4. 在数据收集之后，将开始 Data Analysis（数据分析）的一个新的过程并且加载正常运行 (RTLOCK3.D)。选择用于 RTL 校准计算的峰（单击并拖动鼠标右键）。

  5. 显示出所选择峰的光谱。单击 Yes（是）使软件自动将锁定化合物峰置于其余 4 个运行中。软件将进行光谱比较和曲线拟合。显示5 个选择的峰。

  6. 显示曲线方程（基于保留时间对压力值），询问您是否继续操作。单击 Yes（是）。

  7. 接下来，输入要使用的锁定保留时间并单击 OK（确定）。

  8. 单击 Yes（是）将锁定压力信息保存到方法中。输入要使用的锁定化合物的名称并单击 OK（确定）。

  9. 现在提供可以删除校准数据文件（RTLOCK1.D-RTLOCK5.D）的选项。选择 Yes（是）或 No（否）。方法现在被锁定。

当一个锁定的方法加载到 Instrument Control（仪器控制）时，标题栏会显示该方法被锁定，并指出用于锁定的化合物。压力（仅适用于联机仪器）设定为被锁定压力。如果从 Instrument Control（仪器控制）中一个新名称保存方法，将会询问锁定状态在新方法中是否保留。

注意 运行一个锁定的方法时，压力被存储为锁定压力值，即使使用 GC 键区或从 Instrument Control（仪器控制）中改变也不起作用。

另见

锁定 GC 方法

保留时间锁定菜单

结果筛选器


锁定 GC 方法

  1. 从 Instrument Control（仪器控制）中加载想锁定的方法。如果需要，编辑方法参数。

  2. 对于 ALS 进样，将瓶放在位置 1。

  3. 选择 Instrument / Acquire RTLock Calibration Data（仪器/采集 RT 锁定校准数据）。这开始 RTL 校准文件的收集。

    对校准范围 -20％、-10％、+10％ 和 +20％ 自动进行 5 个正常压力下的评价。并提示您 5 次测试，如果前面的校准数据存在，也会提示您注意。前面的校准可以清除掉或停止进行校准。5 个数据文件将存储在方法目录中的名为 RTLOCK 的文件夹中，文件名为 RTLOCK1-RTLOCK5。

  4. 在数据收集之后，将开始 Data Analysis（数据分析）的一个新的过程并且加载全部 5 个运行的结果。在第一个运行 (RTLOCK1.D) 中，选择用于 RTL 校准计算的峰（单击并拖动鼠标右键）。为其余 4 个运行 (RTLOCK2.D - RTLOCK5.D) 重复此步骤。

  5. 显示 5 个选择的峰。显示曲线方程（基于保留时间对压力值），询问您是否继续操作。选择 Yes（是）。

  6. 输入要使用的锁定保留时间并单击 OK（确定）。

  7. 单击 Yes（是）将锁定压力信息保存到方法中。

  8. 输入要使用的锁定化合物的名称并单击 OK（确定）。方法现在被锁定。

当一个锁定的方法加载到 Instrument Control（仪器控制）时，标题栏会显示该方法被锁定，并指出用于锁定的化合物。压力（仅适用于在线仪器）设定为被锁定压力。如果从 Instrument Control（仪器控制）中一个新名称保存方法，将会询问锁定状态在新方法中是否保留。

注意 运行一个锁定的方法时，压力被存储为锁定压力值，即使使用 GC 键区或从 Instrument Control（仪器控制）中改变它，也不起作用。

另见

锁定 MS 方法

保留时间锁定菜单

结果筛选器


重新锁定一个方法

在下列情况下您可能需要重新锁定方法：

  • 色谱柱被更换或被清理

  • 方法被安装到一个新仪器上

  • 使用一个出口压力不同的检测器

  • 验证了系统性能

  • 排除色谱故障

  1. 从 Instrument Control（仪器控制），使用锁定方法运行包含锁定化合物的样品。

  2. 检查锁定化合物的保留时间。如果洗脱化合物的保留时间正确，不需进行进一步操作。如果洗脱化合物的保留时间不正确，进入步骤 3。

  3. 从 Data Analysis（数据分析），选择 RTLock Setup（RT 锁定设定）。

  4. 选择 RTLock / Relock Method（RT 锁定/RT 锁定方法）。

  5. Relock Method（重新锁定方法）菜单项将提醒您选择一个数据文件和峰，进行光谱（仅适用于 MS；不能低于 0.8）的交叉相关排列，并根据选择的文件中的峰的保留时间、收集时的压力和保存在方法中的曲线来计算建议使用的压力。

  6. 将会提醒您使用新的压力值更新方法。

当一个锁定的方法加载到 Instrument Control（仪器控制）时，标题栏会显示该方法被锁定，并指出用于锁定的化合物。压力（仅适用于在线仪器）将被设定在锁定压力。如果从 Instrument Control（仪器控制）中一个新名称保存方法，将会询问锁定状态在新方法中是否保留。

注当一个锁定的方法运行时，压力被存储为锁定压力值，即使使用 GC 键区或从 Instrument Control（仪器控制）中改变它，也不起作用。


自动重新锁定方法

  1. 在 Data Analysis（数据分析）中加载保留时间锁定方法。

  2. 选择 View / RTLock Setup（查看/保留时间锁定设置）（或者，对于环境或药品分析软件，选择 Tools / RTLock Setup（工具/保留时间锁定设置）)。

  3. 选择 RTLock / Use AutoRelock（保留时间锁定/使用自动重新锁定）。显示 Select AutoRelock Mode（选择自动重新锁定模式）对话框。

  4. 选择要用的自动重新锁定选项，单击 OK（确定）。

另见

保留时间锁定

选择自动重新锁定模式对话框


解除方法锁定

  • 从 Instrument Control（仪器控制）中选择 Instrument / Unlock Method（仪器/解除方法锁定）。

  • 从 Data Analysis（数据分析）中，选择 View / RTLock Setup（查看/RT 锁定设定） (或对于“环境或药物分析”软件，选择 Tools / RTLock Setup（工具/RT 锁定设定）），然后选择 RTLock / Unlock Method（RT 锁定/解除锁定方法）。

这将从允许用户进行手动色谱柱流量调节的方法中删除锁定标志。

另见

保留时间锁定


修改筛选数据库参数

  1. 在 Data Analysis（数据分析）中，选择 Tools / Change Screen Database Parameters（工具/修改筛选数据库参数）。

  2. 如果没有当前筛选数据库，系统会提示您选定一个筛选数据库。选择您想使用的筛选数据库文件 (*.scd) ，单击 OK（确定）。

  3. 在显示的 Screen Database Update（筛选数据库更新）对话框中选择您想改变的参数。进行修改，并单击 OK（确定）。

另见

创建用户 RTL 筛选数据库


创建用户 RTL 筛选数据库

现在的化学工作站软件已经允许用户创建自己的锁定筛选数据库。创建用户锁定筛选数据库的步骤如下：

注意 保留时间锁定数据库是 筛选数据库。这些数据库用于快速估计用户样品中可能存在的各种化合物是否确实存在。它们也不是专为定量分析而设计的。如果用户对于定量分析化合物含量感兴趣，那么，建立一个保留时间锁定 GC/MS 方法定量数据库是更为恰当的途径。

该程序包括三个步骤：创建 RTL GC/MS 方法、创建 RTL 方法从样品采集到的质谱库，然后将这个质谱库转换成为筛选数据库。在创建质谱库之前，了解以下信息将不无裨益：化合物的标识符（化学名），化学式（可选），分子量（可选），CAS 号（可选），每个峰的保留时间（单位为秒）。这些信息可以通过对色谱的积分和质谱峰的谱库检索（峰时间由分钟转化为秒）获得。

创建保留时间锁定 GC/MS 方法

若已经创建了适宜的方法，锁定方法的必要步骤如锁定 MS 方法中所述。经验可以用于判断方法是否符合用户在合理的时间内优化分离标准，及是否正确地选择了锁定化合物；因此对样品拥有充足的经验就很重要了。最理想地，锁定化合物是内标化合物或已知在每一样品中都出现并且在近于色谱分离图中段洗脱出来的化合物。

创建质谱库

  1. 在 Data Analysis（数据分析）中调用您想使用的 RTL 方法。

  2. 调用由选定 RTL 方法进行采集所得的数据文件。

  3. 选择 Spectrum / Edit Library（谱图/编辑谱库）。显示 Edit PBM Library（编辑 PBM 谱库）对话框。

  4. 选择 Create Library（创建谱库）。为新的谱库输入名称（8 位字符），以文件名 .L 格式，保存到您的数据库目录下。

  5. 选择显示在窗口 1 中的峰和它的质谱图。您可以使用峰顶点光谱、峰平均光谱及扣除本底光谱。

  6. 选择 Spectrum / Edit Library（谱图/编辑谱库）。显示 Edit PBM Library（编辑 PBM 谱库）对话框。

  7. 选择 Add New Entry（添加新项目）。显示的对话框包含有质谱的所有字段。项目必须添加在以下字段中：Name（名称），Molecular Weight（分子量）；和 Retention Index（保留指数）。如果您没有分子量的信息，请填入 9999。Retention Index（保留指数）字段必须是峰（在顶点）的保留时间（单位为秒）。若已填写完所有字段，请单击 OK（确定）更新谱库。

  8. 在选择下一质谱之前必须单击 Cancel（取消）。移至下一峰，选定谱图，从选择数据文件一步一步往下做，直至所有的化合物都添加完毕。项目不必以保留时间为序。

  9. 如果其他数据文件中有您感兴趣的化合物，则调用该文件，添加色谱到谱库中。

创建用户筛选数据库

  1. 在命令行键入命令 MAKESCREENDB，然后单击 Execute（执行）。

  2. 得到提示后，选择您刚才建立的质谱库，转换为筛选数据库 (SCD) 文件。

  3. 得到提示 “Sort filename.L by Retention Time?（以保留时间对 文件名 .L 排序吗？）”，选择 Yes（是）。

  4. 得到提示后，输入您想保存 SCD 文件的文件名与目录。

检查用户筛选数据库

  1. 在 Data Analysis（数据分析）中，选择 Tools / List Screen Database（工具/对筛选数据库列表），检查您刚才建立的 文件名 .SCD 。这样将会以保留时间的次序显示化合物的特征图标。

  2. 选择 Tools / Specify Method Screen Database（工具/指定方法筛选数据库），并选择适宜的文件名 .SCD 指定特定 RTL 方法的筛选数据库。

  3. 调用锁定方法采集的数据文件。

  4. 选择 Tools / Create Screen Results For The Current File（工具/创建当前文件的筛选结果）。

  5. 选择 View / Result Screener（查看/结果筛选器）。如果您的数据文件是用于建立数据库的数据文件，那么，所有化合物的标识符应出现在筛选器中。


RTLock 设置视窗

通过选择 Data Analysis（数据分析）下的 View/ RTLock Setup（查看/ 保留时间锁定设置）（在 Environmental and Drug Analysis（环境与药品分析）软件中为 Tools/ RTLock Setup（工具/保留时间锁定设置）），进入此视窗。一旦已经从 Instrument Control（仪器控制）中收集到了 RTL 校准文件，所有的实际锁定就从 Data Analysis（数据分析）内部执行。

另见

保留时间锁定菜单

保留时间锁定概述

锁定 MS 处理方法

锁定 GC 处理方法

结果筛选器


结果筛选器

从 Data Analysis（数据分析）中选择 View/ Results Screener（查看/结果筛选器）（在环境与药物分析软件中为 Tools/ Results Screener（工具/结果筛选器）），进入结果筛选器。

结果筛选器用于计算保留时间锁定条件下采集的数据文件中的锁定化合物的期望保留时间/离子（仅对 MS）。如果没有“锁定” 信息（数据不是在保留时间锁定条件下进行采集），则不能使用该筛选过程。

在 Results Screener（结果筛选器）模式下可使用一系列新的菜单：

Screener（筛选器）

Spectrum (MS mode only)（色谱（仅对 MS 模式））

ChromEval（光谱计算）

Display (MS mode only)（显示（仅对 MS 模式））


保留时间锁定菜单

在 Instrument Control（仪器控制）中

Instrument Control（仪器控制）中的 retention time locking（保留时间锁定）菜单项由 Instrument（仪器）菜单进入。

在 Data Analysis（数据分析）中

若您选择 View/ RTLock Setup（查看/建立保留时间锁定），可进入 Data Analysis（数据分析）中的 retention time locking（保留时间锁定）菜单。所有的保留时间锁定计算与报告都由 RTLock（保留时间锁定）菜单进入。View（查看）菜单让您回到 Data Analysis（数据分析）视窗。

在 Data Analysis（数据分析）的 Tools（工具）菜单中还有一些额外的菜单项（仅对 Enhanced（增强型）模式），让您执行某些 RTL 作业，例如创建 RTL 筛选报告或修改方法筛选数据库。

另见

Results Screener（结果筛选器）菜单


筛选数据库更新对话框

选择 Data Analysis（数据分析）菜单中的 Tools / Change Screen Database Parameters（工具/修改筛选数据库参数）时显示此菜单。在这个对话框中，您可以对指定的筛选数据库修改以下参数。

Set Extraction Window（设置提取窗口）

提示输入每 x 分钟重新设置提取窗口。设置提取窗口影响筛选数据库中的保留时间信息。

Set Subtraction Method（设置提取方法）

在这个对话框中，您可以指定计算特征离子比的方法：取开始和结束的平均值；开始和结束的较小值；不进行减法运算；扩展定量（仅用于定量峰面积）。

Set Uncertainty Type（设置不确定度类型）

允许您选择 Relative（相对）或 Absolute（绝对）。例如，一个特征离子的相对响应是 40%，不确定度为 a%，a 为 20：如果选择 Relative（相对），可接受范围为 32% 到 48%。如果选择 Relative（绝对），可接受范围为 20% 到 60%。

Set Uncertainty Range（设置不确定度范围）

提示您输入特征离子与目标离子相对响应比的可接受范围。它既可以是相对不确定度（缺省），也可以是相对不确定度。校准过程中每一个特征离子的不确定度缺省值为 20%。

Make New RT/x SCD（创建新的 RT/x 筛选数据库）

从当前选择的方法 SCD 文件出发，保留时间除以一个常数因子，来创建新的 RTL 筛选数据库 (SCD)。当使用特定 SCD 文件的 RTL 方法经过修改来产生新的保留时间，对每一个化合物都同时除以一个“确定的”因子（例如，方法快两倍，因此现在所有的锁定保留时间都应该是原来锁定保留时间得一半），这个选项就很有用处。

Set Other (via command)（通过命令设置其他)

允许您使用命令来对其他参数作全程修改。例如，要改变所有化合物的浓度单位为“ug/L”，输入 Amt_Units$=”ul/L” 命令，并单击 OK（确定）。这样，筛选数据库中所有化合物的浓度单位都进行了更新。注意：在筛选过程中没有使用所有的参数。

另见

修改筛选数据库的参数

创建定制 RTL 筛选数据库


选择自动重新锁定模式对话框

当您选择 RTLock / Use AutoRelock（保留时间锁定/采用自动重新锁定），将弹出此对话框。在此对话框中，确定依次采集中是否采用保留时间锁定及怎样执行 RTL 软件。为使用该功能软件，需要一个校准定量数据库，用由 Edit Compounds（编辑化合物）面板中第二页中指定为 ‘R’ 类型的化合物来校准保留时间锁定曲线。如果在方法定量数据库中没有 ‘R’ 类型的化合物，Use AutoRelock（采用自动重新锁定)菜单项将呈灰色。此外，用于校准 RTL 处理方法的化合物必须存在，或已添加到指定的 RTL 重新校准样品中。

All Calibrators（所有校准物）

当每一个校准样品类型的集合都在一个序列中运行时，选择这个选项将会初始化自动重新锁定。

Specified Calibrator Level（指定校准物的浓度）

弹出一个面板，显示存在于方法中的当前校准浓度。您可以选择用于自动重新锁定的浓度。在依次数据采集中，只有选择这一浓度的校准样品类型会用于初始化自动重新锁定。

All Method Acquisitions（所有方法采集）

在每一次依次采集后，运行自动重新锁定过程。每一个样品“必须”包含用于创建 RTL 校准的化合物。

Disable Auto Relock（禁用自动重新锁定）

该选项关闭自动重新锁定。


报告示例

这是一个从 Data Analysis（数据分析）中的 RTLock Setup view（保留时间锁定设置查看）选择 RTLock / Report RTLock Calibration（保留时间锁定/报告保留时间锁定校准）时生成的一个报告示例。

Retention Time Locking Data Report

Retention Locked Method: C:\MSDCHEM\2\METHODS\LFSRTL.M

Retention Locked Cal Date: 21 Jan 1998 12:21

Instrument: GC/MS Ins

Operator: T.Otsuka

Method Lock is currently Off

Compound: dde

Retention Time Calibration:

psi Time Spec Deviation

File Pressure min. Xcor Seconds

RTLOCK1.D 15.00 17.315 1.000 41.748

RTLOCK1.D 16.50 16.959 1.000 20.394

RTLOCK1.D 18.00 16.619 1.000 0

RTLOCK1.D 19.50 16.307 1.000 -18.750

RTLOCK5.D 21.00 16.005 0.999 -36.858

Maximum Deviation: 41.748 seconds

RTL Curve: R = 2.86e+004 A*A - 1.27e+006 A + 1.44e+007

Terms of Curve Fit:

Constant = 1.44201e+007

Linear = -1.26786e+006

Quadratic = 28575.7

Locked Retention Time information:

Retention Locked Method: C:\MSDCHEM\2\METHODS\LFSRTL.M

Acq Date: 21 Jan 1998 12:21

Instrument: GC/MS Ins

Operator: T.Otsuka

Measured Retention Time: 16.619 Pressure: 18.00 (psi)

Measured Retention Time: 16,000 Pressure: 21.02 (psi)

Lock run spectrum XCor: 1.0000

Report created: Tue Feb 10 10:32:44 1998


保留时间锁定的术语表

术语 | 说明
RTL | 保留时间锁定
Lock Compound （锁定化合物） | 命令产生在所有锁定文件和 RTL 校准中被检验的峰。
Lock Retention Time （锁定保留时间） | 锁定化合物要求的保留时间
RTL Calibration Files （RTL 校准文件） | 五个在不同压力（-20%，-10%，标识值，+10%，+20%）下收集的数据文件
RTL Lock File （RTL 锁定文件） | 用于设定锁定的数据文件。在这个文件中，比较了锁定化合物的实际保留时间和用于采集文件的压力以及校准曲线和用于决定锁定压力的锁定保留时间。
Scouting Run （检索运行） | 在色谱柱维护后或在另外一台仪器上运行 RTL 校准创建方法时收集到的数据文件。把这个文件用在重新锁定的方法中。
Confirming Run （确认运行） | 用通过评估检索运行中得到的峰位置和压力而收集得出新压力的数据文件。
Lock Pressure （锁定压力） | 通过比较 RTL 锁定文件采集压力和保留时间以及校准曲线和锁定保留时间而决定的压力。
Nominal Pressure （标识压力） | 当前加载的方法中进样设定值对应的进样口压力。
Screen Database （屏幕数据库） | 使用锁定的方法产生的保留时间的化合物数据库（.scd 文件）。这个 .scd 文件可以从一个标准 qdb.mth 文件创建，可能没有校准信息。
Screen File （屏幕文件） | 从一个使用包含从锁定的方法产生的保留时间的筛选数据库的筛选过程得到的筛选结果文件。


向现有方法中添加化合物

  1. 加载方法。

注意 向配置有 5973 MSD 的系统载入方法时，软件将对实际离子源/四极杆质量过滤器温度和存储在该方法的调谐文件中的设定值进行对比。如果它们超过三摄氏度的公差范围，系统将问您是否希望下载新的设定值。

  2. 对含有您希望添加进方法的化合物的校准样品采集数据。测定新化合物的保留时间，以及用于 MS 分析的目标离子和特征离子。

  3. 在 Data Analysis（数据分析）中选择 Calibrate / Set Up Quantitation（校准/设置定量），将新化合物添加到数据库中。

  4. 保存更新过的方法。

  5. 重新定量数据文件，更新校准。


编辑整个方法

当从 Instrument Control（仪器控制）或 Top 窗口的菜单中选择 Method / Edit Entire Method（方法/编辑整个方法）出现该框。Edit Method（编辑方法）对话框允许您选择方法中您要编辑的那一部分进行编辑：

  • Method Information（方法信息）

  • Instrument/Acquisition（仪器/采集）— 将显示所有用于输入的相关 GC 和 MS 对话框。

  • Data Analysis（数据分析）

当单击 OK（确定）时，所选方法部分的对话框将顺序显示用于编辑。

当提示您保存方法时，如果愿意可以为该方法输入一个新名称。如果要用一个自定义报告模版作为报告类型，会提示您是否希望保存一个带有数据文件的生成报告副本。


加载一个方法

在顶部加载方法

当启动化学工作站软件时，把缺省方法（通常为 DEFAULT.M）加载到内存中。

在可以编辑或运行一个方法之前，您必须将其加载到 Top（顶部）（或 Instrument Control（仪器控制））中。Data Analysis（数据分析）自动加载最后的方法和在 Data Analysis（数据分析）中使用的数据文件。

  1. 从 Top（顶部）视窗，选择 Method / Load（方法/加载）。

  2. 单击欲使用的方法或输入它的名字（如果方法不在当前路径下需要输入路径），并单击 OK（确定）。

注意 当在一个配置了 5973 MSD 的系统上加载方法时，软件比较实际源/四极杆温度与存储在调谐文件（调谐文件为方法的一部分）中的设定值。如果它们不在三摄氏度公差内，将询问您是否下载新的设定值。


向方法添加额外信息

  1. 调用方法。

  2. 在 Instrument Control（仪器控制）视窗中选择 Method / Additional Method Information（方法/方法额外信息）。启动 Notepad 程序。

  3. 键入您希望添加到方法中的信息。您可以按您的要求输入尽可能多的信息。

  4. 选择 File / Save（文件/保存）。

  5. 关闭 Notepad 程序。

文件将被保存为方法目录下的文本 (.txt) 文件，文件名与所用方法相同。只要打印方法，也将该文件打印出来。如果方法存为新文件名，系统将附加提示 Method <original method name> renamed as <new method name>（方法<原方法名称>重命名为<新方法名称>）。


方法菜单

Run （运行） | 运行当前方法。显示 Start Run（开始运行）对话框。
Load （加载） | 允许从磁盘上的文件列表中选择一个方法文件。
Save （保存） | 允许保存方法
Edit Entire Method （编辑整个方法） | 允许编辑当前内存中的方法。
Additional Method Information （其他方法信息） | 仅在 Instrument Control（仪器控制）中有效。打开 Notepad 程序，在其中输入其他方法信息（例如色谱柱或样品信息）。然后把信息同方法一起保存。
Print （打印） | 打印当前方法。
Set New Default Paths （设定新缺省路径） | 允许改变方法、数据文件、序列和谱库的缺省文件路径。这些改变保存在 win.ini 文件中。
Exit （退出） | 退出所有视窗。请确认在退出前已保存了所有需要改变的方法！


设定一个序列

Sample Log Table（样品日志表）对话框用于设定一个序列。在 Sample Log Table（样品日志表）中的每一行包含一个样品的分析信息（对于一个 ALS，为一个瓶）。

  1. 如果没有打开 Sample Log Table（样品日志表），请选择 Sequence / Edit Sample Log Table（序列/编辑样品日志表）。

  2. 单击表中的空白行。然后单击带有 Type（类型）标签的框中的箭头并选择要运行的样品类型。

  3. 使用 Tab 键或鼠标移动到 Vial（瓶）框并输入瓶号。

  4. 移动到 Method（方法）并输入要在当前样品中使用方法的名字。（有关方法列表，在该字段输入 ?。）

  5. 提供 Data File（数据文件）名、一个 Sample Name（样品名）、Miscellaneous Information（其他信息）和 Expected Barcode（期望的条形码）。

  6. 移动到要在样品中使用的其他字段。如果出现一个 More（更多）的按钮，单击可以得到其他选择。

注将出现的字段依赖于被选择的样品的 Type（类型）。帮助行显示在对话框的下部。

使用 Repeat（重复）、Cut（剪切）、Copy（复制）和 Paste（粘贴）等适宜的按钮将样品添加到表格中。Repeat（重复）复制被加亮的行、增加瓶号并迅速将新的一行加到被加亮行后。Copy（复制）复制加亮行并不对加亮行做任何更改。使用 Paste（粘贴）将那行放到希望的位置。已经完成时，单击 OK（确定）。

将另一个序列的目录加到当前序列，选择 Sequence / More（序列/更多）并选择 Append Sequence（增加序列）。

另见

样品日志表对话框

使用条形码读出机

从 CSV 文件输入序列信息

关键字

序列模式


检测一个序列

在分析样品前检测序列是否有故障，选择 Sequence / Simulate Sequence（序列/模拟序列）。这种模拟仅能检查语法的一般错误，而不能检查逻辑错误。还应注意这仅为一次模拟运行，而不是实际运行。

模拟序列将结果发送到序列日志文件。当模拟结束时，您将被询问是否希望查看日志文件。日志将包括：

  • 将要进样的列表

  • 将被分配的数据文件名

  • 在序列中可能产生的故障提示

  • 存放序列生成的数据文件所需的估计磁盘空间

注意

模拟序列不能检查 GC 关键字或数据文件命名的结果。

首先显示 Start Sequence （开始序列）框，您可在其中输入数据。然后校验下列条目：

  • 不使用改写模式可避免覆盖已存在的数据文件。

  • 在只进行后处理的序列中，数据文件存在。

  • 不存在的方法文件。

  • 存在由 DataPath（数据路径）和 MethPath（方法路径）关键字指定的路径。如果该路径为根目录，例如 C:\, 测试将会失败。如果数据路径不存在，您将会被询问是否要创建数据路径。如果回答是，则自动生成数据路径。

  • 可用的磁盘空间。将每种方法采集的最后一个数据文件（如果有定量输出文件，也包含在其中）的大小乘以样品的数量。这一方法假设所有文件都存储在同一个盘上。

采集样品时，RunMethod（运行方法）宏将在方法目录中创建一个宏文件，其中包括最后的数据文件的名称及目录。如果该宏文件或最后的数据文件不存在，使用50000 比特的缺省值。如果数据路径不包含驱动器名，则在计算中使用包含化学工作站软件的驱动器。


定位一个系列

为了在 Sample Log Tabl俄（样品日志表）中的指定行数上启动一个序列运行，请选择 Sequence / Position and Run（序列/定位和运行）。显示 Sample Log Table（样品日志表）中的列表部分，可以用箭头键选择在哪开始。选择后显示 Run Sequence（运行序列）框。

注意定位应只在当前执行的主要序列或次一级序列中进行。如果您尝试在两个序列级间跳跃，结果将不可预测。

在开始序列之前，将询问您是否在开始行前的每个关键字都要进行处理。您选择的关键字将被处理。

如果序列在次一级序列进行时被暂停或异常中断，Position and Run（定位和运行)菜单项将变为灰色。要清除该项，请重新加载序列。


保存/调用序列

在文件中保存序列，请选择 Sequence/ Save（序列/保存）。在出现的对话框中，提示要求您输入文件名。输入您想要的文件名，并单击 OK（确定）。如果您不输入文件名的扩展名，系统会自动提供 .S 扩展名。

若要调用一个序列，请选择 Sequence/ Load（序列/调用），单击序列文件名或输入序列文件的文件名，并单击 OK（确定），或双击显示在列表中的文件名。


启动一个序列

  • 欲启动一个序列，请选择 Sequence / Run（序列/运行）。

  • 如果想先加载一个序列，请选择 Load and Run Sequence（加载并运行序列）。

  • 开始一个在 Sample Log Table（样品日志表）中指定行数上的序列，请选择 Position and Run（定位和运行）。（注意定位应只在当前执行的主要序列或次一级序列中进行。如果您尝试在两个序列级间跳跃，结果将不可预测。在指定行前面的关键字不执行。）

所有三个选择使您到达 Start Sequence（启动序列）对话框，它要求初始化序列所需的所有信息。准备好时，单击 Run Sequence（运行序列）。上部将显示一个状态框。


重新开始一个序列

一个序列可能由于故障、关键字 Pause（暂停）的存在或删除、或异常中断而停止。一旦出现问题的故障被排除，只要没有加载不同的序列，原来的序列可能在它被停止的地方重新开始。如果已经改变了序列，运行结束时将会提醒您保存已更改的序列。

欲重新开始一个序列，选择 Sequence / Run（序列/运行）。在单击 Run Sequence（运行序列）按钮时，将会被询问是否要重新开始序列。

当一个被中止的序列重新开始时，把新的信息被添加到当前的序列日志文件。当故障或异常中断发生并且序列重新开始时，将在新的开始时间创建一个新的日志文件。


打印一个序列

当选择 Sequence / Print Sequence（序列/打印序列）时，您将被询问打印序列的摘要格式还是全部打印。Sample Log Table（样品日志表）的时间标记被打印在每页的下部。

摘要格式

选择 Brief Format（摘要格式）打印 Sample Log Table（样品日志表）中的表格信息。

完全格式

选择 Full Format（完全格式）打印 Sample Log Table（样品日志表）中有关序列的全部信息。


附加一个序列

要在当前内存中的序列中附加一个以前创建的序列，请选择 Sequence / More（序列/更多）然后选择 Append Sequence（附加序列）。您会得到提示确定要附加的序列文件名称；在列表中选择一个。

序列受样品日志表大小限制。溢出时不产生错误。


从 CSV 文件输入序列信息

可以在运行样品前通过从 Excel 或 LIMS 输入 CSV 文件设定并模拟整个序列。

  1. 从 Top（顶部）视窗，选择 Sequence / Import Sequence Information from CSV file（序列/从 CSV 文件输入序列信息）。显示出 Specify Field Numbers（指定字段号）对话框。

  2. 输入与 CSV 文件匹配的字段号并单击 OK（确定）。显示 Specify Line Numbers（指定行号）对话框。

  3. 输入在 CSV 文件中使用的开始和结束的行号。单击 OK（确定）。

    例如，项目 6 和 12 将输入 6 行 到 12 行，将忽略 1-5 行或 12 行以后的任意行。这意味着 CSV 可能包括“文件头”或“页脚”信息，这些信息将被忽略或不被认为是样品。

    如果没有添加项目，将提示您是否使用整个文件。单击 Yes（是）继续，单击 NO（否）返回 Specify Line Numbers（指定行号）对话框。

  4. 接下来将提示您指定文件类型。选择 Comma Separated (CSV)（逗点分离）项并单击 OK（确定）。

    如果选择 Tab Separated (TSV)（制表符分离），文件中的信息被制表符而不是被逗点分离。

  5. 当被提示时，选择要使用的 CSV 文件并单击 OK（确定）。

  6. 接下来，系列被建立并自动被模拟和保存。系列文件的名字将为 ddmmmXnn 形式，这里“dd”为日，“mmm”为月, “X”为小时 (0=”A”,1=”B”)，“nn”为小时的分钟数。

  7. 将提示您是否希望浏览系列模拟结果。如果选择 Yes（是）,显示类似于如下数字的结果。

CSV 文件示例

下图显示一个用于创建上述报告的 CSV 文件的例子。

字段号示例

下图示意您如何完成上述 CSV 文件示例所示的 Specify Field Numbers（指定字段号）对话框。每个字段号代表信息所处的色谱柱。例如，数据文件名被列在色谱柱 D，即第四个色谱柱中。

行号示例

下图示意您如何完成上述 CSV 文件示例所示的 Specify Line Numbers（指定行号）对话框。这个例子显示将使用 CSV 的 6-12 行。忽略 1-5 行。

参比信息

对于 CSV 和 TSV 格式，下面应用：

  • 如果 CSV 文件不包含数据文件名，数据文件名将为缺省值 ddmmmxxx.D, 其中 “dd” 为日(01,02&ldots;), “mmm” 为月(Jan,Feb&ldots;), “xxx”为样品号(001、002、003&ldots;)。如果 CSV 文件中的数据文件名不包含 *.D 的扩展名, 把“.D”加到文件名中。

  • 如果 CSV 文件不包含方法名，将使用当前加载的方法。

  • 如果 CSV 文件不包含 Sample Name（样品名），它将留为空白。

  • 如果 CSV 文件不包含 Miscellaneous Information（其他信息），它将留为空白。

  • 如果 CSV 文件不包含 Vial Number（瓶号）, 它将是增量(1、2、3、&ldots;100)。

  • 如果 CSV 文件不包含 Sample Multiplier（样品乘数），它将设定为 1.0000。

  • 如果 CSV 包含与预期的输入不一致的数据，如瓶号 = ”abc”, 项目作为一个“注释”和“无效项目&ldots;”加入到说明里。


重排数据文件序列

为了要重排数据文件序列，请选择 Sequence/ More（序列/更多），并选择 Re-Sequence Data Files（重排数据文件序列）。系统要求您输入起始数据文件的文件名。缺省设置为序列中的第一个文件。

如果文件名中含有数字字段，如 Data001，序列中数据文件的文件名将会改变，以便它们形成连续升序。如果您有 10 - 99 个数据文件，请在文件名中启用两位数字；如果文件数为 100 或更多，则在文件名中启用 3 位数字。（如果数据文件名中不含有数字字段，则在样品日志表中，所有的文件都会赋予相同的文件名。）

在样品日志表中插入或删除一个样品后，若要重新对数据文件排序，这个命令就很有用处了。系统将对文件名进行编辑，直至遇到关键字 END 为止。子序列中的文件名不会被改变。


重排样品瓶序列

要改变序列中的样品瓶号，使其从 1 开始以连续升序排列，请选择 Sequence/ More（序列/更多），并选择 Re-Sequence Vials（重排样品瓶序列）。注意：数据文件名仍以原来的次序排列；它们并不随相应的样品瓶号的移动而重新排序。

在序列中，样品瓶号为 1 的样品最先进样，样品瓶号加 1 的样品为下一个进样的样品。在 Staggered Dual Tower（交错双塔进样）模式下使用此选项时，应该注意的一点是系统将虚拟样品分配在样品瓶的位置上。


改变方法

要一次性改变所有样品的方法，请选择 Sequence / More（序列/更多），然后选择 Change Method（改变方法）。将提示您给出原方法的名称，然后要求从列表中选择新方法。序列中所有出现原名称的地方将被新名称替代。

所列的方法是在缺省方法目录中由 variable _MethPath$ 指定的方法。序列使用的所有方法必须位于该目录下。

请注意如果方法不在缺省方法目录中，您必须通过向序列中添加 MethPath（方法路径）关键字来更改目录。


样品日志表对话框

当您选择 Sequence/ Edit Sample Log Table（序列/编辑样品日志表），将显示此对话框。它可以用来创建一个序列。下面是所有可用项的列表；Sample Log Table（样品日志表）中是否出现某些字段由化学工作站的配置及当前所选择的 Type（样品类型）决定。

Type（样品类型） | Sample Amt（样品总量）
Vial（样品瓶） | Multiplier（乘数）
Data File（数据文件） | Gas Smpl Wt（汽油样品重量）
Method（方法） | Gas Density（汽油密度）
Sample Name（样品名称） | Gas ISTD Wt（汽油分析的内标重量）
Miscellaneous Information（其他信息） | Area% Report（面积百分比报告）
Expected Barcode （预期的条形码） | Lib. Search Rep.（谱库检索报告）
Keyword / Keyword String（关键字/关键字字符串） | Quant Report（定量报告）
Level（校准级） | Post-Quant Macro（后定量宏）
Upd RF（更新响应因子） | CR Database（定制报告数据库）
Upd RT（更新保留时间） | CR Spreadsheet（定制电子表格）
Upd QI（更新特征离子） |

Type（样品类型）

每一次进样的样品类型。以下所列的样品类型决定于化学工作站的配置：

Sample （样品） | 对于（未知的）非校准物样品，采用该样品类型。这些样品将在 Data Analysis（数据分析）中根据指定的处理方法进行处理。
Blank （空白） | 这些样品不在 Data Analysis（数据分析）中处理；只报告总离子流色谱。如果您想知道样品中除了溶剂外没有其他样品时的结果，请选择 Blank（空白）项。Blanks（空白）选项用于检查系统中有无污染。
Calibration （校准） | 处理方法中必须包含一个完整的定量数据库。在 Data Analysis（数据分析）中根据 Level（校准级） 项中指定的校准浓度将数据文件视为重新校准样品进行处理。当您选择这种样品类型时，对话框中将出现其他字段，允许您设定校准浓度、更新响应和保留时间。
Keyword （关键字） | 您可以通过选择关键字来修改序列的执行情况。
QC | 选择该样品类型，将对样品进行定量分析、输出摘要到打印机，并根据校准表中的‘QC’识别码对定量结果进行计算。报告将列出实际值与标识总量的比较及百分比误差。 如果‘QC’级不存在，则不会生成报告，序列日志文件将记录一条消息。
RearSamp （后样品） | 在 Dual Tower（双塔）模式下，您能够使用一种特殊的样品类型，称为 RearSamp（后样品）类型。该样品类型允许您使用已安装的双注射器/双色谱柱同时进样。在运行之前，RearSamp（后样品）类型的样品必须在样品日志表中位于同时进样的另一样品的前面。这就告诉软件，表中这一行的样品与下一个样品是同时进样的。
RearCal （后校准） | 任何仪器故障都会中止序列的执行。Data Analysis（数据分析）处理 Calibration（校准）或 Blank（空白）类型的样品时发生的任何故障都会中止序列的执行。对于 Samples（样品）类型，Data Analysis（数据分析）错误将会被忽略，但与其他任何错误一样会在序列日志文件中记录下来。

Vial（样品瓶）

对于 ALS 进样，根据以下各项输入样品的物理位置：

ALS tray present （有 ALS 托盘） | 输入从 1 到 100 中的一个数。
Normal density turret （正常密度转盘） | 输入从 1 到 3 中的一个数（没有托盘）
High density turret （高密度转盘） | 输入从 1 到 8 中的一个数（没有样品架）。

对于手动进样（没有 ALS 样品架), Vial（样品瓶）字段可用来反映样品瓶标签。

如果调用的序列中对同一个样品瓶有多个进样，多次进样将转换为独立的项目，最大为表的极限大小。若要以连续升序对样品瓶重新进行编号，请选择 Sequence（序列）/ More（更多），再选择 Re-Sequence Vials（对样品瓶重新排序）。

Data File（数据文件）

根据您对系统配置的不同，在序列表中命名数据文件的方式也不相同。在序列中命名数据文件共有五种方式：

  • 对每一个样品输入各自的文件名。

  • 若该字段空白，系统将自动生成数据文件的缺省格式 VVIIRRR（2 位样品瓶号，2 位进样号，3 位运行次数计数。0101001, 0102002 等。）（表中的数据文件字段用虚线 ------- 显示。）

  • 若该字段空白，使用 SwapName 关键字，系统将自动生成 RRRVVII（运行次数计数交换）格式的文件名。

  • 使用 SeedName 关键字，系统将自动生成 ABCDExxx 或 ABCxxxDE 格式的文件名。所有的字符都可以是数字，但应在文件名中某处位置留下数学字符 (xxx) 的足够空间，来包含序列中的样品编号。

  • 使用 SwitchGC，MaskName 和 MakeSec 关键字来修改下一信号文件的命名方式。

  • 若要创建该表，单击 OK（确定），然后选择 Sequence / More（序列/更多），并选择 Re-Sequence Data Files（对数据文件重新排序）选项。提示要求您输入起始数据文件名；并提供可以在给定文件名基础上通过递增数字来命名其他文件的文件名，如 samp01。

若要覆盖与新的文件序列中重名的已存在文件，在 Start Sequence（启动序列）对话框中选择 Overwrite（覆盖）复选项，或使用 OverWrite（覆盖）关键字。

Method（方法）

分析该样品时所使用的处理方法名。该方法必须存在。输入 ? 显示可用方法列表。所列出的方法是处于宏 _MethPath$ 变量指定的缺省方法目录下的方法。一个序列所使用的所有方法必须都位于这个目录下。注意：如果处理方法不在缺省方法目录下，您必须将 MethPath（方法路径）关键字添加到序列中来修改目录。如果您想一次性修改所有样品的方法，请选择 Sequence / More（序列/更多），并选择 Change Method（更改方法）。

Sample Name（样品名称）

样品名称。这一行最长为 45 个字符。

Miscellaneous Information（其他信息）

有关样品的其他信息。这一行最长为 45 个字符。

Expected Barcode（预期的条形码）

输入当前样品的条形码。在样品日志表中，您可以选择使用条形码读出机。

Level（校准级）

只有在样品类型是 Calibration（校准）时才会显示此对话框。进行重新校准的浓度（ID 浓度）必须与定量数据库中出现的校准浓度完全相同（ID 浓度区分大小写）。

Upd RF（更新响应因子）

只有在样品类型是 Calibration（校准）时才会显示此对话框。若要更新响应，请单击箭头，选择 No Update（不进行更新），Average（平均），Replace（替换），或 Clear/Replace（清除/替换）。或者，您可以输入 N（代表 不进行更新），A（代表平均），R（代表替换），C（代表清除/替换）。

Upd RT（更新保留时间）

只有在样品类型是 Calibration（校准）时才会显示此对话框。若要更新保留时间，请单击箭头，选择 No Update（不进行更新），Average（平均），或 Replace（替换）。或者，您可以输入 N（代表不进行更新），A（代表平均），或 R（代表替换）。

Upd QI（更新特征离子）

只有在样品类型是 Calibration（校准）时才会显示此对话框。若要更新特征离子相对响应，请单击箭头，并选择 Replace（替换）或 No Update（不进行更新）。或者，您可以输入 R （代表替换），或 N（代表不进行更新）。

Sample Amt（样品总量）

此字段只有在选择 More（更多）按钮时方才有效，对于校准运行无效。仅对质谱仪的使用有效。仅在方法中指定了定量报告格式的情况下有效。在打印之前，未知样品的所有计算结果都要除以这个总量然后乘以 100 。最后的分析报告中，样品总量的单位被 % 所取代。零表明不用进行样品总量计算。

Multiplier（乘数）

此字段只有在选择 More（更多）按钮时方才有效。此字段在校准运行时无效。乘积因子，仅在方法中指定了定量分析报告格式的情况下使用，用于校正样品稀释及所进行的其他处理的结果。例如，如果您用稀释因子 10 对样品进行了稀释，在当前已更新的样品浓度条件下，您可以输入因子 10 作为乘积因子。此处设定的乘积因子的值只会影响到所选择的序列行和该样品。

Gas Smpl Wt（汽油样品重量）

汽油样品重量，单位为克。此字段仅在您的系统经过配置，进行汽油样品的分析时方才有效。

Gas Density（汽油密度）

汽油样品的密度或 API 索引号。此字段仅在您的系统经过配置，进行汽油样品的分析时方才有效。

Gas ISTD Wt（汽油分析的内标重量）

内标重量，单位为克。此字段仅在您的系统经过配置，进行汽油样品的分析时方才有效。

Area% Report（面积百分比报告）

此字段只有在选择 More（更多）按钮时方才有效。在下拉式菜单中选择是否每一个方法都有一个报告，或通过选择 Summary（摘要）中的 Detailed（详细）或 None（无）来覆盖运行中保存的方法。

Lib. Search Rep.（谱库检索报告）

此字段只有在选择 More（更多）按钮时方才有效。仅用于质谱数据。

Quant Report（定量报告）

此字段只有在选择 More（更多）按钮时方才有效。在下拉式菜单中选择是否每一个方法都有一个报告（缺省），或通过选择 Summary（摘要）中的 Full（全部），Profile（图形），或 None（无）（没有报告）来覆盖运行中保存的方法。

Post-Quant Macro（后定量宏）

此字段只有在选择 More（更多）按钮时方才有效。在下拉式菜单中选择是否每一个方法都有一个 LSC 报告（缺省），或通过选择 LSC Summary（LSC 摘要），LSC Detailed（LSC 详细）或 None（无）来覆盖运行中保存的方法。

CR Database（定制报告数据库）

此字段只有在选择 More（更多）按钮时方才有效。在下拉式菜单中选择是否每一个方法都对定制报告 (CR) 数据库进行更新，或选择 Update（更新）或 None（无）（不进行更新时）。

CR Spreadsheet（定制报告电子表格）

此字段只有在选择 More（更多）按钮时方才有效。在下拉式菜单中选择是否每一个方法都定制报告（缺省），或通过打印一份定制报告来覆盖运行中保存的方法。或选择 None（无）。


关键字/关键字字符串

这些字段仅当从 Sample Log Table（样品日志表）的 Type（类型）字段中所列的项目选择 Keyword（关键字）时才会出现。日志表中出现的蓝色线用于标记关键字项目的位置。关键字可以任何次序出现多次。

单击 Keyword（关键字）字段中的箭头显示选项。输入 Keyword String（关键字字符串）字段的参数紧随关键字之后可应用的地方。

可使用关键字创建内置逻辑序列，它会影响注射样品、文件存储管理、采集时间等的顺序。例如，您能把自动进样器样品架中的每个样品注射到两根色谱柱（仅用于双色谱柱 GC）中。

可用于 Sample Log Table（样品日志表）的关键字和与它们关联的参数列在下面。如果一个关键字要求或接受参数，请键入参数到 Keyword String（关键字字符串）字段中。可选参数显示在方括号中（[ ]），但键入参数时不必键入括号。

ClockSrt（时钟字符串）时间

允许为下一个样品指定起始时间（24 小时制军用时间）。起始时间输入到关键字字符串。

示例：16:30 — 下一个样品将在 4:30 PM 处理。

Command（命令）命令

允许任何在顶部水平有效的命令或宏在一个序列中被执行。一个同步控制在命令之后发生，允许操作在序列结束前完成。在宏被评价前变量锁定关闭 (varlock 0)，因而保存变量可被赋值。命令执行后，变量锁定重新开启 (varlock 1)。

Comment（注释）

允许输入一个注释（最多 45 个字符）到 Sample Log Table（样品日志表）中。键入到关键字字符串字段中的注释将显示在序列日志或 Sample Log Table（样品日志表）的打印输出中。

DataPath（数据路径）路径

为所有后继样品更改数据路径（数据文件的存储位置）。序列中的后继样品使用新的数据路径。

示例：c:\MSDchem\7\data\may1\ — 将把所有后继数据文件存储在该目录下。

Debug（调试）

在序列日志文件中放入详细诊断信息。

有效关键字字符串有：

NO — 关闭调试模式。

任何其他项目或空白关键字字符串字段开启调试模式。

Interval（时间间隔）数字

Interval（时间间隔）关键字可用于将运行的启动定时在每个 n 分钟时发生。例如，如果色谱运行需要约 18 分钟，但您希望数据文件每 60 分钟获取或间隔开来，时间间隔值 60 将拖延下一次运行直至前一次运行启动后 60 分钟。这对于动力学的研究可能是有用的。

Interval（时间间隔）关键字的关键字字符串是运行之间的以分钟为单位的时间。如果关键字字符串为负值（如 -0.33）或包含字母字符（如“ABCD..”），时间间隔关键字将被取消。使用该功能将在指定 Interval（时间间隔）前一半时间内启动运行（或更准确的说，进行采集）；然而两个数据文件采集时间的实际时间间隔可能与指定的 Interval（时间间隔）略有不同，因为存在进样设备（ALS、顶空、吹扫和捕集）的时间重复。

有效关键字符串有：

"###" — 任何数字，如 60 或 55，可用于指定以分钟为单位的数据采集时间间隔。

NO — 或其他任何关键字字符串字段的非数字登录取消任何原先指定的时间间隔。

在第一次运行被获得“后”，关键字才生效。例如，欲获得两次运行间隔 60 分钟：

正确的方式 | 错误的方式
Interval 60 样品 1 样品 2 | 样品 1 Interval 60 样品 2

MethPath（方法路径）路径

为所有后继样品更改方法路径。键入新路径，如 f:\newmethods\。后继行将其用为方法路径。

示例：MSDchem\7\methods\pcb\

OverWrite（重写）yes/no

重写出现在该命令后的任意同名文件。缺省为 yes。当对导致两个文件同名的序列作出更改时使用该命令。

Pause（暂停）

使序列暂停。序列可在下一行重新启动或移动到新一行重新启动。

SeedName 数据文件名

选择用于生成后继行名称的方式。只能使用一次并且只能在序列开始时使用。第一个样品运行后或如果序列重新启动，就会忽略 SeedName 项。请参见数据文件。

SepGC1

从混合模式采集发送 GC Signal 1（GC 信号 1）数据到不同的数据目录。如果不使用该关键字，MS 和 GC 数据都被发送到同一目录。

SepGC2

发送“GC Signal 2（GC 信号 2）”数据到不同的数据目录。如果使用 SepGC1 和 SepGC2，它们都进入同一目录。

SwapName on/off（开/关）

如果处于 on（开）状态，请使用 RRRVVII。如果处于 off（关）状态，请使用 VVIIRRR（缺省）。请参见数据文件。范围是全局的，应用于主序列和所有子序列直至更改完毕。

Tune type Interval（调谐类型时间间隔）

执行所选的 AutoTune（自动调谐）并可选择在指定时间间隔重复调谐。关键字字符串确定运行哪一种调谐：

5973 MSD

关键字字符串 | 菜单选项
AUTO | Autotune（自动调谐）
LOWMASS | Low Mass Autotune（低质量调谐）
STD | Standard Spectra Tune（标准谱图调谐）
QUICK | Quick Tune（快速调谐）
DFTPP | DFTPP Tune（DFTPP 调谐）
BFB | BFB Tune（BFB 调谐）

5972 MSD

关键字字符串 | 菜单选项
MAX | Maximum Sensitivity Tune（最大灵敏度调谐）
STD | Standard Spectra Tune（标准谱图调谐）
AUTO | Standard Autotune（标准自动调谐）
QUICK | Quick Tune（快速调谐）
DFTPP | DFTPP Tune（DFTPP 调谐）
BFB | BFB Tune（BFB 调谐）

如果希望调谐在指定时间间隔后再次运行，请键入时间间隔，采用 24 小时时间 (HH:MM) 格式，与调谐类型之间空一个空格。例如，关键字字符串 BFB 08:00 当序列中遇到该行时将执行 BFB Target Tune（BFB目标调谐），然后每 8 小时再次执行直至序列完成。

DualTwr（双塔）

该关键字专门设计用于 Dual Tower（双塔）操作。因为 GC 可能有第二个数据文件，该关键字将允许为 RearSamp（后样品）样品类型指定的二级数据文件命名第二个目的路径。当该关键字被调用时，其假定已使用双塔技术并且用户不希望二级信号作为初级信号的子目录进行存储。

有效关键字字符串有：

  • NO — 取消任意原有二级路径并终止 Unlinked（未连接）模式。

  • " " — 空字符串（缺省）使扩展名 .sec 被加到初级信号的缺省数据路径。如果初级路径已经有扩展名，未连接数据文件将被保存在缺省方法路径目录中，以防文件重写。

  • <任意路径> — 可指定一个显式路径。路径必须完整（如，c:\MSDchem\8\mydata）。如果路径不存在，将会创建路径。如果不能创建或路径实际上是一个文件，则将一个错误记录到序列日志文件中，而关键字被执行时二级文件数据将被重新指向缺省数据路径 + .sec.。

该关键字仅对于使用双塔和双检测器的 GC 和 GC/MS 采集是有效的。


序列日志文件

序列运行的始终都维持有一个序列日志文件。序列日志文件包含每一次进样记录和序列的运行过程中发生的故障情况。对序列运行的每一步进行报告，在调试序列时非常有用。设定全程变量 Seq_Trace=1 ，打开调试工具；输入 Seq_Trace=0 ，关闭调试工具。

在菜单中选择 Sequence/ View Sequence Log（序列/查看序列日志），将打开 Notepad 或 Write（决定于序列日志文件大小），显示序列日志文件。您能够使用 File（文件)菜单打印或保存该文本。或者，也可以选择 Sequence/ Print Sequence Log（序列/打印序列日志文件)。

启动新序列，则覆盖原来的序列日志文件。如果您要保存序列日志文件，可从记事本中保存。

如果一个序列成功运行完毕，序列日志文件的备份文件将保存在数据路径的目录下，并基于序列的起始时间给定一个独特的文件名。文件名的格式为 DDMMMXTT.LOG ，其中

DD = 月份中的某天（01 到 31）

MMM = 月份的 3 个字母简写 (JAN...DEC)

X = 用字母表示的一天中的某时 (12 am = A, 1 am = B....11 pm = X)

TT = 分钟 (00 - 59)

.LOG = 文件名的后缀

一个序列成功运行完毕，若要自动打印序列日志文件，使用如下关键字命令：

Command printsequencelog=1

一个序列成功运行完毕，若要自动显示序列日志文件，使用如下关键字命令：

Command viewsequencelog=1


对于 GC 仪的序列模式

不同的序列模式根据 Sample Log Table（样品日志表）中的不同关键字和样品类型的组合来调用。有关每个关键字的完整解释，请参见关键字/关键字字符串。

对于 GC 的三种基本序列模式为：

Single Sample - Single Signal（单一样品 — 单信号）

Single Sample - Linked Signal（单一样品 — 连接的信号）

Dual Tower - Unlinked Signals（双塔 — 未连接的信号）


序列菜单

Run （运行） | 启动一个序列。
Load （调用） | 调用一个序列。
Save （保存） | 保存一个序列。
Edit Sample Log Table （编辑样品日志表） | 让您创建或修改一个序列。
Load and Run Sequence （调用运行序列） | 选择一个序列，显示 Start Sequence（启动序列）对话框。
Print Sequence （打印序列） | 打印一个序列。
Simulate Sequence （模拟序列） | 测试一个序列。
Position and Run （定位并运行） | 启动样品日志表中特定行号的序列。
View Sequence Log （查看序列日志） | 在 Notepad 中查看序列日志。
View Sequence Quality Log （查看序列质量日志） | 允许您查看序列中所有样品的 ISTD 并代理 QA 信息。
Print Sequence Log （打印序列日志） | 打印序列日志。
Import Sequence Information from CSV file （从 CSV 文件输入序列信息） | 您能通过从 CSV 文件输入序列信息来创建或模拟一个序列，CSV 文件由 Excel 或 LIMS 生成。
Batch Mode （批模式） | 初始化批模式创建过程。
More （更多） | 显示一个对话框，允许您将一个序列附加到另一个序列，重排数据文件序列，重排样品瓶序列，或更改方法。


使用批模式

Batch Mode（批模式）操作让您按批来组织数据与方法。链接的数据与方法只能是由您创建的批序列收集的。运行该序列时，使用的方法与收集到的数据文件存放在一个名称唯一的文件夹里。这是组织数据的一种好方法，可确保方法文件与数据储存在一起。在 Data Analysis（数据分析）中还有其他的批操作模式，可允许您重新处理或重新校正批数据。

顶部的批模式

批模式数据分析（在环境或药品分析模式下无效）


顶部的批模式

Top（顶部）的 Sequence / Batch Mode（序列／批模式）菜单项可允许您建立一个基于当前日期与时间来命名的批目录文件夹(.b) ，可将所选方法复制到该文件夹，并建立一个指向该批文件夹且指明了所复制的方法的序列。这时 Sample Log Table（样品日志表）中会出现一个部分完成的序列，您可在此向序列完成信息输入。 这样得到的批目录包含方法文件和作为序列的一部分而收集的“所有”数据文件。

要使用批模式：

  1. 请在 Top（顶部）选择 Sequence / Batch Mode（序列/批模式）。

  2. 得到提示后，选择数据收集与处理的方法，单击 OK（确定）。

  3. 接下来，会显示出一个类似于下图的部分完成的 Sample Log Table（样品日志表）。

  4. 更新分析的 Sample Log Table（样品日志表），并单击 OK（确定）。

  5. 您将被提示现在运行批处理序列。如果选择 Yes（是），将显示出与下图相似的 Start Sequence（启动序列）对话框：

  6. 单击 Run Sequence（运行序列）来启动批数据的采集。

注意序列名 (26JulK14.S) 和数据目录名 (26JulK14.b) 都是指批创建的日、月、小时（用字母表示；a=0, b=1,,,k=10）和分钟。数据文件名也以日和月为基础，如果选用了 Sample Log Table（样品日志表）编辑器中的 Repeat（重复）选项，则在原文件名基础上倍增。然而您仍然可以使用其他文件名。

注意：Sample Log Table（样品日志表）中规定的校准物“必须”参考 Data Analysis（数据分析）的校准步骤中明确规定的已有的校准级 ID。Sample Log Table（样品日志表）中的所有信息（样品种类、样品瓶号、适用的校准级数等）都存储在 datafile.d\pre_post.ini 文件中。


批模式数据分析

一旦通过 Top（顶部）菜单中的 Batch Mode setup（批模式设置）收集数据后，Data Analysis（数据分析）就可使用组织好的方法和数据文件更好地控制环境。具体做法是选择 Data Analysis（数据分析）中的 Method / Batch Mode（方法/批模式）菜单，然后选择包含方法与数据文件的理想的批目录：

如果选择的批 (.b) 文件夹中含有一种方法，则将该方法加载为当前数据分析方法，在批文件夹中准备数据文件列表。自动加载文件夹中的第一个数据文件。

通过保留一种方法和由该方法采集和处理得到的数据文件间的链接，采用 Batch Mode Data Analysis（批模式数据分析）可显著提高数据的完整性。由于预设了校准级且能够保存手动积分的化合物响应，增强了重新处理与校准能力，使校准更新为一步过程。

这会有何帮助？

首先，一旦处于 Batch Mode Data Analysis（批模式数据分析）状态下，您只能加载与原始数据收集的该批相关的“唯一”方法 — 没有 Load Method（加载方法）菜单，它被 Load Batch（调用批处理）菜单取代了。这意味着数据处理或重新分析时将总是使用正确的方法。另外，数据文件的选择仅限于该批数据文件的一部分。

这可避免您在目录树之间来回转换，也可避免方法与数据文件的不匹配。由于存储的数据文件信息可在批加载过程中存储（pre_post.ini 文件）和检索，校准和重新处理程序变得更加直接明了。方法参数能够通过化学工作站的一般程序（“色谱”/积分参数或“编辑化合物”）改变，而通过 Batch Method（批处理方法）菜单或 Batch Recalibrate（批重新校准）菜单进行重新处理：

批重新处理

Batch Reprocess（批重新处理）菜单中有 Complete Batch（处理完全批）、Calibrators First（先处理校准物）和 Samples Only（只处理样品）三个选项。选择 Complete Batch（处理完全批）选项将使用“当前”方法设定值以便与第一次收集数据时完全相同的次序重新对批处理。选择 Calibrators First（先处理校准样）选项将在处理样品“前”进行校准步骤；当该批的校准物分布很广，而样品必须在更新所有校准后进行最后处理时这一点很有帮助。

批重新校准

Batch Recalibrate（批重新校准）允许在“不”重新计算基线的情况下进行重新校准。当您已经通过 Qedit 纠正了定量结果的积分异常并想使用手动响应时，采用批重新校准很有帮助。

另见

批处理方法菜单


批处理方法菜单

选择 Method / Batch Mode（方法／批模式）后，该菜单将取代 Data Analysis（数据分析）下的 Method（方法）菜单。请参见使用批模式。

Run Batch Method （运行批处理方法） | 只执行当前数据文件中当前批处理方法的 Data Analysis（数据分析）部分。
Batch Reprocess （批重新处理） | 显示 Batch Reprocess（批重新处理）对话框。
Load Batch （调用批） | 加载所选的批 (.b) 文件夹中的第一个数据文件。该文件夹中存储的方法成为当前方法。
Save Batch Method （保存批处理方法） | 将该方法存储在批方法目录下。
Edit Method （编辑方法） | 允许您编辑批处理方法目录下存储的方法。
Non-Batch Mode （非批处理模式） | Exits Batch Mode Data Analysis（退出批模式数据分析）。该菜单返回到 Method（方法）菜单。


调谐介绍

必要时应进行调谐，可能在每天开始时，而且最后的调谐报告应保存在日志簿中。使用该信息检测调谐故障的开始以及监测电子倍增器和离子聚焦电压随时间的逐渐升高。这些报告有助于计划安排离子源清洗或倍增器的更换。

既然优化一个参数会影响另一个的最佳设定，调谐需要几次反复。可调节的参数有：透镜、四极杆质量过滤器、电子倍增器、质量坐标轴和峰宽校准。

调谐中的对象有：

最大化所有丰度

优化高质量丰度

调节峰宽

调节质量指认

另见

自动调谐

手动调谐

Tune Report（调谐报告）


调谐的故障排除故障提示 (5972 MSD)

有关 5973 MSD 故障提示，请单击此处

出现一个调谐故障提示框时

调谐窗口（在 Tune Error（调谐故障）提示框后面）包含对该故障的说明。如果说明的一部分被挡住，将提示框移至一侧。下列为最常出现的信息。有关此处未列出的信息，请参见 MSD 硬件手册。

找不到峰

选择 Diagnostics（诊断）视窗中的 Diagnostics / Edit MS Params（诊断/编辑 MS 参数）（或 Manual Tune（手动调谐）中的 AdjParam（调节参数）菜单）。然后选择 More Params / Acq Params（更多参数/采集参数）使两套参数均在视野中。选择 Mass Window（质量窗口），将其值设为 10。将 AMU Gain（AMU 增益）和 AMU Offset（AMU 补偿）设定为 0。单击 Prof 按钮。如果现在有峰存在，打开 Calibrate（校准）菜单，选择 Mass axis（质量轴），然后选择 Mass #3 widths（质量 #3 宽度）。将 Mass Window（质量窗口）重新设置为 5。保存该调谐文件。

如果自动调谐不能找到峰，增加 EMV。重新进行自动调谐。如果最后找到了峰，这说明离子源很脏而自动调谐使用的是缺省参数。

无法得到恒定峰宽

按照“找不到峰”的说明，重复进行“质量 #3”峰宽调节，直至得到恒定的峰宽为止。保存该调谐文件。

检查真空度

要检查真空度，请选择 Tune（调谐）中的 Status / Vacuum/Temp Status（状态/真空/温度状态）。报告值应小于 60 毫托。如果 MS 有离子真空规，高真空压力应低于 5x10-5 托。

扩散泵太“冷”。

一个或两个扩散泵温度太低，无法操作仪器。

DP 太热

确认扩散泵风扇是干净的且在运行。

质量过滤器电路的故障

“降低线圈”（调节 RF 线圈得到最小电压）。打开 Diagnostics and Vacuum System Control（诊断和真空系统控制）视窗中的 Diagnostics（诊断）菜单。选择 Set RFPA（设置 RF 参数），按照 MSD 硬件手册中“维护/故障排除”一章的说明调节线圈。

信号超出警戒

降低 EMV 设置。选择 Diagnostics（诊断）视窗中的 Diagnostics / Edit MS Params（诊断/编辑 MS 参数）（或 Manual Tune（手动调谐）中的 AdjParam（调节参数）），选择 EMVolts，将其设定值降低 400 伏特左右。保存该调谐文件。

源电压超出警戒

如果您刚重新充满校准瓶，则可能会在第一次打开校准阀时看到这条提示。请重试。

前级压力超过 300 毫托。

真空故障使前级压力超过临界真空度。可能存在空气泄漏或其他原因引起压力突然波动。要重新开始操作，请清除所有的真空故障，将系统抽气，并重新设置每个加热区域的温度。

没有发射电流

试用另一根灯丝。选择 Diagnostics（诊断）视窗中的 Diagnostics / Edit MS Params（诊断/编辑 MS 参数） （或 Tune（调谐）中的 AdjParam（调节参数）菜单）,选择 Filament（灯丝）字段。显示当前所用的灯丝；选择另外一个。在提示下保存该调谐文件。

如果处于化学电离 (CI) 模式下，灯丝连接的导线错误。

没有图形或扫描显示

在 Tune（调谐）视窗中，在命令行键入：

GDISPLAY ON

在提示下保存该调谐文件。

智能卡缓冲过载

在质谱仪接口卡能从 PC 上下载数据前，采集的数据过多。这可能发生在 SIM 模式下，停留时间很短，或者在扫描范围太宽或步长太小时也可能发生在原始扫描模式下。计算机正在运行其他高度占用 CPU 的应用程序时也可能发生。尝试在采集或修改 MS 采集参数时退出其他应用程序。

如果这些措施不能清除缓冲器，请选择 Diagnostics（诊断）视窗中的 Diagnostics / Initialize MS Interface（诊断/初始化 MS 接口）。

系统处于 VENT（放空）状态

系统已经被用户放空，可能是为进行某种维护。要重新开始操作，请完成要求的维护并对系统抽气。

系统处于 STANDBY（备用）状态

这可能由于 GC 关闭断路引起的，例如无法得到氦气流。检查 GC 参数和状态并排除故障。


手动调谐

手动调谐让您调节 MS 参数来满足您定义的标准。Manual Tune（手动调谐）面板可以从 Instrument Control（仪器控制）的 View（查看）菜单、Target Tune（目标调谐，[不在 5973 上]）和 Diagnostics（诊断）进入。有关更多信息，请单击下列主题。

如何

调节质量指认

调节峰宽

校准质量坐标轴和丰度

最大化所有丰度

优化高质量丰度

手动调谐概述

设定和监测 MS 参数

参见

采集和显示对话框

编辑参数对话框

调谐介绍

手动调谐菜单


调节质量指认

使用质量过滤器参数补偿和质量增益来调节质量指认。质量补偿对所有质量影响相同，而质量增益对高质量峰的影响比低质量峰大。


调节峰宽

使用质量过滤器参数 amu 增益和 amu 补偿来调节峰宽。AMU 补偿对所有质量影响相同，而 AMU 增益对高质量峰的影响比低质量峰大。


校准菜单 — 调谐

Mass axis（质量轴） | 校准质量轴。
Mass #2 / Mass #3 widths（质量 2/质量 3 宽度） | 将质谱峰宽校准至 0.5+/-0.06 amu（峰的半高宽）。
PW linearity（峰宽线性） | 使用 amu 增益、amu 补偿和 wid219 在整个质量范围内将峰宽线性化。(5972 / 6890 MSDs)
Adjust abundances（调节丰度） | 将丰度最大的调谐质量调节为合格数值。

Mass Axis（质量轴）

通过调节质量增益和质量补偿校准质量轴，可使给定化合物的检测峰按已知峰值排列。假定扫描窗口中的最大丰度表示精确的调谐质量值。如果调谐质量覆盖了所关注的质量范围并且质量点的差值尽可能大，质量轴的校准效果最佳。允许的最小质量差异是 100 amu。

  • 要停止校准过程，请从 Tune（调谐）菜单中选择 Abort（异常中止）。

  • 要查看结果，请参见 Edit Parameters （编辑参数）面板中的质量增益和补偿数值（该面板在 AdjParam（调节参数）菜单中。也可以通过该面板进行质量轴校准。）

Mass #2 / Mass #3 Widths（质量 2 /质量 3 宽度）

将质谱峰宽校准至 0.5+/-0.06 amu（峰的半高宽）。这是缺省值。峰宽值打印在每个峰形上方。

  • 要更改峰宽，请使用 PWIDTHS 命令。

  • 要将峰宽调节至峰高 10% 处的值，请使用 PEAKPARM 命令。


最大化所有丰度

EM 电压和 X 射线电压可以影响所有质量的丰度。提高电子倍增器电压将在增强信号的同时增大噪音。应该使用能给出满意结果的最低电压。

X-射线电压(在 5973 MSD 中不使用)将离子加速至倍增器。最佳设定受电子倍增器设定的影响。因此，通常先设定电子倍增器电压。


优化高质量丰度

Entrance Lens（入射透镜）、Repeller（推斥极）和 Ion Focus（离子聚焦）均影响高质量丰度；对其进行反复调节。推斥极对改变高质量丰度比对低质量有效的多。

如果推斥极电压设定过低，则离开源的离子太少，使灵敏度和高质量响应降低。如果推斥极电压设定过高，太多的离子以较高的速率离开离子源。这可能出现前体（低质量过滤）、峰裂分和较低的低质量分辨率。


手动调谐概述

手动调谐是在保持合格的分辨率、精确的分辨率、确保精确的质量指认，并在整个质谱中保证理想的相对丰度的同时将灵敏度调到最大的反复过程。

在 Execute（执行）菜单中选择 Profile scan（图形扫描）和 Spectrum scan（谱图扫描），您可以监测峰形中三种调谐时的质量丰度。

使用 Ramp（梯度）菜单来定性检验当前参数设定是否为最优。如果您想改变其中的设定，请使用 AdjParam（调节参数）菜单。

利用 Calibrate（校准）来设定校准参数。Status（状态）菜单主要供经过公司培训的服务工程师使用。


调节参数菜单 — 调谐

AdjParam（调节参数）菜单可使您控制所有重要的质谱仪参数，同时在图形扫描和谱图中监测其影响。也可通过梯度变化电压和观察对三个调谐质量的影响对特定参数进行精细调谐。

Edit MS Params （编辑 MS 参数） | 显示 Edit Parameters（编辑参数）对话框。
Edit Acq Params （编辑采集参数） | 显示 Acquisition & Display（采集和显示）对话框。
Edit MS Temps （编辑 MS 温度） | 仅适用于 5973 MSD。显示 MS Zones（MS 区）对话框。
Select Data Filter （选择数据过滤器） | 仅适用于 5973 MSD。可把数据过滤器设定为标准或增强分辨率。增强分辨率过滤器在高质量（大于 500 amu ）处质谱峰检测更佳。
Masses （质量） | 提示输入三个调谐质量。


采集和显示参数 — 调谐

采集和显示参数

采集和显示参数控制图形扫描和谱图扫描数据的采集和显示。

Masses（质量）

Acquisition - Samples（采集 － 样品）

Acquisition - Averages（采集 － 平均值）

Acquisition - StepSize（采集 － 步长大小）

Acquisition - Threshold（采集 － 阈值）

Scan Range（扫描范围）

Profile Display（图形显示）

Masses（质量）

质量 1，质量 2和质量 3 是图形扫描中显示的三个质量（以 amu 为单位）。它们是调谐过程中使用的质量。设定全氟三丁基胺 (PFTBA) 为调谐的缺省化合物。在 Window 设定图形扫描窗口的大小；输入值（以 amu 为单位）是窗口宽度的一半。例如，如果窗口是 10 ，对m/z （质荷比）为 69 的图形扫描就从 59 到 79 amu 之间进行。值越小，图形扫描速度越快。最小值由 Acquisition - Step Size（采集 － 步长大小）决定。范围为 0.3 - 100 amu。

Acquisition - Samples 2^N（采集 － 样品 2^N）

使用该字段设定扫描样品数和图形扫描次数。输入 n 值（样品数等于 2^n）。允许值为 0 到 7。例如，输入 5 会为每一质量点输送 32 (2^5=32) 个样品，这样可以增强有噪音的信号或者小信号。建议对调谐和数据采集采用相同 n 值。

Acquisition - Averages（采集 － 平均值）

使用该字段设定每次扫描报告或显示中采取多少次图形扫描进行平均。允许值为 1 到 9。该数值越小，扫描速度越快。较高数值会降低调谐数据的采集速度，但有利于对小信号或有强噪音的信号进行调谐。缺省值为 1。

Acquisition - StepSize（采集 － 步长大小）

使用该字段设定图形扫描的质量步长大小。允许值为 0.05 到窗口当前值。该数值越大，扫描速度越快（以分辨率为代价）。该数值的范围为：0.05 - 100 amu。

Acquisition - Threshold（采集 － 阈值）

使用该字段设定峰检测阈值，决定哪些信号被认作峰。阈值越小，检测到的质谱峰越多。阈值越高，谱图越“干净”。典型阈值范围为 0 到 500。在每一 0.1 amu 的步长上，使用当前信号与前 4 个信号计算加权平均值。如果平均值大于阈值，当前信号被认作质谱峰并保存。

Scan Range（扫描范围）

用 From（起始）和 To（结束）设定扫描的质量 (amu) 范围。该数值范围为仪器的最大扫描范围。

Profile Display（图形显示）

用 Scale 设定图形扫描中 Y 轴的显示模式。对于 Autoset（自动设定）和 Relative（相对）选项，其数值由 Abundance（丰度）的设定控制。

用 Autoset（自动设定）将 Y 轴范围设为每个调谐质量的最小值到最大值。

用 Relative（相对）将 3 个调谐质量的 Y 轴最大值均设为同质量 1。

Fixed from/to（固定起/止）将 Y 轴设为指定的绝对数值。

Scale Factor（坐标设定因子）是 Y 轴的除数，也就是说丰度值应与该数值相乘。有用值为从 0.1 到 100。当 Scale（坐标设定） 被设置为 Fixed（固定）时该参数不可用。

用Abundance（丰度）控制调谐质量最大丰度的报告。如果选择 Absolute（绝对），将报告 3 个质量的丰度计数。如果选择 Percent（百分比），质量 2 和 3 会在报告中以百分比方式显示相对于质量 1 的丰度（以数值显示）。


编辑 MS 参数 — 调谐

5973 MSD

5972 / 6890


手动调谐菜单

File （文件） | 允许您进行各种文件管理和打印任务。
Tune （调谐） | 允许您运行自动调谐和设定调谐目标及调谐限制。
Execute （执行） | 允许您检查质谱分辨率和线形
Calibrate （校准） | 允许您校准质量坐标轴和丰度
Ramp （梯度） | 允许您梯度改变质谱参数。
AdjParam （调节参数） | 允许您设定和监测质谱参数。
Status （状态） | 允许您查看 MSD 的状态。
View （查看） | 允许您在 Top（顶部）、Instrument Control（仪器控制）、Data Analysis（数据分析）、Manual Tune（手动调谐）和 Diagnostics（诊断）这些视窗之间切换。
Abort （异常中止） | 异常中止当前进程。

参见

调谐命令


目标调谐

目标调谐包括使用 DFTPP Tune（DFTPP 调谐）、BFB Tune（BFB 调谐）或 Target Tune（目标调谐）对仪器进行调谐。这些菜单项从 Manual Tune（手动调谐）视窗中进入。目标调谐允许您对 MS 参数进行调节，以符合由 EPA（环境保护署）方法 624、625 或其他方法定义的相对丰度标准。

如何进行

BFB 调谐（EPA 方法 624）

DFTPP 调谐（EPA 方法 625）

目标调谐（其他方法）

设定调谐目标

参见

关于目标调谐

动态梯度变化

改进目标调谐结果

调谐命令

方法认证


BFB 调谐

BFB 调谐的设计可满足 EPA 方法 624 和其他使用 BFB 作为调谐化合物的方法的调谐要求。这种调谐使用调谐文件 BFB.U 中提供的目标相对丰度：

PFTBA 离子 | 相对含量 %
50 | 1
131 | 45
219 | 55
414 | 2.4
502 | 2

完成一次目标调谐后，仪器参数保存在 BFB.U 中。这个调谐文件应在使用该调谐参比化合物的分析采集方法中指定。

可通过加载和运行方法认证 BFB624.M 来实现成功的 BFB 调谐测试。

如果离子丰度未达到 EPA 标准，请参见改进目标调谐结果。


DFTPP 调谐

DFTPP 调谐旨在适应 EPA 方法 625 或其他使用 DFTPP 作为调谐化合物的分析的调谐要求。

DFTPP 调谐使用当前加载的调谐文件和调谐文件 DFTPP.U 中提供的目标物相对丰度。

PFTBA 离子 | 相对含量 %
50 | 1
131 | 45
219 | 55
414 | 2.4
502 | 2

这种调谐假设仪器已经被调谐到 PFTBA。一个 DFTPP 目标调谐完成后，仪器参数存储于调谐文件 DFTPP.U 中。

要检验调谐是否满足 DFTPP 标准，进样 DFTPP 并使用方法认证 DFTPP625.M 来运行样品。

如果离子丰度不满足 EPA 标准，请参见改进目标调谐结果。


目标调谐

该调谐使用 TARGETS.U 文件中提供的目标相对丰度。该文件中初始相对丰度的出厂设置为：

PFTBA 离子 | 相对含量 %
50 | 1
131 | 45
219 | 55
414 | 3.5
502 | 2.5

使用 Set Tune Targets（设定调谐目标）改变 PFTBA 目标质量的目标相对丰度，以达到所分析的调谐参比化合物的相对丰度。目标质量必须为 50、131、219、414 和 502 amu。

目标调谐完成后，仪器参数保存在 BFB.U 中。这个调谐文件应在使用该调谐参比化合物的分析采集方法中指定。


设定调谐目标

  1. 在 Manual Tune（手动调谐）视窗中选择 Tune / Set Tune Targets（调谐/设定调谐目标）。一个对话框为每个 PFTBA 目标质量（50、131、219、414 和 502 amu）提示目标物相对丰度,相对于m/z 69 的为 100%。

  2. 输入 ％ 数值以便要求的调谐参比化合物可以达到这一相对丰度。

  3. 单击 OK（确定）。


关于目标调谐

目标调谐包括使用 DFTPP 调谐、BFB 调谐、或者目标调谐对仪器进行调谐。调谐结果保存在对应于特定仪器的调谐文件（分别为 DFTPP.U、BFB.U、或 TARGET.U）中。在运行目标调谐方法前必须先运行目标调谐：只有在正确的调谐文件 (DFTPP.U) 已经存在时才能运行目标调谐方法（例如 DFTPP625.M）。

然后使用适当的采集方法（例如 DFTPP625.M）和相应的调谐化合物 (DFTPP) 来测试样品。该方法会打印出一份报告，详细说明仪器是否通过 DFTPP 标准。如果未通过，可以修改调谐目标然后重试。

在目标调谐中，一些仪器参数会通过系统调节来达到所需比例。

另见

动态梯度变化


动态梯度变化

动态梯度变化允许改变质量范围内选定点的入射透镜补偿的电压。其结果是改变选定质量的丰度。

选择 Ramp / Edit Dynamic Lens Ramping（梯度/编辑动态透镜梯度变化）后，一个对话框会提示设定在 m/z 50、69、131、219、414 和 502 的入射透镜补偿。如果目标调谐结果指示您想要增加特定离子的丰度，增加电压。要降低丰度，降低电压。

设定好变化值后，单击 OK（确定）。Dynamic Ramping（动态梯度变化）现在被激活。注意 Edit Parameters（编辑参数）面板中的 EntOffs 设定会成为 VAR，并且直到选择 Ramp / Disable Dynamic Lens Ramping（梯度/禁用动态透镜梯度变化）前不能改变。

要观察动态梯度变化的效果，在菜单中选择 Execute / Spectrum scan（执行/光谱扫描）。如果结果是所需的，确认以保存调谐文件。或者可以选择 File / Generate Report（文件/生成报告）。


改善目标调谐结果

如果调谐结果未达到 EPA 标准或用于分析的调谐标准，加载合适的调谐文件，bfb.u、dftpp.u 或 target.u，然后选择 Set Tune Targets（设置调谐目标）。（您可能希望以另一个名字保存原来的 .U 文件，如 bfbold.u，因为该过程将改变文件中的值。）

提高相对丰度

  • 提高相应 PFTBA 离子的目标比；或

  • 降低所有其他调谐离子的目标比

降低相对丰度

  • 降低相应 PFTBA 离子的目标比；或

  • 提高所有其他调谐离子的目标比

保存新的调谐值。然后通过选择合适的目标调谐（DFTPP Tune（DFTPP 调谐），BFB Tune（BFB 调谐）或 Target Tune（目标调谐））调谐到新的目标化合物。注入样品（例如 DFTPP），采集数据，再次将结果与标准比较。这可能是个反复的过程，但一般只需要一两次。


方法认证

两种 EPA（环境保护代理）方法，DFTPP625.M 和 BFB624.M，包括在软件中用于检验 DFTPP 和 BFB 调谐。

这些方法提供采集和数据分析参数来运行 DFTPP 或 BFB 分析和生成报告显示质谱和质量相对丰度表。使用这些方法前，采集参数应该编辑为适于系统的值。

由 Data Analysis（数据分析）产生的报告由方法的 DEUSER.MAC 文件中的宏控制。宏 init_parms 指定报告标题、基峰和比较次数。宏 print_ratios 包含用于每个质量的命令行来指定目标质量、比较质量和低限及高限。


CI 调谐 - 5973 MSD

CI Tune（CI 调谐）视窗从 Instrument Control（仪器控制）中的 Instrument / Perform MS Autotune（仪器/执行 MS 自动调谐）菜单项进入。CI 调谐允许您调节化学电离 (CI) 模式（仅在配备有化学电离附件的 MSD 中有效）操作中的 MS 参数。有关化学电离和 CI 调谐的正确安装，请参见 CI 硬件手册。

如何

设置 CI 调谐

CI 调谐

设定并监测反应物和校准物质量，吹扫校准阀

参见

CI 调谐菜单


设定 CI 调谐（5973 MSD）

设定 CI 调谐

仅适用于为 CI 配置的 5973 MSD。

  1. 从 Instrument Control（仪器控制）视窗中选择 Instrument / Select MS Tune File（仪器/选择 MS 调谐文件）。

  2. 选择一个 CI 调谐文件（例如 pcitune.u 或 ncitune.u）。

  3. 保存方法。

  4. 选择 View / Manual Tune（查看/手动调谐）进入 CI 模式的 Manual Tune（手动调谐）视窗。

  5. 将会询问您是否要经历所有的设定菜单项。单击 Yes（是）确认设定或改变。一系列可以用于设定 CI 调谐的对话框将被显示出来。

  • 选择要使用的 CI 反应气并单击 OK（确定）。

  • 选择要使用的调谐极值（或使用缺省值）并单击 OK（确定）。所有这些参数根据特定的反应气和离子化模式被优化，请参见 PFDTD 校准物。它们可能需要根据正在分析的特定化合物而调整。

  • 输入要使用的反应离子质量（或使用缺省值）并单击 OK（确定）。该面板仅用于 PCI，因为在 NCI 中，没有可见的反应离子。在 NCI 中用于预调谐的离子为 m/z 17 (OH-)、m/z 35 (Cl-) 和 m/z 235 (ReO-)；没有对 NCI 有效的流量调节。

  • 输入要使用的调谐离子质量（或使用缺省值）并单击 OK（确定）。该面板仅对甲烷 PCI 有效，由于异丁烷和氨不能产生正的 PFDTD 离子。

  • 选择基本调谐梯度质量并单击OK（确定）。这个质量将被自动调谐优化。

将被引导通过 CI 调谐过程的其余部分。您也可通过选择合适的菜单项单独访问设定对话框。

另见

设定菜单 － CI 调谐


调谐菜单 — CI 调谐 (5973 MSD)

调谐菜单 — CI 调谐

CI Autotune（CI 自动调谐）

使用 PFDTD 化合物以甲烷为反应气进行自动调谐。结果调谐参数存储在调谐文件 pcitune.u 或 ncitune.u 中（取决于选择的离子极性）。


调节参数菜单 － CI 调谐 (5973 MSD)

调节参数菜单 - CI 调谐

仅适用于为 CI 配置的 5973 MSD。AdjParam（调节参数）菜单可使您控制所有重要的 MSD 参数，同时在图形扫描和谱图中监测其影响。也可通过梯度变化电压和观察对三个调谐质量的影响对特定参数进行精细调谐。

Edit MS Params （编辑 MS 参数） | 显示 Edit Parameters（编辑参数）对话框。
Edit Acq Params （编辑采集参数） | 显示 Acquisition & Display（采集和显示）对话框。
Edit MS Temps （编辑 MS 温度） | 显示 MS Zones（MS 区）对话框。
Select Data Filter （选择数据过滤器） | 可把数据过滤器设定为标准或增强分辨率。增强分辨率过滤器在高质量（大于 500 amu）处质谱峰检测更佳。
Purge Cal Valve （吹扫校准阀） | 吹扫 PFDTD 校准阀和空气瓶。仅在初次安装时使用。


CI 调谐菜单 (5973 MSD)

File （文件） | 允许您执行多种文件管理和打印任务。
Setup （设置） | 允许您设置 CI 调谐。
Tune （调谐） | 允许您执行 CI 自动调谐和快速调谐。
Execute （执行） | 允许您检查质谱分辨率和线形。
Calibrate （校准） | 允许您校准质量轴和丰度。
RampParam （梯度参数） | 允许您梯度设定质谱仪参数。
AdjParam （调节参数） | 允许您设定和监测反应物和校准物质量，吹扫校准阀。
Status （状态） | 允许您查看 MSD 的状态。
View （视图） | 允许您切换到另一个化学工作站视窗。
Abort （异常中止） | 异常中止当前过程。

另见

调谐命令


调谐命令和函数

下列命令可用于调谐质谱仪。请注意，函数包括一个紧随函数名之后的括号( )中的值。在命令中，可选的参数显示在方括号 [ ] 中。获取有关特定命令的更多信息，请单击其名称。

另见 | 输入命令
 | 仪器控制命令

用命令设置的变量都在相关命令的描述中列出。

ABUNDANCE [低目标] [,高目标]

AVERAGES [当前值的变量] [,新值]

AXIS [质量]

BUFSIZE [当前值的变量][,新值]

CAL_VALVE [当前值的变量] [,新值]

CALVALVE [当前值的变量] [,新值][,通知]

CAPTURE [质量] [,记数] [,"文件名"]

DISPPRINT [x] [,y] [,cx] [,cy] [,继续] [,延迟]

DYNAMIC

EDDISP

EDITFILEINFO [运行信息]

EDPARMS

EDRAMP

EDZONE

ENDJOB

FILTERM [类型变量] [,类型] [,参数变量] [,过滤器参数]

FINDBIT 值，位编号[,位值变量]

FINDMASS 低质量[,高质量] [,质量值的变量] [,丰度值的变量] [,未扩展的范围]

FRESHTUNE

GCLEAR

GDISPLAY [1/0]

GETCONFIG ["文件名"] [,延迟发送]

GETMSFAULT ( )

IOTEST [屏幕显示] [,继续]

INSTRPARM()

LOGDATA [当前值的变量] [,保存]

LSTSQFIT 数据矩阵，[m], [n]

MASS [质量 1] [,质量 2] [,质量 3] [,设置变量]

MASSES [质量 1] [,质量 2] [,质量 3] [,设置变量]

MASSFACTOR [比例因子]

MASSGAIN [当前值的变量] [,新值]

MASSOFFSET [当前值的变量] [,新值]

MASSWINDOW [尺寸]

MATTOFILE 数组名称，"文件名"

MAXSCANRNG ( )

MENUSTATE（菜单项编号）

MSBUILD #文件编号, y1, y2, y3, y4, y5

MSCHECK [变量]

MSCLOSE #文件编号

MSCREATE ["文件名"] [,变量]

MSOFF

MSON

MSOPEN "文件名" [FOR OUTPUT] AS #文件编号

MSPARM 参数 [,当前值的变量] [,新值]

MSPARMINFO 关键字 [,启用的变量] [,下限的变量] [,上限的变量], [,分辨率变量]

MSPRINT [y] [,继续] [,延迟]

MSSNAP #文件编号

MSTATUS [变量]

MSTEMP SOURCE / QUAD [,实际] [,当前设定值] [,新设定值] [,当前极限] [,新极限]

MSWRITE #文件编号

OPTIM ["文件名"] [,使用 cp 变量] [,使用当前 MS 值] [,读/写]

PAGESIZE [x 的变量][,y 的变量]

PEAKPARM[当前类型的变量] [,新类型] [,当前 % 的变量] [,新 %]

PICKTUNEFILE

PROFILE [控制]

PROFPARM PW / SHOWABUND [,当前值的变量] [,新值]

PWIDTHS [目标] [,范围] [,协议] [,% 宽度] [,设置变量]

RAMPSMOOTH [当前值的变量] [,新值的变量]

SAMPLES [当前值的变量] [,新值]

SAVECONFIG ["文件名"]

SC [低质量] [,高质量] [,样本] [,阈值] [,清除显示]

SCALEMODE [模式] [,最小] [,最大] [,进行扫描]

SCAN [低质量] [,高质量] [,样本] [,阈值] [,清除显示]

SCANPARM 参数 [,当前值的变量] [,新值] [,当前间隙的变量] [,新间隙]

SCANPRINT [当前值的变量] [,新值]

SCINIT [1/0]

SCIOINIT

SETCIACTIVE 开/关

SETRAMP [参数] [,开始] [,停止] [,步长]

SETRFPA [质量]

SETTHRESH 关键字 [,质量编号] [,当前值的变量] [,新值]

SETUSER 索引 [,变量] [,新值]

SIMACQ [停留] [,离子 1] [,离子 2] [...] [,离子 30]

SIMRAMP 参数 [,质量编号] [,优化] [,未优化] [,停留时间] [,用户选择]

STARTJOB ["作业描述"]

STEPSIZE [当前值的变量] [,新值]

STRPRINT "字符串" [,x] [,y] [,继续] [,延迟]

TEMPEQUIL

THRESHOLD [质量编号] [,循环] [,调整推斥极] [,调整轴]

TRACE ["文件名"] [,附加]

VACUUM [STATUS/VENT/PUMPDOWN]

WAIT [秒] [,"注释"]

WIDTHS [循环] [,质量编号]

WINDDISP "字符串 1" [,值] [,"字符串 2"] [,x] [,y]

XFER 操作代码 [,数据] [,变量名称] [,循环]

XFR 操作代码 [,数据] [,变量名称] [,循环]


常见症状

这部分说明首次打开 GC/MS 系统时可能观察到的症状。所有这些症状都会妨碍系统的运行。

GC 没有打开

MSD 没有打开

前级泵没有工作

高真空泵冷却风扇没有工作

MSD 开启但状态 LED 均在闪烁


GC 没有打开

指 GC 打开时没有什么发生的情况。GC 风扇没有打开且键盘显示区没有亮。

CG 电源线未连接

确认 GC 电源线连接到适当的电源插座上。

电源插座没有电压或电压不合适

确认有电且电压对于 GC 合适。

警告！只有经过训练的电工可以检查电源插座。

GC 中保险丝故障

请参见与 GC 一起提供的用户信息，或与安捷伦科技公司维修代表处联系。

GC 电源工作异常

请与安捷伦科技公司维修代表处联系。


MSD 没有打开

这是指 MSD 开启时没发生什么情况。前级泵没有启动。高真空泵的冷却风扇没有打开。MSD 前面的状态 LED 没有亮。

MSD 电源线断开连接

确认它连接到正确的电源插座上。

电源插座没有电压或电压不正确

确认电源有电且对于 MSD 电压正确。

警告！只有训练过的电工可以检查电源插座。

主要保险丝故障

检查主要保险丝，必要的话进行更换。有关更换主要保险丝的说明，请参见 MSD 硬件手册。主要保险丝故障通常是一个较严重问题的症状。如果主要保险丝重复出现故障，请与安捷伦科技公司维修代表处联系。

警告！主要保险丝带有高压。在检查或更换主要保险丝前放空 MSD 并断开从电源插座的 MSD 电源线连接。

MSD 电路工作异常

请与安捷伦科技公司维修代表处联系。


前级泵未工作

这是指 MSD 有电（风扇运转且状态显示灯中的电源 LED 亮着）但前级泵没有工作的情况。

前级泵电源线未连接

确认前级泵电源线可靠地连接到 MSD 背面的插槽中。

前级泵故障

请与安捷伦科技公司维修代表处联系。


高真空泵冷却风扇没有工作

这指示 MSD 开启（至少前级泵在工作）但高真空泵风扇没有工作的状况。可以通过听声或把手放在靠近仪器前端的通风槽来确定。您应该能够感觉到鼓入 MSD 的空气流。

如果发生这种现象，首先关闭 MSD。等待一分钟然后再开启 MSD。如果风扇仍然没有工作，检查下列各项：

风扇电缆未连接

高真空信号电缆未连接

风扇故障

5973 MSD 在电路模块中包含一个辅助风扇。这个风扇是否正确工作更难断定。这个电路模块风扇用户是不能维修的。

风扇电缆未连接

  1. 移去上下的 MSD 顶罩。

    警告！不要移去任何其他顶罩。移去其他顶罩可能有危险高电压。

  2. 确认风扇电缆与 MSD 外框上的连接器牢固连接。

高真空信号电缆未连接

确认高真空信号 (HIVAC SIGNAL) 电缆牢固连接到 MSD 的后面板。如果电缆没有连接，高真空泵不会开启。

风扇故障

  1. 将 MSD 放空。

  2. 移去上下的 MSD 顶罩。

    警告！不要移去其他顶罩。移去其他顶罩可能有危险高压。

  3. 断开风扇电缆。

  4. 确认风扇叶片自由、平滑和安静地旋转。风扇转动时轴承损坏会发出噪音或转动猛烈。

  5. 如果风扇已坏，更换风扇。

有关更换高真空泵风扇的说明，请参见 MSD 硬件手册。


MSD 开启但所有状态 LED 都在闪烁

MSD 刚打开时这是很正常的。状态灯会一直闪烁直到数据系统软件已启动或抽气循环已经初始化。然后数据系统将仪器控制软件下载到 GPIB/MS 控制卡。这时，所有状态 LED 都亮起几秒钟然后开始正常工作，留下电源 LED 亮着而其他熄灭。如果 LED 没有停止闪烁，原因可能是下面其中的一项：

断电中断通讯

MSD 的突然断电可能中断 MSD 和数据系统之间的通讯。这会导致状态 LED 闪烁。较长的中断会使 MSD 关闭。电源恢复后，MSD 自动抽气但通讯不会自动建立以致状态 LED 将会闪烁。重新初始化 MSD 与数据系统之间的通讯。

软件故障

软件故障可能中断 MSD 和数据系统之间的通讯。这会导致状态 LED 闪烁。重新初始化 MSD 与数据系统之间的通讯。

MSD 与数据系统之间的连接不良

  1. 确认 GPIB 电缆连接在 MSD 与数据系统之间。

  2. 确认 GPIB 电缆在两端可靠地连接。

  3. 必要的话，清洁连接器导线或拧紧连接器螺丝。

  4. 如果这样不能解决问题，更换 GPIB 电缆。

  5. 重新初始化 MSD 与数据系统之间的通讯。

MSD 电路工作异常

请与安捷伦科技公司维修代表处联系。


色谱症状

这一节说明在数据采集生成的色谱图中可能观察到的症状。一般来说，这些症状不会妨碍您操作 GC/MSD 系统。然而，它们表明您获得的数据可能不是可以得到的最佳数据。这些症状可由仪器故障引起，但更可能是由于不正确的色谱技术所造成的。

无峰 | 高基线
峰拖尾 | 基线上升
峰前伸 | 基线下降
峰顶部分裂 | 基线漂移
峰顶平直 | 保留时间漂移

下列两个症状同时见于色谱症状和质谱症状：

灵敏度低

重复性降低


没有色谱峰

如果一次分析中没有出现色谱峰，只有水平基线和小的噪音，请运行自动调谐。如果 MSD 合格，则故障很可能与 GC 有关。检查 Passes tune（通过调谐）下所列的可能原因。如果 MSD 不合格，则故障很可能与 MSD 有关。检查 Does not pass tune（未通过调谐）下所列的可能原因。

通过调谐

未通过调谐


峰拖尾

如果分析显示显著的拖尾峰，原因可能是下列项目之一：

样品流路中有活化点

进样量过大

进样口温度不正确

色谱柱流量不足

GC/MSD 接口温度过低

离子源温度过低


谱峰前伸

如果分析显示谱峰不对称，当谱峰顶部偏向右侧然后陡然下降，检查下列可能原因。这一症状最可能与不分流进样有关。这有时也称为过载因为这经常是由于使衬管和色谱柱过载的大量进样引起。

色谱柱膜厚与被分析物浓度不匹配（色谱柱过载）

初始柱箱温度过低

样品流路中有活化点

进样量过大

进样口温度过高

色谱柱流量不足


峰顶分叉

如果分析显示峰顶分叉，检查下列项目：

进样技术不良

进样量过大


峰有平顶

如果分析显示峰有平顶，检查下列项目：

溶剂延迟过短

显示坐标不正确

进样量过大

电子倍增器电压过高


基线过高

如果某次分析中基线反常过高，请检查是否出现色谱柱流失或其他污染。

色谱柱流失

其他污染

电子倍增器电压过高


基线上升

如果某次分析中基线上升，请检查是否出现色谱柱流失或其他污染。

色谱柱流失

其他污染


基线下降

基线下降表明某些污染源正在被清除。等待至基线达到合格水平。常见原因包括：

色谱柱流失

隔垫流失

残留水或溶剂

不分流进样时间过长


基线漂移

如果某次分析中基线不水平而是漂移的（上升和下降），很可能是由载气故障引起的。

载气供给不足

流量或压力调节器出现故障

进样口处的断续泄漏

这些很可能使 GC 出现故障而不能正常操作。


保留时间漂移（所有峰）

它指的是所有峰的保留时间都延长或缩短。

保留时间缩短

保留时间延长


灵敏度低

如果灵敏度低于预期值，检查下列可能原因：

调谐不正确

调谐文件与分析类型不匹配

推斥极电压过低

温度异常

样品浓度不正确

进样口泄漏

分流比不正确

不分流模式的吹扫关闭时间过短

MSD 压力超出警戒

脏离子源

MSD 中空气泄漏

检测器工作异常

灯丝工作不良

质量过滤器极性不正确


重复性差

注射器针头脏

进样口泄漏

进样口衬管和进样量不匹配

色谱柱连接松动

压力、色谱柱流量和温度差异

脏离子源

分析器中连接松动

地循环电流


质谱症状

这部分讲述在质谱中可能观察到的症状。部分症状会出现在样品的质谱中。其他的只能在调谐报告中观察到。其中一些症状的成因可以由操作人员来纠正。但是其他症状则需要由安捷伦公司维修代表处进行维修。

同位素丢失或同位素比例不正确

高本底

m/z 18、28、32 和 44 或 m/z 14 和 16 处的峰

质量指认不正确

峰有前体

峰宽不一致

m/z 502 的相对丰度小于 3%

高质量灵敏度低

一些色谱症状也见于质谱：

灵敏度低

重复性差


同位素丢失或同位素比不正确）

自动调谐报告 PFTBA 离子比。如果 MSD 未通过这部分调谐，请勿采集数据。检查下列情况：

峰过宽或过窄故障

高扫描速度（扫描模式）

低停留时间（SIM 模式）

电子倍增器电压过高

推斥极电压过高

高本底

脏离子源


高本底

本底是指 MSD 中没有样品情况下的所有物质的质谱。进样后，质谱就成为本底光谱和样品光谱的加和。新的或刚放空过的 MSD 一般有许多本底峰。这会随着时间降低。给 MSD 充分时间降压。确认离子源、质量过滤器（四极杆）和 GC/MSD 接口加热器开启并处在通常工作设定值。如果高本底在真空下存在超过一天，检查下列各项：

真空多路连接管压力过高

空气泄漏

污染


m/z 18、28、32 和 44 或 m/z 14 和 16 处的峰

处于 m/z 18，28，32 和 44 的峰是 MSD 有空气泄漏时的典型峰。m/z 14 和 16 的大峰是非常大的峰的症状。

在这些质量的小峰是正常的，尤其是如果 MSD 最近刚放空过。如果这些峰变大或干扰了分析，请检查调谐报告。调谐报告比较 m/z 18（水）和 m/z 28（空气）的丰度与m/z 69 (PFTBA) 的丰度之比。如果调谐报告中的比例不可接受（m/z 18 > m/z 69 的 10%），等待几个小时然后重新调谐。如果比例仍然不可接受且没有降低，检查空气泄漏。

另见

空气泄漏


质量指认不正确

质谱峰顶部的小的形状改变可能导致质量指认 0.1 amu 的偏移。大于 0.2 amu 的偏移说明可能有故障。检查下列各项：

MSD 没有足够时间达到热平衡

实验室温度大幅度波动

MSD 最近未调谐

不正确的调谐文件


峰有前体

调谐报告列出调谐报告前体的大小。小的前体很正常。对于可接受和不可接受前体大小没有指定。如果对于您的应用，前体过大而不可接受，原因可能是下列之一：

推斥极电压过高

谱峰过宽


峰宽不一致

不一致的峰宽在调谐报告中是最显而易见的。如果 MSD 不能通过调谐则不要采集数据。可能的原因包括：

不正确的调谐

MSD 没有足够时间达到热平衡

实验室温度波动过大

校准瓶为空或几乎为空

校准阀工作异常

电子倍增器接近使用寿命限期

脏离子源

地循环电流


m/z 502 的相对丰度小于 3%

自动调谐应给出 m/z 502 的相对丰度大于 3%。然而 m/z 502 的相对丰度可能变化很大，这依赖于色谱柱流量、离子源温度和其他因素。只要相对丰度高于 3%，相对丰度的稳定性比其绝对值更重要。如果对于固定一组操作参数观察到 m/z 502 相对丰度的显著改变，则可能存在故障。MSD 化学工作站软件中的 View tunes（查看调谐）选项用于识别出现的变化。

m/z 502 的低相对丰度不应与在高质量处的低绝对丰度相混淆。在高质量处的灵敏度可以极佳尽管 m/z 502 的相对丰度接近 3%。如果您的仪器在高质量处产生低的绝对丰度，请参见症状高质量灵敏度差。如果绝对丰度可以接受但相对丰度显示出有问题，请检查下列情况：

错误的调谐程序

MSD 预热和抽真空时间不足

真空多路连接管压力过高

离子源温度过高

色谱柱流量过高

灯丝操作差

脏离子源

四极杆质量过滤器的直流极性不正确


高质量灵敏度低

这是指高质量范围内的绝对丰度低的情况。绝对丰度不应该和 m/z 502 到 m/z 69 的相对丰度（百分比）混淆。即使 m/z 502 的相对丰度低，高质量灵敏度仍可以非常好。

如果 MSD 的相对丰度对于使用的调谐程序不正确，请参见症状 m/z502 的相对丰度小于 3%。如果相对丰度正确但高质量绝对丰度低，请检查下列各项：

错误的调谐程序

错误的调谐文件

用于 MSD 预热和抽气的时间不足

真空多路连接管压力过高

色谱柱流量太大

灯丝工作不良

脏离子源

四极杆质量过滤器的直流极性不正确


压力症状

这部分说明了异常压力读数及其可能的原因。这里所说的症状基于典型压力。在典型色谱柱流速（0.1 - 2.0 ml/minute）下，前级压力近似为 20 至 100 mTorr。真空多路连接管的压力近似为1 x 10^-6 至 1.4 x 10^-4 Torr。仪器之间的压力会差别很大，因此熟悉在给定载气流量下的仪器典型压力是非常重要的。

列出的前级压力只能在配备扩散泵的系统中进行测量。涡轮分子泵由速度控制，没有前级压力表。只有在系统配备有可选的真空规控制器时，才能测量真空多路连接管压力。

载气报警声

前级压力过高

真空多路连接管压力过高

前级压力过低

真空多路连接管压力过低

真空规控制器显示 9.9+9 然后变黑

真空规控制器的电源指示灯不亮


载气报警声音

如果载气或加热区出现故障，GC 会发出嘟嘟的报警声。

如果载气压力过低从而不能保持当前气流设定值，会发出 1 到 2 分钟的嘟嘟报警声。之后如果压力仍然过低，GC 加热区关闭，色谱柱气流停止。GC 显示屏上会出现一条提示。

如果 GC 被配置为使用氢气作载气，整个 GC 将关机，嘟嘟的警报声将一直持续到您按下 [Clear]（清除）键为止。

在无载气流的情况下加热色谱柱会损坏色谱柱。这种情况最可能发生在进口和 GC/MSD 接口内的色谱柱末端。载气流出现故障时如果柱箱过热，整个色谱柱可被损坏。导致氧气进入色谱柱的泄漏问题也会损坏色谱柱。

如果怀疑色谱柱损坏，请更换色谱柱或取出色谱柱截断其末端后重新装入。如果色谱柱曾经被老化过，则不必再次进行老化。

载气警报的可能原因包括：

载气供给压力过低

载气管线泄漏

载气管线堵塞

GC 故障


前级压力过高

在通常色谱柱流速下 (0.1 - 2.0 ml/min)，前级压力大致为 20 - 100 mTorr。如果前级压力比 100 Torr 高出很多，或观察到的给定色谱柱流量的压力已增加超过时间，原因可能是下面之一：

色谱柱流量过高

空气泄漏

前级泵油位过低或油被污染

前级管过紧

前级真空规工作异常

前级泵工作异常


真空多路连接管压力过高

真空多路连接管压力只有 MSD 配备了可选的真空规控制器才能测量。在典型色谱柱流速 (0.1 – 2.0 ml/min) 下，真空多路连接管压力近似 1 x 10^-6 至 1.4 x 10^-4 Torr。如果观察到的压力明显高于 1.4 x 10^-4 Torr，或观察到的给定色谱柱流的压力已增加超过时间，检查下面各项：

色谱柱流量过高

空气泄漏

前级泵油位过低或油被污染

前级管过紧

扩散泵油位过低或油被污染

扩散泵工作异常

涡轮分子泵工作异常

另见

前级压力过高


前级压力过低

前级压力只能在安装了扩散泵的 MSD 上被测量。在通常色谱柱流速下（0.1 - 2.0 ml/min），前级压力大致为 20 - 100 mTorr。如果前级压力低于 20 mTorr，检查下列各项：

没有足够色谱柱流量

色谱柱堵塞或因螺帽过紧而碎裂

没有或载气供给不足*

载气管过紧*

前级真空规工作异常

* 这可能产生一个使 GC 不能工作的故障情况。


真空多路连接管压力过低

真空多路连接管压力只有 MSD 配备了可选的真空规控制器才能测量。在典型色谱柱流速 (0.1 – 2.0 ml/min) 下，真空多路连接管压力近似 1 x 10^-6 至 1.4 x 10^-4 Torr。如果观察到的压力低于 1 x 10^-6 Torr，检查下列各项：

色谱柱流量不足

色谱柱堵塞或因螺帽过紧而碎裂

空载气供给或载气供给不足*

载气气路管过紧*

*这些可能在 GC 中产生的，会妨碍 GC 正常工作的故障情况。


真空规控制器显示 9.9+9 然后变黑

这可能会发生在当您试图开启三级真空规或三级真空规已经开启时。说明真空多路连接管中压力在 8 × 10^-3 Torr 以上。如果压力在这个标准以上时三级真空规不会开启。当压力上升到 8 × 10^-3 Torr 时它会自动关闭。

柱头进样引起的溶剂峰

MSD 没有足够时间抽气

前级压力过高

三级真空规和真空规控制器之间连接不良或电缆损坏

扩散泵油位过低

三级真空规管工作异常

电源电压过低


真空规控制器的电源指示灯不亮

如果打开电源开关后，真空规控制器上的电源指示灯 (LED) 不亮，请检查下列各项：

真空规控制器电源线没有插上

插座的电源电压不正确或不合适

真空规控制器保险丝故障


温度症状

MSD 有三个加热区：

  • 离子源（MSD 化学工作站软件中的源或 MS 源）

  • 质量过滤器（MSD 化学工作站软件中的四极杆或 MS 四极杆）

  • GC/MSD 接口（MSD 化学工作站软件中的热辅助通道 2）

每个加热区均有一个加热器卡套和温度传感器。离子源和质量过滤器加热器由 MSD 供电并控制。GC/MSD 接口由 GC 供电并控制。

离子源不能升温

质量过滤器（四极杆）加热器不能升温

GC/MSD 接口不能升温


离子源不加热

这是指离子源根本不加热或虽然加热但未达到其设定值的情况。离子源通常需要 10 - 20 分钟达到其设定值*。如果在此之后，离子源未加热或未达到其设定值，请检查下列情况：

高真空泵关闭或未达到标准操作条件

不正确的设定值

MSD 电路工作异常

其他可能的原因有离子源加热器或传感器断路、短路或连接故障。所有这些都会生成下列故障提示：

温度控制故障

注意在所有加热区达到它们的设定值后，MSD 至少需要 2 小时才能达到热平衡。在 MSD 达到热平衡以前获得的数据不是可重复的。


质量过滤器（四极杆）加热器不能加热

这是指质量过滤器根本不能加热或加热达不到设定值的情况。质量过滤器通常需要 10 - 20 分钟来达到其设定值*：如果经过这段时间后，质量过滤器还没有加热或没有达到设定值，检查下列各项：

高真空泵关闭或没有达到正常工作条件

不正确的设定值

MSD 电路工作异常

其他可能的原因是加热器或传感器断开连接、短路或有连接故障。所有这些都会产生下列故障提示：

Temperature control fault（温度控制故障）

注意 所有加热区都达到使 MSD 达到热平衡的设定值最少需要 2 小时。在 MSD 处热平衡前采集的数据可能无法重现。


GC/MSD 接口不加热

GC/MSD 温度通常通过 GC 的 Thermal Aux 2 加热区来控制。GC 会产生一个提示说明加热区未就绪直到加热区达到设定值 +/- 1 度并将该设定值保持 30 秒。通常需要 10 - 20 分钟让 GC/MSD 接口达到设定值*。如果经过这段时间后系统指示加热器仍未就绪，检查下列项目：

不正确的设定值

设定值被输入错误的加热区

GC 电路工作异常

其他可能的原因是加热器或传感器未连接、短路或有连接故障。如果 GC/MSD 接口电缆从 GC 断开连接，加载方法时会产生一个警告，指出由于指定加热区不可用因而使得 GC 设置改变。如果加热器或传感器被短路或打开，GC 会产生故障或适当的警告消息。

注意：最少需要 2 小时来使所有加热区都达到让 MSD 达热平衡的设定值。在 MSD 处于热平衡前采集的数据可能不具有重现性。


故障提示

有时，MSD 中的问题将导致一个故障提示出现在 MSD 化学工作站软件中。一些故障提示仅出现在调谐过程中。其他故障提示出现在调谐或数据采集过程中。有时候仅有一个数字而不是故障提示出现。该数字代表一个或更多故障提示。将一个数字翻译成一个故障提示或提示：

  1. 记录该数字。

  2. 从 View（查看）菜单中选择 Diagnostics/Vacuum Control（诊断/真空控制）。

  3. 从 Status（状态）菜单中选择 MS Error Codes（MS 故障代码）。

  4. 键入故障号并按下 Enter（回车）。

将出现相应故障提示。

一些故障提示被“锁定”。这些提示在数据系统中保持有效，甚至在引起这些故障的原因已经消除后仍然有效。如果原因已被消除，这些故障提示可通过查看数据系统中的仪器状态消除。

质量过滤器电路故障

电子倍增器电源故障

风扇故障

HED 供压故障

高真空泵故障

前级压力超过 300 mTorr

内部 MS 通讯故障

透镜供压故障

对数放大器 ADC 故障

无峰

温度控制失效

温度控制故障

高真空泵未就绪

系统准备中

系统处于放空状态（高真空泵关闭）

无发射电流

无足够信号开始调谐


质量过滤器电路的故障

真空多路连接管压力过高

RFPA 没有正确调节

质量过滤器（四极杆）触点短路或工作异常

质量过滤器工作异常

MSD 电路工作异常


电子倍增器源的故障

大峰如溶剂峰在分析器开启状态下被洗脱

真空多路连接管压力过高

MSD 电路工作异常


风扇故障

如果冷却风扇出现故障，真空控制电路会自动关闭高真空泵。因此，提示：系统处于放空状态（高真空泵关闭）也会出现。这一次要提示的重要部分是高真空泵已关闭。实际上真空多路连接管可以不放空。

风扇未连接或有连接故障

MSD 电路工作异常


HED 源的故障

大峰（如溶剂峰）在分析器开启状态下被洗脱

真空多路连接管压力过高

HED 高压导线与地短路

检测器工作异常

MSD 电路工作异常


高真空泵的故障

如果您的 MSD 配备了扩散泵，这表示扩散泵过热。如果您的 MSD 配备了涡轮分子泵，这表示涡轮分子泵控制器在预设时间内不能达到全速的 50％或出现了其他故障。

扩散泵

高真空泵冷却风扇不工作

通向冷却风扇的进气口被堵塞

实验室温度过高（通常高于 35°C)

扩散泵油位过低

高真空信号电缆未连接或工作异常

扩散泵温度传感器工作异常

MSD 电路工作异常

涡轮分子泵

大的空气泄漏使涡轮分子泵无法达到全速的 50％

前级泵工作异常

高真空信号电缆未正确连接

涡轮分子泵控制器工作异常

涡轮泵工作异常

MSD 电路工作异常


前级压力超过 300 mTorr

只有配备了扩散泵的 MSD 才有前级压力表。

载气流量超过警戒

空气泄漏

前级真空规工作异常

前级泵工作异常


内部 MS 通讯故障

MSD 电路工作异常。请与您的安捷伦科技公司维修代表处代表联系。


透镜供压故障

分析器中电路短路

MSD 电路工作异常


记录放大器 ADC 故障

MSD 电路工作异常请与您的安捷伦科技公司维修代表处代表联系。


没有发现峰

阈设置得过高

发射电流设置为 0

电子倍增器电压过低

AMU 增益或补偿过高


温度控制失灵

一根加热保险丝出现故障

MSD 电路工作异常


温度控制故障

这表示离子源或质量过滤器（四极杆）的加热器的温度控制出现故障。故障原因可以通过在 Diagnostic/Vacuum Control（诊断/真空控制）视窗的 Status（状态）菜单中选择 MS Temp Ctlr Status（MS 温度控制状态）进行进一步分析。下列内容之一应显示为故障原因：

离子源温度传感器断开

离子源温度传感器短路

质量过滤器（四极杆）的温度传感器断开

质量过滤器（四极杆）的温度传感器短路

加热器未通电

加热器电压过低

温度区暂停

温度控制电路工作异常（HC11 故障）


高真空泵未就绪

扩散泵虽然启动，但没有足够的时间达到正常的操作温度

涡轮分子泵虽然启动，但没有足够的时间达到正常操作速度的 80％

前级泵工作异常

扩散泵中的流体液面过高

扩散泵组合排列错误

扩散泵加热器故障

涡轮分子泵工作异常

MSD 电路工作异常


系统处于备用状态

该提示由遥控的启动电缆的关机信号触发。它通常由 GC 故障、ALS 故障或电缆连接故障而引起。一旦纠正了故障，选择 MS ON 或 检测 MSD 状态应该可清除该提示。


系统处于“放空”状态（高真空泵关闭）

系统处于放空状态

在 MSD 系统人为放空后，出现该提示是正常的。如果它意外地出现，可能由下列原因之一所引起：

风扇故障将泵关闭

高真空泵的保险丝损坏

扩散泵加热器套故障

MSD 电路工作异常

虽然该提示指出系统处于放空状态，但事实上真空多路连接管不一定被放空。真空多路连接管中可能依然存在一定真空度。


没有发射电流

灯丝故障或没有连接好

MSD 电路工作异常


信号不足以开始调谐

amu 校准不良

真空多路连接管压力过高

空气泄漏

电子倍增器电压过低

校准样品瓶为空或几乎为空

信号电缆未连接

电子倍增管的导线连接错误

离子源的导线连接错误


空气泄漏

任何需要真空操作的仪器都存在空气泄漏的故障。空气泄漏的原因通常是真空密封垫损坏或固定不当。空气泄漏的症状包括：

超过正常真空多路连接管压力或前级压力

超过正常本底

空气特征峰 (m/z 18、28、32 和 44 或 m/z 14 和 16)

灵敏度低

m/z 502 处相对丰度低（该值随所用的调谐程序而有所不同）

空气泄漏在 GC 或 MSD 中都可能出现。在 GC 中，泄漏常常出现在：

  • 进样口隔垫

  • 进样口柱螺帽

  • 断裂或破裂的毛细管色谱柱

空气泄漏还可出现在 MSD 的更多处：

  • GC/MSD 接口柱螺帽

  • GC/MSD 接口 O 形圈

  • 侧板 O 形圈（整个周围）

  • 前端盖和后端帽的 O 形圈

  • 三级真空规管的连头

  • 校准阀

  • 放空阀的 O 形圈

  • 高真空泵和真空多路连接管之间的密封垫

空气泄漏更容易出现在频繁开关的密封垫处，如色谱柱螺帽、侧板 O 形圈或放空阀的 O 形圈。空气泄漏在很少或从不打开的密封垫处出现较少，如前端盖和后端帽的 O 形圈或GC/MSD 接口柱螺帽。

下述步骤有助于确认空气泄漏的存在并且找到泄漏位置。

确认空气泄漏的存在

查找 GC 中的空气泄漏

查找 MSD 中的空气泄漏

隔离难以发现的泄漏


确认空气泄漏的存在

如果 MSD 最近进行过放空，不要使用下面讨论的空气和水检查来确认空气泄漏的存在。需要经过 4 个小时，m/z 28（氮气）才能降至适当低的水平。需要经过 24 个小时，m/z 18（水）才能降至适当低的水平。

  1. 在 Diagnostics/Vacuum Control（诊断/真空控制）视窗的 Diagnostics（诊断）菜单中，选择 Air and Water Check（空气和水检查）。

  2. 比较 m/z 28（氮气）和 m/z 18（水）的丰度。

    m/z 28 的丰度应该比 m/z 18 的丰度低。

  3. 比较 m/z 18（水）和 m/z 69 (PFTBA) 的丰度。

    m/z 18 的丰度应该小于 m/z 69 的丰度的 10% 。

  4. 比较 m/z 28（氮气）和 m/z 69 (PFTBA) 的丰度。

    m/z 28 的丰度应该小于 m/z 69 的丰度的 5%。

  5. 比较 m/z 28（氮气）和 m/z 32（氧气）的丰度。

    如果空气泄漏存在，那么 m/z 28 与 m/z 32 的丰度比值约为 5:1。如果 m/z 28 的丰度远远超过 m/z 32 丰度的 5 倍，那么可能存在另外的一种化合物，离子的质量为 m/z 28 ，如 CO 或 C2H4 。如果 CO 存在，那么在 m/z 44 (CO2) 处也存在一个典型的大峰。

如果空气和水检查证实存在空气泄漏，请参见：

查找 GC 中的空气泄漏

查找 MSD 中的空气泄漏

如果难以发现空气泄漏，请采取下列步骤：

隔离难以查找的泄漏


查找 GC 中的空气泄漏

大多数 GC 中的空气泄漏发生在 GC/MSD 接口末端螺帽、进样口或隔垫这三个地方其中之一。GC/MSD 接口末端螺帽的泄漏在 MSD 泄漏的查找 MSD 中的空气泄漏中提到。

分流/不分流进样口的泄漏有时可通过开关进样口吹扫和检查和谱峰（主要是 m/z 28 和 m/z 32）相关的离子丰度来确认。如果吹扫关闭时这些离子的丰度比吹扫开启时大得多 (×100)，就可以确认进样口泄漏。

进样次数太多后隔垫会产生泄漏。隔垫应该最少每 100 次进样后进行更换。随时在温度 250 ℃的柱箱中保持一个装隔垫的烧杯可以免去新隔垫安装后进行就地老化。

我们大力推荐使用 Merlin Microseal (TM) 取代常规隔垫。这种微密封垫圈免去了对隔垫的需要并且能持续进行上万次进样而不产生泄漏。最适合同自动进样器一起使用。仅同锥形钝头注射器一起工作。

另见

安捷伦科技公司应用注释：优化 GC 不分流进样以获取高效 MS 分析。


查找 MSD 中的空气泄漏

在 MSD 中查找空气泄漏的最简便方法就是将 MSD 作为检测器使用，在可能发生空气泄漏的位置喷射惰性气体。总是从最近被打开过的密封装置开始。这是最有可能发生空气泄漏的地方。

所需材料：

  • 氩气，演示瓶（0.6 升）

  • 吸液管（可选）

  • 螺丝起子，TORX T-15 (8710-1622)

  • 气路管

  1. 若您的 GC 配置了分流/无分流进样口，在检查空气泄漏时，请打开进样口吹扫。

  2. 若您的 MSD 配置了真空规控制器，请在进行检查之前关掉三级真空规和真空规控制器。

  3. 在 MSD 打开时，卸下 MSD 的上盖与下盖。

    警告! 不要卸下其他盖板。这些盖板下有危险电压。扩散泵可能很烫，危险！三级真空规可能很烫，危险！

  4. 如果前级泵位于 MSD 的下部，请将它卸下，这样您就可以接近高真空泵了。

  5. 在 Manual Tune（手动调谐）视窗的 AdjParam（调节参数）菜单中选择 Masses（质量）。

  6. 对所有三个质量输入氩气主要离子的质量 40 ，然后单击 OK（确定）。

    如果您选择的惰性气体不是氩气，则输入该气体主要离子的质量。

  7. 在 AdjParam（调节参数）菜单中选择 Edit MS Params（编辑 MS 参数）。

  8. 将 PFTBA 字段由 OPEN 修改为 CLOSE。

  9. 选择 Prof（重复图形扫描）按钮。

    这个按钮将启动对 3 种调谐质量的连续扫描。当前情况下，三种质量均为 m/z 40 。

  10. 将气路管连接到氩气钢瓶气供给的出口。

    气路管使得精确定位检测气体变得简单。而在气路管的末端加一个吸管，将进一步增强气路管精确定位检测气体的能力。

  11. 将气路管的末端或吸管尖端浸没在烧杯的水中，调节气体流量直到得到一串细小的气泡。

    流量太大既浪费氩气，又导致大量氩气充斥仪器的周围，增加了精确定位泄漏发生位置的难度。

  12. 对下面所列的可能发生空气泄露的位置，喷射氩气，每次一个位置。

    总是从最近被打开过的密封装置开始。这是最有可能发生空气泄露的地方。在喷射完一个位置后，观察数据系统中的峰图。如果在 2 到 5 秒后，您看到曲线在质荷比 40 处出现一个陡峭的、显著的攀升，说明在您刚刚喷洒氩气的位置存在空气泄漏。如果在 5 到 20 秒后，您看到曲线在质荷比 40 处逐渐上升，说明在您刚刚喷洒氩气的位置附近，但不是在您喷洒的位置存在空气泄漏。

  • GC/MSD 接口色谱柱螺帽

  • GC 接口 O 形圈

  • 侧板 O 形圈（周围各处*）

  • 三级真空规管的连接头

  • 校准阀（阀状态为关）

  • 校准阀（将 PFTBA 字段的状态修改为 OPEN 后）

  • 放空阀的 O 形圈

  • 高真空泵与真空多路连接管连接处

    • 警告! 请勿触摸高真空泵。它很烫！

  13. 定位并排除了一处空气泄漏后，请再次对此位置进行检测，确保该处泄漏已经修理好。

    如果对一处空气泄漏的纠正要求关闭或抽空 MSD ，请在纠正此处泄漏以前检查其他位置。可能不止一处发生了空气泄漏，一次性地对所有泄漏位置进行补漏，效率更高。

    侧板 O 形圈凹槽的延长部分安装在真空室的右下角。这一延长部分的末端正好通过侧板的右下角。如果在这个位置喷射泄漏检测气，气体将沿侧板 O 形圈前进，检查侧板 O 形圈处是否存在空气泄漏。这比在整个侧板沿线进行检测气的喷射要方便得多。


隔离难以发现的泄漏

如果寻找空气泄漏过程中遇到困难，下列程序提供一个方法确定泄漏是否在 GC 中还是 MSD 中。该程序并不推荐用于常规的故障排除，因为如果不正确地被执行会导致毛细管柱堵塞或损坏。

  1. 在 Diagnostics/Vacuum Control（诊断/真空控制）视窗中，从 Diagnostics（诊断）菜单选择 Air and Water Check（空气和水检查）。保存结果。

  2. 关闭 GC/MSD 接口加热器和进样口加热器。降低 GC 柱箱温度到室温。令所有加热区冷却。

    警告!在取下色谱柱前确信柱箱和进样口已冷却。

    注意 无载气流通过时加热毛细管柱会损坏色谱柱。

  3. 从进样口取下 GC 色谱柱。

  4. 用一个隔垫盖住色谱柱端口。

  5. 等待 15 – 20 分钟。

    步骤 2 和 3 允许小量的空气进入 MSD。如果在 MSD 有机会抽出这部分空气之前仍未完成操作，这次测试将是无效的。

  6. 再一次检查空气和水。

  7. 比较第一次和第二次检查的结果。

    如果结果基本相同，则泄漏存在于 MSD 中或 GC/MSD 接口末端的色谱柱螺帽处。如果结果显著不同，泄漏可能存在于 GC 的进样口。

  8. 取下隔垫。

  9. 划痕并折断毛细管柱起始 30 mm 的一段。

    注意 如果色谱柱未正确折断，它可能被隔垫或柱碎屑堵塞。

  10. 重新在进样口处安装色谱柱。

根据泄漏的位置，请转至：

查找 GC 中的空气泄漏

查找 MSD 中的空气泄漏


污染

污染通常由质谱中的过量本底鉴定。它可能来源于 GC 或 MSD。污染源有时可通过鉴定污染物来确定。有些污染来源于 GC 的可能性较大。而另一些则更可能来源于 MSD。

GC 中的污染

源于 GC 的污染通常由下列污染源之一引起：

色谱柱或隔垫流失

脏进样口

进样口衬管

污染的注射器

劣质载气

MSD 中的污染

源于 MSD 的污染通常由下列污染源之一引起：

空气泄漏

清洗溶剂

扩散泵油

前级泵油

指纹

下面的程序可用于检测离子源是否已被污染（脏了）：

检查脏离子源

常见污染物

下表列出了一些更为常见的污染物、这些污染物的特征离子及其可能的来源。

离子 (m/z) | 化合物 | 可能来源
18、28、32、44 或 14、16 | H20、N2、O2、CO2 或 N、O | 残留空气和水、空气泄漏、Vespel 密封垫圈的脱气
31, 51, 69, 100, 119, 131, 169, 181, 214, 219, 264, 376, 414, 426, 464, 502, 576, 614 | PFTBA 和相关离子 | PFTBA（调谐化合物）
31 | 甲醇 | 清洗溶剂
43, 58 | 丙酮 | 清洗溶剂
78 | 苯 | 清洗溶剂
91, 92 | 甲苯或二甲苯 | 清洗溶剂
105, 106 | 二甲苯 | 清洗溶剂
151, 153 | 三氯乙烷 | 清洗溶剂
69 | 前级泵油或 PFTBA | 前级泵蒸汽或校准阀泄漏
73, 147, 207, 221, 281, 295, 355, 429 | 聚二甲基硅氧烷 | 隔垫流失或聚甲基硅氧烷色谱柱流失
77, 94, 115, 141, 168, 170, 262, 354, 446 | 扩散泵油及相关离子 | 扩散泵油
149 | 增塑剂（邻苯二甲酸酯） | 真空密封垫（O 形圈）因高温损坏，聚乙烯手套
间距 14 amu 的峰 | 烃 | 指纹，前级泵油

除去 MSD 中污染的措施依赖于污染的类型和水平。由水或溶剂引起的次要污染通常可由系统抽吸一夜（使用纯净的载气流）除去。除去泵油或指纹引起的严重污染要困难得多；可能需要彻底地清洗。


色谱柱或隔垫流失

这通常可由位于 207 amu （聚二甲基硅氧烷）处的一个强峰来鉴别。非交联毛细管色谱柱是一个主要原因。高流失隔垫也是一个常见原因。我们推荐几乎全部采用交联毛细管色谱柱。同时推荐使用低流失隔垫，如安捷伦科技公司的“红色”隔垫（5181—3383）。

检测色谱柱流失的一个简单测试方法是将 GC 柱箱温度提高 20 或 30 摄氏度。本底的对应增加说明出现色谱柱流失。色谱柱流失可通过老化色谱柱来避免或减至最小程度。

有关老化色谱柱和隔垫的说明，请参见 MSD 硬件手册。


脏进样口、衬管、注射器和污染载气

这些较难诊断，是因为所看见的本底光谱取决于污染物。如果污染问题由 GC 所带来，但不是隔垫或色谱柱流失，尝试：

  • 清洗进样口

  • 更换进样口衬管

  • 清洗或更换注射器

  • 换一种载气供给并/或更换气阱

  • 把载气气路管更换为新的（清洁的）气路管

另见

安捷伦科技公司应用注释：优化 GC 不分流进样以获取高性能 MS 分析


清洗溶剂

刚清洗过离子源后在质谱中出现清洗溶剂的峰是很普通的。为避免此类情况发生，GC 柱箱中清洗过的金属部件在重新装配和安装前应全部干燥。所用温度应高于溶剂的沸点但低于色谱柱的限制。确保载气流过整个色谱柱。

警告！未通电的真空状态下的 MSD 中不可流入氢气。

应避免溶剂接触 O 形圈。请勿烘烤 O 形圈或含有聚四氟乙烯的部件。


扩散泵油

如果允许扩散泵在真空系统中没有色谱柱（载气）流时操作，扩散泵油的蒸气会漂流到真空多路连接管中。更严重的是在真空系统突然放空或者不正确放空时液体回流到真空多路连接管中。如果扩散泵回油，在m/z 446 经常能观察到显著的峰并且光谱基线在大多数质量处会出现一些小峰。在真空多路连接管的一些部分还可能观察到油膜。


前级泵油

前级泵油污染可以通过间隔 14 amu 的峰（烃类）表征。前级泵油污染没有扩散泵油污染常见，但可能在前级泵被允许在扩散泵关闭和没有载气进入系统时延长一段工作时间的情况下出现。


指纹图

指纹图包括可在质谱中出现的烃类。指纹图污染由一系列相差 14 amu 的质谱峰来表现。这些峰的丰度随着峰质量的增加而降低。指纹图污染通常是由于在进行离子源清洗或 GC 进样口维护时没有戴干净手套而引起。尽量小心避免清洗之后的再污染。


检查脏离子源

脏离子源是引起灵敏度降低和其他性能故障的更普遍的原因之一。所有的离子源最终都会变脏。MSD 中离子源变脏的速度取决于下列因素：

  • 被分析的样品数量 — 样品越多，离子源变脏越快

  • 样品类型和样品基质 — 复杂基质中的高浓度样品使离子源变脏的速度比洁净基质中的痕量样品更快。

  • 操作条件（主要是离子源温度） — 离子源温度越高，通常离子源越干净，保持清洁的时间越长。

脏离子源的外观不一定很脏。脏离子源实际情况的迹象可由调谐报告获得。MSD 化学工作站 软件自动保存上一次的自动调谐结果（但不能为标准谱图、BFB、DFTPP 或其他调谐）并将调谐参数和调谐值的趋势绘制出来。

采取这些步骤后，如果确定离子源是脏的，则可以通过采取 MSD 硬件手册的“维护”一章中的清洁步骤恢复它的性能。

  1. 选择 Instrument Control（仪器控制）视窗中 Qualify（定性）菜单中的 View tunes（察看调谐）。下列趋势表明离子源在变脏：

  • 离子聚焦电压越来越高

  • 推斥极电压越来越高

  • 电子倍增器电压越来越高（也可能表明电子倍增器出现老化）

  • 低质量分辨率越来越差

  • m/z 502 处的相对丰度越来越低

  2. 执行 Autotune（自动调谐）操作（仅适用于自动调谐，而不适用于 Standard Spectra Tune（标准谱图调谐）、Quick Tune（快速调谐）等）。脏离子源的症状包括：

  • m/z 502 的相对丰度低于 3％

  • m/z 219 处的相对丰度低于 30％

  • 推斥极电压处于最大值（自动调谐情况下为 35 伏）

  3. 在 Edit Parameters（编辑参数）窗口中，改变推斥极电压。干净的离子源会在 15 到 35 伏之间产生一条具有良好峰形的单峰的响应曲线。离子源变脏时，该峰将向高电压端漂移直至达到最大的推斥极电压（42.7 伏）。脏离子源也可能在低推斥极电压处突然出现一段低响应或无响应的区域，然后出现很陡的响应曲线。出现这种类型的响应时，峰仍然位于最大推斥极电压处。


关于 CI 的常见故障

由于 CI 所要求的部件增加了复杂度，因此增加了许多潜在的问题。至今为止，CI 中出现最多且最严重的故障与反应气进样系统的泄漏或污染有关。NCI 对空气特别敏感，不足以在 PCI 中引起故障的少量空气泄漏也能够破坏 NCI 的灵敏度。

对于 EI，如果 MSD 调谐良好并且不存在空气泄漏，出现样品灵敏度问题应首先检查 GC 进样口的维护。

  • 错误的反应气

  • 反应气未接通，或接入了错误的反应气进样口。

  • 调谐文档中输入了错误的离子

  • 选择了错误的调谐文件

  • 放空后的烘烤时间不足(本底过高）

  • 毛细管色谱柱的位置不对（伸出接口末端 > 1mm。）

  • 接口端没有安装密封垫

  • 在 CI 模式下安装了 EI 源

  • CI 离子源上安装了 EI 金属丝或 EI 源的部件

  • 反应气流路通道存在空气泄漏

  • CI 灯丝拉伸或下垂：

高 EMV

线性（没有拐点）电子能量 (EleEnergy) 梯度。


故障排除的技巧和诀窍

以下为故障排除应遵循的一般原则与具体的 CI 示例。

规则 1：“查找曾经更换过的部分。”

很多故障都是人们在操作中偶然引入的。每一次对系统的扰动都可能引入新的故障。

  • 如果 MSD 保养后刚进行过抽气操作，则怀疑故障为空气泄漏或组装不正确。

  • 如果反应气瓶或气体净化器刚更换过，则怀疑故障为泄漏、气体污染或气体不正确。

  • 如果 GC 色谱柱刚更换过，则怀疑故障为空气泄漏、色谱柱污染或流失。

  • 如果您刚切换了离子极性或反应气，则怀疑故障出在内存中加载的调谐文件 — 该文件是否适合当前的操作模式？

规则 2：“如果复杂情况下不能正常工作，则回到简单情况下操作。”

复杂的任务不仅难以操作，而且更难进行故障排除。例如，要进行正常工作，CI 比 EI 所需的部件更多，所有这些额外部件也如此

  • 如果在 NCI 下出现问题，则要证实在 PCI 下仍然能够正常工作。

  • 如果使用其他反应气时出现故障，则要证实在甲烷条件下仍然能够正常工作。

  • 如果在 CI 下出现故障，则要证实 EI 仍然能够正常工作。

规则 3：“先分割后排除。”

该技术称为“半分流”故障排除。如果能将故障限制在系统的某个部分中，则查找故障就容易得多了。

  • 要隔离空气泄漏，在保持隔离阀和 MFC 开启的状态下先关闭气体选择阀（打开 Purge（吹扫）和 Gas Off（气体关闭）。）如果质荷比 32 处的丰度下降，则故障在流量模块的“上游”。


空气泄漏

如果出现了空气泄漏，我如何得知？

大的空气泄漏可以由真空症状检测出：前级泵发出很大的“汩汩”噪音，涡轮泵无法达到 95% 的速度，或者在泄漏较小的情况下，高真空规控制器的压力读数很高。

注意质量流量控制器用甲烷校准，而高真空规控制器用氦气校准。因此这些测量结果的绝对项并不精确，它们是用作典型读数的参考。在下组条件下进行测量：

离子源温度 250°C

四极杆温度 106°C

接口温度 320°C

氦气载气流量 1ml/min

MFC (%) | 压力 (Torr)
 | 甲烷 | 异丁烷 | 氨气
10 | 5.6 x 10-5 | 6.5 x 10-5 | 4.7 x 10-5
15 | 7.7 x 10-5 | 9.2 x 10-5 | 6.7 x 10-5
20 | 9.8 x 10-5 | 1.2 x 10-4 | 8.5 x 10-5
25 | 1.2 x 10-4 | 1.4 x 10-4 | 1.0 x 10-4
30 | 1.4 x 10-4 | 1.8 x 10-4 | 1.2 x 10-4
35 | 1.6 x 10-4 | 2.0 x 10-4 | 1.4 x 10-4
40 | 1.8 x 10-4 | 2.3 x 10-4 | 1.6 x 10-4
45 | 2.0 x 10-4 | 2.6 x 10-4 | 1.9 x 10-4
50 | 2.2 x 10-4 | 3.0 x 10-4 | 2.1 x 10-4
60 | 2.7 x 10-4 | 3.5 x 10-4 | 2.5 x 10-4

设定甲烷流量时应始终注意小的空气泄漏。用甲烷进行预调谐。质荷比为 19（质子化的水）的离子丰度应低于质荷比为 17 的离子丰度。如果 MSD 刚经过抽气，则质荷比为 19 的离子丰度应降低。

质荷比 32（氧气）处不应有任何可见峰。它几乎无例外地表明空气泄漏的存在。

关于负化学电离的特殊说明

由于 NCI 极为灵敏，在使用 EI 或 PCI 时检测不出的空气泄漏都能给 NCI 带来灵敏度故障。要在 NCI 下检查这种空气泄漏，注入 OFN。基峰应在质荷比 272 处。如果质荷比 238 处的离子丰度远高于质荷比 272 处的离子丰度，则表明存在空气泄漏。

如何发现空气泄漏？

  1. 查找前一次操作给密封性造成的故障。

  • 如果您刚对 MSD 进行过抽气操作，请按侧板检查密封是否良好。分析器和 GC/MSD 接口密封处之间未对准可导致侧板无法密封。

  • 如果您刚更换了反应气瓶或者气体净化器，请检查刚打开过然后重新紧固的接头。

  2. 检查进样口和接口柱螺帽处密封的紧密程度。

    经过几次加热循环后，毛细管色谱柱的垫圈经常松动。接口螺帽不要拧得过紧。

  3. 如果流量部件中任何 VCR 接头出现了松动然后重新拧紧，则必须更换垫圈。这些垫圈仅适于一次性使用。

    注意

    除了更换垫圈时，不要松开任何 VCR 接头。否则将产生空气泄漏。

  4. 请记住，CI 模式下大部分可见的小的空气泄漏都出现在载气或反应气流通路中。

    由于电离室中压力更高，在 CI 模式下不可能检出渗入真空多路连接管中的泄漏气体。

  5. 使系统半分流。

  • 关闭气体选择阀进口处的阀（打开气体关闭阀和吹扫阀），然后向“下游”移至隔离阀（打开气体关闭阀，关闭吹扫阀。）

  • 可以冷却并放空 MSD ，卸下 GC 色谱柱，然后取下接口帽。

如果您习惯于用氩气或者引入其他气体查找空气泄漏，需要注意这种方法对于反应气流系统来说效果不佳— 如果泄漏发生在流量部件的进口处，则需要 15 分钟峰才能到达离子源。

CI 流量控制模块示意图

流量部件状态图：

结果

气体 A 流量

气体 B 流量

用气体 A 吹扫

用气体 B 吹扫

排气
流量部件

备用、放空或 EI 模式

控制面板灯 (LED)

气体 A （绿色） | 开 | 关 | 开 | 关 | 关 | 关
气体 B （黄褐色） | 关 | 开 | 关 | 开 | 关 | 关
吹扫 （红色） | 关 | 关 | 开 | 开 | 开 | 关
气体关闭（红色） | 关 | 关 | 关 | 关 | 开 | 开

阀状态

阀 A | 开 | 关 | 开 | 关 | 关 | 关
阀 B | 关 | 开 | 关 | 开 | 关 | 关
MFC | 开 设定值 | 开 设定值 | 开 100% | 开 100% | 开 100% | 关 (0%)
隔离阀 | 开 | 开 | 开 | 开 | 开 | 关


与压力相关的症状（概述）

以下症状都与高真空压力有关。

没有反应气流时，真空度不足

有反应气流时压力高

反应气流速改变，而压力不变

质量流量控制器用甲烷进行校准，而高真空规控制器则用氦气校准。因此这些测量结果的绝对项并不精确，它们只能用作典型读数的参考。在下组条件下进行测量：

离子源温度 250°C

四极杆温度 106°C

接口温度 320°C

氦气载气流速 1ml/min

MFC (%) | 压力 (Torr)
 | 甲烷 | 异丁烷 | 氨气
10 | 5.6 x 10-5 | 6.5 x 10-5 | 4.7 x 10-5
15 | 7.7 x 10-5 | 9.2 x 10-5 | 6.7 x 10-5
20 | 9.8 x 10-5 | 1.2 x 10-4 | 8.5 x 10-5
25 | 1.2 x 10-4 | 1.4 x 10-4 | 1.0 x 10-4
30 | 1.4 x 10-4 | 1.8 x 10-4 | 1.2 x 10-4
35 | 1.6 x 10-4 | 2.0 x 10-4 | 1.4 x 10-4
40 | 1.8 x 10-4 | 2.3 x 10-4 | 1.6 x 10-4
45 | 2.0 x 10-4 | 2.6 x 10-4 | 1.9 x 10-4
50 | 2.2 x 10-4 | 3.0 x 10-4 | 2.1 x 10-4
60 | 2.7 x 10-4 | 3.5 x 10-4 | 2.5 x 10-4


没有反应气流时，真空度不足

可能的原因

本底中水分过多。

措施

从 10 – 40 amu 进行扫描。在质荷比 19（> 质荷比 17）处存在大峰表明本底中存在水分。有水份存在时需要用更长的时间来烘烤仪器，并用反应气吹扫管线来清除任何累积水分。

可能的原因

空气泄漏。

措施

用甲烷进行预调谐。质荷比 32 处出峰表明系统中存在空气。检查空气泄漏并排除。请参见空气泄漏一节。

可能的原因

前级泵工作异常。

措施

更换泵油。如果这样仍不能奏效，则可能需要更换泵。请与当地安捷伦科技公司的客户工程师联系。

可能的原因

涡轮泵工作异常。

措施

检查泵速。泵速至少要达到 95%。请与当地安捷伦科技公司的客户工程师联系。

注意

使用氨气作为反应气会缩短前级泵油的使用寿命，甚至可能缩短前级泵本身的寿命。请参见硬件手册中“维护”一章。


有反应气流时压力高

可能的原因

反应气流速过高。

措施

在流量控制器上将反应气流速调低到合适的水平。证实反应离子比是正确的。

可能的原因

空气泄漏。

措施

用甲烷进行预调谐。质荷比 32 处的可见峰表明系统中存在空气。检测空气泄漏并排除泄漏。请参见空气泄漏一节。

可能的原因

接口端没有安装密封垫。

措施

检查离子源储存盒。如果密封垫不在离子源储存盒中，放空 MSD，校验密封垫要正确安装。


反应气流速改变，而压力不变

可能的原因

反应气调节器关闭。

措施

检查反应气调节器，如有必要，将其打开。

可能的原因

反应气调节器设定的压力值错误。

措施

反应气调节器设定的压力值：甲烷为 10 psi (70 kPa) ；或异丁烷与氨气为 3 – 10 psi

(20 – 70 kPa)

可能的原因

反应气瓶上的阀门关闭。

措施

检查反应气调节器，如有必要，将其打开。

可能的原因

反应气瓶是空的。

措施

检查反应气瓶，如有必要，更换气瓶。

可能的原因

反应气管线阻塞、打结、压扁或未连接。

措施

检查反应气管线并修理其中的任何故障。尤其要注意检查反应管线是否与 GC 接口末端的 T 形管相连接。

可能的原因

GC/MSD 接口阻塞或损坏。

措施

检查气流通道并维修，或更换其中有故障的部件。


与信号相关的症状（概述）

本节说明与信号相关的症状。与信号相关的症状可为信号太强、信号太弱、信号有噪音或信号错误。与信号相关的症状通常是在调谐时观察到的，但也可能在采集数据时观察到。自动调谐时由于信号不足产生的故障提示可能会有所不同。

本节中详细讨论以下症状:

无质谱峰

没有反应气信号或信号很低

没有 PFDTD 信号或信号很低，而反应离子正常

噪音超出警戒或信噪比过低

最大峰出现在质荷比 19 处

质荷比 32 处出峰


无质谱峰 (CI)

无质谱峰

排除“无质谱峰”故障时，确定正在使用的操作模式以及哪些质谱峰没有出现是很重要的。总是在甲烷 PCI 模式下启动仪器，检查是否存在反应气离子。

PCI 模式下没有反应气的质谱峰

如果 MSD 一贯运行良好，而且看起来一切正常

  • 装载了错误的调谐文件或调谐文件遭到破坏

  • 错误的离子极性（在 NCI 下没有反应离子出现）

  • 没有反应气流，寻找本底离子并检查压力

  • 调谐文件中选择了错误的反应气（寻找错误的离子）

  • 大的空气泄漏

  • 脏的离子源

  • 真空度不够（泵的故障）。

如果 MSD 最近从 EI 模式切换到 CI 模式

  • 接口端没有安装密封垫

  • 没有反应气流

  • 分析器没有密封（大的空气泄漏）

  • 装载了错误的调谐文件或调谐文件遭到破坏

  • 离子源未正确组装或连接

  • 调谐文件中选择了错误的反应气（寻找错误的离子）

PCI 模式下没有 PFDTD 质谱峰

  • 反应气不正确。异丁烷或氨气不会产生 PCI PFDTD 质谱峰。切换为甲烷。

  • 分析器没有密封（大的空气泄漏）

  • 校准样品瓶中没有校准物

  • 校准阀出现故障

  • 载气或反应气流通道上出现空气泄漏

NCI 模式下没有反应气质谱峰

  • NCI 下反应气没有离子化；转而寻找本底离子。

  • 校验调谐参数

  • 如果没有本底离子的可见峰，则返回甲烷 PCI 模式

NCI 模式下没有 PFDTD 质谱峰

  • 寻找本底离子

  • 校验调谐参数

  • 返回甲烷 PCI 模式

NCI 模式下没有 PFDTD 质谱峰

  • 寻找本底离子

  • 返回甲烷 PCI 模式

NCI OFN 色谱在质荷比 283 处存在大的质谱峰

  • 寻找本底离子

  • 查找小的空气泄漏并排除


没有反应气信号或信号很低

可能的原因

如果您刚安装好 CI 离子源，系统中存在空气泄漏或大量的水份，且已经运行了一个或多个自动调谐，则离子源很可能已经脏了。

措施

排除空气泄漏。清洁离子源。在调谐之前，使系统烘烤 8 小时。有关更多信息，请参见硬件手册中的“维护”一章。

可能的原因

流动的是错误的反应气。

措施

根据调谐文件打开正确的反应气。

可能的原因

离子极性设为 Negative（负）。NCI 中没有反应气离子形成。

措施

切换为正电离模式。

可能的原因

设定的反应气流速过低。

措施

增加反应气流速。

可能的原因

反应气供应管线阻塞、打结、压扁或未连接。

措施

检查反应气供给气路管，如有必要，还应进行维修或更换。

可能的原因

灯丝的导线连接错误。

措施

确保灯丝 1 的导线连接到 CI 离子源灯丝上，灯丝 2 的导线连接到虚拟灯丝上。

可能的原因

碳累积在灯丝上，或者灯丝下垂未对准。

措施

检查灯丝。如有必要，更换灯丝。

可能的原因

系统中的空气或水分过多。

措施

用甲烷进行预调谐。质荷比 32 和 19 处出现峰通常分别表明存在空气和水。烘烤并吹扫仪器，直到质荷比 32 处的峰比质荷比 31 处的峰小得多，并且质荷比 19 处的峰已降到非常低的水平。如果质荷比 32 处的峰不下降，则可能出现了空气泄漏。请参见空气泄漏一节。

可能的原因

信号传输电缆没连接上。

措施

检查信号电缆，如有必要，还应重新连接电缆。

可能的原因

灯丝或灯丝支架与离子源主体或排斥极之间短接。

措施

检查灯丝。如有必要，重新对准灯丝的支架臂。

可能的原因

电子入口孔阻塞。

措施

检查电子入口孔。如有必要，用配备的 0.016 英吋钻头清理小孔。如果电子入口很脏，那么很可能整个离子源都需要清洗。有关更多信息，请参见硬件手册中的“维护”一章。

可能的原因

离子源导线未连接，或连接方式不正确。

措施

检查排斥极。确定排斥极的导线牢固地连接到排斥极上。检查离子聚焦透镜与入射透镜上的导线。如果连接反向，排除故障。

可能的原因

电子倍增器的导线之一（真空多路连接管中）未连接。

措施

检查电子倍增器的导线，如有必要，请重新连接。

可能的原因

甲烷/异丁烷气体净化器达到饱和。

措施

更换气体净化器。


没有 PFDTD 信号或信号很低，而反应离子正常

可能的原因

在 PCI 模式下，流动的是任意其他反应气，而不是甲烷。

措施

切换为甲烷。

可能的原因

调谐文件错误或被破坏。

措施

检查调谐文件。

可能的原因

校准标样瓶中没有 PFDTD。

措施

在流量控制器的后部检查校准标样瓶。如有必要，在校准标样气瓶 中注入 PFDTD。不要将校准标样瓶完全装满；液面至少应低于瓶顶部 0.5 cm。

可能的原因

进入流量控制器的甲烷压力过高。

措施

确定甲烷源调节器的读数为 10 psig (70 kPa)。

可能的原因

CI 离子源脏了。

措施

清洁离子源。有关更多信息，请参见硬件手册中的“维护”一章。

可能的原因

向校准标样瓶中重新注满样品后，没有吹扫校准阀。

措施

请按硬件手册中“维护”一章所述，吹扫校准阀。然后清洁离子源。

可能的原因

校准标样瓶加样过满。过量的 PFDTD 可猝灭化学电离反应。

措施

请按硬件手册中“维护”一章所述，检查校准标样气瓶中的 PFDTD 水平。


噪音超出警戒或信噪比过低

可能的原因

GC 进样口需要维护。

措施

请参见 6890 GC 用户手册。

可能的原因

CI 离子源脏了。

措施

清洁离子源。有关更多信息，请参见硬件手册中的“维护”一章。

可能的原因

真空度过低

措施

检查高压真空规控制器的压力。

可能的原因

空气泄漏。

措施

运行甲烷预调谐（在 PCI 模式下）。质荷比 32 处的大峰表明系统中存在空气。检查空气泄漏并补漏。请参见空气泄漏一节。

可能的原因

甲烷/异丁烷气体净化器达到饱和。

措施

更换气体净化器。


最大峰出现在质荷比 19 处

如果质荷比 19 处的质谱峰丰度高出质荷比 17 处的质谱峰丰度的两倍，则系统中很可能存在过多的水分。

可能的原因

系统在最后一次抽空后没有充分烘干。

措施

请按硬件手册中“维护”一章所述，烘干系统。

可能的原因

反应气供给气路管和流量部件中有水汽残存。

措施

对反应气供给管线吹扫至少 60 分钟。请参见硬件手册中“维护”一章。

可能的原因

反应气供给受到污染。

措施

更换反应气供给，吹扫管线和流量部件。

可能的原因

甲烷/异丁烷气体净化器达到饱和。

措施

更换气体净化器。


质荷比 32 处出峰

用甲烷进行预调谐时在质荷比 32 处出峰通常表明系统中存在空气。

可能的原因

最后一次抽空残存的空气 — 检查是否有水（由质荷比 19 处的峰表征）。

措施

请按硬件手册中“维护”一章所述，烘干系统。

可能的原因

反应气供应管线是新的或脏了。

措施

请按硬件手册中“维护”一章所述，对反应气供给管线及流路部件吹扫至少 60 分钟。

可能的原因

空气泄漏。

措施

检查空气泄漏，排除发现的任何泄漏处。请参见空气泄漏一节。排除所有的空气泄漏后，清洁离子源。

可能的原因

反应气供给受到污染。如果您最近刚更换过气罐并且已经排除了空气泄漏故障，应考虑这一点。

措施

更换反应气供给。

可能的原因

毛细管色谱柱破裂或未连接。

措施

检查毛细管色谱柱。确保它没有破裂并且安装正确。

可能的原因

甲烷/异丁烷气体净化器达到饱和。

措施

更换气体净化器。


与调谐相关的症状（概述）

本节讨论与调谐相关的症状。大部分症状都涉及调谐困难或与调谐结果有关。本节将讨论以下症状：

反应气离子比难于调节或不稳定

电子倍增器电压过高

不能完成自动调谐

峰宽不稳定


反应气离子比难于调节或不稳定

可能的原因

MSD 或反应气管线中残存有空气和水。

措施

用甲烷进行预调谐。空气在质荷比 32 处出峰，过量水份在质荷比 19 > 质荷比 17 处出峰。只要出现任何一种情况，就需要吹扫反应气供给管线并烘烤 MSD。在质荷比 32 处持续出峰，表明有空气泄漏。排除了这些故障之后，需要清洁离子源。

可能的原因

空气泄漏。

措施

用甲烷进行预调谐（在 PCI 模式下）。质荷比 32 处的大峰表明系统中存在空气。检查空气泄漏并排除。请参见空气泄漏一节。

可能的原因

反应气调节器设定的压力值错误。

措施

检查反应气供给管线上的调节器。它应调至

20 psi (140 kPa)。

可能的原因

反应气输送管路上存在空气泄漏。如果甲烷的流速设定值远高于正常值，而比值仍很低，则很可能为该原因。

措施

检查反应气流关路。拧紧连接部位。

可能的原因

CI 离子源脏了。

措施

清洁离子源。有关更多信息，请参见硬件手册中的“维护”一章。

可能的原因

接口端密封垫放置不对、损坏或脱落。

措施

检查接口端密封垫。如有必要，取下密封垫重新安装，确保 CI 离子源的密封良好。如有损坏，则更换密封垫。如有脱落，则安装密封垫。


电子倍增器电压过高

电子倍增器电压可在几百伏到 3000 伏的区间内变化。如果 CI 自调谐程序统一将电子倍增器电压设定在 3000 V 或 3000 V 附近，但是仍然能够出峰完成调谐, 则表明出现故障。

可能的原因

灯丝磨损。CI 灯丝没有真正断裂时也可能已经磨损。检查电子能量梯度；曲线在拐点处应出现一个确定的最大值。如果曲线是线性的，斜率为正且无拐点，并且 EMV 高，则灯丝已经出现拉伸到无法对准离子源的入口的程度，大部分的电子没有进入离子源。

措施

更换灯丝。

可能的原因

分析器的操作温度不当。

措施

检查离子源与四极杆质量过滤器的温度。PCI 源的缺省温度为 250°C ，NCI 源的缺省温度为 150°C。四极杆在两种 CI 模式下的缺省温度均为 106°C。

可能的原因

CI 离子源脏了。

措施

清洁离子源。有关更多信息，请参见硬件手册中的“维护”一章。

可能的原因

电子倍增器（检测器）失灵。切换到 EI 模式，确认出现故障。

措施

更换电子倍增器。


不能完成自动调谐

可能的原因

调谐文件错误或者被破坏。

措施

检查调谐参数。

可能的原因

质荷比 28/27 处的离子比（甲烷）不正确。正确的比值应在 1.5 和 5.0 之间。

措施

如果比值不正确，请调整比值。

可能的原因

CI 离子源脏了。

措施

清洁离子源。有关更多信息，请参见硬件手册中的“维护”一章。

可能的原因

系统中的空气或水分过多。

措施

请参见空气泄漏一节。排除这些故障后，清洁离子源。


峰宽不稳定

可能的原因

调谐文件错误或者被破坏。

措施

检查调谐参数。

可能的原因

CI 离子源脏了。

措施

清洁离子源。有关更多信息，请参见硬件手册中的“维护”一章。

可能的原因

空气泄漏

措施

用甲烷进行预调谐（在 PCI 模式下）。质荷比 32 处出峰表明系统中存在空气。检查空气泄漏并排除。请参见空气泄漏一节。排除所有的空气泄漏故障后，清洁离子源。


诊断/真空系统控制

Diagnostics（诊断）和 Vacuum System Control（真空系统控制）窗口，可从 Instrument Control（仪器控制）的 View（查看）菜单和 Tune（调谐）窗口进入，包括下面的菜单项：

File （文件） | 可以运行文件管理任务
Status （状态） | 可以对 MSD 执行状态检查。
Vacuum （真空） | 控制 MSD 的放空和抽气；吹扫校准阀。
Diagnostics （诊断） | 进入 MS 诊断
Logs （日志） | 进入日志文件
View （查看） | 从一个窗口切换到另一个窗口
Stop/Abort （停止/异常中止） | 停止或中止当前程序。使用 Abort（异常中止），除非软件指示使用 Stop（停止）。


安全控制概述

Secured Control（安全控制）允许实验室管理员为化学工作站的操作设立两套安全模式。两种模式都使用帐号系统，要求操作人员在使用该仪器之前先登记。第一种模式是化学工作站的正常环境，给予操作人员完全访问的权限，可以进行处理方法的开发、仪器的调谐、数据处理等。第二种模式限制操作人员只能在 Autosampler 下用已经定义好的处理方法来运行仪器、处理样品。第一种模式主要允许经过训练并且合格的操作人员进入化学工作站。第二种模式主要是允许未经过训练的人员对样品进行分析，不给予它们访问化学工作站所有性能的权限。

管理员拥有高达 300 个权限，由他来设立帐号系统。安全控制系统可以由监督员来启动，他有 200 个权限。日常操作人员分配了 100 个权限，如果安全控制系统启动的话，他至少要先登记，而且只有部分访问化学工作站软件的权限。

在 MSD 化学工作站中，可以从 Top（顶部）视窗进入 Secured Control（安全控制）菜单。

另见

安全控制菜单


安全控制菜单

Enable Security （启用安全控制） | 初始化使用 MSD 化学工作站菜单和视窗的口令要求。由下面的 Edit Accounts（编辑帐号）菜单项设定口令和用户。当安全控制已经生效时，该菜单项变为 Disable Security（安全控制失效）。
Start Secured Control （启动安全控制） | 初始化受限访问模式，有着正确帐号名和口令的用户不能进入菜单或视窗，而只能使用 Autosampler 启动预定模式。
Select Methods for Secured Control （选择安全控制的方法） | 当系统在安全控制条件下时，由管理器指定操作员所运行的方法。
Set / Change Startup Method （设定/修改启动方法） | 只要有人登录仪器时，由管理器指定运行的方法
Set / Change Standby Method （设定/修改备用方法） | 只要系统不在使用中并且某方法结束时，由管理器指定运行的方法。
Assign Sample Names to Method （为方法指定样品名称） | 由管理器为当前调用的方法加入最多 15 个样品名。
Use Sample-centric Secured Control （使用样品中心安全控制） | 当选中此复选项后，系统要求操作员选择样品中心样品名，而不再是当前方法名。 如果方法还没有指定样品名，或所有的方法已经从样品中心方法列表中删除，那么，该菜单项将呈灰暗色。
Report Manager Password （报告管理器口令） | 提示您输入报告管理器口令。参见报告管理器的帮助信息。
Edit Accounts （编辑帐号） | 提示您输入帐号文件口令，然后显示所有帐号列表。要获得更多信息，单击对话框中的 Help（帮助）按钮。


启用安全

Enable Security（启用安全）用于启动 Secured Control（安全控制）。只能由具有安全级 300 的管理人员开启或关闭安全。一旦安全功能被调用，Secured Control（安全控制）菜单中其他菜单项即被激活。只要化学工作站或数据分析启动，操作员就会被提示要求输入登录帐号和口令。初始的帐号文件使用下列帐号、口令和权限级别设定：

帐号 | 口令 | 级别 | 注释
manager | manager | 300 | 编辑帐号时要求
supervisor | supervisor | 200 | 启动安全控制时要求
operator | operator | 100 |
MANAGER | MANAGER | 300 | 编辑帐号时要求
SUPERVISOR | SUPERVISOR | 200 | 启动安全控制时要求
OPERATOR | OPERATOR | 100 |
CEUSER | 仅为安捷伦科技公司所掌握；不要更改或删除
ceuser | 仅为安捷伦科技公司所掌握；不要更改或删除

注意 帐号名称和口令区分大小写。

帐号文件也有一个口令。帐号文件的缺省口令为 msd。为确保系统安全，建议使用 Edit Account（编辑帐号）菜单项更改口令或 MANAGER，SUPERVISOR 和 OPERATOR 帐号并更改帐号文件口令。如果忘记帐号文件口令，软件必须被重新加载。CEUSER 帐号必须为安捷伦科技公司维修代表处人员保留在帐号文件中。


启动安全控制

安全控制的受限访问模式是在 Start Secured Control（启动安全控制）的菜单项中调用的。该模式只有那些帐号级别为 200 或更高的用户可以调用。一旦该模式被调用，用户必须在提交样品前登录，并且只允许提交样品。不允许访问化学工作站的其他功能。

注意 该功能起作用时，必须安装自动进样器。

一旦操作者处于安全控制的受限访问模式，仅允许进行下列操作：

操作 | 允许性
运行一个单独的样品 | 任意级
运行一批样品 | 任意级
重新启动安全系统 | 超级用户
重置计数器(文件或瓶) | 超级用户
方法选择管理器 | 管理者
退出安全控制 | 超级用户

每次进行这些操作时，用户将被提醒输入用户名帐号名和口令。如果级别不正确，则不能操作。

当选择 Start Secured Control（启动安全控制）时，询问操作者是否开始 MS-1，它为受限模式窗口并由“报告管理器”控制。预运行样品并生成报告，答案必须是 yes。

然后询问操作者选择是否：

运行单个样品

这个选择提示用于登录、显示安全分析方法列表和告诉操作者如何将瓶子放置在自动进样器支架的指定位置上。然后提示 Sample Title（样品名）和 Misc Info（其他信息）。

然后提示另一个自动排列。回答 Yes 使程序从刚说明的步骤处开始循环。

由于每个样品均被记录，它按文件名顺序排列在图表栏里的“报告管理器”中。可以打开该程序观察运行的系列是怎样的。准备运行样品时，单击 Report Manager（报告管理器）中的 Start（开始）按钮。

运行一批样品

这个选择生成与“单个样品”相同系列的事件，除非被提示输入 Sample Title（样品名）、Misc Info（其他信息）和 Number of Vials（瓶号）。所有的样品均与增加的计数器和各种信息具有相同的样品名。

重新启动安全系统

重新启动系统并在 Report Manager（报告管理器）中设定另一个运行系列。

重新设定计数器(文件或瓶）

重新设定文件计数器改变“报告管理器”中指定最近文件名的第 1 或 2 位。重新设定瓶计数器可以跳过样品瓶架的孔洞并改变 Report Manager（报告管理器）窗口的列表。

方法选择管理器

退出

提示输入口令。关闭Secured Control（安全控制）样品队列面板可以避免进来新的分析样品，但是不能避免前面还未运行的样品的采集。完全终止安全控制，必须从 Task（任务）栏选择 Report Manager（报告管理器），并为 MS-1 选择 Shutdown（关闭）按钮。这个关闭将发生在当前的数据采集完成之后。


设定/改变启动/备用方法

超级用户或管理员也可以指定一个启动方法和一个备用方法。启动方法在担保控制的受限访问模式开始的任何时候都可以执行。比较典型地，启动方法用于将色谱系统加热至比采集方法中稍高的温度。备用方法在没有样品被分析时调用。备用方法减小色谱柱流量以保存载气并降低柱箱温度使实验室内的热负荷降到最小。

选择 Set / Change Startup Method（设定/改变启动方法），将出现一个对话框提示您选择下列之一：

Select Startup Method （选择启动方法） | 显示一个选择文件框
Load/Edit/Save/Select Method （加载/编辑/保存/选择方法） | 允许选择一个方法，如果愿意可以编辑整个方法并保存它。
Disable Startup Method （禁用启动方法） | 禁用当前启动方法。

选择 Set / Change Startup Method（设定/改变备用方法）, 将出现一个对话框提示您选择下列之一：

Select Standby Method （选择备用方法） | 显示一个选择文件框
Load/Edit/Save/Select Method （加载/编辑/保存/选择方法） | 允许选择一个方法，如果愿意可以编辑整个方法并保存它。
Disable Standby Method 禁用备用方法 | 禁用当前备用方法。
Select Standby Timeout （选择备用暂停） | 禁用当前启动方法。


选择安全控制的处理方法

选择安全控制的方法

此菜单项仅对拥有 200 或 300 帐号级别访问权限的个人有效。选择这个菜单项将显示 Secured Control Method Manager（安全控制方法管理器），最多可选择 6 个方法用于安全控制中的受限访问模式。


使用样品中心安全控制

  1. 激活 Secured Control（安全控制）模式。

  2. 为方法指定样品名称。

  3. 选择 Secured Control / Use Sample-centric Secured Control（安全控制/使用样品中心安全控制）。在这个菜单项旁边将出现一个复选标记。

  4. 选择 Secured Control / Start Secured Control（安全控制/启动安全控制）。

  5. 选择 Run Individual Sample（运行一个样品）或 Run Batch of Sample（运行一批样品）并单击 OK（确定）。Select Sample Name（选择样品名）显示出对话框。

  6. 在列表中选择一个样品名将使相关方法被 Secured Control（安全控制）使用。如果样品中心方法列表中有多个方法，将使用的方法被加到那个方法的“第一个”样品名右边的列表中。


概述

报告管理器软件负责管理报告的生成和从化学工作站采集的数据。在 Data Analysis（数据分析）的 Jobs（作业）菜单中初始化数据分析报告。在 Top（顶部）视窗（不在环境软件中） 的 Secured Control（安全控制）菜单中初始化数据采集。对任何一个处理过程，请求或作业送至报告管理器。报告管理器对每一个配置过程的请求进行排列或列表。以非交互式或数据分析背景备份或 Instrument Control（仪器控制）接受请求的次序依次处理请求。报告管理器可以配置为将报告重新定向为其他情况或其他联网的计算机。


配置报告管理器

Report Manager（报告管理器）配置确定了处理请求所用的目标文件和程序。配置 Report Manager（报告管理器）系统有两个主要步骤：

选择节点

选择过程

可通过选择 Configure Reporting System（配置报告系统）对话框的 Add（添加） 按钮添加额外的 Report Manager（报告管理器）系统。将会提示您给出要添加的系统名称。

Report Manager（报告管理器）采用将在本地系统执行的两个 Data Analysis（数据分析）过程 MSDA 和 MSDA2 进行预配置。只要 Secured Control（可靠控制）首先启动，本地系统的 Instrument Control（仪器控制）过程 MS-1 将会自动创建。


管理报告系统

Report System（报告系统）为处理一个请求的应用程序和节点。在大多数情况下，应用程序为 Data Analysis（数据分析）。

显示 Report Manager（报告管理器）时，将看到一个有 Report System（报告系统）的列表。

  1. 从列表中选择报告系统。

  2. 单击下列按钮之一：

    Start（开始）

    Pause（暂停）

    Resume（重新开始）

    Shutdown（关闭）

另见

检查报告系统的状态


查看请求

要刷新请求堆栈中当前的请求列表，选择 File / Refresh（文件/刷新）。

Report Manager（报告管理器）列出被 Report System（报告系统）排列的所有请求。添加或删除一个项目时，该列表自动更新。

请求没被列表

Report Manager（报告管理器）根据节点和过程列出请求。一个请求可能不出现在列表中。如果有一个 Report System（报告系统）未解决的请求而那个系统的节点改变，则这个请求将不显示在具有改变的节点名字的系统名下。


区分请求的优先次序

欲将一个请求移动到堆栈的上部：

  1. 选择该请求。

  2. 单击 Move to Top（移动到顶部）按钮。

所选择的请求位于将要处理的请求的下一行。


删除请求

为了要从 Report Manager（报告管理器）中删除请求，请：

  1. 选定该请求。

  2. 单击 Delete（删除）按钮。这样，选定的请求就从请求堆栈中删除掉了。

为了要从 Report Manager（报告管理器）中删除所有请求，请：

  1. 选择 Report Manager（报告管理器）中的 File/ Delete File（文件/删除文件）。

  2. 系统提示您是否确定要删除所有请求。单击 OK（确定）或 Cancel（取消）。

注意：删除所有请求可能会将这些请求存放在其他的 Report Manager（报告管理器）系统上。因此，您若要删除所有请求，建议您删除网络中所有系统上的请求。


定量列表配置

定量列表/列表配置

当为使用 Report Manager（报告管理器）(QList) 或局部 Data Analysis（数据分析）(DOLIST) 的过程选择多种数据文件时，该配置面板用于修改可用选项的列表。因为 QList（定量列表）的选择面板被限制在仅有 6 个选项，您希望使用的选项可能不在列表中。

该配置面板允许您从近三十个 Report Manager（报告管理器）或 Data Analysis（数据分析）任务或者被添加的新选项中进行挑选。只要选项在 Selected Options（所选选项）列表中，单击 OK（确定）可更新 QList（定量列表）或 DOLIST（列表）中可用的选择。

Add（添加）

复制 Option（选项）列表中当前选择到 Selected Options（被选选项）列表中。

Remove（删除）

从 Selected Options（被选选项）列表中删除被选项目。

Add Option（添加选项）

允许您输入新选项到 Option（选项）列表中。

Delete Option（删除选项）

允许您从 Option（选项）列表中删除项目。

Command Name（命令名称）

允许您指定命令显示在面板中的名称。

Command String（命令字符串）

允许您指定运行的命令。有关更多信息，请到关于单独命令的帮助。例如，定量命令使用 QT 命令。


从外部源输入

配置 Report Manager（报告管理器）使之可以监视一个目录中文件的存在，并当检测到文件时自动生成请求。如果配置了下列一个或多个选项，每分钟进行两次监视。

从 RTE 输入

从 UNIX 输入

从 3365 输入

从峰 - 96 输入

从外部源输入


删除文件

允许您删除 Report Manager（报告管理器）的所有请求：

  1. 在 Report Manager（报告管理器）中选择 File / Delete File（文件/删除文件）。

  2. 提示您确定删除所有请求。单击 OK（确定）或 Cancel（取消）。

注意：删除所有请求可能会在另一个 Report Manager （报告管理器）系统中保留请求。当删除所有请求时，建议删除网络中所有系统上的所有请求。


退出

退出 Report Manager（报告管理器）。后台运行的程序不受影响。


系统名

用于识别在哪台计算机上生成报告。这个名字将出现在大多数由“环境数据分析”生成的报告的页脚处。


从 RTE 输入

注:这个软件不提供对 Wndows 的 AdvanceLink（高级链接）、RTE.ACP 文件和在该主题下描述的 RTE 程序文件。“报告管理器”中保留了这个功能，为现有的顾客服务。

概述

当使用 Windows 的 Advancelink（高级链接）时，“报告管理器”可以自动的通过 RS-232 系列端口从 RTE-6 或 RTE-A 数据体系接受数据文件并生成处理数据的请求。

RTE 体系使用一个程序文件将数据转化成化学工作站格式并开始一个 XMODEM 传输。该程序也传输共用 1G-4G 的数值。

在“Windows 的 AdvanceLink”中运行的一个文本编辑程序监控系列端口，并与其进行信号交换以便接受转化的数据文件。PC 上的数据文件与 RTE 体系具有相同的文件名，除了>字符被删除并加上扩展名.MS以外。

除了数据文件，还会创建一个包含共用 1G-4G 值的文本文件。这个文件除了扩展名为.RTE外，与数据文件具有相同的文件名。

“报告管理器”监控扩展名为.RTE的文件。当检测到一个文件时，创建一个以数据文件名和扩展名.D（标准化学工作站格式）的目录。数据文件被重命名为DATA.MS 并被保存在新的目录中。

用.RTE文件中的全局符创建一个请求。输入 3G 用作运行“环境”方法，并以 4G 作为命令。如果不输入命令，则使用RUNMETHOD。

配置您的系统

  1. 配置 RTE。

  2. Windows 的 AdvanceLink。

  3. 为 RTE 输入配置报告管理器。


从 UNIX 输入

概述

Report Manager（报告管理器）可以处理使用 59940 MS 化学系统（HP-UX 系列）采集的数据。这个配置要求透明文件使用 ChemLan 之类的软件从 PC 访问 HP-UX 系统。

使用“报告管理器”在 HP-UX 化学系统上处理采集的数据时，后运行宏在与数据文件相同的目录中生成一个扩展名为.UNX的 ASCII 文件。“报告管理器”监控 *.UNX 文件的存在。

当检测到文件时，读取此文件以确定运行的方法。之后把一个请求加入“报告管理器”中并且删除 .UNX 文件。

UNIX 后运行宏

Name PostRun

! Macro to Create an ASCII file containing Report Manager Request

Open d_file$[1:len(d_file$)-2]+".unx" for output as #7

Print using #7,"[PostRun]"+ Chr$(13) + Chr$(10)

print using #7,"Source=HPUX"+Chr$(13)+Chr$(10)

! The name of the Environmental method to run. 在这个例子中, RTE.M

Print using #7,"RptMethod=RTE.M"+Chr$(13) + Chr$(10)

Close #7

! Give the file write access

Execwait "chmod a+w "+d_file$[1:len(d_file$)-2]+".unx"

Return

在 HP-UX 化学系统上，在“方法运行列表”中选择一个后运行宏并输入PostRun（后运行）作为运行的宏的名字。编辑方法目录中的user.mac文件，使其包含PostRun（后运行）宏。HP-UX 和 DOS 使用不同字符结束程序行，因此 Chr$（13）＋ Chr$（10）取代“/”作为程序行的结束。

配置报告管理器

  1. 在“报告管理器”中，选择Options / UNIX Monitor（选项/UNIX 监测器）。

  2. 输入目录监测 .UNX 文件的存在。

  3. 在初始化过程中选定 Start Monitor（启动监测器）框。

方法必须在 win.ini 文件中 [PCS，1] 部分的 _methpath$ 指定的目录中存在。


从峰 - 96 输入

概述

Report Manager（报告管理器）可以用于处理积分器采集的数据，把积分器连接到在 PC 上运行的 Peak 96（峰 96）上。Peak 96（峰 96）从积分器将数据文件装载到 PC 并将其转化成 3365 GC 化学工作站格式。然后，Report Manager（报告管理器）检测文件并在数据文件上运行指定的方法。

欲配置峰 96

  1. 从 Data Acquisition（数据采集）菜单中选择 Set Up PC（设定 PC）。

  2. 为 Auto Export, Data to ChemStation（自动输出、数据到化学工作站）输入 Y。

配置报告管理器

配置 Report Manager（报告管理器）可使之接受从 4 个积分器传送来的数据。

  1. 选择 Options / Peak - 96 Monitor（选项/峰 - 96 监测器）。

  2. 为配置 Peak - 96（峰 96）的每个积分器输入路径和方法。方法必须存在于 MSDchem\1\methods 目录中。

  3. 在初始化过程中选定 Start Monitor（启动监测器）框。


从外部源程序导入

概述

Report Manager（报告管理器）能处理先前版本或最新版本的 G1701DA MS 化学工作站所采集的数据。配置要求运行 Report Manager（报告管理器）的 PC 机与外部系统之间能够进行文件的透明访问。

用 Report Manager（报告管理器）来处理外部 MS 化学工作站采集的数据时，数据文件从外部数据采集 PC 复制到数据处理 PC　上。在外部化学工作站上执行宏 (expdata.mac) 来配置数据处理 PC 上的目标文件夹。然后这个宏将作为后运行方法宏将数据文件复制到数据处理 PC　机上，并在与数据文件相同的目录下生成一个扩展名为 .DAT 的文件。Report Manager（报告管理器）监视 *.DAT 文件的存在。

检测到 .DAT 文件后，读取该文件，确定运行的方法。读取该文件后，Report Manager（报告管理器）中添加一个请求 ，并且删除 .DAT 文件。

“导入”文件夹的创建方式与外部化学工作站的文件夹相似，允许来自多个外部程序源的数据存储。

配置外部化学工作站

  1. 将要使用的宏 expdata.mac　从 msdchem\supplemental\utility programs\file_transfer 复制到外部化学工作站的缺省可执行文件夹中（对于 MS 化学工作站则为 msexe 文件夹）。

  2. 在命令行中输入 macro "expdata.mac"，从 TOP 过程中加载宏。

  3. 在命令行中输入 configexport，开始配置过程。输入路径，将数据文件复制到 Report Manager（报告管理器）PC　上。这必须是报告管理器 PC 能够透明访问的驱动器。

  4. 在外部 PC 上编辑方法，以添加后运行的宏指令：

    macro "expdata.mac",go

注意：用于采集数据的方法就是指定的数据处理方法。请参见下面有关数据处理 PC 上方法存储单元的注释。

配置报告管理器

  1. 在　Report Manager（报告管理器）中选择 Options / ImportData Monitor（选项／数据输入监控器）。

  2. 输入监控 .DAT 文件的存在的文件夹名称。这就是外部 PC 按照配置过程的指定来复制数据文件的目的文件夹。可以指定最多 4 个监控文件夹。

  3. 选中 Start Monitor during initialization（初始化时启动监控）对话框。

注意：处理方法必须处于数据处理 PC 中 _methpath$ 指定的目录，它位于 msdchem.ini 文件的　[PCS,1]　部分。


目录

显示 Report Manage（报告管理器）在线帮助的Contents（目录)页面。


关于

关于报告管理器

显示报告管理器软件修订和许可信息。


术语表 — 报告管理器

术语表

节点

节点是网络中的一个系统。在 Report Manager（报告管理器）中，一个节点可以是一个质谱仪和数据系统或一个单数据处理系统。

过程

过程是一个可以执行由任务提交的命令的应用程序。大多数情况下进程会是 Data Analysis（数据分析）。Report Manager（报告管理器）有两个已配置的过程，MSDA 和 MSDA2。

报告系统

报告系统是一个配置在某一特殊节点运行的过程。当有请求时，Data Analysis（数据分析）安排一个 Report System（报告系统）名称。缺省为 RPT1 和 RPT2。请求添加到报告管理器后，报告系统名称用于决定最终对象和用于执行产生的报告的进程。


系统命令

每个 ChemStation 应用程序都有一个命令集：

Instrument Control（仪器控制）

Tune（调谐）

Data Analysis（数据分析）

Top（顶部）

常用命令以及函数在所有应用程序中都可用。

您可以通过在命令行输入这些命令或将它们合并到宏来使用这些命令。变量由一些命令使用。

另见

使用命令的帮助

输入命令

使用函数

使用变量


使用有关命令的帮助

所有命令都以此统一的类型来表示：

命令 必需的参数 [,可选参数] [, 关键字1 / 关键字2] ["字符串"] [1/0]

  • 命令是以大写显示的助记词（但可以用小写形式键入命令）。

  • 命令之后跟有参数，如果参数指定了一类要输入的信息，则它们以小写形式表示，如果参数正如上所示的那样输入关键字，则以大写形式表示。关键字中不允许有空格。

  • 任何在键入时必须加引号的参数都以 "parameter" 形式显示在语法汇总中，当参数为标量或字符串时，则显示在参数定义中。

  • 有两种类型的参数：可选和必需。可选参数显示在方括号中[参数]。使用参数时请勿键入方括号。

  • 如果只是要选定参数的其中一个选项，则选项要以斜杠分隔开：关键字1 / 关键字2。

  • 与 ChemStation 以前版本不一样，ON / OFF、TRUE / FALSE 和 YES / NO 不是关键字，不能使用。带有这些函数的参数通过输入 1（打开）或 0（关闭）来设置。

  • 当方括号嵌套时，只有指定在外层方括号中的参数后才能指定内层括号中的参数。

  • 系统有若干个仅可用于宏的命令。在帮助中，这些命令通过以 "Used in a macro to. . ." 为开始的描述来指定。


输入命令

除非您能够真正意识到使用命令的影响，否则，请不要将命令与菜单混合使用。例如，Data Analysis（数据分析）中的某些命令可将色谱图和光谱放置在不同的变量中，而不是利用功能明显相同的菜单项。这样，在使用了这些命令后，有些菜单项就可能不起作用。

  • 使用字符大写和/或小写的语句。可以将命令的字母个数缩短到能唯一标识该命令的长度。

  • 用空格将第一个参数与命令分开。

  • 括在括号内的参数是可选的；要指定这样的参数，请不要键入扩号。

  • 要赋予可选参数新的值，请在命令之后按照命令描述中指定的顺序键入这些值。

  • 每个可选参数都有一个缺省值。要使用所有参数的缺省值，仅输入此命令。若某些参数是必须的，而不是可选的，并且您不能输入这些参数，则将会产生一个错误。

  • 若要在一串参数中使用单个参数的缺省值，只要为此参数输入一个逗号。

  • 命令中使用的所有文本字符串都必须用引号引起："text"。

  • 输入文件名时，除非文件位于当前目录下，否则使用完整路径（路径/文件名）。整个路径必须用引号引起。

  • 键入命令和所有参数后，请按 Enter（回车)。

  • 用作参数的小数值输入时小数点前面必须有一个数字，例如 1.5、0.5。


使用函数

函数在参数列表上执行一些类型的处理并返回一个结果。当您在命令行输入一个函数名时，结果将会打印在消息行上。（请参阅 输入函数名称。）函数通常可用作给变量赋值的语句的一部分。例如，Number = SQRT(4) + 1 将值 3 赋给了变量 Number。

函数的名称表明返回的值是一个数字还是一个字符串。如果名称以 $ 符号结尾，则此函数返回一个字符串。如果函数名称不是以 $ 结尾，则它返回一个数字。若函数的结果是要赋给一个变量，则变量的类型与函数结果的类型必须匹配：

Today$ = DATE$()

NumSeconds = TIME()


使用变量

变量是用来存储数据的计算机内存中的已命名位置。一些命令会影响特定变量的值；这些变量在命令描述中列出。宏可以用变量来临时存储一个值或返回一个结果。请参阅给变量赋值。

不是所有的变量在所有的程序中都存在或者可用。要查看一个程序中当前定义的变量列表，请使用 REMOVE 命令。

变量名不区分大小写。它们可多达 132 个字符，但只有前 15 个字符有效。

有三种基本类型的变量：数值（标量）、字符串和数组。这些类型的变量可以保留为系统所用，也可以不保留它们。保留变量在 REMOVE 列表中可识别，因为它们的名称前有一下划线字符(_)。


常见命令

常见命令和函数

这些命令和函数可用于任何化学工作站应用程序。请注意，函数要包含一个跟在函数名后的圆括号 ( ) 中的值。在命令中，可选的参数显示在方括号 [ ] 中。有关某个具体命令或函数的更多信息，请单击其名称。

另见 输入命令

ABS（数值表达式）

ALERT ["消息字符串"] [,类型] [,变量]

ARRAYSTAT (数组 1, 项个数)

ASC ("ascii 字符")

BIT_AND (a,b)

BYE

CEIL (数值表达式)

CHECK ("关键字", "名称")

CHR$ (ascii 数字)

CLOSE [#文件编号] [,...]

CMDLINE 1/0

COLS (矩阵名称)

COMMANDS

COPY "源名称", "目的名称" [,DONTASK]

CPBYE

CPPURGE 符号

CPSHOWWIN winid [,loc]

CPTAG 符号

CPTITLE "标题字符串"

CPTITLE$ ( )

CPTOOL 符号, 任何对象, 符号, 标量

DATE$ ( )

DDEADVISE 通道, "项", 变量名

DDEEXECUTE 通道, "命令"

DDEINITIATE ("应用程序名称", "主题")

DDEPOKE 通道, "项", "字符串"

DDEREQUEST 通道, "项", 变量名

DDETERMINATE 通道

DELETE "文件/目录" [,DONTASK]

DIM 变量名称, 标量 1 [,标量 2]

DLLINSTALL ("文件名")

DLLREMOVE 标量

DOSRUN "运行字符串"

ECHO 1/0

ECHOMODE 1/0

ELSE

ENDIF

EOF (文件编号)

EQSTR ("s1", "s2")

EVALUATE "命令字符串"

EXEC ("运行字符串", 窗口尺寸)

EXP (数值表达式)

FILEATTRIBUTES$ ("路径", "属性")

FILESIZE "文件名"

FILESTAT ("目录"/"文件名")

FINDFIRSTFILE ("掩码", "输出变量", "属性")

FINDNEXTFILE (句柄, "输出变量")

FLOOR (数值表达式)

FREESPACE ("驱动器名")

GENERATE_ERROR [错误编号] [,"字符串"]

GETCWD$ ( )

GETINFO ("项名称")

GETINIINT ("文件名", "应用程序名称","关键字名称")

GETINISTRING$ ("文件名", "应用程序名称", "关键字名称")

GETPROPERTY 字符串, 字符串, 符号

GETWINDOWID "标题"

GETWINLOC [x] [,y] [,宽度] [,高度]

HELP

IF-THEN-ELSE-ENDIF

INISTRFORINT$ ("文件名", "应用程序名称", 标量)

INPUT "字符串表达式", 字符串变量

INPUT #文件编号, 变量$

INPUT6 类型, 数量, "标题", 标签对象, 按钮对象, 变量名 [,帮助索引] [,帮助文件]

INSERT 索引, 目的, 源

INSTR ("s1", "s2")

JOIN 目的名称, 源名称

LEN ("字符串表达式")

LN (数值表达式)

LOCAL 变量名 [,变量名] [,...]

LOG (数值表达式)

LOGGING [1/0] [,"文件名"] [,命令] [,消息] [,错误] [,信息] [,清除]

LOWER$ ("字符串")

MACRO ["宏文件名"] [,GO]

MDIARRANGE

MDICASCADE

MDITILE 0/1

MENUBEG

MENUCHG 对象名称, "字符串" [,"菜单项"] [,"命令/宏"] [,"帮助文本"] ["控制文本"]

MENUCMD "标签字符串", "命令字符串" [,"消息字符串"] [,变量名]

MENUCMDFN "标签字符串", "命令字符串" [,"消息字符串"] [,"字符串"]

MENUEND [对象名称]

MENUHLP 1/0

MENUNEW "名称字符串"

MENUSEP

MENUSHW [对象名称]

MENUSTP ["标签字符串"] [,"消息字符串"]

MENUVAR "标签字符串", "赋值语句", "消息字符串"

MKDIR "目录名称"

MOD (a,b)

MTIME (数值表达式)

NAME 宏名称

NUM (集名称/数组名称)

ON_ERROR 陷阱

OPEN "文件名" FOR OUTPUT / FOR APPEND / FOR INPUT AS #文件编号

PARAMETER 参数列表

PRINT 表达式 [,...]

PRINT #文件编号, 表达式 [,...]

PRINT 使用 "格式图形字符串", 表达式 [,表达式] [,...]

PRINT USING #文件编号, "格式图形字符串", 表达式 [,表达式] [,..]

PRINTTEXTFILE "文件名"

PROTECTMACRO ["文件名"], ["密码"]

PULLOUT 索引, 源, 目的

REMOVE [宏名称/变量名称] [,...]

REMOVELIST ["基本名称"]

RENAME "源名称", "目的名称", [,DONTASK]

RETURN

RMDIR "目录名称"

ROUND (数字)

ROWS (矩阵名称)

RUNCLASS (运行类型)

SELECTFILE 属性, "标题" [,"扩展名"], 路径变量名, 文件变量名, 文件状态变量名

SDIM 集名称, 正整数

SETINFO "项名称"

SETINISTRING ("文件名", "应用程序名", "关键字名称", "字符串")

SLEEP 时间

SPRINT 变量名, 表达式 [,...]

SPRINT USING "格式图形字符串", 表达式 [,表达式] [,...]

SQR (表达式)

SQRT (表达式)

STRCMP ("字符串 1" ,"字符串 2")

TIME ( )

TIME$ ( )

TOPCMD "命令"

TOPDOT 变量名

TRUNC (表达式)

UNPROTECTMACRO ["文件名"], [“密码”]

UPPER$ ("字符串")

VAL ("字符串")

VAL$ (表达式)

VARLOCK 1/0

VERSION

VERSION$ ( )

WHILE-ENDWHILE

WINMOVE [x] [,y]

WINSIZE [宽度] [,高度]


Top 命令

这些命令可在 Top 中使用。可选参数显示在方括号[ ]中。获取有关特定命令的更多信息，请单击其名称。

另见 输入命令。

DATANALYSIS ["命令"] [,"自动启动宏文件"] [,QUIT] [,ICON]

EDITMETHPANEL [edittop] [,editacq] [,editda]

LOADMETHPANEL ["方法"] [,清除]

LOADMODE [insctl] [,da]

LOADSEQUENCE ["序列文件名"]

METHINFOPANEL

MSINSCTL ["命令"] [,"自动启动宏文件"] [,QUIT] [,ICON]

POP / PUSH

PROMPTMODE [insctlmode] [,damode]

RUNMODE ["模式"]

SAMPLELOGTABLE 关键字 [,"字符串"]

SAVEMETHPANEL "方法路径"

SAVESEQUENCE ["序列文件名"]

SAVETOPMETHOD

SETDATAFILE 类型, 参数

STARTRUNPANEL

STARTSEQPANEL

STATUSPANEL [1/0]

SYNCHRONIZE

TOPBOX1 "消息", 颜色

TOPBOX2 "消息", 颜色


仪器控制命令

仪器控制命令和函数

ÒÔÏÂ命令和函数可用于控制 6890 Series GC/MSD 系统。请注意，函数包括一个紧随函数名之后在括号 ( ) 中的值。对于命令，可选的参数显示在方括号[ ]中。获取有关特定命令的更多信息，请单击命令名称。

另见 | 输入命令
 | 常见命令 调谐命令

EDZONE

FIRMWARE7673$ ( )

GCMETHODEDIT（面板编号）

GCMETHODEDIT$ ( )

GCMETHODLOAD "方法文件名和完整路径"

GCMETHODNAME ( )

GCMETHODNUM ( )

GCMETHODPRINT "文件名和完整路径"

GCMETHODSAVE "方法文件名和完整路径"

GCPLOTEDIT ( )

GCPLOTOFF [图编号]

GCPLOTON [图编号]

GCSHOWDEVICEWIN [窗口编号] ,位图编号, x 位置,y 位置

GCVIEWPARAMS ( )

ICARRANGEPLOTS [标量] [,标量] [,标量]

ICCREATEBAR ( 标量, 字符串, 标量, 标量, 标量, 标量 )

ICCREATEHP (标量, 标量, 标量)

ICDESTROYGADGET 标量

ICDUMPERROR

ICMAKEDIR "字符串"

ICSAMPLEINFO 标量

ICSHOW 标量

INJECTORS7673 ( )

INSTRVIEW 信号，标量

LBADDENTRY "消息", "文本", ["帮助文件名"] [,帮助编号]

LBCLEAR ["文件名"]

LBCREATEBM (位图,x,y)

LBDISPLAY 0/1 [,"文件名"]

LBPRINT ["假脱机系统文件名"] [,"记事簿的数据路径和文件"]

LBSAVEAS "源数据路径和文件", "目的数据路径和文件"

MSMETHODEDIT ( 标量, 字符串 )

MSMETHODLOAD

MSMETHODPRINT "字符串"

MSMETHODSAVE "目录名"

MSQUERYTUNE ( )

MSRECOVER "文件名 — 完整路径"

MSRTCHANGE

MSSENDVALVES

MSSHOWDEVICEWIN 标量, 标量, 标量, 标量

MSTEMP SOURCE / QUAD [,实际] [,当前设定值] [,新设定值] [,当前极限] [,新极限]

MSVIEWPARAMS ( )

MS_SEND_VALVES

NOTRAY7673

PICKTUNEFILE

READBARCODE$ ( )

RCMETHODEDIT ( )

RCMETHODLOAD

RCMETHODPRINT "文件名"

RCMETHODSAVE "目录名"

RUNABORT

RUNERROR

RUNSTART 标量,标量

SCCLEAR

SCERROR [反应]

SCPOLL

SCQUERY "SC 命令字符串", [变量名]

SCTRACE [覆盖]

SCWRITE "SC 命令字符串"

SCWRITERD "SC 命令字符串", [变量名]

SENDMODULE$ ("68GC", "命令字符串")

SETCIACTIVE 打开 / 关闭

TEMPEQUIL

USETRAY7673

WRITEMODULE "68GC", "命令字符串"


数据分析命令

数据分析命令和函数

在 Data Analysis（数据分析）中可以使用以下命令和函数。列表中包含一般的数据分析、定量、谱库和积分命令。专用于 Chemical Structures（化学结构）软件的命令已标出，它们不能用于宏中，除非已配置相应软件。

请注意，函数要包含一个跟在函数名后的圆括号 ( ) 中的值。在命令中，可选的参数显示在方括号 [ ] 中。

另见

输入命令

+ 运算符

- 运算符

* 运算符

[ ] 运算符

ABORT

ADDPEAKS 变量

ALLCONT [1/0]

ANNOTATE 窗口，对象编号, x, y [,"文本", 相对位置 [,NOREFRESH] [颜色索引]

AREAREJECT 值，时间

AREASUM 1/0, 时间

AUTOINT 变量, , , 面积截除

AVERAGE 时间 1:时间 2 [,变量] [,文件描述符对象]

BASELINE NOW / NEXTVALLEY / BACK, 时间

BASELINE ALLVALLEY / HOLD, 1/0, 时间

BSB [时间 1:时间 2] [,变量] [, "文件名"] [,DONTASK] [,忽略] [,文件描述符对象]

CALEXCEL

CALIBPRINT x0, y0, x1, y1, 结果编号, "文件名", 标量

CALRPT [输出形式]

CCCHK [输出形式]

CCRPT [输出形式]

CHROMATOGR [时间 1：时间 2] [，质量 1] [，...][，质量 10]

CLEAR [窗口]

CLEAR 变量，结果类型

CLEARCPNDS [选项] [，模式]

CLIP 窗口 [，文件名]

CLREVENTS

CMI gcms 对象，左边时间，右边时间，左边高度，右边高度，基线检查

COMPOUND [化合物编号]

CPDANALYZE [文件描述符对象] [,n]

CREATEWINDOW (结构对象, 窗口 id, xlow:xhigh, ylow:yhigh)

CSADDSTRUCT "数据库文件名", 结构对象 [, 结构 id [, "结构标题"]]

CSATTACH 结构对象, ms 对象, xlow:xhigh, ylow:yhigh

CSCHRO [文件描述符] [,扫描范围], 过滤器谱; 目的

CSCOPY 结构对象

CSCOPY 结构窗口对象

CSCOPY 结构 id

CSCOPY "cas 编号字符串"

CSCREATE (结构 id, "数据库文件名")

CSCREATE ("cas 编号字符串", "数据库文件名")

CSDRAWOPTS [结构对象]

CSEXISTS (结构 id, "数据库文件名")

CSEXISTS ("cas 编号字符串", "数据库文件名")

CSLIBS

CSMFATTACH 图元文件对象, ms 对象, xlow:xhigh, ylow:yhigh

CSMFATTACH 图元文件对象, gcms 对象, xlow:xhigh, ylow:yhigh

CSMFCREATE ( )

CSMOLCREATE ("mol 文件名")

CSSUBSET "结构 id 列表文本文件", "源结构数据库文件名"

DELETEINTPEAK 窗口, 对象, 保存时间

DLGQDBSETUP 代码

DOLIST ["宏名称"]

DOSCAN ["宏名称"]

DRAW [窗口] [,变量] [,x1:x2] [,y1:y2]

EASYID

EDITCPNDS [变量 1], 变量 2, [n]

EDITEVENTS 标量

EDITGCVALCC

EDITGCVALEPA

EDITGCVALLSC

EDITGCVALTUNE

EDITHEADER [X] [,操作] [,项编号]

EDITMETHFILE "文件名"

EDITSTRATEGY [u+a] [,标志阈值] [,斜置] [,纯度] [,交叉相关] [,重复] [,低过滤器] [,高过滤器] [,最大匹配]

EDITVALCC

EDITVALEPA

EDITVALLCS

EDITVALTUNE

EIC [时间 1:时间 2] ,质量 [,变量] [,文件描述符对象]

ENDJOB

ENDLOG

ENDPRINT

ENDSET [相关窗口]

ENDWHILE

EXCHANGE [变量] [,变量]

EXIT

EXPORTRSLT ["源文件"] [,"Excel 目的文件"] [,文件描述符对象]

FILEcd13 ["数据文件名"]

FILEPRINT "文件名", x, y

FILTER (类型, 数字, 宽度, 步长)

FINDBYCAS cas 编号 [,"谱库"]

FORMAT [MERGED / SEPARATED] [,LABELPEAKS / NOLABELPEAKS] [,重绘] [,自动设定 Y] [,TIMEPEAKS / NOTIMEPEAKS]

GET 关键字, MS 对象/ GC/MS 对象 [,标量] [,标量] [,范围]

GETCOMPOUND [类型] [,化合物编号] [,FULL]

GETMSREF 项编号 [,"谱库文件名"] [,变量] [,CONDMS / FULLMS]

GETRESULT , 结果编号, "文件名" [,FULL] [,匹配编号]

GETSCALARS [INFO] [,对象]

GETSCALARS INDEX [,类型] [,索引] [,对象 ]

GETSCALARS POINT [,Xval:Xval] [,对象 ]

GETSCALARS RESULTS [,对象] , [,结果编号]

GETWINDOWTEXT$ (结构窗口对象)

GRAPHICS

GRP

HGFILE "数据文件名"

INITREJECT 值

INITTHRESH 值

INITWIDTH 值

INSERTINTPEAK 窗口,对象,时间 1,时间 2,丰度 1,丰度 2,基线

检查

INTEGRATE [变量] [,时间 1:时间 2]

INTEGRATOR 1/0, 时间

INVERSEB (GCMS 对象)

INVERSEM (GCMS 对象)

LABEL [输出形式] [,页码]

LIBRESULTS [对象]

列表

LOADMETHPANEL ["方法"] [,清除]

LOADQUANTMETH

MAKEBAR 变量

MAKECONT 变量

MENUSTATE（菜单项编号）

MENUSTP ["标签字符串"] [,"消息字符串"]

MI [变量], 时间 1, 时间 2, 丰度 1, 丰度 2 [,基线检查]

MSCLIP [变量] ,质量 1:质量 2

MSTRUNC [变量], 百分比

MULTITHUMB

MW "分子式"

NEGPEAKS 1/0, 时间

_NML [归一化值] [,ms 对象 / gcms 对象]

NORMALIZE [归一化值] [,变量]

ORIGINAL

PAGESIZE [x 的变量名] [,y 的变量名]

PBMSEARCH ["谱库文件名"], 变量

PCTRPTOPT [计算类型, 到屏幕, 到打印机, 到文件, "报告文件名", 报告标记, 积分类型, "积分文件名"]

PEAKFIND 保存时间, 对象

PEAKNUMBER [峰编号] [,START / TOP / END], 变量 [,结果]

PEAKVARS [峰编号] [,START / TOP / END], 变量

PEAKVARS , 峰编号, 组编号

PEAKWIDTH 值, 时间

PICSIX

POINTS [变量]

PRCLOSERESULTS

PRGETRETRESULTS 项编号, 谱库名

PRPARAMS

PRRESULTS

PRRETRIEVE [继续]

PRSAVEPARAMS

PRSETPARAMS 要更改的变量, on 或 off, RANGE / SCALAR / STRING

PRSETWINPOSITION x 位置，y 位置

PUTCOMPOUND 化合物编号 [,INSERT]

QCAL ["级别 id"] [,"文件"] [,upd_resp_tp] [,upd_rt_tp] [,upd_qi] [,upd_ref] [,保存]

QCALCC

QDEL [化合物编号] [, 匹配编号]

QEDIT

QLIST ["宏名称"]

QREF

QT [计算] [,输出形式] [,"选项"] [,化合物编号]

QUALPARMS ["谱库 1", "谱库 2", "谱库 3"] [,阈值 1, 阈值 2] [,选择方法] [,本底时间] [,积分类型] [,"文件名"]

QUALRPTOPT [ 冗长, 到屏幕, 到打印机, 到文件, "文件名", 在运行方法期间]

QUANTPARMS 参比窗口尺寸, 参比窗口类型, 非参比窗口尺寸, 非参比窗口类型, 相关窗口, 乘积因子, 浓度

QUANTRPTOPT [报告类型, 到屏幕, 到打印机, 到文件, "文件名", 生成报告, 化合物编号]

QUANTSAVE [路径] [,文件]

QUEUE ["命令"] [,"报告系统"]

RECALIB "结果文件.RES" [,标量]

RECALL 变量, "文件名"

REFRESH [窗口]

REPORT_TIC [输出形式] [,"类型"]

ROLL [数字]

RRCAL [类型] [,总离子色谱]

RRCAL [类型] , 化合物类型

RTEINT [变量]

RTEINTPARMS [类型, 面积, 最大峰, 数据点组合, 启动, 停止, 复位, 峰谷, 过滤器, 基线, 坐标设定因子, 位置, IP]

SAVEEVENTS "文件名"

SAVEMETHPANEL "方法路径"

SAVEMISC "文件名.mac" [,标量]

SAVESTRATEGY "文件名.mac"

SCAN 扫描编号 [,变量] [,文件描述符对象]

SCREEN docalc, 输出形式, 格式

SELECTFILTER 过滤器类型, [过滤器谱, 步长大小, 显示步长大小]

SETUPCALIB

SETWINATTRIBUTE 窗口, 属性, 值, "宏名称"

SETWINDOWLOC 结构窗口对象, x, y

SETWINDOWLOC "窗口标题", x, y

SETWINDOWTEXT 结构窗口对象, "窗口文本字符串"

SHOULDERS 1/0

SHOWWINDOW 结构窗口对象，显示模式

SLOG [详细信息]

SMOOTH (z, 过滤器数组)

SMOOTHCHR (z, 过滤器数组)

SOLVENTS 1/0, 时间

SPECTRUM 时间 [,变量] [,文件描述符对象]

SPIKE [输出形式] [,矩阵]

STACK [1/0]

STARTANALYSIS ["文件名"] [,标量]

STARTJOB ["作业描述"]

STARTPRINT

STARTREPORT "结果文件名"

STARTSET 排列顺序

STORE 变量, "文件名"

STRPRINT "字符串", x, y

SUBTRACT [SUPPRESS]

SUBZERO (y,x)

TABULATE [信息类型] [,"PRINTER" / "CRT" / "CONSOLE" / "文件名"] [,变量]

_TAB [信息类型] [,"PRINTER" / "CRT" / "CONSOLE" / "文件名"], ms 对象 [,数据范围] [,丰度值]

_TAB [信息类型] [,"PRINTER" / "CRT" / "CONSOLE" / "文件名"] ,gcms 对象 [,数据范围]

_TABH , "PRINTER" / "CRT" / "CONSOLE" / "文件名" , 文件描述符对象

TANSKIM 时间

THRESHOLD 值, 时间

TIC [时间 1:时间 2] [,变量] [,文件描述符对象]

TOOL ["化合物编号" / "所有"]

TRANSFORM X0:X1, X2:X3 [,变量] [,XAXIS / YAXIS]

TRFILE

TUNECHECK [输出形式] ,"参数文件"

UPDATECALIB ["级别 ID", "级别文件名称", ,,respact,,rtact,qiact]

UPDATERSLT 峰面积, 保存时间, 开始时间, 结束时间, 起始基线, 结束基线, 结果编号, "结果文件名", 匹配编号

VIEWCALCURVE

VIEWPBMTEXT 变量, 匹配编号

WINDOW [窗口], X1:X2,Y1:Y2

WINEXIST (窗口)

WINPOSITION 窗口 [,x1] [,x2] [,y1] [,y2]

WINPRINT 窗口, x, y, 宽度, 长度 [,无 Y 轴]

WINVARNAME$（窗口）

_XFM X0:X1, X2:X3 [,变量] [,XAXIS / YAXIS]

XPAND [分钟]

ZOOM 窗口, X1:X2, Y1:Y2

ZOOMOUT 窗口


变量

所有 MSD 化学工作站的变量在此按字母顺序说明如下：

保留变量 A 到 D (_A to _D)

保留变量 E 到 P (_E to _P)

保留变量 R 到 Z (_R to _Z)

A 到 D | Q
E 到 M | R 到 S
N 到 P | T 到 Z

使用变量时要用到的应用程序和命令在每个录入的最后一行给出，例如：

(Top, STARTSEQPANEL).

所有应用程序（Data Analysis，Instrument Control 和 Top）都要用到的变量由 (All) 指派。

另见

使用变量


ABS

值 = ABS（数值表达式）

此函数返回表达式的绝对值。


ALERT

ALERT ["消息字符串"] [,类型] [,变量]

显示一个带有按钮的消息框，要求用户响应。

"消息字符串"

将显示在此框中的消息。它可以是任何有效的字符串表达式，包括字符串、变量或函数。缺省值为无任何消息。

类型

输入一个数字：

1 = 问号（警告符号）、OK（缺省）和 Cancel 按钮

2 = i（信息符号）和 OK 按钮

3 = 惊叹号（停止符号）和 OK 按钮

4 = 问号（警告符号）、Yes（缺省）和 No 按钮

5 = 问号（警告符号）、Yes、No 和 Cancel 按钮

变量

CP 变量的名称（没有问号），它可以接收用户对 ALERT 框作出响应的值。先前，此值存储在 CP 变量 _Button 中。此参数可覆盖该变量。如果省略此参数，_Button 可以使用如前。

示例

ALERT "将要删除文件，是否继续？", 1

ALERT "文件已删除。", 2

ALERT "错误！文件未被删除。", 3

变量集

_Button

0 = 选定 Cancel 或 No 按钮

1 = 选定 OK 或 Yes 按钮

如果键入 5：

0 = 选定 Cancel 按钮

1 = 选定 No 按钮

2 = 选定 Yes 按钮


ARRAYSTAT( )

值 = ARRAYSTAT（数组 1, 数据项数）

在提供的数组中取值并在一个数组中返回下列信息的数组函数；

[1] - 平均值

[2] - 标准偏差

[3] - 平均值的标准偏差

[4] - 总计

[5] - 最大值

[6] - 最小值

数组 1

先前已经测量的数组名称：例如，

DIM TEST, 40

创建大小为 40，名为 Test 的数组。

数据项数

传递到数组中的数据项数量。例如，ARRAYSTAT(test,3)。注意，如果尝试将多个项目发送到已调整为可接受大小的数组中（在此示例中，大于 40 个数据项），则数组的大小可确定可接受多少个数据项（此示例中只能接受 40 个数据项）。

如果发送的数据项数小于数组大小，请使用数据项目数。这可让您测量较大的数组，但只需填充和使用该数组的一部分，而不必在您每次要使用 ARRAYSTAT 时删除然后重新创建和测量该数组。

示例

dim test, 40 !创建带有 40 个“位置”的数组 test

test[1]=3 !将值 3 发送到 test[1] 中

test[2]=5 !将值 5 发送到 test[2] 中

test[3]=7 !将值 7 发送到 test[3] 中

A=arraystat(test,3) !将结果发送到 A

A[1]= 的结果是 15/3 或 5

A[4]= 的结果是 15

等等。


ASC( )

数字 = ASC("ascii 字符")

返回与参数的第一个字符相对应的 ASCII 表中的数字。

"ascii 字符"

用于查找 ASCII 表中的数字的字符。如果该参数包含多个字符，则将只使用第一个字符。

示例

b = ASC("A")

将 65 赋值给 b


BIT_AND( )

值 = BIT_AND (a,b)

一个函数，将 a 和 b 转换为 16 位的整数（二进制格式形式）然后返回这两个整数按位“与”的结果。用于解码质谱仪错误代码。

示例：

result = BIT_AND(6,2)

0110

*0010

0010

注：* 在此用作位与操作符。


BYE

退出当前应用程序。

讨论

除了 Top 外所有应用程序都加载一个名为 BYE 的宏，它不直接退出，而是提示确认退出。

该命令退出当前应用程序，清除所有数据、变量和宏。它恢复所有缺省设置并隐藏窗口。但是，考虑到快速激活，Top 可以不必完全从内存中删除应用程序（请参见命令 MEMMODE）。

要暂时搁置一个应用程序而不必删除数据或作任何更改，可以标记它（例如，使用 WINSIZE 0,0）。


CEIL( )

值 = CEIL (数值表达式)

该函数将表达式向上舍入到最接近的整数。


CHECK( )

值 = CHECK ("变量 / 宏 / 命令 / 函数", "名称")

检查具有给定 "名称" 的特定变量、宏、命令或函数是否存在。如果存在，该函数返回 1，否则返回 0。

"变量 / 宏 / 命令 / 函数"

一个关键字，指出您所检查的是变量、宏、命令还是函数。用于检查变量类型的关键字为 SCALAR、STRING、RANGE、ARRAY、MATRIX、SET、MENU。

"名称"

要检查的宏、变量、命令或函数的名称。名称必须完全匹配（即不能用缩写）。

示例

值 = CHECK(“SCALAR”, “X”)

如果 “x” 不存在或 x 不是标量则返回 0；如果 x 存在而且是标量则返回 1。


CHR$( )

ascii$ = CHR$(ascii 数字)

返回与 ASCII 码表中的数字相对应的字符。

ascii 数字

ASCII 码表中的数字，返回其对应的字符。该数字必须介于 0 和 255 之间。

示例

b$=CHR$(65)

将字符 "A" 赋值给 b$


CLOSE

CLOSE [#文件编号] [,...]

删除文件编号与文件名称的关联。这些关联是在使用命令 OPEN 时生成的。

#文件编号

如果未指定文件编号，则删除所有文件编号/文件名称的关联。

示例

假设先前打开了文件 1-10。要关闭文件 3 和 5，可以输入：

CLOSE #3, #5


CMDLINE

CMDLINE 1/0

打开 (1) 或关闭 (0) 命令行的显示。

可以从应用程序窗口的控制菜单打开某个应用程序的命令行。命令行可见时，可以使用 F3 功能键再次调用上次（由您或者系统）输入的命令。

变量集

CmdLineState

0 = 命令行关闭

1 = 命令行打开


COLS( )

值 = COLS ( 矩阵名称)

返回某个矩阵对象的列数。

矩阵名称

包含矩阵对象的变量。

示例

Y = COLS(X)

将 X 的列数赋给 Y

COLS(X)

将 X 的列数写到消息行。


COMMANDS

列出当前应用程序中可用的宏和命令。如果命令行可见，在宏或命令名称上单击，它将显示在命令行上。

OK（确定） 保持显示命令，允许添加参数（如果需要的话）之后再使用该命令。Cancel（取消） 从命令行清除命令。


COPY

COPY "源名称", "目的名称" [,DONTASK]

复制某个文件或包括所有文件和子目录的目录。

"源名称"

要复制的文件或目录名称。建议使用完全限定的文件名和目录名。

"目的名称"

要创建的文件或目录名称。如果未指定路径，则使用源文件的路径。源名称和目的名称之间必须用一个逗号来分隔。

DONTASK

若指定了该关键字，COPY 不给出覆盖文件或目录的警告。该关键字不能缩写，它前面必须有一个逗号。


CPBYE

仅在内部使用。


CPPURGE

CPPURGE 符号

仅在内部使用。


CPSHOWWIN

CPSHOWWIN winid [,loc]

将当前应用程序图标化，然后显示指定应用程序。

winid

要显示程序的 id（窗口句柄）

loc

显示的位置：

0 = 不缩放或移动，只显示

1 = 这个 CP 程序的当前 (x,y)

2 = 这个 CP 程序的当前 (x,y) 和 (dx,dy)。


CPTAG

CPTAG 符号

仅在内部使用。


CPTITLE

CPTITLE "标题字符串"

更改当前应用程序窗口的标题。您也可以使用任何有效的字符串表达式（可以包括字符串、变量或函数）。


CPTITLE$( )

标题字符串$ = CPTITLE$ ( )

返回由 CPTITLE 命令设置的当前窗口标题。


CPTOOL

CPTOOL 符号, 任何对象, 符号, 标量

仅在内部使用。


DATE$ ( )

date$ = DATE$ ( )

该函数以 mm/dd/yy 格式返回当日日期。


DDEADVISE

DDEADVISE 通道,"项",变量名

无论数据何时更改都与 DDE 服务器建立一个热链接，以从该服务器获取数据。

通道

标识特定 DDE 会话的编号。该数值由 DDEINITIATE () 函数获得。

"项"

标识所请求信息项的字符串。

变量名

接收所请求项的变量名。请注意，该命令只使用全局变量，而“不能”使用局部变量。


DDEEXECUTE

DDEEXECUTE 通道, "命令"

给 DDE 服务器发送要执行的命令。

通道

标识特定 DDE 会话的编号。该数值由 DDEINITIATE () 函数获得。

"命令"

一个字符串，它是 DDE 服务器要执行的命令。

讨论

DDE 客户机使用该命令，以在 DDE 服务器上启动操作。该命令处于等待状态，直到 DDE 服务器指示可以进行。每一台服务器都以自己的方式指示其何时可用。某些服务器只在命令已执行后才指示可用。其他服务器则立即指示可用，并随后执行此命令。MS ChemStations（化学工作站）支持两个不同的主题（CPWAIT 和 CPNOWAIT），因此无论要进行哪种操作，DDE 客户机都可以完成。


DDEINITIATE( )

通道 = DDEINITIATE ("应用程序名", "主题")

该函数启动一个 DDE 会话，并返回一个标识该会话的编号。

"应用程序名"

指定应用程序名的一个字符串，利用它来启动会话。应用程序名的格式如下：

名称[任务 id]

其中名称是一个字符串而任务 id 是一个编号。后者由 EXEC() 函数获得。另请参见以下变量的描述：

_DDEname$

_INSCTLDDE$

_DaDDE$

"主题"

一个字符串，指定会话的主题。

讨论

该函数返回一个标识 DDE 会话的编号。如果没有可建立的会话，则编号为零。在随后所有涉及该会话的 DDE 命令中，都必须使用该编号。


DDEPOKE

DDEPOKE 通道, "项", "字符串"

从一台 DDE 客户机向 DDE 服务器单向发送一个未被请求的数据项。

通道

标识特定 DDE 会话的编号。该数值由 DDEINITIATE () 函数获得。

"项"

标识所发送信息项的字符串。

"字符串"

一个字符串，它是要发送到服务器的数据。


DDEREQUEST

DDEREQUEST 通道,"项",变量名

由 DDE 客户机使用，以从 DDE 服务器获取数据项。

通道

标识特定 DDE 转换的编号。该数值由 DDEINITIATE () 函数获得。

"项"

标识所需信息项的字符串。

变量名

接收所请求项的变量名。


DDETERMINATE

DDETERMINATE 通道

由 DDE 客户机使用，以终止指定的 DDE 会话。

通道

标识特定 DDE 会话的编号。该数值由 DDEINITIATE () 函数获得。


DELETE

DELETE "文件/目录" [,DONTASK]

删除某个文件或包括所有文件和子目录的目录。建议使用完全限定的文件名和目录名。

"文件/目录"

要删除的文件或目录的名称。建议使用完全限定的文件名和目录名。如果指定了某个目录，其中所有的文件和子目录都要被删除。

DONTASK

如果已指定，则不给出警告提示。该关键字不能缩写，它前面必须有一个逗号。


DIM

DIM 变量名, 标量 1 [,标量 2]

设置一个 阵列变量的维数。

变量名

要确定维数的矩阵变量的名称。

标量 1

指定一维矩阵的大小。

标量 2

指定第二维的大小。缺省=1.

示例

DIM test, 4

定义了一个具有四个“槽”的数组，分别指定为 test[1]、test[2]、test[3]、test[4]。

DIM test, 4.4

定义了一个二维数组，它有 16 个“槽”，分别被指定为

test[1,1] test[1,2] test[1,3] test[1,4]

test[2,1] test[2,2]...

test[3,1]...

...test[4,4]


DLLINSTALL( )

值 = DLLINSTALL ("文件名")

该函数设法安装名为 "文件名" 的动态链接库。如果路径并非文件名的一部分，就使用缺省执行路径。如果该函数成功地执行了，则返回加载的动态链接库 ID。


DLLREMOVE

DLLREMOVE 标量

删除 ID 标量所指定的动态链接库。


DOSRUN

DOSRUN "运行字符串"

运行一个 DOS 应用程序。

"运行字符串"

通常包括文件名，后跟空格，之后跟随参数。

文件名是要执行的、包含扩展名（.EXE、.BAT 等）的应用程序名称。如果未给定路径，就使用当前工作路径以及文件 autoexec.bat 中的 PATH 命令内容。

参数是应用程序所需要的。

讨论

该命令将命令行上的所有参数提交给 DOS，以作为要加载和执行的程序的名称进行译码，就如同用户已经在 Program Manager（程序管理器）中选择 Run（运行）选项一样。当前应用程序不必等待 DOS 程序结束，也不必与其进行任何通讯。

在宏中，应当在 DOSRUN 之后包含一个 SLEEP 命令以给应用程序留出启动时间。

示例

DOSRUN "wordpad.exe"


ECHO

ECHO 1/0

用于宏中以覆盖应用程序的反应模式。在宏中出现并对其他任何宏无影响的反应对该宏而言是局部的。

1/0

1（打开）允许覆盖。

另请参见

ECHOMODE


ECHOMODE

ECHOMODE 1/0

对当前应用程序设置反应模式。反应模式打开 (1) 时，显示所有仅报告信息和错误消息；当其关闭 (0) 时，仅报告信息的消息不显示。

如果一个宏不包含 ECHO 命令，则将使用该值。

讨论

对于所有的应用程序，ECHOMODE 最初是打开的。建议将 ECHOMODE 设置为关闭以提高速度。您在编写一个宏时，如果在其中能看到仅报告信息的消息是很重要的，则可使用 ECHO 命令覆盖当前反应模式。


IF - THEN - [ELSE -] ENDIF

在宏中使用。 指定条件的测试；如果存在，将执行指定的命令集，否则将执行不同的命令集；ELSE 是可选的。

语法是：

IF 条件 THEN

<命令列表>

ELSE

<命令列表>

ENDIF


EOF( )

iseof = EOF(文件号)

此函数确定指定的文件号是否位于文件末尾。在文件末尾时返回 1；否则返回 0。

文件号

要检查的文件的文件号。

示例

OPEN "test.txt" FOR INPUT AS #1

WHILE (EOF(1) <> 1)

INPUT #1, line$

! Process line$

ENDWHILE

CLOSE #1


EQSTR( )

结果 = EQSTR ("s1", "s2")

此函数可测试两个字符串是否相等；在比较中忽略大小写。

0 = 字符串不相等

1 = 字符串相等

"s1", "s2"

进行比较的字符串。

示例

EQSTR ("ABC", "aBc")

返回 1

EQSTR ("ABC", "aBc")

返回 0


EVALUATE

EVALUATE "命令字符串"

对字符串表达式求值，并作为命令执行此结果。对创建要执行命令很有用，如下例所示。

"命令字符串"

任何涉及字符串、变量或函数的有效字符串表达式。结果字符串必须是一个句法正确的宏名、命令或表达式。

示例

B$ = "THIS IS A TEST"

A$ = "PRINT B$"

EVALUATE A$

执行这一命令序列将会显示 THIS IS A TEST。


EXEC( )

TaskID = EXEC ("运行字符串", 窗口尺寸)

此函数启动一个 Windows 应用程序，并在实际启动时返回应用程序的任务标识。若应用程序并未运行，则任务标识为 0。在宏中，您应该通过在 EXEC( ) 后面包含 SLEEP 命令的方式赋予应用程序启动的时间。

这通常用于 DDEINITIATE 之前。

"运行字符串"

指定要启动的应用程序名称的字符串。它必须包含此应用程序需要的所有参数。

窗口尺寸

指定应用程序窗口尺寸的数字：

0 = 隐藏窗口

1 = 常规窗口

2 = 最小化窗口

3 = 最大化窗口


EXP

值 = EXP（数值表达式）

此函数返回表达式 e 的乘幂的值。


FILEATTRIBUTES$( )

string$ = FILEATTRIBUTES$ ("路径", "属性")

设置/返回指定文件的属性。以字符串格式返回指定文件的属性。

"路径"

文件的完整路径名。

"属性"

"N" 常规文件；读和写的权限。

"R" 只读文件。

"H" 隐藏文件。无法通过目录搜索找到此文件。

"Y" 系统文件；无法通过目录搜索找到此文件。

"V" 卷标识。此文件必须位于根目录下。

"S" 子目录。列出所有的子目录。

"A" 归档。列出具有 DOS 归档位集的所有文件。

可以合并所有常规文件、只读文件和子目录的属性（如 "NRS"）。若未给出属性，则不更改文件的属性，但会报告这些属性。


FILESIZE

FILESIZE "文件名"

获得指定文件的大小（以字节表示）。若未指定路径，则使用当前的工作路径。此命令对目录不起作用，因此此命令对方法和数据文件也不起作用。

变量集

Size - 以字节表示的文件尺寸（若文件存在）；

-1 = 文件不存在


FILESTAT( )

值 = FILESTAT ("目录" / "文件名")

一个数组函数，该函数以下列数组元素形式返回有关文件或目录（不允许为根目录，如 C:\）的信息。若指定了一个目录，则返回的大小为此目录（非子目录）下的所有文件大小值的总和。这包括隐藏文件和系统文件。

[1] - 上一次更新的月份 (1-12)。

[2] - 上一次更新的日期 (1-31)。

[3] - 自 1900 年以来上一次更新的年份。

[4] - 上一次更新的小时 (0-23)。

[5] - 上一次更新的分钟 (0-59)。

[6] - 以字节表示的文件大小。

[7] - 类型（0 = 不存在，1 = 文件，2 = 目录）。

[8] - 读访问标志（0 = 否，1 = 是）。

[9] - 写访问标志（0 = 否，1 = 是）。

[10] - 执行访问标志（0 = 否，1 = 是）。


FINDFIRSTFILE( )

值 = FINDFIRSTFILE ("掩码", 输出变量, "属性")

返回一个被称为“句柄”的数字，该数字可以用于识别和操作特定类型的文件。若出现错误（未找到该类型的文件）将返回 0。

"掩码"

文件标记，例如，*.mac 表示当前工作目录下带有扩展名 "mac" 的所有文件。

"输出变量"

保留找到的第一个文件的名称的字符串变量。若没有找到文件，则未定义此变量

"属性"

"N" 常规文件。具有读写权限的文件。

"R" 只读文件。

"H" 隐藏文件。无法通过目录搜索找到此文件。

"Y" 系统文件。无法通过目录搜索找到此文件。

"V" 卷标识。此文件必须位于根目录下。

"S" 子目录。列出所有子目录。

"A" 归档。列出具有 DOS 归档位集的所有文件。

可以合并属性，例如，"NRS" 表示所有常规文件、只读文件和子目录。

示例

a = FINDFIRSTFILE("*.mac","a$","NR")

返回当前工作目录下的所有常规和只读宏文件的句柄；将找到的第一个文件放置在字符串变量 a$ 中。


FINDNEXTFILE( )

值 = FINDNEXTFILE (句柄, "输出变量")

可以与函数 FINDFIRSTFILE( ) 一起使用以标识和操作多种类型的文件。若找到句柄标识的文件类型，将返回 0，且将文件名放到输出变量中。若存在错误，将返回一个 DOS 文件错误，且输出变量为空。

句柄

FINDFIRSTFILE 返回的值。

"输出变量"

包含文件名（如果存在）的字符串变量。

示例

查找所有具有 "mac" 扩展名的文件，并将它们列在一个文件中。

Name Findtest

local a,a$

open _ExePath$+"test.out" for output as #2

a=FINDFIRSTFILE(_ExePath$+"*.mac","a$","NR")

if (a = 0) !No files found

CLOSE #2

return

endif

print using #2, "%/", a$

while (FINDNEXTFILE(a,"a$") = 0)

print using #2, "%/", a$

endwhile

CLOSE #2

return

Print the volume ID of the supplied drive letter.

Name VolID

parameter drive$ default "C"

local a,a$

a = FINDFIRSTFILE(drive$+":\*.*","a$","V")

if (a = 0) !

print a$

endif

return


FLOOR( )

值 = FLOOR（数值表达式）

此函数将表达式向下舍入到最接近的整数。


FREESPACE( )

字节数 = FREESPACE("盘符")

此函数返回指定驱动器上的可用字节数。


GENERATE_ERROR

GENERATE_ERROR [错误号] [,"字符串"]

生成一个特定错误。

错误号

要使用的错误号。缺省为变量 _Error 的内容。

"字符串"

要在消息行报告的消息。缺省为变量 _ErrMsg$ 的内容。

讨论

无论何时出现错误，其值和消息都将被记录在保留变量 _Error 和 _ErrMsg$ 中。错误通常会停止宏的执行；但是，若 ON_ERROR 起作用，则此错误将被忽略。此命令允许错误处理例程重新创建其不能处理的错误。


GETCWD$( )

cwd$ = GETCWD$ ( )

此函数返回当前工作目录的名称。


GETINFO( )

值 = GETINFO ("项名称")

此函数返回有关指定硬件部件状态的信息。

"项名称"

指定要检索其信息的部件。下面列出返回值的含义。x 表示一个非零数字。

"ALS_ID"

0 = 没有连接的 ALS （缺省）

x = WIN.INI 中的值

"ALS_TYPE"

0 = 无

1 = 7673

"GC_ID"

0 = 没有连接的 GC（缺省）

x = WIN.INI 中的值

"INLET_GC"

0 = 6890（缺省）

2 = 其他或无

"MS_CI"

0 = 未安装（缺省）

1 = 已安装

"MSCONNECTION"

0 = 前进样口

1 = 后进样口

"MS_DCI"

0 = 未安装（缺省）

1 = 已安装

"MS_DCPOL"

0 = 5972 的正设置

1 = 5972 的负设置

2 = 未设置

"MS_DIP"

0 = 未安装（缺省）

1 = 已安装

"MS_EI"

0 = 未安装

1 = 已安装（缺省）

"MS_EXTRA"

0 = 无（缺省）

x = 额外

"MS_EXTRA2"

0 = 无（缺省）

x = 额外

"MS_FAB"

0 = 未安装（缺省）

1 = 已安装

"MS_HED"

0 = 未安装（缺省）

1 = 已安装

"MS_ID"

0 = 没有连接的 MS（缺省）

x = WIN.INI 中的值

"MS_NI"

0 = 未安装（缺省）

1 = 已安装

"MS_TYPE"

4 = 5973 MSD

99 = 没有 MS

"OFFLINE"

0 = 仪器联机

1 = 仪器脱机


GETINIINT( )

值 = GETINIINT("文件名", "应用程序名", "关键字名称")

此函数为指定的应用程序搜索已提供的 .ini 文件，并返回与关键字名称相关的正整数。若文件名参数为一个空字符串("")，则所使用的 ini 文件为 %SystemRoot%\msdchem.ini。若关键字名称不存在，则返回 -1。


GETINISTRING$( )

string$ = GETINISTRING$("文件名", "应用程序名", "关键字名称")

此函数在所提供的 .ini 文件中搜索指定的应用程序，并返回与此关键字名称相关的字符串，最多可达 132 个字符。若遇到错误，此函数将返回一个空字符串。若文件名参数为一个空字符串("")，则所使用的 ini 文件为 %SystemRoot%\msdchem.ini。


GETPROPERTY

GETPROPERTY 字符串, 字符串, 符号

仅在内部使用。


GETWINDOWID

GETWINDOWID "标题"

获取与 MS Windows（MS 窗口）应用程序相关的Windows ID（窗口 ID），并将其放置在变量 _WindowID 中。若未打开具有指定标题的窗口，此变量将被设置为 0。

"标题"

出现在应用程序标题栏中的标题；例如，“记事本”。

示例

在其他应用程序结束前，可使用以下宏来等待，例如，一个网络文件传输程序。

NAME WaitForWindowToGoAway

PARAMETER WinName$

GETWINDOWID WinName$

WHILE (_WindowID > 0)

SLEEP 3

GETWINDOWID Title$

ENDWHILE

RETURN

NAME WaitFor FTP

WaitForWindowToGoAwau "FTP - 网络传输"

RETURN

变量集

_WindowID

0 = 不存在具有该标题的窗口

>0 = 窗口存在


GETWINLOC

GETWINLOC [x] [,y] [,宽度] [,高度]

获取应用程序窗口的位置和大小。

x,y

指定窗口左上角的当前位置。其值以屏幕宽度和高度的分数表示。稍后将在 WINMOVE 命令中使用这些值。

宽度,高度

指定窗口的当前宽度和高度。其值以屏幕宽度和高度的分数表示。若对窗口进行缩放，两个值都将为 1。若将窗口最小化，两个值都将为 0。稍后将在 WINSIZE 命令中使用这些值。


HELP

弹出已显示主题列表的 Help（帮助）窗口。可选的标量参数指定特定帮助屏幕的前后关系编号（仅内部适用。）


INISTRFORINT$( )

string$ = INISTRFORINT$ ("文件名", "应用程序名称", 标量)

提供文件、应用程序和整数，并且在字符串变量中返回关键字名称。若文件名参数为一个空字符串("")，所使用的 ini 文件为 %SystemRoot%\msdchem.ini。若遇到错误，此函数将返回一个空字符串。


INPUT "字符串"

INPUT "字符串表达式", 字符串变量

如果第一个参数为字符串表达式，将显示对话框，包含将要放置在已命名字符串变量中的信息的提示。可用于创建交互宏。

"字符串表达式"

可以为包含字符串、变量或函数的任何有效字符串表达式。最多可以输入 79 个字符。

字符串变量

将编辑框中输入的文本赋给此变量。

讨论

此命令显示具有指定提示字符串、编辑框、OK（确定）和 Cancel（取消）按钮的对话框。如果此变量存在，将会在编辑框中显示其值。如果选定 Cancel（取消）按钮，将不读取值，且变量 _Button 设为 0。否则，字符串变量被设为编辑框中输入的任何内容，且 _Button 设置为 1。

示例

NAME Example

ON_ERROR EnterNumber !打开错误陷阱

EnterNumber

ON_ERROR EnterNumber !打开错误陷阱

RETURN

NAME EnterNumber

INPUT "键入一个大于零的数字", string$

IF VAL(string$)>=0

IF VAL(string$)>=0

ELSE

GENERATE_ERROR 1, "那不是一个数字"

ENDIF

RETURN

变量集

_Button

按下的按钮（1, 2, 或 3）的编号。如果按下 Enter，即使不显示按钮 1，_Button 也将返回 1。如果按下 Esc，_Button 将返回 2。


INPUT #文件编号

INPUT #文件编号, variable$

从 #文件编号指定的文件中读取换行终止的文本行，并将其赋予给指定的变量名，变量名必须以 $ 结尾。


INPUT6

INPUT6 类型, 数量, "标题", 标签对象, 按钮对象, 变量名称, [帮助索引], [帮助文件]

用在宏中，以允许用户输入。

类型

1 = 将显示一个具有 1 到 6 个编辑框的面板

2 = 将显示一个具有 1 到 6 个检查框的面板

3 = 将显示一个具有 1 到 6 个单选按钮的面板

数量

要显示的项的数目。

"标题"

要在面板标题栏中显示的字符串。

标签对象

包含所有控件标签的字符串数组。每个标签最多为 40 个字符。实际显示的字符数可能由于字符宽度的不同而更少。如果要在标签内指定一个加速键，请在字母前输入一个 ＆ 号（例如，"Se&cond Label" 让用户通过按下 Alt-c 来访问此项)。

按钮对象

包含按钮的字符串的字符串数组。按钮从左到右编号，从 1 开始。若标签字符串为空，将不显示此按钮。

每个按钮最多为 8 个字符。实际显示的字符数可能由于字符宽度的不同而更少。

注释：在单选按钮的情况下，双击任何项与单击此项以及按下 Enter 键具有相同的效果。

Enter 键 — 如果按钮之一具有 "OK"（确定）标签（没有定义加速键），Enter 键将与 OK（确定）按钮具有相同的功能。

Escape 键 — 如果按钮之一具有 "Cancel"（取消）标签（没有定义加速键），Escape 键将与 Cancel（取消）按钮具有相同的功能。

变量名

存储结果的变量的名称。创建的变量的类型取决于显示的控件的类型。

Edit（编辑）框 — 保留每个编辑框中键入的字符串的字符串数组。对应于面板上顶部项的数组元素 1。

检查框 — 一个标量数组，包含每个显示的检查框的状态。A 1 指示该框已被检查，0 指示框未被检查。对应于面板上顶部项的数组元素 1。

单选按钮 — 指示最后一次所按按钮的标量变量。

帮助索引

定位帮助的帮助文件中的索引编号。若此编号为 0 或丢失，将不显示帮助按钮。

帮助文件

帮助文件的完整路径名。È±Ê¡为 _HelpPath$+_HelpName$。

示例

name six

local a,array,labels$,text$,buttons$,i

sdim labels$,6

labels$[1] = "First Label"

labels$[2] = "Second Label"

labels$[3] = "Third Label"

labels$[4] = "Fourth Label"

labels$[5] = "Fifth Label"

labels$[6] = "Sixth Label"

sdim buttons$,3

buttons$[1] = "One"

i=1

while (i <= 6)

dim array,6

array[1] = 1

array[2] = 0

array[3] = 1

array[4] = 0

array[5] = 1

array[6] = 0

Input6 2,i,"Test of Check Six Box",labels$,buttons$,array,4998

!print array[1], array[2], array[3], array[4], array[5]

print "Button = ",_Button

i=i+1

endwhile

i=1

while (i <= 6)

a = 1

buttons$[2] = "One"

Input6 3,i,"Test of Radio Six Box",labels$,buttons$,a,4998

!print c

print "Button = ",_Button

i=i+1

endwhile

i=1

while (i <= 6)

sdim text$,6

text$[1] = "First Line of Text"

text$[2] = "Second Line of Text"

text$[3] = "Third Line of Text"

text$[4] = "Fourth Line of Text"

text$[5] = "Fifth Line of Text"

text$[6] = "Sixth Line of Text"

buttons$[3] = "Three"

Input6 1,i,"Test of Input Six Box",labels$,buttons$,text$,4998

!print text$[1], text$[2], text$[3], text$[4], text$[5]

print "Button = ",_Button

i=i+1

endwhile

return

变量集

_Button

按下的按钮（1, 2, 或 3）的编号。如果按下 Enter，即使不显示按钮 1，_Button 也将返回 1。如果按下 Esc，_Button 将返回 2。


INSERT

INSERT 索引, 目的, 源

将源对象插入到集合中。

索引

一个数字，为集合（列表）中要放置源的位置。<=1 的值会将对象放在列表头。大于当前大小的值会将对象放在末尾。ÆäËû 'n' 值，源对象被插入到 'nth' 位置。

目的

源对象要插入到的集合（列表）的名称。

源

要插入的对象的名称。它必须是一个集合。如果操作成功，将删除名称。


INSTR( )

值 = INSTR ("s1", "s2")

此函数返回一个整数，表示字符串 s1 中字符串 s2 开始的位置。大小写是至关重要的。

示例

INSTR ("look in here", "in")

返回 6


JOIN

JOIN 目的名称, 源名称

将源名称中的对象附加至目的名称中的对象，然后删除源名称。

目的名称, 源名称

它们都是必需的参数。源名称对象必须存在。如果目的名称对象不存在，JOIN 的作用就与 EXCHANGE 命令完全一样。

讨论

这是对对象所做的破坏性的附加操作。此命令部分替代旧的 Data Analysis（数据分析） MERGE 命令。MERGE 命令的完全转换如下：

JOIN Y, X !将 X 附加到 Y, 破坏 X

EXCHANGE X, Y !滚动堆栈

EXCHANGE Y, Z

EXCHANGE Z, T


LEN( )

值 = LEN ("字符串表达式")

此函数返回表达式中的字符（包括空格）数。


LN( )

值 = LN（数值表达式）

此函数返回表达式的自然对数（以 e 为底）。


LOCAL

LOCAL 变量名 [,变量名] [,...]

用于宏中，以设置仅用于此宏的变量。

变量名

数值变量或字符串变量的名称。如果局部变量不存在，将创建它。将字符串初始化为空字符串 ("")，标量初始化为 0。

讨论

LOCAL 命令可以在宏中的任意位置出现。如果局部变量已经由于之前的一个 PARAMETER 语句或一个 LOCAL 命令而存在，则将按照以上描述重新设置它。

允许将一个新值赋给局部变量。不需要作为字符串或标量保留它。一旦设置这些局部变量的宏完成，就将从内存中删除它们。

局部变量与全局变量具有相同的名称是可能的。在这种情况下，仅能访问局部变量。

当对宏进行故障排除时，查看局部变量内容的一种方便的方法是通过 REMOVE 命令。


=LOG(

值 = LOG (数值表达式)

此函数返回表达式的对数（以 10 为底）。


LOGGING

LOGGING [1/0] [,"文件名"] [,命令] [,消息] [,错误] [,信息] [,清除]

文件的日志命令、消息和错误。

1/0

启用 (1) 或禁用 (0) 记入文件日志。如果没有指定，将显示当前值和日志文件名。

"文件名"

缺省文件名为具有扩展名 .LOG 的应用程序名。如果文件存在，将附加此文件；否则，创建此文件。如果没有指定路径，文件将被放在 _InstPath$ 目录中。

命令

0 = 关闭（初始值）

1 = 打开。如果此项打开，由系统执行的所有命令将被记入到日志文件。如果未输入此值，将使用当前值。

消息

0 = 关闭（初始值）

1 = 打开。如果此项打开，打印在命令行上的所有消息（不考虑 ECHO 或 ECHOMODE）将被记入到日志文件。如果未输入值，将使用当前值。

错误

0 = 关闭

1 = 打开（初始值）。如果此项打开，打印在命令行上的所有消息将被记入到日志文件。如果未输入值，将使用当前值。

信息

0 = 关闭（初始值）

1 = 打开。如果此项打开，打印在命令行上的所有消息将被记入到日志文件。错误消息与其他描述性信息一起打印：

  • 日期和时间

  • 应用程序、方法、运行类型、样品瓶

  • 宏、命令

  • 错误消息

如果未输入值，将使用当前值。

清除

0 = 关闭（缺省）

1 = 打开。如果清除和记入日志都已打开，则将清除日志文件。否则，不改变此日志文件，打印在命令行上的所有错误消息将被记入到日志文件。1/0；当打开记录日志以在使用前清除日志文件时，使用 1（是）。

讨论

使用此命令将极大地减慢宏的执行速度，因而应当谨慎使用。

示例

假定 Top 正在运行，并且没有给定记录日志命令，那么

LOGGING ON

就将使错误被记录到 c:\MSDchem\1\mstop.log 中


LOWER$( )

string$ = LOWER$ ("字符串")

依据 Windows 启动时用户选定的当前语言标准，将给定的字符串转换为小写。


MACRO

MACRO ["宏文件名"] [,GO]

加载文件中的宏，且如果指定了 GO，将执行文件中最后一个宏。如果未指定路径，将使用 _AutoPath$ 的内容。如果没有指定文件名，对话框将列出可用的文件。

变量集

_Button

仅当未指定文件名时才进行设置

0 = 选中 Cancel（取消）按钮

1 = 选中 OK（确认）按钮


MDIARRANGE

排列图标。


MDICASCADE

层叠窗口。


MDITILE

MDITILE 0/1

平铺窗口。

0 = 水平平铺窗口（缺省）

1 = 垂直平铺窗口


MENUBEG

用于菜单栏宏中，以发出启动新菜单栏的信号。该命令必须后跟定义菜单栏和菜单项的其他命令。必须使用 MENUEND 命令来完成对菜单栏的定义。

另请参见以下命令： MENUNEW。 MENUCMD、MENUVAR、MENUSTP、MENUCHG、MENUSEP。

示例

MENUCMD


MENUCHG

MENUCHG [对象名], "字符串" [,"菜单项"] [,"命令/宏"] [,"帮助文本"] ["控制文本"]

立即更改菜单对象。即使当前正显示菜单对象，也要更改 — 不必调用 MENUSHW。

对象名

要修改的菜单对象（一个变量名）。缺省为 STDMENU

"字符串"

一个导航标签（用引号括起来的字符串），忽略空格、"&" 和 "."，并且区分大小写。"&&" 被当作字符 "&"。示例："file|exit"。注释：不要有大写字母、加速键、省略号或所需的选择等式。可以用截断的标签。例如，"File|1" 可以匹配象 File|1 c:\MSDchem\1\data\evaldemo.d 这样的菜单项。

"菜单项标签"

新的菜单项的名称。

"命令/宏"

新命令或宏。

“帮助文本”

消息行的新的帮助文本。

“控制文本”

用于变暗/复选的新的控制文本。


MENUCMD

MENUCMD "标签字符串", "命令字符串" [,"消息字符串"] [,变量名]

用于菜单栏宏中以定义执行宏或命令的菜单项。另请参见 MENUNEW。MENUVAR、MENUSTP、MENUCHG、MENUSEP。

"标签字符串"

菜单中该项的标签。要启用通过键盘 (Alt+key) 对菜单项访问，请在要使用的标签中的字母之前放置一个 & 符号。在菜单中，该字母由下划线标出。

"命令字符串"

一个宏或命令，确定当选中该菜单项时要执行的操作。

"消息字符串"

当该菜单项处于活动状态并突出显示时，出现在消息行上的信息。要关闭消息显示，使用 MENUHLP 0 命令。

变量名

用于控制菜单项显示形式的比例变量名。如果该变量不存在，或者其值无法识别，则使用缺省值零。该标量的可识别值是：

0 = 正常

1 = 已复选

2 = 已变灰

3 = 已变灰并已复选

讨论

您可以重复使用该命令以在一个菜单中定义选项。要在菜单中定义选项组，可以使用命令 MENUSEP，它用线分隔各组。要创建一个可在命令或宏运行时设置变量的菜单项，可使用命令 MENUVAR。

示例

以下的宏生成下面所示的菜单栏和菜单：

NAME ExampleMac

MENUBEG

MENUNEW "&File"

MENUCMD "&Load Data File...", "Idnewfile", "Provides dialog box for selecting a file"

MENUSEP

MENUCMD "E&xit", "Bye", "Quits this application"

MENUNEW "&Abort"

MENUSTP "Stop Now"

MENUEND

RETURN


MENUCMDFN

MENUCMDFN "标签字符串", "命令字符串" [,"消息字符串"][,"字符串"]

用于菜单栏宏中以定义执行宏或命令的菜单项。另请参见 MENUNEW。MENUCMD、MENUVAR、MENUSTP、MENUCHG、MENUSEP。

"标签字符串"

菜单中的该项的标签。要启用通过键盘 (Alt+key) 对菜单项访问，请在要使用的标签中的字母之前放置一个 & 符号。在菜单中，该字母由下划线标出。

"命令字符串"

一个宏或命令，确定当选中该菜单项时要执行的操作。

"消息字符串"

当该菜单项处于活动状态并突出显示时，出现在消息行上的信息。要关闭消息显示，应使用 MENUHLP 0 命令。

"字符串"

一个字符串，可以包含多达 25 个字符，将其估算为一个用于设置菜单项状态（正常、已复选等）的标量。


MENUEND

MENUEND [对象名]

用于菜单栏宏中以发出结束菜单栏信号。

对象名

要创建的菜单对象名称。如果给定名称，则创建对象但不显示菜单。

如果未给定名称，则使用缺省名称 STDMENU，并且将命令 MENUSHW STDMENU 作为下一个 CP 命令来提交。

该命令必须跟在 MENUBEG 命令以及其他定义菜单栏和菜单项的命令之后。

另请参见

MENUNEW

MENUCMD

MENUVAR

ENUSTP

MENUCHG

MENUSEP


MENUHLP

MENUHLP 1/0

启用 (1) 或禁用 (0) 菜单项的帮助消息在消息行上的显示。帮助消息由 MENUCMD 命令的最后一个参数定义。


MENUNEW

MENUNEW "名称字符串"

用于菜单栏宏中，以定义菜单栏中新菜单的启动。该命令后面必须跟随在菜单中定义项的命令，例如：

MENUCMD

MENUVAR

MENUSEP

"名称字符串"

出现在菜单栏中的标签或标题。可以是包含字符串、变量或函数的任何有效字符串表达式。

示例

请参见 MENUCMD 命令。

另请参见

MENUSTP

MENUCHG


MENUSEP

用在菜单栏宏中，将一条水平线置于菜单中。

另请参见

MENUNEW

MENUCMD

MENUVAR

MENUSTP

MENUCHG


MENUSHW

MENUSHW [对象名]

使已命名的菜单对象可见。先前的菜单对象不作任何更改。多个菜单对象可以同时存在。MENSHW 将在它们之间迅速切换。另请参见 MENUNEW。MENUCMD、MENUVAR、MENUSTP、MENUCHG、MENUSEP。

讨论

可以删除菜单栏宏。同样，也可以删除菜单对象，因为菜单系统已经通过参比计数将其“锁定”。

示例

NAME MyMenuBar

MENUBEG

...

MENUEND mymenuobj

remove MyMenuBar

!可以在任何时候删除宏

MENUEND mymenuobj

!显示菜单

remove MyMenuBar

!甚至在显示时都可以删除对象（尽管并非真的有用）


MENUSTP

MENUSTP ["标签字符串"] [,"消息字符串"]

用在菜单栏宏中，以定义终止当前宏或命令的菜单项。另请参见 MENUNEW。MENUCMD、MENUVAR、MENUCHG、MENUSEP。

"标签字符串"

显示在菜单中的标签；可以是包含字符串、变量或函数的任何有效字符串表达式。

"消息字符串"

当使用该菜单项时，将要在窗口顶部显示的消息，以黄色突出显示。

讨论

如果不存在正在进行的可终止操作，则终止功能就处于非活动状态（且在菜单中显示为灰色）。当该菜单处于活动状态而且已被选中时，就会对一个内部标志进行设置，并且在菜单栏下面的行上以黄色突出显示一条消息。当前应用程序通过终止正在进行的操作以响应该标志；这在当前正在执行的命令（如果可能）或在某个宏中的命令之间出现。

示例

请参见 MENUCMD 命令。


MENUVAR

MENUVAR "标签字符串", "赋值语句", "消息字符串"

用于菜单栏宏中以定义设置变量值的菜单项。另请参见 MENUNEW。MENUCMD、MENUSTP、MENUCHG、MENUSEP。

"标签字符串"

显示在菜单中的标签；可以是包含字符串、变量或函数的任何有效的字符串表达式。

"赋值语句"

必须以如下方式输入：

"变量名 = 表达式"

"消息字符串"

显示在菜单栏之下的黄色行上的消息。

讨论

除非存在正在进行中的可终止操作，否则该菜单项为非活动状态（且在菜单中显示为灰色）。该项处于活动状态并已被选中时，在当前应用程序中设置所定义的变量，并在菜单栏之下的行上显示一条消息。正在进行的命令或宏没有被中断。在当前应用程序退出之前或在使用 REMOVE 命令显式地将其删除之前，该变量保留在内存中。

示例

如果已定义了以下的菜单项：

MENUVAR "Stop_Loop", "Stop_Loop=1"

并且正在运行某个宏的以下部分：

Stop_Loop=0

WHILE (Stop_Loop=0) DO

  •

  •

ENDWHILE

那么选中菜单上的 Stop Loop（停止循环）选项将会在一个精确的点上（循环的顶部）终止 WHILE 循环，但不会停止宏的剩余部分。


MKDIR

MKDIR "目录名称"

创建一个 DOS 目录。推荐使用完全限定的文件名和目录名。

示例

MKDIR "d:\archive"

在磁盘驱动器 d: 上创建一个称为 archive 的目录。


MOD( )

余数 = MOD (a,b)

一个函数，返回 a/b 的余数。


MTIME( )

值 = MTIME ( )

此函数返回系统启动后经过的时间，以毫秒数表示。


NAME

NAME 宏名称

在宏中使用。为宏指定一个名称。这是宏定义的第一个语句，在命令行上不可用。

宏名称

用来调用宏程序的名称。

命令列表

包含宏的命令的列表。

讨论

此格式的命令用于那些不返回值的宏。若希望宏返回值，请参见 RETURN 命令。另请参见 Using and Writing Macros（使用和编写宏）手册。


NUM( )

值 = NUM (集合名称/数组名称)

返回一个集合中对象的数量或一个一维数组中元素的数量。

集合名称/数组名称

包含集合或数组的变量的名称。

示例

Y = NUM(X)

将 X 中对象（或元素）的数量放入 Y

NUM(X)

将 X 中对象（或元素）的数量写到消息行。


ON_ERROR

ON_ERROR 陷阱

在宏中使用以指定出错时要执行的命令或宏。

陷阱

任何有效的 ChemStation（化学工作站）宏或包括参数的命令。

讨论

ON_ERROR 应用于其“下”的所有命令或宏。假设宏 A 有一个 ON_ERROR 命令并且调用没有 ON_ERROR 命令的宏 B。接着，宏 B 中的一个错误将导致返回到宏 A。由于宏 A 有一个 ON_ERROR 陷阱集合，则将执行该陷阱并且宏将从调用宏 B 的行下面的一行开始继续执行。

ON_ERROR 命令还可以嵌套。要继续该示例，假设现在宏 B 调用有自己 ON_ERROR 命令的宏 C。宏 C 中的任何错误都将被宏 C 的 ON_ERROR 命令捕获。执行该陷阱并且宏 C 从导致错误的行下面的一行开始继续执行。当宏 C 返回到宏 B 时，宏 A 的 ON_ERROR 再次变为活动状态。

每个宏都可能有一个或多个 ON_ERROR 命令。每个宏中，只有最近执行过的 ON_ERROR 处于活动状态。

如果当前宏没有有效的 ON_ERROR，系统将返回到宏堆栈直至找到 ON_ERROR 命令。执行 ON_ERROR 宏之后，控制返回到启动 ON_ERROR 语句的宏处。启动宏调用链的命令继续执行（请参见示例 2）。

这里有两个特殊情况：

ON_ERROR （无参数）有效地忽略所有的错误而盲目继续。

ON_ERROR GENERATE_ERROR 有效地取消错误捕获。

示例 1

NAME TestError

ON_ERROR print "This is error handler #1"

  •

JUNKCMD

  •

ON_ERROR print "This is error handler #2"

JUNKCMD

  •

RETURN

第一个错误出现时（由第一个 JUNKCMD 导致的），此宏打印消息 "This is error handler #1"。第二个错误出现时（由第二个 JUNKCMD 导致的），此宏打印第二个消息并正常结束。

示例 2

NAME LevelA

ON_ERROR LevelA_macro

LevelB

PRINT "I am in Macro LevelA"

RETURN

NAME LevelA

<INVALID COMMAND>

PRINT "I am in macro LevelB"

RETURN

当宏 LevelB 在宏 LevelA 中执行时，处理错误后，控制将跳转到紧跟 LevelB 宏调用之后的那条语句。

示例 3

NAME Example

ON_ERROR EnterNumber !打开错误陷阱

EnterNumber

ON_ERROR EnterNumber !打开错误陷阱

RETURN

NAME EnterNumber

INPUT "Type a number greater than zero", string$

IF VAL(string$)>=0

PRINT VAL(string$)

ELSE

GENERATE_ERROR 1, "That is not a number"

ENDIF

RETURN


OPEN

OPEN "文件名" FOR OUTPUT / FOR APPEND / FOR INPUT AS #文件编号

根据所用的关键字短语，用 PRINT # 和 PRINT USING # 或者 INPUT # 将一个文件编号与一个文件名关联起来。当已结束打印到文件时，请使用 CLOSE 命令。

"文件名"

要打开的文件。如果没有指定路径，则使用当前工作目录。

FOR OUTPUT / FOR APPEND

必须输入这些关键字短语中的一个以指定怎样写入到文件。随后就可以用 PRINT # 或 PRINT USING # 访问文件。

FOR INPUT

当您想要用 INPUT # 访问已打开的文件时，请使用此关键字短语。

AS #文件编号

一个介于 1 到 100 的数字；必须包括 # 符号（例如，#3）。

示例

OPEN "myfile" FOR OUTPUT AS #1


PARAMETER

PARAMETER 参数列表

只用于宏中。指定宏的调用变量。按照实际传递变量的顺序（从左到右）来处理这些变量。可选关键字 DEFAULT 允许指定某个参数未给定时的缺省值。可以在连续多行上指定多个参数的声明。可以使用多个参数。请参见手册《使用和编写宏》。


PRINT 表达式 [,...]

将字符串或标量表达式的结果写到当前应用程序的消息行上。

表达式

任何有效的字符串或标量表达式。字符串表达式必须包含在引号中。

变量集

LastPrint$

最后一个 PRINT 命令的内容；必须在最初就定义了（在第一个 PRINT 之前）。


PRINT #文件编号

PRINT #文件编号, 表达式 [,...]

将字符串或标量表达式的结果写入到一个 ASCII 文件。

#文件编号

一个已打开文件的编号（请参见 OPEN 命令），该文件已为 OUTPUT 或 APPEND 而打开。

表达式

任何有效的字符串或标量表达式。字符串必须包含在引号中。

变量集

LastPrint$

最后一个 PRINT 命令的内容；必须在最初就定义了（在第一个 PRINT 之前）。


PRINT USING "格式字符串"

PRINT USING "格式图形字符串",表达式 [,表达式] [,...]

将字符串或标量表达式的格式化结果写到当前应用程序的消息行上。

"格式图形字符串"

必须包含专用于格式化表达式的字符串。也可以包含可打印文本。

# 表示一位数。##.### 或 2#.3#，句点代表小数点。只要在格式字符串中的句点左边至少有一个 # 号，小数左边所有的位都会打印出来。如果 # 比位数多，多余的 # 由数字前面的空格替代。小数右边的位数按指定的 # 舍入。如果未使用句点，则数字按右对齐舍入和打印。超过 100,000,000 的数字按科学计数法的形式打印。

% 代表一个字符。如果 % 多于字符串中的字符个数，则字符串按左对齐的方式打印。如果字符串中的字符个数多于 % 个数，则打印所有字符。

\ 打印那些被该命令用做正常字符的专用格式化字符（#，%）。其后必须紧跟着每个要打印的字符。

/ 当打印到文件时，用于插入一个回车。如果不包含，则下一个 PRINT 命令就接着同一行上打印。

表达式

任何有效的字符串或标量表达式：

在格式字符串中的 # 要求标量表达式

格式字符串中的 % 要求字符串表达式；字符串表达式必须包含在引号中。

示例

PRINT USING "#.##", 999.5555

打印 999.56

PRINT USING "% %", "example", "one"

打印 example one

PRINT USING "\# \% \\"

打印 # % \

PRINT USING "9% This is column 11", " "

打印（在 11 列）：This is column 11。9% 打印 9 个空格。在 % 符号和短句之间有两个内嵌的空格。

变量集

LastPrint$

最后一个 PRINT 命令的内容；必须在最初就定义了（在第一个 PRINT 之前）。


PRINT USING #文件编号

PRINT USING #文件编号, "格式图形字符串", 表达式 [,表达式] [,..]

将字符串或标量表达式的格式化结果写入到一个 ASCII 文件。文件编号由 OPEN 命令设置。

#文件编号

已打开文件的编号（请参见 OPEN 命令）。

"格式图形字符串"，表达式

请参见 PRINT USING。

变量集

LastPrint$

最后一个 PRINT 命令的内容；必须在最初就定义了（在第一个 PRINT 之前）。


PRINTTEXTFILE

PRINTTEXTFILE "文件名"

在打印机上打印一个文本文件的内容。可以打印多页。不打印图形。如果存在变量 Footer$ 和 PageNumA，则会在每一页的底部打印一行文本和页号。页脚文本由 Footer$ 定义，页号由 PageNum 值开始增加。支持双面打印。

"文件名"

文本文件的完全限定的名称。

讨论

使用 CP 变量 OrientPr 确定打印方向。如果 OrientPr 设置为 1，则使用纵向模式。如果 OrientPr 设置为 2，则使用横向模式。如果不存在 OrientPr，将对当前打印机使用 win.ini 中的方向设置。如果在 win.ini 中没有方向设置，则使用纵向模式。

如果 DirectPr = 1，文件直接被发送到打印机（不使用 ChemStation（化学工作站）假脱机程序）。若 DirectPr = 0，

使用 ChemStation（化学工作站）假脱机程序。


PROTECTMACRO

PROTECTMACRO [“文件名”], [“密码”]

该命令将正常宏文件转换为同名的受保护的宏文件。该命令只在 Top 和 Instrument Control（仪器控制）中可用。该命令不能用于 Data Analysis（数据分析）中，因而受保护的宏将不能用于 Data Analysis（数据分析）。

“文件名”

要保护的宏文件的名称。如果未指定文件名，则会显示文件选择框。宏的缺省路径是由 _ExePath$ 所指定的路径。

密码

文件的保护密码。若未指定密码，将显示对话框询问密码。密码是区分大小写的。

讨论

当宏被保护时，在文件开头会附加可读的警告消息。

而宏文件的其余部分则是使用了保护算法后的加密编码。宏文件中的所有内容都被保护起来，通过使用 UNPROTECTMACRO 命令就可以完全恢复此文件，只要此文件尚未被破坏。如果一个受保护的宏文件被修改，则无法恢复它。

宏文件被保护后，它就被更改为只读文件。这是为了防止意外地修改或删除受保护文件。

使用“零长度字符串” ("") 作为密码可防止去除保护。“零长度字符串”密码只可以从命令行输入，不能在对话框中输入。既然用“零长度字符串”密码保护的文件不能被去除保护，因此“零长度字符串”密码只用于那些必须一直要确保安全的文件。

提供密码参数可以自动保护一组文件。为确保安全，显示地包含密码的例程应对其进行保密处理，或许可以通过驻留在一个受保护的宏文件中来实现。

WARNING 和 DISCLAIMER

PROTECTMACRO 命令应用复杂的数据加密算法来保护宏文件。无法解密受保护的宏文件，如果没有密码的话。MSD ChemStation（化学工作站）软件的修订版本将可以读取已受保护的宏，但不保证 ChemStation（化学工作站）的增强版能向下兼容。因此，宏的开发者有责任保存受保护的宏文件的去除保护的拷贝。

PROTECTMACRO 和 UNPROTECTMACRO 命令应当限于宏开发者使用，他们担负着维护其所创建的宏环境的责任。PROTECTMACRO 命令只应当用于保护本地开发的宏。ChemStation（化学工作站）产品所提供的去除保护的宏不应被保护起来。同样，非宏文件（*.EXE、*.DOC ...）也不应当被保护起来。


PULLOUT

PULLOUT 索引, 源, 目的

从一个集合（源）中提取一个指定对象并将其放置到一个变量（目的）中。

索引

一个数字，它是从中提取目的的对象的源集合（列表）中的位置。如果索引 <1 或大于列表的大小，会给出错误消息。

源

从中删除目的对象的集合（列表）的名称。如果源最初包含两个对象，提取执行完后，源就由集合更改为剩下的那个对象类型。

目的

要在其中放置“被提取的”对象的变量名称。


REMOVE

REMOVE [宏名称/变量名] [,...]

从内存删除宏或变量。

若未指定名称，则显示一个对话框，其中列示了当前可用的宏和变量。可单击变量名读取它的当前值。如果接着单击 OK（确定）按钮，命令 REMOVE 中的变量名将出现在命令行上。按下 Enter 删除此变量。

讨论

不能删除保留变量（前面加下划线的那些变量）或对其赋值（请参见 VARLOCK 命令）。

REMOVE 可用在宏的结尾以使宏删除其自身。在这种情况下，如果是一个嵌套宏，REMOVE 的作用就象 RETURN 命令，使宏返回到调用它的那个宏。


REMOVELIST

REMOVELIST ["基名"]

一次性删除一系列变量。如果没有提供可选的基名，则用 "METHCOMMENT" 作为基名。

基名

一系列变量的全名的一部分。变量的全名为 basenameX$，其中 X 是一个界于 0 和 99 之间的一位或两位数。（若基名为 test，则 test0$、test1$、..、test99$ 都将被命令 REMOVELIST "test" 删除）

讨论

按数字顺序从小到大删除变量。如果系列中有一个变量没有定义，则此命令将在那个变量处停止，余下的变量不再删除。

示例

假设存在下列变量：test0$、test1$、test2$、test3$、test4$、test6$、test7$ 和 test8$。

执行 REMOVELIST "test" 后，还将存在下列变量：test6$、test7$ 和 test8$


RENAME

RENAME "源名称", "目的名称" [,DONTASK]

将一个文件或目录重命名；移动文件。需要有完全限定的文件名或目录名。

"源名称"

要重命名的文件或目录的名称。如果没有指定路径，则使用当前工作目录。

"目的名称"

新的名称。重命名文件时可以给定一个不同的路径（例如，可以将文件移动到一个新目录）。重命名目录时不能指定不同的路径。

DONTASK

如果指定了此关键字，RENAME 将不警告对文件或目录的覆盖。此关键字不能用缩写；它的前面必须有逗号。

示例

RENAME "\mypath\MYDIR", "\mypath\YOURDIR"

将 MYDIR 目录重命名为 YOURDIR。

RENAME "MYDIR\myfile", "YOURDIR\myfile"

将文件 myfile 从 MYDIR 目录移动到 YOURDIR 目录。


RETURN

在嵌套宏中使用以迫使宏返回到正在调用的宏。

讨论

RETURN 用于嵌套宏中。如果没有 RETURN，则所有宏均停止。如果没有正在调用的宏，则 RETURN 不进行任何操作。


RMDIR

RMDIR "目录名称"

删除一个空目录。推荐使用完全限定文件和目录的名称。

讨论

此命令删除空目录。要删除包含文件的目录，请用 DELETE 命令。


ROUND( )

val = ROUND(数字)

此函数将一个标量值舍入到最接近的整数值。

数字

一个标量值或变量。

示例

val = ROUND(1.2)

PRINT val !打印 1.0

val = ROUND(1.8)

PRINT val !打印 2.0


ROWS( )

var2 = ROWS (矩阵名称)

返回一个矩阵对象的行数。

矩阵名称

包含矩阵对象的变量。

var2

要放置结果的变量。

示例

Y = ROWS(X)

将 X 中的行数放入 Y

ROWS(X)

将 X 中的行数写在消息行上。


RUNCLASS( )

值 = RUNCLASS（运行类型）

将运行类型转换到运行类。运行类为：

1 = 空

2 = 样品

3 = 校准

运行类型可以是 0、1、2、3 或者是 100 到 399 之间的用户定义类型：

100 到 199 在 Blank（空）类中。

200 到 299 在 Sample（样品）类中。

300 到 399 在 Calibration（校准）类中。


SELECTFILE

SELECTFILE 属性, "标题" [,"扩展名"], 路径变量名称, 文件变量名称, 文件状态变量名称

显示一个 file-select（文件选择）对话框。

属性

对话框属性：

0 = 无列表框，无实体检查

1 = 用以显示和选择文件的列表框，强制进行实体检查

2 = 用以显示和选择目录的列表框，强制进行实体检查

3 = 用以显示和选择文件的列表框，不强制进行实体检查

4 = 用以显示和选择目录的列表框，不强制进行实体检查

"标题"

对话框标题。

"扩展名"

强制的扩展名；它必须是 *.xyz 形式。

路径变量名称

包含驱动器和路径的字符串变量；字符串必须以 \ 结尾。例如，"c:\MSDchem\msexe\"

文件变量名称

包含文件或目录名称但不包含路径的字符串变量；字符串不以 \ 结尾。

文件状态变量名称

包含选定文件或目录状态的标量变量：

0 = 不存在

1 = 是一个文件

2 = 是一个目录

讨论

如果路径变量名称变量或文件变量名称变量在使用命令前已存在，则将它们用作缺省值。否则，当前工作目录可用作路径，*.* 可用作文件名。

示例

SELECTFILE 2, "Load Method", "*.M", _MethPath$, _MethFile$, Fstat

SELECTFILE 1, "Load Sequence", "*.S", _SeqPath$, _SeqFile$, Fstat

变量集

_Button

0 = 按下的 Cancel（取消）

1 = 两个输出变量都未更改

2 = 两个输出变量都已更改


SDIM

SDIM 集合名称，正整数

一个设置集合变量的维数的宏。正整数应大于 1。

请参见 DIM 命令。另见联机帮助中的 Using and Writing Macros（使用和编写宏）手册。


SETINFO

SETINFO "项目名"

此命令设置关于指定硬件组件状态的信息。

"ALS_ID"

0 = 无 ALS 连接（缺省）

x = WIN.INI 中的值

"ALS_TYPE"

0 = 无

1 = 7673

"GC_ID"

0 = 无 GC 连接（缺省）

x = WIN.INI 中的值

"INLET_GC"

0 = 6890（缺省）

2 = 其他值或者无

"MS_CI"

0 = 未安装（缺省）

1 = 已安装

"MSCONNECTION"

0 = 前进样口

1 = 后进样口

"MS_DCI"

0 = 未安装（缺省）

1 = 已安装

"MS_DCI"

0 = POS 设置

1 = NEG 设置

2 = 未设置（缺省）

"MS_CI"

0 = 未安装

1 = 已安装（缺省）

"MS_EXTRA"

0 = 无（缺省）

x = 多余

"MS_EXTRA2"

0 = 无（缺省）

x = 多余

"MS_FAB"

0 = 未安装（缺省）

1 = 已安装

"MS_CI"

0 = 未安装（缺省）

1 = 已安装

"MS_CI"

0 = 无 MS 连接（缺省）

x = WIN.INI 中的值

"MS_NI"

0 = 未安装（缺省）

1 = 已安装

"MS_TYPE"

4 = 5972 / 6890 MSD

99 = 无 MS

"OFFLINE"

0 = 仪器在线

1 = 仪器离线


SETINISTRING ( )

值 = FILESTAT ("目录" / "文件名")

此函数在所提供的 .ini 文件中搜索指定的应用程序，并将与关键名称相关的字符串设置为所提供的字符串，该字符串可达 132 个字符。若不存在关键名称，则创建一个新的项目，并将此字段设置为字符串。若文件名参数为一个空字符串 ("")，则所使用的 ini 文件为 %SystemRoot%\msdchem.ini。

如果遇到错误，函数返回 0，否则它返回一个非 0 值。

若输入的字符串为空字符串 ""，则关键名称和字符串将从文件中删除。

要保留关键名称且只删除字符串，请输入一个空格 " "。

若输入的关键名称为空字符串 ""，则整个应用程序将从文件中删除。


SLEEP

SLEEP 时间

在宏中使用以按指定的时间长度暂停当前应用程序。

时间

以秒表示的时间。休眠时间至少与所指定的时间长度一样长，有时会更长。

示例

在等到其他应用程序结束时才可使用下列宏，例如，一个网络文件传输程序。

NAME WaitFor WindowToGoAway

PARAMETER WinName$

GETWINDOWID WinName$

WHILE (_WindowID > 0)

SLEEP 3

GETWINDOWID WinName$

ENDWHILE

RETURN

NAME WaitForFTP

WaitForWindowToGoAwau "FTP - network transfer"

RETURN


SPRINT

SPRINT 变量, "表达式" [,...]

将字符串表达式的结果写到指定的变量。

"表达式"

任意有效的字符串表达式。字符串表达式必须用引号引起。


SPRINT var USING

SPRINT 变量 USING "格式图象字符串", "表达式" [,...]

将格式化的字符串表达式写到指定的变量。

"表达式"

任意有效的字符串表达式。字符串表达式必须用引号引起。

"格式图象字符串"

必须包括格式化表达式所需的特殊字符。还可以包括可打印文本。

# 代表一个数字。##.### 或 2#.3#，句点表示小数点。只要格式字符串中句点左边有一个 #，则打印小数点左边的所有数字。如果 # 的个数多于数字的个数，则在数字前用空格代替额外的 #。小数点右边的数字将被舍入以与指定的 # 相匹配。若没有使用句点，则舍入数字并右对齐打印。大于 100,000,000 的数字将以科学记数法的形式打印。

% 代表一个字符。如果字符串中 % 的个数多于字符的个数，则字符串左对齐打印。若字符串中的字符个数多于 % 的个数，则打印所有字符。

\ 将此命令使用的特殊格式字符 (#, %) 当作常规字符打印。它必须在每个要打印的字符之前。

/ 打印到文件时用来插入一个回车符。如果不包括此字符，下一个 SPRINT 命令将在同一行上继续。

示例

要使用变量 Var3$ 和 Var4$ 获取输出：

B$ = "dichloromethane"

C = 16.7

D$ = "ppm"

SPRINT var3$ USING "16%, 6# 5%, B$, C, D$

n = 96

SPRINT var4$ USING "The square root of # = #.##, n,"

sqrt(n)

变量的内容是:

Var3$ dichloromethane, 17 ppm

Var4$ The square root of 96 = 9.80


SQR( )

值 = SQR (表达式)

此函数返回表达式的平方。


SQRT( )

值 = SQRT (表达式)

此函数返回表达式的平方根。


STRCMP( )

值 = STRCMP("字符串1" ,"字符串2")

词典式地比较两个字符串并返回一个说明它们之间关系的值。比较区分大小写。返回的值为如下之一：

<0 条件是 "字符串1" 比 "字符串2" 短

=0 条件是 "字符串1" 和 "字符串2" 相同

>0 条件是 "字符串1" 比 "字符串2" 长

"字符串1", "字符串2"

要比较的两个字符串。


TIME( )

值 = TIME ( )

此函数返回从 1970 年 1 月 1 日开始的以秒表示的当前时间。


TIME$( )

value$ = TIME$ ( )

此函数返回以 24 字符的字符串表示的当前时间，例如，Wed Oct 21 02:03:55 1992。午夜是 00:00:00。小时从 0 开始到 23，分钟从 0 开始到 59。使用格林尼治标准时间。


TOPCMD

TOPCMD "命令"

从应用程序将一个命令发送到 Top。

"命令"

从某个应用程序中向 Top 提交并要由 Top 执行的字符串。


TOPDOT

TOPDOT 变量

将一个变量发送到 Top。

变量

要发送到 Top 的变量的名称和值。

讨论

可以被所有应用程序（除 Top 外）使用，以便动态改变 Top 中的宏流量。例如，Data Analysis（数据分析）中的“测量方法”可能会检测到有一个进样需要用更精确的方法（如，要确定某些物质的数量）进行重复。Top 中一个宏的序列流量可以通过设置合适的 Top 变量来改变。


TRUNC( )

值 = TRUNC (表达式)

此函数返回表达式的整数部分。


UNPROTECTMACRO

UNPROTECTMACRO [“文件名”], [“密码”]

此命令将反向转换受保护宏文件，并创建同名的常规宏文件。

文件名

要取消保护的宏文件的名称。如果没有指定文件名，则显示一个文件选择框。宏的缺省路径是由 _ExePath$ 指定的路径。

密码

文件受保护时需使用的密码。如果没有指定密码，则显示一个要求密码的对话框。密码是区分大小写的。

若文件受保护后被修改了，则文件不能取消保护。

提供密码参数是为了能够自动取消一组文件的保护。为了安全起见，显式包含密码的例程应保持专用，可能的方法是通过将该密码驻留在一个受保护的宏文件中。

另见

PROTECTMACRO


UPPER$( )

string$ = UPPER$ ("字符串")

基于用户在 Windows 安装过程中选择的当前语言标准，将所提供的字符串转换成大写字符串。


VAL$( )

value$ = VAL$ (expression)

此函数评估一个字符串表达式并返回相当的数字值。若字符串并非有效的数字，则函数返回 0。

例如

若 a$ = "3" 且 b$ = "4"，则 VAL(a$ + b$) 返回数字值 34。


VAL$( )

value$ = VAL$ (expression)

此函数返回一个数字值的字符串版本。


VARLOCK

VARLOCK 1/0

控制对保留变量作为赋值语句目标的使用：

1/0

锁定或解除对保留变量的锁定。

1 = 无法对保留变量赋值。

0 = 可以对保留变量赋值。

如果没有指定任何参数，则在消息行上报告当前的锁定模式。

论述

通常情况下不能给保留变量赋值或将它们删除，它们的内容由系统管理。然而，为了能够进行自定义操作，可以通过指定 VARLOCK 0 来消除赋值操作上的锁，但删除操作上的锁不能消除。


VERSION

在消息行上显示当前应用程序的版本信息。


VERSION$()

字符串 = VERSION$( )

将版本信息返回到消息行中。


WHILE - ENDWHILE

在宏中使用¡£在循环开始时对循环结构进行测试。语法：

WHILE 条件

<命令列表>

ENDWHILE

请参阅联机帮助中的 Using Writing Macros manual（使用书写宏手册）。


WINMOVE

WINMOVE [x] [,y]

将应用程序窗口移动到一个新的位置。

x,y

窗口左上角的新位置。它们以屏幕的分数形式表示，范围从 0 到 1；1,1 为屏幕的右下角。缺省值为初始值。以小数点前加 0 的形式输入小数值，例如 0.5。

讨论

一个应用程序窗口不可能真正移动到位置(1,1)。窗口的某部分总是可见的，以便它可以从键盘激活或用鼠标进行拖拽。

若窗口已被最小化或缩放了，则此命令不起作用。


WINSIZE

WINSIZE [宽度] [,高度]

更改应用程序窗口的尺寸。

宽度,高¶È

新窗口的宽度和高度。这两个值以屏幕的分数形式表示，其中 1,1 表示全屏，0,0 表示最小化。如果省略参数，则使用原始（缺省）值。


DATANALYSIS

DATANALYSIS ["命令"] [,"自动启动宏文件"] [,QUIT] [,ICON]

激活 Data Analysis（数据分析）。

"命令"

只要自动启动宏已完成，就要执行的 Data Analysis（数据分析）命令。

"自动启动宏文件"

允许 Top 覆盖缺省的自动启动宏文件 (da.mac)。

QUIT

自动启动宏和命令已完成后，或出现错误后，强制退出 Data Analysis（数据分析）。

ICON

强制使 Data Analysis（数据分析）自身显示为图标。

变量集

_DACode

Data Analysis（数据分析）错误代码

_DADDE$

Data Analysis（数据分析）具体实例的 Top 的标识符（例如 MSDA3750）。

_DAErr

0 = Data Analysis（数据分析）中无错误

1 = Data Analysis（数据分析）正忙

2 = Data Analysis（数据分析）已终止运行

3 = Data Analysis（数据分析）有错误（请参见 _DACode, _DAMsg$）

4 = Data Analysis（数据分析）已终止于错误状态（请参见 _DACode, _DAMsg$）

_DaErrMsg$

Data Analysis（数据分析）无响应时 Top 的错误描述。

_DAMsg$

对于 Data Analysis（数据分析）中错误的解释

_DAState

1 = Data Analysis（数据分析）根本不在内存中。

2 = 正从盘中加载 Data Analysis（数据分析）

3 = Data Analysis（数据分析）从待机模式启动

4 = Data Analysis（数据分析）处于活动状态且可见

5 = Data Analysis（数据分析）处于待机模式且不可见


EDITMETHPANEL

EDITMETHPANEL [editop] [,editacq] [,editda]

若未与可选参数一起使用，则显示 Edit Method（编辑方法）对话框。常规操作将显示面板。

Edittop, editacq, editda

可选参数对应于 Edit Method（编辑方法）面板中的三个复选框：Method Information（方法信息）、Instrument/Acquisition（仪器/采集）和 Data Analysis（数据分析）。对于每个复选框（参数）：

0 = 不编辑

1 = 编辑

在对话框中或借助可选参数所做的选择来设置变量。

变量集

_Button

0 = 选定的 Cancel（取消）

1 = 选定的 OK（确定）

_EditAcq

0 = 不编辑

1 = 编辑

_EditDa

0 = 不编辑

1 = 编辑

_EditTop

0 = 不编辑

1 = 编辑


LOADMETHPANEL

LOADMETHPANEL ["方法"] [,清除]

仅在内部使用。显示 Load Method（加载方法）对话框。此命令为加载一个新方法的多步过程的一部分。

"方法"

要加载的方法的名称。如果没有给定，将显示对话框。

清除

0 = 不删除格式 MethCommentx$ 的全部变量

1 = 不删除变量（缺省）

变量集

_Button

0 = 选中 Cancel（取消）

1 = 选中 OK（确定）

_MethFile$

当前方法文件名

_MethPath$

方法的驱动器和路径信息


MEMMODE

LOADMODE [insctl] [,da]

更改应用程序的内存模式。内存模式确定应用程序关闭时会发生什么。

insctl,da

T = 终止；应用程序被从内存清除。

S = 待机状态；应用程序被部分保留在内存中以减少加载时间。

缺省为每一个应用程序的当前值。如果在使用该命令时带有参数，则也显示当前值。

示例

LOADMODE t,s


LOADSEQUENCE

LOADSEQUENCE ["序列文件名"]

将序列加载到内存中。如果没有指定序列文件名，将显示 Load Sequence（加载序列）对话框。若未输入扩展名 .S，将会添加此扩展名。

变量集

_Button

0 = 选中 Cancel（取消）

1 = 选中 OK（确定）

_SeqFile$

序列文件的名称。

_SeqPath$

序列文件的路径


METHINFOPANEL

显示 Method Information（方法信息）对话框。在对话框中所进行的选择可以用来设置变量。

变量集

_CopyMeth

0 = 否

1 = 是

_PostCmd$ - 命令字符串

_PreCmd$ - 命令字符串

_RunAcq

0 = 否

1 = ÊÇ

_RunDa

0 = 否

1 = 是

_RunPost

0 = 否

1 = 是

_RunPre

0 = 否

1 = 是

MethCommentxxx$ - 关于方法的注释；xxx 从 0 开始，以 1 递增。


MSINCTL

DATANALYSIS ["命令"] [,"自动启动宏文件"] [,QUIT] [,ICON]

激活 Instrument Control（仪器控制）。

"命令"

只要自动启动宏已完成，就要执行的 Instrument Control（仪器控制）命令。

"自动启动宏文件"

允许 Top 覆盖缺省的自动启动宏文件 (msacq.mac)。

QUIT

自动启动宏和命令已完成后，或出现错误后，强制退出 Instrument Control（仪器控制）。

ICON

强制使 Instrument Control（仪器控制）显示为图标。

变量集

_InsCtlCode - Instrument Control（仪器控制）的错误代码

_InsCtlDDE$ - Acquisition（采集）的具体实例的 Top 的标识符（例如 MSACQ3750）

_InsCtlErr

0 = Instrument Control（仪器控制）中无错误

1 = Instrument Control（仪器控制）正忙

2 = Instrument Control（仪器控制）已终止运行

3 = Instrument Control（仪器控制）有错误（请参见 _InsCtlCode、_InsCtlMsg$）

_InsCtlErrMsg$ - Instrument Control（仪器控制）无响应时 Top 的错误描述

_InsCtlMsg$ - Instrument Control（仪器控制）的错误解释

_InsCtlState

1 = Instrument Control（仪器控制）根本不在内存中

2 = 正从盘中加载 Instrument Control（仪器控制）

3 = Instrument Control（仪器控制）从待机模式启动

4 = Instrument Control（仪器控制）处于活动状态并可见

5 = Instrument Control（仪器控制）处于待机模式且不可见


POP

PUSH [标量 1], [标量 2], [标量 3], [标量 4] [字符串 1], [字符串 2], [字符串 3], [字符串 4]

POP [变量名 1], [变量名 2], [变量名 3], ...[,变量名 8]

仅在内部使用。每一个 PUSH 或 POP 最多可以处理 8 个变量（4 个标量和 4 个字符串）。对于 POP，弹出变量将被存储在这些变量名中（前四个标量和后四个字符串）。

未定义标量将作为 0 存储和弹出，未定义字符串作为空字符串弹出。如果试图弹出空栈，则标量值被设置为零，字符串值不变，并生成错误。每个字符串最多可以有 16 个字符。多出的字符被截断。

堆栈大小限制为 100 个项。

对于 POP，在最后一项被“弹出”堆栈后,堆栈就被破坏了。

对于 PUSH，如果堆栈为空或不存在，则创建一个。


PROMPTMODE

PROMPTMODE [insctlmode] [,damode]

可选择确定是否在退出应用程序时提示您保存方法或是否自动保存方法。如果不给出参数，则对于每一应用程序显示当前保存模式。

insctlmode,damode

可选关键字 N、S 和 P，分别用于 Instrument Control（仪器控制）和 Data Analysis（数据分析）应用程序。S 使得在退出应用程序时自动保存方法。N 或 P 会在退出相应的应用程序时弹出有关保存方法的对话框提示。


RUNMODE

RUNMODE ["模式"]

在宏中使用以设置 Top 的运行模式。运行模式控制状态显示和对 Sample Log Table（样品日志表）进行的编辑。

"模式"

"I" = 交互模式；状态显示关闭，保存模式为 P

"M" = 方法模式；状态显示打开，保存模式为 N

"S" = 序列模式；状态显示打开，保存模式为 N，仅可对尚未运行的样品进行 Sample Log Table（样品日志表）项目编辑。

讨论

通常 Top 都处于交互模式。然而，在方法或序列期间运行模式更改为 M 或 S。当方法或序列完成后，Top 返回到运行模式 I。在运行模式 S 期间，Sample Log Table（样品日志表）将 "past" 项目显示为灰色文本，并且不确认对这些项目所做的任何更改。所有其他的项目都可按需要修改。

变量集

下列变量设为 0 或空字符串：

_DaCode — Data Analysis（数据分析）中出现的错误编号

_DaErr

0 = 无错误

1 = Data Analysis（数据分析）正忙

2 = Data Analysis（数据分析）已终止运行

3 = Data Analysis（数据分析）出错

4 = Data Analysis（数据分析）已结束

_DaErrMsg$ — Top 的错误描述

_DaMsg$ — 由 Data Analysis（数据分析）返回的错误消息

_DaState

1 = 缺少 Data Analysis（数据分析）（不在内存中）

2 = 正加载 Data Analysis（数据分析）

3 = 正启动 Data Analysis（数据分析）（从待机模式）

4 = 处于待机模式的 Data Analysis（数据分析）

_ErrMsg$ — 系统错误消息

_Error — 基于整个系统的宏的系统错误编号

_InsCtlCode — 发生在 Instrument Control（仪器控制）中的错误编号

_InsCtlErr

0 = 无错误

1 = Instrument Control（仪器控制）正忙

2 = Instrument Control（仪器控制）已终止运行

3 = Instrument Control（仪器控制）出错

4 = Instrument Control（仪器控制）已结束

_InsCtlErrMsg$ — Top 的错误描述

_InsCtlMsg$ — 由 Tune（调谐）返回的错误消息

_InsCtlState

1 = 缺少 Instrument Control（仪器控制）（不在内存中）

2 = 正加载 Instrument Control（仪器控制）

3 = 正启动 Instrument Control（仪器控制）（从待机模式）

4 = Instrument Control（仪器控制）（从磁盘）处于空闲状态 （可见并准备就绪）

5 = Instrument Control（仪器控制）处于待机状态（不可见，未准备就绪）

6 = Instrument Control（仪器控制）正忙（可见，正在工作）


SAMPLELOGTABLE

SAMPLELOGTABLE 关键字 [,"字符串"]

操作 Sample Log Table（样品日志表）。

关键字

ADVANCE = 移动到下一进样

GETENTRY = 获取当前进样的值并将其放入变量中。

EDIT = 显示简短的 Sample Log Table（样品日志表）

INIFILE = 设置 Sample Log Table（样品日志表）将要用到的 .ini 文件。必须是一个有效的、完全限定的文件名。这是一个“特权用户”功能，使用时应特别小心。不对文件名的有效性进行检查。Sample Log Table（样品日志表）所使用的标准 .ini 文件为 mstop.ini。

MERGE, "seqfilename"

此命令将内存中的序列附加到指定文件中的序列上。（注：ChemStation 早期版本的序列文件与 MERGE 不兼容，必须首先通过加载并保存这些文件来将它们转换成新的格式。）

PUTENTRY = 对存储在保留变量中的值进行扫描，并将这些值作为变量 _SeqLine 中的设置放入 Sample Log Table（样品日志表）项目中。项目即被覆盖。如果运行类型不为 6 （关键字），则行状态设置设为 2（行就绪），如果运行类型为 6，则行状态设为 0（行空）。_SeqLine 指向表中的最后一个项目，此项目常常为空。空项目将被填充，同时创建另一空项目。如果在序列活动时试图放置一个项目，则会生成一个错误。

POSITION, "标记或行号"

此命令定位序列以便使指定的行为等待行。"-1" 定位序列以便使表中的最后一行为等待行。

START = 移动到 Sample Log Table（样品日志表）中的第一行

VIEW = 显示 Sample Log Table（样品日志表），但不显示所有更改。正在退出，请设置变量 _Button 和 _Seqline。

"字符串"

此参数只能与 MERGE 和 POSITION 关键字一起使用。

变量集

_AlsBottle — 当前瓶号

_AlsBottle2 — 当前未使用

_Button — 用 View（查看）关键字进行设置

_DataFile$ — 数据文件名称

_Datafile2$ — 当前未使用

_DataName$ — 来自样品名称字段的注释

_DataName2$ — 当前未使用

_DataPath$ — 数据文件的路径

_ExpBarcode$ — 预期的条形码

_InjPerVial — 每个样品瓶的进样

_LevelId$ — 要重新校准的级数 ID

_LineStat — 此行的状态

0 = 空

1 = 无类型（未就绪）

2 = 给定类型（就绪）

3 = 完成（已标记）

_MethFile$ — 当前的方法文件名称

_MethPath$ — 有关方法的驱动器和路径信息

_MiscInfo$ — 来自 Misc 的字符串。信息项

_MiscInfo2$ — 当前未使用

_MoreSamp — 通过 START 和 ADVANCE 关键字设置

_Multiplr — 定量报告的乘积因子值

_Replicate2 — 当前未使用

_RunType

1 = 样品

2 = 空

3 = 重新校准

_SampAmt — 定量报告的 Sample Amount（样品量）的值

_SeqArgs[ ] — 8 元素数组，用于变量在 Top 上运行时，对该变量进行标量，以便将其传递到 Data Analysis（数据分析）。可将这些作为 SeqArgs[1]、SeqArgs[2] 等来参考。

0 = 缺省

_SeqStr$[ ] — 从序列表传递到其他 ChemStation 应用程序的 8 字符串的集合

_SeqIndex — 当前未使用

_SeqIndex2 — 当前未使用

_SeqInj — 当前样品瓶的当前进样

_SeqLine — 作为当前值来源的行号

_SkipAcq

0 = 选定的运行完全方法

1 = 选定的仅限重新处理

_UpdQi — 特征离子相对响应

0 = 不更新

1 = 更新

_UpdRf — 响应因子

0 = 不更新

1 = 更新

_UpdRt — 保留时间

0 = 不更新

1 = 更新


SAVEMETHPANEL

SAVEMETHPANEL "方法路径"

仅供内部使用。显示一个对话框以供保存方法。

"方法路径"

用来保存方法所要用的名称。

变量集

_Button

0 = 选定的 Cancel（取消）

1 = 选定的 OK（确定），新路径和旧路径相同

2 = 选定的 OK（确定），新路径和旧路径不同，但存在

3 = OK（确定），新路径和旧路径不同，或不存在

_SaveMeth$

用来保存方法的完全限定路径


SAVESEQUENCE

SAVESEQUENCE ["序列文件名称"]

将一个序列保存到文件。如果没有指定序列文件名，则显示 Save Sequence（保存序列）对话框。如果没有输入扩展名 .S，则会附加此扩展名。

变量集

_Button

0 = 选定的 Cancel（取消）

1 = 选定的 OK（确定）

_SeqFile$ — 序列文件的名称

_SeqPath$ — 序列文件的路径


SAVETOPMETHOD

在当前方法目录中保存方法的“Top”部分。


SETDATAFILE

SETDATAFILE 类型, 参数

生成一个数据文件名称以便按三种类型之一进行排序，并将其名称保存在变量 _DataFile$ 中。

类型

标量表达式，它的值可确定所生成的数据文件名称的形式以及所期望的参数类型。

1 = runcount 的标量表达式；数据文件名称为 vviirrr.D

2 = runcount 的标量表达式；数据文件名称为 rrrvvii.D

3 = seed 文件名称的字符串表达式；数据文件名称为 PPPPP

vv = 样品瓶编号 0 到 100 （来自 _AlsBottle）

ii = 进样编号（来自 _SeqInj）

rrr = 运行编号（来自 argument）

PPPPP 必须至少包含一个数字

参数

取决于类型，一个表示当前 runcount 的标量，或者是一个表示 seed 文件名称的字符串表达式。

讨论

当执行时，从右向左扫描 seed 文件名称，以查找第一个连续数字字符串。提取并增大此数字，并且其结果将写入 _DataFile$。若不能增大该数字（即，它将溢出），则生成一个错误。

例如，如果模式为 A44BC，则 DataFile$ 将为 A45BC。

示例

VARLOCK OFF

_DataFile$ = "A00BC"

VARLOCK ON

WHILE (_MoreSamp)

  •

  •

SETDATAFILE 3, _DataFile$

  •

  •

ENDWHILE

_DataFile$ 出现连续的值：

A01BC

A02BC

A03BC

变量集

_DataFile$ — 生成的数据文件


STARTRUNPANEL

显示 Start Run（开始运行）对话框。

在对话框中所做的选择设置了变量。要设置变量使方法的各部分都运行，请使用 METHINFOPANEL 命令。

变量集

_AlsBottle — 当前样品瓶编号

_Barcode$ — 通过 Instrument Control（仪器控制）中的条形码读取器功能所读取的条形码

_Button

0 = 选定的 Cancel（取消）

1 = 选定的 OK（确定）

2 = 选定的 Run Method（运行方法）按钮

_DataFile$ — 数据文件名称

_DataName$ — Sample Name（样品名称）字段的内容

_DataPath$ — 数据文件的路径

_ExpBarcod$ — 一个包含样品瓶的预期条形码的 16 字符的字符串

_MiscInfo$ — 来自 Misc 的字符串。信息项

_Multiplr — 定量报表乘积因子的值

_Operator$ — 来自 Operator Name（操作符名称）项的字符串

_RunAcq

0 = 否

1 = 是

_RunDa

0 = 否

1 = 是

_RunPost

0 = 否

1 = 是

_RunPre

0 = 否

1 = 是

_SampAmt — 定量报表的 Sample Amount（样品量）的值

_SkipAcq — 始终设置为 0。请参见命令 STARTSEQPANEL。


STARTSEQPANEL

显示 Start Sequence（开始排序）对话框。

变量集

_Button

0 = 选定的 Cancel（取消）按钮

1 = 选定的 OK（确定）按钮

2 = 选定的 Run Sequence（运行排序）按钮

_CheckBar

0 = 忽略条形码检查

1 = 加强条形码检查

_DataPath$ — 数据文件的路径

_Operator$ — 来自 Operator Name（操作符名称）项的字符串

_OverWrite

1 = 选中 overwrite（覆盖）复选框

0 = 不选中

_PostSeqCmd$ — 后序列化宏驱动器、路径和文件名；缺省值为空

_PostSeqCmd$ — 预先序列化宏驱动器、路径和文件名，缺省值为空

_SeqComment$ — 来自 Sequence Comment（序列备注）项中字符串

_SeqTimeStamp$ — 启动时序列的时间戳记

_SkipAcq

0 = 选定的 run full method（运行完全方法）

1 = 选定的 reprocess only（仅限重新处理）


STATUSPANEL

STATUSPANEL [1/0]

控制 Top 中的状态显示。缺省值为 1（打开）。

在运行模式 M （方法）和 S （序列化）下显示 Top 的状态显示。通常，它在运行模式 I（交互）中是关闭的。


SYNCHRONIZE

在继续之前等待，直到所有应用程序结束。

讨论

此命令由 Sequence（序列）宏使用，以一直等待到所有应用程序结束。可以通过按位于 Top 状态显示的 Edit Samp Log Tbl（编辑样品日志表）、New Data Analysis（新数据分析） 或 Abort（中止）按钮来提前中止等待。

示例

NAME MyMethod

ACQUISITION RunMethod, AcqSeq, QUIT, ICON

SYNCHRONIZE

ACQUISITION RunMethod, AcqSeq, QUIT, ICON

SYNCHRONIZE

RETURN

指示 TOP 在继续方法的下一阶段前等待应用程序的 Instrument Control（仪器控制）以及 DataAnalysis（数据分析）。

变量集

_Button

0 = 命令结束，没有活动的应用程序

1 = 选定的 Edit Samp Log Tbl（编辑样品日志表）按钮

2 = 选定的 New Data Analysis（新数据分析）按钮

99 = 选定的 Abort（中止）按钮


TOPBOX1

TOPBOX1 "消息", 颜色

将一条消息放置在状态显示中 Top 框的第 1 行中。

颜色

下列任一关键字都可确定消息文本的颜色：

  • WHITE

  • YELLOW

  • GREEN

  • RED

示例

TOPBOX1 "This is a yellow line", YELLOW


TOPBOX2

TOPBOX2 "消息", 颜色

将一条消息放置在状态显示中 Top 框的第 2 行中。

颜色

下列任一关键字都可确定消息文本的颜色：

  • WHITE

  • YELLOW

  • GREEN

  • RED

示例

TOPBOX1 "This is a green line", GREEN


MS 区对话框

此对话框可以让您编辑 MSD 温度区。在 Setpoint（设定值）中键入需要的设定值。Limit（极值）必须至少和每个区的设定值一样高。

对于 EI 的推荐设定值为：

区 | 设定值 | 极值
MS 源 | 230 | 250
MS 四极杆 | 150 | 200

对于 CI 的推荐设定为：

区 | 设定值 | 极值
MS 源 | 250 – PCI 150 – NCI | 300 -- PCI* 300 – NCI
MS 四极杆 | 106 – PCI 106 – NCI | 200 – PCI 150 – NCI

按钮

Apply （应用） | 把选定值发送给仪器。
Cancel （取消） | 退出该面板，不改变当前加载的调谐文件或下载任何东西到仪器。
OK （确定） | 改变当前加载的调谐文件，但不下载任何东西到仪器（使用 Apply（应用））。


FIRMWARE7673$ ( )

字符串 = FIRMWARE7673$( )

以字符串形式返回固件修订版。


GCMETHODEDIT()

值 = GCMETHODEDIT (面板号)

显示 10 个面板中的一个。

面板号

panel.25 的编号(1 - 10)

变量集

_Button

0 = OK（确定）

1 = Cancel（取消）。否则出错。


GCMETHODEDIT()

值 = GCMETHODEDIT$ ( )

仅在内部使用。


GCMETHODLOAD

GCMETHODLOAD "方法路径和方法文件名"

将 GC 参数下载到仪器。


GCMETHODNAME( )

字符串 = GCMETHODNAME( )

仅在内部使用。


GCMETHODNUM( )

值 = GCMETHODNUM( )

返回 GC 面板 (10) 的编号。


GCMETHODPRINT

GCMETHODPRINT "文件名和完整路径"

将当前方法中的 GC 参数复制到指定的文件中，并打印此文件。此文件必须已经存在，且调用此命令时必须关闭该文件。


GCMETHODSAVE( )

GCMETHODSAVE "方法文件名和完整路径"

保存方法。


GCPLOTEDIT()

值 = GCPLOTEDIT( )

显示实时绘图面板。返回:

0 = OK（确定）

1 = Cancel（取消）

2 = Error（错误）

变量集

_Button

0 = Cancel（取消）或错误

1 = OK（确定）


GCPLOTOFF

GCPLOTOFF [绘图号]

破坏实时绘图。ChemStation 同时也会保存位置。

绘图号

绘图（1 或 2）的编号。


GCPLOTON

GCPLOTON [绘图号]

显示实时绘图。

绘图号

绘图（-2, -1, 1 或 2）的编号。正数将使用 win.pos 来确定是否显示绘图。负数将不考虑 win.pos 而显示绘图。


GCSHOWDEVICEWIN

GCSHOWDEVICEWIN [窗口号], 位图号, x 位置, y 位置

创建位图，将其放在 Instrument Control（仪器控制）面板上，或将其移动。

窗口号

窗口号表示 Instrument Control（仪器控制）面板或 0 表示当前的 Instrument Control（仪器控制）面板。

位图号

指定位图的编号。

x 位置, y 位置

用于确定位图在面板上的位置的 x,y 坐标。


GCVIEWPARAMS()

值 = GCVIEWPARAMS( )

显示 Edit GC Monitors（编辑 GC 监测器）对话框。返回:

0 = OK（确定）

1 = Cancel（取消）

2 = Error（错误）

变量集

_Button

0 = Cancel（取消）或错误

1 = OK（确定）


ICARRANGEPLOTS

ICARRANGEPLOTS [标量] [,标量] [,标量]

重新安排 Instrument Control（仪器控制）面板上的图和监控程序。屏幕在 GC（或 LC）和 MS（或其他检测器）之间被分开。GC 图和监控程序在左侧和底部；MS 图和监控程序在右侧和底部。(X,Y) 点分割此行。

参数 1

(标量)(可选项)Instrument Control（仪器控制）面板窗口句柄。

参数 2

(标量)(可选项) x 位置

参数 3

(标量)(可选项) y 位置


ICCREATEBAR( )

值 = ICCREATEBAR( 标量, "字符串", 标量, 标量, 标量, 标量 )

在 Instrument Control（仪器控制）面板中添加或移动静态文本。返回一个（标量）位图窗口。

参数 1

（标量）用于文本的数字 (100 - 199)

参数 2

（字符串）“文本”

参数 3

(标量) x 位置

参数 4

(标量) y 位置

参数 5

(标量) 宽度

参数 6

(标量) 高度


ICCREATEHP( )

值 = ICCREATEHP(标量, 标量, 标量)

添加或移动 Instrument Control（仪器控制）屏幕上的位图。返回一个（标量）位图窗口。

参数 1

（标量）位图编号：

3 = 样本信息

7 = 帮助

8 = 停止

10 = 时钟

参数 2

(标量) x 位置

参数 3

(标量) y 位置


ICDESTROYGADGET

ICDESTROYGADGET 标量

从屏幕上删除位图。

参数 1

标量：位图编号


ICDUMPERROR

显示所有重要错误。


ICMAKEDIR

ICMAKEDIR "字符串"

创建一个新目录，或者如果目录存在，检查此目录下的文件。

参数 1

创建或检查文件的绝对“路径名”。

变量集

_Button

0 = 目录存在，且文件位于此目录下

1 = 已创建目录

其他 = 错误。


ICSAMPLEINFO

ICSAMPLEINFO 标量

显示样本信息面板。

参数 1

标量

0 = 启用 Start Run（开始运行）按钮

1 = 禁用 Start Run（开始运行）按钮。

变量集

_Button

0 = IDCancel

1 = IDOK


ICSHOW

ICSHOW 标量

显示或隐藏 Instrument Control（仪器控制）面板。

参数 1

标量

0 = 隐藏

1 = 显示


INJECTORS7673( )

值 = INJECTORS7673( )

检查进样器的存在情况。返回:

0 = 没有进样器或不受支持

1 = 仅有前进样器

2 = 仅有后进样器

3 = 两个进样器


INSTRVIEW

INSTRVIEW 符号, 标量

仅在内部使用。


LBADDENTRY

LBADDENTRY "消息", "文本", ["帮助文件名"] [,帮助编号]

将一个项放到记事簿中，并且可以选择将其链接到一个帮助屏幕。

参数 1

键入消息（示例： 6890)

参数 2

文本

参数 3

“帮助”文件的名称（如果存在）

参数 4：(标量)：

帮助编号（如果存在）


LBCLEAR

LBCLEAR ["文件名"]

删除一个记事簿。

参数 1

Null = 删除当前打开的记事簿

文件名 = 删除记事簿的数据路径和数据文件。


LBCREATEBM( )

窗口 = LBCREATEBM( 位图, x, y )

在 Instrument Control（仪器控制）面板上创建记事簿位图。返回(标量)：位图窗口。

参数 1

标量：位图编号 (200)

参数 2

标量：x 位置

参数 3

标量：y 位置


LBDISPLAY

LBDISPLAY 0/1 [,"文件名"]

控制记事簿的显示。

参数 1

0 = 关闭记事簿窗口

1 = 显示记事簿窗口

参数 2

Null = 显示当前记事簿

文件 = 数据路径和数据文件。

如果参数 1 = 1，则使用参数 2。


LBPRINT

LBPRINT ["假脱机系统文件名"] [,"记事簿的数据路径和文件"]

打印记事簿。

参数 1

要打印的假脱机系统文件名

参数 2

Null = 当前记事簿

文件 = 记事簿的数据路径和数据文件。


LBSAVEAS

LBSAVEAS "目的数据路径和文件", "源数据路径和文件"

保存记事簿。

参数 2

记事簿的目的数据路径和数据文件

参数 1

记事簿的源数据路径和数据文件。


MSMETHODEDIT( )

值 = MSMETHODEDIT (标量, 字符串)

显示某个质谱仪面板。返回：

0 = OK（确定）

1 = Cancel（取消）

2 = Error（出错）

标量

第一个参数是面板编号：

1 = MS Tune File（MS 调谐文件）

2 = MS SIM/Scan Parameters（MS SIM/扫描参数）

3 = MS Timed Events Table（MS 时间事件表）

6 = MS Monitors（MS 监控程序）

字符串

第二个参数仅用于 MS Tune File（调谐文件）。其他面板必须以 " " 作为第二个参数。如果第一个参数为 1（MS Tune File）且第二个参数为 " "，则 MSMethodEdit 将显示一个面板用于选择调谐文件。如果第一个参数为 1，且第二个参数是有效字符串，则 MSMETHODEDIT 将 _TunePath$ 与第二个参数相链接并且不显示面板。

变量集

_Button

1 = OK（确定）

0 = Cancel（取消）或 Error（出错）

示例

MSMETHODEDIT( 1, “” )

MSMETHODEDIT ( 1, “atune.u” ) {无面板}

MSMETHODEDIT( 2, “” )


MSMETHODPRINT

MSMETHODPRINT "字符串"

如果 MS 正在运行，则打印带有文件名的 MS 方法。如果该参数为空，则 MSMETHODPRINT 将该参数用作 “PRTMETH.TXT”。

示例

MSMETHODPRINT _InstPath$ + “METHOD.TXT”


MSMETHODSAVE

MSMETHODSAVE "目录名称"

若 MS 处于活动状态，则将 MS 方法保存到指定的目录中。

示例

MSMETHODSAVE “c:\MSDchem\1\methods\pest.m”


MSQUERYTUNE( )

字符串 = MSQUERYTUNE( )

查询调谐文件。为当前调谐文件返回一个字符串。

示例

MSQUERYTUNE()

返回：atune.u


MSRECOVER

MSRECOVER "文件名 — 完整路径"

当 Instrument Control（仪器控制）无法完成数据文件时，在特定的出错条件后恢复部分数据。

"文件名 — 完整路径"

您必须指定截断的数据文件的完整文件路径；例如："c:\MSDchem\1\data\evaldemo.d"

讨论

数据采集期间，在数据文件子目录里会创建一个叫 "tempdat" 的临时文件。MSRECOVER 命令将此文件转换成一个叫 "data.ms" 的文件，这样您就可以通过选择原始文件名（例中为 evaldemo.d）在 Data Analysis（数据分析）中查看它了 .

如果在采集期间超出了磁盘空间，您可以备份并删除其他一些文件，然后用这个命令恢复在磁盘已满之前采集到的数据。


MSRTCHANGE

仅供内部使用。


MSSENDVALVES

关闭 EI 校准阀。


MSSHOWDEVICEWIN

MSSHOWDEVICEWIN 标量, 标量, 标量, 标量

在 Instrument Control（仪器控制）窗口的顶端显示一个质谱仪图标/位图。

参数 1

仪器控制编号。若此参数为空，MSSHOWDEVICEWIN 将查询 Instrument Control（仪器控制）程序以获取该编号。

参数 2

图标/位图编号。应该为 1。

参数 3

图标/位图的 x 位置。

参数 4

图标/位图的 y 位置。


MSTEMP

MSTEMP SOURCE / QUAD [,实际值] [,当前设定值] [,新设定值] [,当前限制] [,新限制]

仅限 5973 MSD。获取并设置 MS 源和四极杆温度。

SOURCE / QUAD

关键字，指定您想要获取或者是设置源或四极杆的温度。

实际值、当前设定值、当前限制

要读取 ChemStation（化学工作站）当前设置的 CP 变量。请注意，设定值可能和 MS 控制卡的设定值不匹配。

新设定值、新限制

新值。如果给出了新设定值，则此值立刻被发送到 MS 控制卡。请注意，所有温度值都被舍入到偶数的度数。


MSVIEWPARAMS ( )

显示 MS 监控程序面板，如果 MS 处于活动状态，则您可以修改、添加或删除监控程序。

返回：

0 = OK（确定）

1 = Cancel（取消）

2 = Error（出错）

变量集

_Button

1 = OK（确定）

0 = Cancel（取消）或 Error（出错）

示例

MSVIEWPARAMS ( )


MS_SEND_VALVES

将“关闭 EI 校准阀”发送到 MS。


NOTRAY7673

禁用托盘。这是为了让 Bench (实验台)将样品瓶传送到进样塔，而不是传送到托盘上的一个中间位置。


PICKTUNEFILE

仅适用于 5973 MSD。显示 Select Tune File（选择调谐文件） 对话框。


READBARCODE$ ( )

字符串 = READBARCODE$ ( )

不管 7673 是否启用，此函数都返回已读取的条形码字符串（一串字符）。如果未读取任何条形码，则返回一个空字符串。条形码读取器中应该有此样品瓶。


RCMETHODEDIT ( )

值 = RCMETHODEDIT( )

显示 Inlet and Injection Parameters（进样口和进样参数）面板。

返回

0 = OK（确定）

1 = Cancel（取消）

2 = Error（出错）

变量集

_Button

1 = OK（确定）

0 = Cancel（取消）或 Error（出错）


RCMETHODLOAD

从 CP 变量 _MethPath$ 和 _MethFile$ 加载 Run Control（运行控制）当前方法。此命令也将使仪器设备加载它们的方法。


RCMETHODPRINT

RCMETHODPRINT "文件名"

将 Run Control（运行控制）方法打印到文件名中。

示例

MSMETHODPRINT _InstPath$ + “METHOD.TXT”


RCMETHODSAVE

RCMETHODSAVE "目录名称"

将 Run Control（运行控制）方法保存到指定的目录。

示例

RCMETHODSAVE “c:\MSDchem\1\methods\pest.m”


RUNABORT

仅供内部使用。


RUNERROR

仅供内部使用。


RUNSTART

RUNSTART 标量, 标量

启动数据采集。启动运行时，使用在 Instrument Control（仪器控制）对话框中设置的参数和自动调谐文件。

参数 1

0 = 非交互（对于序列）

1 = 交互

参数 2

0 = 非截止（仅供内部使用）

1 = 正常（缺省）。


SCCLEAR

仅供服务人员使用。将一个设备清除发送到质谱仪接口卡。


SCERROR

SCERROR [echo]

检索 CP 变量中的质谱仪接口卡错误字符串。

echo

0 = 在消息行中不显示最后的 SC 错误字符串。

1 = 显示错误字符串（缺省）。

变量集

ScErrString$


SCPOLL

将一个系列查询发送到质谱仪接口卡。


SCQUERY

SCQUERY "SC 命令字符串" [,变量]

将命令发送到质谱仪控制卡。

缺省的超时期间为 2 秒。若已定义 CP 变量 ScTimeOut 并将其设为大于等于 1，则超时期间将被设为 ScTimeOut，并限定其下限为 1 秒，上限为 600 秒。如果 ScTimeOut 小于 1，则使用缺省值 2 秒。

示例

SCQUERY "*idn?"

返回质谱仪控制卡的版本号。


SCTRACE

SCTRACE [覆盖]

获取质谱仪控制卡内部跟踪数据并将其附加到 _TunePath$ 下的文件 sctrace.txt 中。此命令需要有正确的质谱仪接口卡版本；否则会出现一条错误消息。

覆盖

1 = 覆盖旧文件

0 = 缺省

讨论

缺省的超时期间为 2 秒。如果已经定义了 CP 变量 ScTimeOut 并将其设置为大于等于 1，则超时期间将被设置为 ScTimeOut，限定其下限为 1 秒，上限为 600 秒。若 ScTimeOut 小于 1，则使用缺省值 2 秒。


SCWRITE

SCWRITE "SC 命令字符串"

将命令发送到质谱仪控制卡。

缺省的超时期间为 2 秒。如果已经定义了 CP 变量 ScTimeOut 并将其设置为大于等于 1，则超时期间将被设置为 ScTimeOut，限定其下限为 1 秒，上限为 600 秒。若 ScTimeOut 小于 1，则使用缺省值 2 秒。


SCWRITERD

SCWRITERD "SC 命令字符串" [,变量]

将命令发送到质谱仪控制卡。在消息行中显示来自质谱仪控制卡的响应，并选择性地将其保存在变量（参数 2）中。

缺省的超时期间为 2 秒。如果已经定义了 CP 变量 ScTimeOut 并将其设置为大于等于 1，则超时期间将被设置为 ScTimeOut，限定其下限为 1 秒，上限为 600 秒。若 ScTimeOut 小于 1，则使用缺省值 2 秒。


SENDMODULE$( )

字符串 = SENDMODULE$ ("68GC", "命令字符串")

将一个命令发送到 6890 GC 并读取响应。

命令字符串

对 6890 GC 的一个命令字符串。

示例

a$ = SENDMODULE$("68GC", "CCID")


设定 CI 有效

设定 CI 开/关

这个命令用于 5973 MSD 打开或关闭 CI 模式。


TEMPEQUIL

仅限 5973 MSD。调谐引擎用此命令来检查源和四极杆温度。若温度不在当前调谐文件中设定值的 3 度范围内，则显示一个对话框，询问您是否要覆盖平衡期间。此对话框是一直显示，直到您选择了 override（覆盖）按钮或温度最终得到了平衡为止。


USETRAY7673

若存在托盘，则启用该托盘。这是为了让 Bench（工作台）可以将瓶递送到进样塔而不是托盘中的一个中间位置。


ABUNDANCE

ABUNDANCE [低目标] [,高目标]

调整电子倍增器电压。中止菜单项可以用来停止此命令。

低目标，高目标

来自调谐质量的最高丰度的最小或最大的期望信号。缺省值是当前值。一旦运行了自动调谐，缺省的剖面图丰度值将提供相应的目标值。注意，这些是目标值，而不是绝对值。此外，如果指定的范围以一个很低的 EMV 结束，则此信号不稳定，并在此范围内外波动。

在首先输入调谐时，初始的低目标为 200,000，初始的高目标为 400,00。

讨论

增加或减小电子倍增器电压可调整当前调谐质量的最高丰度，使它们在丰度范围之内。


AVERAGES

AVERAGES [当前值的变量] [,新值]

设置图形扫描的平均值个数。

当前值的变量

如果已指定，则在新值起作用之前，当前值将被存储在此变量中。

新值

报告或显示的每次扫描要进行平均计算的图形扫描次数。范围为 1-9；缺省为当前值。

示例

AVERAGES A

将平均值的当前个数存入变量 A。

AVERAGES , 9

将平均值个数设置为 9。


AXIS

AXIS [质量]

计算校准质量轴所必要的质量轴增益和质量轴补偿。中止菜单项可以用来停止此命令。

质量

0=在使用质量 1 和质量 3 调整轴后，使用调谐质量 1 和调谐质量 2 对轴进行调整。可为调谐质量 1 和调谐质量 2 获得 10 次光谱扫描的平均值。此结果可用来估计轴增益和轴补偿。通过使用调谐质量 1 和调谐质量 3 的 10 次扫描的平均值，可使用估计轴增益和轴补偿来估计新的增益和补偿。缺省值为 0。

2 = 使用质量 1 和质量 2 调整轴。

3 = 使用质量 1 和质量 3 调整轴。

质量必须至少相差 10 amu；如果质量相差小于 100 amu，则会发出警告。


BUFSIZE

BUFSIZE [variable for current value][,new value]

使用该命令将 I/O 数据缓冲器从缺省的 8K 增加到最大 64K。该缓冲器用于从仪器获取数据（扫描、图形等等）。

当前值的变量

如果指定该变量，在新值生效之前，当前值就存储在该变量中。

新值

必须介于系统缺省的 8464 字节与最大值 65064 字节之间。


CAL_VALVE

CAL_VALVE [variable for current value（当前值的变量）] [,new value（新值）][,notify（通知）]

等同于 CALVALVE


CALVALVE

CALVALVE [variable for current value（当前值的变量）] [,new value（新值）][,notify（通知）]

通过设置一个内值（在下一次 MS 被打开时该内值使阀打开或关闭）来控制自动校准阀的开/关状态。取决于电离模式，该命令会影响 EI 或 CI 阀。

当前值的变量

如果指定该变量，新值生效之前，当前值就存储在该变量中。

新值

0 = 将要关闭阀

1 = 将要打开阀

通知

0 = 未通知的 MS 控制卡

1 = 立即通知（缺省）的 MS 控制卡

讨论

该命令实际上并不打开或关闭阀，而是设置一个内值，在下次质谱仪打开时，该内值使阀打开或关闭。该命令只适用于具有自动校准阀的仪器，对于带手动阀的仪器无效。

命令 CAL_VALVE 与 CALVALVE 相同。


CAPTURE

CAPTURE [mass（质量）] [,count（计数）] [,"filename"]

重复测量指定质量的丰度，求出读数的均值和标准偏差，并以图形显示结果（如果 GDISPLAY 打开的话）。Y 轴上的勾号显示与最小丰度的偏移量。使用该命令前应确保质量规格是打开的。

质量

读取丰度处质量 (amu)。缺省为 502 amu。

计数

用于计算平均值和标准偏差的读数个数。允许值为 10 -10,000 之间。缺省为 100。对于大于 2000 的计数，应使用 BUFSIZE 命令来分配一个较大的缓冲器。计数 10,000 至少需要 40,064 字节的缓冲器。

"filename"

数据以 ASCII 码写入该文件。每行一个数。

变量集

CapData - 来自 CAPTURE 的数据

CapDataPts - 来自 CAPTURE 的数据点的 #

CapMax - 最大丰度

CapMean - 丰度平均值

CapMax - 最小丰度

CapStdDev - 标准偏差

CapTime - 获取数据所花的时间（微秒）


DISPPRINT

DISPPRINT [x] [,y] [,cx] [,cy] [,继续] [,延迟]

打印当前位于 Tune（调谐）显示窗口中的图形和文本。

x,y

打印输出的左上角位置。该值以页的分数表示，取该页的右下角作为参考点并指定为 1，1。以此点为参考，范围在 0 到 0.95 之间。若省略 x，就使用缺省位置和尺寸 (0.05, 0.2, 0.9, 0.5)。

cx, cy

图形窗口的新尺寸，以页的分数形式表示。范围是 0.05 到 1-x （或 1-y）。最小尺寸是强制性的，这取决于显示的字符个数和打印机类型。同样，最大尺寸（1-x 和 1-y）也是强制性的。请注意，有些打印机不能调整打印尺寸，只能调整实际图形尺寸。此时，文字就可能无法与图形对齐。

继续

0 = 开始新页（缺省）。

1 = 继续在当前页上绘制。

延迟

0 = 立即打印（缺省）。

1 = 尚不打印；还要在当前页上进行绘制。

讨论

另请参见 STRPRINT 和 PAGESIZE。


DYNAMIC

DYNAMIC <透镜名称>|CLEAR|LIST, (请参见以下的更多语法）

（跟随 <透镜名称>）

ENABLE|DISABLE | |SET|APPEND | |READ|PLOT
<曲线类型> | |<质量> | |<C0 的 cp 变量或点编号>
<梯度步长> | |<透镜设置> | |<质量或 C1 的 cp 变量>
 | <质量> | |<透镜设置或 C2 的 cp 变量>
 | <透镜设置> | | <C3 的 cp 变量>

（跟随 LIST）

<启用的透镜的 cp 字符串变量>

用于系统目标调谐宏中，在扫描时为动态梯度变化设置透镜。动态梯度变化可以放大或衰减特定质谱峰以达到特殊的目标比率。梯度变化可以跟随一个分段的或三次多项式曲线。该命令并非常用命令。

透镜名称

标准透镜名称（如 ENTR）或包含标准透镜名称的变量：

REPELLER

IONFOCUS

ENTRANCE_LENS

XRAY

ENTLENSOFFSET

CLEAR

一个关键字，关闭所有透镜的动态梯度变化。

LIST

一个关键字，列出当前启用的透镜名称并将其写入到用户提供的字符串变量中。如果变量数量超出启用的透镜数量，则忽略额外的变量。如果未提供该参数，则使用缺省 LIST。

DISABLE / ENABLE

分别启用或禁用指定透镜的动态梯度变化的关键字。可以同时进行动态梯度化的透镜的最大个数为 4。

SET

一个关键字，指定要将梯度参数设置成同由后续曲线设置点或参数所指定的一样。

APPEND

一个关键字，允许按曲线分段指定其他质量/设置对。它与三次曲线的 SET 相同。最多可以指定 10 对。

READ

一个关键字，指示将跟随 cp 变量，以获取设置点的信息。

PLOT

一个关键字，将对应设置绘制质量。现在不应用它了。现在不允许缺省值。应用 PLOT 时，PLOT 将为缺省值。

启用透镜

<曲线类型>

只有当指定 ENABLE 时才适用。允许的曲线类型为 PIECE 或 CUBIC。PIECE 意思为线性工作区。三次曲线为

C0 + C1*质量 + C2*质量*质量 + C3*质量*质量*质量

缺省曲线类型为 PIECE。将缺省曲线参数设置为具有常数透镜值，如同禁用梯度变化。

<梯度步长>

只有当指定为 ENABLE 时才适用。这些是梯度变化过程中的质量分辨率步长。缺省值为 1 个质量单位。

设置曲线参数

<质量>

只有当指定 SET 或 APPEND 时才适用。这指定了分段曲线的质量/设置对中的质量或三次曲线的 C0。

10 <设置>

只有当指定 SET 时才适用。这指定了质量/设置对中的设置或三次曲线的 C1。

<质量>

第二质量/设置对中的质量或三次曲线的 C2。

<设置>

第二质量/设置对中的设置。最多可以指定 10 个质量/设置对。

如果动态梯度变化关闭，则 <质量> 之后的 <设置> 的缺省值为当前透镜值。

输入的质量必须按升序排列，且差别至少为一个梯度步长（见上面的定义）。

读取曲线参数

|<C0 的点编号或 cp 变量>

只有当指定 READ 时才适用。这是要读取的分段函数的质量/透镜对的编号或三次函数的 C0 的 cp 变量。

如果点编号为 0，则返回可用（质量、电压）对的数量。

例如，

DYNAMIC CAPEX, READ, 0, a

返回 a 中对的个数。

<质量或 C1 的 cp 变量>

只有当指定 READ 时才适用。PIECEWISE 的质量和三次曲线的 C1。

<透镜设置或 C2 的 cp 变量> -

只有当指定 READ 时才适用。PIECEWISE 的设置和三次曲线的 C2。

<C3 的 cp 变量>

只用于读取 Cubic（三次）函数。

跟随 LIST 的参数

<已启用的透镜的 cp 字符串变量>

将已启用的透镜名称赋值给 cp 字符串变量。将 cp 字符串变量赋值为已启用的透镜名称。如果跟随 LIST 的 cp 字符串变量个数多于已启用的透镜个数，则将不会使用多出部分。字符串变量将具有透镜名称（如 ENTLENSOFFSET），并且可以用于命令 DYNAMIC。

注释：如果您不知道已启用了多少个透镜，则可以将两个 cp 字符串变量预设为 ""。

LIST 选项将填充所有已启用的透镜。随后您可以检查 cp 变量是否为 NULL，以找出已启用的透镜。

注意

命令字符串应当少于 130 字节，否则会被截断。对于分段梯度变化，如果有太多的质量/设置对，可以使用 APPEND 选项。

示例

DYNAMIC ENTLENS, ENABLE, PIECE

用缺省梯度步长（1 amu）启用 Entrance Lens Offset（入射透镜）的线性工作区的动态梯度变化。

DYNAMIC LIST, lens1$, lens2$

将为梯度变化而启用的两个透镜的名称返回给变量 lens1$ 和 lens2$。

DYNAMIC lens1$, SET, 131, 50, 219, 10, 502, 20

对变量 lens1$ 所指定的透镜进行动态梯度变化设置。指定了质量/设置对 131/50、219/10 和 502/20。


EDDISP

显示 Acquisition & Display Parameters（采集与显示参数）对话框，它允许您编辑控制图形扫描和谱图扫描的显示的参数。


EDITFILEINFO

EDITFILEINFO [运行信息]

显示一个用于编辑 MS 数据文件标题中的其他选项信息的模式对话框。

运行信息

0 = 显示不带运行控制信息的对话框

1 = 显示带有运行控制信息的对话框，允许您设置扫描次数和分钟数

变量集

_Button

0 = 取消

1 = 确定

_DataName$ - 数据文件的名称

_MiscInfo$ - 数据文件的 其他选项信息

_Operator$ - 操作员名称

ScanNumOn - 如果为 0，则设置 TRun_Duration；如果为 1，则设置 TRun_NScans


EDPARMS

显示 Edit Parameters（编辑参数）对话框，该对话框允许您在采集并显示要进行调谐的数据时编辑仪器参数。

注意：如果移动了 Edit Parameters（编辑参数）中可用的各个对话框的位置，软件都会记忆下来。下一次您输入 Edit Parameters（编辑参数）并调用这些框时，这些框将会在您最后一次放置的位置处显示出来。位置被保存在文件 _TunePath$ + "mstune.ini" 中 [EDPPOS] 下面。

Edit Parameters（编辑参数）还“记忆”最后一次退出 Tune（调整）时出现哪个面板。若离子化模式被更改或屏幕小于 100 个字符宽度，则此“记忆”失败。信息存储在 [EDPON] 下的与 "onstate" 和 "ionmode" 相同的 mstune.ini 文件中。

要使这些功能无效并且恢复软件缺省值，请删除文件 _TunePath&+"mstune.ini" 或将变量 EDPDefPos 设置为非零值。


EDRAMP

显示 Ramp Parameters（梯度参数）对话框，使您能够编辑梯度参数。


ENDJOB

将从上一次 STARTJOB 命令累积的打印作业发送到 Windows Print Manager（Windows 打印管理器）进行打印。

可能以相反的顺序打印页面。要完成这一操作，必须首先修改 win.ini 文件。在标签为 [PCS] 的部分，添加下面的行：

REVERSEPAGE = TRUE


FILTERM

FILTERM [类型变量] [,类型] [,参数变量] [,过滤器参数]

仅限 5973 MSD。在质量域中设置数据响应过滤器。若未输入参数，则显示 Data Filter（数据过滤器)对话框。

类型变量

用于读取当前类型。

类型

STD 表示标准类型过滤器

ERES 表示增强的分析过滤器

增强的分析过滤器以更高的（大于 500 amu）质量提供更好的质峰检测。

参数变量

用于读取当前过滤器参数。

过滤器参数

此参数将自动设置为 0。若输入了任何其他值，则该参数将被忽略。


FINDBIT

FINDBIT 值, 位数[, 位值变量]

找出 16 位单词的位值。

值

值限制在 0 到 2^16 - 1 之间。任何值在计算之前都将被截取。

位数

位数限制在 0 到 15 之间。非整数将被截取。

位值变量

以 0 或 1 返回位值。


FINDMASS

FINDMASS 低质量 [,高质量] [,质量值变量] [,丰度值变量] [,未扩展的范围]

在给定范围内查找最高峰的精确质量和丰度。

低质量，高质量

定义可从中查找最大质峰的质量范围的质量 (amu) 。

质量值变量

如果指定该变量，则最大峰的精确质量将存储在此变量中。

丰度值变量

如果指定该变量，则最大峰的丰度将存储在此变量中。

未扩展的范围

0 = （缺省）在给定的质量范围（-0.3 到 +0.7 amu）内搜索最高峰。

1 = 搜索未扩展的给定质量范围。

讨论

若当前扫描使用了 Gaussian 峰检测，且指定的当前峰检测不是一种简单的方法，则高斯曲线拟合的质心作为质量返回。丰度仍是原数据峰中的最大值。

如果发现 SCAN 绘图下报告了 "m/z"，您将会获得质心数据；否则，将获得最大丰度的质量。

示例

FINDMASS 69

在 68.7 到 69.7 之间搜索最大峰。


FRESHTUNE

将所有调谐参数重设为其初始值。它还根据当前离子化模式和进样口重新设置阀状态。要显示当前的调谐参数，请输入命令 EDPARMS。可以从 Edit Parameters（编辑参数）对话框或使用 MSPRINT 命令打印当前参数。


GCLEAR

清除 Tune（调谐）显示窗口；还可以集中并缩小本机内存（在宏中使用局部变量时，这是极为有用的）。


GDISPLAY

GDISPLAY [1/0]

控制 Tune（调谐）显示窗口中的图形显示。

1/0

0 = 关闭

1 = 打开

若未输入值，将显示带有当前值的对话框。

讨论

此命令控制调谐命令 ABUNDANCE、CAPTURE、PROFILE、SCAN、SIMRAMP、THRESHOLD 和 WIDTHS 的图形显示。


GETCONFIG

GETCONFIG ["文件名"] [,延迟发送]

加载一个调谐文件。

"文件名"

要加载的调谐文件 (.U) 的名称。此文件中的值覆盖当前内存中的值。不需要路径，因为调谐文件仅存储在存放仪器名称和类型的 mstune 目录下，例如：

c:\MSDchem\1\mstune\5973\*.U

延迟发送

1 = 直到下一次打开 MS 时才设置仪器参数（如阀）。

0 = 立即设置它们

变量集

_Button

0 = 在对话框中选中 Cancel（取消）

1 = 在对话框中选中 OK（确定）

TuneFileName$

当前调谐文件；初始值为 ATUNE.U

TuneFilePath$

当前调谐文件的目录路径；初始值为 \MSDchem\仪器名称\mstune\仪器类型。


GETMSFAULT ( )

值 = GETMSFAULT ( )

将最后一个 MS 故障状态作为数字返回，在 Diagnostics（诊断）窗口中可以对其进行转换。


IOTEST

IOTEST [屏幕显示][,继续]

执行一个 IO 测试。可用 Abort（终止） 菜单项终止此命令。

屏幕显示

1 = 显示在屏幕上（缺省）

0 = 不显示

这两种情况下，执行测试后将会向消息行发送一条消息。

继续

1 = 连续重复测试，直到错误出现或选定了 Abort（终止）；对检测间歇性仪器问题很有用。

0 = 已进行一次测试（缺省）


INSTRPARM

值 = INSTRPARM ("类型")

返回仪器参数。

"类型"

为以下字符串之一：

"maxmass" = 此仪器的最大质量

"minmass" = 此仪器的最小质量

若出现错误，将返回 -1。

示例

a = INSTRPARM("maxmass")

a 现在就具有最大质量限制


LOGDATA

LOGDATA [当前值的变量] [,保存]

将图形、梯度、捕捉和扫描数据保存到预定义的 CP 数组。

保存

1 = 保存数据

0 = 不保存数据

缺省为当前状态；初始状态为 0 或关闭。

讨论

任何数组中最多可以保存 4096 个数据点。如果获取的数据具有更多数据点，则其余的数据点将被忽略。使用标准 CP 语言来访问数组元素。要将矩阵写入到文件，请参阅 MATTOFILE。

数组为：

profdata1 | 来自质量 1 图形扫描的数据
profdatapts1 | 来自质量 1 图形的数据的编号
profdata2 | 来自质量 2 图形扫描的数据
profdatapts2 | 来自质量 2 图形的数据的编号
profdata3 | 来自质量 3 图形扫描的数据
profdatapts3 | 来自质量 3 图形的数据的编号
scandata | 光谱扫描的数据
scandatapts | 光谱扫描的数据的编号
梯度数据 | 来自 SIMRAMP 的数据，最高质量编号
rampdatapts | 来自 SIMRAMP 的数据的编号，最高质量编号
capdata | 捕捉的数据
capdatapts | 捕捉的数据的编号

示例

要保存扫描原始数据：

SCANPARM scantype,,1

! 过滤原始数据

PEAKPARM ,1

! 峰检测类型

BUFSIZE ,65064

!最大采集缓冲

LOGDATA s, 1

!将数据保存在数组中

SCAN

LOGDATA ,s

!恢复以加速

MATTOFILE scandata, "scan.txt"

!保存在文件中

REMOVE scandata, scandatapts

!保存内存

变量集

ProfData1 — 来自质量 1 图形扫描的数据

ProfDataPts1 —来自质量 1 图形的数据的编号

ProfData2 — 来自质量 2 图形扫描的数据

ProfDataPts2 —来自质量 2 图形的数据的编号

ProfData3 — 来自质量 3 图形扫描的数据

ProfDataPts3 —来自质量 3 图形的数据的编号

ScanData — 光谱扫描的数据

ScanDataPts — 光谱扫描的数据的编号

RampData — 来自 SIMRAMP 的数据，最高质量编号

RampDataPts — 来自 SIMRAMP 的数据的编号，最高质量编号

CapData — 来自 CAPTURE 的数据

CapDataPts — 来自 CAPTURE 的数据点的编号


MASS

MASS [质量 1] [,质量 2] [,质量 3] [,设置变量]

这与 MASSES 相同。


MASSES

MASSES [质量 1] [,质量 2] [,质量 3] [,设置变量]

指定新的调谐质量。

质量 1, 质量 2, 质量 3

要用于调谐的离子质量（以 amu 表示）。缺省为当前值。当将 PFTBA 用于调谐时，质量通常为 69、219 和 502。

如果 set variables（设置变量） 参数设置为 1，则在此处输入放置调谐质量当前值的变量的名称。

set variables（设置变量）

0 = 使用指定的值设置质量（缺省）

1 = 读取当前调谐质量，并将值放在为每个质量指定的变量中。

示例

MASSES a1, a2, a3, 1

将当前调谐质量值放在变量 a1、a2 和 a3 中。


MASSFACTOR

MASSFACTOR [坐标设定因子]

调整图形扫描的 Y 轴比例。当将 SCALEMODE 设置为固定比例时，不应用此因子。

坐标设定因子

用此因子除全部三个调谐质量的 Y 轴比例（即，丰度与此因子相乘）。

有效范围是 0.1 到 100。缺省为当前值，通常为 1。


MASSGAIN

MASSGAIN [当前值的变量] [,新值]

设置质量轴增益（质量轴校准参数）。

当前值的变量

如果已指定，则在新值起作用之前，当前值将被存储在此变量中。

新值

质量轴增益的新值。这是等式中所使用的乘法因子,以校准质量轴。对于 5972, 6890 MSD，范围是 -4999 到 4999。缺省为当前值（显示在消息行，且如果指定了一个变量，则将其存储在此变量中）。

讨论

设置加法因子，另请参见 MASSOFFSET。这些参数还可以由 AXIS 命令设置。

不要拒绝具有 amu 增益和 amu 补偿的那些参数（借助 MSPARM 或 WIDTHS 命令设置），它们调整仪器以便在光谱内获得期望的峰宽。

示例

MASSGAIN MG

MASSGAIN , MG+5

将质量轴增益的当前值存储在变量 MG 中，然后按 5 的递增量来递增它的值。


MASSOFFSET

MASSOFFSET [当前值的变量] [,新值]

设置质量轴补偿。

当前值的变量

如果已指定，则在新值起作用之前，当前值将被存储在此变量中。

新值

质量轴补偿的新值；这是等式中使用的加法因子,以校准质量轴。对于 5972 和 6890 MSD，范围是 -99 到 99。缺省为当前值（显示在消息行，且如果指定了一个变量，则将其存储在此变量中）。

讨论

设置乘法因子，另请参见 MASSGAIN。这些参数还可以由 AXIS 命令设置。

不要拒绝具有 amu 增益和 amu 补偿的那些参数（借助 MSPARM 或 WIDTHS 命令设置），它们调整仪器以便在光谱内获得期望的峰宽。

示例

MASSOFFSET MO

MASSOFFSET ,MO-5

将质量轴补偿的当前值存储在变量 MO 中，然后按 5 的递增量来递增它的值。


MASSWINDOW

MASSWINDOW [尺寸]

设置图形扫描的窗口尺寸。

尺寸

位于 0.2 和 100 个amu（原子质量单位）之间的 m/z 值。结果窗口为此处输入的值的两倍。缺省为当前值。初始值为 5 amu。

示例

MASSWINDOW 2

定义调谐质量任意一边的窗口为 +/- 2 amu。


MATTOFILE

MATTOFILE 数组名称，"文件名"

将 LOGDATA 产生的矩阵写入到一个 ASCII 文件中。

数组名称

n<=4 且数字介于 -9999999 和 +9999999 之间的数组的名称 (m x n)。为了支持指定的固定格式，大于 1e7 或小于 -1e7 的数字将产生错误。

"文件名"

ASCII 文件名。矩阵的每一行都写作具有 +/-nnnnnnn.nn 数字格式的文本行。数字之间有 4 个空格。


MAXSCANRNG ( )

值 = MAXSCANRNG ( )

返回在没有缓冲溢出的情况下原始数据的最大扫描范围。返回值总是不大于此仪器允许的扫描范围。


MENUSTATE ( ) （在 Tune（调谐）中）

值 = MENUSTATE （菜单项编号）

支持对菜单项进行复选或变灰的函数。

菜单项编号

100 = 检查原始数据。如果当前扫描数据类型是过滤后的原始数据或是原始数据，则返回 1，否则返回 0。

101 = 检查 ES 离子化。如果当前离子化为 ES，则返回 0；否则返回 2。

102 = 检查 Trace on/off （跟踪打开/关闭）的状态。如果该菜单项被选中，则返回值 1；若它关闭，则返回 0。


MSBUILD

MSBUILD #文件编号, y1, y2, y3, y4, y5

根据输入的丰度值在指定文件中创建一个扫描。

#文件编号

从 1 到 10 的一个数字。它必须是先前使用 MSOPEN 命令打开的一个文件的编号。

y1, y2, y3, y4, y5

其中的每一个都是从 0 到 10,000 之间的一个数字。这些 y 值被作为丰度值写入到文件中。对应的质量值为 0.1、0.2、0.3、0.4 和 0.5。如果未指定某个 y 值，则使用零值。

讨论

该命令创建一个可以被写入到一个辅助数据文件中（使用 MSWRITE）的扫描，允许将辅助数据源作为 MS 数据文件来操作。同时创建多个辅助数据文件的功能考虑到了具有 MS 数据的不同数据源之间的相关性。

另请参见

MSOPEN

MSCLOSE

MSWRITE

MSSNAP


MSCHECK

MSCHECK [变量]

检查最后的 I/O 状态。为了节省时间，不要尝试 I/O 操作。

变量

若已输入该值，则 0 = 到目前为止没有 MS 响应；1 = 有 MS 响应。


MSCLOSE

MSCLOSE [#文件编号] [,...]

关闭指定的调谐数据文件。如果未输入文件编号，则关闭所有数据文件。

#文件编号

从 1 到 10 的一个数字。它必须是先前使用 MSOPEN 命令打开的一个文件的编号。

另见

MSWRITE

MSCREATE

MSSNAP

MSBUILD


MSCREATE

MSCREATE ["文件名"] [,变量]

创建一个质谱扫描数据文件。自动添加路径名和 .D 扩展名。

"文件名"

如果该命令未提供文件名，则弹出一个询问名称的对话框。如果选中的文件已经存在，会询问您是否希望将其覆盖。

变量

如果指定的文件存在并且可以用于 MSWRITE，则变量 MsDataFile$ 中保存有数据文件名。否则为空（空字符串）。如果您在任何一个对话框上单击 Cancel（取消），则该变量中会成为空字符串。

变量集

_Button

0 = 在对话框中选择 Cancel（取消）

1 = 在对话框中选中 OK（确定）


MSOFF

关掉所有质谱仪电压并关闭校准阀。


MSON

将当前的 MS 参数发送到仪器接口，打开质谱仪，随后打开或关闭校准阀（取决于 CALVALVE 的当前设置）。

请注意，MSPARM 和 CALVALVE 命令只改变内存中的参数值。


MSOPEN

MSOPEN "文件名" [FOR OUTPUT] AS #文件编号

创建并打开一个调谐数据文件，同时将其名称和一个数字相关联。此数字随即被其他调谐数据文件命令使用以对此数据文件进行操作；请参见：

MSCLOSE

MSWRITE

MSSNAP

MSBUILD

MSCREATE

"文件名"

必须是以扩展名 .D 结尾的现存的目录名。必须指定完整路径。

#文件编号

一个 1 到 10 之间的数字。

讨论

如果在使用 MSOPEN 之前已设置了变量 _MiscInfo$、_Operator$ 和 _InstName$，那么 MSOPEN 将把变量中的信息读进数据文件，在其中它可用于数据分析和报告。（只有在使用 VARLOCK 命令后才能设置这些。）

若 ScanNumOn 设为 1，MSOPEN 将使用扫描编号而不是时间来检索数据文件的扫描。这在 Tune（调谐）中交互收集数据时很有用。

变量集

_TuneData

0 = 编号为 10 的文件中无 MS 数据变量

1 = 编号为 10 的文件中有 MS 数据变量


MSPARM

MSPARM 参数 [,当前值的变量] [,新值]

将指定的质谱仪参数设置为一个新值。参数的新值被舍入到最接近的 DAC（数模转换器）步长。

参数

指定所要设置的参数的关键字。关键字可尽量简短，所用字符能够在如下列表中唯一定义关键字即可。每个参数的 DAC 步长在括号中给出。

关键字(电压/DAC 步长)

AMUGAIN (1.0)

AMUOFFSET (1.0)

DCPOLARITY (正或负)

EMISSION ( 0 = 关闭，1 = 打开)

ELECTRON (0 = 关闭，1 = 打开)（仅限 5973 MSD）

EMVOLTS (11.764)

ENTLENSOFFSET (0.25098)

ENTRANCE_LENS (0.50196)

FILAMENT (1 或 2)

IONFOCUS (0.5)

REPELLER (0.07765)

TTI (打开或关闭)

XRAY (0.8549)

WIDTH219 (0.001176)

当前值的变量

若指定，当前值将一直存储在此变量中，直到新值生效。

新值

参数的新值。缺省时为显示在屏幕上的当前值（若指定了变量，则存储在变量中）。

讨论

新值仅在内存中。在用 MSON 命令打开质谱仪之前，不用新值来设置 MS 电压。

示例

MSPARM EMV

返回当前电子倍增器电压。

MSPARM REPELLER,,17

将推斥极电压设为 17。


MSPARMINFO

MSPARMINFO 关键字 [,已启用的变量] [,下限变量] [,上限变量], [,分辨率变量]

给出 MS 参数信息。

关键字(电压/DAC 步长)

AMUGAIN (1.0)

AMUOFFSET (1.0)

DCPOLARITY (正或负)

EMISSION ( 0 = 关闭，1 = 打开)

ELECTRON (0 = 关闭，1 = 打开)（仅限 5973 MSD）

EMVOLTS (11.764)

ENTLENSOFFSET (0.25098)

ENTRANCE_LENS (0.50196)

FILAMENT (1 或 2)

IONFOCUS (0.5)

REPELLER (0.07765)

TTI (打开或关闭)

XRAY (0.8549)

WIDTH219 (0.001176)

变量

要接收信息的 CP 变量。

返回

如果关键字不是一个有效的 MS 参数，已启用的变量将返回 0。当已启用的变量为 0 时，上下限以及分辨率都设为 0。


MSPRINT

MSPRINT [y] [,继续] [,延迟]

打印 MS 参数。可以用此命令在同一页上打印带有扫描和图形数据的调谐报告。

y

以字符为单位的 MS 参数的起始位置。y >= 0。缺省值 = 5。y+1 为实际的行号。因此一个 y=2 的值在行 3 处启动 MS 参数。参数在 x 方向居中。

继续

1 = 在当前页上继续绘制。

0 = 不继续（缺省）

延迟

0 = 立即打印。

1 = 还不打印；还要在当前页上绘制更多（缺省）

讨论

仅使用 win.ini 中的缺省打印机（[windows]下的第一个 DEVICE）。假设打印机存在。

用户必须确保随后的打印命令不会打印重叠字符串或图形。

使用继续和延迟时要谨慎。使用这些参数可能会覆盖多个图形，可能使打印输出作废。很复杂的输出会延长打印时间。这些参数主要用于在同一页上打印带有扫描和图形数据的调谐报告。

示例

MSPRINT 2

在打印纸的第三行上打印。


MSSNAP

MSSNAP #文件编号

创建指定调谐数据文件的一个快照文件。

#文件编号

一个 1 到 10 之间的数字，它必须是一个先前用 MSOPEN 命令打开过的文件的编号。

另请参见

MSCLOSE

MSWRITE

MSBUILD


MSTATUS

MSTATUS [变量]

检查 MS 的状态。

变量

若已指定，MS 的状态将存储在此变量中。如果没有指定名称，状态将显示在 Tune（调谐）显示窗口中。

如果指定了变量，它将包含一个数字，此数字为已发生错误的值的总和：

位# | 位值 | 含义
 | 0 | 无错误
0 | 1 | 团体错误（一个或多个错误）
1 | 2 | 存在额外的信号级别
2 | 4 | 质量过滤器电路中有故障
3 | 8 | 无发射电流
4 | 16 | 离子源压力超出警戒
5 | 32 | 扩散泵过热
6 | 64 | 前级压力已超过 300 mTorr
7 | 128 | 扩散泵过冷
8 | 256 | 系统处于 VENT 状态
9 | 512 | 检测器 HV 供应中有故障
13 | 8192 | MS 内部通讯故障。
14 | 16384 | 系统处于 STANDBY 状态（由连接到 MS 接口的 APG 远程光缆关闭，可能由 GC 或 LC 关闭）。

用 FINDBIT 命令对错误位进行解码。

示例

MSTATUS 状态

变量状态的值为 12，它表示遇到了两个问题 (4+8)并且均已报告：

“质量过滤器电路中有故障。”(4) 和

“无发射电流。” (8)

如果状态值为 14（“系统处于 Standby（待机）模式”），GC 检测器、温度、压力或者流量设定值尚未达到，则6890 GC 可能会关闭 MS。MS 将保持待机模式，直到问题已解决或 APG 光缆断开了。


MSWRITE

MSWRITE #文件编号

将当前扫描写到指定的调谐数据文件。

#文件编号

一个 1 到 10 之间的数字，它必须是一个先前用 MSOPEN 命令打开过的文件的编号。

另请参见

MSCLOSE

MSCREATE

MSSNAP

MSBUILD


OPTIM

OPTIM ["文件名"] [,使用 CP 变量] [,使用当前 MS 值] [,读/写]

仅供内部使用。优化 MS 镜头以在所要求的质量处获得目标比率或最大丰度。

"文件名"

文件的名称，带有一个 .OPT 扩展名；变量文件为 DFTPP4.OPT、BFB.OPT 和 TARGET.OPT。此文件包含需要的所有优化参数。若未指定文件，则使用缺省参数。如果指定了下面的 OPTIM 命令参数，则特定的参数将被取代。

使用 CP 变量

1 = 使用下面的 CP 变量，而不用 .OPT 文件中的值：

targmass = 以 amu 表示的第一个目标质量

target1 ... target6 = 目标比率

0 = 不使用 CP 变量（缺省）

使用当前的 MS 值

1 = 使用优化所使用的第一组值的当前 MS 参数值。

0 = 不使用当前的 MS 参数（缺省）

读/写

1 = 将缺省的参数值写入到文件 DFTPP4.OPT 中

0 = 不写入文件（缺省）

讨论

此命令在目标和 DFTPP 自动调谐中使用。支持 Abort（终止）菜单项。

如果在 Tune（调谐）中启用了跟踪，则优化参数和优化过程都记录在跟踪文件中。


PAGESIZE

PAGESIZE [x 变量名][,y 变量名]

在消息行上显示当前打印机配置所使用的页尺寸。如果未指定参数，会在消息行上显示信息。

x 变量名

该变量返回页宽度。该值等于宽度中的字符平均个数减去 1。

y 变量名

该变量返回页长度。该值等于页长度中的字符平均个数减去 1。

讨论

对于使用标准系统字体的各种配置，返回以下值。这些值可能会根据打印机中实际安装的墨盒而有所变化。

配置列编号和行编号

DeskJet Plus 80 60

DeskJet Plus (A4) 77 65

LaserJet III 79 63

LaserJet III (A4) 76 67

LaserMaster 76 60

LaserMaster (A4) 76 64


PEAKPARM

PEAKPARM [当前类型的变量] [,新类型] [,variable for current%] [,new%]

设置峰检测参数。由 PROFILE、AXIS 和 WIDTHS 命令使用。

当前类型的变量、新类型

和在其他 Tune（调谐）命令中一样，这些参数用于读取和设置峰检测类型。

0 = 简单峰检测；对于 PROFILE，则意味着图形数据的最大值。对于 AXIS，则意味着已检测到的简单峰扫描数据。

1 = 对 PROFILE 和 AXIS，为已过滤的原始扫描数据进行 Gaussian 拟合所获得的峰。

2 = 对 PROFILE 和 AXIS，为未经过滤的原始扫描数据进行 Gaussian 拟合所获得的峰。

缺省为调谐文件值；初始为 0。

variable for current%, new%

这两个参数只应用于类型 1 和 2。它们指定在峰矩心检测中要包含哪些数据点。例如，new% 取值 20 意味着所有具有大于或等于峰中最大丰度的 20% 丰度的数据点都包含在内。缺省为调谐文件值；初始为 30。


PROFILE

PROFILE [控制符]

获取并显示当前调谐质量的图形扫描。

每次图形扫描所报告的丰度值都是扫描窗口中的最大峰的丰度与最小比例处的丰度之间的差值（请参见 SCALEMODE）。

控制符

控制图形扫描过程的一个数字：

1 = 连续重复图形扫描；Abort（终止） 菜单项、Stop（停止）按钮、空格键或 Enter 键都可以停止该过程。

0 = 进行单次图形扫描（缺省）

-1= 进行单次图形扫描；显示报告

变量集

BasePeak1, BasePeak2, BasePeak3 - 最大丰度出现处的质量

ConFidm_z1, ConFidm_z2, ConFidm_z3 - Peakm_z 的 95% 置信级

IsoAbund1, IsoAbund2, IsoAbund3 - 同位素峰的丰度

IsoMass1, IsoMass2, IsoMass3 - 同位素峰的质量

Peakm_z1, Peakm_z2, Peakm_z3 - m/z 来自曲线拟合的值

PeakMax1, PeakMax2, PeakMax3 - 每一调谐质量的最大丰度

PeakMin1, PeakMin2, PeakMin3 - 每一调谐质量的最小丰度

PeakWidth1, PeakWidth2, PeakWidth3 - 每一调谐质量 50% 高度处的峰宽

Precursor1, Precursor2, Precursor3 - 前体的丰度

ProfData1, ProfData2, ProfData3 - 图形扫描的数据。只有当 LOGDATA 打开且使用 MATTOFILE 命令时这些变量才存在。

ProfDataPts1, ProfDataPts2, ProfDataPts3 - 对每一质量进行图形扫描的数据点的编号。只有当 LOGDATA 打开且使用 MATTOFILE 命令时这些变量才存在。

PW101, PW102, PW103 - 每一调谐质量 10% 高度处的峰宽

Valley1, Valley2, Valley3 - 峰谷的丰度


PROFPARM

PROFPARM PW / SHOWABUND [当前值的变量][,新值]

设置图形扫描参数。

PW

0 = 使用 50% 最大丰度处的峰宽。初始值为 0。

1 = 使用 10% 最大丰度处的峰宽。该参数控制图形扫描的峰宽显示，也控制 WIDTHS 命令达到 10% 或 50% 的峰宽目标。

SHOWABUND

0 = 如果不是固定比例，则显示百分比丰度。

1 = 显示丰度计数单位。该参数只控制图形扫描显示

讨论

请注意，图形扫描后在 50% 和 10% 处的两个峰宽都可以由 CP 变量得到:

PeakWidth1, PeakWidth2, PeakWidth3 = 50%

PW101, PW102, PW103 = 10%


PWIDTHS

PWIDTHS [目标] [,范围] [,协议] [,% 宽度] [,集合变量]

设置峰宽调节的目标。对于最大丰度的 10% 或 50% 处的峰宽，可以通过 CP 变量设置或读取目标。

目标

0.3 和 2.5 之间的值。缺省为当前值，初始为 0.5 amu。请注意，该值只是一个目标，不一定达到。

范围

实际和目标峰宽之间的最大可接受偏差。缺省为当前值，初始为 0.06 amu。

协议

调谐质量的实际峰宽之间的最大可接受偏差。缺省为当前值，初始为 0.03 amu。

% 宽度

1 = 将峰宽参数设置为最大丰度的 10%。

0 = 将峰宽参数设置为最大丰度的 50%（缺省）。

集合变量

1 = 前三个命令参数是 CP 变量，当前值保存在这些 CP 变量中。

0 = 前三个命令参数是数字，在内存中设置峰宽参数。缺省 = 0。

示例

PWIDTHS 1.0,,,1

在 1.0 处设置 10% 峰宽目标

PWIDTHS a,b,c,1,1

读取 CP 变量 a、b、和 c 中的 10% 峰宽参数。


RAMPSMOOTH

RAMPSMOOTH [变量的当前值] [,变量的新值]

为 SIM-ramp 数据指定要进行平滑处理的点数。

变量的当前值，变量的新值

一个包含当前值的变量和一个包含新值的变量。新值必须为 0，或者是一个 5 到 101 之间的奇数。如果您输入一个 5 到 101 之间的数字，则利用指定的点来应用 Savitsky-Golay 二次/三次平滑。如果输入的数字不是奇数，则使用最近的奇数。

要重新设定平滑，可将 0 作为新参数输入。

讨论

平滑中用到的点的数量标识于 SIM 梯度图上。此平滑命令也可由 Edit Ramp Parameters（编辑梯度参数）面板获取。


SAMPLES

SAMPLES [当前值的变量] [,新值]

设置样品的数量以便进行扫描和图形扫描。

当前值的变量

若指定该变量，则当前值在新值起作用之前存储在此变量中。

新值

n 的值，其中样品的数量等于 2^n。允许值的范围从 0 到 7。缺省值为当前值；初始值为 4。

示例

SAMPLES N,6

将当前值保存在变量 N 中，并将新值设为 6。2^6=64 个样品。


SAVECONFIG

SAVECONFIG ["文件名"]

将 MS 参数保存到一个调谐文件。

"文件名"

用来存储参数的调谐文件的名称。如果没有输入文件名，则显示 Select File（选择文件）对话框。如果未提供扩展名，则在名称后附加扩展名 .U。

调谐文件只能存储在 ChemStation 的 \MSDchem\inst number\inst name 目录下。

示例

对于 C 上的 ChemStation 软件：用仪器 1 将驱动器配置为一个 5972 质谱仪：

SAVECONFIG "SAVE.U"

将调谐参数保存在 C:\MSDCHEM\1\ 5972\SAVE.U 中

变量集

_Button

0 = 在对话框中选定的 Cancel（取消）

1 = 在对话框中选定的 OK（确定）

TuneFileName$ — 当前的调谐文件；初始值为 ATUNE.U

TuneFileName$ — 当前调谐文件的目录路径；初始值为

\MSDchem\inst number\inst name。


SCAN (调谐)

SCAN [低质量] [,高质量] [,样品] [,阈值] [,清除显示]
SC [低质量] [,高质量] [,样品] [,阈值] [,清除显示]

获取并显示一个质谱。若参数随此命令一同输入，则这些参数仅用来获取当前扫描，并不影响当前值。要更改当前值，请使用 FRESHTUNE、GETCONFIG、MASSES、SAMPLES 或 SCANPARM。

低质量、高质量

定义要扫描的质量范围。允许值范围从 1.2 到 700 amu。缺省值为当前值。

样品

编号 n，其中样品的编号为 2^n；n 的允许值范围从 0 到 7（请参见 SAMPLES）。缺省值为当前值。

阈值

峰检测阈值。缺省值为当前值。

清除显示

0 = 在接收到扫描数据前不清除显示。当此参数为 0 时，若错误为 "no scan peaks"，则命令将不会生成一个错误。而是将 CP 变量 Scan_No_Peaks 设置为 1。此标记可用于数据的继续采集。

1 = 清除早期的显示（缺省）

讨论

如果数据不是峰检测的类型(请参见 SCANPARM 命令）并且峰检测并不单一（请参见 PEAKPARM 命令），则将为质量和同位素质量报告 Gaussian 质心。图形下方的文本使用 m/z 代替质量。但是，丰度仍然取原数据峰中的最大值。

示例

若质量范围的当前设置为 10 到 600：

SCAN 50,200

扫描范围从 50 amu 到 200 amu。

SCAN

再次从 10 amu 扫描到 600 amu。

变量集

NumScanPeaks — 峰的数量

ScanAbund1, ScanAbund2, ScanAbund3 — 每个调谐质量的丰度

ScanBaseAbund — 基峰的丰度

ScanBasePeak — 基峰 (amu)

ScanData — 来自光谱扫描的数据

ScanDataPts — 来自光谱扫描的数据点的编号

ScanIsoAbund1, ScanIsoAbund2, ScanIsoAbund3 — 同位素丰度

ScanIsoMass1, ScanIsoMass2, ScanIsoMass3 — 同位素质量

ScanMass1, ScanMass2, ScanMass3 — 每个调谐质量的质量 (amu)


SCALEMODE

SCALEMODE [模式] [,最小值] [,最大值] [,进行扫描]

为图形或光谱扫描设置 Y 轴坐标的显示模式。

模式

0 = 固定坐标；值是由最小值、最大值参数设置

1 = 为图形扫描的第一调谐质量设定坐标；对扫描自动设定坐标；为每个由 PROFILE 变量 PeakMin1、PeakMin2 和 PeakMin3 分别设置的调谐质量设定坐标最小值；为所有由 PROFILE 变量 Peakmax1 所设置的调谐质量设定坐标最大值。

2 = 对每个调谐质量进行自动设定坐标；为每个由 PROFILE 变量 PeakMin1、PeakMin2 和 PeakMin3 分别设置的调谐质量设定坐标最小值；为所有由 PROFILE 变量 Peakmax1、PeakMax2 和 PeakMax3 分别设置的调谐质量设定坐标最大值。

缺省值为显示在消息行中的当前值。初始值为 2。

最小值、最大值

用来为固定坐标模式设置 Y 轴限制的丰度值。在其他模式下将被忽略。缺省值分别为 0 和 100。限制值为 0 和 6,400,000。

进行扫描

此参数可确定受前面的参数影响的扫描类型。

0 = 图形扫描（缺省）

1 = 扫描

讨论

扫描功能的固定坐标用于内部诊断。要节省时间和降低对 y 轴进行标记的屏幕真实等级，扫描的 y 轴仍旧以坐标最小值和坐标最大值之间差的百分比表示。若使用自动设定坐标，则坐标最小值为 0，最大值为基峰丰度。


SCANPARM

SCANPARM 参数 [,当前值的变量] [,新值] [,当前间隙的变量] [,新间隙]

设置扫描参数。

参数

指定所要设置的参数的关键字。

LOWMASS

HIMASS

THRESHOLD

SCANTYPE

0 = 正常峰检测扫描，条形图显示

1 = 筛选的原数据，连续曲线

2 = 原数据，连续曲线

当前值的变量

若指定该变量，则当前值在新值起作用之前存储在此变量中。

新值

缺省值为初始值。

当前间隙的变量/新间隙

这些参数仅当 SCANTYPE = 1 时使用，且用于内部展开。缺省并推荐的间隙为 0。当扫描数据具有非 0 的阈值，并且峰的质量间隙大于指定的间隙时，扫描图将下降到阈值以表示丰度已降到阈值以下。

新间隙值的范围为 0 到 20。当输入的间隙值为 0 或小于检测器可能的最窄值时，则使用可能的最窄值。


SCANPRINT

SCANPRINT [当前值的变量] [,新值]

控制 SCAN 的丰度和同位素数据的打印。

当前值的变量

若指定该变量，则当前值在新值起作用之前存储在此变量中。

新值

0 = 关闭；不打印数据

1 = 打开；打印丰度和同位素数据


SCINIT

SCINIT [1/0]

如果有必要，可通过下载控制程序初始化 MS 接口。这也是验证计算机和 MS 接口之间通信的一种方法。下载发生前存在一个 10 到 20 秒钟的延迟。

1/0

0 = 仅当需要时才进行下载（缺省）。

1 = 强制下载；这在不关闭 MS 电源的情况下加载新固件修订版时很有用（推荐用于 5972/6890；否则，您必须进行系统放气然后关闭电源）。


SCIOINIT

SCIOINIT 1/0

如果有必要，可通过下载控制程序初始化 MS 接口。这也是验证计算机和 MS 接口之间通信的一种方法。下载发生前存在一个 10 到 20 秒钟的延迟。

1/0

0 = 仅当需要时才进行下载（缺省）。

1 = 强制下载；这在不关闭 MS 电源的情况下加载新固件修订版时很有用（推荐用于 5972/6890；否则，您必须进行系统放气然后关闭电源）。


SETRAMP

SETRAMP [参数] [,开始] [,停止] [,步长]

设置调节指定参数的限定值和步长。

参数

指定要设置的 MS 参数的关键字。此关键字可简写为能够唯一定义该参数的几个字符。

AMUGAIN

AMUOFFSET

ENTLENSOFFSET

ENTRANCE_LENS

IONFOCUS

REPELLER

XRAY

开始, 停止

梯度的开始点和结束点。

步长

梯度点之间参数改变的数量。

讨论

参数真正的开始、结束、以及步长值可能与输入的那些值有轻微的差异。这些值都舍入到该参数最接近的 volts/DAC（到模拟转换器的数字）步长（请参见 MSPARM）。

通过 SETRAMP 设置的值可被 SIMRAMP 所用。


SETRFPA

SETRFPA [质量]

发送命令以将 RFPA 设置为 MS 接口。诊断命令。

质量

用 amu 表示的质量。如果没有指定质量，则会有一个对话框提示您指定此值。对话框中的缺省值为第一调谐质量。


SETTHRESH

SETTHRESH 关键字 [,质量编号] [,当前值的变量] [,新值]

覆盖与指定质量的 WIDTHS 或 THRESHOLD 命令相关缺省阈值。

关键字

用来指定要设置的命令阈值的关键字：

WIDTH — 影响阈值可提高 WIDTHS 命令的 EMV

THRESH — 影响阈值可提高 THRESHOLD 命令的 EMV。

RESET — 删除使用此命令设置的所有阈值并恢复缺省值。忽略其他所有参数。

质量编号

调谐质量编号 1、2 或 3；缺省值为 1。

当前值的变量

若指定该变量，则当前值在新值起作用之前存储在此变量中。

新值

用于所指定质量的阈值的值。

示例

SETTHRESH THRESH, 2, A, 1000

将第二调谐质量的阈值设置为 1000，以供 THRESHOLD 命令使用。当前值将存储在变量 A 中。


SETUSER

SETUSER 索引 [,变量] [,新值]

设置用户参数，可将这些参数保存到调谐文件中以便在宏中使用。

索引

一个 0 到 19 之间的值，该值可用来指向存储在调谐文件中的另一个值（新值）。缺省值为 0。

变量, 新值

允许读写。

讨论

运行 FRESHTUNE 后，这些参数被重置为 -1.0e+99。


SIMACQ

SIMACQ [停留] [,离子 1] [,离子 2] [...] [,离子 30]

采集 SIM 数据并将其图形化显示。

停留

在每个质量中以毫秒表示的采集数据的时间，可接受的范围是从 10 到 9999，缺省值为 100。停留时间与离子个数的乘积必须小于 100 秒。

离子 1, ...,离子 30

以 amu 表示的离子质量。离子 1 的缺省值为 74.1。命令行的录入最长可接受 132 个字符，超出此限制的字符串将被截短。

讨论

显示所选定离子的质量为 +/-10 amu。要关闭显示在绘图下面的报表，请使用 SCANPRINT。


SIMRAMP

SIMRAMP 参数 [,质量编号] [,优化] [,未优化] [,停留时间] [,用户选择]

调节并用图表示指定的 MS 参数。可用 Abort（中止）菜单项中止此命令。

参数

指定要调节的 MS 参数的关键字。此关键字可简写为能够唯一定义该参数的几个字符。

AMUGAIN

AMUOFFSET

ENTLENSOFFSET

ENTRANCE_LENS

IONFOCUS

REPELLER

XRAY

质量编号

确定在调节参数时，哪个调谐质量需要被监控；可能值为 1、2、3 或 -1，当为 -1 时调节所有的透镜。如果不指定第二个参数，则调节所有质量。

优化

一个表示是否要保留为此参数找到的优化值的关键字（例如，应该替换以前的值）。

NONE — 缺省值。保留以前的值。

MAXIMUM — 保留与梯度最大值相应的值。若调节了所有这三个质量，则保留质量 3 的优化值。

FIRST_INFLECTION — 在遇到一个特定阈值的标准时与第一个最大峰相对应的值（用于消除噪声）。

未优化

不起作用的参数。

停留时间

在每个透镜值中以毫秒表示的采集数据的时间。缺省值为 50。

用户选择

0 = 不显示用户选择选项（缺省）。

1 = 显示一个带滚动条的对话框，以便您可以手动选择 MS 参数值。

讨论

SIMRAMP 在由 SETRAMP 设定的范围中调节参数，并显示一个调谐质量丰度与参数设置（volts 或 DAC）的绘图。

变量集

RampData — 来自梯度的数据

RampDataPts — 来自梯度的数据点的点数

RampMax — 优化参数设为 MAX 时最后梯度的最大丰度


STARTJOB

STARTJOB "作业描述"

初始化一项多页打印作业。使用适当的打印命令可以累积打印几张输出页。直到发出 ENDJOB 命令后才能打印页面。打印页面顺序可以是逆向的，请参见 ENDJOB。

"作业描述"

显示在 Windows Print Manager（Windows 打印管理器）中的一个描述性字符串。

变量集

JobName$ — 打印作业的名称（在第一个参数中指定）


STEPSIZE

STEPSIZE [当前值的变量] [,新值]

设置图形扫描的质量步长。

当前值的变量

若指定该变量，则当前值在新值起作用之前存储在此变量中。

新值

新的质量步长，范围从 0.05 amu 到 MASSWINDOW 的当前值。初始值为 0.10 amu。缺省值为当前值。

讨论

真正的 STEPSIZE 值可能会与输入值有轻微的差异，该值被舍入到最接近的可分辨步（0.05）。


STRPRINT (Tune)

STRPRINT "字符串" [,x] [,y] [,继续] [,延迟]

将一个字符串发送到打印机。

"字符串"

要打印的字符串。

x,y

用字符单位表示的打印字符串的开始位置。最小值为 0，最大值由打印机所允许的每页行数确定。如果您输入一个大于最大值的值，则字符串将无法打印。缺省值为 5,1。

继续

0 = 开始新页面（缺省）。

1 = 继续在当前页上绘制。

延迟

0 = 立即打印（缺省）。

1 = 尚未打印，在当前页上还要进行更多绘制。

讨论

字母数字字符串可以用 PRINT USING 命令进行格式化。另见 PAGESIZE。


THRESHOLD（调谐）

THRESHOLD [质量编号] [,循环] [,调整推斥极] [,调整轴]

从 MS 为调谐质量 1 和选定的调谐质量获取阈值响应。可以使用 Abort（中止）菜单项终止此命令。

质量号

调谐质量编号 2 或 3，缺省值为 2。

循环

调整阈值所作的尝试次数。缺省值为 50。

调整推斥极

0 = 不调整推斥极电压

1 = 调整推斥极电压（缺省）

调整轴

0 = 不重置质量增益和质量补偿

1 = 将质量增益补偿重置为 0（缺省）

讨论

此命令可调整乘积因子和推斥极电压以及原子质量单位增益和补偿，以获得大于或等于用 SETTHRESH 命令所设置阈值的调谐质量的响应。


TRACE

TRACE ["文件名"] [,附加]

切换调谐步骤（MSON、IO Test, 等）的记录。若 TRACE 先前已关闭，则此命令记录到指定的文件中。若 TRACE 先前是打开的，则此命令将关闭 TRACE（忽略文件名）。

"文件名"

文件的名称。如果没有指定文件名，将会提示您输入一个名称。缺省路径为 TuneTracePath$：例如：

c:\MSDchem\1\5972\yourfile.TRC.

附加

若文件已存在：

0 = 重写（缺省）。

1 = 附加

变量集

TuneTraceName$ — 初始值为 TUNE.TRC

TuneTracePath$ — 初始值为 \MSDchem\inst number/inst name


VACUUM

VACUUM [STATUS/VENT/PUMPDOWN]

初始化一个放空或抽气过程并显示 MS 真空状态。

STATUS/VENT/PUMPDOWN

MS 温度在任何情形下都受监测，但温度控制器必须由用户打开或关闭。

STATUS — 显示一个对话框，其中显示 MS 的状态（缺省）。

VENT — 初始化放空过程。扩散泵关闭，泵温度和 MS 前级电压一直受到检测，直到完成为止。过程结束后，对话框自动消失。

PUMPDOWN — 初始化抽气过程。扩散泵打开，泵温度和 MS 前级电压一直受到检测，直到完成为止。过程结束后，对话框自动消失。

讨论

可以在放空或抽气期间退出对话框。此操作不会终止过程，但当系统就绪时不会出现提示。建议您在真正放空或开始测量前使用命令 VACUUM STATUS。

变量集

_Button

1 = 在 Status（状态）对话框中选定的 OK（确定）

2 = 在 vent（放空）或 pumpdown（抽气）框中选定的 Exit（退出）


WAIT

WAIT [秒数] [, "注释"]

在特定时间终止操作并显示注释。可用 Abort（中止）菜单项停止此命令。

秒数

要等待的秒数。缺省值为 1 秒。

"注释"

等待时在消息行中显示的注释。


WIDTHS

WIDTHS [循环] [,质量编号]

调整质量 1 和指定质量的质谱峰宽以拟合调谐文件标准。可用 Abort（中止）菜单项停止此命令。

循环

试图调整峰宽时叠代数量的最大值。如果设置为 0 或负数，则可获得两个质量的图形扫描，但并不试图调整峰宽。缺省值为 50。

质量编号

调谐质量编号 2 或 3；缺省值为 2。

讨论

使用 SETTHRESH 命令设置 WIDTHS 的阈值。


WINDDISP

WINDDISP "字符串1" [,值] [,"字符串2"] [,x] [,y]

在 Tune display（调谐显示）窗口中显示消息。在显示消息前清除窗口。

"字符串1"

在值之前显示的字符串。

值

一个保留两位小数的标量；两边都留空格。缺省状态下没有值和空格。

"字符串2"

在值之后显示的字符串。

x,y

消息的位置。x 可以为 -79 到 79；y 可以为 0 到 19。缺省值为 0，0，即指左上角。若 x 为负，则首先清除显示。若 y 与包含消息的行相对应，则现有的消息将被删除。

讨论

此命令在显示消息前清除窗口。使用 DISPPRINT 将显示发送到打印机。

字母数字字符串可以用 PRINT USING 命令进行格式化。


XFER

XFER opcode [,data] [,variable name] [,loop]

仅在内部使用。返回有关质谱仪的信息。XFER 和 XFR 为同一命令的不同名称。

opcode

一个要发送到质谱仪的数字，即操作代码。

data

一个可选的数字，为和特定的 opcode 相关的数据。

variable name

一个变量名称，在其中存储由 XFER 命令返回的信息。

loop

执行 opcode 命令的次数。


+ 运算符

结果 = 对象 1 + 对象 2

+ 可将对象 1 和对象 2 相加。对象 1 和对象 2 必须是单个相同类型的对象。如果它们是编号，则结果将显示在消息行中。也可将对象 1、对象 2 和结果指定为变量。

叠加运算的结果的对象是用字符 (+) 在标题结尾处标识出来。

示例

Z=X+Y

将 X 轴方向上的光谱叠加到 Y 轴上的光谱得到 Z 方向上的光谱。


- 运算符

结果 = 变量 1 - 变量 2

不推荐将此运算符与复杂变量（如质谱或色谱）一起使用。请使用 SUBZERO 或 SUBTRACT。

- 运算符可从变量 1 中的对象截除变量 2 中的对象，并将结果添入结果中。变量 1 和变量 2 都必须包含相同类型的单个对象（不是集合），如都是色谱或都是光谱。在截除色谱时，它们的 X 轴（时间轴）必须在某一点重叠。

已截除对象用 (-) 字符在标题（此标题是变量 1 中原始对象的标题）结尾处标识出来。

您可以使用变量 Suppress 来确定负余数是否包含在结果中。如果您设置 Suppress=1，那么结果对象将只包含减运算中的正余数。如果您设置ISuppress=0，正余数和负余数都包含在结果中。当截除色谱时，没有任何效果。


* 运算符

变量 1 = 值 * 变量 2

* 运算符将变量 2 的内容乘以指定的值，并将乘积赋给变量 1。图标题中的星号 (*) 指示色谱和光谱已经进行了缩放（通过 * 运算符、NORMALIZE 或 TRANSFORM）。

变量 1 / 变量 2

变量 2 参数包含要相乘的对象。不存在缺省的参数。可将乘积赋给变量 1。

值

用来乘以变量内容的数值。

警告

可能在进行缩小比例缩放时会丢失数据。例如：

X= 0.001 * X
X = 1000 * X
通常不会生成同源光谱或色谱。

示例

Y = 0.01 * X

X 轴方向的内容乘以 0.01，得到 Y 轴方向的内容。


[ ] 运算符

变量名称 1 = 变量名称 2[对象编号]

[ ] 运算符可让您从一个对象集合中抽取一个对象，并将其指定给一个变量。

变量名称 1 / 变量名称 2

变量。变量名称 2 必须标识一个对象集合。

对象编号

将要抽取的对象编号。有效的编号都大于零并小于等于集合中的对象数。不存在缺省的编号。要显示对象列表及其指定的编号，请使用 TABULATE 命令。

示例

如果 X 是三个对象的集合，那么

Y =X[3]

将 X 中的第三个对象指定给 Y。


中止

在 EasyID 或 QEdit 中使用可保留原样，不保存更改。出现一个消息框，要求您确认您的决定。要去除更改并恢复原始数据或定量结果文件，请单击是。要保留更改并返回到 EasyID 或 QEdit，请单击否。


ADDPEAKS

ADDPEAKS 变量

从与存储在变量中的色谱关联的合并结果中获得峰信息,并将此信息添加到各个峰列表中。标准的定量宏使用此变量。

在使用此命令处理合并结果之后，可使用 ENDSET 命令处理各个峰列表以创建其他定量报告命令所使用的相关峰列表。

在使用 ADDPEAKS 来生成新的单个峰列表之前，应使用 STARTSET 命令清除所有现存的峰列表。


ALLCONT

ALLCONT [1/0]

控制光谱是按连续曲线还是按条线图进行绘制。

如果打开 ALLCONT (1)，任何连续创建的光谱将按连续曲线绘制。如果关闭 ALLCONT (0)，任何连续创建的光谱将按条线图绘制。如果没有指定任何参数，绘制方法是固定的。

要更改现有光谱的绘制格式，请使用 MAKEBAR 和 MAKECONT 命令。

示例

ALLCONT 1 !打开连续曲线。

SCAN 1,X

DRAW 1,X !按连续曲线绘制 X。

ALLCONT 0 !关闭连续曲线。

SCAN 1,X

DRAW 1,X !按条线图绘制 X。


ANNOTATE

ANNOTATE 窗口, 对象编号, x, y [,"文本", rel 位置 [,NOREFRESH], [colorindex]

在可指定文本和相关替换文本时，显示 Annotate 对话框。

窗口

出现注释的图形窗口的编号 (1-30)。

对象编号

0 = 单个对象；合并集；单独集合显示中的第一个（顶层）对象。

1 = 单独集合显示中的第二个（自顶层）对象。

1 = 单独集合显示中的第 N+1 个（自顶层）对象。

x 轴

注释将位于的点的 X 轴值。对于光谱，输入 amu*20；对于色谱，输入 time*60000。缩放前的 X 轴值必须在对象的最高和最低 X 轴值之间。使用 GETSCALARS POINT 命令可查找低值和高值。

y 轴

注释将位于的点的 X 轴值（丰度计数）。Y 轴值必须在对象的最高和最低 Y 轴值之间。使用 GETSCALARS POINT 命令可查找低值和高值。

"文本"

注释文本。如果使用命令输入 "文本"，则注释已完成，并且不显示对话框。

rel 位置

如果在输入 "文本" 时未指定 rel 位置，文本将处于中央位置。

0 = 左侧

1 = 中央（缺省）

2 = 右侧

NOREFRESH

如果未指定此关键字，则正在进行注释的窗口不能刷新。此关键字在进行一系列的注释时很有用。

colorindex

指定文本的颜色。有效值是 0 到 16（包括 0 和 16）。这些值与在 windows 注册文件中指定的颜色相匹配。

颜色索引 | win.ini 中的颜色名称
0 | DEFrame
1 | DETitle
2 | DEAxes
3 | DEChrom1
4 | DEChrom1
5 | DEChrom1
6 | DEChrom1
7 | DEChrom1
8 | DEChrom1
9 | DEChrom1
10 | DEChrom1
11 | DEChrom1
12 | DEAnnotation（缺省）
13 | DEBaselines
14 | DEFrame
15 | DEBackground
16 | DEBaselines


AREAREJECT

AREAREJECT 值，时间

为 ChemStation 积分仪创建面积截除事件。小于指定值的区域不包括在积分结果中。要在内存中查看积分事件列表，请输入 TABULATE EVENTS?

值

0 到 1E14。每个较大的值都可以用指数计数法进行输入。例如，4x10^12 可按 4E12 键入。

时间

允许的值范围是 -650 到 650 分钟。要删除定时事件，请对带负时间值的事件输入该命令。

示例

AREAREJECT 100,2

在 2 分钟时设置面积截除值为 100

AREAREJECT 100,-2

删除上面创建的项目


AREASUM

AREASUM 1/0,时间

为 ChemStation 积分器创建面积求和事件。可将由 AREASUM 1（开）和 AREASUM 0（关）给定的时间之间的所有峰看成单个峰，并对这些面积求和。

时间

允许的值范围是 -650 到 650 分钟。要删除定时事件，请对带有相应负时间值的事件输入该命令。

示例

AREASUM 1,3

告知分析仪，将要在 3 分钟时对峰面积开始求和。这将一直持续到“AREASUM 0,时间”命令中给出的时间为止。

AREASUM 1,-3

删除上例中创建的项目。


AUTOINT

AUTOINT 变量, , 信号编号, 面积截除

自动对指定的色谱或色谱集进行积分。

变量

指定要积分色谱的变量的名称。变量中的数据必须是色谱数据。没有缺省值。

信号编号

确定要对哪些信号进行积分。

0 = 对对象中的所有信号进行积分（缺省）

1 = [image] 信号编号 [image] num （变量）意味着只对该信号进行积分。

面积截除

面积截除所占最大峰的百分比。缺省为零（或无面积截除）。

讨论

AUTOINT 自动查找初始阈值和初始峰宽的最佳值，将面积截除设置为 0，然后执行积分。使用峰肩检测的当前设置。

不用参数 2 和 3 ，只是因为它们以前在自动积分宏中的位置才使用它们。

变量集

Npeaks - 在积分中已找到的色谱峰的个数。


AVERAGE

AVERAGE 时间 1 : 时间 2 [,变量] [,文件描述符对象]

平均指定时间范围内的光谱，并将其结果赋予变量中。

时间 1 : 时间 2

时间范围（以分钟为单位）。如果输入了一个不在数据范围内的时间，则会使用与实际数据相对应的时间。

变量

包含结果的变量。缺省值是 X（它将滚动计算堆栈）。

文件描述符对象

从 FILE 命令载入的数据文件。

讨论

平均光谱用字符 (*,+) 在标题结尾处标识出来。平均是在当前数据文件 (_DataFile$) 上进行的。


基线

BASELINE NOW / NEXTVALLEY / BACK，时间
BASELINE ALLVALLEY / HOLD, 1/0，时间

为 ChemStation 积分器创建基线事件。要查看当前在内存中的积分事件列表，请进入 TABULATE EVENTS。

NOW（现在）

在指定时间设置基线。

NEXTVALLEY（下一峰谷）

在下一个检测到的峰谷设置基线。

BACK（向后）

将基线从指定时间的信号值水平向后拖动。

ALLVALLEY（所有峰谷）

在所有检测到的、指定时间之后的峰谷点(两峰之间）设置基线。

HOLD（保持）

将基线从指定时间的信号值水平向前拖动。

1/0

将基线事件打开 (1) 或关闭 (0)。

time（时间）

允许值在 -650 到 650 分钟之间。要删除时间事件，请对具有相应负时间值的事件输入命令。

示例

BASELINE NOW, 5.5

在 5.5 分钟时刻设置基点

BASELINE NOW, -5.5

删除上面创建的项

BASELINE ALLVALLEY, 1, 0

对于从 0.00 分钟之后直到关闭所检测到的所有峰谷，设置基点。


BSB

BSB [time1:time2] [,variable] [, "new filename"] [,DONTASK] [,] [,file descriptor object]

在所有的指定时间范围内的质谱上扣除本底值，并创建新的数据文件。读 Spectral_Window 变量。

time1:time2

以分钟为单位的保留时间范围。缺省为整个数据文件范围。该时间范围之外的点的质谱被加入到新的数据文件，不加改变。

变量

包含用于本底值的质谱的变量。缺省为 X。

"new filename"

新的数据文件的名称，该数据文件包含扣除本底数据。该名称必须以扩展名 .D 结尾。如果未输入文件名称，将会由 variables _DataPath$ and _DataFile$ 构造一个：

如果 _DataPath$ 不是以 BSB\ 结尾

new filename（新文件名称） = _DataPath$ + BSB\ + _DataFile$

（如果 BSB 目录不存在，就创建一个）

如果 _DataPath$ 以 BSB\ 结尾

new filename（新文件名称） = _DataPath$ + _DataFile$

DONTASK

如果指定了该关键字，新的数据文件将要重写现有数据文件时，不会显示警告消息。

文件描述符对象

由 FILE 命令载入的数据文件。

讨论

新文件的运算符字段修改为显示进行了多少次本底扣除。字符串 [BSBx] 被置于该字段的内容之前，其中 x 是一个 1 到 9 的数字，指示该文件本底扣除的次数。所有结果都限定为 14 位精度。

示例

假设当前的数据文件是：

C:\MSDchem\1\data\alkdemo.d

本底扣除文件应当为：

C:\MSDchem\1\data\alkdemo.d


CALEXCEL

将初始校准的相对响应因子报告 Excel 电子表格。

数据库中有关所有化合物的表格被以内标编号排序。对应每一化合物都列出每一级别的相对响应因子、所有级别的平均值以及标准偏差。CC 级别不含在内。

如果没有级别数量，相对响应因子就留空。如果有数量但无响应，相对响应因子被报告为 0。

不标记具有平均相对响应因子的化合物或具有超出范围的相对标准偏差的化合物。


CALIBPRINT

CALIBPRINT x0, y0, x1, y1, result #, "file name", scalar

从 QuantResults 文件搜集并格式化数据，为打印校准曲线作准备。前面必须有 STARTPRINT 命令；打印数据使用 ENDPRINT。

x0, y0,

定义曲线左上角的坐标，x 是字符数，y 是行数。x 的缺省值为 7，y 的缺省值为 5。可选范围为 0 到 PAGESIZE 命令所报告的 x 值。

x1, y1

图的宽度和长度，x 是字符数，y 是行数。如果这两个值太小，会产生一个最小尺寸的图。如果太大了，所打印的图会被截去一部分。x 最小为 25，缺省为 65。y 最小为 14，缺省为 20。

result #

QuantResults 文件中的条目数量包括要打印的校准数据。

"filename"

QuantResults 文件名称通常是 quant.res。quant.res 文件必须带有完全的路径。

标量

如果使用非零值从来自 Quant 数据库（而不是 Quant 结果文件）的数据检索校准图的话。

变量集

Eqn1$ - 校准方程

Eqn2$ - RSD 和 RHO 和曲线拟合类型。


CALRPT

CALRPT [destination]

报告当前方法的初始校准的相对响应因子。

数据库中有关所有化合物的表格被按照内标编号排序。对应每一化合物都列出每一级别的相对响应因子、所有级别的平均值以及标准偏差。CC 级别不含在内。如果没有级别数，相对响应因子就留空。如果有数量但无响应，相对响应因子被报告为 0。

目的

0 = screen (default).以 Multivu 显示。文件 calrpt.txt 被添加到方法目录。

1 = 打印机

2 = 表单文件。文件 calib.csv 被添加到数据目录。


CCCHK

CCCHK [输出形式] [,文件] [,漂移]

根据当前方法的初始校准的相对响应因子，估算当前数据文件的相对响应因子。具有所估算的日校准样品浓度的、初始校准级别的 ID 必须使用 Edit Continuing Calibration Criteria（编辑连续校准指标）来设定。

数据库中所有化合物的表格按照内标编号排序。对于每一化合物，都列出了所有初始校准级别的平均相对响应因子、数据文件中的相对响应因子以及二者的差异百分比。不包括 CC 级。如果某个级别没有含量，则将相对响应因子留为空。如果有含量但是没有响应，则相对响应因子报告为 0。

按照 Edit Continuing Calibration Criteria（编辑连续校准指标）中的指准，对超出范围的值进行标记。

输出形式

0 = 屏幕 （缺省）。以 Multivu 显示。文件 cccheck.txt 被添加至方法目录。

1 = 打印机

2 = 格式文件。文件 calib.csv 被添加至数据目录。

文件

要估算的数据文件。缺省为当前载入的数据文件。

漂移

0 = （缺省）根据响应因子报告值。

1 = 根据标称含量与计算含量的比值报告值。在不使用 Average RF（平均 RF）的地方很有用。

化合物类型 "C" Continuing Calibration Check（连续校准检查）和 "P" System Performance Check Compounds（化合物系统性能检查）可以设置单独的化合物指标。

"C"

N4= 介于 Initial RRF（初始 RRF）和 Continuing RRF（连续 RRF）的 RSD 之间的 Maximum RSD（最大 RSD）。

"P"

Signal Level Minimum（信号级别最小值） = Minimum RRF（最小 RRF）

Signal Level Maximum（信号级别最大值） = RF 的 RSD 中的 Maximum RSD（最大 RSD）。


CCRPT

CCRPT [输出形式]

根据当前方法的初始校准的相对响应因子，估算连续校准级别的相对响应因子。

数据库中所有化合物的表格按照内标编号排序。对于每一化合物，都列出了所有初始校准级别的平均相对响应因子、CC 级别的相对响应因子以及二者的差异百分比。不包括 CC 级。

如果某个级别没有含量，则将相对响应因子留为空。如果有含量但是没有响应，则相对响应因子报告为 0。

按照存储在 cc.val 文件（位于当前方法目录）中的指标，对超出范围的值进行标记。

输出形式

0 = 屏幕 （缺省）。以 Multivu 显示。文件 ccrpt.txt 被添加至方法目录。

1 = 打印机


CHROMATOGR

CHROMATOGR [时间 1:时间 2] [,质量 1] [,...][,质量 10]

生成提取离子色谱并将其置于 X 中作为叠加集。始终打开堆栈。

时间 1:时间 2

以分钟为单位的保存时间范围。

质量 1, 质量 2, ...[,质量 10]

正数指出要提取的每种离子的质量 (amu)。每一质量值 (N) 都作为质量范围 (N-0.3):(N+0.7) 对待。忽略零质量。负数质量或质量大于 2000 会生成错误消息。如果输入了 10 个以上的质量值，超出长度的质量值会被忽略，但不生成错误消息。

要覆盖 -0.3:0.7 amu 设置，需设定变量 MzRange。例如：

MzRange=-0.2:0.4

要指定质量范围，可以使用语法质量 1:质量 2，其中质量 1 是起始质量而质量 2 是终止质量。

如果没有指定质量，会显示 Extracted Ion Chromatograms（提取离子色谱）对话框。

大于当前数据文件中任何质量的质量会生成空对象。没有缺省值。

变量集

NIons - 使用该命令检索到多少个 EIC（提取离子色谱）。


CLEAR

CLEAR [窗口]

清除一个图形窗口。

窗口

图形窗口的编号（1 到 30）。缺省情况下清除所有的图形窗口。

示例

CLEAR 清除所有图形窗口

CLEAR 2 清除窗口 #2


CLEAR 变量

CLEAR 变量, 结果类型

清除与 MS 对象相关联的结果。

变量

包含谱图的变量名称。

结果类型

指定要清除的结果类型的关键字。可以是以下之一：

INTRESULTS - 清除积分结果

LIBRESULTS - 清除谱库检索结果


CLEARCPNDS

CLEARCPNDS [选项] [,模式]

从当前方法的定量数据库中清除化合物项。在清除项之前由一个消息框给出警告。将缺省值恢复到 Quantitation Globals（全局定量）面板。

选项

0 = 缺省值；确认之后清除整个数据库。（请参见下面的“讨论”。）

非零 = 确认之后只清除校准级别 ID 和文件。

模式

0 = 缺省值；这是交互模式，并且设置 variable _Button。

1 = 批模式；抑制 Warning（警告）面板并执行相应的清除化合物或级别的操作。

讨论

如果将选项参数设置为零，则将以下全局值设置为：

Reference Window（参比窗口）=10%

Non-Reference Window（非参比窗口）=5%

Correlation Window（相关窗口）=0.02 分钟

Multiplier（乘积因子）=1

Default Sample Concentration（缺省样本浓度）=0

Report type（报告类型）=Summary（摘要）

To Screen（到屏幕）=True（真）

To Printer（到打印机）=False（假）

To File（到文件）=False（假）

Generate Report during RUNMETHOD（在 RUNMETHOD 期间生成报告）=False（假）

Report File Name（报告文件名称）=空字符串

Single Compound Number（单个化合物编号）=1

Quant by Height(按高度定量）=False（假）

Title（标题）=空字符串

Timestamp（时间标记）=空字符串

Default units string（缺省单位字符串）=空字符串

Default curve fit（缺省曲线拟合）=Linear Regression（线性回归）

Use RTEINT（使用 RTEINT）=False（假）

Default +/- extraction window length（缺省 +/- 提取窗口长度）=0.5 分钟

Default integration parameter file（缺省积分参数文件）=空字符串

Default ISTD concentration（缺省 ISTD 浓度）=0

All Level IDs（所有级别 ID）=空字符串

All Level filenames（所有级别文件名）=空字符串

变量集

_Button （当模式为交互模式时）：0 = 已取消的；1 = 已接受的。


CLIP

CLIP 窗口, [文件名]

将一个图形窗口复制到 Clipboard（剪贴板）然后可以将图形从 Clipboard（剪贴板）粘贴到其他应用程序，或者,也可以选择粘贴到具有 Windows 图元文件格式 (.WMF) 的文件中。

窗口

要复制的图形窗口编号 (1-30)。

文件名

要在其中以 Windows 图元文件格式存储剪切板图形的文件。这些文件最好使用 .WMF 扩展名，以便于导入到其他程序，比如 Microsoft Excel、Word 等。

注释：如果要使用如 ( ) 或 [ ] 这样的符号，应给该参数添加双引号（" "）。


CLREVENTS

清除当前内存中的所有 ChemStation（化学工作站）积分器时间事件；将初始设置（请参见 INITTHRESH、INITREJECT、INITWIDTH, 和 SHOULDERS 命令）重新设定为 INTEGRATE 命令的缺省值。

要查看当前在内存中的积分事件列表，请使用 TABULATE EVENTS 命令。


CMI

CMI 变量, 左时间, 右时间, 左高度, 右高度, 基线检查, 信号编号

使用 ChemStation（化学工作站）积分器手动积分。

变量

用于手动积分的 TIC、EIC 或 EIRC。

左时间, 右时间

左（起始保存时间）和右（截止保存时间）基线时间，单位为毫秒。

左高度, 右高度

左（峰头）和右（峰尾）基线高度，以数量表示。

基线检查

标量。该参数被接受但不会被应用。您可以将其留为空或输入一个标量值。

信号编号

确定要进行积分的是哪些信号。

0 = 对对象中的所有信号进行积分运算（缺省）

1 = [image] 信号编号 [image] num (变量) 表示只对该信号进行积分。

讨论

如果信号没有以前的积分结果，则现在得到的 CMI 峰就成为积分结果。

如果信号有以前的积分结果。则新的 CMI 峰就被添加到已有列表中。同样，如果在列表中存在以前的峰，其起始和截止时间范围包括新峰的保存时间，则旧列表中的、按保存时间升序排列的第一个这样的峰就被删除。


COMPOUND

COMPOUND [化合物编号]

用在 EasyID 或 QEdit 中，以选择一个化合物。

化合物编号

要编辑的化合物编号。缺省为下一化合物。


CPDANALYZE

CPDANALYZE [文件描述符对象] [,n]

用于宏中，对数据库中的化合物（而不是所获取的数据文件中的信号）进行定性和定量计算。

文件描述符对象

由 FILE 命令载入的数据文件。

n

n = 0 在 Edit Compounds（编辑化合物）列表中用星号标记内标。

If n = 非零值，则使用标记的内标技术。

给所有被认为“匹配”结果文件的峰附加记录，结果文件的名称在最近对于 STARTANALYSIS 的调用中已指定。最大匹配个数在 Compound Entry（化合物项）面板的第一页中指定。

变量集

Istd_Area - ISTD 的响应，可以是范围或高度，取决于为一个化合物所选择的 Measure Response By（测量响应方法）。仅当感兴趣的目标化合物是与内标化合物相关的被分析物时才有意义。

Q_XCResp - 面积校正响应。如果未启用面积校正，则为 0。这是从普通峰面积中减去的值，以产生校正面积。由 UPDATERSLT 读取。

TR_Corr - 时间参比相关性；如果将某化合物标记成时间参比化合物，则设置成实际和期望保存时间比；否则，不设置。


CREATEWINDOW

窗口 = CREATEWINDOW (结构对象, 窗口 id, xlow:xhigh, ylow:yhigh)

创建一个结构窗口（在谱库检索和参数检索中见过）。

结构对象

使用 CSCREATE 函数创建的任何对象。

窗口 id

任何整数 (0-255)，用于标识窗口。

xlow:xhigh

ylow:yhigh

描述一个框，它给出窗口的位置和尺寸。以父窗口中用户区（从 0.0 到 1.0）的百分比形式来指定这些值。


CSADDSTRUCT

CSADDSTRUCT "数据库文件名", 结构对象 [,结构 id [,"结构标题"]]

该命令将给定结构添加至指定的数据库。如果所有参数都未指定，就会显示一个对话框，要求输入它们。

"数据库文件名"

要用于该结构的、数据库文件的名称。尽管要求该参数，如果它是空字符串（即 ""），将使用所有已通过 CSLIBS 命令建立的数据库。

结构对象

使用 CSCREATE 函数创建的任何对象。

结构 id

一个编号，用它来唯一地标记一个结构，通常使用 CAS 编号。

"结构标题"

描述该结构的字符串。


CSATTACH

CSATTACH 结构对象, ms 对象, xlow:xhigh, ylow:yhigh

该命令将给定结构与给定质谱相关联。无论是绘制、打印质谱，还是将其复制到剪切板，都会同时绘制、打印结构，或将其复制到剪切板。

结构对象

使用 CSCREATE 函数创建的任何对象。

ms 对象

一个现存的质谱对象。

xlow:xhigh, ylow:yhigh

描述一个框（以数据单位表示），将在其中绘制结构并显示数据。


CSCHRO

CSCHRO ["文件描述符"] [,扫描范围], 过滤器谱, 目的

从经质谱过滤的数据文件中提取色谱信号。

"文件描述符"

期望数据文件的路径和名称，缺省为当前数据文件。

扫描范围

缺省为整个扫描范围（数据文件中的所有扫描）。否则，应表示为诸如 10:20 之类的某个范围。

过滤器谱

用作色谱过滤器的质谱名称。它必须是一个变量名，如 X 或 MyScan。没有缺省值。

目的

输出色谱的名称。它必须是一个变量名，如 R1 或 CsChro1。没有缺省值。

讨论

扫描范围中的每一次扫描都是从数据文件读取的。该算法将过滤器谱中的每一 m/z 点与每一次扫描的 m/z 点相比较。求出与变量 Spectral_Window 中所设置的允许误差范围内的过滤器谱相匹配的扫描中所有点的丰度之和。


CSCOPY

CSCOPY 结构对象
CSCOPY 结构窗口对象
CSCOPY 结构 id
CSCOPY "cas 编号字符串"

该命令将一个结构（确切的数据图形和图元文件图像）复制到 Microsoft Windows 剪贴板中。接受结构 ID 或 CAS 编号字符串的两种格式将访问结构数据库，其他格式则访问给定的结构对象。

结构对象

使用 CSCREATE 函数创建的任何对象。

结构窗口对象

使用 CREATEWINDOW 函数并将结构对象指定为第一参数时创建的任何对象。

结构 id

唯一标识一个结构的编号，通常使用 CAS 编号。

cas 编号字符串

表示成字符串的一个编号，它的格式就象是一个 CAS 编号（如 "xxxx-xx-x"），它唯一标识一个结构。


CSCREATE

结构 = CSCREATE (结构 id, "数据库文件名")
结构 = CSCREATE ("cas 编号字符串", "数据库文件名")

该函数搜索数据库文件并创建结构对象。

结构 id

唯一标识一个结构的编号，通常使用 CAS 编号。如果使用负数，则其绝对值就当作记录编号处理，并加载该记录编号对应的结构。

cas 编号字符串

表示成字符串的一个编号，它的格式就象是一个 CAS 编号（如 "xxxx-xx-x"），它唯一标识一个结构。

数据库文件名

从中搜索该结构的数据库文件的名称 (*.sdb)。尽管需要该参数，可如果它是空字符串（即 ""），则将搜索所有通过 CSLIBS 命令配置的数据库。


CSDRAWOPTS

CSDRAWOPTS [结构对象]

此命令将显示 Chemical Structure Options（化学结构选项）对话框，它允许对给定结构的各种属性进行更改。如果不带结构对象调用它，则所进行的更改将会应用于将来所有的结构；否则只应用于给定结构。

结构对象

使用 CSCREATE 函数创建的任何对象。


CSEXISTS

值 = CSEXISTS (结构 id, "数据库文件名")
值 = CSEXISTS ("cas 编号字符串", "数据库文件名")

结构 id

唯一标记一个结构的编号，通常使用 CAS 编号。

cas 编号字符串

表示成字符串的一个编号，它的格式就象是一个 CAS 编号（如 "xxxx-xx-x"），它唯一标识一个结构。

"数据库文件名"

在其中搜索该结构的数据库文件的名称。尽管需要该参数，可如果它是空字符串（即 ""），则将搜索所有通过 CSLIBS 命令建立的数据库。


CSLIBS

该命令显示一个对话框，允许对结构数据库文件（将用于访问各种命令）进行配置和排序。


CSMFATTACH

CSMFATTACH 图元文件对象, ms 对象, xlow:xhigh, ylow:yhigh
CSMFATTACH 图元文件对象, gcms 对象, xlow:xhigh, ylow:yhigh

该命令将图元文件对象与一个质谱或 GC/MS 色谱相关联。无论是绘制、打印光谱或色谱，还是将其复制到剪切板，都会同时绘制、打印结构，或将结构复制到剪切板。

图元文件对象

使用 CSMFCREATE 函数创建的任何对象。

ms 对象 或 gcms 对象

将要具有图元文件关联的数据对象。

xlow:xhigh, ylow:yhigh

描述一个框（以数据单位表示），在其中绘制图元文件。


CSMOLCREATE

结构 = CSMOLCREATE ("mol 文件名")

该函数读取 Molecular Design（分子设计）Mol 文件并创建一个结构对象。

mol 文件名

包含结构连接表数据的的文件的名称。尽管需要该参数，可如果它为空字符串（即 ""），则将会出现一个文件选择对话框。


CSSUBSET

CSSUBSET "结构 id 列表文本文件", "源结构数据库文件名"

该命令生成一个结构数据库文件，它是给定的源结构数据库文件名的子集。

结构 id 文本文件

包含已排序的 CAS 数值列表的 ASCII 文本文件的名称。

源结构数据库文件名

在其中搜索这些结构的数据库文件的名称。


DELETEINTPEAK

DELETEINTPEAK 窗口, 对象, 保存时间

该命令从与指定窗口相关联的对象中删除一个积分峰。

窗口

包含要删除峰的图形窗口的编号 (1 - 30)。

对象

0 = 单个对象；合并的集合；在单独集合显示中的第一个（顶部）对象。

1 = 在单独集合显示中的第二个（从顶部算起）对象。

N = 在单独集合显示中的第 N+1 个（从顶部算起）对象。

保存时间

要删除峰的保存时间（以毫秒计）。进入时间 * 60000。


DLGQDBSETUP

DLGQDBSETUP 代码

仅在内部使用。 控制 Quant Setup（定量设置）对话框。

代码

0 = 关闭 Quant Setup（定量设置）框（如果它是打开的）。

1 = 打开 Quant Setup（定量设置）框（如果它是关闭的）。

2 = 对 m/z 和 YVal 使用值 X0 来更新当前选中的信号以给出对于目标信号的相对响应。

3 = 使用变量 X0 更新对话框中的保存时间值。


DOLIST

DOLIST ["命令 / 宏"]

在一个选中数据文件的列表上执行宏或命令。

在运行宏或命令之前，会提示您选择要处理的数据文件。只要选定了要处理的文件，就可以单击 Process（处理）按钮以开始执行命令或宏。如果在执行中存在错误，则不处理列表上的剩余文件。

"命令 / 宏"

用于处理文件列表的命令或宏。若未指定命令或宏，会提示您选择一个报表选项或选择宏复选框。如果您选择宏复选框，会提示您从列表中选择一个宏。

示例

DOLIST 可以用来处理任何命令字符串。宏或命令中的运行字符串需要用双引号引起来，它们需要使用：左单引号以开始命令字符串，右单引号以结束命令字符串。该示例只适用于先前进行过定量化处理的数据文件。

DOLIST `QT 0,1,"S"'

提示您选择数据文件，然后在选中的文件上处理定量报告。左单引号 (`) 与代字号 (~) 位于同一键上。右单引号就是撇号。


DRAW

DRAW [窗口] [,变量] [,X1:X2] [,Y1:Y2]

将指定变量中的数据绘制到指定图形窗口中。当绘制质谱图时，可以设置变量 Label_Peaks_Thr（在 0 到 1 之间取值），以便仅限于对那些相对丰度等于或大于 Label_Peaks_Thr 的值的质谱峰进行标记。

您可以绘制对象的集合，也可以绘制单个对象。绘制集合时，由 FORMAT 命令控制该图是单独的还合并的。

窗口

在其中绘制对象的图形窗口编号 (1 - 30)。缺省为 1。

变量

包含要绘制对象的变量。缺省为 X。如果变量中有多个对象，则所有对象都必须是同一数据类型。

X1:X2

用于绘制的 X 轴范围。缺省为对象的整个范围。范围 0:0 也意味着整个范围。

Y1:Y2

用于绘制的 Y 轴范围。缺省范围是零到最大 Y 值（如果所有 Y 值都是非负值）或是最小到最大 Y 值（如果某些 Y 值是非负值）。范围 0:0 给出与缺省同样的结果。

示例

DRAW

使用整个数据范围来缩放 X 轴和Y 轴，将 X 中的所有内容绘制到窗口 #1。

DRAW 2, X, 200:400

将 X 中的所有内容绘制到窗口 #2 并以 200 到 400 间的 X 值显示数据


EASYID

加载 EasyID 菜单和命令，以便以图形方式更新定量数据库。要放弃 EasyID 更改并返回到初始结果文件，请选择 Abort（终止）。

EasyID 和 QEdit 是数据分析的特殊模式，不是为了与其他命令（如 DOLIST、DOSCAN、LABEL 等）一起使用。

在 EasyID 窗口中可以使用几种鼠标操作。


EDITCPNDS

EDITCPNDS [变量 1] [,变量 2] [,n]

显示 Edit Compounds（编辑化合物）对话框。

变量 1

如果非零，则禁用该对话框中的 Delete（删除） 和 View（查看）按钮。如果该变量非零时选中 Insert Above（在上部插入），则将 QDB_Insert 设置为化合物序数。

变量 2

如果设置为 1，则删除化合物编号 n。如果设置为 0，则显示 Edit Compounds（编辑化合物）对话框。

n

若将变量 2 设置为 1，则 n 指定列表中的化合物数量。


EDITEVENTS

EDITEVENTS 标量

显示 ChemStation（化学工作站）积分器的 Integration Parameters（积分参数）对话框，在其中您可以输入初始阈值、峰宽和面积截除的值并控制肩峰测定，或者显示 Edit Integration Parameters（编辑积分参数）对话框，在其中您可以安排时间事件。

要激活该对话框中的 Load（加载）和 Save（保存）按钮，必须由一个宏来执行该命令。当从命令行中输入这个命令时，这两个按钮都不可用。

标量

0 = 显示简易的初始参数面板。

非零 = 显示时间事件面板。

变量集

_Button

0 = 取消选中

1 = 确定选中

2 = 保存选中

3 = 加载选中


EDITGCVALCC 命令

EDITGCVALCC

显示连续校准报告参数以供编辑。

该命令将读取当前方法目录下的文件 "CC.VAL" 并将这些值显示在对话框中以供编辑。当按下此对话框上的 OK（确定）按钮时，设置将被写回到文件 "CC.VAL" 中。

在 EnviroQuant GC-only 模式中使用。


EDITGCVALEPA 命令

EDITGCVALEPA

GC-only（仅限 GC）模式。显示定量报告参数以供编辑。

该命令将读取当前方法目录下的文件 "EPA.VAL" 并将这些值显示在对话框中以供编辑。当按下此对话框上的 OK（确定）按钮时，设置将被写回到文件 "EPA.VAL" 中。


EDITGCVALLSC 命令

EDITGCVALLCS

未使用。仅在内部使用。


EDITGCVALTUNE 命令

EDITGCVALTUNE

未使用。仅在内部使用。


EDITHEADER

EDITHEADER [X] [,操作] [,项目号]

显示 Edit PBM Library（编辑 PBM 谱库）对话框。若要在会话期间添加一个项目，则在调用此命令时必须存在一个名为 X 的质谱。

操作

指定将要进行的操作的值：

1 =Select Library（选择谱库）（缺省）

2 =Add New Entry（添加新的项目）（必须首先选择的谱库）

3 = Add New Entry（添加现有项目）（必须首先选择的谱库）

4 =Create Library（创建谱库）

5 =Delete Library（删除谱库）

6 =BatchInsert（批插入）

项目号

利率的项目号。仅当操作设置为 3 时才有意义。缺省为项目 1。

若选定了操作 6，则 EDITHEADER 命令就有 10 个其他参数（参数 4 - 13）：

化合物名称 （字符串，80 个字符）

分子式（字符串，24 个字符）

分子量（标量，以道尔顿表示）

其他信息（字符串，128 个字符）

CAS 号（标量，不带破折号输入）

公司标识（字符串，10 个字符）

保留索引（标量）

熔点（标量，摄氏度）

沸点（标量，摄氏度）

包含在搜索标记内（标量，0=是，非 0=否）

变量集

当操作为 1 或 4 时，由此命令设置 _Button。

_Button

0 = 选定的 Cancel（取消）按钮

1 = 选定的 OK（确定）按钮


EDITMETHFILE

EDITMETHFILE "文件名"

在 Multivu 中显示指定的文件以供查看和编辑。

"文件名"

当前方法目录中的参数文件的名称。必须包括扩展名，例如 bfb.val 或 rteparm.p。


EDITSTRATEGY

EDITSTRATEGY [U+A] [,标记阈] [,倾斜] [,纯度] [,交叉相关] [,重复] [,低过滤器] [,高过滤器] [,最大匹配数]

设置 PBM 搜索策略参数。

U+A

设置预滤器选择性的数字 (1-9)。初始值为 2。值 1 将导致最少的比较，而 9 将导致搜索整个谱库。最常用的值为 1、2 和 3。初始值为 2。

标记阈

指定 PBM 算法可能标记的未知峰的数字 (0 - 10)。0 值表示“让算法确定”。更高的值 (N) 表示只有大于基峰的 N% 的峰才可能被标记。初始值为 3。

倾斜

1/0；初始值为 1 （开）。指明是(1)否(0)调用参考谱图到未知谱图的二次拟合。

纯度

引起使用纯度预滤器的数字 (20-80)。初始值为 50。此预滤器将库谱图的基峰与未知谱图中相应的峰比较；未知峰必须具有一个等于或大于纯度值的相关丰度，以便在搜索中保留库谱图。输入 0 可绕过此预滤器。（此设置提高了 PBM 检索混合物中组件的能力。）

交叉相关

1/0；初始值为 0（关）。若设置为 1，则 PBM 搜索找到的最可能的匹配数是由某个正向检索计算出来的。0 可导致结果按 PBM 匹配质量排序。

重复

若此参数不为 0，则仅报告任意特定化合物（由其 CAS 号标识）的最佳匹配。较低匹配质量的重复匹配将从结果列表中删除，且不报告。由于 CAS 号删除了重复匹配，因而不具备与其关联的 CAS 号的谱库项目即使可能是同一化合物，也不会被删除。

低过滤器, 高过滤器

分子量阈值。将从结果列表中删除具有低于（高于）输入数字的分子量的任意搜索结果，并且不报告。低报告 MW 是将要报告的最低分子量，高报告 MW 是将要报告的最高分子量。（若低等于高，仅报告具有此分子量的化合物。若低大于高，则将不报告结果。）有效范围为 0 到 9999。缺省低过滤器为 0，高过滤器为 9999。

最大匹配数

通常，搜索可返回最多达 20 个匹配。更改此数字将会更改要报告的匹配数。不影响搜索和搜索速度。最大匹配数限制将报告的匹配数目。

有效范围为 1 到 20。缺省值为 20。

讨论

每个参数的缺省值为其自身的当前值。若未输入参数，将显示 Search Strategy（搜索策略）对话框，您可以从中设置参数，还可以从中选择搜索谱库。


EDITVALCC

显示连续校准报告参数以供编辑。

该命令将读取当前方法目录下的文件 "CC.VAL" 并将那些值显示在对话框中以供编辑。当按下此对话框上的 OK（确定）按钮时，设置将被写回到文件 "CC.VAL"。

仅在 EnviroQuant 模式下使用。


EDITVALEPA

显示定量报告参数以供编辑。

该命令将读取当前方法目录下的文件 "EPA.VAL" 并将那些值显示在对话框中以供编辑。当按下此对话框上的 OK（确定）按钮时，设置将被写回到文件 "EPA.VAL"。

仅在 EnviroQuant 模式下使用


EDITVALLCS

显示库搜索化合物报告参数以供编辑。

该命令将读取当前方法目录下的文件 "TIC.VAL" 并将那些值显示在对话框中以供编辑。当按下此对话框上的 OK（确定）按钮时，设置将被写回到文件 "TIC.VAL"。

仅在 EnviroQuant 模式下使用


EDITVALTUNE

EDITVALTUNE “BFB / DFTPP”

显示调谐评价报告参数以供编辑。

该命令将读取当前方法目录下的文件 "BFB.VAL" 或 "DFTPP.VAL" 并将那些值显示在对话框中以供编辑。当按下此对话框上的 OK（确定）按钮时，设置将被写回到文件 "BFB.VAL" 或 "DFTPP.VAL"。

仅在 EnviroQuant 模式下使用


EIC

EIC[时间1:时间2],质量[,变量][,质量阵列][,文件描述符对象]

从一个或多个 m/z ("mass") 值或范围中萃取一个或多个色谱图。

时间1:时间2

时间范围（以分钟为单位）。缺省值为整个区域。

质量

要萃取的质量的原子质量单位值。此参数是必须的，并且没有缺省值。

变量

存储色谱图的变量的名称。缺省值为 X。

质量数组

一组用于 EIC 萃取的编码质量和质量范围值。如果显示此参数，则会忽略参数 2。编码如下：对于单个的质谱图，存在一个该质量的数组元素。对于一个质量范围色谱图，存在一个数组元素 -3，该元素后面紧跟两个表示范围限制的质量值。在列表的末端，数组中存在一个 -2。

例如，若要请求 112 到 113.6 道尔顿的质量范围色谱图（在 59 道尔顿的质谱图之后）后面的 162 和 174 道尔顿的质量色谱图，则表示此请求的数组用以下方式创建：

DIM mymasses, 7

mymasses[1] = 162

mymasses[2] = 174

mymasses[3] = -3

mymasses[4] = 112

mymasses[5] = 113.6

mymasses[6] = 59

mymasses[7] = -2

文件描述符对象

从 FILE 命令加载的数据文件。


ENDLOG

与 SLOG 联合使用以显示日志文件。

此命令在 SLOG 之后使用，以显示使用 MultiVu 或 Wordpad（取决于文件大小）的日志文件的内容。在通常使用过程中，命令 SLOG 用于启动将错误记录到文件。问题宏和报告将被执行，并且 ENDLOG 命令用于显示遇到的错误。


ENDPRINT

打印具有最后一次执行 STARTPRINT 命令以来收集并格式化的所有数据的页面。这些数据是使用以下命令进行收集和格式化的：

CALIBPRINT

FILEPRINT

STRPRINT

WINPRINT


ENDSET

ENDSET [相关窗口]

从单个峰列表中调用创建相关峰列表的信号相关算法（请参见 ADDPEAKS）。

相关窗口

时间（以分钟为单位）。缺省值为当前方法中的相关窗口。（使用 SETUPCALIB 命令可看到 Quantitation Database Globals - page 1（全局定量数据库 - 第一页）对话框。）


EXCHANGE

EXCHANGE [变量] [,变量]

交换两个变量的内容。缺省变量为 X 和 Y。

示例

EXCHANGE

交换 X 和 Y 变量的内容

EXCHANGE Z,Y

交换 Z 和 Y 变量的内容

EXCHANGE ,T

交换 X 和 T 变量的内容


Exit

在 EasyID 或 QEdit 中用以保留和保存更改。会出现消息框询问您是否确认您的决定。要保存更改（更新原数据库或定量结果文件）并返回到 EDA 菜单，请单击 YES（是）。

要返回到 EasyID 或 QEdit，请单击 NO（否）。


EXPORTRSLT

EXPORTRSLT ["源文件"] [,"Excel 目标文件"] [,文件描述符对象]

从 Quant Results（定量结果）文件中为 Custom Reports（自定义报表）编写一个 Excel .XLS 文件。

"源文件"

源结果文件。缺省为空字符串。

"Excel 目标文件"

目标 Excel BIFF 文件。缺省为空字符串。

文件描述符对象

需要此变量名来检索与原始匹配峰的保留时间对应的数据文件中的扫描编号。


FILE

FILE [“数据文件名”]

加载用于 Data Analysis（数据分析）中的指定数据文件的宏。若未指定文件名，将显示 Select File（选择文件）对话框。

变量集

_ActBarcode$ — 包含从样品（如果有）读取的条形码的字符串。

_AlsBottle — 样品瓶编号

_Button — 只能在显示对话框时设置；

0 = 选定的 Cancel（取消）按钮

1 = 选定的 OK（确定）按钮

_DataFile$ — 数据文件的名称

_DataName$ — 样品名

_DataFile$ — 数据文件的路径

_DateAcquired$ — 数据采集的日期

_ActBarcode$ — 包含样品（如果有）中 EXPECTED（期望）的条形码的字符串。

File_End - 文件中最后一次扫描的时间（以分钟表示）

File_Start - 文件中第一次扫描的时间（以分钟表示）

_Inlet$ - 如何将样品导入 MS

_MiscInfo$ - 备注

_Operator$ - 分析员姓名

_OrgMethFile$ - 用于采集数据的方法

_Replicate - 如果已进行了排序，则此值是当前方法的重复计数。如果尚未排序，则此值为 0。

_SeqIndex - 如果已进行了排序，则此值是当前方法的序列文件中的行号。如果尚未排序，则此值为 0。


FILEPRINT

FILEPRINT "文件名", x, y

可将最多一页 ASCII 文件的文本进行格式化以备打印。必须从 STARTPRINT 命令开始；要打印数据，请使用 ENDPRINT。最多可打印 80 行。

不推荐使用此命令。在未来的修订版中将不支持此命令。

"文件名"

必须是一个 ASCII 文件。

x, y

开始打印的位置；x 为字符，y 为行。可接受的值的范围为 0 到 PAGESIZE 命令报告的 x 或 y 值。

变量集

FilePrint_Lines - 打印的行数


FILTER

FILTER(类型, 数量, 宽度, 步长)

在 CP 数组内创建一个预定义的过滤器。返回一个一维数组 filter_array。数组中的第一个元素为过滤器中的点数。其后紧跟过滤器系数。

注：若参数超出了范围，则使用最接近的可接受值。

类型

0 = Gaussian；使用参数宽度和步长。

1 = Savitzky-Golay 四次/五次

2 = Savitzky-Golay 二次/三次

数量

要生成的点数。

对于 Gaussian 类型，负数表示要获取足够的点以包含 ABS(n)*（标准偏差）。

使用宽度和步长。

对于 Gaussian 类型，数量可以为 -2 到 -5。

此外，数量 = 2*m+1，其中 m 为 3 和 50 之间的一个整数。这意味着数量的范围为 7 到 101。

宽度

若类型为 Gaussian，则宽度为以原子质量单位表示的 FWHM（半最大值全宽）。若输入 0，则使用 0.5 amu。宽度至少应为 2*步长。若宽度 < 2*步长，则 宽度设置为 2*步长。

步长

若类型为 Gaussian，则此项为以原子质量单位表示的扫描步长。若输入 0，则使用 0.1 amu。若步长小于 0.0001，则它会被更改为 0.0001。

示例

a = filter(1,19,0,0)

! 在数组 a 中获得 19 点 Savitzky-Golay 四次/五次过滤器。

b = filter(0,11,0,0)

! 获得 11 点 Gaussian 过滤器，其缺省半最大值全宽为 0.5 amu、扫描步长为 0.1 amu。

c = filter(0,-3,1,0.15)

! 使用 1 amu 的半最大值全宽，0.15 amu 的扫描步长，获得 Gaussian 过滤器，以包含 +/- 3 sigma。

要生成 1,2,2,2,1 过滤器：

dim d, 8

! 定义一个 8 个元素的数组。

d[1]=7

! 第一个元素为系数编号。

d[2]=0

d[3]=1/8

! 归一化以使所有系数的和为 1..

d[4]=2/8

d[5]=2/8

d[6]=2/8

d[7]=1/8

d[8]=0


FINDBYCAS

FINDBYCAS CAS 编号 [,"谱库"]

在谱库内可找到具有指定的 CAS （化学文摘服务）编号的所有条目。谱库必须包含用于此命令运行的 CAS.IND 文件。最多报告 20 种化合物。在观察了第二十个匹配的化合物之后或在谱库文件的末尾都会得出搜索结果，不管二者谁先出现。

CAS 编号

CAS 编号。仅允许数字；不使用破折号或其他符号。

"谱库"

从其中重新调用质谱的谱库文件名称。若未指定谱库名，则可使用最近用于 PBM 搜索的谱库名称。

若未指定路径，则使用当前的谱库路径 (_LibPath$)。若未输入扩展名 .L，则会追加此扩展名。若出现下列情形，将显示错误消息：

  • 输入 Data Analysis（数据分析）后未选定谱库，且在此处也未指定谱库。

  • 当前谱库名无效。

变量集

Cas_Hits - 找到的匹配的数量

Cas_Hit1、Cas_Hit2 等等 — 匹配的项目编号


FORMAT

FORMAT [MERGED / SEPARATED] [,LABELPEAKS / NOLABELPEAKS] [,重新绘制] [,自动设定Y] [,TIMEPEAKS / NOTIMEPEAKS]

设置显示一组数据对象的格式。启动时，将分离格式并标记峰。格式更改时，不会自动重新抽取当前显示的数据。

MERGED / SEPARATED

当多个对象处于正在绘制的变量中时，可控制图形窗口中的显示。

MERGED = 所有对象都放在同一绘图内。当集合中有大量对象要绘制时，必须使用组合格式，因为在分离格式中仅可以绘制有限数量的对象。

SEPARATED = 分别对每个对象都进行单独绘制。

LABELPEAKS/NOLABELPEAKS

控制标记谱峰（如果标记存在）。仅影响输入 FORMAT 命令之后抽取的数据对象的标签。

重新绘制

1 = 根据 FORMAT 参数重新绘制现有的窗口

0 = 不立即重新绘制（缺省）

自动设定 Y

确定当绘图格式为 SEPARATED 时，该如何绘制一组对象的 Y 轴。

1 = 允许集中每个对象的 Y 轴范围各不相同。每个对象的 Y 轴范围将是此对象的整个 Y 数据范围。用鼠标对对象进行放大或用 DRAW 命令指定 Y 范围不会更改对象的 Y 轴。只可更改 X 轴范围。将 autoscaleY 设置为 0 以允许更改 Y 轴范围。

0 = 确保集合中的每个对象都具有相同的 Y 轴范围。

TIMEPEAKS/NOTIMEPEAKS

控制标记色谱图的积分峰（如果存在）。仅影响输入 FORMAT 命令之后抽取的数据对象的标签。仍在绘制基线。


_GET

_GET 关键字, MS 对象 / GC/MS 对象 [,标量] [,标量] [,范围]

获取指定对象的有关信息。此命令有不同的形式：参数的含义取决于参数 2 的设置。

若参数 2 为 MS 对象，则 _GET 参数如下所示：

关键字

INFORMATION

INDEX

POINT

RESULTS

MS 对象

包含质谱数据的变量。

标量

对于 INDEX 选项：

0 = 表示 m/z 值（缺省）

1 = 表示质谱响应值（即，“丰度”）。

对于 RESULTS 选项：

PBM 结果编号。搜索前根据用户的选择，依据质量或交叉相关值对结果进行排序。运算数 MS 的 PBM 匹配数量的有效值为 1。缺省为 1。

标量

对于 INDEX 选项：

指定质谱中 m/z 丰度点的序数。从零开始。必须在 0 到（谱中的点数减 1）范围之内。

范围

对于 POINT 选项：

要估算的 m/z 范围。缺省为 MS 对象的整个质量范围。

若参数 2 为 GC/MS 对象，则 _GET 参数如下所示：

关键字

INFORMATION

INDEX

POINT

GC/MS 对象

包含 GC/MS 色谱的变量。

标量

对于 INDEX 选项：

0 = 表示保存时间值（缺省）

1 = 表示保存时间响应值（即，“丰度”）。

标量

对于 INDEX 选项：

色谱中保存时间/丰度点的序数。从零开始。必须在 0 到（色谱中的点数减 1）范围之内。

范围

对于 POINT 选项：

要估算的保存时间范围。缺省为色谱图的整个时间范围。


GETCOMPOUND

GETCOMPOUND [类型] [,化合物编号] [,FULL]

从定量数据库中检索指定的化合物信息。

类型

指示化合物类型的关键字，将根据它来检索信息：TIMEREF / ISTD / SELECT

若输入了 TIMEREF 或 ISTD，将检索此类型的下一化合物。

若输入 SELECT，将检索第二个参数中指定的化合物编号。若不输入化合物编号，

将是错误的。

若未输入类型关键字，则一次检索数据库中一种化合物的信息。按 STARTANALYSIS 命令后的第一个 GETCOMPOUND 命令检索第一个化合物。随后的 GETCOMPOUND 命令将按照化合物在数据库中出现的顺序对其进行检索。

FULL

若 FULL 关键字被指定为第三参数，由用 FULL 选项调用的 GETRESULT 设置的其他变量就由 GETCOMPOUND 来设置。

讨论

此命令在定量数据库中循环，一次获得一种化合物的信息。若定量数据库为空，将设置错误代码，并显示错误消息。

变量集

Amt_Units$

指示浓度单位的字符串

Cavg[]

校准表级别平均计数器。这是一个数组变量；请参考 Cavg[1]、Cavg[2] 等数组中的值。

Cconc[]

校准表级别浓度。这是一个数组变量；请参考 Cconc[1]、Cconc[2] 等数组中的值。

Cal_Fit

曲线拟合类型

0 = 线性

1 = 平均 RF（响应因子）

2 = 线性 (0,0)

3 = 二次

4 = 二次 (0,0)

Cal_Istd

内标化合物

0 = 非 ISTD

1 = 化合物为 ISTD

Cal_Pk_Num

使用 SELECT 选项的定量数据库化合物的项编号

Cal_TR

时间参比化合物

0 = 非时间参比化合物

1 = 时间参比化合物

CpndType$

用户定义的化合物类型

Cresp[]

校准表级别响应。这是一个数组变量；请参考 Cresp[1]、Cresp[2] 等数组中的值。

Exp_Rt

化合物的期望保存时间

Height_Quant

按面积或高度定量

0 = 面积

1 = 高度

Istd_Amt

未知化合物中的 ISTD 量；-1 = ISTD 量不适用

Lcv

适用于所有选项（SELECT 除外）的循环控制标记。

0 = 选定的选项已到达数据库末尾

Linear_wt

加权

0 = 等量加权

1 = 浓度的倒数

2 = 浓度倒数的平方

Peak_Name$ - 化合物名称

Q1, Q2, Q3 - 特征离子质量

Q1_Pu, Q2_Pu, Q3_Pu - 以 % 表示的特征离子不确定度

Q1_Rr, Q2_Rr, Q3_Rr - 以 % 表示的特征离子相对响应

Q1_Sum、Q2_Sum、Q3_Sum

打开（关闭）特征离子的面积和

1 = 打开

0 = 关闭

Q1Events$、Q2Events$、Q3Events$

用在特征离子上的集成模式

QHits_Max

Target Compound（目标化合物）鉴别过程保存的目标化合物的最大匹配数。

Q_XCF、Q_XCI

对于感兴趣的目标化合物项，为 Edit Compounds（编辑化合物）面板中的面积校正因子和面积校正离子 m/z

Ratio_Method

比率方法

0 = Extended Area Quant（扩展面积定量）

1 = 未扣除

2 = 缩窄第一个和最后一个

3 = 求第一个和最后一个的平均值

Ref_Name$

参比谱名称

RTWinMod

提取窗口的格式

0 = 以分钟格式显示 Compounds（化合物）面板上的提取窗口

1 = 以百分比格式显示 Compounds（化合物）面板上的提取窗口

Sig_Num - 目标离子质量

T0, T1 - 集成时间范围

TgtEvents$ - 目标离子集成模式

Unc_Tp

百分比不确定度类型

0 = 相对

1 = 绝对

UseQIons

特征离子鉴别方法

0 = 仅使用最靠近的 RT

1 = 使用满足特征比的峰组最靠近的 RT，或是使用最靠近的 RT（若没有峰组满足特征）

2 = 使用最大的目标峰响应

3 = 使用最佳特征值

4 = 使用所有匹配

当选择 FULL 选项时，由 GETCOMPOUND 和 GETRESULT 命令设置（对以上变量以外的变量进行设置）

A1$, A2$, A3$ - 用户定义的字符串项目

CasNo$ - Chemical Abstracts（化学文摘）编号

EntryNo - 质谱库中的项编号

MatALo, MatAHi, MatARpd, MatAMdl - 基质 A 的数据

MatBLo, MatBHi, MatBRpd, MatBMdl - 基质 B 的数据

MatSpk - 基质掺料量

MsDbName$ - 质谱库名称

N4, N5, N6, N7, N8, N9 - 用户定义的数值项目

SigMin, SigMax - 最低信号级别和最高信号级别

Surrogate - 替代级别


GETMSREF

GETMSREF 项编号 [,"谱库文件名"] [,变量] [,CONDMS / FULLMS]

从 MS 库检索光谱。

项编号

指定谱库中的项的编号。

"谱库文件名"

谱库文件的名称。缺省为最近用于 PBM 搜索的谱库。若未指定路径，则使用当前的谱库路径 (_LibPath$)。若未输入扩展名 .L，将会添加此扩展名。若输入 Data Analysis（数据分析）后尚未选中谱库，或者当前谱库名称无效，就会在消息行显示错误消息。

变量

CP 变量，将光谱放入其中。若此变量具有以前的值，旧值将丢失。

CONDMS / FULLMS

CONDMS，缺省情况下，从谱库中检索压缩光谱。

若谱库中包含完整的光谱文件，FULLMS 将检索完整光谱；若不包括，将检索压缩光谱。用户谱库需要完整的光谱。

变量集

Boil_Pt

沸点

Cas_Num$

CAS 编号（来自格式 nnnnn-nn-n 中的谱库文件头）

Company_ID$

与检索到的参比化合物相关的公司 ID（最长为 10 个字符）

EntryNo

谱库中的项编号

Hit_Name$

项名称

Mol_Formula$

检索到的参比化合物分子式的前 132 个字符

Melt_Pt

熔点。若没有可用的信息，将报告 -300.00。

Misc_Info$

与检索到的参比化合物相关的其他信息的前 132 个字符

Mol_Wt

分子量（在谱库文件头中）

PbmInclude

若选定“Include In Search”（包含在搜索中），则为 1；否则为 0

Ret_Index

保存索引


GETRESULT

GETRESULT , 结果编号, "文件名" [,FULL] [,匹配编号]

获取有关定量结果的信息。

结果编号

QuantResults 文件中结果的编号。（结果编号之前必须要有逗号，因为它代表一个未使用的参数。）

"文件名"

包含定量计算结果的 QuantResults 文件的名称。文件名必须包括 .RES 扩展名，且必须完全限定。

FULL

若指定此关键字，将检索指定结果的所有信息，并放置在变量中；若未指定，则仅设置选定的变量。

匹配编号

若此参数为零或空白，将检索原始匹配峰的结果信息。匹配编号 k>1 从匹配列表中搜索具有 kth 最低保存时间的峰。大于给定结果匹配数的值是错误的。

变量集

常用化合物变量

Amt_Units$ - 指示浓度单位的字符串

Cavg - 数组；校准表级别平均计数器

Bl0, Bl1 - 积分基线的起始高度和结束高度

Cconc - 数组；校准表级别浓度

Cal_Fit - 曲线拟合类型；

0 = 线性

1 = 平均 RF（响应因子）

2 = 线性 (0,0)

3 = 二次

4 = 二次 (0,0)

Cal_Istd - 内标化合物

0 = 非 ISTD

1 = 化合物为 ISTD

Cal_Pk_Amt - 计算出的目标信号的浓度

Cal_Pk_Found - 目标信号状态

0 = 已丢失

1 = 找到但未限定

2 = 找到且完全限定

Cal_Pk_Ret - 目标信号的保存时间，以毫秒表示（已积分）

Cal_TR - 时间参比化合物

0 = 非时间参比化合物

1 = 时间参比化合物

Coef0, Coef1, Coef2 - 校准曲线方程的系数

CpndType$ - 用户定义的化合物类型

Cresp - 数组；校准表级别响应

Exp_Rt - 化合物的期望保存时间

Exp_Rt_Hi - 化合物的期望高保存时间

Exp_Rt_Lo - 化合物的期望低保存时间

Int0, Int1 - 以毫秒表示的基线开始和结束的保存时间

Istd_Amt - ISTD 的浓度未知；-1 = ISTD 浓度不适用

Istd_Area - ISTD 的响应，该响应可以是化合物的高度或面积，取决于 Measure Response By（测量响应方法） 选项。仅当所需的目标化合物是与内标化合物相关的分析物时才有意义。

Lcv - TIMEREF 和 ISTD 化合物类型的循环控制标志（请参阅 GETCOMPOUND）

0 = 选定的选项已到达数据库末尾

Mi_Used - 手动积分

0 = 未使用

1 = 已使用

Peak_Name$ - 化合物名称

Pk_Area - 峰面积或高度，取决于选择

Q1, Q2, Q3 - 特征离子质量

Q1_HiRat, Q2_HiRat, Q3_HiRat - 特征信号比的上限，以百分比表示

0 = 未使用

Q1_LoRat, Q2_LoRat, Q3_LoRat - 特征信号比的下限，以百分比表示

0 = 未使用

Q1_Pk_Area, Q2_Pk_Area, Q3_Pk_Area - 特征的积分面积

0 = 未使用

Q1_Pk_Ret, Q2_Pk_Ret, Q3_Pk_Ret - 特征的保存时间（已积分），以毫秒表示

0 = 未使用

Q1_Pu, Q2_Pu, Q3_Pu - 以 % 表示的特征离子相对响应不确定度

Q1_Rr, Q2_Rr, Q3_Rr - 以 % 表示的特征离子相对响应

Q1_Sum, Q2_Sum, Q3_Sum - 打开（关闭）特征离子的面积加

1 = 打开

0 = 关闭

Q1Events$, Q2Events$, Q3Events$ - 特征离子集成模式

QDel - 定量匹配状态

1 = 已删除定量匹配

0 = 未删除定量匹配

QHits

结果记录中的定量匹配数。

QHits_Max - Target Compound（目标化合物）鉴别过程保存的目标化合物的最大匹配数。

QValue - 计算出的 Target Compound（目标化合物）匹配的 QValue

Q_XCF, Q_XCI - 对于感兴趣的目标化合物项，为 Edit Compounds（编辑化合物）面板中的面积校正因子和面积校正离子 m/z

RF 数组 — 响应因子

Rho - 校准曲线拟合统计

Sig_Num - 目标离子质量

T0, T1 - 集成时间范围

TgtEvents$ - 目标信号集成模式

Unc_Tp - 百分比不确定度类型

0 = 相对

1 = 绝对

UseQIons

0 = 仅使用最靠近的 RT

1 = 使用满足特征比的峰组最靠近的 RT，或是使用最靠近的 RT（若没有峰组满足特征）

2 = 使用最大的目标峰响应

当选择 FULL 选项时，用 GETCOMPOUND 和 GETRESULT 命令设置（对以上变量以外的变量进行设置）

A1$, A2$, A3$ - 用户定义的字符串项

CasNo$ - Chemical Abstracts（化学文摘）编号

EntryNo - 质谱库中的项编号

MatALo, MatAHi, MatARpd, MatAMdl - 基质 A 的数据

MatBLo, MatBHi, MatBRpd, MatBMdl - 基质 B 的数据

MatSpk - 基质掺料量

MsDbName$ - 质谱库名称

N4, N5, N6, N7, N8, N9 - 用户定义的数值项目

SigMin, SigMax - 最低信号级别和最高信号级别

Surrogate - 替代级别


GETSCALARS

GETSCALARS [INFO] [,对象]

获取指定对象的有关信息。

INFO

为此命令的缺省信息类型。有关其他类型，请参阅 GETSCALARS INDEX、GETSCALARS POINT 和 GETSCALARS RESULTS。

对象

缺省为 X，一个简单的标识符。若对象为一组命名为 A 的 nth 组件，请使用表示法 A[n]。

变量集

Nobjects - 变量中对象的个数；总是设为 1

Xval - 对应于最大 Y 值(y)的 X 值

Xlow - 对象中最小的 X 值

Xhigh - 对象中最大的 X 值

Yval - 对象中最大的 Y 值

Ylow - 对象中最小的 Y 值

Yhigh - 对象中最大的 Y 值


GETSCALARS INDEX

GETSCALARS INDEX [,类型] [,索引] [,对象]

获取基质内某个点的 X 或 Y 值。

类型

指示要返回的信息类型的数字：

0 = X 值（缺省）

1 = Y 值

索引

基质内的点数。对于一个 n 点的基质，0 为第一个点，n-1 为最后一个点。缺省值为 0。

对象

缺省为 X，一个简单的标识符。若对象为一组命名为 A 的 nth 组件，请使用表示法 A[n]。

示例

GETSCALARS INDEX, 1, 32, Z

将 Z 中第 33 个点的 Y 值放到变量 Value（值）中

变量集

Value — 找到的值。如果索引超出范围，请使用现有的最新索引。


GETSCALARS POINT

GETSCALARS POINT [,Xval:Xval] [,对象 ]

在指定的 X 范围内查找最大 Y 值。

Xval:Xval

缺省为整个 X 范围。注意范围 0:0 不表示此对象的整个 X 范围。

对象

缺省为 X，一个简单的标识符。若对象为一组命名为 A 的 nth 组件，请使用表示法 A[n]。

变量集

Nobjects - 变量中对象的个数；总是设为 1

Xval - 对应于最大 Y 值(y)的 X 值

Xlow - 指定范围内对象中的最小 X 值

Xhigh - 指定范围内对象中的最大 X 值

Yval - 指定范围内对象中的最大 Y 值

Ylow - 指定范围内对象中的最小 Y 值

Yhigh - 指定范围内对象中的最大 Y 值

讨论

若将一组对象赋予 GETSCALARS POINT 命令，则由此命令设置的变量将适用于此集合中的最后一个对象。


GETSCALARS RESULTS

GETSCALARS RESULTS [,对象] , [,结果编号]

获取有关库中搜索到的质谱的信息。第一个参数和第二个参数之间必需有逗号。

对象

缺省为 X，一个简单的标识符。若对象为一组命名为 A 的 nth 组件，请使用表示法 A[n]。

结果编号

指明搜索中找到的匹配的编号。缺省为 1，具有最高匹配质量的匹配；最大值为 20。

变量集

若未在库内搜索质谱，或未找到匹配，则所有变量被设置为空或零值。

Boil_Pt - 沸点

Cas_Num$ - CAS 编号（来自格式 nnnnn-nn-n 中的谱库文件头）

Entry_Num — 库中的项编号

Hit_Name$ — 项名称

Lib$ — 已搜索的库的名称

Melt_Pt — 熔点。若没有可用的信息，将报告 -300.00。

Mol_Wt — 分子量（在谱库文件头中）

Num_Hits — 已找到的匹配的编号。如果找不到匹配（或者如果尚未执行查询），请将其设置为 0。

PBM_Class1 -

Quality — 指定结果的质量

Ret_Index — 保存索引


GETWINDOWTEXT$

字符串 = GETWINDOWTEXT$ (结构窗口对象)

返回当前窗口标题。

结构窗口对象

任何由 CreateWindow 函数创建的对象，将一个结构对象指定为第一个参数。


GRAPHICS

用于 EasyID 或 QEdit 中以生成图形显示。色谱将显示在窗口 6 中，光谱显示在窗口 1 中，文本显示在窗口 7 中。


GRP

将单个化合物的整体结果加起来以作为单个结果报告。

GRP 将化合物的未删除匹配组合起来，并且更新原始结果。结果是一个单个匹配，它将表明未删除的匹配的总体面积和总体浓度。

起始保存时间将用于第一个匹配，结束保存时间将用于最后一个匹配。组合匹配的保存时间将为具有最大面积的峰的保存时间。

无论何时需要总体浓度，都应使用 GRP。化合物类型用于触发器组合。若希望将定量数据库中某一给定项的所有未删除的匹配组合起来，请在 Edit Compounds（编辑化合物）的第 2 页输入 "G" 作为化合物类型。


HGFILE

HGFILE “数据文件名”

从数据文件创建一个 MSFHG CP 对象，将其命名为 “_”。由于此对象被用作所有数据检索函数（如 SCAN、AVERAGE）的缺省值，此操作能有效“加载”数据文件。

用户应当使用 FILE 宏或 Load Data File（加载数据文件）菜单项，因为这些操作旨在独立于数据文件格式。当此宏得知有关的数据文件是 HG 格式时，它将引起 HGFILE 的调用。若由 FILE 宏（以及 LOADFILE.MAC 中的相关宏）确定文件为另一种格式，则调用一个不同的文件加载函数。

“数据文件名”

以智能卡 1 格式表示的 MS 数据文件的完整路径（由 Pascal、DOS ChemStation（化学工作站）、HP-UX ChemSystem 生成）。此字符串必须包括实际的文件名（通常是 data.ms）。


INITREJECT

INITREJECT 值

为 ChemStation（化学工作站）积分器设置初始面积截除值。小于指定值的面积不包括在积分结果中。系统缺省为 0；范围从 0 到 1E14。

要查看当前在内存中的积分事件列表，请进入 TABULATE EVENTS。


INITTHRESH

INITTHRESH 值

为 ChemStation（化学工作站）积分器设置初始阈值。要查看当前在内存中的积分事件列表，请进入 TABULATE EVENTS。

值

允许的值为 -12 到 25。系统缺省为 18。阈值每改变 1 个单位，则积分器的灵敏度改变 2 倍（例如，阈值为 8 时比阈值为 6 时不灵敏 4 倍）。


INITWIDTH

INITWIDTH 值

为 ChemStation（化学工作站）积分器设置初始峰宽度。要查看当前在内存中的积分事件列表，请进入 TABULATE EVENTS。

值

允许的值为 0.001 到 100 或 0；0 允许积分器自动指定适当的峰宽值。系统的缺省值为 0.02。

讨论

积分器预处理原色谱中的数据点，方法是通过过滤（一种移动的、加权平均计算方法以降低噪音的影响）和应用束状（对每 N 个相邻数据点取平均值）。

宽度参数影响是否使用束状（以及使用多少）和是否使用强、中或弱过滤器。直到此处指定的宽度值内出现至少 8 个数据点（以整个运行中的平均值为基础）时，才进行束状应用。在此之后，宽度参数中每增加两倍就会导致束状数量的增加。少于两倍的改变将更改过滤的数量，而不影响束状的数量。

如果宽度不是太大，窄峰可能会完全丢失或者量很小。如果宽度太小，信号噪音可能被作为峰（如果阈值太低）来删除，甚至非常宽的峰都可能丢失。


INSERTINTPEAK

INSERTINTPEAK 窗口 ,对象 ,时间 1,时间 2 ,丰度 1 ,丰度 2 ,基线检查

此命令使用 RTE 积分算法插入一个已积分的峰。旨在用于 Update Quantitation Results（更新定量结果）过程。

窗口

要插入峰的图形窗口的编号 (1-30)。

对象

0 = 单个对象；合并的集合；单独集合显示中的第一个（顶部）对象。

1 = 单独集合显示中的第二个（从顶部算起）对象。

N = 单独集合显示中的第 N+1 个（从顶部算起）对象。

时间 1:时间 2

开始和结束积分的保存时间（以毫秒表示）。时间 1 为峰的第一个结束点的时间值，时间 2 为第二个结束点的时间值。输入时间 * 60000。

丰度 1, 丰度 2

峰开始和结束时的基线级别。

基线检查

确定指定的结束点是否必须位于曲线之下。

0 = 关闭基线检查

1 = 如果基线检查是打开的，就打开基线检查（缺省），结束点就必须位于曲线之下。


INTEGRATE

INTEGRATE [变量] [,时间 1:时间 2], [,信号编号]

执行 ChemStation（化学工作站）积分器峰检测和积分操作。此过程由 integration events（积分事件）控制。要查看积分结果，请对刚刚积分的变量使用 TABULATE RESULTS。要查看当前在内存中的积分事件列表，请使用 TABULATE EVENTS 命令。

变量

缺省为 X。变量中的数据必须为色谱数据；但是，它可以是一个单独的对象 (TIC) 或一组对象（提取离子色谱的集合）。

时间 1:时间 2

进行积分的时间范围（以分钟表示）；缺省为当前数据文件中的整个时间范围。

信号编号

确定要对哪些信号进行积分。

0 = 对对象中的所有信号进行积分（缺省）

1 = [image] 信号编号 [image] num(变量）只对该信号进行积分。

ÌÖÂÛ

一旦已对变量中的数据进行了积分，就可以通过显示具有 DRAW 命令的变量内容来绘制积分器所使用的基线。由积分器检测到的峰在图上用峰的保存时间来标记。

示例

INTEGRATE R0

¶Ô变量 R0 中的数据进行积分

变量集

Npeaks

积分中找到的色谱峰数量


INTEGRATOR

INTEGRATOR 1/0, 时间

为 ChemStation（化学工作站）积分器创建一个积分器事件。数据积分在指定的时间打开或关闭。要查看当前在内存中的积分事件列表，请进入 TABULATE EVENTS。

积分器初始为 (1)。若希望在稍后的时间 t 时开始积分，应当输入以下事件：

INTEGRATOR 0,0

INTEGRATOR 1,t

时间

允许值为从 -650 到 650 分钟。要删除一个定时事件，输入带有相应负时间值的事件命令。

示例

INTEGRATOR 1.3

在 3 分种内打开积分

INTEGRATOR 1,t

删除上面创建的项


INVERSEB( )

值 = INVERSEB (GCMS 对象)

返回线性数学函数（此函数可用于计算已转换的色谱对象的原始保存时间）的 y 截距。

例如，如果 TIC 已将 TRANSFORM 命令应用到其 y 轴，则 INVERSEB 函数可与 INVERSEM 函数一起用于计算原始保存时间，利用以下等式：

原始 RT = 已转换的 RT * INVERSEM(R0) + INVERSEB R0)

其中 RT 为保存时间，R0 为包含 TIC 的变量。

若保存时间轴尚未被 TRANSFORM（转换），则 INVERSEM(R0) = 1，INVERSEB(R0) = 0。


INVERSEM( )

值 = INVERSEM (GCMS 对象)

返回线性数学函数（此函数可用于计算已转换的色谱对象的原始保存时间）的斜率。

例如，如果 TIC 已将 TRANSFORM 命令应用到其 y 轴，则 INVERSEB 函数可与 INVERSEM 函数一起用于计算原始保存时间，利用以下等式：

原始 RT = 已转换的 RT * INVERSEM(R0) + INVERSEB(R0)

其中 RT 为保存时间，R0 为包含 TIC 的变量。

若保存时间轴尚未被 TRANSFORM（转换），则 INVERSEM(R0) = 1，INVERSEB(R0) = 0。


LABEL

LABEL [输出形式] [,页码]

利用化合物编号和类型标签重新绘制当前数据文件中的色谱。标签以 Quant Reports Options（定量报告选项）列表中的标准为基础。必须预先已对数据文件进行过定量化处理。

输出形式

0 = 屏幕（缺省）

1 = 打印机

页码

要在打印 TIC 中使用的页数。缺省为 1。如果指定了多页，每个连续页上将有 2% 的重叠。


LIBRESULTS

LIBRESULTS [对象]

仅在宏中使用。 在对话框中显示 PBM 搜索结果，允许您查看统计数字、文本和图形结果。

对象

包含搜索到的光谱的变量名称。如果没有指定变量名，将使用 X。

讨论

此命令仅应从宏中使用。显示的对话框使用宏 (pbmrslt.mac)，该宏希望搜索到的变量名为 PbmSearchVar。

要查看统计数字、图形或文本结果，请对显示的光谱执行谱库检索。

要查看已搜索到的光谱的表格形式的列表，请使用 TABULATE RESULTS。


LIST

列出化合物（附带其保存时间）和当前定量数据库中的定量离子。将表格放在当前方法中的文件 list.txt 中，并显示在 Multivu 中。


LOADQUANTMETH

加载当前方法中所有与定量相关的项，定量数据库中的化合物记录除外。

变量集

AutoIntItem

将 Chromatogram 菜单上的 Autointegrate 项的状态指定为正常或无效（变灰）。2 = 使用在 Quant Global（全局定量）面板中选中的 RTEINT；0 = 使用在 Quant Global（全局定量）面板中取消选中的 RTEINT

Cal_Title$

标识与定量数据库相关的标题。

Cal_UpdTime$

指定最后一次更新定量数据库的时间和日期的字符串。

ClFl$[]

校准文件基本名称。数组变量；请参考 ClFl$[1]、ClFl$[2] 等数组中的值。

Clid$[]

校准级别的字符串 ID。数组变量；请参考 Clid$[1]、Clid$[2] 等数组中的值。

DefSampAmt

定量报告中缺省的样品量值。

乘积因子

定量报告中使用的乘积因子值。

NRfWin

非参比窗口。此值的一半为时间极限，在此时间范围内，给定峰可以存在且仍然可以看作是非时间参比化合物的潜在匹配。

NRfWin_TP

如何表达 NRfWin：0 = 分；1 = 相对于期望保存时间的百分比。

Quant_Detailed

0 = 摘要；1 = 详细/文本；2 = 详细 + 图形；3 = 单个化合物；4 = 面积百分比。

Quant_File$

文件名（如果非空）。

Quant_Method

0 = 否；1 = 是

Quant_Printer

0 = 否；1 = 是

Quant_Screen

0 = 否；1 = 是

Quant_Select

单个化合物的选择。

QuantItems

使用方法的定量数据库跟踪积分器的选择：如果选择 RTEINT，则为 0，否则为 2。

RefWin

参比窗口：此值的一半为时间极限，在期望的保存时间内，给定峰可以存在且仍然可以看作是时间参比化合物的潜在匹配。

RefWin_TP

如何表达 RefWin 值：0 = 分；1 = 相对于期望保存时间的百分比。

Rt_Delta

期望的保存时间范围，在该范围内将化合物添加到定量数据库中时，给定峰可以存在且仍然可以看作是潜在匹配。

ScWin

定量使用的信号相关窗口。

UseRteInt

>0 = 使用 RTE 积分器，标准 MSDA 过程将调用其中的积分。0 = 使用 MS ChemStation（化学工作站）积分器。


MAKEBAR

MAKEBAR 变量

使指定变量中的任意连续光谱图被绘制为条形图表。有关控制光谱图格式的其他方法，请参阅 MAKECONT 和 ALLCONT。

变量

包含光谱的变量名。

示例

ALLCONT 1 !打开连续曲线。

SCAN 1,X

DRAW 1,X ! 将 X 绘制为连续曲线。

MAKEBAR X

DRAW 1,X ! 将 X 绘制为条形图。


MAKECONT

MAKECONT 变量

使指定变量中的任意连续光谱图被绘制为连续曲线。有关控制光谱图格式的其他方法，请参阅 MAKEBAR 和 ALLCONT。

变量

包含光谱的变量的名称。

示例

ALLCONT 0 !关闭连续曲线。

SCAN 1,X

DRAW 1,X !将 X 绘制为条形图。

MAKECONT X

DRAW 1,X !将 X 绘制为连续曲线。


MENUSTATE ( ) （在 Data Analysis（数据分析）中）

值 = MENUSTATE （菜单项编号）

支持对菜单项进行复选或变灰的函数。

菜单项编号

500 = 检查是否要单独或合并（覆盖）绘制对象集合。如果对象集合将被覆盖绘制，则返回 1；如果对象集合将被单独绘制，则返回零。

501 = 检查是否要标记质量峰。如果要标记质量峰则返回 1；如果不标记则返回零。

502 = 检查是否将要对单独的图形中的 y 轴进行自动设定（单独设定）。如果单独设定 y 轴，则返回 1；否则返回 0。


MI

MI [变量], 时间 1, 时间 2, 丰度 1, 丰度 2 [,基线检查] [,信号编号]

对在定量结果的复查过程中选中的单个峰执行手动积分。

变量

包含用于定量计算的提取离子或总离子色谱的变量。缺省为 X。

时间 1，时间 2

开始和结束积分时的保存时间（以毫秒计）。时间 1 是峰的第一个端点的时间值，时间 2 是第二个端点的时间值。ÊäÈë时间 * 60000。

丰度 1, 丰度 2

峰的起始和结束位置处的基线级别。

基线检查

确定指定的端点是否必须位于曲线之下。

0 = 关闭基线检查

1 = 打开基线检查（缺省）。如果基线检查是打开的，则端点必须位于曲线之下。

信号编号

确定要对哪些信号进行积分。

0 = 对对象中的所有信号进行积分（缺省）

1 = [image] 信号编号 [image] num （变量）意味着只对该信号进行积分。

讨论

该命令使用 RTE 积分算法准确地生成一个积分峰。用于在 Update Quantitation Results（更新定量结果）过程中使用。


MSCLIP

MSCLIP [变量], 质量 1:质量 2

在指定的质量范围上删除质谱中的质量/丰度数据。

变量

包含单个质谱的变量。缺省为 X。

质量 1:质量 2

要删除质量/丰度数据的质量范围 (amu)。该参数是必需的。

另请参见

MSTRUNC


MSTRUNC

MSTRUNC [变量] ,百分比

从质谱中删除丰度小于指定的相对丰度的那些质量的质量/丰度数据。

变量

包含单个质谱的变量。缺省时为 X。

百分比

最大丰度值的百分数，在它之下的质量/丰度数据将被删除。值 <0 将强制变为 0。值 >100 将强制变为 100。

另请参见 MSCLIP。


MULTITHUMB

使您可以打印详细的 SIM 风格的报告，每页可打印多个数据文件。在命令行上输入此命令时，显示一个多文件选择对话框，使您可以选择要处理的数据文件。

当定量数据库中只有 4 个或更少的化合物时，使用此命令是很便利。


MW

MW "分子式"

由分子式计算分子量。

"分子式"

请使用带有大小写字母的标准元素符号；例如，Cl 而不是 CL。所有情况下都需要引号。

讨论

元素的重量被当作最大丰度同位素的重量（不是那个元素的所有自然存在同位素的重量平均值）。元素重量表在 ChemStation MSEXE 目录下的 MWTABLE.P 文件中。

变量集

Mol_Wt

计算分子量


NEGPEAKS

NEGPEAKS 1/0, 时间

创建一个 ChemStation（化学工作站）积分器的负峰事件。负峰的检测和积分在特定时间打开 (1) 或关闭 (0)。要查看当前在内存中的积分事件列表，请进入 TABULATE EVENTS。

时间

允许的值在 -650 到 650 分钟之间。

要删除定时事件，请对具有相应负时间值的事件输入此命令。

示例

NEGPEAKS 1,6.43

在 6.43 分钟时打开负峰积分。

NEGPEAKS 1,-6.43

删除上面的项


_NML

_NML [归一化值] [,MS 对象/GC/MS 对象]

将指定数据中的 Y 值归一到指定的值。这是 NORMALIZE 命令的一个超载形式，它对不同的对象类型分别执行 NORMALIZE。

归一化值

要将数据中的最大 Y 值设置到的值。所有其他的 Y 值都将基于它们和最大 Y 值的比例乘上此值来设置。缺省值为 10,000。

MS 对象/GC/MS 对象

包含要归一化对象的变量。缺省时为 X。

注意

在进行归一化时可能会丢失数据。

讨论

图标题中的星号(*)表示已设定色谱或光谱的坐标（通过 * operator、NORMALIZE、_NML 或 TRANSFORM 命令）。

如果色谱已经过积分或者如果光谱已经过谱库检索，则结果将被删除。0.0 到 1.0 之间的丰度被设置为 0.0。


NORMALIZE

NORMALIZE [归一化值] [,变量]

将指定变量中的 Y 值归一到指定的值。

归一化值

要将数据中的最大 Y 值设置到的值。所有其他的 Y 值都将基于它们和最大 Y 值的比例乘上此值来设置。缺省值为 10,000。

变量

包含要归一化对象的变量。缺省时为 X。

注意

在进行归一化时可能会丢失数据。

讨论

图标题中的星号 (*) 表示已设定色谱或光谱的坐标（通过 * operator、NORMALIZE 或 TRANSFORM 命令）。

如果色谱已经过积分或者如果光谱已经过谱库检索，则结果将被删除。0.0 到 1.0 之间的丰度被设置为 0.0。


ORIGINAL

在 EasyID 或 QEdit 中使用以从当前数据文件中提取离子色谱，并将它们显示在原始离子色谱窗口中。在窗口中的所有手动积分或注解都将丢失。


PBMSEARCH

PBMSEARCH ["谱库文件名"], 变量

使用指定的谱库在指定的光谱上执行 PBM 谱库检索。由 TABULATE RESULTS 菜单项可获得结果。

"谱库文件名"

谱库文件的名称。若未指定路径，则使用当前谱库路径 (_LibPath$)。如果未输入扩展名 .L，会自动添加。

缺省为最近编辑或用于 PBM 检索的谱库。如果进入 Data Analysis（数据分析）之后还未选择谱库，或者当前谱库名称无效，会在消息行上显示错误消息。

变量

要搜索的质谱。缺省为 X。


PCTRPTOPT

PCTRPTOPT [计算类型, 到屏幕, 到打印机, 到文件, "报告文件名", 报告标记, 积分类型, "积分文件名"]

只用在宏中，以设置百分比报告的参数。如果未指定参数，则显示 Percent Parameter（百分比参数）报告。

计算类型

0 = 通过信号

1 = 通过保存时间

到屏幕

报告到屏幕上

0 = 不报告

1 = 报告

到打印机

报告到打印机

0 = 不报告

1 = 报告

到文件

报告到文件中

0 = 不报告

1 = 报告

"报告文件名"

将报告发送到的文件的名称。

报告标记

在 RunMethod（运行方法）期间生成报告

积分类型

0 = 对 INTEGRATE 自动积分；RTEINT 的缺省方法

1 = 参数文件

"积分文件名"

积分参数文件的名称。

变量集

_Button

0 = 选中 Cancel（取消)按钮

1 = 选中 OK（确定）按钮

2 = 选中 Generate Report（生成报告）按钮

Percent_Events$

积分参数文件名；如果已指定自动积分则为空。

Percent_File$

将报告发送到其中的文件名；如果不将报告发送给文件则为空。

Percent_Method

0 = 不是在 RunMethod（运行方法）期间生成的报告

1 = 在 RunMethod（运行方法）期间生成的报告

Percent_Printer

0 = 不发送到打印机的报告

1 = 发送到打印机的报告

Percent_Screen

0 = 不发送到屏幕的报告

1 = 发送到屏幕的报告

Percent_Type

计算类型

0 = 通过信号计算

1 = 通过保存时间计算


PEAKFIND

PEAKFIND 保存间, 对象

该命令检索有关指定对象中与指定保存时间最接近的积分峰的信息。

保存时间

要查找的峰的保存时间。

对象

0 = 单个对象；合并的集合；在单独集合显示中的第一个（顶部）对象。

1 = 在单独集合显示中的第二个（从顶部算起）对象。

N = 在单独集合显示中的第 N+1 个（从顶部算起）对象。

变量集

AbsPeakHeight | 未经基线校正的峰高
BslPeakHeight | 经基线校正的峰高
End_Time | 色谱峰的结束时间
Peak_Area | 色谱峰的积分面积
Peak_Type | 为指定的积分结果提供峰类型代码。
Peak_Width | 峰宽，以时间单位计算
Pk_End_BLine | 基线高度，在峰终点处以计数单位计算
Pk_Start_BLine | 基线高度，在峰起点处以计数单位计算
Ret_Time | 积分峰的保存时间
Scan_Num | 被检索谱（只对 PEAKNUMBER）的扫描次数
Start_Scan、Stop_Scan | 与积分峰相关的起始和终止扫描次数。仅用于 RTEINT 积分 — 对于 ChemStation（化学工作站）积分，值始终为 1。
Start_Time | 色谱峰的起始时间

注释：通常，ChemStation（化学工作站）积分器所报告的未经基线校正的峰高 (AbsPeakHeight) 与 GETSCALARS 命令的 Yhigh 变量所报告的峰高不完全相等。这是因为 ChemStation（化学工作站）积分器执行了曲线拟合，能更准确地估算实际峰高。


PEAKNUMBER

PEAKNUMBER [峰编号] [,START / TOP / END], 变量 [,结果]

从积分色谱获取光谱。选中的光谱是与指定峰位置的保存时间最接近的一个。

峰编号

从其中挑选光谱的 GC 峰的编号（1 = 第一个峰，2 = 第二个峰，等等）。缺省值为 1。

START / TOP / END

从中挑选光谱的峰的部分。缺省为 TOP（ 峰顶点）。

变量

包含已积分的色谱的变量。该变量可能是数组下标表达式，如 a[2]。该参数是必须的。

结果

在其中存放结果的变量名。缺省为 X （将 X 中的先前值传递给 Y，Y 的传递给 Z，Z 的给 T，而丢弃以前的 T 值）。

变量集

AbsPeakHeight - 未经基线校正的峰高

BslPeakHeight - 经基线校正的峰高

End_Time - 色谱峰的结束时间

Peak_Area - 色谱峰的积分面积

Peak_Type$ - 为指定的积分结果提供 Peak Type（峰类型）代码。

Peak_Width - 峰宽，以时间单位计算

Pk_End_BLine - 基线高度，在峰终点处以计数单位计算

Pk_Start_BLine - 基线高度，在峰起点处以计数单位计算

Ret_Time - 积分峰的保存时间

Scan_Num - 被检索谱（只对 PEAKNUMBER ）的扫描次数

Start_Scan, Stop_Scan - 与积分峰相关的起始和终止扫描次数。仅用于 RTEINT 积分 — 对于 ChemStation（化学工作站）积分，值始终为 1。

Start_Time - 色谱峰的起始时间


PEAKVARS

PEAKVARS [峰编号] [,START / TOP / END], 变量

利用保存在一个变量中的积分色谱的信息设置变量。（比较 PEAKVARS 的标量形式。）

峰编号

根据其设置变量的 GC 峰的编号（1 = 第一个峰，2 = 第二个峰，等等）。如果输入零，则对指定变量和对象中的色谱进行积分时，变量 NPeaks 设置为找到的峰个数（并且不设置其他变量）。缺省值为 1。

START / TOP / END

从中读取保存时间的峰的部分。

变量

包含已积分的色谱的变量。该变量可能采用方括号的表示形式如 A[2]。该参数是必须的。

变量集

AbsPeakHeight - 未经基线校正的峰高

BslPeakHeight - 经基线校正的峰高

End_Time - 色谱峰的结束时间

Peak_Area - 色谱峰的积分面积

Peak_Type - 为指定的积分结果提供 Peak Type（峰类型）代码。

Peak_Width - 峰宽，以时间单位计算

Pk_End_BLine - 基线高度，在峰终点处以计数单位计算

Pk_Start_BLine - 基线高度，在峰起点处以计数单位计算

Ret_Time - 积分峰的保存时间

Scan_Num - 被检索谱（只对 PEAKNUMBER ）的扫描次数

Start_Scan, Stop_Scan - 与积分峰相关的起始和终止扫描次数。仅用于 RTEINT 积分 — 对于 ChemStation（化学工作站）积分，值始终为 1。

Start_Time - 色谱峰的起始时间

注释：通常， ChemStation（化学工作站）积分器所报告的未经基线校正的峰高 (AbsPeakHeight) 与 GETSCALARS 命令的 Yhigh 变量所报告的峰高不完全相等。这是因为 ChemStation（化学工作站）积分器执行了曲线拟合，能更准确地估算实际峰高。


PEAKVARS

PEAKVARS , 峰编号, 组编号

设置积分峰结构的变量。此形式的 PEAKVARS 使用一个标量作为第三个参数（比较另一形式的 PEAKVARS）。第一个参数在此形式的该命令中被忽略掉了。

峰编号

必须的参数；无缺省值。峰指的是已添加至结构的积分峰的原始编号，按信号描述排序。

组编号

必须的参数；无缺省值。组指的是信号相关性所决定的保存时间处的峰的集合。

, 0, 0 | 将 NPeaks 设置为积分峰结构（使用 STARTSET 和 ADDPEAKS 而形成的）中的峰的编号。
, m>0, 0 | 从单独的峰列表（不是组合的峰列表）中检索峰编号 m。将 Ret_Time 设置为峰保存时间（以分为单位），Peak_Area 设置为峰响应，Peak_Sig 设置为信号描述（以 amu 为单位，对于总离子信号为 0）。
, 0, n>0 | 将 NGroups 设置为由 ENDSET 根据积分峰结构形成的峰组编号。
, m>0, 0 | 从第 n 组中检索 m 峰，并按上面的指示设置 Ret_Time、Peak_Area 和 Peak_Sig 。

变量集

NGroups - 组编号；由命令的标量形式设置。

NPeaks - 在积分期间找到的峰个数。

Peak_Area - 色谱峰的积分面积

Peak_Sig - 在命令的标量形式中指定的组号和峰号的信号描述（TIC 或 EIC m/z）。

Ret_Time - 积分峰的保存时间


PEAKWIDTH

PEAKWIDTH 值, 时间

为 ChemStation（化学工作站）积分器创建峰宽事件。要查看当前在内存中的积分事件列表，请进入 TABULATE EVENTS。

值

允许的值在 0.001 到 100 之间或为 0。零 (0) 允许积分器自动分配合适的峰宽值。

时间

允许的值在 -650 到 650 分钟之间。

要删除定时事件，请对具有相应负时间值的事件输入此命令。

讨论

积分器通过过滤（采用一个可变加权平均算法以减少噪声的影响）和应用束状（对每 N 个邻近的数据点进行平均）来对原始色谱中的数据点进行预处理。

宽度参数对于是否使用束状（及使用多少）以及是采用强过滤器、中等过滤器还是弱过滤器都有影响。在这里指定的宽度值中至少要出现 8 个数据点（基于整个运行中的平均值）才进行束状应用。之后，宽度参数每增加 2 倍，都会导致束状数量的增加；小于 2 倍的变化则会改变进行过滤的数量，但不影响束状的数量。

如果宽度太大，则会完全忽略窄峰或者显示不良定量。如果宽度太小，信号噪声则可能被当成峰来检测（如果阈值太低的话）而太宽的峰却可能被忽略。

示例

PEAKWIDTH 0.5, 1.70

在 1.70 分设置 0.5 分的峰宽

PEAKWIDTH 1.5, .5

在 5.0 分设置 1.5 分的峰宽。

PEAKWIDTH 1.5, -5

删除上面的项


PICSIX

PICSIX 显示 QList 选项的配置编辑器。

在 \MSDCHEM\MSMACROS 目录下，配置编辑器读取 QLISTIN.INI 文件并写入 QLISTOUT.INI 文件。QList 命令读取 QLISTOUT.INI 文件以显示所配置的选项。


POINTS

POINTS [变量]

获取指定变量中第一对象的数据点个数。

变量

该变量包含一个或多个色谱或光谱。缺省为 X。

变量集

NPoints

点的个数


PRCLOSERESULTS

该命令将关闭 Parametric Retrieval Results（参数检索结果）面板（如果正在显示它的话）。只用于 Parametric Retrieval（参数检索）。


PRGETRETRESULTS

PRGETRETRESULTS 项编号,库名称

该命令将基于指定的项编号和库设置许多 CP 变量。只用于 Parametric Retrieval（参数检索）。

变量集

Boil_Pt - 沸点

Cas_Num$ - CAS 编号（来自 nnnnn-nn-n 格式的谱库文件头）。

Company_ID - 与检索到的参比化合物相关的公司 ID（最长为 10 个字符）

— 库中的项编号

Melt_Pt - 熔点。如果没有可用信息，则报告 -300.00。

Misc_InfoN - 其他信息字段，被分成 60 个字符的字符串，其 CP 变量名分别是 Misc_Info1、Misc_Info2

Mol_Formula - 检索到的参比化合物分子式的前 132 个字符

Mol_NameN - 化学名称，被分成 60 个字符的字符串，其 CP 变量名为 Mol_Name1、Mol_Name2 等。

Num_Misc_Info - 构成其他信息的字符串个数

Num_Misc_Info - 构成分子名称的字符串个数

PRLibName$ - 从中检索该项的库名称

Ret_Index - 保存索引


PRPARAMS

该命令显示 Set Parameters（设置参数）面板，它允许您更改在下次参数检索期间要使用的参数。只用于 Parametric Retrieval（参数检索）。


PRRESULTS

该命令显示 Parametric Retrieval Results（参数检索结果）对话框。包含参数检索结果（谱库检索光谱）的对象的名称是 PRSpectrum。只用于 Parametric Retrieval（参数检索）。

只要选中项更改了，PRRESULTS 设置就变量 entrynum 并且调用 PRDORESULT 宏。当按下不同按钮时，它调用其他宏：

Text - PRPBText

Print - PRPBPrint

Next - PRPBNext 然后 PRPBNext2


PRRETRIEVE

PRRETRIEVE [继续]

该命令检索下 N 个找到的匹配。您可以指定是否启动搜索或继续从使用 continue（继续） 参数结束的上次搜索开始进行搜索。只用于 Parametric Retrieval（参数检索）。

继续

1 = 从上次搜索结束位置继续进行

0 = 从库开头处重新启动搜索

缺省 = 使用当前设置。如果一个搜索正在进行，将继续。否则，它将从头开始。

变量集

EntryNum - 第一个匹配的项编号

PRMaxMatches - 指定匹配的最大数量

PRNumMatches - 实际找到的匹配数（0 至 PRMaxMatchest

PRLibName$ - 已搜索的谱库名称

PRMatches - 由 100 个项组成的数组，其中包含最后一次搜索的项编号


PRSAVEPARAMS

该命令将 Set Parameters（设置参数）面板的当前设置保存到 PARAMRET.INI 文件。这些值将是下次 Data Analysis（数据分析）启动时的缺省值。只用于 Parametric Retrieval（参数检索）。


PRSETPARAMS

PRSETPARAMS 要更改的变量, on or off, RANGE / SCALAR / STRING

该命令允许您从命令行更改某个搜索参数。只用于 Parametric Retrieval（参数检索）。

变量必须包含在引号中。OFF 从搜索中删除参数设置。

最后一个参数是要设置的新值；可以是一个范围、一个标量或一个字符串。范围中的值必须由冒号 (:) 分隔。要更改的变量和要使用的变量类型有：

MOLNAME STRING

CAS SCALAR

MOLFORMULA STRING

MOLWEIGHT RANGE

ENTRYNUMBER RANGE

MISCINFO STRING

COMPANYID STRING

MELTINGPOINT RANGE

BOILINGPOINT RANGE

RETINDEX RANGE

ION1MASS SCALAR

ION1ABUND RANGE

ION2MASS SCALAR

ION2ABUND RANGE

ION3MASS SCALAR

ION3ABUND RANGE

MAXNUMMATCHES SCALAR

LIBRARYNAME STRING

CLEAR STRING -- 关闭所有设置


PRSETWINPOSITION

PRSETWINPOSITION x 位置，y 位置

指定 Parametric Retrieval Results（参数检索结果）面板的左上角应在何处。x 位置和 y 位置的范围是从 0 到 1，1 是可用窗口空间的最大量；0 是 x 和 y 轴的原点。只用于 Parametric Retrieval（参数检索）。


PUTCOMPOUND

PUTCOMPOUND 化合物编号 [,INSERT]

由 GETCOMPOUND 读取变量集合并更新定量数据库中现有的化合物记录。

如果输入 INSERT，则化合物被添加到定量数据库中恰好由 compound number（化合物编号）指定的位置之前的位置。


QCAL

QCAL ["级别 id"] [,"文件"] [,upd_resp_tp] [,upd_rt_tp] [,upd_qi] [,upd_ref] [,保存]

用一个定量结果文件更新校准表。会提示您以指定要进行更新的类型。此命令不能更新特征离子比。

"级别 id"

标识要更新的校准级别的字符串。

"文件"

更新校准时所要用到的数据文件的名称。

upd_resp_tp

更新响应类型：

0 = 平均

1 = 替换

2 = 不更新

upd_rt_tp

更新保存时间类型

0 = 平均

1 = 替换

2 = 不更新

upd_qi

更新特征离子比：

0 = 不更新

1 = 更新

upd_ref

更新参比光谱：

0 = 不更新

1 = 更新

保存

更新后保存方法：

0 = 不保存

1 = 保存


QCALCC

更新定量数据库的连续校准级别。

QCALCC 使用 Edit Continuing Calibration Criteria（编辑连续校准指标）中指定的参数来更新 Continuing Calibration（连续校准）"CC" 的校准级别。


QDEL

QDEL [化合物编号] [,匹配编号]

用于 QEdit 中以将一个化合物的定量结果设为 0。变量 mi_used 设为 1 （请参见 Commands（命令）手册中的 GETRESULT）。

化合物编号

化合物的编号。缺省时为当前化合物。

匹配编号

化合物的匹配编号。缺省值为 0，原始匹配。


QEDIT

加载 QEdit 菜单和命令以便对当前数据文件进行手动积分并更新定量结果文件。要放弃 QEdit 更改并返回到原始的结果文件，请选择 Abort（终止）。

EasyID 和 QEdit 是数据分析的特定模式，并不与其他命令（如 DOLIST、DOSCAN、LABEL 等）一同使用。

在 QEdit 窗口中可以使用几种 mouse actions（鼠标操作）。


QLIST

QLIST ["宏名称"]

在数据文件列表上将选定的报告或宏进行排队。

此命令用于将请求发送到报告管理器以处理一列文件。如果没有指定宏，用户可以从多达 6 个命令选项中进行选择，这些命令选项预先已用 Configure QList（配置 QList）配置过。

在将报告或宏进行排队前，将提示您以选择要处理的数据文件。选择文件时可使用多文件选择实用程序。选择数据文件所属的目录（在左边），然后从中间栏选择这些数据文件。双击文件或使一组文件突出显示并单击右 (-->) 箭头以选择文件。单击 Process（处理）按钮开始进行文件排队。

只要宏执行已开始，它就将连续处理列表中的每个文件。若执行中出错，则将不再处理列表中剩余的文件。

"宏名称"

用来处理文件列表的宏的名称。如果没有指定名称，则显示宏文件列表。如果选择了宏文件 xxx.mac，则将要运行文件中的最后一个宏（如同已输入了命令宏 xxx.mac,g）。宏必需存在于 Report Manager（报告管理器）处理系统上。

示例

此示例仅适用于先前进行过定量化处理或已经过手动积分的文件。

QLIST 'QT 0,1,"S"'

提示您选择数据文件

PROCESSLISTQ

将每个选定数据文件的摘要定量报告在打印机中进行排队。


QREF

用来更新定量数据库所使用的参比光谱。

此命令审核定量结果文件，以查看那些已查找到的化合物的当前数据文件。当认为一个化合物已找到时，从峰顶的光谱中扣除峰开始前的光谱。结果存储在方法中，以备在详细定量报告 QEdit 和 EasyID 中使用。


QT

QT [计算] [,输出形式] [,"选项"] [,化合物编号]

生成一个定量报告。报告的选项存储在当前方法的文件 epa.val 中。要查看或编辑这些选项，请选择 Quant（定量）/Edit Quant Report Options（编辑定量报告选项）或输入命令 EDITMETHFILE "EPA.VAL"。

计算

0 = 跳过计算并生成报告（用现有的结果文件）

1 = 进行计算（创建新结果文件）并生成报告

输出形式

0 = 屏幕（缺省）

1 = 打印机

"选项"

"S" = 摘要

"F" = 全部；摘要报告加上每个化合物的光谱

"P" = 图形，摘要报告加上每个化合物的离子色谱

"X" = Excel，报告到以 Custom Reports（自定义报告）所使用的格式表示的文件 <methodname>.xls 中。

"C" = 用逗号分隔的值；报告到以 Forms 软件所使用的格式表示的文件 quant.csv 中。

化合物编号

若编号已提供，则生成此化合物的详细报告。


QUALPARMS

QUALPARMS ["谱库 1", "谱库 2", "谱库 3"] [,阈值 1, 阈值 2] [,选择方法] [,本底时间] [,积分类型] [,"文件名"]

设置谱库检索的参数或者显示 Library Search Parameters（谱库检索参数）对话框。

"谱库 1", "谱库 2", "谱库 3"

要用来检索的第一、第二以及第三谱库的名称。

阈值 1, 阈值 2

第一谱库和第二谱库的匹配阈值（表示为匹配质量）。

选择方法

1 = 顶点

2 = 顶点减去在峰开始处的本底

3 = 顶点减去在指定时间的本底

4 = 峰平均

本底时间

本底光谱选择的时间

积分类型

0 = 自动积分（对 RTEINT 无效）

1 = 使用参数文件

"文件名"

积分参数文件名

若未输入任何参数，则显示 Library Search Parameters（谱库检索参数）对话框。

变量集

_Button

0 = 选定 Cancel(取消)按钮

1 = 选定 OK(确定)按钮

Qual_Apex

1 = 从峰顶获得的光谱

2 = 峰顶的光谱减去峰开始处的本底

3 = 峰顶的光谱减去在指定时间的本底

4 = 峰中所有光谱的平均光谱

Qual_Events$ — 积分参数文件的名称；如果已指定自动积分，则为空

Qual_Hit1, Qual_Hit2 — 第一和第二谱库的匹配质量阈值

Qual_Lib1$, Qual_Lib2$, Qual_Lib3$ — 用于搜索的第一、第二以及第三谱库的名称

Qual_Time — 本底光谱的时间


QUALRPTOPT

QUALRPTOPT [冗长, 到屏幕, 到打印机, 到文件, "文件名", 在运行方法期间]

在宏中使用以显示 Library Search Report Options（谱库检索报告选项）对话框。

冗长

报告冗长

0 = 摘要

1 = 详细

到屏幕

报告到屏幕

0 = 否

1 = 是

到打印机

报告到打印机

0 = 否

1 = 是

到文件

报告到文件

0 = 否

1 = 是

"文件名"

报告的目的文件。

在运行方法期间

在运行方法期间生成报告：

0 = 否

1 = 是

讨论

缺省时为当前设置。因此，此命令可用来修改选定的设置而不影响其他设置。

变量集

_Button

0 = 选定 Cancel(取消)按钮

1 = 选定 OK(确定)按钮

2 = 选定 Generate Report（生成报告）按钮

Qual_File$ — 报告发送到的文件的名称；报告不发送到文件时为空

Qual_Method

0 = 不选定 "Generate During Run Method"（在运行方法期间生成）

1 = 选定 "Generate During Run Method"（在运行方法期间生成）

Qual_Printer

0 = 报告不发送到打印机

1 = 报告发送到打印机

Qual_Screen

0 = 报告不发送到屏幕

1 = 报告发送到屏幕

Qual_RepType — 报告类型

0 = 摘要报告

1 = 详细报告


QUANTPARMS

QUANTPARMS 参比窗口尺寸, 参比窗口类型, 非参比窗口尺寸, 非参比窗口类型, 相关窗口, 乘积因子, 浓度

直接设置下列定量全局变量（不用对话框）。必需输入所有参数。

参比窗口尺寸

根据ref window type的设置，以百分比或分表示的参比窗口尺寸。

参比窗口类型

0 = 分

1 = 百分比

参比窗口尺寸

以分或百分比表示的非参比窗口尺寸，基于non-ref window type的设置。

非参比窗口类型

0 = 分

1 = 百分比

相关窗口

以分表示的信号相关窗口的尺寸。

乘积因子

一个用来乘以结果的缺省因子；任何非 0 值都有效。

浓度

以当前定量数据库中指定的单位表示的缺省样品浓度。


QUANTRPTOPT

QUANTRPTOPT [报告类型, 到屏幕, 到打印机, 到文件, "文件名", 生成报告, 化合物编号]

在宏中使用以设置定量报告。若未给定任何参数，则显示 Quant Report Options（定量报告选项）对话框。

报告类型

0 = 摘要

1 = 详细/仅有文字

2 = 详细

3 = 详细/单个化合物

4 = 仅有使用定量数据库的百分比报告

到屏幕

0 = 否

1 = 是

到打印机

0 = 否

1 = 是

到文件

0 = 否

1 = 是

"文件名"

目的文件的名称，最多 80 个字符。

生成报告（是或否）

在 RunMethod（运行方法）期间生成报告（请注意：此参数不在 Quant Report Options（定量报告选项）面板上；它在由 Data Analysis（数据分析）中的 Method（方法）菜单进入的 Select Reports（选择报告）框上。

化合物编号

需要详细报告的化合物的编号。仅当 report style（报告类型） = 3 时才有效。范围为 1 到 250。

讨论

缺省时为当前设置。因此，此命令可用来修改选定的设置而不影响其他设置。

变量集

Quant_File$

文件名（如果非空）。

Quant_Detailed

0 = 摘要

1 = 详细/文字

2 = 详细 + 图形

3 = 单个化合物

4 = %

Quant_Method — 0 = 否；1 = 是

Quant_Printer — 0 = 否；1 = 是

Quant_Screen — 0 = 否；1 = 是

Quant_Select — 单个化合物选择


QUANTSAVE

QUANTSAVE [路径] [,文件]

将当前定量数据库写到永久存储器中。

路径

完整文件名的路径组件。缺省值为当前方法(_methpath$ + _methname$)

文件

完整文件名文件组件的名称。缺省值为 QBD.MTH。


QUEUE

QUEUE ["命令"] [,"报告系统"]

将一条命令送入到 Report Manager（报告管理器）中进行排队。使用当前数据和方法文件。

"命令"

一个字符串，代表当前数据文件上要调用的命令，调用通过使用 Report Manager（报告管理器）来实现

"报告系统"

一个字符串，代表用来处理请求的 Report Manager（报告管理器）系统的名称。

示例

此示例仅适用于先前进行过定量化处理或已经过手动积分的文件。

QUEUE 'QT 0,1,"S"',"RPT1"

这将用于生成摘要定量报告的当前数据文件在 Report Manager（报告管理器）系统 "RPT1" 上的打印机中排队。


RECALIB

RECALIB "结果文件 .RES" [,标量]

在宏中使用以由结果文件 .RES（文件必须具有完全限定的路径）中所包含的信息更新当前定量数据库。在 Update Calibration（更新校准）对话框中输入控制进程的参数。

标量

0 or 空 = 无影响

非 0 = 设置一个数组变量 RecalStat。

变量集

RecalStat — 当 Update Calibration（更新校准）操作使用以前创建的 ChemStation（化学工作站）G1034C 结果文件时，用以提供信息的数组。

RecalStat[1] = 定量数据库中化合物的数量，定量数据库是 Update Calibration（更新校准）操作的目标。

RecalStat[2] = Quant Results（定量结果）文件中结果记录的数量，包括 NOT FOUNDS，不包括多次匹配记录。请注意，定量文件 XYZ.D 与 ABC.M 的对比，其中 ABC.M 中的定量数据库有 C 化合物，使得所创建的 Quant Results（定量结果）文件 XYZ.D\QUANT.RES 带有 C 结果记录。

RecalStat[3] = Update Calibration（更新校准）操作过程中实际发生的更新定量数据库的次数。对于更新定量数据库化合物的结果记录来说，该结果记录不必是一个 NOT FOUND 记录，并且该结果记录的化合物的名称必需和定量数据库中化合物的名称严格匹配。

RecalStat[4] = Results（结果）文件中的记录个数，这些记录都是成功的 IDENT/QUANTs （即不是 NOT FOUNDs），但是定量数据库中没有任何化合物产生与其名称严格匹配的化合物。

如果校准标准文件的定量后紧接一个 Update Calibration（更新校准） — 在这期间没有加载任何文件、方法或数据库 — 数组变量 RecalStat 的值为 C、C、C、和 0，其中 C 为定量数据库中化合物的编号。校准标准文件来自一个样品的运行，此样品包含数据库中的所有化合物，这些化合物都处于标准浓度级别。


RECALL

RECALL 变量, "文件名"

在一个先前用 STORE 命令保存的文件中检索一个光谱。

变量

将要放置光谱的变量的名称。

"文件名"

包含此光谱的文件的完整路径文件名。


REFRESH

REFRESH [窗口]

刷新指定的窗口。

窗口

要刷新的图形窗口的编号(1-30)。如果没有指定任何窗口编号，则将刷新所有的图形窗口。

讨论

跟 DRAW 命令不同，REFRESH 保留窗口当前的特定属性，如缩放位置以及所有由 SETWINATTRIBUTE 命令设置的属性。


REPORT_TIC

REPORT_TIC [计算] [输出形式] [,选项]

生成一个 LSC（谱库检索化合物）报告。必须预先已对当前数据文件进行过定量化处理。用来定位非目标化合物的峰和指定搜索中用到的谱库的参数在 LSC Report（LSC 报告）的 Edit Parameter（编辑参数）中设置，并且保存在当前方法目录中的文件 TIC.VAL 中。

计算

0 = 跳过计算并生成报告（用现有的结果文件）

1 = 进行计算（创建新结果文件）

输出形式

0 = 屏幕（缺省）

1 = 打印机

选项

"S" = 摘要报告

"F" = 全部，详细的 LSC 报告，仅限打印机

"RR" = 将报告生成到一个简化的结果文件 xxx.TIC，此文件格式为 Forms 软件可以使用的一种格式


ROLL

ROLL [数字]

更改堆栈窗口中内容的布置（仅限 X、Y、Z 和 T）。

数字

缺省值为 +1。为正数时向上滚动指定次数；为负数时向下滚动。


RRCAL

RRCAL [类型] [,tic]
RRCAL [类型] , 化合物类型

生成一个简化的结果 (RR) 文件。

类型

0 = 标准样品

1 = 校准标准；会提示您输入一个级别数字 (1-20)。

2 = 仪器调谐估算；必须输入一个化合物类型（0 或 1）。

tic

0 = 无 LSC 报告（缺省）

1 = 包括报告到文件的 LSC 报告；文件的 .qz 部分用当前方法中文件 TIC.VAL 中存储的报告参数生成。

2 = 包括报告到打印机和报告到文件的 LSC 报告

讨论

对于类型 0 和 1，结果文件是带有扩展名 ".RR" 的数据文件名。类型 2 将生成一个带数据文件名和扩展名为 ".PC" 的文件。

化合物类型

0 = BFB

1 = DFTPP


RTEINT

RTEINT 变量 [,信号编号]

用 RTE 积分器执行峰检测和积分。

变量

包含一个或多个色谱的变量。

信号编号

确定要对哪些信号进行积分。

0 = 对对象中所有的信号进行积分（缺省）

1 = [image] 信号编号 [image] num（变量）表示只对那个信号进行积分。

讨论

积分基于当前在内存中的积分参数。要查看当前参数，请使用 RTEINTPARMS 命令。要列示积分的结果，请使用 TABULATE RESULTS。

当用 DRAW 命令显示变量的内容时，绘制积分器所使用的基线。由积分器检测到的峰用它们的保存时间来标识。

变量集

NPeaks

积分期间找到的峰数目


RTEINTPARMS

RTEINTPARMS [类型, 面积, 最大峰, 数据点束, 启动, 停止, 复位, 峰谷, 过滤器, 基线, 坐标设定因子, 位置, IP]

设置 RTE 积分器的积分参数；请参见 RTEINT。若省略前面的 12 个参数，则显示 RTE Integrator Parameters（RTE 积分器参数）对话框。如果指定了所有参数，它们将被改变，但除过滤器和基线以外的所有空参数都将保留调用此命令前的原值。

要激活对话框中的 Load（加载）和 Save（保存）按钮，必须由一个宏执行此命令。当从命令行输入此命令时没有这些按钮。

类型

选择面积阈值的参数类型。

0 = 绝对单位（计数单位*秒）

1 = 检测到的最大峰的百分数（缺省）

面积

要报告的最小峰面积的面积阈值。范围是从 0 到 100% 或者 0 到 1E8 计数单位*秒。缺省时为检测到的最大峰的 5%。

最大峰

要报告的峰的最大编号。范围是从 1 到 250。缺省时为 100。

数据点束

选择在应用了束状数据点的移动平均中使用的数据点数量。范围是整数 1 到 9 以及 -1 到 -9。缺省时为 1。如果您希望将数据点平均化（例如，对 SIM 或干扰很多的数据），请使用一个 2 到 9 之间的值。较高的值将减少分裂峰的影响。如果输入一个大于 9 的值，进样就被设为 9。负值将导致对导数进行平滑化，其方式和在面板中选择平滑化复选框一样。

启动

Æô¶¯阈值。确定斜坡灵敏度计算必须大于数据绝对值多少才能使峰启动。缺省值 0.2 对大多数据都是最优的。有效范围为 0.001 到 100。

停止

停止阈值。缺省值为 0，表示已检测到基线。对于受干扰信号，将停止参数提高到 0.3 到 0.5 之间，这样 RTEINT 就不会提前触发了。范围为 0 到 100。

复位

基线复位。为定义基线峰的特征点或那一点的丰度，两个相邻的峰之间必须要分隔的扫描数。如果两个或两个以上的峰之间相隔的扫描数都比由复位参数指出的少，则在峰开始和结束处，基线将绘制在丰度下面。范围为 0 到 500。缺省时为 5 次扫描。

峰谷

确定峰的原面积是由向下画基线的计算方法来修正还是由切线计算方法来修正。范围为 1 到 100%。缺省时为 100%，这使得为所有峰都使用向下画基线的面积校正方法。

过滤器

确定将使用哪个过滤器筛选数据：

0 = 5 点数字过滤器（缺省）

1 = 7 点数字过滤器

2 = 9 点数字过滤器

基线

确定将如何绘制基线：

0 = 水平（缺省）

1 = 切线开始/结束

坐标设定因子

缩放来自积分的已报告的面积结果。范围是 0 到 100；缺省值为 1。当坐标设定因子为 1 时，面积计数单位 = 计数单位 - 秒。要设置由 RTE 积分器报告的面积计数单位以估计 ChemStation（化学工作站）积分器的输出，将坐标设定因子设为 10。

若坐标设定因子为 0，则单位是“原面积计数单位”。

位置

0 = 峰保存时间在峰顶

1 = 峰保存时间为面积的第一时段的坐标（形心）

IP

一个名为 IP 的数组，大小为 12。为 0 时不起作用。非 0 时，用开头的 12 个参数的值设置一个数组 IP。

变量集

若显示 RTE Integrator Parameters（RTE 积分器参数）框，则变量由此命令设置。

_Button

0 = 选定 Cancel（取消）

1 = 选定 OK（确定）

2 = 选定 Save（保存）

3 = 选定 Load（加载）

IP

一个有 12 个标量元素的数组，包含开头 12 个参数的值；当参数 13 非 0 时设置。


SAVEEVENTS

SAVEEVENTS "文件名"

将当前在内存中的 ChemStation 积分器事件保存到一个文件。除非提供一个路径名称，否则文件用当前方法保存。若不输入扩展名，则自动提供扩展名 .E。

EVENTS.E 是每个方法中缺省的 ChemStation 积分器事件文件；无论何时保存 Data Analysis（数据分析）方法时，当前在内存中的事件都保存到文件中。重载方法时，EVENTS.E 也被自动加载，并且，除自动积分以外的后随积分将可使用保存在 EVENTS.E 中的任何定时事件。


SAVEMISC

SAVEMISC "文件名.mac" [,标量]

仅供内部使用。将谱库搜索参数、报告选项以及百分比报告选项保存到指定的宏文件中。缺省路径为当前工作目录。不会自动附加扩展名 .mac。

标量

若指定了标量且是非 0 标量，则仅记录 RTEINT 参数宏。

讨论

此命令保存与 QUALPARMS、QUALRPTOPT、 PCTRPTOPT 和 RTEINTPARMS 命令相关的变量，以及 Spectral_Window 和 Pctscwin 变量。

变量保存在宏文件中，当执行宏文件时，宏文件将把变量初始化为所保存的值。所创建的文件通常用方法保存。此命令可作为多步“savemethod（保存方法）”操作的一部分使用。


SAVESTRATEGY

SAVESTRATEGY "文件名.mac"

仅供内部使用。将 PBM 策略设置保存到指定的宏文件名中。缺省路径为当前数据库目录。不会自动附加扩展名 .mac。

此命令作为多步“save method（保存方法）”操作的一部分使用。


SCAN (数据分析)

SCAN 扫描编号 [,变量] [,文件描述符对象]

将来自指定扫描的质谱分配给指定的变量。

扫描编号

从当前数据文件读取的扫描编号（1 = 文件中的第一次扫描）。

变量

将要放置扫描的变量的名称。缺省值是 X（它将滚动计算堆栈）。

文件描述符对象

从 FILE 命令加载的数据文件。

讨论

无论何时在一个包含质谱的变量上使用 DRAW 命令时，光谱的扫描编号在显示时被标记。

变量集

Ret_Tim e

检索光谱的保留时间

Scan_Nu m

检索光谱的扫描编号。

Scan_Status

0 = 正常扫描

123 = 记录溢出

136 = 值溢出

212 = MS 故障

359 = 全部离子溢出

456 = MS I/O 出错

567 = CPU 硬件出错


SCREEN

SCREEN docalc, dest [,“S”]

生成一个屏幕报告。

docalc

选择是否要执行计算。

0 = 不执行任何计算；仅报告最后的屏幕结果。当已使用 Quick Screener 删除或添加结果时，这是很有用的。

1 = 用当前选定的屏幕数据库执行屏幕进程。这将覆盖屏幕数据库中旧的屏幕结果。

dest

0 = 将报告发送到屏幕

1 = 将报告发送到打印机

“S”

汇总


SELECTFILTER

SELECTFILTER 过滤器类型, [过滤器规格, 步长, 显示步长]

显示 Response Filter（响应筛选器）对话窗格并允许用户设置筛选器规格。

过滤器类型

指出显示哪个窗格的标量值。

0 = 表示一个质量筛选器

1 = 表示一个时间筛选器

过滤器规格

一个数组对象的变量名。此参数既可用于输入也可用于输出。若指定了此参数且存在该变量，则其内容将可用来初始化窗格中的可编辑字段。当用户按下 OK（确定）按钮时，变量的内容被更新为用户所做的选择。

变量 filterspec 是一个包含下列信息的数组：

filterSpec[1] — 选定筛选器的类型

0 - Gaussian

1 - Savitzky-Golay 四次/五次

2 - Savitzky-Golay 二次/三次

filterSpec[2] — 如果 [1] 是 Gaussian，则这是 FWHM。如果是 Savitzky-Golay，那么这是要生成的点的数量。

filterSpec[3] — 仅为质量筛选器存在。这是扫描的步长。

步长

仅为时间筛选器所用。它为 Gaussian 筛选器设置对话窗格上的步长字段。此值可用来验证为 Gaussian 筛选器输入的 FWHM 的值是否有效。FWHM 必须至少为 2 * 步长。对于质量筛选器，StepSize（步长）字段是一个可编辑字段，并可以用 filterSpec 变量将其初始化。

显示步长

确定是否要显示 Gaussian 筛选器的 StepSize（步长）字段。若不显示 StepSize（步长）字段，则在 FWHM 上不会进行任何验证检查。

0 = 不显示 StepSize（步长）字段。

非 0 = 显示 StepSize（步长）字段。

使用 FILTER 函数，filterspec 变量的内容可以被用来创建筛选器。

另见 FILTER、SMOOTHCHR 和 SMOOTH。

变量集

_Button

0 = 按下的 Cancel（取消）

1= 按下的 OK（确定）

示例

POINTS R0

GETSCALARS INFO, R0

StepSize = (xhigh - xlow) / npoints

IF StepSize < 0.0001

StepSize = 0.0001

ENDIF

SelectFilter 1,TimeSpec, StepSize

IF _BUTTON <> 0

IF TimeSpec[1] = 0

! 用户选择一个 Gaussian 筛选器

TIMEFILTER = FILTER(TimeSpec[1],-2,TimeSpec[2],StepSize)

ELSE

! 用户选择一个 Savitzky-Golay 筛选器

TIMEFILTER = FILTER(TimeSpec[1],TimeSpec[2],0,0)

ENDIF

ENDIF


SETUPCALIB

显示 Set Up Quantitation Globals（设置全局定量）对话框。

变量集

AutoIntItem

将 Chromatogram（色谱）菜单上的 Autointegrate（自动积分）菜单项的状态指定为正常或无效。2 = 选中 Quant Global（全局定量）面板中的 RTEINT；0 = 取消选中 Quant Global（全局定量）面板中的 RTEINT

_Button

0 = 选定的 Cancel（取消）按钮

1 = 选定的 Enter Compound Info（输入化合物信息）按钮


SETWINATTRIBUTE

SETWINDOWATTRIBUTE 窗口, 属性, 值, "宏名"

设置指定图形窗口的属性。

窗口

图形窗口的编号 (1-30)。属性为 RESETALL 时此参数不是必需的。

属性

用来指示所要设置属性的关键字。

CURSORSHAPE

MOUSEMACRO

MARKERSHAPE

SNAPTOACTUAL

RIGHTDRAGSHAPE

SHOWTITLES

LEFTDRAGSHAPE

COLOROFFSET

USERCODE

RESETALL

值

用来指定所指定属性特性的整数。

CURSORSHAPE

1 = 箭头光标

2 = 白色十字标

3 = 标尺

4 = 带方尖顶的标尺

5 = 砂漏

6 = 黑色十字标

7 = 文本 I 型光标

8 = 空图标

9 = 四个指向东南西北方向的箭头十字标

10 = 指向东北方向和西南方向的双向箭头

11 = 指向北方和南方的双向箭头

12 = 指向西北方向和东南方向的双向箭头

13 = 保留

14 = 指向北方的垂直箭头

MARKERSHAPE

0 = 无标记

1 = 垂直线

2 = 水平线

3 = 垂直线和水平线

RIGHTDRAGSHAPE/LEFTDRAGSHAPE

0 = 无

1 = 框

2 = 线

3 = 满框

USERCODE

可将起设置为宏中的一个测试。

0 = 无

MOUSEMACRO

忽略值参数。

SNAPTOACTUAL

双击鼠标时，可将鼠标的位置转换为最近的真实数据点。

0 = 不转换

1 = 转换

SHOWTITLES

0 = 不在图形窗口显示标题

1 = 在图形窗口显示标题。

下一次拖拉图形窗口时才能看到上一次的更改。

COLOROFFSET

通过指定的值可循环使用颜色表中的所有颜色。更改所有绘制于图形窗口中的对象的颜色。窗口刷新后才能见到新的颜色。

RESETALL

忽略值参数。将所有图形窗口的所有属性重新设置为它们的初始设置。属性的初始设置为：

CURSORSHAPE=1

MARKERSHAPE=1

SNAPTOACTUAL=0

RIGHTDRAGSHAPE=1

LEFTDRAGSHAPE=1

SHOWTITLES=1

COLOROFFSET=0

USERCODE=0

MOUSEMACRO="mouseaction"

"宏名"

将一个鼠标操作宏指派给窗口。忽略除 MOUSEMACRO 以外的所有属性。初始的鼠标操作宏名为"mouseaction"。当在窗口中进行鼠标操作时，设置此窗口属性可更改哪个宏将调用。


SETWINDOWLOC

SETWINDOWLOC 结构窗口对象, x, y

"窗口标题", x, y

此命令将移动一个结构窗口。

结构窗口对象

使用可将结构对象指定为第一个参数的 CreateWindow 函数创建的所有对象。

窗口标题

一个指定现有子窗口的标题的字符串。

x, y

放置窗口左上角的点的坐标。这些值按父窗口的客户区域的百分比形式（范围从 0.0 到 1.0）指定。


SETWINDOWTEXT

SETWINDOWTEXT 结构窗口对象, "窗口文本字符串"

此命令将更改一个结构窗口的标题。

结构窗口对象

使用可将结构对象指定为第一个参数的 CREATEWINDOW 函数创建的所有对象。

窗口文本字符串

一个包含给定窗口对象的新标题的字符串。


SHOULDERS

SHOULDERS 1/0

为 ChemStation 积分器启用 (1) 或禁用 (0) 肩峰检测逻辑。系统的缺省值为关闭。

要查看当前在内存中的积分事件列表，请进入 TABULATE EVENTS。


SHOWWINDOW

SHOWWINDOW 结构窗口对象, 显示模式

此命令可显示、隐藏结构窗口，或改变其大小。

结构窗口对象

使用可将结构对象指定为第一个参数的 CREATEWINDOW 函数创建的所有对象。

显示模式

0 = 隐藏

1 = 正常

2 = 最小化

3 = 最大化

5 = 显示

9 = 还原


SLOG

SLOG [详细信息]

此命令可初始化将错误记录到一个文件。

详细信息

控制记录到日志文件的消息的详细信息。

0 = 仅限错误（缺省）

1 = 所有命令

此命令用于将错误和命令记录到一个文件。它在开发宏并对这些宏进行故障排除时非常有用。它与 ENDLOG 联合使用可显示日志文件的内容。


SMOOTH

值 = SMOOTH(z, filter_array)

返回平滑的 MS 对象。此函数将 filter_arra y 和 MS 对象 z 结合使用以使 MS 数据平滑。

注：假设用 m/z 表示相等的空间。

z

一个 MS 对象。

filter_array

一个一维数组。第一个元素为筛选器系数的个数，紧跟系数之后。筛选器必须有 2m+1 个元素，其中 m 是一个整数。要保存筛选的数据的质心，筛选器必须对称。FILTER 函数的输出可以被 SMOOTH 函数使用。

示例

y = SMOOTH(z, a)

其中 y 和 z 是 MS 对象，a 是一个数组对象。

下列示例使用命令和函数在以 X 表示的光谱上设置并运行一个 Gaussian 和一个 Savitsky-Golay 质量筛选器。

要运行 Gaussian 筛选器：

  1. 如果在常规的 Data Analysis（数据分析）中运行，请指定连续曲线：

    allcont on

  2. 立即加载一个文件并选择一个光谱。选定的光谱在 MS 对象 X 中。

  3. 创建一个 3 西格马的 Gaussian 筛选器：

    gaus=filter(0,-3,0,0)

  4. 使 X 的内容变光滑并将其放入 R8：

    R8=smooth(x,gaus)

  5. 合并 X 和 R8 并将其放入 X 中。使用 STACK 命令检查注册。

    join X,R8

    stack

  6. 显示 X 的内容。

    draw 1, X !draw

  7. 选择显示格式。如果在常规的 Data Analysis（数据分析）中，您可以选择 Options（选项）菜单中的 Overlay graphs（覆盖图形）以在合并显示格式或单独显示格式之间切换。如果在 Electrospray Data Analysis（Electrospray 数据分析）中，请使用命令 FORMAT MERGED 或 FORMAT SEPARATED。

  8. 以新格式重新绘制。

    draw 1, X

要运行 Savitsky-Golay 筛选器：

  1. 请创建一个 31 点的 S.G. 筛选器。

    gaus=filter(1.31,.0,0)

  2. 从 TIC 中选择一个光谱以获取以 X 表示的 MS 光谱

  3. 使光谱变平滑并将其放入 R7 中:

    R7=smooth(X , sg31)

  4. 合并以 X 和 R7 表示的光谱：

    join X ,R7

  5. 显示以 X 表示的光谱：

    draw 1, X


SMOOTHCHR

SMOOTHCHR (z, filter_array)

返回平滑的 GC/MS 对象。此函数将 filter_arra y 和 GC/MS 对象 z 结合使用，用来使 GC/MS TIC 或离子色谱数据平滑。

注：假设用 m/z 表示相等的空间。

z

一个 GC/MS 对象。

filter_array

一个一维数组。第一个元素为筛选器系数的个数，紧跟系数之后。筛选器必须有 2m+1 个元素，其中 m 是一个整数。要保存筛选的数据的质心，筛选器必须对称。FILTER 函数的输出可以被 SMOOTHCHR 函数使用。

示例

y = SMOOTHCHR(z, a)

其中 y 和 z 是 GC/MS 对象，a 是一个数组对象。

此示例用命令和函数在离子色谱图上设置并运行一个 Gaussian 时间筛选器。

  1. 加载数据文件并选择提取离子色谱图。

  2. 设置筛选器。以下是一种可能性：

    gaus=filter(0,-2,4,1)

    这可为隔开 1 个单位的峰和 4 个单位的 FWHM 设置一个 2 西格马的 Gaussian。可使用扫描编号查找感兴趣的最窄峰的 FWHM。

  3. 使以 R0 表示的离子色谱图变平滑并将结果放入 R6 中：

    R6=smoothchr(R0,gaus)

  4. 复制以 Y 表示的原始离子色谱图：

    Y=R0

  5. 将平滑化后的 R6 与原谱图合并：

    join Y, R6

  6. 显示这两个离子色谱图：

    draw 3, Y


SOLVENTS

SOLVENTS 1/0, 时间

为 ChemStation 积分器创建一个溶剂峰事件。1 打开自动溶剂峰检测；0 将其关闭。要查看内存中当前积分事件列表，请进入 TABULATE EVENTS。

时间

允许值的范围为 -650 到 650 分钟。

要删除一个定时事件，请输入带有相应负时间值的事件命令。


SPECTRUM

SPECTRUM 时间 [,变量] [,文件描述符对象]

将来自与指定时间最接近的扫描的质谱分配给指定变量。

变量

要放置结果的变量的名称。缺省值为 X （它可滚动堆栈）。

文件描述符对象

从 FILE 命令加载的数据文件。

讨论

另见 SCAN。光谱来自当前数据文件。

变量集

Ret_Time

被检索的光谱的保留时间

Scan_Nu m

被检索的光谱的扫描次数。

Scan_Status

0 = 正常扫描

123 = 记录溢出

136 = 值溢出

212 = MS 故障

359 = 全部离子溢出

456 = MS I/O 出错

567 = CPU 硬件出错


SPIKE

SPIKE [目标] [,基质]

生成一个基质掺料化合物回收率报告。 此报告所需的三个数据文件（样品、基质添加、和基质掺料复制）必须先前已定量化。系统会提示您选择三个文件中的每一个文件。

在 Multivu 中列出的结果为每个基质掺料化合物列出了下列属性：化合物名称、样品中发现的浓度、所添加掺料的量、掺料和掺料复制样品中发现的量、掺料和掺料复制样品中的回收率 (%)。

目标

0 = 屏幕（缺省）

1 = 打印机

基质

1 = 水（基质 A）（缺省）

2 = 油（基质 B）

如果没有输入值，则为字符 H2O、WATER、或 SOIL 搜索样品名称和其他信息，如找到，则使用合适的标准。如没有找到，则使用适合水的标准。


STACK

STACK [1/0]

切换堆栈窗口的显示。要进行显式设置：1 = 打开，0 = 关闭。

有 14 个常用的变量显示在堆栈窗口中：X、Y、T、Z、R0、R1、R2、R3、R4、R5、R6、R7、R8 和 R9。缺省的窗口大小只显示前六个变量。可以通过扩大窗口显示其他变量。


STARTANALYSIS

STARTANALYSIS ["文件名"] [,标量]

初始化内部定量结构和 QuantResults 文件（如果已指定一个）。

"文件名"

存储定量计算结果的 QuantResults 文件的完全限定名称。如果没有提供任何文件名称，则不创建任何结果文件。

标量

0 = 是，重置隐式化合物计数器

1 = 否，不重置

典型的定量循环（从化合物 1 到 n），通常在定量开始时化合物编号应重置为 1。有一些如 EnviroQuant 的应用程序可能要在多个阶段执行定量，并需要抑制计数器重置。

变量集

TR_Corr — 时间参比相关

1 = 设置

Cal_Peaks — 结果数量


STARTPRINT

初始化系统以接受用来打印格式页面的数据。使用下列命令收集和格式化数据：

CALIBPRINT

FILEPRINT

STRPRINT

WINPRINT

使用 ENDPRINT 命令打印页面。STARTPRINT 取消因输入 ENDPRINT 而未打印的打印命令（当使用 ChemStation 假脱机系统将打印作业直接发送到打印机时）。

如果设置为直接打印（变量 Direct_Pr = 1，这样可绕过 ChemStation 假脱机系统），第二次的 STARTPRINT 相当于 ENDPRINT，首先打印当前页，然后为新一页初始化系统。


STARTREPORT

STARTREPORT "结果文件名"

仅供内部使用。用一个结果文件初始化定量报表控制信息。在结果文件中，将变量设置为结果数量和时间参比化合物数量。此文件名为必需的，无缺省值。

"文件名"

要打开的文件的完全限定名称。

变量集

Cal_Peaks — 结果数量

NTimeRefs — 时间参比化合物数量


STARTSET

STARTSET 排序顺序

从内存中清除所有现有的单峰列表（请参见 ADDPEAKS）以及相关峰列表（请参见 ENDSET）并确定如何对新的峰进行排序。

排序顺序

0 = 在单峰结构中收集峰将首先按峰的保留时间排序，然后按峰信号（首先排 TIC，然后按升序排列 m/z 值）排序。用于定量算法的峰识别阶段。

非 0 = 峰将首先按峰信号排序，然后按峰保留时间排序。用于按信号进行面积百分比报告。


STORE

STORE 变量, "文件名"

为了存档将一个光谱存储在一个文件中。要检索光谱，请参见 RECALL 命令。

变量

包含要保存的光谱的变量名称。

"文件名"

将在其中存储光谱的文件的完整路径文件名。


STRPRINT（数据分析）

STRPRINT "字符串", x, y

格式化指定的字符串以备打印。必须从 STARTPRINT 命令开始，要打印数据，请使用 ENDPRINT。

x, y

打印起始位置，x 用字符表示，y 用行表示。最大值可以用 PAGESIZE 命令来确定。任何比所选定行上可用字符数更长的字符串将被截短。


SUBTRACT

SUBTRACT [SUPPRESS]

suppress

若使用此可选关键字，结果光谱仅包含来自扣除的正值余数。当扣除色谱图时不产生任何影响。函数 SUBZERO(y,x) 和 SUBTRACT SUPPRESS 的结果一样。

讨论

结果对象驻留于 X 变量中，堆栈向下滚动一次。两个原始对象会被忽略。当显示被扣除对象时（用 DRAW），图形窗口具有与包含在 Y 变量中的原始质谱相同的标题信息。标题的结尾显示标记(-)。

当扣除色谱图时，它们的 X 范围（时间）必须在某一点重叠。


SUBZERO( )

值 = SUBZERO (y,x)

一个函数，该函数从以变量 y 表示的光谱中扣除以变量 x 表示的光谱，并且只返回正值的余数。当扣除色谱图时不产生任何影响。


TABULATE

TABULATE [信息类型] [,"PRINTER" / "CRT" / "CONSOLE" / "文件名"] [,变量]

显示有关 ChemStation 积分器当前数据文件、变量内容、或者当前积分事件的信息。

信息类型

X1:X 2 指定要列表的数据的范围（缺省值为整个范围，这也是缺省的信息类型）。若变量包含多个对象，则分别将每个对象分别进行列表。

RESULT S 一个用来指定与指定变量中的对象关联的积分或谱库搜索结果的关键字。

HEADE R 一个用来指定当前数据文件标题信息的关键字。

EVENT S 一个用来指定 ChemStation 积分器当前积分事件的关键字。

PERCEN T 一个用来指定百分比结果的关键字。若在 Percent Report Options（百分比报告选项）对话框中选定了 Sort by Signal（按信号排序），则指定的变量必须包含一个积分色谱图。若选定了 Sort by Retention Time（按保留时间排序），则必须存在一个积分集（请参见 ADDPEAKS）。

"PRINTER" / "CRT" / "CONSOLE" / "文件名"

表格的目标文件。引号是必需的。缺省值为"CRT"。"PRINTER" 为缺省的系统打印机。

变量

仅为信息类型 X1:X2、RESULTS 和 PERCENT 所使用，对于其他类型可忽略此变量。缺省值为 X。

讨论

若存在变量 TabFooter$ 和 PageNum，则在每页下方的页码后面打印一行文本。脚注文本由 TabFooter$ 定义，页码从 PageNum 的值开始递增。若目标为 CRT 或一个文件，则脚注仅在表格的结尾出现一次，不需要也不用使用 PageNum。不支持逆页打印。


_TAB

_TAB [关键字] [,"文件名"] ,MS 对象 [,数据范围] [,丰度值]
_TAB [关键字] [,"文件名"] ,GC/MS 对象 [,数据范围]

显示有关 ChemStation 积分器当前数据文件、变量内容、或者当前积分事件的信息。这是 TABULATE 命令的一个已重载的版本。

关键字

RESULT S 一个用来指定与指定变量中的对象关联的积分或谱库搜索结果的关键字。

PERCEN T 当参数 3 是 GC/MS 对象时用来指定百分比结果的关键字。若在 Percent Report Options（百分比报告选项）对话框中选定了 Sort by Signal（按信号排序），则指定的变量必须包含一个积分色谱图。若选定了 Sort by Retention Time（按保留时间排序），则必须存在一个积分集（请参见 ADDPEAKS）。在将来的软件修订版中可能会删去此关键字选项，不推荐使用此关键字。

"文件名"

表格的目标文件。缺省时为空字符串。

MS 对象 / GC/MS 对象

参数 3 的选择可确定 _TAB 是接受 4 个参数还是 5 个参数。若参数 3 指定一个包含光谱数据（MS 对象）的变量，则丰度值可能会被指定为参数 5。若参数 3 是一个 GC/MS 对象，则命令仅有 4 个参数。

数据范围

要列表的数据的范围。仅当参数 1 中没有指定任何关键字此参数才相关。对于 MS 对象，缺省值为全质谱范围。对于 GC/MS 对象，缺省值为全色谱保留时间范围。

丰度值

只有当参数 3 中指定了质谱数据时此参数才可用。要指定一个最小丰度，必须将一个数据点包含在表格中。

0 = 包括所有数据点（缺省）

>0 - <1 = 最大丰度的百分比丰度

>=1 = 绝对丰度


_TABH

_TABH , "PRINTER" / "CRT" / "CONSOLE" / "文件名" , 文件描述符对象,

将文件描述符对象所表示的数据文件的标题进行列表。忽略第一个和第四个参数，并应将其保留为空白。

"PRINTER" / "CRT" / "CONSOLE" / "文件名"

表格的目标文件。引号是必需的。缺省值为"CRT"。"PRINTER" 为缺省的系统打印机。

文件描述符对象

无缺省值，禁止为空。


TANSKIM

TANSKIM 时间

为 ChemStation 积分器创建一个切线斜滑事件。要查看当前内存中的积分事件列表，请进入 TABULATE EVENTS。

时间

允许值范围为 -650 到 650 分钟。

要删除一个定时事件，请输入带有相应负时间值的事件命令。

示例

TANSKIM 2.30

创建一个 2.30 分钟的切线斜滑事件

TANSKIM -2.30

删除上面的项目


THRESHOLD（数据分析）

THRESHOLD 值, 时间

为 ChemStation 积分器创建一个阈值事件。阈值在指定的时间更改为指定的值。要查看当前在内存中的积分事件列表，请进入 TABULATE EVENTS。

值

允许值的范围从 -12 到 25，其中 -12 指定了最灵敏（最低）阈值，25 指定了最不灵敏（最高）阈值。阈值每改变 1 个单位，则积分器的灵敏度随之改变 2 个单位（例如，阈值为 8 时的不灵敏度比阈值为 6 时的不灵敏高 4 倍）。

时间

允许值范围为 -650 到 650 分钟。

要删除一个定时事件，请输入带有相应负时间值的事件命令。

示例

THRESHOLD -6,4

将 4.00 分钟的阈值设置为 -6

THRESHOLD 15, 6.005

将 6.005 分钟时的阈值设置为 15

THRESHOLD 15, -6.005

删除上面的项目


TIC

TIC [时间1:时间2] [,变量] [,文件描述符对象]

从当前数据文件创建总离子色谱并将其放入指定的变量。

时间1:时间2

缺省值为整个时间范围。

变量

将要放置 TIC 的变量名称。缺省值为 X （它将滚动堆栈）。

文件描述符对象

从 FILE 命令加载的数据文件。


TOOL

TOOL ["化合物编号" / "全部"]

在一个未定量的数据文件中查找化合物。如果在预期的保留时间窗口中未找到化合物，则扩大窗口并重新搜索。这将一直继续，直到发现峰或搜索完整个数据文件为止。化合物的存在用特征离子比率验证。

使用了当前积分器设置。为得到最佳结果，请设置下列积分参数：

面积阈值 = 10000 计数单位

阈值类型 = 绝对值

"化合物编号" / "全部"

一个用来指定要查找的化合物的数量的字符串，或者用 "全部" 查找在当前定量数据库中列出的所有化合物。


TRANSFORM

TRANSFORM X0:X1, X2:X3 [,变量] [,XAXIS / YAXIS]

沿 X 或 Y 轴移动和设定数据。图标题中的星号 (*) 表示色谱或光谱已被设定（通过 * 运算符、NORMALIZE 或 TRANSFORM）。

X0:X1

要转换的数据范围。

X2:X3

转换后的数据范围。

变量

包含对象的变量名称。缺省值为 X。

XAXIS / YAXIS

要转换的坐标。缺省值为 XAXIS。

警告

向下转换可能会丢失数据。

示例

TRANSFORM 4:12, 2:10

用 2 分钟时间将 X 变量中色谱的时间轴移动到左边。新的色谱替换了 X 中的原始色谱。

TRANSFORM 3.5:7.8, 3:7,Z

转换 X 轴以便 3.5 移动到 3.0，7.8 移动到 7.0，且重新设定整个轴。对象在 Z 变量中。

TRANSFORM 100:100000, 0:50000,, YAXIS

转换 Y 轴以便 100 移动到 0，10000 移动到 50000，且重新设定整个轴。对象在 X 变量中。

另见

INVERSEM( )

INVERSEB( )


TRFILE

提示宏运行并将请求发送到 Report Manager（报表管理器）。

此命令用来选择一个宏，使其在当前数据文件上运行，并将这个请求发送到 Report Manager（报表管理器）。此命令在 /MSDCHEM/MSEXE 目录中显示一个宏列表。

当其中的一个文件被选定时，请求就会被发送到 Report Manager（报表管理器），以便在当前数据文件上运行选择宏文件中的最后一个宏，并使用缺省的 Report Manager System（报表管理器系统）处理此宏。


TUNECHECK

TUNECHECK [目标] ,"参数文件" [,自动查找)

按照调谐评价标准评价 X 注册中的光谱。

目标

0 = 屏幕（缺省）。以 Multivu 显示。文件 tuneeval.txt 被添加到当前方法目录中。

1 = 打印；包括光谱

2 = 表格文件。文件 tune.csv 被添加到当前数据目录中。

"参数文件"

一个指定存储于当前方法中的参数文件 (.val) 名称的字符串。

自动查找

0 = 缺省；评价 X 注册中的当前光谱。

1 = 在标准文件中通过对基 m/3 离子色谱积分来定位光谱。


UPDATECALIB

UPDATECALIB ["级 ID", "级文件名",,respact,,rtact,qiact ]

用于查找级 ID 以及更新相关文件名或用于显示 Update Calibration（更新校准）对话框。若一个宏正在运行并且所有的参数都为 null，则显示该对话框。

"级 ID"

一个用来追踪样品的名称或编号，该样品可用来校准此级。

"级文件名"

作为校准数据源的数据文件。

respact

更新响应因子 (RF)

0 = 无操作

1 = 平均

2 = 替换

rtact

更新保留时间 (RT)

0 = 无操作

1 = 平均

2 = 替换

qiact

更新离子比

0 = 无操作

2 = 替换

变量集

_Button

0 = 选定的 Cancel（取消）按钮

1 = 选定的 OK（确定）按钮

2 = 选定的 Do Update（进行更新）按钮（添加级数）

3 = 选定的Do Update（进行更新）按钮（重新校准）

4 = 选定的 Do Update（进行更新）按钮（删除级）

Uqr

0 = 更新合格率

1 = 不更新合格率


UPDATERSLT

UPDATERSLT 峰面积, 保留时间, 开始时间, 结束时间, 开始基线, 结束基线, 结果数量, "结果文件名", 匹配编号

更新一个定量结果记录。所有参数都是必需的，无缺省值。

峰面积

以面积记数表示的峰面积。

保留时间

以毫秒表示的保留时间（时间 * 60000）。

开始时间/结束时间

以毫秒表示的开始时间和结束时间。

开始基线/结束基线

以面积记数表示的开始基线和结束基线。

结果编号

结果编号，介于 1 和文件中结果数量之间。

"结果文件名"

ÓÃÀ´存储结果的完全限定文件名。

匹配编号

匹配编号，介于 1 和结果记录的匹配数量之间。或者使用 0 表示最佳匹配。

讨论

UPDATERSLT 命令读取变量 Cal_Pk_Found 的值。如果变量不存在，则结果记录中与 Cal_Pk_Found 相应的值被设置为 0。


VIEWCALCURVE

VIEWCALCURVE [N]

若调用 VIEWCALCURVE（无参数 N），则显示 View Calibration Curves（查看校准曲线）对话框。

若调用 VIEWCALCURVE N（其中 N 为一个介于 1 和 Quant Database（定量数据库）中化合物数量之间的一个数），则不会显示任何对话框，而是设置了下列变量。

变量

COEF0

校准方程中的常数项系数

COEF1

校准方程中的线性项系数

COEF2

校准方程中的二次项系数

RHO

确定系数


VIEWPBMTEXT

VIEWPBMTEXT 变量, 匹配编号

显示 PBM 搜索的 PBM 文本结果。

变量

包含 PBM 搜索结果的变量名称。此参数为必需的，无缺省值。

匹配编号

PBM 搜索匹配数，介于 1 和匹配数之间。此参数为必需的，无缺省值。


WINDOW

WINDOW [窗口], X1:X2,Y1:Y2

重置图形窗口的大小和位置，但不影响图标化的窗口。

窗口

要重置的图形窗口的编号 (1-30)。若没有指定窗口编号，则所有图形窗口的位置和尺寸将被重置为它们的初始设置。

X1:X2, Y1:Y2

指定窗口宽度和高度的范围。X 1 和 Y 1 为左下角的坐标； X 2 和 Y 2 为右上角的坐标。X 和 Y 的有效值为：

  • X1 小于或等于 0.95

  • X2 大于或等于 0.04

  • 窗口的宽度 (X2-X1) 小于或等于 1.025

  • Y2 必须在 0.04 到 1.03 之间

  • 窗口的高度 (Y2-Y1) 小于或等于 1.5

示例

WINDOW 4, 0:0.5, 0:0.5

将窗口 4 定义在 Data Analysis（数据分析）窗口的左下象限中


WINEXIST

值 = WINEXIST (窗口)

确定指定的图形窗口当前是否显示在 Data Analysis（数据分析）窗口中。若窗口已显示，则返回 1；若未显示，则返回 0 。

窗口

要检查的窗口编号。


WINPOSITION

WINPOSITION 窗口 [,x1] [,x2] [,y1] [,y2]

获取一个图形窗口的位置和尺寸。返回的值可用于 WINDOW 命令。

窗口

为其获取位置和尺寸的窗口的编号(1-30)。此参数是必需的。

x1

用来存储窗口左下角 x 坐标的变量。此参数是可选的。缺省的变量名为 xleft。

x2

用来存储窗口右上角 x 坐标的变量。此参数是可选的。缺省的变量名为 xright。

y1

用来存储窗口左下角 y 坐标的变量。此参数是可选的。缺省的变量名为 ylower。

y2

用来存储窗口右上角 y 坐标的变量。此参数是可选的。缺省的变量名为 yupper。


WINPRINT

WINPRINT 窗口, x, y, 宽度, 长度 [,无 Y 轴]

收集并格式化图形窗口中的数据以备打印。必须从 STARTPRINT 命令开始，要打印数据，请使用 ENDPRINT。

窗口

包含要打印数据的图形窗口的编号 (1-30)。

x, y

打印开始位置；x 以字符表示，y 以行表示。它们的范围都是从 0 到 PAGESIZE 命令报告的值。

宽度, 长度

以字符和行表示的图的尺寸。

无 Y 轴

0 =（缺省）正常显示，打印所有的轴和标签

1 = 不打印 Y 轴和标签、X 轴标签、标题和积分峰标签


WINVARNAME$ ( )

name$ = WINVARNAME$（窗口）

返回显示在指定窗口中的 CP 对象的名称。若显示在窗口中的对象没有名称，则返回一个空字符串。

窗口

确定对象当前是否显示的窗口编号。

示例

DRAW 2, R0

NAME$=WINVARNAME$(2)

PRINT NAME$ ! 在消息行上打印 "R0"


_XFM

_XFM X0:X1, X2:X3 [,variable] [,XAXIS / YAXIS]

沿 X 或 Y 轴移动和缩放数据。绘图标题中的星号 (*) 表示色谱或光谱已被缩放（通过 * operator, NORMALIZE, TRANSFORM, 或 _XFM）。此为 TRANSFORM 命令的一个重载版本。

X0:X1

要转换的数据的范围。此参数为必需，无缺省值。

X2:X3

转换后数据的范围。此参数为必需，无缺省值。

variable

缺省值为 X。变量的内容可能为一个 MS 对象（光谱）或一个 GC/MS 对象（色谱）。

XAXIS / YAXIS

指定要转换的坐标的关键词。缺省为 XAXIS.

对于 MS 对象(参数 3):XAXIS 表示 m/z 方向已被转换。YAXIS 表示质谱响应方向已被转换。

对于 GC/MS 对象（参数 3）：XAXIS 表示保留时间方向已被转换。YAXIS 表示色谱响应方向已被转换。

警告

向下转换可能会丢失数据。


XPAND

XPAND [minutes]

在 EasyID 或 QEdit 中使用以展开萃取离子色谱图的视图。存在的任何手动积分将丢失。如果您用鼠标放大并随后输入了 XPAND，新的开始和终止时间和在窗口中首次绘制的，而不是视图中缩放后的数据相对。

要返回原始视图，输入命令 ORIGINAL。

minutes

在每个色谱图终止时需要延长的分钟数。缺省值为 2 分钟。


ZOOM

ZOOM 窗口，X1:X2, Y1:Y2

将指定图形窗口的一部分放大。

window

发生缩放的图形窗口的编号(1-30)。

X1:X2

一个定义缩放方框宽度的范围。对于光谱，请输入 amu*20；对于色谱，请输入 time*60000。

Y1:Y2

一个定义缩放方框高度的范围。Y 值作为丰度输入。


ZOOMOUT

ZOOMOUT 窗口

将一个缩放后的图形窗口还原为它的原始的、未缩放的状态。

window

要还原的图形窗口的编号(1-30)。


宏的示例

在线书籍《Using and Writing Macros（使用和编写宏）》使用了许多示例来阐述宏的概念和创建宏的命令使用。这些宏的示例在系统的 MSDchem/msexe 目录下的 macros.mac 文件中。您可在学习宏时使用该文件中的宏来理解各章节，或将文件中的宏作为创建自己的宏的起点。mcros.mac 文件可用文本编辑器如 Notepad 或 Wordpad 打开。


第一章 — 宏基础

本章给出了一个通过创建和使用宏来简化 MS 化学工作站任务的范例。您可用本章的说明作为手动操作任务和开发宏的指南。由于该示例的目的是介绍宏编程的概念，所以即使您目前没有理解全部内容也没有关系。同一主题将在后续章节中详述。

为什么使用宏？

您需要使用宏吗？

创建一个宏

使用一个宏

编辑一个宏

摘要


为什么要使用宏？

作为用户，您可以通过使用和编写宏程序来大大扩展 MS 化学工作站的功能和适用性。

例如，可以编写一个宏来改变系统对鼠标输入的解释。这样的宏将允许使用鼠标单击来进行通常需要更多的输入的操作。例如，您可以创建一个宏来将数据仅通过鼠标的一次单击来从 MS 化学工作站传送到 Excel 电子制表软件。

类似的，一个宏可以从 MS 化学工作站应用程序的命令行调用来执行一个冗长的系列 DOS 命令，从文本文件输入大量的信息，或者产生一个结合了文本、色谱图、光谱和从谱库搜索中得到的相关参比光谱的用户定制报告。

一个宏程序（或简称宏）基本上只是一系列 MS 化学工作站命令。宏被命名并存储在文件中。一旦将这个文件加载到系统内存中，可以将宏作为各种方法中的一个单元来执行。

宏程序使您能自动进行和自定义化学工作站操作。由于所有方法、序列和大多数菜单项目实际上是作为宏的调用而实现，可以通过编写新的定制宏或编辑和使用现存系统宏的修订版本来适应 MS 化学工作站中几乎每个方面 。


您需要使用宏吗？

在特殊应用情况下操作 MS 化学工作站时，您有时候可能会觉得花在繁琐和重复性的任务上的时间太多。例如，假设您经常需要放大谱图、标记特定峰并打印显示结果，这一操作需要以下步骤：

  1. 启动 MS 化学工作站。

  2. 选择 View / Data Analysis（查看/数据分析）（脱机）。

  3. 在 Data Analysis（数据分析）视窗中选择 File / Load Data File（文件/载入数据文件）。

  4. 在显示的数据文件列表中选择 evaldemo.d （示例），然后单击 OK（确定）。显示 TIC。

  5. 在 TIC 的第一个峰（时间＝ 5.27 秒）上双击鼠标右键。

  6. 谱图被拖入窗口 1 后，拖动鼠标左键框住 x=50 和 x=60 之间的部分图形，然后放开按钮。选定的区域被放大到充满整个图形区域。

  7. 确认打印机已准备好，然后在 Data Analysis（数据分析）窗口中的命令行中键入如下说明。如果命令行未显示，从应用程序窗口的 Control（控制）菜单中选择 Cmdline on（命令行开启）。

FILE _DATAPATH$ _DATAFILE$
STARTPRINT
STRPRINT "Name of file: " _DATAPATH$ _DATAFILE$, 1, 1
STRPRINT "Name of operator: " _OPERATOR$, 1, 2
WINPRINT 1, 1, 4, 65, 15
ENDPRINT

完成上述步骤后，数据文件名称、操作者姓名和放大图形被打印出来。工作完成了，但是步骤繁琐漫长，尤其是当有许多谱图要进行类似处理时。因为每张纸上只有一个图，纸张也浪费了。

怎么办？编写一个宏！

宏可以使操作步骤自动化，例如上述这个实验室中的频繁操作，从而节省时间。编写一个宏仅比在命令行上键入一次命令稍微困难一点。

宏本质上是一个化学工作站命令处理器的指令列表。列表可能很长，但是您可以在命令行上仅输入几个字符（宏的名称）来执行所有指令。

化学工作站软件由许多在不同的窗口或视窗中运行的软件模块构成。这些模块，例如 Top（顶部）和 Data Analysis（数据分析），也称作应用程序。每个化学工作站应用程序都有一个可使用的命令行。在化学工作站的应用程序窗口的命令行上键入命令时，该命令由该应用程序的命令处理器直接处理。命令处理器（或 CP）是一个能够连续读取指令、编译指令、执行指令、读取另一个指令，以及进行其他操作的软件模块。CP 对化学工作站的操作十分重要；化学工作站执行的每项操作都是 CP 处理一个或多个指令的结果。


创建宏

作为一个简单宏的示例，在下面的宏示例中，编写一个宏来完成第 7 步的作业。

  1. 单击 Start（开始）按钮，指向 Programs / Accessories（程序/附件）并选择 Notepad。这样就启动了 Notepad 文本编辑程序。

  2. 键入以下文字：

NAME ZoomPrint
FILE _DATAPATH$ _DATAFILE$
STARTPRINT
STRPRINT "Name of file: " _DATAPATH$ _DATAFILE$, 1, 1
STRPRINT "Name of file: " _OPERATOR$, 1, 2
WINPRINT 1, 1, 4, 65, 15
ENDPRINT
RETURN

  3. 选择 File / Save As（文件/另存为），定位到您想保存文件的目录（例如 \MSDchem\my_macs）并在 Filename（文件名）框中键入 reports.mac。

您刚才就创建了一个宏！ 正您所如看到的，宏基本上就是能够在化学工作站应用窗口上执行的一系列的指令。关键字 NAME 和 RETURN 标志着宏的开始和结束。上面程序中的 NAME ZoomPrint 行同时也给宏定名为 ZoomPrint。


使用宏

  1. 切换到要使用的宏所处的应用程序窗口。

  2. 通过在 Data Analysis（数据分析）窗口的命令行上输入MACRO（宏），接一个空格，将宏加载到内存、包含宏的文件的完整路径名并按下 Enter 键。在双引号中包含文件路径名，如下例所示：

    MACRO "\MSDchem\my_macs\reports.mac"

  3. 如果没有这样做，遵循前面所述在 Data Analysis（数据分析）窗口加载一个数据文件的指引并将一个放大的光谱图放到窗口 1 中。

  4. 通过下例所示命令行键入宏的名字来执行宏。

    ZoomPrint

带有标记的图形将出现在打印机上。


编辑宏

在运行宏以后，您可能会决定对宏的某些方面进行修改或对其功能进行某些方面的增强。您编制的宏的末稿可能会很复杂。在编制宏的时候，您可能想在简单条件下开始，然后每次不断添加宏的复杂层次。您可以如下面所述，使用 Notepad 应用软件来对宏的初稿进行修改并保存对宏的修改。

  1. 在 Notepad 应用软件中，选择 File / Open（文件/打开）。

  2. 定位至该宏所在目录，在文件列表中选择 reports.mac ，然后单击 OK（确定）。

  3. 编辑该文件，进行您想作的修改或添加。

例如，假设通过您原来的宏打印的图形比你想要的大，而您又想在一页纸上打印更多的这类图形。第一步，修改该宏，并排打印文本和图形。

接下来，在 Notepad 窗口中的文本修改为下面的文本：复制以 STRPRINT 打头的两行文字，然后编辑四行以 STRPRINT 打头的文本，最后将数值参数修改为黑体字标记的数值。

Name ZoomPrint
FILE _DATAPATH$ _DATAFILE$
STARTPRINT
STRPRINT "Name of file: ", 1, 1
STRPRINT " "_DATAPATH$ _DATAFILE$, 1, 2
STRPRINT "Name of Operator: ", 1, 3
STRPRINT " "_OPERATOR$, 1, 4
WINPRINT 1, 37, 1, 43, 18
ENDPRINT

编辑后的宏将在 1 — 4 行打印文本，而不再是 1 — 2 行，并将图形的左上角定位在第一行的第 37 个字符处，图形坐标设定为宽 43 个字符、长 18 行。

  4. 将编辑后的宏保存在 Reports2.mac 文件中。

  5. 在 Data Analysis（数据分析）中用以下步骤测试刚经过修改的宏：

用 MACRO 命令调用宏文件，输入新的文件名（在此处为 Reports2.mac ）。

在命令行中键入宏名称（在此例中为 ZoomPrint），然后按 Enter 键测试该宏。


摘要

宏是一个文件中存储在一起的指令的列表。通过几次按键即可执行一个宏。宏对于经常在 MS 化学工作站执行的自动任务非常有用，否则需要进行多次鼠标操作、菜单选择、面板输入或命令行输入。宏也可用于 MS 化学工作站的定制操作，如以特定形式打印一个报告。如前例所示，宏易于创建、存储、修改和使用。

在第二章中继续学习关于 MS 化学工作站宏语言的更多内容。


第二章 — 化学工作站的宏语言

本章对化学工作站的宏语言进行了深入描述，您可以开始编写自己使用的宏。

什么是宏？

注释语句

赋值语句和变量

表达式和运算符

声明语句

控制语句

调用语句

参数


什么是宏？

一个宏，或宏程序，是一系列以 MS 化学工作站宏语言编写的指令（称作语句）。宏被命名并存储在一个可以包含超过一个宏的文本文件中。一旦宏存在，用户可以如第 1 章中所述加载并执行它。

宏中的大多数指令的作用是执行 MS 化学工作站命令或功能。关于这些命令和功能的使用和效果的信息可以通过从任何 MS 化学工作站应用窗口中选择 Help / Help Topics（帮助/帮助主题）在线获得。通过在 MS 化学工作站应用程序中的命令行上键入 COMMANDS 可以看到该程序中定义的命令和功能列表。

作为原始 MS 化学工作站软件一部分的宏称作系统宏。对于每个主要 MS 化学工作站程序（Top（顶部），Tune（调谐），Instrument Control（仪器控制）和 Data Analysis（数据分析））起作用的命令处理程序在程序启动时加载一系列系统宏。所有方法和许多菜单选项作为系统宏执行。

由MS 化学工作站用户创建来自动进行或自定义化学工作站操作的某些方面的宏称作用户宏。

一个命令处理程序，或 CP，是一个持续进行等待指令、编译指令和执行指令的循环过程的软件模块。CP 对于 MS 化学工作站的操作非常重要；所有化学工作站进行的操作都是由 CP 执行指令的结果。

Top（顶部）、Tune（调谐）、Acquisition（采集）和 Data Analysis（数据分析）应用窗口的命令行给用户提供了提交命令给 CP 执行的方法。当键入一个命令名称及其相关参数列表并按下回车键后，命令处理程序将执行该命令。如第 1 章中所述，还可以在 MS 化学工作站命令行上键入宏名称。这种情况下，所有宏中的命令由 CP 顺序执行。

宏中使用的语句可以分为赋值语句、说明语句、控制语句、调用语句和注释语句。这些项目尽管有些重复，但是很有用。事实上，每条语句都可以视为对命令、宏、功能或运算符的调用。所有语句，除注释语句外，都称作可执行语句。


注释语句

注释语句被命令处理器忽略。它们是宏中有用的注释，用来记录宏的目的并说明如何实现该目的。注释使宏的阅读者更容易理解，包括一次写了许多宏或以后可能需要修改宏的宏作者。

请使用下列规则来准确的确定一个注释的起始位置：

在一个包含宏的文件中任意行中未加引用的感叹号 (!) 将被命令处理器忽略，该行中其后的所有字符也同样被忽略。感叹号通常是程序行中的第一个字符，但并不一定。

注释的示例

! This is a comment.
!
H2O$ = "water" ! This is a comment too.
!
! There are six comments in this group
! and one executable statement.

在宏的一行中存在注释不影响命令处理器对后续行或前面行的解释。


赋值语句和变量

一条赋值语句把一个表达式的值存储在一个变量中。例如：

Sum = 1 5 ! stores 6 in the variable Sum

变量是计算机内存中命名的一部分，用来存储数据。变量可以根据其数据类型和作用域分类。在 MS 化学工作站中预先定义的数据类型是标量、标量值域、字符串、标量数组、标量矩阵和集合。变量的作用域可以是局部或者全局的。它们称为局部变量和全局变量。

变量的使用是宏和 MS 化学工作站软件各方面操作的核心。在宏中使用变量时，数据如下所示在宏中写入和读出。

Sum = 21 3.42 ! stores 24.42 in Sum
Index = Index 1 ! retrieves Index, adds 1 to it, and stores
! the new value back into Index
Index_range = 1:10 ! stores a range value
Time_range = 4.39:8.46E1 ! stores a range value
X_array = Y_array ! retrieves y_array and stores it in x_array
My_set[3] = Line_of_text$ ! stores a string in a set
Covar_matrix[25, 31] = 0.741 ! stores to a scalar matrix

局部变量是在宏中定义且仅由该宏使用的变量。命令处理器在宏结束运行时清除局域变量。每次运行宏时该宏指定的局部变量都会重新创建。

全局变量由命令处理器保留，独立于宏而存在。局部变量可以由任何宏、命令或 CP 执行的函数使用。除非全局变量被 REMOVE 命令明确清除，否则只要 CP 运行它就存在。

变量

标量变量

标量值域变量

字符串变量

标量数组变量

标量矩阵变量

集合变量


标量变量

如下例所示，标量变量用于储存单个浮点实际值。

Enough = 7.99
Avogadros_num = 6.02e23
Total = Subtotal * (1 Tax_rate) Postage Handling
PRINT VAL$(Total)


标量范围变量

标量范围变量用于代表一系列从下限变化到上限的数字，如下例所示：

Range1 = 4:9 ! represents the numbers from 4 to 9 (inclusive)
Range2 = 5.17:9.253
Range3 = Range1 Range2 ! stores the range sum 4:9.253 到 Range3
Range7 = Alpha:Beta
AVERAGE Range2, results ! averages spectra over Range2


字符串变量

字符串变量用于存储如下例所示的一系列字符（一个文本字符串）。虽然未被系统严格限定，字符串变量名通常以一个 $ 字符结尾。

Part1$ = "Good morning! "
Part2$ = "How are you?"
PRINT Part1$ Part2$
ALERT Part1$[6:12] Part2$[12], 4
! puts panel on screen that says "morning?"


标量数组变量

标量数组变量用来储存元素的集合，每个元素都是一个标量变量。单个的元素能够用整数位标进行访问，位标可看作该元素的行号。使用标量数组变量的示例如下：

My_array[122] = 97 ! assigns 97 to the variable in row 122

Total[23] = Price[23] * ( 1 Tax_rate)
! assigns the contents of Price[23], plus tax, to Total[23]

Res_array = Arraystat(Total, 40)
! get a result array of statistics about Total

如果数组位标不是整数，该值将四舍五入到最接近的整数。


标量矩阵变量

标量矩阵与标量数组相似，只不过它是双位标的。它可以看作一个正方形数组，第一个位标指行，第二个位标指列。运用标量矩阵变量的一个示例如下：

My_matrix[21,31] = 98.6
! assigns 98.6 to the variable in row 21, column 31


集合变量

一个集合变量存储两个或更多元素，通过这种方式每个元素均可通过一个整数指数访问。元素可以为下列任意类型：标量、标量序列、字符串、标量数组或标量矩阵。集合不允许自己作为一个集合的元素。通常，字符串被存储到一个集合的所有元素中，使得集合的作用类似于一个字符串数组。

使用集合变量的示例

My_set[1] = My_matrix
My_set[4] = 1.2:3.92
My_set[17] = "...With eyes severe and beard of formal cut,"
My_set[18] = "Full of wise saws and modern instances;"


表达式和运算符

任何有值的即为表达式。在化学工作站宏语言中，表达式可具有下列类型的值：标量、标量序列、字符串、标量数组、标量矩阵、集合或逻辑值（整数）。文字和变量是表达式最简单的例子。更复杂的表达式可通过使用运算符和函数构成。

表达式的例子

5 ! 标量表达式
Sum
2 LOG(3.142)
(Sum <0) AND (Checking =1) ! 逻辑表达式
"The cat" " came back." ! 字符串表达式

5.682e-12 ! 文字
0
39.9999
"It was a dark and stormy night ..."
2.13:47.95

化学工作站宏语言的运算符为：

- * / : > >= < <= = NOT AND OR () []


ËµÃ÷Óï¾ä

说明语句

一个说明语句给变量、参数或宏命名或提供存储空间，如下例所示：

NAME My_Macro
! declares a macro
PARAMETER Amt, Size DEFAULT 0, Result BYNAME defaultRsltVar
! declares three formal parameters:Amt, Size, and Result

LOCAL Tax_rate, My_array, My_matrix, My_set
! declares variables, makes them local, and gives them names

DIM my_array, 125
! reserves storage for 125 scalars
DIM my_matrix, 30, 40
! reserves storage for 1200 scalars
Sdim my_set, 10
! reserves storage for 10 elements


控制语句

控制语句引导其他语句的执行信息流。控制语句决定宏中的哪个语句将被执行以及执行多少次。控制语句允许一个宏根据执行时变量和参数的值执行不同任务。一些控制语句终止宏的执行。

控制语句示例

! IF-THEN-ELSE-ENDIF statement for conditional execution
!
IF discriminant >= THEN
num_real_solutions = 2
ELSE
IF discriminant >= THEN
num_real_solutions = 1
ELSE
num_real_solutions = 0
ENDIF
ENDIF

! WHILE loop, including index initialization
! It prints the elements indexed from 1 to 5.
!
index = 1
WHILE index <6
PRINT #1, my_set[index]
index = 1
ENDWHILE
! handle_error is a call to make if an error occurs
!
ON_ERROR handle_error
! each statement terminates execution
!
RETURN
REMOVE This_macro


调用语句

调用是执行一项操作的请求。调用可输入命令行中或放在宏内。许多调用仅由化学工作站的命令名组成，后面带有由逗号分隔的所需参数的列表。函数的调用参数列表必须被括在括号中。

调用的示例

a call to a command

PRINT "The print command is " , "printing two strings."
! a call to a command with two parameters

OPEN "C:\MSDchem\temp" FOR OUTPUT AS #1
! opens a file and makes #1 a synonym for the filename

! If either of the next two calls is entered on a command line,
! the CP will write the absolute value, 32, on the message line.
! Neither call results in any output at all if executed in a macro.

abs(-32)
abs(-32)
result = eqstr("AbC", "abC")

! assignment and function call.
! result gets value of 1 because the strings are considered equal
! nested function calls, on the right side of the assignment.

! Computes a third power.

ThirdPowerOfN = EXP(3*ln(N))
Date_string$ = DATE$()

出现给定调用的宏称为调用方。如果在命令行中输入调用，则可将 CP 视为调用方。被调用方是调用所请求的操作。


参数

参数是用于调用者和被调用者之间传送数据的变量或数值。如果从命令行调用一个命令或宏就键入正确参数。调用其他宏的宏将参数作为调用的一部分传送到宏，如下面例中所示。

! This is a macro named CallER.
!
NAME CallER
! this macro makes a call to CallEE
! the parameter "Hello" is passed to the parameter String$
! when the call to CallEE is executed.
! CallEE then prints "Hello!" on the message line.
!
CallEE "Hello!"
RETURN

! This is a macro named CallEE.
!
NAME CallEE
PARAMETER String$ !String$ is a formal parameter
PRINT String$ ! prints the value in String$ on the message line
RETURN

参数可以用两种非常不同的方法传送到宏：通过数值或通过名称。如果仅需要单方向传送数据，参数通常通过数值来传递。从调用者到被调用者。当被调用者需要分配一个数值给实参数而调用者需要能在调用被执行后访问这个数值时，参数通过名称传递。下面的例子显示数值和名称参数的说明：

! declares three formal parameters:Amt, Size, and
! Result.Amt and Size are value parameters.
! Result is a byname parameter
!
PARAMETER Amt, Size DEFAULT 0, Result BYNAME defaultRsltVar

另见

第 4 章，关于化学工作站宏的更多信息


第三章 — 宏的示例

本章介绍并逐行解释了一个简单的宏程序，阐述了化学工作站的宏中的一些常用概念和命令。

宏

说明


宏

本章中用宏的例子来说明化学工作站中宏语言的一些基本特征。如果您是第一次编写宏，可以先在 Notepad 窗口中键入宏，保存成一个文件，将其加载至 Data Analysis（数据分析）然后执行。有关编辑、加载和运行宏的更多信息，请参阅第一章。

宏的作用是显示一个对话框，用户可在其中输入信息。该对话框有几个文本信息字段，如 Name、Title、和 Organization。这些字段有缺省显示，但用户可更改这些缺省值。

用户单击 Save（保存）按钮时，对话框中文本区的信息被保存到一个文件中并在 Notepad 窗口中显示。在 Notepad 中，用户可以编辑信息、增加信息和/或将其保存在一个新文件名下。

本章中举出的宏示例说明了如何为变量赋值，如何使用系统变量在宏中做出决策。该宏示例还说明了如何使用下列化学工作站命令及有用的 Sdim 宏：

  • NAME

  • PARAMETER

  • LOCAL

  • INPUT6

  • IF-ENDIF

  • OPEN

  • WHILE-ENDWHILE

  • PRINT

  • CLOSE

  • RETURN

注意 该例中显示的行数仅供参考。如果要在该例中输入，不要输入行数！！！ 宏中不允许出现行数，否则会在加载宏文件时出错。

1 ! A macro for a Data Analysis command processor.
2 ! This macro demonstrates the use of the command
3 ! INPUT6 to accept up to six character strings from the
4 ! user. The line numbers are not part of the macro
5 ! and appear only for easy reference to the example.
6 NAME Get_Address
7 PARAMETER prompt$ DEFAULT "Enter up to 5 lines"
8 LOCAL label, button, addr, index, filename$
9 Sdim label,5
10 Sdim button,2
11 Sdim addr,5
12 label[1] = "Name"
13 label[2] = "Title"
14 label[3] = "Organization"
15 label[4] = "Street Address"
16 label[5] = "City, State, Zip"
17 addr[1] = "Dr. Jean C. Doe"
18 addr[2] = "Laboratory Supervisor"
19 ! addr[2] = "Laboratory Manager"
20 addr[3] = "Ident-Rite Analytical Laboratories, Inc."
21 addr[4] = "10001 Industrial Avenue"
22 addr[5] = "Wichita, CA 92001"
23 button[1] = "Save"
24 button[2] = "Cancel"
25 INPUT6 1, 5, prompt$, label, button, addr
26 IF _Button = 1 ! if user pushed the Save button
27 ! Create a file to write the strings to
!
28 filename$ = _EXEPATH$ "addrfile.txt"
29 OPEN filename$ FOR OUTPUT AS #1
30 index = 1
31 WHILE index <= 5
32 PRINT #1, addr[index]
33 index = index 1
34 ENDWHILE
35 CLOSE #1
36 ! Display the contents of this file.
37 ! ViewFile is a system macro defined
38 ! in Data Analysis CP's.
!
39 ViewFile filename$
40 ENDIF
41 RETURN


说明

1 － 5 行

! A Macro for a Data Analysis command processor.
! This macro demonstrates the use of the command
! INPUT6 to accept up to six character strings from the
! user. The line numbers are not part of the macro
! and appear only for easy reference to the example.

这五行为注释行。注释对每个希望使用、调试或更改宏，或将其一部分复制到另一个宏的用户来说都很重要。

这一宏示例的可执行部分从说明语句开始：

第 6 行

NAME Get_Address

从文件加载宏时，上述说明语句具有双重作用。它在用来存储宏的计算机的主内存中保留一个存储单元，并通过表格中进行输入将该单元与名称 Get_Address 联系起来。该说明语句使命令处理程序可对调用 Get_Address 作出适当响应。在进行调用时，CP 通过在表格中查找该名称来确定宏的位置，然后检索、解释、执行命令。

其他说明语句具有类似作用。它们可实现通过名称访问参数和变量。与在宏被加载至内存时才起作用的第 6 行语句不同，大多数说明在调用宏时就被执行。

第 7 行

PARAMETER prompt$ DEFAULT "Enter up to 5 lines"

该行为宏说明一个值的参数。该参数是宏显示在屏幕上的对话框中的提示。此处使用关键字 DEFAULT，它说明参数的缺省值已经包括在说明中。给定缺省值可保证即使调用者不指定参数值，参数也具有合理的数值。如果对宏的调用为：

Get_Address

对话框中的提示为：

Enter up to 5 lines

如果对宏的调用为：

Get_Address "Tell me about yourself"

对话框中的提示为：

Tell me about yourself

第 8 行

LOCAL label, button, addr, index, filename$

该语句创建一些局部变量并为每个变量命名。创建的变量为 label、button、addr、index 和 filename$。

9 － 11 行

Sdim label,5
Sdim button,2
Sdim addr,5

这些行建立集合变量。例如，Sdim label,5 在变量命名的列表中分配空间存储 5 个元素，并通过对每个元素指定位标可对元素进行单独访问。标量数组和标量矩阵以类似的方式确定大小，不同之处在于数组和矩阵使用 DIM 命令，而且如果是确定矩阵大小，则需要列出两个自变量的大小。

12 － 16 行

label[1] = "Name"
label[2] = "Title"
label[3] = "Organization"
label[4] = "Street Address"
label[5] = "City, State, Zip"

这些为赋值语句的例子。每个语句为名为 label 的变量中的一个元素赋值。这些元素是 label[1]、label[2] 等。所赋的值为字符串 "Name"、"Title"、"Organization"、"Street Address" 和 "City, State, Zip"。字符串用于标记宏在屏幕上显示的对话框中的字段。

17 － 22 行

addr[1] = "Dr. Jean C. Doe"
addr[2] = "Laboratory Supervisor"
! addr[2] = "Laboratory Manager"
addr[3] = "Ident-Rite Analytical Laboratories, Inc."
addr[4] = "10001 Industrial Avenue"
addr[5] = "Wichita, CA 92001"

这些语句为每个地址元素赋值。每个元素出现在宏显示在屏幕上的对话框的各个字段内。

注意第 19 行通过在前面加入一个感叹号已变成了注释行。这是在不必完全删除指令的情况下而不执行该指令的一种简便方法。如果您认为应执行第 19 行而不执行第 18 行，仅需换一下 (！) 的位置，然后重新加载宏即可。

23 － 24 行

button[1] = "Save"
button[2] = "Cancel"

这些行为每个按钮元素赋值。这些值为宏显示在屏幕上的控制按钮的标签。

第 25 行

INPUT6 1, 5, prompt$, label, button, addr

这一行为调用 INPUT6 的命令，在屏幕上显示一个对话框。面板上包括编辑框和按钮。参数用于在调用中从宏向 INPUT6 命令发送数据，并按照如下所述方式返回宏。

参数 | 意义
1 | 需要带编辑框的对话框的信号。
5 | 指出需要多少个编辑框
prompt$ | 对话框标题。它是一个宏参数，作为参数通过宏传递给 INPUT6
label | 编辑框的标签集合
button | 对话框下部按钮的标签集合
addr | 编辑框中显示的数值集合，可被用户修改。

当下面的对话框显示在屏幕上时，用户可在每个编辑框内看到一个地址元素并可编辑这些数值。改变一个框的内容具有为相应的地址元素赋予新值的效果。这些新值一直保存到 INPUT6 被中断。这一作用是因为地址通过名字传递。所有其他参数通过值传递。

用户单击 Save（保存）或 Cancel（取消）来关闭对话框。当单击按钮后，INPUT6 将按钮数赋给全局变量 _Button，INPUT6 的调用结束。

第 26 行

IF _Button = 1 ! if user pushed the Save button

这一行是控制语句的例子。只有在 _Button 的值等于 1 时，它才会告诉命令处理程序在第 26 行和对应的第 40 行的 ENDIF 之间执行指令。

化学工作站为一个或多个全局变量赋值是很普通的。后面运行的宏和命令可以检查这些变量，并根据找到的变量值适应其操作。上面的 IF 语句是宏如何根据变量值（这里指 _Button）来确定执行哪一行的例子。有关在宏中使用全局变量的更多信息，请参阅第四章。

第 27 行

! Create a file to write the strings to

另一注释行。

第 28 行

filename$ = _ExePath$ "addrfile.txt"

这一行在名为 filename$ 的变量里存储一个字符串。等号右侧的表达式为字符串赋值表达的一个例子。_ExePath$ 为系统全局变量，它的值代表每个目录的路径。表达式为一个字符串的和,为 "addrfile.txt" 到 _ExePath$ 的值结束的链接。例如，如果 _ExePath$ 的值为 c:\MSDchem\msexe\，则 filename$ 获得 c:\MSDchem\msexe\addrfile.txt 的值。

第 29 行

OPEN filename$ FOR OUTPUT AS #1

该语句打开一个文件以便在其中写入数据。文件被打开，文件名储存在变量 filename$ 中。该语句也建立描述符 #1 作为文件名的同义字。

第 30 行

index = 1

这行初始化在下面的 WHILE 循环中用到的变量位标。

31 － 34 行

WHILE index <=5
PRINT #1, addr[index]
index = index 1
ENDWHILE

这几行定义了一个控制语句，即大家熟知的 WHILE 循环。在 WHILE 行和 ENDWHILE 行之间的语句反复执行，直至 WHILE 行中的条件为真。31 到 34 行的作用是将五个地址元素写入第 29 行打开的文件中。

第 35 行

CLOSE #1

该语句关闭文件。

第 39 行

ViewFile filename$

该语句调用宏 ViewFile。ViewFile 宏在 Data Analysis（数据分析）中定义。它将文件内容复制到 Notepad 窗口，以便用户能看到对话框的改变确实生效。

第 41 行

RETURN

RETURN 语句用来标识当前宏的末尾。如果其他宏调用上述的宏 Get_Address，命令处理程序则认为 RETURN 语句为中断执行 Get_Address 的命令，并在下一个指令中重新调用宏。


第四章 — 关于化学工作站宏的更多内容

本章更详细地讨论了化学工作站宏语言的各个方面。

加载、调用和删除宏

宏、参数和变量的命名

使用语句

使用参数

使用控制语句

使用逻辑表达式

运算符的优先次序


加载、调用和删除宏

习惯上将相关的宏集合一起保存在一个文件中。给予文件的名称应该包括自身的信息，以便可以提醒包含在其中的宏的目的。

任何命令处理器可执行宏。在每一个化学工作站应用中有一个独立的 CP：Top Level（顶部水平）、Tune（调谐）、Acquisition（采集）和 Data Analysis（数据分析）。可以从化学工作站应用程序的命令行加载和执行宏。如果命令行不能在应用窗口底部看到，请从所使用的 Control（控制）菜单选择 Cmdline on（打开命令行）。

另见

加载宏

嵌套宏的调用

存储器需要考虑的事项

有关正确执行的告诫


加载宏

MACRO 命令的语法是：

MACRO ["宏文件名"] [,GO]

如果指定了 GO，当文件加载后立即执行文件中最后一个宏。

如果在调用中没有指定文件名，将出现对话框进行提示。如果指定的文件名没有路径，路径将被假定为全局变量 _ExePath$ 的内容。如果文件的扩展名未被指定，将假定为“.MAC”。

如果从一个命令行重复调用 MACRO 命令，可使用 F3 功能键。它会重复调用所键入的最后的命令。

如果加载的宏包含超过 132 个字符的行，会产生错误并且不会加载宏文件（请参见本章后面的使用语句）。

示例

MACRO "C:\MSDchem\msexe\spcl_rpt.txt",GO
! loads all macros in the file
! C:\MSDchem\msexe\spcl_rpt.txt and executes
! the last one

MACRO "test_rpt"
! loads all macros in the file
! from the directory
! specified by the value of _ExePath$


宏的嵌套调用

宏在执行过程中能够调用并执行包含其他宏的文件。举例说明如下：

! start first file
! The name of this file is hello_1.mac
! It contains macros to be loaded and executed
! by the macro named Greeting
!
NAME Regular_hello
PRINT "Hello!"
RETURN

NAME Big_hello
PRINT "HELLO!"
RETURN

! end first file

! start second file

! The name of this file is hello_2.mac
! It contains the macro named Greeting.
!
NAME Greeting
PARAMETER all_caps DEFAULT 0
MACRO "C:\MSDchem\test_macs\hello_1" ! load the macro file
IF all_caps = 0 THEN
Regular_hello
ELSE
Big_hello
ENDIF
RETURN

! end second file

如果您用命令行调用、执行上面程序中名为 Greeting 的宏，而 Greeting 又将调用 hello_1.mac 文件中的宏，并基于 all_caps 中的值执行其中的一个宏。

用 RETURN 或 REMOVE 语句结束被其他宏所调用的宏。如果被调用的宏后面漏掉了 RETURN 或 REMOVE 语句，则系统不会执行调用程序中接下来的指令。养成在每一个宏后面以 RETURN 或 REMOVE 语句结尾的习惯。要做到这一点并不难，而且这样做会使得同一文件中宏之间的区分一目了然。

宏的调用链可以扩展到很多级。宏 A 可以调用宏 B，而宏 B 又可以调用宏 C，等等。调用链长度并没有具体的限制。系统资源不支持太长的调用链，但具体长度由很多因素决定。


内存要考虑的问题

可用于加载宏的内存量是有限的。应该安排将不必要的宏删去。许多大的系统宏编写来使 REMOVE 总是最后执行的一条指令。大的宏可以通过保留在内存中的小的宏在需要的时候加载和执行。

REMOVE 命令的语法是

REMOVE [宏名称 / 变量名称] [,...]

记住 MACRO 和 REMOVE 命令的区别：REMOVE 命令要求需要删除的宏的名称，而 MACRO 命令要求包含该宏的文件的名称。


关于正确执行的告诫

指定给宏的名称有时会引起如下所述的问题，影响宏的正确执行。对宏进行命名和调用时请遵守下列准则：

  • 请勿向宏指定与已有命令或宏相同的名称

  • 请勿使用宏名称的缩写来调用宏或命令

您可以检查在命令处理器中已使用的宏和变量名称的列表。您只需在命令行中键入 REMOVE。在出现的面板中浏览列表或打印其副本。类似地可通过键入 COMMANDS 查看命令和函数名称。尽管有些条目会出现在多个列表中，但每个命令处理器的列表是不同的。可用于所有程序的命令和函数作为 Common（公用）命令列于在线帮助中。

重复的名称

有时很难避免向两个宏赋以相同的名称。例如，建立宏时需要进行测试。通常会修改、测试多次。为每个版本起一个新的名称很不方便。

问题随之而来，“如果我加载的宏的名称与已有的宏同名，调用时会执行哪一个宏？”答案是：在任意数目的文件中如果加载的宏有两个或更多同名，则仅有一个是可调用的。对于名称出现在调用语句中的宏，被执行的宏是在最后加载的文件中出现的第一个宏。其他的宏将无法被访问（已删除），就像用 REMOVE 命令删除了一样，如果要使用这些宏则需重新加载。如果一个含有两个或更多同名宏的文件用 MACRO 命令加载，则只有重名的第一个宏是可调用的。如果两个不同文件中的同名宏被加载，则最后加载的文件中的宏是可调用的。

例如，如果一个创建的文件中含有如下的宏：

NAME Duplicate
ALERT "This is the first Duplicate.", 3
RETURN

NAME Duplicate
ALERT "This is the first Duplicate.", 3
RETURN

而且如果加载文件后对 Duplicate （复本）进行调用，屏幕中出现的 ALERT（警告）面板将显示字符串“This is the first Duplicate.（这是第一个复本。）”。但如果第一个宏被置于文件 1 中，第二个置于文件 2 中，并且文件 1 先加载；则对 Duplicate （复本）的调用将包含提示 “This is the second Duplicate.（这是第二个复本）”。

注意

此类影响并不限于用户宏。如果加载了同名的不同宏，可能删除一个重要的系统宏。此外，宏会屏蔽同名的命令。该命令未被删除，但不会再被调用。因为宏将代替它被执行。发生这种情况时，化学工作站的操作可能出现异常，因为命令和宏的调用对所有的系统操作都有效。

下面的宏将屏蔽 VARLOCK 命令：

! Masking Test -- test only in an application that is
! not currently being used for anything. Remove the macro
! after the test or exit the application and restart it.
!
NAME Varlock
PRINT "This is a message from the macro named Varlock."
RETURN

VARLOCK 是化学工作站的一个命令名，用于打开或关闭变量锁定。通常执行该命令时键入 VARLOCK 1 打开锁定，或 VARLOCK 0 关闭锁定。执行命令时，提示行中会显示“Variable locking is on（变量锁定打开）”或“Variable locking is off（变量锁定关闭）”。

加载上面的宏后，如果试图执行 VARLOCK 命令实际上只会执行宏，并在提示行中显示“This is a message from the macro named Varlock.（这是来自于 Varlock 宏的一条提示）”。即使调用中包含参数，而且宏未说明此参数，命令处理器仍会认为 VARLOCK 1 是对宏的调用。

如果使用 REMOVE 命令删除宏，则被屏蔽的命令将解除屏蔽。因此在加载上面的宏后，在命令行中键入 REMOVE Varlock 可使 VARLOCK 命令解除屏蔽。

下例说明了函数调用被认为是宏调用的缩写时，函数调用如何引起误操作执行（请参见下面的缩写）。从这个示例中得到的经验是：给宏命名时必须注意确保它们与系统命令、宏和函数均不重名！

! Test 2
NAME Abs_SPOOF
PRINT "This is the Abs_SPOOF macro."
RETURN

! Test 3
NAME Call_abs
PARAMETER number
PARAMETER number
RETURN

加载 Abs_SPOOF 后，在命令行中键入 abs(-32)，正常情况下在提示行中应写上 32（-32 的绝对值），而实际上却调用 Abs_SPOOF。这是因为 ABS 函数的名称是 abs_SPOOF 的缩写，而且如果命令行以名称开始，CP 会优先考虑宏名称的缩写而不是函数的全名。宏中有用的函数调用永远不会出现在命令行的开头。宏 Call_abs 有相同的效果。调用它会导致调用 abs_SPOOF。您可在命令行中键入 =ABS(-32) 代替 ABS(-32) 来避免这一问题。

缩写

化学工作站的老版本允许您使用两个或更多首字符的名称缩写来调用宏和命令。例如，在命令行中键入 gr 可执行名为 Greeting 的宏。在 G1034C 中缩写仍然有效，但我们不鼓励使用缩写。尤其在宏中，应使用命令和宏的全名来消除实际上调用的是哪个命令或宏的混淆，确保执行正确的命令或宏。请改掉使用缩写的习惯，因为化学工作站将来的版本可能不支持缩写。

命令处理器保留其当前定义的宏、命令、变量和函数的各自名称列表。每个列表按字典顺序排列（依据 ASCII 码，即美国信息交换标准码）。

当 CP 对宏中以名称起始的命令行进行解释时，它首先寻找名称后的等号来检查该行是否为赋值语句。如果没有发现等号，CP 下一步将试图确认该命令行是对宏或命令的调用。这通过检索上述列表中的匹配名称来实现。列表按如下顺序进行检索：

  • 宏列表中的完全匹配

  • 命令列表中的完全匹配

  • 宏列表中至少两个字符的缩写匹配

  • 命令列表中至少两个字符的缩写匹配

如果找到匹配，检索停止，CP 试图执行匹配的宏或命令。如果未找到匹配，CP 试图将命令行解释为一个表达式，行起始处的名称可被解释为变量或函数名。

检索过程的本质决定了使用缩写来调用宏或命令会产生无法预料的结果。由于有人加载新的宏，今天可正常使用的缩写明天就可能变为无效。加载了名为 Gr 或 Greetb 的宏后，Greeting 无法被缩写为 gr。同样的问题在使用缩写的命令名时也会出现。

下例说明了使用缩写时如何可能引起执行误操作：

! Abbreviation Test 1
! If you run this test, be sure that the Varlock macro
! listed above is not loaded too.
!
NAME VARL
PRINT "This is a message from the macro named Varlock."
RETURN

如果加载了 VARL，使用名称为 va、var 和 varl 的调用将执行 VARL，尽管在加载前它们会执行 VARLOCK 命令。另一方面，使用名称为 varlo、varloc 和 varlock 的调用仍将执行 VARLOCK 命令。


宏、参数和变量的命名

程序中的名称，又名标识符，在多数程序设计中占有相当重要的地位。编程人员用于命名文件、宏、变量和参数对象的标识符应该简单、可读性好、易于记忆，并且标识符应该一目了然地表示它所描述的对象。与下面的例子一样，标识符应根据对象本身的意义来编制：

Sum

Peak_Value

X_Coord

Get_Address

Compound_Name$

Index

  • 宏的标识符应以字母或下划线 (_) 打头，仅含字母、数字和下划线，可以选择用美元符号 ($) 拖尾。

  • 变量和参数的命名规则相同；美元符号不允许使用，除非是最后一个字符。

  • 标识符以下划线打头的变量或参数是保留变量。除非使用 VARLOCK 命令关闭变量锁定，否则这些变量不能被赋值。

  • 数组变量名不必以美元符号结尾，与先前所作的修正相同。这条约定可使得宏的阅读人员更易于辨别哪个标识符指的是数组。

另见

标识符长度限制

大小写不区分

重名


长度限制

限制宏、参数和变量的名称到 15 个字符。命令处理器将不分配更长的名称。如果声明名称多于 15 个字符，在最后的名称没有不合乎规定的字符的前提下，CP 将只分配前面 15 个。例如，如果执行下面的命令行，命令处理器将在消息行显示 1。

LOCAL start0123456789x, start0123456789y
start0123456789x = 0
start0123456789x = 1
PRINT val$(start0123456789x)

因为对于 CP 来说，两个标识符都将是 start0123456789。


大小写不区分

命令处理器在处理宏、命令、函数、变量和参数时不区分字母大小写。这意味着 CP 对于这些标识符中的大小写字母不加以任何区别。对 CP 来说，具有声明名称 GET_ADDRESS，get_address，或 Get_AddREss 的宏的名称均完全相同。


复制名称

由于对两个宏使用相同名称或宏名称与命令或功能相同而引起的问题在本章前面的加载、调用和删除宏中已经讨论过。变量重名的问题将会在本章后面的使用变量中讨论。作为通用规则，在命名宏和变量时记住下面这些警告：

  • 如果加载了与重要的系统宏同名的另一条宏，该系统宏将被删除。

  • 一条宏会屏蔽一条同名的命令，造成严重和广泛的执行错误。

  • 如果宏中使用的全局变量与重要的系统变量同名，两个变量会成为同一个。如果化学工作站访问在一个系统变量中存储的伪值，任何由该宏或该宏调用的宏对该变量造成的改变都会导致异常结果。


使用语句

通常情况下，要求所有语句位于一行上。同一行上可执行语句后面的注释可能会被看作是一种小范围的例外。控制语句看起来好像是一种例外，但实际上并非如此。控制语句是通过调用原始命令（如 IF、ENDIF、WHILE 和 ENDWHILE）来实现的，这些命令需要放在一行上。

无论如何，命令处理器都有可能误解或无法解释未在一行上清晰且正确输入的语句。如果宏中的行太长，则无法执行该行，行长度不应超过 132 个字符。

只要名称或文字中不出现空格，语句中插入的多余的空格或 tab 字符对语句的解释就没有任何影响。例如：

43 5

不同于

435.

如名称

my_array

不能写作

my _array。

使用空格和缩进可以使宏具有更高的可读性。清楚起见，请缩进所有控制语句中的嵌套语句。

在某些示例中必须有空格，以便命令处理器可以识别符号之间的界线。例如：

a>2 OR 2>c

不能写作

a>2OR2>c

因为这样会造成识别逻辑连接词 OR 的困难。（CP 将忽略第二个表达式中 a>2 之后的部分）。

另见

注释语句

声明语句

赋值语句


注释语句

注释语句以一个感叹号（！）开头，可出现在宏的任意一行。感叹号及该行中其后的所有字符被命令处理器忽略。注释对于那些想要学会如何正确使用宏、对宏进行问题诊断、修改宏、或拷贝一部分宏到新宏中的人来说是至关重要的。甚至对于宏的作者来说，注释也是有用的，因为编写宏时显而易见的内容到后来需要修改或增强宏功能时就可能变得不明显了。

每个宏应该以注释开始，解释该宏的用途以及描述正确操作所需的任何输入或条件。宏还应包括一些注释用来解释其中复杂、模糊或难懂的部分。

测试或编辑宏时，在行的前面插入感叹号将它们“注释出来”是很有用的，否则这些行就会被执行。例如，第三章中宏示例中的下面行已被注释出来。

! addr[2] = "Laboratory Manager"


说明语句

一条宏说明语句的格式为：

NAME 标识符

宏中的第一条可执行语句的要求如下。不支持宏说明语句嵌套。例如，如果下面的命令行出现在文档中并通过 MACRO 命令加载后，命令处理程序在加载时将把第二条 NAME 语句作为内部宏的开始信号同时也是外部宏的结束信号。当调用外部宏时，只执行第一条 ALERT 命令。

! This macro has an ERROR
!
NAME Outer_macro
ALERT "This is before the inner macro!",3

NAME Inner_macro ! ERROR
ALERT "Hello, I am the inner macro!",3
RETURN

Inner_macro
ALERT "This is after the inner macro!", 3
RETURN


赋值语句

赋值语句的格式为：

变量指定 ＝ 表达式

变量指定可以是任何变量或参数的名称。可以是标量数组、标量矩阵或集合中的选定元素。例如，一个宏可以以如下形式开始：

NAME my_macro
LOCAL my_array, my_scalar, my_other_array
DIM my_array, 2
DIM my_other_array, 2
my_array[1] = 27.3
my_array[2] = 39.112 * my_array[1] exp(14)
my_other_array = my_array
my_scalar = my_array[2]

赋值语句右端表达式的值是下列类型时没有限制：标量、字符串、标量值域、标量数组、标量矩阵或集合。一个变量可以先被赋予一个某种数据类型的值，然后被赋予另一个不同数据类型的值。命令处理器可以有效地给变量重新分配存储器，因此在执行赋值时可自动转换其数据类型。由于这种转换数据类型的方式可能会使人们在阅读宏时产生混淆，因此尽量对每个变量仅使用一种数据类型。


使用变量

使用变量

全局变量

系统全局变量

本地变量

标量

标量范围

字符串

标量数组和标量矩阵

集合


全局变量

在被定义因次和赋值前没包含在 LOCAL 说明中的变量会缺省成为全局变量。

注意

如果宏中使用的全局变量与重要的系统变量同名，两个变量会成为同一个。如果化学工作站访问在一个系统变量中存储的伪值，任何由该宏或该宏调用的宏对该变量造成的改变都会导致异常结果。

尽量在宏中使用全局变量。如系统全局变量中所述，任何全局变量名称都应该小心选择。

下列例子显示说明全局变量的不同方式。如果全局变量尚不存在，在为它们赋值后即进行有效的自动说明。另外，全局标量数组、标量矩阵和集合能够通过定义因次后进行说明。

NAME Var_test

LOCAL local_var, local_array

DIM local_array, 12
DIM global_array, 12 ! declares global_array

local_var = 10 * 10.00
local_array[3] = 14.312

global_var = 20 ! declares global_var
global_array[12] = -8.910
global_arr2 = global_array ! declares global_arr2
RETURN

变量作用域的差异会影响到它是否能够被访问。如果使用一条命令行来加载一个包含上面的宏的文件，执行 Var_test，并在命令行上键入 local_var。故障提示 'Undefined symbol:local_var'在提示行上打印出来。所有全局变量在定义他们的宏执行完成后被 CP 清除。如果键入 global_var 和 global_array[12]，提示行上会打印出 20 和 -8.91，因为宏中的下列命令行可以说明全局变量，这独立于宏而存在。

DIM global_array, 12
global_var=20

如果键入 global_arr2[12]，值 -8.91 会再次显示，因为命令行

global_arr2 = global_array

有使 golbal_arr2 成为全局变量的效果。


系统全局变量

很多化学工作站命令为一个或更多全局变量赋值，作为传递结果或其他信息的一种方式。后面执行的宏和命令可以检查这些变量并通过变量值判断它们的行为。

用户宏需要返回这些系统变量的值以便能完成预期的任务。同时，许多变量值被用户宏改变，仅仅因为被宏调用的命令改变了它们的值。

注意

当编写宏时，一定要确定您理解了宏中使用的重要的系统变量的涵义。这些变量可能包含仪器状态或分析结果的重要信息。如果要使您的宏直接改变系统变量的值，一定要特别小心，因为这样做可能使仪器失控，甚至损坏。

这里是使用宏之前需要仔细检查的一个清单：

  1. 制定一个列表，列出宏将改变的所有系统变量，无论是直接或间接的。欲了解那些变量可能被间接的改变，遵循在宏中生成的宏调用链。调用链是指当宏 A 调用宏 B ，而宏 B 调用宏 C，依此类推时，将发生什么。仔细读您的宏和所有调用链中的宏。寻找对系统变量的直接改变。寻找所有被调用的命令并使用这些命令的在线帮助了解它们设定了哪些变量。

  2. 阅读在线帮助中标题中有 Variables（变量）的部分的副标题以确信您知道哪个应用程序和命令使用了在您的宏中可能改变的系统变量。同时，读这些命令的在线说明决定在您的宏中变量的设置如何影响它们的操作。

  3. 欲查看全局变量和当前命令处理器中定义的宏的列表，您可以在命令行输入 REMOVE。已经创建的变量和宏将同化学工作站软件的标准部分一起列出来。可以用鼠标单击变量名查看简单变量的数值。


局部变量

请尽可能使用局部变量而非全局变量。全局变量往往浪费计算机内存，因为他们是永久性的。

注意

如果在宏中使用的一个全局变量和一个重要的系统变量同名，那么两个变量是相同的。如果化学工作站访问存储在一个系统变量中的伪值，由这个宏或它调用的宏作出的对该变量的任何更改都可能导致异常的结果。

相反，当一个赋予局部变量的名称与系统变量相同时，系统变量通过屏蔽被保护起来。

局部变量声明的形式为：

LOCAL 变量名 [, 变量名] [,...]

通常，只有声明局部变量的宏可以访问它。唯一的例外是一个调用主可通过利用数值或名称将变量作为参数传递而使局部变量被调用者访问。调用主无法访问调用者的局部变量。

LOCAL 声明中的变量列表不可被延续到新的一行，但如下所示，在一个宏中可以有几个 LOCAL 声明。

LOCAL label, button, addr
LOCAL index, filename

局部变量按下列方式被初始化：

  • 如果标识符以一个 $ 结束，变量被初始化到一个空字符串。

  • 如果标识符以其他形式结束，变量被初始化到 0。

假如每个局部变量使用前都作了声明，可将 LOCAL 声明放到宏的任意一行。局部标量数组、标量矩阵和集合变量在它们用 DIM 命令或 Sdim 宏设定维数前以及向它们或其元素赋值前必须在一个 LOCAL 语句中作出声明。在被声明为局部之前设定维数或赋值的变量将缺省成为全局变量。

通常，好的编程风格规定将所有 LOCAL 语句放置于宏起始位置附近，位于任何赋值、控制或调用语句之前。同时应尽可能将所有用于局部变量的 DIM 和 Sdim 语句紧随最后的 LOCAL 语句来放置。有时一个宏将需要进行计算以确定一个数组、矩阵或集合中所需元素的数目，自然进行计算的说明必须在目标的设定维数之前出现。

如果宏声明一个与全局变量同名的局部变量，两个变量是不同的，局部变量将屏蔽全局变量。换言之，当名称在宏中被使用时，该名称指的是局部变量而非全局变量。这种屏蔽的效果通常是有益的。程序员可为局部变量自由选择一个方便的名称，而不必考虑会影响重要的系统变量。


标量

标量用于表示实际值。标量直接量可以采用十进制记数法或科学记数法。在尾数和指数中，允许出现正负号。整数可以写成含或不含小数点的形式。以下是一些表示正确的标量文字示例：

5

5.

1743.245

1.743245e3

-2.931

14

220

2.2E2

-.345

-345E-3

还可以与基本的代数运算符结合起来表达标量：+（加），-（减），* （乘），/（除）；以及化学工作站所有的实际值值方程。标量还能用关系运算符进行比较，这些关系运算符包括：>（大于），<（小于），>= （大于或等于），<=（小于或等于），<>（不等于），=（等于）。要获得更多信息，请参见使用逻辑关系式和运算符优先次序。


标量序列

标量序列变量用于代表一组的数字，从下限变化到上限。下限与上限本身就是标量值域的一部分。

指定标量值域值的格式如下：

表达式:表达式

表达式的唯一限制就是它们必须为实际值值。例如，

range1 = small/2:abs(est)1

是对值域值的一次有效赋值。值域值在冒号附近下限与上限可以用两种次序书写。不过无论采用哪种次序进行书写，值域值都相同，有相同的下限和上限。

运算符能够合并两个值域值。Range1 range2 是 range1 和 range2 中包含的最小值域值。特别地，若 range1 有下限 L1 和上限 U1 ；而 range2 的下限为 L2 ，上限为 U2 ；那么 range1 range2 的下限就是 L1 和 L2 的最小值，range1 range2 的上限就是 U1 和 U2 的最大值。

标量运算符值域也能与相关的运算符进行比较： （不等）， 和 = （相等）。如果两个标量值域的下限与上限都相同，那么两个标量值域相等。否则，他们就不相等。标量值域的示例如下：

(4.124:8.4) (5.7:9.2) = 4.124:9.2

4.124:9.2 = (8.4:4.124) (5.7:9.2)

(1:2) (3:5) = 5:1

(1:2) (3:5) <>1:6

上面的表达式中需要添加圆括号，因为 () 运算符的优先级数比 (:) 运算符的要高。要获得更多信息，请参见本章末尾部分的运算符优先次序。


字符串

字符串文字周围要求加引号。在 MS 化学工作站的上一个版本中，引号为可选的。

字符串文字可以写成两种方式：

  • 形式 A："X" 双引号 X 双引号

  • 形式 B：'X' 开始单引号 X 结束单引号

在形式 A 的字符串内，单引号没有特定涵义而一行中的两个双引号说明其使周围成为一个整体。

形式 A 示例

! Prints Hello
!
phrase1$ = "Hello"
PRINT phrase1$

! Prints "Hello"
!
phrase2$ = """Hello"""
PRINT phrase2$

! Prints "Hello," he said, "I must be going."
!phrase3$ = """Hello,"" he said, ""I must be going."""
PRINT phrase3$

在形式 B 字符串里，双引号没有特殊涵义但是单引号说明被包围的是一组字符串并且必须象括号一样平衡。这种字符串文字在传递一个文本将在后面执行的参数时非常有用。

形式 B 示例

! First example
! Prints "hello," he said, "I must be going."
!
PRINT `"hello," he said, "I must be going."'

! Second Example
!
! Passes a parameter that is to be executed.
! The imbedded command takes a parameter that
! requires quotes.
!
NAME DoThis
PARAMETER text$
EVALUATE text$
RETURN

NAME Example
DoThis `macro `myfile',GO'
RETURN

可以通过加一个 [] 算符从字符串变量中选择一个子字符串。[] 和 : 算符一起使用可以从字符串变量中选择任意一个子字符串。例如，程序行为：

sentence$ = "Macros are fun!"
ALERT sentence$[9], 3
PRINT sentence$[12:15]

在屏幕上显示 ALERT 面板，上面打印上一个字符 r，同时在提示行上打印 fun!。这种选择不能在字符串文字上进行，下面是一个不能工作的例子：

! These instructions have errors.
!
ALERT "Macros are fun!"[9], 3
PRINT "Macros are fun!"[12:15]

算符连接字符串。例如，

sentence$ = "Macros are fun!"
PRINT sentence$[1:11] 'a lot of ' sentence$[12:15]

打印

Macros are a lot of fun!

在一行提示行。文字可以和算符一起使用。

字符不能和象 ＝ 或 < > 相关的运算符一起用，而函数 EQSTR（）可以被使用。函数语句为

EQSTR ("string1", "string2")

用作参数的字符串文字可以是形式 A 或 形式 B。如果两个字符串相同，函数值返回 1，否则返回 0。函数不区分大小写。例如，

eqstr ("ABC", 'abc')

返回 1。

没有字符串为空，即包含 0 个字符。空字符串可以写成如下形式：

""

空字符串可以与 0 一样使用。例如，

NAME Do_panel
PARAMETER value_known DEFAULT 0
LOCAL part1$, part2$, part3$
part1$ = "The value is "
IF value_known = 1 THEN
part2$ = ""
ELSE
part2$ = "un"
ENDIF
part3$ = "known"
ALERT part1$ part2$ part3$, 2
RETURN

将打印

The value is known

或

The value is unknown

在 ALERT 面板中，由参数 value_known 的值决定。


标量数组和标量矩阵

用 DIM 命令定义标量数组和标量矩阵的维数。DIM 命令的调用格式为：

DIM 标量数组名,整数

或

DIM 标量矩阵名,正整数, 正整数

下例定义了标量数组变量的维数，保存 125 个标量，位标从 1 到 125。

DIM my_array, 125

下面的语句定义了标量矩阵变量的维数，保存 1200 个标量，第一个位标（行位标）从 1 到 30，第二索引（列位标）从 1 到 400：

DIM my_matrix, 30, 40

定义语句中的维数大小参数可以是下例中的表达式。定义对象大小的可以是变量，也可以是参数。

DIM my_array, 2 * size

使用选择运算符 [] 来储存或检索数组或矩阵中的元素。下例给 my_array 中的一个元素赋值。注意选择运算符用于检索赋值语句右部分的矩阵元素，储存左部分的数组元素。

my_array[size4] = my_matrix[abs(t),j-2] my_matrix[i,23]

以上示例也说明了用于选择的位标可为表达式。只要表达式的值四舍五入后得到的整数在数组定义的维数范围内，该表达式就是允许的。

标量数组可以直接通过下例中的运算符直接相加：

z_array = x_array y_array

标量矩阵不能以这种方式进行相加。用 WHILE 循环同时给两个标量矩阵添加一个元素。有关更多信息，请参见“使用控制语句”。

数组运算符也可以直接用 = 进行比较，如下例所示。

IF x_array = y_array
ALERT "They are: Equal.",3
ELSE
ALERT "They are: Not Equal.",3
ENDIF

IF x_array = y_array
ALERT "They are: Not Equal.",3
ELSE
ALERT "They are: Equal.",3
ENDIF

标量矩阵不能以相同方式进行比较。用 WHILE 循环同时比较两个标量矩阵的一个元素。有关更多信息，请参见使用控制语句。


集合

一个集合变量由 Sdim 宏建立。语句形式为：

Sdim set name, positive integer

除了关键字不同外，度量和选择集合变量的规则与标量数组类似。有关更多的信息，请参见标量数组和标量矩阵。

Sdim 语句中的正整数应大于 1。少于两个元素的集合还原为简单变量。选择算子不能用于访问单元素集合的元素。例如，下面的 Sdim 语句语法上是正确的，但赋值是错误的。

Sdim my_set, 1

! ERROR: This is a disallowed assignment operation
!
my_set[1] = "Hello."

然而，

my_set = "Hello."

是被允许的并使 my_set 为一个简单的字符串变量。

与标量数组和标量矩阵元素不同的是，标量数组和标量矩阵只能赋标量值，而集合元素可以指定下列任意类型的数值：标量、标量序列、字符串、标量数组、标量矩阵。不允许将集合的值赋给一个集合元素。

集合通常通过为每个元素分配一个字符串值用作字符串数组。


使用参数

形式参数与实际参数

按值或按名称传递参数

参数与调用


正式和实际参数

实际参数是在一次调用中指定的参数。正式参数是在被调用者中作为实际参数占位符使用的参数。实际参数通常称为实参数。正式参数有时称为虚参数。例如，下面的第 3 章中的例子，宏中的命令行定义了一个名为 Get_Address 的宏，其中含有一个名为 prompt$ 的正式参数。

NAME Get_Address
PARAMETER prompt$ DEFAULT "Enter up to 5 lines"

宏中的语句，如：

25 INPUT6 1, 5, prompt$, label, button, addr

在他们指到该参数时使用了正式参数名称，prompt$。对该宏的调用，如：

Get_Address "Tell me a little about yourself."
Get_Address prompt83$
Get_Address word[4] word[29]

指定了一个实际参数。


通过值或通过名称传送参数

通过数值或通过名称传送参数

通过数值和通过名称传送参数之间的混淆是程序中最常见的故障源。下面是典型症状： 宏在调用另一个宏时发生错误。所有调用者和被调用者中的指令都被检查和再检查。他们看起来都完全正确，然而调用者却没有产生预期结果。当这种情况发生时，应该检查是否应该由名称传送的参数被通过数值传送。请记住当需要参数在调用后与调用前的数值不同时，它必须通过名称传送。

一个通过名称传送的实参数必须是一个变量。调用开始执行时，命令处理程序认为这个变量与正式参数一样。然后命令处理程序执行被调用者中的指令。由于身份相同，每一条指令中对正式参数的引用实际上被作为变量的引用。特别是，每条被调用者中分配值给正式参数的的指令实际上将值分配给变量。因此，变量在调用后就能得到一个不同的值。

而命令处理程序评估通过数值传送的实参数，并将数值复制一份存储在内存的特定位置。被调用者仅能访问该复制的数值。所有由被调用者执行的改变正式参数的指令实际上仅改变该复制的数值。调用的执行结束时，没有任何数值被写回。即使实参数是一个变量，参数的值不会被写回该变量。因此，变量在调用前后的数值总是一样。

您可能会疑惑是否所有参数都应该通过名称传送。答案是“否”，因为那就意味着任意表达式永远不能作为参数使用。


参数和调用

如果要把参数传送给宏，必须在单独的 PARAMETER 语句中说明。PARAMETER 语句必须是 NAME 语句后的第一条可执行语句。下列类型的数值和变量可以作为参数传输：标量、标量范围、字符串、标量数组、标量矩阵和集合。不允许通过名称传送数组、矩阵和集合的元素。

参数语句的格式为：

PARAMETER 参数列表

参数列表代表由逗号隔开的一系列参数。列表的每个元素必须匹配下列模式之一：

模式 1：正式参数名称

模式 2：正式参数名称 DEFAULT 表达式

模式 3：正式参数名称 BYNAME 单一标识符

要通过数值传送参数而不指定一个缺省值，使用模式 1。要通过数值传送参数并指定一个缺省值，使用模式 2。要通过名称传送参数使用模式 3。模式 3 需要您指定一个缺省值。

合乎规定的 PARAMETER 说明的示例：

! using patterns 3 and 1
PARAMETER my_array BYNAME z_array, length

! using patterns 3, 2, and 2 again
PARAMETER my_array BYNAME z_array, length DEFAULT 10, format DEFAULT portrait

进行调用时，确认将参数以正确顺序排放。一些参数为可选项。可以忽略任何已使用了缺省值的参数。必须输入逗号作为占位符，这样剩下的参数才不会被错误编译。例如，如果

NAME Calc_volume
PARAMETER height, width DEFAULT 350, depth

是一个宏的首两行，然后一个省去 width 参数的正确调用将是：

Calc_volume 89,,240

width 假定为缺省值 350，height 和 depth 编译为 89 和 240。如果调用以这种方式进行：

Calc_volume 89,240

height 将设定为 89，width 为 240，而 depth 参数将为缺项。

如果宏开始

NAME Calc_volumePARAMETER height, width DEFAULT 350, depth DEFAULT 240

然后由于所有 height 之后的参数都有缺省值且被省略掉因此下列调用被允许。

Calc_volume 89

如果省略了一个没有缺省值的数值参数且被调用者作为一个标量使用，效果和缺省值为 0 相似。类似的，如果参数作为字符串使用，它缺省为空字符串。

当参数为标量数组、标量矩阵或参数时，在将参数名称放到参数说明或调用中时不要包含方括号。方括号为选项算符且只有访问个别元素时才能使用。在下列正确的示例宏中，方括号没有出现在正式参数 (some_array) 或缺省变量 (xx_array) 中。

NAME Test_A
PARAMETER some_array BYNAME xx_array
PRINT val$(some_array[4])
RETURN

在上例中方括号在第三行中用来选择 some_array 的第四个元素。

下面对于上述宏的调用中，方括号不出现在实际参数 (my_array) 中。

Test_A my_array

不要假定上面的规则即是暗示了方括号永远不在 PARAMETER 语句或调用中出现。该规则只在参数的数据类型为标量数组、标量矩阵或集合时才有用。在下例中，Test_B的正式参数是由数值传送的标量：

Test_B my_array[3]

下面是 PARAMETER 语句中方括号的合法使用：

NAME Test_C
PARAMETER a_scalar DEFAULT my_array[3]

一个通过名称传送的实际参数需要由一个简单的标识符指定。尽管从数组、矩阵或集合中选定的元素是一个变量，但它不能通过名称传送。只有可由调用者访问的局部变量、全局变量和正式参数的简单名称是被允许的。同样的规则也适用于 PARAMETER 语句中的关键词 BYNAME 后给出的标识符。如果实际参数没有在调用中被指定，命令处理程序会假定它是和该标识符有关的变量。

通过数值传送的参数限制很少。如果调用者可以判断一个表达式且数据类型适合，就允许此表达式。同样的规则也适用于 PARAMETER 语句中的关键词 BYNAME 后给出的缺省表达式。

开始时，要认为被调用者的 PARAMETER 语句中指定的缺省值必须指定调用者可以访问或判断的变量或表达式且被调用者不必能直接访问或判断它们，这一情况看起来似乎有些难以理解。如果将缺省值想成 CP 可以填进调用中留下的空白处的东西似乎更容易理解。他们和任何实参数有相同的状态。被调用者对他们的访问由调用时正式参数和实际参数的识别来安排。如果试图让宏进行一个一般任务并在不同时刻被许多不同的宏调用，则要确认缺省值对所有依赖他们的调用者都有效。

下面的示例宏示例说明了通过名称和通过数值调用的参数的区别。要运行这个示例，加载它并执行 Caller。

NAME PassByNameTest
PARAMETER a DEFAULT "", b BYNAME zzz
A = "New Value for A"
B = "New Value for B"
RETURN

NAME Caller
LOCAL a, b, zzz, result
a = "Old Value for A"
b = "Old Value for B" !The first call to PassByNameTest uses the defaults.
! The local parameter zzz declared here in Caller
! becomes the actual parameter corresponding to b.
!

PassByNameTest
! The ALERT command below draws a panel on the screen
! with the value of the string zzz written in it.
! Since zzz was passed by name, the string that
! PassByNameTest assigned to it ("New Value for B")
! is still its value now, after the call to
! PassByNameTest ended.So "New Value for B" is the
! string the user sees in the panel.
!

ALERT "ZZZ = "zzz,3
! The next call passes a by value and b by name.
! After the call, only b is affected by the assignments
! done in PassByNameTest.
!

PassByNameTest a,b
! The SPRINT command assigns a formatted string
! to the local variable named result."A = %/B = %"
! is the format image string.Result will be assigned
! the string that is obtained from the format image
! string by placing the value of a where the first %
! is, a carriage return where the / is, and the value
! of b where the second % is.
! SPRINT result USING "A = %/B = %",a, b
! Since the parameter a was passed by value, the call to
! PassByNameTest has not changed a. Thus it still
! has the value it received in the assignment at the
! beginning of this macro ("Old Value for A").But b
! was passed by name and assigned a value in the call
! to PassByNameTest, and it retained that value
! ("New Value for B").Therefore, these are the
! two strings the ALERT command writes in the panel.
!

ALERT result,3

RETURN

这是一个进一步扩展的示例说明了可以和不可以通过参数传递的事物的范围：

! Third_mac is called by Second_mac
!
NAME Third_mac
! Note The default declared here in the callee Third_mac
! is Second_var$, a variable accessible by the caller,
! Second_mac.The callee is not required to have direct
! access to the default parameter.
!!
PARAMETER Th_name_parm$ BYNAME Second_var$
! This assignment has real effect on whatever variable
! is passed in as the actual parameter.
!
Th_name_parm$ = "The value Third_mac assigns."

RETURN

! Second_mac is called by First_mac
!
NAME Second_mac
PARAMETER Sec_val_parm$, Sec_name_parm$ BYNAME First_var2$
LOCAL Second_var$, Second_set
Sdim Second_set,2
! Start by assigning a value.This value is
! going to be changed by the call to Third_mac below.
!
Second_var$ = "The value Second_mac assigns."
! using a local variable of Second_mac as an actual
! parameter for Third_mac.Any global variable would
! be allowed too.
!
Third_mac Second_var$
! Since the variable is passed by name, the call to
!Third_mac has changed the value of Second_var$.The
! value now stored there is
! "The value Third_mac assigns."
!
ALERT "The string in Second_var$ is:" Second_var$,3
!
! Similar cases with different kinds of actual parameters used:
!
! using a value parameter of Second_mac as an actual
! parameter for Third_mac
!
Sec_val_parm$ = "The value Second_mac assigns."
Third_mac Sec_val_parm$
ALERT "The string in Sec_val_parm$ is: " Sec_val_parm$,3

! using a name parameter of Second_mac as an actual
! parameter for Third_mac
!
Sec_name_parm$ = "The value Second_mac assigns."
Third_mac Sec_name_parm$
ALERT "The string in Sec_name_parm$ is: " Sec_name_parm$,3

! using the default parameter.It could have been
! any of the actual parameters specified in calls above.
!
Second_var$ = "The value Second_mac assigns."
Third_mac
ALERT "The string in Second_var$ is:" Second_var$,3
!
! This illustrates something you cannot do.
! Second_set[1] = "The value Second_mac assigns."

! ERROR:attempting to use an element of a set
! as a byname parameter.The CP will
! only allow a simple identifier.
!
!!Third_mac Second_set[1]
! Since no call to Third_mac changes Second_set[1]
! The ALERT panel displays
! "The value Second_mac assigns."
!
ALERT "The string in Second_set[1] is: " Second_set[1],3
RETURN

NAME First_mac
LOCAL First_var1$, First_var2$
First_var1$ = "The value First_mac assigns."
First_var2$ = First_var1$
! The second argument is omitted in the call to
! Second_mac.Therefore the default specified after
! the BYNAME in Second_mac is assumed to be the
! argument (it is First_var2$).
!

Second_mac First_var1$

! Since First_var1$ was passed by value, it still contains
! the same value it did before the call to Second_mac.The
! panel put up by the ALERT command below will say "The
! string in First_var1$ is:The value First_mac assigns."
!
ALERT "The string in First_var1$ is: " First_var1$, 3

! Since First_var2$ was passed by name, it was changed.
! Second_mac changed it, and then passed it through to
! Third_mac, where it was changed again.The panel put
! up by this ALERT command says "The string in First_var2$
! is:The value Third_mac assigns."
!

ALERT "The string in First_var2$ is: " First_var2$, 3
! Since the first parameter of Second_mac is a value parameter,
! we can make the following call.
! Second_mac "Twas" " brillig and the slithey " "toves..."
RETURN


使用控制参数

RETURN 和 REMOVE

IF-THEN-ENDIF

IF-THEN-ELSE-ENDIF

WHILE-DO-ENDWHILE

ON_ERROR


RETURN 与 REMOVE

RETURN 语句的格式简单，为：

RETURN

RETURN 的作用之一就是中止宏的执行。如果出现 RETURN 的宏被另一个宏调用，那么，RETURN 将使得调用程序在调用该宏后，恢复执行下一条指令。在下面的示例中，执行调用程序，在 ALERT 语句后，将命令处理器的控制权交给了被调用程序。若被调用程序末端没有 RETURN 语句，命令处理器的控制权将不会返交给调用程序，并且被调用程序中的第二个 ALERT 语句不会执行。

NAME Callee
ALERT "Hi, I am the callee.",3
RETURN

NAME Callee
ALERT "Hi, I am the callee.",3
Callee
ALERT "Hi, I'm back because of Callee's RETURN.",3
RETURN

RETURN 也可以出现在宏的中部，来中止执行宏的剩余语句，如以下示例所示：

NAME Big_switch
PARAMETER setting

IF setting = 1 THEN
Do_job_1
RETURN
ENDIF

IF setting = 2 THEN
Do_job_2
RETURN
ENDIF

IF setting = 3 THEN
Do_job_3
RETURN
ENDIF
...

此宏的目的是用参数值匹配参数，然后调用相应的操作程序。一旦找到匹配项，RETURN 将中止检索过程。这将节约执行剩余 IF-THEN-ENDIF 语句来检索更多匹配项的时间。从该示例的格式可以看出，不会有更多的匹配项出现。

不要过于频繁地使用 RETURN 语句，因为含有很多 RETURN 语句的宏难于阅读，因而也就难于修改。在可行的情况下，使用其他控制语句。数据类型、命令、函数的创造性的使用将会使得宏更简单。如果在数组 command_set 中储存了适当的命令，上面的示例可以改写为：

NAME Big_switch
PARAMETER setting, command_set BYNAME command_list
EVALUATE command_set[setting]
RETURN

REMOVE 命令的某种格式可以取代 RETURN 语句。该格式如下：

REMOVE This_macro

其中，This_macro 是 RETURN 语句出现的宏的文件名。它的作用就是将该宏从存储器中删除，返回主程序。例如：

NAME Big_macro
! 在此处插入 Big_macro 的指令。
NAME Big_macro

NAME Call_big_macro
ALERT "Hi, I am the little macro that calls Big_macro.",3
MACRO "C:\MSDchem\some_dir\bg_mac.mac"
Big_macro
ALERT "Big_macro finished and removed.Lots of memory free.",3
RETURN

Call_big_macro 运行时，MACRO 命令将调用名为 bg_mac.mac 的大文件进入命令处理器。然后，调用文件中 Big_macro 。Big_macro 末端的 REMOVE 指令将 Big_macro 从存储器中删除掉，返回宏 Call_big_macro ，显示下一 ALERT（报警）面板。


IF-THEN-ENDIF

IF-THEN-ENDIF 语句的形式为：

IF 逻辑表达式 [THEN] 表达式列表 ENDIF

方括号中的 THEN 是可选的。它有助于使语句更加易读，但没有它也不会有影响。逻辑表达式必须是命令处理器可以求值以判断其是否为真或为伪。有关更多信息，请参见使用逻辑表达式。

当 IF-THEN-ENDIF 语句被执行时，首先对逻辑表达式求值。如果逻辑表达式为真，语句列表接着执行。此后，跟在 ENDIF 后面的将被执行，除非 RETURN（回车）、REMOVE（删除）或列表执行中的错误使其无法执行。如果逻辑表达式为伪，将跳过语句列表继续执行跟在 ENDIF 后面的语句。

! This macro draws an ALERT panel on the screen that
! wishes you Happy New Year if the date, as returned
! by the DATE$() function, is the first of January.
!
Name Happy_New_Mac2
LOCAL d_str$

! Assign the value of the date$() function to d_str$.The
! value is a string of the form dd/mm/yy.
! For example: 07/28/92
d_str$ = DATE$()
! If the numerical equivalent of dd and mm are both 1
!
IF val(d_str$[1:2]) = 1 AND val(d_str$[4:5]) = 1 THEN

! Put up a panel.Get all four digits of the year in
! the message by concatenating yy onto "19".
!
! Programmers note:The "19" below will have to
! be changed to "20" when the millennium arrives.
!

wish$ = "HAPPY NEW YEAR! -- " "19" d_str$[7:8] "!", 3
ENDIF
RETURN

IF-THEN-ENDIF 语句的各部分必须以上面显示的形式出现。IF 和逻辑表达式必须在同一行。如果关键词 THEN 存在，它必须出现在逻辑表达式之后（在同一行）。ENDIF 必须独自占一行。这些规则非常重要因为 IF 和 ENDIF 实际上作为单独的命令被执行，每一个都有自己要求的语法。语句列表可以是任何一系列的语句，包括其他的控制语句。


IF-THEN-ELSE-ENDIF

IF-THEN-ELSE-ENDIF 语句的形式为：

IF 逻辑表达式 [THEN]
语句列表 1
ELSE
语句列表 2
ENDIF

方括号中的 THEN 是可选的。它有助于使语句更加易读，但没有它也不会有影响。逻辑表达式必须是命令处理器可以求值以判断其是否为真或为伪。有关更多信息，请参见使用逻辑表达式。

当 IF-THEN-ELSE-ENDIF 语句被执行时，首先对逻辑表达式求值。然后语句列表中正确的一个被执行。如果表达式为真，列表 1 被执行，否则列表 2 被执行。下一步，跟在 ENDIF 后面的将被执行，除非 RETURN（回车）、REMOVE（删除）或列表执行中的错误使其无法执行。

IF-THEN-ELSE-ENDIF 语句的各部分必须以上面显示的形式出现。IF 和逻辑表达式必须在同一行。如果关键词 THEN 存在，它必须出现在逻辑表达式之后（在同一行）。ELSE 和 ENDIF 语句必须独自占据一行。这些规则非常重要因为 IF、ELSE 和 ENDIF 实际上作为单独的命令被执行，每一个都有自己要求的语法。语句列表可以是任何一系列的语句，包括其他的控制语句。示例：

使用如下所示的一个嵌套 IF-THEN-ELSE-ENDIF 语句，上面的 Happy_New_Mac 宏可被固定在千禧年之前：

Name Happy_New_Mac2
LOCAL d_str$, wish$, first_dgts$
wish$ = "HAPPY NEW YEAR! -- "
d_str$ = DATE$()
IF val(d_str$[1:2]) = 1 AND val(d_str$[4:5]) = 1 THEN
IF val(d_str$[7:8]) >92
first_dgts$ = "19"
ELSE
first_dgts$ = "20"
ENDIF
ALERT wish$ first_dgts$ d_str$[7:8] "!", 3
ENDIF
RETURN


WHILE-DO-ENDWHILE

WHILE-DO-ENDWHILE 循环的形式为：

WHILE 逻辑表达式 [DO] 语句列表
ENDWHILE

方括号中的“DO”是可选项。它有助于使语句更具可读性，而去掉它不会对语句的作用有任何影响。逻辑表达式必须是命令处理程序可以判断它为“是”或“非”的东西。有关更多信息，请参见使用逻辑表达式。

WHILE-DO-ENDWHILE 循环也称为 WHILE 循环。语句的目的是允许程序员来使一个语句列表被一遍又一遍的执行需要的时间。语句的形式非常灵活。WHILE 循环被执行后，其效果为执行这个概念指令列表：

步骤 1 | 判断逻辑表达式然后进行步骤 2
步骤 2 | 如果表达式为“是”，执行整个语句列表然后进行步骤 1。否则的话，执行任何 ENDWHILE 后的语句。

如果逻辑表达式在首次判断时为“非”，语句列表根本不会被执行。例如，下面的 ALERT 命令一次也不会被执行，因为逻辑表达式 0 = 1 总为“非”：

WHILE 0 = 1
ALERT "Paradox!", 3
ENDWHILE

如果语句列表中的首句被执行，那么所有列表中的语句都将被执行，除非一些情况如语句列表中的 RETURN、REMOVE 或故障情况导致程序停止。列表的执行将不会仅因为逻辑表达式变为“非”后而停止在中间的某个位置。在下列循环中，逻辑表达式在首次判断时即为“是”，因此 ENDWHILE 前的两条语句都在首条语句执行后立即执行，即使指针大于 1。

index = 1
WHILE index <= 1 DO
index = index 1
ALERT "Do you think I'll be executed?", 3
ENDWHILE

WHILE 循环是化学工作站宏语言中唯一的宏控制语句。幸运的是，其形式非常灵活和功能强大且能实现在其他编程语言中的循环实现的功能。例如，许多编程语言有一个特定的能执行语句列表指定时间的 FOR 循环语句 。下面显示的 WHILE 循环的形式类似 FOR 循环。循环准确的执行其语句列表 N 次。

index = 1
WHILE index <= N DO
! put the statement list here.
index = index 1
ENDWHILE

下面的一般形式可以用于达到 REPEAT 循环的效果，REPEAT 循环是许多编程语言也有的另一种控制语句。其思想为重复执行语句列表直到某些逻辑表达式变为“是”。这看起来似乎同 WHILE 循环一样，但在 REPEAT 循环中，不管逻辑表达式的结果如何，语句列表总是将执行至少一次。

语句列表
WHILE NOT 逻辑表达式 DO
语句列表
ENDWHILE

如果语句列表非常长，可以将之变成宏调用，然后上面的形式就会成为：

Statement_list stop_param
WHILE NOT 逻辑表达式 DO
Statement_list stop_param
ENDWHILE

宏应该至少有一个参数（上面例中的 stop_param），这样它造成的任何结果都能影响逻辑表达式。否则的话，无论何时逻辑表达式变为“是”后语句列表即将被无限执行。显示这个故障的循环成为无限循环。一旦他们开始运行就很难停止。在应用窗口的左上角的控制按钮中选择“Abort（中止）”通常可以起作用。

可以使得 WHILE 循环的语句列表执行的次数依赖于列表处理的数据条件。这使得设计循环来运行需要的时间相对容易。下面的循环是一个简单示例：

string$ = "It sure is a hot day.I could use some lemonade"
index = 1
sentence$ = ""
WHILE NOT eqstr(string$[index], ".")DO
sentence$ = sentence$ string$[index]
index = index 1
ENDWHILE
ALERT "The first sentence is: " sentence$ ".",2

只有到达输入字符串的首句末端时循环中的语句才停止执行。循环具有对任意长度的输入字符串作用的适应性且仅完成要取到需要结果所必须的工作。


ON_ERROR

ON_ERROR 语句的形式是：

ON_ERROR [陷阱]

ON_ERROR 语句用来指定出错时要执行的宏或命令。参数“陷阱”可以是任何有效的化学工作站宏或命令并可包括参数。

当命令处理器在执行宏时遇到无法执行的指令时，它通常会停止执行宏并在消息行写上一条错误消息。ON_ERROR 语句的作用是使 CP 执行“陷阱”而不终止执行宏。“陷阱”可以用来修复一个问题，并在导致错误的指令的下一条指令处重新启动宏，或者仅仅是保存一些结果并在允许宏停止前重新初始化一些设备或数据。

在一个宏中可以有任意多数量的 ON_ERROR 语句。基本上来说，每个语句都将应用于执行分路径中所有在其后面的语句，直到在每个路径中出现下一条 ON_ERROR 语句。

如果没有指定任何“陷阱”，则在出错时除了试图执行导致错误的指令的下一条指令外，将不进行任何操作。通常这具有组合错误的功效，但在“陷阱”宏中，它可能很有用。

若特定命令 GENERATE_ERROR 被用作“陷阱”，则它具有取消任何错误陷阱的功效，这些错误陷阱由于早先的 ON_ERROR 语句而生效。

有关更多其他信息和示例，请参见第 5 章。


使用逻辑表达式

逻辑表达式常与控制语句连用（请参见“使用控制语句”）。所有的逻辑表达式实际上都是标量，但是使用方法不同。零值被解释为“假”，而其他所有数值都被解释为“真”。在下例中，ALERT 面板将显示“The value is TRUE except when the scalar_value is zero.（除了标量数值为零时，所有值均为“真”。）”

IF scalar_value
ALERT "The value is TRUE."
ELSE
ALERT "The value is TRUE."
ENDIF

语句 PRINT VAL$(14=3) 将在提示行中显示 0。PPRINT VAL$(3=3) 显示 1。

可用一个比较运算符与两个允许的操作数形成一个简单的逻辑表达式。比较运算符为：=（等于），<>（不等于），>（大于）和 >=（大于或等于）。使用所有运算符的形式为：

表达式1 运算符 表达式2

两个表达式的数据类型必须相同。例如：

8 < 7 ! false
2.33 <> 2.34 4 - 3.91 ! true
4/2 = 2 ! true
array1 <> array2 array 3
(2:3) = (3:2) ! true

标量表达式可与比较运算符自由使用。标量数组和标量范围只能直接通过 = and 比较。标量矩阵、集合和字符串不能作为任何比较运算符的操作数。（使用 EQSTR( )函数来比较字符串）。有关更多信息，请参见标量、标量范围、标量数组和标量矩阵和集合。

较简单的逻辑表达式可以通过逻辑运算符 NOT、AND 和 OR 组合成为更复杂的表达式。


NOT

使用 NOT 操作符的格式为：

NOT 逻辑表达式

若逻辑表达式为假 (false)，则此格式的值为真 (true)；若逻辑表达式为真，则此格式的值为假。逻辑表达式可以包括任意内容，只是不能以 NOT 开头，如 NOT NOT 这样的逻辑表达式。但是，NOT （NOT 逻辑表达式）是可接受的。

示例

NOT 1 = 0 ! 真
NOT 1 = 1 ! 假


AND

使用 AND 运算符的形式是：

逻辑表达式 1 AND 逻辑表达式 2

如果逻辑表达式 1 和逻辑表达式 2 都为真，则值的形式为真,否则为假。

示例

30 >24 AND EQSTR("abc", "abcd") ! 假
ln(10) < 10 AND 1<>0 ! 真


OR

使用 OR 操作符的形式为：

逻辑表达式 1 OR 逻辑表达式 2

如果逻辑表达式 1 或逻辑表达式 2 中有一个为真 (true)，或者两者都为真，则此形式的值为真。仅当逻辑表达式 1 和逻辑表达式 2 都为假时，此形式才为假。

示例

2 < 3 OR 3 < 2 ! true
8 <> 6 OR 7 <> 3 ! true
(21 = 3 * 7 OR 0 = 1) AND 10 < 10/3 ! false
21 = 3 * 7 OR (0 = 1 AND 10 < 10/3) ! true
21 = 3 * 7 OR 0 = 1 AND 10 < 10/3 ! true

请注意，最后三个示例差异仅与有无括号及括号的位置有关。由于 AND 的优先级比 OR 高，计算最后一个例子时，发现它和前一例子加括号时一样。括号应该在各种表达中随意使用，以增强它们的可读性。在某些情况下，必须有括号以迫使命令处理器作出想要的解译。有关更多信息，请参见运算符优先次序。


运算符优先次序

一个表达式如

10 4 / 2

能有两种不同的方法进行运算。如果 10 + 4 先计算，结果再除以 2 ，结果为 7 。另一方面，如果先用 4 除以 2 ，运算结果再与 10 相加，最后的结果就是 12 。为处理这种不定性，化学工作站命令处理器采用以下的优先次序表（优先级数高的在顶部）。注意圆括号视作优先级最高的运算符。

( ), []

unary , unary -

/

binary , binary -

:

>, <, >=, <=, <>, =

NOT

AND

OR

在上表中，unary 和 unary — 指的是出现在表达式之前的加号或减号。而 binary 和 binary — 运算符指的是加法和减法。

运算符优先次序表通过化学工作站中的 CPs 得到应用，计算表达式的方法如下：

  • 先进行最高级优先次序的运算，然后是次高级，等等，直到整个表达式运算完毕。

  • 在上表中同一行的运算符的优先级数相同，依从左至右的顺序进行运算。

示例

10 + 4 / 2 与 10 + (4/2)相同，运算结果为 12

3 * 16 - 20 / 8 / -13 + 2 与((3 * 16) - ((20 / 8) / -13)) + 2 相同，运算结果为 50.1923

13 前面的减号是 unary 运算符的例子。


第五章 — 宏的有用技巧

本章包括一些宏示例，它们在用户的交互作用、文件输入输出、打印和故障处理方面非常有用。在本章中学习如何执行特定任务、发现您感兴趣的主题、阅读讨论以及研究示例。在这些示例中您可以输入数据、将输入结果保存在一个文件中，然后运行观察所得结果。您也可以将它们作为自己的宏的模板。

欲获得示例中各命令的更多信息，请参见在线帮助中的命令部分。

用户交互作用

文件输入输出

打印

故障处理


用户交互作用

在宏运行时收集信息或将信息报告给用户，这种需求经常存在，如获取文件或目录名称。化学工作站宏语言提供有几种执行用户交互作用的方法。本节包括简单的把数据用于交互作用以及自定义菜单栏和鼠标操作的更高级的主题。

典型的情况下，宏通过调用诸如 INPUT、INPUT6 或 SELECTFILE 之类的命令来获取此类信息。用户使用这些命令可以输入字符和（或）单（双）击鼠标。当命令存储了用户在其中输入一个或多个变量的表达式时，用户和宏之间的通信即完成。然后，宏可以解析和使用信息。

当需要将少量数据从宏传递给用户时，宏可以使用 PRINT 命令在提示行上打印一字符串，或使用 ALERT 命令在屏幕上画一对话框。

另见

传递字符串和标量

获取文件和目录名称

同时获取多项

修改应用程序菜单栏

定制鼠标操作宏


传送字符串和标量

INPUT 命令

从用户获取字符串或标量的最简单方法是使用一种 INPUT 命令。语法是：

INPUT “字符串表达式”，字符串变量

INPUT 在屏幕上绘制一个字符串表达式为标题的对话框。该对话框包含一个用户可以在内键入字符串的编辑框。如果用户单击对话框中的 OK（确定） 按钮，INPUT 命令会将编辑框中的字符串分配给字符串变量然后返回。如果用户单击 Cancel（取消）按钮，变量值不会改变。变量可以在 INPUT 被调用前被赋予一个初始值。在用户更改这个值前它会在编辑框中一直显示。调用 INPUT 的宏可以通过检查保留变量“_Button”的值来查看用户所点击的是哪个按钮。

PRINT 命令

PRINT 是传送信息给用户的最简单的命令。语法是：

PRINT 表达式 [,...]

任意标量或字符串表达式都允许作为参数。PRINT 的效果是将表达式值输出到应用程序窗口的提示行上。

例 1

NAME Get_string
LOCAL str$
str$ = "Your string goes here."
INPUT "Please enter a string.", str$
IF _Button = 1 THEN
! if the OK button was pushed ...
!
! Here, put any instructions you want to execute
! after the user has chosen a string. The string is
! stored in the variable str$. Do whatever you like
! with it.
!
PRINT "You chose the string: " , str$
ELSE
!
! Here, put instructions to execute if the Cancel
! button was pushed.
!
PRINT "You pressed the Cancel button."
ENDIF
RETURN

例 2

从用户获取一个标量值的简单方法是使用 VAL( ) 来转换输入的字符串，如下所示：

NAME Get_scalar
LOCAL str$, the_num
INPUT "Please enter a number.", str$
! translate the string into a number.
!
the_num = val(str$)
! This line shows that the_num is a scalar.
!
the_num = the_num / 2
PRINT "What you entered was twice: ", the_num, "."
RETURN


获取文件和目录名称

SELECTFILE 命令

要从用户处获取文件或目录名称，使用 SELECTFILE 通常是比 INPUT 更好的选择。SELECTFILE 能显示一个允许用户在文件系统中浏览的对话框且能防止用户选择一个不存在的文件或目录。SELECTFILE 命令的语法是：

SELECTFILE attr, "title", ["extension"], path$, entry$, status

attr 参数对于文件为 1，对于目录为 2。Title 是对话框的标题。Extension 是一个用于限制允许的文件扩展名的格式为“.xyz”的字符串。Path$ 和 entry$ 是用于返回部分路径全名的字符串变量。Status 是一个用于返回文件状态的必要标量参数。SELECTFILE 也设定保留变量 _Button。下面是使用 SELECTFILE 命令的一个例子：

例 3

! This macro needs to be run by a Data Analysis command
! processor, or one that has previously loaded the system
! macro, ViewFile
!
NAME Show_file
LOCAL prompt$, ext$, path$, file$, status
LOCAL fmt$, msg$
prompt$ = "Please find and select the file you wish to see..."
ext$ = "*.txt" ! allow only files with ".txt" extension
path$ = "C:\" ! initial directory
file$ = "" ! initial filename is null
SELECTFILE 1, prompt$, ext$, path$, file$, status
IF _Button 0 THEN ! if the user did not click on Cancel
! Show the file in the drive and directory indicated
! by path$, with name the value of file$. Use the
! system macro ViewFile. (See below)
!
Viewfile path$ file$
ENDIF
PRINT `Path$ is: "' path$ `"', ` File$ is: "' file$ `"'
RETURN


同时获取几个项目

INPUT6 命令

INPUT6 命令和 INPUT 命令相似，但指定用于给出和收集最多六个不同选择。INPUT6 可以用于不同的情况，具体取决于所需的信息种类，具有下面的语法：

INPUT6 type, count, "title", label, button, data

INPUT6 在屏幕上出现一个对话框。取决于参数命名类型的值（1、2 或 3），对话框同编辑框、复选框或选项按钮一起出现。Count 是需要的对话框数目。Title 是对话框的标题。Label 是用于标注对话框或功能按钮的字符串集合。Button 是用于出现在对话框底部的控制按钮的一组标志。Data 是存储用户输入内容的变量名称。除使用列出的参数外，INPUT6 设置保留变量 _Button 为 1、2 或 3，取决于所点击的控制按钮。

ALERT 命令

ALERT 命令在屏幕上出现几种对话框中的一个以及一个对话框中用于用户阅读的字符串。ALERT 的语法为：

ALERT ["message string"] [,type]

SPRINT USING 命令

提示字符串可以用 SPRINT USING 命令格式化。SPRINT USING 的语法为：

SPRINT variable USING "format image string", "expression" [,...]

ViewFile 宏

ViewFile 是一个在屏幕打开 Notepad 或 Write 窗口并在其中显示文件的系统宏。有时使用 ViewFile 比 ALERT 方便。通常，ViewFile 仅在 Data Analysis（数据分析）或 Tune（调谐）命令处理程序中可用，但可以复制一份，然后在任何要用的地方加载。ViewFile 的全文本在下面的“例 5”中给出。使用 ViewFile 的语法是：

ViewFile "complete filename"

例 4

在下面的例子里，INPUT6 用来从用户取得最多六行的地址信息。将数据输入到编辑框中然后以一系列名为 addr 的字符串返回。然后将数据存储到一个文件并用 ViewFile 在屏幕上显示。

! This macro is written for a Data Analysis command
! processor, or one that has previously loaded the ViewFile
! system macro.
!
NAME GetAddress
LOCAL label, button, addr, index, filename$
SDim label,6
SDim button,3
SDim addr,6
label[1] = "Line &1" label[2] = "Line &2"
label[3] = "Line &3"
label[4] = "Line &4"
label[5] = "Line &5"
label[6] = "Line &6"
button[1] = ""
button[2] = "&Save"
button[3] = "Cancel"
addr[1] = "Dr. Jean C. Doe"
addr[2] = "Laboratory Supervisor"
addr[3] = "Ident-Rite Analytical Laboratories, Inc."
addr[4] = "10001 Industrial Avenue"
addr[5] = "Wichita, CA 92001"
button[6] = ""
! get edit boxes by using 1 as the type argument
! ! get 6 boxes by using 6 as the count argument
! ! INPUT6 1, 6,"Enter up to 6 lines of Address",label,button,addr
IF _Button = 2 ! if the Save button was pushed
! Build a filename string.
! filename$ = _EXEPATH$ "addrfile.txt"
! Open a file and establish #1 as a synonym for the
! filename.
!
OPEN filename$ FOR OUTPUT AS #1
index = 1
WHILE index <= 6
! write the contents of addr[index] to the file,
! on a line by itself
!
PRINT #1, addr[index]
index = index1
ENDWHILE
CLOSE #1
! Display the contents of this file
!
ViewFile filename$
ENDIF
REMOVE GetAddress ! performs a RETURN

上例中的“&”号定义对话框中的快捷键。例如，用户可以通过键入 Alt-3 来选择编辑框 3 来输入。“&”号可以放在对话框或按钮标志的任何字符的前面。指定的字符会以下划线显示。

注意 button[1] 被指定为空字符串作为标记。这使得 1 号按钮不在对话框中显示，其效果是使可见的按钮居中。

例 5

! ViewFile !
! Starts up Notepad or Write depending on the file
! size. Changes the _EXEPATH$ temporarily so that
! doing an open file from the editor will show the
! path of the file being viewed.
!
! The filename$ must be a full path filename!!!!
!
NAME ViewFile
PARAMETER filename$, deletefile DEFAULT 0
LOCAL exedir$, size
! Check for file existence
! FILESIZE filename$
IF size = -1
ALERT filename$ " does not exist.", 3
ELSE
! Save current _EXEPATH$
! exedir$ = _EXEPATH$
ON ERROR
VARLOCK OFF
_EXEPATH$ = filename$
IF size
DOSRUN "notepad.exe " filename$
IF deletefile 0
DELETE filename$, DONTASK
ENDIF
ELSE
DOSRUN "write.exe " filename$
!
! Don't delete a text file that is being viewed
! in Write. Write may try to access the file
! (as when doing a file conversion) and will
! produce an error if the file no longer exists.
!
ENDIF
! Restore _EXEPATH$
!
_EXEPATH$ = exedir$
VARLOCK ON
ENDIF
RETURN

例 6

在下面的例子里，INPUT6 用来让用户通过单击复选框选择最多三个选项。选择作为一个名为 choice 的标量数组返回。choice 的一个或多个元素被赋予初始值 1，则可通过已复选（选择）相应的方框引出对话框。调用 SPRINT USING 来创建一个返回值格式的字符串。调用 ALERT 来把这个字符串输出到屏幕上的对话框中。

NAME CheckList
LOCAL label, button, choice, onOff, fmt$, msg$, index
SDim label, 3
SDim button, 2
DIM choice, 3
SDim onOff, 3
label[1] = "Option One"
label[2] = "Option Two"
label[3] = "Option Three" button[1] = "OK" button[2] = "Cancel"
choice[2] = 1 ! initialize this box to checked state
! get check boxes by using 2 as the type argument
! ! get 3 boxes by using 3 as the count argument
! !
INPUT6 2,<= 3, "Select Options", label, button, choice
index = 1
WHILE index <= 3 ! Convert choices to ON and OFF strings
IF choice[index]
onOff[index] = "ON"
ELSE
onOff[index] = "OFF"
ENDIF
index = index 1
ENDWHILE
! Create a format string. [%] and [/] are place holders
! for strings and carriage returns.
!
fmt$ = "Option 1 %/Option 2 %/Option 3 %/"
! Copy an image of the format string into msg$, putting
! onOff[1], onOff[2], and onOff[3] in the positions of the
! percent signs [%], and carriage returns where the
! slashes [/] appear.
!
SPRINT msg$ USING fmt$, onOff[1], onOff[2], onOff[3]
ALERT msg$, 2
REMOVE CheckList ! performs a RETURN

例 6 中的 WHILE 循环说明了一个把标量数据翻译为字符串数据的方法。这里的翻译包括把词 ON 替换为 1 和 OFF 替换为 0。

例 7

在下面的例子里，INPUT6 用来绘制一个具有功能按钮的对话框。用户从提供的选项中选出一个，然后选项的编号返回到标量变量 choice 中。

NAME PickOne
LOCAL label, button, choice
SDim label, 5
SDim button, 3 label[1] = "Pick Me. I'm first."
label[2] = "Pick Me. I'm second."
label[3] = "Pick Me. I'm third."
label[4] = "Pick Me. I'm fourth."
label[5] = "Pick Me. I'm fifth."
button[1] = ""
button[2] = "OK"
button[3] = "Cancel"
choice = 1
! get option buttons by using 3 as the type argument
! ! get 5 buttons by using 5 as the count argument
! !
INPUT6 3, 5,"Select one.", label, button, choice
IF _Button = 2
ALERT "Choice was number " VAL$(choice), 2
ENDIF
REMOVE PickOne ! performs a RETURN


修改程序菜单栏

可以通过在程序窗口中安装额外菜单来自定义化学工作站。例如，可以使一个自定义宏的执行作为一个菜单项目使用。可以通过在创建系统菜单栏的宏中添加指令来扩展化学工作站程序中的菜单选项。一些相关文件和宏有：

程序 | 文件* | 宏名称
Top | ~\msexe\topmenu.mac | FullBar
Tune | ~\msexe\atune.mnu | TuneBar
Data Acquisition | ~\msexe\msacq.mac | AcqBar
Data Analysis | ~\msexe\msda.mac | DABar

[~] 是指化学工作站的安装目录。对于标准安装为 \MSDchem。

注意

自然，如果不知道这些重要的系统宏的可能效果，不要对这些宏做出任何改变。并且，在进行改变前应该保存一个原文件的复制件。这样如果需要的话就能将系统恢复为已知状态。

用于创建菜单项目的两条重要命令是 MENUCMD 和 MENUCMDFN。这些命令的语法如下：

MENUCMD "标志", "命令" [,"提示"] [,变量]
MENUCMDFN "标志", "命令" [,"提示"] [,"字符串"]

标志是要出现于菜单上的字符串。命令是菜单项目被选定时要执行的指令。消息是菜单项目被选中后在状态行将出现的字符串。这些命令的第四个参数控制了该项是变灰还是选中。MENUCMD 的第四个参数是一个标量变量。MENUCMDFN 的第四个参数是一个代表功能调用或表达的字符串。

例 8

您可以通过阅读和测试下面的例 8 来安全的学习菜单栏宏是如何运作的。这个例子没有扩展成一组菜单，而是使用新的菜单进行替换。要测试这个例子，只要启动一个 Data Analysis（数据分析）程序，加载宏，然后执行它。从看到的菜单中进行选择并注意例中的效果是如何与指令相关的。关闭程序可以中止宏。

在熟悉了这个例子和它的行为后，愿意的话可以试着在一个系统宏中扩展菜单命令。

影响菜单的命令有 MENUBEG，MENUNEW，MENUCMD，MENUCMDFN，MENUVAR，MENUSTP，MENUSEP，MENUEND，MENUHLP 和 MENUSTATE( )。

! Macros that will be called by menu selections.
!
NAME Op1
PARAMETER a BYNAME N
a = a1
PRINT a
RETURN

NAME Op2
PARAMETER a BYNAME N
a = a/3
PRINT a
RETURN

NAME Op3
PARAMETER a BYNAME N
a = sqr(a)
PRINT a
RETURN

NAME Op4
PARAMETER a BYNAME NLOCAL string$
INPUT "New Value", string$
a = trunc(val(string$))
PRINT a
RETURN

Name Print1
PARAMETER a
IF trunc(a) = a AND mod(a,2) = 0
PRINT a, " is even."
ELSE
PRINT "NOT!"
ENDIF
RETURN

Name Print2
PARAMETER a
IF ((trunc(sqrt(abs(a)))=sqrt(abs(a))) AND (a = >= 0))
PRINT a," is a perfect square."
ELSE
PRINT "NOT!"
ENDIF
RETURN

NAME MyMenuBar
LOCAL lbl$
MENUBEG
! Start a new menu bar description
MENUNEW "&Change N"
! Start the first menu description
lbl$
= "to one higher to make it Even"
MENUCMDFN lbl$, "Op1 N", "Add one to make even", "3*(1-mod(N,2))"
lbl$ = "to N/3"
MENUCMDFN lbl$,"Op2 N", "Divide evenly by three", "2*(mod(N,3)0)"
lbl$ = "to square of N"
MENUCMDFN lbl$,"Op3 N", "Square, if < 1,000,000", "2*(1-(abs(N)<1000))”
MENUSEP
! Place a line in the menu here
MENUCMD "N = N 1", "N=N1", "Add 1 to N"
MENUCMD "to new input Value", "Op4 N", "Pick new value for N"
MENUNEW "&Messages" ! Start the second menu description
lbl$ = "N is even"
MENUCMDFN lbl$, "Print1 N", "Display Even sentence", "mod(N,2)=0"
lbl$ = "N is a perfect square"
MENUCMDFN lbl$, "Print2 N", "Display Perfect Square sentence"
MENUEND ! Marks the end of the menu bar description
RETURN
! Perform initializations before calling MyMenuBar
!
NAME Dummy
N=1
PRINT " Initial value of N is 1"
MyMenuBar
! REMOVE Dummy
RETURN


定制鼠标操作宏

下面的示例 9 说明了使用 SETWINATTRIBUTE 命令来定制鼠标操作的技巧。如果您希望在您的系统中定制鼠标操作，请研究该示例并将作为模版创建您自己的宏。

建立一个当前数据文件，其总离子流色谱中的一个峰可采用当前积分参数设定由 RTE 积分器来积分，然后运行 Data Analysis（数据分析）中的宏。

示例 9

NAME Mouse1
PARAMETER w, o, m, tp, x0, y0, x1, y1, cs, ms, lds, rds, un
! LEFT CLICK AND DRAG -- Zoom in
!
IF m = 128
PRINT "<MOUSE1> L CLICKDRAG--Zoom in"
ZOOM w,x0:x1,y0:y1
RETURN
ENDIF
! LEFT DOUBLE CLICK -- Zoom out
IF m = 160
PRINT "<MOUSE1> L CLICKDRAG--Zoom in"
ZOOMOUT w
RETURN
ENDIF
! RIGHT DOUBLE CLICK, GC/MS DATA
! Pick Spectrum and Display it
! IF m = 288 AND tp = 1
PRINT " <MOUSE1> R DOUBLE CLICK on TIC/EIC--Get Spectrum at",x0/60000," minutes"
SPECTRUM x0/60000,X
DRAW 10,X
RETURN
ENDIF
! RIGHT DOUBLE CLICK, GC/MS DATA
! Generate average mass spectrum and Display it
!
IF m = 256 AND tp = 1 AND un = 0
PRINT "Averaging..."
AVERAGE x0/60000:x1/60000,X
DRAW 10,X
PRINT " <MOUSE1> R DOUBLE CLICK on contains: GC/MS--Average MS"
RETURN
ENDIF
! RIGHT DOUBLE CLICK, MS DATA -- Library Search MS
!
! IF m = 288 AND tp = 0
PRINT " <MOUSE1> R DOUBLE CLICK on contains: MS = 0"
MACRO "libsrch.mac"
LibSrch X
RETURN
ENDIF
! BOTH CLICK --Put up Annotate Box
!
! IF m = 194 AND tp = 321
PRINT "<MOUSE1> BOTH CLICK--Annotate using Panel"
ANNOTATE w,o,x0,y0
RETURN
ENDIF
RETURN

NAME Mouse1
PARAMETER w, o, m, tp, x0, y0, x1, y1, cs, ms, lds, rds, un
LOCAL tempSpec
! LEFT CLICK AND DRAG -- Zoom in
!
IF m = 128
PRINT "<MOUSE1> BOTH CLICK--Annotate DRAG--Zoom in"
ZOOM w,x0:x1,y0:y1
RETURN
ENDIF
! LEFT DOUBLE CLICK -- Zoom out
IF m = 160
PRINT "<MOUSE1> L CLICKDRAG--Zoom in"
ZOOMOUT w
RETURN
ENDIF
! RIGHT DOUBLE CLICK, GC/MS DATA
! Extract ion chromatogram & draw to window 2
!
! IF m = 288 AND tp = 0
PRINT " <MOUSE1> R DOUBLE CLICK on contains: MS--Get EIC "
EIC ,ROUND(x0/20),R0
DRAW 11,R0
RETURN
ENDIF
! RIGHT DOUBLE CLICK, GC/MS DATA
! Pick Spectrum and Display it
!
! IF m = 288 AND tp = 1
PRINT " <MOUSE1> R DOUBLE CLICK on contains: TIC/EIC--Show Scan"
SPECTRUM x0/60000,tempSpec
_TAB ,,tempSpec
RETURN
ENDIF
! RIGHT DOUBLE CLICK, GC/MS DATA
! Tabulate subset, assuming associated MS named R8 or
! associated TIC/EIC named R6
!
IF m = 256
IF tp = 0
PRINT "<MOUSE1> BOTH CLICK--Annotate Window contains MS.Show subset"
_TAB ,,R8,x0/20:x1/20
ENDIF
IF tp = 1
PRINT "<MOUSE1> BOTH CLICK--Annotate Window contains TIC/EIC. Show subset"
_TAB ,,R6,x0/60000:x1/60000
ENDIF
RETURN

! BOTH CLICK -- Annotate automatically
!
! IF m = 194 AND tp = 321
IF tp = 0
PRINT "<MOUSE1> BOTH CLICK--Annotate Annotate MS Automatically"
ANNOTATE w,o,x0,y0
ENDIF
IF tp = 1
PRINT "<MOUSE1> BOTH CLICK--Annotate Annotate MS Automatically"
ANNOTATE w,o,x0,y0
ENDIF
RETURN
ENDIF
RETURN

NAME SetupMouseAct
PARAMETER fileName DEFAULT _DATAPATH$ _DATAFILE$
LOCAL left,right,top,bottom,horizCenter
left = 0.0:0.5 top = 0.5:1.0
right = top
bottom = left
horizCenter = 0.25:0.75
! Get sample data for this demonstration
!
FILE fileName
TIC ,R6
RTEINT R6
PEAKNUMBER 1,TOP,R6,R8
! Place windows in each quadrant of the
! Data Analysis plot window area
!
WINDOW 6, left, top
WINDOW 7, left, top
WINDOW 8, left, top
WINDOW 9, left, top
WINDOW 10, left, top
WINDOW 11, left, top
! Plot data to the windows in each quadrant
!
DRAW 6,R6
DRAW 7,R6
DRAW 8,R8
DRAW 9,R8
! Set cursor shapes for each window
!
SETWINATTRIBUTE 6,CURSORSHAPE,1 ! arrow
SETWINATTRIBUTE 7,CURSORSHAPE,1 ! arrow
SETWINATTRIBUTE 8,CURSORSHAPE,1 ! arrow
SETWINATTRIBUTE 9,CURSORSHAPE,4 ! gun sight
! Set cursor shapes for each window
!
SETWINATTRIBUTE 6,MARKERSHAPE,0 ! none
SETWINATTRIBUTE 7,MARKERSHAPE,1 ! vertical line
SETWINATTRIBUTE 8,MARKERSHAPE,2 ! horizontal line
SETWINATTRIBUTE 9,MARKERSHAPE,3 ! both vertical and horizontal
! Set right drag shape for each window
!
SETWINATTRIBUTE 6,RIGHTDRAGSHAPE,0 ! none
SETWINATTRIBUTE 7,RIGHTDRAGSHAPE,1 ! vertical line
SETWINATTRIBUTE 8,RIGHTDRAGSHAPE,1 ! vertical line
SETWINATTRIBUTE 9,RIGHTDRAGSHAPE,3 ! both and horizontal
! Set right drag shape for each window
!
SETWINATTRIBUTE 6,MARKERSHAPE,0 ! none
SETWINATTRIBUTE 7,MARKERSHAPE,1 ! vertical line
SETWINATTRIBUTE 8,MARKERSHAPE,2 ! horizontal line
SETWINATTRIBUTE 9,MARKERSHAPE,3 ! both vertical and horizontal
! Set cursor shapes for each window
!
SETWINATTRIBUTE 6,SHOWTITLES,1 ! off
SETWINATTRIBUTE 7,SHOWTITLES,1 ! off
SETWINATTRIBUTE 8,SHOWTITLES,1 ! off
SETWINATTRIBUTE 9,SHOWTITLES,1 ! off
! Set mouse action macro for each window
!
SETWINATTRIBUTE 6,MOUSEMACRO,,"Mouse1"
SETWINATTRIBUTE 7,MOUSEMACRO,,"Mouse1"
SETWINATTRIBUTE 8,MOUSEMACRO,,"Mouse1"
SETWINATTRIBUTE 9,MOUSEMACRO,,"Mouse1"
REMOVE SetupMouseAct


文件输入和输出

这一部分包含从数据读取和写数据到文件的宏的几个示例。下列命令可以在化学工作站中用于对无格式文本文件的逐行处理：OPEN，CLOSE，PRINT #filenumber，PRINT USING #filenumber 和 INPUT #filenumber。特殊的化学工作站命令如 FILE，TABULATE，GETCOMPOUND，PUTCOMPOUND 和 STARTANALYSIS 用于向 MS 数据文件输入和输出。

输出到文件

从文件输入

定量的文件输入/输出


输出到文件

示例 10 说明了 OPEN ，PRINT USING #filenumber ，和 CLOSE 命令的使用，使用这些命令能够一次将一行文字输入到文件中。FILE 是从数据文件读取数据并将此数据信息储存到系统变量中。使用 PRINT USING # 命令，宏将格式化数据信息，并写到文本文件中。然后它调用 ViewFile 宏，显示文本文件。

Êµ例 10

! Formats file header information lines for various
! MSDA reports. This macro should be run by the Data
! Analysis command processor.
!
NAME HdrFormat
PARAMETER filename$ DEFAULT _DATAPATH$_DATAFILE$
LOCAL headerOutput$
FILE filename$
! Set a path for the output text file. Typically
! the resulting path will be \MSDchem\msexe\file_hdr.txt,
!
headerOutput$ = _EXEPATH$"FILE_HDR.TXT"
! Initialize a new file for writing. Make the descriptor #1
! a synonym for the file name. If the file exists already,
! the OPEN FOR OUTPUT will remove it. Use OPEN FOR APPEND
! if a non-destructive OPEN is desired.
!
OPEN headerOutput$ FOR OUTPUT AS #1
! Write the format string "File name is %/" to the file
! opened above, except substitute the string
! _DATAPATH$ _DATAFILE$ for the [%] in the format string,
! and place a newline character in the file where the [/]
! appears in the format string. _DATAPATH$ and _DATAFILE$
! are two of the variables set previously by the call to
! FILE.
!
PRINT USING #1, "File name is %/",_DATAPATH$ _DATAFILE$
PRINT USING #1, "Operator is %/",_OPERATOR$
PRINT USING #1, "Date Acquired is : %/",_DATEACQUIRED$
PRINT USING #1, "Method used for acquisition %/",_ORGMETHFILE$
PRINT USING #1, "Sample Name is %/",_DATANAME$
PRINT USING #1, "Expected bar code is %/", _EXPBARCODE$
PRINT USING #1, "Miscellaneous Information: %/",_MISCINFO$
PRINT USING #1, "Actual Barcode is %/",_ACTBARCODE$
! Format a scalar with the [#] character.
!
PRINT USING #1, "Vial Number is #/",_ALSBOTTLE
! Close the file. This frees the descriptor for re-use
!
CLOSE #1
ViewFile headerOutput$
RETURN


从文件输入

示例 11 说明使用 INPUT #文件号命令从一个文件每次一行读取信息。宏接受 Data Analysis（数据分析）的 TABULATET 命令产生的质谱数据表，处理数据并写出一个包含质谱中最大响应的 N 个点的新文件。

首先从 Data Analysis（数据分析）中的 File（文件）菜单选择 Load（加载）并选择一个数据文件以运行该示例。当在窗口 2 看到 TIC 时，在一个峰处双击鼠标右键使一个质谱图显示在窗口 1 中。然后加载包含示例宏的文件并调用自变量为 N（等于输出点数）的 FileFilter。例如，调用可以是 FileFilter 5。

示例 11

! InsertSort
!
! This inserts a new (m/z, response) point into two
! parallel arrays M and R. R is sorted in increasing
! order of response.
!
NAME InsertSort
PARAMETER rsltArrBound, newM, newRLOCAL stage, movingM, movingR, swapM, swapR
stage = 0
WHILE rsltArrBound > 0
stage = 0
! check if new element is to be inserted
!
IF newR > R[rsltArrBound]
movingM = M[rsltArrBound]
movingR = R[rsltArrBound]
M[rsltArrBound] = newM
R[rsltArrBound] = newR
stage = 1
ENDIF
ELSE
! move existing element down one for insert
! of new value
!
movingM = M[rsltArrBound]
movingR = R[rsltArrBound]
M[rsltArrBound] = newM
R[rsltArrBound] = newR
movingM = swapM
movingR = swapR
ENDIF
rsltArrBound = rsltArrBound - 1
ENDWHILE
RETURN
! CompareOne
!
! This macro takes extracted fields from the TABULATE
! text file lines, converts these to m/z and response
! values, and checks if the (m/z, response) point ought to
! be added to to the list of points with greatest response.
!
NAME CompareOne
PARAMETER mzBounds, respBounds, rsltArrBound, inputLine
LOCAL mz, resp mz = VAL(inputLine[mzBounds])
resp = VAL(inputLine[respBounds])
IF newR > R[rsltArrBound]
InsertSort rsltArrBound, mz, resp
ENDIF
RETURN
! FileFilter
!
! Use TABULATE to get a file with a human-readable
! numerical display of the mass spectrum. Open the
! file for input. Read lines. Extract fields containing
! (m/z, response) points. See if each point is in the
! list of points with the greatest m/z. The value
! rsltArrBound determines the length of the list.
!
NAME FileFilter
PARAMETER rsltArrBound DEFAULT 5, zzz BYNAME x
LOCAL line$, desc$, i, fileName$
DIM M, rsltArrBound
! global variable MDIM R, rsltArrBound
! global variable R fileName$ = _EXEPATH$ "INPUT.TXT"
! Read information from the data file, and put into a plain
! text file with name fileName$.
!
TABULATE , fileName$, zzz
! Open the file for reading. Establish descriptor #1 as a
! synonym for the file name
OPEN fileName$ FOR INPUT AS #1
! Read past the header lines. Each INPUT command reads
! one line into desc$ or line$.
!
INPUT #1, desc$ ! save the description for later comparison
INPUT #1, line$
INPUT #1, line$
INPUT #1, line$
! stop when two consecutive lines of zero length string are found
! i = 0
WHILE i < 2
INPUT #1, line$
IF LEN(line$) = 0
i = i1
ELSE
! reset end-of-file checker
!
! i = 0
! if line is the description, skip it.
!
IF EQSTR(line$, desc$)
line$=""
ENDIF
! (m/z, response) points.
!
IF LEN(line$) = 18
CompareOne 1:9, 10:19, rsltArrBound, line$
ENDIF
IF LEN(line$) = 37
CompareOne 29:38, 20:28:00, rsltArrBound, line$
ENDIF
!
IF LEN(line$) = 56
CompareOne 39:47, 10:19, rsltArrBound, line$
ENDIF
IF LEN(line$) = 75
CompareOne 58:66, 10:19, rsltArrBound, line$
ENDIF
ENDIF
ENDWHILE
CLOSE #1
fileName$ = _EXEPATH$"OUTPUT.TXT"
! write out results. Use a second descriptor #2, so two
! files can be open at the same time.
!
OPEN fileName$ FOR OUTPUT as #2
i = rsltArrBound
! output the top hits to the file
!
WHILE i < 0
! Format scalars. Specify precision with [#]
!
PRINT USING #2, "Abundant ion ### is ####.## at ######### counts/", rsltArrBound-i1,M[i],R[i]
i = i-1
ENDWHILE
CLOSE #2
ViewFile fileName$
NAME FileFilter


定量的文件输入/输出

例 12 说明了 GETCOMPOUNDS 和 PUTCOMPOUNDS 命令的使用。这个示例中主要的宏，DisplayCpnds 和 QdbCycle，在目标化合物鉴定/定量的方法数据库中间检索每个化合物。根据化合物在数据库中的顺序进行检索。

DisplayCpnds 显示每个化合物名称、预期保留时间和目标信号。

QdbCycle 和 MyUpdateCpnd 一起根据由 GETCOMPOUND 设定和由 PUTCOMPOUND 读出的系统变量值的改变来模拟一个更新数据库的方法。有关感兴趣的变量列表，请参见关于 GETCOMPOUND 和 PUTCOMPOUND 的在线帮助部分。

在 Data Analysis（数据分析）中检验 DisplayCpnds 和 QdbCycle。在带有有效目标化合物数据库的方法加载后 (~\msdemo\rptmeth.m 由于仅包含很少的化合物因此能做的很好。注意：[~]指化学工作站的安装目录。对于标准安装，这个目录是 \MSDchem。）

例 12

NAME DisplayCpnds
LOCAL index, msg$, CAL_PEAKS, sigDescription$, fmt$
STARTANALYSIS ! sets CAL_PEAKS to number of compounds
index = 1
WHILE index <= CAL_PEAKS
GETCOMPOUND SELECT, index ! sets PEAK_NAME$, EXP_RT, SIG_NUM
IF SIG_NUM = 0
sigDescription$ = "TIC"
ELSE
SPRINT sigDescription$ USING "####.##", SIG_NUM
ENDIF
fmt$ = "%/ RT = ####.### Target signal = %"
SPRINT msg$ USING fmt$, PEAK_NAME$, EXP_RT, sigDescription$
ALERT msg$, 2
index = index 1
ENDWHILE
ALERT "End of Target Compound Database", 2
RETURN

NAME MyUpdateCpnd
PARAMETER cpndNum default 1
LOCAL msg$, fmt$
GETCOMPOUND SELECT, cpndNum, FULL
!
! Here insert macro lines to update compounds. Update
! values of variables set by GETCOMPOUND and read by
! PUTCOMPOUND.
!
fmt$ = "Now simulating update of://%"
SPRINT msg$ USING fmt$, PEAK_NAME$
ALERT msg$, 2
PUTCOMPOUND cpndNum
RETURN

NAME QdbCycle
LOCAL index, CAL_PEAKS
STARTANALYSIS
! sets CAL_PEAKS to number of compounds
index = 1
WHILE index <= CAL_PEAKS
MyUpdateCpnd index
index = index 1
ENDWHILE
RETURN


打印

这部分给出示例来说明了文本和图形打印命令的使用。这些例子也有助于指示如何使用化学工作站命令和系统变量来访问重要报告信息。

单页打印

多页打印

其他宏示例


单页打印

Data Analysis（数据分析）命令处理器执行的宏通过调用 STARTPRINT 来打印带格式的文本和图形，这是通过调用一系列收集和格式化数据的命令，然后调用 ENDPRINT 开始打印。格式化和收集数据的命令为 STRPRINT、WINPRINT、CALIBPRINT 和 FILEPRINT。

STRPRINT 格式化字符串文本，为其指定在打印页上的位置。WINPRINT 与从图形窗口格式化数据的命令相似。

对格式化命令的调用可以用任何顺序进行。它们不需要按照材料打印的顺序进行。例如，可以先格式化一系列图形，然后在图形中打印一系列字符串。

例 13 中的 QuadrantPrint 宏是上面所描述内容的一个简单说明。它应该在加载带有四个可积分峰的数据文件后用于“数据分析”程序。

对宏的调用语句为：

QuadrantPrint whichPeak, mode

whichPeak 确定峰数和打印峰谱的区域。它的值应为 1、2、3 或 4。打印肖像模式选择 1 或 山水模式选择 2。

例 13

NAME QuadrantPrint
PARAMETER whichPeak DEFAULT 1, mode DEFAULT 1
LOCAL row, col, halfWidth, halfHeight
! check Quadrant the data plot is to go
!
IF (whichPeak > 4)
whichPeak = 1
ENDIF
! set orientation system variable
!
IF mode = 1
ORIENTPR = 1
ELSE
ORIENTPR = 2
ENDIF
! Get data for graphical output
!
FILE _DATAPATH$ _DATAFILE$
TIC, R0 RTEINT R0
PEAKNUMBER 1,,R0,R1
DRAW 17,R1
PEAKNUMBER 2,,R0,R2 DRAW 18,R2
PEAKNUMBER 3,,R0,R3 DRAW 19,R3
PEAKNUMBER 4,,R0,R4 DRAW 20,R4
! set row and col, according to orientation
! Row is the row width -- the number of characters
! across the display, minus one. Likewise, col is
! column height
!
PAGESIZE row,col
halfWidth = row/2 - 1
halfHeight = col/2 - 1
! Begin formatting a page of text.
!
STARTPRINT
! upper left quadrant
!
IF whichPeak = 2
! Format the printing of window 17 at column zero,
! line zero. Make the width of the plot in
! characters and height in lines equal to the values
! of halfWidth and halfHeight.
!
WINPRINT 17, 0, 0, halfWidth, halfHeight
ELSE
! Format the printing of a label,
! starting at the center of the quadrant
!
STRPRINT "Quadrant II", halfWidth/2, halfHeight/2
ENDIF
! lower left quadrant
!
IF whichPeak = 3
WINPRINT 18, 0, halfHeight1, halfWidth, halfHeight
ELSE
STRPRINT "Quadrant III", halfWidth/2, 3*halfHeight/2
ENDIF
! upper right quadrant
!
IF whichPeak = 1
WINPRINT 19, halfWidth1, 0, halfWidth, halfHeight
ELSE
STRPRINT "Quadrant I", 3*halfWidth/2, halfHeight/2
ENDIF
! lower right quadrant
!
IF whichPeak = 4
WINPRINT 20, halfWidth1, halfHeight1, halfWidth, halfHeight
ELSE
STRPRINT "Quadrant IV", 3*halfWidth/2, 3*halfHeight/2
ENDIF
! Stop formatting this page and allow
! printing to start.
!
ENDPRINT
RETURN


多页打印

例 14 是一个宏集合，它可以协同工作来打印校准曲线图形。

调用 STARTREPORT 命令，以便使用 QuantResults（定量结果）文件初始化定量报告控制信息。GETRESULT从 QuantResults（定量结果）文件检索有关当前化合物的信息，并将之存储到系统变量中。CALIBPRINT 可产生图形。

STARTJOB 和 ENDJOB 命令用来延迟多页打印任务的打印直到最后一页已安排为一定格式。一个分类变量用于了解一页上还剩余多少空间，以便必要时开始新的一页。

有关在这个宏的例子中使用的故障处理技术的讨论，请参见故障处理。

在加载一个带有一个有效目标化合物数据库（~\msdemo\rptmeth.m 由于仅包含很少的化合物因此能很好的起作用）的方法后，在 Data Analysis（数据分析）中测试这个宏。注意： [~] 表示化学工作站的安装目录。（对于标准安装为 \MSDchem。）

例 14

! PlotCpnd: Print a single plot for compound cpndNum.
!
NAME PlotCpnd
PARAMETER cpndNum, numPerPage
! Difference of max row and current row, minus 2 for footer
!
IF ROW-ROWNUM-3
! Not enough room for next plot. Paginate.
! DoFooter
ENDPRINT
STARTPRINT
PrintTopHeader cpndNum, numPerPage
ENDIF
! Format the plot for the current compound,
! as determined by cpndNum
!
CALIBPRINT STARTCOL, ROWNUM, COL-STARTCOL-2, PLOTHEIGHT, cpndNum, RSLTFILE$
! The plus two is a correction
ROWNUM = ROWNUM PLOTHEIGHT 2
RETURN
! Cleanup: free system resources used for the
! calibration curve printing procedure.
!
NAME Cleanup
PARAMETER doall DEFAULT 0
IF doall = 1
ON ERROR
REMOVE RepAbort
ENDIF
ON ERROR
STARTPRINT
! Allow the fully formatted pages to be printed.
! ENDJOB
REMOVE STARTCOL, DOFOOTER
REMOVE COL, ROW, ROWNUM, CENTER, PAGENUM
REMOVE EQN1$, EQN2$
REMOVE EXP_RT, EXP_RT_HI, EXP_RT_LO, ISTD_AMT
REMOVE CAL_PK_FOUND, CAL_PEAKS, CAL_PK_AMT, CAL_FIT
REMOVE CAL_PK_RET, CAL_ISTD, CAL_TR, AMT_UNITS$, PEAK_NAME$
REMOVE Q1, Q1EVENTS$, Q1_HIRAT, Q1_LORAT
REMOVE Q1_PK_AREA, Q1_PK_RET, Q1_PU, Q1_RR
REMOVE Q2, Q2EVENTS$, Q2_HIRAT, Q2_LORAT
REMOVE Q2_PK_AREA, Q2_PK_RET, Q2_PU, Q2_RR
REMOVE Q3, Q3EVENTS$, Q3_HIRAT, Q3_LORAT
REMOVE Q3_PK_AREA, Q3_PK_RET, Q3_PU, Q3_RR
REMOVE UNC_TP, T0, T1, TGTEVENTS$, USEQIONS
REMOVE RSLTFILE$, STARTPLOTSROW
REMOVE PlotCpnd, PrintTopHeader
REMOVE Cleanup
! DoFooter: print date, time, and page number at
! bottom of page
!
NAME DoFooter
LOCAL page$, footerRow footerRow = ROW - 1
STRPRINT TIME$(),STARTCOL,footerRow
page$="Page "VAL$(PAGENUM)
STRPRINT page$,Col - 8,footerRow
PAGENUM = PAGENUM 1
RETURN
! RepAbort: Report abort and error handler
!
NAME RepAbort
ON ERROR
LOCAL saveerror, saveerror$
saveerror$ = _ERRMSG$
saveerror = _ERROR
Cleanup 0
!assign correct error message
!
VARLOCK OFF
_ERROR = saveerror
_ERRMSG$ = saveerror$
VARLOCK ON
PRINT _ERRMSG$
!
! Fall out of this macro: no RETURN
!

! PrintTopHeader: At top of page, print time of last
! update, and number range of compounds on this page.
!
NAME PrintTopHeader
PARAMETER cpndNum, numPerPage
LOCAL updatestr, numstr, lastonpage
updatestr = "Calibration Curves Last Updated: " CAL_UPDTIME$
STRPRINT CAL_TITLE$,CENTER-LEN(cal_title$)/2,1
STRPRINT updatestr,CENTER-LEN(updatestr)/2,2
lastonpage = cpndNumnumPerPage-1
IF lastonpage > CAL_PEAKS
lastonpage = CAL_PEAKS
ENDIF
IF cpndNum = lastonpage
SPRINT numstr USING "Curve for Compound # (of #)",cpndNum, CAL_PEAKS
ELSE
SPRINT numstr USING "Curves for Compounds # to # (of #)",cpndNum,lastonpage,CAL_PEAKS
ENDIF
STRPRINT numstr,CENTER-LEN(numstr)/2,3
ROWNUM = STARTPLOTSROWRETURN
! PrintAllCurves: Main routine for curve printing procedure.
NAME PrintAllCurvesLOCAL count, numPerPage
RSLTFILE$ = _datapath$ _datafile$ "\quant.res"
ON ERROR RepAbort
FILESIZE RSLTFILE$
IF size = -1
GENERATE ERROR 1, "No results file available!"
ENDIF
STARTREPORT RSLTFILE$
STARTCOL = 2
STARTPLOTSROW = 6
PLOTHEIGHT = 16
ROWNUM = 0
PAGESIZE COL,ROW
CENTER = (COL - STARTCOL)/2
CURVEPLOTSIZE = 18
numPerPage = TRUNC((ROW - STARTPLOTSROW) / CurvePlotSize)
! Begin multiple page formatting job. The argument is a
! title for the job list in the Print Manager
!
STARTJOB _METHFILE$"CalCurve"
PAGENUM = 1
STARTPRINT
cpndNum = 1
PrintTopHeader cpndNum, numPerPage
count = CAL_PEAKS
WHILE cpndNum <= count
GETRESULT ,cpndNum,RSLTFILE$,FULL
PlotCpnd cpndNum, numPerPage
cpndNum = cpndNum 1
ENDWHILE
IF TRUNC(CAL_PEAKS/numPerPage) - CAL_PEAKS/numPerPage<> 0
DoFooter
ENDPRINT
ENDIF
Cleanup 1
PRINT "Calibration Curves Generated !"
REMOVE PrintAllCurves


其他宏示例

如果您对编写宏来定制 Data Analysis（数据分析）中的结果报告很感兴趣，请阅读在线帮助部分有关 GETRESULT ，GETSCALARS ，GETSCALARS INDEX ，GETSCALARS POINT 和 GETSCALARS RESULTS 命令，以及使用这些命令设定的系统变量列表的信息。您还可以参阅以下文件：

示例 15

~\msdemo\dftpp625.m\deuser.mac

示例 16

~\msexe\qual_rpt.mac

其中，[~] 是化学工作站安装的目录（标准安装为 \MSDchem）。

Dftpp625.m\deuser.mac 使用 GETSCALARS ，GETSCALARS POINT ，GETSCALARS INFO 命令和这些命令设定的系统变量，应该能引起您的兴趣。要测试文件中的宏，请先启动 Data Analysis（数据分析），在 File（文件）菜单中选择 Load（调用）选项，并选择 \msdemo 目录下的 dftpp625.d 文件。然后用 MACRO 命令调用 \msdemo\dftpp625.m\deuser.mac ，并执行宏run_method_test.

Msexe\qual_rpt.mac 尤为重要，因为正是由它显示谱库检索的结果，而且它使用 GETSCALARS RESULTS 命令及由改命令设定的系统变量。msexe\qual_rpt.mac 文件中的宏，可以通过调用数据文件并选择 Spectrum（谱图） 菜单中的 Library Search Report（谱库检索报告）来进行测试。


故障处理

ON_ERROR 命令可用于减轻宏中执行错误的影响。通常，调用 ON_ERROR 安排一个特殊的陷阱宏在错误事件中被执行。很难写出陷阱宏因为某种程度上它们必须盲目地行动。很少能预期所有可能发生的错误位置。另外，陷阱宏执行过程中其自身发生错误的可能性也必须特别小心地考虑在内。

有时写出的宏可以纠正一个问题，重新启动指令的正常序列。更多的情况下只是保存部分结果和在宏终止其错误前执行重新初始化或清除程序。本章前面的示例 14 说明了第二种类型的陷阱。基本上，它具有下列形式：

示例 17

1 NAME PlotCpnd
2 ((Print a single plot for compound cpndNum))
3 RETURN
4 NAME PlotCpnd
5 PARAMETER doall DEFAULT 0
6 IF doall = 1
7 RETURN
8 NAME PlotCpnd
9 RETURN
10 RETURN
11 RETURN
12 RETURN
13 ((Remove variables and macros to conserve memory))
14 NAME PlotCpnd
15 NAME PlotCpnd
16 ((Remove time and page number at bottom of page))
17 RETURN
18 NAME PlotCpnd
19 RETURN
20 saveerror$ = _ERRMSG$
21 saveerror$ = _ERRMSG$
22 NAME PlotCpnd
23 VARLOCK OFF
24 saveerror$ 25 saveerror$ 26 VARLOCK OFF
27 PRINT _ERRMSG$
28 ! Fall out of this macro
29 NAME PlotCpnd
30 ((Remove header at top of page.))
31 RETURN
32 NAME PlotCpnd
33 ((Remove 34 RETURN
35 IF doall = -1
36 GENERATE_ERROR 1, "No results file available!"
37 RETURN
38 ((Remove 39 WHILE cpndNum
40 ((Remove graph for current compound))
41 RETURN
42 NAME PlotCpnd
43 NAME PlotCpnd

注意 上面宏包含的行号仅用于参照。行号在宏中是不允许的，将产生错误。

下列讨论假定您熟悉 ON_ERROR 和 GENERATE_ERROR 命令。有关更多信息，请参见在线帮助。

在上面 34 行中，RepAbort 被安装为陷阱，当执行 PrintAllCurves 过程中出现错误时即被执行。RepAbort 确保错误消息和错误号准确反映导致打印任务终止的问题、调用 CleanUp、在主应用对话框的消息行放入错误消息，然后使执行终止。CleanUp 打印所有完整格式化页面然后释放分配给打印任务的内存。

由 RepAbort 做出的第一个调用是 19 行的 ON_ERROR。该命令指定当错误发生时没有陷阱被调用。如果 RepAbort 中的一个指令不能被执行，命令处理器将简单的继续下一个。在许多宏中，无根据的调用宏将是非常坏的想法。然而，这样的调用经常在用为陷阱的宏中使用。很少有选择的余地。

完全遗漏 ON_ERROR 命令是危险的。该情况发生时，RepAbort 中的一个错误将使其停止。错误条件将被送回调用方，PrintAllCurves。然后 RepAbort 将被重新调用，因为这是由 PrintAllCurves 指定的陷阱。这时 RepAbort 中的错误将再次发生。这会导致调用和错误的失控循环。

在 RepAbort 做出的调用中第二个陷阱宏可被指定到 ON_ERROR，但那只会转移问题而没有解决它。仍必须决定是否在第二个陷阱中使用 ON_ERROR 以及如何使用它。

使用调用 ON_ERROR GENERATE_ERROR 是可行的替代。如果该调用在 RepAbort 中做出，当错误发生时所有执行将停止。

ON_ERROR 和 ON_ERROR GENERATE_ERROR 都是陷阱宏中合理的故障处理方式。后者更加保守，当出现错误后继续时可能造成损害的情况下是明智的选择。在 RepAbort 和 CleanUp 中，仅仅是盲目继续而实际上没有什么会丢失。

在 20 行和 21 行，RepAbort 保存当前错误信息字符串和错误号作为预防。当 RepAbort 及其调用者执行时另一个错误发生，新错误的消息和号将覆盖保存的变量 _ErrMsg$ 和 _Error 的内容。保存这些变量的内容确保 RepAbort 打印的错误消息会给用户或 PrintAllCurves 的调用方有关错误的更准确的陈述。在退出前打印错误消息是个不错的想法，因为这样会减少某个其他消息在它被读取之前将其覆盖的机会。

下一个 RepAbort 对 CleanUp 的调用在 22 行。CleanUp 必须认真写出，因为在正常运行的最后它也会被 PrintAllCurves 调用。

CleanUp 中的 ON_ERROR 调用与 RepAbort 中使用的 ON_ERROR 原因相同。

11 行 调用的 STARTPRINT 取消未完全格式化的任何页面的打印。当 CleanUp 从 RepAbort 被调用时，可具有取消打印当前页的效果，因为在对 STARTPRINT 的最后一个调用后不可能再做出对 ENDPRINT 的调用。

12 行对 ENDJOB 的调用使所有完全格式化的页面被打印。在 CleanUp 中放入一个对 ENDJOB 的调用，而其他地方没有对它的调用，是个好策略。这样 RepAbort 可用其打印所有可挽救的页面，做出两个对 ENDJOB 的调用也没有危险。

从 CleanUp 返回到 RepAbort 后，RepAbort 恢复并打印错误消息。为允许所有执行在该处停止，它没有调用 RETURN。如果调用 RETURN，命令处理器将试图在导致错误的指令后继续 PrintAllCurves 的执行。这里使用的策略是保存已被格式化的页面后停止。


第六章 — MS 化学工作站命令分类

本章包含 MS 化学工作站的命令分类列表。使用本章来学习对于不同任务可使用哪些命令。可使用列表来了解相关命令。有些命令出现在多个列表中。

有关所有 MS 化学工作站命令的完整信息，请使用在线帮助。

窗口输出和位置

菜单定义和控制

文件系统

数组、矩阵和集合操作

算术

字符串对象支持

Microsoft Windows DDE

其他操作系统服务

命令处理器的应用程序

宏和控制流

用户交互作用

仪器数据提取（仅适用于 Data Analysis（数据分析））

仪器数据显示（仅适用于 Data Analysis（数据分析））

仪器数据处理（仅适用于 Data Analysis（数据分析））

化学工作站集成（仅适用于 Data Analysis（数据分析））

RTE 集成（仅适用于 Data Analysis（数据分析））

定性分析和质谱数据库（仅适用于 Data Analysis（数据分析））

目标化合物鉴定和定量分析（仅适用于 Data Analysis（数据分析））


窗口输出和位置

CMDLINE

CPTITLE

CPTITLE$( )

ECHO

ECHOMODE

GETWINLOC

PRINT

SPRINT

WINMOVE

WINSIZE


菜单定义和控制

MENUBEG

MENUCMD

MENUCMDFN

MENUEND

MENUHLP

MENUNEW

MENUSEP

MENUSTP

MENUVAR


文件系统

CLOSE

COPY

DELETE

FILEATTRIBUTES$( )

FINDFIRSTFILE( )

FINDNEXTFILE( )

FILESIZE

FILESTAT( )

FREESPACE( )

GETCWD$( )

INPUT #

MKDIR

OPEN

PRINT #

RENAME

RMDIR

SELECTFILE


数组、矩阵和集合操作

ARRAYSTAT( )

COLS( )

DIM

INSERT

JOIN

NUM( )

PULLOUT

ROWS( )


算术

ABS( )

BIT_AND( )

CEIL( )

EXP( )

FLOOR( )

LN( )

LOG( )

MOD( )

ROUND( )

SQR( )

SQRT( )

TRUNC( )

VAL$( )


支持的字符串对象

EQSTR( )

INSTR( )

LEN( )

LOWER$( )

UPPER$( )

VAL( )


Microsoft Windows DDE

DDEADVISE

DDEEXECUTE

DDEINITIATE ( )

DDEPOKE

DDEREQUEST

DDETERMINATE


操作系统的其他维护

DATE$( )

DOSRUN

EXEC( )

GETINIINT( )

GETWINDOWID

MTIME( )

PRINTTEXTFILE

SLEEP

TIME( )

TIME$( )


命令处理器的应用程序

CHECK( )

COMMANDS

DLLINSTALL( )

GETINFO( )

HELP

LOGGING

RUNCLASS( )

TOPCMD

TOPDOT

VARLOCK

VERSION


宏与控制流

BYE

ELSE

ENDIF

ENDWHILE

EVALUATE

GENERATE_ERROR

IF

LOCAL

MACRO

ON_ERROR

REMOVE

RETURN

WHILE


用户交互作用

ALERT

INPUT

INPUT6

LOADMETHPANEL

SAVEMETHPANEL


仪器数据提取

AVERAGE（平均）

CHROMATOGR（色谱图）

EIC

FILE（文件）

SCAN（扫描）

SPECTRUM（谱图）

TIC


仪器数据显示

_TAB

ALLCONT

ANNOTATE（注释）

CLEAR（清除）

CLIP

DRAW（画）

FORMAT（格式）

MAKEBAR

MAKECONT

MENUSTATE( )

REFRESH

SETWINATTRIBUTE

STACK（堆栈）

TABULATE（制表）

WINDOW（窗口）

WINEXIST( )

WINPOSITION

ZOOM（选定坐标）

ZOOMOUT（缩小）


仪器数据处理

operator + ( )

operator + ( )

operator + ( )

_GET

_NML

_XFM

BSB

CLEAR

GETSCALARS

MSCLIP

MSTRUNC

NORMALIZE

PEAKNUMBER

PEAKVARS

POINTS

RECALL

SAVEMISC

STORE

SUBZERO( )

TRANSFORM


化学工作站积分

AUTOINT（自动积分）

AREAREJECT（面积截除）

AREASUM（面积求和）

BASELINE（基线）

CLREVENTS（清除事件）

EDITEVENTS（编辑事件）

INITREJECT（初始截除）

INITTHRESH（初始阈值）

INITWIDTH（初始峰宽）

INTEGRATE（积分）

INTEGRATOR（积分器）

NEGPEAKS（负峰）

PEAKWIDTH（峰宽）

SAVEEVENTS（保存事件）

SHOULDERS（肩峰）

SOLVENTS（溶剂）

TANSKIM（切线斜滑）

THRESHOLD（阈值）


RTE 积分

MI

RTEINT

RTEINTPARMS


定性分析和质谱数据库

EDITHEADER（编辑文件头）

EDITSTRATEGY（编辑策略）

FINDBYCAS（通过 CAS 号搜索）

GETMSREF

MW（分子量）

PBMSEARCH（PBM 检索）

QUALPARMS

QUALRPTOPT

SAVESTRATEGY（保存策略）

VIEWPBMTEXT（查看 PBM 文本）


目标化合物的鉴定与定量分析

ADDPEAKS

CALIBPRINT

CLEARCPNDS

CPDANALYZE

DELLEVEL

DLGQDBSETUP

EDITCPNDS

ENDSET

EXPORTRSLT

GETCOMPOUND

GETRESULT

LOADQUANTMETH

PCTRPTOPT

PUTCOMPOUND

QUANTPARMS

QUANTRPTOPT

RECALIB

SETUPCALIB

STARTANALYSIS

STARTREPORT

STARTSET

UPDATECALIB

UPDATERSLT

VIEWCALCURVE


Hpmsduntitled00000458

A-B

ALS（自动液体进样器）

amu（原子质量单位）

Amu Gain（Amu 增益）

Amu Offset（Amu 补偿）

Annotate（注释）

Autotune（自动调谐）

Average spectra（平均光谱）

BFB（溴氟苯）

BNA compounds（碱/中/酸性化合物）


Hpmsduntitled00000459

C

Calibration（校准）

Calibration curve（校准曲线）

Calibration level（校准级）

Calibration level ID（校准级 ID）

Calibration sample（校准样品）

Calibration table（校准表）

ChemStation integrator（化学工作站积分器）

Chromatogram（色谱图）

CI mode（CI 模式）

Clipboard（剪贴板）

Continuing calibration（连续校准）

Curve fits（曲线拟合）


Hpmsduntitled00000460

D

Daily calibration（日校准）

DFTPP

Dwell time（停留时间）

动态梯度变化


Hpmsduntitled00000461

E-F

EIC（提取离子色谱）

Emission（发射）

EMVolt(电子倍增器电压)

EntLens（入射透镜）

Environmental analysis protocol（环境分析协议）

External standard calibration（外标法校准）

Extracted ion chromatogram（提取离子色谱）

Filtered raw data（过滤的原始数据）

Forward search（正向检索）


Hpmsduntitled00000462

G-I

HED（高能打拿极）

Initial calibration（初始校准）

Integration（积分)

Internal standard（内标）

Ion Focus（离子聚焦）

ISTD（内标）


Hpmsduntitled00000463

J-L

JCAMP

Library（谱库）

LSC（谱库检索化合物）


Hpmsduntitled00000464

M-O

Macro（宏）

Mass Gain（质量增益）

Mass Offset（质量补偿）

Mass spectral library（质谱谱库）

Mass spectrum（质谱）

Matrix（基质）

Matrix spike（基质添加）

Matrix spike compound（基质添加化合物）

Matrix spiking（添加基质）

Method（方法）

m/z


Hpmsduntitled00000465

P-Q

Parametric retrieval（参数检索）

PBM search（PBM 检索）

Percent Report（百分比报告）

PFTBA

PFDTD

Qualifier ion（特征离子）

Quantitation database（定量数据库）

Quantitative analysis（定量分析）

QuickTune（快速调谐）


Hpmsduntitled00000466

R-S

Recalibration（再校准）

Relative response factor（相对响应因子）

Repeller（推斥极）

RTE Integrator（RTE 积分器）

Sample（样品）

Scan mode（扫描模式）

Semivolatile compounds（半挥发性化合物）

Sequence（序列）

SIM mode（SIM 模式）

SIM ramping（SIM 梯度变化）

Standard（标准）

Surrogate（替代）


Hpmsduntitled00000467

T-Z

Target ion（目标离子）

Target compounds（目标化合物）

Target tune（目标调谐）

Target tune compound（目标调谐化合物）

TIC（总离子流色谱）

Time Reference Peak（时间参比峰）

Total ion chromatogram（总离子流色谱）

Tune evaluation（调谐评价）

Tune evaluation compound（调谐评价化合物）

Tuning（调谐）

Unknown（未知）

VOA compounds（挥发性化合物）

Xray（X-射线）(HED)


配置 CI 5973 的故障排除

本节概述了配备有 PCI/NCI（正/负化学电离）的 5973 MSD 的故障排除方法。大部分 5973 MSD 的故障排除信息同样适用于 CI MSD。

关于 CI 的常见故障

故障排除的技巧和诀窍

空气泄漏

与压力相关的症状（概述）

没有反应气流时，真空度不足

有反应气流时压力高

反应气流速改变，而压力不变

与信号相关的症状（概述）

无质谱峰

没有反应气信号或信号很低

没有 PFDTD 信号或信号很低，而反应离子正常

噪音超出警戒或信噪比过低

最大峰出现在质荷比 19 处

质荷比 32 处出峰

与调谐相关的症状（概述）

反应气离子比难于调节或不稳定

电子倍增器电压过高

不能完成自动调谐

峰宽不稳定


SIM 自动安装对话框

在 Data Analysis（数据分析）中选择 Method / Generate AutoSIM Method（方法/生成自动 SIM 方法） ，会显示 Automatic SIM Setup （SIM 自动安装）对话框。该对话框会自动由定量方法生成 SIM 采集方法。

峰与峰组启动之间的最小时间，0-1 分钟。

它是指 SIM 峰组切换时间与当前峰组中最末一个峰的峰尾到下一峰组第一个峰开始出峰之间的最小绝对时间。

单位是分钟，缺省值为 0.017 分钟（1 秒）。增大该参数会减少峰组数。

峰的最小扫描次数或 SIM 周期

SIM Setup（SIM 设置）算法会调整每个峰组中离子的驻留时间，以获得峰组中最窄峰的最小扫描次数或 SIM 周期。

峰组中最窄峰的扫描次数缺省值为每个峰 10 次。减小扫描次数会增加驻留时间。

峰组启动位置间隙，0-100%

当前峰组中最末一个峰的峰尾到下一峰组第一个峰开始出峰之间的时间差称为“间隙”。下一个峰组中第一个峰的出峰位置应该在“间隙”的中部 (50%) 附近。当该值为 60% 到 70% 时，受上一峰组中最后一个组分的峰拖尾的影响较小。

增大该参数会使峰组的开始时间更接近峰组中第一个峰的出峰时间；> 50% 的数值则意味着更接近于下一个峰的起始时间，可允许峰拖尾。减小该参数 (< 50%) 会使峰组的开始时间更接近最后一个峰。

峰展宽因子，0-100%

“峰展宽因子”增加了峰与峰组启动时间之间的最小时间。时间的增量等于“峰展宽因子”与下一峰组中第一个峰的峰宽的乘积。该参数可用于补偿峰拖尾、随时间色谱的老化或组分的饱和。

增大该参数会减少峰组数，增加峰组中的化合物组分数，尤其是产生峰拖尾的化合物。

每个离子的最大驻留时间，单位为 ms,10-9999

如果某一峰组中含有只有一种离子的组分，算法将基于峰的最小扫描次数或 SIM 周期参数计算出一个较大的驻留时间。该参数确定了每个离子的最大驻留时间，可保证峰的扫描次数更多。

低 (0) 或高 (1) 分辨率 SIM

低分辨率 SIM 调节 MSD 电路产生稍宽的质谱峰，并且强度稍高，即更灵敏。

高分辨率 SIM 调节 MSD 电路产生稍窄的质谱峰，从而尽可能降低了相邻质量组分的干扰。在高分辨率下操作要求将离子质量优化为 0.05 amu。


批重新处理对话框

选择 Batch Mode Data Analysis（批模式数据分析）中的 Batch Method / Batch Reprocess（批处理方法／批重新处理）选项，会进入此对话框。

Complete Batch（处理完全批）

将用“当前”处理方法设定值以与第一次收集数据完全相同的次序重新处理完全批。

Calibrators First（先处理校准物）

将在处理样品“前”进行校准步骤；当批的校准物分布较广，而必须在更新所有校准后进行样品的最后处理时，这一点很有帮助。

Samples Only（只处理样品）

仅重新处理样品。


索引

目录 索引


目录

目录 索引


5973 质量选择检测器故障排除

常见症状

色谱症状

质谱症状

压力症状

温度症状

故障提示

空气泄漏

污染

检查脏离子源


6890 GC 阀

使用阀进样。

通过选择 阀1，阀2, 或者 双阀 来指定进样时所用的阀。

色谱仪准备就绪后方可运行。


7673 进样器参数

GC 进样器参数

使用 GC Injector Parameters（GC 进样器参数）对话框来指定 GC 进样器的操作参数。

指定要使用前进样器、后进样器或两个进样器同时使用。单击相应的选项按钮：

使用前进样器 - 前进样器参数有效

使用后进样器 - 后进样器参数有效

前后进样器同时使用 - 前后进样器参数均有效

此处的选择决定了哪些进样器（前进样器、后进样器、或两者）参数可进行编辑，并与方法一起保存。

本对话框内容：

Injection Volume（进样体积）

Washes（洗涤）

More Button (6890 GC)（更多按钮 (6890 GC)）

Configuration Button（配置按钮）

OK/Cancel/Help Buttons（确定/取消/帮助按钮）

本对话框内容（对于使用 PTV 进样口的多次进样）：

显示对应 Multiple Injections（多次进样）的 GC 进样器参数。

多次进样仅在具备程序升温挥发 (PTV) 进样口和装于 6890 GC 上的正确配置的 G1513A GC 进样器时才能进行。

在进样器屏幕上选择 Configuration Button（配置按钮）来配置 Multiple Injections（多次进样）的 GC 进样器。


风扇未连接或有连接故障

  1. 移去上下的 MSD 顶罩。

    警告！不要移去任何其他顶罩。会有危险的高电压。

  2. 检查高真空泵风扇。确认它在向 MSD 鼓风。

  3. 如果高真空泵风扇没有工作，检查它的接线。确认已安全连接。如果风扇连接正确且仍然无法工作，更换风扇。有关更换高真空泵风扇的说明，请参见 MSD 手册。

  4. 检查电路模块风扇（确认它从电路模块中抽出空气）。

    警告！请勿打开电路模块。内部有危险的高电压。如果电路模块风扇不能工作，请与安捷伦科技公司维修代表处联系。


缩写指令

缩写命令

键入命令时，所用字母只需能同当前宏和命令列表下的其他命令区分开来即可。系统按如下顺序检索列表：

  • 与宏命令列表准确匹配

  • 与命令列表准确匹配

  • 与宏命令列表中的缩写匹配

  • 与命令列表中的缩写匹配

因此，命令的缩写方式会有所不同。如果加入的宏含有与命令缩写匹配的缩写，系统会先找到宏。要避免这种情况，可使宏的命名约定中所用的起始两三个字母在系统宏和命令列表中是唯一的。


关于 BSB 数据

您如果查看一份 BSB 数据列表，可能会发现由于数据的精度表示而出现差异。MS 对象的表示范围是一个有符号的 32 位整数。在一次扫描记录中，显示容量仅为 14 位尾数（在压缩 16 位指数表示中还包括 2 位指数）。这可能导致 2*2e-14 = 2e-13 = 1/8096 的相对舍入误差。

BSB 从两个不同的 MS 对象（31 位精度）的差开始，在一个新的数据文件中写出扫描记录（14 位精度）。然后从新的数据文件中检索出扫描记录时，记录损失了 17 位的精度。

这一精度损失并不显著，但是除非知道精度限制，否则对于扣除本底值的光谱数据相对于分别进行的减数和被减数的扫描记录，在列表中所观察到的差值将是惊人的。


累计积分峰

所有信号被积分后，把积分峰的记录加到一个峰列表（通过 ADDPEAKS 命令）中，并按保留时间进行分组（通过 ENDSET 指令）。生成的分组中最多有一个峰描述为具有任何定义的信号 (TIC 或 EIC m/z)，但可以包含许多不同的峰。

几分钟内给出的用户指定的 Signal Correlation Window（信号相关窗口）决定分组情况。算法产生一个峰分组列表，按照由信号相关算法计算出的分组保留时间对该表进行排序。


采集状态指示灯

可以使您轻松查看当前运行状态（如果正在运行）：

系统正装载软件。 | 设置仪器。
运行中。 | 运行结束。在柱箱温度梯度中加入 Post Tim（运行后时间）会出现。
出现故障，停止运行。 | 系统空闲（无任何运行）；系统就绪可进样。
系统配置为脱机状态（未连接 GC 或质谱）。 |


进样管路中的活化点

活化点可导致许多症状。最常见的症状是峰拖尾。其他症状包括峰前伸和保留时间增加。

  1. 更换一个经去活化处理的新进样口衬管。

  2. 确认衬管已正确安装。衬管中的柱碎屑可导致峰拖尾。

  3. 更换进样口密封垫。

  4. 将色谱柱从进样口移开。截去前 10 厘米，重新把色谱柱装到进样口。

有关进样口的维护，请参见 GC 仪器附带的帮助文档。


可用实际值

下面是可用实际值列表中每项的监测信息。

  • 实际值： 监测项的实际值，由 GC 传输。

  • 设定值： 监测项的目标值。

  • 状态： 仪器的就绪状态。如果仪器尚未就绪，会说明当前原因。

可用实际值

实际值

设定值

状态
_______________________________________________________

辅助压力 (3/4/5)

辅助温度 (1/2)

色谱柱流量 (1/2)

_______________________________________________________

当前运行时间

检测器空气流量（前/后）

检测器阳极流量（前/后）

_______________________________________________________

检测器 H2 流量（前/后）

检测器尾吹气流量（前/后）

检测器参比流量（前/后）

_______________________________________________________

检测器温度（前/后）

进样口压力（前/后）

进样口温度（前/后）

_______________________________________________________

进样口总流量（前/后）

MPV（多位阀）位置

MPV 状态 (7)

_______________________________________________________

柱箱温度

信号值 (1/2)

阀状态 (1-8)


在 GC 中添加第 3 和第 4 个信号

要在 GC 中获得四个分析信号，GC 必须配置有 35900 作为数据采集器来提供信号 3 和信号 4。

要使用附加信号：

  1. 按照信号 1 和信号 2 的常用准备方法来准备分析方法。

  2. 双击 GC 仪器图形界面的 (BMC ADC.bmp) 图标来显示和编辑 35900 信号 3 和信号 4 参数。也可在 View（查看）菜单中选择 Instrument Control（仪器控制）来处理这些参数。

  3. 根据分析需要编辑 35900 信号参数。


调节参数菜单 － CI 调谐 (5972 MSD)

AdjParam（调节参数）菜单可使您控制所有重要的质谱仪参数，同时在图形扫描和谱图中监测其影响。也可通过梯度变化电压和观察对三个调谐质量的影响对特定参数进行精细调谐。

Edit MS Params（编辑 MS 参数） | 进入 Edit Parameters（编辑参数）对话框。
Edit Acq Params（编辑采集参数） | 进入 Acquisition & Display（采集和显示）对话框。
PCI Methane reagent masses（PCI 甲烷试剂质量） | 快速设定调谐质量来检测 17、29、41 amu 处的重要甲烷试剂离子。
PCI PFTBA masses（PCI PFTBA 质量） | 快速设定调谐质量来检测 CI 中 69、219、414 amu 处的 PFTBA 试剂质量。
PCI Isobutane reagent masses（PCI 异丁烷试剂质量） | 快速设定调谐质量来检测 57、43、39 amu 处的异丁烷试剂质量。
PCI Ammonia reagent masses（PCI 氨试剂质量） | 快速设定调谐质量来检测 18、35、52 amu 处的氨试剂质量。
Purge Cal Valve（吹扫校准阀） | 吹扫 PFTBA 校准阀和空气瓶。仅在初次安装时使用。


调节参数菜单 — 目标调谐

调节参数菜单可使您控制所有重要的质谱仪参数，同时在图形扫描和谱图中监测其影响。也可通过梯度变化电压和观察对三个调谐质量的影响对特定参数进行精细调谐。

Edit MS Params（编辑 MS 参数） | 进入 Edit Parameters（编辑参数）对话框。
Edit Acq Params（编辑采集参数） | 进入 Acquisition & Display（采集和显示）对话框。


调节补偿值

如果正在使用 ECD 或 NPD，用 Adjust..（调节...）按钮来调节检测器灵敏度。

给要调节的检测器指定下列值（有关详细信息，请单击下面各项）：

ECD：调节补偿值, Hz

NPD：调节补偿值, pA

平衡时间，min

如果想立刻开始调节过程，按下 Start 按钮：

完成整个过程大约需要 10 - 30 分钟。在这段时间里，可以通过观察提示框中的状态提示来跟踪调节进程。如果要取消调节过程，按下 Abort 按钮：

调节过程完成后，单击 OK（确定）关闭 Adjust Offset（调节补偿）对话框。

如果在这个对话框中选择不进行调节过程，单击 OK（确定）关闭。下次单击 OK（确定）或 Instrument Control（仪器控制）屏幕的 Apply（应用）（有关详细信息，请参见按钮）时，调节过程会自动开始。


调节补偿值, Hz

给检测器灵敏度指定设定值。参比电流会增加或减少直到检测器输出频率稳定且等于设定值。调节过程约 30 秒。

使用 Adjust Offset（调节补偿值）在不同 ECD 上获得相同基线或确定每天的基线都保持一致。

注:如果检测器在基线上的输出频率低于 100 Hz，灵敏度会下降。使用 Adjust Offset（调节补偿值）增加输出值。

有效范围： 20 至 200 Hz


调节补偿值, pA

给检测器灵敏度指定设定值。调节铷珠电压直到检测器输出频率稳定且等于设定值。

注:调节过程不包括打开检测器气流,也不包括激活电流加热铷珠。

有效范围： 10 至 99 pA


Windows 脚本文件的高级链接

Exit.ttx 退出 AdvanceLink（高级链接）

FromRTE.ttx 从 RTE 传送

LoadRTE.ttx 加载按钮并启动脚本

NewPath.ttx 输入新的传送路径


开启空气冷却

Air Cooling On（空气冷却开启）

要激活使用压缩空气加速冷却，选择 Air Cooling On（开启空气冷却）复选框。

本对话框中其他项目：

Gas（气体）

Heater（加热器）

Ramps（梯度）

Pressure（压力）

Total Flow（总流量）


空气流，mL/min

要激活空气流流向检测器中，在 On 复选框中加上 X。

由 GC 传送的 Actual（实际）流量是只读显示。

EPC 设定值： 0 至 800 mL/min


空气流，mL/min

要激活空气流流向检测器中，在 On 复选框中加上 X。

由 GC 传送的实际流量为只读显示。

EPC 设定值： 0 至 320 mL/min


通向冷却风扇的进气口被堵塞

进气口堵塞会使风扇不能有效冷却扩散泵。

  1. 取下 MSD 的上下盖。

    警告！不要取下任何其他盖。会有危险的高电压。

  2. 检查 MSD 下盖前面的进气口通道。确认它们没有堵塞。

  3. 检查风扇上的安全防护网。确认它没有堵塞。

    警告！在 MSD 开启时不要取下风扇安全防护网。

有关打开 MSD 盖的说明，请参见 MSD 硬件手册。


MSD 中空气泄漏

寻找与空气有关的质谱峰（m/z 18、28、32 和 44 或 m/z 14 和 16）。如果在这些质量处观察到显著峰，检查是否出现空气泄漏。


全部报告

对话框的该部分适用于全部报告。它可以：

包含非目标峰

包含二级碰撞峰

该部分也可使您忽略具有如下情况的目标化合物的详细报告：

  • 遗漏的（两种模式下）

  • 含有超过范围的特征离子（GC/MS 模式）

检查对应的对话框排除这些项。


ALS — 定义

ALS 是指“自动液体进样器”，用于帮助自动进样过程。一旦把样品瓶放入样品瓶架之后，仪器即可恢复对样品瓶的操作，用溶剂和样品洗针，然后注射指定数量的样品。

ALS 可以自动进样多达 100 个样品。


环境温度

实验室的正常室温(以 [image] C 为单位)。

Ambient Temperature（环境温度）设定值用于设定有效利用冷却液的最佳温度。它决定可使用冷却液的温度：

  • 当设定值为环境温度以上 35°C时，可使用固定的冷却操作。

  • 当设定值为环境温度以上 55°C时，可使用快速冷却操作


amu — 定义

amu（原子质量单位）有时用来指质谱仪产生的离子碎片大小。准确术语为质荷比，简写为 m/z。


AMU 增益或补偿过高

重新调谐 MSD 或降低 amu 增益和补偿。


Amu 增益（参数）

Amu 增益通过调节质量过滤器的直流电压与射频电压之比来影响质谱峰宽度。电压比值越高峰形越窄，但是电压比对高质量的峰比对低质量的峰影响更大。

MSD | 最小值 | 最大值 | 步长大小
5972 / 6890 | 0 | 1023 | 1
5973 | 0 | 4095 | 1


Amu 补偿（参数）

AmuOff（Amu 补偿）通过调节质量过滤器的直流电压与射频电压之比来影响质谱峰宽度。电压比值越高，所有质量的峰越窄。

最小值 | 最大值 | 步长大小
0 | 255 | 1


分析数据

如何

显示和处理色谱图

显示和处理质谱图

在谱库中检索谱图

定量

生成报告

检查混合模式数据文件

给图形显示作注释

复制一个窗口到剪贴板

打印色谱图和光谱

放大色谱或光谱

缩小色谱图或光谱

参见

数据分析菜单

GC 和 MS 校准工具

DOLIST 工具

DOSCAN 工具

EASYID 工具

参数检索工具

峰纯度工具

QEdit


注解 — 定义

注解可以被添加到在 Data Analysis（数据分析）或 Parametric Retrieval（参数检索）模式下显示数据的任何图形窗口中。

单击注释出现或消失处的按钮，即可开始注释。


注解对话框

该对话框用于在图形显示中添加或删除注解。

Adding（添加）

使用 Justify（对齐）使文本置于选定点。右对齐是指文本出现在选定点的左侧；左对齐是指文本出现在选定点的右侧。

键入您希望在图形显示中出现的文本。按键盘上的 Enter 键，或单击对话框中的 Add（添加）。

Deleting（删除）

点中的文本显示在文本框中。按键盘上的 Enter 键，或单击对话框中的 Delete（删除）。

另见

MS 化学工作站中的字体选择


阳极流量，mL/min

要激活阳极吹扫流量，在 On（开启）复选框中加上 X。

EPC 设定值：0 至 15 mL/min


应用按钮

单击 Apply（应用）按钮下载新参数或上次单击 Apply(应用)（或 Edit Parameters...（编辑参数...））后被修订的参数。化学工作站会清除所有蓝色标记和 X。

注:在您改正所有非法值前，化学工作站不会下载任何参数。


应用稀释因子

应用样品乘数于：

这部分对话框允许您选择应用在采集软件或可选的 Quantitation Parameters（定量参数）对话框输入的样品乘数。样品乘数是对报告浓度的乘法操作。样品乘数 “2” 可以使被影响的化合物类型的报告浓度加倍。通过选中对应的对话框，样品乘数可用于：

  • 内标

  • 系统监测化合物/替代物

  • 目标化合物


数组变量（定义）

数组变量是一个可以存储一组一维或二维数值的变量。您可以给一维数组中指定名为 varname[1]，varname[2] 等的“槽”赋值。二维数组包含指定名为 varname[1,1]，varname[1,4]，varname[2,1] 等的槽，具体名称取决于数组大小。

有关数组变量的使用，请参见 DIM 和 ARRAYSTAT 命令。


指定新色谱柱目录号

每次向目录中添加新色谱柱后，化学工作站会提示您给它指定一个名为目录号的唯一识别号。

首次分配

依据您认为重要的编号系统给第一个色谱柱输入一个唯一的目录号。

注:如果选用 Inventory#（目录号）的末尾字符是数字的系统（例如 ABC123 ），则可以使用 Incremen（增量）按钮（参见下文）。

所有其他的分配

下拉式列表显示了已被指定给色谱柱的 Inventory#（目录号）。您可以：

  • 在新色谱柱的目录号下输入新号，或

  • 在以数字字符结尾的下拉列表中选择一个已有的 Inventory#（目录号），用 Incremen（增量）按钮产生下一个最高的唯一 Inventory#（目录号）。化学工作站会在新色谱柱的目录号下自动显示新号。例如，如果你选择了已有的 Inventory#（目录号）ABC123，使用 Increment（增量）按钮会产生新的Inventory#（目录号）ABC124。

另见

Add New Column to Inventory（在目录中添加新色谱柱）

OK/Cancel/Help Buttons（确定/取消/帮助按钮）


给变量赋值

变量通常由命令设定。例如:

SCAN 273

在“数据分析”中把值 273 赋值给变量 Scan_Num，同时将其对应的保留时间赋值给变量 Ret_Time。

在命令行或者宏中，可以把变量及其值用等号 (＝) 隔开来给变量赋值。给字符串变量赋值时，必须把字符串用双括号括起来。例如：

Name$ = "Jane Doe"

除非先调用 VARLOCK 命令，否则不能给保留变量赋值。


自动积分 — 仅适用于 GC

自动积分

选择 Chromatogram / Autointegrate（色谱/自动积分）时，Data Analysis 软件会设法找到当前色谱的最佳积分参数并进行自动积分。自动积分是一个完全自动的两步过程。如果 Autointegrate（自动积分）的结果不尽人意，您可以自己设置初始事件（使用色谱/MS（或 GC）信号积分参数），然后选择 Chromatogram / Integrate（色谱/积分）。

如何自动积分

  • 首先将 Initial Area Reject（初始面积截除）设为 0。

  • 自动确定当前色谱的 Initial Events Threshold（初始事件阈值）和 Initial Peakwidth（初始峰宽）的最佳值（使用积分参数对话框中的 Shoulder Detection（肩峰测定）的当前设定）。

  • 使用这些初始事件进行积分。


自动调谐 (5973 MSD)

自动调谐

使用 PFTBA 质量 69，219 和 502 进行自动调谐，使仪器灵敏度在质量范围内达到最大。如果某种应用情况只要求灵敏度最大而不要求 100% m/z 69，35 - 85% m/z 219 和 1 - 5% m/z 502 的传统丰度比，则可以使用这种调谐。这种调谐也是对 DFTPP 或 BFB 进行手动调谐的良好起点。

见于 5973 MSD。


自动调谐 — 定义

Autotune（自动调谐）将所有 MSD 参数调节为预定目标值。它能找到质谱峰、获得足够的响应和分辨率、优化质量 3 的响应、优化其他质量的响应和分辨率，并且准确指认质量。

首次安装质谱系统以及对 MSD 进行了任何维护后都需要进行自动调谐。


辅助通道

选择要配置或编程的辅助通道。Aux（辅助）对话框中的参数会根据您是否选择加热通道（＃1 或 ＃2）或压力通道（＃3、＃4 或 ＃ 5）而变化。

本对话框中其他项目：

Description（说明）

Heater (thermal channels)（加热器（加热通道））

Cryo Focus Configuration（低温冷凝配置，选项无效）

Type（类型）（热通道）

Pressure (pressure channels)（压力（压力通道））

Gas (pressure channels)（气体（压力通道））

Ramps（梯度）


辅助按钮 (6890)

辅助按钮
单击此按钮设定传输线温度。


辅助压力控制器配置

检查安装在 6890 系列 GC 上的辅助压力控制器的配置信息。尽您所能回答，然后单击 OK（确定）。

指定用于 GC 压力控制器的气体：

  • ArCH4 （氩气/甲烷 5%）

  • He（氦气）

  • H2（氢气）

  • N2（氮气）

  • 空气

使用 Description of use（使用说明）对控制器功能进行更详尽的描述。

有关辅助压力控制器的更多信息，请参见 Aux（辅助）。

OK/Undo/Help Buttons（确定/撤销/帮助按钮）


辅助加热区配置

检查安装在 6890 系列 GC 上的辅助加热区的使用的配置信息。化学工作站会使用这些信息，根据加热区用途将其温度设定为适当值。

指定在 GC 上安装辅助加热区的目的，然后单击 OK（确定）：

  • 在阀箱中加热阀或进样口，或

  • 用作 MSD 或 AED 传输线。

如果将加热区配置为其他用途，请选择 Other（其他）。

使用 Description of use（使用说明）对加热区功能进行更详尽的描述，例如“开关阀加热器。”

有关辅助加热区的更多信息，请参见 Aux（辅助）。

OK/Undo/Help Buttons（确定/撤销/帮助按钮）


平均谱图 — 定义

Average spectra（平均谱图） 组成特定峰的 GC 曲线的光谱可进行平均，以获得对该峰更具代表性的谱图并降低谱图的随机本底噪音。

获取平均光谱的鼠标操作是单击鼠标右键，点中并拖动所需的色谱保留时间区域。


平均速率

通过色谱柱的气流速率（以 cm/sec 为单位）。由 GC 传送的 Actual（实际）速度为只读显示。


后退按钮

当您已经一步一步地进入所需的主题后，您可以用 Back 按钮返回各操作步骤。重复使用该按钮，直至返回到包含您所需的相关主题处。

如果没有找到所需的相关主题，进入 Contents（目录），然后选择另一个起始主题。


本底数据分析

Data Analysis（数据分析）的 Report Manager（报告管理器）部分是在本底中运行的 MSDA.EXE 的另一例。尽管 Report Manager（报告管理器）MSDA 具有 Data Analysis（数据分析）的所有功能，但它缺乏 Environmental Data Analysis（环境数据分析）菜单，这是因为 Report Manager（报告管理器）MSDA 被设计为由 Report Manager（报告管理器）而不是由交互用户所控制。


三级真空规与真空规控制器之间连接不良

确认电缆已安全连接到三级真空规和真空规控制器。

警告！ 当真空规控制器有电或 MSD 处于真空状态时，不要连接或断开三级真空规的电缆。

如果已经排除了其他可能的原因，尝试更换电缆。


检测器接线连接不良

  1. 放空 MSD。

  2. 打开真空多路连接管。

  3. 检查检测器（电子倍增器）接线。确认连接良好。确认接线没有接触到其他金属表面。

有关开启真空多路连接管的说明，请参见 MSD 硬件手册。


进样技术不佳

在分流模式下，拙劣的手动进样技术可能导致色谱峰峰顶分裂或呈锯齿状。进样必须平稳迅速。


离子源接线连接不良

  1. 放空 MSD。

  2. 打开真空多路连接管。

  3. 确认电源板和离子源之间的所有接线已安全连接。

有关开启真空多路连接管的说明，请参见 MSD 硬件手册。


信号电缆连接不良

  1. 取下 MSD 的上盖。

  2. 检查信号电缆。确认它牢固连接在侧板上。


三级真空规管损坏

  1. 关掉真空规控制器。

  2. 放空 MSD。

  3. 断开连接到三级真空规管的电缆。

  4. 取出并检查三级真空规管。如果灯丝断裂，更换三级真空规管。

有关更换三级真空规管的说明，请参见 MSD 硬件手册。


铷珠

要激活加热铷珠的电流，在 On（开启）复选框中加上 X。


最佳匹配选择

在此处，所有被认为符合目标化合物项的峰组都被保存到一个含有保留时间、特征信息和积分信息的列表中。现在可从该列表中选择将输入 Quantitation（定量）步骤的的峰。

用户已经预先从下面的 Ident by（识别对象）列表中选定了 Best Match（最佳匹配）的标准：

  • 仅匹配保留时间

  • 最佳的 QVALUE

  • 最大峰响应（最大峰面积/峰高）

  • 所有项均匹配

  • 基于 Retention Tim（保留时间）和 Qualifier Ratio（合格率）的混合标准

在最后一项中，每一项成功匹配都经过“通过/不通过”合格率的测试。在所有通过测试的成功匹配中，Retention Tim（保留时间）最接近 E 的匹配被认为是 Best Match（最佳匹配）。仅在没有任何匹配通过测试时，将 Retention Tim（保留时间）最接近 E 的匹配选作 Best Match（最佳匹配）。

All Hit（所有成功匹配）选项平等考虑所有匹配项，在用户以后手动决定 Best Match（最佳匹配）时使用。


BFB — 定义

BFB（溴氟苯）作为调谐参比化合物用于挥发性化合物分析（EPA 方法 624）。


BNA 化合物

BNA 化合物是在有机溶剂提取的分析方法中使用的碱性/中性/酸性化合物。BNA 化合物也称作半挥发性化合物。


夹样器中有瓶

当夹样器接收到移动另一个样品瓶的指令时其中已经有一个瓶。可能的原因是前次操作中断。取走夹样器中的瓶。如果检测夹样器中样品瓶有误，化学工作站也会报告其有故障。


按钮

单击 Apply（应用）按钮下载新参数或上次单击 Apply（应用）（或 Edit Parameters...（编辑参数...））后被修订的参数。化学工作站会清除所有蓝色标记和 X。

注意：在您改正所有非法值前，化学工作站不会下载任何参数。

单击 OK（确定）按钮下载新参数或上次单击 Apply（应用）（或 Edit Parameters...（编辑参数...））后被修订的参数，然后离开 Instrument Control（仪器控制）屏幕。

注意：在您改正所有非法值前，化学工作站不会下载任何参数。

单击 Cancel（取消）按钮离开 Instrument Control（仪器控制）屏幕，不下载任何新参数或上次单击 Apply（应用）（或 Edit Parameters...（编辑参数...））后被修订的参数。

单击 Help（帮助）按钮，显示与当前打开的仪器对话框相关的帮助内容。

关于其他按钮的帮助和与其对应的对话框相关的帮助内容一起给出。


计算按钮

如果您选择了 DetSource（检测离子源）并按下 Calc（计算）按钮，化学工作站会:

  • 根据当前仪器配置的柱设定值和流量自动计算出预期的 Minimum Peak Width（最小峰宽） [image] [image] ，并且

  • 设定最佳的 Data Rate（数据传输效率） 数值。

注意：化学工作站使用的是仅为当前运行过程计算的最佳值。

本对话框内容：

Source（离子源）

Data Rate（数据采样频率）

Minimum Peak Width（最小峰宽）

Save Data（保存数据）


计算/生成报告

第一次对数据文件进行定量分析并生成报告时，必须选择 Quantitate / Calculate（定量/计算）。定量结果文件（METHODNAME.RES）存储在数据目录下。如果该文件已经存在，它会被覆盖。可以通过选择 View / QEdit Quant Result（查看/定量编辑定量结果） 修改结果文件。

报告类型和目标在 Quant Report Options（Quantitate / Generate Report（定量/生成报告））对话框中指定，并采用 Quant Report Options（定量报告选项）对话框（Quantitate / Report Options（定量/报告选项））中指定的选项。

后续报告可以通过选择 Quantitate / Generate Report（定量/生成报告） 由已有的定量结果文件生成。报告类型和目标在 Quant Report Options（定量报告选项）对话框中指定，并采用 Quant Report Options（定量报告选项）对话框中指定的选项。

注意：Quantitate / Calculate（定量/计算）总是生成摘要输出在屏幕上。


校准 1

 如果能估计色谱柱长，则使用 Set Length...（设定长度）按钮根据估计的色谱柱长和最新校准直径进行校准（如果色谱柱从未经过校准，则采用其标识直径）。


校准 2

 如果您已将色谱柱截短，测量所截下部分的长度。使用 Adjust Length...（调节长度）按钮根据截断部分的长度和最新校准直径进行校准（如果色谱柱从未经过校准，则采用其标识直径）。


校准 5

 如果您想采用标识值用于 6890 系列 GC 和化学工作站的压力和流量计算，使用 Reset to Original Manufacturer's Specs（重新设定到原始的制造商规格） 按钮用制造商规格代替当前校准数据。


校准 3/4

 如果您已经测量过一个非保留峰的滞留时间（也称为“死时间”），则可以：

  • 使用 Calc Length...（计算长度）按钮根据您的测量结果和色谱柱的最新校准直径进行校准（如果色谱柱从未经过校准，则采用其标识直径）。

  • 或使用 Calc Diameter...（计算直径）按钮根据您的测量结果和色谱柱的最新校准长度进行校准（如果色谱柱从未经过校准，则采用其标识直径）。


校准菜单 — CI 调谐 (5973 MSD)

校准菜单 — CI 调谐

5973 MSD 配置为仅使用 CI。Calibrate（校准）菜单允许您校准质量轴和丰度。

Mass axis（质量轴） | 校准质量轴。
Mass #2 / Mass #3 widths（质量 2/质量 3 宽度） | 将质谱峰宽校准至 0.5+/-0.06 amu（峰的半高宽）。
Adjust abundances（调节丰度） | 将丰度最大的调谐质量调节为合格数值。


校准 — 定义

校准是定义仪器对已知量的某特定化合物的响应的过程。所得的校准曲线用于确定未知浓度的样品中该化合物的量。

对于色谱数据，所测的仪器响应是积分峰高度或面积。无相互干扰（无共洗脱）的化合物的混合物可用于在单次校准中定义多个化合物的响应；然后将这些化合物的保留时间和响应因子填到校准表中。


校准曲线 — 定义

校准曲线是从一个或多个校准样品获得的响应数据相对浓度所作的图。曲线显示了在相同的仪器条件和存在恒定浓度的内标物（如果存在内标物）的情况下，一个给定化合物的不同浓度所对应的面积计数。

为获得可靠结果，校准曲线应该具有至少两个浓度级，两个浓度级之间应包括未知样品中的预期含量。


校准数据文件

显示当前数据文件名。该数据文件是加入定量数据库中的校准数据来源。


校准信息

曲线拟合

校准曲线拟合指定了对化合物校准数据（浓度/响应）的数学处理方法。

选择理想的曲线拟合。许多定量方法要求使用特殊的曲线拟合。如果您在 Quant Database Globals（全局定量数据库）对话框的设定中没有指定正确的曲线拟合，您可以在此逐个化合物地改变拟合方法或使用 Calibrate / Update/Global Update（校准/更新/全局更新）整体改变。

查看校准曲线：

  • 一旦校准了一个化合物后，点击Plot（绘图）。

  • 确定最佳的统计拟合：

  • 查看线性拟合的相关系数。相关系数越接近 1.000, 所选直线的拟合程度越好。

框中的该部分和图表中均列有用于计算拟合的方程项以及其他相关数据。

另见

Weighted Linear Regression（加权线性回归）


校准浓度级 — 定义

校准浓度级是校准曲线上的一点。它的定义是某一浓度及其所对应的响应。


校准浓度级 ID

指定 level ID（浓度级 ID）（数字或名称） 添加一个 浓度级 时，它的 ID 必须不同于当前数据库中使用过的任何 ID。

重新校准或删除时，ID 必须与一个已有的 ID 严格匹配（字符及大小写）。

欲查看当前数据库中使用过的名称列表：

请单击下拉框中的箭头。


校准浓度级 ID — 定义

校准浓度级 ID 是用来跟踪获取该校准级数据的样品的名称或标记。


校准样品 — 定义

校准样品是指含有已知浓度的用于定量的化合物（目标化合物）的样品。它也可称为校准标准物或标准混合物。


校准表

校准表是在校准样品分析中获得的每个目标化合物的含量和响应的集合。软件允许校准表最多可有 20 个浓度级，它是根据初始校准结果以及日校准的一个校准浓度级建立的。


校准标题

可选。如果希望具有标题，请输入标题。输入结果会作为标题行显示在每个定量报告的标题中。


校准阀工作异常

  1. 启动自动调谐。

  2. 校准阀开始运行时注意听阀发出的卡嗒声。如果没听到卡嗒声，则阀或阀的控制电路工作异常。更换校准阀。

有关更换校准阀的说明，请参见 MSD 硬件手册。


校准阀工作异常

校准阀可能部分阻塞或出现故障。检查其他可能的原因。如果这些都不是引起故障的原因，尝试更换校准阀。

有关更换校准阀的说明，请参见 MSD 硬件手册。


校准瓶为空或几乎为空

如果校准标样瓶是空的，您会看到错误提示：Not enough signal to begin tune（没有足够信号开始调谐）或可能是 No peaks found（没有发现峰）。如果标样瓶几乎是空的，则可能观察到诸如不一致的峰宽等症状。

  1. 取下 MSD 的上盖。

  2. 检查校准标样瓶中 PFTBA 的高度。如有必要，加入 PFTBA。

有关重新注满校准标样瓶的说明,请参见 MSD 硬件手册。


载气供给压力过低

载气供给压力至少应比压力设定值高出 10 psi。若不满足此要求，请提高载气供给压力。如有必要，请更换载气供给。


更换色谱柱 1/2

化学工作站保存有所使用的色谱柱以及其规格的目录。

每次安装新的或不同的色谱柱时，必须更新色谱柱目录。

如果已安装的色谱柱：

  • 不在当前目录中，单击 Add...（添加...）按钮：

  • 已在当前目录中，单击 Install...（安装...）按钮：

OK/Help Buttons（确定/帮助按钮）


更换色谱柱 1/2

化学工作站保存有所使用的色谱柱以及其规格的目录。

每次：

  • 安装一根新的或不同的色谱柱，或

  • 需要校准当前安装的色谱柱（例如，截断色谱柱末端后）时，必须更新色谱柱目录。

如果已安装的色谱柱：

  • 不在当前目录中，单击 Add...（添加...）按钮：

  • 已在当前目录中，单击 Install...（安装...）按钮：

如果希望校准当前已安装的色谱柱，单击 Calibrate...（校准...）按钮：

确定/帮助按钮


化学工作站积分器 — 定义

化学工作站积分器可令人满意地对所有类型的色谱图进行积分，包括基线确定困难和出现负峰的谱图。您可以通过设定积分参数来控制积分过程，通常称为“积分事件”。

注意： 化学工作站积分器不能用于 GC/MS 环境的分析。


化学工作站积分器类型代码

开始的两个字符表示如何通过在峰的起始点描述基线来构造基线：

B = 色谱基线

H = 水平基线

P = 基线贯穿

V = 峰谷垂直线

第三个字符表示峰积分

A = 异常中止、失真、过度、不足

空白 = 正常

第四个字符给出峰类型：

+ = 面积求和的峰

- = 负峰

S = 溶剂峰

T = 切线斜滑峰

空白 = 正常峰


选择化合物名称

在谱库中检索每个积分峰后，与该积分峰对应的本对话框依次出现。化合物名称的选择有：

  • 不含 CAS 号的最佳谱库匹配的名称

  • CAS 号和前三个（最多）谱库匹配的名称

  • RT: XXX；离子：XXX（保留时间和主要离子）

  • 用户指定（键入您的任意选择）

Add （添加） | 允许您向数据库添加化合物并移向下一个峰。
Skip （跳过） | 允许您跳过该化合物并移向下一个峰。连续按三次 Skip（跳过）按钮会出现提示： You have selected Skip 3 successive times.（您已经连续三次选择 Skip（跳过）。）Stop now?（现在停止？） 选择 Yes（是）则用已加入的化合物创建一个数据库；选择 No（否）则继续检查色谱图。
ISTD （内标） | 允许您将化合物标记为 Internal Standard（内标）并移向下一个峰。
Help （帮助） | 显示关于本对话框的在线帮助。

给化合物命名后，软件将提示您 File has not been quantitated.Quantitate now?（文件尚未被量化。现在量化？）单击 Yes（是）对数据文件进行量化并显示下一个对话框。

返回自动定量设置


色谱图坐标设定

允许您用所选的坐标设定方法来对所选的色谱图进行坐标设定。选择 Chromatogram / Chromatogram Scaling（色谱图/色谱图坐标设定）可使用该功能。

选择要设定坐标的信号

允许您选择哪个（些）信号来进行坐标设定。大多数情况下，除非加载了一个包含多重信号的数据文件，否则您只能看到一个信号（TIC 或提取离子色谱）。选择信号，单击 OK（确定）进入下一个对话框选择坐标设定方法。选择了坐标设定方法和坐标设定值后，返回该对话框。单击 Done（完成）设定色谱图的坐标，或如果您希望设定其他色谱图的坐标，选择色谱图然后重复该过程。单击Done（完成）时，对两个色谱图均进行坐标设定。

选择坐标设定方法

有三种坐标设定方法可供使用：

  • 输入 Y 轴的绝对值使用输入的 Y 轴显示最大值进行坐标设定。

  • 最大峰 > 输入 RT 在输入数据后将 Y 轴显示最大值设定为数据文件中的最高丰度。该方法在数据文件中存在大的溶剂峰时很有用。

  • 与输入的 RT 最接近的峰将当前信号中所有峰定位，找出与输入值最接近的峰，将 Y 轴最大值设为该峰的响应。’


色谱评价菜单 — RTL

本菜单包含对色谱的分辨率、峰拖尾和降解进行评价的选项。

Evaluate Resolution （评价分离度） | 计算使用者所选的两个峰的分离度。
Evaluate Tailing （评价拖尾） | 计算 6 号窗口中使用者所选的一个峰的拖尾。
Evaluate Degradation （评价降解） | 计算 6 号窗口中使用者所选的两个峰的降解。


色谱评价菜单 — EasyID 和 QEdit

本菜单包含对色谱的分离度、峰拖尾和降解进行评价的选项。

Evaluate Resolution （评价分离度） | 计算使用者所选的两个峰的分离度。
Evaluate Tailing （评价拖尾） | 计算 6 号窗口中使用者所选的一个峰的拖尾。
Evaluate Degradation （评价降解） | 计算 6 号窗口中使用者所选的两个峰的降解。


CI 模式 — 定义

CI 模式是指 MSD 的化学电离设置。它包括化学电离离子源、流量控制器、主板开关、接口部件和用户提供的反应气。


CI 调谐菜单 -5972 MSD

CI 调谐菜单 (5972 MSD)

File（文件） | 允许您执行多种文件管理和打印任务。
Tune（调谐） | 用于 CI 的安装和自动调谐
Execute（执行） | 允许您检查质谱分辨率和线形。
Calibrate（校准） | 允许您校准质量轴和丰度。
Ramp（梯度） | 允许您梯度设定质谱仪参数。
AdjParam（调节参数） | 允许您设定和监测反应物和校准物质量，吹扫校准阀。
Status（状态） | 允许您查看 MSD 的状态。
View（查看） | 允许您切换到 Instrument Control（仪器控制）视窗。
Abort（异常中止） | 异常中止当前过程。


CI 调谐 -5972 MSD

CI Tune（CI 调谐）视窗是从 Instrument Control（仪器控制）中的 Instrument / Perform MS Autotune（仪器/执行 MS 自动调谐）菜单项进入。CI 调谐允许您调节化学电离（CI）模式（仅在配备有化学电离附件的 MSD 中有效）操作中的 MS 参数。有关化学电离和 CI 调谐的正确安装，请参见 CI 附件硬件手册。

如何

安装和调谐 CI

设定并监测反应物和校准物质量，吹扫校准阀

参见

CI Tune（CI 调谐）菜单


剪贴板 — 定义

剪贴板是指由 Microsoft Windows 为从 Windows 应用程序拷贝的项目提供的临时存储区。复制或剪切操作将所选项目放到剪贴板，替代原有的项目。该项目即可通过粘贴操作被另一应用程序获得。


CO 下一化合物

CO Next Compound（CO 下一化合物）调出文件中的下一个化合物。您也可在化合物信息窗口（7 号窗口）中双击鼠标右键来实现此功能（要转到上一个化合物，请在化合物信息窗口中双击鼠标左键）。


色谱柱 1/2

如果您在 6890 系列 GC 的原来位置上刚安装了一根新的或不同的色谱柱，请单击 Install（安装）或 Change Column...（更换柱...） 按钮鉴别色谱柱：

查看当前安装的色谱柱的配置信息。回答后单击 OK（确定）。

有关详细信息，请单击下面各项：

Column Inlet/Outlet（色谱柱进口/出口）

Installed Column（已安装的色谱柱）

Manufacturer's Specifications/Column Dimensions（制造商规格/色谱柱尺寸）

OK/Undo/Help Buttons（确定/撤销/帮助按钮）


色谱柱 1/2 信息

下列当前设定值定义了您所选择用于进样的色谱柱。化学工作站使用这些数值来确定流量和温度设定值。有关详细信息，请单击下面各项：

Length（长度）

Diameter（直径）

Film Thickness（膜厚）

Max Temperature（最高温度）

继续 Quick Setup（快速安装）过程：

转到下一对话框。

返回上一对话框。

要创建并显示 Quick Setup（快速安装）方法：

要取消 Quick Setup（快速安装）过程：


色谱柱流失

色谱柱流失主要发生在程序升温运行中。检查质谱图中色谱柱流失的特征离子。如果存在特征离子，从 GC/MSD 接口中取出色谱柱进行老化。

有关老化毛细管色谱柱的说明，请参见 MSD 硬件手册。


色谱柱补偿检测器

进行色谱柱补偿运行时，请为曲线 1 和曲线 2（对应色谱柱 1 和 2）指定您要使用的检测器（前或后）。（有关色谱柱补偿运行的更多信息，请参见 StartColumnCompRun（开始柱补偿运行）。）

本对话框中其他项目：

Pressure Units（压力单位）

Lock Keyboard（键盘锁定）


色谱柱连接

Quick Setup（快速设定）方法会影响使用所选色谱柱（1 或 2）进行的 1 微升进样。

注意：如果色谱柱与一个非 EPC 进口连接或色谱柱连接不完全（例如，色谱柱与进口连接但未与检测器连接），色谱柱选项将显示为灰色（无效）。

对于安装的每根色谱柱，化学工作站将显示：

  • 与其连接的进口和检测器，以及

  • 进口配置的载气（He、H2、N2 或 ArCH4）。

如果使用分流/不分流进口，请为 Quick Setup（快速设定）进样指定分流或不分流操作模式。

欲继续 Quick Setup（快速设定）过程：

转到下一对话框。

返回上一对话框。

要创建并显示 Quick Setup（快速设定）方法：

欲取消 Quick Setup（快速设定）过程：


色谱柱膜厚与分析物浓度不匹配

分析物浓度相对于当前色谱柱膜厚过高。确认分析物浓度与色谱柱膜厚相匹配。


色谱柱流量减小

如果色谱柱流量减小，保留时间会变长。


色谱柱被截短

每次在进口或检测器接口安装色谱柱时都要切下一小段。色谱柱长度的减少会缩短保留时间（尤其是对于较短的色谱柱）。


色谱柱进口/出口

从每个列表中选择一个来指定色谱柱如何连接：

进口 | 出口
前进口 | 前检测器
后进口 | 后检测器
Aux 3 | MSD
Aux 4 | AED
Aux 5 | 其他
未指定 |

该位置上如果没有安装色谱柱，请在进口列表中选择Unspecified（未指定），在出口列表中选择 Other（其他）。


色谱柱老化

检查色谱柱的进样次数。关于一根色谱柱的使用时间长短没有固定的规定，但色谱柱会逐渐流失少量的液相。这会减少保留时间。


色谱柱或隔垫流失

检查质谱图中有无色谱柱或隔垫流失的相关离子。

如果质谱图显示出现色谱柱或隔垫流失，请采取下列步骤：

  1. 放空 MSD。

  2. 从 GC/MSD 接口取下色谱柱。

  3. 老化色谱柱。

  4. 烘烤隔垫。升高进样口温度直至基线降至合格水平。

注意

请勿超过色谱柱或隔垫的温度限制。

有关放空 MSD 和老化色谱柱的说明，请参见 MSD 硬件手册。


色谱柱堵塞或因螺帽过紧而碎裂

色谱柱可被进样口或 GC/MSD 接口处的过紧螺帽压碎。色谱柱也可被色谱柱碎片堵塞。检查色谱柱两端。如有必要，截断柱两端的前几厘米（请记住，这样会略微改变保留时间）。


色谱柱类型

指定所用色谱柱是 Capillary（毛细管）还是 Packed（填充）色谱柱。如果选择 Packed（填充）色谱柱，Length（长度）、Diameter（直径）和 Film Thickness（膜厚）选项将显示为灰色。


色谱柱按钮 — 6890

色谱柱按钮
单击此按钮来配置色谱柱并设置流量和压力梯度程序。


商业谱库

可购买下列商业谱库用于 MS 化学工作站的 PBM 检索功能：

  • Wiley Library - G1035

  • NIST Library of Mass Spectra and Subsets - G1033

  • Pfleger/Maurer/Weber Drug Library - G1039

  • Pesticide Library - G1038

要查看这些谱库中的项目（不可编辑）：

  1. 请选择 Spectrum / Edit Library（谱图/编辑谱库）。

  2. 从 Edit PBM Library（编辑 PBM 谱库）框中选择 Select Library（选择谱库），选择想要查看的谱库。

  3. 在 Edit PBM Library（编辑 PBM 谱库）框中选择 Edit Existing Entry（编辑已有的项目）。您将被提示给出项目的编号。


比较算法

由预筛选器从数据库（参比谱图）中选出的每个压缩谱与未知谱图中的所有峰（已归一化）相比较。每个参比谱图与未知谱图的相似性按如下方法评估：

  1. 通过计算 r 值比较参比和未知谱图中每个峰的丰度：

r = 未知丰度/参比丰度

  2. 确定参比谱图的基峰存在于未知谱图中时，其相对丰度是否高于 Minimum Estimated Purity（最小估计纯度）参数值。如果答案为否，则该参比谱图不能作为可能的匹配项，转到步骤 1 评价下一个参比谱图。

  3. 标记缺失峰。缺失峰是指那些存在于参比谱图但不存在未知谱图中的峰，它们的数值大于 Flag Threshold（标记阈值）的参数值。这不适用于扫描范围外的质量。如果有四个或更多的峰缺失，终止比较，该参比谱图不能作为可能的匹配项，转到步骤 1 评价下一个参比谱图。

  4. 使用最小 r 值设定参比谱图的坐标。

  5. 计算置信因子（K）、污染百分比（CON）和匹配的可靠性。

  6. 如果起用了倾斜，将倾斜函数应用于参比谱图，重复步骤 5。

  7. 保留所找到的该参比谱的最高可靠性因子。

  8. 标记刚使用的 r 值，获取下一个最小的 r 值并用其重复步骤 4—7。重复此步骤直到至少三个 r 值被标记。

  9. 转到下一个参比谱，从步骤 1 开始。

预筛选器生成的参比谱图列表完全经过比较算法处理后，保留一个包括 20 个最佳匹配项的列表。


浓度/响应数据

每次处理一个校准文件，并且单击 Update Calibration（更新校准）框中的 Do Update（执行更新）向数据库添加新数据时，把浓度级 ID、浓度和响应记录在此处。最多允许记录 20 项。这些是校准曲线中采用的数据点。

它们被记录后即可进行编辑。（如果在更新校准后决定采用手动积分或需要忽略特定化合物的校准级浓度时，可对其进行编辑。）


浓度单位

该数值打印在未知样品定量报告中的计算浓度旁。可在此处逐个化合物地输入该数值或在 Quantitation Database Globals（全局定量数据库）对话框中输入。最多可使用 7 字符，但只报告前 5 个。


压缩谱图

PBM 检索采用两种方式优化质谱数据库：

  • 每个谱图在添加到谱库中时被压缩。

  • 对压缩谱图进行分类以便快速、方便地检索。

要压缩谱图

  1. 请选择要存储的峰数目 (N)；该数值范围可为 15 到 26，与分子量成正比。

  2. 向谱图中的所有峰赋以 U+A 值（显著性）。

  3. 选择最显著的 N 个峰加入压缩谱图。必须遵守下列标准：

— 必须包括基峰。

— 必须包括分子离子。

— 必须包括合理丢失（例如比分子离子小 15.36 的峰）。

— 不合理的中性丢失和增益的强度减少（例如比分子离子小 8 的峰）。

  4. 根据 U+A 值选择一个最显著的峰。

压缩算法确保那些统计最显著的峰以及逻辑最显著的峰均保留在压缩谱图中。

分类

在质谱数据库中根据压缩谱图中最显著的峰对谱图进行排序。


配置参数按钮

配置按钮

单击 Configuration Button（配置按钮）显示 Injector Configuration（进样器配置） 对话框。


配置

要指明您将如何使用阀（例如，切换色谱柱），请选择 Valve #（阀号）（1 到 8），然后从下列列表中选择合适的配置Type（类型）。有关更详细信息，请单击任一Type（类型）。

Not configured（未配置）

Multiposition（多位）

Gas Sampling（气体进样）

Switching（切换）

Other（其他）

注意：对阀进行配置后，它的 On（开启）复选框变为有效。请参见 Valve（阀）。

本对话框中其他项目：

Valve（阀）


载气管线堵塞

确信管路未被挤压、弯曲或堵塞。


载气气路管堵塞

确信载气气路管未堵塞。如果载气气路管堵塞，会发出警报，并且 GC 键盘上可能会出现一条提示。


报告管理器目录

目录

概述

如何

配置报告管理器

管理报告系统

查看请求

区分请求的优先次序

删除请求

排序文件列表

从外部来源导入

参见

菜单

术语表


连续校准 — 定义

连续校准是用于验证校准的定期进行校准样品分析的过程。软件要求校准表中包含名为 CC 的连续校准浓度。连续校准也称为日校准。


复制/粘贴化合物

欲复制一个化合物

  1. 在 Edit Compounds（编辑化合物）的化合物列表中，选择希望复制的化合物并单击 View（查看） 按钮。

  2. 单击 OK（确定）或 Cancel（取消）。化合物信息现在存在缓冲区内。

  3. 滚动到化合物列表中希望粘贴信息的输入点，单击 Insert Above（插入上面）。出现第 1 步中所选的化合物信息。

  4. 按照您的希望进行任意修改（确保将化合物重命名以避免化合物名称重复）。单击 OK（确定），然后单击 Yes（是）保存修改。

欲将化合物移动到另一位置

  1. 在 Edit Compounds（编辑化合物）的化合物列表中，选择希望移动的化合物并单击 View（查看） 按钮。

  2. 单击 OK（确定）或 Cancel（取消）。现在化合物的信息存在缓冲区内。

  3. 把滚动条移动到化合物列表中希望移动信息的输入点，单击 Insert Above（插入上面）。出现第 1 步中所选的化合物信息。

  4. 在其中一个字段上键入（例如，如果 Ret Time（保留时间）是 11.548，重新键入 11.548）。单击 OK（确定），然后单击 Yes（是）保存修改。

  5. 把滚动条往后滚动选择原化合物。单击 Delete（删除）按钮。


复制或打印

要复制所有显示：

请单击 Copy（复制）或 Print（打印）。

要复制部分显示：

  1. 在要复制或打印的最后一行下单击。闪烁标记会移至该行。

  2. 将指示器移至要复制或打印的首行。

  3. 按住 Shift 键，单击鼠标左键。所选部分会突出显示。

  4. 请单击 Copy（复制）或 Print（打印）。


相关窗口

在处理当前数据文件时用来确定积分目标信号和特征信号时发现的峰是否源于同一色谱流出物（即具有相同保留时间）。单位为分钟。


创建新谱库

在 Edit PBM Library（编辑 PBM 谱库）对话框中单击 Create Library（创建谱库），显示 Create New Library（创建新谱库）框。一旦您创建了新的用户谱库，就向谱库中提供内容（请参见 Parametric Retrieval（参数检索）中的 To Add a New Entry（添加新项目）和 Library menu（谱库菜单））。

要创建新谱库

  1. 键入新谱库的名称（最多 8 个字符）。扩展名 .L 自动添加。

  2. 单击 OK（确定）。谱库将置于文本框上的目录中。

要将谱库放入不同的目录中

请键入完整路径。不可将谱库放在多于 9 层的子目录中。


为第二个信号创建 Quant DB Entries（定量数据库项目）— GC Only

一旦在 GC 模式下输入一个化合物信号，您就可以使用 Calibrate / Create Quant DB Entries for Second Signa（校准/为第二信号创建定量数据库项目）将列表复制到确认运行的信号。一个名为 Column #2（色谱柱 2）的化合物被添加到第一个信号的化合物列表末尾。第一个信号的化合物复制在该项目下。#2 加到每个化合物名称中。Column #2（色谱柱 2）项目仅为一个位置标志符，用来分开两个信号的化合物。创建第二个信号项目后，使用 Calibrate / Edit Compounds（校准/编辑化合物）或 View / EasyID（查看/EasyID）来修改 Column #2（色谱柱 2）信号的保留时间。


低温配置

PTV 进口温度可降至 -60 [image] C （用 CO2 冷却）或 -160 [image] C （用液氮冷却）。

  • 如果 Cryo Config（低温配置）按钮禁用，则必须按下 6890 GC 前面板上的 [Config] [Front Inlet] 为 PTV 进口配置冷冻剂类型。

  • 如果 6890 GC 柱箱已完成低温操作配置，则只有 6890 GC 对话框中 [Config] [Front Inlet] 下指定的低温类型是有效的，或是无效的。

Cryo On（启动低温）

选择此框启用低温冷却。若此框为空，低温冷却关闭。

Cryo use temp（低温使用温度）

如果选择了 Cryo On（启动低温）参数，该参数即为低温冷却用来保持其进口温度设定值的温度上限。在该温度以上，不用低温冷却控制温度。

Timeout Detection On（启动暂停检测）

如果柱箱达到平衡后运行不在指定时间内（5 到 120 分钟，缺省为 30 分钟）启动，则低温暂停，进口温度关闭。关闭低温暂停可禁用该功能。建议开启低温暂停，因为在一个序列结束或自动操作失败时低温暂停可节省冷冻剂。也可使用后序列方法。

Fault Detection On（启动故障检测）

如果连续低温操作 16 分钟进口仍未达到设定值，关闭进口温度。注意这是指达到设定值的时间，而不是温度稳定在设定值上和仪器准备就绪的时间。

本对话框中其他项目：

Mode（模式）

Gas（气体）

Heater（加热器）

Ramps（梯度）

Pressure（压力）

Total Flow（总流量）

GasSaver（载气节省）（如果色谱柱已被定义）


低温配置

低温阀可允许您在室温以下操作柱箱。柱箱温度可达到的最低值依赖于所安装阀的类型。

不需进行低温冷却或低温冷冻剂耗尽时，关闭低温操作。否则可能无法获得合适的柱箱温度，尤其是在室温附近时。

为低温操作指定下列配置参数。有关详细信息，请单击下面各项：

Cryo On（启动低温）

Quick Cooling On（启动快速冷却）

Timeout Detection On（启动暂停检测）

Fault Detection On（启动故障检测）

本对话框中其他项目：

Oven（柱箱）

Oven Ramp（柱箱梯度）

Oven Configuration（柱箱配置）


低温故障

如果连续低温操作 16 分钟后柱箱仍未达到其温度设定值，On（开）将关闭柱箱。

Off（关）则禁用 Cryo Fault（低温故障）选项。


低温冷凝配置（选项）

低温冷凝配置（选项不可用）

低温冷凝部件是一个安装在 GC 柱箱内部毛细管色谱柱头处的捕集阱，采用液氮或液体二氧化碳低温冷却。冷却的低温冷凝部件将溶质浓缩后用一个快速加热器使其挥发。这一过程可改善峰形。由于温度变化局限在色谱柱的一个 4 英寸的区域内，低温冷凝部件可以迅速加热、冷却同时节省冷冻剂。

Cryo On（启动低温）

要启用低温冷凝部件，在 Cryo On（启动低温）复选框中加上 X。不需要低温冷却或冷却剂耗尽时，应该关闭该部件。可对低温冷凝定时编程作为一个 Run Table（运行表）事件。

Timeout Detection On（启动暂停检测）

启动暂停检测时，如果在指定的暂停期（分）内运行没有启动，低温冷凝部件将关闭。建议将 Cryo Timeou（低温暂停）保持设定在 On（开）状态以节省冷冻剂。

有效时间范围：10 至 120 分

Fault Detection On（启动故障检测）

启动故障检测时，如果连续低温操作 16 分钟后仍未达到温度设定值，低温部件将关闭。注意这是指达到设定值的时间，而不是在设定值处达到平衡和仪器准备就绪的时间。

本对话框中其他项目：

Aux Channel（辅助通道）

Description（说明）

Heater (thermal channels)（加热器（热通道））

Type (thermal channels)（类型（热通道））

Pressure (pressure channels)（压力（压力通道））

Gas (pressure channels)（气体（压力通道））

Ramps（梯度）


启动低温

激活低温（室温以下）操作。低温冷却在高于 [image] C, 即室温设定值（本组框中指定的）以上 35 [image] C 时启用。


低温暂停

Timeout（暂停）指定的若干分钟时间内没有启动仪器，将关闭柱箱和低温（室温下）冷却。

选择 On（开）启用 Cryo Timeout（低温暂停），或 Off（关）禁止使用。


曲线拟合

校准曲线拟合指定了对化合物校准数据（浓度/响应）的数学处理方法。如果定量过程不要求特定类型的曲线拟合，请使用加权线性回归，除非您已完成了过程的确立、查看过校准数据并确定需要使用一种特殊拟合。

此处所选的校准曲线拟合被指定用于在当前定量设置过程中添加到定量数据库中的每个化合物。数据库中已有的化合物不受影响。

要改变某个化合物的曲线拟合：

请选择 Calibrate / Edit Compounds（校准/编辑化合物），更改 Edit Compounds（编辑化合物）对话框页面 1 中的设定，单击 OK（确定）。

要改变所有化合物的曲线拟合：

请选择 Calibrate / Update/Global Update（校准/更新/全局更新），选择 Curve Fit（曲线拟合）按钮，更改设定，然后单击 OK（确定）。


曲线拟合 — 定义

有六种类型的曲线拟合可供选用：

  • Weighted Linear Regression（加权线性回归）

  • Linear Regression（线性回归）

  • Average of Response Factors（响应因子平均）

  • Quadratic Regression（二次回归）

  • Quadratic Regression forced through the origin.（过原点的二次回归。）

“响应因子平均”采用对所有校准浓度级的响应因子平均值作为定量分析的响应/浓度比。


日校准

日校准是用于校验校准的定期校准样品运行过程。软件要求校准表中包含名为 CC 的连续校准级。日校准也称为连续校准。


 数据分析

有关详细信息，请单击下面各项：


数据分析菜单

File（文件）菜单

Method（方法）菜单

Chromatogram（色谱）菜单

Spectrum（光谱）菜单

Calibrate（校准）菜单

Quantitate（定量）菜单

Tools（工具）菜单

View（查看）菜单


数据文件信息

列出在当前数据文件采集时文件头包含的信息。

File（文件）

数据文件名称，包含路径。

Operator（操作者）

在 Acquisition - Sample Information（采集 - 样品信息） 或 Start Run（开始运行）对话框输入的操作者信息。

Acquired（时间）

运行开始的日期和时间。

Sample Name（样品名称）

前 16 个字符作为期望条码输入 Start Run（开始运行）或 Sample Log Table（样品日志表）对话框中。该行中的其他部分是样品名称信息，输入 Acquisition - Sample Information（采集 - 样品信息）、Start Run（开始运行）或 Sample Log Table（样品日志表）的对话框中。

Misc Info（其他信息）

此项为输入 Acquisition - Sample Information（采集 - 样品信息）、Start Run（开始运行）或 Sample Log Table（样品日志表）对话框的其他各种信息。

Vial Number（样品瓶编号）

输入 Start Run（开始运行）或 Sample Log Table（样品日志表）对话框的样品瓶编号。当运行从 Acquisition - Sample Information（采集 - 样品信息）对话框启动时此数总是为 1。

CurrentMeth（当前方法）

当前在 “Data Analysis（数据分析）中加载的方法文件的名称。


数据过滤器对话框

仅适用于 5973 MSD。如果没有使用 FILTERM 命令来指定任何参数，这个对话框就会出现。这个对话框允许选择数据响应过滤器类型。

  • 推荐把标准分辨率用在低于 500 amu 的扫描。

  • 增强型分辨率过滤器对高质量（大于 500 amu）样品能提供更好的色谱峰检测。


线性回归的数据点权重

定量 GC/MS 分析员确定“最适当的加权因子是标准点方差的倒数，尽管 1/x、1/y 和 1/x2（x = 浓度，y = 响应）也是该方差的有效近似值”。（请参见 Kames, Shiu and Shah，Validation of Bioanalytical Methods,Pharmaceutical Research, vol. 8, no. 4, 1991.）

您可以选择相等权重、浓度倒数或浓度平方的倒数。

要改变个别化合物的权重：

请选择 Calibrate / Edit Compounds（校准/编辑化合物），改变设定，然后单击 OK（确定）。

要改变所有化合物的权重：

  1. 请选择 Calibrate / Update/Global Update（校准/更新/全部更新）。出现一个有六个选项的对话框。

  2. 请选择Set Other (via command)（通过命令设定其他）并单击 OK（确定）。会提示您输入一个命令。键入下面命令之一，单击 OK（确定）。

linear_wt = 0 | 对于相等权重
linear_wt = 1 | 对于 1/c
linear_wt = 2 | 对于 1/c^2


数据点

化学工作站从检测器多次测定每个峰来确定在一次运行中的信号。

一个数据点是这些测量中一次的结果。

一个色谱实际上是一系列数据点。


数据采样频率

以每秒的数据点表示速率，积分器以此速率对分析数据进行取样。例如，Data Rate（数据采样频率）为 10 Hz 意思是积分器每秒取样 10 个数据点。

缺省数据采样频率：20 Hz

注意：数据采样频率越高，需要的分析数据存储空间就越大。

GC 可以在 11 种不同数据采样频率下处理数据。每个 Data Rate（数据采样频率）和一个 Minimum Peak Width（最小峰宽）相对应。下面的列表列出了可能的数据采样频率及其最小峰宽。相对噪声、检测器适应性和建议色谱柱类型也一并列出。

化学工作站信号处理

数据采样频率
(Hz)

最小
峰宽
(分钟)

相对噪声

检测器

色谱柱类型

200.00

0.001

  3. 1

仅适用于 FID

小口 (50 [image] m) 毛细管柱

100.00

0.002

2.2

.

.

50.00

0.004

  1. 6

.

.

20.00

0.01

  1. 0

所有类型

.

10.00

0.02

0.7

.

.

5.00

0.04

0.5

.

.

  2. 00

0.1

0.3

.

.

  1. 00

0.2

0.22

.

.

0.50

0.4

0.16

.

.

0.20

  1. 0

0.10

.

.

0.10

  2. 0

0.07

.

慢填充柱

设定数据采样频率时自动决定一个最小峰宽。（数据采样频率越高，最小峰宽越小。）

在运行中不能更改数据采样频率。

如果已选择了一个 Det(检测器）源，有关数据采样频率的进一步信息，请参见 Calc button（计算按钮）。

本对话框内容：

Source（离子源）

Minimum Peak Width（最小峰宽）

Calc Button（计算按钮）

Save Data（保存数据）


数据分析

选择编辑方法的 Data Analysis（数据分析）部分的同时会显示 Select Reports（选择报告）对话框。所列出的报告取决于您的系统配置以及是否安装了 Custom Reports（定制报告）软件：

从下述各项中复选您的方法所需的报告类型：

Percent Report（百分比报告）

在方法运行时会产生一个 Area Percent（面积百分比）报告。这个报告根据保留时间进行排序，同时输出到屏幕、打印机和根据您的选择命名的文本文档。在报告产生时还可以指派一个积分参数文件（事件文件）。在对话框中键入 ? 得到事件文件列表。

Library Search Report Style（谱库检索报告样式）

一个谱库检索报告包括从数据文件来的信息、检索参数和选定格式的检索结果：

  • 摘要：摘要格式提供了一个每个峰命中对象的列表。

  • 详细报告：详细报告格式列出一个命中色谱峰的列表，在下面列出检索到的光谱图和 #1 命中对象。每个峰在新的一页中显示。

Quant Report（定量报告）

在方法运行结束时产生一个定量报告。可以指定报告类型和输出对象（屏幕、打印机、文件）。

Custom Report（定制报告）

如果想在方法运行结束后产生一个 Custom Report（定制报告），选择该选项。提示指定 Custom Reports（定制报告）临时文件名称 (*.crt)。使用 Data Analysis（数据分析）中的 Quantitate（定量）菜单进入 Custom Reports（定制报告）软件并指定临时文件。要选择这个选项还必须创建一个 Quant Report（定量报告）。

Update Custom Database（更新定制数据库）

只要当前数据文件（不管是手动的还是作为方法的一部分）进行了定量测定，就自动地对指定的 Custom Reports（定制报告）数据库进行更新。将提示您指定数据库文件 (*.crd)。您必须使用此选项创建一个 Quant Report（定量报告）。


数据库容量考虑事项

Custom Reports（自定义报告）数据库的最大容量是 250 列，16,000 行。然而实际容量可能受数据系统性能所限。在添加任何新数据文件前必须先将整个数据库加载到内存中。随着数据库大小的增加，加载所需时间也会相应增加。

例如，在一台内存 16 M 的 486/66 MHz 计算机上，当更新一个含有 239 列的数据库时可以观察到下面的情况：

条目数目

更新所用时间（以秒为单位）

1

7

10

8

100

9

1,000

51

2,000

1,840（约 30 分钟）


直流电流极性（参数）

直流电流极性设定输入四极杆质量过滤器的直流电流的极性。这个参数在出厂时已设定到最佳极性，正常使用时不要更改。


缺省 +/-

处于预期保留时间附近的缺省 +/- 时间指定了将用于产生色谱和对每个化合物进行峰积分的时间范围。

此处可输入的值为 0 至 5 分钟；缺省值为 0.5 分钟。这个值会用于指定在当前期间添加到定量数据库的每个化合物的时间范围除非在 Edit Compounds（编辑化合物）对话框中对每个化合物进行修改。已存在于数据库中的化合物不受影响。


缺省乘数

该参数未使用。


缺省样品浓度

用于以样品百分比浓度含量表示的报告。所有未知样品计算出的结果在报告打印前都被除以这个浓度然后乘以 100。浓度单位在最终报告里由“%”代替。

输入零用于指样品浓度以绝对值而非百分比方式表示的报告。如果保留该字段空白，则会使用零。

如果被分析的样品不是汽油或收集样品时没有输入适当的汽油信息，该参数只用在 Aromatics in Gasoline（汽油中的芳香族化合物）模式下。


缺省值对初始值

缺省值是未给可选参数输入值时系统使用的值（或采取的操作）。

初始值是系统为必需参数或可选参数设定的值。

初始条件在出厂时已随软件设好。您可以通过宏控制的许多功能来定制以满足您的需要。宏里的这些更改可能导致在线帮助给出的初始值和您定制的软件实际条件之间存在差异。


定义：色谱

由 MSD 系统生成的色谱是在运行中每一时间点（扫描）产生的离子丰度的图形。可以显示两种色谱图：TIC（总离子流色谱）或 EIC（提取离子色谱）


定义：参数检索 — 定义

参数检索允许在光谱库中依据指定标准找出化合物。检索产生一个满足指定标准的谱库中的化合物列表。这时可以查看这些化合物光谱并同样品光谱进行比较。


延迟

在一系列多次进样中，每次进样之间的停顿时间，以秒为单位。这被添加到最小硬件循环时间中。

有效输入值：0 至 120 秒。缺省输入为零。

本对话框中其他项目：

Inject (X) uL (Y) Times（进样 (X) uL (Y) 时间）

延迟（当前选择）

Washes（洗涤）


说明

色谱柱类型的简要说明。


说明

键入一个简要说明来描述指派给该辅助通道的功能。下一次打开 Aux（辅助）对话框时，化学工作站会把辅助通道的标志替换为您的说明。

例如，可以把辅助通道 #3 的标志“Pres Aux #3（压力辅助 #3）”替换为“Gas Sampling（气体采样）”。

本对话框中其他项目：

Aux Channel（辅助通道）

Heater (thermal channels)（加热器（热通道））

Cryo Focus Configuration (option not available)（低温冷凝配置，选项不可用）

Type (thermal channels)（类型（热通道））

Pressure (pressure channels)（压力（压力通道））

Gas (pressure channels)（气体（压力通道））

Ramps（梯度）


输出对象

选择谱库检索报告的一种或多种输出对象：

Screen（屏幕）

报告（仅文本）显示在 Notepad 中。

Printer（打印机）

报告输出到打印机。对于详细报告，这是唯一允许的输出对象。

File（文件）

报告（仅文本）输出到指定文档。


输出对象

为选择定量报告的一种或多种输出对象：

Screen（屏幕）

报告（仅文本）被显示。

Printer（打印机）

报告输出到打印机。

File（文件）

报告（仅文本）输出到指定文档。


详细报告

除去详细信息的文本形式的报告外，还包括色谱图和每个化合物的校准曲线。输出对象是打印机。

提供的一般信息包括：

  • 数据文件来的信息

  • 定量设定

  • 定量数据库中的化合物编号

  • 一个时间参比峰数据列表（如果有的话）

对于每个化合物，提供的信息包括：

  • 从数据文件头来的信息

  • 定量结果

  • 目标离子和特征离子数据（仅适用于 GC/MS）

  • 曲线拟合类型

  • 校准曲线拟合方程及其相关系数（线性）或相对标准偏差（平均 RF）


详细报告

仅适用于详细报告

对话框的这部分应用于详细报告。它允许您：

  • 给报告选择一个扫描类型或 SIM（选定离子）类型（仅适用于 GC/MS）

  • 省略对于 Internal Standards（内标）和/或 System Monitoring Compounds/Surrogates (both modes)（系统监测化合物/替代物（两种模式））的图形报告

另见

MULTITHUMB 命令


详细（单一化合物）报告

对指定化合物的带有图形的详细报告。输入定量数据库列表中该化合物的编号。输出对象为打印机。


详细（仅文本）报告

首页包括从数据文件来的信息、定量设定、定量数据库中的化合物编号和一个时间参比峰数据列表（如果有的话）。

当 Printer（打印机）作为输出对象时，对每个化合物都有一页包含数据文件头来的信息、定量结果、目标离子和特征离子数据、曲线拟合类型和校准曲线拟合方程及其相关系数（线性）或相对标准偏差（平均 RF）。

对于 Custom Reports（自定义报告），选择该格式并以文件 DETAIL.XLS 为输出对象。


检测器

指定连接到色谱柱的检测器：

  • Front（前）

  • Back（后）

  • MSD

  • AED

  • Other（其他）

本对话框中其他项目：

Mode（模式）

Inlet（进样口）

Outlet psi/kPa/bar（出口 psi/kPa/bar）

Flow（流量）

Installed Column（已安装的色谱柱）

Manufacturer's Specifications/Column Dimensions（制造商规格/色谱柱尺寸）

Ramps（梯度）


检测器工作异常

增加电子倍增器电压。如果增加电压不能提高灵敏度，检查其他可能的原因。如果电子倍增器电压处于或接近其极限（3000 V），请更换电子倍增器角。

有关更换电子倍增器的说明，请参见 MSD 硬件手册。


检测器工作异常

请与安捷伦科技公司维修代表处联系。


检测器按钮
单击此按钮用以显示控制安装于 6890 系列 GC 上的检测器的面板。


DFTPP — 定义

DFTPP（十氟三苯基膦）在半挥发性化合物分析（EPA 625）中用作调谐参比化合物。


直径

色谱柱的内径或“id”（以微米为单位）。化学工作站把标识 Diameter（直径）同方法一起保存。


扩散泵油位过低

如果油位过低，扩散泵不能有效工作。检查扩散泵中的油位。如有必要，更换扩散泵油。

有关检查和更换扩散泵油的说明，请参见 MSD 硬件手册。


扩散泵加热器套故障

用户不能更换扩散泵加热器套。请与安捷伦科技公司维修代表处联系。


扩散泵加热器故障

请与安捷伦科技公司维修代表处联系。


扩散泵工作异常

扩散泵性能差常常是由于扩散泵油位低或扩散泵油污染所致。也可能是由于扩散泵组合中的部件排列错误引起的。错误排列的组合部件非常罕见，因为在日常操作和维护中组合从不打开。如果扩散泵油位和条件都正确并且组合最近未被打开过，请与安捷伦科技公司维修代表处联系。


扩散泵开启但没有足够时间达到正常操作温度

通常扩散泵需要 10 - 15 分钟来达到其正常操作温度。在下列情况下，该时间可能会稍微延长：

  • 实验室比正常条件冷

  • 扩散泵油位非常高

  • 前级泵工作异常

  • 色谱柱流量比正常高


扩散泵组合对齐错误

如果扩散泵组合中的部件没有正确对齐，可能使扩散泵无法达到正常操作温度。这种情况非常罕见，因为日常维护中组合不会打开。


扩散泵温度传感器工作异常

请与安捷伦科技公司维修代表处联系。


直接模式

直接进样允许不会污染气路系统的被分析物定量传输。它提供了空气有害物质分析的灵敏度。接口的极小死体积也消除了溶质同不洁的活性表面的可能反应。

要在直接模式下操作，必须：

  • 断开分流口和进样口的物理连接

  • 在 6890 GC 前面板上手动设置直接模式

不能在化学工作站对话框中进入直接模式。有关完成这些操作的说明，请查阅 6890 Series Installation and Operating Guide for the Volatiles Interface（6890 系列针对挥发物接口的安装和操作指南）。

直接模式操作参数

参数 | 设定值范围 | 建议起始值
柱箱初始时间 | 0 至 999.9 分钟 | > 接口进样端
接口温度 | 环境 ＋10C 至 400C | > 传输线温度
> 接口进样端 | 0 至 999.9 分钟 | 比实际进样时间长 0.2 分钟

有关更多信息，请参见 Direct Mode Pneumatics（直接模式气路）。

本对话框内容：

Gas（气体）

Heater（加热器）

Pressure（压力）

Total Flow（总流量）

Sampling End（进样端）

GasSaver（载气节省）（如果色谱柱已被定义）


直接模式气路

在预运行前，接口由前压力控制；压力在流量比例阀的下游被检测。

在进样时间内，在外部进样器开关阀引起的压力变化可能导致色谱柱流速的波动。为了对此进行补偿，接口在进样时间内是控制流量的。进样流速从进样开始时激活的压力设定值计算出。这种流量模式在 6890 GC 进入 Pre Run（预运行）状态（当 Pre Run（预运行）灯亮时）后开始，在接口进样端达到设定值时结束。流到接口的流量由流量传感器测量并由比例阀控制。

在进样时间结束后，接口由前压力控制；压力在流量比例阀的下游被检测。

不能控制流量系统中的所有设定值。如果改变了一个设定值，其他设定值会随着改变以进行补偿。

色谱柱已被定义时

如果改变 — 这些设定值改变

压力 | 色谱柱流量* 总流量**
色谱柱流量* | 压力 总流量**

  • 这个设定值在色谱柱控制表上出现。

  • 这个值是唯一实际值。

色谱柱未被定义时

在运行时间前后色谱柱流量*设定值无效。可以改变压力设定值。其他设定值不受影响。

在进样期间不能改变压力和流量设定值。


目录结构

根据 CPU 限制，可以和 MSD 化学工作站一起装配和运行最多四台仪器。装配的每台仪器使用一个与仪器编号一致的编号目录。这些仪器目录处于 MSDchem 目录下，例如，c:\MSDchem\2 即为您设置为 #2 的仪器的目录。

每个仪器目录包含一个数据、方法和序列子目录（和其他的并列）。

方法目录包含您的所有方法。每个方法存于其自己的 .m 子目录下，其中包含该方法的所有文件，例如化合物列表、校准表、报告等。

序列目录包含了所有您的序列文件 (.s)。


脏注射器针头

脏的注射器针头是重复性差的最常见原因。如果进行手动进样，在用注射器取样前先用一块用溶剂浸过的干净、没有棉绒的布或纸擦拭针头。用注射器取样后擦去过量的溶剂。


显示菜单 — RTL

显示菜单–RTL

这个菜单仅在 MS 模式下有效。

Normal （正常） | 所有离子重叠在一起，仅能在目标信号上进行手动积分。
Qualifiers （特征） | 如果对当前化合物选定了扩展区域，信号区分开允许对特征离子进行手动积分。
Exclude Zero Qualifiers （排除零特征） | 这一菜单项可以选择为开启或关闭。它决定屏幕报告过程如何评价缺失一个或多个特征离子的化合物。如果这一项被选中，任何缺少一个特征离子的化合物都会被从报告中排除。


双塔配置和序列

如果两个数据文件要同时采集，必须在 Sample Log Table（样品日志表）中使用 DualTwr 关键词来建立一个序列。在这种模式下样品日志表中的两行必须用于每次双进样。第一行用于后进样口及其样品，第二行用于前进样口及其样品。第一行应该是 Sample Type（样品类型）＝RearSamp 或 RearCal，第二行应该是 Sample 或 Calib。输入 RearSamp 的 Sample Name（样品名称）和Misc. Info（其他信息）被放到 GC 数据文件中。输入 Sample（样品）的 Sample Name（样品名称）和Misc Info（其他信息）被放到 MSD 数据文件中。

如果使用两个 AlS 进样器，应该将 ALS 设定为进样源并把 Both Towers（前后两个进样口）设定为进样器来设置方法。

注意 如果使用双塔配置，确认 MSD 在 MS Configuration（MS 设置）程序中被设置为 Front Inlet（前进样口）。

另见

Sequence File Examples（序列文件示例）


停留时间 - 定义

停留时间是样品编号和积分时间的乘积。为了增强信号，在 Acquisition（采集）中对于 SIM 数据使用了一个固定积分时间 235 μs，并且为Integr（积分）设定的调谐文件值被忽略了。这样，SIM 丰度和饱和度可能和 Scan（扫描）模式或 Tune（调谐）中图形扫描的有所不同。其差值大致由调谐文件积分时间和 SIM 积分时间 235 μs之比决定。


动态梯度变化 — 定义

动态梯度变化允许您通过对不同质量设定不同电压来在感兴趣的整个质量范围内优化信号。而 SIM 梯度变化允许您在指定电压下优化调谐质量的信号。


EasyID 菜单

EasyID 菜单项用于显示一个化合物的结果。在 EasyID 菜单中，大写字母对应于菜单项中的等价命令。例如，键入 XP 与选择 XPand 菜单项的结果相同。

CO Next Compound （转到下一化合物） | 调出文件中下一化合物。
Goto Compound # （转到化合物号） | 提示欲查看的化合物号。
Xpand Chromatographic Window +/- 2 minutes （将色谱窗口扩大 +/- 2 分钟） | 将提取窗口扩大两分钟。
Original Chromatographic Window （原色谱窗口） | 从当前数据文件提取原色谱图，将窗口重新设置回原时间范围。
Graphics Report to the Printer （向打印机输入图形报告） | 向打印机发送色谱图形报告。
Restart Quick EasyID （重新启动 Quick EasyID） | 显示 Quick EasyID 窗口。
Set Extract Window Start （设置提取窗口开始） | 说明正确的鼠标/键盘组合，设置峰的积分开始时间。
Set Extract Window Stop （设置提取窗口停止） | 说明正确的鼠标/键盘组合，设置峰的积分停止时间。
Abort Changes and Exit （终止更改并退出） | 退出 EasyID 模式，不保存对定量数据库的更改。
Exit and Save Changes （退出并保存更改） | 退出 EasyID 模式，使用所作更改更新定量数据库。


编辑方法

Edit Entire Method（编辑整个方法）选项提供一个自动方式用于查看和根据需要更改方法的任意一点或全部内容。

请按下列步骤编辑方法的一部分或几部分。

  1. 加载方法 — 打开对话框。

VIEW / METHOD AND RUN CONTROL（查看/方法和运行控制）

METHOD / LOAD / METHOD...（方法/加载/方法...）

a. 选择编辑的方法（方法文件具有一个 .m 扩展名。）

b. 单击 OK（确定）。

  2. 选择编辑部分 — 打开对话框（有关特定部分的详细信息，请单击任意绿色区域）。

METHOD / EDIT ENTIRE METHOD...（方法/编辑整个方法...）

a. 选择一部分，单击相应的复选框在其中加上 X。（再单击一次去掉 X。）

b. 单击 OK（确定）。

  3. 编辑指定的部分。化学工作站将自动显示包括在每个指定部分的对话框 （除了 Instrument Controls（仪器控制） [image] 请见下面）。输入任何希望更改的信息，单击 OK（确定）继续。

在 Instrument Control（仪器控制）屏幕：（因为有许多可能性）化学工作站将只显示希望看到的仪器控制。

a. 选择希望修改的 Instrument Control（仪器控制）（单击图标条中相应图标）。

b. 根据需要更改项目。

c. 如有必要，从图标条中选择另一个图标。请勿选择 OK（确定）除非已经从 Instrument Control（仪器控制）图标条中选择所有希望修改的图标。

d. 完成修改仪器控制后，单击 OK（确定）继续自动过程。化学工作站将继续自动显示在步骤 2 中所选的项目。

  4. 单击最后对话框中的 OK（确定）保存编辑过的方法。

FILE / SAVE / METHOD（文件/保存/方法）


编辑化合物

当选择 Calibrate / Edit Compounds（校准/编辑化合物）和更新校准时，该框作为 Set Up Quantitation（设置定量）序列中的一部分被显示。使用 AutoQuant Setup（自动定量设置）功能时也会显示。

该框显示定量数据库中存在的化合物列表。化合物列出的次序决定了处理它们的方式：

  • 外标化合物。所有列在第一个内标 (ISTD) 前面的化合物采用外标计算处理。

  • 内标。当遇到一个内标时，即对其进行分析。ISTD（内标）采用星号(*)加以标记。

  • 目标化合物。一个内标后面所有化合物均相对该内标进行分析。

如果列表是空的，则不存在与当前方法关联的数据库 — 请参见创建定量数据库。

查看或编辑一个项目

单击该项目，数据库信息将显示在一个对话框内。

在特定位置添加一个化合物

单击将要在其前面添加新项目的项目。然后单击 Insert Above（插入上方）按钮。使用对话框填入必要信息。

查看校准曲线，每次一个化合物

当查看一个化合物项目（第 1 页 或 第 3 页）时，单击 Plot（图）。显示列出所有校准级的浓度和响应并给出相关系数、拟合类型和响应。


Edit File Info（编辑文件信息）

编辑文件信息

使用这一对话框编辑与当前数据文件相关联的标题信息。当选择 OK（确定）时，对此信息的更改即被保存在当前数据文件中。因为更改值会永久地存储在数据文件中，它们将用于以后的所有报告。请注意更改 Sample Multiplier（样品乘数）会影响将来为该数据生成的定量报告中的计算的量。

任何更改将记录在 AUDIT.TXT 中。


编辑谱库

可以创建一个谱库并在需要时进行编辑。编辑一个用户创建的谱库包括添加、修改和删除项目。不能编辑商用谱库，但可以查看项目（标题信息）。选择 Edit Library（编辑谱库）会出现下列选择：

Select Library（选择谱库）

该菜单项允许选择和加载一个谱库。

Add New Entry（添加新项目）

该菜单项允许向当前谱库中添加一个新项目。该谱库必须由用户创建，不能向商用谱库中添加项目。在选择 Add New Entry（添加新项目）前必须选择一张谱图。程序将窗口 [1] — 堆栈中的 X 寄存器 — 中的谱图添加到谱库中。

Edit Existing Entry（编辑已有项目）

Edit Existing Entry（编辑已有项目）允许在当前谱库中选择和编辑一个项目。这个谱库必须是用户创建的，不能编辑商用谱库。

Create Library（创建谱库)

该菜单项允许创建新谱库。通过逐个添加项目组建一个谱库。

Delete Library（删除谱库）

选择该菜单项允许删除当前谱库。


编辑方法

选择 Edit Method（编辑方法）允许您编辑当前数据分析方法。将提示您选择和编辑将要生成的报告类型。选项包括：

Percent Report（百分比报告）

当该方法运行时，将生成一个 Area Percent（面积百分比）报告。该报告按保留时间分类并可被送到屏幕、打印机和所选择的文本文件名。当生成报告时，可指定使用一个积分参数文件（事件文件）。在框中键入 ? 获取事件文件列表。

Library Search Report Style（谱库检索报告类型）

一个谱库检索报告包括来自数据文件、检索参数和所选格式的检索结果的信息：

  • 摘要：摘要格式提供一张对应每个峰所发现的命中的表格。

  • 详细信息：详细信息格式列出一个峰所发现的命中的化合物以及一张检索谱图和 1 号命中对象。每个峰在一个新的页面开始。

Quant Report（定量报告）

当该方法运行时，将生成一个 Quant（定量）报告。可指定报告的类型和它的目的地（屏幕、打印机、文件）。

Custom Report（定制报告）

当方法运行时如果希望生成一个 Custom Report（定制报告），请选择该选项。将提示要求 Custom Reports（定制报告）模版文件 (*.crt) 的名称。使用 Data Analysis（数据分析）中的 Quantitate（定量）菜单访问 Custom Reports（定制报告）软件并设计自己的模版。除选择该选项外，必须生成一个 Quant Report（定量报告）。

Update Custom Database（更新定制数据库）

只要用当前数据文件（手动或作为一个方法的组成部分）进行定量，就会为该方法自动更新指定的 Custom Reports（定制报告）数据库。将提示您用数据库文件 (*.crd)。使用该选项必须生成一个 Quant Report（定量报告）。

Instrument Information（仪器信息）

允许为该方法指定进样体积、涂渍的固定相、色谱柱 ID 和仪器名称。该信息显示于报告的标题信息中。


编辑 MS 参数 — 校准菜单

这一菜单可让您在主 Tune（调谐）视窗上用 Calibrate（校准）菜单实现两个校准功能Mass axis（质量轴）和 Mass #3 peak width（3 号质量峰宽）

Mass #3 Widths（3 号质量宽度）启动峰宽校准。当校准执行时，就会显示一个质量为 1 - 3 的扫描图形，并不断地重复更新。校准将一直持续到峰宽达到通过标准。

欲在下一个可能的停止点停止操作，请单击 Stop（停止）按钮。


编辑 MS 参数 — 调谐 (5973 MSD)

故障排除(5973 MSD)

除上面显示的参数外（X 射线不用于 5973 MSD），也可调节下列参数：

Emission（发射） | Electron Energy（电子能量）
DC Pol（DC 极性） | PFTBA

下列项目会连续更新：

Source（源）

Quad

下列参数依赖于 MSD 配置扩散泵还是涡轮泵：

ForePres

TurboSpd

欲调节一个所选参数

  • 键入新值，然后按下 Tab 键

  • 使用参数列表下方的滚动条

一个可接受范围外的值会自动转换为最靠近的极限值。所有值位于最近的 DAC（数模转换器）台阶周围。

按钮控制显示并和菜单一起提供其他功能。所有功能可用键盘访问。


编辑 MS 参数 — 调谐 (5971/5972/6890 MSD)

除上面显示的参数外，也可调节：

Emission（发射） | TTI
DC Pol（DC 极性） | PFTBA

下列项目会连续更新：

MS Temp（MS 温度）

Vacuum（真空）

欲调节一个所选参数

  • 键入新值，然后按下 Tab 键

  • 使用参数列表下方的滚动条

一个可接受范围外的值会自动转换为最靠近的极限值。所有值位于最近的 DAC（数模转换器）台阶周围。

按钮控制显示并和菜单一起提供其他功能。所有功能可用键盘访问。


编辑 MS 参数 — 查看菜单

这一菜单提供两个显示的选项：

  • Expand（扩大）使图象显示充满整个窗口同时隐藏图像下面的 MS 参数显示。扩大模式中的梯度允许查看调谐质量的丰度比。

  • Show Scan Ratios（显示扫描比）锁定扫描比的显示为开或关。如果希望图像获得更多的显示面积，可将它们关闭。


编辑 MS 参数菜单（调谐）

编辑 MS 参数菜单

在 Edit Parameters（编辑参数）面板中有四个菜单：

File（文件） | 允许打印当前仪器设置和图像窗口中的显示。
Calibrate（校准） | 允许使用所有三个调谐质量校准质量轴或执行一个峰宽校准。
More Params（更多参数） | 可使您方便地访问 Acq Params（采集参数）参数框。
View（查看） | 提供两个显示选项。

请注意移动时 Edit Parameter（编辑参数）中可用的 Acq 对话框的位置会保存在软件中。下一次进入 Edit Parameters（编辑参数）并调用此框时，它将显示在上次放置的位置。欲使该功能失效并恢复框的最初排列，请将变量 EDPDefPos 设定为非零值。


编辑非目标峰

在生成一个 Non Target Peak（非目标峰）报告后可选择该菜单项。允许您将每个非目标化合物的质谱与由谱库检索确定为可能匹配的化合物谱图进行比较。

Edit Non Target Peaks（编辑非目标峰）调出 Library Search Results（谱库检索结果）对话框。它显示下列信息：

#X of Y（Y 中的 X 数目）

Y 是发现的非目标化合物总数目，X 是当前被查看的化合物数目。化合物根据它们的保留时间来编号。保留时间最短的化合物编号是 1，Next（下一个）和 Previous（上一个）按钮允许在非目标化合物之间移动。

Retention Time（保留时间）

这是被查看的非目标化合物的保留时间。

Concentration（浓度）

这是非目标化合物基于一个外标或最近的内标（如果内标在化合物数据库中被定义）的响应的估计浓度。

Reported（报告对象）

这是当前与非目标化合物比较的谱库化合物。

Name（名称）

这些是根据当前谱库检索标准对于非目标化合物的所有可能匹配。选择 (DEL) Alkane（删除烷烃）选项可从报告中删除一个峰。

Ref No.（参比号）

这些是谱库中可能匹配的谱库参比号。一些可能匹配也许没有参比号。

CAS#（化学文摘号）

这些是谱库中可能匹配的化学文摘号。一些可能的匹配也许没有 CAS 号。

Qual（质量）

这是命中对象的质量；即非目标化合物和谱库化合物之间的匹配。1 和 99 分别代表最差和最佳的匹配。

在 Library Search Results（谱库检索结果）对话框显示时，一个拆分窗口（窗口 [5]）显示非目标化合物的质谱（上部）和所选谱库化合物的质谱（下部）。可从视觉上比较谱图并决定是否谱库化合物实际上是一个可能的匹配。如果不是一个可能的匹配，可选择报告另一个化合物，如“未知烃”，或单击 Delete（删除）键删除非目标化合物。完成所有必要的更改后，单击 Exit（退出）。


编辑参数按钮

下列按钮提供到 Edit Parameters（编辑参数）对话框中所有显示选项的访问：

  • Prof 进行连续文件扫描。

  • Ramp（梯度） 使滚动条上方出现的参数对于所有三个调谐质量是 SIM-ramped（SIM 梯度）的。

  • Scan（扫描） 进行连续谱图扫描。

  • Stop（停止） 停止文件扫描、谱图扫描、梯度等等。

  • MSOff（MS 关） 关闭质谱仪。

  • OK（确定） 退出对话框（关闭所有打开的参数框）并保留所有参数的当前值。

  • Cancel（取消） 退出对话框（关闭所有打开的参数框）并将所有参数返回到原值。


编辑梯度参数

梯度控制调谐参数时使用该对话框调节极限值、步长和欲平滑的点。如果向 Points to Smooth（欲平滑的点）输入一个 5 和 101 之间的数，Savitzky-Golay 二次/立方平滑即被用于指定的点。如果输入数字不是奇数，则使用最近的奇数。输入零禁用平滑。

Repeller（推斥极）

Ion Focus（离子聚焦）

Ent Lens（入射透镜）

Ent Offset（入射补偿）

X-ray（X-射线）（5973 无）

Amu Gain（Amu 增益）

Amu Offset（Amu 补偿）

Emission（发射）

Electron Energy（电子能量）

选择 Ramp（梯度）菜单中合适项目或使用 Edit Parameters（编辑参数）框中 Ramp（梯度）函数对参数进行梯度控制。


电子倍增器电路连接不正确

  1. 放空 MSD。

  2. 打开真空多路连接管。

  3. 检查电子倍增器。

    确信编织电线牢固连接到电子倍增器和信号输入端。确信电子倍增器上的针与连接带接触良好。

有关放空 MSD 和打开真空多路连接管的说明，请参见 MSD 硬件手册。


离子源电路连接不正确

  1. 放空 MSD。

  2. 打开真空多路连接管。

  3. 检查离子源配线。

    确信所有配线安全连接到输入板和离子源。确信正确的配线连接到正确的插针。

有关放空 MSD 和打开真空多路连接管的说明，请参见 MSD 硬件手册。


分析器短路

  1. 放空 MSD。

  2. 打开真空多路连接管。

  3. 检查陶瓷输入板到离子源透镜的配线。确信没有配线短接到地。

有关放空 MSD 和打开真空多路连接管的说明，请参见 MSD 硬件手册。


静电计

在复选框中加上 X 打开静电计。

去掉 X 关闭静电计。操作检测器时应一直保持静电计开启。


静电计

在 On（开）复选框中加上 X 激活静电计。


电子捕获检测器

电子捕获检测器（ECD）包含一个附有 63Ni（一种放射性同位素）的检测室。63Ni 释放的 [image] 粒子与载气分子碰撞产生低能电子， [image] 每个 [image] 粒子约产生 100 个电子。自由电子产生一个小电流 [image] 称为参比或恒定基流 [image] ，通过一个脉冲电路搜集和测量。

当样品成分分子与自由电子接触时，样品分子可捕获电子形成负离子。加在检测室电极上的脉冲电压搜集剩余的自由电子而重的离子相对不受影响并由载气流吹出放空。

化学工作站测量检测室电流并将其与参比电流比较。然后调节脉冲频率以保持恒定的检测室电流。自由电子越多，与参比电流匹配所需的脉冲频率越低。当可捕获电子的成分通过检测室时，脉冲频率升高。该脉冲频率被转换为电压记录下来。

使用 ECD 对话框设置检测器参数和指定设定值。有关详细信息，请单击下列任意绿色区域：

选择温度和流量时请使用下表中的信息。

操作参数

气体类型

推荐流量范围

建议流量

载气
填充柱
（氮气或氩气—甲烷）
毛细管柱
（氢气、氮气
或氩气—甲烷）

30 到 60 mL/min

0.1 到 20 mL/min，
根据直径

毛细管尾吹
（氮气或氩气—甲烷）

20 -150 ml/min
（典型为 50 - 60 ml/min 可上下调节使校准曲线移动。）

60 ml/min

阳极气体
（与尾吹气类型相同）
EPC 检测器
毛细管柱
填充柱

尾吹气的 10%

3 到 6 ml/min

6 ml/min

非 EPC 检测器
毛细管柱

填充柱

不由用户控制。流量通常为
尾吹气流量的 6 - 7%。
3 到 6 ml/min

温度

250 [image] C 到 400 [image] C
检测器温度通常设置为高于柱箱最高梯度温度 25 [image] C。

调节补偿

30 到 70，范围为 20 到 200

ECD 的响应依赖于许多因素。包括分析物的分子组成及其浓度、所使用的 ECD、检测室的清洁程度、色谱柱、进样口和仪器设定值（温度、流速和参比电流）。

所以为所有化合物作出校准曲线和根据固定的标准评价检测器响应是重要的。甚至对于经常的校准，可以预期当操作条件改变时检测器响应也会改变， [image] 例如，当所分析的脏样品污染检测器时。

通常 ECD 对于不同种类化合物的灵敏度

化合物类型 | 相对灵敏度
烃 | 1
醚、酯 | 10
脂肪醇、酮、胺； 单氯和单氟化合物 | 102
单溴、二氯和二氟化合物 | 103
酐和三氯化合物 | 104
单碘、二溴和硝基化合物 | 105
二碘、三溴、聚氯和聚氟化合物 | 106

用于数据分析的 ECD 信号转换：

  • 5 Hz = 1 高度单位

  • 5 Hz x 1 秒 = 1 面积单位


电子能量（参数）

Electron Energy(电子能量）是以 eV 为单位的电子束以基态为参照的能量。（对于 EI 模式，强烈推荐使用 70 eV）。

MSD | MIN | MAX | STEPSIZE（步长）
5973 | 0 | 241.5 | 0.95

5973 MSD 的 Electron Energy（电子能量）通常应设为 70 eV 以获得有机分子的标准谱。Electron Energy（电子能量）的减少将导致有机分子的软电离（较少的碎裂）和灵敏度的显著降低。

当降低 Electron Energy（电子能量）时，请勿超过下表所列的发射电流，否则灯丝寿命将缩短。

能量 | 电流
70 | 300 μA
50 | 250 μA
30 | 200 μA
10 | 100 μA
<10 | 50 μA


电子倍增器触角接近其使用寿命尽头

电子倍增器上的触角可能会接近其使用寿命尽头。如果自动调谐一直将电子倍增器电压设为其极限值或接近极限值 3000 V，就会发生这种情况。更换电子倍增器触角。

有关更换电子倍增器触角的说明，请参见 MSD 硬件手册。


电子倍增器电压过高

请降低电子倍增器电压 50 或 100 伏。如果效果改善，继续调节电子倍增器电压直至发现最佳设定值。


电子倍增器电压过低

升高电子倍增器电压。如果电子倍增器电压位于或接近其极限值 3000 V，则可能需要更换电子倍增器。

有关更换电子倍增器的说明，请参见 MSD 硬件手册。


电子倍增器电压

电子倍增器 (EM) 电压对于决定 MS 的响应是很重要的。其值越高，响应越大（无论信号还是噪声）。EM 电压可设为当前调谐文件中电压的相对值 (Rel) 或一个绝对值 (Abs)。

Rel（相对值）

调谐文件的 EM 电压值由在对话框中的输入值来调节。作为结果的数值显示在 = 号后面。输入的相对值自动调节到最近的步长（11.76 伏）还可能进一步调节以使作为结果的数值位于 0 到 3000 伏范围内。

推荐使用调谐文件的值；选择“Rel”并在框中输入 0。

Abs（绝对值）

它指定在框中输入的值即为被使用的值。调谐文件的值未被使用。范围为 0 到 3000 伏。如果输入值落在该范围外，将自动转换到最近的极限值。允许范围内的值自动调解到最近的步长（11.76 伏）。


电子倍增器电压过高

高的电子倍增器电压可导致或恶化该问题。降低电压约 200 V。如果结果改善，继续调节电压直至发现最佳设定值。如果电子倍增器电压过高足以导致同位素出现，可能会同时导致平顶峰。


EMF 缺省值

下面图片给出了第一次使用该功能以及单击 Reset（重新设置）按钮时显示在 Enter Limits for EMF Parameters（为 EMF 参数输入极限值）对话框中的缺省极限值。起始三个区域内的 -1 表明这些参数被禁用。


EMF 极限值示例

下图给出一个完整的 Enter Limits for EMF Parameters （为 EMF 输入极限值）对话框的示例。


发射电流被设置为 0

返回到发射电流原值或缺省值。


5973 MSD 发射能量设置

电子能量设定 (5973 MSD)

5973 MSD 的 Electron Energy（电子能量）通常应设为 70 eV 以获得有机分子的标准谱。Electron Energy（电子能量）的减少将导致有机分子的软电离（较少的碎裂）和灵敏度的显著降低。

当降低 Electron Energy（电子能量）时，请勿超过下表所示的发射电流，否则灯丝寿命将缩短。

能量 | 电流
70 | 300 μA
50 | 250 μA
30 | 200 μA
10 | 100 μA
<10 | 50 μA


发射（参数）

发射

在 5973 和 5972 MSD 上，灯丝的发射电流可被重新设定，但缺省设置被推荐为最佳值。电流越大，发射的电子越多。如果发射电流设置过低，将导致较少的离子化而降灵敏度低。如果发射电流设置过高，会有更多的样品碎片，灯丝会更快烧坏。

MSD

MIN

MAX

STEPSIZE（步长）

5972 / 6890

0

317.5

  2. 5

5973

0

315.2

  1. 2


载气瓶空或载气供给不充分

确认载气瓶未空。如果载气瓶已空或压力过低，应会发出警报并在 GC 键盘上出现提示。


EM 电压（参数）

EMVolts（EM 电压）设定电子倍增器的电压（检测器部分）。提高电压会提高灵敏度。升高 EMVolts（EM 电压）通过提高质谱仪输出的信号提高丰度。升高 EMVolts（EM 电压）也会降低电子倍增器的寿命。应在能够提供足够灵敏度的最低电压下操作电子倍增器。

为延长电子倍增器的寿命，可在溶剂峰通过倍增器前关闭（0 伏）电子倍增器（及所有其他电压）。（如果指定了溶剂延迟，这些电压将被关闭至溶剂延迟结束）。同理，如果分析一个高浓度样品或在 CI 模式下进行操作，应降低 EMVolts（EM 电压）。

MSD | MIN | MAX | STEPSIZE（步长）
5972 / 6890 | 0 | 3000 | 11.764
5973 | 0 | 3000 | 11.764


进入 CI 调谐面板

允许访问 CI Tune（CI 调谐）菜单（仅用于配备化学电离组件的 5973 MSD 系统）。CI 调谐允许为化学电离（CI）模式中的操作调节 MS 参数。有关化学电离的正确安装和 CI 调谐的说明，请参见 G1999A CI 组件硬件手册。

另见

CI Tune（CI 调谐）菜单 (5973 MSD)


为 EMF 参数对话框输入极限值

当选择 Select EMF Action（选择 EMF 活动）对话框的 Set Limits（选择极限值）时显示该对话框。它用于为一个特定部件或程序的预期损耗率输入极限值。当达到输入的极限值时，软件将显示警示框通知。在任何字段输入 -1 将禁用该参数。

Septum (Injections)（ 隔垫（进样））

在 GC 隔垫需要查看或更换前的进样数。输入的值将依赖于所使用的隔垫品牌。请查看制造商文献以获取对于特定隔垫的理想的可能进样数。

Liner (Injections)（ 衬管（进样））

在 GC 衬管需要查看或更换前的进样数。

Number of Injections (Total)（进样数（总数））

在色谱柱需要截断或更换前的总进样数。

Pump Oil (Days)（泵油（天数））

前级泵油需要查看、补充或更换的天数。根据系统的使用，前级泵油应每周查看，大约每六个月更换。

Tune Time (Hours)（调谐时间（小时））

MSD 需要重新调谐前的小时数。

EM Voltage（EM 电压）

用于显示重新调谐、清洗离子源或更换电子倍增器需要的 EM 电压。

Reset（重新设置）按钮

将极限值重新设置回缺省值。

另见

EMF 极限值示例

EMF 缺省值

启用 EMF 实用程序


为流量调节对话框 (5973 MSD) 输入反应物离子质量

5973 MSD 仅为 CI 配置。

从 CI Tune（CI 调谐）视窗选择 Setup / Select Masses （设置/选择质量）时会显示一系列对话框。

该对话框用于选择流量调节所使用的反应物离子质量。对于所选反应气体（甲烷、异丁烷、氨气或其他）缺省值自动显示。

请注意在 NCI 中看不到反应物离子。NCI 中用于预调谐的离子是 m/z 17 (OH-), m/z 35 (Cl-), 和 m/z 235 (ReO-)；没有用于 NCI 的流量调节；请将反应气体流量设置到 40%。


输入调谐离子质量对话框 (5973 MSD)

输入调谐离子质量对话框

仅适用于为 CI 配置的 5973 MSD。

从 CI Tune（CI 调谐）视窗中选择 Setup / Select Masses（设置/选择质量）时会显示一系列对话框。

该对话框用于选择调谐所使用的 PFDTD（和可能一个或更多反应物离子）离子质量。缺省值会自动显示，可用于大多数情况。

使用异丁烷或氨气时不会形成 PFDTD 正离子。


输入函数名称

在线帮助中把函数和命令一起列入。函数名称后面总跟有一组含有参数列表的扩号，这使它们与帮助中的命令区分开来。

  • 输入函数名称和参数时使用大写或小写字母。

  • 函数名称后面总跟有包含在扩号中的参数列表。列表可以为空，但扩号必须仍包括在函数名称中，例如，DATE$()。

  • 函数名称不可缩写。

  • 字符串参数必须括在双引号中，例如，ASC("A")。


入射透镜（参数）

EntLens（入射透镜）是指入射透镜增益，即一个用于确定加在入射透镜上与质量有关的电压的值。入射透镜是离子在其进入质量过滤器前通过的最后的透镜。

通常在调谐中，对入射透镜电压梯度控制以发现获得最大丰度的设定值。

MSD | MIN | MAX | STEPSIZE（步长）
5972 / 6890 | 0 | 128 | 0.502
5973 | 0 | 127.5 | 0.502


入射透镜补偿（参数）

EntOffs（入射透镜补偿）是指入射透镜补偿，即施于入射透镜（离子源的一部分）的恒定电压。提高补偿值会提高低质量离子丰度，同时不显著降低高质量离子丰度。

MSD | 最小 | 最大 | 步长
5972 / 6890 | 0 | 64 | .251
5973 | 0 | 64 | .251


环境分析协议

环境分析协议 管理机构要求执行一个特定环境分析中所必须坚持的标准和程序的集合。协议可包括一些项目如保管要求、样品准备程序、分析方法标准和报告要求。


环境程序文件

:SV,4,,IH

:* * This procedure file will convert and transfer a data file from

:* * RTE-A or RTE-6 to Environmental / MS ChemStation

:DP,CONVERTING DATA FILE

:DP,1G

:RU,RTECS,1G,TEMPD::SCRATCH

:DP,SENDING GLOBALS

:RU,WAIT,5

:DP,1G

:DP,1G

:DP,1G

:DP,1G

:DP,DONE

:RU,WAIT,5

:DP,READY TO SEND FILE

:XMODM,DB,TEMPD::SCRATCH

:RU,CI,/CMDFILES/PU_CI_FILE.CMD,/SCRATCH/,TEMPD

:SV,4,,IH

:TR


平衡时间，分

检测器的加热元件在其准备运行前需要稳定在温度设定值的时间长短。

平衡时间始于检测器输出频率位于设定值附近。平衡过程中，化学工作站进行测量并将其与 Adjust Offset(调节补偿）值比较。如果输出在整个平衡时间内位于 Adjust Offset（调节补偿）值附近，检测器准备就绪。但如果输出在平衡过程中任何时间过高或过低，调节补偿过程将继续，平衡时间重新开始。

如果计划操作仪器延长一段时间，请使用长平衡时间（10 到 15 分钟）。这样可确保运行中基线漂移最小。

如果只运行几个样品，请使用短平衡时间（3 分钟）。这样可确保足够的基线稳定性同时不必花多余时间调节补偿。

有效范围：0.0 到 999.99 分


平衡时间

系统准备运行前柱箱需要稳定在温度设定值的时间长短。

平衡时间从实际柱箱温度与柱箱温度设定值相差 1 [image] C 范围开始计算。Equilibration min（平衡时间）设置值可设为 0 到 999.99 分钟。

Equilibration min（平衡时间）不是运行时间的一部分。


评价降解

选择该菜单项然后积分主要峰和降解峰。结果显示于 6 号窗口。如果仅有一个峰被发现，则降解为零。


评价分离度

选择该菜单项然后积分 6 号窗口中的两个峰。Evaluate Resolution（评价分离度）计算两峰之间峰谷的高度与峰平均高度的比值。结果显示于 6 号窗口。


评价拖尾

选择该菜单项然后积分 6 号窗口中的一个峰。峰的拖尾显示于峰旁边。使用下列参数计算拖尾因子。

拖尾 = BC/AB

峰高 = DE

10% 峰高 = BD

10% 峰高处峰宽 = AC

顶点 = E


事件文件

缺省事件文件

如果在退出 Data Analysis（数据分析）之前保存 Data Analysis（数据分析）方法，则将内存中的当前化学工作站积分器事件保存为当前方法中缺省事件文件，EVENTS.E。

以后加载方法时即加载该缺省事件文件。

补充事件文件

补充事件文件可和一个方法一起保存，与 Quantitative（定量）、Library Search（谱库检索）、或 Percent（百分比）报告一起使用。请使用 Edit Integration Events（编辑积分事件）对话框中的 Save（保存）按钮，并输入一个文件名（最多八个字符）。

文件和当前方法自动被保存，如果未输入则带有 .E 扩展名。要保存一个不同的方法，请输入文件名的完整路径。


屏幕报告示例

Data Analysis（数据分析）中，选择 Tools / Generate Screen Report（工具/生成屏幕报告）可获得一个类似下面显示的 RTL（保留时间锁定）报告。

如果屏幕结果不存在，也就没有报告生成。状态栏中的 ‘X’ 和 ‘?’ 分别表明是大概的和可能的鉴定。‘?’ 表示一个或更多特征离子未发现。Expected Retention Time（预期保留事件）和 Delta 与目标离子一起报告。超出范围的特征离子在 Qualifiers Out of Range（超出范围特征离子）栏内注明。最后一栏报告与参比谱的交叉相关。


监测器示例

实时 GC 信号监测器从 Instrument / GC Plot（仪器/ GC 图）菜单选项设置。

柱箱温度监测器从 Edit GC Monitors（编辑 GC 监测器）框设置。

EM Volts（EM 电压）监测器从 Edit MS Monitors（编辑 MS 监测器）框设置。


前级压力或真空多路连接管压力超出警戒

压力超出警戒会减小或消除信号。在通常的色谱柱流量（0.1 到 2.0 ml/min）下，前级压力应在 20 和 100 mTorr 之间。真空多路连接管应在 1 x 10^-6 和 1.4 x 10^-4 Torr 之间。如果压力过高，请减少色谱柱流量和/或查看空气泄漏。


MSD 中压力超出警戒

在通常色谱柱流量（0.1 - 2.0 ml/分）下，前级压力将大约在 20 到 100 mTorr。真空多路连接管压力大约在 1 x 10^-6 到 1.4 x 10^-4 Torr。这些压力对于不同仪器可能变化很大，所以熟悉在给定载气流量条件下您的仪器的通常压力非常重要。

如果您的 MSD 中前级压力或真空多路连接管压力感觉好像过高，请参见：

前级压力过高

真空多路连接管压力过高


执行菜单 — CI 调谐 (5972 MSD)

Execute（执行）菜单允许您在图形扫描和全谱及 PFTBA 谱扫描中检查质谱分辨率和峰型。

MS ON（MS 开）和 MS OFF（MS 关） | 允许您开启和关闭质谱仪。
Profile scan（图形扫描） | 执行单个图形扫描
Repeat profile（重复图形） | 执行重复图形扫描（2 行）。
Detailed profile（详细图形） | 执行单个图形扫描并显示参数设置。
PFTBA Spectrum scan（PFTBA 谱扫描） | 执行 45 - 650 amu 的 PFTBA 质量范围的谱图扫描。
Full Spectrum scan（全谱扫描） | 执行 10 - 650 amu 整个质量范围的谱图扫描。
Find mass（发现质量） | 提示您给出一个质量，然后在最后一次的谱图扫描中发现其准确质量和丰度。


执行菜单 — CI 调谐 (5973 MSD)

执行菜单 — CI 调谐

5973 MSD 仅为 CI 配置。

Execute（执行）菜单允许您在图形扫描和全谱及 PFTBA 谱扫描中检查质谱分辨率和峰型。

MS ON（MS 开）和 MS OFF（MS 关） | 允许您开启和关闭质谱仪。
Profile scan（图形扫描） | 执行单个图形扫描。
Repeat profile（重复图形） | 执行重复图形扫描（2 行）。
Detailed profile（详细图形） | 执行单个图形扫描并显示参数设置。
PFTBA Spectrum scan（PFTBA 谱扫描） | 使用 10-800 amu 质量范围执行校准气体 PFDTD 的谱图扫描。
Full Spectrum scan（全谱扫描） | 执行 10 - 650 amu 整个质量范围的谱图扫描。
Find mass（发现质量） | 提示一个质量然后发现其在最后一次谱图扫描中的准确质量和丰度。


执行菜单 — 调谐

执行菜单

Execute（执行）菜单允许您在图形和谱图扫描中检查质谱分辨率和峰型。

MS ON（MS 开）和 MS OFF（MS 关） | 允许您开启和关闭质谱仪。
Profile scan（图形扫描） | 执行单个图形扫描
Repeat profile（重复图形） | 执行重复图形扫描（2 行）。
Detailed profile（详细图形） | 执行单个图形扫描并显示参数设置。
Spectrum scan（谱图扫描） | 执行谱图扫描
Find mass（发现质量） | 提示一个质量然后发现其在最后一次谱图扫描中的准确质量和丰度。


退出

Exit（退出）关闭所有视窗并结束化学工作站 session。万一您忘记保存调谐参数，您还可有机会 Cancel（取消）该命令。

当退出或关闭 Tune（调谐）时，MSD 被关闭。当仪器处于 EI 模式时，PFTBA 阀会自动关闭。


扩展进样器参数

使用 Extended Injector Parameters（扩展进样器参数）对话框为前或后进样器指定补充的进样器参数。（依赖于在 GC Injector Parameters（GC 进样器参数）对话框中的选择）。

本对话框内容：

Viscosity（粘度）

Sample Skim Depth（样品撇取一层的深度）（不是所有进样器有效）

PreInjection Dwell（前进样停留）（不是所有进样器有效）

PostInjection Dwell（后进样停留）（不是所有进样器有效）

Plunger Speed（活塞速度）

OK/Cancel/Help Buttons（确定/取消/帮助按钮）


外标校准 — 定义

外标校准过程要求校准样品和未知样品在相同条件下进行分析。定量结果通过比较未知样品与校准样品的数据获得。


提取离子色谱 — GC/MS

Extract Ion Chromatograms（提取离子色谱）菜单项允许从当前数据文件的总离子流色谱（TIC）提取并显示提取离子色谱（EICs）。选择该选项显示 Extracted Ion Chromatogram（提取离子色谱）对话框。在该对话框中可指定下列参数：

Time（时间）

数据文件的全部时间范围开始时被显示。可通过输入合适的起始和结束值指定一个较短的时间范围。

Ions（离子）

可指定最多六个离子。

Use Mass Range（使用质量范围）

每个离子的缺省质量范围为指定离子质量的 -0.3 amu 到 +0.7 amu。可改变这些值中的任何一个。


提取离子色谱 — 定义

提取离子色谱 (EIC) 是在 Scan（扫描）或 SIM 模式下采集的数据相对某特定质量或质量范围的跟踪曲线。


影响匹配质量的因素

大多数情况下，PBM 检索能从数据库中检索出一个高质量的匹配，并且未知样能够得到高度可靠的鉴定。然而，不管多复杂的检索例程都不能在当时提供一个 100 ％的最终鉴定。考虑下面这些影响匹配质量的因素：

  • 用于采集未知物和参比光谱的仪器类型

  • 用于采集未知物和参比光谱的实验条件

  • 用于本底扣除的光谱选择

  • 在 PBM 检索中使用的策略参数

  • 数据库中的光谱质量

一些因素同实际数据采集有关。通过谱库检索的一次成功鉴定的最重要方面是高质量的参比和未知样光谱。

例如，如果质谱的信噪比过低，没有本底扣除量或 PBM 策略参数的改变将会增加好的匹配的几率。另外，通过使用 GC 作为质谱仪进样口获得的光谱和使用直接进样获得的光谱可能有很大差别。这就是为什么在一个在相同仪器使用相同条件下获得参比光谱的用户创建谱库上进行检索是一个理想办法。

因为许多因素都可影响匹配质量和匹配列表中的化合物排序，该列表应被视为一个未知样身份的说明指引。不应假定列出的第一个匹配是唯一的正确答案。在最后的分析中，通过使用 PBM 结果和其他信息一起来决定匹配是否正确就是化学家的责任。例如，未知样和可靠样品的质谱的图形对比、对样品记录的了解和其他相关信息都应该被考虑。


电子倍增器角故障

更换电子倍增器。有关更换电子倍增器的说明，请参见 MSD 硬件手册。


真空规控制器保险丝故障

  1. 关掉真空规控制器。

  2. 断开连接到真空规控制器的电源线。

    警告！没有先断开电源线不要更换保险丝。如果电源线没有断开会出现高压。

  3. 拿出并检查真空规控制器保险丝。如果保险丝有故障，更换一个相同标识功率的保险丝。

如果保险丝频繁出现故障表示有更严重的根本问题。请与安捷伦科技公司维修代表处联系。


风扇故障已使泵关闭

风扇故障导致 MSD 关闭高真空泵和离子源以及质量过滤器加热器。如果原因是这样，提示Difficulty with the fan（有关风扇的困难）也会出现。如果风扇故障导致错误，必须循环开启 MSD（关闭和打开）来消除故障。

另见

风扇故障


快注射

有关准确注射的快速指定，请参见自动进样器文件。


故障检测开启

如果在 16 分钟的连续低温操作后没有达到指定的温度设定值（柱箱的当前温度 Setpoint（设定值）或柱箱梯度程序的温度设定值） ，请关闭柱箱。

注意这是用于达到设定值的时间，不是用于稳定和准备好设定值的时间。例如，在柱箱跟踪模式下使用冷柱头和低温控制，可能柱箱需要 20 至 30 分钟来达到稳定。


故障示例

有关 5973 MSD，请单击此处

下面列出的是一些出现最频繁的 MS 故障及其可能原因。

故障值 | 可能原因
3 | 电子倍增器电压设定过高；
 | MS 在溶剂峰上运行；
 | 电子倍增器刚更换过；
 | 离子源刚清洁过
5 | RF 线圈没有正确校正
9 | 灯丝烧坏
17 | GC 色谱柱流量过高；
 | 校准样品瓶刚被重新装满；
 | 空气泄漏
19 | MS 在溶剂峰上运行
33 | 扩散泵冷却风扇被堵塞或没有运行
129 | 扩散泵正在预热
257 | MS 处于 VENT（放空）状态（扩散泵加热器关闭）；
 | 扩散泵正在冷却
289 | 扩散泵过热，正在冷却
321 | 前级真空规电缆断开连接和扩散泵关闭
385 | 扩散泵冷却并关闭
417 | 扩散泵过热，自动关闭，目前已冷却
513 | （电子倍增器的）高压源出现故障


灯丝

要激活灯丝，在 On 复选框中加上 X。


灯丝出现故障或未正确连接

  1. 在 Edit Parameters（编辑参数）窗口，选择另一个灯丝。

  2. 运行自动调谐。如果 MSD 通过调谐，使用这个灯丝。方便时更换第一条灯丝。

  3. 如果第二条灯丝未通过调谐，将 MSD 放空并且检查灯丝接线连接。

  4. 检查灯丝。必要的话更换灯丝。

有关更换灯丝的说明，请参见 MSD 硬件手册。


灯丝（参数）

灯丝允许在离子源中的两条灯丝中选择一条。


文件菜单 - 调谐

File（文件）菜单允许运行下面列表中的任务，包括把调谐文件保存为一个新名称。调谐文件可以根据后缀“.U”来辨认。

Reset to Defaults（重置为缺省值） | 将所有调谐参数重置为缺省值。对于 5973 MSD，可以选择调谐类型。
Load Tune Values（加载调谐值） | 可以选择调谐文件 。
Save Tune Values（保存调谐值） | 可以保存调谐值到一个指定调谐文件。
Trace On（跟踪开启） | 把关于调谐步骤的详细报告保存到一个跟踪文件
View Trace（查看跟踪） | 可以查看跟踪文件
Print（打印） | 把 Tune（调谐）视窗中显示的图形或文本信息输出到缺省打印机。
Printer Setup（打印机设置） | 设定纵向或横向格式。（注意调谐报告和系统测试输出总是纵向格式。）
Generate Report（生成报告） | 产生调谐报告
Exit（退出） | 退出化学工作站。


文件菜单（参数检索）

文件菜单

Load（加载） | 加载一个数据文件。这一项会保持灰色直到检索完成。
List the Header（列出文件头） | 显示数据文件来的信息
Take a Shapshot（抽点打印） | 对当前采集到的数据抽点打印以便使用 Data Analysis（数据分析）工具来检验。
Subtract Background (BSB)（扣除本底 (BSB)） | 运行本底扣除 。
Print Current View（打印当前视窗） | 打印当前视窗（如View（视图） 菜单中所选）。
Save Parameters（保存参数） | 保存当前 Parametric Retrieval（参数检索）参数
Abort（异常中止） | 允许中止已经没有兴趣的 Data Analysis（数据分析）例程。
Exit（退出） | 立即关闭所有化学工作站窗口。在仅进行 Data Analysis（数据分析）中，仅 Data Analysis（数据分析）被关闭；其他程序不受影响。


HpmsdFILENAMEM_has_XX_compounds_AutoQ 有 XX 个化合物（自动定量对话框）

<FILENAME.M> 有 XX 个化合物

如果您的方法中已经包含一个定量数据库，软件会显示一个对话框说明当前方法的数据库中有多少化合物并让您选择：

Append Compounds to Database（在数据库中增加化合物）

让您添加化合物到列表的末端。

Insert Compounds in Database（在数据库中插入化合物）

让您在列表的名称中插入化合物。

Delete/Create New Database（删除/创建新数据库）

删除旧数据库并创建一个新的数据库。

如果想保持您的方法中存在的数据库，单击 Cancel（取消） 并在继续前将您的方法保存为一个新名称。

Back to AutoQuant Setup（返回自动定量设置）


膜厚

色谱柱内表面涂渍固定相的平均厚度（以微米为单位）。化学方法把标识 Film Thickness（膜厚）同方法一起保存。


过滤后的原始数据 - 定义

过滤后的原始数据通过加权平均过滤，可由 Gaussian 拟合进行峰检测。所有丰度大于等于最大丰度的 30％ 的数据点都被包含在内。（要改变这个缺省阈值，请参见 PEAKPARM 命令。）

对于过滤后的原始数据，扫描数据以连续曲线而不是以简单峰检测数据的棒图显示。质量步长大小在扫描范围 1600 amu 内限制在 0.1 或 0.15。然而，如果峰在过滤后的原始数据中遗漏，曲线会跌落到扫描阈值水平，使曲线看起来像一个棒图。

峰检测算法显示了每个调谐质量图形显示上部的 m/z 指认的可信度。如果数据同 Gaussian 拟合不一致，在报告中以质量值取代 m/z 值。


火焰

要点燃火焰，在 On 复选框中加上 X。

要熄灭火焰，除去 X。这会中断流向检测器的氢气气流足够长的时间来熄灭火焰。


火焰

要点燃火焰，在 On 复选框中加上 X。

要熄灭火焰，除去 X。这会关闭流向检测器的氢气和空气气流但保持尾吹气流继续开启。


火焰离子化检测器

火焰离子化检测器把样品和载气从色谱柱通入氢火焰里。单纯的氢火焰几乎不产生任何离子，但当燃烧有机化合物后产生的离子量会增加。一个极化电压将这些离子吸引到火焰附近的收集器。产生的电流同被燃烧的样品量成比例。一个电位计检测这个电流、将之转换为数字模式并送至输出设备。

使用 FID 对话框来设定检测器参数并指定设定值。有关详细信息，请单击下面绿色区域中的任何一项：

在选择温度和流量时请使用下面表格中的信息。

推荐温度和流速

气体类型 | 流量范围 | 建议流量
载气 （氢气，氦气，氮气） 填充柱 毛细管柱 |  | 10 至 60 ml/min 1 至 5 ml/min
检测器气体 氢气 空气 | 0 至 100 mL/min 0 至 800 mL/min | 40 mL/min* 450 mL/min*
色谱柱附加毛细管补充气 推荐：氮气 替换：氦气 | 0 至 100 mL/min | 50 mL/min

检测器温度

<150 [image] C，火焰不会点燃，防止水冷凝而损坏检测器
检测器温度应该比最高柱箱梯度温度大概高 20°C，具体取决于色谱柱类型。

点燃补偿值（检测器输出的 0.0 - 99.9 %）

如果火焰打开时的检测器输出减去火焰关闭时的检测器输出降到这个设定值以下，FID 会试图重新点火两次。如果输出仍然达不到这个值，检测器会关机。

2.0 pA 为推荐设定。

0.0 pA 禁止自动点火功能。
______
*氢气和空气比例应该在 8% 和 12% 之间来保持火焰处于点燃状态。

数据分析的 FID 信号转换：

  • 1.0 pA = 1 单位高度

  • 1.0pA x 1 second = 1 单位面积


火焰光度检测器

火焰光度检测器 (FPD) 通过在富氢火焰中燃烧色谱柱流出物来检测含磷或含硫化合物，并测量火焰上方发射光的选定光谱部分。在选定化合物的特征波长的发射光通过一个窄带通滤波器进入光电倍增管 (PMT)，此处它被转换为一个放大的数字电流。这时这个信号就既可以作为通讯输出的数字信号也可以作为 6890 GC 模拟输出的电压信号。

使用 FPD 对话框来设定检测器参数并指定设定值。有关详细信息，请单击图中的参数：

在选择温度和流量时请使用下面表格中的信息。

推荐温度和流速

气体类型

建议流量 (S)

建议流量 (P)

载气
（氢气，氦气，氮气）

填充柱
毛细管柱

10 至 60 ml/min

1 至 5 ml/min

10 至 60 ml/min

1 至 5 ml/min

检测器气体
氢气
空气

50 mL/min*
60 mL/min*

150 mL/min
110 mL/min

色谱柱附加毛细管补充气
推荐：氮气
替换：氦气

60 mL/min

60 mL/min

检测器温度

<120 [image] C，火焰不会点燃，防止水冷凝而损坏检测器
检测器温度应该比最高柱箱梯度温度大概高 25°C，具体取决于色谱柱类型。

化学工作站“FPD”对话框不能允许输入值超过最大允许温度 250 度。

点燃补偿值

6890 将当前信号输出同阈值进行比较以确定火焰是否已点燃。阈值定义为点燃补偿值加上火焰关闭时的输出值；火焰关闭时的输出值由在尝试点火之前的信号输出检测决定。如果输出低于这个阈值，火焰会被关闭而检测器会尝试重新点火。如果经过两次尝试后输出仍不能增加到阈值，检测器会关机。

2.0 单位为推荐设定。

设定为 0 时自动重新点火功能会被禁用。


流量

如果色谱柱已被定义，可以指定初始 Pressure（压力）、Flow（流量）或 Average Velocity（平均速率）中的任意项。GC 会根据您指定的项（显示为蓝色）计算并显示出其他两个设定值。

例如：

  • 如果选择 Constant Pressure（恒定压力）作为色谱柱 Mode（模式），并决定指定色谱柱 Flow（流量）作为初始条件，GC 会计算达到这个流量所必需的压力值（和平均线速度）并在整个运行期间保持此压力恒定。

  • 如果选择 Constant Flow（恒定流量）作为色谱柱 Mode（模式），并决定指定色谱柱 Flow（流量）作为初始条件，GC 仍会计算达到这个流量所必需的压力值，但会调节这个压力以保持恒定流量。

对于吹扫填充进样口，只能指定 Flow（流量）。

本对话框中其他项目：

Mode（模式）

Inlet（进样口）

Detector（检测器）

Outlet psi/kPa/bar（出口 psi/kPa/bar）

Installed Column（已安装的色谱柱）

Manufacturer's Specifications/Column Dimensions（制造商规格/色谱柱尺寸）

Ramps（梯度）


流量

色谱柱流速（以 ml/min 为单位）。GC 传送的 Actual（实际）色谱柱流速是只读显示。


流量和气体设定对话框

允许您将流量和气体设定同调谐文件一起保存。这个对话框可以在选择 File / Save Tune Values（文件 / 保存调谐值）时从 Manual Tune - CI（手动调谐 - CI）进入。

每个参数的范围显示在圆括号中。

输入流量设定 (0 - 100)

输入一个从 0 至 100 的流量设定。对于 PCI 其缺省流量设定为 29，对于NCI 为 40。

输入气体设定 (A 或 B)

选择需要使用的气体设定。缺省气体设定为 A。

输入的流量和气体设定将用作加载方法或调谐文件时的提示。它们不会影响实际硬件设定。

注意 在一个序列分析中，加载方法或调谐文件时不会提醒您对流量和气体进行设定。如果想运行带有要求气体切换的调谐文件的序列，需要在开始运行序列前切换到正确的气体/流量。然后在序列运行中，需要暂停序列运行，切换到正确的气体/流量，等待合适的时间，然后继续运行序列。


流量梯度

一个梯度色谱柱流量程序可以包括用来在运行中控制色谱柱质量流速的最多三阶（或“梯度”）。化学工作站顺序执行这些阶段的程序。一个程序包括：

  • 一个 Initial（初始）色谱柱流量，

  • 最多三个色谱柱流量 Ramps（梯度），和

  • 一个运行后色谱柱流量。

GC 将 Initial（初始）色谱柱流量保持指定的时间（Hold min（保持时间））。然后压力根据指定速率（以 ml/min2 为单位）改变到 Ramp 1（梯度 1）流量然后 GC 保持这个流量指定的时间。可以对Ramps 2（梯度 2） 和 3 的流量变化用同样的方法进行编程。最后，流量改变到 Post（后）色谱柱流量，GC 将之保持 Post Hold min（后保持时间）指定的时间。

柱箱程序决定了运行时间长短。

如果梯度色谱柱流量程序比柱箱的梯度升温程序长，流量程序会在柱箱程序结束时结束。此时，色谱柱流量回到并保持在程序设定的初始流量。

如果色谱柱流量程序比柱箱的短，色谱柱会把程序运行终点的流量值保持到运行结束。

对梯度色谱柱流量程序指定下列参数。有关详细信息，请单击下面绿色区域任何一项：

Total min（总时间）对于每个梯度阶数都是累计运行时间（由柱箱程序决定）的一个只读显示。

要查看色谱柱流量设定值的图形，单击 Plot...（图形...）按钮并选择 Column 1 (or 2) Flow（色谱柱 1（或 2）流量：


MS 化学工作站中的字体选择

Data Plot（数据图形）窗口中的四个文本元素可以通过 CP 变量的设定来独立控制。

图形元素 | 控制变量
积分峰标记 | PlotFont
图形标题 | FontTitle
用户创建的注解 | FontAnn
图形轴标志 | FontAxis

要控制某个图形元素的字体选择，选择相应的 Controlling Variable（控制变量）并把它设为一个格式为“字体名称，大小，旋转，粗体”的字符串。这些元素应该用逗号隔开并且不能为空。缺省值为：字体名称 = Arial，大小 = 12，旋转 = 0，粗体 = 0（内部映象到 FW_THIN）。当变量为空时这些值被使用。语义学如下：

参数

特征

字体名称

使用标准 Windows 字体名称

大小

以点表示

旋转

以 10 度的倍数倾斜表示

粗体

0 = 正常，1 = 粗体

宏使用示例

NAME PlotExample

FILE "xyz.d"

TIC, TICOBJECT

PlotFont = "Arial, 14, 900, 0" ! vertical labels reading upward

DRAW 3, TICOBJECT ! plot window assumes vert. labels

STARTPRINT

WINPRINT 3, 1, 1, 60, 12 ! so does the printed page

ENDPRINT

REMOVE PlotFont ! go back to default settings

RETURN

推荐的编程结构使用局部变量来提供一个恢复宏的先前状态的简便方法：

NAME BetterExample

LOCAL PLOTFONT, TICOBJECT

FILE "xyz.d"

TIC, TICOBJECT

PlotFont = "Arial, 14, 900, 0" ! vertical labels reading upward

DRAW 3, TICOBJECT ! plot window assumes vert. labels

STARTPRINT

WINPRINT 3, 1, 1, 60, 12 ! so does the printed page

ENDPRINT

RETURN

另外，变量 XPlotLabel 和 YPlotLabel 中包含可替换标准 X 和 Y 轴标志的字符串。不提供长度检验。


前级真空规工作异常

更换前级真空规。有关更换前级真空规的说明，请参见 MSD 硬件手册。


前级软管过紧

检查前级软管。确认它没有折叠。确认它没有弯曲太大或过紧。


前级泵工作异常

更换前级泵或与安捷伦科技公司维修代表处联系。


前级泵工作异常

如果前级泵工作异常，可能使涡轮分子泵无法达到常规工作速率。在配备涡轮分子泵的 MSD 上不测量前级压力。

另见

前级压力过高


前级泵油位过低或油被污染

如果前级泵油位过低或已被污染，前级泵不能有效工作。这可能增加前级压力和真空多路连接管压力。检查前级泵油位。必要的话，添加或更换前级泵油。同时检查油的情况（颜色）。前级泵油受热，或进入空气、水、溶剂和样品时会逐渐失效。一种症状是油的颜色逐渐变深。


ForePres（参数）

Foreline Pressure(前级压力)以 mTorr 为单位显示 MSD 的前级压力。

仅适用于 5973 MSD


前检索 — 定义

前检索算法对参比光谱同未知物光谱的相似性进行评估。要获得良好匹配，参比光谱中必须出现未知样中的所有重要峰。前检索中的最佳匹配通常看起来同未知物非常相似。


前/后进样未完成

检查进样器是否正确安装和校正，并确认运作时在通向接口处没有障碍。如果没有明显障碍或安装和校正故障，则需要进行维修。


前/后进样器

指定要使用的进样器的下列信息：

  • 注射器体积容量 (5 [image] l 或 10 [image] l)，以及

  • 是否安装了纳升接头 (18599N)。

要继续 Quick Setup（快速设置）过程：

转到下一个对话框。

回到前一个对话框。

要创建和显示 Quick Setup（快速设置）方法：

要取消 Quick Setup（快速设置）过程：


前/后进样器通信故障

可能的原因是电缆滑落。关闭仪器并确认所有电缆连接可靠，然后开启仪器重试。如果这样处理不能排除故障，可能需要对该仪器进行维修。


前/后进样器内存故障

可能的原因是电缆滑落。关闭仪器并确认所有电缆连接可靠，然后开启仪器重试。如果这样处理不能排除故障，可能需要对该仪器进行维修。


前/后进样器重新设定

可能的原因是电缆滑落。关闭仪器，确认所有电缆连接可靠，然后打开仪器重试。如果该处理不能排除故障，可能需要对仪器进行维修。


前/后无效的样品瓶编号

化学工作站请求从已安装硬件不支持的样品瓶号中进样。验证正确的样品瓶编号。如果化学工作站安装时具有该瓶号，安装好之后，装卸样品瓶架时可能会发生该故障。


前/后活塞故障

检查进样器是否正确安装和校正，并确认运行时在通向接口处没有障碍。如果没有明显障碍或安装和校正问题，则需要进行维修。


前/后注射器故障

检查进样器是否正确安装和校正，并确认运行时在通向接口处没有障碍。如果没有明显障碍或安装和校正问题，则需要进行维修。


前/后塔故障

检查进样器是否正确安装和校正，并确认进样器移向接口时没有障碍。如果没有明显障碍或安装和校正故障，则仪器需要进行维修。


前/后（样品瓶编号）需要（预期条码），为（实际条码）。

读出条码非预期条码。

（进样完成/样品未被进样）)

在读出的条码和在样品名称中找到的预期值不匹配时，化学工作站会记录这三条信息。化学工作站报告指出是前样品还是后样品、涉及哪些样品瓶编号、预期条码和实际读出条码。第三行说明化学工作站是否进行了进样。


函数（定义）

函数是在得到有效参数后返回一个唯一值的表达式。函数同变量相似，用于替换一个表达式。

函数名后总跟着一个括在圆括号中的参数列表。即使函数没有参数圆括号仍必须同函数名一起出现。


高真空泵保险丝故障

用户不能更换该保险丝。请与安捷伦科技公司维修代表处联系。


气体

打开下拉列表框并选择要使用的气体：

注： 此时，化学工作站仅支持氦气和氢气同 6890 挥发物接口一起使用。选择氩气/甲烷或氮气作为挥发物接口用气将使化学工作站弹出一个语法故障提示框。

该对话框中的其他项目：

Heater（加热器）

Pressure（压力）

Total Flow（总流量）

Split Ratio（分流比）

Split Flow（分流流量）

GasSaver（载气节省）（如果色谱柱已定义）


气体

打开下拉列表框并选择要使用的气体：

本对话框中其他项目：

Heater（加热器）

Mode（模式）

Ramps（梯度）

Pressure（压力）


气体

打开下拉列表框并选择要使用的气体：

本对话框中其他项目：

Mode（模式）

Cryo Config（低温配置）

Heater（加热器）

Ramps（梯度）

Pressure（压力）

Total Flow（总流量）

GasSaver（载气节省）（如果色谱柱已被定义）


气体

打开下拉列表框并选择要使用的气体：

本对话框中其他项目：

Heater（加热器）

Pressure（压力）

Total Flow（总流量）

Sampling End（进样端）

Purge Time（吹扫时间）

Purge Flow（吹扫流量）

GasSaver（载气节省）（如果色谱柱已定义）


气体

打开下拉列表框并选择要使用的气体：

本对话框中其他项目：

Heater（加热器）

Pressure（压力）

Total Flow（总流量）

Sampling End（进样端）

GasSaver（载气节省）（如果色谱柱已被定义）


气体

Gas（气体）

打开下拉列表框并选择要使用的气体：

对于通常操作，在化学工作站 PCM 对话框中调节载气流量（氦气）到大概 19 mL/min。

本对话框中其他项目：

Air Cooling On（空气冷却开启）

Heater（加热器）

Ramps（梯度）

Pressure（压力）

Total Flow（总流量）


气体

打开下拉列表框并选择要使用的气体：

本对话框中其他项目：

Heater（加热器）

Pressure（压力） （如果色谱柱已被定义）

Total Flow（总流量） （如果色谱柱已被定义）


气体

打开下拉列表框并选择要使用的气体：

本对话框中其他项目：

Mode（模式）

Heater（加热器）

Pressure（压力）

Total Flow（总流量）

GasSaver（载气节省）（如果色谱柱已被定义）


气体

打开下拉列表框并选择要使用的气体：

  • N2（氮气）

  • H2（氢气）

  • He（氦气）

  • ArCH4（氩气/甲烷 5%）

  • Air（空气）

注意： 如果压力辅助通道已连接到色谱柱，Air（空气）就不再是有效的气体选项。如果当通道连接时选定的气体是 Air（空气），会自动更换为 N2（氮气）。

本对话框中其他项目：

Aux Channel（辅助通道）

Description（说明）

Heater (thermal channels)（加热器（加热通道））

Cryo Focus Configuration (option not available)（低温冷凝配置（选项不可用））

Type (thermal channels)（类型（加热通道））

Pressure (pressure channels)（压力（压力通道））

Ramps（梯度）


气体进样

双位阀（抽样或进样）。

要完成配置信息，指定：

  • Loop Volume（定量管体积） [image] 定量进样管的容量（以 mL 为单位）。

  • Description of use（使用说明） [image] 更详细的描述了阀功能，例如，“1 ml 定量阀”。

  • Inlet（进样口） [image] 用于进样的进样口。

只能配置两个阀作为 Gas Sampling（气体进样）阀。

有关气体进样阀的更多信息，请参见 Gas Sampling（气体进样）。


气体进样

最多可配置两个阀作为 Gas Sampling（气体进样）阀。气体进样阀是双位阀（抽样或进样）。

  • 在抽样位置，外部气流流经附加样品定量管进入废液瓶。

  • 在进样位置，把装满的样品定量管注入载气流。

Stream Selection（气流选择） [image] 气体进样阀与多位阀协同作用实现自动进样器的功能。打开气体进样阀后，化学工作站假设已进行了一次进样。（有关更多信息，请参见 Multiposition（多位）。）

要完成配置信息，指定：

  • Loop Volume（定量管体积） [image] 定量进样管的容量（以 mL 为单位）。

  • Load time（抽样时间） [image] 阀在转换到进样位置前在抽样位置保持的时间（以 min 为单位）。

  • Inject time（进样时间） [image] 阀在回到抽样位置前在进样位置保持的时间（以 min 为单位）。

  • Inlet（进样口） [image] 要用于进样的进样口。

气体进样阀进样

对一个气体进样阀的配置通常包括下列规范：

  • 进样源是 6890 GC 阀，

  • 一个阀是 Multiposition（多位）阀，

  • 另一个阀是 Gas Sampling（气体进样）阀。

当运行开始时：

  1. 6890 系列 GC 把多位阀转换到代表前样品瓶编号的位置。

  2. GC 会为气体进样阀的 Load Time（进样时间）假定一个未就绪状态（如果配置了两个气体进样阀，较长的 Load Time（进样时间）优先）。

  3. 打开气体进样阀后：

  • 作为进样方法的部分，或

  • 作为运行时间事件，或

  • 当把设定值改变为 On 并下载时，化学工作站会等待直到 GC 达到就绪状态然后把选定作为进样源的气体进样阀转换到进样状态。

  4. GC 在 Inject Time（进样时间）期间假定进样位置。

注意： 在气体进样阀的 Load Time（进样时间）期间，无论是化学工作站还是 GC 均未就绪。不能忽视等待 GC 达到就绪状态所需要的时间。


载气节省

在样品进入色谱柱后从分流口减少载气流量。当吹扫和分流口流量下降，化学工作站会保持色谱柱头压力和色谱柱流速。载气节省可在 Const Pressure（恒定压力） 或 Const Flow（恒定流量）色谱柱模式下使用。

如果色谱柱已被定义，通过在复选框中加上 X 来激活载气节省功能。（有关定义色谱柱的信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。）

需要化学工作站降低分流口流量时，在运行开始后指定所需的分流口流量（以 ml/min 为单位）和时间（以分钟为单位）。

有效范围

15 ml/min - 对当前配置气体在 0 - 999.9 min 的传感器范围

本对话框中其他项目：

Gas（气体）

Heater（加热器）

Pressure（压力）

Total Flow（总流量）

Sampling End（进样端）


载气节省

在样品进入色谱柱后从分流口减少载气流量。当吹扫和分流口流量下降，化学工作站会保持色谱柱头压力和色谱柱流速。载气节省可以在 Const Pressure（恒定压力） 或 Const Flow（恒定流量）色谱柱模式下使用。

如果色谱柱已被定义，通过在复选框中加上 X 来激活载气节省。（有关定义色谱柱的信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。）

需要化学工作站降低分流口流量时，在运行开始后指定所需的载气节省流量（以 ml/min 为单位）和时间（以分钟为单位）。

如果进行手动进样且 GasSaver（载气节省）开启，必须在进样前按下 6890 GC 的[Prep Run]（[预运行]）键。

有效范围 [image] 15 ml/min - 对当前配置气体在 0 - 999.9 min 的传感器范围

本对话框中其他项目：

Mode（模式）

Gas（气体）

Cryo Config（低温配置）

Heater（加热器）

Ramps（梯度）

Pressure（压力）

Total Flow（总流量）


载气节省

在样品进入色谱柱后从分流口减少载气流量。当吹扫和分流口流量下降，化学工作站会保持色谱柱头压力和色谱柱流速。载气节省可以在 Const Pressure（恒定压力） 或 Const Flow（恒定流量）色谱柱模式下使用。

如果色谱柱已被定义，通过在复选框中加上 X 来激活载气节省。（有关定义色谱柱的信息，请参见向目录中添加新色谱柱型号。）

需要化学工作站降低分流口流量时，在运行开始后指定所需的分流口流量（以 ml/min 为单位）和时间（以分钟为单位）。

Valid Range（有效范围）

15 ml/min - 对当前配置气体在 0 - 999.9 min 的传感器范围

本对话框中其他项目：

Gas（气体）

Heater（加热器）

Pressure（压力）

Total Flow（总流量）

Split Ratio（分流比）

Split Flow（分流流量）


载气节省

在样品进入色谱柱后从分流口减少载气流量。当吹扫和分流口流量下降，化学工作站会保持色谱柱头压力和色谱柱流速。载气节省可以在 Const Pressure（恒定压力） 或 Const Flow（恒定流量）色谱柱模式下使用。

如果色谱柱已被定义，通过在复选框中加上 X 来激活载气节省。（有关定义色谱柱的信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。）

需要化学工作站降低分流口流量时，在运行开始后指定所需的分流口流量（以 ml/min 为单位）和时间（以分钟为单位）。

有效范围

15ml/min - 999.9 min

本对话框中其他项目：

Gas（气体）

Heater（加热器）

Pressure（压力）

Total Flow（总流量）

Sampling End（进样端）

Split Ratio（分流比）

Split Flow（分流流量）


载气节省

在样品进入色谱柱后从分流口减少载气流量。当吹扫和分流口流量下降，化学工作站会保持色谱柱头压力和色谱柱流速。载气节省可以在 Const Pressure（恒定压力） 或 Const Flow（恒定流量）色谱柱模式下使用。

如果色谱柱已被定义，通过在复选框中加上 X 来激活载气节省。（有关定义色谱柱的信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。）

需要化学工作站降低分流口流量时，在运行开始后指定所需的分流口流量（以 ml/min 为单位）和时间（以分钟为单位）。

有效范围 [image] 15 ml/min - 对当前配置气体在 0 - 999.9 min 的传感器范围

本对话框中其他项目：

Mode（模式）

Gas（气体）

Heater（加热器）

Pressure（压力）

Total Flow（总流量）


GC ALS

GC 进样器

使用 GC 进样器自动进样。

色谱仪准备就绪后运行才能开始。

Front, Back（前、后）和 Dual（两者同时）的选择在这个对话框中为灰色。设定好进样器参数后指定要使用的进样器位置。


GC 配置变更检查

无论何时在修改 6890 系列 GC 硬件配置后停止化学工作站，化学工作站就会显示检测到的变化的列表并提示进行确认。

化学工作站会使用所提供的信息：

  • 升级 GC 的缺省方法 (DEF_GC.M)，并且

  • 正确操作仪器。

当前配置以图形方式总结。Pressure Units（压力单位）指定压力测量值的当前单位 (kPa，psi 或 bar)：

  • 1 kPa = 0.145 psi = 0.01 bar

  • 6.895 kPa = 1 psi = 0.06895 bar

  • 100 kPa = 14.504 psi = 1 bar

注意：灰色图标表示硬件可能已安装但当前没有配置。
单击Pressure Units（压力单位）来修改压力测量值的单位。

要审查重新配置后的硬件项目，单击其相应图标。

化学工作站会显示和您的选择相应的配置对话框。检查对话框并尽您所能做出选择。

要检查整个仪器配置，使用 Review Entire Configuration（检查全部配置）按钮：

化学工作站会为您显示所有的配置对话框。检查每个对话框，并尽您所能做出选择。

OK/Help Buttons（确定/帮助按钮）


GC 电路工作异常

请与安捷伦科技公司维修代表处联系。


GC 进样器参数（对于多次进样）

使用 GC Injector Parameters（GC 进样器参数）对话框来指定进行多次进样的操作参数。对于多次进样， GC 进样器必须是 G1513A 配置的。有关更多的信息，请参见 Injector Configuration（进样器配置）。

可以使用 Programmed Temperature Vaporization (PTV) Inlet（程序升温挥发 (PTV) 进样口）通过在 Solvent Vent Mode（溶剂放空模式）下使用大样品体积操作来使灵敏度增加。

指定要使用的是前、后进样器或同时使用两个进样器。单击相应的选项按钮：

Use Front Injector（使用前进样器） - 前进样器参数可用

此处的选择决定了哪些进样器（前进样器、后进样器、或两者）参数可进行编辑，并与方法一起保存。

注 多次进样在进样器有 8-样品转动架选项时会更快。100-瓶进样器样品瓶架和 8-样品转动架不兼容。

对于多次进样的进样器参数：

Inject (X) uL (Y) Times（进样 (X) uL (Y) 时间）

Delay（延迟）

Washes（洗涤）

计算值和显示值

化学工作站计算并显示两个值；总样品体积和总进样时间。

总样品体积在进样器屏幕上显示。它是每次进样的体积和每次运行的进样的乘积。

估计总进样时间在 PTV 进样口屏幕上显示。这是用于进行依据输入的参数和进样器的机械周期时间的一系列多次进样的近似总时间。包括进样之间的延迟、其他延迟和停留时间。这一时间用于计算溶剂放空时间。


GC 故障

请参见与 GC 一起提供的用户信息，或与安捷伦科技公司维修代表处联系。


GC 状态提示框

这个对话框给出 GC 前面板显示的简单摘要。使用 Edit GC Monitors（编辑 GC 监测器）来设定显示。


GC/MSD 接口温度过低

升高 GC/MSD 接口（Thermal Aux #2）温度然后看拖尾情况是否减轻。如果仍然如此则继续调节温度直到找到最佳设定。

注意

不要超出色谱柱的温度极限。


一般信息

可以将 6890 系列 GC 设置为一台化学工作站仪器，通过一个 GPIB 接口连接。化学工作站参数控制 GC 的操作，并分析 GC 产生的数据。

化学工作站能知道您使用的 6890 系列 GC 的主要硬件特性。例如，它可以知道安装的检测器类型。

未安装一个硬件或软件选项时，和该选项相关的信息成为灰色而不能选择和/或修改。

ChemStation Status/6890 Series GC Status（化学工作站状态/6890 系列 GC 状态） [image] 化学工作站状态窗口反映当前化学工作站状态，而 GC 状态窗口（运行在线部分时显示）反映 GC 的状态。在预运行状态下，化学工作站状态可能与 GC 状态有所不同。例如，工作在脉冲不分流模式下时，化学工作站会在吹扫进样口以准备进样时到达就绪状态（这段时间内 GC 将表现为“未就绪”状态）。

化学工作站将设定值下载到6890 系列 GC，当：

  • 初始化化学工作站。加载缺省方法 (DEF_GC.M)，且所有 GC 参数被设定到缺省值。

  • 加载一个方法。

  • 修改设定值并选择“Apply”或“OK”。

  • 使用前面板修改 GC 参数。

注意：化学工作站不使用 GC 前面板下载已创建序列的设定值。


生成调谐报告

选择File / Generate Report（文件/生成报告）使用当前调谐参数产生图形扫描和谱图扫描，然后打印调谐报告。把新图形和谱图送到缺省系统打印机。报告总是以竖排格式打印。


生成报告

生成面积百分比报告

生成谱库检索报告

生成定量报告

使用定制报告


全局最低检测限

Global Minimum Detection Limit（全局最低检测限）确立一个信号水平，在这个水平以下的化合物都被认为没有找到。此处的设定会覆盖 Edit Compunds（编辑化合物）的第 2 页上的化合物限制集合。

Hints（建议） - 设定 Minimum Detection Level（最低检测水平）为 0.00 能产生最长且最完整的报告。设定 Minimum Detection Level（最低检测水平）为方法的 MDL 或实验室本底的水平则产生一个限制为与目标化合物确定匹配的报告。

Global Minimum Detection Limit（全局最低检测限）与基体无关。如果词 H2O 或 Water 在 Sample Name（样品名称）或 Miscellaneous Information（其他信息）中，Matrix A（有时标记为 Water）的局部 MDL 会被使用。而如果使用的是“soil”，Matrix B（有时标记为 Soil）的局部 MDL 会被使用。如果上面任何一项都没有找到， Edit Compounds（编辑化合物）的第 2 页上找到的 Matrix A 的局部 MDL 会被使用。


全局更新对话框

Global Update Dialog Box（全局更新对话框）

选择 Calibrate（校准）/ Update（更新）/ Global Update（全局更新），Global Update（全局更新）对话框可以改变下列用于整个定量数据库的参数。

Shift Retention Times（保留时间漂移）

提示使时间漂移常数 x 分钟或按比例漂移 x%。在数字后面加一个 m 来指定一个恒定漂移值（以分钟为单位）或在数字后加一个 % 来指定一个百分比漂移值。例如，如果所有化合物比预期保留时间多洗脱 2 分钟，输入 2m 作为保留时间漂移。Shift Retention Times（保留时间漂移）影响化合物数据库中的 Retention Time Information（保留时间信息）。

Resize Extraction Windows（调整提取窗口大小）

提示改变窗口大小 x% 或 x 分钟。Resize Extraction Windows（调整提取窗口大小）”影响化合物数据库中的 Retention Time Information（保留时间信息）。

Set Curve Fit Type（设定曲线拟合类型）

提示您选择一种曲线拟合。影响 Calibration Information（校准信息）。

Set Identification Method（设定鉴定方法）

提示您为目标离子在提取窗口中选择一种鉴定方法。尽管可以在这里全局设定，但最好在数据库中逐个化合物进行设定。另见 Quantitation Parameters（定量参数）。

Set Subtraction Method（设定扣除方法）

让您指定用于计算特征离子比例的方法：平均首项和末项；降低首项或末项；不扣除；扩展面积定量（仅同峰面积定量使用）。另见 Target Compound Identification（目标化合物鉴定）”。

Set Other (via command)（设定其他（通过命令））

让您使用命令对其他参数进行全局改变。例如，要把所有化合物的浓度单位改变为“ug/L”，输入 Amt_Units$="ug/L" 并单击 OK（确定）。然后定量数据库中的所有化合物的浓度单位都被更新。

任何定量数据库变量都可以用这种方式更新。GETCOMPOUND 和 GETRESULT 包含一个应用参数的列表。


术语表按钮

Glossary（术语表）按钮

如果这个按钮在帮助窗口的菜单中出现，可以单击它来显示一个依字母顺序的重要的词和短语及其定义的列表。

术语表中定义的术语也可以在遇到下划点时被访问，如： Tuning(调谐） 把光标放在有下划点的词下面并单击鼠标按钮。


色谱图形

# Pages（页数）

分析得出的总离子流色谱（GC/MS 模式中的 Total Ion Current（总离子流）或 GC-only 模式下的Chromatogram（色谱））可以打印在一页上或增加到最多达 10 页。选项 None 将从报告中删除总离子流色谱。

Y Axis Scale（Y 轴坐标）

这用于设定一个溶剂峰或污染物的信号水平大大超过样品信号水平时的有用响应坐标。总离子流色谱 (TIC) 可以根据指定时间后（例如，溶剂峰冲洗后）的最大色谱峰来设定坐标。色谱坐标由指定时间后的最大峰决定。

对 TIC 输入一个大于 100 的数值，Sig 1 或 Sig 2 抵消了 “largest peak after x minutes（x 分钟后的最大峰）”功能。另外可以用大于 100 的数值设定响应坐标的输入值。在 GC-only 模式下，对每个信号可设定独立的强度坐标。

峰标记

标记出在指定的 MDL 限上的色谱上的峰。

横向定向

在页面上横向而不是垂直方向（纵向）打印定量报告。这一设定不必和由 File / Printer Setup（文件 / 打印机设置）指定的方向一致，且只用于定量报告。


 接地回路

接地回路

检测器和 GC 电源的地线可能处于不同电位。这产生一个通过检测器接口和分析器的电流通路（接地回路）。确认电源的地电势相同。

警告！ 检查地电流应由合格电工操作。


氢气流量，mL/min

要激活通到检测器的氢气流，在 On 复选框中加上 X。

GC 传送的 Actual（实际）流量是只读显示。

EPC 设定值： 0 至 30 mL/min


H2 Flow, mL/min

氢气流量，mL/min

要激活通到检测器的氢气流，在 On 复选框中加上 X。

GC 传送的 Actual（实际）流量是只读显示。

EPC 设定值： 0 至 100 mL/min


氢气流量，mL/min

要激活通到检测器的氢气流，在 On 复选框中加上 X。

GC 传送的 Actual（实际）流量是只读显示。

设定值范围： 0 至 250 mL/min


加热器

要激活加热辅助通道，在 On 复选框中加上 X。

使用 Setpoint（设定值）来指定辅助通道的温度（以 [image] C 计）。

有效范围：从环境温度至 400 [image] C

GC 传送的检测器辅助通道 Actual（实际）温度是只读显示。

本对话框中其他项目：

Aux Channel（辅助通道）

Description（说明）

Cryo Focus Configuration (option not available)（低温冷凝配置（选项不可用））

Type (thermal channels)（类型（热通道））

Pressure (pressure channels)（压力（压力通道））

Gas (pressure channels)（气体（压力通道））

Ramps（梯度）


加热器

要激活进样口的加热元件，可以在复选框 On 中加上 X。

GC 传输的进样口 Actual（实际）温度（显示在 [image] C）是只读显示。

本对话框中其他项目：

Gas（气体）

Mode（模式）

Ramps（梯度）

Pressure（压力）


加热器

Heater（加热器）

要激活进样口的加热元件，可以在复选框 On 中加上 X。

使用 Setpoint（设定值）来指定 PTV 进样口的温度设定值：

无冷却* | 0°C 至 450°C
CO2 冷却 | -60 [image] C 至 450°C
液氮冷却 | -160 [image] C 至 450°C

*实际下限大约比环境温度高 10°C。GC 传送的进样口 Actual（实际）温度（以 [image] C 显示）是只读显示。

本对话框中其他项目：

Mode（模式）

Gas（气体）

Cryo Config（低温配置）

Ramps（梯度）

Pressure（压力）

Total Flow（总流量）

GasSaver（载气节省）（如果色谱柱已被定义）


加热器

Heater（加热器）

要激活进样口的加热元件，可以在复选框 On 中加上 X。

使用 Setpoint（设定值）来指定进样口的温度设定值。

Valid Range（有效范围）：

0.0 至 400°C

6890 GC 传送的进样口 Actual（实际）温度（以 [image] C 为单位显示）是只读显示。

本对话框中其他项目：

Gas（气体）

Pressure（压力）

Total Flow（总流量）

Split Ratio（分流比）

Split Flow（分流流量）

GasSaver（载气节省）（如果色谱柱已被定义）


加热器

要激活进样口的加热元件，可以在复选框 On 中加上 X。

使用“Setpoint（设定值）”来指定进样口的温度设定值。

有效范围：

0.0 至 400°C

6890 GC 传送的进样口实际温度（显示在 [image] C）是只读显示。

本对话框中其他项目：

Gas（气体）

Pressure（压力）

Total Flow（总流量）

Sampling End（进样端）

Purge Time（吹扫时间）

Purge Flow（吹扫流量）

GasSaver（载气节省）（如果色谱柱已被定义）


加热器

Heater（加热器）

要激活进样口的加热元件，可以在复选框 On 中加上 X。

使用 Setpoint（设定值）来指定进样口的温度设定值。

Valid Range（有效范围）：

0.0 至 400°C

6890 GC 传送的进样口 Actual（实际）温度（以 [image] C 为单位显示）是只读显示。

本对话框中其他项目：

Gas（气体）

Pressure（压力）

Total Flow（总流量）

Sampling End（进样端）

GasSaver（载气节省）（如果色谱柱已被定义）


加热器

PCM 和加热的进样口一起配置时，可以在复选框 On 中加上 X 来激活进样口的加热元件。

在输入框中输入进样口所需的设定值温度。

GC 传送的进样口实际温度（显示在 [image] C）是只读显示。

本对话框中其他项目：

Gas（气体）

Air Cooling On（空气冷却开启）

Ramps（梯度）

Pressure（压力）

Total Flow（总流量）


加热器

要激活进样口的加热元件，可以在复选框 On 中加上 X。

使用 Setpoint（设定值）来指定进样口的温度设定值（环境为 450 [image] C）。

GC 传输的进样口 Actual（实际）温度（显示在 [image] C）是只读显示。

设定值范围

参数 | 允许设定值范围
柱箱跟踪 | 3 [image] C 高于柱箱温度 至最大值 450 [image] C 。如果有“CryoBlast”，进样口可以 保持温度到 -40 [image] C， 尽管允许的柱箱设定值对于 CO2 是 -60 [image] C，而对于 N2 是 -80 [image] C。
没有 CryoBlast 的梯度温度 | 24 [image] C 至 450 [image] C
带有 CryoBlast 的梯度温度 | -40 [image] C 至 450 [image] C

本对话框中其他项目：

Gas（气体）

Pressure（压力） （如果色谱柱已被定义）

Total Flow（总流量） （如果色谱柱已被定义）


加热器

要激活进样口的加热元件，可以在复选框 On 中加上 X。

使用 Setpoint（设定值）来指定进样口的温度设定值（环境为 400 [image] C）。

GC 传输的进样口 Actual（实际）温度（显示在 [image] C）是只读显示。

本对话框中其他项目：

Mode（模式）

Gas（气体）

Pressure（压力）

Total Flow（总流量）

GasSaver（载气节省）（如果色谱柱已被定义）


加热器，°C

要激活检测器的加热元件，可以在复选框 On 中加上 X。

由 GC 传送的检测器实际温度为只读显示。

设定值范围： 0 至 400 [image] C


加热器，°C

要激活检测器的加热元件，可以在复选框 On 中加上 X。

由 GC 传送的检测器实际温度为只读显示。

设定值范围： 0 至 250 [image] C


加热器，°C

要激活检测器的加热元件，可以在复选框 On 中加上 X。

由 GC 传送的检测器实际温度为只读显示。

设定值范围： 0 至 450 [image] C


加热器卡套有故障（开路）

  1. 将 MSD 放空。

  2. 打开真空多路连接管。

    注意

    任何时候打开真空多路连接管时注意释放静电（ESD），尤其是在质量过滤器（四极杆）导线附近工作时。这些导线可能使静电释放到侧板上的敏感部件。

  3. 从电源板断开加热器导线的连接。对于每个加热器，使用电阻表检查加热器是否断路。如果电阻表指示加热器是开路（电阻无穷大），更换加热器组件。

有关放空 MSD、打开真空多路连接管和更换加热器组件的说明，请参见 MSD 硬件手册。


加热器电压过低

这是指电路模块中的变压器未正确配置。变压器不能由用户维修。请与安捷伦科技公司维修代表处联系。


HED 高压导线同地短接

  1. 将 MSD 放空。

  2. 打开真空多路连接管。

  3. 检查 HED 高压导线。确认它已连接。确认它没有和地表短接。

有关将 MSD 放空和打开真空多路连接管的说明，请参见 MSD 硬件手册。


帮助按钮
单击这个按钮显示关于 Instrument Control（仪器控制）视窗的帮助并可进入帮助系统的其他部分。


高扫描速度（扫描模式）

如果在扫描模式中采集数据并遇到同位素遗漏或同位素比例不正确的故障，尝试减少扫描速率。


高真空泵关闭或未达到正常操作条件

离子源和质量过滤器（四极杆）加热器不会加热直到高真空泵开启和已达到它的正常操作温度（扩散泵）或它的正常工作速率的 80%（涡轮分子泵）。如果是这样，数据系统应该显示如下提示：

The system is in VENT state（系统处于放空状态）

The high vacuum pump is not ready（高真空泵未就绪）


高真空信号电缆未正确连接（扩散泵）

检查 MSD 的后部。确认高真空信号 (HIVAC SIGNAL) 电缆安全连接到 MSD 的后面板。

警告！扩散泵在危险高温下工作。请不要尝试检查连接到扩散泵的高真空信号电缆连接，除非 MSD 关闭且扩散泵有足够时间冷却。


高真空信号电缆未正确连接（涡轮分子泵）

检查 MSD 的后部。确认高真空信号 (HIVAC SIGNAL) 电缆安全连接到 MSD 的后面板和涡轮分子泵控制器。


保持时间

欲使 GC 对每个给出程序级保持 Next [image] C 的时间。

开始运行时初始保持时间间隔开始：

  • 如果是自动进样，在进样时间开始，或

  • 如果是手动进样，在 GC 前面板按下 Start（开始）时开始。


保持时间

欲使 GC 对每个给出程序级保持下一 [image] C 的时间。

开始运行时初始保持时间间隔开始：

  • 如果是自动进样，在进样时间开始，或

  • 如果是手动进样，在 GC 前面板按下 Start（开始）的时候开始。


保持时间

欲使 GC 对每个给出程序级保持ml/min 的时间。

运行开始时初始保持时间间隔开始：

  • 如果是自动进样，在进样时间开始，或

  • 如果是手动进样，在 GC 前面板按下 Start（开始）的时候开始。


保持时间

欲使 GC 对每个给出程序级保持 Next [image] C 的时间。

开始运行时初始保持时间间隔开始：

  • 如果是自动进样，在进样时间开始，或

  • 如果是手动进样，在 GC 前面板按下 Start（开始）的时候开始。

对于等温运行，在程序的初始行中将 Hold min（保持时间）参数设定到等温运行应该持续的时间长短。


保持时间

欲使 GC 对每个给出程序级保持 Next [image] C 的时间。

开始运行时初始保持时间间隔开始：

  • 如果是自动进样，在进样时间开始，或

  • 如果是手动进样，在 GC 前面板按下 Start（开始）的时候开始。


保持时间

欲使 GC 对每个给出程序级保持 Next psi, kPa 或 bar 的时间。

开始运行时初始保持时间间隔开始：

  • 如果是自动进样，在进样时间开始，或

  • 如果是手动进样，在 GC 前面板按下 Start（开始）的时候开始。


非保留峰的停留时间

色谱柱中的非保留峰的洗脱时间（以分钟为单位）。

停留时间也称为“死时间”。


如何

校准色谱柱

更换色谱柱

编辑方法

最佳数据采样频率

准备柱箱梯度升温程序

准备使用载气节省的等压运行

准备等压运行

设置脉冲压力进样口

设定分流比

设置程序升温挥发进样口

使用 GC 石油化工增强


图标条

单击相应图标打开一个仪器对话框。例如，单击 Valves（阀）图标打开 Valves（阀）对话框。

黄色背景表示图标相应的对话框当前是打开的（一种表示“您在此处”的消息）。

一旦打开对话框，可以添加或修改那里的参数。

蓝色背景表示您已经打开图标相应的对话框，但是没有更改任何参数。

蓝色的 X 表示您已经打开图标相应的对话框并且更改了那里的一个或更多参数，但是还没有下载更改。

红色背景表示在图标相应的对话框中存在一个或更多不合乎规定的数值（同样将以红色显示），在化学工作站允许下载前您需要将其改正。

带有红色文本的黄色背景表示图标相应的对话框当前是打开的并含有一个或更多不合乎规定的数值。

注意： 化学工作站将不会下载任何参数除非已改正所有不合乎规定的数值。

当使用 Apply（应用）或 OK（确定）按钮时，化学工作站将下载添加或修改的参数到仪器上：

有关更多信息，请参见按钮。


改善匹配质量

假定您对未知样品的鉴定有了看法并进行 PBM 检索以确定您的怀疑。

如果可疑化合物出现在匹配列表中但匹配率低：

在此情况下，可疑化合物已通过预过滤器标准，所以改变 U + A 选项没有影响。查看 Tilting（覆盖）；如果关闭，将其开启可修正参比和未知谱图之间的不同质谱仪响应。

这时列表报告的检查非常有用。如果 K 值高而 dK 值低，可疑化合物的匹配质量低是因为 PBM 认为未知样品被污染（% 低，Con 高）。未知样品和可疑化合物的图形比较也会指出哪些质量/丰度是不同的。

有时，平均跨越峰顶点的谱或检查顶点谱图以外的扫描也是有用的。在最后的分析中，图形比较对于正确的鉴定可能是必要的。

如果可疑化合物未出现在匹配列表中：

这种情况有几种可能性。升高 U + A 和 Flag Threshold（标识阈）并开启 Tilting（覆盖）放松预过滤器参数。尝试重新检索。如果仍未成功，化合物可能不在数据库中。


坐标显示不正确

如果显示图谱的顶部出现平顶峰，坐标可能不正确。更改坐标。


不正确的加热器导线连接

  1. 放空 MSD。

  2. 打开真空多路连接管。

小心

一旦打开真空多路连接管尤其在质量过滤器（四极杆）接点附近作业时，请小心预防静电放电（ESD）。这些接点可将有害的静电放电传送到侧板上的敏感部分。

  3. 检查离子源和质量过滤器加热器的加热器导线。确信加热器接线牢固连接到输入板正确的插针上。

  4. 如果加热器导线连接正确，检查加热器自身是否有故障。

有关放空 MSD 和打开真空多路连接管的说明，请参见 MSD 硬件手册。


不正确的进样口温度

过高或过低的进样口温度可导致峰拖尾。升高或降低进样口温度 25 到 50 摄氏度重新尝试。

警告

请勿超出毛细管色谱柱的温度限制。否则会毁坏色谱柱。


质量过滤器极性不正确

转换四极杆质量过滤器（四极杆）的直流极性。重新调谐 MSD。如果效果改善，继续使用新的直流极性。


不正确或不充分的电源电压

确信电源电压位于真空规控制器可接受范围以内。

警告！只允许专业电工检查线电压。


不正确样品浓度

确信样品浓度正确。一个比您认为的浓度低的样品可能会表现出灵敏度差，但实际相反。


不正确设定值

确信离子源温度的设定值正是您所希望的。除非被覆盖，设定值由与当前方法关联的调谐文件中的设定值确定。


不正确温度

MSD 中不正确温度可降灵敏度低。正确的温度随被分析样品类型而变化，但通常的温度为：

GC/MSD 接口 — 280 摄氏度

离子源 — 230 摄氏度

质量过滤器 — 150 摄氏度


不正确的调谐文件

如果调谐文件中的条件与采集数据时的条件不匹配，质量指认可能出现位移。确信当前调谐文件与用于分析的条件匹配（确信条件未被覆盖）。


不正确的调谐

确信方法中指定的调谐文件是一个有效文件。确信它对于分析技术和将要分析的样品的类型是合适的。如果 MSD 未通过调谐，请勿采集数据。


初始校准

初始校准是不同浓度级校准样品的分析。它定义了 MSD 对目标化合物响应的线性和动态范围。


初始柱箱温度过低

升高初始柱箱温度 10 或 20 摄氏度判断是否前伸峰减小。


降低初始柱箱温度

查看初始柱箱温度。确信其已被降低。降低初始柱箱温度会增加所有化合物的保留时间。


升高初始柱箱温度

查看初始柱箱温度。确信其已被升高。升高初始柱箱温度会缩短所有化合物的保留时间。


注射 (X) uL (Y) 次

Edit Injector Parameters（编辑注射器参数）对话框中的这一参数定义 (X) 为希望注射样品的体积（单位 ul），(Y) 为注射体积 (X) 的次数。

定义样品体积的有效值为：

  • Inject (X)（注射 X 倍体积）范围为注射器体积的 0.1 到 0.5 倍。缺省项为注射器体积的 0.1 倍。

  • (Y) Times（Y 次）范围从 1 到 100。缺省值是 1。

注射器必须配置为 Injector Configuration（注射器配置）对话框的 Multiple Injections（多次进样）。（单击 Configuration（配置）按钮。）

Syringe Size（注射器尺寸）在本对话框中是只读显示。可在 Injector Configuration（注射器配置）对话框修改 Syringe Size（注射器尺寸）。（单击 Configuration（配置）按钮。）

本对话框其他项目：

Delay（延迟）

Washes（清洗）


进样量过大

如果进样体积大于衬管体积，可能使峰歪向左边（峰拖尾）或右边（峰前伸）。请减少进样量。


进样口温度过高

进样口温度过高可导致峰前伸。降低进样口温度 25 到 50 摄氏度重试。


进样脉冲压力

从运行开始到进样口压力回到其标准设定值的时刻（单位为分钟）的进样口压力（单位为 psi、kPa 或 bar)。

有效范围：

0 - 100 psi 持续 0 - 999.9 分钟

0 - 690 kPa 持续 0 - 999.9 分钟

0 - 6.9 bar 持续 0 - 999.9 分钟


进样脉冲压力

从运行开始到进样口压力回到其标准设定值的时刻（单位为分钟）的进样口压力（单位为 psi、kPa 或 bar）。

有效范围：

0 - 100 psi 持续 0 - 999.9 分钟


进样量过大

大量进样会使色谱柱过载，导致带有分裂峰顶或锯齿状峰顶的色谱峰。请减少进样量。


进样方式

GC ALS

当计划使用自动液体进样器（ALS）时选择此方式。

Manual（手动）

请选择此方式如果您希望：

  • 使用注射器手动注射样品

  • 从吹扫/捕集系统导入样品

  • 同步运行

如果选择此项，在运行开始时出现一个对话框允许从键盘使运行同步。一旦完成进样，必须单击 Start Run（启动运行）。

Valve / Immediate Start（阀/立即启动）

当 GC 和 MSD 都就绪时开始运行。当质谱仪就绪时选择此方式启动运行；将不会有对话框提示启动运行。

External Device（外部设备）

当 GC 和 MSD 都就绪时运行开始，随后“外部设备”发出一个遥控启动。将不会有对话框提示启动运行。这种选择对于一个吹扫/捕集配置是最有用的。


进样体积

Injection Volume（进样体积）是希望注射的样品体积（单位为 ul）。可在 Injector Configuration（注射器配置）对话框指出是否使用 Nanoliter Adapter（纳升接头）。（单击 Configuration（配置）按钮。）

Syringe Size（注射器尺寸）在本对话框中是只读显示。可在 Injector Configuration（注射器配置）对话框修改 Syringe Size（注射器尺寸）。（单击 Configuration（配置）按钮。）

本对话框其他项目：

Washes（清洗）

更多按钮（6890 GC）

Configuration（配置）按钮

OK/Cancel/Help（确定/取消/帮助）按钮


注射器按钮（6890）

注射器按钮
当使用自动液体进样器配置仪器并在 Inlet / Injection Types（进样口/进样类型）框中选择 GC ALS 时，单击此按钮为注射器设定参数。


注射器配置

使用 Injector Configuration（注射器配置）对话框为前（和/或后）注射器（依赖于在 GC Injector Parameters（GC 注射器参数）对话框的选择）指定下列配置参数。

本对话框内容：

Syringe Size（注射器尺寸）

Nanoliter Adapter（纳升接头）

Multiple Injections（多次进样）

On-Column Injection（柱头进样）（不是所有注射器可用）

OK/Cancel/Help Buttons（确定/取消/帮助按钮）


注射器不存在

化学工作站试图从或向一个未安装的注射器的地方移动瓶子。关闭该部件并核实所有电缆接线牢固，然后开启该部件重试。如果故障再次发生，请与维修代表处联系。


进样口

指定色谱柱连接的进样口：

  • Front（前）

  • Back（后）

  • Pres Aux #3（压力辅助#3）

  • Pres Aux #4（压力辅助#4）

  • Pres Aux #5（压力辅助#5）

  • Unspecified（未指定）

注意： 如果指定 Pres Aux #3, #4, 或 #5 作为色谱柱的 进样口，可对运行时间事件编程以及为该通道梯度控制压力变化（请见运行时间）。（气体进样阀进样是对于该类配置的最普通的应用。）

本对话框中其他项目：

Mode（模式)

Detector（检测器）

Outlet psi/kPa/bar（出口 psi/kPa/bar）

Flow（流量）

Installed Column（安装色谱柱）

Manufacturer's Specifications/Column Dimensions（制造商规格/色谱柱尺寸）

Ramps（梯度）


进样口及检测器气体

检查安装在 6890 系列 GC 上的进样口和检测器的配置信息。化学工作站将使用这些信息执行电子流量控制 (EPC) 模块的正确操作。请发挥最佳的知识水平回答，然后单击 OK（确定）。

注意： 如果 EPC 未安装，可输入被请求信息以备存档或单击 OK（确定）继续。

请指定：

  • 用于前/后进样口的气体，和

  • 用于前/后检测器尾吹气流的气体。

有关进样口和检测器气的更多信息，请参见进样口和检测器。

OK/Undo/Help Buttons（确定/撤销/帮助按钮）


进样口按钮 — 6890

进样口按钮
单击此按钮为系统配置的进样口（例如，EPS 吹扫填充进样口）设定参数。一个面板将显示用于输入。


已安装的色谱柱

Installed Column（已安装的色谱柱）显示色谱柱的Inventory#（目录号）和当前校准规格，包括：

  • 色谱柱最后一次校准的日期和时间，

  • 校准长度和直径值，据此，将标识规格调节到“真”值，6890 系列 GC 和化学工作站利用此真值进行计算，调节压力获得理想的流量（或调节流量获得理想的压力），以及

  • 化学工作站校准所依据的任何死时间测量。


已安装的色谱柱

Installed Column（已安装色谱柱）确定当前安装在该位置的色谱柱 Inventory#（目录号）及其校准规格，即 6890 系列 GC 在压力/流量计算中使用的值：

  • 校准 length（长度）和 diameter（直径）值反映调节标识规格，即考虑色谱柱长度的制造偏差或改变在内的“真”值。

  • 校准 film thickness（膜厚）总是与标识规格一致。

本对话框中其他项目：

Mode（模式）

Inlet（进样口）

Detector（检测器）

Outlet psi/kPa/bar（出口 psi/kPa/bar）

Flow（流量）

Manufacturer's Specifications/Column Dimensions（制造商规格/色谱柱尺寸）

Ramps（梯度）


仪器控制对话框 (6890 GC)

请注意如果指定软件未安装，一些 GC 对话框不可用。

Acquisition - Sample Information（采集 — 样品信息）

GC Column 1/2 Calibration（GC 色谱柱 1/2 校准）

GC Auxiliary（GC 辅助设备）

GC Columns（GC 色谱柱）

GC Detectors（GC 检测器）

GC Inlet（GC 进样口）

Cool On-Column Inlet（冷柱头进样口）

Purged Packed Inlet（吹扫填充进样口）

Split - Splitless Inlet（分流—不分流进样口）

Volatiles Interface（挥发物接口）

AC SIMDIS Inlet（AC SIMDIS 进样口）

Programmed Temperature Vaporization (PTV) Inlet（程序升温挥发进样口）

GC Injector（GC 注射器）

GC Install Column 1/2（GC 安装色谱柱 1/2）

GC Options（GC 选项）

GC Oven（GC 柱箱）

GC Real Time Plot（GC 实时绘图）

GC Runtime（GC 运行时间）

GC Signals（GC 信号）

GC Valves（GC 阀）

Edit GC Monitors（编辑 GC 监测器）

Inlet and Injection Parameters（进样口和进样参数）

MS SIM / Scan Parameters（MS SIM/扫描参数）

MS Timed Events Parameters（MS 时间事件参数）

Y Scale（Y 坐标）

Monitor Alarm（监测器报警）

Edit MS Monitors（编辑 MS 监测器）


仪器日志文件

仪器日志文件将 Instrument Control（仪器控制）视窗中生成的命令错误记录到文件 MSINSCTL.LOG 中。这些错误包括 GC、MS 采集或调谐引起的任何命令错误。CP 命令 LOGGING 控制日志文件输出，后者被设定为仅记录错误。当写宏的时候这是有用的调试工具。

可以查看、打印和清除 Diagnostics（诊断）视窗中的仪器日志 MSINSCTL.LOG：

请另见

Trace On/Off（跟踪开/关）

Logbook（日志簿）


仪器菜单 (6890)

仪器菜单 (6890 GC)

Inlet / Injection Types（进样口/进样类型） | 允许选择进样口和进样的类型向 MS 提供样品。
GC Edit Parameters（GC 编辑参数） | 显示 GC Instrument | Edit（仪器 | 编辑）面板，在该处可设定所有 GC 参数。
GC Plot（GC 绘图） | 在 Instrument Control（仪器控制）面板为 GC 信号设定实时显示窗口。
GC Monitors（GC 监测器） | 显示 Edit GC Monitors（编辑 GC 监测器）面板。
Acquire RTLock Calibration Data（获取保留时间锁定校准数据） | 开始搜集 RTL（保留时间锁定）校准文件。
Unlock Method（解除锁定方法） | 删除方法的 RTL 锁定标签。 这将允许您执行手动色谱柱流量调节。
Select MS Tune File（选择 MS 调谐文件） | 允许选择不同的 MS 调谐文件。
MS SIM / Scan（MS SIM/扫描） | 允许设定获取 SIM 或扫描模式中的 MS 数据。
Change Source Temp（改变离子源温度） | 显示 MS Zones（MS 区）对话框。
MS Monitors（MS 监测器） | 显示 Edit MS Monitors（编辑 MS 监测器）面板。
Edit MS Tune Parameters（编辑 MS 调谐参数） | 允许设定 MS 调谐参数。
Perform MS Autotune（执行 MS 自动调谐） | 允许选择和运行一个自动调谐。
EMF Utilities（EMF 应用程序） | 提供到早期维护预告（EMF）应用程序的访问，在该处可选择或重新设定不同的极限值和计数器。


仪器菜单 — RTL

下列两个保留时间锁定菜单项由 Instrument Control（仪器控制）中的 Instrument（仪器）菜单提供：

Acquire RTLock Calibration Data（获取保留时间锁定校准数据） | 开始搜集保留时间锁定（RTL）校准文件。
Unlock Method（解除锁定方法） | 从允许用户执行手动色谱柱流量调节的方法删除锁定标识。


仪器/采集

有关详细信息，请单击下列各项：

Select Injection Source...（选择进样方式...）

图标条


载气供给供应不足

查看载气供给压力。应在 40 和 60 psi 之间。必须高于 Electronic Pneumatic Control (EPC)（电子流量控制）部件要求的压力 10 - 15 psi。


色谱柱（载气）流量不足

载气（色谱柱）流量不足可导致峰拖尾和峰前伸。尝试提高流量。如果 MSD 配备有扩散泵，请勿超过 2.0 ml/min；或者如果 MSD 配备有涡流分子泵，请勿超过 4.0 ml/min。


MSD 预热和抽真空时间不足

干扰 m/z 502 相对丰度的污染物可能仍然存在于仪器中。请等候直到 MSD 加热区位于其标准设定值至少 2 小时，然后重新尝试自动调谐。


积分菜单 — EasyID

Integration Parameters（积分参数） | 显示 Integration Parameters（积分参数）对话框。
Save compound specific integration parameters（保存化合物指定积分参数） | 保存化合物积分参数。
Remove compound specific integration parameters（删除化合物指定积分参数） | 删除化合物积分参数文件名。
Integrate（积分） | 使用方法参数积分化合物。


积分 — 定义

积分是用于发现色谱图中的峰并确定其大小的工具。对于产生百分比报告、设定定量数据库、确定和定量目标化合物、产生谱库检索报告和对积分峰进行谱库检索，积分是必需的。化学工作站软件有三个积分选项： 用于化学工作站积分器的 Autointegrate（自动积分）或 Integrate（积分）以及用于 RTE 积分器的 Integrate（积分）。


积分事件命令

下列命令可供用于设定使用化学工作站积分器的积分事件。

AREAREJECT（面积截除） 数值，时间

AREASUM（面积求和） 1/0, 时间

BASELINE（基线） 当前/下一峰谷/后面，时间

BASELINE（基线） 所有峰谷/保持, 1/0, 时间

INITREJECT（初始截除） 数值

INITTHRESH（初始阈值） 数值

INITWIDTH（初始峰宽） 数值

INTEGRATOR（积分器） 1/0, 时间

NEGPEAKS（负峰） 1/0, 时间

PEAKWIDTH（峰宽） 数值，时间

SHOULDERS（肩峰） 1/0

SOLVENTS（溶剂） 1/0, 时间

TANSKIM（切线斜滑） 时间

THRESHOLD（阈值） 数值，时间

欲查看内存中当前积分事件列表，请进入 TABULATE EVENTS（制表事件）。


积分参数文件

如果一个文件未被指定：

  • 如果使用 RTE 积分器，则使用系统缺省 RTE 积分参数（不是“RTE Integration Parameters（RTE 积分参数）”对话框中指定的参数）积分色谱图。

  • 如果使用化学工作站积分器，色谱图被自动积分（使用 AUTOINT（自动积分）命令）。

欲指定一个积分参数文件，请输入一个 RTE 积分参数文件或化学工作站积分器事件文件名称（输入 ? 获取可用的事件文件（.E）列表）。


积分参数文件

如果一个文件未被指定：

如果使用 RTE 积分器，则使用保存在当前方法中的 RTE 积分参数（不是 RTE Integration Parameters（RTE 积分参数）对话框中指定的参数）积分色谱图。

如果使用化学工作站积分器，色谱图被自动积分。

欲指定一个积分参数文件：

请输入一个 RTE 积分参数文件或化学工作站积分器事件文件名称。该文件必须包括在当前方法中。

注意： 对于 GC 数据，使用由 Chromatogram / GC Signal Integration Parms（色谱图/GC 信号积分参数）指定的参数积分 GC 色谱图。对于 GC 数据，不支持单独的积分参数。因此，推荐使用化学工作站积分器的时间编程功能。


积分参数文件

创建积分参数文件并保存在 RTE Integrator Parameters（RTE 积分器参数）对话框中。当生成百分比、谱库检索或定量报告时，可指定一个特定的积分文件。在适当对话框的 Integration Parameter File（积分参数文件）文本框中输入文件名称：

  • Percent Report Options（百分比报告选项）

  • Library Search Report Options（谱库检索报告选项）

  • Edit Compounds（编辑化合物）

  • Quantitation Database Globals（全局定量数据库）（仅用于新化合物项目）


积分结果

此菜单项显示一张与当前数据文件关联的积分结果表。其中的信息可以从显示处被打印或复制到剪贴板。对于每个峰，列出下列信息：

Peak#（峰号）

积分发现峰的编号。

Ret Time（保留时间）

峰的保留时间（分钟）。

Type（类型）

对于 RTE 积分器，一个代码确定基线是如何构造的。第一个字母（r）表示使用 RTE 积分器。下两个字符（B= 色谱基线；V= 峰谷画线）描述峰起始和结束处的基线。m 显示峰是手动积分的。

如果一个数字出现在起始三个字符后面，则表示峰纯度算法在峰中检测到不止一个化合物。显示的数字（2、3 等等）对应检测到化合物的数目。

对于化学工作站积分器，一个四个字符的代码描述积分峰。

Area（面积）

每个峰的面积。

Start Time（起始时间）

峰开始的时间（分钟）。

End Time（结束时间）

峰结束的时间（分钟）。


进样口间歇泄漏

检查进样口寻找泄漏。

有关更多信息，请参见 GC 附带的文件。


内标校准 — 定义

内标是在样品制备后进行分析之前加入到每个标样、空白、基质添加、基质添加复制和未知样品中的化合物。内标以一个准确的已知浓度加入。这对于目标化合物相对响应因子的计算是必需的。

内标无论化学成分还是保留时间都应与目标化合物相似。但是它必须可通过保留时间或离子分辨出来。


目录号

所分配的唯一确定色谱柱的号码。


离子图

单击放大的 Total Ion（总离子）或 Extracted Ion（提取离子）窗口上的坐标轴按扭，会显示一个对话框，可以输入最小值（极限值 ＝ 0）或最大值（极限值 ＝ 2E9）。或者，您也可单击临近的箭头按钮将最小值（或最大值）乘（或除）以 2 的幂。

时间事件，如校准阀开，在实时 MS 图上被标记出来。这些事件在 MS Timed Events Parameters（MS 时间事件参数）对话框中设定。


离子源温度过低

升高离子源温度，看是否拖尾减少。如果是，则继续调节温度直至发现最佳设定为止。


离子源温度过高

降低离子源温度，看是否 m/z 502 的相对丰度有所改善。


离子聚焦（参数）

IonFocus（离子聚焦）设定离子聚焦透镜（离子源的部分）的电压。离子聚焦影响离子丰度。通常，在调谐中梯度调节补偿以发现导致最佳离子丰度的离子聚焦补偿。

MSD | MIN | MAX | STEPSIZE（步长）
5972 / 6890 | 0 | 127.5 | 0.5
5973 | 0 | 242.0 | 0.95


ISTD — 定义

ISTD 内标 — 是进行分析之前加入到每个标样、空白、基质添加、基质添加复制和未知样品中的化合物。内标以一个准确的已知浓度加入。这对于目标化合物相对响应因子的计算是必需的。

内标无论化学成分还是保留时间都应与目标化合物相似。但是它必须可通过保留时间或离子分辨出来。

它是在定量分析中所使用的校准方法之一。


ISTD 浓度

为数据库中所含的内标输入缺省浓度。此即已知存在于一个样品中的内标的浓度。


JCAMP — 定义

JCAMP 是由原子和分子物理数据交换联合委员会（JCAMP-DX）开发用于谱图信息的一种 ASCII 文件格式。


实验室温度过高（通常在 35°C 以上）

查看实验室温度。如果温度过高，风扇可能不足以冷却扩散泵。


大峰如溶剂峰洗脱时分析器开启

确信溶剂延迟足够长以使分析器在溶剂峰洗脱前不开启。


实验室温度大的变化

MSD 温度变化可导致质量指认有小的位移。实验室温度变化大，有时足以改变 MSD 温度并影响质量指认。


大体积进样

大部分挥发进样口设计样品范围为 1 到 5 uL。对更大的进样，当样品挥发时生成的蒸气云可使进样口过载而色谱分离不好。对于 PTV，标识衬管容量为：

衬管

标识容量

惰性

?
开启挡板

5 uL

?
高

玻璃毛填充

25 uL

较低，因为表面积更大

在溶剂放空模式，分析物被热捕集在衬管中而溶剂被排出。随着溶剂排出，衬管体积可用于另一次进样。进样可重复几次以浓缩大样品体积的分析物。在进样和溶剂排出后，分析物被转移到色谱柱。这可以代替离线再浓缩的要求并使样品损失达到最小。

PTV 使用多次进样以获得大体积进样。化学工作站系统控制该过程。


泄漏的载气管线

载气管线的某处主要泄漏可导致报警。可能的位置包括：

  • 载气供给和 GC 之间的管路。

  • GC 内部的载气管接头

  • 进样口

  • 断色谱柱

从视觉和物理检测所有接头。确信它们未泄漏。检查进样口寻找泄漏。确信色谱柱未断。有关更多信息，请参见 GC 附带的用户信息。


泄漏的进样口

隔垫、进样口密封垫和色谱柱螺帽中的泄漏会使样品逃逸。加固接头或更换必要的进样口部件。


进样口中的泄漏

隔垫、进样口密封垫和色谱柱螺帽中的泄漏会使样品逃逸。加固接头或更换必要的进样口部件。

有关进样口维护的说明，请参见 GC 附带的文件。


长度

色谱柱的长度（单位为米）。化学工作站将标识 Length（长度）和方法一起保存。


扩散泵油位过高

如果扩散泵油位过高，会减慢抽真空过程或阻碍扩散泵达到其标准的操作温度。检查扩散泵油位。

有关检查扩散泵油位的说明，请参见 MSD 硬件手册。


谱库

输入将要检索的谱库的完整路径名称。例如，欲检索 C:\DATABASE 目录中的 DEMO.L，请输入：C:\DATABASE\DEMO.L


谱库菜单（参数检索）

谱库菜单

Library（谱库）菜单包括用于编辑定制谱库的两个选项。

Select Library （选择谱库） | 将您引到 Library Search Parameters（谱库检索参数）框，在该处可选择进行 PBM 检索时使用的谱库。
Edit Strategy （编辑策略） | 将您引到 Search Strategy（检索策略）框，在该处可更改 PBM 检索的检索参数。
Edit Library （编辑谱库） | 显示 Edit PBM Library（编辑 PBM 谱库）框，在该处可手动编辑谱库项。
Library Search Report （谱库检索报告） | 显示 Library Search Report Options（谱库检索报告选项）框，为 TIC 中的积分峰创建谱库检索结果报告。
Read JCAMP File （读取 JCAMP 文件） | 从 JCAMP 格式转换谱库。
Write JCAMP File （写 JCAMP 文件） | 以 JCAMP 格式写已存在的谱库。
Subset Library （子集谱库） | 创建一个谱库的子集（子集谱库）。
Add Current Entry （添加当前项目） | 提示您选择一个谱图作为项目添加到当前编辑谱库中。

另见

关于参数检索中的谱库选择


谱库检索命令

这些命令可供与谱库检索软件一起或在 Parametric Retrieval（参数检索）窗口中使用。可选参数显示在方括号中 [ ]。有关特定命令的更多信息，请单击命令名称。

另见 输入命令。

EDITHEADER [x] [,操作] [,项目号]

EDITSTRATEGY [u+a] [,标识阈] [,覆盖] [,纯度] [,交叉相关] [,复制] [,低过滤器] [,高过滤器] [,最大匹配]

FINDBYCAS cas 号 [,"谱库"]

GETMSREF 项目号 [,"谱库文件名"] [,变量] [,CONDMS / FULLMS]

LIBRESULTS [目标]

MW“分子式”

PBMSEARCH ["谱库文件名"] ,变量

PRCLOSERESULTS

PRGETRETRESULTS 项目号，谱库名称

PRPARAMS

PRRESULTS

PRRETRIEVE [继续]

PRSAVEPARAMS

PRSETPARAMS 变量改变, on 或 off, RANGE / SCALAR / STRING

PRSETWINPOSITION x-位置, y 位置

QUALPARMS ["谱库 1", "谱库 2", "谱库 3"] [,阈值 1, 阈值 2] [,选择方法] [,本底时间] [,积分类型] [,"文件名"]

QUALRPTOPT [verbosity, to screen, to printer, to file, "文件名", 在运行方法中]

SAVESTRATEGY "文件名.mac"

VIEWPBMTEXT 变量，命中数


电源电压过低

确信电源电压在真空规控制器可接受的范围以内。

警告！只允许专业电工检查线电压。


列出文件信息

选择 File / List File Info（文件/列出文件信息）显示来自数据文件文件表头以及使用数据文件时操作执行历史的信息。下面列出的信息是采集数据时包括的数据文件。

File（文件）

包括路径的数据文件名。

Operator（操作员）

输入到 Acquire Data（采集数据）或 Start Run（启动运行）对话框中的操作员信息。

Date Acquired（采集的数据）

运行启动的日期和时间。

Method File Name（方法文件名称）

用于采集数据的方法文件的名称。

Sample Name（样品名称）

这是输入到 Acquire Data（采集数据）、Start Run（启动运行）或 Sample Log Table（样品日志表）对话框中的样品名称信息。

Misc Info（其他信息)

这是输入到 Acquire Data（采集数据）、Start Run（启动运行）或 Sample Log Table（样品日志表）对话框中的其他信息。

Vial Number（样品瓶号）

输入到 Start Run（启动运行）或 Sample Log Table（样品日志表）对话框中的样品瓶号。当运行从 Acquire Data（采集数据）对话框启动时，号码总是 1。

Files in Data Directory（数据目录中的文件）

数据文件目录中通用文件的时间标志和大小被列出。如果 Quantitation Results（定量结果）（Quant.res）”文件的时间标志在一个生成报告之后，则该报告文件将用一个“*”标记以显示其不包括大部分当前结果。包括在已存在的列表中的文件有：

<MethodName>.RES 定量结果

DETAIL.XLS 定制报告

File History（文件历史）

数据文件目录中的文件 AUDIT.TXT 包含对该数据文件执行的操作的历史。被记录的操作包括： Quantitation（定量）、Manual Integrations（手动积分）和错误因素的删除。

系统宏总是维护一个对方法或数据文件结果进行更改的记录。这些更改被记录在 AUDIT.TXT 中，位于方法（*.M）或数据文件结果（*.D）目录之下并可通过选择 Calibrate / List（校准/列表）/Calibration History（校准历史）或 File（文件）/ List Header（列出文件头）查看。当选择 Audit Trail（审核跟踪）时，宏将提示您输入您的用户 ID 并将此信息作为更改的一部分记录下来。


加载数据文件

Load Data File（加载数据文件）可加载用户指定的数据文件并显示该文件的总离子流色谱（TIC）。选择 File / Load Data File（文件/加载数据文件）然后从左边的文件列表选择想要的数据文件。

Sort By（分类依据）选项允许根据不同标准（File Name（文件名）、Sample Name（样品名）、Misc Info（其他信息）、Data Acquired（采集的数据）和 File Name Only（仅使用文件名））重排文件列表。Sort By（分类依据）选项也将确定当选择 Next Data File（下一个数据文件）选项时，使用哪一个数据文件。


查找化合物 — GC/MS

欲确定是否一个特定的目标化合物（来自当前定量数据库）存在于当前数据文件中，请选择 Tools / Locate a Compound（工具/查找一个化合物）。结果显示在屏幕上。

欲确定是否当前定量数据库中所有的目标化合物存在于当前数据文件中，请选择 Tools / Locate All Compound（工具/查找所有化合物）。其结果在 MultiVu 中制成表格，为每个化合物列出下列各项：

  • Peak #（峰号）

  • Compound name（化合物名称）

  • Quantitation ion（定量离子）

  • Expected retention time（期望保留时间）

  • Actual retention time（实际保留时间）

  • Difference between actual and expected retention times（实际保留时间和期望保留时间之间的差别）


锁定键盘

化学工作站提供在 6890 系列 GC 仪器活动期间从 GC 键盘锁定设定项目的选项。

欲锁定项目，请选择 Yes（是）选项按钮。

本对话框中其他项目:

Pressure Units（压力单位）

Column Compensation Detector（色谱柱补偿检测器）


色谱柱连接松动

确信色谱柱两端的连接牢固。GC 柱箱的加热和冷却可导致色谱柱螺帽松动。

警告！GC 柱箱和色谱柱螺帽通常很热。在进行处理前请确信它们已经冷却。


分析器中的连接松动

  1. 放空 MSD。

  2. 打开真空多路连接管。

  3. 检查内分析器接线连接。排除任何松动连接。

  4. 关闭真空多路连接管。

  5. 确信所有到侧板的电缆都安全地固定住。

有关打开真空多路连接管的说明，请参见 MSD 硬件手册。


低停留时间（SIM 模式）

如果您在 SIM 模式下采集数据并遇到同位素丢失或不正确同位素比，请尝试增加停留时间。


宏（定义）

宏是集合在一起成为一组并命名的一系列命令。使用宏时只需键入其名称即可按顺序执行宏中的命令。

有关更多的详细信息，请参见在线帮助中的“Using and Writing Macros（使用和编写宏）”部分。


尾吹气流

尾吹气进入靠近色谱柱末端的检测器。它的用途是提供自由电子和加速峰通过检测器的速度 [image] ，尤其是对于毛细管柱 [image] 。这样，色谱柱达到的色谱峰分离度就不会因在检测器中重新混合而降低。

要激活尾吹气流，在复选框 On 中加上 X 并选择要使用的气体：

有效项目：N2（氮气），Ar/Me（氩气/甲烷）

有效范围：0 至 200 mL/min

推荐最大值： 150 mL/min

如果进样口已配置到检测器并且使用的色谱柱已被定义，可以两种尾吹气模式：

  • “Makeup Flow（尾吹气流）”模式提供恒定流量的尾吹气流向检测器。

    要选择这种模式，激活它并指定一个恒定值。

  • Const Col + Makeup, mL/min 模式提供恒流量可变的尾吹气流向检测器。色谱柱流量增加或减少时，尾吹气流量随之改变以提供恒定的混合气流向检测器。

    要选择这种模式，同时激活 Makeup Flow（尾吹气流）和 Const Col + Makeup，mL/min。指定一个恒定混合气流量值。

对于两种模式的最大值：200 mL/min

推荐两种模式的最大值：150 mL/min


尾吹气流

尾吹气进入靠近色谱柱末端的检测器。它的用途是加速色谱峰通过检测器的速度 [image] ，尤其是对于毛细管柱 [image] 。这样，色谱柱达到的峰分离度就不会因在检测器中重新混合而降低。

要激活尾吹气流，在复选框 On 中加上 X 并选择要使用的气体：

有效项目：N2（氮气），He（氦气）

N2 有效范围： 0 至 130 mL/min

H2 有效范围： 0 至 160 mL/min

如果色谱柱已被定义，可以选择两种尾吹气模式：

  • “Makeup Flow（尾吹气流）”模式提供恒定流量的尾吹气流向检测器。

    要选择这种模式，激活它并指定一个恒定值。

  • Const Col + Makeup, mL/min 模式提供流量可变的尾吹气流向检测器。色谱柱流量增加或减少时，尾吹气流量随之改变以提供恒定的混合气流向检测器。

    要选择这种模式，同时激活 Makeup Flow（尾吹气流）和 Const Col + Makeup，mL/min。指定一个恒定混合气流量值。

对于两种模式的最大值：参考上面的有效项目


尾吹气流

尾吹气进入靠近色谱柱末端的检测器。它的用途是加速峰通过检测器的速度 [image] ，尤其是对于毛细管柱 [image] 。这样，色谱柱达到的色谱峰分离度就不会因在检测器中重新混合而降低。

要激活尾吹气流，在复选框 On 中加上 X 并选择要使用的气体：

有效项目：N2（氮气），H2（氢气），He（氦气），ArCH4（氩气/甲烷 5%）

如果有一个非 EPC 检测器，必须手动在气路载体的压力调节器中测量并调整尾吹气。

有效范围：0 至 200 mL/min

如果有一个非 EPC 进样口或者一个未被定义色谱柱的 EPC 进样口，指定一个恒定 Makeup Flow（尾吹气）的设定值。

有效范围：0 至 100 mL/min

如果安装的 EPC 进样口已配置到检测器且正在使用的色谱柱已被定义,则有两种尾吹气模式的选择：

  • “Makeup Flow（尾吹气流）”模式提供恒定流量的尾吹气流向检测器。

    要选择这种模式，激活它并指定一个恒定值。

  • Const Col + Makeup, mL/min 模式提供流量可变的尾吹气流向检测器。色谱柱流量增加或减少时，尾吹气流量随之改变以提供恒定的混合气流向检测器。

    要选择这种模式，同时激活 Makeup Flow（尾吹气流）和 Const Col + Makeup，mL/min 。指定一个恒定混合气流量值。

对于两种模式的最大值： 100 mL/min


尾吹气流

尾吹气进入靠近色谱柱末端的检测器。它的用途是加速峰通过检测器的速度 [image] ，尤其是对于毛细管柱 [image] 。这样，色谱柱达到的色谱峰分离度就不会因在检测器中重新混合而降低。

要激活尾吹气流，在复选框 On 中加上 X 并选择要使用的气体：

有效项目：N2（氮气），ArCH4（氩气/甲烷 5%）

如果有一个非 EPC 检测器，必须手动在气路载体的压力调节器中测量并调整尾吹气。

有效范围：0 至 230 mL/min

如果有一个非 EPC 进样口或者一个未被定义色谱柱的 EPC 进样口，指定一个恒定Makeup Flow（尾吹气）的设定值。

有效范围：0 至 230 mL/min

如果安装的 EPC 进样口已配置到检测器且正在使用的色谱柱已被定义,则有两种尾吹气模式的选择：

  • Makeup Flow（尾吹气流）模式提供恒定流量的尾吹气流向检测器。

    要选择这种模式，激活它并指定一个恒定值。

  • Const Col + Makeup, mL/min 模式提供流量可变的尾吹气流向检测器。色谱柱流量增加或减少时，尾吹气流量随之改变以提供恒定的混合气流向检测器。

    要选择这种模式，同时激活 Makeup Flow（尾吹气流）和 Const Col + Makeup，mL/min。指定一个恒定混合气流量值。

对于两种模式的有效范围：0 至 230 mL/min


尾吹气流

尾吹气进入靠近色谱柱末端的检测器。它的用途是加速峰通过检测器的速度 [image] ，尤其是对于毛细管柱 [image] 。这样，色谱柱达到的色谱峰分离度就不会因在检测器中重新混合而降低。

要激活尾吹气流，在复选框 On 中加上 X 并选择要使用的气体：

有效项目：N2（氮气），H2（氢气），He（氦气），ArCH4（氩气/甲烷 5%）

如果有一个非 EPC 检测器，必须手动在气路载体的压力调节器中测量并调整尾吹气。

有效范围：0 至 12 mL/min

如果有一个非 EPC 进样口或者一个未定义色谱柱的 EPC 进样口，指定一个恒定Makeup Flow（尾吹气）的设定值。

有效范围：0 至 12 mL/min

如果安装的 EPC 进样口已配置到检测器且正在使用的色谱柱已被定义,则有两种尾吹气模式的选择：

  • Makeup Flow（尾吹气流）模式提供恒定流量的尾吹气流向检测器。

    要选择这种模式，激活它并指定一个恒定值。

  • Const Col + Makeup, mL/min 模式提供流量可变的尾吹气流向检测器。色谱柱流量增加或减少时，尾吹气流量随之改变以提供恒定的混合气流向检测器。

    要选择这种模式，同时激活 Makeup Flow（尾吹气流）和 Const Col + Makeup，mL/min。指定一个恒定混合气流量值。

对于两种模式的有效范围：0 至 12 mL/min


尾吹气流

尾吹气进入靠近色谱柱末端的检测器。它的用途是加速峰通过检测器的速度 [image] ，尤其是对于毛细管柱 [image] 。这样，色谱柱达到的色谱峰分离度就不会因在检测器中重新混合而降低。

要激活尾吹气流，在复选框 On 中加上 X 并选择要使用的气体：

有效项目：N2（氮气），H2（氢气），He（氦气），ArCH4（氩气/甲烷 5%）

如果有一个非 EPC 检测器，必须手动在气路载体的压力调节器中测量并调整尾吹气。

有效范围：0 至 160 mL/min

如果有一个非 EPC 进样口或者一个未定义色谱柱的 EPC 进样口，指定一个恒定Makeup Flow（尾吹气）的设定值。

有效范围：0 至 160 mL/min

如果安装的 EPC 进样口已配置到检测器且正在使用的色谱柱已被定义,则有两种尾吹气模式可选择：

  • Makeup Flow（尾吹气流）模式提供恒定流量的尾吹气流向检测器。

    要选择这种模式，激活它并指定一个恒定值。

  • Const Col + Makeup, mL/min 模式提供流量可变的尾吹气流向检测器。色谱柱流量增加或减少时，尾吹气流量随之改变以提供恒定的混合气流向检测器。

    要选择这种模式，同时激活 Makeup Flow（尾吹气流）和 Const Col + Makeup，mL/min。指定一个恒定混合气流量值。

对于两种模式的有效范围：0 至 160 mL/min


流量故障或压力调节器

如果载气供给的压力不正确，那么 EPC 可能工作异常。请与安捷伦科技公司维修代表处联系。


手动

手动进样。

选择Front（前）、Back（后）或Both（两者同时）来指定要用来进样的位置。

当准备好开始分析时，注射样品并按色谱仪前面板的 Start（开始）按钮。化学工作站会忽略色谱仪和任何其他分析装置的就绪状态。


手动校准

通常经过分析一个校准标准混合物、创建一个校准表和输入用于获取响应因子的所有校准过的峰的含量后，就产生了一个新的校准后的方法。然而，这种方法在石油化工中是无效的，因为相同的化合物已经被分析了多年而且对于不同的化合物和检测器都可以迅速获得响应因子。

在使用 New Calibration Table（新校准表）对话框中的 Manual Setup（手动设置）功能按钮进行的校准的基础上可以标准化整个校准表。Manual Calibration（手动校准）允许用户输入已发表的方法中的校准表。这些方法发表时一般附带一个不同化合物的保留时间列表。通常对于不同化合物的响应因子也一并给出。通过在校准表中输入峰及其响应因子，并使用仅需包含一个（或几个）选定的响应参比峰做，以手动方式创建校准表，使用响应值的 Delta% 做更新的标准。


手动积分 - 仅对于 GC

这一菜单项允许对一个已手动积分的文件进行定量和产生定量报告。报告仅包括手动积分峰的数据。所有其他化合物将在报告中定为未检测 (ND) 和保留时间为 0。报告输出到指定目的地。报告内容由 Quantitation Report Options（定量报告选项）对话框决定。定量结果文件 (<method name>.res) 被储存在数据目录下。如果该文件已存在，原有文件将被覆盖。通过选择 View / QEdit Quant Result（视图/Q 编辑定量结果）可以修改该结果文件。


制造商

指定生产该类型色谱柱的制造商。

首次添加该制造商生产的某类型色谱柱时，输入他们的名称。把这个名称添加到目录的制造商列表中。

下一次添加该制造商生产的一种色谱柱时，从下拉列表框中选择他们的名称即可。


制造商规格/色谱柱尺寸

Manufacturer's Specifications/Column Dimensions（制造商规格/色谱柱尺寸）显示了色谱柱的色谱性能：

  • Model Number（型号） [image] ”指定色谱柱类型的编号。

  • Max Temperature（最高温度） [image] Maximum oven temperature（最高柱箱温度）(以 [image] C 为单位)，依据制造商对于色谱柱操作的建议。

  • Description（说明） [image] 色谱柱类型的简要说明。

  • Length（长度） [image] 色谱柱标识长度（以米为单位）。

  • Diameter（直径） [image] 色谱柱标识内径或“id”（以微米为单位）。

  • Film Thickness（膜厚） [image] 色谱柱内表面涂层的标识平均厚度（以微米为单位）。


制造商规格/色谱柱尺寸

Manufacturer's Specifications/Column Dimensions（制造商规格/色谱柱尺寸）显示了色谱柱的色谱性能，包括：

  • Model Number（型号） [image] 指定色谱柱类型的编号。

  • Max Temperature（最高温度） [image] Maximum oven temperature（最高柱箱温度）(以 [image] C 为单位)，依据制造商对于色谱柱操作的建议。

  • Description（说明） [image] 色谱柱类型的简要说明。

  • Length（长度） [image] 色谱柱标识长度（以米为单位）。

  • Diameter（直径） [image] 色谱柱标识内径或“id”（以微米为单位）。

  • Film Thickness（膜厚） [image] 色谱柱内表面涂层的标识平均厚度（以微米为单位）。

本对话框中其他项目：

Mode（模式）

Inlet（进样口）

Detector（检测器）

Outlet psi/kPa/bar（出口 psi/kPa/bar）

Flow（流量）

Installed Column（已安装的色谱柱）

Ramps（梯度）


质量过滤器工作异常

请与安捷伦科技公司维修代表处联系。


质量过滤器（四极杆）导线短接或工作异常

请与安捷伦科技公司维修代表处联系。


质量过滤器（四极杆）温度传感器开启

  1. 让 MSD 放空。

  2. 打开真空多路连接管。

注意

任何时候打开真空多路连接管时都要警惕静电释放（ESD），尤其是在质量过滤器（四极杆）接点附近工作时。这些导线可能带有对于侧板上的敏感部件有害的静电。

  3. 检查质量过滤器（四极杆）传感器接线。确认传感器接线连接到引线板上。

  4. 如果接线正确连接但传感器仍不工作，更换质量过滤器加热器组部件（加热器、传感器和加热块）。

有关放空 MSD、打开真空多路连接管和更换质量过滤器加热器组件的说明，请参见 MSD 硬件手册。


质量过滤器（四极杆）温度传感器短路

  1. 放空 MSD。

  2. 打开真空多路连接管。

注意

任何时候打开真空多路连接管时都要警惕静电释放（ESD），尤其是在质量过滤器（四极杆）接点附近工作时。这些接点可能带有对于侧板上的敏感部件有害的静电。

  3. 检查质量过滤器（四极杆）传感器接线。尝试检查传感器接线是否短接到地表。

  4. 如果接线看起来连接正确但传感器仍不工作，更换质量过滤器加热器组件（加热器、传感器和加热块）。

有关放空 MSD、打开真空多路连接管和更换质量过滤器加热器组件的说明，请参见 MSD 硬件手册。


质量增益（参数）

MassGain（质量增益）设定质量坐标轴增益的值，这是用在质量坐标轴校准方程中的乘法参数。

质量增益将给定质量的报告值调节到正确数值。报告中出现的质量使用了线性校正。这可以想象成一条以未校正质量为 x 轴，报告质量为 y 轴的校准曲线。这条校准曲线是一条斜率和质量增益成比例的直线。

质量增益在质量范围内的高质量比低质量对质量指认的影响更大。

MSD | 最小值 | 最大值 | 步长
5972 / 6890 | -4999 | +4999 | 1
5973 | -2048 | +2047 | 1


质谱谱库 - 定义

一个质谱谱库由几个由 extension.L 识别的一起存储在一个谱库目录中的文件构成。


质谱仪接口卡

要想知道系统质谱仪接口卡的版本，键入命令：

SCQUERY "*idn?"

就能得到答复如：

Agilent Technologies, 5972,0,2.xx.xx

给出接口卡软件版本。

命令：

SCQUERY 命令 [,cp 变量]

可以用来存储一个 CP 变量的响应。

例如：

SCQUERY "*idn?", a$

会包含上面显示的版本字符串。


质谱 — 定义

质谱描绘出一个化合物在选定保留时间内所有找到的离子的丰度和质量的图形。可以以棒图或表格形式显示。


质谱列表

列出光谱中每个质量峰的质量 (m/z) 和丰度。光谱被修改后（加、减、使用 * 或 TRANSFORM 命令进行相乘、使用 MSCLIP 进行剪贴或使用 MSTRUNC 进行缩短），显示中的第三行会指出这些修改：

修改：[加][减][改变比例][剪贴][缩短]

“Print（打印）”和“Copy（复制）”按钮让您打印数据和将其复制到剪贴板。如果仅想选择表中的一部分进行打印和复制，单击表格直至闪烁的横行标记出了需要的表的结束位置。


质量偏移（参数）

MassOffs（质量偏移）设定质量坐标轴偏移值，这是用在质量坐标轴校准方程中的可加参数。

MSD | 最小值 | 最大值 | 步长
5972 / 6890 | -99 | +99 | 1
5973 | -499 | +499 | 1


基质

Matrix（基质)是待分析样品中的主要材料。在环境样品中，基质通常是水或土壤。在药物样品中，基质通常是尿液或血液。


基质添加

Matrix spike（基质添加）是被添加了已知量指定目标化合物（基质添加化合物）的一等分样品。基质添加用在整个分析过程中，用以确定基质添加化合物的回收率。另见 Matrix spiking（基质添加）。


基质添加化合物

Matrix spike compound（基质添加化合物）是一个精确已知量的目标化合物，被添加到样品的一等分而不添加到另一等分以确定分析过程对于该目标化合物的准确度。另见 Matrix spiking（基质添加）。


基质添加复制样

Matrix spike duplicate（基质添加复制）是用在整个分析过程中第二个基质添加以确定基质添加化合物的回收率精确度。另见 Matrix spiking（基质添加）。


基质添加 — 定义

Matrix spiking（基质添加）是一种用来测量样品回收率的准确度和精密度的技术。一个未知样品被等分为两份或三份。第一部分不变。第二部分被基质添加添加化合物 - 一个已知浓度的目标化合物。分析样品的第一和第二分。

从未掺料的样品中回收的目标（基质添加）化合物浓度被从从掺料样品种回收的基质添加化合物浓度中扣除。结果同加入样品的第二分的基质添加化合物浓度进行比较。这两个数的比值表示了回收率百分比和目标（基质添加）化合物的样品回收率的准确度。

例如，如果从未掺料的样品中回收5 ng/ml，从掺料的样品中回收50 ng/ml，基质添加的回收量是 45 ng/ml。如果实际基质添加是 50 ng/ml，则回收率百分比是 45/50 = 90%。

有时，样品的与第二分完全相同的第三部分被掺料并分析。这称作基质添加复制。计算出基质添加复制的回收率百分比。基质添加和基质添加复制的回收率百分比用来计算百分比相对偏差 (RPD%)。这可以指示分析对于目标（基质添加）化合物的精确度（重复性）。


最高温度

最高柱箱温度(以 [image] C 为单位)，依据制造商对于色谱柱操作的建议。


最高 oC

最高 C

最高允许柱箱温度设定值。一些附件，如阀箱、阀和色谱柱有指定温度限制。配置 Maximum（最高） [image] C 时,考虑这些限制以避免损坏附件。化学工作站在您输入柱箱设定值会检验他们；如果输入了与之前定义的不一致的设定值则会出现一条提示。

柱箱温度不会超过 Maximum（最高） [image] C值。

注意： 设定 Maximum（最高） [image] C会使所有柱箱梯度升温程序中超过新的 Maximum（最高） [image] C值的值无效，并会与已安装色谱柱的定义相互影响。在下载新设定值到仪器前进行校正是必要的。


最大灵敏度自动调谐 (5971/5972/6890)

最大灵敏度自动调谐

Maximum Sensitivity Autotune（最大灵敏度自动调谐）在质量范围内使用 PFTBA 质量 69、219 和 502 来使仪器的灵敏度达到最大。对于要求最大灵敏度而不要求 100% m/z 69、35 - 85% m/z 219 和 1 - 5% m/z 502 的传统丰度比的应用请使用这种调谐。这种调谐对于 DFTPP 或 BFB 的手动调谐也是一个好的起始点。

在 5972 / 6890 上有效。


测量（全局定量数据库）

测量

选择计算是基于峰面积还是峰高。


方法 — 定义

方法是一个包含要进行一次分析所需要的所有说明和参数的文件。方法文件可以通过它们的名称中的扩展名 .m 来进行识别。它们一起存储在一个方法目录中。内存中总有一个方法，因为一个方法总是作为系统启动程序的一部分被加载。


方法信息对话框

Method Information（方法信息）对话框有三个部分：

Method Comments（方法注释）

可选项。输入最多 99 行 关于方法的信息。该信息同方法一起保存并在打印方法时一起打印。

Save Copy of Method with Data（同数据一起保存方法复制件）

可选项。当前方法的完全复制件作为数据文件的一部分被保存。推荐将这一步骤作为好的实验习惯。但是如果硬盘空间非常珍贵的话，使用这一功能可能不太实际。

Method Sections to Run（方法运行部分）

分析进行时检查方法要运行的部分。此信息同方法一起保存，且不论何时方法在序列中使用时都将被使用。使用 Method / Run（方法 / 运行）初始化一个单一分析时，就显示这一信息。可以在此处进行改变，但只有方法再次保存后改变的内容才能成为方法的一部分。


微池电子捕获检测器

微池电子捕获检测器比“普通” ECD 具有更小的内部体积（约为 1/10）。微型 ECD 可以通过带孔顶罩进行区分。微型 ECD 包含一个镀 63Ni（一种放射性同位素）的池体。63Ni 释放 [image] 粒子同载气和尾吹气分子碰撞，产生低能电子。 每个 [image] 粒子产生许多这样的电子。自由电子产生一个在脉冲电路中采集和测量的小电流 [image] 称作参比电流 [image] 。

当样品组分分子同自由电子接触，样品分子就可以捕获这些电子而产生负离子。电池电极间的电压是脉冲电压以收集剩余自由电子，而重离子相对没有受影响并由载气流吹出排气口。

检测器电路测量池体电流并把它同参比电流进行比较。然后调节脉冲速度以保持恒定电池电流。自由电子越多，需要的用来匹配参比电流的脉冲频率越低。捕获了电子的组分通过电池时，脉冲速度升高。这一脉冲速度被转换为电压并记录。

使用微型 ECD 对话框来设定检测器参数和指定设定值。有关详细信息，请单击这些参数：

选择温度和流量时请使用下表中的信息。

操作参数

气体类型 | 推荐流量范围
载气 填充柱 （氮气或氩气－甲烷） 毛细管柱 （氢气、氮气 或氩气－甲烷） | 30 至 60 mL/min 0.1 至 20 mL/min， 取决于直径
毛细管尾吹气 （氮气或氩气－甲烷） | 10-150 ml/min （通常为 30-60 ml/min）

温度

250 [image] C 至 400 [image] C
检测器温度通常设定为比最高柱箱梯度温度高 25 [image] C。

微型 ECD 的响应取决于许多因素。包括被分析物的分子组成及其浓度、微型 ECD、电池清洁度、色谱柱、进样口和仪器设定值（温度、流动速率和参比电流）。

因此，创建所有化合物的校准曲线和在一个固定基础上评估检测器的响应就很重要了。即使进行了频率校准，当操作条件变化时也可能看到检测器的响应发生变化。 例如，在污染检测器的脏样品的时候。

微型 ECD 对于不同类型化合物的一般灵敏度

化合物类型 | 相对灵敏度
烃类 |
醚，酯 | 10
脂肪醇，酮，胺； 单取代氯化物和单取代氟化物 | 102
单取代溴化物，二氯化物和二氟化物 | 103
酸酐和三氯化物 | 104
单取代碘化物，二溴化物和硝基化合物 | 105
二碘化物，多取代氯化物和多取代氟化物 | 106

微型 ECD 对于数据分析的信号转换：

  1. Hz = 1 峰高单位

  2. Hz x 1 秒 = 1 峰面积单位

微型 ECD 的最高有效数据采样频率是 50 Hz。将数据采样频率设定为大于 50 Hz 会增加基线噪音但不会提高检测器性能。


最小峰宽

根据期望峰宽的采样频率（以分钟单位）。Peak Width（峰宽）在峰检测中控制检测器的灵敏度（检测窄峰的能力）。

Minimum Peak Width（最小峰宽）越小，灵敏度越高。指定的Minimum Peak Width（最小峰宽）必须足够大以摒弃基线噪音，但又要足够小以能检测出感兴趣的最小峰。

注意：Minimum Peak Width（最小峰宽）越小，分析数据所需要的存储空间越大。

GC 可以在 11 种不同 Data Rate（数据采样频率）下处理数据。每一个 Data Rate（数据采样频率）与一个 Minimum Peak Width（最小峰宽）相关。下面的列表列出了可能的 Data Rate（数据采样频率）及其 Minimum Peak Width（最小峰宽）。相对噪音、检测器适应性和建议色谱柱类型也一并列出。

化学工作站信号处理

数据采样频率 (Hz)

最小
峰宽
(minutes)

相对噪音

检测器

色谱柱类型

200.00

0.001

3.1

仅对于 FID

细口 (50 [image] m) 毛细管柱

100.00

0.002

2.2

.

.

50.00

0.004

1.6

.

.

20.00

0.01

1.0

所有类型

.

10.00

0.02

0.7

.

.

5.00

0.04

0.5

.

.

2.00

0.1

0.3

.

.

1.00

0.2

0.22

.

.

0.50

0.4

0.16

.

.

0.20

1.0

0.10

.

.

0.10

2.0

0.07

.

慢填充柱

设定一个 Peak Width（峰宽）自动确定一个 Data Rate（数据采样频率）。（Minimum Peak Width（最小峰宽）越大，Data Rate（数据采样频率）将越小。）

在运行中不能改变 Minimum Peak Width（最小峰宽）。

如果已选择了 Det (detector) Source（检测器源），有关峰宽的进一步信息，请参见 Calc Button（计算按钮）。

本对话框内容：

Source（源）

Data Rate（数据采样频率）

Calc Button（计算按钮）

Save Data（保存数据）


ml/min

对于给定程序标准流量改变到的流量值（以 ml/min 为单位）。


ml/min2

流量从一个程序流量的 ml/min 改变到下一个程序流量的 ml/min 的速率（以 ml/min2 为单位）。也称作“流量梯度”。

任何程序流量下速率为零都会使该流量及其以下的梯度流量程序无效。


模式

冷柱头进样口的操作模式有两种，梯度和跟踪。对两种模式说明如下：

梯度温度

在这种模式中，可以对进样口设定最多三个温度梯度，可以工作在独立于柱箱的温度下。

如果在 -20 [image] C 以下操作,Ramped Temp（梯度温度）是推荐的操作模式。

在这种非常低的柱箱温度下，进样口温度应该至少比柱箱温度高出 20 [image] C。这对于溶剂聚焦足够充分。

在大于环境温度的温度下，进样口应该比柱箱至少高 3 [image] C 以便正确控制进样口温度。

如果进样口是梯度升温程序：

  • （程序时间）比柱箱的长，它将在柱箱的程序结束时中止。

  • （程序时间）比柱箱的短，进样口将保持最终的程序温度直至运行结束。

有关进一步信息，请参见 Ramps（梯度）。

跟踪柱箱

在这种模式下，进样口温度在整个柱箱程序中保持比柱箱温度高 3 [image] C。

如果有低温冷却，进样口将跟踪柱箱温度到 -40 [image] C。没有低温冷却的话，室温为最低限。

Cryogenic considerations（对低温的考虑） [image] 当在低温柱箱中使用柱箱跟踪模式时，所有其他进样口必须关闭或处于柱箱跟踪模式。

可以将带 CO2 冷却阀的柱箱程序设定到 -60 [image] C，带 N2 冷却阀的柱箱设定到 -80 [image] C。

本对话框中其他项目：

Heater（加热器）

Gas（气体）

Ramps（梯度）

Pressure（压力）


模式

对于程序温度蒸发 (PTV) 进样口有五种操作模式。有关详细信息，请单击下拉对话框中的任何一种模式：

本对话框中其他项目：

Gas（气体）

Cryo Config（低温配置）

Heater（加热器）

Ramps（梯度）

Pressure（压力）

Total Flow（总流量）

GasSaver（载气节省）（如果色谱柱已被定义）


模式

对于分流-不分流进样口有四种操作模式。（脉冲模式仅与 EPC 一起时有效。） 有关详细信息，请单击绿色区域的任何一种模式：

本对话框中其他项目：

Gas（气体）

Heater（加热器）

Pressure（压力）

Total Flow（总流量）

GasSaver（载气节省）（如果色谱柱已被定义）


模式

选择下列色谱柱模式的一种：

Constant Pressure Mode（恒定压力模式）在整个运行中保持了色谱柱头处的恒定表压。如果色谱柱阻力改变，表压不变但质量流量会改变。

Constant Flow Mode（恒定流量模式）在整个运行中保持了色谱柱中载气的恒定质量流量。如果色谱柱阻力因温度程序而改变，化学工作站会调整色谱柱头压力以保持流量恒定。这样可以显著缩短运行时间。

Ramped Pressure Mode（梯度压力模式）根据输入的程序来在运行中增加色谱柱头表压。一个色谱柱压力曲线可以有最多三个梯度，每个梯度后面增加一个保持期。（请参见 Ramps（梯度）。）

Ramped Flow Mode（梯度流量模式）根据输入的程序来在运行中增加质量流量。一个色谱柱流量曲线可以有最多三个梯度，每个梯度后面增加一个保持期。（请参见 Ramps（梯度）。）

本对话框中其他项目：

Inlet（进样口）

Detector（检测器）

Outlet（出口）psi/kPa/bar

Flow（流量）

Installed Column（已安装的色谱柱）

Manufacturer's Specifications/Column Dimensions（制造商规格/色谱柱尺寸）

Ramps（梯度）


型号

识别一种类型色谱柱的编号。化学工作站将 Model Number（型号）同方法一起保存。


更多按钮或扩展参数按钮

当同化学工作站一起使用 6890 GC 时，单击 More（更多）按钮来显示 Extended Parameters（扩展参数）对话框。


更多信息摘要

此表说明了定量数据库的第二页上的项目如何通过 CP 变量和 Custom Reports（自定义报告）软件的菜单来访问。要阅读此表，将帮助窗口扩展到全屏。

项目 | CP 变量 | (菜单/菜单项目)
CAS # | CASNO$ | More1/CAS#
Compound Type | CPNDTYPE$ | More1/CpndType
Surrogate Amount） | SURROGATE | More1/Surrogate
Matrix spike Amount | MATSPK | More1/MATSPK
Matrix A Low | MATALO | More2/Matrix A low
Matrix A High | MATAHI | More2/Matrix A high
Matrix A % Dev | MATARPD | More2/Matrix A %Dev
Matrix A MDL | MATAMDL | More2/Matrix A MDL
Matrix B Low | MATBLO | More2/Matrix B low
Matrix B High | MATBHI | More2/Matrix B high
Matrix B % Dev | MATBRPD | More2/Matrix B %Dev
Matrix B MDL | MATBMDL | More2/Matrix B MDL
Signal Minimum | SIGMIN | More1/SIGMIN
Signal Maximum | SIGMAX | More1/SIGMAX
MS Database Name | MSDBNAME$ | More1/DBNAME$
Entry # | ENTRYNO | More1/ENTRY#
A1 | A1$ | User/A1$
A2 | A2$ | User/A2$
A3 | A3$ | User/A3$
N4 | N4 | User/N4
N5 | N5 | User/N5
N6 | N6 | User/N6
N7 | N7 | User/N7
N8 | N8 | User/N8
N9 | N9 | User/N9


鼠标操作

数据分析中的鼠标操作

鼠标光标可以改变形状和功能，取决于使用的 Data Analysis（数据分析）模式和光标是位于色谱图还是光谱数据上。进行的操作取决于窗口中的数据类型，如下表所示。

有关进一步的鼠标操作，请参见峰纯度模式。

鼠标操作 | 色谱结果 | 光谱结果 | 其他结果
双击右键 | 获取光谱 | 进行谱库检索 | EasyID， QEdit 模式：在文本窗口 (7) 中显示下一个化合物。
单击右键并拖动 | 平均光谱 |  |
按住 Shift 键并双击右键 | EasyID 模式：设定提取窗口的结束位置 (E) |  |
单击左键并拖动 | 放大 | 放大 |
双击左键 | 缩小 EasyID，QEdit 模式：将视窗的两端各扩展 2 分钟 | 缩小 | EasyID，QEdit 模式：在文本窗口 (7) 中显示前一个化合物。
同时单击左右键 | 注释 | 注释 |
按住 Shift 键 并双击左键 | EasyID 模式：设定提取窗口的起始位置 (S) |  | 交互检索：打印整个 Data Analysis（数据分析）屏幕


鼠标操作

下面的鼠标操作在 EasyID 和 QEdit 窗口中可用：

色谱窗口 (#6)

双击鼠标左键在视图的两端各扩展 2 分钟。

双击鼠标右键来选择一个光谱。

光谱窗口 (#1)

双击鼠标右键来进行一次谱库搜索。

双击鼠标左键来放大。

文本窗口 (#7)

双击鼠标右键用 来转到下一个化合物。

双击鼠标左键用来转到上一个化合物。


峰纯度模式下的鼠标操作

要查看 | 使用此鼠标操作
下一个峰 | 双击右键
下一个不纯峰 | 按住 Shift 键同时双击鼠标右键
前一个峰 | 双击左键
前一个不纯峰 | 按住 Shift 键同时双击鼠标左键


结构软件中的鼠标/键盘操作

下面的鼠标和键盘操作用在参数检索或 PBM 搜索中的化学结构软件里。在 PBM 搜索中，鼠标操作是访问结构软件的唯一途径。

鼠标右键

放置于匹配光谱中。单击并拖动鼠标来显示光谱中的匹配结构（如果有效的话）。重复以改变大小或改变位置。

Shift ＋ 鼠标右键

放置于光谱中。单击并拖动鼠标来复制一个剪贴板图元文件到光谱中。重复以改变大小或改变位置。

Ctrl ＋ 鼠标右键

放置于光谱中。单击并拖动鼠标以选择一个文件用于显示。

鼠标左键

在匹配结构上双击来编辑结构的颜色、字体、旋转等，用以在在光谱中显示或添加结构到结构库。


MS 按钮
单击此按钮弹出一个菜单：
Edit MS SIM / Scan（编辑 MS SIM /扫描） | 显示一个可以设定质谱数据采集参数的面板。
Select MS Tune File（选择 MS 调谐文件） | 显示一个对话框，在其中可以选择另一个调谐文件来与当前方法一起使用。
Edit MS Monitors（编辑 MS 监测器） | 显示一个面板，在上面可以在 Instrument Control（仪器控制）视窗上建立窗口以检测选定的参数。


MS 数据库名称/登录条目 #

MS 数据库名称是包含当前化合物的一个参比光谱的质谱数据库的名称。登录条目 # 是该化合物的登录编号。通常这些地方不使用而第 1 页的 Ref Spec Name（参比光谱名称）用作参比光谱。


MS 诊断

Diagnostics（诊断）视窗中的 Diagnostics（诊断）菜单为 MS 提供了下面的排除故障的测试。这些测试多数是可重复的，且只有在遇到故障或从菜单选择 Stop（停止）或 Abort（异常中止）时会停止。(Abort（异常中止）引出一个必须点击的确认框；而 Stop（停止）不可以。） 进一步信息在 MSD 硬件手册中给出。

MS ON/OFF

打开或关闭 MSD。

设定 RFPA（射频功率放大器）

需要一个质量，设定 RFPA 电压并显示 RF 驱动水平。选择 Stop（停止）来停止这一过程。

设定参数

提示一个参数名称及其值。这些设定直接送到质谱接口卡而不会在 Edit Parameters（编辑参数）或变量中报告。

注意： 只能由工厂训练过的人员使用。

引起群体故障（非 5973 上）

触发共有的故障这样所有质谱电压都被关闭。

初始化 MS 接口

初始化 MS 接口卡。

空气和水份检查

产生一个系统空气（氮气 m/z 28）和水份 (m/z 18) 相对于 PFTBA 质量 69 的水平的标准化测量和报告。m/z 28 的丰度应该比 m/z 18 的小，两者都应该小于 m/z 69 的 5%。

Edit MS Params（编辑 MS 参数）

通电温度

显示一个让您在开启电源时改变所用离子源和四极杆温度的对话框。仅适用于 5973 MSD。

测量质量坐标轴校正因子

仅由安捷伦用户工程师使用。


MS 故障

有关 5973 MSD，请单击此处

所报告的 MS 故障是一个数值，它产生故障值的总和。可能的故障如下。

故障值 | 故障说明
1 | 总体故障发生。
2 | 信号水平超过警戒。
4 | 质量过滤器电路中的故障。
8 | 没有发射电流。
16 | 源电压超出警戒。
32 | 扩散泵过热。
64 | 前级压力超过 300 mTorr。
128 | 扩散泵过冷。
256 | 系统处于放空状态。
512 | 检测器 HV 电源的故障。
8192 | MS 内部通讯的故障。
16384 | 系统处在 STANDBY（备用）状态下（可能由 GC 或 LC 关闭由 APG 遥控电缆通向 MS 接口的连接）。如果 GC 检测器、温度、压力或流量设定值没有达到的话 6890 GC 可能关闭 MS。MS 保持在备用状态直到故障排除或 APG 电缆被断开连接为止。

另外的故障示例列表包含一些可能的原因。


MS 仪器参数

Sample Inlet（样品进样口）

在 Inlet and Injection Parameters（进样口和进样参数）对话框中设定。

Run Time（运行时间）

仅当 Other/None（其他/无）选作进样口时出现。

Tune File（调谐文件）

当前选定的调谐文件 (*.U)

EM Voltage（EM 电压）

Solvent Delay（溶剂延迟）

Acq.（采集） Mode（模式）

SIM 或 Scan（扫描）。此处做出的选择将决定 Real Time Plot（实时图形）和对话框中的 MS SIM 或 Scan Parameters（扫描参数）中的显示。


MS 故障/故障提示

有关5973 MSD 故障提示请单击此处。

如果在采集前或采集中质谱有问题，运行会被异常中止而一个 MS 故障提示会写到日志中。这些提示表明发生了什么故障和造成这些故障的原因。有时，一个故障值会和故障提示相关。如果需要比提示中给出的更详细的信息，可以使用 Diagnostics（诊断）视窗来解析故障值。

下面列出的是一些最频繁遇到的 MS 故障及其可能原因。

故障值 | 可能原因
3 | 电子倍增器电压设定过高；
 | MS 运行在溶剂峰上；
 | 电子倍增器刚更换过；
 | 离子源刚清洗过
5 | RF 线圈没有正确调节
9 | 灯丝烧坏
17 | GC 色谱柱流量过高；
 | 校准瓶刚加满；
 | 空气泄漏
19 | MS 运行在溶剂峰上
33 | 扩散泵冷却风扇堵塞或没有运行
129 | 扩散泵仍在预热
257 | MS 处于放空状态（扩散泵加热器关闭）；
 | 扩散泵正在冷却
289 | 扩散泵过热，正在冷却
321 | 前级真空规电缆断开连接且扩散泵关闭
385 | 扩散泵已冷却且关闭
417 | 扩散泵过热，自动关闭，现在已冷却
513 | （电子倍增器的）高压源故障
16384 | 系统处在 STANDBY（备用状态）下（可能由 GC 或 LC 关闭由 APG 遥控电缆通向 MS 接口的连接）。如果 GC 检测器、温度、压力或流量设定值没有达到的话 6890 GC 可能关闭 MS。MS 保持在备用状态直到故障排除或 APG 电缆被断开连接为止。


MS 四极杆

MS Quad（MS 四极杆）以摄氏度显示了四极杆的温度。此温度可以通过选择 Manual Tune（手动调谐）的 Edit MS Temps（编辑 MS 温度）菜单项来进行设定。推荐范围为 100 至 200。设定值低于 100 时 MSD 不能可靠地控制加热区。

仅适用于 5973 MSD


MS 扫描参数

MS 扫描参数确定了获取的质谱质量。

Start Time（启动时间）

用于激活表中每一行项目定义的扫描参数的时间（运行起始后以分钟为单位）。运行中三个扫描范围的最大值有效。

启动时间空白表示该组当前无效。第一组总是被定义并在溶剂延迟之后开始。

Mass Range（质量范围）

输入低质量和高质量 (amu) 来指定由 MS 扫描的范围。范围越大，每秒的扫描数就越少。

Threshold（阈值）

只有丰度大于等于此值的离子才能在质谱的每次扫描中被保留。典型阈值为 500。

Sampling（进样）

此处的输入值用于计算在继续下一个质量前每个质量丰度的记录次数。值为 2 适合大多数分析。结果数在 Samples（样品）中报告并以 2^N 进行计算。推荐值为 2（使样品值为 4）。范围为 0 至 7。

Scans/sec（扫描/秒）

根据质量范围和输入的进样值计算的一个近似值。这不考虑进行时间事件所需的额外时间。

MS Window 1 / MS Window 2 Mass Range（MS 窗口 1 / MS 窗口 2 质量范围）

输入要用于实时绘图的离子质量范围。这些部分仅在相应窗口的对话框的 Real Time Plot Parameters（实时图形参数）部分中选定 Extracted Ion（提取离子）图形类型时有效。


MS SIM 参数

MS SIM 参数可以让您定义多达 50 组，每组最多 30 种离子来进行选定的离子监测 (SIM)。

左边的表格定义每个 SIM 组一个起始时间和一个功能组 ID。第一组的起始时间要与溶剂延迟时间相同。如果不是这样，将使用溶剂延迟时间。

应用于组内的每个离子的停留时间和分辨率参数的缺省值分别为“100 ms”和“Low”。在停留色谱柱中，输入用于进样指定离子的时间量。“100 ms”对于在典型毛细管 GC 峰中的两个或三个离子是满意的。多于三个离子时，使用较短的停留时间（如 30 或 50 ms）以确定有足够的数据点来定义峰。如果分析需要，可以对组中的每个离子设定一个停留时间。

如果输入的停留时间超出允许范围 (10-9999 ms)，此值将变为最近的极限值。总循环时间必须小于等于 100 s。停留时间可以调节以满足此要求。

Resolution（分辨率）色谱柱指定了低质量分辨率。Low指定峰宽为 0.7 - 0.9 amu；峰宽增加能增加灵敏度而专一性没有什么损失。High从调谐文件指定峰宽（通常为 0.5 amu）。

当前组（由箭头显示）中的被监测离子必须输入在表格右边。每组中最多两个离子可以选定来在实时显示中绘图。为了要显示两个离子，必须将窗口 2 中的 Plot Type（图形类型）在面板的 Real Time Plot Parameters（实时图形参数）部分中指定为 Single（单一）。如果没有指定一个离子，组中的第一个将被使用。

删除组按钮

删除一个完整的 SIM 组及其中的离子。

删除离子按钮

从组中删除个别离子。


MS 源

MS Source（MS 源）以摄氏度显示离子源的温度。此温度可以通过在 Manual Tune（手动调谐）中选择 Edit MS Temps（编辑 MS 温度）菜单项来设定。

对于序列号高于 XX64400000 的 5973 MSD 和安装了高温升级的旧式 MSD，建议温度范围为 150 至 300。设定值在 150 以下时 MSD 可能难以可靠地控制加热区。

对于未安装高温升级的旧式 MSD 建议温度范围为 150 至 250。

仅适用于 5973 MSD


MS 温度（参数）

MS Temp（MS 温度）以摄氏度显示质谱仪的温度。传感器位于离子源附近。

仅适用于 5972 / 6890 MSD。


MS 调谐文件

使用此对话框来从系统中可用的调谐文件列表中选择一个调谐文件。可通过选择 Instrument / Select MS Tune File（仪器/选择 MS 调谐文件）或单击下列图标来显示此对话框。

在 5973 MSD 系统上，这个菜单项显示 Select Tune File（选择调谐文件）对话框，这个对话框除了可用调谐文件列表外也能显示存储在每个调谐文件中的各种设定。

这些调谐文件包含在打开 MS 采集参数时可由它使用的 MS 参数。调谐文件名称从当前方法中读出并在进入 Instrument Control（仪器控制）时自动被加载。如果此调谐文件不存在则会显示一个故障提示。必须选择一个有效调谐文件才能继续进行。

如果之前已创建并保存了一个带有为某种特定类型的分析而选择特定参数的调谐文件（但没有在当前方法中指定此文件），可以在开始数据采集前选择此文件。

所有调谐文件必须处于化学工作站的 \MSDCHEM\instname\instmodel 目录下，例如 \MSDCHEM\1\5972\ATUNE.U。


MSD 最近未调谐过

MSD 的变化可能导致质量指认的小变化。如果调谐文件非常旧，MSD 条件的变化可能足以导致质量指认的显著改变。重新调谐 MSD 并使用新的调谐文件。


MSD 没有足够时间达到热平衡

MSD 温度的变化可能导致质量指认的小变化。如果调谐文件在 MSD 在热平衡之前采集，温度的差异可能是质量指认变化的原因。调谐 MSD 或采集数据前确认 MSD 处于热平衡。当所有加热器达到其设定值以使 MSD 达到热平衡后至少需要 2 小时。


MSD 没有足够时间达到热平衡

当所有加热器达到其设定值让 MSD 达到热平衡后至少需要 2 小时。


MSD 没有足够时间降压

如果最近打开了 MSD，给系统多一点时间来降压。如果 20 分钟后三级真空规没有打开，检查其他原因。


MSP（定义）

 MSP 为最显著峰。


多次进样

Multiple Injections（多次进样）选项仅在 6890 PTV 进样口同 G1513A GC 进样器一起配置时存在。

选中 Multiple Injections（多次进样）复选框配置 GC 进样器来进行多次进样。当配置为多次进样后，进样器只在首次进样时使用 Start Run（开始运行）命令。如果未选中，进样器进一次样且每次运行时都使用一次 Start Run（开始运行）命令。

本对话框中其他项目：

Syringe Size（注射器尺寸）

Nanoliter Adapter（纳升接头）

On-Column Injection（柱头进样，不是对所有进样器都可用）

OK/Cancel/Help Buttons（确定/取消/帮助按钮）

更多的关于 Multiple Injections（多次进样）


多位阀

让您选择这个阀的某一位置通过 GC 的 BCD 的端口。也称作气流选择阀。

要完成您的配置，指定：

  • 以秒为单位的 Switching Time（切换时间） [image] ，为连续的传动装置动作之间的延迟。提供了驱动器结构准备好进行下一个动作的时间。

  • Description of use（使用说明） [image] 更详细地说明了阀的功能，例如“产生气流”。

  • 对于用来从 BCD 电缆反转二进制编码的十进制以使所有 0 会作为 1 接收而 1 作为 0 接收的负逻辑设定的阀的 BCD Outputs（BCD 输出） [image] 。否则选择 Normal（正常）。

注意： 要使用 BCD 电缆读出多位阀的位置，必须将电缆连接到 Valve #7位置。将 Valve #7配置为 Multiposition（多位）阀。

只能配置一个阀为 Multiposition（多位）阀。

有关多位阀的更多信息，请参见 Multiposition（多位阀）。


多位

让您选择这个阀的某一位置通过 GC 的 BCD 的端口。也称作气流选择阀。

只能配置一个阀为 Multiposition（多位）阀。

Stream Selection（气流选择） [image] 可以使用多位阀选择几种气流的一种并将该气流输入到气体进样阀以进行分析。（6890 系列 GC 提供序列控制，允许仪器使用多位阀从一个位置范围取样。） 连接到多位阀的 BCD（二进制编码的十进制）电缆读出其当前位置。使用命令启动序列时，GC 使用多位阀和气体进样阀来抽样和进样，发挥的功能和 Automatic Liquid Sampler（自动液体进样器）系统一样。（有关更多信息，请参见 Gas Sampling（气体进样）。）

注意： 要使用 BCD 电缆读出多位阀的位置，必须将电缆连接到 Valve #1位置。将 Valve #1配置为 Multiposition（多位）阀。

要完成配置，指定：

  • 以秒为单位的 Switching（切换） [image] ，为连续的传动装置动作之间的延迟。提供了传动装置结构准备好进行下一个动作的时间。

  • 对于负逻辑设定的阀的 Invert BCD（反转 BCD） [image] ，选择这个选项来从 BCD 电缆反转二进制编码的十进制，这样所有 0 会作为 1 接收而 1 作为 0 接收。

  • BCD [image] 反映存在（不存在） BCD 电缆连接。

  • Position（位置） [image] 阀位置。

化学工作站将 Position（位置）设定值和方法一起保存。加载方法时，阀会进到指定位置，除非正将多位阀与气体进样阀联合使用。对于后一种情况，多位阀会进到前样品瓶编号代表的位置。

缺省位置： 1


m/z - 定义

符号 m/z 是用于报告质谱仪产生的离子碎片大小的单位。它是离子质量与其电荷量（通常为 +1）的比值。


纳升接头

如果已经在前注射器和/或后注射器安装了纳升接头 (18599N)，请选择 Nanoliter Adapter（纳升接头）。这个接头通过改变活塞的步长来调节进样量。

本对话框中其他项目：

Syringe Size（注射器尺寸）

Multiple Injections（多次进样）

On-Column Injection (not available on all injectors)（柱头进样(只有部分进样器可用））

OK/Cancel/Help Buttons（确定/取消/帮助按钮）


负极性

要激活负极性，在 On（开） 复选框中打上叉 (X) 。

激活负极性将转换质谱峰，这样积分器或化学工作站就能够对质谱峰进行测量了。


下一数据文件

选择该菜单项将调用新的数据文件。被调用的数据文件是同一目录下按字母顺序紧接当前数据文件的那一个数据文件。例如，如果该目录下包含下列文件：

Soil1.d

Soil2.d

Soil3.d

Water1.d

Water2.d

Water3.d

并且 Soil3.d 是当前显示的文件，选择 Next Data File（下一数据文件）选项将调用 Water1.d 。如果当前数据文件是该目录下的最后一个文件（在这个示例中为 Water3.d), 将显示 No next file（下一文件不存在）的提示信息。若您选择 Load Data File（调用数据文件）选项，并从错误的文件列表中调用文件，系统也会显示同样的提示信息。

该菜单项与菜单底部显示的多个项目无关，那里显示的项目是最近曾经调用过的数据文件。

注意 Load Data File（调用数据文件）菜单中的 Sort By（排列方式）选项允许您用不同的排序标准重新对文件列表排序。Sort By（排列方式）选项也会决定选择 Next Data File（下一数据文件）选项后将调用的数据文件。


下一温度 oC

下一温度 C

对给定程序的温度范围，GC 加热/冷却柱箱的温度（单位为 [image] C）。

对于等温运行，在程序的 Initial（初始）行设置 Next（下一） [image] C参数为您所需要的柱箱温度。

初始Next（下一） [image] C 参数值与刚启动运行时的设定值相同。

注意： 如果您在运行时改变 Setpoint（设定值），它将覆盖初始Next（下一） [image] C 。


下一温度 oC

下一温度 C

对给定程序的温度范围，GC 加热/冷却进样口的温度（单位为 [image] C）。

有效范围:

24 [image] C — 450 [image] C 不进行低温冷却

-60 [image] C — 450 [image] C 低温冷却 (CO2)

-80 [image] C — 450 [image] C 低温冷却 (N2)


下一温度 oC

下一温度 C

对给定程序温度范围，GC 加热/冷却进样口的温度（单位为 [image] C）。

有效范围:

无低温冷却 * | 0°C 至 450°C
CO2 低温冷却 | -60 [image] C 至 450°C
液体 N2 低温冷却 | -160 [image] C 至 450°C

* 实际下限温度约高于室温 +10°C


下一温度 oC

下一温度 C

给定程序级时，GC 加热/冷却进样口的温度（单位为 [image] C）。

有效范围:

0°C 至 450°C


下一温度 oC

下一温度 C

对给定程序温度范围时，GC 加热/冷却辅助通道的温度（单位为 [image] C ）。


下一压力 psi ，kPa ，或 bar

对给定程序压力范围，压力改变（用 psi ，kPa ，或 bar 为单位）。


NIST 输出

NIST Output ( NIST 输出）将质谱数据用 ASCII 码格式保存到文件中。这个菜单项有 4 个选项：

Create File with integrated Spectra（用积分光谱创建文件）

Append integrated Spectra to file（添加积分光谱到文件）

Create File with Spectra in X（在 X 中用光谱创建文件）

Append File with Spectra in X（在 X 中用光谱添加文件）

在 ASCII 码输出文件中，每一个色谱积分峰的数据列表为：

  • 峰的扫描次数

  • 峰的保留时间

  • 谱图中每个峰顶点的质量（荷质比）。

  • 每个质量的丰度

Create File with integrated Spectra（用积分光谱创建文件）

如果还没有对色谱图进行积分，这个选项将对显示出来的色谱图进行积分。然后，从每一个质谱峰的顶点取出光谱。该数据以 ASCII 码格式保存在 <filename>.d 目录下的 <filename>.msp 中，其中 <filename> 是当前显示色谱图的文件名。

例如，如果 DLWV002.D 是当前显示色谱图的文件名，那么，该程序的运行结果将保存在 DLWV002.D 目录下的 DLWV002.MSP 文件中。这个文件必须重命名为扩展名是 .txt 的文件方能打印。

Append Integrated Spectra to File（添加积分光谱到文件）

如果还没有对色谱图进行积分，这个选项将对显示出来的色谱图进行积分。然后，从每一个质谱峰的顶点取出光谱。该数据以 ASCII 码格式保存，并添加到 <filename>.d 目录下的 <filename>.msp 文件中，其中 <filename> 是当前显示色谱图的文件名。

例如，如果 DLWV002.D 是当前显示色谱图的文件名，那么，该程序的运行结果将添加到 DLWV002.D 目录下的 DLWV002.MSP 文件中。这个文件必须重命名为扩展名是 .txt 的文件方能打印。

Create File with Spectra in X（在 X 中用光谱创建文件）

这个选项将光谱（出现在窗口[1]中的光谱）以 ASCII 码格式保存在 X 寄存器的堆栈中。该数据保存在 <filename>.d 目录下的 <filename>.msp 文件中，其中 <filename> 是当前显示色谱图的文件名。

例如，如果 DLWV002.D 是当前显示色谱图的文件名，那么，该程序的运行结果将保存在 DLWV002.D 目录下的 DLWV002.MSP 文件中。这个文件必须重命名为扩展名是 .txt 的文件方能打印。

Append File with Spectra in X（在 X 中用光谱添加文件）

这个选项将光谱（出现在窗口[1]中的光谱）以 ASCII 码格式保存在 X 寄存器的堆栈中。该数据添加到 <filename>.d 目录下的 <filename>.msp 文件中，其中 <filename> 是当前显示色谱图的文件名。

例如，如果 DLWV002.D 是当前显示色谱图的文件名，那么，该程序的运行结果将添加到 DLWV002.D 目录下的 DLWV002.MSP 文件中。这个文件必须重命名为扩展名是 .txt 的文件方能打印。


氮磷检测器 (NPD)

NPD 使样品与载气通过氢气/空气等离子体。一个加热了的陶瓷源，经常称作铷珠，位于喷嘴的正上方。低的氢气/空气比值不能维持火焰，却能使烃的离子化程度降到最低，而铷珠表面的碱金属离子促使含氮或磷有机化合物的离子化。输出电流与收集到的离子数量成正比。电流计检测到该输出电流，转换成数字信号，传输到输出设备。

使用 NPD 对话框设定检测器参数，指定设定值。单击以下各项获取详细信息：

在您选择温度与流量时，请参考下表中的信息。

流量、温度、铷珠信息

气体种类 | 建议流量值
载气 （氦器、氢气、氮气 *) | 填充色谱柱，20 至 60 ml/min ，随色谱柱而定 毛细管色谱柱，根据色谱柱的大小选择最优流量。
检测器气体 |
氢气 | 3 ml/min （最大流量为 5 ml/min)
空气 | 60 ml/min
毛细管色谱柱尾吹 （氦气，** 氮气） | 关

温度（缺省值为 250 [image] C ；变化范围为室温至 400 [image] C）

<150 [image] C ，不启动调节点火补偿程序。
>250 [image] C 为建议使用值。
检测器温度应比最高的柱箱梯度温度还高。
检测器温度越高，则铷珠所需的加热电压越小。

调节点火补偿（缺省值为 50 pA, 建议操作范围为 30 至 60 pA, 允许操作范围为 10 至 99 pA）

-50 pA 时增加了灵敏度，却会缩短铷珠的寿命。
较低的设定值降低了灵敏度，增加了铷珠的使用寿命，但设定值过低可能会导致
溶剂淬灭
。一旦启动调节点火补偿程序，将用 20 至 60 分钟使检测器达到就绪状态。

平衡时间（缺省值为 5 分钟；范围为 0 至 999.9 分钟）

平衡时间越长，操作基线越稳定。平衡时间越长，则检测器得花越长的时间才能达到就绪状态。

* 当使用氢气作载气时，流量必须低于 3 [image] [image] /min 。

    **为获得更好的峰形，建议使用氦气作载气

NPD 对流量很敏感。如果正在使用程序升温，用以下步骤设定仪器：

  • 有 EPC 进样口时，设定载气为恒定流量模式。建议关闭尾吹气。如果您一定要在有 EPC 检测器时使用尾吹气，将它设定为 Makeup Flow（尾吹气流量）模式。非 EPC 检测器支持恒定尾吹气流量模式。

  • 如果是使用 EPC 进样口和 EPC 检测器，并选择在恒压模式下工作，则尾吹气应设定为 Const Col + Makeup（柱+尾吹=常数），mL/min 模式。

NPD 信号转换，用于数据分析

  • 1.0 pA = 1 高度单位

  • 1.0 pA x 1 秒 = 1 面积单位


条形码读出机不存在

化学工作站试图将瓶子移入或移出条形码读出机，然而系统提示条形码读出机没有安装。关掉这个单元，检查是否所有的电缆都紧密连接，重新开启此单元，并重试。如果仍旧出现这个故障，请与售后服务部联系。


夹样器中没有样品瓶

夹样器没有夹到样品瓶。检查样品瓶是否处于正确位置以及夹样器是否工作正常。如果夹样器检测器出了故障，化学工作站也会提示同样的故障信息。


检测器不存在

当您使用 Mass Selective Detector（质量选择检测器），利用 NOD 对话框来：

  • 激活检测器加热元件，并

  • 指定温度设定值。

单击 Heater（加热器）， [image] C，来获得更多信息。


没有加热器电压

这表明交流电路板或主板的保险丝熔断。这些保险丝用户无法弄到手。请与 Agilent 技术服务代表联系。


无峰且 MSD 没有通过调谐

如果没有峰出现而且 MSD 没有通过调谐,故障排除的下一步就是要确定故障是否与电子倍增器及其电路有关。

  1. 使用手动调谐程序初始化重复峰形图扫描。

  2. 增加电子倍增器的电压。

如果噪音的丰度增加，则故障可能与电子倍增器及其电路无关。如果噪音的丰度不增加，则故障可能存在于电子倍增器及其电路上。

噪音增加

噪音不增加


MSD 通过调谐，而仍无峰出现

如果在您的分析过程中，MSD 通过调谐，而仍无峰出现，则故障可能与 GC 有关。可能的故障原因包括：

样品浓度不正确

检查样品稀释情况。如果样品稀释不正确，则样品浓度可能过低，以至于检测不到被分析物。

不存在分析物

目标分析物可能根本不存在。如果在溶剂峰出峰时关闭分析器，那么将检测不到峰。

ALS 处注射器脱落或没有正确安装

在配备 ALS 的系统中，如果注射器脱落或没有正确安装,那么 ALS 可能继续工作，但由于没有注射任何样品，因此没有峰出现。检查 ALS 。确保注射器正确安装。

样品瓶为空或几乎为空

如果样品瓶为空或几乎为空，注射器可能没有吸到任何样品。检查样品瓶，确保试样瓶非空。

进样口泄漏

如果密封隔垫没有密封良好，样品可能被压出密封隔垫。检查并在必要时更换密封隔垫。参见 GC 附带的用户使用信息。

进样口处的柱螺帽松动

如果进样口处的柱螺帽松动，样品可能会泄漏出去。如有必要，稍微拧紧进样口处的柱螺帽。

注意 进样口处的柱螺帽拧得过紧会压碎色谱柱。

在分流模式下，而不是在无分流模式下进样

如果偶然在分流模式下进样，而处理方法要求在无分流模式下进样，则可能丧失大部分的样品。确保在正确模式下进样。


噪音不增加

如果增加 EM 电压，重复峰形图扫描的噪音量并不增加，则电子倍增器或相关的电路可能发生了故障。检查下列可能导致无质谱峰的原因：

信号传输电缆连接不良

检测器电线连接不良

电子倍增管发生故障


噪音增加

如果增加 EM 电压，重复峰形图扫描的噪音量增加，则电子倍增器和相关的电路可能工作正常。检查下列可能导致无质谱峰的原因：

校准样品瓶为空或几乎为空

前级压力和真空多路连接管压力超出警戒

离子源很脏

灯丝故障或没有正确连接

校准阀工作异常

离子源电线连接不良


没有进行配置

没有安装阀。


色谱柱流量不足

确保色谱柱流量没有减少或关闭。色谱柱流量至少应为 0.1 ml/minute 。确保色谱柱没有阻塞。

注意

在色谱柱流量不足时加热会损坏毛细管色谱柱。


检索命中项数

输入每一次检索的命中（匹配）项数。这是将检索分成几组的一种方法，每一组都指定了检索命中项数。您可以通过此参数来控制谱库检索的时间，尤其是与其他参数共同来限制检索条件时。


oC/min

C/min

ÔÚ GC ÖÐ加热/冷却辅助通道的速率（单位为 [image] C/min)即从一个程序温度，下一温度 [image] C 到下一个程序温度，下一温度 [image] C 。这就是所谓的“温度梯度”。

任意温度下的零速率将使得该温度及接下来的任意温度的辅助通道梯度升温程序无效。


oC/min

C/min

在 GC 中加热/冷却进样口的速率（单位为 [image] C/min ）即从一个程序温度，下一温度 [image] C 到下一个程序温度，下一温度 [image] C 。这就是所谓的“温度梯度”。

任意温度下的零速率，将使得该温度及接下来的任意温度的进样口梯度升温程序无效。


oC/min

C/min

从一个程序级数温度，下一温度 [image] C 到下一个程序温度，下一温度 [image] C ，GC 加热/冷却进样口的速率（单位为 [image] C/min ）。这就是所谓的“温度梯度”。

任意温度下的零速率，将使得该温度及接下来的任意温度的进样口梯度升温程序无效。


oC/min

C/min

从一个程序温度，下一温度 [image] C 到下一个程序温度，下一温度 [image] C ，GC 加热/冷却进样口的速率（单位为 [image] C/min ）。这就是所谓的“温度梯度”。

任意温度下的零速率，将使得该温度及接下来的任意温度的进样口梯度升温程序无效。


oC/min

C/min

从一个程序温度，下一温度 [image] C 到下一个程序温度的 下一温度 [image] C，GC 加热/冷却柱箱的速率（单位为 [image] C/min).这就是所谓的“温度梯度”。

任意温度下的零速率，将使得该温度及接下来的任意温度的进样口梯度升温程序无效。


确定按钮

单击 OK（确定）按钮来下载 最近一次单击 Apply（应用）（或 Edit Parameters（编辑参数）...）后的新参数或修改过的参数，并离开 Instrument Control（仪器控制）屏幕。

注意：在您改正所有非法值前，化学工作站不会下载任何参数。


确定/取消/帮助按钮

确认输入新的和/或订正的信息，并关闭对话框。

取消输入新的和/或订正的信息，并关闭对话框。

显示与此对话框有关的帮助信息。


确定/取消/帮助按钮

确定按钮

单击 OK（确定）按钮,确认输入新的和/或订正的信息，并关闭对话框。

取消按钮

单击 Cancel（取消）按钮，取消输入新的和/或订正的信息，并关闭对话框。

帮助按钮

单击 Help（帮助）按钮,显示与此对话框有关的帮助信息。


确定/帮助按钮

确认输入新的和/或订正的信息，并关闭对话框。

显示与此对话框有关的帮助信息。


确定/撤销/帮助按钮

确认输入新的和/或订正的信息，并关闭对话框。

取消输入新的和/或订正的信息，并关闭对话框。

显示与此对话框有关的帮助信息。


柱头进样

注意 On-Column Injection（柱头进样）选项在化学工作站使用 6890 GC 时无效，因为如果安装有柱头进样口，仪器就已经“知道”了它的存在。

本对话框中其他项目：

Syringe Size（注射器尺寸）

Nanoliter Adapter（纳升接头）

OK/Cancel/Help Buttons（确定/取消/帮助按钮）


加热器的一根保险丝发生故障

用户不能更换这些保险丝。请与 Agilent 技术服务代表联系。


选项对话框

当您选择 Data Analysis（数据分析）菜单中的 Tools / Options（工具/选项）时，将显示出此菜单。

Label Spectral Peaks（标记质谱峰）

将质量标记打开或关闭。

Autoscale Y-axis（自动设定 Y 坐标轴）

当这个触发器打开时，每一个图的纵坐标轴都分别进行设定。当这个触发器关闭时，每一个图的纵坐标轴都由峰组中最大峰进行设定。

Command Line（命令行）

将command line（命令行） 打开或关闭。当这个触发器打开时,能在 Data Analysis（数据分析）窗口的底部输入命令。

Stack（堆栈）

将 Stack（堆栈） 窗口显示打开或关闭。这个触发器打开时，Stack（堆栈）窗口出现在 Data Analysis（数据分析）窗口的右下部。

Manual Integration（手动积分）

让您执行手动积分。

Copy （复制）窗口

提示输入您要复制到剪贴板的图形窗口数目。

Reset（复位）窗口

重新安排图形窗口到缺省位置


选项菜单（参数检索）

选项菜单

Select Normalization Ion （选择归一化离子） | 允许您选择归一化离子。
Extend Database Headers （扩展数据库文件头） | 在此软件的先前版本中，一定的数据元（化学名、分子量及各种其他信息）允许使用不同的字符串长度。这个菜单项允许您扩展这些数据元的字符数目。
Command Line （命令行） | 打开或关闭 Command Line（命令行）。打开此开关时，能在 Data Analysis（数据分析）窗口的底部输入命令。
Stack （堆栈） | 打开或关闭 Stack（堆栈）窗口显示。打开此开关时，Stack（堆栈）窗口出现在 Data Analysis（数据分析）窗口的右下部。
Manual Integration （手动积分） | 让您执行手动积分。
Copy Window （复制窗口） | 提示输入您要复制到剪贴板的图形窗口数目。
Reset Windows （复位窗口） | 重新安排图形窗口到缺省位置。


其他

阀的功能是由用户进行指定的。

利用 Description of use（使用说明） 来详细指定阀的功能，例如，阀的“中心切割”。


其他

阀的功能是由用户来进行指定的。


其他污染

污染可来自于进样口、饱和阱或遭污染的载气。在质谱中检查污染的特征离子。如果污染离子存在：

  1. 更换进样口隔垫、衬管和密封垫。

  2. 更换载气气供给。

  3. 更换水分捕集阱。

  4. 维护化学捕集阱。

  5. 更换氧吸附阱。

  6. 设置载气流量。

  7. 整夜吹扫整个系统。

参见 GC 附带的文档来指导您对进样口与捕集阱的维护。


影响 PBM 的其他因素

PBM 检索正确命中项的能力也决定于数据库的质量。PBM 检索是专为 Wiley 质谱库而设计的。数据库中项数较大以及相同化合物的相同光谱数目较大时，成功检索的机会也较大。

PBM 难于正确检索高度氯化的化合物如七氯等。这是由于这类化合物存在大的质量缺陷、PBM 所使用的约数算法、小的质量坐标轴校准误差共同作用的结果。

例如，含有七个氯原子的质量碎片大约有 -0.28 amu 的质量缺陷。再加上 -0.10 amu（在指定误差范围内）的质量坐标轴校准误差，报告质量将为 -0.38 amu 。由于 PBM 使用的约数质量窗口是 -0.3 到 +0.7 ，因此这个质谱峰将约数到下一较小整数。参比化合物有 -0.28 amu 的质量缺陷，而被约数到下一较大整数,产生 1 amu 的差别。在比较过程中，这些“丢失的”质谱峰将导致参比色谱的忽略。

通过对仪器的正确调谐可以避免校准误差，从而可以将这类问题降低到最小。如果仍然出现这类问题，您可以在进行 PBM 检索之前，用 TRANSFORM 命令来纠正细微的质量坐标轴校准误差。


色谱柱出口端压力单位 psi/kPa/ bar

选择色谱柱出口端压力（或“背压”）的单位类型：

Vacuum（真空） [image] 当色谱柱的下游末端处于真空状态下时，也就是在您选择色谱柱 与质谱同时使用 时，选择 Vacuum（真空）选项。

流量根据下面所列的方程进行计算，其中 P out 指流出色谱柱时流体的压力。

(C * Diam.4 (P in2 - P out2) )
流量 = __________________________________
（长度 * 粘度 * 温度）

若已经选择了 Vacuum（真空）选项， P out 在流量计算时设为零。

若没有选择 Vacuum（真空）选项， P out 在流量计算时设为标准压力(1 个大气压）。

Ambient（环境） [image] 当您想使用当地大气压力时，选择 Ambient（环境）选项。

Positive（正压） [image] 当您想使用校正后当地大气压力时，选择 Positive（正压）选项。例如，当色谱柱与一个原子发射检测器连接时，您选择 Positive（正压）选项，那么，色谱柱就不是在大气压或真空压力下工作了。在左边的文本框中指定一个压力校正值（单位可以是 psi ，kPa ，或 bar ）。

本对话框中其他项目：

Mode（模式）

Inlet（进样口）

Detector（检测器）

Flow（流量）

Installed Column（已安装的色谱柱）

Manufacturer's Specifications/Column Dimensions（制造商规格/色谱柱尺寸）

Ramps（调节）


柱箱

打开 oven（柱箱）菜单，在它的复选框中打叉 (X) 。

使用 Setpoint（设定值） 来指定一次运行中柱箱的一个理想温度设定值 （单位为 [image] C ）。

GC 传输的柱箱 Actual（实际）温度是只读显示。

本对话框中其他项目：

Oven Ramp（柱箱梯度）

Oven Configuration（柱箱配置）

Cryo Configuration（低温配置）


柱箱配置

Oven Configuration（柱箱配置）设置柱箱的最高温度和平衡时间。

指定柱箱操作的以下配置参数。单击以下各项获取详细信息：

Maximum（最高温度） [image] C

Equilibration（平衡时间）min

本对话框中其他项目：

Oven（柱箱）

Oven Ramp（柱箱温度梯度）

Cryo Configuration（低温配置）


柱箱低温选项

检查安装在 6890 系列 GC 上的低温阀的配置信息。作出响应，单击 OK（确定）。

单击以下各项获取详细信息：

Ambient Temperature（室温）

Cryo Timeout（低温暂停）

Quick Cryo Cool（快速低温冷却）

Cryo Fault（低温故障）

Set Defaults Button（设定缺省按钮）

要获取有关低温冷却的更多信息，请参见Cryo Configuration（低温配置）。

OK/Undo/Help Buttons（确定/撤销/帮助按钮）


柱箱梯度

您能使用高达六阶（或“温度梯度”）的柱箱升温程序，按连续次序依次执行，来控制一次运行中的 GC 柱箱温度。一个梯度柱箱升温程序包括：

  • Initial（初始） 柱箱温度，

  • 最多为六阶温度梯度 和

  • 运行后 柱箱温度。

单级梯度 温度程序将初始温度以指定的速率升至指定的最后温度，并将最后的温度维持指定的时间。

多阶梯度 温度程序与之相似。通过多阶梯度温度程序，您也能使得柱箱温度从初始温度升至最后的温度，但两个不同温度之间的升温速率、时间、温度差不相同。您也能设计多阶梯度温度程序，使柱箱温度 下降。

在多阶柱箱升温程序中指定下列参数 。单击以下各项获取详细信息：

Total（总时间）min 是每一个温度梯度的累计运行时间，它是只读的显示项。

要查看柱箱温度设定值的分布图 ，单击 Plot（绘图）... 按钮，并选择 Oven Temperature（柱箱温度）:

柱箱恒温控制: 参见 Prepare for an Isothermal Run（准备等温运行） 的逐步指令，准备柱箱恒温运行程序。

本对话框中其他项目：

Oven（柱箱）

Oven Configuration（柱箱配置）

Cryo Configuration（低温配置）


覆盖色谱

Overlay Chromatograms（覆盖色谱）菜单让您选择将要覆盖显示在同一窗口中的色谱。将您选择的色谱添加到当前显示的色谱上。以“原来”的色谱为基线。如果当前没有显示任何色谱，最近调用的色谱（File （文件）菜单的第一个文件））就是“原来”的色谱。在覆盖显示中，原来的色谱以白色显示。其他的每一个色谱都有它自己的颜色。

单击 Overlay Chromatograms（覆盖色谱） ，会激活 Multiple File Select （多文件选择）对话框，在这个对话框中，您可以指定要覆盖的数据文件（色谱）。这个对话框主要有三部分：

  • 目录列表

  • 数据文件列表

  • 已选好待处理文件列表

选择要覆盖的色谱：

  1. 先从目录列表中选择适当的目录。

  2. 从数据文件列表中选择数据文件。

  3. 单极右箭头按钮，将文件移到处理文件列表。

  4. 重复以上步骤，制定所有您想显示的文件。

  5. 单击 Process（处理）按钮，处理、显示这些文件。

色谱显示的确切方式由 Tools（工具）菜单中的 Set Overlay Parameters（设定覆盖参数） 选项控制。


氧化剂流量，mL/min

要激活检测器中的空气流，在 On（开） 复选框中打上叉 (X) 。

实际流量，通过 GC 传输出来，是只读显示。

注意：氧气不能作为氧化剂气体。

设定值范围：0 至 200 mL/min


6890 GC / 5972 MSD 的参数和范围

对于 5972 / 6890 的合乎规定的参数和范围为：

AMUG（AMU 增益） | 0 - 1023 DAC counts
AMUO（AMU 补偿值） | 0 -255 DAC counts
ECUR (发射电流=灯丝） | 0=off；1=on
REP（推斥极电压） | 0 - 19.8 V
IFOC（离子聚焦透镜电压） | 0 -127.5 V
ENT（入射透镜电压） | 0 -128 V
XRAY（X 射线透镜电压） | 0 -218 V
EMUL（EM 电压） | 0 -3000 V

对于下列项目的范围： -32768 - 32767

MASG（质量坐标轴静态增益）

MASO（质量坐标轴静态补偿值）

MADO1（质量坐标轴动态补偿值 1）

MADO2（质量坐标轴动态补偿值 2）

MADO4（质量坐标轴动态补偿值 3）

MADO8（质量坐标轴动态补偿值 4）

MADO16（质量坐标轴动态补偿值 5）

MADO32（质量坐标轴动态补偿值 6）

MADO64（质量坐标轴动态补偿值 7）

MADO128（质量坐标轴动态补偿值 8）

TTI（真实总离子模式） | 0=off；1=on
DIF（扩散泵控制） | 0=off；1=on
DCP（直流电流极性） | 0=pos；1=neg
FSEL（灯丝选择） | 1 - 2
MMW（中等质量宽度） | -0.15 - 0.15
ENTO（入射透镜补偿值） | 0 - 64
CAL（校准阀） | 0=closed；1=open
OUT1（打开采集器输出 1） | 0=off；1=on
OUT2（打开采集器输出 2） | 0=off；1=on


PBM 搜索 - 定义

PBM Search（搜索）是将未知化合物光谱同参比光谱库比较的一种谱库搜索。MSD 化学工作站的搜索步骤使用由 Cornell 大学的 Fred McLafferty 教授及其合作者开发的根据概率匹配（PBM）算法。通过检验参比光谱中的主要峰是否出现在未知物光谱中，搜索从与未知化合物光谱最相似的参比谱库中识别这些光谱。这种算法称作逆搜索。即使样品光谱包含共洗脱化合物时，它也能在谱库中找到光谱。特殊相似性由一种称作匹配质量的量度来评定。


PBM 检索 - 统计

单击 PBM Search Results（PBM 检索结果）对话框中的 Statistics（统计）按钮显示下列由 PBM 算法产生的数量。另见 About PBM（关于 PBM）。

Prob

CAS #

Ref #

K / dK

Flag

Con

C_1

Tilt

R_IV

XCorr

Prob

未知物作为参比正确鉴定出概率。其值大于 90 就是最好匹配。值小于 50 意味着未知物和参比之间存在相当大的差异，且匹配值得怀疑。概率值 +/-5 的差异通常不很重要。概率值前的星号 (*) 表示在匹配中使用了分子离子。如果没有星号，则没有使用分子离子。

这个值会考虑所有其他统计。这是一个经验判断；这就是说，K，dK 和其他值用来在表格中“查找”一个概率。这一个查看表是由 McLafferty 及其合作者通过对在一个很大的数据库中得到的检索结果进行广泛评估而开发出来的。

最终概率值是一个污染物校正的 IV 类可靠性值。一个 IV 类可靠性值意味着匹配项可能为一个准确匹配、同系物或一个异构体。因此，您不应该假定在命中列表中的第一个匹配项代表了确切的鉴定。

CAS #

NIST 和 Wiley 质谱数据库中的许多化合物通过其 CAS（化学文摘）号来标识。这一编号打印出来提供一个比化合物名称更确切的标识符。在用户创建的数据库中，编号为文件表头信息的 CAS 字段中的编号。

Ref #

谱库中的项目编号。

K / dK

K | 置信因子。这个值通常范围为 15-250 且与未知物和参比光谱的相似性相关。通常较高值意味着未知物与参比之间较好的相似性。
dK | “完美匹配”（通过将参比与自己匹配获得）和未知物的置信因子之间的差别。未知物与参比的完美匹配的 dK 为 0。通常低的 dK 值意味着未知物光谱和参比光谱之间几乎没有差别的“良好匹配”。许多情况下，低 dK 值比高 K 值更具诊断功能。

Flag

出现在压缩参比光谱而不是出现在未知物光谱中的离子数。值为 0 是表示非常好，而值为 3 并不就一定意味着匹配很差。

%

由 PBM 计算的光谱纯度的量度。PBM 设计来寻找混合物中的组分。因此，首先假定低纯度（小计数因子），然后较高的测量因子连续的被尝试直到找到参比和未知物的最佳匹配。100% 值表示已得到最佳对照时参比质谱没有改变比例。

Con

污染因子，纯度的另一个量度。范围为 0-100，0 是首选值。通常 % 和 Con 因子的行为相反，这就是说 % 高时 Con 很低。

C_1

I 类污染校正可靠性值。此值为 100 意味着一个准确匹配。然而因为质谱常常不能区分异构体或同系物，这个值总是小于 100。

Tilt

当调用倾斜作为一种检索策略，并且利用倾斜光谱来确定最终概率时，TILT 栏中的数值代表了与非倾斜对照相比 IV 类 (R_IV) 可靠性的增加值。另见倾斜

R_IV

IV 类可靠性值。匹配项可以为一个准确匹配、异构体或同系物，这就是说，它代表了质谱仪的诊断能力。值范围为 0-99，较高值意味着良好匹配。

XCORR

交叉相关系数。这一选项打开时用于整理检索结果。相关系数由前检索算法对每个匹配产生。前检索算法要求所有的未知物光谱的重要离子在参比光谱中出现。


PBM 检索 — 文本结果

单击 PBM Search Results（PBM 检索结果）对话框中的 Text（文本）按钮来查看从最近的谱库检索的命中物列表中选择的谱库光谱的文件头信息。化合物名称显示在列表的上部。

匹配质量

这个光谱和未知物光谱的匹配质量。

项目号

在所检索的谱库中谱库项的位置。

CAS 号

化学文摘号。（在用户创建的谱库中，这一字段会包含所有用户输入的编号。）

分子量

化合物分子量。

分子式

化合物分子式。

保留指数

化合物保留指数；值处于 0 和 10000 之间。

公司 ID

一个 10 位标识符。

熔点

化合物熔化的温度 (C)。值为 -300.00 表示数据无效或未知。

沸点

化合物沸腾的温度 (C)。值为 -300.00 表示数据无效或未知。

其他信息

任何同光谱有关的信息；可能超过一行。


PBM 检索结果

PBM Search Results（PBM 检索结果）对话框显示了从最近的谱库检索得到的匹配项列表，显示了每个化合物的名称、它的项目编号 (Ref. No.)、分子量 (MW) 和匹配质量 (Qual)。这个对话框出现在由鼠标（而不是通过 PBMSEARCH 命令）引起的谱库检索末端。

未知物、选定匹配光谱和差值光谱（如果选择了的话）显示在图形窗口中。（这个窗口覆盖了 Data Analysis（数据分析）主窗口，可以通过单击最大化按钮来扩大。）

选择显示命中物：

单击列表中的化合物。

显示未知物和谱库光谱的差值（未知物减命中物）：

选择 Difference（差值）复选框。

显示检索统计（概率/可靠性）：

单击 Statistics（统计）按钮。

显示文本结果（选定命中物的匹配质量和谱库信息）：

单击 Text（文本）按钮。

打印未知物和当前显示的谱库光谱：

单击 Print（打印）按钮。

一个窗口只有当它有光点时才可以接受键盘输入 — 如显示标题栏变暗那样。例如，在 PBM Search Results（PBM 检索结果）面板上单击时，该面板就有光点，而且加速键（按钮上的下划字母，如，Alt＋t 表示 Text（文本）显示）可用，但直接指向 Data Analysis（数据分析）的加速键不起作用。

切换光点：

单击想要键入内容的窗口或按下 Alt-F6 直到该窗口上出现光点。


峰匹配

决定识别窗口。在检索对目标化合物的标识预期保留时间 E 和比例 r 的定义的标志时，定义 Adjusted Expected Retention Time（调节预期保留时间）为 E' = rE。（请参见信号提取。）

现在注意有两个全局数据库分别称为 Reference Window（参比窗口）和 Non-Reference Window（非参比窗口）。这些以分钟或百分比表示的值描述了 E' 周围的时间范围，在这个时间范围内目标信号峰被考虑为调节预期保留时间为 E' 的目标化合物的匹配。

Reference Window（参比窗口）用于标志 Time Reference Compounds（时间参比化合物）的 ISTD 项目；Non-Reference Window（非参比窗口）用于所有其他目标化合物项目。

如果 Reference Window（参比窗口）以 m 分钟补偿值表示，然后定义 Dr 为 m/2。而如果 Reference Window（参比窗口）以 p 百分比表示，则定义 Dr 为 pE'/200。最后如果化合物 C 是 Time Reference Compound（时间参比化合物）则令 D = Dr，否则令 D = Dn。然后化合物 C 的 Recognition Window（识别窗口）Q 可以定义为

max {0, E' - D} : E' + D

注意包含一个化合物 C 的目标信号峰的色谱峰组的保留时间必须包含在 Q 和 R 范围内（更正确的包含在信号相关窗口两端扩展 Q 的范围内）。

色谱峰组选择和鉴定。此时色谱峰组检测和选择可以开始了。仅考虑色谱峰组列表中组保留时间在 Q 内的色谱峰组。注意所有这些谱峰保留时间在范围 R 内，因为谱峰仅在目标化合物的提取信号中被找到，且信号提取在时间范围 R 内取得。每个包含一个目标信号峰的时间范围 Q 内的色谱峰组被认为是一个“匹配项”或“命中项”。

对于所有命中项，目标峰保留时间同积分基线和响应数据一起保存在一个 Quant Hit Record（定量命中项记录）中。如果在这个目标化合物条目中 Quant By Height（通过高度定量）被启用，保存的响应为峰高，否则的话为峰面积。另外对于所有带特征信号的目标化合物的项目，合格率根据用户对 Subtraction Method（扣除方法）的选择来进行计算。

作为合格率满足质量的度量的 Q 值。对于所有命中项，Q 值如下所述来计算。对于没有特征信号的目标化合物项，Q 值定义为 100。对于有 n 个特征信号 qi 的目标化合物项，1 <= i <= k，定义 ri 为特征峰 qi 与目标峰的预期比例。然后定义 ri' 为由上述 Qualifier Ratio Computation（合格率计算）决定的观测合格率。现在定义总比例偏差 RD（将帮助屏幕最大化来阅读这个方程）：

RD = {100sum[(100*abs(Ri-Ri’))*(ln(100*Ri+1))^2/21.3]}/sum[Ri]

然后 Q 值为最接近 max {100 - D, 1} 的整数。

合格率通过/不通过测试。把所有命中项提交到一个 ri'（由用户的 Ratio Method（比例方法）选择而决定）与 ri 的合格率测试。对于每个特征 qi 用户指定了一个百分比不确定度。令 ui 将百分比不确定度表示为比例而不是百分比；例如，如果 qi 的百分比不确定度为 30% 则 ui 为 0.3。每个目标化合物项可以这样设定为所有目标化合物的 ui 为 Absolute（绝对）或者 Relative（相对）。如果选择了 Absolute（绝对）选项，则可接受的合格率范围 Zi 由下面给出

max {ri - ui , 0 } : min {ri - ui , 60}

如果选择了 Relative（相对）选项，则可接受的合格率范围 Zi 由下面给出

max {ri (1 - ui ) ,0 } : min {ri (1 + ui ), 60}

注意系统的合格率 ri 极限为 60 或 6000%。通过/不通过测试很简单如：如果对于所有 i，ri’包含在 Zi 中这样 qi 存在，则测试通过；否则不通过。


峰纯度显示

峰纯度显示包含三个窗口。

  • 窗口 [1] 处于屏幕左下方。显示色谱峰。窗口 [1] 显示色谱 (TIC) 中的峰。如果积分了一个完整色谱，峰纯度显示以色谱中第一个被积分峰开始。如果手动积分了一个单峰，峰纯度显示显示该峰。如果从色谱中选择了一个光谱，它将在窗口 [1] 中显示。

  • 窗口 [2] 处于屏幕上方。显示峰的主要提取离子色谱。

  • 窗口 [7] 处于右下方。提供了关于谱峰中组分的详细信息。这些详细信息包括保留时间和由峰纯度工具检测的可能组分的主要离子。报告的扫描次数是接近峰顶点出现位置的插入值。

窗口 [7] 也允许选择要查看的谱峰。光标处于窗口 [7] 时，它成为双头箭头。双击鼠标右键使显示的峰右移。双击鼠标左键使显示的峰左移。按住“Shift”键并双击鼠标按钮按鼠标按钮的方向移动到下一个多组分峰（左移使用左键而右移使用右键）。


峰宽

色谱峰宽，通常在其峰高一半时测得，以时间的单位（秒或分钟）计。

Minimum Peak Width（最小峰宽）越高，Data Rate（数据采样频率）越低。


谱峰过宽

使用手动调谐程序使峰变窄并查看是否前体减少。


谱峰过宽或过窄

检查临近峰的分辨率。非常宽的峰有时导致高于正常的同位素比例或同位素遗失。非常窄的峰有时造成低于正常的同位素比例。


对等结构网络

Windows NT、Windows 95 和 Windows for Workgroups 可以用在与其他电脑的对等结构配置中或用于访问一个服务器。对等结构网络是没有专门服务器的网络。这种配置中每个节点与网络中的其他节点共享资源。

共享磁盘配置

Report Manager（报告管理器）要求方法和数据文件必须能被生成报告请求和处理请求的计算机访问。

包含方法和数据文件目录的驱动器必须被共享。共享驱动器名称必须同该驱动器卷标相同。所有 Report Manager（报告管理器）使用的共享驱动器必须有一个唯一名称和卷标。

使用文件管理器或资源管理器来共享一个驱动器或改变卷标。

另见

Example（示例）

对于 Windows NT 使用，远程 Report Manager（报告管理器）需要 对 NetDDE 服务额外配置以正常工作。特别的：

  1. 运行 winnt\system32\ddeshare.exe。

  2. 在 Shares（共享）下面，选择 DDE Shares（DDE 共享）。

  3. 使用 Add a Share（添加共享）按钮来添加两个共享：

    Share #1

    共享名称： REQUEST$

    静态： REQUEST

    主题名称： FORM2

    Share #2

    共享名称： REQUEST1$

    静态： REQUEST

    主题名称： FORM3

  4. 输入新共享的信息后，设定 Permissions（许可）（每一个！！），并选择 OK/OK。

  5. 选择刚添加的共享名并单击 Trust Share（真实共享）按钮。

  6. 选择 Initiate to Application Enable（初始化程序）并单击 SET（设定）按钮，然后单击 OK/OK（确定/确定）。

    对于每个共享都必须这样做。必须使每台 PC 上的用户名称与帐号、组等匹配。如果匹配失败就必须对 Report Manager（报告管理器）发出的 每条 NET DDE 命令提供网络密码。每台 PC 的 Reprt Manager Name（报告管理器名称）必须与用于网络中的机器名称相同。


根据保留时间的百分比报告

根据保留时间分类的面积百分比报告。定量数据库中的数据用于产生和积分离子色谱，然后使用积分结果产生此报告。


百分比报告 - 定义

Percent Report（百分比报告）提供色谱中积分峰相对大小的信息。


百分比报告选项

分类

选择下列选项之一来对结果进行分类并将其显示在报告中：

  • Retention Time（保留时间）谱峰以保留时间增加的顺序列出。在每个时间内，列出每种处于该时间的信号类型（质谱或 TIC）。

  • Signal（信号）对于每种信号类型，谱峰以保留时间增加的顺序列出。

输出对象

选择一个或多个百分比报告的对象：

  • 选择 Screen（屏幕）让报告在屏幕上显示。

  • 选择 Printer（打印机）将报告送到打印机。

  • 选择 File（文件）将报告送到指定文件。

积分参数文件

要指定一个积分参数文件，输入 RTE 积分参数文件或化学工作站事件文件的名称（输入 ？来获取有效事件 (.E) 文件列表）。

如果文件没有指定：

  • 如果使用 RTE 积分器，色谱使用系统缺省 RTE 积分参数（而不是 TE Integration Parameters（RTE 积分参数）对话框中指定的参数）进行积分。

  • 如果使用化学工作站积分器，色谱会自动积分（使用 AUTOINT 命令）。


PFDTD — 定义

PFDTD（全氟二甲基三氧化十二烷）可以用了作为 5973 MSD 上的 CI 自动调谐的调谐化合物。CI 调谐观察下列离子：

PCI 模式

NCI 模式

离子(amu) | 化合物 | 离子(amu) | 化合物
41 | 甲烷 | 185 | PFDTD
267 | PFDTD | 351 | PFDTD
599 | PFDTD | 449 | PFDTD


PFTBA — 定义

PFTBA（全氟三丁基胺）用作所有 GC/MS 自动调谐的调谐化合物。它包含 31、50、69、100、131、219、264、414、464、502、576 和 614 amu 的离子。


PFTBA（阀）

PFTBA（阀）指用于调谐化合物 PFTBA 的校准阀。阀可以打开或关闭。


光电倍增管

要打开光电倍增管，在复选框中加上 X。

要关闭光电倍增管，去掉 X。这会关掉通向光电倍增管的高压。在这种状态下，将 PMT 暴露在室内光线下会很安全。

注意

直接曝光会降低 PMT 的性能。


图形

使用 Plot（图形）对话框来选择要在图形上观察的仪器参数。同时只能显示最多五个。要选择一个仪器参数，在它的复选框中加上 X。（变灰的仪器参数不是当前仪器配置的一部分。）化学工作站可以绘制下列设定值：

Temperature（温度，以 [image] C 为单位）

  • 辅助通道（仅热辅助通道 #1 和 #2）：3 个温度梯度

  • 检测器：恒定值

  • 进样口（冷柱头）：3 个温度梯度

  • 进样口（吹扫填充和分流/不分流）：恒定值

  • 柱箱：6 个温度梯度，加上一个后运行阀

压力（以 psi/kPa/bar 为单位）

  • 辅助通道（仅压力辅助 #3，#4 和 #5）：3 个压力梯度，加上运行时间表事件

如果辅助通道连接到色谱柱，GC 将不使用压力梯度且化学工作站不会绘制程序压力设定值。

  • 色谱柱（仅适用于 EPC）：3 个压力梯度，加运行后阀（如果色谱柱处于流量模式，化学工作站会计算图形值）

如果色谱柱未被定义，化学工作站不会绘制压力设定值。

流量（以 ml/min 为单位）

  • 色谱柱（仅适用于 EPC）：3 个流量梯度，加运行后阀（如果色谱柱处于压力模式，化学工作站会计算图形值）

如果色谱柱未被定义，化学工作站不会绘制流量设定值。

速度（以 cm/sec 为单位）

  • 色谱柱：由压力和/或流量设定值计算的线速度

如果色谱柱未被定义，化学工作站不会绘制速度设定值。

确定/取消/帮助按钮


活塞速度

选择 Fast Plunger（快活塞）或 Slow Plunger（慢活塞）速度

本对话框中其他项目：

Viscosity（粘度）

Sampling Depth（进样深度，不是对于所有进样器有效）

PreInjection Dwell（进样前停留，不是对于所有进样器有效）

PostInjection Dwell（进样后停留，不是对于所有进样器有效）

OK/Cancel/Help Buttons（确定/取消/帮助按钮）


amu 校准不良

使用手动调谐从上一次成功的自动调谐或手动调谐进入 amu 增益和 amu 补偿。这些值应该足够准确以允许 MSD 开始运行。


灯丝工作不良

  1. 在 Edit Parameters（编辑参数）窗口中，选择其他灯丝。

  2. 重新调谐 MSD。如果灵敏度增加，使用新灯丝。

  3. 方便时更换原来的灯丝。

有关更换灯丝的说明，请参见 MSD 硬件手册。


可能的时间事件

用于色谱中指定时间的积分过程控制的时间事件。时间事件在 Edit Integration Parameters（编辑积分参数）面板中安排。时间事件包括：

积分器

要查看当前内存中的所有积分事件（初始事件和时间事件），输入命令 TABULATE EVENTS。要去掉时间事件并重新设置初始事件，输入命令 CLREVENTS。

积分事件可以保存在事件文件中以便以后重新调用。

面积截除

输入 0 至 99,999,999 之间的面积阈值；缺省为 1。输入 0 至 650 分钟的时间值。

这个值指定了谱峰要包含在积分结果的最终列表中所必须具有的最小积分面积。任何检测到但面积小于此值的峰就不会进入报告。

事件列表中一直有一个面积截除的初始值 (Initial Area Reject)。另外，任何时间面积截除值都可以添加到列表中来改变这个参数在指定时间的值。

面积小于指定值的谱峰不会被保存、在计算中使用或在积分结果中报告。Area Reject（面积截除）事件通常可以编程，以便在运行过程中起作用，从而淘汰不需要的谱峰并报告样品中的组分峰。

Area Reject（面积截除）改变的时间规则为：

  • 非溶剂峰 AR 事件在峰的起始和结束之间的任何时间：改变后的值应用于整个峰。

  • 溶剂峰 AR 事件在峰开始后而在保留事件以前：改变后的值应用于溶剂峰和所有骑峰。

  • 溶剂峰 AR 事件在保留事件后但在溶剂峰结束前：原始值应用于溶剂峰；改变后的值应用于事件时间后的骑峰。

阈值也可以淘汰峰，但是不能用作运行确定的色谱基线。

面积求和开启/关闭

选择 Area Sum ON（面积求和开启）或 OFF（关闭），并输入合适的事件时间（0 至 650 分钟）。所有在面积求和打开和关闭之间时间内的峰被当作一个峰对待，并且把面积求和。

面积求和允许将一组临近峰的面积加在一起并将总值作为一个值报告。与此和相关的保留时间是求和事件起始（面积求和开启）和结束（面积求和关闭）之间的时间的平均值。

Area Sum ON（面积求和开启）和 Area Sum OFF（面积求和关闭）事件应该定时发生在基线上，如果可能的话。当他们必须发生在峰上时，使用这些规则：

  1. 如果 Area Sum ON（求和事件开启）事件发生在峰的起始位置和顶点之间，把整个峰包含在求和之中。如果发生在顶点和峰的结束位置之间，该峰被截除且面积求和立即开始。请参见下面所示的图形

  2. 如果 Area Sum OFF（求和事件关闭）事件发生在峰的起始位置和顶点之间，面积求和立即结束。这个事件发生的信号点成为 Valley Point（峰谷点）。如果 Area Sum OFF（面积求和关闭）事件发生在顶点后，事件延迟到该峰结束位置完成。请参见下面所示的图形。

当 Area Summation（面积求和）开启时，这些事件被忽略了：

  • Baseline Next Valley（下一峰谷为基线）

  • Baseline All Valleys ON/OFF（所有峰谷为基线开启/关闭）

  • Tangent Skim（切线斜滑）

  • Negative Peaks ON（负峰开启）

Baseline Now（现在调为基线）事件立即中止面积求和，不管信号是处于基线上还是峰上的某个位置。

所有峰谷为基线开启/关闭

选择来打开或关闭对所有检测峰谷的基线检测，并输入合适的事件时间（0 至 650 分钟）。

Baseline All Valleys ON（所有峰谷为基线开启）事件强制使基线通过所有峰谷点（还有任何其他可能发生的）直到被 Baseline All Valleys OFF（所有峰谷为基线关闭）事件取消。请参见下面所示的图形。这个事件可以使一系列谱峰升高，脱离基线上的宽峰。这是否对特定色谱有意义则取决于用户。

这样重复地重新设置的基线能截去峰的边角。这些边角成为负面积；减少谱峰的总测得面积。如果启用 Negative Peaks（负峰）被，或 Integrator ON（积分器开启）或 Area Sum ON（面积求和开启）事件在 Baseline All Valleys ON（所有峰谷为基线开启）事件之后，则基线不能重置。

基线返回

有时一个完美的合乎规定的谱峰会很快出现在基线干扰之后，而在此峰之前无法确定基线。当一个阀操作突然的改变了基线而一个峰突然开始时，这种情况可能出现。相似的情况在峰还在洗脱过程中就开始下一个分析时可能出现。

Baseline Back（基线返回）事件使一个峰具有根据该峰结束后的首个基线点绘制的水平基线。基线的结束位置和他的垂直位置由下一个基线点设定。它在峰的下面向后绘制直到峰开始的时间。请参见下面所示的图形。事件时间可以使峰上的任何位置。时间的允许范围为 0 至 650 分钟。信号处于基线上的话，这一事件被忽略。

基线维持开启/关闭

选择 Baseline Hold ON（基线维持开启）或 OFF（关闭），并输入合适的事件时间（0 至 650 分钟）。Baseline Hold（基线维持）打开时，从事件开始前的最后一个基线点开始绘制一条水平基线。这条基线维持到运行结束、Baseline Hold Off（基线维持关闭）或发生的其他重新设置基线的事件。请参见下面所示的图形。

如果事件发生时信号处于基线上，基线就简单的保持在该水平。而如果正在绘制峰形时，基线被修订为峰开始前的最后一个基线点的水平，即使这会造成基线贯串。

下一峰谷为基线

一个基线点被强制设为在指定的事件时间之后的下一个峰谷处。时间的允许范围为 0 至 650 分钟。Baseline Next Valley（下一峰谷为基线）时间是一个单时间点命令。它在下一个峰谷点执行并强制进行一次基线重新设置。同 Baseline All Valleys（所有峰谷为基线）时间一起时，不小心使用这个事件会导致负面积问题。如果 Negative Peaks（负峰）被启用，或 Integrator ON（积分器开启）或 Area Sum ON（面积求和开启）事件在峰谷前发生，则基线不能被重新设置。

设定当前为基线

输入想要强制设定的时间为基线的起点。时间的允许范围为 0 至 650 分钟。这会即时无条件地使得当前信号值重新设置为基线。

负峰开启/关闭

选择打开或关闭负峰检测，并输入合适的事件时间。所有处于负峰检测打开和关闭时间之间的负峰（处于基线以下）和正峰都会被检测。时间的允许范围为 0 至 650 分钟。

某些仪器，如液相色谱中使用的折射率检测器同时产生正负峰。化学工作站积分器指定来首先处理正峰数据。然而，负峰处理可以通过时间事件条目打开或关闭。如果有显著信号漂移的话，面积测量可能不正确。

负峰处理开启时，出现这些差别：

  • 基线被设置为 Negative Peaks ON（负峰开启）事件期间的基线水平。造成提供的信号斜率和曲率小。基线贯串校正关闭。

  • 高斜率和/或高曲率意味着峰的开始或结束。基线交叉标志着正峰和负峰的分离。

  • 溶剂检测关闭。

没有或几乎没有基线漂移，谱峰如下面图形所示被积分。所有面积以正数报告。

基线漂移能严重影响数据。在这个例子中，漂移非常严重以至于唯一能找到的基线点是由 Negative Peaks ON（负峰开启）和 Negative Peaks OFF（负峰关闭）事件强制产生的。系统绘制一条从 Negative Peaks ON（负峰开启）点到 Negative Peaks OFF（负峰关闭）事件的时间的水平线。这条线和信号的交叉点成为峰区边界。连接 Negative Peaks ON（负峰开启）和 Negative Peaks OFF（负峰关闭）点的直线成为基线。下面的图形显示了负漂移。

峰 1 从 Negative Peaks ON（负峰开启）点到 A 点。A 处的黑色区域被从峰面积中扣除因为它处于基线的另一侧。峰 2 从 A 点到 B 点。A 和 B 之间实际属于该峰的黑色区域没有被包含进去。峰 3 从 B 点到 C 点。它被减去了 B 和 C 之间的黑色区域。峰 4 从 C 点到 D 点。C 和 D 之间的黑色区域没有被包含进去。

漂移的净效应是低估了所有这四个峰，不管他们是正或负。理想的情况是，Negative Peaks ON（负峰开启）和 Negative Peaks OFF（负峰关闭）事件应该是定时发生在基线上。

Negative Peaks On/Off（负峰开启/关闭）应该只在非常必要的时候使用。当负峰开启时使用其他事件会导致意料不到的后果。强烈推荐不要与其他时间事件一起使用。

峰宽

输入一个用来作为鉴定峰的目标的新的峰宽（以分钟为单位）。可接受的范围近似的定为由峰宽值的 1/3 至 3 倍。这个参数的细微改变（小于 2 的因子）通常没有什么影响。宽度的允许值为 0.001 至 100 或 0。Zero (0) 允许积分器自动分配峰宽值。时间的允许范围为 0 至 650 分钟。

  • 输入 0 作为峰宽允许积分器自动分配它认为合适的峰宽值（通常称作自动改变）。

  • 峰宽时间事件停止自动峰宽更新。

峰宽定义为峰处于半高时的完全宽度。这个参数告诉积分器什么宽度的峰期望被找到。积分器使用这个信息来调节用于数据作为峰检测过程的一部分的平滑量。期望得到较宽峰时会进行更多的平滑。

在事件表中总是有一个峰宽的初始值。另外，任何峰宽时间事件的数都可以被添加到表中来改变这个参数在指定时间的值。

与 Integrator OFF（积分器关闭）或 Area Sum ON（面积求和开启）事件不兼容。

注意 宽度比指定峰宽值小的多或大的多的峰将不会被检测。谱峰的报告面积在这个参数变化时也可能变化。平滑数据的不同可能导致积分器选择略有不同的基线结束点。

溶剂峰开启/关闭

选择打开或关闭溶剂峰检测，并输入合适的事件时间。鉴定出溶剂峰，并且拖尾峰的边缘被切线斜撇分开。时间的允许范围为 0 至 650 分钟。

切线斜撇

输入一个时间来将下一个峰定义为溶剂峰。处于后缘的峰通过切线斜撇分开。事件时间必须输入在峰的开始时间和保留时间之间。时间的允许范围为 0 至 650 分钟。

溶剂峰可能上升太慢以致不易指认为溶剂，或在运行中有一组您认为应该作为溶剂处理的带有一些骑峰的峰。通常是一个合并峰组，其中第一个比剩下的要大的多。简单的画线处理会增强后面的峰，因为他们实际上处于第一个峰的尾部。将第一个峰强制指认为溶剂，组中余下的则作为尾部被撇去。请参见下面所示的图形。

Tangent Skim（切线斜撇）事件设定一个阱。该事件后的第一个峰将被指认为溶剂峰，无关他的大小形状和溶剂峰指认的通常测试。然后一旦 Tangent Skim（切线斜撇）事件发现了这个第一个峰，它会自动取消自己。

由于这个自我取消，Tangent Skim（切线斜滑）事件将仅使得一个峰作为溶剂。然而，如果在指定溶剂峰的尾部有好几个峰，他们全都会被进行切线斜滑，因为这是处理溶剂峰的通常方法。

阈值

输入一个从 -12 至 +25 的阈值。阈值范围为以 2 为底的对数，-12 最灵敏（最低阈值）而 25 最不灵敏（最高阈值）。将值增加 1 将使阈值加倍。时间的允许范围为 0 至 650 分钟。

同 Area Reject（面积截除）相似，阈值也可以淘汰峰，但不作为运行确定的色谱基线。高阈值通常比低阈值得到更少的接受峰。这个参数决定了信号要引发峰检测必须升多高（和多快）。

在事件表中总是有一个噪音阈值的初始值。另外，任何噪音阈值时间事件的数都可以被添加到表中来改变这个参数在指定时间的值。

积分器开启/关闭

选择 Integrator OFF（积分器关闭）或 ON（开启），并输入合适的事件时间。所有积分器关闭和打开之间的峰被忽略掉。时间的允许范围为 0 至 650 分钟。Integrator ON（积分器开启）或 OFF（关闭）定义了要忽略的信号部分。积分器可以关闭以将不需要的数据排除在积分和计算之外，如一些信号干扰或污染峰。保留时间时钟继续运行通过被排除区域，这样保留时间和时间事件才不会被改变。

如果 Integrator OFF（积分器关闭）事件在谱峰上发生，积分自动停止。根据上次确立的基线点创造一条水平基线，必要的话对贯串进行校正。（截除后的）峰如果保留时间在 Integrator OFF（积分器关闭）事件前将被保存。请参见下面所示的图形。

Integrator ON（积分器开启）事件将基线重新设置为当前信号并继续峰积分。积分器初始时设为 ON。


进样后停留

进样冲程后注射器针头应该在进样口停留的时间，以 1/100 分钟为单位。

有效输入值： 0.00 至 1.00

本对话框中其他项目：

Viscosity（粘度）

Sampling Depth（进样深度，不是对于所有进样器有效）

PreInjection Dwell（进样前停留，不是对于所有进样器有效）

Plunger Speed（活塞速度）

OK/Cancel/Help Buttons（确定/取消/帮助按钮）


预过滤器

使用 PBM 预过滤器可减少大大缩短检索时间而几乎不牺牲准确度。另见 U+A。预过滤器运行下列步骤：

  1. 给未知物光谱中的所有峰赋 U＋A 值。

  2. 以 U＋A 值降低的顺序排列谱峰。

  3. 选择在下列 U+A 值范围内的峰：

Max U+A >= Peak U+A >= (Max U+A - Delta U+A)

此处

“Max U+A”是未知物中的最显著峰形。

“Peak U+A”是当前讨论的离子

“Delta U+A”是一个 1 至 9 的值，可以在 Search Strategy（检索策略）对话框中同 U＋A 参数一起设定。

  4. 继续在步骤 3 中选择谱峰直到没有任何离子为止。

  5. 对于每个选定的峰，在质谱数据库中查找所有 MSP 与选定峰一致的光谱。

预过滤器的使用是可选的。要略过预过滤器检索整个质谱数据库，在 Search Strategy（检索策略）对话框中将 U+A 设定为 9。


进样前停留

进样冲程前注射器针头应该在进样口停留的时间，以 1/100 分钟为单位。

有效输入值： 0.00 至 1.00

本对话框中其他项目：

Viscosity（粘度）

Sampling Depth（进样深度，不是对于所有进样器有效）

PostInjection Dwell（进样后停留，不是对于所有进样器有效）

Plunger Speed（活塞速度）

OK/Cancel/Help 按钮


准备 GC（自动预运行）

准备 6890 GC（自动预运行）

当在不分流或直接模式下操作时，或正在使用载气节省时，气路设定值必须在每次运行开始前进行调节。这些气路调节在 6890 GC 进入 Pre Run（预运行）状态时发生。

当挥发物接口连接到 Headspace（顶空）、Purge and Trap（吹扫和捕集）或非安捷伦气体进样器时，必须对 GC 进行配置这样它在每次运行前自动进入 Pre Run（预运行）状态。

从 6890 GC 运行下列任务：

  1. 按下[Config] 键来查看可配置参数列表。

  2. 滚动到 Instrument（仪器）参数并按下 [Enter]。

  3. 滚动到 Auto（自动）预运行并按下 [On]。

注意 对于 MSD 不建议使用 Auto Prep Run（自动预运行）。典型进样口流量程序使用大于 2 ml/min 的脉冲流速。Auto Prep Run（自动预运行）被指定后，若仪器没有处于色谱运行中时进样口通常会保持在较高流速。高流速代表进入 MSD 的超出检测器的设计指定值的连续气流。在这种情况下可能禁止仪器调谐并且会增加真空系统的维护要求。


压力

如果手动调节冷柱头进样口压力，Pressure（压力）参数为灰（无效）。

要激活进样口 Pressure（压力），在 On复选框中加上 X。

使用 Setpoint（设定值）来指定流经进样口的气体压力（以 psi，bar 或 kPa 为单位）。

GC 传输的进样口 Actual（实际）压力是只读显示。

有效范围：

0 - 100 psi

0 - 690 kPa

0 - 6.9 bar

本对话框中其他项目：

Heater（加热器）

Gas（气体）

Mode（模式）

Ramps（梯度）


压力

如果色谱柱未定义，指定的值不会影响 Total Flow（总流量）。

如果色谱柱已被定义，且改变 Pressure（压力），化学工作站会重新计算 Total Flow（总流量）。

有关定义色谱柱的更多信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。

要激活进样口 Pressure（压力），在 On复选框中加上 X。

使用 Setpoint（设定值）来指定流经进样口的气体压力（以 psi，bar 或 kPa 为单位）。

GC 传输的进样口 Actual（实际）压力是只读显示。

Valid Ranges（有效范围）：

0 - 100 psi

0 - 690 kPa

0 - 6.9 bar

本对话框中其他项目：

Mode（模式）

Gas（气体）

Cryo Config（冷却配置）

Heater（加热器）

Ramps（梯度）

Total Flow（总流量）

GasSaver（载气节省）（如果色谱柱已被定义）


压力

Pressure（压力）

由压力传感器测量的色谱柱头压力。

压力也可在 Columns（色谱柱）对话框中设定。

如果色谱柱已被定义，可以在色谱柱对话框中设定色谱柱流量或平均线速度然后就会计算并显示出相应压力。

如果色谱柱未定义，Columns（色谱柱）对话框中只有压力参数是有效的。有关定义色谱柱的更多信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。

在进样时间内（仅用不分流或直接模式），不能输入压力设定值。

有关更多信息，请参见 Splitless mode pneumatics（不分流模式气路）、Split Mode Pneumatics（分流模式气路）或 Direct Mode Pneumatics（直接模式气路）。

Valid Ranges（有效范围）：

0.0 - 100 psi

0 - 690 kPa

0 - 6.9 bar

本对话框中其他项目：

Gas（气体）

Heater（加热器）

Total Flow（总流量）

plit Ratio（分流比）

Split Flow（分流流量）

GasSaver（载气节省）（如果色谱柱已被定义）


压力

由压力传感器测量的色谱柱头压力。

压力也可在 Columns（色谱柱）对话框中设定。

如果色谱柱已被定义，可以在色谱柱对话框中设定色谱柱流量或平均线速度然后就会计算并显示出相应压力。

如果色谱柱未定义，Columns（色谱柱）对话框中只有压力参数是有效的。有关定义色谱柱的更多信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。

在进样时间内（仅用不分流或直接模式），不能输入压力设定值。

有关更多信息，请参见 Splitless mode pneumatics（不分流模式气路）、Split Mode Pneumatics（分流模式气路）或 Direct Mode Pneumatics（直接模式气路）。

有效范围：

0.0 - 100 psi

0 - 690 kPa

0 - 6.9 bar

本对话框中其他项目：

Gas（气体）

Heater（加热器）

Total Flow（总流量）

Sampling End（进样端）

Purge Time（吹扫时间）

Purge Flow（吹扫流量）

GasSaver（载气节省）（如果色谱柱已被定义）


压力

Pressure（压力）

由压力传感器测量的色谱柱头压力。

压力也可在 Columns（色谱柱）对话框中设定。

如果色谱柱已被定义，可以在色谱柱对话框中设定色谱柱流量或平均线速度然后就会计算并显示出相应压力。

如果色谱柱未定义，Columns（色谱柱）对话框中只有压力参数是有效的。有关定义色谱柱的更多信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。

在进样时间内（仅用不分流或直接模式），不能输入压力设定值。

有关更多信息，请参见 Splitless mode pneumatics（不分流模式气路）、Split Mode Pneumatics（分流模式气路）或 Direct Mode Pneumatics（直接模式气路）。

Valid Ranges（有效范围）：

0.0 - 100 psi

0 - 690 kPa

0 - 6.9 bar

本对话框中其他项目：

Gas（气体）

Heater（加热器）

Total Flow（总流量）

Sampling End（进样端）

GasSaver（载气节省）（如果色谱柱已被定义）


压力

如果色谱柱未定义，指定的值不会影响总流量。

如果色谱柱已被定义，且改变压力，化学工作站会重新计算总流量。

有关定义色谱柱的更多信息，请参见 向目录中添加新色谱柱型号。

要激活 Pressure（压力），在 On复选框中加上 X。

使用 Setpoint（设定值）来指定气流压力（以 psi，bar 或 kPa 为单位）。

GC 传输的 Actual(实际)压力是只读显示。

有效范围：

0 - 100 psi

0 - 690 kPa

0 - 6.9 bar

本对话框中其他项目：

Gas（气体）

Air Cooling On（空气冷却开启）

Heater（加热器）

Ramps（梯度）

Total Flow（总流量）


压力

如果安装了 EPC 且色谱柱已被定义，进样口是压力控制的。（有关定义色谱柱的更多信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。）

要激活进样口 Pressure（压力），在 On 复选框中加上 X。

使用 Setpoint（设定值）来指定流经进样口的气体压力（以 psi，bar 或 kPa 为单位）。

GC 传输的进样口 Actual（实际）压力是只读显示。

有效范围：

0 - 100 psi

0 - 690 kPa

0 - 6.9 bar

本对话框中其他项目：

Heater（加热器）

Gas（气体）

Total Flow（总流量）（如果色谱柱已被定义）


压力

如果安装了 EPC 且色谱柱未定义，进样口是受压力控制的且指定值不会影响 Total Flow（总流量）。

如果安装了 EPC 且色谱柱已经定义，进样口可以是压力控制或流量控制的。如果改变压力，化学工作站会重新计算出总流量。

有关定义色谱柱的更多信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。

要激活进样口 Pressure（压力），在 On 复选框中加上 X。

使用 Setpoint（设定值）来指定流经进样口的气体压力（以 psi，bar 或 kPa 为单位）。

GC 传输的进样口 Actual（实际）压力是只读显示。

有效范围：

0 - 100 psi

0 - 690 kPa

0 - 6.9 bar

本对话框中其他项目：

Mode（模式）

Gas（气体）

Heater（加热器）

Total Flow（总流量）

GasSaver（载气节省）（如果色谱柱已被定义）


压力

色谱柱头压力（以 psi/kPa/bar 为单位）。

由 GC 传送的实际流量为只读显示。


压力

要激活压力辅助通道，在复选框 On 中加上 X。

使用 Setpoint（设定值）来指定流过辅助通道的气体压力（以 kPa，psi 或 bar 为单位－从 Options（选项）中选择）。

有效范围：

0 - 100 psi

0 - 690 kPa

0 - 6.9 bar

Low Pressure Channels（低压通道） [image] 如果安装了低压 (0 - 15.0 psi) 辅助通道，最大允许压力为 15.0 psi，不管 Setpoint（设定值）中如何指定。

GC 传输的辅助通道 Actual（实际）压力字段是只读显示。使用 Setpoint（设定值）字段来改变通道压力。

本对话框中其他项目：

Aux Channel（辅助通道）

description（说明）

Heater (thermal channels)（加热器（加热通道））

Cryo Focus Configuration（低温冷凝配置，选项无效）

Type (thermal channels)（类型（加热通道））

Gas (pressure channels)（气体（压力通道））

Ramps（梯度）


压力梯度

梯度色谱柱压力程序可以由最多 3 级（或“梯度”）组成来在运行中控制色谱柱头压力。化学工作站顺序执行这些程序梯度。一个程序包括：

  • 初始色谱柱压力，

  • 最多 3 个色谱柱压力梯度，和

  • 运行后色谱柱压力。

GC 将初始色谱柱压力保持指定时间 (Hold min)。然后压力以指示速率（以 psi，kPa 或 bar/min 为单位）改变到 Ramp 1（梯度 1）压力然后 GC 将该压力保持指定时间。用同样的方法可以程序设定 Ramps 2（梯度 2）和 3 的压力变化。最后，压力变为运行后色谱柱压力，GC根据保持“PostRun Hold min（运行后保持时间）”运行一定的时间。

梯度柱箱升温程序决定了运行时间长短。

如果梯度色谱柱压力程序比柱箱梯度升温程序长，压力程序将在柱箱程序结束时停止。这时，色谱柱压力返回并保持在程序初始压力。

如果色谱柱压力程序比柱箱程序短，辅助通道将保持它的最终程序梯度直到运行结束。

要查看色谱柱压力程序设定值的图形，单击“Plot...（绘图）”按钮并选择“Column #1 (#2 or #3) Pressure”：

指定梯度色谱柱压力程序的下列参数。有关详细信息，请单击绿色区域的任何部分：


压力梯度

梯度辅助通道压力程序可以由最多 3 级（或“梯度”）组成来在运行中控制通道压力。化学工作站顺序执行这些程序梯度。一个程序包括：

  • 初始辅助通道压力，和

  • 最多 3 个辅助通道压力梯度。

注意： 如果压力辅助通道连接到色谱柱，则不能使用 Aux（辅助）对话框来准备压力程序。使用运行时间表来安排压力变化（参见 Runtime（运行时间）。
运行中，可以编辑和下载压力梯度参数，除非辅助通道在补偿进样口流量（恒定流量操作）。这种情况下，压力参数为灰色（无效），不允许改变。

GC 将初始辅助通道压力保持指定时间 (Hold min)。然后 GC 以指示速率（以 psi，kPa 或 bar/min 为单位）改变压力到 Ramp 1（梯度 1）压力并将该压力保持指定时间。用同样的方法可以程序设定 Ramps 2（梯度 2）和 3 的压力变化。

程序压力改变造成辅助通道相应的流量改变。

柱箱温度决定了运行时间长短。

如果梯度辅助通道压力程序比柱箱梯度升温程序长，压力程序将在柱箱程序结束时停止。这时，辅助通道压力返回并保持在程序 Initial（初始）压力。

如果辅助通道压力程序比柱箱程序短，辅助通道将保持它的最终程序梯度直到运行结束。

如果同时使用梯度压力程序和运行时间表来程序设定辅助通道的压力设定值，且已选择显示该通道的压力设定值图形，设定值编程的组合结果将被绘制成图形。（有关更多信息，请参见 Runtime（运行时间）和 Setpoint Plots（设定值图形）。）

指定梯度辅助通道压力程序的下列参数。有关详细信息，请单击任何一项：

psi, kPa, or bar/min

Next psi, kPa, or bar

Hold min（保持时间）

Total min（总时间）是每个梯度的累计运行时间（由柱箱程序决定）的只读显示。

要查看辅助通道压力程序设定值的图形，单击 Plot...（绘图）按钮并选择 Aux #1 (#2 or #3) Pressure：


压力单位

选择当前方法中的压力测量值单位： kPa，psi 或 bar。

  • 1 kPa = 0.145 psi = 0.01 bar

  • 6.895 kPa = 1 psi = 0.06895 bar

  • 100 kPa = 14.504 psi = 1 bar

如果从一个单位变换到另一个单位，当前方法中的所有压力值会自动转换为新的单位下的等价值。

缺省压力单位： kPa

本对话框中其他项目：

Lock Keyboard（锁定键盘）

Column Compensation Detector（色谱柱补偿检测器）


将自定义报告打印到文件

现在可将在化学工作站的 Report Layout（报告设计）窗口中创建的自定义报告模板添加到 Specify Report（指定报告）对话框中的有效报告格式列表中。在此可将报告直接输出到文件，以便进一步由 EXCEL 或其他类似程序进行计算。


psi，kPa 或 bar/min

从一个程序梯度的“Next psi，kPa 或 bar”到下一个程序梯度的“Next psi，kPa 或 bar”的压力变化速率（以 psi，kPa 或 bar/min 为单位）。也称作“压力梯度”。

任何梯度速率为零时，禁止使用该梯度及其以后的梯度压力程序。


脉冲分流模式

PTV 进样口的 Pulsed Split（脉冲分流）模式类似于 Split Mode（分流模式），然而它允许注入较大量的样品。

脉冲分流模式通常用于：

  • 主要组分分析，主要用于可以允许使样品大部分从分流/吹扫口流失的高浓度样品。

  • 不能稀释的样品。

压力脉冲模式在运行开始前的瞬间增加进样口压力然后在指定时间后让它回到正常值。压力脉冲使样品从进样口冲出然后进入色谱柱的速度加快，降低样品在进样口分解的机会。脉冲也减少或消除了样品歧视。（如果色谱图因压力脉冲而受到影响，利用保留间隙可以帮助恢复峰形。）

可以在压力脉冲模式下进行色谱柱压力和流量编程。但是，压力脉冲优先于色谱柱压力或流量梯度。

设定脉冲分流模式的下列参数（有关详细信息，请在绿色区域上单击）：

（如果色谱柱已被定义）

有关定义色谱柱的信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。


脉冲分流模式

Pulsed Split（脉冲分流）模式（仅适用于 EPC）类似于分流模式，然而它允许进样较大量的样品。Pulsed Split（脉冲分流）模式通常用于：

  • 主要组分分析，主要用于可以允许使样品大部分从分流/吹扫口流失的高浓度样品。

  • 不能稀释的样品。

压力脉冲模式在运行开始前的瞬间增加进样口压力，然后在指定时间后使其恢复正常值。压力脉冲将样品扫出进样口，样品进入色谱柱的速度加快，从而降低了样品在进样口分解的机会。脉冲也减少或消除了样品歧视。（如果色谱图因压力脉冲而受到影响，利用保留间隙可有助于恢复峰形。）

设定 Pulsed Split（脉冲分流）模式的下列参数（有关详细信息，请单击绿色区域的任何位置）：

（如果色谱柱已被定义）

有关定义色谱柱的信息，请参见向目录中添加新色谱柱型号。

可以在压力脉冲模式下进行色谱柱压力和流量编程。然而，压力脉冲优先于色谱柱压力或流量梯度。


脉冲不分流模式

PTV 进样口的 Pulsed Splitless（脉冲不分流）模式类似于 Splitless Mode（不分流模式），然而它允许进样较大量的样品。脉冲不分流模式通常用于痕量分析。

压力脉冲模式在运行开始前的瞬间增加进样口压力然后在指定时间后让它回到正常值。压力脉冲使样品从进样口冲出然后进入色谱柱的速度加快，降低样品在进样口分解的机会。脉冲也减少或消除了样品歧视。（如果色谱图因压力脉冲而受到影响，利用保留间隙可以帮助恢复峰形。）

设定脉冲不分流模式的下列参数（有关详细信息，请在绿色区域上单击）：

有关定义色谱柱的信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。

可以在压力脉冲模式下进行色谱柱压力和流量编程。但是，压力脉冲优先于色谱柱压力或流量梯度。


脉冲不分流模式

Pulsed Splitless（脉冲不分流）模式（仅适用于 EPC）类似于 Splitless Mode（不分流模式），然而它允许进样较大量的样品。脉冲不分流模式通常用于痕量分析。

压力脉冲模式在运行开始前的瞬间增加进样口压力然后在指定时间后让它回到正常值。压力脉冲使样品从进样口冲出然后进入色谱柱的速度加快，降低样品在进样口分解的机会。脉冲也减少或消除了样品歧视。（如果色谱图因压力脉冲而受到影响，利用保留间隙可以帮助恢复峰形。）

设定 Pulsed Splitless（脉冲不分流）模式的下列参数（有关详细信息，请单击绿色区域的任何位置）：

有关定义色谱柱的信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。

可以在压力脉冲模式下进行色谱柱压力和流量编程。但是，压力脉冲优先于色谱柱压力或流量梯度。


泵

泵（预进样）

进样前注射器装入下一个样品的次数。对于每次抽样冲程，把注射器装满到最大体积的 8/10 （对于 5 ul 注射器为 4 ul，对于 10 ul 注射器为 8 ul），然后放空返回样品瓶。抽样时排除了空气气泡，能改善重现性。

有效输入值： 0 至 15。4 至 6 次抽样冲程通常足够。缺省输入为零。


泵

泵（预进样）

注射器在进样前装入下一个样品再放空返回样品瓶的次数。抽样时排除了空气气泡，能改善重现性。

这一操作仅用于一系列多次进样的第一次进样。

有效输入值： 0 至 15。4 至 6 次抽样冲程通常足够。缺省输入为零。


分流口吹扫流量

运行开始后需要打开吹扫阀时（也称作“吹扫时间”，以分钟为单位）吹扫放空的流量（以 ml/min 为单位）。

如果色谱柱未定义，也可以设定吹扫时间，但吹扫流量参数将变灰（无效）。

Purge Flow（吹扫流量） = Split Flow / Split Ratio（分流流量/分流比）

有效范围：

对于 N2 0 - 200ml/min 直到 0 - 999.9 分钟

对于 He、H2 0 - 1000ml/min 直到 0 - 999.9 分钟


分流口吹扫流量

Purge time（吹扫时间）是运行开始后电磁阀打开且从分流口继续吹扫的时间。Purge time（吹扫时间）设定值必须大于 Sampling End（进样端）设定值。

Purge flow（吹扫流量）是电磁阀打开且进样口在吹扫时流出分流口的流量，以 mL/min 为单位。

如果色谱柱未定义，可以输入一个吹扫时间值，但吹扫流量值是无效的。这种情况下，设定 Total flow（总流量）足够高以保证足够的色谱柱流量。将 Total flow（总流量）设定为高于色谱柱流量和隔垫吹扫 S 流量 (6 mL/min) 之和。

有效范围：

吹扫时间： 0 to 999.9 分钟

吹扫流量： 6 to 100 mL/min


分流口吹扫流量

运行开始后需要打开吹扫阀时（也称作“吹扫时间”，以分钟为单位）吹扫口的流量（以 ml/min 为单位）。

如果色谱柱未定义，也可以设定吹扫时间，但吹扫流量参数将变灰（无效）。

Purge Flow（吹扫流量） = Split Flow / Split Ratio（分流流量/分流比）

有效范围：

对于 N2 0 - 200ml/min 直到 0 - 999.9 分钟

对于 He、H2 0 - 1000ml/min 直到 0 - 999.9 分钟


不分流模式下的吹扫关闭时间过短

如果吹扫关闭时间太短的话，部分样品会在吹扫重新开启时丢失。延长吹扫关闭时间。


定量编辑菜单

CO Next Compound（转到下一化合物） | 显示文件中的下一个化合物。
Goto Compound（转到化合物） | 提示您输入希望查看的化合物编号。
Xpand Chromatographic Window（扩大色谱窗口） | 扩大提取窗口两分钟。
Original Chromatographic Window（原色谱窗口） | 从当前数据文件提取原色谱图，并将窗口重新设定到原时间范围。
Graphics Report to the Printer（向打印机发送图形报告） | 向打印机发送色谱图图形报告。
QDEL Compound（定量删除化合物） | 更改当前选择化合物的报告状态，从 Found（发现）到 Not Found（未发现）。
Next File（下一个文件） | 加载下一个数据文件。
Load Data File（加载数据文件） | 允许选择加载的数据文件。
Restart Quick QEdit（重新启动快速定量编辑） | 显示 Quick Qedit（快速定量编辑）窗口。
Abort Changes and Exit（终止更改并退出） | 退出 QEdit（定量编辑）模式，不在定量数据库中保存更改。
Exit and Save Changes（退出并保存更改） | 退出 QEdit 模式，用所做的更改更新定量数据库。


特征离子 — 定义

特征离子从目标化合物的质谱中选取。这些离子相对于目标离子以正确的量存在为目标化合物的正确鉴定提供了依据。依赖于您对峰选择参数的选择，特征离子可能影响到软件如何在匹配峰之间进行选择。


资格认证菜单

该菜单仅当系统配置 5973 MSD 时是可用的。

Checkout Tune（校验调谐） | 执行一个自动调谐。该调谐通常可用于检查系统。结果保存在一个 .CSV 文件中并用于 View Tunes（查看调谐）菜单项。
Tune Evaluation（调谐评价） | 评价最近的自动调谐（ATUNE.U）参数。当评价完成时，一份系统检验报告被打印出来。
View Tunes（查看调谐） | 允许您查看近来调谐的结果。
Sensitivity Check（灵敏度检查） | 使用 OFN_SN.M 方法执行信噪比性能检验。当测试完成时，结果被打印出来。
Software Validation（软件认证） | 执行软件认证并打印结果。
Installation Checklist（安装检查表） | 显示客户工程师用于安装您的系统的安装检查表。
Familiarization Checklist（熟悉检查表） | 显示客户工程师用于帮助客户熟悉其系统的检查表。
Checkout Tune（校验调谐）

必要时应进行调谐，可能在每天开始时，而且最后的调谐报告应保存在日志簿中。使用该信息检测调谐故障的开始以及监视电子倍增器和离子聚焦电压随时间的逐渐升高。这些报告有助于计划安排离子源清洗或倍增器更换。

既然优化一个参数会影响另一个的最佳设定，调谐需要几次反复。可被调节的参数有透镜、四极杆质量过滤器、电子倍增器、质量轴和峰宽校准。用于系统性能的调谐是自动调谐。

View Tunes（查看调谐）

通过添加每次自动调谐的结果到仪器配置编号目录中的 ATUNE.CSV 文件（例如，\MSDchem\1\5973\ATUNE.CSV），该模块允许您跟踪调谐参数随时间的变化。可以用表格、图表或一个单独参数的独立图表的形式查看并打印报告。必须运行自动调谐至少三次以提供绘图所需的最少的数据点。

Software Validation（软件认证）

该功能对于配置 5972 MSD 的系统不可用。当选择该项目时，就启动了数据分析的离线复制，同时 Software Validation（软件认证）报告被计算并使用 MSDchem\mssetup\data\evaldemo.d 和 database\demo.l 打印出来。下列报告作为 Software Validation（软件认证）报告的一部分使用 RTE 积分器和化学工作站积分器计算出来：

  • 面积百分比

  • 使用 demo.l 的谱库检索摘要

  • 定量摘要

Installation Checklist（安装检查表）

客户工程师使用该检查表确保仪器和系统被正确安装并在客户的实验室中按设计标准运行。正确安装是确保仪器和系统在长期使用中可靠运行的第一步。

客户应确保提供必需的操作备用品、易耗品和随使用而定物品如样品瓶、注射器和溶剂。在安装过程中一位客户代表应始终在场。

Familiarization Checklist（熟悉检查表）

客户工程师使用该检查表演示诸如使用标准样品或内部数据文件进行基本分析、评价结果数据和进行常规操作维护所必需的步骤。熟悉旨在给操作者一个新仪器、系统和应用软件的操作和维护的基本概况，它不是用来替代全面的操作员培训课程。

客户应确保提供必需的操作备用品、易耗品和随使用而定物品如样品瓶、注射器和溶剂。在熟悉过程中仪器的用户应始终在场，否则可能错过重要的关于操作和维护的信息。

Software Validation Report（软件认证报告）

当从“Instrument Control（仪器控制）”上选择 Qualify / Software Validation（资格认证/软件认证）时，计算并显示出下列报告。


定量化合物项目 — 第 3 页

这些是 Compound Entry（化合物项目）对话框第 3 页的字段：

Concentration / Response data（浓度/响应数据）

Integration Parameter File（积分参数文件）

Sum ?（求和 ？）

选择一个复选框将指定特征离子的响应与目标离子的响应相加。该方法仅在使用计算特征离子比的扩展面积定量方法（缺省）的面积定量中是有效的。

Area Correction Mass / Factor（面积校正质量/因子）

对于一个指定峰中存在的特定质量，通过扣除其面积的指定倍数来校正目标物的总响应。该方法仅在使用计算特征离子比的扩展面积定量方法（缺省）的面积定量中是有效的。

另见

定量化合物项目 — 第 1 页

定量化合物项目 — 第 2 页


定量化合物项目

定量数据库中每个化合物的项目由包含目标化合物分析所需的所有信息的三“页”组成。

第 1 页指定目标化合物鉴定的大部分必要信息。

第 2 页允许您使用定量数据库统一质量保证和质量控制所需的补充信息。这些项目可以从 Data Analysis（数据分析）宏或通过菜单和 Custom Reports（定制报告）软件的 CP 变量来访问。

第 3 页定积分参数文件并记录化合物的浓度级/浓度/响应数据。该信息用于目标化合物定量和生成校准曲线。

每一页均有按钮用于数据库导航。

  • Page（页）按钮让您移到指定页码。

  • Prev（上一个）和 Next（下一个）允许您在定量数据库中从一个化合物移到另一个化合物。

  • Plot（绘图）为当前化合物显示校准曲线（如果浓度/响应数据有效）。


定量化合物项目 — 第 1 页

这些是 Compound Entry（化合物项目）对话框第 1 页的字段：

（化合物）Name（名称）

Concentration Units（浓度单位）

Retention Time Information（保留时间信息）

Quantitation Parameters（定量参数）

Signals to be used for Quantitation（用于定量的信号）

Calibration Information（校准信息）

Copy/Paste Compounds（复制/粘贴化合物）

另见

定量化合物项目 — 第 2 页

定量化合物项目 — 第 3 页


定量化合物项目 — 第 2 页

这些是 Compound Entry（化合物项目）对话框第 2 页的字段：

Special compound attributes（特殊化合物属性）

Special reporting parameters（特殊报告参数）

User-defined items（用户定义项目）

另见

定量化合物项目 — 第 1 页

定量化合物项目 — 第 3 页


定量报告选项

Quant Report Options（定量报告选项）对话框允许您指定类型和定量报告的输出格式。


定量命令

下列命令可供与定量软件一起使用。可选参数显示在括号中 [ ]。有关特定命令的更多信息，请单击命令名称。

请另见 输入命令

ADDPEAKS 变量

CALIBPRINT x0, y0, x1, y1, 结果编号, "文件名", 标量

CLEARCPNDS [选项] [,模式]

CPDANALYZE [文件说明符对象] [,n]

DELLEVEL ["浓度级 ID"]

DLGQDBSETUP 代码

EDITCPNDS [变量 1] [,变量 2] [,n]

ENDSET [相关窗口]

EXPORTRSLT ["源文件"] [,"Excel 目标文件"] [,文件说明符对象]

GETCOMPOUND [类型] [,化合物编号] [,FULL]

GETRESULT , 结果编号, "文件名" [,FULL] [,匹配号]

LOADQUANTMETH

MI [变量], 时间 1, 时间 2, abund1, abund2 [,基线检查]

PUTCOMPOUND 化合物编号 [,INSERT]

QUANTPARMS 参比窗口尺寸, 参比窗口类型, 非参比窗口尺寸, 非参比窗口类型, 相关窗口, 倍增器, conc

QUANTRPTOPT [报告类型, 到屏幕, 到打印机, 到文件, "文件名", 生成报告, 化合物编号]

QUANTSAVE [路径] [,文件]

RECALIB "结果文件.RES" [,标量]

SETUPCALIB

STARTANALYSIS ["文件名"] [,标量]

STARTREPORT "结果文件名"

STARTSET 分类次序

UPDATECALIB ["浓度级 id", "浓度级文件名", ,,respact,,rtact,qiact]

UPDATERSLT 峰面积, 保留时间, 起始时间, 结束时间, 起始基线, 结束基线, 结果编号, "结果文件名", 命中号

VIEWCALCURVE


定量数据库 — 定义

定量数据库是进行定量分析所需要的信息和数据的集合。对于每个化合物，数据库包括校准表和提取和积分离子色谱必需的信息。来自校准表的校准曲线用于定量目标化合物。定量数据库是方法的一部分。


定量参数

Quant type（定量类型）

选择下列任意选项：

ISTD, not time reference（内标，无时间参比）（在此情况下，未调节保留时间漂移。）

ISTD, time reference（内标，时间参比）

Target compound（目标化合物）

Sample ISTD Concentration（样品内标浓度）

该字段仅当指定化合物作为 ISTD（内标）时存在。使用该字段指定样品中 ISTD（内标）浓度。

Measure response by（测量响应借助）

计算可以根据峰面积或峰高。

Ident by（识别对象）

这将指定如何选择多重命中的最佳命中用于定量： Meets qualifiers（符合特征离子），Best RT（最佳保留时间）；Largest area/height（最大面积/高度）；Best qualifier value（最佳特征离子值）；All hits（所有命中）。有关最佳匹配项选择的讨论，请参见 Target Compound Identification（目标化合物鉴定）。

可以使用 Calibrate / Update/Global Update（校准/更新/全局更新）为所有化合物重新设定 Identification Method（鉴定方法）。

Maximum Number of Hits（命中数目的最大值）

指定了满足该化合物鉴定标准的最佳的 n 个峰。范围从 1 到 9。

Subtraction Meth.（扣除方法）

指定用于计算特征离子比的方法： 第一个和最后一个的平均值；第一个和最后一个中较低的；无扣除；扩展面积定量（仅用于峰面积定量）。请另见 Target Compound Identification（目标化合物鉴定）。

可以使用 Calibrate / Update/Global Update（校准/更新/全局更新）为所有化合物重新设定 Subtraction Method（扣除方法）。

对于混合模式定量（即带有 MS 确认的 GC 定量）扩展面积定量方法是首选的并将在校准设定过程中由软件设定。为混合模式定量选择其他本底扣除方法将导致特征离子比与定量信号不相关。


定量报告选项

Quantitation Report Options（定量报告选项）对话框（Quantitate / Report Options（定量/报告选项））指定来自目标化合物分析的定量报告的格式。一份定量报告可以由总离子流的图形表示，一份定量结果的表格摘要和一份表明一个化合物是否存在的详细图形报告组成。

对话框的左上方的字段包含将要打印的色谱的所有信息。右边栏中显示是否该字段仅影响报告的摘要部分或详细报告（图形部分）还是所有报告。可以从对话框设定的参数包括：

Graphics（图形）

Global Minimum Detection Limit（全局最小检测限）

Apply Sample Multiplier To（应用样品乘数到）

Summary Report Only（仅有摘要报告）

Detailed Report Only（仅有详细报告）

All Reports（所有报告）


定量分析 — 定义

定量分析即确定一个样品中存在的特定化合物的含量。在该分析进行前，必须设定一个包含待测定化合物的定量数据库。


启动快速冷却

激活低温（室温以下）操作以便在运行期间提供快速冷却。

该功能与 Cryo On（低温开启）是分离的。

快速冷却在 [image] C，室温设定值以上 55 [image] 摄氏度激活。该功能当需要最大样品输入时是很有用的，但它会使用更多冷却剂。快速冷却当柱箱达到其设定值后立刻关闭，如有必要转到 cryo（低温）模式运行。

使用 [image] C，室温设定一个有效利用冷却液的最佳温度。

C，室温 — 实验室内温度。该设定值确定了低温冷却激活的温度：

  • 常规低温操作在 [image] C，室温设定值以上 35 [image] 摄氏度激活。

  • 快速冷却操作在 [image] C，室温设定值以上 55 [image] 摄氏度激活。


快速低温冷却

激活低温（室温以下）操作以便在运行期间提供快速冷却。

选择 On（开）启用 Quick Cryo Cool(快速低温冷却）或 Off（关）禁用快速低温冷却。

室温设定值用于设定一个有效利用冷却液的最佳温度。该设定值确定了低温冷却激活的温度：

  • 常规低温操作在室温设定值以上 35°C 激活。

  • 快速冷却操作在室温设定值以上 55°C 激活。


快速定量编辑

Quick QEdit（快速定量编辑）窗口用于快速查找数据库中化合物以供编辑。双击 Quick QEdit（快速定量编辑）化合物列表中的任意化合物将在 QEdit（定量编辑）窗口中显示色谱包含该化合物的部分。

Quick QEdit（快速定量编辑）窗口中的按钮可进行下列任务：

Start（开始）

单击该按钮允许您通过化合物进行扫描。扫描开始于当前高亮显示的化合物并一直持续到单击 Stop（停止）按钮。每个化合物显示的时间长短使用下面介绍的 Configure（配置）按钮设定。

Stop（停止）

Stop（停止）按钮在 Start（开始）按钮被单击后方才显示。单击该按钮停止化合物列表的扫描并使当前化合物显示在 QEdit（定量编辑）窗口中。

Exit（退出）

关闭 Quick QEdit（快速定量编辑）窗口并退出 QEdit（定量编辑）模式。

Qdel

更改当前选定化合物的报告状态从 Found（发现）到 Not Found（未发现）。

Configure（配置）

允许您调节扫描中每个化合物显示的时间长短。


快速筛选器

Quick Screener（快速筛选器）窗口用于快速查找数据库中化合物以供编辑。双击 Quick Screener（快速筛选器）化合物列表中的任意化合物将在 Results Screener（结果筛选器）窗口中显示色谱包含该化合物的部分。

Quick Screener（快速筛选器）窗口中的按钮可进行下列任务：

Start（开始）

单击该按钮允许您通过化合物进行扫描。扫描开始于当前高亮显示的化合物并一直持续到单击 Stop（停止）按钮。每个化合物显示的时间长短使用下面介绍的 Configure（配置）按钮设定。

Stop（停止）

Stop（停止）按钮在 Start（开始）按钮被单击后方才显示。单击该按钮停止化合物列表的扫描并使当前化合物显示在 Screener（筛选器）窗口中。

Exit（退出）

关闭 Quick Screener（快速筛选器）窗口并退出 Quick Screener（快速筛选器）模式。

Qdel

更改当前选定化合物的报告状态从 Found（发现）到 Not Found（未发现）。

Configure（配置）

允许您调节扫描中每个化合物显示的时间长短。


快速设定...

Quick Setup（快速设定）提供一种自动方式用于准备包含所有必要内容的基本方法。当您更加精通化学工作站时，您将可能希望使用 Quick Setup（快速设定）进一步精炼和添加已经完成的项目。

当使用 Quick Setup（快速设定）时，当前加载方法中的设定将被取代为：

· 缺省方法中指定的设定和
· 在该过程中输入的任何设定值。

程序 [image] 准备一个使用 Quick Setup（快速设定）的方法：

  1. 从 Instrument（仪器）菜单中选择 Choose Quick Setup...（选择快速设定...）。化学工作站将显示一组四个对话框。

  2. 在其显示时阅读并回答每个对话框（有关更多详细信息，请单击下面各项）：

  • Column Connections（色谱柱连接）

  • Column 1/2 Information（色谱柱 1/2 信息）（只读显示）

  • Solvent Boiling Point（溶剂沸点）（当向一个不分流模式中分流 — 不分流进口或一个冷柱头进口进样时显示）

  • Front/Back Injector（前/后注射器）

单击 Back（后退）或 Next（下一个）按钮在对话框中移动。确信复查并核实所有项目。

  3. 完成时单击 Finish（完成）按钮。化学工作站将显示 Instrument Control（仪器控制）屏幕。

过程中此刻，化学工作站已经替换当前被加载方法中所有项目为缺省方法的仪器设定和您在步骤 2 中指定的项目。

  4. 如期完成整个过程，例如，单击 Apply（应用）、OK（确定）、Cancel（取消）、Help（帮助）或图标条上任意图标进一步修改您的选择。（有关更多详细信息，请参见按钮和图标条。）

欲保存当前被加载的方法，请使用 Save（保存）或 Save As（另存为）（文件菜单）。

起始柱箱温度的快速设定方法：

进口 | 柱箱温度 =
冷柱头 | 溶剂沸点
吹扫填充 | 50 [image] C
分流 — 不分流 |
分流模式 | 50 [image] C
不分流模式 | 溶剂沸点 — 30 [image] C

起始进口/检测器温度的快速设定方法：

 | 用于进样 | 未使用
进口 |  |
冷柱头 | 跟踪柱箱（请参见模式） | 与起始柱箱温度相同
其他 | 色谱柱温度最高值 — 25 [image] C | 与起始柱箱温度相同
检测器 | 色谱柱温度最高值 | 与用于进样的检测器相同

有关步进说明，请参见下列任务：

编辑方法

有关补充信息，请单击下列任意项：


快速调谐 — 定义

QuickTune（快速调谐）提供精细调谐，可确保获得合格的响应和分辨率以及精确的质量指认。只调节质量坐标轴、峰宽和 EM 电压；透镜不受影响。

它不调节三个调谐质量的相对丰度。只要这些相对丰度的数值合格（换言之，仪器几乎具有调谐过后的性能），那么 QuickTune（快速调谐）是日校准的首选方法。


梯度按钮

梯度的步长和范围在 Edit Ramp Parameters（编辑梯度参数）框（从 Tune（调谐）视窗中的 Ramp（梯度）菜单访问）中设定。结果以 SIM 丰度对所选参数的形式显示在图形区域。如果您选择的参数不是梯度可调的，将得到故障提示。

一条垂直线标志当前透镜电压。您可以通过左右拖动该垂直线为所选参数手动设定电压。（注意更改显示到 Ramp Parameters（梯度参数）框中指定的最近的梯度步长。滚动条显示 DAC [数模转换器] 步长最小值，这可能小于或等于梯度步长。） 对三个调谐质量重复地进行梯度运行。

  • 欲在当前调谐质量结束时停止梯度，请单击 Stop（停止）按钮。

  • 欲查看调谐质量的丰度比，请从 View（视窗）菜单选择 Expand（扩大）。


梯度菜单 — 目标调谐

Ramp（梯度）菜单允许您为推斥极、离子聚焦、入射透镜、入射透镜补偿和 X 射线（5973 MSD 上无 X 射线）进行优化设定。

当所选梯度完成时，将显示 Tune Ramp（梯度调谐）对话框可供复查结果，如果希望可选择不同数值。

  • 欲更改梯度参数，请选择 Edit Ramp Params（编辑梯度参数）。

  • 欲跨越质量范围最大化灵敏度，请选择 Maximize Sensitivity（最大化灵敏度）为 m/z 69 和 502 的最大丰度调节入射透镜补偿。

  • 欲为入射透镜补偿的动态梯度变化设定电压，请选择 Edit Dynamic Lens Ramping（编辑动态透镜梯度变化）。

  • 欲停止动态梯度变化，请选择 Disable Dynamic Lens Ramping（禁用动态透镜梯度变化）。


梯度菜单 — 调谐

Ramp（梯度）菜单允许您优化推斥极、离子聚焦、入射透镜、入射透镜补偿和 X 射线（5973 MSD 上未使用）的设定。

当所选梯度完成时，将显示 Tune Ramp（调谐梯度）对话框可供复查结果，如果希望可选择不同数值。

  • 欲更改梯度参数，请选择 Edit Ramp Params（编辑梯度参数）。

  • 欲跨越质量范围最大化灵敏度，请选择 Maximize Sensitivity（最大化灵敏度）为 m/z 69 和 502 的最大丰度调节入射透镜补偿。


梯度参数菜单 — CI 调谐 (5973 MSD)

5973 MSD 仅为 CI 配置。RampParam（梯度参数）菜单允许您为推斥极、离子聚焦、入射透镜和入射透镜补偿进行优化设定。

当所选梯度完成时，将显示 Tune Ramp（调谐梯度）对话框可供复查结果，如果希望可选择不同数值。

  • 欲跨越质量范围最大化灵敏度，请选择 Maximize Sensitivity（最大化灵敏度）为 m/z 69 和 502 的最大丰度调节入射透镜补偿。

  • 欲更改梯度参数，请选择 Edit Ramp Params（编辑梯度参数）。


梯度

可对 PCM 进行编程，使其具有一个初始温度和最多三个水平（或“梯度”）和平台，在与柱箱独立的温度下进行操作。可以选择 0.1 和 720°C/min 之间的速率。

柱箱程序确定运行的时间长短。

如果梯度进样口温度程序：

  • 比柱箱程序时间长，它将在柱箱程序结束时截止。

  • 比柱箱程序时间短，进样口将保持其最后程序温度直至运行结束。

为梯度进样口温度程序指定下列参数。有关详细信息，请单击下面各项：

C/min

下一个 [image] C

保持 min

只要在负温度梯度试图冷却进样口到柱箱温度以下，受热进样口就需要空气冷却操作。

本对话框中其他项目：

Gas（气体）

Air Cooling On（空气冷却开启）

Heater（加热器）

Pressure（压力）

Total Flow（总流量）


梯度

当一个冷柱头进样口处于 Ramped Temp（梯度温度）模式中时，您可以准备一个最多三个水平（或“梯度”）的程序，在运行中控制进样口温度以便其可以在与柱箱独立的温度下进行操作。化学工作站按照连续的顺序执行这些程序。一个梯度进样口温度程序包括：

  • 一个初始进样口温度以及

  • 最多三个进样口温度梯度。

单一梯度温度程序以给定速度升高初始进样口温度到一个指定最后温度并在该温度下保持规定一段时间。

多重梯度温度程序与其类似。可以对进样口编程从一个初始温度到最后温度，但在此期间具有不同的速度、时间和温度。也可以为温度降低又升高编程多重梯度。如果在低于 -20 [image] C 时操作，这是推荐模式。

在非常低的柱箱温度，进样口温度应至少高于柱箱温度 20 [image] C。这对于应付溶剂凝聚绰绰有余。

在温度高出室温很多时，对于正确的进样口温度控制，进样口应总保持至少高出柱箱 3 [image] C。

柱箱程序确定运行的时间长度。

如果梯度进样口温度程序：

  • 比柱箱程序时间长，它将在柱箱程序结束时截止。

  • 比柱箱程序时间短，进样口将保持其最后程序温度直至运行结束。

设定值范围

参数 | 允许设定值范围
梯度温度 无低温冷却 | 24 [image] C 到 450 [image] C
梯度温度 有低温冷却 | -40 [image] C 到 450 [image] C

为梯度进样口温度程序指定下列参数。有关详细信息，请单击下面各项：

C/min

下一个 [image] C

保持 min

总 min是为每个梯度水平累计运行时间（由柱箱程序确定）的只读显示。

欲查看绘图关于进样口温度设定值，请单击 Plot...（绘图）按钮并选择 Front (or Back) Inlet Temperature（前（或后）进样口温度）：

本对话框中其他项目：

Heater（加热器）

Gas（气体）

Mode（模式）

Pressure（压力）


梯度

Ramps（梯度）

程序温度挥发（PTV）进样口可以被编程具有一个初始温度和多达三阶（或“梯度”）及平台，在与柱箱独立的温度下进行操作。可以选择 0.1 和 720°C/min 之间的速率。

柱箱程序确定运行的时间长度。

如果梯度进样口温度程序：

  • 比柱箱程序时间长，它将在柱箱程序结束时截止。

  • 比柱箱程序时间短，进样口将保持其最后程序温度直至运行结束。

有关详细信息，请参见 6890 操作手册第 5 章。

补充温度梯度

对于大多数意图，PTV 计划用于保持进样口衬管中的样品直至整个样品（可能有几次进样）被注射完。然后 PTV 被快速加热以转移样品到色谱柱。这可以由一个初始保持时间、一个单一梯度和结束时为完成样品转移的保持来实现。

两个补充梯度可供使用，它们有几个可能用途：

  • 进样口可被加热到高温用于热清洗衬管以备下一次运行。

  • 进样口可被向下编程（只需设定最后温度低于原温度）以减少进样口受热压力。

  • 向下编程可用于准备下一次运行的进样口。这对于更大量的样品输入会减少循环时间。

为梯度进样口温度程序指定下列参数。有关详细信息，请单击下面各项：

C/min

下一个 [image] C

保持 min

冷却进样口

样品可注射到一个冷却的或加热的进样口中。

设定值范围

参数 | 允许的设定值范围
无低温* | 0°C 到 450°C
CO2 低温 | -60 [image] C 到 450°C
液 N2 低温 | -160 [image] C 到 450°C

* 实际更低极限大约为室温 +10°C

只要在负温度梯度试图冷却进样口到柱箱温度以下，PTV 进样口就需要低温冷却操作。

尽管 GC 可以感觉到哪种冷却剂用于色谱柱柱箱，PTV 的低温操作信息必须通过 6890 GC 配置来应用。

有关更多信息，请参见 Cryo Config（低温配置）。

本对话框中其他项目：

Mode（模式）

Gas（气体）

Cryo Config（低温配置）

Heater（加热器）

Pressure（压力）

Total Flow（总流量）

GasSaver（载气节省）（如果色谱柱已被定义）


梯度

如果选择梯度压力作为色谱柱模式，您可以准备一个梯度色谱柱压力程序以控制运行中色谱柱柱头压力。

如果选择梯度流量作为色谱柱模式，您可以准备一个梯度色谱柱流量程序以控制运行中色谱柱质量流量。

有关详细信息，请单击下列各项：

Pressure Ramps（压力梯度）

Flow Ramps（流量梯度）

本对话框中其他项目：

Mode（模式）

Inlet（进样口）

Detector（检测器）

Outlet psi/kPa/bar（出口 psi/kPa/bar）

Flow（流量）

Installed Column（已安装色谱柱）

Manufacturer's Specifications/Column Dimensions（制造商规格/色谱柱尺寸）


梯度

您可以准备为每个热通道（#1 和 #2）准备一个梯度辅助通道温度程序，为每个压力通道（#3、#4 和 #5）准备一个梯度辅助通道压力程序。有关详细信息，请单击下列各项：

Temperature Ramps（温度梯度）

Pressure Ramps（压力梯度）

本对话框中其他项目：

Aux Channel（辅助通道）

Description（说明）

Heater (thermal channels)（加热器（加热通道））

Cryo Focus Configuration（低温冷凝配置）（选项无效）

Type (thermal channels)（类型（热通道））

Pressure (pressure channels)（压力（压力通道））

Gas (pressure channels)（气体（压力通道））


读/写 JCAMP 文件

如果在 Data Analysis - Parametric Retrieval Mode（数据分析 — 参数检索模式）窗口中选择 Library / Read JCAMP File（谱库/读 JCAMP 文件），您将被提示要求 JCAMP 文件名。缺省路径为 \MSDchem\msexe。当您提供一个有效文件名并单击 OK（确定）时，会提示您提供一个谱库名。如果谱库存在，您将被询问是否希望添加到其中。如果选择 No（不），您将再次被提示提供一个新谱库名。

一旦谱库被选择，程序自动翻译 JCAMP 文件中的谱图信息到 DOS 可编辑的谱库格式。在其他数据系统创建的用户谱库可以通过该工具导入。


实时绘图参数

MS 实时绘图（显示在下面）是当采集数据时绘制在 Instrument Control（仪器控制）面板的窗口中的一个或两个离子色谱图。

下列参数控制显示。

Time Window（时间窗口）

输入以分钟为单位的时间窗口值。这为实时绘图设定 X 坐标轴。如果总运行时间大于该值，绘图显示给定时间间隔，然后滚动 20% 显示下一个时间间隔。实时绘图显示和滚动的周期持续到运行结束。如果希望查看整个运行，使该项目和您的样品色谱运行时间（包括溶剂延迟时间）匹配。

MS 窗口 1 / MS 窗口 2

您可以定义两个窗口。每个具有依赖于扫描模式的特定的绘图类型。

Plot Type（绘图类型）

  • 在 Scan（扫描）模式中，您可以显示所有监测离子的总丰度（Total（总））或者一个指定质量范围内所有离子的总丰度（Extracted ion（提取离子））。选择 Extracted Ion（提取离子）时，面板的 MS Scan Parameters（MS 扫描参数）部分中该窗口的质量范围字段被激活，可在其中设定范围。

  • 在 SIM 模式中，您可以显示所有监测离子的总丰度（仅绘图 #1）或者一个单一离子的总丰度。对于每个 SIM 组，可以选择两个离子用于绘图，请参见 MS SIM 参数。

另见

显示 MS 实时图


再校准 — 定义

再校准用于补偿在更换 GC 色谱柱或执行一些维护任务后可能发生的系统性能的改变。为了再校准一个定量数据库，分析另外一个与原样品一样包含相同浓度、相同化合物的样品。新文件将包含基于新条件下更新的响应值和保留时间。使用这些数据来更新校准。


回收率极限

对于基质添加化合物（化合物类型 = M）和替代化合物（化合物类型 = S），计算一个回收率百分比。可确定回收率极限。可以为水和土壤基质分别确定极限。可确定的极限有：

Low（低）

最低可接受回收率百分比。

High（高）

最高可接受回收率百分比。

%Dev（％偏差）

基质添加和基质添加复制浓度之间的可接受百分比偏差最大值。

MDL（最低检测限）

最低检测限或是用常规的方法定义，或是用实验方法进行计算。

Data Analysis（数据分析）软件检查 Sample Log Table（样品日志表）中的 Sample Name（样品名称）和 Miscellaneous Information（其他信息）字段寻找单词“土壤”和“水”。如果发现它们中的一个，它就会为“水”使用基质 A 的回收率极限，为“土壤”使用基质 B 的回收率极限。如果软件未发现这些单词，它缺省设为基质 A 的回收率极限。Sample Name（样品名称）中的关键词优先于那些在 Miscellaneous Information（其他信息）字段中的。


参比流量，mL/min

在 On（开）复选框中加上 X，激活到检测器的参比载气流量。

GC 传送的 Actual（实际）流量是只读显示。

EPC 设定值： 0 到 100 mL/min


参比窗口/非参比窗口

用于确定是否在定量数据库中指定的峰存在于当前被处理的数据文件中。一个 5% 的窗口意味着被处理的峰一定具有在定量数据库中的时间 +/-2.5% 以内的保留时间。

参比窗口用于指定作为时间参比峰的内标。非参比峰用于所有其他化合物。


再点火按钮

如果检测器火焰熄灭但载气和空气流以及静电计还开着，Reignite（再点火）按钮将变为有效。

单击 Reignite（再点火）按钮，再次点燃火焰。


重新初始化 MSD 和数据系统之间的通讯

  1. 在 Diagnostics/Vacuum Control（诊断/真空控制）菜单中，从 Diagnostics（诊断）菜单选择 Initialize MS interface（初始化 MS 接口）。

如果没有重新建立通讯联系：

  2. 在配备扩散泵的 MSD 上，从 MSD 后面板断开 HIVAC POWER 电缆并等待 15 分钟。这会关闭扩散泵并允许其冷却但仍维持前级泵运转。

  3. 切断 MSD 电源开关（所有 MSD）。

警告！如果使用氢气载气，冷却所有加热区并关闭载气。

  4. 重新启动软件。

  5. 打开 MSD 并继续进行正常抽气过程。抽气过程应重建 MSD 和数据系统之间的通讯。


相对响应因子

相对响应因子是一个测定目标化合物响应相对于内标响应的无量纲量。

RF = (目标物面积 x ISTD 量) / (ISTD 面积 x 目标物量)


推斥极（参数）

Repeller（推斥极）设定推斥极（离子源的部分）的电压。推斥极具有正的电压，它排斥离子将它们推出离子源。

如果推斥极设定过低，过少的离子离开离子源，导致灵敏度差和高质量响应差。如果设定过高，将有过多的离子以过高的速度离开离子源。这会导致前体（质量过滤差）和低质量分辨率差。

MSD | MIN | MAX | STEPSIZE（步长）
5972 / 6890 | 0 | 42.84 | 0.168
5973 | -0.2 | 42.7 | 0.168


推斥极电压过高

高的推斥极电压可导致前体或使其更大。降低推斥极电压并查看是否前体减少。


推斥极电压过低

略微升高推斥极电压并查看是否灵敏度有所改善。


替换特征离子相对响应

将结果文件中所有鉴定的化合物使用新值替换原值。

从再校准的结果文件中的 Best Hit（最佳命中）更新比值。当数据文件按定量数据库完成定量时，就确定了 Best Hit（最佳命中）。在数据库项目第 1 页上的 Ident by（鉴定借助）字段确定了 Best Hit（最佳命中）的标准。


报告管理器菜单

下列菜单在 Report Manager（报告管理器）软件中有效。

File（文件）菜单

Refresh（更新）

Delete File（删除文件）

Exit（退出）

Options（选项）菜单

System Name（系统名称）

Report Manager Setup（报告管理器设定）

RTE Monitor（RTE 监测器）

UNIX Monitor（UNIX 监测器）

3365 Monitor（3365 监测器）

Peak - 96 Monitor（峰 — 96 监测器）

Import Data Monitor（数据输入监测器）

Help（帮助）菜单

Contents（目录）

About Report Manager（关于报告管理器）


报告格式

谱库检索报告格式

谱库检索报告包括来自数据文件的信息、检索参数和以选定格式显示的检索结果：

摘要格式

摘要格式提供每一个峰的命中项的列表。

详细格式

详细格式除列出峰的命中项外，还会显示被检索光谱及 #1 命中项的谱图。每一个峰都在新页上开始显示。


报告格式

所有的报告都包含 来自数据文件的信息。为了显示定量结果，请从以下的报告格式中选择其中一种：

根据保留时间确定百分比

摘要

详细内容（仅含文本）

详细内容

详细内容（单个化合物）


复位缺省值

以下参数的缺省值不复位：

5973 MSD | 5972
MS 温度 灯丝 直流电流的极性 | 灯丝 直流电流的极性

在配置了 5973 MSD 的系统中，选择该菜单项后将弹出一个对话框，让您在以下任何一种调谐方式下复位到厂商设定的缺省值：

Autotune（自动调谐）

Low Mass Autotune（低质量自动调谐）

Standard Spectra Tune（标准谱图调谐）

DFTPP Tune（DFTPP 调谐） BFB Tune（BFB 调谐）

Target Tune（目标调谐）


Reset EMF Counters（复位 EMF 计数器）对话框

在 Select EMF Action（选择 EMF 操作）对话框中选择 Reset Counters（复位计数器），将显示一个对话框。该对话框用于对以下各项复位计数器。例如，如果您更换了 GC 密封隔垫，请在 Septum (Injections)（密封隔垫（进样））框中将其计数器复位为 1 。然后，该计数器就会随每一次进样而不断累加，直至达到您在 Set Limits for EMF Parameters（设定 EMF 参数的极限）对话框中设定的极限值。

Septum (Injections)（密封隔垫（进样））

如果复选此框，GC 密封隔垫的计数器复位为 1 。

Liner (Injections)（衬管（进样））

如果复选此框，GC 衬管的计数器复位为 1 。

Number of Injections (Total)（总进样次数）

如果复选此框，总进样次数的计数器复位为 1 。

Pump Oil (Days)（（泵油）（天数））

如果复选此框，泵油的计数器复位为当前日期和当前时间。

另见

启动 EMF 实用程序

EMF 实用程序

在 EMF Parameters（EMF 参数）对话框中输入参数


残存水分或溶剂

对 MSD 进行放空操作时，水蒸气将进入 MSD 。对 MSD 的部件如离子源等进行清洁而没有妥当干燥时，溶剂将进入 MSD 。水分或溶剂将由真空系统逐渐抽出系统。增加离子源与四极轩质量过滤器的温度会加速水分与溶剂的排除。


目标化合物分析结果

结果报告主要以 Compound Entry（化合物项目） 对话框中第 2 页上输入的信息为基础。

CAS 号

Compound Type（化合物类型）

Matrix spike amounts（基质添加含量）

Matrix concentration limits（基质浓度极限）

User-defined values（用户定义值）

参比光谱名（第 1 页）

结果文件包含所有命中目标化合物项目与峰组的记录，相信与各自的命中目标化合物项目相对应。所用的文件名是 STARTANALYSIS 命令指定的文件名，该命令先于 Target Compound Identification and Quantitation (TCIQ)（目标化合物鉴定与定量）程序的执行。

结果记录与目标化合物项目相关。该结果记录包含目标化合物项目在执行 TCIQ 程序时的状态，以及最佳匹配结果信息（如果有的话！）。结果记录中还有一个指针，指向结果文件的 Overflow（过载）区域。它包含“所有”相对于目标化合物项目的额外峰组信息。当一个化合物有两个或多个命中项时，注意观察最佳匹配是否储存了两次：一次是在主结果记录中，一次是在 Overflow（过载）区域。


保留时间漂移——保留时间的缩短

随保留时间逐渐缩短而保留时间漂移

色谱柱变短

初始柱箱温度升高

色谱柱老化


随保留时间逐渐延长而保留时间漂移

如果所有峰的保留时间都延长，可能的原因如下：

色谱柱流量减少

初始柱箱温度降低

样品流路上存在活性点

进样口泄漏


保留时间信息

Ret. Time / RRT（保留时间/ RRT）

您可以在此处输入保留时间（单位为分钟）。如果仪器条件导致保留时间漂移，您可以使用 Calibrate（校准）/ Update（更新）/Global Update（全程更新）来调整数据库中所有化合物的这个字段。注意保留时间漂移值在千分位上截断。

Extract signals from（从...提取信号）

期望保留时间附近时间范围的缺省值在设定定量数据库全程变量时进行设定。输入以分钟为单位的时间范围或百分比，来定义适于峰两侧进行积分的基线。积分时，峰的开始/结束都必须落在此窗口中，否则将检测不到化合物。

该时间窗口转化为一个相对于期望保留时间的时间范围，单位为分钟。时间范围的相对值保存在处理方法中；如果在接下来的重新校准中发生峰保留时间的漂移，该窗口将与峰一起移动。

通过 Calibrate/ Update/Global Update（校准/更新/全程更新），您可以调整数据库中的所有化合物的提取窗口。

Ref Spec Name（参比光谱名）

参比质谱的名称。在以特殊格式报告时使用（参见化合物项目的第 2 页）。


保留时间锁定

在色谱系统中，与色谱柱有关的条件的改变在正常条件下将影响保留时间。保留时间锁定就是通过计算特定处理方法（色谱柱、流量设定值、柱箱参数）的特征，来忽略这些条件改变的一个方法。该方法首先要采集化合物（最好是保留时间已知的化合物）在当前方法中设定值附近不同进样口压力（-20% ，-10% ，标识值，+10% ，+20% ）条件下的数据。然后计算五次运行的结果，生成压力—保留时间曲线来表征某质谱仪的特点。从这个曲线计算锁定化合物在理想的时间内洗脱的压力，并将这个压力值保存为方法运行的压力。

如何

锁定 MS 处理方法

锁定 GC 处理方法

重新锁定处理方法

自动重新锁定处理方法

解除处理方法锁定

创建用户 RTL 筛选数据库

参见

保留时间锁定概述

RTLock Setup（建立保留时间锁定）视窗

结果筛选器

Retention Time Locking（保留时间锁定）菜单

Screen Database Update（筛选数据库更新）对话框

Select AutoRelock Mode（选择自动重新锁定模式）对话框

报告示例

术语表


自动重试

在没有用户干预的条件下，化学工作站将重试记录表中的上一次故障。如果没有重复出现故障提示信息，则可认为重试成功。


检索菜单（参数检索）

检索菜单

Search Parameters （检索参数） | 带您进入 Search Parameters（检索参数）对话框，从中选择谱库和参数检索中所使用的参数。
Select Library （选择谱库） | 让您选择用于谱库检索的谱库。显示当前可用谱库的列表。
Continue Results （继续检索结果） | 从谱库中的当前位置开始继续检索接下来的 N 个项目。在您进行一次检索时，将只检索最初的 N 个项目。

N 的值是由 Search Parameters（检索参数）对话框中的 Number of Hits to Retrieve（检索命中项数）设定的。Continue Results（继续检索结果）将显示下一组检索结果。这与 Parametric Retrieval Results（参数检索结果）中的 Search Next（检索下一组）按钮的功能相同。如果此按钮为灰，Continue Results（继续检索结果）将从头开始检索。


检查 6890 配置

在您将化学工作站配置到 6890 系列 GC 上时， 化学工作站将提示您输入 GC 的硬件配置信息。

化学工作站使用这些信息来：

  • 更新 GC 的缺省方法 (DEF_GC.M)，并

  • 妥善地操作您的仪器。

当前配置用图表为您总结为： 压力单位 确定压力值测定的当前单位 (kPa, psi, or bar)：

  • 1 kPa = 0.145 psi = 0.01 bar

  • 6.895 kPa = 1 psi = 0.06895 bar

  • 100 kPa = 14.504 psi = 1 bar

注意： 灰色图标表明该硬件可能已经安装，但现在还没有配置。

建议您检查配置的所有状态和设定值。若要开始此过程，请使用 Review Entire Configuration（检查所有配置）按钮：

化学工作站将为您显示一系列的配置对话框。检查每一个配置，并据您的知识进行最好的配置：

若要检查硬件项，请单击相应的图标。

根据您所进行的选择，化学工作站将显示配置对话框。检查对话框，并据您的知识进行最好的配置：

确定/帮助按钮


没有正确调节 RFPA

如 MSD 硬件手册中所述，调节（倾斜）RF 蛇管。


RT（保留时间）

此值是校准设定的一个组成部分。它是色谱或 Quant Setup（安装定量设定）程序中所选 GC 峰的保留时间。


RTE 积分积分器 — 定义

RTE 积分器是 GC/MS 数据的快速峰检测器和积分器。缺省参数假定要进行积分的数据是从毛细管色谱柱流出物在整个色谱范围内扫描数据的总离子流 (TIC)。如果选择了合适的积分参数，RTE 积分器能够进行 SIM 采集、处理积分对象，如在小的保留时间窗口检测内标等。


保留时间锁定菜单

View Current Method Setpoints（查看当前方法设定值） | 显示（如果可用）上一次 RTL 校准时保存在方法中的当前保留时间—压力值。
Calculate New Curve from Selected Peaks（计算选择峰的新曲线） | 对当前选择峰（保留时间—压力）执行二次拟合，并对选择峰 进行色谱相关检验（仅对 MS ）。
Restore Nominal Chromatogram（恢复标识色谱） | （MS 模式）重新显示标识运行。您可以通过单击、拖动等一系列鼠标右键操作选择您想要的峰。自动检测其余峰。在校准过程中，为节省磁盘空间而使用删除数据文件选项时，此菜单项失效。
Restore Startup Chromatograms（恢复启动色谱） | （GC 模式）重新显示所有 5 次运行。您可以通过单击、拖动等一系列鼠标右键操作选择您想要的峰。
Report RTLock Calibration（报告保留时间锁定校准） | 输出 RTL 校准和锁定（如果有的话）报告到显示屏。
Print（打印） | 让您打印屏幕上的图形。
Relock Method（重新锁定方法） | 重新锁定 所选择的方法。
AutoRelock Method（自动重新锁定方法） | 显示 Select AutoRelock Mode（选择自动重新锁定模式）对话框，从中可选择您中意的自动 RTL 重新锁定过程。 如果在方法定量数据库中没有“ R ”类型的化合物，AutoRelock（自动重新锁定)菜单项将呈灰暗色。此外，用于校准 RTL 处理方法的化合物必须存在，或已添加到指定的 RTL 重新校准样品中。
Unlock Method（解除方法锁定） | 对所选择的方法解除锁定。

色谱相关系数的极限为 0.8 ，低于此值，不进行校准计算（当您正试图锁定不同化合物的峰时）。二次拟合相关系数的极限值为 0.97 ，低于此值，系统提示您这可能是一个糟糕的拟合，但拟合方程依然能够进行保存。

您能将该方法锁定在这一点上；使用标识运行 (rtlock3.d) ，可以输入峰的理想的保留时间。基于峰的实际保留时间与理想的保留时间之间的差别，计算压力的建议使用值。

系统提示您删除源数据文件，以节省磁盘空间（仅对 MS 模式）。


运行时钟

Run Time Clock（运行时钟） | 当一个运行正在进行时，此时钟将显示自开始运行以来所经历的时间。此时，时钟累加。计划运行时间显示在此数字时钟的下方。 当没有运行在进行时，此时钟显示自上次运行结束以来所经历的时间，称为 后运行时间。此时，时钟递减。


运行单个化合物分析

若要使用方法运行单个化合物的分析，请在 Instrument Control（仪器控制）或 Top（顶部）视窗中选择 Method（方法）菜单，并使用以下选项：

Load（调用）

若您想使用与当前方法不同的分析方法，请选择此项。系统提示您先调用一个方法，然后选择 Method/ Run（方法/运行）。

Run（运行）

若您想使用当前方法，请选择此项。显示 Start Run（开始运行）对话框。若您在此框中单击 Run Method（运行方法），将出现顶部 status display（状态显示） ，最小化 Instrument Control（仪器控制）视窗。


样品

样品（进样前）

在进样前进行溶剂洗涤后，用下一样品清洗注射器的次数。每一次清洗，注射器都应充满十分之八的容积（对于 5 ul 注射器则为 4 ul，10 ul 注射器则为 8 ul)，然后将清洗液排空注入废液瓶中。

有效输入值： 0 到 15. 缺省值是零。


样品

样品（进样前）

在进样前进行溶剂洗涤后，用下一样品清洗注射器的次数。每一次清洗，注射器都应充满十分之八的容积，然后将清洗液排空注入废液瓶中。

仅适用于多次进样中的第一次进样。

有效输入值： 0 到 15. 缺省值是零。


样品 — 定义

样品是指将要注射到质谱系统的溶液。


样品携留效应

对显示在谱图中的前一样品的携留。

注射进样后，注射器的针头、活塞与针管间还会保留 0.6 到 1 ul 的样品。为了稀释、洗尽残存的样品，实验室惯例要求用溶剂和/或下一样品来洗涤注射器。


取样深度偏移量

针头端在样品瓶中的伸入深度（单位为 mm ）。要使得这项功能有效或失效，单击 Sample Depth Enable（采样深度有效）复选框，然后输入您想要的值。此值为零（缺省）是在标准位置，注射器针头端与样品瓶底部相距 3.6 mm 。

注意:采样深度偏移量项目是相对于标准位置而言的。

有效项目： -2.0 到 30.0

本对话框中其他项目：

Viscosity（粘度）

注射前针停留（只有部分进样器可用）

注射后针停留（只有部分进样器可用）

Plunger Speed（活塞速度）

OK/Cancel/Help Buttons（确定/取消/帮助按钮）


进样结束时间

气体进样设备中切换阀的压力扰动会导致色谱柱流率的波动。为对此进行补偿，在样品引入时控制接口处的流量。当开始引入样品时，用有效的压力设定值计算进样速率。

进样结束时间设定值要比进样器引入样品的时间长 0.2 分钟。例如，7694 顶空进样器有“进样时间”参数。该参数控制了进样阀保持在进样位置的时间。如果这个时间为 1 分钟，那么，适宜的进样结束时间设定值就应该是 1.2 分钟。

样品引入过程中，总流量与压力的设定值不能进行修改。

如果您采用梯度流量或梯度压力色谱柱程序（仅对已定义的色谱柱），则直到进样结束时间设定值间已经过去，压力或流量的调节方才开始进行。

在分流进样模式下，不存在进样结束时间设定值。


保存数据

若要保存信号数据，请选择 Save Data（保存数据）。然后选择：

  • All（所有）保存 entire run（整个运行）的数据。

  • Partial（部分）保存 Part of the run（部分运行）数据。指定 Start（起始） 和 Stop（结束） 时间（单位为 min)，指定两次保存数据采集的时间间隔。

一定不要 选择 Save Data（保存数据），如果您想对信号：

  • 在进行分析运行前，进行初始的空白运行来清理色谱柱，或

  • 保存基线图形以进行单柱补偿。

本对话框内容：

Source（源）

Data Rate（数据采样频率）

Minimum Peak Width（最小峰宽）

Calc Button（计算按钮）


保存文件

在化学工作站软件的不同位置，您都会得到提示要求输入文件保存的参数或数据。这些提示信息可能有几种形式：

  • 您输入文件名的文本框。

  • 包含当前文件的文件名文本框。文件的当前路径显示在文本框的上方，除非输入完全合格的文件名，否则系统将会采用当前路径。

您可以输入一个不同的文件名（最多 8 个字符）。如果您没有输入该文件类型所使用的扩展名，系统将会自动添加。

如果输入的路径或文件名无效，当您单击 OK（确定）时，将回到此对话框。

  • 从文件列表和目录列表中，您可以选择已经存在的路径、文件名或创建新的文件名。


保存方法

当您在 Instrument Control（仪器控制）或 Data Analysis（数据分析）中设定方法时，一定要在退出应用软件之前保存方法。在菜单条中选择 Method/ Save（方法/保存)。当前方法的名称显示在此编辑框中。您可以：

  • 保留当前方法的名称。

  • 输入另一方法的名称。

  • 输入一个新的名称。

当您单击 OK（确定），所有当前方法的参数保存到指定的方法中，新的方法成为当前方法。

当您想关闭此应用软件时，系统会提醒您保存所作的修改：

  • 如果您想放弃所作的修改，请单击 No（否）。

  • 如果您想保存所作的修改，单击 Yes（是）。


保存调谐参数值

当前调谐文件的名称显示在此文本框中。显示在文本框上方的路径是保存调谐参数值的唯一路径。

您可以输如一个不同的文件名（最多8 个字符）或从文件列表中选择一个文件名。如果您没有输入调谐文件的扩展名，系统将会自动添加（.U) 。

如果文件名无效，单击 OK（确定），不会保存调谐参数值。


标量变量（定义）

scalar variable（标量变量）赋值为实际值（与整数相对）。


扫描模式 — 定义

Scan mode（扫描模式）是一种数据采集技术，检测器在质量范围内从高到低进行扫描。当一次扫描完毕以后，系统复位并立即再次扫描此质量范围。运行过程中，扫描过程连续运行，除非是在 MSD 关闭，启动运行时的溶剂延迟时间内，才没有进行扫描。


筛选器菜单

筛选器菜单 — RTL

CO Next Compound （CO 下一化合物） | 显示文件中的下一化合物。您也可以在化合物信息窗口（窗口 #7）中双击鼠标右键来完成这一功能（要进入上一化合物在化合物信息窗口，请双击鼠标左键）。
Goto Compound （转至化合物） | 提示输入您想查看的化合物数目。
Xpand Chromatographic Window （扩展色谱窗口） | 将色谱窗口扩展两分钟（每个窗口一分钟）。当感兴趣的质谱峰位于窗口的边缘时，这个选项很有用处。 注意 如果您已经用鼠标对图形进行了放大操作，再用 XPand 功能，扩展的新窗口仍以原始数据为基础。而不是基于所查看的放大图形。
Original Chromatographic Window （原色谱窗口） | 从当前数据文件中提取原色谱，并将窗口重新设置为原时间序列窗口。
Graphics Report to the Printer （输出图形报告到打印机） | 将图形报告传输到打印机。
QDEL Compound （QDEL 化合物） | 将当前选择的化合物从 Found（发现）状态修改为 Not Found（未发现）状态。
Next File （下一文件） | 调用下一文件。
Load Data File （调用数据文件） | 让您选择要调用的文件。
Restart Quick Screener （重新启动快速筛选器） | 显示 Quick Screener（快速筛选器）窗口。
ReRun Screen （重新运行筛选） | 基于与处理方法相联系的筛选数据库，重新创建筛选结果文件。
Abort Changes and Exit （中止修改并退出） | 不保存对筛选结果文件所作的修改，退出 Results Screener（结果筛选器）模式。
Exit and Save Changes （退出并保存修改） | 用对筛选结果文件所作的修改更新筛选结果，退出 Results Screener（结果筛选器）模式。


检索参数

若要选择检索参数，在邻近参数检索的框中进行复选。只有复选框中选中的参数才能用于检索。所有检索到的谱库项目必须匹配所有的复选参数。因此，每一个复选框都有可能会减少命中项的个数。没有复选任何参数将检索整个数据库。注意检索过程中只会检索压缩光谱，也就是说象质荷比 28 等普通质量的光谱将会被忽略掉，不进行检索。

Chem. Name

CAS Number

Mol. Formula

Mol. Weight

Entry Number

Misc. Info.

Company ID

Melting Point

Boiling Point

Ret. Index

Ion Search

CAS 和 Entry Number（项目号）检索比其他检索方法快得多。应尽可能采用这两种检索方法。当您指定起始检索的项目号，检索结果也会以项目号的顺序显示。用 Ion Search（离子检索），而不指定项目号或 CAS 号，检索结果的顺序将是任意的。

Chem. Name（化学名）

输入您想检索的化学名的碎片。对数据库中的所有化学名进行检索；任何化学名中包含所选择的碎片，就是一个匹配项。这种检索方法不区分字母的大、小写。例如，要匹配 benzene ，可以输入字段 "eNe"。匹配项将有 benzene 和 ethylene。

CAS Number（CAS 号）

对于 CAS 号检索，可使用长型或短型数。例如，107211 与 000107-21-1 等价。

Mol. Formula（分子式）

输入结构式或经验式。输入的分子式将会转化为标准的经验式。检索中将此分子式与数据库中的分子式碎片进行匹配。该检索方法区分字母大小写 — Cl ，H ，C ，N 等。例如，输入 HHCHH ，它将会转化为分子式 CH4 。检索结果为甲烷、乙醇等。

Mol. Weight（分子量）

输入分子质量的范围以缩小检索范围。

Entry Number（项目号）

输入谱库中项目号的范围以限定检索范围。当您知道某化合物在谱库中的大概位置，或者您想从某一点开始进行检索时，这个参数非常有用。

Misc. Info.（其他信息）

对输入的字符串不区分大小写，进行检索。例如，如果输入字符串 "Red"，所有在 Misc. Info.（其他信息）字段中包含该字符串的项就是匹配项。

Company ID（公司 ID）

这种检索方法与 Misc. 相近似。都是信息检索，只不过这种检索方法是在 ID 字段进行的。

Melting Point（熔点）

输入所要检索的化合物的熔点的变化范围。注意：在一些数据库中并没有输入熔点信息。在这些情况下，-300.00 是缺省值。

Boiling Point（沸点）

输入所要检索的化合物的沸点的变化范围。注意：在一些数据库中没有输入沸点信息。在这些情况下，-300.00 是缺省值。

Ret. Index（保留指数）

输入所要检索的化合物的保留指数（保留时间）的变化范围。注意：在一些数据库中并没有输入保留指数信息。这部分信息是由每个实验室自己进行定义的。

Ion Search（离子检索）

输入离子质量和丰度的变化范围；丰度变化范围用百分比表示。只有在指定丰度范围内的离子光谱才会被检索到。最多可指定三个不同离子。注意：丰度范围 0% 到 0% 与 0% 到 100% 等价。

如果您要在未知光谱或参比光谱中匹配某些离子，这个参数就相当有用了。


检索结果（定义）

 检索结果指的是用 PBM 算法计算的定量结果列表，可用于进一步计算匹配质量。


检索策略参数

PBM 有好几种检索策略参数，通过精心预设参数值来在大多数情况下得到最佳检索结果。

U+A (2)

Flag Threshold（标识阈） (3%)

Minimum Estimated Purity（最小估计纯度） (50%)

Tilting（光谱倾斜）（开）

Cross-Correlation Sort（交叉相关排列）（关）

下面的任何参数对检索本身和检索的速度都不会产生任何影响。检索过程完成后将在检索结果列表中删除某些项目。

Low report MW（最低报告分子量） = 0

Low report MW（最高报告分子量） = 9999

Max hits（最大命中项数） = 20

Remove duplicate CAS numbers（删除重复的 CAS 号） = 关

若要查看或修改检索策略参数，请选择 Spectrum/ Edit Strategy（谱图/编辑策略）。

对该算法广泛的测试表明，缺省检索策略参数几乎总是能够得到 PBM 所能提供的最佳答案。也就是说，如果 PBM 没有得到期望的检索结果，那么将 U+A 参数值修改为 3，PBM 也不会检索得到预期的检索结果。同样的，关闭 Tilting（光谱倾斜）或 Minimum Estimated Purity（最小估计纯度）预过滤器也不会有多大帮助。但调节标识阈可能会使得 PBM 检索成功。

U+A

这是控制 PBM 预过滤器的一个参数，而 PBM 预过滤器决定了从谱库中检索出何种光谱，再由检索算法进行检验。

U+A 值可从 1 到 9 中取值，1 代表最快检索，而 9 则强制检索算法对整个数据库进行检索（也就是说，没有使用预过滤器）。缺省值为 2。

将此参数设为 1 将加速检索，但如果未知光谱与参比光谱有差异，则会增加遗失正确匹配项的可能性。如果未知光谱与参比光谱的差异是由仪器或仪器条件的误差引起的，那么将 U+A 设为 3 ，使检索算法依此参数进行检索，就很有必要了。

Flag Threshold（标识阈）

当用参比光谱的显著峰与未知光谱中相应离子质量进行比较时，如果未知光谱中某离子的相对丰度很低，那么该离子可能会发生标识错误。标识阈设置的丰度阈应低于标识不发生时的丰度。

例如，参数值为 3 意味着任何相对丰度低于 3% 的离子将不会标识为非匹配项。如果数据采集阈的设置高到能排除所有相对强度低于 5% 的离子，那么将标识阈也调节至 5% 是可取的。

变化范围是：0 - 99% ；缺省值为 3。

标识阈能用于调节 PBM 对低相对丰度离子的敏感度。PBM 对低强度离子非常敏感，如果在未知光谱中有好几个低强度离子丢失，那么可能检索不到正确的命中项，或出现错误的强度比。

Minimum Estimated Purity（最小估计纯度）

未知光谱的纯度是通过比较谱库的基峰与相应的未知峰而计算得到的。对于检索中所考虑的参比光谱，未知峰的相对丰度必须等于或大于指定的纯度值。

变化范围是：20 -80%；缺省值为 50%。

最小估计纯度 (MEP) 参数是在预过滤器从谱库中检索到参比光谱后，实际检索比较发生之前得到应用的。这个参数要求参比光谱中的基峰在未知光谱中能够找到，并且是处于用户指定的百分值。

例如，如果当前参比光谱中的基峰（相对丰度为 100% 的质荷比）是 质荷比 为 224 ，并且 MEP 设定为 50% ，那么 MEP 测试将快速检验未知光谱中质荷比为 224 的百分比。如果未知光谱中 质荷比 224 的相对强度大于 50% ，实际 PBM 检索比较将会进行；相反，如果其相对强度小于 50% ，将舍弃该参比光谱，检验另一参比光谱。

对于大部分的 GC/MS 分析，缺省值为 50% 的 MEP 成功地排除了将错误匹配项检索出来作为正确匹配项的可能性，而仍然保存了 PBM 在两个或多个组分混合物光谱中检索一个或多个组分的能力。

将 MEP参数设定为 80 会加速对数据库的检索，但如果参比光谱和未知光谱存在显著误差，可能会遗漏正确的结果。

Tilting（光谱倾斜）

当开启光谱倾斜时，检索算法通过放大参比光谱来适合未知光谱，以提高检索匹配项的可靠性。为做到这一点，检索算法先对参比光谱完成正常的粗略比较算法，然后使用二次方程放大参比光谱，用比较算法重新检验参比光谱。二次方程是由参比光谱与未知光谱的最佳拟合算法决定的。

缺省状态为开。对于大的 NIST 和 Wiley 质谱库，光谱倾斜将方便数据库的检索。当您对用户自建数据库进行检索时，关闭光谱倾斜能得到可以接受的检索结果。

Cross-Correlation Sort（交叉相关排列）

当交叉相关排列状态为开时，PBM 检索所得到的最可能命中项是通过正向检索 算法计算得到的，并将生成交叉相关系数。这个系数用于决定命中项列表中各项的显示次序。

正向检索算法要求未知光谱中的所有显著离子都出现在参比光谱中。

初始状态为关，PBM 检索结果各项以匹配质量排序。

Low report MW（最低报告分子量）

此处输入的数值设定了分子量阈。所有检索结果中分子量低于所输入数字的各项在结果列表中会被删除掉，不进入报告。

有效范围为 0 到 9999 。缺省值为 0 。

最低报告分子量是允许报告的最低分子量，而最高报告分子量则是允许报告的最高分子量。（如果最低报告分子量与最高报告分子量的值相同，则只会报告此分子量的化合物。如果最低报告分子量比最高报告分子量的值还大，那么 没有 可报告的结果。）

High report MW（最高报告分子量）

您在此处输入的数设定了一个上限。所有检索结果中分子量高于所输入数字的各项将在结果列表中被删除掉，不进入报告。

有效范围为 0 到 9999 。缺省值为 9999 。

Max hits（最大命中项数）

正常地，每次检索最多可返回 20 个命中项。修改这个参数，将改变检索可返回的最大命中项数。检索本身和检索速度不会受到影响。最大命中项数仅会影响报告中删除的命中项项数。

有效范围为 1 到 20 。缺省值为 20 。

Remove duplicate CAS numbers（删除重复的 CAS 号）

当您选择此对话框，对任何特定的化合物，仅报告最佳匹配项（由 CAS 号进行鉴别）。低匹配质量的重复匹配项将从检索结果中删除掉，不进入报告。重复项的删除是根据 CAS 号进行的，因此如果 CAS 号不相同，即使是同一化合物也不会被删除。


安全控制方法管理器

安全控制方法管理器允许监督员或管理员选择最多 6 个方法用于安全控制下的受限访问模式。

Show Secured Methods（显示安全控制方法） | 显示当前操作员可用的所有处理方法。
Remove Secured Method（删除安全控制方法） | 允许从安全控制方法列表中删除处理方法。
Add Another Method（添加安全控制方法） | 允许您从文件选择框中添加安全控制方法。
Sample Centric Method List（样品中心方法列表） | 如果该方法已经在样品中心方法列表中，这个选项允许您从该列表中删除方法。


选择 6890 GC 选定坐标优先对话框

6890 GC 检测器的动态范围超过了 Data Analysis（数据分析）中色谱对象的动态范围。因此，无论信号大小，都必须经过“剪切”后才能进行数据处理。

如果您想在分析中得到主要组分或溶剂峰的精确报告或定量分析，则应当选择第二选项 Clip small noise peaks（剪切小的噪音峰）。该选项将色谱数据进行选定坐标，以适合 Data Analysis（数据分析）对象。若选择了该选项，校准表中的响应将自动更新，反映数据的选定坐标。

5890 GC 和 35900 A/D 产生的数据文件没有超过色谱对象的动态范围，因此无需进行“剪切”。对于这些仪器，应选择首选项 Clip large solvent peaks（剪切大的溶剂峰）。


为计算分子量选择加合离子对话框

选择加合离子来用于计算分子量。若选择 Chromatogram/ Percent Report（谱图/百分率报告），并且当前数据文件是由 5973 MSD 的 PCI 模式采集得到的，就能进入此对话框。

为用于进行数据采集（仅对 PCI 模式)的反应气选择加合离子。分子量的计算值将出现在 CI Area Percent Report（ CI 面积百分比报告）的末端。


选择 CI 反应气 (5973 MSD)

选择 CI 反应气对话框

5973 MSD 仅对 CI 模式进行配置。 在 CI Tune（ CI 调谐）视窗中选择 Setup/ Select CI Gas（设置/选择CI 反应气），进入该对话框。

这个对话框用于选择您想要使用的反应气。大部分工作都采用甲烷作为反应气，但在您的应用中，样品的化学性质会决定最佳的反应气。对于 PCI 模式，样品的相对质子亲和力和反应气通常是最为重要的考虑因素。对于 NCI 模式，样品的电子亲和力和反应气通常是最重要的考虑因素。

有关更多信息，请参见 Chemical Ionization Mass Spectrometry ，by Alex. G. Harrison (CRC Press, 1992, ISBN: 0849342546).


选择清除选项

当您选择 Calibrate / Clear（校准/清除），将会弹出此对话框。

Clear Compound Responses（清除化合物响应）

从当前定量数据库中清除所有的响应数据，而保存样品总量及化合物数据。

Clear Calibration Levels（清除校准级数）

从当前定量数据库中清除所有的校准浓度（响应和样品总量数据），而保存化合物信息。

Clear All Compounds（清除所有的化合物）

从当前处理方法中清除整个定量数据库（响应、样品总量和化合物信息）。


选择要修改的计数器

通过对 File Counter（文件计数器）的重新设定，可以改变报告管理器分配的文件名的最后 1 或 2 位数字。

通过对 Vial Counter（瓶号计数器） 的重新设定，您可以跳过样品瓶架的位置，并可以改变报告管理器窗口的列表方式。


选择进样方式...

通过使用 Select Injection Source/Location（选择进样方式/位置）对话框来设定进样方式。选择以下任一选项（有关更多细节，请单击其中任何一项）：

GC Injector（GC 注射器） （对于配置了自动液体进样器的仪器）

6890 GC Valve（6890 GC 进样阀）（通常用于气体进样阀进样 — 参见Valves（阀） ，以获得详情）

Manual（手动）


选择积分器

Chromatogram/ Select Integrator（谱图/选择积分器） 允许您暂时选择一个积分器，不同于当前方法中指定的积分器。

要指定当前方法中采用的积分器，请操作以下步骤：

  1. 从 Calibrate（校准） 菜单中选择 Set Up Quantitation（设置定量模式）。

  2. 若要使用 RTE 积分器，在 Use RTEINT（使用 RTE 积分器）复选框中选中此项。否则，系统将会自动使用化学工作站积分器。

  3. 单击 OK（确定） 保存对积分器的选择。

  4. 选择 Method/ Save Method（方法/保存处理方法）。


选择标记和重绘总离子流色谱对话框

这个对话框让您选择您想使用的峰标记（如果有的话），然后用所选的峰标记重绘总离子流色谱。当您选择 Chromatogram/ Select Chromatogram Labels（谱图/选择色谱标记），进入此对话框。

No Labels（无峰标记）

无峰标记，重绘总离子流色谱。

Name if Quantitated (TIC Only)（对于定量报告，采用化合物名称作为峰标记（仅对总离子流色谱）)

采用化合物名称作为峰标记,重绘总离子流色谱。只有与定量结果中匹配的峰才进行标记。如果文件还没有定量，这个选项不起作用，信息栏显示定量文件没有找到的提示信息。

Conc if Quantitated (TIC Only)（对于定量报告，采用化合物浓度作为峰标记（仅对总离子流色谱）)

采用化合物浓度作为峰标记,重绘总离子流色谱。只有与定量结果中匹配的峰才进行标记。如果文件还没有定量，这个选项不起作用，信息栏显示定量文件没有找到的提示信息。

Type if Quantitated (TIC Only)（对于定量报告，采用化合物种类作为峰标记（仅对总离子流色谱）)

采用 Edit Compounds（编辑化合物）面板中第二页指定的化合物种类作为峰标记,重绘总离子流色谱。只有与定量结果中匹配的峰才进行标记。如果文件还没有定量，这个选项不起作用，信息栏显示定量文件没有找到的提示信息。

Abbr if Quantitated (TIC Only)（对于定量报告，采用化合物缩写作为峰标记（仅对总离子流色谱）)

采用 Edit Compounds（编辑化合物）面板中第二页的 A1 栏内容作为峰标记,重绘总离子流色谱。只有与定量结果中匹配的峰才进行标记。如果文件还没有定量，这个选项不起作用，信息栏显示定量文件没有找到的提示信息。

Retention Times (TIC or EIC)（采用保留时间作为峰标记（总离子流色谱或提取离子色谱）)

采用积分中的保留时间作为峰标记,重绘色谱图。


选择方法报告

当您选择 Data Analysis（数据分析）菜单中的Calibrate / List（校准/列表）时，将显示出此菜单。选择您想查看的方法的任何部分。您的选择将显示在 MultiVu（多重查看）窗口中。

Calibration History（校准记录）

选择 Calibration History（校准历史）生成两个报告，显示在 MultiVu（多重查看）窗口中。

Calibration Status Report（校准状态报告） | 选择校准状态报告，显示每一级校准的路径、文件名、采集时间、最后一次定量更新的时间、浓度更新的时间。
Audit Report（审核报告） | 该文本文件包含了对方法所进行的修改记录，包括： –修改进行的时间 – 所进行的修改 – 修改人 – 修改的严重性

Reporting Criteria（报告标准）

列出了详细报告可用的打印选项，它们由变量进行设定。

Quantitation Database List（定量数据库列表）

这是当前定量数据库中所有化合物的列表。该列表显示在 MultiVu（多重查看）窗口中，包括每一个化合物的峰号、定量离子、期望保留时间和保留时间上、下限。文本文件 list.txt 保存在当前方法目录下。

Calibration Report（校准报告）

显示数据库中每一个化合物的校准报告。

All the Above (to Printer)（输出所有以上各项到打印机）

输出所有以上各项到打印机。


选择主调谐梯度质量对话框 (5973 MSD)

选择最优化质量对话框

仅适用于为 CI 配置的 5973 MSD。当您在 CI Tune（CI 调谐）视窗中选择 Setup/ Select Masses（设置/选择质量），将显示一组对话框。

这个对话框用于选择您想优化的调谐质量（低、中、高质量范围）。您在对话框中所见到的值是在 Enter Tune Ion Masses（输入调谐离子质量）对话框中选定的。

自动调谐仅对甲烷有效，因此这个对话框对异丁烷、氨气或其他化合物无效。


选择输出报告到打印机选项对话框

当数据文件经过定量以后，您就可以检索非目标化合物了。那些化合物称作非目标质谱峰。用于检索非目标质谱峰的数据库和积分参数由参数文件，tic.val 进行设定。选择 Quantitate/ Report Non Target Peaks（定量/报告非目标质谱峰)，进入此对话框。这个选项仅在 Quantitation Report Option（定量报告选项） 对话框中已经选择 Include Non Target Peaks（包含非目标质谱峰)选项时方才有效。

该对话框包含两个选项:

  • Calculate/Generate Report（计算/生成报告）

  • Generate Report（生成报告）

如果文件还没有检索非目标质谱峰，则选择 Calculate/Generate Report（计算/生成报告）。如果文件已经检索了非目标质谱峰，只是您还没有用 Edit Non Target Peaks（编辑非目标质谱峰）功能编辑报告，则选择 Generate Report（生成报告）。


选择调谐文件对话框

仅对 5973 MSD 有效。在该对话框，您可以从可用调谐文件列表中选择一个调谐文件。当您单击一个文件名，还将显示储存在调谐文件中的各种设定值。

若要选定一个调谐文件，选择一个文件名（例如 STUNE.U ），然后单击 OK（确定）。


选择调谐类型对话框

在 Instrument Control（仪器控制）菜单条中选择 Instrument/ Perform MS Autotune（仪器/执行 MS 自动调谐），将会显示此对话框。Autotunes（自动调谐）使用 PFTBA 作为校准化合物，并自动调节 MS 参数来满足 EI 模式下操作的预定标准。这就叫调谐。如果您的系统配置的是 CI，通过此对话框您能够进入 CI 调谐面板。

选择您想执行的调谐类型。可用的调谐类型决定于您使用的 MSD 模式：

5973

Autotune（自动调谐）

Standard Spectra Tune（标准谱图调谐）

QuickTune（快速调谐）

Enter CI Tune Panel（进入 CI 调谐面板）

5972/6890

Max Sensitivity Autotune（最大灵敏度自动调谐）

Standard Spectra Autotune（标准谱图自动调谐）

QuickTune（快速调谐）

另见

Tuning for CI (5972 MSD)（CI 调谐 (5972 MSD)）

Tuning for CI (5973 MSD)（CI 调谐 (5973 MSD)）


选择更新选项对话框

这个对话框允许您选择以下选项：

Update One Level（更新一个浓度）

Quick LevelsUpdate（快速更新各浓度）

Global Update（全局更新）

Update Gasoline Amounts（更新汽油量）（仅对汽油分析模式）

该浓度下要添加或更新的校准样品的数据文件必须在启动 Calibrate/ Update（校准/更新）之前，进行调用和定量。如果您想在更新校准浓度数之前手动查看和编辑数据文件，请选择 Quantitate/ Calculate（定量/计算）对数据进行定量。然后选择 View/ QEdit Quant Result（查看/定量编辑定量结果）来查看结果。

Update One Level（更新一个浓度）

当您选择 Update One Level（更新一个浓度）时，将会显示 Update Calibration（更新校准）对话框，从中更新校准表。选择 Do Update（进行更新），将会读取校准样品的数据文件（包括任何手动的编辑）结果，更新校准表。

Quick Levels Update（快速更新各浓度）

Quick Levels Update（快速更新各浓度）提供了一次更新当前定量数据库中所有浓度的途径。当您选择此项，将会显示一组对话框。

Clear Responses First? （先清除响应?） | 更新一个浓度，当前定量数据库中该浓度的响应将会被新的数据文件的响应替换。 对此问题，如果选择 Yes（是），在添加新的响应前会删除所有的当前响应。这样的结果就是，如果新的数据文件丢失了当前数据库的某些组成部分，那么这些部分将不会出现在更新后的数据库中。 对此问题，如果选择 No（否），程序将用新的数据文件中的响应来替换原数据文件中的响应， 并保存当前数据库中存在而新的数据文件中所没有的组成部分。
Select Update Mode （选择更新模式） | 所有的选项包括 Single Datafile/Level（单个数据文件/浓度） 和 Multiple Datafiles/Level（多个数据文件/浓度）。若选择单个数据文件，每一个浓度的定量数据库将被单个文件的数据所替换。若选择多个数据文件，某一浓度的定量数据库可被多个数据文件的组合所替换。
Select Data File for Level （选择某浓度的数据文件） | 提示您选择一个文件或几个文件来更新每一个浓度的定量数据库。
Select Cal Level ID for RT Update （选择保留时间更新的计算浓度 ID） | 您所选择的校准浓度数将用于更新整个定量数据库的保留时间。

Update Gasoline Amounts（更新汽油量）

（仅对汽油分析模式）在显示对话框中，可以选择以下各项：

Individual Level Weights （各级权重） | 它们通常是从厂商所提供的标准化磁盘引入的。选择磁盘所在位置的驱动器，然后选择文件（该文件通常为 calamts.txt）。匹配 CAS 号或化学名中任一项的化合物将会插入其各自的含量。如果您想创建您自己的文件，请咨询 Agilent 技术分析顾问了解该文件所要求的格式。
Serial Dilution （连续稀释） | 在对话框中输入新的总权重。在定量数据库第二页的用户定制项目中，输入低于 N6 的每一个化合物的百分含量。


选择文件

移动鼠标指针到您想使用的文件，单击文件名选中该文件。选中的文件名显示在文本框中，位于文件列表的上部。

选择该文件

单击 OK（确定）。或者，您可以双击文件名，该文件就立即被选上了。

创建新文件

输入新的文件名，并单击 OK（确定）。

移动文件至其他目录

单击 [. .] 。

移动文件至其他驱动器

单击代表该驱动器的字母，如要移至 A 驱动器，单击 [-a-] 。


选择谱库

移动鼠标指针到您想使用的谱库，单击谱库名选中该谱库。选中的谱库名显示在文本框中，位于谱库列表的上部。

调用该谱库

单击 OK（确定）。或者，您可以双击谱库名，该谱库就立即被调用了。

移动谱库至其他目录

单击 [. .] 。

移动谱库至其他驱动器

单击代表该驱动器的字母，如要移至 A 驱动器，单击 [-a-] 。


选择报告系统

报告系统是配置在某一特定节点运行的过程。生成请求时，Data Analysis（数据分析）同时分配报告系统名。缺省配置为 RPT1 和 RPT2 。当请求添加到报告管理器，报告系统名用于确定最终目标和执行报告生成的过程。


选择积分器

可用的积分器有： 化学工作站积分器 和 RTE 积分器 。

对每一种定量模式，整个校准过程与未知样品的分析过程，都必须使用相同的积分器。

使用 RTE 积分器：

选择 Use RTEINT(使用 RTE 积分器)对话框。这是一个全程设定，不能对每一个化合物分别进行设定。如果没有选中此对话框，则使用的积分器为化学工作站积分器。

使用积分参数文件：

对于指定的积分器，在 Integration Parameter File（积分参数文件）文本框中输入积分参数文件的文件名。如果不指定积分参数文件，则化学工作站积分器使用保存在方法中的积分参数，RTE 积分器使用保存在当前方法中的积分参数。

在校准过程中，所有新的化合物的色谱由此处提供的信息进行积分。

你可以通过 Calibrate/ Edit Compounds（校准/编辑化合物）来对每一个化合物所使用的积分参数文件进行修改。您也可以对每一个信号所使用的积分参数文件进行修改（也就是说，对目标峰和每一个特征峰，即使是对同一化合物，也能使用不同的积分参数文件）。


半挥发性化合物

半挥发性化合物指的是能够通过有机溶剂萃取进行分析的化合物。半挥发性化合物也称作 base/neutral/acid（碱性/中性/酸性）(BNA 化合物）。


隔垫吹扫

隔垫吹扫管线接近样品引入的隔垫。少量的载气离开此隔垫吹扫管线吹扫出所有流失的样品，方便进样口压力的改变。

每一个进样口都有一个不同的隔垫吹扫流量。6890 GC 自动设定 EPC 进样口的隔垫吹扫流量，如果您有兴趣，可以在隔垫吹扫排空口处的多路连接管处进行测定。

Inlet（进样口） | Septum purge rate（隔垫吹扫流速）(mL/min)
Split/splitless（分流/无分流） | 3 到 6
挥发性化合物 | 3 到 6
PTV | 3 到 6
吹扫填充色谱柱 | 1 到 3
冷柱头进样 | 15 到 30


序列 — 定义

序列包含运行多个样品的信息。此信息输入样品日志表，其中必须包含进样的信息。

序列保存在磁盘上，在文件名后自动添加扩展名 .S。创建并保存序列后即可重新调用该序列，作为运行另一批样品的起始点。


序列文件示例

选择下面任一序列文件示例:

双塔序列

单进样口，单柱，GC 和 MS 检测器，数据文件目录


设定缺省按钮

单击 Set Defaults（设定缺省）按钮将所有的 Oven Cryo Option（柱箱低温选项）设定为缺省值：

  • 室温： 25 [image] C

  • 低温暂停： On（开启）

暂停： 10 minutes(10 分钟）

  • 快速低温冷凝： On（开启）

  • 冷却故障： On（开启）


设定提取窗口开始/结束

这些菜单项提供了正确的鼠标/键盘组合来设定峰的积分开始和结束时间。

  • 要设定开始时间 - 将十字放在正确的保留时间处，按住 Shift 并双击鼠标左键。在您单击标记提取窗口开始的地方会出现一个“S”。

  • 要设定停止时间 - 将十字放在正确的保留时间处，按住 Shift 并双击鼠标右键。在您单击标记提取窗口结束的地方会出现一个“E”。

如果想改变化合物的保留时间，通常应在 EasyID中调整提取开始和结束时间。如果在原始提取窗口以外移动保留时间而不通过重新设定开始/结束时间进行补偿，可能会出现故障。所有的提取窗口可以通过选择 Init Cal / Global Update / Set Extraction Windows（初始计算/全局更新/设定提取窗口）（在退出 Easy ID后）被重新设定为常数值。


设定覆盖参数

可以通过选择 Tools / Overlay Chromatograms（工具/覆盖色谱）显示相互覆盖的色谱。Set Overlay Parameters（设定覆盖参数）菜单项决定覆盖色谱如何显示。这里有三个可以调整的参数：

使用补偿

该参数允许将补偿打开或关闭。如果补偿打开，每个色谱的基线将从其他色谱得到补偿。原始色谱（在选择“覆盖色谱”前加载的色谱）不能补偿。

补偿模式

这一参数决定色谱采取绝对数量补偿，还是相对百分比补偿。百分比是基于原始色谱（在选择“覆盖色谱”前加载的色谱）中最高峰的高度的比值。

信号 1 数值

补偿决定色谱基线被补偿的量。通常，目标是得到足够的补偿从而能将色谱分离开来但又不会太多给比较它们带来困难。信号补偿的缺省值为 0（没有分离）。

如果选择了 Absolute（绝对值），这里输入的数值将为每个基线从前一个上得到的补偿的绝对量。原始色谱（在选择“覆盖色谱”前加载的色谱）的基线不能补偿。

如果选择了 Percent（百分比），这里输入的数值将为每个基线从前一个上得到的补偿的百分比。百分比是基于原始色谱（在选择“覆盖色谱”前加载的色谱）中最高峰的高度的比值。因此，如果信号补偿为 100 并且原始色谱中最高峰为 10000 个记数单位，则第一个色谱的基线将向上移动 10000 个记数单位，接下来的每个色谱也都向上移动 10000 个记数单位。

“坐标因子”是改变每个色谱坐标（原始色谱除外）的乘子。如果设定信号坐标为 10，除了原始色谱，所有的丰度均乘以 10。同理，如果信号坐标为 0.1，则除原始色谱以外所有丰度均为原来的1/10。信号坐标的缺省值为 1。

颠倒信号参比

选择这一对话框可以引起参比信号（在覆盖过程开始时加载的数据文件）在结果显示中被颠倒过来。

注选择覆盖色谱时加载的数据文件将不能被任何覆盖参数改变，也不能被自己覆盖。


设定定量分析

欲在方法中创建一个定量数据库时，选择Calibrate / Set Up Quantitation（校准/设定定量分析）。显示的对话框将引导您完成数据库需要的数据的输入。有关其他信息，单击对话框中的Help（帮助）。


设定程序温度挥发进样（PTV）

选择下列任务列表以帮助您完成 6890 PTV（程序温度挥发）进样的设定：

PTV 分流模式操作（w/ 已定义色谱柱）

PTV 分流模式操作（w/ 未定义色谱柱）

PTV 脉冲分流模式操作（w/ 已定义色谱柱）

PTV 脉冲分流模式操作（w/ 未定义色谱柱）

PTV 不分流模式操作（w/ 已定义色谱柱）

PTV 不分流模式操作（w/ 未定义色谱柱）

PTV 脉冲不分流模式操作（w/ 已定义色谱柱）

PTV 脉冲不分流模式操作（w/ 未定义色谱柱）

PTV 溶剂放空模式操作（w/ 已定义色谱柱）

PTV 溶剂放空模式操作（w/ 未定义色谱柱）


设定值输入错误的加热区

GC/MSD 接口正常情况下由 #2 辅助加热区控制。确定您的系统该项是正确的。确定温度设定值输入在正确的加热区内。


设定值曲线

设定值曲线窗口允许显示仪器参数设定值的形象的表示。

例如，可以在柱箱对话框内编辑温度参数使其在特定一段的时间内变化。柱箱曲线提供了该程序中设定值的图形表示。

有多达五中彩色编码的曲线可以同时显示。单击 Plot...（绘图……）按钮选择希望查看的仪器参数的设定值：

图形左边的彩色图例反应当前的选择。（柱箱温度曲线将总是黑色的，表示柱箱温度决定运行时间。）

欲为指定的仪器参数的设定值显示坐标单位，选择仪器参数的选项按钮。Y 坐标代表被选择的坐标单位。X 坐标总是代表从运行开始到结束（包括后运行）的时间（分钟）。

实线说明运行时间的数值。

虚线说明后运行时间的数值。

欲放大图形的特定区域，单击想放大的区域的一角并按住鼠标左键，托动指针到区域的另一角，并释放鼠标左键。

再扩大一级（仅一级），重复上述过程。

想缩小：

  • 一级，单击图形区域的任何部分。

  • 两级，双击图形区域的任何部分。


设定积分事件

当您已经选择化学工作站积分器时，会出现Edit Integration Events(编辑积分事件）对话框。使用它：

  • 指定下列初始事件，这些初始事件将成功的积分大多数色谱。

初始面积排除除

初始峰宽

肩峰检测

初始阈

这些是积分的开始条件，如果它们没有让以后色谱的时间点没有被一个事件设定取代，则在整个色谱中有效。可以编辑这些初始事件，但不能从列表中将它们删除。对于很多色谱，这些初始值的正确设定是成功积分整个色谱的全部条件。

  • 确定积分过程中其他可能事件的时间。

欲加载一个事件文件

单击Load（加载）按钮可以让您选择一个事件文件进行编辑。这个文件可以与方法联系起来。

欲保存一个事件文件

单击Save（保存）可以让您保存对相同或不同的事件文件的改变。

确定积分事件的时间

从可能的事件列表中选择预期的事件:（左边表格）。被选择的事件（加亮的区域）也出现在事件输入框内。输入事件要求的数值和/或时间参数。单击Enter（回车）键将积分器事件输入到时间列表中（右边表格）。单击Save（保存）将进度表保存在在方法中将会使用的事件文件中。如果仅想在当前色谱上使用该事件，单击OK（确定）。

修改积分事件

单击要改变的值并输入新的数值。单击Enter（回车）然后单击Save（保存）或OK（确定）。

删除积分事件

以鼠标左键单击表格项目，然后单击Delete（删除）。

初始面积排除

面积比这个数值小的峰将不被保存、不在计算中使用或包括在报告中。大的初始面积截除值通常在方法中被设定以消除进样瞬间或溶剂峰。小的数值可能被设定（参见可能事件）在后面的运行中发生。

范围为 0 到 1E14。缺省值为 1。

初始峰宽

峰宽为峰在半峰高处的峰的总宽度。这个参数告诉积分器希望发现的峰的宽度。如果这个峰宽的数值太大，窄的峰将可能定量出错或事件被遗漏。如果峰宽设定太小，噪音尖峰将被作为峰检测，宽的峰可能被整个错过。初始峰宽与Integrator Off（积分器关闭）或Area Sum On（面积求和打开）事件不一致。

范围为 0 或 0.001 到 100.0（以分钟的形式）。系统缺省值为 0.02。

峰的可接受的范围约为Initial Peak Width（初始峰宽）项目的 1/3 到 3 倍。初始峰宽为 0 允许使用当前有效数值重新进行束状计算并允许积分器自动指定合适的峰宽。

肩峰检测

当两个峰离得很近以至于在它们中间不存在峰谷因此显然不能分辨时出现肩峰。积分器不去尝试分割两个峰然后计算它们的面积。在“环境数据分析”软件中不能被报告肩峰。肩峰检测总是“关闭”的。如果将“肩峰检测”设定为“打开”，即使软件好像是接受了但这种改变也不能被保存。

初始阈

初始阈决定积分器的初始灵敏度。阈值增加一倍则灵敏度下降两倍。更高的阈值通常会导致可接受峰更少。

范围为 -12.0 到 25.0。缺省值为 18。

也可参见

可能的时间事件


设定 RTE 积分参数

使用 RTE Integrator Parameters（RTE 积分器参数）对话框为RTE 积分器设定积分参数。该对话框有三组参数：

Detector（检测器）参数决定色谱峰和区如何识别：

  • 数据点采样

  • 平滑

  • 检测过滤

  • 开始阈

  • 结束阈

Baseline Allocation（基线位置）参数确定如何走基线：

  • 基线重新设定

  • 如果有前伸峰或拖尾峰

  • 基线优先选择

Output（输出）参数确定报告哪个检测到的峰：

  • 最小峰面积和度量单位

  • 峰位置

  • 最大峰数

欲加载参数

使用Load（加载）按钮从拥有特定方法（缺省值为当前方法）的 RTE 积分参数的宏文件（.P）中加载参数。

欲保存参数

使用Save（保存）按钮将当前的 RTE 积分参数保存到与特定方法关联的 .P 文件中。

也参见

积分参数文件

数据点采样

范围为整数从 1 到 9。缺省值为 1。不允许是负数。对于被扫描的毛细管柱的数据，采样正常情况下应设定为 1。对于 SIM（选择性离子检测）数据，参数通常为 2 或 3。

选择哪个数据点用于计算斜率灵敏度。缺省选择为 1，即每个数据点均被使用。每隔一个数据点选一个，请选择 2，每隔两个选一个，请选择 3，等等。有时可以通过调整这个参数以利用如下所示的更宽的峰来提高性能：

数据点通过一个峰 | 尝试的设定
25 或更多 | 2 或更小
50 或更多 | 6 或更小
70 或更多 | 9 或更小

该参数在 RTEINT 的前一个版本中被称作束。输入负数时，可以得到与在“平滑”下描述的相同的平滑。

平滑

选择此复选框打开其他过滤器，它在一阶导数用于确定开始/结束点时对数据起作用。缺省 ＝ 不选定。当您选择 5 点数字化过滤时，您可以只选择“平滑”。

使用检测器平滑以改善带噪音的数据的结果。它可以用于积分器呈现“分裂峰”的趋势的任何时候。一个分裂峰是一个单独的色谱事件或峰，由于其峰形波动下而被报告为两个峰。

当为束输入负数值时,它与在前一个版本的 RTEINT 有效的过滤器是相同的。它在 RTEINTPARMS 命令中仍然可以被设置为有效。

检测过滤

为提高噪音色谱的检测器性能，使用数字化过滤。可以改善 SIM 数据的结果。缺省值 ＝ 5 点。

数字化过滤在一阶导数被使用时平滑用于确定峰开始和结束点的数据。该参数允许选择在移动加权平均中包含的数据点的个数。正确的参数选择依赖于特征峰的宽窄和在与数据点采样关联时如何处理。

缺省设定提供与前一个 RTEINT 版本（这个参数是不可选的）相同的 5 点过滤。

开始阈

范围为 0.001 到 100。缺省值为 0.200。开始阈很少被改变是因为峰检测器自身动态调整开始阈以补偿改变的型号级和噪音级。缺省值 0.2 对于大多数色谱为最佳值。

当一阶导数计算超过开始阈（它部分由参数设定确定）时，峰被检测或开始。

结束阈

范围为 0 到 100。缺省值为 .00。结束阈确定峰何时结束。该阈可以进行调整以便改变包含在积分峰面积内的拖尾峰的数量。更大的数值将增加被积分的拖尾峰的数量。数据中的噪音可能导致积分过早终止。在这种情况下，尝试将值增大到 0.3 到 0.5 以超出峰结束的位置。

基线重新设定（#点）>

范围为 0 到 500 个扫描。缺省值为 5 个扫描。参数为扫描数，它必须将两个相连的色谱峰分开以便峰开始和结束点的坐标用于定义基线。如果两个或更多峰被小于该值的数分开，则基线将被画在峰开始和结束的丰度下面。当峰分离设定为 0 扫描时，单独评价每个峰。这一点可能非常有用，例如，当一个峰的基线受一个 SIM 组结束处的丰度偏移所影响时。

每个峰相对于它的邻峰被检验以确定相邻峰是否影响当前被检验的峰的基线的位置。欲查看当改变 # 点时会发生什么，暂时将“最小峰面积”改为 1％ 以便可以报告更小的相邻峰。

如果有前伸峰或拖尾峰 <

这个条件与“基线优先”一起用来确定从峰开始到停止基线是否下降或者发生切线斜滑。范围为 1 到 100％。缺省值为 100％。注意在 RTEINT 中这个参数也被称为谷。

该参数测量峰开始/结束处振幅的不同并以总峰高的百分比表示出来：

% = 100 * |Y开始 - Y结束| / (Y最高 - Y最低)

这里，Y开始 和 Y结束 分别为峰开始和结束处的振幅，Y最低 为 Y开始 和 Y结束 中较小的一个，Y最高 为峰顶部的数值。

基线优先选择

缺省值 ＝ Baseline drop（基线下降）而不是切线斜滑。在前缘或后缘引起从峰开始到结束的基线下降或切线斜滑时使用。在前缘或后缘 < 100％ ，基线下降而不是切线斜滑的缺省情况下，基线下降将用于所有峰因为所有峰均满足条件。同样地，如果选择 Tangent（切线斜滑）而不是基线下降，所有的峰从开始到结束均有一个切线斜滑。

如果输入的值不是 100％，则基线下降和切线斜滑在给定的色谱中均可能发生。例如：如果前缘或后缘 < 20％，则切线斜滑而不是基线下降将引起从开始到结束丰度差别小于 20％ 的峰的基线从开始到结束下降。其他峰将从开始到结束下降到一个水平的基线上。

最小峰面积

这是面积阈，单击一个按钮可以为其选择单位。表示成面积数，范围为 0 到 1E8。表示成最大峰的百分比，范围为 0 到 100％。缺省值为 5％。最大峰的百分比通常用于保证仅有重要的色谱信息被积分并报告的。在 GC/MS 分析中，溶剂峰通常不被检测，但是最大峰和许多噪音峰将会被发现。为舍弃小的噪音峰，选择最大峰的 ％。

当积分内标、系统监控化合物和其他在样品中为已知浓度的化合物时使用面积数。指定最小面积数可以减少小峰或噪音不经意的被检测并不正确的分配给化合物的可能性。

对于目标化合物分析，面积数通常为较好的选择。最大峰的 ％ 不应用于目标化合物检测是由于如果目标化合物不存在，检测的灵敏度将会检测到许多噪音峰。这些噪音峰可能以错误的形式出现在定量报告中。

面积数影响峰检测器。在这种情况下，峰检测器检测每个积分峰的原始面积以确定峰是否应该被保留并提交到基线定位算法。

重要在检测阶段舍弃的面积基于原始面积的单位。当选择最大峰的 ％ 时，最小面积对算法的检测阶段没有影响。

一个标量因子可以用于使用 RTEINTPARMS 命令的面积计数上。当这个因子在它的缺省设定 1 时，面积计数 ＝ 数值-秒。

峰位置

可以选择保留时间是报告到峰顶部还是报告到峰的中心（有效面积的中心）。缺省位置为顶部。

这个选项对显示出一个平的顶部的重叠峰或显示几个峰最大值的宽的噪音峰时非常有用。

最大峰数

报告的最大峰数。范围为 1 到 250。缺省值为 100。被报告的峰为那些面积最大的峰。


设定 6890 GC

使用 6890 GC 采集数据

如何

采集 GC/MS 数据（概述）

编辑采集参数

设定进样口和进样参数

设定 GC

设定 MS

显示监测器

显示实时曲线

使用 MS 时间事件表

参见

仪器控制视窗输出设计

GC 仪器|编辑屏幕输出

仪器控制菜单

仪器控制对话框

日志簿

使用方法

使用序列


设定实际值

使用 Setup Actual（设定实际值）对话框指定 7 个您想在化学工作站显示面板中监控的仪器实际值或设定值。

实际值变量列表确定您可以监控的39 个仪器调节装置。

显示的实际值列表代表化学工作站的显示面板。

欲监控一个化学工作站面板中的仪器调节装置：

  1. 从 Instrument（仪器）菜单中选择Setup Actuals（设定实际值）。

  2. 单击有效的实际值列表项目，并按住鼠标左键。

  3. 将该项拖动到显示的实际值列表。

  4. 将项目放置在您希望它在显示面板上出现的位置上。

  5. 释放鼠标键。

要在化学工作站显示面板中重置一个项目：

  1. 从 Instrument（仪器）菜单中选择Setup Actuals（设定实际值）。

  2. 单击显示的实际值列表项目，并按住鼠标左键。

  3. 将项目拖动到您希望它在显示面板上出现的位置上。

  4. 释放鼠标键。

要在化学工作站显示面板中删除一个项目：

  1. 从 Instrument（仪器）菜单中选择Setup Actuals（设定实际值）。

  2. 单击显示的实际值列表项目，并按住鼠标左键。

  3. 将该项拖动到显示的实际值列表。

  4. 释放鼠标键。

单击 OK（确定）以保存对显示面板的设定。


设定菜单 — CI 调谐

仅适用于为 CI 配置的 5973 MSD。下列菜单项用于设定 CI 调谐。

Select CI Gas （选择 CI 气体） | 显示 Select CI Reagent Gas（选择 CI 反应气）对话框，在这里可以选择用于调谐的反应气。
Set Tune Limits （设定调谐限制） | 显示 Tune Control Limits（调谐控制限制）对话框。
Select Masses （选择质量） | 显示一系列对话框可以选择反应离子质量、调谐离子质量和您想优化的质量。
Methane Flow Setup （甲烷流量设定） | 引导您在预调谐前完成甲烷流量（或其他选择的反应气）的初步调节。
Methane Pre-Tune （甲烷预调谐） | 在调节流量之前自动调整峰宽和反应离子（在这种情况下为甲烷）的坐标轴位置。
Methane Flow Adjust （甲烷流量调节） | 引导您在监测离子丰度比时完成反应流量（在这种情况下为甲烷）的精密调节。


信号电缆未连接

  1. 拿走 MSD 上面的盖。

  2. 检查信号电缆。

    确定它是否安全的连接到侧板上。


信号提取

目标化合物鉴定的第一步是决定信号提取发生的时间范围 R。在目标化合物项目中，用户指定期望的保留时间 E、前时间偏移 d0和后时间偏移d1。

设定t0 = max {0, E - d0 }和

t1 = E + d1 。

现在考虑数值 r,是被指定同时作为“内标化合物”和“时间参比化合物”的前面一个化合物被观察到的时间对期望的时间的比值。如果没有化合物与当前化合物相关，则 r值为 1。时间范围 R被指定为

r t0 :r t1

每个目标化合物项目指定一个目标信号描述符，TIC 或 EIC 质量。

所有的 EIC 均为被“MS 数据分析“定义为标准的单一质量 EIC：也就是说，它们是由 MzRange 变量和给定的单一质量所确定的质量范围内的响应的总和。

如果 TIC 为目标信号，则 TIC 被从在时间范围 R 内的当前的 GC/MS 数据文件中提取出来。否则，一个 EIC 将在时间范围 R 内为数据文件中的目标m/z提取出来。

对于指定非零m/z值的任何特征信号，一个 EIC 在指定的m/z值和时间范围 R内被提取出来。总共 3 个特征信号将被提取。

最终，如果非 0 面积较正质量被指定，一个 EIC 将在m/z上被提取出来。系统不检测或避免为相同的目标化合物项目的不同信号多次使用相同的m/z值。


信号积分

目标信号和每个目标化合物项目的特征信号可能有一套相关的积分参数。要指定这些参数，用户创建一个包含命令的宏文件以设定参数，然后提供目标化合物的项目文件的 MS-DOS 的基本名和扩展名。宏文件被指定保存在与保存“目标化合物数据库”相同的“方法”目录中。如果指定这样一个文件，它将在对感兴趣的信号积分前被加载并执行。

如果 Method（方法）积分器是 RTEINT，把信号加载到积分参数文件并执行（或者没有文件被指定，方法的 RTEINT 缺省值为恢复）后由 RTEINT 积分。

如果 Method（方法）积分器是化学工作站积分器，信号在参数文件被指定或 AUTOINT 条件下用 INTEGRATE 积分。


信号级最小、最大

Signal Level Minimum（信号级最小）是该化合物允许的最小相对响应因子（RRF）。

Signal Level Maximum（信号级最大）是在这一化合物初始校准中允许的最大相对标准偏差（％RSD）。


定量使用的信号

定量信号

用于生成化合物定量色谱的信号(TIC或 Target Ion（目标离子）) (混合模式下GC1 或 GC2)。如果选择了 Target Ion（目标离子），必须指定质量（m/z）在 Tgt字段。您也可以指定三个特征离子(Q1等)。

注意在设定过程中 Quant Setup（定量设定）框通过鼠标操作自动输入这些值。

相对响应

在校准过程中计算并输入这些数值。这个值为特征离子对目标离子响应的百分比。

％ 不确定度

这为特征离子对目标离子的相对响应定义了可接受的范围。它可以为相对值（缺省值），也可以是绝对值。在校准过程中，为每个特征离子提供 20％ 不确定度的缺省值。

相对 / 绝对

对于相对响应为 40％、不确定度为 20％ 的特征离子： 如果选择 Rel（相对），可接受的范围为 32％ 到 48％。如果选择Abs（绝对），可接受的范围为 20％ 到 60％。


显著性

PBM 检索根据每个质量峰的m/z和丰度为每个峰指定显著性。显著性最高的峰用于匹配。

质量峰的显著性由两个值决定，U（独特性）和 A（丰度）。U 和 A 的数值都是由 McLafferty 及其合作者从 67,128 化合物的 79,650 个光谱统计研究中得到的。

独特性

确定的质量(m/z) 比其他值更容易发生在质谱中。例如, m/z 43 比m/z 343 更普通。每个质量被分配一个 0 到 12 的独特性数值，最常见的质量(m/z 29, 39, 41, 43)将被指定为 0。

丰度

A 的值由光谱中一个质量的相对丰度决定。相对丰度越高，A 值越大；被分配的值为 －3、－2、－1、0、1、2、3、4 和 5。

显著性计算是 PBM 检索和压缩算法的基础，它以如下方式使用：

  • 在选择存储在压缩参比光谱中的 15 到 26 个峰时，定义峰的显著性。

  • 预过滤算法中为了仅剩下那些最显著的峰与选定的未知光谱相似的光谱。

  • 作为评价参比光谱与未知光谱相似性的一个因子。


SIM 模式 - 定义

SIM 模式 选择性离子控制 (SIM) 模式是一种数据采集技术，它仅监测一些选定的离子碎片以得到最大的灵敏度。


单通道模拟输入面板

当可选项单通道模拟输入面板安装在 6890 GC 中时，您可以连接到可产生最大电压为 1 伏的非安捷伦检测器上。化学工作站认为模拟输入为另一个检测器信号。两个单通道模拟输入面板可安装以提供前和后检测器的位置。

为激活检测器加热元件，在 On（打开）复选框上加上 X。

设定值 0 到 400 [image] C

由 GC 传送的检测器 Actual（实际）温度为只读显示。

为激活 Electrometer（静电计），在复选框内加上 X。

数据分析的信号转换

  • 输入电压 = -10 mV 到 +1.05V (在 + 和 - 负输入之间)

  • 1 显示数字 = 15 uV 输入伏


单个 GC 检测器和单柱配置的 MSD

采集混合模式数据的另一个方法是单一色谱柱配置。这里，样品在色谱柱上被分离成它的组分但是此后它们被分配到两个检测器里。最简单的方法是将色谱柱通过压力匹配的石英“Y”型连接器连接到两个检测器上。MSD 和 GC 检测器的不同流量和两条传输线上的流量限制必须进行很好的平衡。MSD 传输线通过被加热的传输线送到 GC 检测器，此传输线处于色谱柱柱箱的温度。这意味着在一个温度程序运行时，进样口处于恒压下，MSD 流量接近常数而色谱柱流量在下降。这可能改变 MSD 和 GC 检测器间的流量分流。最差的情况下，没有流量通过处于柱箱升温程序下的 GC 检测器部分。

一个 30m*0.25mm ID HP-5MS 的色谱柱安装在分流/不分流进样口上。色谱柱流出物在 MSD 和 FID 间分流。一个锥型石英“Y”形连接器（P/N 5181-3397）通过使用加热枪和手指的压力连接到色谱柱的出口处。去活的包覆聚酰亚胺的熔融石英毛细管用作到检测器的传输线。一个 30cm 长、0.1mm ID 的毛细管连接到 Y 型的一个头，然后插入到 MSD 的传输线中。1m 长的、0.53mm ID 的毛细管连接到另一个头上，然后连接到 FID。色谱柱流量设定到 1.5ml/min 不用进样口在恒定流量模式下操作。在 MSD 和 FID 之间的分流结果为 1：1.6。恒定流量模式在柱箱升温程序过程中维持检测器间恒定的分流。下表说明色谱柱参数。

进样口和色谱柱条件单柱

参数 |
进样口连接 | 前级分流/不分流
检测器连接 | FID/MSD
出口压力 | 常压
进样模式 | 脉冲不分流
压力 | 18.9 psi
脉冲压力 | 25.0 psi
脉冲时间 | 0.5 min
控制模式 | 恒定流量
初始色谱柱流量 | 1.5 ml/min
平均速度 | 36 cm/sec

另见

Sequence File Examples（序列文件示例）


慢进样

有关慢进样速度规定的详细信息，请参见自动进样说明。


溶剂 A

溶剂 A (进样前或进样后)

用“溶剂 A”清洗注射器的次数。每次冲洗时注射器的体积充满 80％（即 5ul 的注射器充满 4ul，10ul 的注射器充满 8ul），然后将溶剂排放空至废液瓶。

有效输入值： 0 to 15。缺省值为 0。


溶剂 A

溶剂 A (进样前或进样后)

用“溶剂 A”清洗注射器的次数。每次冲洗时注射器充满 80％ 并将溶剂完全排放到废液瓶。

有效输入值： 0 to 15。缺省值为 0。


溶剂 B

溶剂 B (进样前或进样后)

用“溶剂 B”清洗注射器的次数。每次冲洗时注射器的体积充满 80％（即 5ul 的注射器充满 4ul，10ul 的注射器充满 8ul。），然后将溶剂完全排放到废液瓶。

有效输入值： 0 to 15。缺省值为 0。


溶剂 B

溶剂 B (进样前或进样后)

用“溶剂 B”清洗注射器的次数。每次冲洗时注射器充满 80％ 并将溶剂完全排放到废液瓶。

有效输入值： 0 to 15。缺省值为 0。


溶剂沸点

从下拉列表中选择一种样品溶剂。化学工作站会自动显示其 Boiling Point（沸点），它可以在分流 - 不分流进样（在不分流模式下）或使用冷柱头进样的情况下确定柱箱温度。

如果选择 Other（其他），指定一个 Boiling Point（沸点） 在 [image] C。

QuickSet （快速设定）方法将包含一个单一的梯度柱箱升温程序基于 Sample Solvent（样品溶剂）的 Boiling Point（沸点）和为已进样柱指定的 Max Temperature（最高温度）。(有关单一梯度柱箱升温程序的更详细信息，请参见 Ramps（梯度）。)

要继续快速设定过程:

转到下一个对话框。

回到前面的对话框。

要创建和显示 Quick Setup（快速设定）方法：

要取消快速设定过程:


溶剂延迟

溶剂延迟是当质谱仪打开时运行开始后的时间（分钟数）。MS 应关闭直至溶剂峰被从色谱柱里洗脱出来并通过 MS 为止。

对于 25米长的毛细管色谱柱，2 分钟的 Solvent Delay（溶剂延迟）通常是比较理想的。


溶剂延迟太短

如果洗脱溶剂峰时分析仪处于打开状态，则检测器可能饱和了。确保溶剂延迟足够长以免丢失溶剂峰。


溶剂峰

这经常发生在进行柱头进样时。溶剂峰将多路连接管压力升高到 8 x 10^-3 托（Torr）以上。如果这个问题重复出现，最好将三级真空规关闭。


溶剂放空模式

溶剂放空模式是程序温度蒸发（PTV）进样口所特有的。它类似于 Splitless Mode（不分流模式），但允许进更大量的样(25 ul)。

样品进入冷进样口。如果条件选择正确并且样品合适，当溶剂挥发被吹扫出去时，待分析物积聚在进样口衬管里。大量或多次进样可用于进入分析柱前在进样口处浓缩样品。带 Solvent Vent（溶剂放空）的进样的三个状态如下所示。

样品和放空在取样过程中的放空期间，电磁阀打开。进样口处于“初始温度”的设定值，通常低于溶剂沸点。溶剂挥发并被吹扫出排气口，而样品积聚在衬管壁或填充物上。

样品转移当溶剂放空结束时，电磁阀关闭并且把进样口加热到“FINAL TEMP 1（终温1）的设定值。样品转移至毛细管色谱柱。

吹扫和清理 电磁阀再次打开并且系统回到初始状态（样品和放空）但设定值不同。PTV(程序温度蒸发）进样口被冲洗。热清洁进样口或在样品转移后降低进样口温度时可以得到附加的梯度速率。这可以延长衬管寿命。

温度、压力和流量

溶剂放空模式要经过三个不同的气路状态：放空、样品转移和吹扫。放空比允许进样口压力和进样口流量被调整到消除溶剂的最佳条件。转移状态模拟传统的不分流操作并从衬管将待分析物转移到色谱柱。吹扫模式允许用户为下一次运行准备进样口。

要避免挥发性待分析物与溶剂一起损失：

  • 进样口衬管可以填充更具保留能力的材料，如 Tenax(一种提取吸附剂）。这样大大提高了挥发性待分析物的回收率，但是可能影响高沸点材料的回收率。

  • 当样品开始转移时，一些溶剂可能仍留在衬管里。残留的溶剂起到固定相的作用并且使挥发性物质保持到大溶剂峰吹扫出去。

  • 可降低进样口温度。这可以减小挥发性分析物的蒸汽压力,使回收率更高。

在进样过程中进样口内部的压力—排气口压力参数—可以被减小以加快溶剂的移出。提高进样口流量—排气口流量参数—也可以加快溶剂的移出。

为Solvent Vent（溶剂放空）模式设定下列参数（单击任何屏幕区域）：

有关定义色谱柱的信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。


在校准表内按信号排列

当多重信号的分析中含有很多要关注的峰的时候，校准表可能比较难编辑。最近被添加到Calibration/Calibration Options/Edit Options（校准/校准选项/编辑选项） 对话框的 Sort Table（排列表）选项可以通过保留时间或信号名排列信号使编辑变得容易了。


源

要指定信号输出源，请选择 Det, Temp, Flow（检测，温度，流量）, 或 Test（测试）, 然后从下拉列表框中选择一个源。

色谱柱补偿测试

要把色谱柱补偿测试中的数据绘成图，选择 Det 并指定 col comp 1（色谱柱补偿 1）或 col comp 2（色谱柱补偿 2）作为源。

检测器气体类型

要把一个检测器的流量或压力绘成图，选择 Flow（流量）并从下列源中指定一个：

  • F/B 检测气体 1 压力

  • F/B 检测气体 2 压力

  • F/B 检测气体 3 压力

  • F/B 检测气体 1 流量

  • F/B 检测气体 2 流量

  • F/B 检测气体 3 流量

绘图的气体类型决定于您为检测器配置的类型。支持的类型如下所示：

检测器 | 气体 1 | 气体 2 | 气体 3
FID（离子火焰检测器） | 氢气 | 空气 | 尾吹气
ECD（电子捕获检测器） | 不被使用 | 阳极吹扫 | 尾吹气
TCD（热导检测器） | 不被使用 | 参比 | 尾吹气
NPD | 氢气 | 空气 | 尾吹气

测试曲线

要把测试数据绘图，请选择 Det 并指定test plot（测试图）作为源。测试图为内部生成的色谱图，它包含三个基线分离的重复峰。最大峰面积大约为 1 Volt－sec（伏特 － 秒），中间的峰为最大峰的 0.1，最小峰为最大峰的 0.01。可以使用测试图不进行重复的色谱运行来确定外部数据处理设备的操作。也可以将其作为稳定信号比较不同数据处理设备的结果。

对话框目录：

Data Rate（数据采样频率）

Minimum Peak Width（最小峰宽）

Calc Button（计算按钮）

Save Data（(保存数据）


源温度传感器断开

  1. 放空 MSD。

  2. 打开真空多路连接管。

  3. 检查离子源接线。确定离子源温度传感器接线连接到输入引线面板上。

  4. 如果把接线正确的连接到传感器仍不能正常工作，替换源加热器（加热器、传感器和加热区）。

有关放空 MSD 的说明，请参见 MSD 硬件手册，打开真空多路连接管，并更换源加热器。


源温度传感器被短路

  1. 放空 MSD。

  2. 打开真空多路连接管。

  3. 检查离子源接线。试着确定传感器接线是否短路到接地表面。

  4. 如果把导线正确地连接到传感器仍不能正常工作，更换源加热器（加热器、传感器和加热区）。

有关放空 MSD 的说明，请参见 MSD 硬件手册，打开真空多路连接管，并更换源加热器。


特定化合物特征

CAS #

专用的“化学摘要服务”号。然而，您可以把这一号码用于任何编号或有关此化合物的信息。

化合物类型

可以指定多达 7 种单字符指示词代表化合物类型用于报告或宏。下列字符已被预定义，它的使用可能会影响软件所处理的化合物。

G － 一组化合物

H － 碳氢化合物

I － 内标

L － 多组分化合物

M - 基质添加化合物

P － 性能检查化合物

R － 用于重新锁定的化合物

S － 替代化合物

T － 目标化合物


特定的报告参数

虽然下列条目已被标明指环境分析的要求，但是它们当然能用于其他分析（如，药物分析、法医检定法）。

替代物/基质添加量

回收率极限

信号水平最小、最大

MS 谱库名称/登录号#


说明

在运行中会改变的设定值：

  • Valve（阀）(1 到 8)

  • Signal（信号）(1 和 2)

  • Auxiliary channel（辅助通道） (#3、 #4 和 #5)

  • TCD（热导检测器）

  • NPD


光谱菜单 — RTL

该菜单仅能在 MS 模式下使用。

Draw Next （画下一个） | 显示下一次扫描的光谱。
Draw Previous （画上一个） | 显示上一次扫描的光谱。
Tabulate （列表） | 以列表格式中显示质谱。
Add （添加） | 添加两个谱图并显示它们的加和。
Subtract （扣除） | 从一个谱图中扣除另一个谱图并显示其差值。
Select Library （选择谱库） | 显示 Library Search Parameters（谱库检索参数）对话框，可以选择将要检索的谱库。
Edit Strategy （编辑策略） | 允许您设置谱库检索策略。
Edit Library （编辑谱库） | 显示 Edit PBM Library（编辑 PBM 谱库）对话框，可以选择、编辑、创建和删除谱库。
Display Reference Spectra （显示参比谱图） | 为当前显示的化合物显示参比谱。


光谱菜单（参数检索）

光谱菜单

Draw Next(画下一个） | 显示下一次 扫描的光谱。
Draw Previous（画前一个） | 显示前一次 扫描的光谱。
列表 | 为当前显示（将被提示选择其中一个）之一显示列表结果。
添加 | 添加谱库中被显示的质谱和一个从数据文件中选定的未知光谱。
归一化扣除 | 从一个数据文件中选定的未知光谱中扣除谱库中的质谱。 谱库光谱在扣除前被归一化到未知光谱。


光谱菜单 － EasyID 和 QEdit

Draw Next（画下一个） | 显示下一次扫描的光谱。
Draw Previous（画前一个） | 显示前一次扫描的光谱。
列表 | 以列表格式来显示一个质谱。
添加 | 添加两个光谱并显示它们的加和。
扣除 | 从一个光谱中扣除另一个光谱并显示它们的差值。
选择谱库 | 显示 Library Search Parameters（谱库检索参数）对话框，可以选择要检索的谱库。
编辑策略 | 允许设置谱库检索策略。
编辑谱库 | 显示 Edit PBM Library（编辑 PBM 谱库）对话框，可以选择、编辑、创建和删除谱库。
显示参比谱 | 为当前显示的化合物显示参比光谱。
升级参比谱 | 一旦显示了参比谱，可以通过选择此项目更新参比谱。


将使用的光谱

每个要积分色谱峰的光谱是谱库检索所需要的。选择得到该光谱的方式：

Apex（顶点）

使用峰顶部的光谱。

Apex - Start of Peak（顶点 － 峰开始处）

使用顶点光谱并使用峰开始处最近的光谱背景校正它。

Apex - Background at time xxx（顶点 － 背景在 XXX 时间）

使用顶点光谱并使用输入的时间处的光谱背景校正它。

Peak Average（峰平均）

使用将色谱峰处所有的光谱平均得到的光谱。


分流流量

Split Flow（分流流量）

分流/吹扫口的流量（ml/min）。

Split Flow（分流流量） = Column Flow（柱流量） x Split Ratio（分流比）（载气节省关闭的条件下）

Split Flow（分流流量）是一个计算值。

本对话框中其他项目：

Gas（气体）

Heater（加热器）

Pressure（压力）

Total Flow（总流量）

Split Ratio（分流比）

GasSaver（载气节省）（如果色谱柱已被定义）


分流流量

分流/吹扫口的流量（ml/min）。

分流流量 = 柱流量 x 分流比（载气节省关闭的条件下）

Split Flow（分流流量）是一个计算值。


分流模式

PTV（程序温度蒸发）进样口的分流模式把进入进样口的气流分为在柱流量之间进入进样口的气流、通过电磁阀的分流口流量和隔垫吹扫流量。分流口流量对柱流量的比值被称为分流比。

分流模式通常:

  • 为了主要组分分析、当允许从分流/吹扫口流失大部分样品是主要为了高浓度的样品。

  • 为那些不能稀释的样品。

当进样口温度过热或过冷时，根据样品和分析的类型，可以把液体样品进到 PTV（程序温度蒸发）进样口。

冷分流进样

对于冷分流进样，使用低于溶剂正常沸点的初始进样温度。如果衬管体积足以容纳所有汽化的溶剂，则可在 0.1 分钟时以高加热速率（500°C/min 或更高）开始第一个进样口温度梯度。最终温度应足够高，从而能汽化衬管待分析物中最重的组分并至少能持续 5 分钟。实验证明 350°C 的最终温度持续 5 分钟足以使 C44 蒸发。

对于更大的进样体积或为消除溶剂，初始温度应持续足够长时间从“分流”口排空溶剂并开始第一个梯度。对于热稳定分析使用一个较快的速率。慢的速率可以减少进样口处的热分解。一个单一的温度梯度对于进样过程足够了。其余的梯度可能用于清理衬管或降低在下一次进样准备过程中衬管的温度。

热分流进样

对于热分流进样，设定一个足够高的温度汽化待分析物。由于进样口在整个运行过程中维持在设定值，所以不需要其他热参数。由于衬管体积较小（大约 120ml），PTV（程序温度蒸发）在热分流进样时有进样量的限制。热分流模式进样量超过 1ml 可能使进样口溢流引起分析问题。冷分流进样避免了这个问题。

如果色谱柱被定义, 为分流模式（有关详细信息，单击闪烁区域）设定如下参数：

有关定义色谱柱的信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。


分流模式

当在分流模式下进样时，少量样品进入色谱柱而主要部分流出分流口。分流流量对色谱柱流量的比例由用户控制。分流模式主要用于高浓度样品在允许从分流口流失大部分样品和样品不能稀释的情况下。

分流模式操作参数

参数 | 允许的设定值范围 | 建议使用的初始值
柱箱初始时间 | 0 到 999.9 分钟 | 色谱柱采样后
接口温度 | 室温 + 10C 到 400C | > 传输线温度
载气节省时间 | 0 到 999.9 分钟 | 色谱柱采样后
载气节省流量 | 15 到 100 mL/min | 比最大色谱柱流量大 15 mL/min。

分流比

由于接口处内部体积较小，接口处的最大总流量为 100ml/min。最大流量对分流比的设定有一定的限制：

柱径 色谱柱流量 最大分流比 总流量

200 m 1 mL/min 100:1 100 mL/min

530 m 5 mL/min 20:1 100 mL/min

有关更详细信息，请参见 Split Mode Pneumatics（分流模式气路）。

如果色谱柱被定义, 可以在 Set Split Ratio（设定分流比）对话框中设定分流比

。

如果色谱柱没被定义, 必须从 6890 GC 前面板设定分流比。参见6890 系列挥发物接口安装和操作指南。

有关定义色谱柱的信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）

本对话框目录：

气体

加热器

压力

总流量

分流比

分流流量

GasSaver（载气节省）（如果色谱柱已被定义）


分流模式

分流进样时，液体样进到热的进样口，并迅速蒸发。少量蒸汽进入色谱柱而主要部分从分流/吹扫口流出。您要控制色谱柱流量对分流流量的比例。

分流模式一般为:

  • 主要组分分析，主要为高浓度样品，在允许大部分样品从分流/吹扫口流失时。

  • 不能稀释的样品。

如果色谱柱被定义,为分流模式设定下列参数(有关更详细信息，单击任何绿色区域):

有关定义色谱柱的信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。


分流模式气路设定值

接口处的总流量由流量传感器测量，由一个比例控制阀控制。柱头流量为后压力调节。压力是从比例控制阀的上游来检测的。

不能在流动体系中控制所有的设定值。如果改变一个设定值，其他设定值可能会做补偿性改变。

当色谱柱被定义时

如果改变 － 这些设定值改变

压力柱流量*

分流流量

总流量

色谱柱流量*压力

分流流量

总流量

分流流量 分流比

总流量

分流比 分流流量

总流量

总流量 分流流量

分流比

* 这个设定值可在 Column（色谱柱）对话框内得到。

当色谱柱没被定义时

不能设定色谱柱流量、分流流量和分流比。可以改变总流量和压力的设定值而不影响其他设定值。


分流比

分流流量（ml/min）对色谱柱流量（1ml/min）的比例。

分流比 = 分流流量/柱流量

有效范围： 0.1 - 7500, 或色谱柱和进样口流量允许的最大值。


分流比

分流流量（ml/min）对色谱柱流量（1ml/min）的比例。

分流比 = 分流流量/色谱柱流量

有效范围： 0.1 - 7500, 或色谱柱和进样口流量允许的最大值


分流比

Split Ratio（分流比）

分流流量（ml/min）对色谱柱流量（1ml/min）的比例。

分流比 = 分流流量/色谱柱流量

有效范围： 0.1 - 7500, 或色谱柱和进样口流量允许的最大值

本对话框中其他项目：

Gas（气体）

Heater（加热器）

Pressure（压力）

Total Flow（总流量）

Split Flow（分流流量）

GasSaver（载气节省）（如果色谱柱已被定义）


分流比不正确

确定分流比是正确的并且样品量适合。有必要的话，减小分流比或切换到不分流进样。


不分流进样时间太长

不分流进样时间太长可能导致进样口清扫不完全。过量溶剂在色谱柱上停留，使溶剂很慢的流出色谱柱。如果使用不分流进样，尽量减少进样时间。


不分流模式

当在这种模式下 PTV Inlet（PTV 进样口），电磁阀在进样过程中关闭并且在样品从衬管蒸发、转移到色谱柱时维持此状态。在进样后指定的时间内，阀打开以将残留在衬管的蒸汽从分流口排出。这避免了由于大体积进样和小的色谱柱流速引起的溶剂拖尾。

不分流模式一般用于痕量分析。

不分流模式进样参数

参数 | 允许的 设定值范围 | 建议使用的 初始值
柱箱温度 | 非低温，室温 + 10°C 到 450°C CO2 低温, -60 [image] C 到 450°C N2 低温, -80 [image] C 到 450°C | 比 溶剂沸 点 低 10°C
? 柱箱 初始时间 | ? 0 到 999.9 分钟 | ? 进样吹扫时间
? 进样 吹扫时间 | ? 0 到 999.9 分钟 | ? (衬管体积*/ 色谱柱流量) x 2
? 气体存储 时间 | ? 0 到 999.9 分钟 | ? 吹扫时间后
? 气体存储器 流量 | ? 15 到 1000 mL/min | ? 比最大色谱柱流量大 15 mL/min
? 进样口温度 | ? 非低温, 室温 + 10°C 到 450°C CO2 低温, -50 [image] C 到 450°C N2 低温, -160 [image] C 到 450°C | ? 在 0.1min 内比溶剂沸点低 10°C，然后梯度升温
* 衬管体积约为 120 uL

当进样口温度过热或过冷时，根据样品和分析的类型不同，液体样品可以 PTV（程序温度蒸发）进样。

冷不分流进样

对于冷不分流进样，使用低于溶剂正常沸点的初始进样温度。对于大多数溶剂，在 0.1 分钟时开始第一个进样温度梯度可以提供良好的转移和再现性。500°C/min 或更高的程序速率适合热稳定性分析物。350°C 的最终温度持续 5 分钟可以使 C44 的烷烃定量的转移。

程序升温进样的优点是可以为转移敏感的待分析物缓慢的升温。如果柱箱温度开始时足够低可以将待分析物聚集在色谱柱上，进样口加热速率可能减慢以减少进样口处的热分解，改善峰形和定量。

对于大多数冷不分流模式的使用，单一温度梯度足够了。其余梯度可用于清扫衬管或为准备下一次进样而降低进样口温度。

热不分流进样

对于热不分流进样，选择的初始温度要足以蒸发待分析物。由于进样口在运行过程中保持设定值，所以没有其他的温度参数。

由于衬管体积小（约 120 毫升），PTV（程序温度蒸发）不能容纳大体积进样的蒸汽。进样体积大于 1ml 蒸汽可能从进样口溢流，引起分析偏差。冷不分流进样避免了这个问题

如果色谱柱被定义,为不分流模式设定下列参数(有关更详细信息，单击任何绿色区域):

有关定义色谱柱的信息，请参见向目录中添加新色谱柱型号。


不分流模式

进样时，电磁阀关闭而样品进入接口并被转移到色谱柱。在进样后指定的时间内，电磁阀打开。

成功的不分流进样包含下列步骤：

  1. 将气体样进到加热的接口。

  2. 在柱头聚集样品时，使用低柱箱温度。

  3. 设定进样结束时间让所有样吹扫出进样器。

  4. 设定吹扫时间使所有样品聚集到色谱柱。

  5. 开始柱箱的程序升温。

不分流模式操作参数

参数 | 建议使用的初始值 | 允许范围
柱箱初始时间 | 0 到 999.9 分钟 | > 接口吹扫时间
接口温度 | 室温 + 10C 到 400C | > 传输线温度
接口进样结束 | 0 到 999.9 分钟 | 比进样时间长 0.2 分钟。
接口吹扫时间 | 0 到 999.9 分钟 | 进样结束后
接口吹扫流量 | 0 到 100 mL/min | > 色谱柱流量 + 6 mL/min 隔垫吹扫
气体节约时间 | 0 到 999.9 分钟 | 一定在吹扫时间之后
载气节省流量 | 15 到 100 mL/min | 比最大色谱柱流量大 15 mL/min。

有关更详细信息，请参见不分流模式气路。

本对话框目录：

Gas（气体）

Heater（加热器）

Pressure（压力）

Total Flow（总流量）

Sampling End（进样端）

Purge Time（吹扫时间）

Purge Flow（吹扫流量）

GasSaver（载气节省）（如果色谱柱已被定义）


不分流模式

在这种模式下进样时，吹扫阀关闭并且在样品从衬管蒸发、转移到色谱柱时维持此状态。在进样后指定的时间内，吹扫阀打开以将残留在衬管的蒸汽从分流口排出。这避免了由于大体积进样和小的色谱柱流速引起的溶剂拖尾。

不分流模式通常用于痕量分析。

不分流模式进样参数

参数 | 允许的 设定值范围 | 建议使用的 初始值
柱箱温度 | 非低温, 24°C 到 450°C CO2 低温, -60 [image] C 到 450°C N2 低温, -80 [image] C 到 450°C | 比 溶剂沸 点 低 10°C
柱箱 初始时间 | 0 到 999.9 分钟 | 进样口吹扫时间
进样口 吹扫时间 | 0 到 999.9 分钟 | (衬管体积/ 色谱柱流量) x 2
载气节省 时间 | 0 到 999.9 分钟 | 在吹扫时间之后
载气节省 流量 | 15 到 1000 mL/min | 比 最大色谱柱 流量 大 15ml/min

为不分流模式设定下列参数（有关详细信息，单击绿色区域）：

有关定义色谱柱的信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。


不分流模式气路

在预运行前，当 6890 GC 准备进样时，接口的总流量由流量传感器测量并由比例控制阀控制。色谱柱流量通过反压调节控制。

在采样时间内，当外部进样时，由于阀的切换引起的压力失常可能引起色谱柱流速的波动。为对此进行补偿，接口在采样时间内采取流量控制。采样流速由压力设定值计算，这个设定值从进样开始有效。当 6890 GC 进入“预运行”状态（当预运行灯亮时）时，流量控制模式开启，并在接口采样结束时结束。

在用户指定的采样时间内，电磁管阀关闭。接口流量由流量传感器测量并由一个比例控制阀控制。

采样时间后，电磁阀打开。当色谱柱流量被后压力调节控制时，接口流量再次被流量传感器测量，并被比例控制阀控制。吹扫流量由用户控制。如果愿意，载气节省可以在运行结束时打开。

当色谱柱被定义时

如果改变 － 当设定值改变时

吹扫流量 吹扫总流量**

压力 吹扫总流量**

色谱柱流量*

色谱柱流量*吹扫压力

总流量**

压力 非吹扫色谱柱流量*

总流量**

色谱柱流量*非吹扫压力

总流量**

*此设定值出现在色谱柱控制表中。

**此值仅为实际值。

在采样时间内不能改变压力和流量设定值。

当色谱柱没被定义时

吹扫时 可以改变压力和总流量设定值。其他设定值不受影响。

不吹扫时 在采样前后，可以改变压力设定值。其他设定值不受影响。

在采样时间内 不能在采样时间内改变压力和流量设定值。


堆栈

当从菜单中选择Tools /Options/Stack（工具/选项/堆栈）时，在窗口下部显示小堆栈窗口。可以在命令行输入 STACK（堆栈）控制其开关。可以拖动标题栏移动窗口，也可以拉伸窗口以浏览更多内容。

该窗口显示变量名为 X、 Y、 T、 Z、 R0、 R1......R9 的变量的值。哪个变量没被定义，“null（空）”这个词将出现在变量名旁边。


标准

标准为包含已知量目标化合物和内标物的样品，内标用于提供 MSD 的定量校准。也可以称为校准样品。


标准谱图自动调谐

“标准谱图自动调谐”保证整个质量范围内的标准响应。特定地，PFTBA(全氟三丁基胺）质量 69 为基峰，质量 219 在 35％ 和 99％之间，质量 502 >1％。如果计划使用此调谐进行质谱库检索。选择此调谐时，一些参数被限定为标准操作条件： EI 模式、 CI 气体关闭 (如果 CI 附件存在)和校准阀打开。


标准谱图调谐（5973 MSD）

标准谱图调谐

Standard Spectra Tune（标准谱图调谐）确定整个质量范围内的标准响应。特别地，PFTBA(全氟三丁基胺）质量 69 为基峰，质量 219 在 35％ 和 99％之间，质量 502 >1％。如果计划进行质谱库检索使用此调谐。选择此调谐时，一些参数被限定为标准操作条件： EI 模式、 CI 气体关闭 (如果 CI 附件存在)和校准阀打开。


开始

运行后的时间（分钟）从化学工作站开始保存信号数据时开始计时。


开始按钮

开始按钮 |
 | 运行没进行时，该按钮上的箭头为绿色（用于“进入”）。如果想开始运行，单击绿色箭头，填充 Sample Information（样品信息）字段，并单击 Start Run（开始运行）按钮。当运行进行时，箭头为灰色。 按钮也显示当前的数据文件名、样品信息（如果有）和瓶号（1，如果不使用 ALS）。
 | 注在 5973 MSD 系统上，当开始一个运行时，运行将直到源和四极杆温度在三度公差内平衡时才开始。可以越过这段等待时间并且在记录文件中会说明平衡被越过。


开始运行

开始运行对话框

"开始运行”对话框用于输入待分析样品的信息，并开始运行。More（更多）按钮引导您使用对话框的扩展型式。

Vial（瓶）

Data File Name（数据文件名）

Operator Name（操作者姓名）

Sample Name（样品名称）

Misc Info（其他信息）

Method Sections to Run（运行方法部分）

Vial（瓶）

该区域为样品瓶指定位置。如果在 Start Run（开始运行）对话框的Method Sections to Run（运行方法部分）选择了 Data Acquisition（数据采集），要求为样品瓶指定位置。

  • 对于 ALS 进样，根据如下所述在该字段内输入瓶的物理地址：

存在 ALS 瓶架
输入一个 1 到 100 的数。

正常排列的转动架
输入一个 1 到 3 的数(没有样品瓶架)。

排列紧密的转动架
输入一个 1 到 8 的数(没有样品瓶架)。

  • 对于手动进样（没有 ALS ），Vial（瓶）字段可以用于标明样品瓶的标签。

数据文件名

要求。如果方法包括“采集”，这就是存储数据的文件。如果方法不包括“采集”，这应该是以前要求的用于“数据分析”的数据文件。类型？显示有效数据文件列表。

操作者名

可选择的 该字段仅在“开始运行”对话框的Method Sections to Run（运行方法部分）的“数据采集”打开时才能访问。输入操作运行的人的名字。该名字存在数据文件的标题里。这条信息也能通过选择File / Edit File Info（文件/编辑文件信息）在“数据分析”中进行修改。

样品名

可选的。这是为您的样品指定名字。该字段只是信息提示并被存储在数据文件标题里。这条信息也能通过选择File / Edit File Info（文件/编辑文件信息）在“数据分析”中进行修改。

Misc 信息

可选的 这一字段仅在“开始运行”对话框的Method Sections to Run（运行方法部分）的“数据采集”打开时才能访问。输入样品或方法的其他信息。该字段存在数据文件的标题里。该字段可以通过 Acquisition － Sample Information（采集 － 样品信息）框和 Sample Log Table(样品日志表）访问。它也能通过选择File / Edit File Info（文件/编辑文件信息）在“数据分析”中进行修改。

运行方法部分

选择在该分析中使用的方法部分。对话框首次出现时被复选的部分是被当前方法指定的。进行的任何改变均是目前方法的一部分（内存中）。如果使它们成为磁盘上的方法部分，则需要保存该方法。

更多按钮

单击More（更多）时可获得下列项目：

  • Expected Barcode（预期的条形码）:

如果生成定量报告作为方法的一部分，下面两个项目可能需要：

  • Sample Amount（样品量）： 将化合物的绝对数量转化成原始样品的百分比的除数。

  • Multiplier(乘法器）： 乘法器校正稀释物或调节处理其他样品。

  • Pre-Run Macro/Cmd and Post-Run Macro/Cmd（预运行宏/命令和后运行宏/命令） 可选的 该字段允许在运行方法前后运行一个宏或程序。“后运行”对自动形成结果到第三方软件的转换是有用的。“预运行”可以用于仪器的自动调谐。


启动序列

启动序列对话框

该对话框用于设定一些控制序列进程的一般参数。当准备好开始一个序列时，单击 Run Sequence（运行序列）。

运行方法部分

  • Full Method（全部方法）选项是根据在每个方法的 Method Information（方法信息）对话框中复选方法部分确定每个要运行的方法。

  • Reprocessing Only（仅重新处理）选项说明要跳过方法的 Acquisition（采集）部分。运行方法的其他部分（如果该部分已在 Method Information（方法信息）对话框中选定）。

条形码不匹配

  • 如果希望即使预期的条形码和实际的不匹配时也进样，选择Inject Anyway（任何情况下进样）。

  • 这一命令也控制当 ALS 出现故障时发生的情况。它可用于避免有大量样品瓶在转动架内或避免序列由于暂时的 ALS 故障状态而停止（使样品失效）。如果希望序列在 ALS 故障后终止，则选择 Don't Inject（不进样）。

重写存在的数据文件

如果希望序列覆盖和新文件同名的已存在的数据文件，复选此框。

序列注释/操作者名称

（可选的）这个字段用于输入序列的信息和记录操作者名称。

数据文件目录

如果希望数据文件保存一个子目录中，而不是在显示的数据文件中，输入另一个子目录。如果这个子目录不存在，它将被创建。如果输入多个子目录，除了最后一个以外别的必须是已经存在的。

More（更多）>>按钮

这个按钮为您提供另外两个可能包含在序列中的条目。Pre-Seq Macro/Cmd（前一个序列宏/命令）和 Post-Seq Macro/Cmd（后一个序列宏/命令）。后者对自动控制结果到第三方软件的转换很有用。


开始色谱柱补偿运行

化学工作站在一个较平的基线上积分比在上升的基线上更准确、重复性更高。

使用色谱柱补偿纠正程序升温过程中基线的上升。

首先,使用StartColCompRun（开始色谱柱补偿运行）产生一个空白运行（未进样）。GC 保存这次运行的数据，并从实际运行数据中将其扣除以生成一个较平的基线。

色谱柱补偿运行的色谱条件必须与实际运行中使用的条件相同。使用相同的检测器和色谱柱，并在相同的温度和气体流量条件下操作。

  1. 指定使用哪个检测器（参见选项）有关曲线 1和曲线 2（相对于色谱柱 1 和色谱柱 2）。

  2. 选择StartColumnCompRun（开始色谱柱补偿运行）。化学工作站为下列文件的两个色谱柱收集色谱柱补偿数据：

  • col comp 1 (色谱柱 1 的补偿数据)

  • col comp 2 (色谱柱 2 的补偿数据)

  3. 在 Signal（信号）窗口选择Det（检测），然后（为源）指定实际运行将使用的检测器和将在实际运行数据中扣除的色谱柱补偿数据：

  • Front det - col comp 1（前检测 － 色谱柱补偿 1）

  • Back det - col comp 1（后检测 － 色谱柱补偿 1）

  • Front det - col comp 2（前检测 － 色谱柱补偿 2）

  • Back det - col comp 2（后检测 － 色谱柱补偿 2）

  4. 进行实际运行（化学工作站将进行自动扣除）。

注意：为将色谱柱补偿运行的数据绘成图，选择Det（检测） (在 Signals（信号）对话框), 指定一个源（为col comp 1（色谱柱补偿 1）或col comp 2（色谱柱补偿 2）并开始运行。


声明（定义）

 声明 NAME（名称）和 PARAMETER（参数）在编写宏时使用。


状态菜单（诊断）

状态菜单（诊断视窗）

Diagnostics（诊断）视窗中的Status（状态）菜单允许检查 MSD 的状态：

MS 状态 | 报告总体状态。
MS I/O 测试 | 测试 16 I/O 行。
MS 接口故障 | 显示由仪器接口卡报告的最近一次故障。（有关故障的列表，在Trace（曲线） On（打开）在File（文件）菜单中设定。可以通过选择View Trace（检查曲线）在记事本中检查文件 tune.trc。)
MS 温度控制状态 | 仅对 5973 MSD 适用。显示 MS 温度控制器的状态。如果源或四极杆有温度控制故障，选择这个菜单项将显示可能的原因。
MS 故障码 | 解释列在文件 MSERROR.LOG 中的故障码。输入故障号，诊断信息将显示出来。有关故障列表、它们的值和可能原因，请参见MS 故障。
记录本/序列记录故障码 | 解释日志或序列记录中列出的故障码。输入故障码号，故障提示会显示出来。
MS 温度 | 仅对 5973 MSD 适用。显示源和四极杆的实际温度并可以更改设定值和限制。


状态菜单

使用 Status（状态）菜单检查在 Manual Tune（手动调谐）下质谱仪的状态。

MS 状态 | 报告总体状态。
MS I/O 测试 | 测试 16 I/O 行。
MS 接口状态 | 显示由仪器接口卡报告的最后一个故障。（有关故障的列表，在Trace（曲线） On（打开）在File（文件）菜单中设定。可以通过选择View Trace（浏览曲线）在记事本中浏览文件 TUNE.TRC。)
MS 温度控制状态 | 仅对 5973 MSD 适用。显示 MS 温度控制器的状态。如果源或四极杆有温度控制故障，选择这个菜单项将显示可能的原因。
真空度/温度状态 | 报告子系统真空状态并显示前级真空压力 (毫托) 和 MS 分析仪温度（摄氏度）。


状态菜单 － CI 调谐（5973 MSD）

状态菜单 － CI 调谐

仅适用于为 CI 配置的 5973 MSD。使用Status（状态）菜单检查 MSD 的状态。

MS 状态 | 报告总体状态。
MS I/O 测试 | 测试 16 I/O 行。
MS 接口故障 | 显示由仪器接口卡报告的最后一个故障。（有关故障的列表，在Trace（曲线） On（打开）在File（文件）菜单中设定。可以通过选择View Trace（检查曲线）在记事本中检查文件 TUNE.TRC。)
MS 温度控制状态 | 显示 MS 温度控制器的状态。如果源或四极杆有温度控制故障，选择这个菜单项将显示可能的原因。
真空度/温度状态 | 报告子系统真空状态并显示前级真空压力 (毫托) 和 MS 分析仪温度（摄氏度）。


停止

时间（分钟）从化学工作站停止保存信号数据时开始计时。


停止信号
当运行时 Stop（停止）标签为红色，而不运行时为灰色。当系统处于 PreRun（预运行）、Run（运行）或 PostRun（后运行）时，使用该按钮停止或（异常中止）系统。如果系统处于 Run（运行）状态,系统将进入 PostRun（后运行）。如果系统处于 PostRun（后运行）状态,系统将进入 Idle（空闲）状态。


由 停止按钮结束

由于按下“Stop（停止）”按钮，就停止了当前操作。检查所有瓶子均在正确的位置上并在运行。


字符串变量（定义）

一个字符串变量被赋于一个文本值而不象标量变量，标量变量的变量名必须以 $ 标记结尾。例如，Var是一个标量变量，仅能赋实际值值。

Var$ 是一个字符串变量，它的值可以为任意文本（总共 132 个字符）。然而，注意可以在一个程序行中输入并被系统接受的字符最多为 132 个，包括变量名。如果希望字符串值为 132 字符，创建两个 66 个字符的字符串变量，然后将它们叠加起来。

a$=“66 个字符”

b$=a$ + “66 个字符”


结构菜单

选择结构数据库 | 允许您指定画出结构时使用的那个结构数据库。
设定结构参数 | 允许您指定缺省选项。可以在画出一个结构时，改变使用的颜色、字体和方位。

有关结构的详细信息，单击显示在菜单项调用框中的 Help（帮助）按钮。


摘要报告

定量数据库中每个化合物是基于当前数据文件的报告。

每个化合物的登录号、名称、保留时间、浓度和峰类型是和定量设定一起进行列表的。


仅适用于摘要报告

对话框的这个部分允许您在 Summary Quantitation Report（摘要定量报告）中包括或排除几种类型的信息。可以包括或排除的信息类型为：

  • 定量离子（GC/MS 模式）

  • 扫描数（GC/MS 模式）

  • 多组分摘要（仅适用 GC 模式）

为将信息包含在摘要报告中，选择相应的对话框。

GC/MS 模式

在 GC/MS 模式中，摘要报告可以包含定量离子的质量或目标化合物的扫描次数。由于摘要报告中没有足够的空间容纳两条信息，必须进行选择。


支持阀

MS Timed Events Table（MS 时间事件表）允许在数据采集过程中控制校准阀和两个辅助输出。辅助输出可以控制 5- 或 24- V dc 设备，例如，螺线管阀或提供给用户的硬件的继电器。

欲控制一个阀，选择 Valve（阀）为 Event Type（事件类型）。在 Parameter（参数） 1框内选择它的阀号并在 Parameter 2（参数 2）框中选择它的 On/Off（开/关）状态。阀门在每次运行开始重新设定。

有关更多信息，请参见 MS 硬件文档。


替代物 － 定义

替代物是添加到每个标准的、空白的、基质添加、复制的基质添加和未知样品的一种化合物（在样品准备之前）。替代物被以确定的已知浓度添加。它用于确定样品准备过程的效率。

替代物应具有与目标化合物相似的化学性质但不能在真实样品的基质中发现。含重氢的化合物通常用作替代化合物。

替代物有时被称为系统监控化合物。


替代/基质添加数量

如果当前化合物为基质添加化合物(化合物类型 = M)或替代化合物(化合物类型 = S),添加或替代物浓度应该被输入相应的Surrogate / Matrix Spike amount（替代物/基质添加数量）字段。不同字段允许不同的基质或替代物浓度输入相应的基质。


切换开关

通常为 4、6 位的双位置阀，或用于选择色谱柱和隔离色谱柱的更多阀门。

使用 Description of use（使用说明）详细说明阀的作用，例如,“中心切割。”


切换开关

4、6 或更多端口的双位阀。

切换阀是用于选择色谱柱和隔离色谱柱的一般性阀门。


注射器尺寸

说明注射器的体积容量。有关进一步信息，请参见 GC 注射器手册。

本对话框中其他项目：

Nanoliter Adapter（纳升接头）

Multiple Injections（多次进样）

On-Column Injection (not available on all injectors)（柱头进样(不是对所有进样器有效））

OK/Cancel/Help Buttons（确定/取消/帮助按钮）


表格按钮

Add（添加）

在表格上部字段里输入的信息作为程序行显示在表格上。

Replace（替换）

表格里的选定程序行被表格上部字段中输入的信息替换。（仅适用于时间事件表。)

Delete（删除）

删除选定行。

OK（确定）

表格中的所有更改均保存在内存中。如果在离开该对话前不保存当前方法，这些采集参数将会丢失。

Cancel（取消）

允许您不保存对表格的任何更改离开面板。


制表

如果有两个或两个以上的光谱图，则要求您选择一个进行制表：

  • 谱库登录值

  • 未知样品( X 的含量)

  • 差值[X 的含量 - NORM (谱库登录值)]

注意为了便于与谱库登录值比较，将未知光谱 Y 轴的值域归一化为 9999。


制表

从目前制表中可得到更多信息(用菜单项生成表格):

  • 积分结果 (List Results 在 Chromatogram 菜单中)

  • 质谱制表 (Tabulate 在 Spectrum 菜单中)

  • PBM 检索 - 统计 (Statistic 按钮在 PBM Search Results 框中，谱库检索结束时通过鼠标显示)

  • PBM 检索 - 文本结果 (Text 按钮在 PBM Search Results 框中，谱库检索结束时通过鼠标显示)

使用 Copy（复制）按钮将信息复制到 Clipboard（剪贴板）。使用 Print（打印）按钮将表格复制到打印机。


目标化合物鉴定

目标化合物的鉴定主要是依据第 1 页上每个化合物的数据库条目信息：

  • 预计保留时间（保留时间信息）

  • 目标和特征信号的质量和预计比例（用于定量分析的信号）

  • 扣除方法

  • 鉴定方法（识别对象）

  • 积分参数（在第 3 页上）

鉴定过程分为五个步骤:

  1. 信号提取。 对于每个目标化合物，从当前的 GC/MS 数据文件中提取目标色谱曲线。从数据文件中提取特征曲线或质谱响应(选择取决于 Subtraction Method（扣除方法）)。

  2. 信号积分。 把所有的色谱曲线进行积分，对每条曲线尽可能选择用户特定的积分参数。

  3. 峰叠加。 然后的工作步骤是根据保留时间的接近程度把不同信号(即目标和特征信号)的叠加峰按照保留时间分组。其思路是从不同的离子曲线中将对应相同的色谱洗脱事件（因此可能为同一化合物）的积分峰收集在一起。

可以为该名为 Correlation Window（相关窗口） 的工作步骤设置一个“保留时间接近度”参数。多数情况的缺省设定为 0.01 分钟。现在每组均为与 Target Compound（目标化合物）匹配的候选物。

  4. 峰匹配。 现在目标化合物鉴定算法检查每一保存的色谱峰组。如果色谱峰组包含一个与目标化合物条目的保留时间“匹配”的目标信号峰，该色谱峰组被认为与目标化合物相匹配，保存在匹配列表中。(“匹配”并不意味着“准确”的对应。)

  5. 最佳-匹配选择。 然后根据用户为化合物选择的 Ident By（识别对象），从匹配列表中选择一个最佳匹配项。保存所有的匹配项，并标明最佳的匹配项。


目标化合物

目标化合物为指定的根据环境分析协议分析的化合物。


目标离子 - 定义

目标离子是目标化合物的特征离子，它应该能将该化合物与其他具有相同保留时间的化合物区分开来。该离子的提取离子谱用于定量分析。


目标离子与特征离子

高丰度离子是目标离子和特征离子比较理想的选择，这是因为它们可以提高分析的灵敏度。目标离子应为特征离子，尤其是能将该化合物与在该化合物特定的保留时间范围内发现的其他化合物区分开来的离子。

如果确定了特征离子，为了使该峰被确定为目标化合物，它们与目标离子的相对存在数量要合适。

如果使用 TIC 作为定量信号并使用特征离子，则在 Quant Setup（定量设置）对话框中输入离子比可能出错。

要得到正确的比例：

  1. 添加至少一种校准级(这步是必须要做的。)

  2. 再校准使用 Replace Qualifier Ion Relative Responses（替换特征离子相对响应）选项的校准级。


目标调谐

目标调谐是校验 MSD 性能的一种方法。目标调谐的方法是先分析调谐评价化合物的样品，然后根据环境分析协议中指定的标准来评价所得质谱的质量轴校准、质量分辨率和离子比。目标调谐化合物有时称为调谐评价。


目标调谐化合物

目标调谐化合物是用于根据特定的环境分析协议来定义 MSD 性能的化合物。该软件将 BFB 和 DFTPP 识别为目标调谐化合物，并为这些化合物的样品提供自动调谐评价。目标调谐化合物有时称为调谐评价化合物。


温度梯度

一个梯度辅助通道温度程序在运行过程中，控制的通道温度最多可有三级（或“梯度”）。化学工作站以连续的顺序执行这些程序梯度。一个程序包括:

  • 辅助通道初始温度，和

  • 最多三个辅助通道的温度梯度。

GC 将在指定的分钟数时间内 (Hold min) 保持初始的辅助通道的温度。然后 GC 以指定的速率（单位为度 C/min）将温度改变至梯度 1 的温度，并在指定的时间内保持该温度。可以用同样的方法编程使温度改变至梯度 2和3 的温度。

柱箱程序决定运行时间长短。

如果梯度辅助通道温度程序比柱箱程序长，那么柱箱程序结束时梯度辅助通道程序将会被切断。

如果辅助通道温度程序比柱箱程序短，辅助通道将保持程序的最终温度直到柱箱程序运行结束。

对梯度辅助通道温度程序指定下列参数。有关详细信息，请单击下面各项：

C/min（度/分钟）

下一个 [image] C（摄氏度）

Hold min

总分钟数为每个梯度水平的累积运行时间（由柱箱程序决定）的只读显示。

要查看辅助通道温度设定值的图形，请单击 Plot... 按钮，选择 Aux #1 (or #2) Temperature:（辅助通道 1 (或 2) 的温度:）


温度传感器出现故障

这不可能为出现 Temperature zone has timed out（温度区暂停）提示的原因。在选择 MS Temp Ctlr Status（MS 温度控制状态）的情况下，传感器故障通常会使下列提示出现：

离子源温度传感器断开

离子源温度传感器短路

质量过滤器（四极杆）的温度传感器断开

质量过滤器（四极杆）的温度传感器短路

然而，如果发现暂停提示并排除了其他的可能原因，则传感器可能出现故障。


温度传感器未可靠地连接

如果温度传感器未牢固连接，它指示的温度比加热区的实际温度要低。这将导致温度控制电路继续让加热器卡套加热，导致区域过热。如果传感器很松，升温速度将很慢或加热区域不能达到设定值，这样会产生暂停故障。

  1. 放空 MSD。

  2. 打开真空多路连接管。

  3. 检查离子源温度传感器。确定离子源温度传感器可靠地连接。

注意

任何时候打开真空多路连接管时都要做好防静电放电（ESD）的措施，尤其是在质量过滤器（四极杆）触点附近操作时。这些触点可以将有害的静电荷转移到侧板上的敏感组件上。

  4. 检查质量过滤器温度传感器。确定离子源温度传感器连接可靠。

有关放空真空多路连接管的说明，请参见 MSD 硬件手册。


温度区暂停

该提示意味着某个加热区的温度上升速度比正常速度慢，或加热区在规定时间内未达到其温度设定值。这可能由以下几种原因引起：

加热器连线错误

加热套故障（开路）

温度传感器未可靠连接

温度传感器出现故障


前后进样器使用相同的瓶号

化学工作站接到 Start Run 命令，为前后进样器指定相同的瓶号。同步进样可避免在运行中两次进样时使用同一样品瓶。


热导检测器

TCD 比较两股气流的热导率 [image] ，两股气体分别为纯的载气（又称为参比气体）和载气与样品组分的混合物（又称色谱柱气流）。

该检测器包含一个电加热的金属丝，其温度高于检测器主体。在参比气体和柱流轮流通过金属丝时，化学工作站保持金属丝温度恒定。添加样品时，需要保持金属丝温度恒定的功率出现变化。两股气流每秒在金属丝上切换 5 次，化学工作站测量并记录下功率差值。

使用氦气（或氢气）作载气时，样品会使热导率降低。如果用氮气作载气，则通常热导率会增加，这是由于大多数物质的热导率都比氮气高。

由于TCD 在检测过程中不损坏样品，因此可将它与火焰离子化检测器或其他检测器连接起来使用。

使用 TCD 对话框设定检测器参数并指定设定值。有关详细信息，请单击下面各项：

为 TCD 选择温度和流速时请使用下表中的信息。

推荐的流速和温度

气体类型 | 流速范围 | 建议流速
载气 （氢气、氦气、氮气） | 0 至 100 ml/min | 填充柱, 10-60 ml/min 毛细管柱, 1-5 ml/min
参比 （与载气同一类型） | 0 至 100 ml/min | 15 至 60 ml/min
毛细管柱组成 （与载气类型相同） | ? He = 0 至 12 ml/min N2 = 0 至 10 ml/min H2 = 0 至 18 ml/min | ? 5-12 ml/min [image] 毛细管柱 2-3 ml/min [image] 填充柱

检测器温度

<150 [image] C [image] 不能启动金属丝
150 [image] C to 200 [image] C [image] 金属丝处在较低设定值
>200 [image] C [image] 灯丝处在较高设定值
检测器温度应比最高梯度炉温高 30°C 至 50°C。

数据分析的 TCD 信号转换：

  • 25 [image] V = 1 高度单位

  • 25 [image] V x 1 second = 1 面积单位


阈值设置过高

减小阈值设置。


TIC - 定义

TIC（总离子流色谱）的 Y 轴为每次扫描中所有离子丰度的总和。首次加载数据文件时，TIC 在 Data Analysis（数据分析）窗口中显示。


时间 (min)

在一个事件即将发生时，启动运行后开始计时（以分钟为单位，例如 0.50 分钟）。

注意：0.00 分钟代表运行开始。


时间参比峰 － 定义

时间参比峰用于增加通过校正保留时间的漂移来发现目标峰的机率。

时间参比峰必须是在校准和未知样运行中都出现的一个显著峰。内标或替代峰为理想的参比峰。多个时间参比峰优于单峰，应均匀分布在整个运行过程中。如果使用单峰，则单峰不应出现在运行开始时。


暂停启动检测

指定的 min 时间内没有启动仪器，将关闭柱箱和低温冷却。


采集 RTL 校准数据

  1. 对于 ALS 进样，将样品瓶放在位置 1。

  2. 从“仪器控制”视窗上选择仪器/采集 RTLock 校准数据。RTL 校准文件收集开始。

系统将对校准范围 -20%、-10%、+10% 和 +20% 的标识压力进行评价，自动运行五次。系统提示您将运行五次，如果存在以前的校准数据，您也会得到提醒。您可以清除以前的校准或停止运行。五个数据文件将保存在方法目录下的 RTLOCK 文件夹中，文件名为 RTLOCK1 - RTLOCK5。

数据采集完成后，将开始新一轮的“数据分析”。系统将载入标识运行（MS 模式）或所有五次运行（GC 模式）以进行评价数据和设置锁定的实际处理。

另见

保留时间锁定


添加谱库谱图和未知样谱图 (PR)

  1. 选择 File / Load （文件/加载）并选择一个文件。窗口的上半部显示 TIC，下半部显示谱库谱图。

  2. 在 TIC 峰上双击鼠标右键，选定所显示的谱图。窗口的上半部显示未知样谱图，下半部显示谱库项谱图。

  3. 选择 Spectrum / Add（谱图/添加）。将添加谱库项和未知样 (X) 的谱图，在窗口顶部显示。

注意 添加操作会改变堆栈中 X 的含量；换言之，未知样改变了。


添加新项目

  1. 在 TIC 的目标扫描图形上双击鼠标右键，选择谱图。

如果您已经了解了该谱图的谱库信息，请转到第 4 步。否则进行 PBM 谱库检索，选择合适的匹配。然后单击文本显示文本结果。

  2. 按 Alt-Print Screen 键将文本结果复制到剪贴板上，可在输入谱库信息时以备参考。或者按 Print 按钮将文本结果发送至打印机。

  3. 如果已将结果复制至剪贴板，请在 Windows 程序管理器中打开 Clipboard Viewer。

  4. 在 Data Analysis（数据分析）菜单中选择 Spectrum / Edit Library（谱图/编辑谱库）。

  5. 在 Edit PBM Library（编辑 PBM 谱库）对话框中单击 Add New Entry（添加新项目）。

  6. 自动给新项目指定下一个项目号，显示 New Entry（新项目）对话框。

  7. 为新项目输入您所需要的有关信息。

必须输入样品名称，样品分子式或分子量；最好输入分子式，由系统计算分子量。如果分子式或分子量未知，则输入 9999 作为分子量。有关字段的详细信息，请参见编辑项目。New Entry（新项目）对话框中的字段与 Edit Entry（编辑项目）中相同。


添加新浓度

  1. 选择 Add New Level（添加新浓度）。

  2. 命名 Calib Level ID（校准级 ID） 。

  3. 输入该校准文件中所用的 Cmpd Conc（化合物浓度）和 ISTD Conc（内标物浓度）。

  4. 单击 Do Update（执行更新）。

输入的 Cmpd Conc（化合物浓度）和 ISTD Conc（内标物浓度）数值分别为当前数据文件中所用的样品中存在的化合物和内标物含量的缺省值。

如果样品含有几种浓度相同的化合物，使用该浓度作为缺省值。Edit Compounds（编辑化合物）对话框在 Do Update（执行更新）完成后自动显示，您即可对浓度不同的化合物进行编辑。

如果数据库中的化合物不在校准样品数据文件中，在该浓度的响应字段中显示空白。该化合物的浓度将被取消。


向用户谱库 (PR) 中添加当前项目

在 Parametric Retrieval（参数检索）窗口的菜单中选择Library / Add Current Entry（谱库/添加当前项目），系统将提示您选择添加哪一项谱图:

  • 参数检索中显示的谱库项目

  • 您从 TIC 中选择的未知谱图

  • 参数检索相减的差分光谱

您的选择将添加到当前编辑谱库中。要改变当前编辑谱库，选择Edit Library（编辑谱库）（在Library（谱库）菜单中）。


调节实时 GC 图的坐标设定

单击箭头调节信号范围，以实时满量程显示。显示为 2 的幂。补偿不能实时进行修改。

另见

GC 实时图


向方法指定样品名称

当前加载的方法中总共可以加入 15 个样品。使用 Secured Control（安全控制）中的 Assign Sample Names to Method（向方法指定样品名称）菜单项将显示 Select Sample Name Action（选择样品名称操作）对话框，在其中指定样品名称。以后在 Secured Control（安全控制）中选择该样品名称时，相关方法即可用于采集和分析。

  1. 选择 Secured Control / Assign Sample Names to Method（安全控制/向方法指定样品名称）。显示 Select Sample Name Action（选择样品名称操作）对话框。

  2. 选中<New Sample>（新样品）行，单击 Modify（修改）按钮。

  3. 输入样品名称，单击 OK（确定）。所选名称添加到列表中。

选择现有输入行可更改样品名称。在同一方法中样品名称不能复制，<新样品>保留用于新样品名称，因此不可使用。要删除样品名称，请选择样品名称并输入一个空字符串。

  4. 继续添加样品名称（最多 15 个）。

  5. 完成指定样品名称后，单击 Done（完成）按钮。样品名称保存到方法中，方法名称添加到 Secured Control（安全控制）中可用方法的样品中心列表中。


检查整个色谱

使用这个步骤来对整个复杂色谱进行扫描，检查可能含有多个组分的所有色谱峰。

  1. 调用该数据文件。

  2. 对谱图进行积分。

  3. 在菜单中选择 View（查看）/ Review Peak Purity（检查峰纯度）。

  4. 扫描 Peak Purity Display（峰纯度显示），检查含有多个组分的质谱峰。

  5. 如果 Peak Purity（峰纯度）发现某峰中含有不止一个组分，若您想从离子色谱中提取一个色谱，那么您需要进行谱库检索。如果谱库检索证实它是一个不合需要的组分，您可以从图谱中将它扣除去。

  6. 在菜单中选择 PkPurity（峰纯度）/ Return to DA（返回 DA）或调用一个新的数据文件，即可退出。


检查 5972A 的发射电流

检查灯丝的发射电流 (5972A MSD)

由于 5972A MSD 中灯丝发射特性的改变，为了提高仪器的灵敏度和离子比的稳定性，自动调谐时的灯丝缺省发射电流从 50 μA 降至 35 μA 。

如果您的 5972 MSD 是在 1995 年 12 月份以后托运的，那么它已经经过了新的缺省发射电流的测试，MSD 化学工作站软件会将修改后的设定作为批或软件的一部分囊括在软件中。

您需要优化此设定，并将优化后的设定保存到调谐文件中 (*.u) 。每次灯丝更新后都应该对灯丝发射电流进行优化设定。

为确定灯丝发射电流设定是否妥当，请检查推斥极电压变化率。下面的图形显示了发射电流对推斥极电压变化率的影响。

此图显示了发射电流过高时推斥极电压的变化率。

此图显示了发射电流达到优化时推斥极电压的典型变化率。

在第一幅图中，所有三个质量在推斥极电压最大值或其附近达到最大值。在第二幅图中，所有三个质量在推斥极电压为 20 — 35 V 时达到最大值。

第一幅图的问题是：在 Standard Spectra Autotune（标准调谐）的推斥极电压为 25 V ，而在此电压下时，三个质量在阱中的丰度仅达到最高丰度的 10 — 25% 。这就意味着灵敏度的降低。在第二幅图中 25 V 处，所有三个质量都接近或达到最大丰度。

在 Maximum Sensitivity Autotune（最大灵敏度自动调谐）中，发射电流对推斥极电压变化率有相同的影响。

注意

离子源脏了，也会出现第一幅图中相似的推斥极电压变化率。在优化灯丝发射电流之前，务必确定离子源已经被清洁过。

为优化灯丝电流设定，请：

  1. 执行标准色谱调谐。

  2. 在标准色谱调谐完成以后，启动手动调谐，调用调谐文件 atune.u 。

  3. 进入 Edit MS Parameters（编辑 MS 参数）菜单。

  4. 在屏幕的底部，单击推斥极字段 Ramp（梯度） 按钮。执行推斥极电压变化率。

  5. 检查推斥极电压变化率，并记录 质荷比 219 达到最大丰度的推斥极电压。对于最优化的灵敏度和离子比的稳定性，质荷比 219 达到最大丰度的推斥极电压应为 30 V 。如果质荷比 219 在更高的推斥极电压处达到最大丰度（或推斥极电压变化与上面的第一幅图相似），用下面的步骤调节发射电流到略小的值。

单击 Emission（发射电流）字段，视情况增加或减小发射电流 5 μA 。

在屏幕的底部，单击推斥极字段 Ramp（梯度） 按钮。

检查推斥极电压变化率，并记录 质荷比 219 达到最大丰度的推斥极电压。重复以上步骤，直到 质荷比 219 达到最大丰度的推斥极电压为 30 V （参见上面的第二幅图）。发射电流约在 20 — 35 μA 的范围内。

  6. 保存 ATUNE.U 调谐文件。

  7. 调用系统中的其他调谐文件（BFB.U ，DFTPP.U ，TTUNE.U ，等等），将调谐文件中的发射电流设定为第 5 步中确定的值，然后保存这些调谐文件。


检查单个峰的纯度

当您怀疑某个峰中含有不止一个组分，请采用以下步骤来检查该峰：

  1. 调用其数据文件。

  2. 缩小您感兴趣的峰。

  3. 对该峰进行手动积分。

  4. 在菜单中选择 View（查看）/ Review Peak Purity（检查峰纯度）。

  5. 选中 Peak Purity Display（峰纯度显示）复选框，查看该峰是否确实含有多个组分。

  6. 如果 Peak Purity（峰纯度）发现该峰确实含有不止一个组分，若您想从离子色谱中提取一个色谱，那么您需要进行谱库检索。如果谱库检索证实它是一个不合需要的组分，您可以从图谱中将它扣除去。

  7. 在菜单中选择 PkPurity（峰纯度）/ Return to DA（返回 DA）或调用一个新的数据文件，即可退出。


检查报告系统状态

在 Report System（报告系统）毗邻处双击鼠标左键。所选报告系统的状态将显示在 Report Manager status（报告系统状态）窗口。


为 Windows 配置高级链接

  1. 安装 AdvanceLink for Windows script files（ Windows 脚本文件的高级链接） 到 AdvanceLink（超级链接）目录。

  2. 在 Program Manager（程序管理器）中，选中 AdvanceLink for Windows（Windows 的高级链接）图标。

  3. 选择 File（文件）/ Properties（属性）编辑图标属性。

  4. 将 RTE.ACF 添加到命令行项目中。例如：

c:\advwin\advlink.exe RTE.ACF

RTE.ACF 是缺省配置文件。缺省配置专用于 COM1 @ 9600 baud 。

  5. 首次运行脚本文件，系统提示您输入转移过的 RTE 文件的路径。这个路径必须与 Report Managere（报告管理器）中的 RTE 菜单项中输入的路径相同。输入路径名。例如：

c:\MSDchem\1\data\

脚本然后开始运行，一直监控 RTE 文件的转移。

注意：若要编辑路径或退出，必须首先中止转移脚本文件的运行。尽管在转移脚本文件运行的时候，能够进行很多的操作，但对于转移文件的路径编辑或退出程序，都有必要中止转移脚本文件。若要中止脚本运行，请选择 Script（脚本）/ Stop Script（中止脚本运行）。


为 RTE 输入配置报告管理器

  1. 在 Report Manager（报告管理器）中，选择 Options（选项）/ RTE Monitor（RTE 监控器）。显示该对话框。

  2. 为了要在 Report Manager（报告管理器）初始化时，启动 RTE 监控器，请选择此复选框。

  3. 为转移过的 RTE 文件指定路径。

此路径名必须与 AdvanceLink（超级链接）中指定的路径相同。环境方法文件必须存在于 _methpath$ 指定的目录中，_methpath$ 位于 win.ini 文件的 [PCS,1] 部分。

  4. 单击 OK（确定）。


配置 RTE

  1. 安装 环境操作程序文件。

  2. 使用 MSCNF 配置 PC，编辑 TRFILE 配置为 TRFILE lu 。

  3. 在 BEDIT 中输入 Enviro 作为要运行的 TR 文件。

  4. 输入在 3G 中运行的环境方法文件名。

注意： 环境方法文件名必须小于或等于 6 个字符。该方法必须处于缺省方法目录下。缺省方法目录是 \MSDchem\ # \methods\ ，其中 # 是仪器号。该仪器号与启动 Report Manager MSDA（方法管理器 MSDA）时 request.ini 中 Command= 行所用的仪器号相同。

若要使 XMODM 的组 <.ms> 正常工作，RTE-6 必须将 TRFILE lu 包含在对话切换表中。

  5. 运行序列。


创建新方法

化学工作站软件允许您从已经存在的方法出发创建新的方法，指定仪器、数据采集、和数据分析的参数。

从 Top（顶部）菜单

  1. 从 Method（方法）菜单调用 default.m（或其他您想要的方法），保存到您想要的文件名。这就创建了一个新的方法。

注意 向配置有 5973 MSD 的系统调用方法时，软件将对实际离子源/四极杆温度和存储在该方法的调谐文件中的设定值进行对比。如果它们超过三摄氏度的公差范围，系统将问您是否希望下载新的设定值。

  2. 选择 Method（方法）/ Edit Entire Method（编辑整个方法）。在显示的一组对话框中，您能改变方法的任何信息，包括仪器、数据采集、数据分析参数。在您的系统中，务必建立方法的数据采集部分。

注意 您也可以在 Instrument Control（仪器控制）视窗中运行 Method / Edit Entire Method（方法/编辑整个方法）。

  3. 选择 Method（方法）/ Save（保存）来保存方法。该方法保存到仪器的方法目录下。


创建新的调谐文件

如果您想将调谐参数保存在其他文件中（例如，将 ATUNE.U 保存到另外的文件名中），而不在缺省调谐文件下，请按如下步骤进行操作：

  1. 在 Tune（调谐）菜单中选择 File（文件）/ Save Tune Values（保存调谐参数值）。

  2. 当 Save MS Tune File（保存 MS 文件）对话框出现时，为调谐文件输入一个新的文件名或在可用文件列表中选择一个文件。单击 OK（确定）。

任何在 Tune（调谐）中执行的自动调谐文件将自动保存到选定的调谐文件，直到您退出 Tune（调谐）。


删除谱库

若要删除谱库，请选择 Delete Library（删除谱库）。这样当前所选的谱库就被删除了，但系统会要求您确认谱库的删除。


删除已经存在的浓度

  1. 在 Update Calibration（更新校准）对话框中选择 Delete（删除）。

  2. 输入要删除的 Calib.Level ID（校准浓度 ID）。

  3. 单击 Do Update（执行更新）。

这样，校准浓度 ID 指定浓度下的定量数据库中所有化合物的校准数据都被删除了。


显示监测器

Display GC monitors（显示 GC 监测器）

Display MS monitors（显示 MS 监测器）

Set monitor alarms（设置监测器警铃）


显示实时图

显示 GC 实时图。

在 MS 实时图中调节 Y 坐标轴

显示 MS 实时图。


编辑项目

一个项目至少需要化合物的分子量或分子式的信息（除项目名外）。

（化学名）

与谱图相关的化合物名称。

Mol. Formula（分子式）

该化合物的分子式。

  • 若由单个字母代表元素，则这些字母必须为大写（如 C ，H ，N）。

  • 若由两个字母代表元素，那么这两个字母必须为大小写的复合模式（如 Cl ，Si）。

  • 可以使用参数[如 (CH2)6] ，但是分子式在处理时将转化为另外的格式（如 C6H12 ）。

分子量和分子式仅在添加项目到谱库时方能进行修改。一旦该项目已经经过处理并添加到谱库，这些项就再也不能进行编辑了。

Mol. Weight（分子量）

提供分子量的首选方式是输入分子式。当您将光标移至其他字段或单击 OK（确定）时，系统自动根据您输入的分子式计算分子量。您也可以输入分子量而不输入分子式或者两者都输入。在后一种情况下，系统将计算分子量并与分子量的输入值相比较。如果两者之间存在差异，系统提示您在两个值之间进行选择。如果分子量未知，请输入 9999 。分子量仅在添加项目到谱库时能够进行修改。一旦该项目已经经过处理并添加到谱库，这些项就再也不能进行编辑了。

Miscellaneous Information（其他信息）

与光谱相关的化合物的其他信息。

CAS Number（CAS 号）

Chemical Abstracts Service（化学文摘）号。

Company ID（公司 ID）

10 个字符的标识符。

Ret. Index（保留指数）

该化合物的保留指数，是从 0 到 100000 之间的一个数。

Melting Point（熔点）(C)

化合物的熔解温度。值 -300.00 表示没有可用数据或未知。

Boiling Point（沸点）(C)

化合物的沸点温度。值 -300.00 表示没有可用数据或未知。

Include in Search（包含在检索中）

选中此复选框，该项目包含在所有的检索中。若没有选中此复选框，该项目将从谱库中“删除”，即不包含在检索中。这是从谱库中“删除”项目的方法之一。


计算峰降解

  1. 选择 ChromEval/ Evaluate Degradation（色谱评估/评估峰降解）。

  2. 先对主峰进行积分，然后积分降解峰。

计算结果显示在窗口 #6 中。如果只发现一个峰，报告降解为零。


计算峰拖尾

  1. 选择 ChromEval/ Evaluate Tailing（色谱评估/评估峰拖尾）。

  2. 在窗口 #6 中对一个峰进行积分。峰拖尾显示在下一个峰中。

拖尾因子用下列参数进行计算。

Tailing = BC/AB

Peak Height = DE

10% Peak Height = BD

Peak Width at 10% Peak= AC

Apex = E


评估分离度

  1. 选择 ChromEval/ Evaluate Resolution（色谱评估/评估分离度）。

  2. 在窗口 #6 中对两个峰进行积分。

Evaluate Resolution（评估分离度）评估两峰间峰谷的高度作为两峰的平均高度。评估结果显示在窗口 #6 中。


输出 3-D 数据

您可以将选定的数据部分输出为 CSV 文件，保存于当前数据文件所在目录中。

  1. 在 Data Analysis（数据分析）中调用您想使用的数据文件。选择您要处理的特定色谱。

  2. 选择 Tools/ Export 3-D Data（工具/输出 3-D 数据）。Exporting Data（输出数据）对话框中显示 Enter Parameters（输入参数）菜单。

  3. 输入您想输出的数据的质量范围和扫描范围。

  4. 选择您想使用的文件名，单击 OK（确定）。一个复杂对话框的示例如下：

  5. 得到提示后，单击 OK（确定）证实输出数据的质量和扫描范围。使用指定的文件名新建 CSV 文件。在上面的例子中，将新建 mydate.CSV 文件。


从 3365 输入

概述

Report Manager（报告管理器）用于处理使用 3365 GC 化学工作站采集的数据。编辑 GC 化学工作站方法使之包含一个后运行程序，gctoms.exe。

该程序将pre_post.ini文件重命名为<data file name>.GC并将其存于数据目录中。“报告管理器”监控带有.GC 扩展名的文件的存在。如果检测到文件，把数据文件复制到 MS 化学工作站数据文件目录中并转化成 MS 格式。

把 .GC 文件重命名为pre_post.ini并将其保存到数据文件目录中，并将一个请求加入“报告管理器”。

配置您的系统

  1. 在 Top（上部）视窗，选择Method / Run Time Checklist（方法/运行时间列表）。

  2. 复选Post-Run Program（后运行程序）框。

  3. 输入gctoms.exe作为要运行的后运行程序的名字。

  4. 输入 pre_post 文件目录作为第一参数。

  5. 输入要运行的方法作为第二个参数。

  6. （可选项）输入要运行的命令作为第三参数。RUNMETHOD 为缺省值。

另见

从 3365 输入 － 示例


从 3365 输入 — 示例

从 3365 输入 － 示例

如果 GC 化学工作站软件位于计算机的驱动器 C 上并想运行方法 mymeth.m，应使用下列：

名字

c:\MSDchem\gctoms.exe

参数

c:\MSDchem\mymeth.m

报告管理器

  1. 在“报告管理器”中，选择Options / 3365 Monitor（选项/3365 监测器）。

  2. 为目前的.GC文件输入监测器目录。

  3. 在初始化过程中复选 Start Monitor（启动监测器）框。


解释故障值

有关5973 MSD，单击这里。

  1. 在 Instrument Contro（仪器控制）中，选择 View / Diagnostics/Vacuum Control（查看/诊断/真空控制）。

  2. 在 Diagnostics（诊断）窗口中，选择 Status（状态） / MS Error Codes（MS 故障码）。

  3. 输入故障值并单击 OK（确定）。

例如，如果在记录文件中报告的故障为 17，您将在框中输入 17 并单击 OK（确定）。程序将返回提示：

  • Excessive Source Pressure（源压力超出警戒）。

  • Party Fault (一组故障)（一个或多个故障）

有关故障列表、它们的值和可能原因，请参见 MS Faults（MS 故障）。


加载调谐数值

从菜单中选择File / Load Tune Values（文件/加载调谐数值）。显示出一个有当前调谐数值的文件列表。双击要使用的文件。

在 5973 MSD 系统上，除了有效调谐文件的列表，Select Tune File dialog box（选择调谐文件对话框）也显示存储在每个调谐文件中的不同设定值。


暂停报告系统

使选择的过程在目标节点上暂停。

注意：一个过程可以在任何时候被中止，然而，它必须在完成当前处理请求后才能中止。


进行信噪比检测

  1. 在 Data Analysis（数据分析）中，加载要使用的数据文件。如果没有数据文件加载，将使用最近的数据文件。

  2. 选择 Tools / Signal to Noise check（工具/信噪比检测）。

  3. 当被提示时，选择是否向打印机发送一个图形报告。如果选择 Yes（是）,图形结果就发送到打印机。如果选择 No（否）, 一旦完成信噪比检测，一个文本报告就显示在屏幕上。

  4. 如果使用多信号数据文件，将提示您选择哪个信号用于信噪比的计算。选择信号，并单击 OK（确定）。

  5. 当被提示时，选择要使用的提取离子或输入0使用总离子流色谱。单击 OK（确定）。

  6. 单击并拖动鼠标右键通过色谱的 “信号” 部分（可以首先使用鼠标左键放大它）。

  7. 单击并拖动鼠标右键通过色谱的“噪音”部分。

进行信噪比的计算。

信噪比报告示例


重新校准

欲进行交互式重新校准：

  1. 在 Update Calibration（更新校准）框内选择 Recalibrate（重新校准）。

  2. 在重新校准时，您可能进行下列一项或多项操作：

    更新响应

    更新保留时间

    替换特征离子相对响应

  3. 单击进行更新。

欲作为系列的一部分进行重新校准，请参见设定系列中的“样品类型”。


重新开始一个报告系统

将选择的过程在目标节点上重新开始。


查看浏览混合模式数据文件

  1. 在 Data Analysis（数据分析）中选择 File / Load Data File（文件/加载数据文件）。Data Analysis（数据分析）的 #2 窗口将包含 TIC（总离子流色谱）是上边曲线和 GC 通道是下边的曲线。

  2. 选择 Chromatogram / Integrate（色谱/积分）。TIC 和 GC 数据均被积分。报告积分结果时包含两个信号的报告。

注意 MS 和 GC 信号使用在分别在 Chromatogram / MS Signal Integration Parameters（色谱/MS 信号积分参数） 和 GC Signal Integration Parameters（GC 信号积分参数）中定义的各自的积分参数文件。

另见

根据 MS 保留时间校准 GC 信号

定量混合模式数据


使用 QEdit 查看定量结果

在“环境”软件中的定量编辑器可以手动积分峰并根据需要更新定量结果。下列步骤说明如何使用 QEdit 功能。许多功能已被Quick QEdit工具简化。

  1. 和要加载的方法一起，加载要使用的数据文件（File / Load Data File（文件/加载数据文件））。

  2. 选择View / Qedit Quant Result（查看/Qedit 定量结果）。该项仅在当前的数据文件已被当前方法定量后有效。加载一套新菜单并且当前数据的定量结果被复制到一个临时文件中。在 QEdit 模式中，所有的改变均存储在这个临时文件。如果如下面步骤 5 或 6 所述方法保存更改，原始数据将被覆盖。

  3. 欲手动积分一个峰，单击并拖动鼠标右键画一个新的积分基线。选择Integrate / Integrate（积分/积分）访问所有离子；否则仅显示目标离子。如果要处理的峰在窗口的边上，在色谱窗口双击鼠标左键或选择 QEdit / Xpand Chromatographic Window（QEdit/缩小色谱窗口）将窗口缩小 2 分钟。

    注意：如果在初始校准或校准更新过程中定量没有发现化合物，或如果积分很差，QEdit可以用于手动积分峰。然而，如果不解决潜在的问题（积分参数不好、不正确的保留时间、窗口太窄），在采样过程中将不得不总是使用 QEdit 手动积分。

  4. 欲进行下一个化合物，在下一个窗口中双击鼠标右键或选择QEdit / CO Next Compound（QEdit/CO 下一个化合物）。

  5. （可选项）欲加载不同的数据文件，选择QEdit / Load Data File（QEdit/加载数据文件）。将会提醒您在加载新的文件前保存对当前数据文件的改变。重复步骤 3-5，处理新数据文件。

  6. 选择QEdit / Exit and Save Changes（QEdit/退出并保存更改）并选择 Yes（是）以保存对当前数据文件的结果文件的更改。您在不保存更改退出时，使用QEdit / Abort Changes and Exit（QEdit/异常中断改变并退出）。

使用 QEdit 改变结果的事实将在打印已被更改的化合物的报告时有注释加以说明。报告中的注释说明使用手动积分（以确定化合物的面积响应）。


保存调谐数值

如果不保存它们就退出 Tune（调谐）视窗，则在 AdjParam（调整参数）面板中保存到内存的参数将会出现。

欲在不退出 Tune（调谐）”的情况下保存当前参数

  1. 选择 File / Save Tune Values（文件/保存调谐数值）。将提醒您输入一个文件名。

  2. 当前调谐文件名显示在文本框。显示在框上面的路径为允许保存调谐文件的唯一路径。

  3. 可以输入一个不同的文件名（最多 8 个字符）或从列表中选择一个。调谐文件扩展名（.U）将会被自动加上，如果您没有输入。如果输入一个无效文件名并单击 OK（确定）,调谐值不予保存。


选择一个节点

  • 欲选择处理过程中的节点，从 Report Manager Setup（报告管理器设定）对话框选择Setup（设定）然后从 Installed Node（已安装的节点）列表中选择节点。

  • 欲为处理过程添加一个网络节点，从 Configuration（配置）对话框选择Add（添加）。这将提醒您输入网络节点的名字。节点名字必须为那个节点所在计算机的名字。

为检测它与另一个网络节点的通讯，选择该节点并单击Test Connection（检测连接）。如果“报告管理器”和网络软件正在运行，检测将提示节点的响应信息。如果节点没有响应，请参见 Troubleshooting（故障排除）。

网络配置

与数据文件和方法文件联系的驱动器标签和请求一起被发送以便处理报告。当处理一个请求时，Report Manager（报告管理器）比较驱动标签和有效的驱动器标签。

当它发现驱动器与请求具有相同的标签时，它将交换原始路径的驱动器字母与当前系统驱动器字母。

对等网络

注意：Report Manager（报告管理器）的设计是提供能在透明文件访问和网络 DDE（动态数据交换）的网络上进行工作。用于 Workgroups 的 Windows 和 Windows 95 窗口已经由Report Manager（报告管理器）测试可以使用。和其他网络产品的兼容性还不清楚。


选择一个过程

欲选择处理总报告的过程，从过程列表中选择一个项目。两个缺省过程为 MSDA 和 MSDA2。

“数据分析“的两种场合的功能是相同的，但是它可以使两个用户向相同的节点发送请求，而不需过程在两个用户环境间前后切换。

当一个请求被处理时，“报告管理器 MSDA”加载与用户生成请求时相同的环境。这包含方法和数据文件。

当“报告管理器 MSDA”的一种情况处理不同用户的请求时，它必须首先加载每个用户正在使用的方法和数据文件。

即使一个过程可以处理多个用户的请求，如果“报告管理器 MSDA”的不同情况为用户设定，那么“报告管理器 MSDA”则不需在每次处理请求前加载用户环境。


选择一个报告系统

欲选择一个“报告系统”，在“报告系统”上定位鼠标指针并单击鼠标左键。选项变亮。


选择请求

欲选择一个请求，在请求上定位鼠标指针并单击鼠标左键。所选请求被选中。


选择归一化离子

该任务允许您在归一化扣除中使用谱库光谱中的另一个离子，而不是标准峰。当这次触发结束时，光谱扣除通过归一化谱库光谱而进行以便谱库项中的基峰从不同的光谱中删除。当这次触发开启时，可以在谱库项中选择归一化峰。

  1. 选择 View / Unknown, Library Entry and Difference（浏览/未知、谱库项和差）。

  2. 选择 Options / Select Normalization Ion（选项/选择归一化离子）。

  3. 将指针移动到谱库项窗口（窗口 #11）。鼠标箭头变为一个标尺。

  4. 当鼠标处于要使用的离子上部时，同时单击鼠标左键和右键。

注意如果从参数检索中选则的离子不是未知光谱的一部分，那么未知光谱将不被扣除。

选择离子将被使用直到您选择不同的离子或这个模式关闭为止。


设定定量项目

Quant Setup（定量设定）框使您可以使用鼠标在数据库中自动输入化合物的保留时间和目标/特征离子质量和比例。

  1. 输入您希望化合物在数据库中出现的化合物的名字。

    注意：数据库中的每个化合物必须有一个唯一的名字。相同的项目可能在定量过程中引起化合物被遗漏。如果需要使用相同的名字，例如，在不同时间洗脱出来的化合物的同位素，则使用细微差别如 xylene1（二甲苯1） 和 xylene2（二甲苯2）。

  2. 如果化合物为内标化合物，检查 ISTD 框。

  3. 然后选择 Tgt 按钮。框中其余字段将根据鼠标的行为被选择并被填充。

  4. 在色谱中感兴趣的扫描上双击鼠标右键。被选择的光谱将显示在 Quant Setup（定量设定）框旁边并且保留时间自动输入到框内。

    注:在混合模式定量中，光谱可能从 MS 信号或 GC 检测器信号中被选择。如果从 MS 信号选择，定量信号将为一个 MS 定量离子。如果从 GC 信号选择，那个信号将用于定量。

  5. 欲选择目标离子，将鼠标箭头移动到目标化合物上并同时单击鼠标左右键。目标离子质量将输入到框中并且 Q1 特征离子按钮被选择。

    注意：当鼠标指针放在光谱上时，其形状象一个目标标尺。单击在光谱图宽度的 1/30 范围的面积内选择最大离子。因此，不需将鼠标准确的定位在“目标”上。然而，如果想选择一个小丰度离子，它离比它大丰度的离子非常近，您需要将光谱的那一部分放大。单击并按住鼠标左键，拖动鼠标在要选择的离子周围画一个矩形框。（当选择卤化物离子时尤其重要。）

  6. 欲选择一个特征离子，在离子上单击鼠标左右键。把质量输入到框中。注意对目标离子的比例也进行计算并输入。（如果不想使用特征离子，进入步骤 7。）

  7. 单击 Save（保存）按钮将项目写入数据库。

  8. 欲向数据库中添加另一个化合物，重复步骤 1-7。

  9. 当完成添加时，单击 Exit（退出）按钮。


设置 6890 GC

如何

向目录中添加新色谱柱型号

向详细目录中添加一个新色谱柱

校准色谱柱

更换色谱柱

编辑 GC 运行时间表格

优化 GC 数据采样频率

使用载气节省准备等压运行

准备等温运行

准备梯度柱箱升温程序

设定 GC 参数

设定分流比

设置脉冲压力进样口

为 MSD 操作设定 GC

设定程序升温挥发进样口

使用 GC 石油化工增强


设定 MSD

自动调谐 MS

设定 MS 扫描参数


关闭报告系统

将选择的过程在目标节点上关闭。

注意：在关闭 Report System（报告系统）前，它必须处于停止状态。


开始一个报告系统

在指定的节点上开始选择的过程。


从未知光谱中扣除谱库光谱（PR）

从未知光谱中扣除谱库光谱

  1. 选择 File / Load（文件/调用）并选择一个数据文件。在窗口上部将显示 TIC，谱库光谱在下面。

  2. 在 TIC 峰上双击鼠标右键选择一个显示的光谱。未知光谱将显示在窗口的上部，谱库光谱在下面。

  3. 选择 Spectrum / Normalized Subtract（光谱/归一化扣除）。谱库条目将从未知光谱中扣除，所得差值显示在窗口下部。谱库条目被归一化以便当谱库项被从未知光谱中扣除时，谱库条目的基峰被完全删除。

注意扣除将通过在结果列表中每个谱库条目循环的进行。（未知光谱不会改变。）

另见

About Normalized Subtraction（关于归一化扣除）

To Select the Normalization Ion（选择归一化离子）


使用 EasyID 更新保留时间

在进入 EasyID 前，加载一个校准样品数据文件，这个数据文件是在所有使用该方法的次一级目标化合物分析将使用的条件下得到的。

  1. 和要加载的方法一起，使用 File / Load Data File（文件/加载数据文件）为校准标准加载数据文件。方法必须有一个已被建立的定量数据库。

  2. 选择View/EasyID（浏览/EasyID)。菜单栏改变并且色谱、光谱和文本窗口被显示出来。

  3. 单击并拖动鼠标右键为在显示的色谱中的峰定义一个基线。由于 EasyID 使用积分保留时间，不需要把基线准确的画在峰开始和结束的位置。在大多数情况下，可以在坐标轴区域内的实际数据下画基线。

    积分峰的保留时间将为化合物的新的期望保留时间。提取信号开始和结束时间将相对于新的期望保留时间移动。如果在当前选择的化合物上没有积分进行，则校准表不被修改。

  4. 欲处理下一个化合物，双击屏幕右下角的下一个出口的任何地方或从 EasyID 菜单中选择CO Next Compound（下一个化合物）。如果进行一个手动积分，但是它是不正确的并且您不希望更新那个化合物，首先从菜单中选择EasyID / Original Chromatographic Window（EasyID/原始色谱窗口）。这将色谱重新保存到它的原始状态并删除任何积分。

    如果正在更新的化合物为一个内标化合物，将出现提示Update relative target compounds?(是否更新相关目标？）。如果yes（是）被选择，则与该内标化合物相关的目标化合物将它们的保留时间更新以维持它们对内标化合物的“相对保留时间”。这次更新后，下一个内标就显示出来。

  5. 选择Exit and Save Changes（退出并保存更改）从EasyID菜单中。

  6. 欲确定更新的保留时间，从“环境数据分析”窗口中选择Quantitate / Calculate（定量/计算）。当被提示时，指定一个总结报告，然后单击OK（确定）。查看显示的报告以发现所有的化合物。


使用条形码条形码读出机

使用条形码读出机

要使用条形码读出机自动输入条形码：

  1. 选择 Sequence / Edit Sample Log Table（序列/编辑样品日志表）。对于样品日志表中想输入条形码的每一项：

  2. 将带标签的瓶子放到条形码读出机中。最小化 Instrument Control（仪器控制）窗口。

  3. 单击 Read（读取）按钮。

注意：Read（读取）按钮仅在有一个条形码读出机存在并被激活的情况下有效。


查看/编辑已有的项目

选择 Edit Existing Entry（编辑已有的项目）时，会提示您输入项目号。输入项目号。在 Edit Entry（编辑项目）对话框中显示项目。如果您不知道项目号，则在谱库中进行参数检索以确定化合物项目号。

谱库项目不能从谱库中删除。然而，在 Edit Entry（编辑项目）对话框中不选定 Include in Search（在检索中包含）可不检索某一项目。


查看校准曲线

  1. 选择 Calibrate / Edit Compound（校准/编辑化合物）并从数据库化合物列表中选择要查看的化合物。

  2. 单击 Compound Entry（化合物项目）框中的 Plot（绘图）。

响应比对浓度比的曲线使用化合物的所有校准浓度，以便绘制出指定的拟合曲线。同时显示相关方程和其他数据。


柱流速过高

在具有扩散泵的 MSD 上，柱（载气）流速不能超过 2.0 ml/min。在具有涡轮分子泵的 MSD 上，柱（载气）流速不能超过 4.0 ml/min。降低流速并重新调谐 MSD。


顶部菜单

Method （方法） | 可使您加载、保存、运行和编辑方法。
Sequence （序列） | 使您可设置批样品处理。
Secured Control （安全控制） | 提供一个帐号系统，要求操作者在使用仪器前登录。
View （查看） | 可使您切换视窗（“顶部”、“仪器控制”和“数据分析”）。
Help （帮助） | 获得在线帮助。


顶部状态显示

开始使用一种方法时，Top（顶部）窗口显示所有应用程序的状态： Top（顶部）、Instrument Control（仪器控制）、Data Analysis（数据分析）。在该方法结束前一直显示程序状态。

该显示在监测序列进程时尤为有用。要在一个序列进行时在 Sample Log Table（样品日志表）中修改或添加项目，请选择 Edit Samp Log Tbl（编辑样品日志表）。要在序列进行时浏览数据文件，请选择 Data Analysi（数据分析）。

要结束方法或序列时，请选择 Abort（异常中止）。


总流量

如果安装了 EPC，并且色谱柱未被定义,则进样口为流量控制的。（有关定义色谱柱的更多信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。）

要激活进样口的 Total Flow（总流量），在 On 的复选框内加上 X。

使用 Setpoint（设定值）指定气流通过进样口的速率（以 ml/min 为单位）。

Total Flow（总流量） = 柱流量 + 隔垫吹扫流量

有效范围： 隔垫吹扫流量 - 1000ml/min

注意： 如果进样口被关闭或进样口压力很低，化学工作站将重新计算 Total Flow（总流量）。 如果重新计算得到的数值不合理，请重新输入 Total Flow（总流量）的设定值。

GC 传送的进样口 Actual（实际）流量 (ml/min) 为只读显示。

本对话框中其他项目：

Heater（加热器）

Gas（气体）

Pressure（压力） (如果色谱柱已被定义）


总流量

为 Total Flow（总流量）指定的任何值都不影响 Pressure（压力）。（有关定义色谱柱的更多信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。）

要激活进样口的 Total Flow（总流量），在 On 的复选框内加上 X。

使用 Setpoint（设定值） 指定气流通过进样口的速率（以 ml/min 为单位）。

分流/脉冲分流模式

总流量 = 分流流量 ＋ 柱流量 ＋ 隔垫吹扫流量

Total Flow（总流量）为进入进样口的总流量。改变 Total Flow（总流量）时，分流比和分流流量也改变，而柱流量和压力保持不变。

有效设定值：

氮气 为 6.1 － 200 ml/min

氦气、氢气为 6.1 － 1000ml/min

不分流/脉冲不分流模式

Total Flow（总流量）为所有时间内进入进样口的实际流量。在不分流模式下操作时，不能在预运行时和 Purge Time（吹扫时间）前输入新的 Total Flow（总流量）设定值。

有效设定值：

氮气 为 0 － 200 ml/min

氦气、氢气为 0 － 1000ml/min

GC 传送的进样口 Actual（实际）流量 (ml/min) 为只读显示。

本对话框中其他项目：

Mode（模式）

Gas（气体）

Cryo Config（冷却配置）

Heater（加热器）

Ramps（梯度）

Pressure（压力）

GasSaver（载气节省）（如果色谱柱已被定义）


总流量

总流量是由流量传感器测定的进入进样口的流量，单位为 ml/min。该流量根据操作模式不同分成几股。

总流量设定值在下列情况下有效：

分流模式 - 所有情况均有效

不分流模式 - 如果色谱柱未定义，在吹扫时间内有效

总流量设定值在下列情况下无效:

直接模式 - 所有情况均无效

不分流模式 - 如果色谱柱未定义，除了吹扫时间内均无效

有关更多信息，请参见 Splitless mode pneumatics（不分流模式气路）、Split Mode Pneumatics（分流模式气路）或 Direct Mode Pneumatics（直接模式气路）。

有效设定值：

0.0 至 100 mL/min

本对话框中其他项目：

Gas（气体）

Heater（加热器）

Pressure（压力）

Split Ratio（分流比）

Split Flow（分流流量）

GasSaver（载气节省）（如果色谱柱已被定义）


总流量

总流量是由流量传感器测定的进入进样口的流量，单位为 ml/min。该流量根据操作模式不同分成几股。

“总”流量设定值在下列情况下有效：

分流模式 - 所有情况均有效

不分流模式 - 如果色谱柱未定义，在吹扫时间内有效

“总”流量设定值在下列情况无效:

直接模式 - 所有情况均无效

不分流模式 - 如果色谱柱未定义，除了吹扫时间内均无效

有关更多信息，请参见 Splitless mode pneumatics（不分流模式气路）、Split Mode Pneumatics（分流模式气路）或 Direct Mode Pneumatics（直接模式气路）。

有效设定值：

0.0 至 100 mL/min

本对话框中其他项目：

Gas（气体）

Heater（加热器）

Pressure（压力）

Sampling End（进样端）

Purge Time（吹扫时间）

Purge Flow（吹扫流量）

GasSaver（载气节省）（如果色谱柱已被定义）


总流量

总流量是由流量传感器测定的进入进样口的流量，单位为 ml/min。该流量根据操作模式不同分成几股。

总流量设定值在下列情况下有效：

分流模式 - 所有情况均有效

不分流模式 - 如果色谱柱未定义，在吹扫时间内有效

“总”流量设定值在下列情况下无效:

直接模式 - 所有情况均无效

不分流模式 - 如果色谱柱未定义，除了吹扫时间内均无效

有关更多信息，请参见 Splitless mode pneumatics（不分流模式气路）、Split Mode Pneumatics（分流模式气路）或 Direct Mode Pneumatics（直接模式气路）。

有效设定值：

0.0 至 100 mL/min

本对话框中其他项目：

Gas（气体）

Heater（加热器）

Pressure（压力）

Sampling End（进样端）

GasSaver（载气节省）（如果色谱柱已被定义）


总流量

为总流量指定的任何值都不影响压力。 （有关定义色谱柱的更多信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。）

要激活进样口的 Total Flow（总流量），在 On 的复选框内加上 X。

使用 Setpoint（设定值） 指定气流通过进样口的速率（以 ml/min 为单位）。

GC 传送的进样口 Actual（实际）流量（以 ml/min 为单位）为只读显示。

本对话框中其他项目：

Gas（气体）

Air Cooling On（空气冷却开启）

Heater（加热器）

Ramps（梯度）

Pressure（压力）


总流量

如果安装有 EPC，并且色谱柱：

  • 已被定义，进样口可由压力或流量控制。

  • 未被定义，进样口由压力控制。

为总流量指定的任何值都不影响压力。 （有关定义色谱柱的更多信息，请参见 Add New Column Model to Catalog（向目录中添加新色谱柱型号）。）

要激活进样口的总流量,，在 On 的复选框内加上 X。

使用 Setpoint 指定气流通过进样口的速率（以 ml/min 为单位）。

分流/脉冲分流模式

总流量 = 分流流量 ＋ 柱流量 ＋ 隔垫吹扫流量

Total Flow（总流量）为进入进样口的总流量。改变 Total Flow（总流量）时，分流比和分流流量也改变，而柱流量和压力保持不变。

有效设定值： 隔垫吹扫流量 -200ml/min

隔垫吹扫流量 -1,000ml/min （氮气、氢气）

不分流/脉冲不分流模式

Total Flow（总流量）为预运行中和运行过程中吹扫时间之前进入进样口的实际流量。在不分流模式下操作时，不能在预运行时和 Purge Time（吹扫时间）前输入新的Total Flow（总流量）设定值。

有效设定值：

对于氮气 为 0 － 200ml/min

氦气、氢气为 0 － 1000ml/min

GC 传送的进样口实际流量 (ml/min) 为只读显示。

本对话框中其他项目：

Mode（模式）

Gas（气体）

Heater（加热器）

Pressure（压力）

GasSaver（载气节省）（如果色谱柱已被定义）


总离子谱 － 定义

总离子流色谱通常称为 TIC。


全离子监测器

离子监测器
当系统配置有 MSD 时，该监测器出现在 Instrument Control（仪器控制）视窗中。它实时提供离子色谱（总离子、提取离子或选择离子）曲线。单击监测器显示离子曲线，可设定曲线坐标。


痕量模式定量 － GC/MS

痕量模式定量生成一个报告，其中包括定量数据库中一个化合物的所有定量信息。在定量过程中会出现某个特定峰积分效果差或无法找到的情况，这一功能对于识别其原因非常有用。

选择 Quantitate / Trace Mode Quant 后，会提示您输入化合物号。显示在 MultiVu 中的结果报告包括：

  • 选定化合物的保留时间和积分信息。

  • 内标物 (ISTD) 的保留时间和积分信息。

  • 选定化合物的定量信息

痕量模式定量还生成定量离子和特征离子（如果存在）的提取离子色谱图。这些显示在“窗口 2”中。这对识别那些被不正确的积分窗口“砍掉”的峰来说非常重要。在痕量模式定量报告中也包括离子的信息。

当前数据文件必须在使用痕量模式定量前输入定量数据。


跟踪开启

“跟踪”可使您将调谐步骤（MSON、IO 检测等）的详细报告保存到扩展名为 .TRC 的文件中。调谐过程的每个步骤均被打印到该文件。该文件同时记录从质谱仪接口卡获得的所有出错提示。该信息可以帮助诊断质谱仪接口卡的交互问题。

首次打开调谐窗口时，Trace（跟踪）开始是关闭的。

创建一个跟踪文件

  1. 选择 Trace On（开启跟踪）；将显示 Trace File（跟踪文件）框。菜单项旁的复选标记说明该项已经开启。（如果 Trace（跟踪）已经开启，选择 Trace On（开启跟踪） 会将其关闭，并且没有面板出现。再选一次可重新开启。）

  2. 为报告输入文件名并单击 OK（确定）. Cancel（取消）允许您在不开启调谐跟踪的情况下离开 Trace File（跟踪文件）框。

要浏览跟踪文件

  • 请选择 File / View Trace（文件/查看跟踪）。


没有样品瓶架

化学工作站试图将样品瓶移入或移出样品瓶架，但没有安装样品瓶架。关闭仪器，确认所有的电缆连接是可靠的，然后打开仪器重试。如果再次出现故障，请和维修处联系。


故障排除

不能发送请求

本地 Report Manager（报告管理器）接到请求时，将待处理系统的名称与自己的名称进行比较。如果两个名称不同，则请求被发送到其他计算机。如果那台计算机是关闭的、网络软件未运行或其 Report Manager（报告管理器）未运行，则计算机接收不到请求。要确定问题所在，请使用 Set Up Report Manager（设置报告管理器）中的 Test Connection（测试连接）工具检查网络软件和网络 DDE（动态数据交换）。

不能处理请求

如果 Report Manager（报告管理器）收到请求但不能访问数据文件或方法，则不能处理请求。这是因为处理系统无法访问在原来的系统中使用的方法或数据文件。

检测连接，系统无响应

如果遥控 Report Manager（报告管理器）没有响应，这是因为网络软件未运行、网络 DDE 未运行，或遥控 Report Manager（报告管理器）未运行。确认每个部分均正常后重试。


对宏进行故障排除

REMOVE 命令(无参数)可在宏内作为故障排除设备使用。

该命令中止宏，显示变量列表，在表中可检查全局变量和局部变量。局部变量出现在列表开始部分，前面加上一个星号 (*)。


排除由于无效设定值引起的故障

无效设定值是指在 GC 当前条件下可接受的范围以外的值。在一套条件下有效的设定值在条件改变后可能变为无效。（有关详细信息，请参见下面的示例。）

在化学工作站向 GC 下载数据前必须改正无效的设定值。

注意： 由于在运行过程中出现的条件而变为不合乎规定的数值不作为无效的设定值。

不合乎规定的数值显示为红色。

指出在“柱箱”对话框内有一个或多个不合乎规定的数值。

指出“柱箱”对话框目前被打开并包含一个或多个不合乎规定的数值。

存在一些改正无效设定值的方法：

  • 输入有效的设定值，或

  • 调节可以使设定值变为有效的相关设定值，或

    注意：相关设定值当前可能为一个有效设定值。它也可为不同的仪器控制的设定值。

  • 改变可影响设定值的条件，例如，更换柱子会影响压力和流量设定值。

示例：

  1. 打开柱箱，温度设定值为 50 [image] C。

  2. 将柱 1 的进样载气设置为氦气。

  3. 添加一个具有标识规格的测试柱：30.0 m x 200 [image] m x 0.00 [image] m.

  4. 将柱流量设定为 8ml/min 的恒定流量。

  5. 通过单击 Pressure Setpoint（压力设定值）文本框，将自动计算对应的柱压力：

  6. 将柱温度设定值改为 150 [image] C, 返回“柱”对话框。因为要保持 8ml/min 的恒定柱流量所需的压力超过了给定条件的最大压力，它的图标现在具有黄色背景和红色文字：

  7. 要排除故障，您可以：

  • 减小柱流量设定值（“柱”对话框），或

  • 减小相关的柱压力设定值（“柱”对话框），或

  • 减小相关的柱箱温度设定值（“柱箱”对话框），或

  • 更换柱（“柱”对话框）。

排除故障并打开另一个对话框前，“柱”图标的背景将保持无效状态。


调谐控制极值对话框 (5973 MSD)

调谐控制极值对话框

5973 MSD 为 CI 所配置。在 CI Tune（CI 调谐）视窗中选择 Setup / Set Tune Limits（设置 / 设定调谐极值）可以进入此对话框。

此对话框用于选择需要使用的调谐控制极值。对于每个参数的范围显示在圆括号中。所有参数对于指定反应气和电离模式都进行了最优化以用于 MSD 校准。他们提供了一个一般起始点，并可能需要对于特殊应用进行调节。

有关更多信息，请参见 Chemical Ionization Mass Spectrometry（化学电离质谱），Alex. G. Harrison 著（CRC 出版社，1992，ISBN：0849342546）。0849342546).

Tune Abund. Target（调谐丰度目标），counts（记数） (1E4-2E6)

电子倍增器电压调节以便达到调谐中丰度最大的离子的需要丰度计数。增加丰度计数也会增加本底和污染离子的丰度。设定此参数足够高以刚好能获取要测定离子满意的数据。

Peakwidth Target（峰宽目标），amu (0.45-0.8)

设定较高的峰宽（较宽峰）能提高灵敏度同时降低分辨率。注意这些是调谐峰，与色谱峰无关。

Maximum Repeller（最大推斥极），V (1-5)

通常较高的推斥极电压会提高灵敏度同时也降低分辨率。较低的推斥极电压能增加分辨率但降灵敏度低。

Maximum Emission Current（最大发射电流）, uA (10-310)

发射电流是灯丝和离子源本体之间的电子流。缺省最大值对于 PCI 为 240 uA，对于 NCI 为 50 uA。

改变发射电流对 NCI 的影响比对 PCI 大。在 NCI 中发射电流的设定过低会降灵敏度低；设定过高会增加本底噪音。高发射电流造成的源加热足以抑制 NCI 电离反应。

Maximum Emission Energy（最大发射能量），eV (40-240)

电子能量是每个发射出的电子的势能。150 eV 为缺省最大值。电子能量过高会造成过度裂解。

反应气流、源温度、推斥极电压、发射电流和电子能量一起相互作用，这就是说，改变其中之一都可能需要改变其他的一个或多个。例如，电子能量和发射电流增加可能需要增加推斥极电压以保持相同的灵敏度。

对于一特定化合物的最佳设定往往需要经验来决定。


调谐评估

Tune evaluation（调谐评估）是一种检验 MSD 性能的方法。这是通过分析一个调谐评估化合物样品然后基于环境分析协议中指定的标准评估一个结果质谱的质量坐标轴校准、质量分辨率和离子比来进行的。调谐评估有时称作target tune（目标调谐）。


调谐评估化合物

Tune evaluation compound（调谐评估化合物）是一种用于对于特定环境分析协议而定义 MSD 性能的化合物。EDA 软件认可 BFB 和 DFTPP 为目标调谐化合物并准备这些化合物样品的自动调谐评估。调谐评估化合物有时称作target tune compounds（目标调谐化合物）。


调谐文件与分析类型不匹配

确认在方法中指定的调谐文件对于正在分析的化学品类型是适当的。


调谐菜单

Tune(调谐）菜单允许进行一种自动调谐和设定下面的：

设定标识 %502（仅对于 5972 / 6890）

仅对于 5972。设定在 Standard Spectra Autotune（标准光谱自动调谐）中使用的 m/z 502 的标识相对丰度（缺省 3%，范围 1.5 - 8.0%）。这个设定仅为一个标识目标。一些系统不能持续达到高 %502 (5 - 8%)。对于要求很高 %502 的应用，请使用 Target Tune（目标调谐）。

设定固定推斥极（仅对于 5972 / 6890）

仅对于 5972/6890。设定 Standard Spectra Autotune（标准光谱）的固定推斥极电压（缺省 25，范围 10 - 40）。

设定最大推斥极

对 Maximum Sensitivity Autotune（最大灵敏度自动调谐）和 Target Tune（目标调谐）设定最大允许推斥极电压（离子能）。对于 5972/6890，对最大灵敏度设定为 40 而对最大分辨率设定为小于等于 20。通常增加 Repeller（推斥极）电压的同时要增加 Peak Width Target（峰宽目标）。把这一设定同调谐文件一起保存。

设定最大离子聚焦

设定最大允许离子聚焦。对于 5972/6890，设定值为 90 以取得最佳信噪比。把这一设定同调谐文件一起保存。

设定峰宽目标

设定目标峰宽范围为 0.4 - 0.85 amu。宽峰 (>=.55) 得到较高灵敏度，而窄峰 (<=.5) 得到较高分辨率（会损失一些分辨率）。通常增加 Repeller（推斥极）电压的同时要增加 Peak Width Target（峰宽目标）。把这一设定同调谐文件一起保存。

另见

Tune Menu（调谐菜单，5973 MSD）


调谐菜单 (5973 MSD)

Manual Tune（手动调谐）中的 Tune（调谐）菜单让您进行下列自动调谐以及设定调谐目标和极值。

Autotune （自动调谐） | 在质量范围内使仪器灵敏度达到最大。
Low Mass Autotune （低质量自动调谐） | 除了它是调谐质量 69，131 和 219 而非 69，219 和 502 之外与 Autotune（自动调谐）完全一样。它用于低分子量的化合物用和 250 道尔顿以下的天然气。
Standard Spectra Tune （标准谱图调谐） | 确认在整个质量范围内的标准响应。
DFTPP Tune （DFTPP 调谐） | 专用于 EPA 方法 625 的目标调谐。
BFB Tune （BFB 调谐） | 专用于 EPA 方法 624 的目标调谐。
Target Tune （目标调谐） | 用于其他方法的 Target Tunes（目标调谐）。
QuickTune （快速调谐） | 提供精细调节以保证可接受的响应和分辨率以及准确质量指认。
Set Tune Targets （设定调谐目标） | 显示一个让您调节调谐目标的对话框。对于每个项目的允许范围显示在圆括号中。
Set Tune Limits （设定调谐极值） | 显示一个让您调节调谐极值的对话框。每项的允许范围显示在圆括号中。
Set View Tune Report Options （设定查看调谐报告选项） | 显示一个让您选择额外的报告在每次调谐后打印出的对话框。这些报告可以被保存然后用于查看 MSD 中的趋势。
Restore Previous Tunes （恢复原来调谐） | 在自动调谐（Standard，Autotune，BFB，DFTPP 或 QuickTune）之前调谐文件（例如 atune.u 或 stune.u）被复制到一个备份文件中。这一菜单项显示一个允许加载这些原来的自动调谐文件之一的对话框。存储最多五个调谐文件，文件根据名称和日期列出。如果选择了一个和当前加载的调谐文件同名的文件，会提示您是否要覆盖当前调谐文件。

另见

调谐介绍

手动调谐概述

调谐报告


调谐菜单 - CI 调谐 (5972 MSD)

Tune（调谐）菜单提供了下面的项目来指引您进行 CI 模式的调谐过程：

CI Setup（CI 设置）指引您设定甲烷流量的步骤，包括下面三步，他们分别也可以单独访问：

  • Methane Flow Setup（甲烷流量设定）指引您进行甲烷预调谐前的粗调。

  • Methane Pre-Tune（甲烷预调谐）在流量调节前自动调节甲烷反应离子 29 的峰宽和坐标轴位置。

  • Methane Flow Adjust（甲烷流量调节）指引您监测离子 27 与 28 的丰度比（比值应为 0.2 - 0.4）用来进行甲烷流量的细调。

CI Autotune（CI 自动调谐）是使用 PFTBA 的自动调谐。结果调谐参数存储在调谐文件 CITUNE71.U 中。

CI QuickTune（CI 快速调谐）提供了一种再调谐来获取最佳响应和分辨率以及准确的质量指认。只有质量坐标轴、峰宽和 EM 电压被调节；透镜不受影响。只要调谐质量的相对丰度在可接受的范围内请使用这种调谐来进行日常调谐。


调谐菜单 - 目标调谐

Tune（调谐）菜单允许您进行下列自动目标调谐。对于 5973 MSD 没有目标调谐菜单（在 Manual Tune（手动调谐）视窗中的 Tune（调谐）菜单上进行）。

DFTPP Tune（DFTPP 调谐） | 用于使用 DFTPP 作为调谐化合物的 EPA 方法。
BFB Tune（BFB 调谐） | 用于使用 BFB 作为调谐化合物的 EPA 方法。
Target Tune（目标调谐） | 用于其他方法的Target Tune（目标调谐）。
Set Tune Targets（设定调谐目标） | Set Tune Targets（设定调谐目标）
Save Tune Targets（保存调谐目标） | Save Tune Targets（保存调谐目标）。
Load Tune Targets（加载调谐目标） | Load Tune Targets（加载调谐目标）。
Set Maximum Repeller（设定最大推斥极） | 让您对目标调谐改变这个设定值。在 Standard Autotune（标准自动调谐）中的电压设定为 19.8 V。此处可以在范围 10 - 19.8 V 内选择。
Set Maximum Ion Focus（设定最大离子聚焦） | 让您对目标调谐改变这个设定值。在 Standard Autotune（标准自动调谐）中的电压设定为 65 V。此处可以在范围 10 -100 V 内选择。
Set Peak Width Target（设定峰宽目标） | 让您对目标调谐改变这个设定值。Standard Autotune（标准自动调谐）中的目标峰宽设定为 0.50 amu。此处可以在范围 0.4 - 0.8 amu 内选择。

成功的进行这些调谐取决于离子源、GC、色谱柱和样品的情况。安捷伦技术公司不保证这些调谐会满足 EPA 要求。

一个宏文件 (.TGT) 包含在上面的调谐中用作目标值的调谐质量的相对丰度。数据不满足 DFTPP 或 BFB 标准时，可以修改调谐目标。

注意 在运行一次目标调谐前： 重命名所有需要保留的原来的 DFTPP.U，BFB.U 或 TARGET.U 调谐文件。每次目标调谐都会覆盖它的调谐文件。


调谐梯度

彩色图线（参见对话框顶部的图例）标记出了对每种调谐质量找到的值。用于扫描的值是质量 3 的值。可以通过使用鼠标左键拖动垂直线光标调节这个值。注意可以用这个显示最优化比值。

步长在 Ramp Parameters（梯度参数）对话框中（选择 Ramp / Edit Ramp Params（梯度 / 编辑梯度参数））或使用 SETRAMP 命令来设定。

OK（确定） - 保存使用光标行手动选定的参数值。

Cancel（取消） - 取消任何手动选择；保存首次进入此对话框时的显示值。


调谐报告

在一次 EI 自动调谐后，您应该检查调谐报告：

  • 显示在“图形”上半部分的质量指认应该在 69，219 和 502 的 +/- 0.2 amu 之内。

  • 这三个峰的峰宽 (PW) 应该为 0.5 +/- 0.1 amu。

  • 显示在“扫描图”下半部分的质量指认应该在 69，219 和 502 的 +/- 0.1 amu 之内。

  • 相对丰度应该显示 69 amu 处的峰是最大的。相对于这个峰，219 和 502 amu 处的峰应该在运行的自动调谐中指定的范围内。

  • 同位素 (Iso) 质量指认应该各自比其母峰的质量指认大 1 amu。

  • 同位素 (Iso) 比值数值（指自然存在的同位素的相对丰度）应该接近于理论值：对于 m/z 69 为 1.08 ，对于 m/z 219 为 4.32，对于 m/z 502 为 10.09。

  • 如果质量 28 大于质量 18，系统某处可能有空气泄漏。在 1 小时的放空时间内或在重新装满校准瓶后的首次自动调谐期间例外。有关如何隔离空气泄漏的信息，请参见在线帮助的 Troubleshooting（故障排除）部分。


调谐 — 定义

调谐是优化 MSD 性能的过程。调谐的目标是在整个光谱中在保持可接受的分辨率同时使灵敏度达到最大，保证准确的质量指认并提供需要的相对丰度。另见：调谐介绍


调谐 MS

从 Instrument Control（仪器控制）的 View（查看）菜单进入的 Manual Tune（手动调谐）视窗提供了调谐和维修 MSD 的工具。有关调谐的更多的信息，请单击下列主题之一。

如何

自动调谐

手动调谐

CI 调谐 (5973 MSD)

CI 调谐 (5972 MSD)

目标调谐

参见

诊断和真空控制

调谐介绍

故障排除 (5973 MSD)

故障排除 (5972 MSD)

调谐命令


涡轮分子泵控制器工作异常

请与安捷伦科技公司维修代表处联系。


涡轮分子泵工作异常

请与安捷伦科技公司维修代表处联系。


涡轮分子泵工作异常

  1. 在 Diagnostics/Vacuum Control（诊断/真空控制）视窗中的 Vacuum（真空）菜单中选择 Vacuum Status（真空状态）。涡轮分子泵速率应该为 100% 除非 MSD 正处于排气过程中。如果速率明显低于 100%，则涡轮分子泵可能工作异常。

  2. 仔细听是否有强烈的嘎嘎声。正常工作的涡轮分子泵应该是安静的。如果听到的声音不是 MSD 的正常环境声音的一部分（风扇等），则涡轮分子泵可能工作异常。

如果涡轮分子泵没有在 100% 速率下运行或产生异常噪音，请与安捷伦科技公司维修代表处联系。涡轮分子泵是用户不能更换的。


涡轮分子泵开启但没有足够时间达到其正常操作速率的 80%

通常需要涡轮分子泵 5 - 10 分钟来达到其正常操作速率的 80%。可能需要较长时间如果：

  • 前级泵没有正常工作。

  • 色谱柱流量高于正常流量


涡轮分子泵速率（参数）

Turbo Speed（涡轮分子泵速率）显示最大速率（仅适用于涡轮分子泵系统）的百分比 (0-100%)。

仅适用于 5973 MSD


类型

Type（类型）

通过选择以下各项来指定加热辅助通道的功能：

  • Valve Box（阀箱）

  • MSD

  • AED

  • Nickel Catalyst（Ni 催化剂）

  • Unknown（未知）

本对话框中其他项目：

Aux Channel（辅助通道）

Description（说明）

Heater (thermal channels)（加热器（热通道））

Cryo Focus Configuration（低温冷凝配置，选项不可用）

Pressure (pressure channels)（压力（压力通道））

Gas (pressure channels)（气体（压力通道））

Ramps（梯度）


日志簿类型

日志簿内容

系统保存一个名为 MSLOGBK.LOG 的记录所有采集前和采集中的仪器故障和状态提示的日志簿。

Current Logbook（当前日志簿）允许审查仪器诊断信息和任何在当前和之前采集中记录的mass spec malfunctions（质谱故障）。它位于仪器目录中。可用 Clear（清除）菜单项目进行清空。


意外的进样器故障

这一错误可能不是由用户操作引起的。关闭仪器，确认所有电缆连接牢固，然后打开仪器重试。如果再次出现故障，请记下故障编号并与维修处联系。


浓度单位

仅在未知样品的最终报告中使用浓度单位；该单位打印在计算出的浓度右边。

随后每在当前定量数据库中每添加一种化合物，就会增加一个在此处输入的值。数据库中已经存在的化合物不受影响。

更改单个化合物的浓度单位：

选择 Calibrate/Edit Compounds（校准/编辑化合物），更改设定，并单击 OK（确定）。

全部更改化合物的浓度单位：

选择 Calibrate / Update/Global Update（校准/更新/全局更新），选择 Set Other (via command)（设置其他（通过命令））按钮，并输入：

amt_units$ = "单位字符串"

字符串最长可由 7 个字符组成，但是只有前 5 个字符会打印在报告上。


未知 — 定义

术语 unknown（未知）是包含浓度未知的待进行定量测量化合物样品的简称。


拔下真空规控制器的电源线

确保电源线已连接至相应的电源插座上。


Hpmsduntitled00000030

单个样品 — 单信号 (GC)

这是最基本的序列模式。即对于 Sample Log Table（样品日志表）中的每一行，从单个样品瓶取样进行单次进样。没有用于确认收集到数据的双柱（除非该数据是从另一仪器收集到的）。

方法要求

GC 方法：单信号（信号 1 或信号 2）

数据分析方法：定量数据库中不含色谱柱 2 的条目

典型 GC 硬件

GC，配有与单个检测器相连的单个进样器。通常使用顶空、吹扫和捕集或单塔自动液体进样器。

相关关键词/样品类型

MakeSec


Hpmsduntitled00000031

单个样品 — 连接的信号

此模式注射每个序列行的单个样品，但是收集和处理双信号。双信号数据将作为双柱主要/证实性数据进行处理。

方法要求

GC 方法：双信号（保存数据 = 双）

数据分析方法：定量数据库中必须包含色谱柱的两项

典型 GC 硬件

GC，配有单个进样器，该进样器与两支色谱柱（均配有一个检测器）的分流器相连，或与连有两个检测器的单个色谱柱相连，这两个检测器可以串联，通常也可以使用分流器。检测器通常为两个电子捕获检测器 (ECD) 或一个光离子检测器 (PID) 和一个电化学检测器 (ELCD)。对于进样器，通常使用顶空、吹扫和捕集或单塔自动液体进样器。

相关关键字/样品类型

开关 GC


Hpmsduntitled00000032

双塔 — 未连接的信号

此模式同时从两个样品瓶注射两种样品。收集双信号，并将其作为独立的、互不相关的数据文件进行处理。通常，对每个信号使用不同的数据处理方法。样品类型 RearSamp 标识与进入后进样口的样品相关的样品瓶、数据文件、方法和样品名称。同时进样时，RearSamp 行必须与 Sample Log Table（样品日志表）中紧挨着的下一行对应。每次 GC 运行将反映一个 RearSamp/Sample（后进样/样品）对。由于允许每次运行时同时分析两个独立的样品，因此对于单柱方法，此模式可以达到最高生产率。

方法要求

GC 方法：双信号（保存数据 = 双）

数据分析方法：定量数据库中不含色谱柱 2 的条目。Sample Log Table（样品日志表）中的第一个条目优先于其他任何样品条目，其关键字必须为 DualTwr。

典型 GC 硬件

GC，配有双进样器，每个进样器均与配有一个检测器的色谱柱相连。检测器通常为两个电子捕捉检测器 (ECD)。对于进样器，通常使用双塔 ALS。

相关关键字/样品类型

DualTwr, RearSamp

RearSamp 样品类型

在双塔模式中，可以使用名为 RearSamp 的专用样品类型。此样品类型使您可以通过设定双进样器/双柱同时进样。RearSamp 样品必须位于表中要与其同时进行测试的样品前面。这可以使该软件识别表中该行以及其下一行是要同时进样的。


Hpmsduntitled00000326

包含次要的命中对象

（仅适用于 GC/MS）如果希望定量报告中包含次要的命中对象，请将此复选框选中。次要的命中对象符合所有或某些鉴定准则，但并非 target compound identification criteria（目标化合物鉴定准则）中指定的最佳命中对象。


Hpmsduntitled00000327

包含非目标峰

GC/MS 模式：如果您选中此复选框，将对所有大于定量数据库中最接近内标 10% 的未知峰（最多为 20 个峰）做出谱库检索报告。如果定量数据库中未定义 ISTD（内标），则对 20 个最大的未知峰进行谱库检索。谱库检索的结果将作为附加报告显示。

GC-only 模式：如果您选中此复选框，将在摘要定量报告末报告所有已积分的且与目标化合物结果不匹配的峰。


Hpmsduntitled00000338

更改数据状态

使用 Change Data State（更改数据状态）可以将状态附加在显示出的数据文件上。此状态显示在 Data Analysis（数据分析）窗口顶部和所有报告文件名的旁边。数据状态选项包括：

  • Not Reviewed（未检查），（缺省数据状态）

  • QT Reviewed（已定量检查）

  • Frozen（已冻结）


Hpmsduntitled00000375

 在指定的节点上开始选定的程序。


Hpmsduntitled00000376

 在指定的节点上暂停选定的程序。

注意：虽然可以随时命令程序暂停，但是，只有当该程序结束了当前正在处理的所有请求后它才会暂停。


Hpmsduntitled00000377

 在指定的节点上继续选定的程序。


Hpmsduntitled00000378

 在指定的节点上关闭选定的程序。

注意：Report System（报告系统）必须首先处于暂停状态，然后才可以将其关闭。


Hpmsduntitled00000544

参见

General Info（普通信息）

Edit Parameters（编辑参数）

Select Injection Source（选择进样方式）

Quick Setup（快速设定）

Setup Actuals（设置实际值）

Start Column Comp Run（开始色谱柱补偿测试）


Hpmsduntitled00000847

 黄色背景表示此对话框当前处于打开状态（“您可输入”类型的消息）。

蓝色复选标记表示您已打开此对话框，但并未更改任何参数。

蓝色 X 表示您已打开此对话框，并更改了一个或多个参数，但尚未下载所作的更改。

红色背景表示此对话框中有一个或多个非法值（也以红色显示），您需要首先改正这些值，然后化学工作站才会允许下载。

带有红色文本的黄色背景表示该图标对应的对话框当前处于打开状态，且其中包含一个或多个非法值。


Hpmsduntitled00000851

写入脱机配置文件时出错

驱动程序无法写入 6890.INI 配置文件。可能是磁盘存在故障，也可能是磁盘已满。


Hpmsduntitled00000852

 读取脱机配置文件时出错

在脱机模式下，驱动程序无法读取脱机配置文件。可能是该文件并不存在，也可能是读取文件时出错，或者是该文件并不包含 GC 配置信息。


Hpmsduntitled00000853

 方法加载警告：无 GC 信息

加载方法时，化学工作站未找到 GC 部分的方法部分。适用于 GC 以外其他仪器的方法将不能在 GC 上运行。


Hpmsduntitled00000854

 方法保存失败：写入文件时出错

将方法写入磁盘时，化学工作站遇到了磁盘故障或磁盘已满。


Hpmsduntitled00000855

 与 GC 之间的 I/O 有故障：切换至脱机模式

化学工作站失去与 GC 的 I/O 通信。在继续重新建立与 GC 之间的通信时，化学工作站切换至脱机模式。一旦化学工作站重新建立通信，联机模式将恢复。


Hpmsduntitled00000856

 从 I/O 恢复时有故障：返回联机模式

出现前面的 I/O 故障后，化学工作站可以重新建立与 GC 之间的通信，并返回联机模式。


Hpmsduntitled00000857

 创建信号 1 的数据文件时出错

运行过程中，化学工作站无法创建信号 1 的原始数据文件。可能是磁盘存在故障，也可能是磁盘已满。


Hpmsduntitled00000858

 创建信号 2 的数据文件时出错

运行过程中，化学工作站无法创建信号 2 的原始数据文件。可能是磁盘存在故障，也可能是磁盘已满。


Hpmsduntitled00000859

 写入信号 1 的数据文件时出错

运行过程中，化学工作站无法写入信号 1 的数据文件。可能是磁盘存在故障，也可能是磁盘已满。


Hpmsduntitled00000860

 写入信号 2 的数据文件时出错

运行过程中，化学工作站无法写入信号 2 的数据文件。可能是磁盘存在故障，也可能是磁盘已满。


Hpmsduntitled00000861

 关闭信号 1 的数据文件时出错

运行过程中，化学工作站无法关闭信号 1 的数据文件。可能是磁盘存在故障，也可能是磁盘已满。


Hpmsduntitled00000862

 关闭信号 2 的数据文件时出错

运行过程中，化学工作站无法关闭信号 2 的数据文件。可能是磁盘存在故障，也可能是磁盘已满。


Hpmsduntitled00000863

 驱动器初始化失败

您所用的软件版本存在软件问题。打电话给安捷伦公司的维修服务部门。


Hpmsduntitled00000870

 GC 运行记录提示

6890 GC 在运行过程中会生成此消息。有关此消息的说明，请参见 6890 GC 文档。


Hpmsduntitled00001674

_A 至 _D

_ActBarcode$

包含条形码的字符串，可以通过样品读取（如果有的话）。

(Data Analysis、FILE)

_AlsBottle

当前的样品瓶编号。Instrument Control 将此值写入数据文件头中。

(Top、SAMPLELOGTABLE、STARTRUNPANEL；Instrument Control：RUNSTART、DataAnalysis、FILE)

_AlsBottle2

仅在内部使用。

_AlsID

0 = 未配置 ALS

n = 当 win.ini 的 [PCS] 部分中存在设备 n 时，指定 ALS 配置

_AutoFile$

Autostart 宏文件的名称。

（全部）

_AutoPath$

Autostart 宏文件的路径。

（全部）

_AppName$

当应用程序处于激活状态时，由所有 CP 应用程序设置。其值为去掉扩展名的应用程序名称，如 “MSDA”。

（全部）

_Button

当打开具有 OK（确定）、Cancel（取消）、Done（已执行）等选项的对话框时，会出现这些按钮。0= Cancel（取消）、Error（错误）或 No（否）；1= OK（确定）、Yes（是）或 Otherwise（其他）等；有关详细信息，请参见具体命令。

（全部）

_CheckBar

1 = 执行条形码检查，0 = 忽略条形码检查

(Top、SAMPLELOGTABLE)

_CopyMeth

1 = 启用用数据文件保存方法副本；0 = 禁用

(Top、METHINFOPANEL)

_CPStatus

1 = CP 正忙于执行命令；0 = 其他。

（全部）

_CurrentVer

与化学工作站软件版本相关的唯一数值，如 2.1。

（全部）

_DaCode

Data Analysis 中出现的任何故障的故障编号。

(Top)

_DaDDE$

DDE 转换中，Data Analysis 可以识别的特定名称。

(Top)

_DaErr

0 = 无故障，1 = Data Analysis 忙，2 = Data Analysis 异常中止，3 = Data Analysis 有错（请参见 _DaCode 和 _DaMsg$），4 = Data Analysis 停止（请参见 _DaCode 和 _DaMsg$）

(Top、RUNMODE)

_DaErrMsg$

Top 的故障说明（如果 Data Analysis 无响应）。

(Top)

_DaMenu

1 = 正常的菜单；0 = 灰色的菜单

(Top)

_DaMsg$

从 Data Analysis 返回的故障提示。

(Top、RUNMODE)

_DaMenu

0 = 正常的菜单；2 = 灰色的菜单

(Top)

_DaState

1 = Data Analysis 不存在（不在存储器中），2 = Data Analysis 正在加载，3 = Data Analysis 正在启动（从待机模式），4 = Data Analysis 处于空闲状态且可见，5 = Data Analysis 处于待机状态且不可见，6 = Data Analysis 不可见但正忙

(Top、DATANALYSIS)

_DaWinId

包含 Data Analysis 的窗口 ID。

(Top)

_DataFile$

最后加载的数据文件名。请参见 SELECTFILE、SETDATAFILE。

(Instrument Control、RUNSTART、Data Analysis、FILE；Top、SAMPLELOGTABLE、STARTRUNPANEL)

_DataFile2$

仅在内部使用。

_DataName$

Sample Name（样品名称）字段的备注。Instrument Control 将此值写入数据文件头中。

(Top、SAMPLELOGTABLE、STARTRUNPANEL；Instrument Control、RUNSTART、Data Analysis、FILE)

_DataName2$

仅在内部使用。

_DataPath$

数据文件驱动器和路径信息。

（全部）

_DateAcquired$

数据采集日期。

(Data Analysis、FILE)

_DDEName$

DDE 转换中，应用程序的特定名称。

（全部）


Hpmsduntitled00001675

_E 至 _P

_EditAcq

显示对话框和设置变量。

1 = 编辑，0 = 不编辑

(Top、EDITMETHPANEL)

_EditDa

显示对话框和设置变量。

1 = 编辑，0 = 不编辑

(Top、EDITMETHPANEL)

_EditTop

显示对话框和设置变量。

1 = 编辑，0 = 不编辑

(Top、EDITMETHPANEL)

_Error

系统范围内宏的系统错误编号。

（全部）

_ErrMsg$

系统故障提示（请参见 _故障）。

（全部）

_ExePath$

化学工作站程序的路径。

（全部）

_ExpBarcode$

用户提供的条形码，或在显示 Instrument Control 的图标的情况下使用 Sample Log Table（样品日志表）对话框中的 Read（读）按钮获得的条形码。Instrument Control 将此值写入数据文件头中。

(Top、SAMPLELOGTABLE；Data Analysis、FILE)

_ExpBarcode2

仅在内部使用。

_GCID

0 = 未配置 GC；n = 当 win.ini 的 [PCS] 部分中存在设备 n 时，指定 GC 配置

_HelpFile$

帮助文件的名称。

（全部）

_HelpPath$

帮助文件的路径。

（全部）

_InjPerVial

每个样品瓶进样的次数。

(Top、SAMPLELOGTABLE)

_Inlet$

如果将样品导入 MS。

(Data Analysis、FILE)

_InsCtlCode

Instrument Control 中出现的任何故障的故障编号。

(Top)

_InsCtlDDE$

DDE 转换中，Instrument Control 可以识别的特定名称。

(Top)

_InsCtlErr

0 = 无故障，1 = Instrument Control 忙，2 = Instrument Control 异常中止，3 = Instrument Control 有错（请参见 _InsCtlCode 和 _InsCtlMsg$），4 = Instrument Control 停止（请参见 _InsCtlCode 和 _InsCtlMsg$）

(Top、RUNMODE)

_InsCtlErrMsg$

Top 的故障说明（如果 Instrument Control 无响应）。

(Top、RUNMODE)

_InsCtlMenu

0 = 正常的菜单；2 = 灰色的菜单

(Top)

_InsCtlMsg$

从 Instrument Control 返回的故障提示。

(Top)

_InsCtlState

1 = Instrument Control 不存在（不在存储器中），2 = Instrument Control 正在加载，3 = Instrument Control 正在启动（从待机模式），4 = Instrument Control 处于空闲状态(可见且已准备就绪），5 = Instrument Control 处于待机状态（不可见且未准备就绪），6 = Instrument Control 正忙（可见，正在执行）

(Top、RUNMODE)

_InsCtlWinId

包含 Instrument Control 的窗口 ID。

(Top)

_Inst

设置 MSDA 通话的 “Windows 示例编号”。通常将 MSDA.EXE 的第一个示例的变量 _Inst 设为 1；给随后并行的示例指定大于 _Inst 的整数值。

(Data Analysis)

_InstName$

仪器的名称；在 MSCONFIG 中设置。Instrument Control 将此值写入数据文件头中。MSOPEN 读取此值，MSWRITE 将此值写入文件。

(Top、Instrument Control、MSOPEN、MSWRITE、Data Analysis、FILE)

_InstNum

当前仪器的编号；缺省情况下为存储该仪器的文件的目录（例如：\MSDCHEM\1）

（全部）

_InstPath$

当前仪器的路径（例如：\MSDCHEM\1\）。缺省情况下，日志文件会保存在此处。

（全部）

_LevelId$

待再校准 ID 的浓度。

(Top、SAMPLELOGTABLE)

_LibPath$

放置谱库文件的路径。

（全部）

_LineStat

此行的状态；0 = 空，1 = 无类型，2 = 给定的类型，3 = 已执行（已标记）。

(Top、SAMPLELOGTABLE)

_MethFile$

当前的方法文件名。Instrument Control 将此值写入数据文件头中。

（全部）

_MethPath$

加载和保存方法的驱动器和路径信息。

(Top、Data Analysis)

_MethVer

每个 .M 目录包含一个 METHVER.MAC 文件，该文件用于将此变量设为表示软件版本的数值，Method（方法）即是由此软件版本而来。尤其是对于化学工作站 B 和 C.01.05 之间的转换，必须比较变量 _MethVer 和 _CurrentVer，以确定该 Method（方法）是否与运行的软件兼容。检测化学工作站 B 方法的 C.01.05 及其以后的化学工作站会提示用户进行 Method（方法）转换授权检索。

（全部）

_MiscInfo$

Misc. Info. 字段的备注。Instrument Control 将此值写入数据文件头中。

(Top、SAMPLELOGTABLE、STARTRUNPANEL；Instrument Control、RUNSTART；MSWRITE、MSOPEN；Data Analysis、FILE)

_MiscInfo2$

仅在内部使用。

_MoreSamp

由序列宏在 Top 中使用，以表示 Sample Log Table（样品日志表）中是否还有很多剩余样品。1 = Yes（是）；0 = No（否）。

(Top)

_MSCont

决定如何绘制光谱图。0 = 用条形图绘制；其他任何值 = 用连续曲线绘制新谱图

(Data Analysis、ALLCONT)

_MSID

0 = 未配置 MS

n = 通过 win.ini 的 [PCS] 部分中的设备 n 指定 MS 配置

(Top、Instrument Control)

_Multiplr

序列表（样品日志）中样品的定量报告中的 Multiplier（倍增器）值。如果该值非 0，它将覆盖当前正在运行方法的值。

(Top、SAMPLELOGTABLE、STARTRUNPANEL；Data Analysis)

_Operator$

Start Sequence（开始序列）对话框中操作人员的姓名。Instrument Control 将此值写入数据文件头中。

(Top、STARTSEQPANEL、STARTRUNPANEL、SAMPLELOGTABLE；Instrument Control、RUNSTART、MSOPEN、MSWRITE；Data Analysis、FILE )

_OrgMethFile$

用于采集数据的方法。

(Data Analysis、FILE)

_OverWrite

1 = 复选框覆盖数据文件框；0 = 未复选该框

(Top、STARTSEQPANEL)

_PostCmd$

后运行命令宏的路径和文件名。缺省为 null。

(Top、METHINFOPANEL)

_PostSeqCmd$

后序列命令宏的驱动器、路径和文件名。缺省为 null。

(Top、STARTSEQPANEL)

_PreCmd$

预运行命令宏的路径和文件名。缺省为 null。

(Top、METHINFOPANEL)

_PreSeqCmd$

预序列命令宏的驱动器、路径和文件名。缺省为 null。

(Top、STARTSEQPANEL)


Hpmsduntitled00001676

_R 至 _Z

_Replicate

如果进行序列分析，此值为当前方法的重复计数。如果不是序列分析，此值为 0。

(Top、Data Analysis、FILE)

_Replicate2

仅在内部使用。

_RunAcq

1 = 启用；0 = 禁用

(Top、METHINFOPANEL、STARTRUNPANEL)

_RunCount

由 SampleLogTable 设置。当前不使用。

(Top)

_RunDa

1 = 启用；0 = 禁用

(Top、METHINFOPANEL、STARTRUNPANEL)

_RunPost

1 = 启用；0 = 禁用

(Top、METHINFOPANEL、STARTRUNPANEL)

_RunPre

1 = 启用；0 = 禁用

(Top、METHINFOPANEL、STARTRUNPANEL)

_RunType

下列可能类型中的一种：-1 = 无类型，1 = 样品，2 = 空，3 = 再校准。

(Top、SAMPLELOGTABLE)

_SampAmt

序列表（样品记录）中样品的定量报告中的 Sample Amount（样品量）值。如果该值非 0，它将覆盖当前正在运行的方法中的值。

(Top、SAMPLELOGTABLE、STARTRUNPANEL；Data Analysis)

_SaveFlag

0 = 不保存方法文件；1 = 提示保存方法文件；2 = 保存方法文件

(Data Analysis)

_SaveMeth$

用于保存方法的完全合乎条件的路径。

(Top、SAMPLELOGTABLE)

_SeqArgs[ ]

标量变量的 8 元素数组，当其从 Top 运行时将传递给 Data Analysis。有关这些信息，请参考 SeqArg[1]、SeqArg[2] 等。

0 = 缺省

(Top、SAMPLELOGTABLE)

_SeqArgs2[]

从序列表传递到其他化学工作站应用程序的标量变量的 8 元素数组。

_SeqComment$

Sequence Comment（序列备注）项的字符串。

(Top、STARTSEQPANEL)

_SeqFile$

序列文件的名称。请参见 SAVESEQUENCE。

(Top、LOADSEQUENCE)

_SeqIndex

如果是序列分析，此值为当前方法的序列文件中的行号。如果不是，此值为 0。

(Top、SAMPLELOGTABLE；Data Analysis、FILE)

_SeqIndex2

仅在内部使用。

_SeqInj

当前样品瓶的当前进样。

(Top、SAMPLELOGTABLE)

_SeqLine

从中提取当前值的行号。

(Top、SAMPLELOGTABLE)

_SeqPath$

序列文件的驱动器和路径信息。请参见命令 SAVESEQUENCE。

(Top、LOADSEQUENCE)

_SeqRunCount

用于序列分析。

(Top)

_SeqStr$[]

从序列表传递到其他化学工作站应用程序的 8 字符串集。

_SeqTimeStamp$

启动序列分析时，序列的时间标记。文件的初始时间标记。编辑序列时更新。

(Top、STARTSEQPANEL)

_SkipAcq

始终设置为 0。请参见命令 STARTSEQPANEL。

(Top、SAMPLELOGTABLE START、STARTRUNPANEL、STARTSEQPANEL)

_TempPath$

由 CP 在应用程序激活时设置，根据 MS-DOS TEMP 环境变量设为路径（如果存在），否则设为 Windows 目录。

（全部）

_TopWinId

包含顶级应用程序的窗口 ID。

_TuneData

0 = 文件编号为 10 的文件中无 MS 数据变量

1 = 文件编号为 10 的文件中有 MS 数据变量

(Instrument Control)

_TunePath$

定位调谐文件 (*.U) 目录（如 MSDCHEM\1\5972）

(Top、Acq、Data Analysis、Instrument Control)

_UpdRf、_UpdRt、_UpdQi

更新响应因子、保留时间、特征离子相对响应因子。

0 = 不更新，1 = 更新

(Top、SAMPLELOGTABLE；Data Analysis)

_WindowID

具有特定 ID 的窗口状态：

0 = 不存在具有该标题的窗口

>0 = 存在该窗口

（全部、GETWINDOWID）


Hpmsduntitled00001677

A 至 D

在 5972 和 5973 软件设置这些变量。

A1$、A2$、A3$

用户定义的字符串项。

(Data Analysis、GETRESULT)

AbsPeakHeight

未经基线校正的峰高。此值不同于零点以上的峰高，因为零点以上的峰高是从绝对峰高中截除了背景（即，峰“起点”处的基线）以后得到的。

(Data Analysis、PEAKNUMBER、PEAKVARS)

Amt_Units$

将在定量报告中使用的单位

(Data Analysis、GETCOMPOUND、GETRESULT)

AutoIntItem

将 Chromatogram（色谱图）菜单上的 Autointegrate（自动积分）项的状态指定为正常或无效。2 = 选中 Quant Global 面板中的 RTEINT；0 = 取消选中 Quant Global 面板中的 RTEINT

(Data Analysis、LOADQUANTMETH、SETUPCALIB)

Barcode2$

由 Instrument Control 中的条形码读取器功能读取的条形码。

(Top、Instrument Control)

BasePeak1、BasePeak2、BasePeak3

出现最高丰度处的质量。

(Instrument Control、PROFILE)

Bl0、Bl1

积分基线数据

(Data Analysis、GETRESULT)

Boil_Pt

沸点（在谱库标题中）。如果此信息不可用，即报告 -300.00。

(Data Analysis、GETSCALARS RESULTS)

BslPeakHeight

经基线校正过的峰高。从峰中央处扣除基线。这样，如果基线不水平，此值将与 AbsPeakHeight 差别很大。

(Data Analysis、PEAKNUMBER、PEAKVARS)

Cal_Fit

在定量数据库中选定的曲线拟合类型；0 = 线性；1 = 平均 RF；2 = 线性 (0,0)；3 = 二次曲线；4 = 二次曲线 (0,0)。

(Data Analysis、GETCOMPOUND、GETRESULT)

Cal_ISTD

0 = 非内标化合物；1 = 化合物是内标化合物

(Data Analysis、GETCOMPOUND)

Cal_Peaks

结果文件中的结果数目。

(Data Analysis、STARTREPORT)

Cal_Pk_Amt

计算出的目标信号的浓度。

(Data Analysis、GETRESULT)

Cal_Pk_Found

目标信号状态：1 = 可以发现但不符合特征离子准则，2 = 可以发现且不符合特征离子准则。

(Data Analysis、GETRESULT)

Cal_Pk_Num

通过 GETCOMPOUND 检索到的定量数据库化合物的条目编号（列表中第一个化合物的编号为 1，第二个为 2 等等）。如果指定 GETCOMPOUND SELECT，n，则值 n 将会依此变量进行编码。

(Data Analysis、GETCOMPOUND)

Cal_Pk_Ret

实际观察到的定量结果的保留时间，以毫秒为单位。

(Data Analysis、GETRESULT)

Cal_TR

0 = 非时间参比化合物；1 = 时间参比化合物。

(Data Analysis、GETCOMPOUND)

Cal_Title$

确定与定量数据库相关的标题。

(Data Analysis)

Cal_UpdTime$

指定最后一次更新定量数据库的时间和日期的字符串。

(Data Analysis)

CapData

收集到的数据。

(Instrument Control、CAPTURE)

CapDataPts

收集到的数据点数。

(Instrument Control、CAPTURE)

CapMax

最高丰度。

(Instrument Control、CAPTURE)

CapMean

平均丰度。

(Instrument Control、CAPTURE)

CapMin

最低丰度。

(Instrument Control、CAPTURE)

CapStdDev

标准偏差。

(Instrument Control、CAPTURE)

CapTime

需要获得数据的时间，以微秒为单位。

(Instrument Control、CAPTURE)

Cas_Hit1、Cas_Hit2。. .

已找到的每个匹配化合物的参考数。

(Data Analysis、FINDBYCAS)

Cas_Hits

已找到的匹配化合物数目。

(Data Analysis、FINDBYCAS)

Cas_Num$

格式 nnnnn-nn-n 中的 CAS 编号（在谱库文件标题中）。

(Data Analysis、GETSCALARS RESULTS)

CasNo$

化学文摘编号。

(Data Analysis、GETRESULT)

Cavg[]

定量数据库中的校准表的浓度级平均计数。数组变量；请参考 Cavg[1]、Cavg[2] 等数组中的值。

(Data Analysis、GETCOMPOUND、GETRESULT)

Cconc[]

定量数据库中的校准表各级的浓度。数组变量；请参考 Cconc[1]、Cconc[2] 等数组中的值。

(Data Analysis、GETCOMPOUND、GETRESULT)

CIConfigured

指明是否已配置 CI 的标志。1 = 是；0 = 否

(Instrument Control)

ClFl$[]

校准文件基本名称。数组变量；请参考 ClFl$[1]、ClFl$[2] 等数组中的值。

(Data Analysis)

Clid$[]

校准级的字符串 ID。数组变量；请参考 Clid$[1]、Clid$[2] 等数组中的值。

Data Analysis

CmdLineState

TOP 和 MSDA 用来跟踪命令行显示状态的变量。如果命令行不可见（或关），则其值为 0，如果命令行可见（或开），则其值为 1。

(Data Analysis、Top)

Coef0、Coef1、Coef2

校准曲线方程的系数。y = 浓度比，x = 响应比。y = coef0 + coef1(x) + coef2(xE2)

(Data Analysis、GETRESULT)

Company_ID$

与检索到的参比化合物相关的公司 ID（最长为 10 个字符）。

(Data Analysis、GETMSREF)

Confidm_z

在曲线拟合基础上，m/z 值的可信度为 95% 。

(Instrument Control、PROFILE)

CpndType$

用户定义的化合物类型。

(Data Analysis、GETRESULT)

Cresp[]

定量数据库中的校准表各浓度级的响应。数组变量；请参考 Cresp[1]、Cresp[2] 等数组中的值。

(Data Analysis、GETCOMPOUND、GETRESULT)

DDS

Top 用于管理内务的变量。

(Top)

DefSampAmt

定量报告中缺省的样品量值。

(Data Analysis)

DirectPr

1 = 直接发送给打印机（使用 LaserMaster 卡时使用此值）；ChemSpooler 不能用于打印使用 ENDPRINT 命令执行的作业（TABULATE 仍使用 ChemStation spooler）；0 = 使用 ChemSpooler（缺省）。

(Instrument Control、Data Analysis、STARTPRINT、ENDPRINT、PRINTTEXTFILE)

Do_Print

指明是否将打印自动调谐报告的标志；1 = Yes（是），0 = No（否）。

(Instrument Control)


Hpmsduntitled00001679

E 至 M

EdpDefPos

1 = 未使用 Edit Parameter（编辑参数）自动定位和调用对话框；0 = 自动（缺省）。

(Instrument Control、EDPARMS)

End_Time

色谱峰的结束时间。请参见 PEAKVARS 命令。

(Data Analysis、PEAKNUMBER)

Entry_Num

指定结果的谱库条目编号。

(Data Analysis、GETSCALARS RESULTS)

EntryNo

质谱库中的条目编号。

(Data Analysis、GETRESULT、GETMSREF)

Eqn1$、Eqn2$

Eqn1$ 包含校准方程，Eqn2$ 包含 RSD 或 RHO 和曲线拟合类型。

(Data Analysis、CALIBPRINT)

Exp_Rt_Hi

期望的定量结果的高保留时间，以分钟为单位。

(Data Analysis、GETRESULT)

Exp_Rt_Lo

期望的定量结果的低保留时间，以分钟为单位。

(Data Analysis、GETRESULT)

File_End

文件中最后一次扫描的时间，以分钟为单位。

(Data Analysis、FILE)

File_Start

文件中第一次扫描的时间，以分钟为单位。

(Data Analysis、FILE)

File_Type

数据文件类型。

(Data Analysis、FILE)

FilePrint_Lines

从 ASCII 文件打印时保留行号。

(Data Analysis、FILEPRINT)

FilePrompt

0 = 无提示，1 = 提示保存调谐文件（缺省）。

(Instrument Control)

Font$

当前指定的字体名称。

(Data Analysis)

FontAnn

CP 变量，用于设置用户创建的注解。请参见 MS 化学工作站中的字体选择

FontAxis

CP 变量，用于设置绘图坐标轴字体。请参见 MS 化学工作站中的字体选择

FontTitle

CP 变量，用于设置绘图标题的字体。请参见 MS 化学工作站中的字体选择

Graphics_On

常数。始终为 on（开）。

(Instrument Control)

HEDConfigured

1 = Yes（是）；0 = No（否）。

(Instrument Control)

Height_Quant

1 = 选定的测量高度；0 = 选定的测量面积。

(Data Analysis、EDITCPNDS)

Hit

选定的 PBM Graphics Hit Number（PBM 图形匹配数）。0 = 取消选中；1-20 = 从谱库检索中选定的化合物匹配数。

(Data Analysis、DLGGRESULTS)

Hit_Name$

谱库标题中记录的指定条目的名称。

(Data Analysis、GETSCALARS RESULTS)

Inject_Time

进样时间，以 Windows 时间计（自启动系统开始已经历的毫秒数）。

(Acq、RUNSTART)

Int0、Int1

积分基线数据。

(Data Analysis、GETRESULT)

IP[]

如果将 RTEINTPARMS 的参数 13 设置为非 0，则将 IP 设置为包含前 12 个参数值的由 12 个标量元素组成的数组。

(Data Analysis、RTEINTPARMS)

IsoAbund1、IsoAbund2、IsoAbund3

同位素峰的丰度。

(Instrument Control、PROFILE)

IsoMass1、IsoMass2、IsoMass3

同位素峰的质量。

(Instrument Control、PROFILE)

IStd_Amt

未知（如果适用；如果不适用，则为 -1）化合物中的内标量。

(Data Analysis、GETCOMPOUND、GETRESULT)

IStd_Area

包含内标的响应，该响应可以是化合物的峰高或峰面积，取决于 Measure Response By 选项。仅当所需的目标化合物是与内标化合物相关的分析物时才有意义。

(Data Analysis、CPDANALYZE、GETRESULT)

JobName$

包含打印作业的名称（在第一个参数中指定为 STARTJOB，缺省为字符串“MSDA Print”）。

(Data Analysis、Instrument Control、STARTJOB)

Label_Peaks_Thr

给定的 m/z 峰和基峰（该峰可看作是一种标记峰）之间的最小响应比。

(Data Analysis)

LastPrint$

预留用于 PRINT 命令；用于将输出创建立一个变量。更新之前必须对其进行定义。

（全部、PRINT）

Lcv

适用于所有选项（SELECT 除外）的循环控制标志。如果命令到达时间参比列表的末尾，则设置为 0（适用于 TIMEREF 选项）或 ISTD（适用于 ISTD 选项）或所有化合物（适用于正常模式）。使用 GETCOMPOUND 命令有助于宏在定量数据库中循环。

(Data Analysis、GETCOMPOUND、GETRESULT)

Lib$

已检索的谱库名称。

(Data Analysis、GETSCALARS RESULTS)

LogToDB

0 = 禁用，1 = 启用

Custom Report（自定义报告）中的 MSDA 变量。如果加载 Method（方法）时不存在名为 CUSTPARM.MAC 的文件，则将 LogToDB 设置为 0。否则，与宏相关的 Custom Report（自定义报告）可能会在相应的条件下将其设置为 1。

(Data Analysis)

MatALo、MatAHi、MatARpd、MatAMdl

基质 A 的数据。

(Data Analysis、GETRESULT)

MatBLo、MatBHi、MatBRpd、MatBMdl

基质 B 的数据。

(Data Analysis、GETRESULT)

MatSpk

基质添加量。

(Data Analysis、GETRESULT)

MaxA

最高自动调谐丰度。

(Instrument Control)

Melt_Pt

熔点（在谱库标题中）。如果此信息不可用，即报告 -300.00。

(Data Analysis、GETSCALARS RESULTS)

MethCommentxxx$

有关方法的备注（其中 xxx 从 0 开始，步长为 1）。

(Top、METHINFOPANEL)

MinA

最低自动调谐丰度。

(Instrument Control)

Mi_Used

手动积分：0 = 未使用，1 = 已使用。

(Data Analysis、GETRESULT)

Misc_Info$

与检索到的参比化合物相关的其他信息的前 132 个字符。

(Data Analysis、GETMSREF)

Mol_Formula$

检索到的参比化合物分子式的前 132 个字符。

(Data Analysis、GETMSREF)

Mol_Wt

分子量（在谱库标题中）。

(Data Analysis、GETSCALARS RESULTS、MW)

MsAcq_State

采集状态：0 = 空闲，1 = 进样前阶段（进样未就绪），2 = 进样后阶段（已采集到数据），3 = 进样前阶段（准备进样就绪）， 4 = 进样后阶段（溶剂延迟，未收集到数据）。

(Instrument Control、RUNSTART)

MsDbName$

质谱数据库（谱库名称）。

(Data Analysis、GETRESULT)

Multiplier

定量报告中使用的倍增器值。

(Data Analysis)

MzRange

期望的质量范围，在该范围内提取离子色谱图时，离子色谱图可以看作而且仍然可以看作是潜在匹配。

(Data Analysis)


Hpmsduntitled00001680

N 至 P

N4、N5、N6、N7、N8、N9

用户定义的数字项

(Data Analysis、GETRESULT)

NGroups

当指定的组编号非 0 但指定的峰编号为 0 时，使用 PEAKVARS 命令可以进行设置（标量修订）。

(Data Analysis、PEAKVARS)

NIons

反映使用该命令检索到多少个 EIC（提取离子色谱图）。

(Data Analysis、CHROMATOGR)

No

否 = 0，是 = 1，关 = 0，开 = 1

预定义的 CP 变量，用于将某些命令的符号 0 转换成 1（历史原因）。

（全部）

NObjects

变量中的对象编号；始终应使用 GETSCALARS POINT 和 GETSCALARS INFO 命令设置为 1。

(Data Analysis、GETSCALARS)

NPeaks

依据积分实现找到的色谱峰编号。请参见 RTEINT。

(Data Analysis、INTEGRATE、AUTOINT)

NPoints

对象中数据点的编号。

(Data Analysis、POINTS)

NRfWin

非参比窗口。此值的一半为时间极限，在此时间范围内，给定峰可以存在且仍然可以看作是非时间参比化合物的潜在匹配。

(Data Analysis)

NRfWin_TP

如何表达 NRfWin：0 = 分钟；1 = 期望保留时间的相对百分比。

(Data Analysis)

NTimeRefs

结果文件中时间参比化合物的编号。

(Data Analysis、STARTREPORT)

Num_Hits

已找到的匹配的编号。如果找不到匹配化合物（或者如果尚未执行匹配检索），请将其设置为 0。

(Data Analysis、GETSCALARS RESULTS)

NumScanPeaks

扫描中的峰编号。

(Instrument Control、SCAN)

Off/On

否 = 0，是 = 1，关 = 0，开 = 1

预定义的 CP 变量，用于将某些命令的符号 0 转换成 1（历史原因）。

（全部）

OnFlagLabel$

存储使用 On_Flag 关键字在 Sample Log Table（样品日志表）中指定的标签名称。可以使用 Data Analysis 更改此变量，这样就允许以分析结果为基础运行不同的子系列。更改过的值将变成下一个样品的缺省值。

(Top)

OpticsConfigure

表明仪器是否具有负离子选项的标志。

(Instrument Control)

OrientPr

在每页的基础上确定打印机方向。使用 PRINTTEXTFILE 读取。1 = 纵向模式；2 = 横向模式。如果不存在 OrientPR，将使用 win.ini 中当前打印机的方向设置。如果 win.ini 中未设置方向，则使用纵向模式。

(Data Analysis)

Orphan

标量。如果此 Data Analysis 的执行示例与 Top Level（顶级）相连，则值为 0，否则为 1。

(Data Analysis)

PageNum

打印作业中页的页号。

(Data Analysis)

PBMShowDiff

仅在内部使用。PBM 检索结果对话框上的 Show Difference 复选框的状态反映。(Data Analysis)

PctSCWin

百分比报告使用的信号相关参数值（与定量计算中使用的参数值类似）

(Data Analysis)

Peak_Area

色谱峰的积分面积。

(Data Analysis、PEAKNUMBER、PEAKVARS)

PeakHeight

此变量已被 AbsPeakHeight 和 BslPeakHeight 取代。

PeakMax1、PeakMax2、PeakMax3

每个调谐质量的最高丰度。

(Instrument Control、PROFILE)

PeakMin1、PeakMin2、PeakMin3

每个调谐质量的最低丰度。

(Instrument Control、PROFILE)

Peakm_z1、Peakm_z2、Peakm_z3

曲线拟合的质/荷比值。1、2、3 表示调谐质量。

(Instrument Control、PROFILE)

Peak_Name$

在定量数据库中选定的化合物的名称。请参见 GETRESULT。

(Data Analysis、GETCOMPOUND、GETRESULT)

Peak_Sig

使用信号描述（TIC 或 EIC m/z）的 PEAKVARS 命令（标量修订）为在命令中指定的组编号和峰编号设置的变量。

(Data Analysis、PEAKVARS)

Peak_Type

使用 PEAKVARS、PEAKNUMBER（GC/MS 形式）设置。为指定的积分结果提供 Peak Type（峰类型）代码。有关 Peak Type（峰类型）代码的说明，请参见 TABULATE RESULTS。

(Data Analysis、PEAKVARS、PEAKNUMBER)

Peak_Width

峰的宽度，以时间单位计。

(Data Analysis、PEAKVARS、PEAKNUMBER)

PeakWidth1、PeakWidth2、PeakWidth3

每个调谐质量 50% 峰高处的峰宽。

(Instrument Control、PROFILE)

Percent_Events$

积分参数文件的名称。如果指定了自动积分，请将其设置为 null。

(Data Analysis、PCTRPTOPT)

Percent_File$

将报告发送到的文件的名称。如果未将报告发送到文件，请将其设置为 null。

(Data Analysis、PCTRPTOPT)

Percent_Method

0 = RunMethod 过程中未生成报告；1 = RunMethod 过程中生成了报告。

(Data Analysis、PCTRPTOPT)

Percent_Printer

0 = 未将报告发送到打印机；1 = 将报告发送到了打印机。

(Data Analysis、PCTRPTOPT)

Percent_Screen

0 = 未将报告发送到屏幕；1 = 将报告发送到了屏幕。

(Data Analysis、PCTRPTOPT)

Percent_Type

0 = 按信号计算；1 = 按保留时间计算。

(Data Analysis、PCTRPTOPT)

PlotFont

CP 变量，用于设置绘图字体。请参见 MS 化学工作站中的字体选择

Pk_Area

峰面积。

(Data Analysis、GETRESULT)

Pk_End_BLine

基线高度，将峰终点计算在内。

(Data Analysis、PEAKVARS、PEAKNUMBER)

Pk_Start_BLine

基线高度，将峰起点计算在内。

(Data Analysis、PEAKVARS、PEAKNUMBER)

PreCursor1、PreCursor2、PreCursor3

每个前体的丰度。

(Instrument Control、PROFILE)

PrintCustReport

0 = 禁用，1 = 启用

Custom Report（自定义报告）中的 MSDA 变量。如果加载 Method（方法）时不存在名为 CUSTPARM.MAC 的文件，则将 PrintCustReport 设置为 0。否则，与宏相关的 Custom Report（自定义报告）可能会在相应的条件下将其设置为 1。

(Data Analysis)

ProfData1、ProfData2、ProfData3

图形扫描得到的数据。

(Instrument Control、PROFILE)

ProfDataPts1、ProfDataPts2、ProfDataPts3

图形数据点的编号。

(Instrument Control、PROFILE)

PRLibName$

已检索的谱库名称。

(Data Analysis、PRRETRIEVE)

PRMatches

由 100 个条目组成的数组，其中包含最后一次检索的条目编号。

(Data Analysis、PRRETRIEVE)

PRMaxMatches

指定的最大匹配数。

(Data Analysis、PRRETRIEVE)

PRNumMatches

实际找到的匹配数（0 至 PRMaxMatches）。

(Data Analysis、PRRETRIEVE)

PRSpectrum

在其中保留库谱的变量。

(Data Analysis、PRRESULTS)

PRSubtract

在其中保留归一化谱库检索光谱的变量。

(Data Analysis、PARAMRET.MAC)

PW101、PW102、PW103

每个调谐质量 10% 峰高处的峰宽。

(Instrument Control、PROFILE)


Hpmsduntitled00001681

Q

Q1、Q2、Q3

在定量数据库中设置的特征信号质量。

(Data Analysis、GETCOMPOUND、GETRESULT)

Q1_HiRat、Q2_HiRat、Q3_HiRat

特征信号比的上限。

(Data Analysis、GETRESULT)

Q1_LoRat、Q2_LoRat、Q3_LoRat

特征信号比的下限。

(Data Analysis、GETRESULT)

Q1_Pk_Area、Q2_Pk_Area、Q3_Pk_Area

特征峰的积分面积。

(Data Analysis、GETRESULT)

Q1_Pk_Ret、Q2_Pk_Ret、Q3_Pk_Ret

特征峰的保留时间（已积分）。

(Data Analysis、GETRESULT)

Q1_Pu、Q2_Pu、Q3_Pu

定量数据库的百分比不确定度。

(Data Analysis、GETCOMPOUND、GETRESULT)

Q1_Rr、Q2_Rr、Q3_Rr

定量数据库的相对响应，以 % 计。

(Data Analysis、GETCOMPOUND、GETRESULT)

Q1_Sum、Q2_Sum、Q3_Sum

打开（关闭）特征离子的面积和。0 = Off （关闭），1 = On（打开）。

(Data Analysis、GETCOMPOUND、GETRESULT)

Q1Events$、Q2Events$、Q3Events$

定量数据库中的特征信号积分模式。如果为 null，则为 RTEINT 模式

(Data Analysis、GETCOMPOUND、GETRESULT)

QDBWinWidth

仅在内部使用。与 Quant Setup（定量设定）对话框相关。

(Data Analysis)

QDB_Insert

仅在内部使用。与 Quant Setup（定量设定）过程相关。为使用 Quant Setup（定量设定）方法的插件提供在数据库中的序号位置。

(Data Analysis)

QDel

1 = 已删除定量匹配化合物；0 = 未删除定量匹配化合物。

(Data Analysis、GETRESULT)

QHits

结果记录中的定量匹配化合物数。

(Data Analysis、GETRESULT)

QHits_Max

Target Compound Ident（鉴定目标化合物）过程保存的目标化合物的最大匹配数。

(Data Analysis、GETCOMPOUND、GETRESULT)

Qrint_Print

定量调试。缺省为 off（关）。

(Data Analysis)

QuadMax

推荐的最高四极杆温度。

(Instrument Control)

Qual_Apex

1 = 在峰顶点测得的光谱；2 = 在峰顶点测得的光谱减去峰起点的背景得到的光谱；3 = 在峰顶点测得的光谱减去指定时间的背景得到的光谱；4 = 峰中所有光谱的平均值。

(Data Analysis、QUALPARMS)

Qual_Edit$

当前正在编辑的谱库名称。用来避免当前编辑的谱库名称变成方法的第一个检索谱库。

(Data Analysis)

Qual_Events$

积分参数文件的名称。如果指定了自动积分，请将其设置为 null。

(Data Analysis、QUALPARMS)

Qual_Edit$

将报告发送到的文件的名称。如果未将报告发送到文件，请将其设置为 null。

(Data Analysis、QUALRPTOPT)

Qual_Hit1、Qual_Hit2

一级和二级 MS 谱库的匹配质量阈值。

(Data Analysis、QUALPARMS)

Qual_Lib1$、Qual_Lib2$、Qual_Lib3$

待检索的一级、二级和三级 MS 谱库文件名。

(Data Analysis、QUALPARMS)

Qual_Method

0 = 运行方法时不要生成谱库检索报告；1 = 运行方法时生成谱库检索报告。

(Data Analysis、QUALRPTOPT)

Qual_Printer

0 = 未将报告发送到打印机；1 = 将报告发送到了打印机。

(Data Analysis、QUALRPTOPT)

Qual_RepType

Library Search Report（谱库检索报告）式样的当前选项；0 为“概要信息”；1 为“详细信息”

(Data Analysis、QUALRPTOPT)

Qual_Screen

0 = 未将报告发送到屏幕；1 = 将报告发送到了屏幕。

(Data Analysis、QUALRPTOPT)

Qual_Time

背景光谱的时间。

(Data Analysis、QUALPARMS)

Quality

结果质量。如果未指定结果数目，请将其设置为所有匹配化合物的最高质量。

(Data Analysis、GETSCALARS RESULTS)

Quant_Detailed

0 = 概要信息；1 = 详细信息/文本信息；2 = 详细信息 + 图形信息；3 = 单个化合物；4 = 面积百分比。

(Data Analysis、QUANTRPTOPT)

Quant_File$

文件名（如果非 null）。

(Data Analysis、QUANTRPTOPT)

QuantItems

使用方法的定量数据库跟踪 Integrator （积分器）的选择：如果选择 RTEINT，则为 0，否则为 2。此变量及其所赋的值存在的原因在于它在 Edit Quant Result（编辑定量结果）和 Save Quant Result（保存定量结果）菜单项的 MENUCMD 命令字符串中用于菜单项显示模式。0 表示正常显示，2 表示变灰显示。

(Data Analysis)

Quant_Method

0 = No（否）；1 = Yes（是）

(Data Analysis、QUANTRPTOPT)

Quant_Printer

0 = No（否）；1 = Yes（是）

(Data Analysis、QUANTRPTOPT)

Quant_Screen

0 = No（否）；1 = Yes（是）

(Data Analysis、QUANTRPTOPT)

Quant_Select

单个化合物的选择。

(Data Analysis、QUANTRPTOPT)

QValue

计算出的 Target Compound（目标化合物）匹配的 QValue。请参见 QValue 的说明。

(Data Analysis、GETRESULT)

Q_XCF、Q_XCI

对于感兴趣的目标化合物条目，为 Edit Compound（编辑化合物）面板中的面积校正因子和面积校正离子 m/z。

(Data Analysis、GETCOMPOUND、GETRESULT)

Q_XCResp

包含面积校正响应。如果未启用面积校正，则为 0。这是从普通峰面积中扣除干扰后产生的校正面积的值。使用 CPDANALYZE 设置，使用 UPDATERSLT 读取。

(Data Analysis、CPDANALYZE)


Hpmsduntitled00001682

R 至 S

RampData

SIMRAMP 的数据。

(Instrument Control、SIMRAMP)

RampDataPts

SIMRAMP 的数据点数。

(Instrument Control、SIMRAMP)

RampMax

如果优化类型为 Max，则为最后一个梯度的最高丰度。

(Instrument Control、SIMRAMP)

Ratio_Method

0 = 扩展面积定量

1 = 未扣除

2 = 缩小第一个和最后一个

3 = 平均第一个和最后一个

(Data Analysis、GETCOMPOUND)

RecalStat[]

当 Update Calibration（更新校准）操作使用以前创建的 MS ChemStation G1034C 结果文件时，用以提供信息的数组。RecalStat[1] = 定量数据库中的化合物编号。RecalStat[2] = Quant Result（定量结果）文件中的结果记录次数，包括 NOT FOUNDS，不包括多次匹配记录。RecalStat[3] = Update Calibration（更新校准）操作过程中实际发生的更新定量数据库的次数。RecalStat[4] = Result（结果）文件中的记录次数，这些记录都是成功的记录，但是定量数据库中没有任何化合物具有与之精确匹配的名称。

(Data Analysis、RECALIB)

Ref_Name$

在 Ref Spec Name 字段中使用 GETCOMPOUND 为给定的目标化合物条目设置名称。

(Data Analysis、GETCOMPOUND)

RefWin

参比窗口：此值的一半为时间极限，在期望的保留时间内，给定峰可以存在且仍然可以看作是时间参比化合物的潜在匹配。

(Data Analysis)

RefWin_Tp

如何表达 RefWin 值：0 = 分钟；1 = 期望保留时间的相对百分比。

(Data Analysis)

ReInt

0 = 指示宏重新积分，因为用户对峰赋值感到不满意；1 = 指示宏接受此对话过程中所作的峰赋值

(Data Analysis、ASSIGNPEAKS)

Ret_Index

谱库标题的保留指数（或保留时间）。

(Data Analysis、GETSCALARS RESULTS)

Ret_Time

当前保留时间，以分钟为单位；数据采集过程中定期更新。

(Instrument Control、RUNSTART)

Ret_Time

积分峰的保留时间。请参见 PEAKVARS、SCAN、SPECTRUM。

(Data Analysis、PEAKNUMBER、PEAKVARS)

RF array

响应因子。

(Data Analysis、GETRESULT)

Rho

校准曲线拟合统计。对于线性拟合，它既是平均响应因子 (RF) 的确定系数，也是相对标准偏差，等等。

(Data Analysis、GETRESULT)

RT_Delta

期望的保留时间范围，在该范围内将化合物添加到定量数据库中时，给定峰可以看作而且仍然可以看作是潜在匹配。

(Data Analysis)

RTWinMod — Extraction（提取）窗口的格式

0 = 以分钟格式显示 Compound（化合物）面板上的 Extraction（提取）窗口

1 = 以百分比格式显示 Compound（化合物）面板上的 Extraction（提取）窗口

(Data Analysis、GETCOMPOUND、PUTCOMPOUND)

Runlength

当前运行的时间长短，以分钟为单位。如果用户在运行过程中延长运行时间，则更新。

(Instrument Control、RUNSTART)

Scan_Num

检索光谱的扫描次数。请参见 PEAKVARS、SCAN、SPECTRUM。

(Data Analysis、PEAKNUMBER)

ScanAbund1、ScanAbund2、ScanAbund3

每个调谐质量的丰度。

(Instrument Control、SCAN)

ScanBaseAbund

基峰丰度。

(Instrument Control、SCAN)

ScanBasePeak

基峰 (amu)。

(Instrument Control、SCAN)

ScanData

光谱扫描得到的数据。

(Instrument Control、SCAN)

ScanDataPts

光谱扫描得到的数据点数。

(Instrument Control、SCAN)

ScanIsoAbund1、ScanIsoAbund2、ScanIsoAbund3

同位素丰度。

(Instrument Control、SCAN)

ScanIsoMass1、ScanIsoMass2、ScanIsoMass3

同位素质量。

(Instrument Control、SCAN)

ScanMass1、ScanMass2、ScanMass3

每个调谐质量的质量 (amu)。

(Instrument Control、SCAN)

ScanNumOn

1 = 用扫描次数代替文件使用的时间。

(Instrument Control、MSOPEN)

SCErrNum

最后一次 I/O 过程中 MS 界面的错误编号。

(Instrument Control)

SCErrString$

最后一次 I/O 过程中 MS 界面的错误字符串。

(Instrument Control)

SCTimeOut

允许修改 SCWRITE、SCQUERY 和 SCTRACE 命令的暂停。

(Instrument Control)

SCWin

定量使用的信号相关窗口。

(Data Analysis)

SequenceFlag

通过 Sample Log Table（样品日志表）关键字 On_Flag 和 If_Flag 进行读取。1 = On（打开），0 = Off（关闭）。

(Top、TOPDOT)

Seq_Trace

用户设置的共用变量；打开或关闭序列调试工具。1 = On（打开），0 = Off（关闭）。

Sig_Num

定量数据库中的目标信号质量。

(Data Analysis、GETCOMPOUND、GETRESULT)

SigMin、SigMax

最低信号级和最高信号级。

(Data Analysis、GETRESULT)

Size

文件大小（如果文件存在），以字节为单位。如果文件不存在，则为 -1。

（全部、FILESIZE）

Snapshot

快照操作的状态：2 = 使用 DDE 远程启动快照；1 = 使用 Make Snapshot File（制作快照文件）按钮交互启动快照；0 = 快照成功；-1 = 快照失败。

(Instrument Control、RUNSTART)

Spectral_Window

间隔大小，以 amu 计，其中质谱中的所有 m/z 点都认为具有同一个 m/z 值（在 MS 加法中使用时，要用 + 运算符）。将其作为 Method（方法）的一部分保存在 MSDAMISC.MAC 中。如果调用 BSB 之前设置为 0，则会为您提供原始的 BSB。

(Data Analysis)

StackState

仅由 MSDA 使用，以跟踪 Stack（堆栈）窗口的显示状态。如果 Stack（堆栈）窗口不可见（或关），则其值为 0，如果 Stack（堆栈）窗口可见（或开），则其值为 1。

(Data Analysis、STACK)

Start_Scan、Stop_Scan

使用 PEAKVARS 和 PEAKNUMBER 设置（GC/MS 形式）。提供与积分峰相关的起点和终点扫描次数。仅用于 RTEINT 积分 — 对于 MS 化学工作站积分，值始终为 1。

(Data Analysis、PEAKVARS、PEAKNUMBER)

Start_Time

色谱峰的开始时间。请参见 PEAKVARS 命令。

(Data Analysis、PEAKNUMBER)

StdMenu

这是类 MENU 的一个变量，其中包含运行化学工作站应用程序的标准菜单的数据结构。

（全部）

Suppress

如果设置为 1，则不在从 MS 扣除的质谱中创建负值的 m/z 点；结果将从结果中删除这些点。

（在 MS 减法中使用时，要用 + 运算符）。

(Data Analysis)

Surrogate

替代级。

(Data Analysis、GETRESULT)


Hpmsduntitled00001683

T 至 Z

T0、T1

定量数据库中的积分时间范围。

(Data Analysis、GETCOMPOUND、GETRESULT)

TabFooter$

如果设置了 TabFooter，将在每页表格的底部打印出 PageNum。

TargMass、Target1、Target2 ...Target6

(Instrument Control、OPTIM)

TgtEvents$

定量数据库的目标信号积分模式。

(Data Analysis、GETCOMPOUND、GETRESULT)

TR_Corr

时间参比相关；如果将某化合物标记成时间参比化合物，则设置实际和期望保留时间比；否则，不设置。

(Data Analysis、STARTANALYSIS、CPDANALYZE)

TRun_Duration

调谐采集运行的持续时间，以分钟为单位。当使用 EDITFILEINFO 将 ScanNumOn 设置为 0 时，设置此变量。

(Instrument Control)

TRun_NScans

调谐采集运行的持续时间，以扫描次数计。当使用 EDITFILEINFO 将 ScanNumOn 设置为 1 时，设置此变量。

(Instrument Control)

TuneFileName$

当前的调谐文件。系统初始缺省为 ATUNE.U。请参见 SAVECONFIG。

(Instrument Control、GETCONFIG)

TuneFilePath$

当前调谐文件的目录路径。缺省始终为 MS 化学工作站的 MSEXE 目录。其他任何路径都将导致错误。请参见 SAVECONFIG。

(Instrument Control、GETCONFIG)

TuneSize

0 = 图标；1 = 满屏。

(Instrument Control)

TuneTraceName$

Tune（调谐）进程记录的输出文件名。初始值为 TUNE.TRC。

(Instrument Control、TRACE)

TuneTracePath$

Tune（调谐）记录输出的驱动器和路径。初始值为 MS 化学工作站的 MSEXE 目录。

(Instrument Control、TRACE)

TuneType$

自动调谐报告的标题字符串。

(Instrument Control)

Type

MS 类型： 4=5973.

(Instrument Control)

Unc_Tp

百分比不确定度类型选择；0 = 相对，1 = 绝对。

(Data Analysis、GETCOMPOUND、GETRESULT)

Uqr

0 = 更新特征峰比，1 = 不更新特征峰比。

(Data Analysis、GETRESULT)

UseQIons

使用特征离子的控制标志；0 = 忽略，1 = 使用特征离子。

(Data Analysis、GETCOMPOUND、GETRESULT)

UseRteInt

>0 = 使用 RTE 积分器，标准 MSDA 过程将调用其中的积分。0 = 使用 MS 化学工作站积分器。

(Data Analysis)

Valley1、Valley2、Valley3

每个峰谷的丰度。

(Instrument Control、PROFILE)

Value

找到的值。如果索引超出范围，请使用最新的索引。

(Data Analysis、GETSCALARS INDEX)

ValvePrompt

使用自动校准阀对仪器无任何影响。

0 = 无提示，1 = 提示关闭阀（缺省）。

(Instrument Control)

Window_Drag

仅在内部使用。选定坐标状态变量。

(Data Analysis)

Xval

与 Y 轴对应的 X 轴的值。请参见 GETSCALARS POINT。

(Data Analysis、GETSCALARS)

Xhigh

对象中最大的 X 值。请参见 GETSCALARS POINT。

(Data Analysis、GETSCALARS)

Xlow

对象中最小的 X 值。请参见 GETSCALARS POINT。

(Data Analysis、GETSCALARS)

Yes

NO（否） = 0，YES（是） = 1，OFF（关） = 0，ON（开） = 1

预定义的 CP 变量，用于将某些命令的符号 0 转换成 1（历史原因）。

（全部）

Yval

如果是单个对象，则 Y 是 Yhigh。请参见 GETSCALARS POINT。

(Data Analysis、GETSCALARS)

Ylow

色谱图：对象中最小的 Y 值（可以是正数、负数或零）。

光谱：如果是负值，则为对象中最小的 Y 值。否则，请将其设置为 0，以反映光谱中不存在的质量峰具有零丰度这一事实。

请参见 GETSCALARS POINT。

(Data Analysis、GETSCALARS)

Yhigh

对象中最大的 Y 值。请参见 GETSCALARS POINT。

(Data Analysis、GETSCALARS)


Hpmsduntitled00001688

双塔序列

序列名称：C:\MSDCHEM\1\SEQUENCE\DEFAULT.S

注释：双塔/双柱序列

操作者：

数据路径： C:\MSDCHEM\1\DATA\

前序列命令：

后序列命令：

对条形码不匹配项所使用的方法部分

(X) 完整方法 (X) 任意方式进样

( ) 只进行重新处理 ( ) 不要进样

行 类型 样品瓶 数据文件 方法 样品名称

--------------------------------------------------------------

1 DualTwr

2 RearSamp 1 REAR1 RearTower Sample 1

3 Sample 2 FRONT2 FrontTower Sample 2

4 RearSamp 3 REAR3 RearTower Sample 3

5 Sample 4 FRONT4 FrontTower Sample 4

前塔数据文件在 c:\MSDchem\1\data 目录下。后塔数据文件在 c:\MSDchem\1\data.sec 目录下。

GC 检测器必须指定为 GC 信号 2，MSD 必须指定为 MS 配置程序中的前进样口。


Hpmsduntitled00001689

单进样口，单色谱柱，GC 和 MS 检测器，一个数据文件目录

序列名称：C:\MSDCHEM\1\SEQUENCE\DEFAULT.S

注释：包含 MS 和 GC 信号的单个数据文件

操作者：

数据路径：C:\MSDCHEM\1\DATA\

前序列命令：

后序列命令：

对条形码不匹配项所使用的方法部分

(X) 完整方法 (X) 任意方式进样

( ) 只进行重新处理 ( ) 不要进样

行 类型 样品瓶 数据文件 方法 样品名称

--------------------------------------------------------------

1 Sample 1 hp1 DEFAULT Sample 1

2 Sample 2 hp1 DEFAULT Sample 2

3 Sample 3 hp1 DEFAULT Sample 3

4 Sample 4 hp1 DEFAULT Sample 4

数据文件在 c:\MSDchem\1\data 目录下。


更新校准

选择 Calibrate / Update Levels/Single Level（校准/更新浓度/单浓度）时，将显示 Update Calibration（更新校准）对话框。使用 AutoQuant Setup（自动定量设置）功能时，也会显示此对话框。

Calibration Data File（校准数据文件）

Calib Level ID（校准浓度级 ID）

Add New Level（添加新浓度级）

Recalibrate（重新校准）

Delete（删除）

完成校准更新所需的项目后，请单击 Do Update（执行更新）。将自动显示 Edit Compound（编辑化合物）对话框，使您可以查看校准数据。

仅在当前方法包括带有此项目的定量数据库时，才可用此对话框。


更新参比光谱

参比光谱用于比较标准或谱库中的已知数据和采集到的目标化合物的数据。可以通过在 EasyID 或 QEdit 中交互加载的数据文件更新参比光谱。

通过选择扫描峰顶点和第一次扫描峰之前扣除扫描，可以获得参比光谱。


更新响应

No Update

不执行任何操作。

Average

新值为初始校准和所有再校准的平均值。计数器将保留校准数据库中的每个值，以指明用于计算当前值的值编号。校正平均值使用的方程为：

n * Response Old + Response New

n + 1

其中

n = 1（初始校准 + 以前再校准的次数）

Response Old = 存储在校准表中的当前相应

Response New = 新获得的响应

使用 GETCOMPOUND 命令，接着使用 Cavg 命令，可以从化合物数据库中获得化合物的当前 n 值。

只要仪器状态更改或生成与当前存储的响应完全不同的响应，即推荐使用 Replace（替换）更新选项。

Replace

用新值替换旧值。将此级计数器全部复位至 1。


更新保留时间

No Update

不执行任何操作。

Average

新值为指数平均值：

新 RT = 3/4（旧 RT）+ 1/4（结果*文件中的新 RT）

Replace

用新值替换旧值。

* 定量数据文件时，将把结果文件与数据文件存储在一起。


用户谱库

用户谱库包含手动输入到谱库中的质谱。此类谱库同常包括可以在特定应用程序中检索到的化合物。项目来源可以是商业谱库，也可以是标准数据文件。

另见

创建谱库

添加新项目


用户调谐 — 定义

User Tune（用户调谐）用于选择不同的调谐质量、调谐至更高的灵敏度（通过牺牲分辨率）或获得不同的相对丰度。

5972 上的用户调谐与 Max Sensitivity Autotune（最高灵敏度自动调谐）类似，不过它使用的是您以前所设置的调谐质量、扫描设置和发射电流。


用户定义的项Ä¿

用户定义的项

您可能需要输入特定的化合物信息。

A1 至 A3 均为最长由 19 个字符组成的文字项。

N5 至 N9 均为数字项。


使用色谱图

如何使用

校准 GC 和 MS 色谱图

以合并格式显示色谱图

显示总离子流色谱图 (TIC)

显示实时（快照）TIC

执行背景扣除 (BSB)

提取离子色谱图 (EIC)

积分色谱图

手动积分色谱图

使用峰纯度工具

参考

色谱图菜单


使用质谱

如何使用

显示质谱

添加质谱

扣除质谱

显示平均质谱

对质谱执行谱库检索

使用 DOSCAN

参考

Spectrum（光谱菜单）


使用化学工作站积分器

化学工作站积分器可以满足各种类型色谱图的积分，包括那些带有难于处理的基线和负峰的色谱图。通过设置积分参数（通常称作积分事件）可以控制积分过程。

化学工作站积分器使您可以使用初始积分事件进行 AutoIntegrate（自动积分）。如果结果不合适，则可以设置积分参数，然后从 Chromatogram（色谱图）菜单中选择 Integrate（积分）。

要设置积分参数，请选择 Chromatogram / MS (or GC) Signal Integration Parameters（色谱图/MS（或 GS）信号积分参数）。将出现 Edit Integration Events（编辑积分事件）面板。

另见

使用 RTE 积分器


使用键盘（调谐）

使用键盘

  • 要从一个字段跳至另外一个字段，请按“Alt+ 下划线字符”，即可跳至您希望的最近一个字段。按 Tab 键可以转到下一个字段，按 Shift+Tab 键可以转到上一个字段。

  • 要在 Edit Parameter（编辑参数）对话框之间进行循环，请按 Alt+Shift+F6。

  • 要得到滚动条，请按 Alt+z。

  • 要从 Acquisition Parameters（采集参数）对话框返回，请按 Alt+F6。


使用 RTE 积分器

RTE 积分器对相对简单的色谱图（其中的峰很窄且已完全解析）提供了一种非常快速的积分。尤其适用于 target compound analyses(目标化合物分析)。缺省参数假设待积分的数据是在整个色谱图范围内使用毛细管色谱柱色谱仪扫描到的数据的总离子流 (TIC)。如果选择适当的积分参数，则 RTE 积分器即可处理采集 (SIM) 和积分目标，如在较小的保留时间窗口中检测内标化合物。

RTE 积分器的积分过程由 integration parameter（积分参数）控制。要设定和检查 RTE 积分器的参数，请执行下列操作：

  1. 确保选中 RTE 积分器 (Calibrate / Set Up Quantitation（校准/设置定量）)

  2. 选择 Chromatogram / Integration Parameters（色谱图/积分参数）。

可以使用定量、谱库检索或百分比报告使用的方法创建和保存 Integration parameter file（积分参数文件）。

另见

使用化学工作站积分器


真空

Diagnotics（诊断)中的 Vacuum（真空）菜单允许：

  • 检查 MSD 的真空状态。

  • 开始放空

  • 开始抽气

  • 吹扫校准阀

放空和抽气是在选择菜单项目时开始的自动过程。一系列提示会指引您选定的过程。将被提示打开 GC 柱箱和 GC/MSD 接口加热器。显示状态对话框一直到过程结束。可以通过选择 Exit（退出）来取消对话框显示；进程继续直至完成。

  • 要取消放空，选择 Pump Down（抽气）。

  • 要取消抽气，选择 Vent（放空）。

  • 要吹扫 PFTBA 校准阀，选择 Purge Cal Valve（吹扫校准阀）。

注意

如果已装满校准瓶或更换了校准阀，必须在调谐或采集数据前（在 MS On 前）吹扫校准阀。详细信息在 MSD 硬件手册中给出。


真空（参数）

Vacuum（参数）以 mTorr 为单位显示前级压力。

仅适用于 5972 / 6890 MSD。


阀

注意：在指定阀设定值前必须指定如何使用它。请参见配置。

要改变阀的状态为开启，在它的复选框“On”上加上 X。（要下载变更到 GC，单击 Apply（应用）或 OK（确定）按钮。（有关更多信息，请参见按钮”。）

化学工作站将 on/off（开/关）设定值同方法一起保存。加载该方法后，化学工作站会打开任何在“On”复选框中有 X 的阀。

Type（类型）是阀配置的只读显示。

该对话框中其他项目：

Configure（配置）


阀 1-8

选择表示阀功能的 Type（类型）。化学工作站提示您需要与指定功能相关的配置信息。

有关更多详细信息，请单击任何一种 Type（类型）：

Gas Sampling（气体进样）

Switching（开关）

Multiposition（多位）

Other（其他）

Not Installed（未安装）

有关阀的更多信息，请参见 Valves（阀）。

OK/Undo/Help Buttons（确认/撤消/帮助 按钮）


阀配置

检查关于 6890 系列 GC 上安装的阀的配置信息。尽您所知回答，然后单击“OK”。

对于每个已安装阀您要配置：

  1. 单击 Configure（配置）按钮。化学工作站会显示一个详细对话框让您完成。

  2. 输入对于该类型的已安装阀需要的信息并单击 OK(确定）。


变量/宏列表

要显示这些列表类型，在所有化学工作站窗口的命令行都没有自变量时键入REMOVE 命令。这些列表用于：

  • 显示一个变量的当前值（对宏进行故障排除时有用）

  • 列出宏的大小（以比特为单位）

  • 删除一个变量或宏

在变量或宏列表中查找一项

  1. 通过单击列表中的任何项目来激活需要的列表。

  2. 使用滚动条或箭头键浏览列表。

查找指定项目

  1. 键入该项目的首字母相应的键。

  2. 继续键入来浏览以该字母开头的项目。

删除一个变量或宏

  1. 选择项目并单击 OK（确认）。

  2. REMOVE 命令显示在命令行上；键入回车键则项目被删除。

以下划线开头的变量是保留变量而不能删除或赋值；它们只能被使用。


压力、色谱柱流量和温度改变

保持前级泵和扩散泵在服役状态。确认载气供给稳定且已调节好。避免环境温度较大变化。保持 MSD 远离气流和直射阳光。


查看菜单（参数检索）

查看菜单

有四个参数检索结果的显示选项。当前有效的选项前有一个选中标记。

Standard Menu （标准菜单） | 返回标准 Data Analysis（数据分析）菜单。
Library Entry Only （仅适于谱库项目） | 此项一直有效。
TIC and Library Entry （TIC 和谱库项目） | 此项为灰直到检索完成且 TIC 已被加载。
Unknown and Library Entry （未知和谱库项目） | 此项为灰直到检索完成且光谱已被从 TIC 中选出。
Unknown, Library Entry, and Difference （未知、谱库项目和差值） | 此项为灰，直到检索完成，谱图已被从 TIC 中选出且已使用 Spectrum / Normalized Subtract（谱图/归一化扣除）进行了扣除。


检查序列质量日志

查看序列质量日志

Sequence / View Sequence Quality Log（序列 / 检查序列质量日志）允许检查上个完成的序列中的每个样品的内标响应和替代物回收率。

序列运行时，可以通过打开仪器目录中的 QA.LOG 在记事本中检查这个信息，例如，MSDCHEM\1。（确定在查看后不要 Save（保存）这个文件，否则会丢失关于当前样品的信息。）


粘度

注射器活塞在最后的抽样冲程和进样冲程之间应该有几秒的停息的时间。对于粘性样品，暂停时间允许让样品流进注射器中造成的真空状态。

在 G1513A GC 进样器中，粘度设定也用于溶剂洗涤步骤。这允许冲洗溶剂有更多时间来溶解针头中的任何残余样品。

有效输入值：0 至 7。

该对话框中其他项目：

Sampling Depth（采样深度，不是对所有进样器有效）

PreInjection Dwell（注射前针停留，不是对所有进样器有效）

PostInjection Dwell（注射后针停留，不是对所有进样器有效）

Plunger Speed（注射速度）

OK/Cancel/Help 按钮


VOA 化合物

VOA 化合物是可以用于使用吹扫和捕集技术来分析的挥发性有机化合物。也称为挥发性或可吹扫化合物。


洗涤

指定溶剂洗涤、样品洗涤和从一次进样要控制样品携留的抽气冲程的次数。有关更多信息，请单击下面的任何参数：

Sample（样品）

Solvent A（溶剂 A）

Solvent B（溶剂 B）

Pumps（泵）

PreInjection（预注射） - 样品洗涤和 抽吸可以指定在进样前进行。

PostInjection（注射后） - 样品洗涤可以指定在进样后进行。

该对话框中其他项目：

Injection Volume（进样体积）

More Button (6890 GC)（更多按钮 (6890 GC)）

Extended Parameters Button（扩展参数按钮）

Configuration Button（配置按钮）

OK/Cancel/Help 按钮


洗涤

指定溶剂洗涤、样品洗涤和需要的抽吸冲程的次数。有关更多信息，请单击下面的任何参数：

Sample（样品）

Solvent A（溶剂 A）

Solvent B（溶剂 B）

Pumps（泵）

PreInjection（预注射） - 样品洗涤和 抽气可以指定在进样前进行。在多次进样设定中不能在余下的进样前进行洗涤。

PostInjection（注射后） - 样品洗涤可以指定在进样后进行。在多次进样设定中不能在余下的进样后进行洗涤。


Wid219

Wid219 影响 219 amu 的质谱峰宽。输入的这个参数的值近似于应用于质量 219 的校正值。例如，如果进行了峰宽调节且值为：

质量 | 69 | 219 | 502
峰宽 | 0.60 | 0.63 | 0.60

然后输入 Wid219 参数的值为 -0.03，接着进行峰宽调节，应该使结果为所有质量的峰宽设定为非常接近 0.60 amu。

MSD | 最小值 | 最大值 | 步长
5973 | -0.15 | +0.15 | 0.001
5972 / 6890 | -0.15 | +0.15 | 0.001


工作组窗口 - 例

例

  1. 计算机 VOA_1 有一台仪器连接来采集数据。

  2. 计算机 Reports 是一个单一数据分析系统用来产生和打印报告。

  3. 计算机 VOA_1 有一个硬盘 C 卷标为 VOA_1_C 。

  4. 从 VOA_1 上的资源管理器（或文件管理器）将驱动器 C 共享为 VOA_1_C （与卷标同名）。

  5. 将计算机 Reports 连接到网络驱动器 VOA_1_C。（与指派的驱动器字母无关。）

  6. 在两个系统上启动Report Manager（报告管理器）。

  7. 计算机 VOA_1 发送一个请求到 Reports 生成一个报告。

  • 在计算机“VOA_1”上，数据文件为 c:\MSDchem\1\data\mydata.d。方法文件为 c:\MSDchem\1\methods\mymeth.m。驱动器 C 的卷标为 VOA_1_C 。

  • 计算机 Reports 使 VOA_1_C 连接为驱动器 D。

  • 计算机 Reports 接收请求来使用 mymethod.m 来运行 mydata.d ，它在其可用驱动器中寻找卷标为 VOA_1_C 的驱动器。

  • 计算器 Reports 找到卷标为 VOA_1_C 的驱动器 D。

  • 然后改变路径为 d:\MSDchem\1\data\mydata.d 和 d:\MSDchem\1\methods\mymeth.m。

然后，当报告在 Reports 上产生后，驱动器字母会与 VOA_1 不同但两者都涉及相同的文件。


错误调谐文件

确认在当前方法中指定的调谐文件适于正在分析的样品。


错误调谐程序

调谐程序除了自动调谐外都有不同的相对丰度目标。DFTPP 和 BFB 目标调谐程序调节 5973 MSD 来使m/z 502/69 的比例约为 0.8%。检查所用的调谐程序。如果观察到的相对丰度不适于所用的调谐程序，请参见其他可能的原因。


扩展色谱窗口

这一菜单项目扩展色谱窗口二分钟（窗口的两端各一分钟）。这对于感兴趣的谱峰处于窗口边缘的情况很有用。如果已使用鼠标进行缩小然后使用 XPand（扩展） 功能，新的扩展后窗口将依据原来的数据。不是依据缩小后的窗口。

要返回原始窗口，请选择 Original Chromatographic Window（原始色谱窗口） 。


X-射线/HED（参数）

X-射线 (HED) 设定 X-射线透镜（检测器的一部分）电压。X-射线透镜将离子聚焦到位于轴外的检测器中，而排斥来自离子源的光子和电子。最佳 X-射线电压取决于电子倍增器的设定。因此，通常首先设定电子倍增器。然后对X-射线电压进行梯度变化，确定提供最大丰度的设定。

MSD | 最小值 | 最大值 | 步长
5972 / 6890 | 0 | 218 | 0.9

不用于 5973 MSD。


低质量自动调谐

“低质量自动调谐”与自动调谐相同，只不过它是在质量 69、131 和 219, 而不是 69、219 和 502 处进行调谐。它专用于低分子量物质与 250 道尔顿以下的天然气。


宏

宏是一起存储在文件中的指令（命令）列表。您执行宏只需击键几次。宏在自动执行您在 MS 化学工作站中常用的任务方面非常有用。如果不使用宏，则需要进行多次鼠标操作、菜单选择、在面板上输入或命令行输入。宏也可用于自定义 MS 化学工作站的操作，例如以特殊格式打印报告。


方法分辨率

方法分辨率对话框列出了您所加载的方法与 6890 GC 的初始配置差异，方法分辨率的赋值及其原因。

注意：您可以通过单击被移动的图标将其拖回对话框左侧，覆盖刚赋的值。

要完成方法分辨率的处理：

  1. 检查自动赋值（在右端）。

  2. 如有必要，编辑赋值。您可以：

  • 覆盖自动赋值。单击已接受自动赋值的 GC 图标，将其拖至左侧。（这样可以开始新的自动赋值。）

  • 手动赋值。单击左侧的图标，将其拖至右侧，放到应接受赋值的 GC 图标上。如果化学工作站认为所赋值不合理（例如，将多位阀的设定值赋给切换阀），您移动的图标将自动回到左侧。

  • 重新开始。清除所有赋值，重新开始，请使用 Start Over（重新开始）按钮：

  3. 如果所赋值正确，请单击 OK（确定），进入 Instrument Control（仪器控制）面板。

  4. 如有必要，运行方法时应调节设定值优化 GC 性能。（有关编辑特定仪器控制对话框参数的更多信息，请参见 Edit Parameters（编辑参数）。

  5. 保存指定了分辨率的方法。


方法分离度的设定值赋值原因

方法分离度对话框中列出：

  • 您所加载的方法与 6890 GC 的初始配置差异，和

  • 为方法的分离度所赋的值及其理由。

检查每次赋值的原因，注明所有需要重新赋值的项。

单击 OK（确定），返回起始的 Method Resolution（方法分离度）对话框。（如有必要，可在该对话框中清除赋值并重新开始赋值过程。）


Spectral Manipulations（谱图处理）对话框

谱图处理选项设计为清除具有以下一个或多个故障的质谱：

  • 离子过多或谱图有噪音

  • 1 amu 范围内有多个离子

  • 质量缺陷超过 1 amu。

  • 需要 CNORM

具有以上特征的谱图可用以下选项进行处理。

选择 N 个最大的质荷比...

修正后的谱图中只出现指定的 "N"　个最大的离子。

将噪音消除到低于 X%

修正后的光谱中只出现那些丰度高于指定阈值的离子。

加和相同质量的离子

质谱中的离子按其标识质量指认，即 69.00 而不是 69.10。修正后的光谱中每一个质量处只有一个离子，该离子的丰度是该质量处原来所有离子丰度的加和。

选择每一质量的最大离子

质谱中的离子按其标识质量指认，即 69.00 而不是 69.10。修正后的光谱中每一个质量处只有一个离子，该离子的丰度是该质量处原来所有离子丰度中最大的。

指定标识质量值

质谱中的离子按其标识质量指认，即例如 69.00 而不是 69.10。

选择 N 个最显著的质荷比

修正后的谱图中只出现 "N"　个最显著的离子。显著性是由谱库检索程序的算法决定的。相对于低质量离子，该算法更有利于高质量离子。

如果出现 CNORM 因子信息（数据文件箱中的 cnorm.ini 和 pre_post.ini 中的 TuneName），将会显示允许对原光谱进行 CNORM 校正的按钮。

做出选择后，寄存器堆栈包含：

X - 原质谱

Y - 修正后的质谱

Z - 原质谱与修正后质谱的差值

T - 包含 X、Y 和 Z 的集合。

窗口 1 中的图是用 T 的数据重新绘制的。


American Standard Code for Information Interchange （美国信息互换标准代码）

American Standard Code for Information Interchange (ASCII)（美国信息互换标准代码）是国际知名的用于提供文本信息的 8 位代码。大部分标准文本编辑器都能生成这种文件。


CAS 号

CAS 号是用于识别化学品的编号。CAS 号后带有星号 (*) 表明该化合物的组成可变（常为天然存在的物质），否则顺序指定的 CAS 号都标识着特定的化学物质。这些编号没有化学意义。CAS 号是识别化学品的一种简明、独特的方法。


Chemical Abstract Service（化学文摘）

Chemical Abstract Service（化学文摘）是为 American Chemical Society （美国化学学会）出版的Chemical Abstracts （化学文摘）中的信息提供索引服务的组织，为文摘中的特定物质信息提供索引向导。

Chemical Abstract Service

Division of American Chemical Society

Box 3012

Columbus, OH 43210

(614) 447-3600


Display Options for Structure Drawings（结构图的显示选项）

这些选项让您改变一个结构中不同部分的颜色与线条粗细，还可旋转该结构。

Dashed Circles（虚线圈）复选框可使芳香键以虚线圈或实线圈显示。（注意包含芳香环的 Mol 文件将芳香键显示为定位双键。）


Dynamic Link Library（动态连接程序库）

Dynamic Link Library（动态连接程序库）是一个包含非静态连接至应用程序的目标代码的文件。DLL 用于压缩常被访问的代码与扩展应用程序的运行性能。Microsoft Windows 本身就是 DLL 的集成。


HIA Compliant 应用程序

HIA-Compliant -- 一个遵守HIA界面规范的应用程序，它可适应 HIA ，并能通过使用 HIADLL模块得到扩展。


Hyphenated Instrument Architecture（联用仪器结构）

 Hyphenated Instrument Architecture（联用仪器结构）是一个软件结构，它可使支持不同联用分析技术（如 GC/MS、GC/IR、GC/IR/MS、LC/MS、LC/ES/MS 等）的应用程序更容易创建。


初始化文件

许多结构图参数都存储在名为struct.ini的初始化文件中。该文件的创建与维护都在 struct.dll 所处的目录下进行。下面列出了一个示例文件的内容。

[全局量]

TextBkMode=2 ; 正文串的背景模式

AromaticCircleMode=2 ; 芳香环内的绘制模式

DefStructureCAS=-2363 ; 无参数调用 CSDrawOpts 时，使用 CAS 号

TextSize=12 ; 原子正文串的大小

DrawBorder=1 ; 结构周围是否要绘制边界

UseThickBonds=0 ; 键的绘制是否采用粗线

HelpFile= ; 帮助文件名（如果不同于 MSEXE 目录下的 struct.hlp 文件）

HelpContextBase= ; 其他帮助文件中结构帮助主题的起始位置

；要检索的数据库的顺序列表

[数据库]

  1. C:\MSDCHEM\MSEXE\SUBSET.SDB

  2. C:\DATABASE\MOLSTRUC.SDB

; 正文串字体的详细资料

[字体信息]

FaceName=Arial

Height=12

Width=0

Weight=400

TypeFlags=0

Family=144

;结构中不同部分的颜色

[颜色]

CustomColor1= 192 192 192 ; 单键

CustomColor2= 0 255 0 ; 双键

CustomColor2= 0 255 0 ; 三键

CustomColor4= 255 0 255 ; 芳香环

CustomColor5= 0 0 0 ; 文字背景

CustomColor6= 0 255 255 ; 正文串

CustomColor7= 255 255 255 ; 边界

CustomColor8= 255 0 255

CustomColor8= 0 128

CustomColor8= 0 128

CustomColor11= 0 128 128

CustomColor12= 128 0 0

CustomColor8= 0 128

CustomColor8= 128,128

CustomColor11= 128,128,128

CustomColor16= 0 0 0

大部分参数的意义应直观明了，只在以下情况例外：

DefStructureCAS:此处列出的数值是一个结构的 CAS 号。如果调用它时没有指明特定结构（即全程选项设定），该结构的 CAS 号将显示在 Drawing Options（绘图选项）对话框中。如果该数值为正，那么它表示一个 CAS 号，如果为负则是指绝对记录号。此处的目的是提供一个可供显示的比较完整的化合物，包含所有或大部分的可变项（如单键、双键、三键、芳香环、正文串等）。

TextSize（文字大小）:列出的数值如果为正，则是正文字符元（比实际的字符略高）的相对高度，当结构尺寸改变时，字符也相应选定坐标。作为参比，标准键长（对于 NIST 数据库）是 10 单位，所以 12 通常就已经足够了。如果该数值为负，则它是一个字符点的绝对大小，即使结构大小发生改变时也不会改变。

HelpFile（帮助文件）:此处列出的文件名表明该HIA 成分的帮助信息不在单独的文件中（如 struct.hlp), 而是嵌在一个更大的应用程序的帮助文件中，该帮助文件名已列出。如果在这种情况下，关键词 HelpContextBase 表示在应用程序的帮助文件中已赋值给结构的上下文编号的起始位置。

[颜色]：本节中列出了 16 项，前面 7 项的意义已经如上预先设定。然而，在 Custom Colors（自定义颜色）部分的 Choose Color（选择颜色）对话框中显示了所有 16 项（可修改）：此处所列的数值代表 Red（红）、Green（绿）和 Blue（蓝） (RGB) 对给定颜色的贡献，范围从 0 至 255。White（白）是所有颜色都做出最大贡献 (255 255 255) ；black（黑）则是所有颜色都不做任何贡献 (0 0 0)。


ISIS（定义）

ISIS 是 Molecular Design Limited　公司的商标。


Mol 文件（定义）

Mol 文件是描述化学结构连接表的一个 ASCII 文本文件。该文件的设计发表在 Journal of Chemical Information and Computer Sciences（化学信息和计算机科学杂志） 1992 年的五/六月 32 卷的Description of Several Chemical Structure File Formats Used by Computer Programs Developed at Molecular Design Limited（Molecular Design Limited 开发的计算机程序使用的几个化学结构文件格式说明） (pp 244-54) 文章中。

ISIS Draw　能为程序中创建的结构生成该类型的文件。


Molecular Design Limited （定义）

Molecular Design Limited 是一家生产集成科学信息系统的公司，产品包括绘制化学结构的软件（如 ISIS Draw)。

Molecular Design Limited

2132 Farallon Drive

San Leandro, Ca 94577

(510) 895-1313


国家标准技术协会

国家标准技术研究所的前身是国家标准局 (NBS)。这一美国政府机构出版了一套质谱信息数据库，目前包含其中所列各种化合物连接表的信息。


结构绘制的文本选项

结构的元素符号可选择任何可用的字体与大小。

Abs 按钮可显示元素符号的大小，而与结构其他部分的大小无关。Rel 按钮使元素符号相对于结构按比例进行大小的变化。

Opaque 按钮使下面的文字或图形变模糊。Transparent 按钮能够让您看到下面的部分。


命令/函数列表

这些列表包括当前应用程序中所有可用的命令和宏。要显示这些列表，可以在任何 ChemStation（化学工作站）窗口的命令行中键入不带参数的 COMMAND 命令。如果您要查看某特定命令的帮助，请转到 System Commands（系统命令）。

在命令或函数列表中查找某个项

  1. 激活期望的列表（如在该列表的任何项上单击）。

  2. 使用滚动条或箭头键浏览列表。

查找特定项

  1. 按下对应于该项的第一个字母的键。

  2. 继续按该键，浏览以此字母开头的项。

如果您单击 OK（确定），当前突出显示的项将显示在命令行中。


CSEDITLIB

CSEDITLIB ["结构数据库文件名称"]

该命令提供一个对话框，使您可以检查和修改现有的结构数据库。

"结构数据库文件名"

要检查的数据库文件的名称。


CSIPACK

CSIPACK "输入文件名", "输出文件名"

该命令根据一个 ASCII 文本文件（其 CAS 编号和文件偏移量按升序排列）创建一个索引文件。

"输入文件名"

包含 CAS 编号和数据库文件偏移量的已排序 ASCII 文本列表的文件的名称。

"输出文件名"

输出数据库索引的二进制文件的名称。

该命令是不受支持的测试实用程序，在系统正常运行时最好不要使用。


CSMFCREATE

对象 = CSMFCREATE ()

该函数由当前位于剪贴板上的数据创建一个图元文件对象。


CSPACK 命令

CSPACK "输入结构文本文件名", "输出二进制文件名" [, 下限:上限]

该命令从一个 ASCII 文本文件创建一个 NIST 格式的结构数据库。

"输入结构文本文件名"

包含结构数据库的 ASCII 表示方法的文件名。

"输出二进制文件名"

要生成的数据库文件的名称。

下限:上限

要转换结构的索引范围。

该命令是不受支持的测试实用程序，在系统正常运行时最好不要使用。


CSVIEW

CSVIEW 结构对象

该命令显示一个对话框，其中显示与给定结构对象相关的连接表数据。

结构对象

使用 CSCREATE 函数创建的任何对象。

该命令是不受支持的测试实用程序，在系统正常运行时最好不要使用。


DELLEVEL

DELLEVEL ["级别 ID"]

用于宏中，从定量数据库中的所有化合物项中删除一个校准级别。

"级别 ID"

一个字符串，对应于要删除的级别 ID。如果未指定，当前校准级别（在 Update Calibration（更新校准）对话框中指定）就被删除。该参数区分大小写。


EDZONE

仅限 5973 MSD。显示对话框，以查看和设置源和四极杆温度。此框显示实际值、设定值和限制值；您可以为设定值和限制值输入新值。除非您保存了调谐文件，否则不能用该方法永久存储新值。


LSC

LSC （谱库检索化合物）为样品中给出的非目标化合物。这样的化合物也称为 LSR （谱库检索结果）或 TIC（暂定标识的化合物）。


LSTSQFIT

LSTSQFIT <数据矩阵>, [m], [n]

此命令处理矩阵点以查找指定次数的多项式的最小二乘解。

y = c0 + c1*x + c2*x^2 + ...+ cn*x^n

数据矩阵

定义数据点的 q (x,y) 对的 (q x 2) 矩阵。

m

要使用的数据矩阵的数据点的个数。m <= q。缺省 = q （数据矩阵的维数）。1000 >=m >= 2

n

要由最小二乘法确定的系数的个数。n<=m 且 n<6。对于一个多项式，n 为多项式的次数 + 1 。例如，n = 2 用于估算一条直线。缺省值 = 2。

输出

在 LstCoef 中定义系数数组。LstCoef 具有 n 维。按以下顺序对系数进行排序：第一个系数为 c0，最后一个为 cn。

讨论

如果无法通过给定的数据集获得最小二乘解，将“不”会产生错误，但 LstCoef 成员将被设置为 0。

示例

一条最小二乘直线需要一组点 (69, 11.9)、(219, 26.9)、(502,55.2)。

DIM myData, 3,2

myData[1,1] = 69 | ! 第一个数据点的 x
myData[1.2] = 11.9 | ! 第一个数据点的 y
myData[2.1] = 219 | ! 第二个数据点的 x
myData[2.2] = 26.9 | ! 第二个数据点的 y
myData[3.1] = 502 | ! 第三个数据点的 x
myData[3.2] = 55.2 | ! 第三个数据点的 y

! 直线为 1 次多项式，因此 n = 2。

LSTSQFIT myData, 3, 2

! LSTCOEF[1] 为此线的偏移量 c0。

! LSTCOEF[2] 为此线的斜率 c1。

注释

当前的统计数字不可用。将来需求增加时，可以添加预定义矩阵（如 LSTVARIANCE），以给出估算参数的方差和协方差。


MDLSKDUMP

MDLSKDUMP "输出文件名"

该命令将剪贴板中的二进制 MDLSK 数据复制到一个文件中。

输出文件名

接受来自剪贴板的 MDLSK 数据的文件名。

该命令是不受支持的测试实用程序，在系统正常运行时最好不要使用。


MFDUMP

MFDUMP "输出文件名"

该函数会将任何剪贴板上的图元文件数据复制到一个文件中。

输出文件名

要将剪贴板图元文件数据复制到其中的文件名称。

该命令是不受支持的测试实用程序，在系统正常运行时最好不要使用。


MSMETHODLOAD

如果 MS 正在运行，则从 CP 变量 _MethPath$ 和 _MethFile$ 加载当前 MS 方法。


TTI

TTI是指采集数据的实际总离子模式，其中 MSD 充当了产生一个单独信号的火焰离子化检测器。TTI 模式能够提供比在 Scan（扫描）模式下获得的灵敏度更高的灵敏度。

不能在 5973 MSD 上使用。


WRITEMODULE

WRITEMODULE "68GC", "命令字符串"

往 6890 GC 写入一个命令。

命令字符串

对 6890 GC 的一个命令字符串。

示例

WRITEMODULE "68GC", "OVTI 75"

此命令将（色谱柱）柱箱的温度设置为 75。