welcome

Agilent L4532A/34A Command Reference

This help file contains reference information for the Agilent L4532A and L4534A digitizers. The products are essentially the same; the difference is that the L4532A is a 2-channel version, and the L4534A is a 4-channel version. The documentation for this product uses the term L4532A/34A when referring to both products.

Introduction to the Command Language

Commands by Subsystem

Commands A-Z

Command Quick Reference

Error Messages

Power-On and Reset State

Related Information

For further information, click on the link of interest:

Libraries and Instrument Drivers

The Agilent IO Libraries Suite software is provided on the Agilent Automation Ready CD-ROM provided with your instrument. Installation instructions are provided on the CD-ROM.

You can also download the Agilent IO Libraries Suite software, along with IVI-COM and LabVIEW drivers from www.agilent.com/find/iosuite.

Agilent L4532A/34A Documentation

The Agilent L4532A/34A Command Reference is provided on the Agilent L4532A/34A Product Reference CD-ROM shipped with your instrument.

In addition, the following documents are available in Adobe® PDF format on this CD-ROM. (Requires Adobe Reader.)

  • Agilent L4532A/34A User’s Guide
  • Agilent L4532A/34A Service Guide

You can also download these documents from the Web at www.agilent.com/find/L4532A or www.agilent.com/find/L4534A.

For information about connecting instruments to USB and LAN interfaces and how to configure and troubleshoot these interfaces, refer to the Agilent USB/LAN/GPIB Interfaces Connectivity Guide. This guide is provided on the Agilent Automation Ready CD-ROM. Or you can download the guide from the Web at www.agilent.com/find/connectivity.

Agilent L4532A/34A Web Interface

The Agilent L4532A/34A provides a web interface that is built into the instrument. You can use this interface over LAN for remote access and control of the instrument via a Java™-enabled Web browser, such as Microsoft® Internet Explorer.

To access and use the instrument's web interface:

  1. Establish a LAN interface connection from your PC to the L4532A/34A.
  2. Open your PC's Web browser.
  3. Launch the instrument's web interface by entering the IP address of the instrument, or its fully-qualified host name, in the browser address field.
  4. Follow the instructions in the web interface's on-line help.
Programming Examples

We have included several example programs on the L4532A/34A Product Reference CD-ROM shipped with your instrument. The examples support the following language environments.

  • Microsoft® C#
  • Microsoft® C++

To install the programming examples, see the Product Reference CD-ROM. Or, you can download the examples from the Web at www.agilent.com/find/L4532A or www.agilent.com/find/L4534A.

Contact Agilent Technologies

You can contact Agilent Technologies at one of the following telephone numbers for warranty, service, or technical support information.

In the United States: (800) 829-4444

In Europe: +31 0 20 547 2111

In Japan: 0120-412-766

Or use our Web link for information on contacting Agilent worldwide.

www.agilent.com/find/assist

Or contact your Agilent Technologies Representative.

Trademarks

Microsoft®, Visual Basic®, and Windows® are U.S. registered trademarks of Microsoft Corporation.

Adobe® and Acrobat® are trademarks of Adobe Systems Incorporated.

Java™ is a U.S. trademark of Sun Microsystems, Inc.

MATLAB® is a registered trademark of the MathWorks, Inc.

© 2009 Agilent Technologies, Inc.

Version 1.0


welcome

Agilent L4532A/34A Command Reference

This help file contains reference information to help you program the Agilent L4532A/34A over a remote interface using the programming language.

Introduction to the Command Language

Commands by Subsystem

Commands A-Z

Command Quick Reference

Error Messages

Power-On and Reset State

Related Information

For further information, click on the link of interest:

Libraries and Instrument Drivers

The Agilent IO Libraries Suite software is provided on the Agilent Automation Ready CD-ROM provided with your instrument. Installation instructions are provided on the CD-ROM.

You can also download the Agilent IO Libraries Suite software, along with IVI-COM and LabVIEW drivers from www.agilent.com/find/iosuite.

 Agilent L4532A/34A Documentation

The Agilent L4532A/34A Command Reference is provided on the Agilent L4532A/34A Product Reference CD-ROM shipped with your instrument.

In addition, the following documents are available in Adobe® PDF format on this CD-ROM. (Requires Adobe Reader.)

  • Agilent L4532A/34A User’s Guide
  • Agilent L4532A/34A Service Guide

You can also download these documents from the Web at www.agilent.com/find/L4532A or www.agilent.com/find/L4534A.

For information about connecting instruments to USB and LAN interfaces and how to configure and troubleshoot these interfaces, refer to the Agilent USB/LAN/GPIB Interfaces Connectivity Guide. This guide is provided on the Agilent Automation Ready CD-ROM. Or you can download the guide from the Web at www.agilent.com/find/connectivity.

 Agilent L4532A/34A Web Interface

The Agilent L4532A/34A provides a web interface that is built into the instrument. You can use this interface over LAN for remote access and control of the instrument via a Java™-enabled Web browser, such as Microsoft® Internet Explorer.

To access and use the instrument's web interface:

  1. Establish a LAN interface connection from your PC to the L4532A/34A.
  2. Open your PC's Web browser.
  3. Launch the instrument's web interface by entering the IP address of the instrument, or its fully-qualified host name, in the browser address field.
  4. Follow the instructions in the web interface's on-line help.
 Programming Examples

We have included several example programs on the L4532A/34A Product Reference CD-ROM shipped with your instrument. The examples support the following language environments.

  • Microsoft® C#
  • Microsoft® C++

To install the programming examples, see the Product Reference CD-ROM. Or, you can download the examples from the Web at www.agilent.com/find/L4532A or www.agilent.com/find/L4534A.

 Contact Agilent Technologies

You can contact Agilent Technologies at one of the following telephone numbers for warranty, service, or technical support information.

In the United States: (800) 829-4444

In Europe: +31 0 20 547 2111

In Japan: 0120-412-766

Or use our Web link for information on contacting Agilent worldwide.

www.agilent.com/find/assist

Or contact your Agilent Technologies Representative.

 Trademarks

Microsoft®, Visual Basic®, and Windows® are U.S. registered trademarks of Microsoft Corporation.

Adobe® and Acrobat® are trademarks of Adobe Systems Incorporated.

Java™ is a U.S. trademark of Sun Microsystems, Inc.

MATLAB ® is a registered trademark of the MathWorks, Inc.

© 2009 Agilent Technologies, Inc.

Version 1.0


Introduction to the Command Language

This document describes the command language for the Agilent L4532A and L4534A digitizers. The products are essentially the same; the difference is that the L4532A is a 2-channel version, and the L4534A is a 4-channel version. The documentation for this product uses the term L4532A/34A when referring to both products. The command language for the L4532A/34A is an ASCII-based instrument command language designed for digitizers. These commands are based on a hierarchical tree system in which associated commands are grouped together under a common node or root to form subsystems. A portion of the MEASure subsystem is shown below to illustrate the tree system.

MEASure:
FALL:
PERiod:
FREQuency:
RISE:
PERiod:
FREQuency:

MEASure is the root keyword of the command, FALL and RISE are second-level keywords, and PERiod and FREQuency are third-level keywords. A colon (:) separates a command keyword from a lower-level keyword.

The command set for the Agilent L4532A/34A reflects the general programming model:

Step1 - Configure the instrument:

CONFigure:CHANnel

CONFigure:ACQuisition

CONFigure:ARM

CONFigure:TRIGger

Step 2 - Run the test:

INITiate

ARM:IMMediate

TRIGger:IMMediate

ABORt

Step 3 - Fetch the data

FETCh:WAVeform

Syntax Conventions

The format used to show commands is illustrated below:

MEASure:INSTall:DELete {<label>|ALL}

The command syntax shows most commands (and some parameters) as a mixture of upper- and lower-case letters. The upper-case letters indicate the abbreviated spelling for the command. For shorter program lines, you can send the abbreviated form. For better program readability, you can send the long form.

For example, in the above syntax statement, MEAS and MEASure are both acceptable forms. You can use upper- or lower-case letters. Therefore, MEASure, meas, and Meas are all acceptable. Other forms, such as MEA and MEASUR, are not valid and will generate an error.

  • Braces ( { } ) enclose the parameter choices for a given command string. The braces are not sent with the command string.
  • A vertical bar ( | ) separates multiple parameter choices for a given command string. For example, {<label>|ALL} in the above command indicates that you can specify a <label>, or "ALL". The bar is not sent with the command string.
  • Angle brackets ( <> ) indicate that you must specify a value for the enclosed parameter. For example, the above syntax statement shows the <label> parameter enclosed in angle brackets. The brackets are not sent with the command string. You must specify a value for the parameter (for example, MEASure:INSTall:DELete "MEZ_25") unless you select one of the other options shown in the syntax (for example, MEASure:INSTall:DELete ALL).
  • Some parameters are enclosed in square brackets ( [ ] ). This indicates that the parameter is optional. The brackets are not sent with the command string. If you do not specify a value for an optional parameter, the instrument chooses a default value.

Command Separators

A colon ( : ) separates a command keyword from a lower-level keyword. You must insert a blank space to separate a parameter from a command keyword. If a command requires more than one parameter, you must separate adjacent parameters using a comma as shown below:

MEASure:THResholds:ABSolute (@1:4),90,50,10

A semicolon ( ; ) is used to separate commands within the same subsystem, and can also minimize typing. For example, sending the following command string:

TRIG:SOUR EXT; COUNT 10

... is the same as sending the following two commands:

TRIG:SOUR EXT
TRIG:COUNT 10

Use a colon and a semicolon to link commands from different subsystems. For example, in the following command string, an error is generated if you do not use both the colon and semicolon:

TRIG:COUN MIN;:SAMP:COUN MIN

Querying Parameter Settings

You can query the current value of most parameters by adding a question mark (?) to the command. For example, the following command turns protection on for channels 1 through 4.

CONFigure:CHANNel:PROTection (@1:4),1

You can then query the protection by sending:

CONFigure:CHANnel:PROTection? (@1:4)

This would return +1,+1,+1,+1.

Command Terminators

A command string sent to the instrument must terminate with a new line (<NL>) character (ASCII decimal value 10). The IEEE-488 EOI (End-Or-Identify) message is interpreted as a <NL> character and can be used to terminate a command string in place of a <NL> character. A <carriage return> followed by a <NL> is also accepted. Command string termination will always reset the current command path to the root level.

For every message that includes a query and is sent to the instrument , the instrument terminates the returned response with a <NL> or line-feed character (EOI). For example, if *IDN? is sent, the response is terminated with a <NL> after the block of data that is returned. If a message includes multiple queries separated by semicolons (for example "*ESR?;*IDN?"), the returned response is again terminated by a <NL> after the response to the last query. In either case, the program must read this <NL> in the response before another command is sent to the instrument, or an error will occur.

IEEE-488.2 Common Commands

The IEEE-488.2 standard defines a set of common commands that perform functions such as reset, self-test, and status operations. Common commands always begin with an asterisk ( * ), are three characters in length, and may include one or more parameters. The command keyword is separated from the first parameter by a blank space. Use a semicolon ( ; ) to separate multiple commands as shown below:

*RST; *CLS; *ESE 32; *OPC?

Parameter Types

The language defines several data formats to be used in program messages and response messages.

Numeric Parameters

Commands that require numeric parameters will accept all commonly used decimal representations of numbers including optional signs, decimal points, and scientific notation. You can also send engineering unit suffixes with numeric parameters (examples include M, k, m, and u). If a command accepts only certain specific values, the instrument will automatically round the input numeric parameters to the accepted values. The following command requires numeric parameters for the <vHigh>, <vMid> and <vLow> parameters.

MEASure:THResholds:ABSolute (@<chan_list>)[,<vHigh>,<vMid>,<vLow>]

Because the parser is case-insensitive, there is some confusion over the letter "M" (or "m"). For your convenience, the instrument interprets "mV" (or "MV") as millivolts, but "MHZ" (or "mhz") as megahertz. Likewise "MO" (or "mO") is interpreted as megohms. You can use the prefix "MA" for mega. For example, "MAV" is interpreted as megavolts.

Discrete Parameters

Discrete parameters are used to program settings that have a limited number of values (like IMMediate, EXTernal, or BUS). They have a short form and a long form just like command keywords. You can mix upper- and lower-case letters. Query responses will always return the short form in all upper-case letters. The following command requires a discrete parameter for the trigger source:

CONFigure:TRIGger:SOURce {IMMediate|SOFTware|EXTernal|CHANnel|OR}

Boolean Parameters

Boolean parameters represent a single binary condition that is either true or false. For a false condition, the instrument will accept OFF or 0. For a true condition, the instrument will accept ON or any number other than 0. Typically, programmers use 1 to indicate ON, but any non-zero value, such as 3.2 or -123.456 will be treated as 1 (ON). When you query a Boolean setting, the instrument will always return 0 or 1. As an example, the following command requires a Boolean parameter:

CALibration:SECure:STATe {OFF|0|ON|1}

ASCII String Parameters

String parameters can contain virtually any set of ASCII characters. A string must begin and end with matching quotes; either with a single quote or a double quote. You can include the quote delimiter as part of the string by typing it twice without any characters in between. The following command uses a string parameter:

DISPlay:TEXT <quoted string>

For example, the following command displays the message "WAITING..." on the instrument's front panel (the quotes are not displayed).

DISP:TEXT "WAITING..."

You can also display the same message using the following command with single quotes.

DISP:TEXT 'WAITING...'

Channels

A channel specifies exactly one digitizer channel. The list of possible channels depends on the model of the digitizer; the L4532A has two channels, and the L4534A has four. A channel always opens with "(@" and closes with ")". Between these symbols, there is one digit, from 1 to 4 (1 or 2 on a two-channel digitizer).

The possible channels are shown below.

Channel List | Meaning
(@1) | channel 1
(@2)

channel 2
(@3) | channel 3
(@4) | channel 4

Channel Lists

A channel list is a list of digitizer channels. The number of channels that a list can specify depends on the model of the digitizer; the L4532A has two channels, and the L4534A has four. Channel lists always open with "(@" and close with ")". Between these symbols, there can be one or more channels or channel ranges, separated by commas. A channel range is two channel numbers, separated by a colon.

Several channel list examples are shown below.

Channel List | Meaning
(@1) | channel 1
(@4)

channel 4
(@1,4) | channels 1 and 4
(@1,3,4) | channels 1, 3, and 4
(@2:4) | channels 2 through 4 - equivalent to (@2,3,4)
(@1,2:4) | channels 1 and 2 through 4 - equivalent to (@1:4) and (@1,2,3,4)

The digitizer ignores duplicated channels in a channel list. For example, the channel list (@1,1,2,3,2:4,1,2,1:3) is the same as the channel list (@1:4).

Queries that use a channel list always return data in ascending order by channel number; the order specified in the channel list is irrelevant. Thus, the channel list (@3:2,4,1) is equivalent to (@1:4). Nevertheless, it is a good practice to create channel lists in ascending order, because that is the order in which a multi-channel query will return data.

Record Ranges

A record range is a single record or a range of records. The format is similar to a channel list (above), but a record range cannot use commas.

Several record range examples are shown below.

Record Range | Meaning
(@1) | record 1
(@4)

record 4
(@2:4) | records 2 through 4
(@100:1000) | records 100 through 1000

Queries that use a record range always return data in ascending order by record number. If you enter a record range where the endpoints of the range are listed in descending order, such as (@35:10), the digitizer will produce an error message.

Using Device Clear

Device Clear is an IEEE-488 low-level bus message that you can use to return the instrument to a responsive state. Different programming languages and IEEE-488 interface cards provide access to this capability through their own unique commands. The status registers, the error queue, and all configuration states are left unchanged when a Device Clear message is received.

Device Clear performs the following actions:

  • If a measurement is in progress, it is aborted.
  • The instrument returns to the trigger "idle" state.
  • The instrument's input and output buffers are cleared.
  • The instrument is prepared to accept a new command string.
  • An overlapped command, if any, will be terminated with no "Operation Complete" indication (applies to the INITiate command).

The ABORt command is the recommended method to terminate a measurement.

VERBose Queries

All measurement queries have two forms, and you select one or the other by using or not using the VERBose keyword. If you do not use the VERBose keyword, the software returns a basic form that provides only the measurement result and the return code. If you use the VERBose form, the software returns six values. The first two are the same that are returned without the VERBose keyword, and the last four are the X and Y coordinates of the beginning and ending points of the measurement window. The X coordinates always indicates time, and the Y coordinates usually indicate a voltage, frequency, or pulse width, depending on what is being measured. In this way, the VERBose form provides marker information similar to what many oscilloscope displays provide.

LAN Port Usage

The Agilent L4532A/34A uses the following LAN ports:

  • Port 5024 is used for Telnet sessions.
  • Port 5025 is used for Socket sessions.


Commands by Subsystem

ABORt

ARM[:IMMediate]

INITiate

TRIGger[:IMMediate]

CALibration Subsystem

CONFigure Subsystem

DISPlay Subsystem Introduction

FETCh Subsystem

FORMat Subsystem Introduction

IEEE-488.2 Common Commands

MEASure Subsystem

READ Subsystem Introduction

STATus Subsystem

SYSTem Subsystem


ABORt

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

ABORt

Description

This command aborts lengthy operations, such as a data acquisition in progress.

Remarks

  • This command can be used to abort an acquisition when the instrument is waiting for an arm, waiting for a trigger, or acquiring data.
  • If an acquisition is aborted, the instrument returns to the idle state and the hardware stores which records have data and which do not. Use the FETCh:WAVeform:RECord:PREamble? query to determine what data is available after an ABORt. This query returns the position of the ABORt in the record preamble.
  • You can also abort a calibration, self test (*TST?), and lengthy data fetches by sending ABORt on a different I/O port.
  • You cannot use this to abort a query from the current I/O session. This is because the ABORt command will not be executed from the current session until the query has completed and returned its response. Applications that have timed out on a query may abort the query by issuing a Device Clear using an I/O Library function, or by issuing an ABORt on another I/O session.
  • The *RST command includes an implied ABORt, but when *RST stops acquisition it clears the waveform data, unlike ABORt.
  • If you ABORt an acquisition, you may FETCh data from any record that was triggered. The final record of an aborted acquisition may not contain a full set of post-trigger samples.
  • The only calibration commands that respond to an ABORt command are CALibration:RANGe:CHANnel? and CALibration:ZERO:AUTO?. An ABORt command executed on another I/O port during these operations terminates the calibration and restores the calibration constants to the state they were in when these commands were entered.
  • An ABORt command will usually complete in less than 500 milliseconds. However, a data FETCh or READ involving very large number of samples with a large decimation count can take up to 5 seconds, and aborting sampling with a slow sample rate can take up to 3 seconds.
  • You should use *OPC? after an ABORt command to determine when the ABORt finishes.

Example

The following commands start an acquisition and then abort the acquisition in progress.

INIT
.
.
.
ABOR

See Also

*RST

INITiate

FETCh Subsystem Introduction

READ Subsystem Introduction

CALibration:ZERO:AUTO?

CALibration:RANGe:CHANnel?

*TST?

MEASure:INSTall:RUN

*OPC


ARM[:IMMediate]

Syntax | Description | Parameters| Remarks | Return Format | Example

Syntax

ARM[:IMMediate]

Description

This command sends a software arm to the digitizer. Arming allows the digitizer to proceed to the Waiting for Trigger state.

Remarks

  • This command is useful only after you have executed an INITiate command and the instrument is in the Acquiring state.
  • This command causes an arm event regardless of the configured arm source, and it can be useful when [CONFigure:]ARM:SOURce is configured to EXTernal, SOFTware, or TIMer.
  • When [CONFigure:]ARM:SOURce is configured to SOFTware, then ARM[:IMMediate] and *TRG are the only ways to satisfy the wait-for-arm state.
  • If you execute this command when the digitizer is not in the wait-for-arm state, then the digitizer will buffer one arm and apply it the next time the digitizer enters the Waiting for Arm state. Of course, if the digitizer is in the Waiting for Arm state, this command will immediately arm the digitizer.
  • A buffered arm is cleared at the beginning of an acquisition. This ensures that a buffered arm from a previous acquisition does not affect the next acquisition.

Example

The following commands initiate and arm the digitizer:

INITiate
.
.
.
ARM

See Also

TRIGger[:IMMediate]

[CONFigure:]ARM:SOURce

*TRG

STATus:OPERation:CONDition?


INITiate

Syntax | Description| Parameters | Remarks | Return Format | Example

Syntax

INITiate

Description

This command changes the state of the triggering system from the "idle" state to the "wait-for-arm" state. Digitizing will begin when the specified arm and trigger conditions are satisfied after the INITiate command. Note that the INITiate command also clears the previous set of readings from memory.

Remarks

  • Once you have run the INITiate command, configuration changes are not allowed.
  • Storing readings in memory using the INITiate command is faster than sending readings to the output buffer using the READ:WAVeform commands. The INITiate command is also an "overlapped" command, meaning that after executing the INITiate command, you can send other commands that do not affect the operation.
  • To retrieve the readings from memory, use the FETCh:WAVeform:VOLTage? command. The ABORt command may be used to return to idle.
  • Triggers are ignored while the first set of pre-trigger samples is acquired and while post-trigger samples are acquired.
  • Triggers are also ignored during trigger holdoff period conditions on records after the first record in multi-record acquisition.
  • You should use *OPC? after an INITiate command to determine when the INITiate command finishes.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Example

The following program segment shows how to use the INITiate command with the FETCh:WAVeform:VOLTage? command. The INITiate command places the instrument in the "wait-for-trigger" state, triggers a measurement when the rear panel Trig In/Out line is pulsed (low by default), and then sends the readings to memory. The FETCh:WAVeform:VOLTage? command transfers the readings from memory to the instrument's output buffer.

INIT
*OPC?
FETCh:WAV:VOLT? (@1),1,100

Typical Response: <data block>

See Also

ARM[:IMMediate]

TRIGger[:IMMediate]

FETCh Subsystem Introduction

READ Subsystem Introduction

*OPC?


TRIGger[:IMMediate]

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

TRIGger[:IMMediate]

Description

This command causes a software trigger event, regardless of the trigger source. An implicit ARM event occurs when this is called because the fact that you are forcing a trigger implies that you want to arm the unit to enable the trigger.

Remarks

  • This command is equivalent to an IEEE 488.2 *TRG command.
  • There is no difference between TRIGger and TRIGger:IMMediate.
  • A TRIGger[:IMMediate] will also force a trigger even if the <source> is configured to values other than SOFTware.
  • To configure the instrument for software-only triggering, use [CONFigure:]TRIGger:SOURce SOFT.
  • This command can buffer one trigger to help alleviate the software timing mismatch between the test system and the digitizer. This means that if the digitizer is not in the Waiting for Arm or Waiting for Trigger state, the TRIGger:IMMediate command will be applied the next time the digitizer enters the Waiting for Arm or Waiting for Trigger state. Of course, if the digitizer is in the Waiting for Arm or Waiting for Trigger state, this command will immediately arm and trigger the digitizer.
  • A buffered trigger is cleared at the beginning of an acquisition. This ensures that a buffered trigger from a previous acquisition does not roll over into the next acquisition.
  • To run this command, the CALibration:STATe must be OFF, and the system must not be digitizing or running an on-board measurement (OBM).

Examples

The following command causes an immediate trigger event.

TRIGger:IMMediate

See Also

ARM[:IMMediate]

*TRG

INITiate


CALibration Subsystem Introduction

The CALibration commands are used to calibrate the Agilent L4532A/34A. Calibration requires an external 6.5 digit voltmeter to measure the internal calibration source as each range is calibrated.

Please note that the use of these commands requires a detailed knowledge of the appropriate calibration procedures, which are described in the Agilent L4532A/34A Service Guide. Please refer to that guide before attempting to calibrate the digitizer. Improper use of the CALibration commands can adversely affect the accuracy of the digitizer.

Command Summary

CALibration:COUNt?

CALibration:DATA

CALibration:DATA?

CALibration:LOAD

CALibration:RANGe

CALibration:RANGe?

CALibration:RANGe:CHANnel?

CALibration:RANGe:SOURce

CALibration:RANGe:SOURce?

CALibration:SECure:CODE

CALibration:SECure:STATe

CALibration:SECure:STATe?

CALibration:STATe

CALibration:STATe?

CALibration:STORe

CALibration:STORe:OVERride

CALibration:STORe:OVERride?

CALibration:STRing

CALibration:STRing?

CALibration:ZERO:AUTO?


CALibration:COUNt?

Syntax| Description| Parameters | Remarks| Return Format| Example

Syntax

CALibration:COUNt?

Description

This query returns the number of times calibration constants were written to non-volatile memory . Note that your instrument was calibrated before it left the factory. When you receive your instrument, be sure to read the count to determine the initial value. You can then subtract this number to determine how many times you have used CALibration:STORe to store calibration constants on the instrument.

Remarks

  • The calibration count is stored in non-volatile memory , and does not change when power has been off or after a Factory Reset (*RST command).
  • The calibration count is incremented by the CALibration:STORe command. You can read the calibration count regardless of whether the CALibration:STATe is ON.
  • The calibration count memory area can store numbers in the billions, so your digitizer's count will never exceed the limit.

Return Format

The command returns the calibration count as an integer indicating how many CALibration:STORe commands have been performed.

Example

The following command returns the calibration count after it was calibrated one time.

CAL:COUN?

Typical Response: +1

See Also

CALibration Subsystem Introduction

CALibration:STORe

CALibration:STATe


CALibration:COUNt?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

CALibration:COUNt?

Description

This query returns the number of times calibration constants were written to non-volatile memory. Note that your instrument was calibrated before it left the factory. When you receive your instrument, be sure to read the count to determine the initial value. You can then subtract this number to determine how many times you have used CALibration:STORe to store calibration constants on the instrument.

Remarks

  • The calibration count is stored in non-volatile memory, and does not change when power has been off or after a Factory Reset (*RST command).
  • The calibration count is incremented by the CALibration:STORe command. You can read the calibration count regardless of whether the CALibration:STATe is ON.
  • The calibration count memory area can store numbers in the billions, so your digitizer's count will never exceed the limit.

Return Format

The command returns the calibration count as an integer indicating how many CALibration:STORe commands have been performed.

Example

The following command returns the calibration count after it was calibrated one time.

CAL:COUN?

Typical Response: +1

See Also

CALibration Subsystem Introduction

CALibration:STORe

CALibration:STATe


CALibration:DATA

Syntax

CALibration:DATA (@<channel>), <cal_data_block>

CALibration:DATA? (@<channel>)

Description

This command forces the given block of channel calibration constants into use on the specified channel. The calibration block typically was acquired via a previous CAL:DATA? query. The query form of the command returns the calibration data block.

 Calibration requires an external 6.5 digit voltmeter to measure the internal calibration source as each range is calibrated. To calibrate all ranges requires following a procedure documented in the Agilent L4532A/34A Service Guide, which explains how to use the CALibration commands. For a more detailed discussion of the calibration procedures, see the Agilent L4532A/34A Service Guide. Please refer to this document before attempting to calibrate the digitizer. Improper use of the CALibration commands can adversely affect the accuracy of the digitizer.

Parameters

Name | Type | Range of Values | Default Value
<channel> String

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<cal_data_block> | This is an IEEE 488 definite arbitrary block whose structure is described in detail in the Return Format section below. The block size is always of the form #3360 <360 byte block>, and if it is not exactly 360 bytes, the digitizer will produce an error.

Remarks

  • This command is rarely used by most users. It is most commonly used by calibration laboratories where constants must be stored for documentation purposes, and possibly restored at a later date.
  • Before you can use the non-query form of this command, you must have performed CALibration:SECure:STATe OFF and CALibration:STATe ON.
  • You may read calibration constants regardless of the CALibration:STATe value. However, you must be in CALibration:STATe ON to set the calibration constants.
  • Be cautious when executing this command. Forcing invalid calibration constants into the instrument can result in readings that do not meet specifications.
  • Writing a calibration block has only temporary effects, unless you perform a CALibration:STORe command, at which point the constants set by this command will overwrite those previously stored in the non-volatile memory.

Return Format

The query command returns an IEEE 488 definite arbitrary block of the form #3360<360 byte block>.

The following table defines the contents of the IEEE 488 <360 byte block>. Note that LSB stands for least significant byte, and MSB stands for most significant byte.

Calibration Constant Description

Byte Offset
20 MHz
Filter

Byte Offset
2 MHz
Filter

Byte Offset
200 KHz
Filter
DC LSB gain: range 0.25 V | 0 | 120 | 240
DC MSB gain: range 0.25 V | 1 | 121 | 241
DC LSB offset: range 0.25 V | 2 | 122 | 242
DC MSB offset: range 0.25 V | 3 | 123 | 243
DC LSB gain: range 0.50 V | 4 | 124 | 244
DC MSB gain: range 0.50 V | 5 | 125 | 245
DC LSB offset: range 0.50 V | 6 | 126 | 246
DC MSB offset: range 0.50 V | 7 | 127 | 247
DC LSB gain: range 1.0 V | 8 | 128 | 248
DC MSB gain: range 1.0 V | 9 | 129 | 249
DC LSB offset: range 1.0 V | 10 | 130 | 250
DC MSB offset: range 1.0 V | 11 | 131 | 251
DC LSB gain: range 2.0 V | 12 | 132 | 252
DC MSB gain: range 2.0 V | 13 | 133 | 253
DC LSB offset: range 2.0 V | 14 | 134 | 254
DC MSB offset: range 2.0 V | 15 | 135 | 255
DC LSB gain: range 4.0 V | 16 | 136 | 256
DC MSB gain: range 4.0 V | 17 | 137 | 257
DC LSB offset: range 4.0 V | 18 | 138 | 258
DC MSB offset: range 4.0 V | 19 | 139 | 259
DC LSB gain: range 8.0 V | 20 | 140 | 260
DC MSB gain: range 8.0 V | 21 | 141 | 261
DC LSB offset: range 8.0 V | 22 | 142 | 262
DC MSB offset: range 8.0 V | 23 | 143 | 263
DC LSB gain: range 16.0 V | 24 | 144 | 264
DC MSB gain: range 16.0 V | 25 | 145 | 265
DC LSB offset: range 16.0 V | 26 | 146 | 266
DC MSB offset: range 16.0 V | 27 | 147 | 267
DC LSB gain: range 32.0 V | 28 | 148 | 268
DC MSB gain: range 32.0 V | 29 | 149 | 269
DC LSB offset: range 32.0 V | 30 | 150 | 270
DC MSB offset: range 32.0 V | 31 | 151 | 271
DC LSB gain: range 64.0 V | 32 | 152 | 272
DC MSB gain: range 64.0 V | 33 | 153 | 273
DC LSB offset: range 64.0 V | 34 | 154 | 274
DC MSB offset: range 64.0 V | 35 | 155 | 275
DC LSB gain: range 128.0 V | 36 | 156 | 276
DC MSB gain: range 128.0 V | 37 | 157 | 277
DC LSB offset: range 128.0 V | 38 | 158 | 278
DC MSB offset: range 128.0 V | 39 | 159 | 279
DC LSB gain: range 256.0 V | 40 | 160 | 280
DC MSB gain: range 256.0 V | 41 | 161 | 281
DC LSB offset: range 256.0 V | 42 | 162 | 282
DC MSB offset: range 256.0 V | 43 | 163 | 283
DC LSB gain (B): range 4.0 V | 44 | 164 | 284
DC MSB gain (B): range 4.0 V | 45 | 165 | 285
DC LSB offset (B): range 4.0 V | 46 | 166 | 286
DC MSB offset (B): range 4.0 V | 47 | 167 | 287
DC LSB gain (B): range 8.0 V | 48 | 168 | 288
DC MSB gain (B): range 8.0 V | 49 | 169 | 289
DC LSB offset (B): range 8.0 V | 50 | 170 | 290
DC MSB offset (B): range 8.0 V | 51 | 171 | 291
DC LSB gain (B): range 16.0 V | 52 | 172 | 292
DC MSB gain (B): range 16.0 V | 53 | 173 | 293
DC LSB offset (B): range 16.0 V | 54 | 174 | 294
DC MSB offset (B): range 16.0 V | 55 | 175 | 295
DC LSB gain (B): range 32.0 V | 56 | 176 | 296
DC MSB gain (B): range 32.0 V | 57 | 177 | 297
DC LSB offset (B): range 32.0 V | 58 | 178 | 298
DC MSB offset (B): range 32.0 V | 59 | 179 | 299
AC LSB gain: range 0.25 V | 60 | 180 | 300
AC MSB gain: range 0.25 V | 61 | 181 | 301
AC LSB offset: range 0.25 V | 62 | 182 | 302
AC MSB offset: range 0.25 V | 63 | 183 | 303
AC LSB gain: range 0.50 V | 64 | 184 | 304
AC MSB gain: range 0.50 V | 65 | 185 | 305
AC LSB offset: range 0.50 V | 66 | 186 | 306
AC MSB offset: range 0.50 V | 67 | 187 | 307
AC LSB gain: range 1.0 V | 68 | 188 | 308
AC MSB gain: range 1.0 V | 69 | 189 | 309
AC LSB offset: range 1.0 V | 70 | 190 | 310
AC MSB offset: range 1.0 V | 71 | 191 | 311
AC LSB gain: range 2.0 V | 72 | 192 | 312
AC MSB gain: range 2.0 V | 73 | 193 | 313
AC LSB offset: range 2.0 V | 74 | 194 | 314
AC MSB offset: range 2.0 V | 75 | 195 | 315
AC LSB gain: range 4.0 V | 76 | 196 | 316
AC MSB gain: range 4.0 V | 77 | 197 | 317
AC LSB offset: range 4.0 V | 78 | 198 | 318
AC MSB offset: range 4.0 V | 79 | 199 | 319
AC LSB gain: range 8.0 V | 80 | 200 | 320
AC MSB gain: range 8.0 V | 81 | 201 | 321
AC LSB offset: range 8.0 V | 82 | 202 | 322
AC MSB offset: range 8.0 V | 83 | 203 | 323
AC LSB gain: range 16.0 V | 84 | 204 | 324
AC MSB gain: range 16.0 V | 85 | 205 | 325
AC LSB offset: range 16.0 V | 86 | 206 | 326
AC MSB offset: range 16.0 V | 87 | 207 | 327
AC LSB gain: range 32.0 V | 88 | 208 | 328
AC MSB gain: range 32.0 V | 89 | 209 | 329
AC LSB offset: range 32.0 V | 90 | 210 | 330
AC MSB offset: range 32.0 V | 91 | 211 | 331
AC LSB gain: range 64.0 V | 92 | 212 | 332
AC MSB gain: range 64.0 V | 93 | 213 | 333
AC LSB offset: range 64.0 V | 94 | 214 | 334
AC MSB offset: range 64.0 V | 95 | 215 | 335
AC LSB gain: range 128.0 V | 96 | 216 | 336
AC MSB gain: range 128.0 V | 97 | 217 | 337
AC LSB offset: range 128.0 V | 98 | 218 | 338
AC MSB offset: range 128.0 V | 99 | 219 | 339
AC LSB gain: range 256.0 V | 100 | 220 | 340
AC MSB gain: range 256.0 V | 101 | 221 | 341
AC LSB offset: range 256.0 V | 102 | 222 | 342
AC MSB offset: range 256.0 V | 103 | 223 | 343
AC LSB gain (B): range 4.0 V | 104 | 224 | 344
AC MSB gain (B): range 4.0 V | 105 | 225 | 345
AC LSB offset (B): range 4.0 V | 106 | 226 | 346
AC MSB offset (B): range 4.0 V | 107 | 227 | 347
AC LSB gain (B): range 8.0 V | 108 | 228 | 348
AC MSB gain (B): range 8.0 V | 109 | 229 | 349

AC LSB offset (B): range 8.0 V

 110 230 350
AC MSB offset (B): range 8.0 V | 111 | 231 | 351
AC LSB gain (B): range 16.0 V | 112 | 232 | 352
AC MSB gain (B): range 16.0 V | 113 | 233 | 353
AC LSB offset (B): range 16.0 V | 114 | 234 | 354
AC MSB offset (B): range 16.0 V | 115 | 235 | 355
AC LSB gain (B): range 32.0 V | 116 | 236 | 356
AC MSB gain (B): range 32.0 V | 117 | 237 | 357
AC LSB offset (B): range 32.0 V | 118 | 238 | 358
AC MSB offset (B): range 32.0 V | 119 | 239 | 359

The instrument includes a secondary divide-by-16 attenuator that is used for upper ranges. The attenuator carries its own set of calibration constants, indicated by (B) in the table above.

Examples

The following command loads a block of calibration constants to channel 1

CAL:DATA (@1),<360 byte block>

The following query returns the present calibration values.

CAL:DATA? (@1)

Typical Response: #3360<360 byte block>

See Also

CALibration Subsystem Introduction

CALibration:STORe

CALibration:STATe

CALibration:SECure:STATe


CALibration:LOAD

Syntax

CALibration:LOAD<chan_list> [,<source>]

Description

This command reloads the active calibration constants from the selected source into the analog front ends of the specified channels.

 Calibration requires an external 6.5 digit voltmeter to measure the internal calibration source as each range is calibrated. To calibrate all ranges requires following a procedure documented in the Agilent L4532A/34A Service Guide, which explains how to use the CALibration commands. For a more detailed discussion of the calibration procedures, see the Agilent L4532A/34A Service Guide. Please refer to this document before attempting to calibrate the digitizer. Improper use of the CALibration commands can adversely affect the accuracy of the digitizer.

Parameters

Name Type Range of Values Default Value
<chan_list> Channel list

One or more channels, specified as in the following examples.

(@2) - channel 2

(@1,4) - channels 1 and 4

(@1:4) - channels 1 through 4.

 This is a required parameter.
<source> Discrete

{STORed|FIXed}

Setting <source> to STORed loads the calibration constants from a channel's non-volatile calibration constants memory into active use by the channel. These are the same calibration constants that are loaded when the instrument boots.

Setting <source> to FIXed loads nominal factory values into the Front end, with offset and gain corrections of 0.

STORed

Remarks

  • An implicit CAL:LOAD command from the STORed <source> occurs on every channel every time you turn the instrument on. Therefore, CAL:LOAD (@<chan_list>) STORed does not require any particular value of CALibration STATe or CALibration:SECure:STATe, as it is equivalent to restoring the calibration constants to their power-up state.
  • Setting the <source> to STORed can be useful after doing CALibration:ZERO:AUTO?, as the CALibration:ZERO:AUTO? will store new offset constants in volatile memory over the default boot calibration constants.
  • Setting the <source> to FIXed requires CALibration:STATe ON, as it changes the calibration constants to nominal values. This de-calibrates the instrument, so the CAL:STAT ON is required to avoid accidental changes of this type. As CAL:STAT ON requires the CALibration:SECure:STATe to be OFF, CAL:LOAD FIXED cannot be done without first un-securing the instrument. The CAL:LOAD FIXED can be useful to restore nominal calibration constants for testing the operation of the digitizer without any offset or gain corrections.
  • Setting the <source> to FIXed is useful if a user has destroyed valid calibration constants and wants to restore a nominal set of calibration constants.
  • Exercise caution when executing a CALibration:STORe command after using CAL:LOAD, as CALibration:STORe will overwrite your non-volatile stored constants with constants loaded by the CALibration:LOAD command.

Examples

The following command loads the non-volatile stored calibration constants as the active calibration constants for channel 1.

CAL:LOAD (@1),STORed

The following command refreshes all calibration constants to the instrument's power-up state.

CAL:LOAD (@1:4),STORed

The following command loads nominal calibration constants for all four channels.

CAL:LOAD (@1:4),FIXed

See Also

CALibration Subsystem Introduction

CALibration:STATe

CALibration:ZERO:AUTO?


CALibration:RANGe

Syntax

CALibration:RANGe <range>

CALibration:RANGe?

Description

This command selects the next channel voltage range to be calibrated.

 Calibration requires an external 6.5 digit voltmeter to measure the internal calibration source as each range is calibrated. To calibrate all ranges requires following a procedure documented in the Agilent L4532A/34A Service Guide, which explains how to use the CALibration commands. For a more detailed discussion of the calibration procedures, see the Agilent L4532A/34A Service Guide. Please refer to this document before attempting to calibrate the digitizer. Improper use of the CALibration commands can adversely affect the accuracy of the digitizer.

Parameters

Name | Type | Range of Values | Default Value
<range> | Numeric | {0.25|0.5|1|2|4|8|16|32|64|128|256} | This is a required parameter.

Remarks

  • You must choose one of the choices for the <range> listed above. If the command includes a <range> not listed above, the digitizer will dispatch an error message.
  • When you select a new calibration range, the CAL OUTPUT BNC connector sources a new calibration source voltage appropriate for the newly selected <range>. The settling time for a new calibration source output voltage is one second. You may use the *OPC? query in your application to ensure that the full settling time has elapsed.
  • The new calibration source output voltage will be consistent with the currently selected CALibration:RANGe:SOURce UPPer or LOWer setting.

Return Format

The query returns the <range> to be calibrated next.

Examples

The following command sets the <range> to the 4 V range.

CAL:RANGe 4

The following query indicates that the 4 V range is the one that will be calibrated next.

CAL:RANGe?

Typical Response: +4.000000E+00

See Also

CALibration Subsystem Introduction

CALibration:RANGe:SOURce

CALibration:STATe

CALibration:RANGe:CHANnel?


CALibration:RANGe:CHANnel?

Syntax

CALibration:RANGe:CHANnel? (@<chan_list>), {OOFFset |<v_lower>} [,<v_upper>]

Description

Calibrates gain and offsets for the specified channels in the range specified by the CALibration:RANGe command. You may choose to store these constants to non-volatile memory with the CALibration:STORe command, once all of the ranges have been calibrated.

 Calibration requires an external 6.5 digit voltmeter to measure the internal calibration source as each range is calibrated. To calibrate all ranges requires following a procedure documented in the Agilent L4532A/34A Service Guide, which explains how to use the CALibration commands. For a more detailed discussion of the calibration procedures, see the Agilent L4532A/34A Service Guide. Please refer to this document before attempting to calibrate the digitizer. Improper use of the CALibration commands can adversely affect the accuracy of the digitizer.

Parameters

Name Type Range of Values Default Value
<chan_list> Channel list

One or more channels, specified as in the following examples.

(@2) - channel 2

(@1,4) - channels 1 and 4

(@1:4) - channels 1 through 4.

 This is a required parameter.
<v_lower> Numeric

Lower calibration source voltage that you previously read at the external calibration connector after issuing the CALibration:RANGe:SOURce LOW command. This will be a negative number.

Values above the 16 V range will have a 0 V calibration source output, because the internal calibration source is limited to +/- 16 V. Calibrations on these ranges is computed based on the calibration of the lower ranges.

If this parameter is OOFFset (Only OFFset), then only an offset calibration will be performed.

 This is a required parameter.
<v_upper> Numeric Upper calibration source voltage that you previously read at the external calibration connector after issuing the CALibration:RANGe:SOURce UPPer command. This will be a positive number.

Any CALibration:RANGe values above the 16 V range will have a 0 V calibration source output, because the internal calibration source is limited to +/- 16 V.

If the previous parameter is OOFFset (Only OFFset), then you should not enter this optional parameter.

 This is a required parameter if the previous parameter is not OOFFset.

Remarks

  • This command is executed in a particular sequence of commands as documented in the Agilent L4532A/34A Service Guide.
  • To execute this command, the calibration subsystem must be in CALibration:STATe ON.
  • The <v_lower> and <v_upper> values are the calibration source voltages that you read at the external calibration source output on the rear panel of the instrument.
  • The calibration constants are stored in volatile memory until you execute the CALibration:STORe command.
  • This command calibrates the gains and offsets for the specified channels for the current calibration range for all channel couplings (AC and DC) and filter settings. Therefore, this command creates six sets of calibration constants each time it runs.
  • The enumerated value OOFFset is short for Only OFFset. If OOFFset is specified, then only a offset calibrations are performed. An offset calibration does not require digital multimeter (DMM) voltages, and it is useful when you do not have a DMM available or when the temperature has changed and the offset calibration must be corrected for the new operating temperature. The optional <v_upper> parameter is not allowed when the OOFFset value is used.
  • If an error occurs, then the calibration constants implicated with the error are left with the same values that they had when the command started. All constants that did not suffer error conditions receive the new calibration constants.
  • The gain values for the four upper ranges (32, 64, 128, and 256 V) are not calibrated directly using the internal calibration source. Instead, their calibration constants are computed based on values resulting from calibrating the lower ranges. Therefore, you must follow the order of ranges to be calibrated as described in the Agilent L4532A/34A Service Guide. Offset calibration for the upper four ranges is based on an internal short and does not rely on computed methods (as the gain calibration does).
  • This query can take up to three minutes to execute, but it typically requires less than one minute.
  • While this command is running, no other commands will be processed by the instrument. Only a device clear operation or an ABORt command sent on a different I/O interface can abort this execution.
  • If the return value is +1 (errors), you should run *TST? to assess the state of your hardware.

Return Format

The query command returns +0 (no errors) or +1 (errors). If a +1 is returned, you should query for calibration error codes by using the SYSTem:ERRor? command.

Examples

The following command calibrates all gains and offsets on all four channels for the 16 V range.

CAL:RANG:CHANnel? (@1:4),-15.6723,15.53221

Typical Response: +0

The following command calibrates channel 1 for offset only.

CAL:RANG:CHANnel? (@1),OOFFset

Typical Response: +0

See Also

CALibration Subsystem Introduction

CALibration:SECure:STATe

CALibration:STATe

CALibration:STORe

CALibration:RANGe:SOURce


CALibration:RANGe:SOURce

Syntax

CALibration:RANGe:SOURce <low_high_select>

CALibration:RANGe:SOURce?

Description

This command specifies whether the lower or upper calibration source voltage is generated for the currently selected range. You must measure both of these voltages and then enter them as parameters using the CALibration:RANGe:CHANnel? command.

Calibration requires an external 6.5 digit voltmeter to measure the internal calibration source as each range is calibrated. To calibrate all ranges requires following a procedure documented in the Agilent L4532A/34A Service Guide, which explains how to use the CALibration commands. For a more detailed discussion of the calibration procedures, see the Agilent L4532A/34A Service Guide. Please refer to this document before attempting to calibrate the digitizer. Improper use of the CALibration commands can adversely affect the accuracy of the digitizer.

Parameters

Name Type Range of Values Default Value
<low_high_select> Discrete

{LOWer|UPPer} to specify which calibration source voltage is generated.

This is a required parameter.

Remarks

  • This command is executed in a particular sequence of commands as documented in the Agilent L4532A/34A Service Guide.
  • To execute this command, the calibration subsystem must be in CALibration:STATe ON. When you enter CALibration:STATe ON, <low_high_select> is set to LOW by default.
  • Specifying LOWer causes the calibration source to generate a negative voltage, and specifying UPPer causes it to generate a positive voltage. These voltages are appropriate for the range currently selected by CALibration:RANGe.
  • Both of these voltages are needed for the CALibration:RANGe:CHANnel? query that does the actual calibration for the current range.
  • Ranges above 16 V set the calibration source to 0 V, as the internal calibration source is limited to +/-16 V. These higher ranges are calibrated through computed methods based on the lower range calibrations, which is why their UPPer and LOWer calibration settings measure approximately 0 V.
  • If you change the CALibration:RANGe, the setting of LOWer or UPPer persists, and the appropriate new calibration source for the new calibration range is output.
  • There is a settling time of one second for the calibration source voltage when you use this command. You must wait for this settling period to finish or send a subsequent *OPC? query, which will return when the settling period is over.

Return Format

The query command returns the current value of <low_high_select> as LOW or UPP.

Examples

The following command specifies that the upper calibration setting will be used.

CAL:RANG:SOUR UPP

The following query returns which calibration setting will be used.

CAL:RANG:SOUR?

Typical Response: UPP

See Also

CALibration Subsystem Introduction

CALibration:RANGe:CHANnel?

CALibration:RANGe

CALibration:STATe


CALibration:SECure:CODE

Syntax

CALibration:SECure:CODE <sec_code>

Description

This command allows you to redefine the security code used as a parameter in the CALibration:SECure:STATe command. To change the security code, you must first unsecure calibration (using the old security code) and then enter a new code with this command.

Calibration requires an external 6.5 digit voltmeter to measure the internal calibration source as each range is calibrated. To calibrate all ranges requires following a procedure documented in the Agilent L4532A/34A Service Guide, which explains how to use the CALibration commands. For a more detailed discussion of the calibration procedures, see the Agilent L4532A/34A Service Guide. Please refer to this document before attempting to calibrate the digitizer. Improper use of the CALibration commands can adversely affect the accuracy of the digitizer.

Parameters

Name Type Range of Values Default Value
<sec_code> Unquoted ASCII String

A string of up to 12 characters. The first character must always be a letter (A-Z). The remaining 11 characters can be letters, numbers (0-9), or the underscore character ("_"). Blank spaces are not allowed.

This is a required parameter.

Remarks

  • You must unsecure the instrument with CALibration:SECure:STATe OFF before sending this command.
  • The default security code is set to ATL4532 or ATL4534 when the digitizer is shipped from the factory. You should change it when you first calibrate the digitizer.
  • The calibration security setting is stored in non-volatile memory, and does not change when power has been off or after a Factory Reset (*RST command).
  • Be sure to remember your <sec_code>. It will be required to unsecure your instrument in the future with CALibration:SECure:STATe so that you may calibrate the digitizer.

Examples

The following command sets a new calibration security code (calibration memory must be unsecured) with CALibration:SECure:STATe OFF,ATL4532 and CALibration:STATe ON.

CAL:SEC:CODE T3ST_DUT165

See Also

CALibration Subsystem Introduction

CALibration:SECure:STATe

CALibration:STATe


CALibration:SECure:STATe

Syntax

CALibration:SECure:STATe <state> [, <security_string>]

CALibration:SECure:STATe?

Description

This command unsecures or secures the instrument for subsequent calibration. To unsecure the instrument, you must provide a security code to prevent accidental or unauthorized calibrations.

 Calibration requires an external 6.5 digit voltmeter to measure the internal calibration source as each range is calibrated. To calibrate all ranges requires following a procedure documented in the Agilent L4532A/34A Service Guide, which explains how to use the CALibration commands. For a more detailed discussion of the calibration procedures, see the Agilent L4532A/34A Service Guide. Please refer to this document before attempting to calibrate the digitizer. Improper use of the CALibration commands can adversely affect the accuracy of the digitizer.

Parameters

Name Type Range of Values Default Value
<state> Boolean

{OFF|0|ON|1}

OFF unsecures the instrument, and ON secures (locks) it.

 This is a required parameter.
<security_string> Unquoted String

A string of up to 12 characters. The first character must always be a letter (A-Z). The remaining characters can be letters, numbers (0-9), or the underscore character ("_"). Blank spaces are not allowed.

This parameter is required to unsecure the instrument (<state>=OFF), but is optional to secure the instrument (<state>=ON). It must be correct if provided.

Remarks

  • You must unsecure the instrument in order to execute the CALibration:STATe ON command, which in turn allows you to calibrate the instrument.
  • The only calibration commands that can be executed on a secure digitizer are CALibration:ZERO:AUTO?, CALibration:LOAD STORed, CALibration:STRing?, and CALibration:COUNt?.
  • Use ON or 1 to secure the instrument. Use OFF or 0 to unsecure the instrument.
  • When you first receive your instrument, it is secured. The <security string> is set to ATL4532 or ATL4534 (depending on the unit's model number) when the instrument is shipped from the factory. See CALibration:SECure:CODE for instructions on changing the security code.
  • Once you have the instrument in the unsecured state, you may re-secure it without providing the <security_string>. If you execute the command without the <security_string>, the instrument will be re-secured, using the old security code. Be sure you know the <security_code> when you re-secure the instrument without the <security_code>. You will need it to unsecure the instrument again.
  • If you forget your security code, you can override the security feature. See the Agilent L4532A/34A Service Guide for more information.
  • You may elect to leave the instrument in the unsecured state, in which case anybody using the instrument may enable calibration via CALibration:STATe ON and use the calibration commands. This is not recommended because the calibration of the instrument may be corrupted, resulting in readings that do not meet specifications.
  • The calibration security setting is stored in non-volatile memory, and does not change when power has been off or after a Factory Reset (*RST command).

Return Format

The query returns 0 (OFF) or 1 (ON). This indicates the current calibration security setting.

Examples

The following command unsecures the instrument using the factory default security code for a 2-channel digitizer.

CAL:SEC:STAT OFF,ATL4532

The following query returns the current calibration security setting.

CAL:SEC:STAT?

Typical Response: 0

See Also

CALibration Subsystem Introduction

CALibration:SECure:CODE

CALibration:STATe


CALibration:STATe

Syntax

CALibration:STATe <state>

CALibration:STATe?

Description

This command causes the instrument to enter or exit the calibration mode. All calibration must be done in the calibration mode, except for CALibration:ZERO:AUTO?.

Calibration requires an external 6.5 digit voltmeter to measure the internal calibration source as each range is calibrated. To calibrate all ranges requires following a procedure documented in the Agilent L4532A/34A Service Guide, which explains how to use the CALibration commands. For a more detailed discussion of the calibration procedures, see the Agilent L4532A/34A Service Guide. Please refer to this document before attempting to calibrate the digitizer. Improper use of the CALibration commands can adversely affect the accuracy of the digitizer.

Parameters

Name | Type | Range of Values | Default Value
<state> | Boolean | {OFF|0|ON|1} | This is a required parameter.

Remarks

  • When the instrument is in calibration mode, the CALibration commands are available and most other commands that operate the digitizer are not available. Attempting to execute commands not related to calibration will cause the digitizer to generate error messages.
  • You must unsecure the instrument with CALibration:SECure:STATe OFF before sending this command.
  • Use ON or 1 to enter the calibration mode. Use OFF or 0 to exit it.
  • When the instrument is in CALibration:STATe ON, the CALibration bit in the Standard Operation Register is asserted. This is also asserted by CALibration:ZERO:AUTO?.
  • When in this mode, all channel inputs are switched to receive input from the internal calibration source. However, you should remove input signals to all channels prior to entering the calibration mode.
  • When you enter the calibration mode, the CAL:RANGe <range> defaults to the 0.25 V range.
  • When you are in the calibration mode, the *RST command will cause all calibration constants to be restored from non-volatile memory to the boot state, and the instrument then automatically exits the calibration mode.
  • Note that *RST will not re-secure the instrument (see CALibration:SECure:STATe ON).
  • You will receive an error if you have changed the current calibration constants and attempt to leave the calibration mode without storing your calibration constants to the non-volatile memory with CALibration:STORe. If you wish to leave without storing the constants to non-volatile memory , use CALibration:STORe:OVERride ON. If you wish to leave and discard any new calibration constants, use the *RST command.
  • To execute this command, you must not be digitizing or running an on-board measurement (OBM).

Return Format

The query returns 0 (OFF) or 1 (ON).

Examples

The following command puts the digitizer into CALibration mode.

CAL:STATE 1

The following query returns the current CALibration mode.

CAL:STATE?

Typical Response: 1

See Also

CALibration Subsystem Introduction

CALibration:SECure:STATe


CALibration:STORe

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

CALibration:STORe

Description

This command stores the calibration constants for all channels in non-volatile memory . Once this is done, the stored calibration constants will be restored during all subsequent boots.

Calibration requires an external 6.5 digit voltmeter to measure the internal calibration source as each range is calibrated. To calibrate all ranges requires following a procedure documented in the Agilent L4532A/34A Service Guide, which explains how to use the CALibration commands. For a more detailed discussion of the calibration procedures, see the Agilent L4532A/34A Service Guide. Please refer to this document before attempting to calibrate the digitizer. Improper use of the CALibration commands can adversely affect the accuracy of the digitizer.

Remarks

  • This command functions only on an unsecured digitizer with CALibration:SECure:STATe OFF and CALibration:STATe ON.
  • This command overwrites your old calibration constants stored in non-volatile memory with the new calibration constants generated by your use of CALibration:RANGe:CHANnel?, CALibration:ZERO:AUTO?, or CALibration:LOAD commands.
  • You can use this command to store a set of custom calibration constants that has been written to the channels by the CALibration:DATA command.
  • This command increments the calibration counter that is read by CALibration:COUNt?.
  • Once the calibration constants are stored in non-volatile calibration memory , they will not change when power has been off or after a Factory Reset (*RST command).
  • This is the only command that commits the calibration constants to non-volatile memory . If you fail to use this command during calibration, any new calibration data will be lost when the system powers down.
  • This command is lengthy, and the possibility exists that you may lose power before it completes. If this occurs, the instrument will display error messages informing you of the calibration constant recovery actions it has taken when the instrument is re-booted.

Example

The following command stores the calibration constants in non-volatile calibration memory .

CAL:STOR

See Also

CALibration Subsystem Introduction

CALibration:DATA

CALibration:SECure:STATe

CALibration:STATe

CALibration:RANGe:CHANnel?

CALibration:ZERO:AUTO?

CALibration:LOAD


CALibration:STORe:OVERride

Syntax

CALibration:STORe:OVERride <state>

CALibration:STORe:OVERride?

Description

This command causes the CALibration:STATe OFF command to allow you to exit the calibration mode without storing the calibration constants. This allows you to operate the digitizer with a temporary set of calibration constants that will disappear the next time the instrument is powered down.

 Calibration requires an external 6.5 digit voltmeter to measure the internal calibration source as each range is calibrated. To calibrate all ranges requires following a procedure documented in the Agilent L4532A/34A Service Guide, which explains how to use the CALibration commands. For a more detailed discussion of the calibration procedures, see the Agilent L4532A/34A Service Guide. Please refer to this document before attempting to calibrate the digitizer. Improper use of the CALibration commands can adversely affect the accuracy of the digitizer.

Parameters

Name | Type | Range of Values | Default Value
<state> | Boolean | {OFF|0|ON|1} | This is a required parameter.

Remarks

  • Normally, if you have changed the current calibration constants, you may not exit the calibration mode (CALibration:STATe OFF) unless you have stored your calibration constants to non-volatile memory using CALibration:STORe. If you try to do this without storing the constants, the instrument will generate an error message.
  • This override command provides a way for you to explicitly declare the intent to exit calibration mode and retain a transient set of calibration constants that will be lost at the next power-down. This flexibility allows you to experiment with varying calibration constants without committing them to non-volatile memory .
  • You should exercise great care in operating with a transient set of calibration constants, because samples acquired with these constants are not traceable to the secured non-volatile calibration constants.
  • At entry to CALibration:STATe ON, the default CALibration:STORe:OVERride <state>is always set to OFF.

Return Format

The query returns 0 (OFF) or 1 (ON).This indicates the current override <state>.

Examples

The following command allows you to exit calibration mode without storing the calibration constants.

CAL:STOR:OVER ON
CAL:STATE: OFF

The following query returns the current state of calibration storage override.

CAL:STOR:OVER?

Typical Response: 1

See Also

CALibration Subsystem Introduction

CALibration:STATe

CALibration:STORe


CALibration:STRing

Syntax

CALibration:STRing "<string>"

CALibration:STRing?

Description

This command allows you to store an informational message related to the most recent calibration in non-volatile memory . For example, you can store such information as the date when the last calibration was performed, the date when the next calibration is due, or even the name and phone number of the person to contact for a new calibration.

Parameters

Name Type Range of Values Default Value
<string> Quoted ASCII String

A string of up to 40 characters enclosed in quotes. You can use letters (A-Z), numbers (0-9), and special characters like "@", "%", "*", and so on. If you enter more than 40 characters, the instrument will produce an error message.

 This is a required parameter.

Remarks

  • The calibration message may contain up to 40 characters.
  • You can store a calibration message only when the instrument is in CALibration:STATe ON.
  • You can query the calibration string regardless of whether the instrument is secured.
  • Storing a calibration message will overwrite any message previously stored in memory.
  • The calibration message is stored in non-volatile calibration memory , and does not change when power has been off or after a Factory Reset (*RST command).

Return Format

The query command returns an ASCII string enclosed in double quotes. If no calibration message has been specified, an empty quoted string ("") is returned.

Examples

The following command stores a message in calibration memory.

CAL:STR "CAL: 21Nov08 at 24.7degC, CAL ID=01756"

The following query returns the message currently stored in calibration memory, including the quotation marks.

CAL:STR?

Typical Response: "CAL: 21Nov08 at 24.7degC, CAL ID=01756"

See Also

CALibration Subsystem Introduction

CALibration:SECure:STATe

CALibration:STATe


CALibration:ZERO:AUTO?

Syntax

CALibration:ZERO:AUTO? (@<chan_list>)

Description

This command performs a quick auto-zero offset calibration on specified channels using the each channel's existing channel configuration. The configured state of the instrument is unaffected. Use this command periodically to improve offset calibration when environmental conditions vary from when the full calibration was done.

Parameters

Name Type Range of Values Default Value
<chan_list> Channel list

One or more channels, specified as in the following examples.

(@2) - channel 2

(@1,4) - channels 1 and 4

(@1:4) - channels 1 through 4.

 This is a required parameter.

Remarks

  • This command provides a convenient way to correct the zero offset calibration in response to changing environmental conditions. This enables a user using a high voltage range to obtain more accurate readings near 0 V, thus allowing for periodic, fast calibrations without calibrating all ranges and filters to zero.
  • This command does not require the digitizer to be in the unsecured state or in CALibration:STATe ON.
  • The results of this command are NOT stored to non-volatile memory , and they will therefore be lost at the instrument's next power cycle unless you enter calibration mode and perform a CALibration:STORe.
  • The auto-zero will apply to subsequent sampling on the configured range, filter, and coupling.
  • The auto-zero is retained when you change channel configuration and then return to the configuration on which the auto-zero was performed. This remains true until you cycle power on the instrument.
  • The instrument connects the calibration bus for the specified channels. For each channel in the <chan_list>, it performs the zero offset calibration for the existing front end configuration.
  • If a 1 is returned, then the calibration failed and you should use the SYSTem:ERRor? query to assess the cause of the failure.
  • When CAL:ZERO:AUTO? finishes, it updates only the offset constants for the current settings, and it then restores the instrument state to what it had been before the CAL:ZERO:AUTO? was executed.
  • Because this command changes the active offset calibration constants, you may later choose to restore the non-volatile boot state constants with the CALibration:LOAD STORed command.
  • This is one of two calibration commands that respond to an ABORt command. The other is CALibration:RANGe:CHANnel?.
  • To execute this command, you must not be digitizing or running an on-board measurement (OBM).

Return Format

The query command returns 0 (no errors) or 1 (errors).

Examples

The following command performs an auto-zero on channels 1, 3 and 4.

CAL:ZERO:AUTO? (@1,3,4)

Typical Response: +0

See Also

CALibration Subsystem Introduction

CALibration:LOAD


CONFigure Subsystem Introduction

Command Summary

[CONFigure:]ACQuisition[:ATTRibutes]

[CONFigure:]ACQuisition[:ATTRibutes]?

[CONFigure:]ACQuisition:SCOunt:MAXimum?

[CONFigure:]ARM:SOURce

[CONFigure:]ARM:SOURce?

[CONFigure:]ARM:SOURce:TIMer

[CONFigure:]ARM:SOURce:TIMer?

[CONFigure:]CHANnel[:ATTRibutes]

[CONFigure:]CHANnel[:ATTRibutes]?

[CONFigure:]CHANnel:PROTection[:RELay]

[CONFigure:]CHANnel:PROTection[:RELay]?

[CONFigure:]EXTernal[:INPut]

[CONFigure:]EXTernal[:INPut]?

[CONFigure:]EXTernal:TRIGger:OUTPut

[CONFigure:]EXTernal:TRIGger:OUTPut?

[CONFigure:]ROSCillator

[CONFigure:]ROSCillator?

[CONFigure:]TRIGger:SOURce

[CONFigure:]TRIGger:SOURce?

[CONFigure:]TRIGger:SOURce:CHANnel?

[CONFigure:]TRIGger:SOURce:CHANnel:EDGE

[CONFigure:]TRIGger:SOURce:CHANnel:EDGE?

[CONFigure:]TRIGger:SOURce:CHANnel:OFF

[CONFigure:]TRIGger:SOURce:CHANnel:WINDow

[CONFigure:]TRIGger:SOURce:CHANnel:WINDow?

[CONFigure:]TRIGger:TIMestamp[:MODE]

[CONFigure:]TRIGger:TIMestamp[:MODE]?


[CONFigure:]ACQuisition[:ATTRibutes]

Syntax

[CONFigure:]ACQuisition[:ATTRibutes] <sample_rate>[, <samples_per_record> [,<pre-trig_samples_per_record> [,<num_records> [,<trigger_holdoff> [,<trigger_delay>]]]]]

[CONFigure:]ACQuisition[:ATTRibutes]?

Individual short form commands are provided to set the individual attributes (parameters). These commands are described for each of the parameters below.

Description

The long form command, as shown above, configures all non-channel-specific acquisition parameters at once, including sampling rates, delays and memory allocation. The query returns all of the parameters listed above.

The individual short form commands can be used to specify a single parameter, or query a single parameter, as described under "Parameters" below.

Parameters

Sample Rate ( [CONFigure:]ACQuisition:SRATe )

This parameter sets the sample rate for the digitizer in units of samples per second.

Name Type Range of Values Default Value
<sample_rate> Numeric

This supports ranges in the 1, 2, 5 pattern from 1000 to 20000000 samples per second. Specifically, the valid values are:

1000

2000

5000

10000

20000

50000

100000

200000

500000

1000000

2000000

5000000

10000000

20000000

Values other than these are rounded up to the nearest one of these values. Values greater than 20000000 produce an error message.

 This is a required parameter.
Short Form Command

The short form command sets the <sample_rate> parameter alone. The query returns the value of only the <sample_rate> parameter:

[CONFigure:]ACQuisition:SRATe <sample_rate>

[CONFigure:]ACQuisition:SRATe?

Examples
CONF:ACQ:SRAT 20.0E+6 | Sets sample rate to 20 MSa/s.
CONF:ACQ:SRAT? | Returns the current sample rate.

Samples per Record ( [CONFigure:]ACQuisition:SCOunt )

This parameter sets the number of samples per record for the digitizer.

Name | Type | Range of Values | Default Value
<samples_per_record> | Numeric | This is the number of samples per record. It must be a multiple of 4 that is at least 8. This number depends on the memory option on your digitizer and the number of records you are acquiring. If you enter an integer that is not a multiple of 4, it will be rounded up to the nearest multiple of 4. | 2048

The minimum value of 8 samples allows for a 200 ns trigger out pulse at the fastest sample rate (at 50% duty cycle).

Use [CONFigure:]ACQuisition:SCOunt:MAXimum? to find the maximum number of samples per record for a specified number of records.

Short Form Command

The short form command sets the <samples_per_record> parameter alone. The query returns the value of only the <samples_per_record> parameter:

[CONFigure:]ACQuisition:SCOunt <samples_per_record>

[CONFigure:]ACQuisition:SCOunt?

Examples
CONF:ACQ:SCO 1000 | Sets the number of samples per record to 1000.
CONF:ACQ:SCO? | Returns the number of samples per record as an integer.

Pre-Trigger Samples Per Record ( [CONFigure:]ACQuisition:SPRetrigger )

This parameter sets the number of pre-trigger samples per record.

Name | Type | Range of Values | Default Value
<pre-trig_samples_per_record> | Numeric | multiple of 4, ranging from 0 to the record size - 4. | 0

The maximum size is 4 less than the record size because the trigger sample must be in the record.

Triggers are ignored until the first set of pre-trigger samples is acquired.

Short Form Command

The short form command sets the <pre-trig_samples_per_record> parameter alone. The query returns the value of only the <pre-trig_samples_per_record> parameter:

[CONFigure:]ACQuisition:SPRetrigger <pre-trig_samples_per_record>

[CONFigure:]ACQuisition:SPRetrigger?

Examples
CONF:ACQ:SPR 1000 | Sets the number of pre-trigger samples per record to 1000.
CONF:ACQ:SPR? | Returns number of pre-trigger samples per record as an integer.

Number of records ( [CONFigure:]ACQuisition:RECords )

This parameter sets the number of records to acquire each time the instrument receives an INITiate command. Each record requires a trigger.

Name | Type | Range of Values | Default Value
<num_records> | Numeric | integer from 1 to 1024, although the dynamic maximum depends on the record size and the memory option on your digitizer. | 1
Short Form Command

The short form command sets the <num_records> parameter alone. The query returns the value of only the <num_records> parameter:

[CONFigure:]ACQuisition:RECords <num_records>

[CONFigure:]ACQuisition:RECords?

Examples
CONF:ACQ:REC 1000 | Sets the number of records to 1000.
CONF:ACQ:REC? | Returns the number of records as an integer.

Trigger Holdoff ( [CONFigure:]ACQuisition:THOLdoff )

Used for multi-record acquisitions, the <trigger_holdoff> is the minimum time following a trigger during which trigger events are ignored. Specify the trigger holdoff in seconds, down to 50 ns resolution. Values that are not multiples of 50 ns are rounded down to the next multiple of 50 ns. If the <trigger_holdoff> is less than the implicit trigger holdoff, the implicit trigger holdoff overrides the <trigger_holdoff>. The implicit trigger holdoff is the sum of the <trigger_delay> and the post-trigger acquisition and re-arm time. The re-arm time is less than 300 ns.

Name | Type | Range of Values | Default Value
<trigger_holdoff> | Numeric | 0 to 10 seconds | 0
Short Form Command

The short form command sets the <trigger_holdoff> parameter alone. The query returns the value of only the <trigger_holdoff> parameter:

[CONFigure:]ACQuisition:THOLdoff <trigger_holdoff>

[CONFigure:]ACQuisition:THOLdoff?

Examples
CONF:ACQ:THOL 1 | Sets the trigger holdoff to 1 second.
CONF:ACQ:THOL? | Returns the trigger holdoff in seconds (for example, "+1.000000E+00").

Trigger Delay ( [CONFigure:]ACQuisition:TDELay )

The <trigger_delay> is the time following a trigger event before the trigger sample is acquired. The <trigger_delay> is specified in seconds, down to the sample frequency. Values that are not multiples of the sample frequency are rounded down to the next multiple of the sample frequency. For example, if the sample frequency is 2000 samples per second, trigger delays will always be multiples of 500 microseconds, which is 1/2000 of a second.

The <trigger_delay> time immediately follows the Trigger Latency period that separates the trigger event from the next user sample.

Name | Type | Range of Values | Default Value
<trigger_delay> | Numeric | 0 to 3600 seconds | 0
Short Form Command

The short form command sets the <trigger_delay> parameter alone. The query returns the value of only the <trigger_delay> parameter:

[CONFigure:]ACQuisition:TDELay <trigger_delay>

[CONFigure:]ACQuisition:TDELay?

Examples
CONF:ACQ:TDEL 10 | Sets the trigger delay to 10 seconds.
CONF:ACQ:TDEL? | Returns the offset (for example, "+1.000000E+01").

Remarks

  • Use the long form command to configure all acquisition parameters simultaneously.
  • Use the appropriate short form command to set an individual parameter by itself.
  • If <trigger_delay> and <trigger_holdoff> are both greater than zero, <trigger_delay> is the only one that affects the first record.
  • For records after the first, the <trigger_delay> period follows the trigger event, which in turn must follow the <trigger_holdoff>.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Return Format

The complete query command returns all acquisition parameters. The short form queries return only the specified parameter, as described above.

Examples

The following command configures acquisition for the digitizer, setting the sample rate to 20 MSa/s, 12 samples per record, 8 pre-trigger samples, 3 records, a zero trigger holdoff, and a trigger delay of 10 seconds.

CONF:ACQ 2.0E+07, 12, 8, 3, 0, 10

The following query returns the current parameters.

CONF:ACQ?

Typical Response: +20000000, +12, +8, +3, +0.00000000E+000, +1.00000000E+001

The following query returns the current value of the <sample_rate> parameter.

CONF:ACQ:SRAT?

Typical Response: +20000000

The following commands set and return the <samples_per_record> parameter. Note that the two numbers are different because the SCOunt is rounded up to the nearest multiple of 4.

CONF:ACQ:SCO 820082
CONF:ACQ:SCO?

Typical Response: +820084

The following commands set and return the <pre-trig_samples_per_record> parameter. This value is also rounded up to the nearest multiple of 4.

CONF:ACQ:SPR 30387
CONF:ACQ:SPR?

Typical Response: +30388

The following commands set and return the <num_records> parameter.

CONF:ACQ:REC 11
CONF:ACQ:REC?

Typical Response: +11

The following commands set and return the <trigger_holdoff> parameter.

CONF:ACQ:THOL 5
CONF:ACQ:THOL?

Typical Response: +5.00000000E+000

The following commands set and return the <trigger_delay> parameter.

CONF:ACQ:TDEL 1800
CONF:ACQ:TDEL?

Typical Response: +1.80000000E+003

See Also

CONFigure Subsystem Introduction

CONFigure:CHANnel[:ATTRibutes]

[CONFigure:]ACQuisition:SCOunt:MAXimum?


[CONFigure:]ACQuisition:SCOunt:MAXimum?

Syntax

[CONFigure:]ACQuisition:SCOunt:MAXimum? [<num_records>]

Description

This query returns the maximum number of samples per record allowed for the specified number of records. The maximum number of samples depends on the memory option that is installed in your digitizer. For option 001, the number is 32 MSa, and for option 002, the number is approximately 128 MSa.

Parameters

Name Type Range of Values Default Value
<num_records> Numeric

An integer from 1 to 1024 that indicates the number of records to be acquired.

 1

Return Format

The query returns the maximum sample count per record as an integer. Here is the procedure the software uses to determine the maximum sample count for a given number of records.

  1. Start with the memory size in samples: either 33,554,432 (standard memory) or 134,205,440 (extended memory). Note that the extended memory option contains slightly less than 227 bytes because of overhead associated with record management.
  2. Divide by the number of records.
  3. If the number is not a multiple of 4, round down to the nearest multiple of 4.

Examples

The following query returns the maximum sample count per record for 500 records.

CONF:ACQ:SCO:MAX? 500

Typical Response (standard memory): +67108
Typical Response (extended memory): +268408

See Also

CONFigure Subsystem Introduction

[CONFigure:]ACQuisition[:ATTRibutes]


[CONFigure:]ARM:SOURce

Syntax

[CONFigure:]ARM:SOURce <source>[,<triggers_per_arm>]

[CONFigure:]ARM:SOURce?

Description

This command configures the source for arming the digitizer.

Parameters

Name | Type | Range of Values | Default Value
<source> Discrete

{IMMediate|EXTernal|SOFTware|TIMer}

 This is a required parameter. The reset value is IMMediate.
<triggers_per_arm> | Numeric | Integer number of triggers that will occur before the instrument waits for the next arm, from 1 to 1024 | 1024

Remarks

  • The number of triggers per ARM may exceed the configured number of records, so no settings conflict will result. In this case, the TRIGger/ARM algorithm ends digitizing before a second ARM occurs.
  • Setting the <source> to IMMEdiate arms the digitizer immediately after INITiate.
  • Setting the <source> to EXTernal arms the digitizer upon receiving an external arm through the Trig In/Out connector.
  • Setting the <source> to SOFTware arms the digitizer when the command ARM[:IMMediate] is issued.
  • Setting the <source> to TIMer causes the software to start a timer whenever the trigger returns to the Waiting for Arm state. The digitizer is then armed when the timer runs out. The duration of the timer is set by the [CONFigure:]ARM:SOURce:TIMer command.
  • Arming is a possible source of a settings conflict. The arm source may not be configured to EXTernal while the trigger source ([CONFigure:]TRIGger:SOURce) is configured to either EXT or OR. Therefore, if you change the trigger to EXTernal or OR when arming is set to EXTernal, the arming source will be changed to IMMediate. Similarly, if you change an arm to EXTernal when a trigger is already set to EXTernal, the instrument will produce an error message and deny the change.

Return Format

The query form of the command returns <source>,<triggers>.

Examples

The following command configures the arm source for 20 external triggers.

CONFigure:ARM:SOURce EXT,20

The following query returns the current parameters for the arm source.

CONF:ARM:SOUR?

Typical Response: EXT,+20

See Also

CONFigure Subsystem Introduction

CONFigure:CHANnel

[CONFigure:]TRIGger:SOURce

ARM[:IMMediate]

[CONFigure:]EXTernal[:INPut]


[CONFigure:]ARM:SOURce:TIMer

Syntax

[CONFigure:]ARM:SOURce:TIMer <time>

[CONFigure:]ARM:SOURce:TIMer?

Description

This command specifies the time interval used when the [CONFigure:]ARM:SOURce is set to TIMer. The timer causes the arm to delay for <time> seconds each time the digitizer returns to the state where it is waiting for an arm.

Parameters

Name | Type | Range of Values | Default Value
<time> | Numeric | This can be from 0 to 3600 seconds, with resolution down to 50 ns. | This is a required parameter.

Remarks

  • The <time> parameter is rounded down to the nearest value that is a multiple of 50 nanoseconds.

Return Format

The number of seconds is returned as a floating point value.

Examples

The following command executes an arm every 5 seconds.

CONF:ARM:SOURce:TIMer 5

The following query returns the arm frequency in seconds.

CONF:ARM:SOURce:TIMer?

Typical response: +5.00000000E+000

See Also

CONFigure Subsystem Introduction

[CONFigure:]ARM:SOURce


[CONFigure:]CHANnel[:ATTRibutes]

Syntax

[CONFigure:]CHANnel[:ATTRibutes] (@<chan_list>), <range> [,<coupling> [,<filter>]]

[CONFigure:]CHANnel[:ATTRibutes]? (@<chan_list>)

Individual short form commands are provided to set the individual attributes (parameters). These commands for each parameter are described below.

Description

This command configures all parameters associated with the specified channel list, with the exception of triggering. The query returns all parameters for the specified channel list, except triggering.

The individual short form commands can be used to specify a single parameter, or query a single parameter, as described under "Parameters" below.

Parameters

Channel List

Specify the channel or channels which the commands should affect.

Name Type Range of Values Default Value
<chan_list> Channel list

One or more channels, specified as in the following examples.

(@2) - channel 2

(@1,4) - channels 1 and 4

(@1:4) - channels 1 through 4.

 This is a required parameter.

Range ( [CONFigure:]CHANnel:RANGe )

Select the voltage range for the specified channel. If you specify a number greater than the largest value (256), the digitizer will return an error. If you specify a number that is less than the smallest value (0.25) or between two valid values, the software will round the range upward to the smallest valid value greater than the one you specified.

Name Type Range of Values Default Value
<range> Numeric

Desired range in volts:

0.25
0.5
1
2
4
8
16
32
64
128
256

This is a required parameter.

The reset value is 256 V.
Short Form Command

The short form command sets the <range> parameter alone. The query returns it:

[CONFigure:]CHANnel:RANGe (@<chan_list>), <range>

[CONFigure:]CHANnel:RANGe? (@<chan_list>)

Examples
CONF:CHAN:RANG (@2), 1 | Sets channel 2 range to 1 volt.
CONF:CHAN:RANG? (@2) | Returns the range for channel 2.

Coupling ( [CONFigure:]CHANnel:COUPling )

Select AC or DC coupling for the specified channel.

Name Type Range of Values Default Value
<coupling> Discrete

{AC|DC}

 DC
Short Form Command

The short form command sets the <coupling> parameter alone. The query returns it:

[CONFigure:]CHANnel:COUPling (@<chan_list>), <coupling>

[CONFigure:]CHANnel:COUPling? (@<chan_list>)

Examples
CONF:CHAN:COUP (@2), DC | Sets channel 2 coupling to "DC".
CONF:CHAN:COUP? (@2) | Returns the coupling setting for channel 2.

Filter ( [CONFigure:]CHANnel:FILTer )

Specify the appropriate digital filter for the specified channel. There are two low-pass filters available, one for 2 MHz, and one for 200 KHz. The LP_20_MHZ option is equivalent to no filtering.

Name Type Range of Values Default Value
<filter> Discrete

A filter type, one of the following choices:

LP_20_MHZ
LP_2_MHZ
LP_200_KHZ

 LP_20_MHZ
Short Form Command

The short form command sets the <filter> parameter alone. The query returns it:

[CONFigure:]CHANnel:FILTer (@<chan_list>), <filter>

[CONFigure:]CHANnel:FILTer? (@<chan_list>)

Examples
CONF:CHAN:FILT (@2), LP_20_MHZ | Sets the filter for channel 2 to 20 MHz.
CONF:CHAN:FILT? (@2) | Returns the filter setting for channel 2.

Remarks

  • Use the full syntax, long form command to improve performance by configuring the entire channel with a single command.
  • Use the appropriate short form command to set an individual parameter by itself.
  • The query form of the command always returns the parameters in ascending channel order. For example, if you use the <chan_list> (@4,2,3), the parameters will still be returned as though you had entered (@2:4). You may wish to query channels individually or enter channels in ascending order to avoid confusion.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Return Format

The complete query command returns all attributes for the specified channel or channels. The short form queries return only the specified parameter. The following table shows several examples of returned values for specific commands.

Command | Returns
CONF:CHAN:ATTR? (@1) | +2.500000E-01,AC,LP_2_MHZ
CONF:CHAN:RANG? (@1:3) | +5.000000E-01,+1.000000E+00,+2.000000E+00
CONF:CHAN:COUP? (@1,4) | AC,DC
CONF:CHAN:FILT? (@1,3) | LP_20_MHZ,LP_200_KHZ

Examples

The following command configures channel 1 for the 0.25 V range, DC coupling and a 20 MHz filter.

CONF:CHAN:ATTR (@1), 0.25, DC, LP_20_MHZ

The following query returns the attributes for channel 1.

CONF:CHAN:ATTR? (@1)

Typical Response: +2.500000E-01,DC,LP_20_MHZ

The following query returns the attributes for three channels.

CONF:CHAN:ATTR? (@1:3)

Typical Response: +2.500000E-01,DC,LP_20_MHZ,+5.000000E-01,AC,LP_20_MHZ,+8.000000E+00,AC,LP_2_MHZ

The following query returns the range for channel 1.

CONF:CHAN:RANG? (@1)

Typical Response: +2.500000E-01

The following query returns the coupling for channels 1, 3 and 4.

CONF:CHAN:COUP? (@1,3,4)

Typical Response: DC,AC,DC

The following query returns the filter settings for channels 2 through 4.

CONF:CHAN:FILT? (@2:4)

Typical Response: LP_2_MHZ,LP_200_KHZ,LP_20_MHZ

See Also

CONFigure Subsystem Introduction

[CONFigure:]ACQuisition[:ATTRibutes]

CONFigure:ACQuisition


[CONFigure:]CHANnel:PROTection[:RELay]

Syntax

[CONFigure:]CHANnel:PROTection[:RELay] (@<chan_list>), <mode>

[CONFigure:]CHANnel:PROTection[:RELay]? (@<chan_list>)

Description

This command allows you to control the input protection relay for the specified channel or channels. When the protection relay is OFF, the channel is connected to the input BNC connector. Turning the protection relay ON disconnects a channel from the input BNC connector and protects that input channel from voltages that may cause damage.

Parameters

Name Type Range of Values Default Value
<chan_list> Channel list

One or more channels, specified as in the following examples.

(@2) - channel 2

(@1,4) - channels 1 and 4

(@1:4) - channels 1 through 4.

 This is a required parameter.
<mode> Boolean {OFF|0|ON|1} This is a required parameter.

The reset value is OFF.

Remarks

  • The overvoltage protection relay is used only on channels configured for ranges of 0.25, 0.5, 1 and 2 volts. Channel overvoltage protection automatically turns the input protection relay ON in the event of an overvoltage, which typically occurs between 11 and 14 volts.
  • Channels configured to ranges over 2 V never engage the overvoltage protection relay. Instead, the channels are designed to handle up to 400 V. Voltages beyond 400 V may damage the instrument. In the event that you apply a voltage over 400 V for a very short time without damaging the instrument, you should re-calibrate the instrument.
  • You would typically turn input protection OFF after an overvoltage event. Of course, you would first clear the cause of the overvoltage.
  • The query form of the command always returns the parameters in ascending channel order. For example, if you use the <chan_list> (@4,2,3), the parameters will still be returned as though you had entered (@2:4). You may wish to query channels individually or enter channels in ascending order to avoid confusion.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Return Format

The query form of the command returns a comma delimited list. Each item is 0 or 1, with one value for each channel in the <chan_list>. The value 0 indicates OFF, and the value 1 indicates ON. The values are always listed in ascending order by channel number, regardless of the order specified in <chan_list>.

Examples

The following command turns the input protection relay off for channels 1 and 3. This is the state used for normal operation of the digitizer.

CONF:CHAN:PROT (@1,3),OFF

The following query returns the current channel protection relay value for all four channels. In this case, it shows that the protection relay is on only for channels 2 and 3.

CONF:CHAN:PROT? (@1:4)

Typical Response: 0,1,1,0

See Also

CONFigure Subsystem Introduction

[CONFigure:]CHANnel[:ATTRibutes]


[CONFigure:]EXTernal[:INPut]

Syntax

[CONFigure:]EXTernal[:INPut] <slope>

[CONFigure:]EXTernal[:INPut]?

Description

Configures the slope of the EXTernal trigger input BNC signal (Trig In/Out ) that will cause either an arm or a trigger. You can configure the slope to be either a POSitive (rising) or NEGative (falling) edge.

Parameters

Name Type Range of Values Default Value
<slope> Discrete {POSitive|NEGative} This is a required parameter.

The reset value is POSitive.

Remarks

  • The command is not specific to either the ARM or TRIGger because the external Trig In/Out may be selected as an arm source or a trigger source.
  • The external input edge is ignored unless [CONFigure:]TRIGger:SOURce is set to EXT or OR.

Return Format

The query returns either POS or NEG.

Examples

The following command configures a negative slope for external inputs.

CONF:EXTernal:INPut NEG

The following query returns the external input slope.

CONF:EXT:INPut?

Typical Response: NEG

See Also

CONFigure Subsystem Introduction

[CONFigure:]EXTernal:TRIGger:OUTPut

[CONFigure:]TRIGger:SOURce

[CONFigure:]ARM:SOURce


[CONFigure:]EXTernal:TRIGger:OUTPut

Syntax

[CONFigure:]EXTernal:TRIGger:OUTPut <event>,<drive_mode>

[CONFigure:]EXTernal:TRIGger:OUTPut?

Description

This command configures the drive characteristics of the external trigger port the Trig In/Out BNC connector.

Parameters

Name Type Range of Values Default Value
<event> Discrete

{TRIGger|RECord|ACQuisition|NONE}

TRIGger specifies that each record's TRIGger event will cause an output pulse.

RECord specifies that each completed record will cause an output pulse.

ACQuisition specifies that a single output pulse will be generated when acquisition completes.

NONE specifies that no output pulse is to be generated.

This is a required parameter.

The reset value is NONE.
<drive_mode> Discrete

{POS_50|NEG_50|POS_25_W_OR|OFF}

POS_50 specifies a positive TTL pulse capable of driving a 50 ohm impedance bus. The inactive state provides a 50 ohm drive to logic low, suitable for termination of wired-OR trigger bus operation.

NEG_50 specifies a negative TTL pulse capable of driving a 50 ohm impedance bus. The inactive state provides a 50 ohm drive to logic high.

POS_25_W_OR specifies a positive TTL drive to a 25 ohm load for wired-OR trigger bus use. The driver goes into tri-state mode at the end of the pulse; the wired-OR bus is responsible for the falling edge.

OFF specifies tri-state output behavior. This can only be used if <event> is NONE.

 This is a required parameter.

The reset value is OFF.

Remarks

  • If the <event> is set to ACQ or the record duration is at least 2 microseconds, then the pulse is set to 1 microsecond. If the record duration is less than 2 microseconds, the pulse is 200 nanoseconds. This guarantees that events do not collide on a single pulse with 50% trigger out duty cycle.
  • The OFF <drive_mode> is allowed only when the <event> is NONE.
  • The *RST command sets the default state of <event> to NONE and <drive_mode> to OFF.

Return Format

The query form of the command returns <event>,<drive_mode>. The <event> may be TRIGger, RECord, ACQuisition, or NONE. The <drive_mode> may be NEG_50, POS_50, POS_25_W_OR, or OFF.

Examples

The following command configures trigger output for a positive TTL pulse capable of driving a 50 ohm impedance bus.

CONF:EXT:TRIG:OUTP TRIGger,POS_50

The following command disables output pulses.

CONF:EXT:TRIG:OUTP NONE, OFF

The following query returns the current parameters.

CONF:EXT:TRIG:OUTPut?

Typical Response: TRIG,POS_50

See Also

CONFigure Subsystem Introduction

[CONFigure:]EXTernal[:INPut]


[CONFigure:]ROSCillator

Syntax

[CONFigure:]ROSCillator {INTernal|EXTernal}

[CONFigure:]ROSCillator?

Description

This command sets the reference oscillator to an internal or external source.

The query form of this command returns the source of the reference oscillator.

Remarks

  • The power-on default value is INTernal.
  • If the CONF:ROSC EXTernal command is executed without a valid external reference, this command will dispatch an error and the reference will be returned to INTernal.
  • If the CONF:ROSC EXTernal command is executed with a valid external reference, but the reference becomes unlocked, the digitizer will dispatch an error and return the reference to INTernal.
  • This command is useful when you are attempting to phase lock multiple digitizers together. The query is useful because it allows you to verify the source to which each digitizer's reference oscillator is locked (INTernal or EXTernal). This allows you to validate the reference clock topology of your system.

Return Format

The query returns INT or EXT.

Example

The following command sets the reference oscillator to an external source. It would be a good practice to follow this command with a SYSTem:ERRor? query to ensure that the command did not produce an error message.

CONF:ROSC EXTernal

The following query indicates that the reference oscillator is locked to the external input.

ROSC?

Typical Response: EXTernal

See Also

CONFigure Subsystem Introduction

STATus:QUEStionable:CONDition?

STATus:QUEStionable:ENABle

STATus:QUEStionable:EVENt?


[CONFigure:]TRIGger:SOURce

Syntax

[CONFigure:]TRIGger:SOURce <source>

[CONFigure:]TRIGger:SOURce?

Description

This command configures which sources can cause a trigger event.

Parameters

Name Type Range of Values Default Value
<source> String {IMMediate|SOFTware|EXTernal|CHANnel|OR} This is a required parameter.

The reset state is IMMediate.

Remarks

  • This is the only way to select a trigger source. The user can use [CONFigure:]TRIGger:SOURce:CHANnel:EDGE and [CONFigure:]TRIGger:SOURce:CHANnel:WINDow to configure how channel triggers behave, but they do not become active until you explicitly activate them with this command.
  • The reset state of <source> of IMMediate causes all wait-for-trigger states to be automatically triggered.
  • If the <source> is SOFTware, then at INITiate after the ARM condition is met, the digitizer will not respond to any triggers other than software triggers. Software triggers include the TRIGger:IMMediate command, the *TRG command, and the IEEE 488.2 GET command.
  • If the <source> is EXTernal, then at INITiate after the arm condition is met, the digitizer will remain in the Waiting for Trigger state until the rear panel Trig In/Out BNC connector receives a satisfactory TTL trigger, at which point the digitizer starts post-trigger digitizing.
  • If the <source> is CHANnel, then at INITiate after the ARM condition is met, the digitizer will wait until any enabled channel trigger condition ([CONFigure:]TRIGger:SOURce:CHANnel:EDGE or [CONFigure:]TRIGger:SOURce:CHANnel:WINDow) is satisfied before post-trigger digitizing.
  • If the <source> is OR, then at INITiate after the ARM condition is met, the digitizer will begin digitizing if any enabled channel trigger condition is satisfied, or if the rear panel Trig In/Out BNC connector receives a TTL trigger.
  • A channel can be configured with [CONFigure:]TRIGger:SOURce:CHANnel:EDGE or [CONFigure:]TRIGger:SOURce:CHANnel:WINDow, and different channels may have different trigger configurations. You may disable individual channels from triggering by using [CONFigure:]TRIGger:SOURce:CHANnel:OFF.
  • Arming is a possible source of a settings conflict. The arm source may not be configured to EXTernal while the trigger source ([CONFigure:]TRIGger:SOURce) is configured to either EXT or OR. Therefore, if you change the trigger to EXTernal or OR when arming is set to EXTernal, the arming source will be changed to IMMediate. Similarly, if you change an arm to EXTernal when a trigger is already set to EXTernal, the instrument will produce an error message and deny the change.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Return Format

The query form of the command returns IMM, SOFT, EXT, CHAN, or OR.

Examples

The following command sets the trigger source to SOFTware.

CONF:TRIG:SOUR SOFT

The following query returns the name of the configured trigger source.

CONF:TRIG:SOUR?

Typical Response: SOFT

See Also

CONFigure Subsystem Introduction

[CONFigure:]TRIGger:SOURce:CHANnel?

[CONFigure:]TRIGger:SOURce:CHANnel:EDGE

[CONFigure:]TRIGger:SOURce:CHANnel:WINDow

[CONFigure:]TRIGger:SOURce:CHANnel:OFF


[CONFigure:]TRIGger:SOURce:CHANnel?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

[CONFigure:]TRIGger:SOURce:CHANnel? (@<chan_list>)

Description

This query returns the EDGE, WINDow, or OFF channel trigger configuration for each channel in the <chan_list>.

Parameters

Name Type Range of Values Default Value
<chan_list> Channel list

One or more channels, specified as in the following examples.

(@2) - channel 2

(@1,4) - channels 1 and 4

(@1:4) - channels 1 through 4.

 This is a required parameter.

Remarks

  • Only the query form exists for this command. The actual selection of a channel's CHANnel trigger (EDGe, WINDow, or OFF) is done by the related CONF:TRIG:SOUR:CHAN:EDGE, CONF:TRIG:SOUR:CHAN:WIND, and CONF:TRIG:SOUR:CHAN:OFF commands.
  • Following a power-up, or after a *RST, all channels will be OFF.
  • Channels configured with EDGE or WINDow trigger actions are active only when CONF:TRIG:SOUR CHAN or CONF:TRIG:SOUR OR is configured.

Return Format

This query returns a comma-delimited list of EDGE, WIND, or OFF for each channel. These are listed in ascending channel order, regardless of the order in which channels are listed in the <chan_list> parameter.

Example

The following query returns the trigger sources of channels 1 and 3.

CONF:TRIG:SOUR:CHAN? (@1,3)

Typical Response: EDGE,WIND

See Also

CONFigure Subsystem Introduction

[CONFigure:]TRIGger:SOURce

[CONFigure:]TRIGger:SOURce:CHANnel:WINDow

[CONFigure:]TRIGger:SOURce:CHANnel:EDGE

[CONFigure:]TRIGger:SOURce:CHANnel:OFF


[CONFigure:]TRIGger:SOURce:CHANnel:EDGE

Syntax

[CONFigure:]TRIGger:SOURce:CHANnel:EDGE (@<chan_list>),<level>[,<slope>[,<hysteresis>]]

[CONFigure:]TRIGger:SOURce:CHANnel:EDGE? (@<chan_list>)

Description

This command configures EDGE trigger attributes for the channels in the <chan_list>. To enable a configured channel trigger to generate an actual digitizer trigger, you must use CONF:TRIG:SOUR to configure CHANnel (or OR) as the trigger source.

Parameters

Name | Type | Range of Values | Default Value

<chan_list>

 Channel list

One or more channels, specified as in the following examples.

(@2) - channel 2

(@1,4) - channels 1 and 4

(@1:4) - channels 1 through 4.

 This is a required parameter.
<level> Numeric The absolute value (in volts) of the <level>, plus the <hysteresis> multiplied by the <range>, must be less than 95% of the channel's <range>. This is a required parameter.

The reset value is 0.
<slope> | Discrete | {POSitive|NEGative} | POSitive
<hysteresis> | Numeric | 0 to 100 (percent of range) | 2 (percent of range)

Remarks

  • By configuring a channel's edge trigger, you implicitly de-select the other channel trigger types (WINDow or OFF).
  • Hysteresis has two effects with EDGE triggers:
    • Rising slope triggers: The signal must ascend across the hysteresis level below the trigger level to qualify as a trigger event.
    • Falling slope triggers: The signal must descend across the hysteresis level above the trigger to qualify as a trigger event.
  • The trigger level must not exceed 95% of the <range>. The resulting hysteresis voltage must not exceed the <range>. If you issue a command that violates either of these rules, the digitizer will create an error message.
  • Reconfiguring the channel range can cause settings conflicts with attributes set by this command. For example, you could have a conflict between certain combinations of channel range, trigger level, and trigger hysteresis. If a channel range change causes the <level> to exceed 95% of the range or the <hysteresis> to exceed the range, then the trigger <level> is set to 0 V and the digitizer dispatches a settings conflict error.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Return Format

The query returns a comma-separated list of <level>,<slope>, and <hysteresis> for each channel in the <chan_list>.

The query form of the command always returns the parameters in ascending channel order. For example, if you use the <chan_list> (@4,2,3), the parameters will still be returned as though you had entered (@2:4). You may wish to query channels individually or enter channels in ascending order to avoid confusion.

If edge triggering is not configured for a channel in the query, the query will return the current values for the <level> and <hysteresis>. If these have not been set, it will return the default values.

Examples

The following command configures channels 1, 3, and 4 for edge triggering with positive slope, level 10 V, and hysteresis equal to 5 percent of the range. The second command configures channel 2 with different parameters.

CONFigure:TRIGger:SOURce:CHANnel:EDGE (@1,3,4),10,POS,5.0
CONFigure:TRIGger:SOURce:CHANnel:EDGE (@2),8,NEG,10.0

This query returns the attributes of channels 1 through 3:

CONF:TRIG:SOUR:CHAN:EDGE? (@1:3)

Typical Response: +1.000000E+01,POS,+5.000000E+00,+8.000000E+00,NEG,+1.000000E+01,+1.000000E+01,POS,+5.000000E+00

See Also

CONFigure Subsystem Introduction

[CONFigure:]TRIGger:SOURce

[CONFigure:]TRIGger:SOURce:CHANnel?

[CONFigure:]TRIGger:SOURce:CHANnel:WINDow

[CONFigure:]TRIGger:SOURce:CHANnel:OFF


[CONFigure:]TRIGger:SOURce:CHANnel:OFF

Syntax

[CONFigure:]TRIGger:SOURce:CHANnel:OFF [(@<chan_list>)]

Description

This command disables triggering on the specified channels. This command is related to CONF:TRIG:SOUR:CHAN:EDGE and CONF:TRIG:SOUR:CHAN:WINDow, and is the only way to turn off triggering on a channel-by-channel basis.

Parameters

Name Type Range of Values Default Value
<chan_list> Channel list

One or more channels, specified as in the following examples.

(@2) - channel 2

(@1,4) - channels 1 and 4

(@1:4) - channels 1 through 4.

 (@1:4)

Remarks

  • You can disable channel triggering on all channels by using the [CONFigure:]TRIGger:SOURce and setting the <source> to IMMediate, SOFTware, or EXTernal.
  • If a channel is not set to [CONFigure:]TRIGger:SOURce:CHANnel:OFF, you must use [CONFigure:]TRIGger:SOURce set to CHAN or OR to enable those configured channels to serve as a trigger source.
  • The *RST command returns all channel triggers to the OFF state.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Examples

The following command turns triggering off for all four channels.

CONFigure:TRIGger:SOURce:CHANnel:OFF (@1:4)

The following command turns triggering off for channels 1 and 3.

CONFigure:TRIGger:SOURce:CHANnel:OFF (@1,3)

See Also

CONFigure Subsystem Introduction

[CONFigure:]TRIGger:SOURce

[CONFigure:]TRIGger:SOURce:CHANnel?

[CONFigure:]TRIGger:SOURce:CHANnel:WINDow

[CONFigure:]TRIGger:SOURce:CHANnel:EDGE


[CONFigure:]TRIGger:SOURce:CHANnel:WINDow

Syntax

[CONFigure:]TRIGger:SOURce:CHANnel:WINDow (@<chan_list>),<level_low>,<level_high>[,<direction>[,<hysteresis>]]

[CONFigure:]TRIGger:SOURce:CHANnel:WINDow? (@<chan_list>)

Description

This command configures WINDow trigger attributes for the specified <chan_list>. A WINDow trigger specifies a voltage region within the channel's voltage range where a trigger is generated when the signal enters or leaves the window boundaries. To enable a configured CHANnel trigger to generate an actual instrument trigger, use CONF:TRIG:SOUR to configure CHANnel (or OR) as the trigger source.

Parameters

Name | Type | Range of Values | Default Value
<chan_list> | Channel list | One or more channels, specified as in the following examples. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:4) - channels 1 through 4. | This is a required parameter.
<level_low> | Numeric | A voltage between -95% of the range and 95% of the range. Of course, <level_low> must not exceed <level_high>. | This is a required parameter. The reset value is 0.
<level_high> | Numeric | A voltage between -95% of the range and 95% of the range. Of course, <level_high> must not be less than <level_low>. | This is a required parameter. The reset value is 0.
<direction> | Discrete | {ENTering|LEAVing} | ENTering
<hysteresis> | Numeric | A percentage of the range. Multiplying the range by the <hysteresis>, we get a hysteresis voltage, which we refer to as VHyst. If the <direction> is set to ENTering, then |<level_low> - VHyst| < range and |<level_high> + VHyst| < range If the <direction> is set to LEAVing, then |<level_low> + VHyst| < range and |<level_high> - VHyst| < range | 2% of range

Remarks

  • By configuring a channel's window trigger, you implicitly de-select the other channel trigger types (EDGE or OFF).
  • The boundaries of the window may be the same, causing trigger events on a single level with either rising or falling edges.
  • The <hysteresis> parameter is common to both window edges. For rising slope triggers, the signal must ascend across the hysteresis level below the trigger level to qualify as a trigger event. For falling slope triggers, the signal must descend across the hysteresis level above the trigger to qualify as a trigger event.
  • The <level_low> and <level_high> must not exceed 95% of the current channel range, and the resulting hysteresis voltage must not exceed the channel range.
  • Other commands can cause settings conflicts with attributes set by this command. For example, you could have a conflict between certain combinations of channel range, trigger level, and trigger hysteresis.
  • Settings conflicts can result if the channel range is changed. If the <level_low> is less than 5% of the range, the <level_high> is more than 95% of the range, or either of these levels combines with the <hysteresis> to go out of the range, then the digitizer dispatches an error message and both <level_low> and <level_high> are set to 0 V.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Return Format

The query returns a comma-separated list of <level_low>,<level_high>,<direction>, and <hysteresis> for each channel in the <chan_list>.

Examples

The following command configures the window triggering parameters for all four channels.

CONFigure:TRIGger:SOUR:CHAN:WIND (@1:4),20,80,ENT,5

The following query returns the window triggering parameters on channel 1.

CONF:TRIG:SOUR:CHAN:WIND? (@1)

Typical Response: +2.000000E+01,+8.000000E+01,ENT,+5.000000E+00

The following query returns the window triggering parameters on channels 1 and 3.

CONF:TRIG:SOUR:CHAN:WIND? (@1,3)

Typical Response: +2.000000E+01,+8.000000E+01,ENT,+5.000000E+00,+3.250000E+01,+9.000000E+01,LEAV,+6.000000E+00

See Also

CONFigure:CHANnel

CONFigure Subsystem Introduction


[CONFigure:]TRIGger:TIMestamp[:MODE]

Syntax

[CONFigure:]TRIGger:TIMestamp[:MODE] <counter_mode>

[CONFigure:]TRIGger:TIMestamp[:MODE]?

Description

This command specifies whether the digitizer's timestamp counter runs continuously or is cleared at each INITiate command.

Parameters

Name Type Range of Values Default Value
<counter_mode> Discrete {INITiate | CONTinuous} This is a required parameter.

The reset value is INITiate.

Remarks

  • The resolution of the timestamp clock is 12.5 nanoseconds. Timestamps mark the time of a trigger event for each sampled record, and you can query for them using the FETCh commands.
  • If the <counter_mode> is INITiate, the timestamp counter is zeroed by the INITiate command.
  • If the <counter_mode> is CONTinuous, the timestamp counter is zeroed by this command and then runs continuously afterward.
  • Setting <counter_mode> to CONTinuous is useful when you are synchronizing multiple L4532A/34A digitizers via SYSTem:SYNChronize:EXTernal, where the timestamp is set to zero synchronously across multiple L4532A/34A digitizers.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Return Format

The query returns either CONT or INIT.

Examples

The following command specifies that the timestamp counter is to be zeroed by the INITiate command.

CONF:TRIG:TIM:MODE INIT

The following query returns the digitizer's timestamp counter mode.

CONF:TRIG:TIM:MODE?

Typical Response: INIT

See Also

CONFigure Subsystem Introduction

SYSTem:SYNChronize:EXTernal


DISPlay Subsystem Introduction

Command Summary

DISPlay[:STATe]

DISPlay[:STATe]?

DISPlay:TEXT

DISPlay:TEXT?

DISPlay:TEXT:CLEar


DISPlay[:STATe]

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

DISPlay[:STATe] <state>

DISPlay[:STATe]?

Description

This command turns off the display of text both lines of the instrument's display. The exceptions are the error annunciators and any non-empty text strings set by DISPlay:TEXT will continue to appear.

Parameters

Name Type Range of Values Default Value
<state> Boolean

{OFF|0|ON|1}

 This is a required parameter. The reset value is ON.

Remarks

  • The display state is not stored in non-volatile memory . When you reboot the instrument, the default state of ON will be restored.

Return Format

The query returns 0 (OFF) or 1 (ON). This indicates the state of the display.

Example

This command turns the instrument's display off.

DISP:STAT 0

This query returns the display's current state. In this case, the display is off.

DISP:STAT?

Typical Response: 0

See Also

DISPlay Subsystem Introduction

DISPlay:TEXT


DISPlay:TEXT

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

DISPLay:TEXT "<string>"

DISPlay:TEXT?

Description

This command displays text on the top line of the instrument's front panel display. There is no command to specify what text should appear on the bottom line of the display.

Parameters

Name Type Range of Values Default Value
<string> String

ASCII text string of up to 12 characters, enclosed in quotation marks. Valid characters include letters, numbers, spaces, dashes and underscores.

 This is a required parameter.

Return Format

The query form returns the <string> that is displayed on the instrument's display, enclosed in quotation marks. If you entered a <string> longer than 12 characters, the string is truncated after the 12th character.

Example

The following command puts the word Digitizer on the instrument's display.

DISPlay:TEXT "Digitizer"

This query returns the <string> being shown on the instrument's display.

DISPlay:TEXT?

Typical Response: "Digitizer"

See Also

DISPlay Subsystem Introduction

DISPlay:TEXT:CLEar


DISPlay:TEXT:CLEar

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

DISPlay:TEXT:CLEar

Description

This command clears the text that was displayed by DISPlay:TEXT on the instrument's front panel display.

Example

The following command clears the text on the instrument's front panel display.

DISP:TEXT:CLEar

See Also

DISPlay Subsystem Introduction

DISPlay[:STATe]

DISPlay:TEXT


FETCh Subsystem Introduction

Command Summary

FETCh:WAVeform:ACQuisition:PREamble?

FETCh:WAVeform:ADC?

FETCh:WAVeform:CHANnel:ERRor?

FETCh:WAVeform:RECord:PREamble?

FETCh:WAVeform:RECord:TIMestamps?

FETCh:WAVeform:VOLTage?


FETCh:WAVeform:ACQuisition:PREamble?

Syntax | Description | Parameters| Remarks | Return Format | Example

Syntax

FETCh:WAVeform:ACQuisition:PREamble?

Description

This query returns the overview of the completion status of acquisition data in the sample memory. After a reset, the latest acquisition data is cleared, and values returned reflect no data. This query is often used in conjunction with the FETCh:WAVeform:RECord:PREamble? query.

Return Format

The standard query returns the following comma-separated list of numbers and discrete values.

Value | Description | Data Format
<last_record_completed>

The number of the last record whose acquisition complete. This is 0 if no record has been completed.

 Unsigned Integer
<last_record_sample_count_completed>

The number of samples completed in the last record with data. An ABORt command can make this less than the number of samples per record specified in [CONFigure:]ACQuisition[:ATTRibutes].

 Unsigned Integer
<all_records_sample_count_completed> | Total count of samples completed on all records. If the acquisition completes normally, this will equal the number of samples per record multiplied by the number of records in the acquisition. | Unsigned Integer
<completion_status>

A status indicator representing how the acquisition completed: {NONE | RUN | NORM | ABOR}.

Value | Meaning
NONE | No data available
RUN | Acquisition running
NORM | Acquisition ended normally
ABOR | Acquisition was aborted
Discrete
<first_record_with_error> | The number of the first record with an error (0 if and only if there are no errors in any record). | Unsigned Integer
<channels_with_error>

The number of the channels with an error (0 if no error). This is a bit sum, where the software adds 1 if channel 1 had an error, 2 if channel 2 had an error, 4 if channel 3 had an error, and 8 if channel had an error.

For example, if channels 1, 2, and 4 had errors, <channels_with_error> would be 11 (1+2+8).

 Unsigned Integer
<init_timestamp> | Timestamp (in seconds) of the INITiate command. | 64-bit Floating point Number

Examples

The following query returns the acquisition preamble.

FETC:WAV:ACQ:PRE?

Typical Response:

25,500,12500,NORM,0,0,+1.12345678000000E+00

See Also

FETCh Subsystem Introduction

FETCh:WAVeform:VOLTage?

FETCh:WAVeform:RECord:PREamble?

FETCh:WAVeform:ADC?


FETCh:WAVeform:ADC?

Syntax

FETCh:WAVeform:ADC? (@<chan_list>)[,<start>[,<count> [,<rec_range> [,<dec_type>,<dec_count>]]]]

Description

This command retrieves a waveform from memory as analog-digital codes (ADC values). ADC values range from -32,767 to +32,767, linearly corresponding to values from the negative of the channel range to the channel range. For example, if a channels range is 16 V, the ADC value -32,767 corresponds to -16 V and the ADC value +32,767 corresponds to +16 V.

As an example, suppose you have the ADC code 14,683 on the 8 V range. This is equivalent to 8*(14,683/32,767), or approximately 3.5848 V.

Parameters

Name | Type | Range of Values | Default Value
<chan_list> Channel list

One or more channels, specified as in the following examples.

(@2) - channel 2

(@1,4) - channels 1 and 4

(@1:4) - channels 1 through 4.

Note that this particular command can have 1, 2, or 4 channels, not exactly 3.

 This is a required parameter.
<start> | Numeric | The first data point, expressed as an integer offset from the trigger (0) sample. A <start> of 0 is defined to be the first sample on or just after the trigger event. Negative <start> values refer to pre-trigger samples, and the absolute value of a negative <start> cannot exceed the number of pre-trigger samples. Similarly, positive <start> must be less than the umber of post-trigger samples. | The default value is the first sample in the record, regardless of whether that sample is a pre-trigger sample.
<count> | Numeric | The number of samples, including the <start> sample, to be fetched. The <count> cannot exceed the number of samples in a record. | The number of samples in the record.
<rec_range> Record range

One record or an ascending range of records. Records are returned in ascending order by record number. Examples are shown below.

(@100) - record 100

(@1:1000) - records 1 through 1000

Note that unlike a <chan_list>, a <rec_range> cannot include commas.

The returned data will be ordered by record number in ascending order.

 (@1)
<dec_type> Discrete

The decimation type: {DATA|AVERage|MINMax}.

DATA specifies simple data decimation.

AVERage specifies an arithmetic mean value on each decimated set.

MINMax specifies a minimum and maximum pair of values on each decimated set.

 DATA
<dec_count> Numeric

Unsigned integer, up to the maximum record size. The following minimum values apply.

For <dec_type> DATA, the minimum is 1.

For <dec_type> MINMax, the minimum is 4.

For <dec_type> AVERage, the minimum is 4.

1

Return Format

If FORMat[:DATA]:INTeger is set to INT,16, this query returns an IEEE Definite Arbitrary Block of signed, 16-bit integers representing channel data as ADC codes. The query begins with a header that specifies the block size. The header is of the form #<n><n digits>, where <n>specifies the number of digits used to indicate the size of the block, and the <n digits> indicate the block size in bytes.

For example, a block beginning with #6123456 means that the 6 digits 123456 indicate that the block size will be 123,456 bytes. A block beginning with #3400 means that the 3 digits 400 indicate that the block size will be 400 bytes.

If FORMat[:DATA]:INTeger is set to ASCii, this query returns a comma-delimited list of signed integers representing the ADC values as ASCII characters.

Remarks

  • Retrieving waveforms as ADC values is the fastest way to fetch data, but conversion to voltage values must be done in your software application.
  • Data is fetched in a non-destructive manner. That is, you may fetch the same data repeatedly.
  • The IEEE Definite Arbitrary Block is limited to 999,999,999 bytes. If you need to FETCh more than this number of bytes, you must do it with multiple FETCh commands.
  • For normal, undecimated data fetches, use <dec_type> DATA and <dec_count> 1. These are the default values
  • A decimated FETCh on a large block of data may require several seconds of calculation time before data begins to be returned. Even with the largest possible block of data, this should be no longer than 7 seconds.
  • You may need to change the timeout setting on your I/O libraries when you fetch large of amounts of data. The numbers shown below are reasonable suggestions, but your network configuration (use of switches, routers, firewalls, anti-virus software, and other considerations) may dictate longer timeouts.
    • Total Samples | Timeout (secs.)
    <25,000,000 | 5
    50,000,000 | 10
    100,000,000 | 20
    250,000,000 | 40
    400,000,000 | 65
    536,821,760 | 85

    Note that 536,821,760 is the maximum number of samples that you can transfer.
  • The default byte order is Big Endian. Use the FORMat:BORDer command if you need to change the byte order.
  • ADC values are 16-bit values, so a query of 100 samples will result in a 200 byte response.
  • Decimating the data refers to using a decimation count that is greater than 1. For MINMax decimation, two samples will be returned for the decimation count window. The first will be the minimum, and the second will be the maximum.
  • To run this query, you cannot be in calibration mode. If you try to run this query in calibration mode, the instrument will produce an error message.

Examples

The following command defaults all parameters other than <chan_list> and returns all samples for record 1 on channel 1.

FETC:WAV:ADC? (@1)

Typical Response: (data block)

The following command retrieves a wave form of 1000 samples starting with the trigger sample on channel 1.

FETC:WAV:ADC? (@1),0,1000

Typical Response: (data block)

See Also

FETCh Subsystem Introduction

FETCh:WAVeform:VOLTage?

FORMat[:DATA]:INTeger

FORMat:BORDer


FETCh:WAVeform:CHANnel:ERRor?

Syntax

FETCh:WAVeform:CHANnel:ERRor? <channel> [,<record>]

Description

This query returns error codes explaining erroneous sample values found in the given <record> on the specified <channel>.

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel list

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<record> | Numeric | Positive integer from 1 to 1024, indicating the record to assess to determine whether an error had occurred in the specified <channel>. | 1

Return Format

The query returns the following information as a comma-separated list.

Value Description Data Format
<error_code>

A positive integer representing the error, where:

0 = "No Errors"

1 = "Over Voltage"

4 = "Internal CRC Error" (Static zap or hardware failure)

8 = "Internal Framing Error" (Channel framing error)

 Unsigned integer
<error_string>

This is the text string associated with the <error_code>. Refer to the list above.

 Quoted ASCII String

Remarks

  • Use this query to evaluate why data from a given channel and record has invalid data values (-32768 ADC code, or 9.91E37 V).
  • The FETCh:WAVeform:ACQuisition:PREamble? query can return the number of first record with an error, and also the first channel with an error. You can then use this query to determine the nature of that error.

Examples

The following query assesses whether the specified <channel> had an acquisition error on channel 3 for record 10. It returns the error code and its associated text.

FETCh:WAV:CHAN:ERR? (@3),10

Typical Response: 4,"Internal CRC Error"

See Also

FETCh Subsystem Introduction


FETCh:WAVeform:RECord:PREamble?

Syntax

FETCh:WAVeform:RECord:PREamble? [<rec_num>]

Description

This query returns the ASCII format, record-specific acquisition overview of what is found in the specified <rec_num>. You can also get the trigger timestamp from the FETCh:WAVeform:RECord:TIMestamps? query.

Parameters

Name | Type | Range of Values | Default Value
<rec_num> | Numeric | Integer from 1 to 1024 | 1

Return Format

This query returns the following comma-separated list of numbers and discrete values.

Value | Description | Data Format
<rec_num>

The record number to be fetched, from 1 to 1024.

 Integer
<sample_count_completed>

The number of samples actually stored in the specified <rec_num>. If this is 0, then the acquisition was aborted before the trigger. If this is less than the configured number of samples per record, then the acquisition was aborted after the trigger.

 Integer
<pre_trigger_samples> | Total number of pre-trigger samples, either 0 or the full configured payload. | Integer
<trigger_time_stamp> | The number of seconds from the time the trigger timestamp was last zeroed (see [CONFigure:]TRIGger:TIMestamp[:MODE) to the trigger of the specified<rec_num>. | 64-bit Floating Point Number
<trigger_time_stamp_latency> | The number of seconds from the trigger event, plus any trigger delay to the trigger sample. | 64-bit Floating Point Number
<channels_with_error>

The number of the channels with an error (0 if no error). This is a bit sum, where the software adds 1 if channel 1 had an error, 2 if channel 2 had an error, 4 if channel 3 had an error, and 8 if channel for had an error.

For example, if channels 1, 2, and 4 had errors, <channels_with_error> would be 11 (1+2+8).

 Integer
<trigger_source>

An integer indicating the type of trigger that triggered this record. Possible values are:

Value | Meaning
-2 | EXTernal
-1 | SOFTware
0 | IMMediate
1 | channel 1
2 | channel 2
3 | channel 3
4 | channel 4
Integer

Remarks

  • This query gives a record-specific summary of the results from the most recent acquisition. It is often used in conjunction with the FETCh:WAVeform:ACQuisition:PREamble? query.

Examples

The following query returns the preamble of record 10.

FETC:WAV:REC:PRE? 10

Typical Response: +10,+500,+4,+1.23929525000000E-02,+4.25769302000000E-04,+4

See Also

FETCh Subsystem Introduction

FETCh:WAVeform:ACQuisition:PREamble?


FETCh:WAVeform:RECord:TIMestamps?

Syntax

FETCh:WAVeform:RECord:TIMestamps?

Description

This query returns all record timestamps as a binary block of 64-bit floating point values.

Remarks

  • Binary timestamps represent seconds between the timestamp register was last zeroed (see [CONFigure:]TRIGger:TIMestamp[:MODE] and when the related record trigger occurred.
  • Each record has a timestamp that indicates when it was triggered, as an offset in seconds from when the trigger timestamp counter was last zeroed.
  • The resolution of the timestamp clock is 12.5 nanoseconds.
  • No record parameter is allowed; you will always receive all timestamps.
  • By default, the binary data is in big Endian format. You can change it with FORMat:BORDer.

Return Format

The response is an IEEE 488 definite arbitrary block comprising IEEE 754 64-bit floating point values, one for each record completed, in ascending record order. The response is not governed by FORMat[:DATA]:REAL, because 64-bit floating point numbers are always returned.

Examples

The following query returns a block containing all timestamps:

FETC:WAV:REC:TIM?

Typical Response: (IEEE 488 Definite Arbitrary Block). Ranges from #10<NoData> to #48192<block of 1024 8-byte floating point numbers>.

See Also

FETCh Subsystem Introduction

FETCh:WAVeform:ACQuisition:PREamble?

[CONFigure:]TRIGger:TIMestamp[:MODE]


FETCh:WAVeform:VOLTage?

Syntax

FETCh:WAVeform:VOLTage? (@<chan_list>)[,<start>[,<count> [,<recList> [,<dec_type>,<dec_count>]]]]

Description

This command retrieves a waveform from memory as voltages.

Parameters

Name | Type | Range of Values | Default Value
<chan_list> Channel list

One or more channels, specified as in the following examples.

(@2) - channel 2

(@1,4) - channels 1 and 4

(@1:4) - channels 1 through 4.

Note that this particular command can have 1, 2, or 4 channels, not exactly 3.

 This is a required parameter.
<start> | Numeric | The first data point, expressed as an integer offset from the trigger (0) sample. A <start> of 0 is defined to be the first sample on or just after the trigger event. Negative <start> values refer to pre-trigger samples, and the absolute value of a negative <start> cannot exceed the number of pre-trigger samples. Similarly, positive <start> must be less than the umber of post-trigger samples. | The default value is the first sample in the record, regardless of whether that sample is a pre-trigger sample.
<count> | Numeric | The number of samples, including the <start> sample, to be fetched. The <count> cannot exceed the number of samples in a record. | The number of samples in the record.
<rec_range> Record range

One record or an ascending range of records. Records are returned in ascending order by record number. Examples are shown below.

(@100) - record 100

(@1:1000) - records 1 through 1000

Note that unlike a <chan_list>, a <rec_range> cannot include commas.

The returned data will be ordered by record number in ascending order.

 (@1)
<dec_type> Discrete

The decimation type: {DATA|AVERage|MINMax}.

DATA specifies simple data decimation.

AVERage specifies an arithmetic mean value on each decimated set.

MINMax specifies a minimum and maximum pair of values on each decimated set.

 DATA
<dec_count> Numeric

Unsigned integer, up to the maximum record size. The following minimum values apply.

For <dec_type> DATA, the minimum is 1.

For <dec_type> MINMax, the minimum is 4.

For <dec_type> AVERage, the minimum is 4.

1

Return Format

If FORMat[:DATA]:REAL is set to REAL,32 or REAL,64, this query returns an IEEE Definite Arbitrary Block of voltage values expressed in IEEE-754 binary format. The response begins with a header that specifies the block size. The header is of the form #<n><n digits>, where <n>specifies the number of digits used to indicate the size of the block, and the <n digits> indicate the block size in bytes.

For example, a block beginning with #6123456 means that the 6 digits 123456 indicate that the block size will be 123,456 bytes. A block beginning with #3400 means that the 3 digits 400 indicate that the block size will be 400 bytes. The block contains a series of 32-bit or 64-bit floating point values, depending on whether FORMat[:DATA]:REAL was set to REAL,32 or REAL,64.

If FORMat[:DATA]:REAL is set to ASCii,0, this query returns a comma-delimited list of voltage values expressed in ASCii characters.

Remarks

  • For faster fetches, use FETCh:WAVeform:ADC?.
  • Data is fetched in a non-destructive manner. That is, you may fetch the same data repeatedly.
  • The IEEE Definite Arbitrary Block is limited to 999,999,999 bytes. If you need to FETCh more than this number of bytes, you must do it with multiple FETCh commands.
  • For normal, undecimated data fetches, use <dec_type> DATA and <dec_count> 1. These are the default values.
  • A decimated FETCh on a large block of data may require several seconds of calculation time before data begins to be returned. Even with the largest possible block of data, this should be no longer than 7 seconds.
  • You may need to change the timeout setting on your Agilent I/O Libraries when you fetch large of amounts of data. The numbers shown below are reasonable suggestions, but your network configuration (use of switches, routers, firewalls, anti-virus software, and other considerations) may dictate longer timeouts.
    • Total Samples | Timeout (secs.)
    <25,000,000 | 5
    50,000,000 | 10
    100,000,000 | 20
    250,000,000 | 40
    400,000,000 | 65
    536,821,760 | 85

    Note that 536,821,760 is the maximum number of samples that you can transfer.
  • Very large <dec_count> values result in long execution times, as large amounts of data are processed.
  • The default byte order is Big Endian. Use the FORMat:BORDer command if you need to change the byte order.
  • Decimating the data refers to using a decimation count that is greater than 1. For MINMax decimation, two samples will be returned for the decimation count window. The first will be the minimum, and the second will be the maximum.

Examples

The following command retrieves a wave form of 1000 samples starting with the trigger sample on channel 1.

FETC:WAV:VOLT? (@1),0,1000

Typical Response: (data block)

The following command fetches all samples from channel 1, record 1.

FETC:WAV:VOLT? (@1)

Typical Response: (data block)

See Also

FETCh Subsystem Introduction

FORMat[:DATA]:REAL

FETCh:WAVeform:ADC?

FORMat:BORDer


FORMat Subsystem Introduction

Command Summary

FORMat:BORDer

FORMat:BORDer?

FORMat[:DATA]:INTeger

FORMat[:DATA]:INTeger?

FORMat[:DATA]:REAL

FORMat[:DATA]:REAL?


FORMat:BORDer

Syntax

FORMat:BORDer <mode>

FORMat:BORDer?

Description

This command sets the byte order for IEEE 488.2 binary data. The keyword BORDer stands for Byte ORDer.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Discrete | {NORMal|SWAPped} | NORMal

Return Format

The query form of this command returns the <mode>.

Remarks

  • Setting <mode> to NORMal specifies Big Endian mode (most significant byte first); setting it to SWAPped specifies Little Endian mode (least significant byte first). The following commands are affected:

    FETCh:WAVeform:ADC?

    FETCh:WAVeform:VOLTage?

    READ:WAVeform:ADC?

    READ:WAVeform:VOLTage?

    FETCh:WAVeform:RECord:TIMestamps?

    MEASure:INSTall:RESults[:RECord][:VERBose]?

Examples

The following command sets the order of packed data to Little Endian mode.

FORM:BORD SWAP

The following query returns the byte order, in this case being Little Endian mode.

FORM:BORD?

Typical Response: SWAP

See Also

FETCh:WAVeform:VOLTage?

FETCh:WAVeform:ADC?

FETCh:WAVeform:RECord:TIMestamps?

MEASure:INSTall:RESults[:RECord][:VERBose]?

READ:WAVeform:VOLTage?

READ:WAVeform:ADC?


FORMat[:DATA]:INTeger

Syntax

FORMat[:DATA]:INTeger <format>[,<length>]

FORMat[:DATA]:INTeger?

Description

This command sets the mode for how integer data is returned. The affected commands are: FETCh:WAVeform:ADC? and READ:WAVeform:ADC? .

Parameters

Name Type Range of Values Default Value
<format> Discrete {ASCii | INTeger} This is a required parameter.

The default value is INT.
<length> Numeric

If you choose to use this parameter, it must be 0 or 16. If the <format> is ASCii, the number must be 0 (characters) or omitted. If the <format> is INTeger, the number must be 16 (bits) or omitted.

If the <format> is ASCii, the default is 0.

If the <format> is INTeger, the default is 16.

Return Format

This query returns an answer of the form <format>,<length>. The two possibilities are ASC,0 and INT,+16.

Remarks

  • A value of INT,16 produces a definite block response to a data retrieval query (FETCh or READ). The byte order (Endianness) is set by the FORMat:BORDer command.
  • When you are retrieving data in ASCII format, responses that would be longer than 32,767 bytes will result in an error message instructing you to use the REAL format.

Examples

The following command sets the digitizer to FETCh and READ data with the return format for integers to be a 16-bit integer:

FORM:DATA:INT INT,16

The following query returns the format in which integer are returned by the FETCh:WAVeform:ADC? and READ:WAVeform:ADC? commands.

FORM:INTEGER?

Typical Response: INT,+16

See Also

FORMat Subsystem Introduction

FORMat[:DATA]:REAL?

FETCh:WAVeform:ADC?

READ:WAVeform:ADC?

FORMat:BORDer


FORMat[:DATA]:REAL

Syntax

FORMat[:DATA]:REAL <format>[,<length>]

FORMat[:DATA]:REAL?

Description

This command sets the mode for how floating point data is returned. The affected commands are: FETCh:WAVeform:VOLTage?, READ:WAVeform:VOLTage?, and MEASure:INSTall:RESults[:RECord][:VERBose]?.

Parameters

Name Type Range of Values Default Value
<format> Discrete {ASCii | REAL} This is a required parameter.

The default is REAL.
<length> Numeric If you choose to use this parameter, it must be one of the following numbers: 0, 32 and 64. If the <format> is ASCii, the number must be 0 (characters) or omitted. If the <format> is REAL, the number must be 32 or 64 (bits), or omitted.

If the <format> is ASCii, the default is 0.

If the <format> is REAL, the default is 32.

Return Format

This query returns an answer of the form <format>,<length>, such as ASC,+0 or REAL,+64.

Remarks

  • Values of REAL,32 and REAL,64 produce a definite block response to a data retrieval query (FETCh or READ).
  • When you are retrieving data in ASCII format, responses that would be longer than 32,767 bytes will result in an error message instructing you to use the REAL format.

Examples

The following command sets the digitizer to FETCh and READ data with the return format for floating point numbers to be a 64-bit number:

FORM:DATA:REAL REAL,64

The following query returns the format in which floating point numbers are returned by the FETCh:WAVeform:VOLTage?, READ:WAVeform:VOLTage?, and MEASure:INSTall:RESults[:RECord][:VERBose]? commands.

FORM:DATA:REAL?

Typical Response: REAL,+64

See Also

FORMat Subsystem Introduction

FORMat[:DATA]:INTeger

FETCh:WAVeform:VOLTage?

READ:WAVeform:VOLTage?

MEASure:INSTall:RESults[:RECord][:VERBose]?


IEEE-488 Common Commands Introduction

Command Summary

*CLS

*ESE

*ESE?

*ESR?

*IDN?

*OPC

*OPC?

*OPT?

*RCL

*RST

*SAV

*SRE

*SRE?

*STB?

*TRG

*TST?

*WAI


*CLS

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

*CLS

Description

This command, whose name derives from CLear Status, clears the event registers in all register groups. It also clears the error queue.

Example

The following commands clear the event register bits and error queue prior to the start of digitizing.

*CLS
INIT

See Also

IEEE-488 Common Commands Introduction

*ESR?

STATus:OPERation[:EVENt]?

STATus:QUEStionable[:EVENt]?


*ESE

Syntax

*ESE <enable_value>

*ESE?

Description

This command enables bits in the enable register for the Standard Event Register group. The selected bits are then reported to bit 5 of the Status Byte Register.

For more information on the Status System for the instrument, see Status System Introduction.

Parameters

Name Type Range of Values Default Value

<enable_value>

Numeric

The decimal value equal to the binary-weighted sum of the bits in the register (see table below).

This is a required parameter.

Remarks

  • The following table lists the bit definitions for the Standard Event Register.
    • Bit # | Bit Name | Decimal Value | Definition
    0 | Operation Complete | 1 | An INITiate operation acquiring data has completed since *OPCwas sent.
    1 | (Reserved) | 2 | (Reserved for future use)
    2 | Query Error | 4 | The instrument tried to read the output buffer but it was empty. Or, a new command line was received before a previous query had been read. Or, both the input and output buffers are full.
    3 | Device Error | 8 | A device-specific error has been generated. For a complete listing of the error messages, see Error Messages.
    4 | Execution Error | 16 | An execution error occurred.
    5 | Command Error | 32 | A command error occurred.
    6 | (Reserved) | 64 | (Reserved for future use)
    7 | Power On | 128 | Power has been turned off and on since the last time the event register was read or cleared.
    *ESR?


*ESR?

Syntax

*ESR?

Description

This command queries the event register for the Standard Event Register group. This is a read-only register and the bits are cleared when you read the register.

For more information on the Status System for the instrument, see Status System Introduction.

Remarks

  • The following table lists the bit definitions for the Standard Event Register.
Bit # | Bit Name | Decimal Value | Definition
0 | Operation Complete | 1 | Acquisition has completed since a *OPC was executed.
1 | (Reserved) | 2 | (Reserved for future use)
2 | Query Error | 4 | The instrument tried to read the output buffer but it was empty. Or, a new command line was received before a previous query had been read. Or, both the input and output buffers are full.
3 | Device Error | 8 | A device-specific error has been generated. For a complete listing of the error messages, see Error Messages.
4 | Execution Error | 16 | An execution error occurred.
5 | Command Error | 32 | A command error occurred.
6 | (Reserved) | 64 | (Reserved for future use)
7 | Power On | 128 | Power has been turned off and on since the last time the event register was read or cleared.

  • In order to be reported to the Status Register, the corresponding bits in the event register must be enabled using the *ESE command.
  • Once a bit is set, it remains set until cleared by reading the event register or execution of the *CLS (clear status) command.

Return Format

The command reads the event register and returns a decimal value corresponding to the binary-weighted sum of all bits set in the register (see table above). For example, if bit 2 (decimal value = 4) and bit 4 (decimal value = 16) are set (and the corresponding bits are enabled), this command will return +20.

Examples

The following command reads the event register (bits 3 and 4 are set).

*ESR?

Typical Response: +24

See Also

IEEE-488 Common Commands Introduction

*ESE

*CLS


*IDN?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

*IDN?

Description

This query returns the instrument's identification string, which contains four comma-separated fields. The first field is the manufacturer's name, the second field is the instrument's model number, the third field is the serial number, and the fourth field is a revision code containing four numbers separated by dashes.

Return Format

The command returns a string with the following format:

Agilent Technologies,L4532A,<Serial Number>,f.ff-dd-a1-00

Agilent Technologies,L4534A,<Serial Number>,f.ff-dd-a1-a2

where:

f.ff

Firmware revision number

dd

Digital board FPGA revision

a1

First analog board FPGA revision (channels 1 and 2)

a2

 Second analog board FPGA revision (channels 3 and 4; equal to 00 if the digitizer is model L4532A)

Example

The following query returns the instrument's identification string.

*IDN?

Typical Response: Agilent Technologies,L4532A,MY12345678,1.00-01-01-00

See Also

IEEE-488 Common Commands Introduction


*OPC

Syntax

*OPC

Description

This command sets the "Operation Complete" bit (bit 0) to 1 in the Standard Event Register when the overlapped INITiate operation has completed.

For more information on the Status System for the instrument, see Status System Introduction.

For more information on the Standard Event Register, see *ESE.

Remarks

  • This command enables you to synchronize your application with the instrument.
  • You can use this in conjunction with SRQ interrupts to notify user applications.
  • Note the difference between the *OPC command and the *OPC? query. The *OPC command returns immediately upon configuring the digitizer to assert the operation complete bit of the *ESE register when a pending INITiate operation completes. It then returns immediately. At the end of the INITiate command, the operation complete bit of the *ESE register is set. This allows a properly configured status system to generate an SRQ event when an acquisition is complete. In contrast, the *OPC? query sets the output buffer to 1 at the completion of the current operation. Unlike *OPC?, the *OPC command does not block subsequent commands pending completion.
  • You may also poll the Standard Event Register with the *ESR? query.
  • Unlike *OPC?, *OPC will not pend until completion of CALibration:RANGe, CALibration:RANGe:SOURce, or any command being executed on another I/O port. It simply indicates the conclusion of digitizing through bit 0 of the Standard Event Register.

Examples

The following command sets the "Operation Complete" bit at the end of initialization.

INIT; *OPC

See Also

IEEE-488 Common Commands Introduction

*OPC?

*ESE

*ESR?


*OPC?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

*OPC?

Description

This query returns +1 to the output buffer upon completion of all operations started prior to this query, including INITiate or operations being done on other I/O ports. This is a blocking query; that is, its completion pends the settling of all channel front ends and the completion of all previous commands.

For more information on the Status System for the instrument, see Status System Introduction.

Remarks

  • This query enables you to synchronize your application with the instrument.
  • Note the difference between the *OPC? command and the *OPC command. The latter sets the "Operation Complete" bit (bit 0) in the Standard Event register at the completion of the current operation.

Return Format

The command returns +1 to the output buffer.

Example

The following series of commands shows a typical use model for the *OPC? query. The *OPC? query sends +1 to the output buffer when all previously started operations are complete.

INITiate
*OPC?
STATus:QUEStionable:DCORrupt?

Typical Response: +1 (note that this is the only possible response for a *OPC query after an INITiate command.)

See Also

IEEE-488 Common Commands Introduction

*OPC

INITiate

STATus:QUEStionable:DCORrupt?


*OPT?

Syntax | Description | Parameters| Remarks |Return Format | Examples

Syntax

*OPT?

Description

This command reports the options that are installed on the instrument. For the L4532A/34A, it identifies whether the extended sample memory option is installed.

Return Format

The command returns the model number (L4532A or L4534A) and the installed memory option, separated by a comma. The possible memory options are OPT32MSa or OPT128MSa, which support up to approximately 32 million or 128 million samples, respectively.

Examples

The following command returns the installed options.

*OPT?

Typical Response: L4534A,OPT32MSa

See Also

IEEE-488 Common Commands Introduction


*RCL

Syntax

*RCL {0|1|2|3|4}

Description

This command recalls the instrument state stored in the specified storage location. You cannot recall the instrument state from a storage location that is empty. When shipped from the factory, all five storage locations are empty.

Use the *SAV command to store the current instrument state.

Remarks

  • The instrument has five storage locations in non-volatile memory to store instrument states. You can only recall a state from a location that contains a previously stored state.
  • A Factory Reset (*RST command) does not affect the configurations stored in memory. Once a state is stored, it remains until it is overwritten.
  • Only the digitizer configuration is recalled. LAN I/O configuration and measurements are not recalled.
  • The SYSTem:SECurity:IMMediate erases states saved by *SAV.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Examples

The following command recalls the instrument state previously stored by *SAV 1.

*RCL 1

See Also

IEEE-488 Common Commands Introduction

*RST

*SAV

SYSTem:SECurity:IMMediate


*RST

Syntax

*RST

Description

This command resets the instrument to the Factory configuration. See Power-On and Reset State for a complete listing of the instrument's Factory configuration. The *RST command implicitly executes an ABORt as an early part of the reset process.

Remarks

  • This command will abort any active digitizing activity and discard all current measurements. If an INITiate operation will not complete, consider using the ABORt command rather than *RST, so that measurements taken up to that point will not be lost.
  • This command does not affect any previously-stored instrument states (see *SAV command).
  • This command does not affect I/O settings, such as IP address.
  • If the CALibration:STATe is ON, the digitizer:
    • Aborts any active calibration operation that is in progress.
    • Restores the calibration constants stored in non-volatile memory for every channel.
    • Sets to CALibration:STATe to OFF.
  • If the CALibration:STATe is OFF, the *RST command does not change any of the calibration constants or CALibration:ZERO:AUTO? results that are currently in volatile memory.
  • The value of CALibration:SECure:STATe is not affected by *RST. You must remember to manually re-secure your instrument with CALibration:SECure:STATe ON if you execute a *RST command with the instrument in CALibration:STATe ON mode.

Examples

The following command resets the instrument.

*RST

See Also

IEEE-488 Common Commands Introduction

ABORt

CALibration:SECure:STATe

CALibration:STATe


*SAV

Syntax

*SAV {0|1|2|3|4}

Description

This command stores (saves) the current instrument state into the specified storage location. Any state previously stored in the same location is overwritten (no error is generated).

Use the *RCL command to recall a stored instrument state.

Remarks

  • The instrument has five storage locations in non-volatile memory to store instrument states. You can store the instrument state in location 0, 1, 2, 3, or 4, but you can only recall a state from a location that contains a previously stored state.
  • LAN I/O configuration and waveform data are not stored by a *SAV operation.
  • When shipped from the factory, all five storage locations are empty.
  • A Factory Reset (*RST command) does not affect the configurations stored in memory. Once a state is stored, it remains until it is overwritten.
  • The SYSTem:SECurity:IMMediate erases states saved by *SAV.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Examples

The following command stores the current instrument state in location 1.

*SAV 1

See Also

IEEE-488 Common Commands Introduction

*RCL

*RST

SYSTem:SECurity:IMMediate


*SRE

Syntax

*SRE <enable_value>

*SRE?

Description

This command enables bits in the enable register for the Status Byte Register. Once enabled, the corresponding bits may generate a Request for Service (RQS) in the Status Byte. This RQS event may generate a "call back" to your application as a type of asynchronous interrupt.

For more information on the Status System for the instrument, see Status System Introduction.

Parameters

Name Type Range of Values Default Value

<enable_value>

Numeric

A decimal value corresponding to the binary-weighted sum of the bits in the register (see table below).

 This is a required parameter.

Remarks

  • The following table lists the bit definitions for the Status Byte Register.
Bit # | Bit Name | Decimal Value | Definition
0 - 1 | (Reserved) | 1 - 2 | (Reserved for future use)
2 | Error Queue | 4 | One or more errors have been stored in the Error Queue. Use the SYSTem:ERRor? command to read and delete errors.
3 | Questionable Data Summary | 8 | One or more bits are set in the Questionable Data Register (bits must be enabled, see STATus:QUEStionable:ENABle command).
4 | Message Available | 16 | Data is available in the instrument's output buffer.
5 | Standard Event Summary | 32 | One or more bits are set in the Standard Event Register (bits must be enabled, see *ESE command).
6 | Master Summary | 64 | One or more bits are set in the Status Byte Register and may generate a Request for Service (RQS). Bits must be enabled using the *SRE command.
7 | Standard Operation Summary | 128 | One or more bits are set in the Standard Operation Register (bits must be enabled, see STATus:OPERation:ENABle command).
  • Use the <enable_value> parameter to specify which bits will be enabled. The decimal value specified corresponds to the binary-weighted sum of the bits you wish to enable in the register. For example, to enable bit 3 (decimal value = 8) and bit 5 (decimal value = 32), the corresponding decimal value would be 40 (8 + 32).
  • The *CLS (clear status) command will not clear the enable register but it does clear all bits in the event register.
  • A *CLS, or *RST command does not clear the bits in the Status Byte enable register.
  • See your I/O library documentation for instructions on configuring your software application to receive callbacks based on SRQ events.

Return Format

The query command reads the enable register and returns a decimal value corresponding to the binary-weighted sum of all bits set in the register. For example, if bit 3 (decimal value = 8) and bit 5 (decimal value = 32) are enabled, the query command will return +40.

Examples

The following command enables bit 4 (decimal value = 16) in the enable register.

*SRE 16

The following query returns which bits are enabled in the register.

*SRE?

Typical Response: +16

See Also

IEEE-488 Common Commands Introduction

*STB?


*STB?

Syntax

*STB?

Description

This command, whose name is derived from STatus Byte, queries the condition register for the Status Byte Register group. This is a read-only register and the bits are not cleared when you read the register.

For more information on the Status System for the instrument, see Status System Introduction.

Remarks

  • The following table lists the bit definitions for the Status Byte Register.
Bit # | Bit Name | Decimal Value | Definition
0 - 1 | (Reserved) | 1 - 2 | (Reserved for future use)
2 | Error Queue | 4 | One or more errors have been stored in the Error Queue. Use the SYSTem:ERRor? command to read and delete errors.
3 | Questionable Data Summary | 8 | One or more bits are set in the Questionable Data Register (bits must be enabled, see STATus:QUEStionable:ENABle command).
4 | Message Available | 16 | Data is available in the instrument's output buffer.
5 | Standard Event Summary | 32 | One or more bits are set in the Standard Event Register (bits must be enabled, see *ESE command).
6 | Master Summary | 64 | One or more bits are set in the Status Byte Register and may generate a Request for Service (RQS). Bits must be enabled using the *SRE command.
7 | Standard Operation Summary | 128 | One or more bits are set in the Standard Operation Register (bits must be enabled, see STATus:OPERation:ENABle command).
  • This query returns the same results as a serial poll but the "Master Summary" bit (bit 6) is not cleared if a serial poll has occurred.
  • See your I/O library documentation for instructions on performing a serial poll in your application. A serial poll is useful for querying for the Status Byte Register value without pending completion of previous instrument commands, as *STB? does.
  • Unlike how a reset clears the condition register, a factory reset (*RST command) does not clear the Status Byte Register.

Return Format

The command reads the condition register and returns a decimal value corresponding to the binary-weighted sum of all bits set in the register (see table above). For example, if bit 3 (decimal value = 8) and bit 5 (decimal value = 32) are set (and the corresponding bits are enabled), this command will return "+40".

Examples

The following command reads the condition register (bits 3 and 5 are set).

*STB?

Typical Response: +40

See Also

IEEE-488 Common Commands Introduction

*SRE


*TRG

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

*TRG

Description

This command sends a software trigger to the instrument.

Remarks

  • This is equivalent to the TRIGger[:IMMediate] command.
  • The software trigger operation that this command executes is accepted by the instrument only when the digitizer is acquiring data (executing INITiate), and the trigger operation is accepted regardless of the configured trigger source ([CONFigure:]TRIGger:SOURce).
  • Use the CONFigure:TRIGger:SOURce command to select the trigger source.
  • After setting the trigger source, you must place the instrument in the wait-for-trigger state using the INITiate command. The instrument will buffer one software trigger to be applied at the next wait-for-trigger state, so it is not necessary to verify that the instrument is precisely in the wait-for-trigger state.
  • To run this command, the CALibration:STATe must be OFF, and the system must be acquiring data.

Example

The following commands trigger the instrument.

CONF:TRIG:SOUR SOFT
INIT
*TRG

See Also

IEEE-488 Common Commands Introduction

CONFigure:TRIGger:SOURce

TRIGger[:IMMediate]


*TST?

Syntax

*TST?

Description

This command performs a complete self-test of the instrument and returns a pass/fail indication. The self-test runs a series of tests and will take more than 45 seconds to complete. If all tests pass, you can have a high confidence that the instrument is operational.

Remarks

  • When sending the *TST? query, you may need to increase the timeout period for your I/O library read response time to allow the command to complete without causing a timeout error.
  • If one or more tests fail, +1 is returned and one or more errors are stored in the error queue. For a complete listing of the error messages related to self-test failures, see Error Messages.
  • If one or more tests fail, see the Agilent L4532A/34A Service Guide for instructions on obtaining service.
  • Upon completion, *TST restores the instrument to its factory reset state.

Return Format

The command returns +0 (all tests passed) or +1 (one or more tests failed). For details on the return format, see Error Messages.

Examples

The following command performs a self-test and returns a pass/fail indication. In this case, there are no failures.

*TST?

Typical Response: +0

See Also

IEEE-488 Common Commands Introduction


*WAI

Syntax

*WAI

Description

This command waits for all pending operations to complete before executing subsequent commands over the interface. It is typically used to turn an overlapped command such as INITiate into a sequential command.

Remarks

  • The *WAI command is of limited utility on the L4532A/34A, but you can use it to suspend command processing until the instrument completes all previous commands.
  • The *WAI command is not necessary prior to fetching measurements with FETCh:WAVeform commands, because data fetch queries pend until data is available.
  • The *OPC command and *OPC? query provide alternative synchronizing capabilities.

Examples

The following compound command header uses *WAI to wait until all pending operations complete before processing the subsequent query.

*WAI; :STATus:QUEStionable:DCORrupt?

See Also

IEEE-488 Common Commands Introduction

FETCh Subsystem Introduction

*OPC

*OPC?

STATus:QUEStionable:DCORrupt?


MEASure Subsystem Introduction

The MEASure subsystem supplies on-board measurements (OBM) from the digitizer. In this context, measurements refers to computed measurements performed on previously digitized data. Past instruments would use this subsystem for fetching voltage data, which is done by the FETCh subsystem on the L4532A/34A. For information on fetching data, please refer to the FETCh subsystem, as this section only discusses OBM.

Command Summary

MEASure:FALL:DUTYcycle[:VERBose]?

MEASure:FALL:FREQuency[:VERBose]?

MEASure:FALL:OVERshoot[:VERBose]?

MEASure:FALL:PERiod[:VERBose]?

MEASure:FALL:PREShoot[:VERBose]?

MEASure:FALL:TIME[:VERBose]?

MEASure:INSTall:CATalog?

MEASure:INSTall:DEFine

MEASure:INSTall:DEFine?

MEASure:INSTall:DELete

MEASure:INSTall:RESults:ERRor:RECord?

MEASure:INSTall:RESults[:RECord][:VERBose]?

MEASure:INSTall:RUN

MEASure:NWIDth[:VERBose]?

MEASure:PWIDth[:VERBose]?

MEASure:RCODe:STRing?

MEASure:RISE:DUTYcycle[:VERBose]?

MEASure:RISE:FREQuency[:VERBose]?

MEASure:RISE:OVERshoot[:VERBose]?

MEASure:RISE:PERiod[:VERBose]?

MEASure:RISE:PREShoot[:VERBose]?

MEASure:RISE:TIME[:VERBose]?

MEASure:THResholds:ABSolute

MEASure:THResholds:ABSolute?

MEASure:THResholds:METHod

MEASure:THResholds:METHod?

MEASure:THResholds:PERCent

MEASure:THResholds:PERCent?

MEASure:THResholds:RESet

MEASure:THResholds:TOPBase:ABSolute

MEASure:THResholds:TOPBase:ABSolute?

MEASure:THResholds:TOPBase:METHod

MEASure:THResholds:TOPBase:METHod?

MEASure:VAMPlitude[:VERBose]?

MEASure:VAVerage[:VERBose]?

MEASure:VBASe[:VERBose]?

MEASure:VLOWer[:VERBose]?

MEASure:VMAX[:VERBose]?

MEASure:VMIDdle[:VERBose]?

MEASure:VMIN[:VERBose]?

MEASure:VPP[:VERBose]?

MEASure:VRMS[:VERBose]?

MEASure:VTOP[:VERBose]?

MEASure:VUPPer[:VERBose]?

MEASure:WINDow[:DEFine]

MEASure:WINDow[:DEFine]?


MEASure:FALL:DUTYcycle[:VERBose]?

MEASure:RISE:DUTYcycle[:VERBose]?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure:FALL:DUTYcycle[:VERBose]? (@<channel>)[,<num_edge>[,<rec_num>]]

MEASure:RISE:DUTYcycle[:VERBose]? (@<channel>)[,<num_edge>[,<rec_num>]]

Description

This query returns the duty cycle, starting at the midpoint of a falling or rising edge. Duty cycle is calculated as follows:

Duty cycle (falling) = 100*(time from falling edge midpoint to rising edge midpoint) / (time from falling edge midpoint to next failling edge midpoint)

Duty cycle (rising) = 100*(time from rising edge midpoint to falling edge midpoint) / (time from rising edge midpoint to next rising edge midpoint)

Note that the denominators in the expressions shown above are equivalent to the period calculations in MEASure:FALL:PERiod[:VERBose]? and MEASure:RISE:PERiod[:VERBose]?.

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<num_edge> | Numeric | Positive integer specifying the falling or rising edge within the measurement window on which the measurement is performed. | 1
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • If no duty cycle can be calculated, +9.910000E+37 is reported. The <return_code> will indicate the nature of the problem in the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The standard form of the query returns the duty cycle as <v al>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax> | Horizontal time location (in seconds) of the measurement's leading edge. Measured as the time from the start of the measurment window to the leading edge's middle threshold crossing. | Floating point number
<Ay> | Vertical voltage marker of the leading edge of measurement. Measured as the voltage at the middle of the leading edge. | Floating point number
<Bx> | Horizontal time location (in seconds) of the measurement's trailing edge. Measured as the time from the start of the measurment window to the trailing edge's middle threshold crossing. | Floating point number
<By> | Vertical voltage marker of the measurement's trailing edge. For this measurement, <By> is defined to equal <Ay>. | Floating point number

Examples

The following query returns the duty cycle starting on for record 1 (default) a falling edge on the specified channel for one falling edge on channel 1.

MEASure:FALL:DUTYcycle? (@1)

Typical Response: +4.381956E+01

The following query returns the duty cycle for record 22, starting on the tenth rising edge on channel 2.

MEASure:RISE:DUTYcycle:VERBOSE? (@2),10,22

Typical Response: +4.381956E+01,+0,+1.279214E-04,+2.500000E+01,+1.324566E-04,+2.500000E+01

See Also

Introduction to: MEASure Commands

MEASure:FALL:PERiod[:VERBose]?

MEASure:INSTall:DEFine

MEASure:WINDow[:DEFine]


MEASure:FALL:FREQuency[:VERBose]?

MEASure:RISE:FREQuency[:VERBose]?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure:FALL:FREQuency[:VERBose]? (@<channel>)[,<num_edge>[,<rec_num>]]

MEASure:RISE:FREQuency[:VERBose]? (@<channel>)[,<num_edge>[,<rec_num>]]

Description

This query returns the frequency (in Hz) of the given cycle, starting at the midpoint of a falling or rising edge. The frequency of a signal is defined as the reciprocal of the period (1 / period). For the MEASure:FALL:FREQuency[VERBose]? query, the period is defined as the time from the midpoint of the specified falling edge to the midpoint of the next falling edge. The MEASure:RISE:FREQuency[VERBose]? query is based on the midpoint crossing of consecutive rising edges.

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<num_edge> | Numeric | Positive integer specifying the falling or rising edge within the measurement window on which the measurement is performed. | 1
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • If no frequency can be calculated, +9.910000E+37 is reported. The <return_code> will indicate the nature of the problem in the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The standard form of the query returns the frequency as <v al>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax> | Horizontal time location (in seconds) of the measurement's leading edge. Measured as the time from the start of the measurment window to the leading edge's middle threshold crossing. | Floating point number
<Ay> | Vertical voltage marker of the leading edge of measurement. Measured as the voltage at the middle of the leading edge. | Floating point number
<Bx> | Horizontal time location (in seconds) of the measurement's trailing edge. Measured as the time from the start of the measurment window to the trailing edge's middle threshold crossing. | Floating point number
<By> | Vertical voltage marker of the measurement's trailing edge. For this measurement, <By> is defined to equal <Ay>. | Floating point number

Examples

The following command measures the frequency of one cycle on the specified channel, starting at the middle of the first falling edge on channel 3, record 1 (default).

MEASure:FALL:FREQuency? (@3)

Typical Response: +6.712391E+04

The following command returns the VERBose form of the frequency measurement for one cycle on channel 3, record 1 (default), starting at the middle of the sixth rising edge.

MEASure:RISE:FREQuency:VERBose? (@3),6

Typical Response: +6.712391E+04,+0,+3.163988E-02,+1.534216E+01,+3.257621E-02,+1.534216E+01

See Also

MEASure Subsystem Introduction

MEASure:FALL:PERiod[:VERBose]?

MEASure:INSTall:DEFine

MEASure:WINDow[:DEFine]


MEASure:FALL:OVERshoot[:VERBose]?

MEASure:RISE:OVERshoot[:VERBose]?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure:FALL:OVERshoot[:VERBose]? (@<channel>)[,<num_edge>[,<rec_num>]]

MEASure:RISE:OVERshoot[:VERBose]? (@<channel>)[,<num_edge>[,<rec_num>]]

Description

This query returns the falling or rising overshoot as a percentage. The formula is:

Overshoot (falling) = 100*(Local minimum of first half of bottom - Base level) / amplitude

Overshoot (rising) = 100*(Local maximum of first half of top - Top level) / amplitude

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<num_edge> | Numeric | Positive integer specifying the falling or rising edge within the measurement window on which the measurement is performed. | 1
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • If no overshoot can be calculated, +9.910000E+37 is reported. The <return_code> will indicate the nature of the problem in the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The standard form of the query returns the overshoot as <v al>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax>

Horizontal time location (in seconds) from the start of the measurement window to the measurement's leading edge. For the FALL version of the query, this is measured as the time from the start of the measurement window to the leading edge's lower threshold crossing. For the RISE version, this is the time from the start of the measurement window to the leading edge's upper threshold crossing.

 Floating point number
<Ay>

Vertical voltage marker of the leading edge of measurement. For the FALL version of the query, this equals the local minimum of the first half of the bottom. For the RISE version, this equals the local maximum of the first half of the top.

 Floating point number
<Bx> | Horizontal time location (in seconds) from the start of the measurement window to the measurement's trailing edge. For the FALL version of the query, this is the time of the midpoint of the bottom of the waveform (between lower threshold crossings). For the RISE version, this is the time of the midpoint of the top of the waveform (between upper threshold crossings). | Floating point number
<By> | Vertical voltage marker of the trailing edge of the measurement. For the FALL version of this command, this equals the base voltage. For the RISE version of this command, this equals the top voltage. | Floating point number

Examples

The following command measures the overshoot on record 1 (default) of the tenth falling edge on channel 1.

MEASure:FALL:OVERshoot? (@1),10

Typical Response: +1.247971E+01

The following command returns the VERBose form of the overshoot measurement for the tenth falling edge on channel 1, record 1 (default).

MEASure:RISE:OVERshoot:VERBose? (@1),10

Typical Response: +1.247971E+01,+0,+2.856520E+00,+9.381554E-01,+2.885126E+00,+3.000000E+01

See Also

MEASure Subsystem Introduction

MEASure:FALL:PREShoot[:VERBose]?

MEASure:INSTall:DEFine

MEASure:WINDow[:DEFine]


MEASure:FALL:PERiod[:VERBose]?

MEASure:RISE:PERiod[:VERBose]?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure:FALL:PERiod[:VERBose]? (@<channel>)[,<num_edge>[,<rec_num>]]

MEASure:RISE:PERiod[:VERBose]? (@<channel>)[,<num_edge>[,<rec_num>]]

Description

This query returns the period of the given cycle (in seconds). For the MEASure:FALL:PERiod[VERBose]? query, the time starts at the midpoint of the specified falling edge and ends at the midpoint of the next falling edge. The MEASure:RISE:PERiod[VERBose]? query is based on the midpoint crossing of consecutive rising edges.

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<num_edge> | Numeric | Positive integer specifying the falling or rising edge within the measurement window on which the measurement is performed. | 1
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • If no period can be calculated, +9.910000E+37 is reported. The <return_code> will indicate the nature of the problem in the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The standard form of the query returns the period as <v al>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax> | Horizontal time location (in seconds) of the measurement's leading edge. Measured as the time from the start of the measurment window to the leading edge's middle threshold crossing. | Floating point number
<Ay> | Vertical voltage marker of the leading edge of measurement. Measured as the voltage at the middle of the leading edge. | Floating point number
<Bx> | Horizontal time location (in seconds) of the measurement's trailing edge. Measured as the time from the start of the measurment window to the trailing edge's middle threshold crossing. | Floating point number
<By> | Vertical voltage marker of the measurement's trailing edge. For this measurement, <By> is defined to equal <Ay>. | Floating point number

Examples

The following command measures the period of the cycle that starts at the tenth falling edge on channel 4, record 1 (default).

MEASure:FALL:PERiod? (@4),10

Typical Response: +4.561083E-03

The following command returns the VERBose form of the period measurement for the cycle that starts at the tenth rising edge on channel 4, record 1 (default).

MEASure:RISE:PERiod:VERBose? (@4),10

Typical Response: +4.561083E-03,+0,+7.821652E-04,+3.521667E+01,+7.879233E-04,+3.521667E+01

See Also

MEASure Subsystem Introduction

MEASure:FALL:FREQuency[:VERBose]?

MEASure:INSTall:DEFine

MEASure:WINDow[:DEFine]


MEASure:FALL:PREShoot[:VERBose]?

MEASure:RISE:PREShoot[:VERBose]?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure:FALL:PREShoot[:VERBose]? (@<channel>)[,<num_edge>[,<rec_num>]]

MEASure:RISE:PREShoot[:VERBose]? (@<channel>)[,<num_edge>[,<rec_num>]]

Description

This query returns the falling or rising preshoot overshoot as a percentage. The formula for this is shown below:

Preshoot (for falling edge)= 100*(Local minimum of second half of bottom - Base level) / amplitude

Preshoot (for rising edge)= 100*(Local maximum of second half of top - Top level) / amplitude

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<num_edge> | Numeric | Positive integer specifying the falling or rising edge within the measurement window on which the measurement is performed. | 1
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • If no preshoot can be calculated, +9.910000E+37 is reported. The <return_code> will indicate the nature of the problem in the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The standard form of the query returns the period as <v al>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax>

Horizontal time location (in seconds) of the measurement's leading edge. For the FALL version of this query, this is measured as the time from the start of the measurement window to the middle of the high level before the fall. For the RISE version, this is the time from the start of the measurement window to the middle of the low level before the rise.

 Floating point number
<Ay> | Vertical voltage marker of the leading edge of measurement. For the FALL version of this query, this equals the local maximum of the first half of the top. For the RISE version, this equals the local minimum for the first half of the bottom. | Floating point number
<Bx> | Horizontal time location (in seconds) of the measurement's trailing edge. For the FALL version of this query, this is measured as the time from the start of the measurement window to the trailing top threshold crossing at the top of the fall. For the RISE version, this is the time from the start of the measurement window to the trailing bottom threshold crossing at the base of the rise. | Floating point number
<By> | Vertical voltage marker of the trailing edge of the measurement. For the FALL version of this query, it equals vTop. For the RISE version of this query, it equals vBase. | Floating point number

Examples

The following command measures the preshoot on record 1 (default) for the first (default) falling edge of channel 1.

MEASure:FALL:PREShoot? (@1)

Typical Response: +2.821612E-02

The following command returns the VERBose form of the preshoot measurement on record 8 for the third falling edge of channel 1.

MEASure:RISE:PREShoot:VERBose? (@1),3,8

Typical Response: +2.821612E-02,+0,+6.525621E-03,+2.566289E+01,+6.569125E-03,+2.502165E+01

See Also

MEASure Subsystem Introduction

MEASure:FALL:OVERshoot[:VERBose]?

MEASure:INSTall:DEFine

MEASure:WINDow[:DEFine]


MEASure:FALL:TIME[:VERBose]?

MEASure:RISE:TIME[:VERBose]?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure:FALL:TIME[:VERBose]? (@<channel>) [,<num_edge>[,<rec_num>]]

MEASure:RISE:TIME[:VERBose]? (@<channel>) [,<num_edge>[,<rec_num>]]

Description

This query measures and returns the fall time value of the falling or rising edge closest to the trigger reference. Fall time is defined as the time in seconds from the upper threshold to the lower threshold of a falling edge. Rise time is defined as the time in seconds from the lower threshold to the upper threshold of a rising edge.

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<num_edge> | Numeric | Positive integer specifying the falling or rising edge within the measurement window on which the measurement is performed. | 1
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • If no rise or fall time starting with the specified edge type can be calculated, +9.91E+37 is reported. The return code will indicate this if you are using the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The standard form of the query returns the fall time as <val>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax>

Horizontal time location (in seconds) of the measurement's leading edge. For the FALL version of the query, this is measured as the time from the start of the measurement window to the leading edge's upper threshold crossing. For the RISE version, this is the time from the start of the measurement window to the leading edge's lower threshold crossing.

 Floating point number
<Ay>

Vertical voltage marker of the leading edge of measurement. For the FALL version of the query, this is measured as the voltage at the upper threshold of the leading edge. For the RISE version, this is the voltage at the lower threshold of the leading edge.

 Floating point number
<Bx> | Horizontal time location (in seconds) of the measurement's trailing edge. For the FALL version of the query, this is measured as the time from the start of the measurement window to the trailing edge's lower threshold crossing. For the RISE version, this is the time from the start of the measurement window to the trailing edge's upper threshold crossing. | Floating point number
<By> | Vertical voltage marker at the end of the measurement. For the FALL version of the query, this equals the lower threshold voltage. For the RISE version of the query, this equals the upper threshold voltage. | Floating point number

Examples

The following command returns the fall time for record 1 (default), on channel 1 for the second falling edge after the start of the measurement window:

MEASure:FALL:TIME? (@1),2

Typical Response: +0.045301E-03

The following command returns the fall time on for record 5 on channel 1 for the third rising edge after the trigger:

MEASure:RISE:TIME:VERBose? (@1),3,5

Typical Response: +0.045301E-03,+0,+1.374921E-05,+9.000000E+00,1.425191E-05,+1.000000E+02

See Also

Introduction to: MEASure Commands

MEASure:INSTall:DEFine

MEASure:WINDow[:DEFine]


MEASure:INSTall:CATalog?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

MEASure:INSTall:CATalog?

Description

This query returns an ordered, comma delimited list of the currently installed measurements.

Parameters

This command has no parameters.

Remarks

  • Each measurement's label is returned as a quoted string, in alphabetical order. This is the same order in which measurement results are returned in by the MEASure:INSTall:RESults[:RECord][:VERBose]? query.
  • If no measurement is installed, the query returns an empty string ("").

Return Format

Each label in the comma delimited list follows the format as specified by the MEASure:INSTall:DEFine command.

Example

The following command generates an ordered, comma delimited list of the currently installed measurements.

MEASure:INSTall:CATalog?

Typical Response: "MEZ_DC_ALL,MEZ_FT_12,MEZ_NW_ALL,MEZ_PW_123"

See Also

MEASure Subsystem Introduction

MEASure:INSTall:DEFine

MEASure:INSTall:DELete

MEASure:INSTall:RESults[:RECord][:VERBose]?


MEASure:INSTall:DEFine

Syntax

MEASure:INSTall:DEFine <label>,<meas_string>

MEASure:INSTall:DEFine? <label>

Description

This command installs the measurement specified in <meas_string> and gives it the name specified in <label>. Any documented measurement may be installed, but VERBose forms and record numbers are not allowed. Each defined <label> and each defined <meas_string> must be unique.

Parameters

Name | Type | Range of Values | Default Value
<label> String Symbolic name used as a label for the installed measurement. A <label> may contain up to 12 characters. The first character must be a letter (A-Z), but the remaining 11 characters can be letters, numbers (0-9), or an underscore ( _ ). Blank spaces are not allowed.

The <label> ALL is not allowed.

 This is a required parameter.
<meas_string> | Quoted String | Quoted string containing a MEASure command with related parameters. The VERBose forms of measurement commands are not allowed, and you cannot specify a record number as part of this parameter. | This is a required parameter.

Remarks

  • All installed measurements are installed for all records, and installed measurements are evaluated at the end of each acquisition. It is because measurements are installed for all records that you cannot specify a record number in the <meas_string>. Installing a new measurement invalidates the previously stored measurement results (if any) for existing data. To compute the results on the same data after installing one or more new measurements, use MEASure:INSTall:RUN.
  • Installing measurements is beneficial because it increases the speed at which the measurements are returned.
  • A *RST causes all installed measurements to be deleted.
  • If you attempt to define a <label> that already exists, the digitizer will overwrite the previous <meas_string> associated with the <label>.
  • If you attempt to install a measurement with a <meas_string> that already exists, the instrument will generate an error message. The error message is "Duplicate measurement not allowed."
  • The command performs a three-step error assessment. First, it assesses the label and reports an error if it is invalid. Then the parser evaluates the MEASure command in the <meas_string> for syntax and parameter validation. Finally, the software checks to see whether the maximum number of installed measurements has been reached. If so, the instrument issues an error message instructing you to delete a measurement before installing a new one.
  • The query form of the command removes excess white space and record number parameters from the command's <meas_string>. Also, the format of the <meas_string> uses only the short forms of the key words, in all upper case. For example, suppose you had installed the following <meas_string>:

    MEASure:FALL:PERiod? (@2) , 5, 11

    The MEASure:INSTall:DEFine? query for the associated label would return the following:

    MEAS:FALL:PER? (@2),5
  • You may query the results of one or all installed measurements with MEASure:INSTall:RESults[:RECord][:VERBose]?.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Return Format

The query returns the measurement string associated with the specified <label>. Any excess white space is removed, and only the short forms of the command key words are returned, in all uppercase.

Examples

The following command installs measurement that measures the width of the fifth positive pulse on channel 2. It gives the label MEZPW25 to this measurement.

MEASure:INSTall:DEFine MEZPW25,"MEAS:PWID? (@2),5"

The following query returns the measurement string associated with the specified <label>, MEZPW25.

MEASure:INSTall:DEFine? MEZPW25

Typical Response: ":MEAS:PWID? (@2),5"

See Also

MEASure Subsystem Introduction

MEASure:INSTall:DELete

MEASure:INSTall:CATalog?

MEASure:INSTall:RESults[:RECord][:VERBose]?

MEASure:INSTall:RUN


MEASure:INSTall:DELete

Syntax | Description | Parameters |Remarks | Return Format | Examples

Syntax

MEASure:INSTall:DELete {<label>|ALL}

Description

This command deletes one or all installed measurements. The *RST command also deletes all installed measurements.

To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Parameters

Name Type Range of Values Default Value
<label> String

You can specify that you want to delete ALL installed measurements, or just the measurement with a specific <label>, as described below.

A <label> is simply a name for an installed measurement. A <label> may contain up to 12 characters. The first character must be a letter (A-Z), but the remaining 11 characters can be letters, numbers (0-9), or underscores ( _ ). Blank spaces are not allowed.

 ALL

Remarks

  • All installed measurements are installed for all records, and installed measurements are evaluated at the end of each acquisition. Deleting a new measurement invalidates the previously stored measurement results (if any) for existing data. To compute the results on the same data after deleting one or more new measurements, use MEASure:INSTall:RUN.

Examples

The following command deletes all installed measurements.

MEAS:INST:DEL ALL

The following command deletes a measurement with the label MEZPW25. Of course, you first would have had to install this measurements with the MEAS:INST:DEF command.

MEAS:INST:DEL MEZPW25

See Also

MEASure Subsystem Introduction

MEASure:INSTall:DEFine

MEASure:INSTall:CATalog?

MEASure:INSTall:RUN


MEASure:INSTall:RESults:ERRor:RECord?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

MEASure:INSTall:RESults:ERRor:RECord?

Description

This query returns the record number of the first record with any measurement result code other than the success code. If the result codes of all records indicate success, the digitizer returns 0 for the record number.

Remarks

  • Use this query to determine whether you need to perform a MEASure:INSTall:RESults[:RECord][:VERBose]? query to investigate which measurements are questionable.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The query returns an unsigned integer.

Example

The following query indicates that record 10 is the first record with one or more measurements that have a result code other than 0 (result correct).

MEASure:INSTall:RESults:ERRor:RECord?

Typical Response: +10

See Also

MEASure Subsystem Introduction

MEASure:INSTall:RESults[:RECord][:VERBose]?


MEASure:INSTall:RESults[:RECord][:VERBose]?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

MEASure:INSTall:RESults[:RECord]? [{<label>|ALL} [,{<record_num>|ALL}]]

MEASure:INSTall:RESults[:RECord][:VERBose]? [{<label>|ALL} [,{<record_num>|ALL}]]

Description

This query returns the current results for the specified installed measurement or ALL measurements, on one or ALL records.

Parameters

Name | Type | Range of Values | Default Value
<label> | String | Symbolic name used as a label for the installed measurement. A <label> may contain up to 12 characters. The first character must be a letter (A-Z), but the remaining 11 characters can be letters, numbers (0-9), or an underscore ( _ ). Blank spaces are not allowed. | ALL
<record_num> | Numeric | Integer from 1 to 1024 | 1

Remarks

  • Results are returned in the format specified by FORMat[:DATA]:REAL.
  • If there are no installed measurements, the query returns an error indicating this.
  • Installed measurements are evaluated at the end of each acquisition.
  • If there are installed measurements, but no values have yet been measured, the query returns values of +9.910000E+37.
  • Values are returned in alphabetical order by <label> of the installed measurement. This is the same order in which data is returned by the MEASure:INSTall:CATalog? query.
  • If ALL records are returned, the data is returned in ascending record order, starting with record 1.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

If ASCii format is specified, the query returns a comma delimited list. Otherwise, the query uses the REAL format to return an IEEE 488 Definite Arbitrary Block. The byte order of the data in this block is returned as specified by the FORMat:BORDer command.

For each installed measurement, the VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

for each record, where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Floating point number
<Ax>

Horizontal time location (in seconds), from the start of the measurement window to the leading edge of the measurement.

 Floating point number
<Ay>

Vertical marker associated with the leading edge of the measurement.

 Floating point number
<Bx> | Horizontal time location (in seconds), from the start of the measurement window to the leading edge of the measurement. | Floating point number
<By> | Vertical marker associated with the trailing edge of the measurement. | Floating point number

Example

The following query returns values for all of the installed measurements on record 6.

MEASure:INSTall:RESults:RECord? ALL, 6

Typical Response: "+1.000000E+02,+2.345215E-01,-1.023619E+01"

The following query returns values for all of the installed measurements on record 6.

MEASure:INSTall:RESults:RECord? MEZ_RMS_2,6

Typical Response: "+9.612800E+01,+0.000000E+00,+3.336781E-05,+1.200000E+01,+3.401292E-05,+1.200000E+01"

See Also

MEASure Subsystem Introduction

MEASure:INSTall:DEFine

MEASure:WINDow[:DEFine]

FORMat[:DATA]:REAL


MEASure:INSTall:RUN

Syntax | Description | Parameters |Remarks | Return Format | Examples

Syntax

MEASure:INSTall:RUN

Description

This command re-evaluates the installed measurements based on the existing digitized samples.

Remarks

  • This can be useful if you reconfigure the installed measurements or thresholds and want to evaluate the new measurements on existing data.
  • On-board measurements are automatically evaluated at the end of each acquisition, so this command is often not required.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Examples

The following command re-evaluates the installed measurements on the existing digitized samples.

MEAS:INST:RUN

See Also

MEASure Subsystem Introduction

MEASure:INSTall:DEFine

MEASure:INSTall:RESults[:RECord][:VERBose]?


MEASure:NWIDth[:VERBose]?

Syntax

MEASure:NWIDth[:VERBose]? (@<channel>)[,<num_neg_pulse>[,<rec_num>]]

Description

This query returns the pulse width (in seconds) of the given cycle, starting at the midpoint of a falling edge.

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<num_neg_pulse> | Numeric | A positive integer representing the number of the negative pulse on which the measurement should be performed. | 1
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • If no pulse width can be calculated, +9.910000E+37 is reported. The <return_code> will indicate the nature of the problem in the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The standard form of the query returns the pulse width as <v al>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax> | Horizontal time location (in seconds) of the measurement's leading edge. Measured as the time from the start of the measurment window to the leading edge's middle threshold crossing. | Floating point number
<Ay>

Vertical voltage marker of the leading edge of measurement.

Vertical voltage marker of the leading edge of measurement. Measured as the voltage at the middle of the leading edge.

Floating point number
<Bx> | Horizontal time location (in seconds) of the measurement's trailing edge. Measured as the time from the start of the measurment window to the trailing edge's middle threshold crossing. | Floating point number
<By> | Vertical voltage marker of the measurement's trailing edge. For this measurement, <By> is defined to equal <Ay>. | Floating point number

Examples

The following measures the pulse width of the third cycle on channel 1 for record 1 (default).

MEASure:NWID? (@1),3

Typical Response: +4.735290E-04

The following query returns the VERBose form of the negative pulse width measurement of the third cycle on channel 1 for record 1 (default).

MEASure:NWID:VERB? (@1),3

Typical Response: +4.735290E-04,+0,+8.822699E-04,+1.000000E+01,+8.901566-04,+1.000000E+01

See Also

MEASure Subsystem Introduction

MEASure:PWIDth[:VERBose]?

MEASure:INSTall:DEFine

MEASure:WINDow[:DEFine]


MEASure:PWIDth[:VERBose]?

Syntax

MEASure:PWIDth[:VERBose]? (@<channel>)[,<num_pos_pulse>[,<rec_num>]]

Description

This query returns the pulse width (in seconds) of the given cycle, starting at the midpoint of a rising edge.

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<num_pos_pulse> | Numeric | A positive integer representing the number of the positive pulse on which the measurement should be performed. This is measured from the start of the measurement window. | 1
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • If no pulse width can be calculated, +9.910000E+37 is reported. The <return_code> will indicate the nature of the problem in the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The standard form of the query returns the pulse width as <v al>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax>

Horizontal time location (in seconds) of the measurement's leading edge. Measured as the time from the start of the measurment window to the leading edge's middle threshold crossing.

Floating point number
<Ay>

Vertical voltage marker of the leading edge of measurement. Measured as the voltage at the middle of the leading edge.

Floating point number
<Bx> | Horizontal time location (in seconds) of the measurement's trailing edge. Measured as the time from the start of the measurment window to the trailing edge's middle threshold crossing. | Floating point number
<By> | Vertical voltage marker of the measurement's trailing edge. For this measurement, <By> is defined to equal <Ay>. | Floating point number

Examples

The following command measures the record 1 (default) pulse width that starts with the seventh rising edge on channel 2.

MEASure:PWID? (@2),7

Typical Response: +4.735290E-04

The following command returns the verbose form of the pulse width measurement that starts with the seventh rising edge on channel 2, record 1 (default).

MEASure:PWID:VERBose? (@2),7

Typical Response: +4.735290E-04,+0,+8.822699E-04,+1.000000E+01,+8.901566-04,+1.000000E+01

See Also

MEASure Subsystem Introduction

MEASure:NWIDth[:VERBose]?

MEASure:INSTall:DEFine

MEASure:WINDow[:DEFine]


MEASure:RCODe:STRing?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

MEASure:RCODe:STRing? <return_code>

Description

This query returns the string that is associated with the specified <return_code> that is returned from the VERBose form of measurement queries. Measurements with a <return_code> other than +0 are questionable or incorrect for the reason associated with the <return_code>.

Parameters

Name | Type | Range of Values | Default Value
<return_code> | Numeric | Integer | This is a required parameter.

Remarks

Return Format

The query returns a quoted string of the following form: "<return_code_string>". The possible values of <return_code> and <return_code_string> are listed below.

Code | Meaning
-3 | No measurement result returned at all.
-2 | Result is pos pulse instead of period.
-1 | Result is neg pulse instead of period.
0 | Result correct. No problem found.
1 | Result questionable but could be measured.
2 | Result greater than or equal to value returned.
3 | Result less than or equal to value returned.
4 | Result returned is invalid.
5 | Result invalid. Required edge not found.
6 | Result invalid. Max not found.
7 | Result invalid. Min not found.
8 | Result invalid. Requested time not found.
9 | Result invalid. Requested voltage not found.
10 | Result invalid. Top and base are equal.
11 | Unexpected Error Code
12 | Result invalid. Lower threshold not on waveform.
13 | Result invalid. Upper threshold not on waveform.
14 | Result invalid. Upper and lower thresholds are too close.
15 | Result invalid. Top not on waveform.
16 | Result invalid. Base not on waveform.
17 | Result invalid. Completion criteria not reached.
18 | Result invalid. Measurement invalid for this type of waveform.
19 | Unexpected Error Code
20 | Result invalid. Waveform is clipped high.
21 | Result invalid. Waveform is clipped low.
22 | Result invalid. Waveform is clipped high and low.
23 | Result invalid. Data contains all holes.
24 | Result invalid. No data in defined window.
25-28 | Unexpected Error Code
29 | Result invalid. FFT peak not found.
30-34 | Unexpected Error Code
35 | Signal may be too small to evaluate.
36 | Unexpected Error Code
37 | The requested edge was ignored.
38-57 | Unexpected Error Code
58 | Measurement window disabled.
59 | Not sufficient valid window data.
60 | Measurements aborted.

Example

The following command returns the meaning of return code 58.

MEASure:RCOD:STRing? 58

Typical Response: "58,Measurement window disabled."

See Also

MEASure Subsystem Introduction

MEASure:INSTall:RESults:ERRor:RECord?

MEASure:INSTall:RESults[:RECord][:VERBose]?


MEASure:THResholds:ABSolute

Syntax

MEASure:THResholds:ABSolute (@<chan_list>),<vHigh>,<vMid>,<vLow>

MEASure:THResholds:ABSolute? (@<chan_list>)

Description

This command configures the absolute threshold level for the given channels. These absolute thresholds become active only if MEAS:THR:METHod is set to ABSolute.

Parameters

Name Type Range of Values Default Value

<chan_list>

 Channel list

One or more channels, specified as in the following examples.

(@2) - channel 2

(@1,4) - channels 1 and 4

(@1:4) - channels 1 through 4.

 This is a required parameter.
<vHigh> Numeric vMid < vHigh <= 256 V This is a required parameter.

The reset value is +1.
<vMid> Numeric vLow < vMid < VHigh This is a required parameter.

The reset value is 0.
<vLow> Numeric vLow < vMid This is a required parameter.

The reset value is -1.

Remarks

  • Absolute thresholds are useful when the percentage threshold method (MEASure:THResholds:PERCent) does not produce satisfactory results.
  • The minimum resolution between any two numeric parameters is 0.001V.
  • All installed measurements are installed for all records, and installed measurements are evaluated at the end of each acquisition with current settings. Changing measurement settings invalidates the previously stored measurement results (if any) for existing data. To compute the results on the same data with new measurement settings, use MEASure:INSTall:RUN.
  • Values set are checked only for descending values (vHigh > vMid > vLow), and not exceeding the maximum range (256 V) of the digitizer. There are no settings conflict checks afterwards should the range be changed to be lower than the threshold. If you are concerned about this, use the PERCent thresholds.
  • When <vHigh> or <vLow> fall outside the channel's range, no cycles will be detected in the resulting measurements.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Examples

The following command sets the high, mid, and low values to 100, 50 and 10 V for channel 1.

MEASure:THResholds:ABSolute (@1),100,50,10

The following query returns the high, middle and low voltage values for channels 1, 2 and 4.

MEASure:THResholds:ABSolute? (@1,2,4)

Typical Response: +1.000000E+02,+5.000000E+01,+1.000000E+01,+3.000000E+01,+2.000000E+01,+1.000000E+01,+9.000000E+00,+5.000000E+00,+1.000000E+00

See Also

MEASure Subsystem Introduction

MEASure:THResholds:TOPBase:ABSolute

MEASure:THResholds:METHod


MEASure:THResholds:METHod

Syntax

MEASure:THResholds:METHod (@<chan_list>),<method>

MEASure:THResholds:METHod? (@<chan_list>)

Description

This command configures the threshold assessment method for the specified channels. Subsequent measurements on these channels will use this method for Hi/Mid/Lo threshold evaluation.

Parameters

Name | Type | Range of Values | Default Value

<chan_list>

Channel list

One or more channels, specified as in the following examples.

(@2) - channel 2

(@1,4) - channels 1 and 4

(@1:4) - channels 1 through 4.

 This is a required parameter.
<method> | Discrete | {PERCent|ABSolute} | This is a required parameter.

Remarks

  • The PERCent <method> uses a percentage of (Top-Base) to assess high, middle, and low thresholds as specified by the MEASure:THResholds:PERCent command.
  • The ABSolute <method> uses explicit high, middle, and low voltage levels specified by the MEASure:THResholds:ABSolute command.
  • All installed measurements are installed for all records, and installed measurements are evaluated at the end of each acquisition with current settings. Changing measurement settings invalidates the previously stored measurement results (if any) for existing data. To compute the results on the same data with new measurement settings, use MEASure:INSTall:RUN.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Return Format

The query form of the command returns PERC or ABS for each channel in the <chan_list>.

Examples

The following command configures channel 2 to use the PERCent method.

MEASure:THResholds:METHod (@2),PERC

The following command returns the <method> for all four channels.

MEASure:THResholds:METH? (@1:4)

Typical Response: PERC,ABS,ABS,PERC

See Also

MEASure Subsystem Introduction

MEASure:THResholds:PERCent

MEASure:THResholds:ABSolute


MEASure:THResholds:PERCent

Syntax

MEASure:THResholds:PERcent (@<chan_list>),<%High>,<%Mid>,<%Low>

MEASure:THResholds:PERcent? (@<chan_list>)

Description

This command configures the percentage threshold level for the given channels. These percentage thresholds become active only if MEAS:THR:METHod is set to PERCentage.

Parameters

Name Type Range of Values Default Value

<chan_list>

 Channel list

One or more channels, specified as in the following examples.

(@2) - channel 2

(@1,4) - channels 1 and 4

(@1:4) - channels 1 through 4.

 This is a required parameter.
<%High> Numeric Each of these three numbers must be between 0 and 100, inclusive. Also, <%Low> must be less than <%Mid>, which in turn must be less than <%Max>. This is a required parameter.

The reset value is 90.
<%Mid> Numeric This is a required parameter.

The reset value is 50.
<%Low> Numeric This is a required parameter.

The reset value is 10.

Remarks

  • The minimum resolution for the three numeric parameters is 0.1%.
  • The instrument checks values only for descending values (%High > %Mid > %Low), and not exceeding the minimum range (0) or maximum range (100). There are no settings conflict checks afterwards should the range be changed to be lower than the threshold.
  • All installed measurements are installed for all records, and installed measurements are evaluated at the end of each acquisition with current settings. Changing measurement settings invalidates the previously stored measurement results (if any) for existing data. To compute the results on the same data with new measurement settings, use MEASure:INSTall:RUN.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Examples

The following command sets the low, mid and high values to 10%, 50% and 90% of the range for channel 1.

MEASure:THResholds:PERC (@1),90,50,10

The following command returns the high, middle and low voltage levels for channels 2 through 4.

MEAS:THR:PERC? (@2:4)

Typical Response: +9.000000E+01,,+5.000000E+01+1.000000E+01,+5.000000E+01,+2.000000E+01,+8.000000E+00,+1.000000E+02,+4.000000E+01,+3.000000E+01

See Also

MEASure Subsystem Introduction

MEASure:THResholds:METHod


MEASure:THResholds:RESet

Syntax

MEASure:THResholds:RESet <@chan_list>

Description

This command configures the specified channels to the RESET Top/Base and Thresholds state. In particular, it is equivalent to the following commands:

MEAS:THR:METHod <@chan_list> PERCent
MEAS:THR:PERCent <@chan_list>,90.0, 50.0, 10.0
MEAS:THR:ABSolute <@chan_list>, 1,0,-1
MEAS:THR:TOPB:METHod <@chan_list>STANdard
MEAS:THR:TOPB:ABSolute <@chan_list>, 1,-1

Parameters

Name Type Range of Values Default Value
<chan_list>

Channel list

One or more channels, specified as in the following examples.

(@2) - channel 2

(@1,4) - channels 1 and 4

(@1:4) - channels 1 through 4.

 This is a required parameter.

Remarks

  • This command is equivalent to the above series of commands. It is a way to set thresholds to the reset state without resetting the entire instrument.
  • All installed measurements are installed for all records, and installed measurements are evaluated at the end of each acquisition with current settings. Changing measurement settings invalidates the previously stored measurement results (if any) for existing data. To compute the results on the same data with new measurement settings, use MEASure:INSTall:RUN.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Examples

The following command configures channel 3 to the RESET Top/Base and Thresholds state.

MEASure:THResholds:RESet (@3)

See Also

MEASure Subsystem Introduction

MEASure:THResholds:TOPBase:METHod

MEASure:THResholds:METHod


MEASure:THResholds:TOPBase:ABSolute

Syntax

MEASure:THResholds:TOPBase:ABSolute (@<chan_list>),<vTop>,<vBase>

MEASure:THResholds:TOPBase:ABSolute? (@<chan_list>)

Description

This command configures the absolute Top and Base threshold levels for the specified channels. These absolute thresholds become active only if MEASure:THResholds:TOPBase:METHod is set to ABSolute. Because the different channels may be set to different ranges, different absolute Top and Base thresholds may result.

Parameters

Name Type Range of Values Default Value
<chan_list> Channel list

One or more channels, specified as in the following examples.

(@2) - channel 2

(@1,4) - channels 1 and 4

(@1:4) - channels 1 through 4.

 This is a required parameter.
<vTop> Numeric -256 V to +256 V. Must be greater than <vBase>. This is a required parameter.

The reset value is 1.
<vBase> Numeric -256 V to + 256 V. Must be less than <vTop>. This is a required parameter.

The reset value is -1.

Remarks

  • The <vTop> and <vBase> parameters define the signal amplitude.
  • Absolute thresholds are useful when the percentage threshold method (MEASure:THResholds:PERCent)does not produce satisfactory results.
  • All installed measurements are installed for all records, and installed measurements are evaluated at the end of each acquisition with current settings. Changing measurement settings invalidates the previously stored measurement results (if any) for existing data. To compute the results on the same data with new measurement settings, use MEASure:INSTall:RUN.
  • The minimum resolution for the two numeric parameters is 0.001 V.
  • Values set are checked only for ascending values (<vBase> < <vTop>), and not exceeding the maximum range (256 V) of the digitizer. There are no settings conflict checks afterwards should the channel range be changed to be lower than the top-base settings. If you are concerned about this, use the PERCent top-base thresholds instead.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Return Format

The query form of the command returns <vTop> and <vBase> for each channel in the <chan_list>.

Examples

The following command sets the top and base for the first three channels to 50 V and 10 V, respectively.

MEASure:THResholds:TOPBase:ABSolute (@1:3),50,10

The following query returns the Top and Base thresholds for all four channels.

MEAS:THR:TOPB:ABS? (@1:4)

Typical result: +9.000000E+01,+1.000000E+01,+5.000000E+01,+2.000000E+01,+8.000000E+01,+1.000000E+01,+4.000000E+01,+3.000000E+01

See Also

MEASure Subsystem Introduction

MEASure:THResholds:TOPBase:METHod


MEASure:THResholds:TOPBase:METHod

Syntax

MEASure:THResholds:TOPBase:METHod (@<chan_list>),<method>

MEASure:THResholds:TOPBase:METHod? (@<chan_list>)

Description

This command configures the Top-Base method for the given channels.

Parameters

Name Type Range of Values Default Value
<chan_list> Channel list

One or more channels, specified as in the following examples.

(@2) - channel 2

(@1,4) - channels 1 and 4

(@1:4) - channels 1 through 4.

 This is a required parameter.
<method> Discrete {STANdard|ABSolute} This is a required parameter.

The reset value is STANdard.

Remarks

  • The STANdard method uses a histogram algorithm to assess Top/Base. If it produces a statistically unsatisfactory result, it switches to a Min/Max method.
  • The ABSolute method forces the absolute voltage levels configured with MEASure:THReshold:TOPBase:ABSolute to be used as the Top and Base values.
  • All installed measurements are installed for all records, and installed measurements are evaluated at the end of each acquisition with current settings. Changing measurement settings invalidates the previously stored measurement results (if any) for existing data. To compute the results on the same data with new measurement settings, use MEASure:INSTall:RUN.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Return Format

The query returns STAN or ABS for each channel in the <chan_list>.

Examples

The following command sets the TOPBase method on channels 1 and 2 to STANdard.

MEASure:THResholds:TOPBase:METHod (@1,2),STAN

The following query returns the <method> for channels 1 and 2.

MEASure:THResholds:TOPBase:METHod? (@1,2)

Typical Response: STAN,STAN

See Also

MEASure Subsystem Introduction

MEASure:THResholds:TOPBase:ABSolute


MEASure:VAMPlitude[:VERBose]?

Syntax

MEASure:VAMPlitude:[VERBose]? (@<channel>) [,<rec_num>]

Description

This query returns the amplitude for the specified <channel>, using the difference between VTOP (MEASure:VTOP[:VERBose]?) and VBASe (MEASure:VBASe[:VERBose]?) as assessed by the histogram method or the absolute method. See MEASure:THResholds:TOPBase:METHod.

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • If no voltage amplitude can be calculated, +9.910000E+37 is reported. The <return_code> will indicate the nature of the problem in the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The standard form of the query returns the amplitude as <v al>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax>

Horizontal time location (in seconds) of the measurement's leading edge. This will always be zero (0), as it is the time of the first sample in the measurement window.

Floating point number
<Ay>

Vertical voltage marker of the measurement's leading edge. For this measurement, <Ay> is defined to equal VBASe.

 Floating point number
<Bx> | Horizontal time location (in seconds) of the measurement's trailing edge. Measured as the time from the start of the measurement window to the last sample in the measurement window. | Floating point number
<By> | Vertical voltage marker of the measurement's trailing edge. For this measurement, <By> is defined to equal VTOP. | Floating point number

Examples

The following query returns the amplitude of record 1 (default) on channel 1.

MEASure:VAMPlitude? (@1)

Typical Response: +3.362989E+01

The following command returns the VERBose form of the amplitude for record 10 on channel 1.

MEASure:VAMPlitude:VERBose? (@1),10

Typical Response: +3.362989E+01,+0,+0.000000E+00,+3.362989E+01,+1.20289331E-05,+3.362989E+01

See Also

MEASure Subsystem Introduction

MEASure:INSTall:DEFine

MEASure:THResholds:TOPBase:METHod

MEASure:WINDow[:DEFine]


MEASure:VAVerage[:VERBose]?

Syntax

MEASure:VAVerage[:VERBose]? (@<channel>) [,<mode>] [,<rec_num>]

Description

This command calculates the arithmetic average (mean) voltage for either a CYCLe or WINDow.

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<mode> | Discrete | {CYCLe|WINDow} | WINDow
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • Setting the <mode> to WINDow assesses the arithmetic average of the waveform across the entire window. For repeating cyclical waveforms, the number of cycles will usually not be an integer.
  • Setting the <mode> to CYCLe assesses the arithmetic average for the first cycle found in the window, whether rising or falling. This enables you to obtain the mean (arithmetic average) value for a single sample. The CYCLe version of the command cannot be targeted at any cycle other than the first cycle; as such, this feature is not useful for discerning arithmetic differences between subsequent cycles.
  • If no average voltage can be calculated, +9.910000E+37 is reported. The <return_code> will indicate the nature of the problem in the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The standard form of the query returns the average voltage as <v al>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax> | Horizontal time location, measured as the number of seconds from the start of the measurement window, of the measurement's leading edge. This will either be the beginning of the CYCLe or the beginning of the WINDow, depending on how the <mode> is set. | Floating point number
<Ay>

Average (arithmetic mean) value of the voltage in the specified CYCLe or WINDow.

 Floating point number
<Bx> | Horizontal time location, measured as the number of seconds from the start of the measurement window, of the measurement's trailing edge. This will either be the end of the CYCLe or the end of the WINDow, depending on how the <mode> is set. | Floating point number
<By> | Average (arithmetic mean) value of the voltage in the specified CYCLe or WINDow. For this command, <By> is defined to equal <Ay>. | Floating point number

Examples

The following query returns the average voltage of the first record over the first cycle on channel 2.

MEASure:VAVerage:VERBose? (@2),CYCL,1

Typical Response: +2.716789E+01

The following query returns the VERBose form of the average voltage measurement for record 1 (default) over the first cycle on channel 2.

MEASure:VAVerage:VERBose? (@2),CYCL

Typical Response: +2.716789E+01,+0,+3.881697E-04,+3.258977E+01,+3.914283E-04,+3.258977+01

See Also

MEASure Subsystem Introduction

MEASure:INSTall:DEFine

MEASure:WINDow[:DEFine]


MEASure:VBASe[:VERBose]?

Syntax

MEASure:VBASe[:VERBose]? (@<channel>) [,<rec_num>]

Description

This query returns the base voltage used for cycle based measurements. This value forms the lower voltage of an amplitude measurement. Base may be evaluated using the STANdard (histogram) method or the ABSolute method. For more information, see MEASure:THResholds:TOPBase:METHod.

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • If no base voltage can be calculated, +9.910000E+37 is reported. The <return_code> will indicate the nature of the problem in the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The standard form of the query returns the base voltage as <v al>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax> | Horizontal time location (in seconds) of the measurement's leading edge. This will always be zero (0), as it is the time of the first sample in the measurement window. | Floating point number
<Ay>

Vertical voltage marker of the leading edge of measurement. Equal to VBASe threshold.

 Floating point number
<Bx> | Horizontal time location (in seconds) of the measurement's trailing edge. Measured as the time from the start of the measurement window to the last sample in the measurement window. | Floating point number
<By> | Vertical voltage marker of the measurement's trailing edge. For this measurement, <By> is defined to equal <Ay>. | Floating point number

Examples

The following command returns the base measurement for record 1 (default) on channel 1.

MEASure:VBAS? (@1)

Typical Response: +4.261084E-03

The following command returns the verbose form of the base measurement for record 10 on channel 3.

MEASure:VBAS:VERBose? (@3),10

Typical Response: +4.261084E-03,+0,+0.000000E+00,+4.261084E-03,+7.287216E-05,+4.261084E-03

See Also

MEASure Subsystem Introduction

MEASure:INSTall:DEFine

MEASure:THResholds:TOPBase:METHod

MEASure:WINDow[:DEFine]


MEASure:VLOWer[:VERBose]?

Syntax

MEASure:VLOWer[:VERBose]? (@<channel>) [,<rec_num>]

Description

This query returns the lower threshold voltage level. This value is determined by the threshold method specified by MEASure:THResholds:METHod, and it is used by other waveform measurements, such as MEASure:FALL:TIME[:VERBose]? and MEASure:RISE:TIME[:VERBose]?.

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • If no lower threshold levelcan be calculated, +9.910000E+37 is reported. The <return_code> will indicate the nature of the problem in the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The standard form of the query returns the lower voltage as <v al>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax> | Horizontal time location (in seconds) of the measurement's leading edge. This will always be zero (0), as it is the time of the first sample in the measurement window. | Floating point number
<Ay>

Vertical voltage marker of the leading edge of measurement. Equal to VLOWer threshold.

 Floating point number
<Bx> | Horizontal time location (in seconds) of the measurement's trailing edge. Measured as the time from the start of the measurement window to the last sample in the measurement window. | Floating point number
<By> | Vertical voltage marker of the measurement's trailing edge. For this measurement, <By> is defined to equal <Ay>. | Floating point number

Examples

The following query returns the lower threshold level of record 1 (default) on channel 1.

MEASure:VLOWer? (@1)

Typical Response: +2.674527E+01

The following command returns the VERBose form of the query for the lower threshold level of record 5 on channel 2.

MEASure:VLOWer:VERBose? (@2),5

Typical Response: +2.674527E+01,+0,+0.000000E+00,+2.674527E+01,4.619368E-05,+2.674527E+01

See Also

MEASure Subsystem Introduction

MEASure:VMIDdle[:VERBose]?

MEASure:VUPPer[:VERBose]?

MEASure:INSTall:DEFine

MEASure:WINDow[:DEFine]


MEASure:VMAX[:VERBose]?

Syntax

MEASure:VMAX[:VERBose]? (@<channel>) [,<rec_num>]

Description

This query returns the maximum voltage for the specified record and channel.

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • If no maximum voltage can be calculated, +9.910000E+37 is reported. The <return_code> will indicate the nature of the problem in the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The standard form of the query returns the maximum voltage as <val>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax>

Horizontal time location (in seconds) from the start of the measurement window to the measurement's leading edge. This equals the time of the first VMAX value in the window.

 Floating point number
<Ay>

Maximum value of the voltage.

 Floating point number
<Bx> | Horizontal time location (in seconds) from the start of the measurement window to the measurement's trailing edge. For this measurement, <Bx> is defined to equal <Ax>. | Floating point number
<By> | Maximum value of the voltage. For this measurement, <By> is defined to equal <Ay>. | Floating point number

Examples

The following command returns the maximum voltage for record 1 on channel 4.

MEASure:VMAX? (@4),1

Typical Response: +1.053281E+02

The following command returns the VERBose form of the maximum voltage measurement on channel 4 for record 1 (default).

MEASure:VMAX:VERBose? (@4)

Typical Response: +1.053281E+02,+0,+4.261266E-04,+1.053281E+02,+4.261266E-04,+1.053281E+02,

See Also

MEASure Subsystem Introduction

MEASure:INSTall:DEFine

MEASure:VMIN[:VERBose]?

MEASure:WINDow[:DEFine]


MEASure:VMIDdle[:VERBose]?

Syntax

MEASure:VMIDdle[:VERBose]? (@<channel>) [,<rec_num>]

Description

This query returns the middle threshold voltage level. This value is determined by the threshold method specified by MEASure:THResholds:METHod, and it is used by other waveform measurements, such as MEASure:FALL:FREQuency[:VERBose]? and MEASure:RISE:FREQuency[:VERBose]?.

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • If no middle threshold can be calculated, +9.910000E+37 is reported. The <return_code> will indicate the nature of the problem in the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The regular form of the query returns middle voltage threshold as <val>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax> | Horizontal time location (in seconds) of the measurement's leading edge. This will always be zero (0), as it is the time of the first sample in the measurement window. | Floating point number
<Ay>

Vertical voltage marker of the leading edge of measurement. Equal to VMIDdle threshold.

 Floating point number
<Bx> | Horizontal time location (in seconds) of the measurement's trailing edge. Measured as the time from the start of the measurement window to the last sample in the measurement window. | Floating point number
<By> | Vertical voltage marker of the measurement's trailing edge. For this measurement, <By> is defined to equal <Ay>. | Floating point number

Examples

The following query returns the middle threshold level for record 1 (default) on channel 1.

MEASure:VMID? (@1)

Typical Response: +1.000000E+02

The following query returns the VERBose form of the middle threshold measurement of record 5 on channel 2.

MEASure:VMID:VERB? (@2),5

Typical Response: +1.000000E+02,+0,+0.000000E+00,+1.000000E+02,+4.022368E-06,+1.000000E+02

See Also

MEASure Subsystem Introduction

MEASure:VLOWer[:VERBose]?

MEASure:VUPPer[:VERBose]?

MEASure:WINDow[:DEFine]

MEASure:INSTall:DEFine


MEASure:VMIN[:VERBose]?

Syntax

MEASure:VMIN[:VERBose]? (@<channel>) [,<rec_num>]

Description

This query returns the minimum voltage on the specified channel and record number.

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • If no minimum voltage can be calculated, +9.910000E+37 is reported. The <return_code> will indicate the nature of the problem in the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The regular form of the query returns the minimum voltage as <val>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax>

Horizontal time marker location (in seconds), measured as the number of seconds from the start of the measurement window, of the leading edge of measurement. For this measurement, <Ax> equals the time of the first occurrence of the minimum voltage in the window.

 Floating point number
<Ay>

Vertical voltage marker equal to the minimum voltage of the wave form.

 Floating point number
<Bx> | Horizontal time location (in seconds), measured as the number of seconds from the start of the measurement window, of the measurement's trailing edge. For this measurement, <Bx> is defined to equal <Ax>. | Floating point number
<By> | Vertical voltage marker of the measurement's trailing edge. For this measurement, <By> is defined to equal <Ay>. | Floating point number

Examples

The following command returns the minimum voltage on channel 3 for record 1 (default).

MEASure:VMIN? (@3)

Typical Response: +1.026288E-01

The following command returns the VERBose form of the minimum voltage measurement for record 6 on channel 2.

MEAS:VMIN:VERB? (@2),6

Typical Response: +1.016288E-01,+0,+3.621755E-04,+1.016288E-01,+3.612755E-04,+1.016288E-01

See Also

MEASure Subsystem Introduction

MEASure:VMAX[:VERBose]?

MEASure:INSTall:DEFine

MEASure:WINDow[:DEFine]


MEASure:VPP[:VERBose]?

Syntax

MEASure:VPP[:VERBose]? (@<channel>) [,<rec_num>]

Description

This query returns the peak-to-peak voltage for the specified record on the specified channel.

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • If no peak-to-peak voltage can be calculated, +9.910000E+37 is reported. The <return_code> will indicate the nature of the problem in the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The standard form of the query returns the peak to peak voltage as <val>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax>

Horizontal time location (in seconds), measured as the number of seconds from the start of the measurement window, of the measurement's leading edge. This is either the time of the minimum or maximum voltage, whichever comes first.

 Floating point number
<Ay>

Vertical voltage marker of the leading edge of measurement. This is either the minimum of maximum voltage in the window, whichever comes first.

 Floating point number
<Bx> | Horizontal time location (in seconds), measured as the number of seconds from the start of the measurement window, of the measurement's trailing edge. This is either the time of the minimum or maximum voltage in the window, whichever comes second. | Floating point number
<By> | Vertical voltage marker of the trailing edge of measurement. This is either the minimum of maximum voltage, whichever comes second. | Floating point number

Examples

The following command returns the peak to peak voltage on channel 1 for record 1 (default).

MEASure:VPP? (@1)

Typical Response: +3.616771E+01

The following command returns the VERBose form of the peak to peak voltage measurement on channel 1 for record 1.

MEASure:VPP:VERBose? (@1),1

Typical Response: +3.616771E+01,+0,+7.816496E-04,+7.913569E+01,+7.823496E-04,+1.816295E+01

See Also

MEASure Subsystem Introduction

MEASure:INSTall:DEFine

MEASure:WINDow[:DEFine]


MEASure:VRMS[:VERBose]?

Syntax

MEASure:VRMS[:VERBose]? (@<channel>)[,<mode>,<coupling>] [,<rec_num>]

Description

This query returns the root mean square (RMS) average voltage for either a cycle or a measurement window.

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<mode> | Discrete | {CYCLe|WINDow} | WINDow

<coupling>

 Discrete {AC|DC} DC
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • Setting the <mode> to WINDow assesses the RMS average of the waveform across the entire window. For repeating cyclical waveforms, the number of cycles will usually not be an integer.
  • Setting the <mode> to CYCLe assesses the RMS average for the first cycle found in the window, whether rising or falling. This enables you to obtain the RMS value for an integer number of samples (1). The CYCLes version of the command cannot be targeted at any cycle other than the first cycle; as such, this feature is not useful for discerning RMS differences between subsequent cycles.
  • Setting the <coupling> to AC performs the RMS measurement, subtracting the DC component. Setting <coupling> to DC includes the DC component in the RMS calculation.
  • If no RMS voltage can be calculated, +9.910000E+37 is reported. The <return_code> will indicate the nature of the problem in the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The standard form of the query returns the root-mean-square (RMS) voltage as <v al>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax> | Horizontal time location, measured as the number of seconds from the start of the measurement window, of the measurement's leading edge. This will either be the beginning of the CYCLe or the beginning of the WINDow, depending on how the <mode> is set. | Floating point number
<Ay>

Vertical voltage marker of the leading edge of measurement. Equal to VMIDdle threshold.

 Floating point number
<Bx> | Horizontal time location, measured as the number of seconds from the start of the measurement window, of the measurement's trailing edge. This will either be the end of the CYCLe or the end of the WINDow, depending on how the <mode> is set. | Floating point number
<By> | Vertical voltage marker of the measurement's trailing edge. For this measurement, <By> is defined to equal <Ay>. | Floating point number

Examples

The following command measures the VRMS for record 1 (default) of the first cycle on channel 3, using AC coupling.

MEASure:VRMS? (@3),CYCL,AC

Typical Response: +9.612800E+01

The following command returns the VERBose form of the VRMS measurement for record 5 of the first cycle on channel 3, using DC coupling.

MEAS:VRMS:VERB? (@3),CYCL,DC,5

Typical Response: +9.612800E+01,+0,+3.336781E-05,+9.612800E+01,+3.401292E-05,+9.612800E+01

See Also

MEASure Subsystem Introduction

MEASure:INSTall:DEFine

MEASure:WINDow[:DEFine]


MEASure:VTOP[:VERBose]?

Syntax

MEASure:VTOP[:VERBose]? (@<channel>) [,<rec_num>]

Description

This query returns the top voltage used for cycle based measurements. This value forms the higher voltage of an amplitude measurement. Top may be evaluated using the STANdard (histogram) method or the ABSolute method. For more information, see MEASure:THResholds:TOPBase:METHod.

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • If no top voltage threshold can be calculated, +9.910000E+37 is reported. The <return_code> will indicate the nature of the problem in the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The standard form of the query returns the top voltage threshold as <val>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax> | Horizontal time location (in seconds) of the measurement's leading edge. This will always be zero (0), as it is the time of the first sample in the measurement window. | Floating point number
<Ay>

Vertical voltage marker of the leading edge of measurement. Equal to VTOP threshold.

 Floating point number
<Bx> | Horizontal time location (in seconds) of the measurement's trailing edge. Measured as the time from the start of the measurement window to the last sample in the measurement window. | Floating point number
<By> | Vertical voltage marker of the measurement's trailing edge. For this measurement, <By> is defined to equal <Ay>. | Floating point number

Examples

The following query returns the top voltage for record 1 (default) on channel 2.

MEASure:VTOP? (@2)

Typical Response: +8.216123E+01

The following query returns the VERBose form of top voltage for record 1 (default) on channel 2.

MEASure:VTOP:VERBose? (@2)

Typical Response: +8.216123E+01,+0,+0.000000E+00, +8.216123E+01,1.371267E-05, +8.216123E+01

See Also

MEASure Subsystem Introduction

MEASure:VBASe[:VERBose]?

MEASure:INSTall:DEFine

MEASure:WINDow[:DEFine]

MEASure:THResholds:TOPBase:METHod


MEASure:VUPPer[:VERBose]?

Syntax

MEASure:VUPPer[:VERBose]? (@<channel>) [,<rec_num>]

Description

This query returns the upper threshold voltage level. This value is determined by the threshold method specified by MEASure:THResholds:METHod, and it is used by other waveform measurements, such as MEASure:FALL:TIME[:VERBose]? and MEASure:RISE:TIME[:VERBose]?.

Parameters

Name | Type | Range of Values | Default Value
<channel> Channel

Desired channel (one channel only):

(@1)

(@2)

(@3) (four channel digitizer only)

(@4) (four channel digitizer only)

 This is a required parameter.
<rec_num> | Numeric | Integer from 1 to the number of records. | 1

Remarks

  • If no upper threshold level can be calculated, +9.910000E+37 is reported. The <return_code> will indicate the nature of the problem in the VERBose form of the query.
  • You can install this measurement using the MEASure:INSTall:DEFine command. Installing the measurement improves performance and speeds up the return of data.
  • All measurements are made on the samples acquired within the measurement window defined by the MEASure:WINDow[:DEFine] command.
  • To run this query, you cannot be in calibration mode. The query blocks you from entering calibration mode.

Return Format

The standard form of the query returns the upper threshold level as <val>.

The VERBose form of the query returns the following :

<val>, <return_code>, <Ax>, <Ay>, <Bx>, <By>

where:

Value | Description | Data Format
<val>

Measurement result (or +9.910000E+37 if no valid value can be calculated).

Floating point number
<return_code> | Measurement's Return Code (see MEAS:RCODe:STRing for a complete list of return codes and their meanings). | Signed integer, with the minimum number of digits required to display the number, such as -4 or +22.
<Ax> | Horizontal time location (in seconds) of the measurement's leading edge. This will always be zero (0), as it is the time of the first sample in the measurement window. | Floating point number
<Ay>

Vertical voltage marker of the leading edge of measurement. Equal to VUPPer threshold.

 Floating point number
<Bx> | Horizontal time location (in seconds) of the measurement's trailing edge. Measured as the time from the start of the measurement window to the last sample in the measurement window. | Floating point number
<By> | Vertical voltage marker of the measurement's trailing edge. For this measurement, <By> is defined to equal <Ay>. | Floating point number

Examples

The following query returns the upper threshold level for record 1 (default) on channel 1.

MEASure:VUPPer? (@1)

Typical Response: +1.050000E+02

The query returns the VERBose form of the upper threshold level measurement for record 5 (default) on channel 1.

MEASure:VUPPer:VERBose? (@1),5

Typical Response: +1.050000E+02,+0,+0.000000E+00,+1.050000E+02,+6.782378E-05,+1.050000E+02

See Also

MEASure Subsystem Introduction

MEASure:VLOWer[:VERBose]?

MEASure:VMIDdle[:VERBose]?

MEASure:INSTall:DEFine

MEASure:WINDow[:DEFine]


MEASure:WINDow[:DEFine]

Syntax

MEASure:WINDow[:DEFine] <start_offset>, <size>

MEASure:WINDow[:DEFine]?

Description

This command sets the measurement window in which on-board measurements are performed.

Parameters

Name | Type | Range of Values | Default Value
<start_offset> Numeric

An integer of offset from the first post trigger sample to the start of the Measurement Window. Negative values indicate offsets before the trigger reading, and positive values indicate offsets after the trigger reading. A value of 0 indicates a start at the trigger reading.

This must be in a range from the negative of the number of pre-trigger samples to the number of post-trigger samples minus 8. The "minus 8" accounts for the minimum window size.

 This is a required parameter.
<size> | Numeric | The number of samples within the Measurement Window, from the <start_offset>. The minimum value of 0 turns on-board measurement (OBM) off. The minimum value that leaves OBM on is 8. The static maximum is 1,000,000 samples, and the dynamic maximum is the number of samples in the record following the <start_offset>. | This is a required parameter.

Remarks

  • Setting <size> to 0 implicitly disables the OBM feature.
  • All measurements installed with MEASure:INSTall:DEFine are computed over this window for all of the records configured by [CONFigure:]ACQuisition[:ATTRibutes]. If the acquisition is configured for multiple records, you can retrieve results for one record, a range of records, or all records with MEASure:INSTall:RESults[:RECord][:VERBose]?.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Return Format

The query returns <start_offset>, <size>.

Examples

The following command disables on-board measurement (OBM):

MEASure:WINDow[:DEFine] 0,0

The following command sets the measurement window to start 3 samples before the trigger reading, with a size of 50 samples.

MEASure:WINDow[:DEFine] -3,50

The following query returns the measurement window parameters.

MEASure:WINDow[:DEFine]?

Typical Response: -3,+50

See Also

MEASure Subsystem Introduction

MEASure:INSTall:DEFine

[CONFigure:]ACQuisition[:ATTRibutes]


READ Subsystem Introduction

Command Summary

READ:WAVeform:ADC?

READ:WAVeform:VOLTage?


READ:WAVeform:ADC?

Syntax

READ:WAVeform:ADC? (@<chan_list>)[,<start>[,<count> [,<rec_range> [,<dec_type>,<dec_count>]]]]

Description

This command is equivalent to INITiate followed by FETCh:WAVEform:ADC?. Its parameters and operation are the same, other than the INIT and the word READ instead of FETCh.

In general, the combination of INITiate and FETCh:WAVeform:ADC? is superior, but READ:WAVeform:ADC? can offer a small speed advantage for a series of short, rapid digitizing configurations.

See Also

FETCh:WAVeform:ADC?

INITiate


READ:WAVeform:VOLTage?

Syntax

READ:WAVeform:VOLTage? (@<chan_list>)[,<start>[,<count> [,<recList> [,<dec_type>,<dec_count>]]]]

Description

This command is equivalent to INITiate followed by FETCh:WAVEform:VOLTage?. Its parameters and operation are the same, other than the INIT and the word READ instead of FETCh.

In general, the combination of INITiate and FETCh:WAVeform:VOLTage? is superior, but READ:WAVeform:VOLTage? can offer a small speed advantage for a series of short, rapid digitizing configurations.

See Also

FETCh:WAVeform:VOLTage?

INITiate


STATus Subsystem Introduction

Agilent L4532/34A Status System Diagram

Printable PDF Version

STATus:PRESet

Command Summary

*ESE

*ESE?

*ESR?

*SRE

*STB?

STATus:OPERation:CONDition?

STATus:OPERation:ENABle

STATus:OPERation:ENABle?

STATus:OPERation[:EVENt]?

STATus:QUEStionable:CONDition?

STATus:QUEStionable:DCORrupt?

STATus:QUEStionable:ENABle

STATus:QUEStionable:ENABle?

STATus:QUEStionable[:EVENt]?

STATus:QUEStionable:PROTection?


STATus:OPERation:CONDition?

Syntax

STATus:OPERation:CONDition? [<bit>]

Description

This command queries the condition register for the Standard Operation Register group. If you omit the optional <bit> parameter, the command returns a decimal value that corresponds to the binary-weighted sum of all bits set in the register (see Remarks). This is a read-only register and the bits are not cleared when you read the register.

For more information on the Status System for the digitizer, see the Status System Diagram .

Parameters

Name Type Range of Values Default Value
<bit> Discrete

The name of the bit whose value is to be returned. The possible values are shown in the table below.

Value: Condition:

CALibrating

 Calibrating
SELFtest | Running self-test
ACQuiring | Acquiring Data
WFT | Waiting for Trigger
WFA | Waiting for Arm
OBM | On-Board Measurement
MTHReshold | Memory Threshold
LOCKed | Instrument Locked
DTRansfer | Data Transfer
ERRor | Error in Global Error Queue
This is an optional parameter.

Remarks

  • The condition register bits reflect the current condition. If a condition is no longer true, the corresponding bit is cleared in the condition register.
  • The following table lists the bit definitions for the Standard Operation Register.
Bit Number | Decimal Value | Definition
0 | Calibrating | 1 | Instrument is performing a calibration. This means that either CALibration:STATe is ON or the instrument is running CALibration:ZERO:AUTO?.
1 | Self-test | 2 | Instrument is executing a self-test.
2 | (Reserved) | 4 | (Reserved for future use)
3 | Acquiring Data | 8 | Instrument is initiated, and is acquiring data or about to acquire data.
4 | (Reserved) | 16 | (Reserved for future use)
5 | Waiting for Trigger | 32 | Instrument is waiting for a trigger.
6 | Waiting for Arm | 64 | Instrument is waiting for the trigger to be armed.
7 | On-board Measurement | 128 | An installed, on-board measurement (a "MEASure" command installed with MEASure:INSTall:DEFine) is in progress.
8 Configuration Changed Event 256

This bit is always 0 in the condition register, as it reflects an event, not a condition.
9 | Memory Threshold | 512 | This bit is set when data is available.
10 | Instrument Locked | 1024 | If a remote interface (USB or LAN) has a lock (see SYSTem:LOCK:REQuest? command), this bit will be set. When a remote interface releases the lock (see SYSTem:LOCK:RELease command), this bit will be cleared.
11 | Coerced Data Event | 2048 | This bit is always 0 in the condition register, as it reflects an event, not a condition.
12 | Data Transfer | 4096 | Data is being transferred.
13 | Global Error | 8192 | There is an error in the global error queue.
14-15 | (Reserved) | 16,384 - 32,768 | (Reserved for future use)

Return Format

The return format depends on whether the optional <bit> parameter is used.

  • If <bit> is not specified, the command reads the condition register and returns a decimal value that corresponds to the binary-weighted sum of all bits set in the register (see table above). For example, if bit 5 (decimal value = 32) and bit 9 (decimal value = 512) are set, the command will return "+544".
  • If <bit> is specified, the command returns either +0 (OFF) or +1 (ON) for the specified bit.

Examples

The following command reads the condition register (bit 5 is set).

STAT:OPER:COND?

Typical Response" +32

The following command reads the WFT (Waiting for Trigger) bit in the condition register.

STAT:OPER:COND? WFT

Typical Response: +1

The following command reads the DIGitizing (Acquiring Data) bit in the condition register.

STAT:OPER:COND? ACQ or STAT:OPER:COND? ACQuiring

Typical Response: +1

See Also

STATus Subsystem Introduction

STATus:OPERation:ENABle

STATus:OPERation[:EVENt]?


STATus:OPERation:ENABle

Syntax

STATus:OPERation:ENABle <enable_value>

STATus:OPERation:ENABle?

Description

This command enables bits in the enable register for the Standard Operation Register group. The selected bits are then reported to the Status Byte as the standard operation summary bit.

For more information on the Status System for the digitizer, see the Status System Diagram.

Parameters

Name | Type | Range of Values | Default Value
<enable_value> | Numeric | A decimal value corresponding to the binary-weighted sum of the bits in the register (see table below). | This is a required parameter.

Remarks

  • The following table lists the bit definitions for the Standard Operation Register.
Bit Number | Decimal Value | Definition
0 | Calibrating | 1 | Instrument is in the calibration mode.Instrument is performing a calibration. This means that either CALibration:STATe is ON or the instrument is running CALibration:ZERO:AUTO?.
1 | Self-test | 2 | Instrument is performing a self-test.
2 | (Reserved) | 4 | (Reserved for future use)
3 | Acquiring Data | 8 | Instrument is initiated, and is acquiring data or about to acquire data.
4 | (Reserved) | 16 | (Reserved for future use)
5 | Waiting for Trigger | 32 | Instrument is waiting for a trigger.
6 | Waiting for Arm | 64 | Instrument is waiting for the trigger to be armed.
7 | On-board Measurement | 128 | An installed, on-board measurement (a "MEASure" command installed with MEASure:INSTall:DEFine) is in progress.
8 Configuration Changed Event 256

This bit is set when anything related to a channel configuration or measurement is changed.
9 | Memory Threshold | 512 | This bit is set when data is available.
10 | Instrument Locked | 1024 | If a remote interface (USB or LAN) has a lock (see SYSTem:LOCK:REQuest? command), this bit will be set. When a remote interface releases the lock (see SYSTem:LOCK:RELease command), this bit will be cleared.
11 Coerced Parameter Event 2048

This bit is set when a coerced parameter event occurs, that is, when a parameter is coerced due to a configuration conflict.
12 | Data Transfer | 4096 | Data is being transferred.
13 | Global Error | 8192 | There is an error in the global error queue.
14-15 | (Reserved) | 16,384 - 32,768 | (Reserved for future use)
  • Use the <enable_value> parameter to specify which bits will be reported to the Status Byte. The decimal value specified corresponds to the binary-weighted sum of the bits you wish to enable in the register. For example, to enable bit 5 (decimal value = 32) and bit 9 (decimal value = 512), the corresponding decimal value would be 544 (32 + 512).
  • The *CLS (clear status) command will not clear the enable register but it does clear all bits in the event register.
  • The *RST command has no effect on this register.

Return Format

The query command reads the enable register and returns a decimal value corresponding to the binary-weighted sum of all bits set in the register. For example, if bit 4 (decimal value = 16) and bit 9 (decimal value = 512) are enabled, the query command will return +528.

Examples

The following command enables bit 5 (decimal value = 32) in the enable register.

STAT:OPER:ENAB 32

The following query returns the decimal value corresponding to the binary-weighted sum of the bits in the enable register.

STAT:OPER:ENAB?

Typical Response: +32

See Also

STATus Subsystem Introduction

STATus:OPERation:CONDition?

STATus:OPERation[:EVENt]?


STATus:OPERation[:EVENt]?

Syntax

STATus:OPERation[:EVENt]?

Description

This command queries the event register for the Standard Operation Register group. The query returns a decimal value that corresponds to the binary-weighted sum of all bits set in the register (see Remarks). This is a read-only register and the bits are cleared when you read the register.

For more information on the Status System for the digitizer, see the Status System Diagram .

Remarks

  • The following table lists the bit definitions for the Standard Operation Register.
Bit Number | Decimal Value | Definition
0 | Calibrating | 1 | Instrument is in calibration mode (CALibration:STATe ON).Instrument is performing a calibration. This means that either CALibration:STATe is ON or the instrument is running CALibration:ZERO:AUTO?.
1 | Self-test | 2 | Instrument is performing a self-test.
2 | (Reserved) | 4 | (Reserved for future use)
3 | Acquiring data | 8 | Instrument is initiated, and is acquiring data or about to acquire data.
4 | (Reserved) | 16 | (Reserved for future use)
5 | Waiting for Trigger | 32 | Instrument is waiting for a trigger.
6 | Waiting for Arm | 64 | Instrument is waiting for the trigger to be armed.
7 | On-board Measurement | 128 | An installed, on-board measurement (a "MEASure" command installed with MEASure:INSTall:DEFine) is in progress.
8 Configuration Changed Event 256

This bit is set when anything related to a channel configuration or measurement is changed.
9 | Memory Threshold | 512 | This bit is set when data is available.
10 | Instrument Locked | 1024 | If a remote interface (USB or LAN) has a lock (see SYSTem:LOCK:REQuest? command), this bit will be set. When a remote interface releases the lock (see SYSTem:LOCK:RELease command), this bit will be cleared.
11 Coerced Data Event 2048

This bit is set when a coerced data event occurs. That is, when data is coerced due to a configuration conflict.
12 | Data Transfer | 4096 | Data is being transferred.
13 | Global Error | 8192 | There is an error in the global error queue.
14-15 | (Reserved) | 16,384 - 32,768 | (Reserved for future use)
  • Once a bit is set, it remains set until cleared by reading the event register or the *CLS (clear status) command.
  • The *RST command has no effect on this register.

Return Format

  • The command reads the event register and returns a decimal value that corresponds to the binary-weighted sum of all bits set in the register (see table above). For example, if bit 5 (decimal value = 32) and bit 9 (decimal value = 512) are set, the command will return +544.

Examples

The following command reads the event register (only bit 5 is set).

STAT:OPER:EVEN?

Typical Response: +32

See Also

STATus:OPERation:ENABle

STATus:OPERation:CONDition?


STATus:PRESet

Syntax | Description| Parameters | Remarks | Return Format | Examples

Syntax

STATus:PRESet

Description

This command clears all bits in the Questionable Data and Standard Operation Enable registers.

For more information on the Status System for the digitizer, see the Status System Diagram .

Remarks

  • For details on the Questionable Data Register, see STATus:QUEStionable:ENABle.
  • For details on the Standard Operation Register, see STATus:OPERation:ENABle.

Examples

The following command resets all bits in both registers

STATus:PRESet

See Also

STATus Subsystem Introduction

STATus:OPERation:ENABle

STATus:OPERation[:EVENt]?

STATus:QUEStionable:ENABle

STATus:QUEStionable:EVENt?


STATus:QUEStionable:CONDition?

Syntax

STATus:QUEStionable:CONDition? [<bit>]

Description

This command queries the condition register for the Questionable Data Register group. If you omit the optional <bit> parameter, the command returns a decimal value that corresponds to the binary-weighted sum of all bits set in the register (see Remarks). This is a read-only register and the bits are not cleared when you read the register.

Use the optional <bit> parameter to test the condition of an individual bit as described in the table below (see Parameters). In this case the condition of the specified bit is returned as a +0 (off) or +1 (on).

For more information on the Status System for the digitizer, see the Status System Diagram.

Parameters

Name Type Range of Values Default Value
<bit> Discrete
Value: Condition:

PROTection

 Overvoltage Protection
PLL | Phase Lock Loop Unlock
DCORrupt | Data Corrupt
This is an optional parameter. There is no default or reset value.

Remarks

  • The condition register bits reflect the current condition. If a condition is no longer true, the corresponding bit is cleared in the condition register.
  • The following table lists the bit definitions for the condition register in the Questionable Data group.
    • Bit Number | Decimal Value | Definition
    0 Overvoltage Protection 1

    Overvoltage protection was tripped on one or more channels.
    1-4 | (Reserved) | 2 - 16 | (Reserved for future use)
    5 | Phase Lock Loop Unlock | 32 | Phase lock loop is not locked to the 10 MHz reference input.See [CONFigure:]ROSCillator for details.
    6-7 | (Reserved) | 64 - 128 | (Reserved for future use)
    8 | Data Corrupt | 256 | Data is corrupt on one or more channels.
    9-15 | (Reserved) | 512 - 32,768 | (Reserved for future use)
  • If bit 0 (Overvoltage) is set, use the STATus:QUEStionable:PROTection? query to determine which channel(s) are reporting an overvoltage.
  • If bit 8 (Data Corrupt) is set, use the STATus:QUEStionable:DCORrupt? command to determine which channel(s) are reporting corrupt data.
  • A Factory Reset (*RST command) clears all bits in the condition register.

Return Format

The return format depends on whether the optional <bit> parameter is used.

  • If <bit> is not specified, the command reads the register and returns a decimal value that corresponds to the binary-weighted sum of all bits set in the register (see table above). For example, if bit 5 (decimal value = 32) is set, this command will return +32.
  • If <bit> is specified, the command returns either +0 (off) or +1 (on) for the specified bit.

Examples

The following command reads the condition register (bit 5 is set).

STAT:QUES:COND?

Typical Response: +32

The following command reads the Phase Lock Loop Unlock bit in the condition register.

STAT:QUES:COND? PLL

Typical Response: +0

See Also

STATus Subsystem Introduction

STATus:QUEStionable:DCORrupt

STATus:QUEStionable:ENABle

STATus:QUEStionable[:EVENt]?

STATus:QUEStionable:PROTection?

[CONFigure:]ROSCillator


STATus:QUEStionable:DCORrupt?

Syntax

STATus:QUEStionable:DCORrupt?

Description

This command queries the Data Corrupt register, which allows you to determine for which channel or channels the most recently digitized data has corrupt data values. This is a read-only register and the bits are not cleared when you read the register. Every time data is digitized, the bits in this register are re-evaluated.

For more information on the Status System for the digitizer, see the Status System Diagram.

Remarks

  • The Data Corrupt register bits reflect the current condition. If a condition is no longer true, the corresponding bit is cleared in the register. Whenever one or more of the bits are set, bit 8 in the Questionable Data Register is also set.
  • The following table lists the bit definitions for the Data Corrupt register.
Bit Number | Decimal Value | Definition
0 | Channel 1 corrupt | 1 | Data corrupt on channel 1.
1 | Channel 2 corrupt | 2 | Data corrupt on channel 2.
2 | Channel 3 corrupt | 4 | Data corrupt on channel 3.
3 | Channel 4 corrupt | 8 | Data corrupt on channel 4.
4-7 | (Reserved) | 16 - 128 | (Reserved for future use)
  • Bits 2 and 3 are not used if the digitizer has only two channels.
  • A Factory Reset (*RST command) will clear all bits in the register.
  • An INITiate command will clear this register.
  • Reconfiguring the instrument will clear these bits because the previous data is cleared from instrument memory.

Return Format

The command reads the register and returns a decimal value corresponding to the binary-weighted sum of all bits set in the register (see table above). For example, if bits 0 and 2 (decimal value = 1+4 = 5) are set, this command will return +5.

Examples

The following command reads the register (bit 3 is set, indicating corrupt data on channel 4).

STAT:QUES:DCOR?

Typical Response: +8

See Also

STATus Subsystem Introduction

STATus:QUEStionable:CONDition?


STATus:QUEStionable:ENABle

Syntax

STATus:QUEStionable:ENABle <enable_value>

STATus:QUEStionable:ENABle?

Description

This command enables bits in the enable register for the Questionable Data Register group. The selected bits are then reported to the Status Byte.

For more information on the Status System for the digitizer, see the Status System Diagram.

Parameters

Name | Type | Range of Values | Default Value
<enable_value> | Numeric | A decimal value corresponding to the binary-weighted sum of the bits in the register (see table below). | This is a required parameter.

Remarks

  • The following table lists the bit definitions for the Questionable Data Register.
Bit Number | Decimal Value | Definition
0 Overvoltage Protection 1

Overvoltage protection was tripped on one or more channels.
1-4 | (Reserved) | 2 - 16 | (Reserved for future use)
5 | Phase Lock Loop Unlock | 32 | Phase lock loop is not locked to the 10 MHz reference input.See [CONFigure:]ROSCillator for details.
6-7 | (Reserved) | 64 - 128 | (Reserved for future use)
8 | Data Corrupt | 256 | Data is corrupt on one or more channels.
9-15 | (Reserved) | 512 - 32,768 | (Reserved for future use)
  • Use the <enable_value> parameter to specify which bits will be reported to the Status Byte. The decimal value specified corresponds to the binary-weighted sum of the bits you wish to enable in the register. For example, to enable bit 0 (decimal value = 1) and bit 5 (decimal value = 32), the corresponding decimal value would be 33 (1 + 32).
  • The *CLS (clear status) command will not clear the enable register but it does clear all bits in the event register.
  • The *RST command has no effect on this register.

Return Format

The query command reads the enable register and returns a decimal value corresponding to the binary-weighted sum of all bits set in the register. For example, if bit 0 (decimal value = 1) and bit 5 (decimal value = 32) are enabled, the query command will return +33.

Examples

The following command enables bit 8 (decimal value = 256) in the enable register.

STAT:QUES:ENAB 256

The following query returns which bits are enabled in the register.

STAT:QUES:ENAB?

Typical Response: +256

See Also

STATus Subsystem Introduction

STATus:QUEStionable:CONDition?

STATus:QUEStionable[:EVENt]?

STATus:QUEStionable:PROTection?

STATus:QUEStionable:DCORrupt?

[CONFigure:]ROSCillator


STATus:QUEStionable[:EVENt]?

Syntax

STATus:QUEStionable[:EVENt]?

Description

This command queries the event register for the Questionable Data Register group. The command returns a decimal value that corresponds to the binary-weighted sum of all bits set in the register (see Remarks). This is a read-only register and the bits are cleared when you read the register.

For more information on the Status System for the digitizer, see the Status System Diagram.

Remarks

  • The following table lists the bit definitions for the Questionable Data Register.
    • Bit Number | Decimal Value | Definition
    0 Overvoltage Protection 1

    Overvoltage protection was tripped on one or more channels.
    1-4 | (Reserved) | 2 - 16 | (Reserved for future use)
    5 | Phase Lock Loop Unlock | 32 | Phase lock loop is not locked to the 10 MHz reference input.See [CONFigure:]ROSCillator for details.
    6-7 | (Reserved) | 64 - 128 | (Reserved for future use)
    8 | Data Corrupt | 256 | Data is corrupt on one or more channels.
    9-15 | (Reserved) | 512 - 32,768 | (Reserved for future use)
  • Once a bit is set, it remains set until cleared by reading the event register or the *CLS (clear status) command.
  • The *RST command has no effect on this register.

Return Format

  • The command reads the event register and returns a decimal value that corresponds to the binary-weighted sum of all bits set in the register. For example, if bit 0 (decimal value = 1) and bit 8 (decimal value = 256) are set, this command will return +257.

Examples

The following command reads the event register (bit 0 is set).

STAT:QUES?

Typical Response: +0

See Also

STATus Subsystem Introduction

STATus:QUEStionable:CONDition?

STATus:QUEStionable:ENABle?

[CONFigure:]ROSCillator


STATus:QUEStionable:PROTection?

Syntax

STATus:QUEStionable:PROTection?

Description

This command queries the Overvoltage Protection register, which allows you to determine which channel(s) are reporting an overvoltage when bit 0 of the Questionable Data Register is set. This is a read-only register and the bits are not cleared when you read the register. A channel overvoltage indicates that a channel's input connector is no longer connected to the digitizing hardware.

For more information on the Status System for the digitizer, see the Status System Diagram.

Remarks

  • The Overvoltage Protection register bits reflect the current condition. Whenever one or more of the bits are set, bit 0 in the Questionable Data Register is also set.
  • The following table lists the bit definitions for the Overvoltage Protection register.
Bit Number | Decimal Value | Definition
0 | Channel 1 overvoltage | 1 | Overvoltage on channel 1.
1 | Channel 2 overvoltage | 2 | Overvoltage on channel 2.
2 | Channel 3 overvoltage | 4 | Overvoltage on channel 3.
3 | Channel 4 overvoltage | 8 | Overvoltage on channel 4.
4-7 | (Reserved) | 16 - 128 | (Reserved for future use)
  • Bits 2 and 3 are not used if the digitizer has only two channels.
  • A Factory Reset (*RST command) will clear all bits in the register.
  • Use the [CONFigure:]CHANnel:PROTection[:RELay] OFF command to turn off the channel protection relay. This is usually done in response to an overvoltage event.

Return Format

The command reads the register and returns a decimal value corresponding to the binary-weighted sum of all bits set in the register (see table above). For example, if bits 0 and 2 (decimal value = 1+4 = 5) are set, this command will return +5.

Examples

The following command reads the register (bit 3 is set, indicating an overvoltage on channel 4).

STAT:QUES:PROT?

Typical Response: +8

See Also

STATus Subsystem Introduction

STATus:QUEStionable:CONDition?

[CONFigure:]CHANnel:PROTection[:RELay]


SYSTem Subsystem Introduction

Command Summary

General Commands

SYSTem:ERRor?

SYSTem:GLOBal:ERRor?

SYSTem:LOCK:NAME?

SYSTem:LOCK:OWNer?

SYSTem:LOCK:RELease

SYSTem:LOCK:REQuest?

SYSTem:PRESet

SYSTem:SECurity:IMMediate

SYSTem:SYNChronize:EXTernal

SYSTem:SYNChronize:EXTernal?

SYSTem:VERSion?

Remote Interface Config

SYSTem:COMMunicate:LAN:CONTrol?

SYSTem:COMMunicate:LAN:DHCP

SYSTem:COMMunicate:LAN:DHCP?

SYSTem:COMMunicate:LAN:DNS

SYSTem:COMMunicate:LAN:DNS?

SYSTem:COMMunicate:LAN:DOMain?

SYSTem:COMMunicate:LAN:GATEway

SYSTem:COMMunicate:LAN:GATEway?

SYSTem:COMMunicate:LAN:HOSTname

SYSTem:COMMunicate:LAN:HOSTname?

SYSTem:COMMunicate:LAN:IPADdress

SYSTem:COMMunicate:LAN:IPADdress?

SYSTem:COMMunicate:LAN:MAC?

SYSTem:COMMunicate:LAN:SMASk

SYSTem:COMMunicate:LAN:SMASk?

SYSTem:COMMunicate:LAN:TELNet:PROMpt

SYSTem:COMMunicate:LAN:TELNet:PROMpt?

SYSTem:COMMunicate:LAN:TELNet:WMESsage

SYSTem:COMMunicate:LAN:TELNet:WMESsage?

SYSTem:COMMunicate:LAN:UPDate

The digitizer uses the following LAN ports:

  • Port 5024 is used for Telnet sessions.
  • Port 5025 is used for Socket sessions.


LAN Configuration Introduction

Remote Interface Configuration Commands

SYSTem:COMMunicate:LAN:CONTrol?

SYSTem:COMMunicate:LAN:DHCP

SYSTem:COMMunicate:LAN:DHCP?

SYSTem:COMMunicate:LAN:DNS

SYSTem:COMMunicate:LAN:DNS?

SYSTem:COMMunicate:LAN:DOMain?

SYSTem:COMMunicate:LAN:GATEway

SYSTem:COMMunicate:LAN:GATEway?

SYSTem:COMMunicate:LAN:HOSTname

SYSTem:COMMunicate:LAN:HOSTname?

SYSTem:COMMunicate:LAN:IPADdress

SYSTem:COMMunicate:LAN:IPADdress?

SYSTem:COMMunicate:LAN:MAC?

SYSTem:COMMunicate:LAN:SMASk

SYSTem:COMMunicate:LAN:SMASk?

SYSTem:COMMunicate:LAN:TELNet:PROMpt

SYSTem:COMMunicate:LAN:TELNet:PROMpt?

SYSTem:COMMunicate:LAN:TELNet:WMESsage

SYSTem:COMMunicate:LAN:TELNet:WMESsage?

SYSTem:COMMunicate:LAN:UPDate

The digitizer uses the following LAN ports:

  • Port 5024 is used for Telnet sessions.
  • Port 5025 is used for Socket sessions.


SYSTem:COMMunicate:LAN:CONTrol?

Syntax

SYSTem:COMMunicate:LAN:CONTrol?

Description

This query returns the control connection port number for socket communications.

Remarks

  • This query is only used when programming over sockets.
  • You can use the control socket connection to send a Device Clear to the instrument or to detect pending Service Request (SRQ) events.
  • This query always returns +0 if not sent from a socket connection.

Return Format

The command returns the control connection port number. If +0 is returned, the interface does not support a Socket Control connection.

Examples

The following query returns the control connection port number.

SYST:COMM:LAN:CONT?

Typical Response: +5005

See Also

LAN Configuration Introduction


SYSTem:COMMunicate:LAN:DHCP

Syntax

SYSTem:COMMunicate:LAN:DHCP <mode>

SYSTem:COMMunicate:LAN:DHCP?

Description

This command disables or enables use of the Dynamic Host Configuration Protocol (DHCP) for the digitizer.

When DHCP is enabled (factory setting), the instrument will try to obtain an IP address from a DHCP server. If a DHCP server is found, it will assign a dynamic IP address, Subnet Mask, and Default Gateway to the instrument. If a DHCP server is not found, the instrument uses AutoIP to automatically configure its IP address in the Automatic Private IP Addressing range (169.254.xxx.xxx).

When DHCP is disabled or unavailable, the instrument will use the static IP address, Subnet Mask, and Default Gateway during power-on.

Parameters

Name Type Range of Values Default Value

<mode>

Boolean

{OFF|0|ON|1}

This is a required parameter.

Remarks

  • You must execute the SYSTem:COMMunicate:LAN:UPDate command for the changes specified by this command to take effect.
  • Most site LANs have a DHCP server. If a DHCP LAN address is not assigned by a DHCP server, then an AutoIP IP address will be assumed after approximately two minutes.
  • The DHCP setting is stored in non-volatile memory , and does not change when power has been off, or after a Factory Reset (*RST command).
  • DHCP is set ON by a LAN reset. The LAN reset button is on the rear panel of the instrument.

Return Format

The query returns 0 (OFF) or 1 (ON).

Examples

The following command disables DHCP.

SYST:COMM:LAN:DHCP OFF

The following query returns the current DHCP setting.

SYST:COMM:LAN:DHCP?

Typical Response: 0

See Also

LAN Configuration Introduction

SYSTem:COMMunicate:LAN:GATEway

SYSTem:COMMunicate:LAN:IPADdress

SYSTem:COMMunicate:LAN:SMASk

SYSTem:COMMunicate:LAN:UPDate


SYSTem:COMMunicate:LAN:DNS

Syntax

SYSTem:COMMunicate:LAN:DNS "<ip_address>"

SYSTem:COMMunicate:LAN:DNS? [{CURRent|STATic}]

Description

This command assigns the DNS address (the IP address of the Domain Name System server). Contact your network administrator to determine whether DNS is being used and for the correct address. If DHCP is available and enabled, DHCP will auto-assign the DNS address. If DHCP is off, the static DNS address assigned with this command will be used.

Parameters

Name Type Range of Values Default Value

<ip_address>

Quoted String

Specified in four-byte dot notation ("nnn.nnn.nnn.nnn"), where "nnn" in each case is a byte value in the range 0 through 255.

This is a required parameter.

Remarks

  • You must execute the SYSTem:COMMunicate:LAN:UPDate command for the changes specified by this command to take effect.
  • The assigned DNS address is used for the DNS server if DHCP is disabled or unavailable. Otherwise, the DNS server address is auto-assigned by DHCP.
  • The DNS address is stored in non-volatile memory , and does not change when power has been off or after a Factory Reset (*RST command). It is only put into its reset state by the LAN Reset button on the rear panel of the instrument.

Return Format

The query form returns the address of the current primary DNS server in the form "nnn.nnn.nnn.nnn".

Note that the query form has two optional parameters. Specify "CURRent" (default) to read the DNS server address currently being used by the instrument. Specify "STATic" to read the static DNS address currently stored in non-volatile memory within the instrument. This is the address that is used if DHCP is disabled or currently unavailable. If DHCP is enabled, it will auto-assign the DNS address, and that DHCP assigned address can be read by specifying "CURRent".

Examples

The following command sets the static DNS address.

SYST:COMM:LAN:DNS "198.105.232.4"

The following query returns the DNS address currently being used by the instrument (the quotes are also returned).

SYST:COMM:LAN:DNS? CURR

Typical Response: "198.105.232.4"

See Also

LAN Configuration Introduction

SYSTem:COMMunicate:LAN:HOSTname

SYSTem:COMMunicate:LAN:UPDate


SYSTem:COMMunicate:LAN:DOMain?

Syntax

SYSTem:COMMunicate:LAN:DOMain?

Description

This query returns the domain name currently being used by the digitizer.

Remarks

  • If Dynamic Domain Name System (DNS) is available on your network and your instrument uses DHCP, the domain name is registered with the Dynamic DNS service at power-on.
  • If DHCP is enabled (see SYSTem:COMMunicate:LAN:DHCP command), the DHCP server can change the specified domain name.
  • The domain name is stored in non-volatile memory , and does not change when power has been off, or after a factory reset (*RST command).

Return Format

The query command reads the domain name and returns an ASCII string enclosed in double quotes. If a domain name has not been assigned, a null string ( " " ) is returned.

Examples

The following query returns the domain name currently being used by the instrument (the quotation marks are also returned).

SYST:COMM:LAN:DOM?

Typical Response: "example.com"

See Also

LAN Configuration Introduction

SYSTem:COMMunicate:LAN:DHCP

SYSTem:COMMunicate:LAN:HOSTname


SYSTem:COMMunicate:LAN:GATEway

Syntax

SYSTem:COMMunicate:LAN:GATEway "<ip_address>"

SYSTem:COMMunicate:LAN:GATEway? [{CURRent|STATic}]

Description

This command assigns a Default Gateway for the digitizer. The specified IP Address sets the Default Gateway which allows the instrument to communicate with systems that are not on the local subnet. Thus, this is the Default Gateway where packets are sent which are destined for a device not on the local subnet, as determined by the Subnet Mask setting. Contact your network administrator to determine whether a gateway is being used and for the correct address.

Parameters

Name Type Range of Values Default Value

<ip_address>

Quoted String

Specified in four-byte dot notation ("nnn.nnn.nnn.nnn"), where "nnn" in each case is a byte value in the range 0 through 255.

This is a required parameter.

Remarks

  • You must execute the SYSTem:COMMunicate:LAN:UPDate command for the changes specified by this command to take effect.
  • If DHCP is enabled (see SYSTem:COMMunicate:LAN:DHCP command), the default gateway is assigned by the DHCP server, so the specified default gateway is not used. However, if DHCP is turned off, the currently configured Default Gateway will be used.
  • A value of "0.0.0.0" indicates that subnetting is not being used.
  • The Default Gateway is stored in non-volatile memory , and does not change when power has been off or after a Factory Reset (*RST command). It is only put into its reset state by the LAN Reset button on the rear panel of the instrument.

Return Format

The query command returns the Default Gateway address in the form "nnn.nnn.nnn.nnn".

Note that the query command has two optional parameters. Specify "CURRent" (default) to read the dynamic Default Gateway currently being used by the instrument. Specify "STATic" to read the Default Gateway currently stored in non-volatile memory within the instrument (may not be the actual address used by the instrument if DHCP is enabled).

Examples

The following command sets the Default Gateway address.

SYST:COMM:LAN:GATEWAY "255.255.20.11"

The following query returns the Default Gateway address currently being used by the instrument (the quotes are also returned).

SYST:COMM:LAN:GATEWAY? CURR or SYST:COMM:LAN:GATEWAY?

Typical Response: "0.0.0.0"

See Also

LAN Configuration Introduction

SYSTem:COMMunicate:LAN:DHCP

SYSTem:COMMunicate:LAN:IPADdress

SYSTem:COMMunicate:LAN:SMASk

SYSTem:COMMunicate:LAN:UPDate


SYSTem:COMMunicate:LAN:HOSTname

Syntax

SYSTem:COMMunicate:LAN:HOSTname "<name>"

SYSTem:COMMunicate:LAN:HOSTname? [{CURRent|STATic}]

Description

This command assigns a host name to the digitizer. The host name is the host portion of the domain name, which is translated into an IP address.

Parameters

Name Type Range of Values Default Value

<name>

Quoted ASCII String

A string of up to 15 characters. The first character must be a letter (A-Z), but the remaining 14 characters can be letters, numbers (0-9), or dashes ("-"). Blank spaces are not allowed.

This is a required parameter.

The LXI reset value is A-L4532A-nnnnn or A-L4534A-nnnnn, where nnnnn is the last 5 digits in the instrument's serial number.

Remarks

  • You must execute the SYSTem:COMMunicate:LAN:UPDate command and then turn the instrument off and on for the changes specified by this command to take effect.
  • If Dynamic Domain Name System (DDNS) is available on your network and your instrument uses DHCP, the host name is registered with the Dynamic DNS service at power-on.
  • If DHCP is enabled (see SYSTem:COMMunicate:LAN:DHCP command), the DHCP server can assign a different name if the requested name is already in use on the network.
  • The host name is stored in non-volatile memory , and does not change when power has been off, or after a factory reset (*RST command).
  • You can reset the host name to its default value by pressing the LAN Reset button on the rear panel of the instrument.

Return Format

The query command reads the host name and returns an ASCII string enclosed in double quotes. If a host name has not been assigned, a null string ( " " ) is returned.

Note that the query command has two optional parameters. Specify "CURRent" (default) to read the host name that the instrument is currently using. Specify "STATic" to read the host name currently stored in non-volatile memory within the instrument (which may not be the actual name currently in use on the network).

Examples

The following command defines a host name.

SYST:COMM:LAN:HOST "LAB1-L4532A"

The following query returns the host name currently being used by the instrument (the quotes are also returned).

SYST:COMM:LAN:HOST? CURR or SYST:COMM:LAN:HOST?

Typical Response: "LAB1-L4532A"

See Also

LAN Configuration Introduction

SYSTem:COMMunicate:LAN:DHCP

SYSTem:COMMunicate:LAN:DOMain?

SYSTem:COMMunicate:LAN:UPDate


SYSTem:COMMunicate:LAN:IPADdress

Syntax

SYSTem:COMMunicate:LAN:IPADdress "<address>"

SYSTem:COMMunicate:LAN:IPADdress? [{CURRent|STATic}]

Description

This command assigns a static Internet Protocol (IP) Address for the digitizer. Contact your network administrator for a valid IP address to use for your instrument.

Parameters

Name Type Range of Values Default Value

<address>

Quoted String

Specified in four-byte dot notation ("nnn.nnn.nnn.nnn"), where "nnn" in each case is a byte value in the range 0 through 255.

169.254.45.32

Remarks

  • You must execute the SYSTem:COMMunicate:LAN:UPDate command for the changes specified by this command to take effect.
  • If DHCP is enabled (see SYSTem:COMMunicate:LAN:DHCP command), the IP address is assigned by the DHCP server, so the specified static IP address is not used. However, if DHCP is turned off, the currently configured static IP address will be used.
  • IF DHCP is enabled, but a DHCP server is not available, the address is determined by AutoIP.
  • If you are planning to use a static IP address, contact your network administrator to obtain a fixed IP address to be used exclusively for your instrument.
  • The IP address is stored in non-volatile memory , and does not change when power has been off or after a Factory Reset (*RST command). It is only put into its reset state by the LAN Reset button on the rear panel of the instrument.

Return Format

The query command returns the IP address in the form "nnn.nnn.nnn.nnn".

Note that the query command has two optional parameters. Specify "CURRent" (default) to read the IP address currently being used by the instrument. Specify "STATic" to read the IP address currently stored in non-volatile memory within the instrument (may not be the actual address used by the instrument if DHCP is enabled).

Examples

The following command sets the IP address.

SYST:COMM:LAN:IPAD "255.255.25.14"

The following query returns the IP address currently being used by the instrument (the quotes are also returned).

SYST:COMM:LAN:IPAD? CURR or SYST:COMM:LAN:IPAD?

Typical Response: "169.254.45.32"

See Also

LAN Configuration Introduction

SYSTem:COMMunicate:LAN:GATEway

SYSTem:COMMunicate:LAN:SMASk

SYSTem:COMMunicate:LAN:DHCP

SYSTem:COMMunicate:LAN:UPDate


SYSTem:COMMunicate:LAN:MAC?

Syntax

SYSTem:COMMunicate:LAN:MAC?

Description

This command reads the digitizer's Media Access Control (MAC) address, also known as the link-layer address, the Ethernet (station) address, LANIC ID, or Hardware Address. This is an unchangeable 48-bit address assigned by the manufacturer to each unique Internet device.

Your network administrator may need the instrument's MAC address in order to assign a static IP address for this device.

Remarks

  • The instrument's MAC address is unique to the instrument. It is set at the factory and cannot be changed.
  • The MAC address is stored in non-volatile memory , and does not change when power has been off, or after a Factory Reset (*RST command).

Return Format

The command reads the MAC address and returns an ASCII string enclosed in double quotes. The MAC address is represented as 12 hexadecimal characters divided into groups of two and separated by dashes (for example, 12-34-56-78-9A-BC).

Examples

The following query returns the MAC address (the quotes are also returned).

SYST:COMM:LAN:MAC?

Typical Response: "00-30-D3-00-10-41"

See Also

LAN Configuration Introduction

SYSTem:COMMunicate:LAN:IPADdress


SYSTem:COMMunicate:LAN:SMASk

Syntax

SYSTem:COMMunicate:LAN:SMASk "<mask>"

SYSTem:COMMunicate:LAN:SMASk? [{CURRent|STATic}]

Description

This command assigns a Subnet Mask for the digitizer. The instrument uses the Subnet Mask to determine whether a client IP address is on the same local subnet. When a client IP address is on a different subnet, all packets must be sent to the Default Gateway. Contact your network administrator to determine whether subnetting is being used and for the correct Subnet Mask.

Parameters

Name Type Range of Values Default Value

<mask>

Quoted String

Specified in four-byte dot notation ("nnn.nnn.nnn.nnn"), where "nnn" in each case is a byte value in the range 0 through 255.

This is a required parameter.

Remarks

  • You must execute the SYSTem:COMMunicate:LAN:UPDate command for the changes specified by this command to take effect.
  • If DHCP is enabled (see SYSTem:COMMunicate:LAN:DHCP command), the subnet mask is assigned by the DHCP server, so the specified subnet mask is not used. However, if DHCP is turned off, the currently configured Subnet Mask will be used.
  • A value of "0.0.0.0" or "255.255.255.255" indicates that subnetting is not being used.
  • The Subnet Mask is stored in non-volatile memory , and does not change when power has been off or after a Factory Reset (*RST command). It is only put into its reset state by the LAN Reset button on the rear panel of the instrument.

Return Format

The query command returns the Subnet Mask in the form "nnn.nnn.nnn.nnn".

Note that the query command has two optional parameters. Specify "CURRent" (default) to read the dynamic Subnet Mask currently being used by the instrument. Specify "STATic" to read the Subnet Mask currently stored in non-volatile memory within the instrument (may not be the actual mask used by the instrument if DHCP is enabled).

Examples

The following command sets the Subnet Mask.

SYST:COMM:LAN:SMAS "255.255.254.0"

The following query returns the Subnet Mask currently being used by the instrument (the quotes are also returned).

SYST:COMM:LAN:SMAS? CURR or SYST:COMM:LAN:SMAS?

Typical Response: "255.255.0.0"

See Also

LAN Configuration Introduction

SYSTem:COMMunicate:LAN:DHCP

SYSTem:COMMunicate:LAN:GATEway

SYSTem:COMMunicate:LAN:IPADdress

SYSTem:COMMunicate:LAN:UPDate


SYSTem:COMMunicate:LAN:TELNet:PROMpt

Syntax

SYSTem:COMMunicate:LAN:TELNet:PROMpt "<string>"

SYSTem:COMMunicate:LAN:TELNet:PROMpt?

Description

This command sets the command prompt seen when using a Telnet session to communicate with the digitizer. A Telnet session allows you to send instrument commands over a TCP/IP network.

Parameters

Name Type Range of Values Default Value

<string>

Quoted ASCII String

A string of up to 15 characters.

"L4532A>"

or

"L4534A>"

Remarks

  • The Telnet port is an alternate way to send commands to the digitizer.
  • The digitizer uses LAN port 5024 for Telnet sessions.
  • Telnet session can typically be started as follows from a host computer shell:

    telnet <IP_address> <port>

    For example:

    telnet 169.254.4.10 5024

    To exit a Telnet session, press <Ctrl-D>.
  • The command prompt is stored in non-volatile memory , and does not change when power has been off, or after a Factory Reset (*RST command).

Return Format

The query command reads the command prompt and returns an ASCII string enclosed in double quotes.

Examples

The following command defines the command prompt.

SYST:COMM:LAN:TELN:PROM "Command>"

The following query returns the command prompt currently being used (the quotes are also returned).

SYST:COMM:LAN:TELN:PROM?

Typical Response: "Command>"

See Also

LAN Configuration Introduction

SYSTem:COMMunicate:LAN:TELNet:WMESsage


SYSTem:COMMunicate:LAN:TELNet:WMESsage

Syntax

SYSTem:COMMunicate:LAN:TELNet:WMESsage "<string>"

SYSTem:COMMunicate:LAN:TELNet:WMESsage?

Description

This command sets the welcome message seen when using a Telnet session to communicate with the digitizer. A Telnet session allows you to send instrument commands over a TCP/IP network.

Parameters

Name Type Range of Values Default Value

<string>

Quoted ASCII String

A string of up to 63 characters.

"Agilent L4532A Instrument"

or

"Agilent L4534A Instrument"

Remarks

  • The digitizer uses LAN port 5024 for Telnet sessions.
  • The welcome message is stored in non-volatile memory , and does not change when power has been off, or after a Factory Reset (*RST command).

Return Format

The query command reads the welcome message and returns an ASCII string enclosed in double quotes.

Examples

The following command defines the welcome message.

SYST:COMM:LAN:TELN:WMES "Agilent L4534A Instrument"

The following query returns the welcome message currently being used (the quotes are also returned).

SYST:COMM:LAN:TELN:WMES?

Typical Response: "Welcome to L4534A Telnet Session"

See Also

LAN Configuration Introduction

SYSTem:COMMunicate:LAN:TELNet:PROMpt


SYSTem:COMMunicate:LAN:UPDate

Syntax

SYSTem:COMMunicate:LAN:UPDate

Description

This command updates all of the LAN changes. It disconnects all active LAN and Web connections and restarts the LAN interface, possibly with a new IP address, depending on how your instrument's IP address is assigned.

Remarks

  • Executing this command is necessary to make the following commands take effect:

    SYSTem:COMMunicate:LAN:DHCP

    SYSTem:COMMunicate:LAN:DNS

    SYSTem:COMMunicate:LAN:GATEway

    SYSTem:COMMunicate:LAN:HOSTname

    SYSTem:COMMunicate:LAN:IPADdress

    SYSTem:COMMunicate:LAN:SMASk
  • Be very careful when you execute this command, because your instrument may not work on the LAN if you update the instrument with invalid LAN settings.

  • If your instrument does not work after you execute this command, push the LAN Reset button to restore the settings to reset values and reset the LAN, or use another I/O interface, such as USB, to correct the settings.

Example

The following command updates the LAN settings described above.

SYST:COMM:LAN:UPDate

See Also

LAN Configuration Introduction

SYSTem:COMMunicate:LAN:DHCP

SYSTem:COMMunicate:LAN:DNS

SYSTem:COMMunicate:LAN:GATEway

SYSTem:COMMunicate:LAN:HOSTname

SYSTem:COMMunicate:LAN:IPADdress

SYSTem:COMMunicate:LAN:SMASk


SYSTem:ERRor?

Syntax

SYSTem:ERRor?

Description

This command reads and clears one error from the current I/O session's error queue. Up to 20 errors can be stored in the instrument's error queue. Each remote interface I/O session (USB, LAN, etc.) has its own error queue. Errors appear in the error queue of the I/O session that caused the error. For example, if an error was generated by a command sent over the USB interface, you can send the SYSTem:ERRor? command from USB to read the error.

For a complete listing of error messages, see Error Messages.

Remarks

  • The front-panel ERROR annunciator turns on when one or more errors are currently stored in any error queue. Therefore, it is possible that the annunciator will show an error, even when there are no errors in the current I/O session's error queue. Use SYSTem:GLOBal:ERRor? to read the errors in all error queues.
  • Errors are retrieved in first-in-first-out (FIFO) order. The first error returned is the first error that was stored.
  • Errors are cleared as you read them. When you have read all errors from all error queues, the ERROR annunciator turns off.
  • If more than 20 errors have occurred, the last error stored in the queue (the most recent error) is replaced with -350,"Error Queue overflow". No additional errors are stored until you remove errors from the queue. If no errors have occurred when you read the error queue, the instrument responds with +0,"No error".
  • Errors generated by the instrument hardware are put into a system error queue. If no errors are in the current session's error queue, this command will then check the system queue and return any system errors.
  • Error conditions are summarized in the Status Byte Register. For more information on the Status System , see Status System Introduction.
  • The error queue is cleared by the *CLS (Clear Status) command (for the I/O session), and when power is cycled (for all errors). All errors are cleared when you read the error queue. However, the error queue is not cleared by a Factory Reset (*RST command).

Return Format

The command reads and clears one error string from the error queue. As it does so, it returns an error number and an error code, which may contain up to 255 characters enclosed in quotation marks. For example:

-113,"Undefined header"

Examples

The following query reads and clears one error.

SYST:ERR?

Typical Response: -101, "Invalid character"

The following query shows what happens if there are no errors.

SYST:ERR?

Typical Response: +0,"No error"

See Also

SYSTem Subsystem Introduction

*CLS

*SRE

SYSTem:GLOBal:ERRor?


SYSTem:GLOBal:ERRor?

Syntax

SYSTem:GLOBAL:ERRor?

Description

This query returns the next error in the instrument. It returns errors for the current I/O session first, and when the current session is empty, this query returns errors from other error queues.

For a complete listing of error messages, see Error Messages.

Remarks

  • The front-panel ERROR annunciator turns on when one or more errors are currently stored in any error queue.
  • The SYSTem:ERRor? query is usually sufficient to clear all errors from the instrument. However, if multiple IO interfaces are in use, the SYSTem:GLOBal:ERRor? query allows you to clear all IO session error queues from a single IO session.
  • The order in which error queues are cleared is as follows:
    • The current queue
    • The USB queue
    • All VXI-11 queues (ordered by the time their connection with the instrument began)
    • All Socket queues (ordered by the time their connection with the instrument began)
    • The global error queue
  • System generated errors that are not associated with an I/O user thread (such as those from the power-on self-test), go into the global error queue. When you read them with SYSTem:GLOBal:ERRor?, they begin with "LOCAL".
  • Errors are retrieved in first-in-first-out (FIFO) order. The first error returned is the first error that was stored.
  • Errors are cleared as you read them. When you have read all errors from all error queues, the ERROR annunciator turns off.

Return Format

The command reads and clears one error string from an error queue. As with the SYSTem:ERRor? query, the error string may contain up to 255 characters and consists of an error number and an error string enclosed in double quotes. This query also includes the name of the I/O session at the beginning of the response. For example:

"LAN156.140.95.216",-113,"Undefined header"

The name of the I/O session will be either "LOCAL", "USB", "VXI11", "LAN<ip_address>", or "NONE".

Examples

The following query reads and clears one error from the current session, which happens to be at IP address 156.140.95.216.

SYST:GLOB:ERR?

Typical Response: "LAN156.140.95.216",-101,"Invalid character"

The following query shows what happens if there are no errors.

SYST:GLOB:ERR?

Typical Response: "NONE",+0,"No error"

See Also

SYSTem Subsystem Introduction

SYSTem:ERRor?

*CLS

*SRE


SYSTem:LOCK:NAME?

Syntax

SYSTem:LOCK:NAME?

Description

This query returns the I/O interface name of the I/O session sending the query. You can use the returned name to determine whether the I/O session owns the interface lock by comparing it to the value returned by SYSTem:LOCK:OWNer?.

Remarks

  • Use this command to determine the lock name for the interface that you are using. Then use the SYSTem:LOCK:OWNer? command to determine which interface, if any, has the lock. Once you have done both of these commands, you can compare the results to determine whether you have the lock.
  • This query is sometimes confused with the SYSTem:LOCK:OWNer? query. The difference is that SYSTem:LOCK:OWNer? returns the name of the interface that has the lock, and SYSTem:LOCK:NAME? returns the name of the current interface, regardless of whether it has the lock.

Return Format

The command returns USB, VXI11, or LAN<IP Address> indicating the I/O interface being used by the querying computer. The IP address is four integers separated by periods, such as 156.140.79.29, and there is no space between the word LAN and the <IP Address>. Therefore, a typical LAN with an IP address would be returned as LAN156.140.79.29.

Examples

The following query returns the name of the I/O interface in use by the querying computers.

SYST:LOCK:NAME?

Typical Response: "LAN169.254.149.35"

See Also

SYSTem:LOCK:OWNer?

SYSTem:LOCK:RELease

SYSTem:LOCK:REQuest?


SYSTem:LOCK:OWNer?

Syntax

SYSTem:LOCK:OWNer?

Description

This query returns the name of the I/O interface that currently has a lock.

Remarks

  • If the value returned by this query matches the value returned by SYSTem:LOCK:NAME?, then the I/O session sending this query owns the lock.
  • When a lock is active, Bit 10 in the Standard Operation Register will be set (see STATus:OPERation:CONDition? command). When there is no active lock on any I/O interface, this bit will be cleared.
  • This query is sometimes confused with the SYSTem:LOCK:NAME? query. The difference is that SYSTem:LOCK:OWNer? returns the name of the interface that has the lock, and SYSTem:LOCK:NAME? returns the name of the current interface, regardless of whether it has the lock.

Return Format

The command returns USB, VXI11, or LAN<IP Address> indicating the I/O interface that currently has a lock. If no interface has a lock, the query returns NONE. The IP address is four integers separated by periods, such as 156.140.79.29, and there is no space between the word LAN and the <IP Address>. Therefore, a typical LAN with an IP address would be returned as LAN156.140.79.29.

Examples

The following query returns the name of the I/O interface that currently has a lock.

SYST:LOCK:OWN?

Typical Response: "USB"

See Also

SYSTem:LOCK:NAME?

SYSTem:LOCK:RELease

SYSTem:LOCK:REQuest?


SYSTem:LOCK:RELease

Syntax

SYSTem:LOCK:RELease

Description

This command decrements the lock count by one and releases the instrument lock.

Remarks

  • When a lock is active, Bit 10 in the Standard Operation Register will be set (see STATus:OPERation:CONDition? command). When the lock is released, this bit is cleared.

Examples

The following command decreases the lock count by one.

SYST:LOCK:REL

The following series of commands illustrates usage.

Initial State = unlocked, Count = 0

<FROM USB> SYST:LOCK:REQ? returns +1 (request successful)

State = locked, Count = 1

<FROM LAN> SYST:LOCK:REQ? returns +0 because USB has lock

State = locked, Count = 1

<FROM USB> SYST:LOCK:REQ? returns +1 (request successful)

State = locked, Count = 2

<FROM USB> SYST:LOCK:REL

State = locked, Count = 1

<FROM USB> SYST:LOCK:REL

State = unlocked, Count = 0

Note that for each successful lock request, a lock release is required. Two requests require two releases.

See Also

SYSTem:LOCK:NAME?

SYSTem:LOCK:OWNer?

SYSTem:LOCK:REQuest?


SYSTem:LOCK:REQuest?

Syntax | Description | Parameters| Remarks | Return Format | Examples

Syntax

SYSTem:LOCK:REQuest?

Description

This command issues a request to lock the instrument's configuration to a single I/O interface. This allows you to lock the instrument or share the instrument with other computers.

Remarks

  • When a request is granted, only I/O sessions from the interface which was granted the lock will be allowed to change the state of the instrument. From the other I/O interfaces, you can query the state of the instrument but no instrument configuration changes or measurements are allowed.
  • Lock requests can be nested and each request will increase the lock count by 1. For every request, you will need a release from the same I/O interface (see SYSTem:LOCK:RELease command).
  • Instrument locks are handled at the I/O interface level (USB, VXI-11, sockets) and you are responsible for all coordination between threads and/or programs on that interface.
  • Locks from socket sessions will be automatically released when a socket disconnect is detected.
  • When a lock is granted, Bit 10 in the Standard Operation Register will be set (see STATus:OPERation:CONDition? command).

Return Format

The command immediately returns +1 if the lock request is granted or +0 if denied.

Examples

The following command requests a lock of the current I/O interface.

SYST:LOCK:REQ?

Typical Response: +1

The following series of commands illustrates usage.

Initial State = unlocked, Count = 0

<FROM USB> SYST:LOCK:REQ? returns +1 (request successful)

State = locked, Count = 1

<FROM LAN> SYST:LOCK:REQ? returns +0 because USB has lock

State = locked, Count = 1

<FROM USB> SYST:LOCK:REQ? returns +1 (request successful)

State = locked, Count = 2

<FROM USB> SYST:LOCK:REL

State = locked, Count = 1

<FROM USB> SYST:LOCK:REL

State = unlocked, Count = 0

Note that for each successful lock request, a lock release is required. Two requests require two releases.

See Also

SYSTem:LOCK:NAME?

SYSTem:LOCK:OWNer?

SYSTem:LOCK:RELease


SYSTem:PRESet

Syntax

SYSTem:PRESet [SAFE]

Description

This command is simply a convenient way to put the instrument's input channels into a safe state, similar to the safe state created by pressing the instrument's power switch. Pressing the digitizer's power switch sets all input channels to their maximum range, disconnects the input channels, and puts the instrument into standby mode. This differs from removing line power, which leaves all input channels in their last configured state and therefore vulnerable to damage.

Remarks

  • It is equivalent to [CONFigure:]CHANnel:RANGe (@1:4),256 followed by [CONFigure:]CHANnel:PROTection[:RELay] (@1:4),ON. Of course, these commands only apply to four-channel digitizers; you would change the (@1:4) to (@1:2) on the L4532A digitizer.
  • You would typically use this command as a final operation in a test application, when you plan to disconnect line power and want to protect the input channels. This also protects your instrument against unexpected power loss and input channel damage that might occur when the input wiring to the digitizer is being reconfigured.
  • The SAFE keyword is optional, and it does not change the behavior of this command.

Examples

The following command protects the digitizers channels against damage.

SYST:PRES SAFE

See Also

SYSTem:PRESet

[CONFigure:]CHANnel[:ATTRibutes]

[CONFigure:]CHANnel:PROTection[:RELay]


SYSTem:SECurity:IMMediate

Syntax

SYSTem:SECurity:IMMediate

Description

This command clears all instrument memory except for the instrument's calibration parameters, Mac address and serial number. It then powers off the instrument. This command is typically used to clear all memory before removing the instrument from a secure area.

This command is not recommended for routine use. It deletes all data and reverts all settings, including LAN configuration settings, back to the factory default state.

Do not turn the instrument off or remove power from the instrument while this command is executing (approximately five minutes). The instrument will turn itself off when this command is complete. If for some reason power to the instrument is removed before the instrument turns itself off, turn the instrument on and wait for it to re-start (it may take much longer than usual). The digitizer will then automatically complete the SYSTem:SECurity:IMMediate operation before returning to the Idle state.

Remarks

  • This command initializes all instrument settings to their Factory Reset (*RST command) values.
  • This command destroys all user-defined state information (see *SAV and *RCL), and I/O settings such as the IP address are returned to their factory settings.
  • The only exception to this is the password for the Web Interface, which gets set to agilent. You may use the LAN Reset button on the rear panel of the instrument to return the instrument to the default state of having no password. You may also reset the password on the network configuration page of the Web Interface.

Examples

The following command clears all instrument memory other than the instrument's calibration parameters, MAC address, memory option, model number, and serial number.

SYST:SEC:IMM

See Also

*SAV

*RCL

*RST

SYSTem Subsystem Introduction


SYSTem:SYNChronize:EXTernal

Syntax

SYSTem:SYNChronize:EXTernal <sync_type>

SYSTem:SYNChronize:EXTernal?

Description

This command configures whether and how an instrument is synchronized. This allows you to synchronize data acquisitions for multiple L4532A/34A digitizers.

Parameters

Name Type Range of Values Default Value
<sync_type> Discrete

{PEND|SYNC|NONE}

 This is a required parameter.

Remarks

  • Setting the <sync_type> to PEND puts the instrument into a state where it is waiting for two external trigger pulses to which it can synchronize.
  • When the <sync_type> is set to PEND, any configuration command that follows prior to synchronization will cause an error message indicating that external synchronization has failed.
  • Setting the <sync_type> to SYNC is similar to setting it to PEND, except that an instrument configured as SYNCh issues trigger pulses to itself and on the trigger bus.
  • When performing synchronization, you should use CONF:TRIGger:TIMestamp:MODE CONTinous prior to sending the command to synchronously reset all timestamps.
  • If you have a single digitizer that is left in the POS_25_W_OR state, do not attempt to synchronize it, or you can put the instrument into a metastable state.
  • If you have several digitizers to be synchronized and leave the trigger line unterminated, then using the SYSTem:SYNChronize:EXTernal command could lead to metastable states logically and not allow proper synchronization to take place.
  • Only positive edge pulses are used during synchronization, and one digitizer should execute the SYSTem:SYNChronize:EXTernal SYNC command to ensure proper synchronization.
  • To execute this command, you cannot be in calibration mode, digitizing, or running an on-board measurement (OBM).

Return Format

The query returns a PEND, SYNC, or NONE as described above.

Examples

The following command configures the instrument for SYNC.

SYSTem:SYNChronize:EXTernal SYNC

The following query returns a value indicating that the instrument's synchronization type. In this example, the instrument is pending synchronization.

SYSTem:SYNChronize:EXTernal?

Typical Response: PEND

See Also

SYSTem Subsystem Introduction

[CONFigure:]TRIGger:TIMestamp[:MODE]


SYSTem:VERSion?

Syntax

SYSTem:VERSion?

Description

This query returns the version of the command language that is in use on the instrument.

Remarks

  • This query determines software compatibility with other instruments of this class.

Return Format

The command returns a version string of the L45XX.0, where the 0 after the period indicates the revision number.

Examples

The following query returns the version string.

SYST:VERS?

Typical Response: L45xx.0

See Also

SYSTem Subsystem Introduction


Commands A-Z

A – E | F – L | M – O | R – S | T – Z

A

ABORt

ARM[:IMMediate]

C

*CLS

CALibration:COUNt?

CALibration:DATA

CALibration:DATA?

CALibration:LOAD

CALibration:RANGe

CALibration:RANGe?

CALibration:RANGe:CHANnel?

CALibration:RANGe:SOURce

CALibration:RANGe:SOURce?

CALibration:SECure:CODE

CALibration:SECure:STATe

CALibration:SECure:STATe?

CALibration:STATe

CALibration:STATe?

CALibration:STORe

CALibration:STORe:OVERride

CALibration:STORe:OVERride?

CALibration:STRing

CALibration:STRing?

CALibration:ZERO:AUTO?

[CONFigure:]ACQuisition[:ATTRibutes]

[CONFigure:]ACQuisition:SRATe

[CONFigure:]ACQuisition:SCOunt

[CONFigure:]ACQuisition:SPRetrigger

[CONFigure:]ACQuisition:RECords

[CONFigure:]ACQuisition:THOLdoff

[CONFigure:]ACQuisition:TDELay

[CONFigure:]ACQuisition[:ATTRibutes]?

[CONFigure:]ACQuisition:SRATe?

[CONFigure:]ACQuisition:SCOunt?

[CONFigure:]ACQuisition:SPRetrigger?

[CONFigure:]ACQuisition:RECords?

[CONFigure:]ACQuisition:THOLdoff?

[CONFigure:]ACQuisition:TDELay?

[CONFigure:]ACQuisition:SCOunt:MAXimum?

[CONFigure:]ARM:SOURce

[CONFigure:]ARM:SOURce?

[CONFigure:]ARM:SOURce:TIMer

[CONFigure:]ARM:SOURce:TIMer?

[CONFigure:]CHANnel[:ATTRibutes]

[CONFigure:]CHANnel:RANGe

[CONFigure:]CHANnel:COUPling

[CONFigure:]CHANnel:FILTER

[CONFigure:]CHANnel[:ATTRibutes]?

[CONFigure:]CHANnel:RANGe?

[CONFigure:]CHANnel:COUPling?

[CONFigure:]CHANnel:FILTER?

[CONFigure:]CHANnel:PROTection[:RELay]

[CONFigure:]CHANnel:PROTection[:RELay]?

[CONFigure:]EXTernal[:INPut]

[CONFigure:]EXTernal[:INPut]?

[CONFigure:]EXTernal:TRIGger:OUTPut

[CONFigure:]EXTernal:TRIGger:OUTPut?

[CONFigure:]ROSCillator

[CONFigure:]ROSCillator?

[CONFigure:]TRIGger:SOURce

[CONFigure:]TRIGger:SOURce?

[CONFigure:]TRIGger:SOURce:CHANnel?

[CONFigure:]TRIGger:SOURce:CHANnel:EDGE

[CONFigure:]TRIGger:SOURce:CHANnel:EDGE?

[CONFigure:]TRIGger:SOURce:CHANnel:OFF

[CONFigure:]TRIGger:SOURce:CHANnel:WINDow

[CONFigure:]TRIGger:SOURce:CHANnel:WINDow?

[CONFigure:]TRIGger:TIMestamp[:MODE]

D

DISPlay[:STATe]

DISPlay[:STATe]?

DISPlay:TEXT

DISPlay:TEXT?

DISPlay:TEXT:CLEar

E

*ESE

*ESE?

*ESR?

F

FETCh:WAVeform:ACQuisition:PREamble?

FETCh:WAVeform:ADC?

FETCh:WAVeform:CHANnel:ERRor?

FETCh:WAVeform:RECord:PREamble?

FETCh:WAVeform:RECord:TIMestamps?

FETCh:WAVeform:VOLTage?

FORMat:BORDer

FORMat:BORDer?

FORMat[:DATA]:INTeger

FORMat[:DATA]:INTeger?

FORMat[:DATA]:REAL

FORMat[:DATA]:REAL?

I

*IDN?

INITiate

M

MEASure:FALL:DUTYcycle[:VERBose]?

MEASure:FALL:FREQuency[:VERBose]?

MEASure:FALL:OVERshoot[:VERBose]?

MEASure:FALL:PERiod[:VERBose]?

MEASure:FALL:PREShoot[:VERBose]?

MEASure:FALL:TIME[:VERBose]?

MEASure:INSTall:CATalog?

MEASure:INSTall:DEFine

MEASure:INSTall:DEFine?

MEASure:INSTall:DELete

MEASure:INSTall:RESults[:RECord][:VERBose]?

MEASure:INSTall:RESults:ERRor:RECord?

MEASure:INSTall:RUN

MEASure:NWIDth[:VERBose]?

MEASure:PWIDth[:VERBose]?

MEASure:RCODe:STRing

MEASure:RISE:DUTYcycle[:VERBose]?

MEASure:RISE:FREQuency[:VERBose]?

MEASure:RISE:OVERshoot[:VERBose]?

MEASure:RISE:PERiod[:VERBose]?

MEASure:RISE:PREShoot[:VERBose]?

MEASure:RISE:TIME[:VERBose]?

MEASure:THResholds:ABSolute

MEASure:THResholds:METHod

MEASure:THResholds:PERCent

MEASure:THResholds:RESet

MEASure:THResholds:TOPBase:ABSolute

MEASure:THResholds:TOPBase:METHod

MEASure:VAMPlitude[:VERBose]?

MEASure:VAVerage[:VERBose]?

MEASure:VBASe[:VERBose]?

MEASure:VLOWer[:VERBose]?

MEASure:VMAX[:VERBose]?

MEASure:VMIDdle[:VERBose]?

MEASure:VMIN[:VERBose]?

MEASure:VPP[:VERBose]?

MEASure:VRMS[:VERBose]?

MEASure:VTOP[:VERBose]?

MEASure:VUPPer[:VERBose]?

MEASure:WINDow[:DEFine]

O

*OPC

*OPC?

*OPT?

R

*RCL

*RST

READ:WAVeform:ADC?

READ:WAVeform:VOLTage?

S

*SAV

*SRE

*SRE?

*STB?

STATus:OPERation:CONDition?

STATus:OPERation:ENABle

STATus:OPERation:ENABle?

STATus:OPERation[:EVENt]?

STATus:PRESet

STATus:QUEStionable:CONDition?

STATus:QUEStionable:DCORrupt?

STATus:QUEStionable:ENABle

STATus:QUEStionable:ENABle?

STATus:QUEStionable[:EVENt]?

STATus:QUEStionable:PROTection?

SYSTem:COMMunicate:LAN:CONTrol?

SYSTem:COMMunicate:LAN:DHCP

SYSTem:COMMunicate:LAN:DNS

SYSTem:COMMunicate:LAN:DOMain?

SYSTem:COMMunicate:LAN:GATEway

SYSTem:COMMunicate:LAN:HOSTname

SYSTem:COMMunicate:LAN:IPADdress

SYSTem:COMMunicate:LAN:MAC?

SYSTem:COMMunicate:LAN:SMASk

SYSTem:COMMunicate:LAN:TELNet:PROMpt

SYSTem:COMMunicate:LAN:TELNet:WMESsage

SYSTem:COMMunicate:LAN:UPDate

SYSTem:ERRor?

SYSTem:GLOBal:ERRor?

SYSTem:LOCK:NAME?

SYSTem:LOCK:OWNer?

SYSTem:LOCK:RELease

SYSTem:LOCK:REQuest?

SYSTem:PRESet

SYSTem:SECurity:IMMediate

SYSTem:VERSion?

T

*TRG

*TST?

TRIGger[:IMMediate]

W

*WAI


Command Quick Reference

Agilent L4532A/34A Command Quick Reference

Printable PDF Version

Syntax Conventions

  • Braces ( { } ) enclose the parameter choices for a given command string. The braces are not sent with the command string.
  • A vertical bar ( | ) separates multiple parameter choices for a given command string. The bar is not sent with the command string.
  • Angle brackets ( < > ) indicate that you must specify a value for the enclosed parameter. For example, consider the following syntax statement:

    [CONFigure:]ARM:SOURce:TIMer <time>

    This shows the <time> parameter enclosed in angle brackets. The brackets are not sent with the command string. You must specify a value for the parameter, such as CONF:ARM:SOUR:TIME 3.
  • Some parameters are enclosed in square brackets ( [ ] ). The square brackets indicate that the parameter is optional and can be omitted. The brackets are not sent with the command string. If you do not specify a value for an optional parameter, the instrument chooses a default value.

Calibration Commands

CALibration:COUNt?

CALibration:DATA (@<channel>), <cal_data_block>
CALibration:DATA? (@<channel>)

CALibration:LOAD

CALibration:RANGe
CALibration:RANGe?

CALibration:RANGe:CHANnel? (@<chan_list>),{0.25|0.5|1|2|4|8|16}

CALibration:RANGe:SOURce {.25|.5|1|2|4|8|16}

CALibration:SECure:CODE <new_code>

CALibration:SECure:STATe {OFF|0|ON|1}, <security_string>
CALibration:SECure:STATe?

CALibration:STATe {OFF|0|ON|1}
CALibration:STATe?

CALibration:STORe

CALibration:STORe:OVERride <state>
CALibration:STORe:OVERride?

CALibration:STRing "<string>"
CALibration:STRing?

CALibration:ZERO:AUTO? (@<chan_list>)

Configuration - Acquisition

[CONFigure:]ACQuisition[:ATTRibutes] <sample_rate>, <samples_per_record> [, <pre-trig_samples_per_record> [, <num_records> [, <trigger_holdoff> [, <trigger_delay>]]]]

[CONFigure:]ACQuisition:SRATe <sample_rate>

[CONFigure:]ACQuisition:SCOunt <samples_per_record>

[CONFigure:]ACQuisition:SPRetrigger <pre-trig_samples_per_record>

[CONFigure:]ACQuisition:RECords <num_records>

[CONFigure:]ACQuisition:THOLdoff <trigger_holdoff>

[CONFigure:]ACQuisition:TDELay <trigger_delay>

[CONFigure:]ACQuisition[:ATTRibutes]?

[CONFigure:]ACQuisition:SRATe?

[CONFigure:]ACQuisition:SCOunt?

[CONFigure:]ACQuisition:SPRetrigger?

[CONFigure:]ACQuisition:RECords?

[CONFigure:]ACQuisition:THOLdoff?

[CONFigure:]ACQuisition:TDELay?

[CONFigure:]ACQuisition:SCOunt:MAXimum? [<num_records>]

Configuration - Arming and Triggering

[CONFigure:]ARM:SOURce <source>[, <triggers>]
[CONFigure:]ARM:SOURce <source>?

[CONFigure:]ARM:SOURce:TIMer <seconds>
[CONFigure:]ARM:SOURce:TIMer?

[CONFigure:]EXTernal[:INPut] <slope>
[CONFigure:]EXTernal[:INPut]?

[CONFigure:]EXTernal:TRIGger:OUTPut <event> [, <drive_mode>]
[CONFigure:]EXTernal:TRIGger:OUTPut?

[CONFigure:]TRIGger:SOURce <source>
[CONFigure:]TRIGger:SOURce?

[CONFigure:]TRIGger:SOURce:CHANnel? (@<chan_list>)

[CONFigure:]TRIGger:SOURce:CHANnel:EDGE (@<chan_list>), <level>[, <slope>[, <hysteresis>]]
[CONFigure:]TRIGger:SOURce:CHANnel:EDGE? (@<chan_list>)

[CONFigure:]TRIGger:SOURce:CHANnel:OFF (@<chan_list>)

[CONFigure:]TRIGger:SOURce:CHANnel:WINDow (@<chan_list>), <level_low>, <level_high>[, <direction>[, <hysteresis>]]
[CONFigure:]TRIGger:SOURce:CHANnel:WINDow? (@<chan_list>)

[CONFigure:]TRIGger:TIMestamp[:MODE] <counter_mode>

Configuration - Channels

[CONFigure:]CHANnel[:ATTRibutes] (@<chan_list>), <range>[, <coupling>[, <filter>]]

[CONFigure:]CHANnel:RANGe (@<chan_list>), <range>

[CONFigure:]CHANnel:COUPling (@<chan_list>), <coupling>

[CONFigure:]CHANnel:FILTER (@<chan_list>), <filter>

[CONFigure:]CHANnel[:ATTRibutes]? (@<chan_list>)

[CONFigure:]CHANnel:RANGe? (@<chan_list>)

[CONFigure:]CHANnel:COUPling? (@<chan_list>)

[CONFigure:]CHANnel:FILTER? (@<chan_list>)

[CONFigure:]CHANnel:PROTection[:RELay] (@<chan_list>), <mode>
[CONFigure:]CHANnel:PROTection[:RELay]? (@<chan_list>)

Configuration - Other

[CONFigure:]ROSCillator <INTernal|EXTernal>
[CONFigure:]ROSCillator?

DISPlay Commands

DISPlay[:STATe] <state>
DISPlay[:STATe]?

DISPlay:TEXT "<string>"
DISPlay:TEXT?

DISPlay:TEXT:CLEar

IEEE-488 Commands

*CLS

*ESE <enable_value>
*ESE?

*ESR?

*IDN?

*OPC
*OPC?

*OPT?

*RCL {0|1|2|3|4}

*RST

*SAV {0|1|2|3|4}

*SRE <enable_value>
*SRE?

*STB?

*TRG

*TST?

*WAI

MEASure Subsytem - Falling and Rising Measurements

MEASure:FALL:DUTYcycle[:VERBose]? (@<channel>)[, <num_edge>]

MEASure:FALL:FREQuency[:VERBose]? (@<channel>)[, <num_edge>]

MEASure:FALL:OVERshoot[:VERBose]? (@<channel>)[, <num_edge>]

MEASure:FALL:PERiod[:VERBose]? (@<channel>)[, <num_edge>]

MEASure:FALL:PREShoot[:VERBose]? (@<channel>)[, <num_edge>]

MEASure:FALL:TIME[:VERBose]? (@<channel>) [, <num_edge]

MEASure:RISE:DUTYcycle[:VERBose]? (@<channel>)[, <num_edge>]

MEASure:RISE:FREQuency[:VERBose]? (@<channel>)[, <num_edge>]

MEASure:RISE:OVERshoot[:VERBose]? (@<channel>)[, <num_edge>]

MEASure:RISE:PERiod[:VERBose]? (@<channel>)[, <num_edge>]

MEASure:RISE:PREShoot[:VERBose]? (@<channel>)[, <num_edge>]

MEASure:RISE:TIME[:VERBose]? (@<channel>) [, <num_edge]

MEASure Subsytem - Installing Measurements

MEASure:INSTall:CATalog?

MEASure:INSTall:DEFine <label>, <meas_string>
MEASure:INSTall:DEFine? <label>

MEASure:INSTall:DELete {<label>|ALL}

MEASure:INSTall:RESults[:RECord][:VERBose]?

MEASure:INSTall:RESults:ERRor:RECord?

MEASure:INSTall:RUN

MEASure Subsytem - Thresholds

MEASure:THResholds:ABSolute (@<chan_list>), <vHigh>, <vMid>, <vLow>
MEASure:THResholds:ABSolute? (@<chan_list>)

MEASure:THResholds:METHod (@<chan_list>), <method>
MEASure:THResholds:METHod? (@<chan_list>)

MEASure:THResholds:PERCent (@<chan_list>), <%High>, <%Mid>, <%Low>
MEASure:THResholds:PERCent? (@<chan_list>)

MEASure:THResholds:RESet (@<chan_list>)

MEASure:THResholds:TOPBase:ABSolute (@<chan_list>) [, <vTop>, <vBase>]
MEASure:THResholds:TOPBase:ABSolute? (@<chan_list>)

MEASure:THResholds:TOPBase:METHod (@<chan_list>), {STANdard|ABSolute}
MEASure:THResholds:TOPBase:METHod? (@<chan_list>)

MEASure Subsytem - Voltage Measurements

MEASure:VAMPlitude[:VERBose]? (@<channel>)

MEASure:VAVerage[:VERBose]? (@<channel>) [,{CYCLe|WINDow}]

MEASure:VBASe[:VERBose]? (@<channel>)

MEASure:VLOWer[:VERBose]? (@<channel>)

MEASure:VMAX[:VERBose]? (@<channel>)

MEASure:VMIDdle[:VERBose]? (@<channel>)

MEASure:VMIN[:VERBose]? (@<channel>)

MEASure:VPP[:VERBose]? (@<channel>)

MEASure:VRMS[:VERBose]? (@<channel>)[,{CYCLe|WINDow},{AC|DC}]

MEASure:VTOP[:VERBose]? (@<channel>)

MEASure:VUPPer[:VERBose]? (@<channel>)

MEASure Subsytem - Other Commands and Queries

MEASure:NWIDth[:VERBose]? (@<channel>)[, <num_neg_pulse>]

MEASure:PWIDth[:VERBose]? (@<channel>)[, <num_pos_pulse>]

MEASure:RCODe:STRing? <return_code>

MEASure:WINDow[:DEFine] <num_record>, <start_offset>, <size>
MEASure:WINDow[:DEFine]?

Sample Memory Commands

FETCh:WAVeform:ACQuisition:PREamble?

FETCh:WAVeform:ADC?

FETCh:WAVeform:CHANnel:ERRor?

FETCh:WAVeform:RECord:PREamble?

FETCh:WAVeform:RECord:TIMestamps?

FETCh:WAVeform:VOLTage?

FORMat:BORDer <mode>
FORMat:BORDer?

FORMat[:DATA]:INTeger <format>[, <size>]
FORMat[:DATA]:INTeger?

FORMat[:DATA]:REAL <format>[, <size>]
FORMat[:DATA]:REAL?

READ:WAVeform:ADC?

READ:WAVeform:VOLTage?

STATus Subsystem

STATus:OPERation:CONDition?

STATus:OPERation:ENABle

STATus:OPERation[:EVENt]?

STATus:PRESet

STATus:QUEStionable:CONDition?

STATus:QUEStionable:DCORrupt?

STATus:QUEStionable:ENABle

STATus:QUEStionable[:EVENt]?

STATus:QUEStionable:PROTection?

SYSTEM Subsystem - LAN Configuration

SYSTem:COMMunicate:LAN:CONTrol?

SYSTem:COMMunicate:LAN:DHCP {OFF|0|ON|1}
SYSTem:COMMunicate:LAN:DHCP?

SYSTem:COMMunicate:LAN:DNS "<address>"
SYSTem:COMMunicate:LAN:DNS? [{CURRent|STATic}]

SYSTem:COMMunicate:LAN:DOMain?

SYSTem:COMMunicate:LAN:GATEway "<address>"
SYSTem:COMMunicate:LAN:GATEway? [{CURRent|STATic}]

SYSTem:COMMunicate:LAN:HOSTname "<name>"
SYSTem:COMMunicate:LAN:HOSTname? [{CURRent|STATic}]

SYSTem:COMMunicate:LAN:IPADdress "<address>"
SYSTem:COMMunicate:LAN:IPADdress? [{CURRent|STATic}]

SYSTem:COMMunicate:LAN:MAC?

SYSTem:COMMunicate:LAN:SMASk "<mask>"
SYSTem:COMMunicate:LAN:SMASk? [{CURRent|STATic}]

SYSTem:COMMunicate:LAN:TELNet:PROMpt "<string>"
SYSTem:COMMunicate:LAN:TELNet:PROMpt?

SYSTem:COMMunicate:LAN:TELNet:WMESsage "<string>"
SYSTem:COMMunicate:LAN:TELNet:WMESsage?

SYSTem:COMMunicate:LAN:UPDate

SYSTem Subsystem - Other Commands

SYSTem:ERRor?

SYSTem:GLOBal:ERRor?

SYSTem:LOCK:NAME?

SYSTem:LOCK:OWNer?

SYSTem:LOCK:RELease

SYSTem:LOCK:REQuest?

SYSTem:PRESet

SYSTem:SECurity:IMMediate

SYSTem:VERSion?

Triggering Commands

*TRG

[CONFigure:]EXTernal[:INPut] <slope>
[CONFigure:]EXTernal[:INPut]?

[CONFigure:]EXTernal:TRIGger:OUTPut <event>[, <drive_mode>]
[CONFigure:]EXTernal:TRIGger:OUTPut?

[CONFigure:]TRIGger:SOURce <source>
[CONFigure:]TRIGger:SOURce?

[CONFigure:]TRIGger:SOURce:CHANnel? (@<chan_list>)

[CONFigure:]TRIGger:SOURce:CHANnel:EDGE (@<chan_list>), <level>[, <slope>[, <hysteresis>]]
[CONFigure:]TRIGger:SOURce:CHANnel:EDGE? (@<chan_list>)

[CONFigure:]TRIGger:SOURce:CHANnel:OFF (@<chan_list>)

[CONFigure:]TRIGger:SOURce:CHANnel:WINDow (@<chan_list>), <level_low>, <level_high>[, <direction>[, <hysteresis>]]
[CONFigure:]TRIGger:SOURce:CHANnel:WINDow? (@<chan_list>)

TRIGger[:IMMediate]

Other Commands

ABORt

ARM[:IMMediate]

INITiate

© 2009 Agilent Technologies, Inc.


Error Messages

SCPI Error Messages

Execution Errors (-101...) | Instrument Errors (200...) | Self-Test Errors (600...) | Calibration Errors (700...)

The Agilent L4532A/34A returns error messages according to the following rules.

  • A record of up to 20 errors can be stored in the instrument's error queue. Each remote interface I/O session (USB, VXI-11, Telnet/Sockets) has its own interface-specific error queue. Errors appear in the error queue of the I/O session that caused the error. For example, if an error was generated by a command sent over the USB interface, send the command from USB to read the error queue.

  • The front-panel E annunciator turns on when one or more errors are currently stored in the error queue.

  • A special global error queue holds all power-on and hardware-related errors (for example, overvoltage).

  • Errors are retrieved in first-in-first-out (FIFO) order. The first error returned is the first error that was stored. Once you have read all of the interface-specific errors, the errors in the global error queue are retrieved.

  • Errors are cleared as you read them. When you have read all errors from the interface-specific and global error queues, the E annunciator turns off and the errors are cleared.

  • If more than 20 errors have occurred, the last error stored in the queue (the most recent error) is replaced with -350,"Error queue overflow". No additional errors are stored until you remove errors from the queue. If no errors have occurred when you read the error queue, the instrument responds with +0,"No error".

  • The front panel reports errors from all I/O sessions as well as the global error queue.

  • Error conditions are also summarized in the Status Byte Register. For more information on the Status Subsystem for the Agilent L4532A/34A, see Status Subsystem Introduction.

  • The interface-specific error queues are cleared by the *CLS (Clear Status) command and when power is cycled. All errors are cleared when you read the error queue. The error queue is not cleared by a Factory Reset (*RST command) or an Instrument Preset (SYSTem:PRESet command).

  • Remote Interface Operation:

SYSTem:ERRor? Read and clear one error from the queue

Errors have the following format (the error string may contain up to 80 characters):

-113,"Undefined header"

Execution Errors

-101, "Invalid character"

-108,"Parameter not allowed"

-109,"Missing parameter"

-151,"Invalid string data"

-161,"Invalid block data"

-211,"Trigger ignored"

-213,"ARM ignored"

-213,"INIT ignored"

-221,"Settings Conflict"

-222,"Data out of range"

-224,"Illegal parameter value"

-224,"Illegal parameter value, ranges must be positive"

-224,"Incorrect format for list parameter"

-230,"Data stale"

-231,"Data questionable"

-231,"Internal software error"

-310,"System error"

-314,"Save/recall memory lost; memory corruption detected"

-316,"Must be in Calibration mode to execute this command"

-317,"This command not allowed when in Calibration mode"

-350, "Error queue overflow"

+810,"State has not been restored"

+811,"Operation not implemented"

Instrument Errors

+112,"Channel list: channel number out of range"

+281,"Not able to perform on more than one channel"

+514,"Not allowed"

Self-Test Errors

The L4532A/34A self-tests (power-on self-test and *TST?) perform series of tests on the instrument hardware. Any failure of these tests will generate a SCPI error number -330, with additional test failure information. Refer to the Agilent L4532A/34A Service Guide for more information.

The form of this error message is as follows:

-330,"Self-test failed; <fail code>: <text explaining fail code>"

Where <fail code> is the number of the test that failed (range 600 -647) and <text explaining fail code> describes the test. Here is an example of a test failure message:

-330,"Self-test failed; 619 - AC 0.1VAC Zero Test"

The following is the list of test numbers and descriptions:

Test # | Test Name:
602 | Internal IO to digitizer failed
603 | LAN IO failure
604 | Sample memory test failed
605 | Sample memory DMA failed
606 | Sample memory DMA address failed
610 | Sample clock PLL failed
613 | Input channel n: missing
614 | Invalid channel n: for this model
615 | Channel n: calibration gain DAC adjustment failed
616 | Channel n: calibration offset DAC adjustment failed
618 | Channel n: overvoltage protection test failed
622 | Channel n: DC blocking capacitor test failed
623 | Channel n: with no attenuators failed
624 | Channel n: (1:16) attenuator 1 failed
625 | Channel n: (1:16) attenuator 2 failed
626 | Channel n: (1:2) attenuator 3 failed
628 | Channel n: x1.125 gain failed
629 | Channel n: x2.250 gain failed
630 | Channel n: x4.500 gain failed
631 | Channel gain test failed
632 | Calibration ground source failed
633 | Calibration voltage source failed (50 Ohm)
634 | Calibration voltage source failed (1 MOhm)
635 | Channel n: 20 MHz filter failed
636 | Channel n: 2 MHz filter failed
637 | Channel n: 200 KHz filter failed
641 | FPGA memory stuck low
642 | FPGA memory stuck high
643 | FPGA memory test failed
646 | No input channels found
647 | Channel n: input board sync test failed

Calibration Errors

The following errors indicate failures that may occur during a calibration. Refer to the Agilent L4532A/34A Service Guide for more information.

+702,"Cal: secured"

+703,"Cal: invalid secure code"

+704,"Cal: secure code too long"

+705,"Cal: aborted"

+741,"Cal data lost: string data"

+747,"Calibration failed;Gain Chan[n] Range[x.x] Coupling[yyy] Filter[zzz]"

+747,"Calibration failed;Offset Chan[n] Range[x.x] Coupling[yyy] Filter[zzz]"

+748,"Cal checksum failed, internal data"


Power-On and Reset State

The following tables show the factory defaults for various instrument settings. The parameters marked with a bullet (•) are stored in non-volatile memory , and are not affected by power-on or a system reset. Other parameters are stored in volatile memory and are reset to the indicated values at power-on or after a *RST command is issued.

The power-on/reset state may be different than that in the tables if you have enabled the power-on state recall mode. This mode is entered from the Utility menu. See the Agilent L4532A/34A User's Guide for further information.

Measurement Configuration | Factory Setting
[CONFigure:]ACQuisition[:ATTRibutes] <#pre-trig samples/record> | 0
[CONFigure:]ACQuisition[:ATTRibutes] <trig holdoff> | 0
[CONFigure:]ACQuisition[:ATTRibutes] <trig delay> | 0
[CONFigure:]ACQuisition[:ATTRibutes] <#records> | 1
[CONFigure:]ACQuisition[:ATTRibutes] <#samples/record> | 2048
[CONFigure:]ACQuisition[:ATTRibutes] <sample rate> | 20,000,000
[CONFigure:]ARM:SOURce <triggers> | 1024
[CONFigure:]ARM:SOURce <source> | IMMediate
[CONFigure:]ARM:SOURce:TIMer <time> | 0
[CONFigure:]CHANnel:PROTection[:RELay] <mode> | OFF
[CONFigure:]CHANnel[:ATTRibutes] <range> | 256
[CONFigure:]CHANnel[:ATTRibutes] <coupling> | DC
[CONFigure:]CHANnel[:ATTRibutes] <filter> | LP_20_MHZ
[CONFigure:]EXTernal:TRIGger:OUTPut <driveMode> | OFF
[CONFigure:]EXTernal:TRIGger:OUTPut <event> | NONE
[CONFigure:]EXTernal[:INPut] <slope> | POSitive
[CONFigure:]ROSCillator {INTernal|EXTernal} | INTernal
[CONFigure:]TRIGger:SOURce <source> | IMMediate
[CONFigure:]TRIGger:SOURce:CHANnel | (all channels OFF)
[CONFigure:]TRIGger:SOURce:CHANnel:EDGE <level> | 0
[CONFigure:]TRIGger:SOURce:CHANnel:EDGE <hysteresis> | 2.0 (% of range)
[CONFigure:]TRIGger:SOURce:CHANnel:EDGE <slope> | POSitive
[CONFigure:]TRIGger:SOURce:CHANnel:WINDow <levelLo> | 0 V
[CONFigure:]TRIGger:SOURce:CHANnel:WINDow <levelHi> | 0 V
[CONFigure:]TRIGger:SOURce:CHANnel:WINDow <hysteresis> | 2.0% of range
[CONFigure:]TRIGger:SOURce:CHANnel:WINDow <direction> | ENTering
[CONFigure:]TRIGger:TIMestamp[:MODE] <counter_mode> | INITiate
CALibration:RANGe:SOURce state | 0.25 V
CALibration:STATe state | OFF
FORMat:BORDer <mode> | NORMal
FORMat:DATA:REAL <format> | REAL
FORMat:DATA:REAL <length> | 32
FORMat:DATA:INTeger <format> | INTeger
FORMat:DATA:INTeger <length> | 16
MEASure:INSTall:DELete <label> | (all labels cleared)
MEASure:THResholds:ABSolute <vHi> | +1.0 V
MEASure:THResholds:ABSolute <vMid> | 0 V
MEASure:THResholds:ABSolute <vLow> | -1.0 V
MEASure:THResholds:METHod {PERCent|ABSolute} | PERCent
MEASure:THResholds:PERCent <%Low> | 10
MEASure:THResholds:PERCent <%Mid> | 50
MEASure:THResholds:PERCent <%Hi> | 90
MEASure:THResholds:TOPBase:ABSolute <vTop> | +1.0v
MEASure:THResholds:TOPBase:ABSolute <vBase> | -1.0v
MEASure:THResholds:TOPBase:METHod {STANdard, ABSolute} | STANdard
MEASure:WINDow[:DEFine] <start_offset> | 0 (trigger reading)
MEASure:WINDow[:DEFine] <size> | 0 samples (OBM off)


Definite-Length Block Data

Definite-length block response data allows any type of device-dependent data to be transmitted as a series of 8-bit binary data bytes. This is particularly useful for transferring large quantities of data or 8-bit extended ASCII codes.


Ext Trig Input line

Trig In/Out (BNC)

Signal is shown for a negative pulse.

The Trig In/Out connector is found on rear panel of instrument.


L4532A/34A

The Agilent L4532A is a 2-channel digitizer. There is a 4-channel equivalent, the Agilent L4534A. Note that the last digit before the A indicates the number of channels. In this documentation, the term L4532A/34A indicates that the concept at hand applies to both digitizers.


New Line

Line Terminator

<NL> = New Line or Line Feed (ASCII decimal 10)


Non-Volatile Memory

Information in memory is not lost when power is turned off.


Quoted String

Quoted ASCII String

A quoted ASCII string is a string delimited either by " or '. This quoted string must be received by the instrument. Some programming languages require may special handling or syntax.


Volatile Memory

Information in memory is lost when power is turned off.


DHCP

Short for Dynamic Host Configuration Protocol, a protocol for assigning dynamic IP addresses to devices on a network. With dynamic addressing, a device can have a different IP address every time it connects to the network.


Condition Register

A condition register continuously monitors the state of the instrument. The bits in the condition register are updated in real time and the bits are not latched or buffered.


Enable Register

An enable register defines which bits in the event register will be reported to the Status Byte register group. You can write to or read from an enable register.


Event Register

An event register latches the various events from the condition register. There is no buffering in this register; while an event bit is set, subsequent events corresponding to that bit are ignored. This is a read-only register.


Note_Caution_Warning Template

Caution Warning Note

Use the Caution, Warning, and Note examples from this page in your own HTML Help project. Just copy and paste.

Type note text here.

Type caution text here. If you go on and on, you can just keep going and going and going, like this.

Type warning text here.

If you prefer creating your own Caution, Warning, and Note entries, here's how:

  1. Create a two-cell table. Table--> Insert -->Table -->Insert Table Dialog>
    - Two columns, 1 row, no header.
    - Autofit to Window: 00%
    - Align: Left
    - No Caption.
    - Style: NoteTable

  2. The NoteTable style sets the appropriate lack of borders and shading.
  3. Adjust the position of the center column divider (see above).
  4. Insert the Caution, Warning, or Note graphic into the left cell in the table.
  5. Enter the appropriate text to the right of the divider.