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     LAB EXERCISE 2 

Matching Networks and Optimization 

              
Topics:  Small-signal S-parameter optimization and designing matching networks 
for amplifiers and other designs.  Optional is the Impedance Matching too. 

Audience:  Engineers who have a basic working knowledge of ADS or have 
completed the prerequisite course. 

Prerequisites:  Completion of lab exercise 1 of this course.  Also, completion of 
Workspaces and Simulation Tools or equivalent experience, including basic 
circuit design concepts.    

Objectives: Be able to set up and run the optimizer with multiple goals.   Also, 
simulating to verify amplifier gain and stability using a matching network. 
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Lab 2:  Optimization   

About this lab - This lab uses small signal optimization for matching a FET amp to 50 
Ohms.  This will teach you how the optimizer and goals are used. Afterward, you will 
simulate with a matching network based on Load Pull results (lab 1) and created with 
the ADS Impedance Matching tool (optional step only if you have time). Because many 
designers use optimization for many purposes, this lab will teach all the basics.  

1. Amplifier Design with Template 

a. In your my_FET_AMP workspace, add a new cell / schematic and select the 
S_Params_DC template.  Name the new cell S_Params and click OK. 

This will be used to build and test the FET amp before optimization.  The 
templates automatically add simulators and components so you don’t have to 
insert them from the palette – this saves time and effort. Your schematic should 
now have the template items as shown here. Save the design (good practice). 

b. In the corner of the schematic, click the Open icon as shown here to open the 
HB1Tone_LoadPull schematic.  Now, copy (Ctrl-C) the feedback network 
(LRC), the FET, and INCLUDE component as shown here.  Then paste (Ctrl-V) 
it into the new S_Params schematic.  Close the Load Pull schematic.  
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c. Complete the design as shown here.  You will need to insert or copy the 
remaining lumped components and DC sources - you should know how to do this 
already. At the least, rename the feedback components as shown here - this 
makes it easy to identify them for optimization or not) later.  Note that the values 
used for the bias L and C are approximations.  

 

d. Activate the Display Template for the gain and 
stability circles as shown here.  This will create 
the pages in the Data Display and the plots as 
you will see.   

 

2. Simulate and examine Gain and Stability 

a. If your design is correct and you have activated the 
template, go ahead and run the simulation using 
the default simulation shown here. 

Within a few seconds, the simulation should be 
complete and the data display window will open 
with all the template results.  This saves a lot of time… 
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b. Look at Page 1 of the Data Display. Put a marker on S11 and set the Format to 
50 as shown here. These results are expected – Zin is about 29 +j*8 and the gain 
is about 14 dB at 7 GHz.  Also, look at page 2 for zoomed-in views. 

 

c. Look at Pages 3 and 4: these are the activated template pages and they show 
both gain and stability circles.  Move the markers to 7 GHz as shown here.  Try 
changing the step size of the gain circles.  As expected, the greatest gain is at 
the center of the Smith chart.  On page 4, the marker at 7 GHz shows that the 
amplifier is stable.  With the source stability circle outside the Smith chart, it 
simply means that anywhere inside the chart is a stable region – this is good. 
Next, it’s time to set up the Optimization. 

 

d. Save the schematic (keep it open) - Save and close the data display window. 
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At this point, you have seen some load pull results plus the Gain and Stability results. 
Next, you will set up an optimization to match the input and output to 50 Ohms.   

 
3. Set up an Optimization controller and Goals 

a. In your schematic, use the command: File > Save 
As and save it as S_Opt.  Now you only have to 
swap out a few components for the optimization.   
This also keeps the workspace organized with cells 
that describe the contents or simulations.  

 

 

b. Go to the Optim/Stat/ 
DOE palette and insert an 
Optimization controller 
and one Goal shown 
here.  

c. Edit the Goal by double 
clicking.  In the dialog 
box, type in or use the 
buttons to make the 
following settings and 
click Apply each time: 

 

• Expression: dB (S11).  

• Analysis: SP1 (or the 
S_param controller name 
that appears) with the arrow 
button. 

• Freq:  Check the box and 
type in the frequency range 
columns will be added to the 
limit lines – you will set the 
frequency in the next steps. 
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• Type:  Use your cursor to set the limit type to: < (less than).   

• Max: Type in the value of -10. 

This means your goal must 
be a value of S11 that is 
less than -10 dB.  In other 
words, it cannot exceed the 
maximum limit of -10 dB.   

• Freq min & freq max: 
Type in the values for the 
frequency range: 6.5G and 
7.5G.  This means that the 
optimization will only 
operate from 6.5 GHz to 
7.5 GHz.  Also, G is used 
(same as e9) because freq 
is a reserved variable and 
uses Hertz by default.  
Click Apply. 

Verify that your Goal Information and limit lines are set as shown here: 

 

d. Go to the Display tab and check the boxes shown here. Click Apply and 
then OK.  Your Goal should look like this one - if not, check your work. 
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e. Copy the S11 goal - select 
it and use the copy icon.  

f. On screen, change the 
goal expression to 
“dB(S22)” as shown here.  Now, you have two goals: 
one for the input and one for the output match. 

 

 

g. Set up the Optimization controller.  For this lab exercise, most of the 
default settings can remain, including the Random type.  However, use 
your cursor on-screen to change the MaxIter = 50 and the FinalAnalysis 
= “SP1”. These settings mean that the optimizer will run for up to 50 
iterations to achieve the goals.  The Normalize goals setting means that all 
goals will have equal weighting.  Also, the Final Analysis set to yes means 
it will automatically run one final simulation with the last optimization 
values so that you can plot the results without running another simulation.  

Note on other Optim parameter settings:  
 
NormalizeGoals = yes means that multiple goals are equally weighted.   

SetBestValues = yes means that the 
components on schematic can be 
updated with the best optimized 
values.  

All the Save settings save data to the 
dataset.  In some cases, this can be a 
lot of data and a lot of memory.  Also, 
the default is to use all goals and all 
enabled components (next steps) on 
the schematic.  However, you can edit 
the OPTIM controller and select which 
goals or variables to use.  

 

NOTE: The ‘Save’ parameters that are 
set to ‘no’ mean that those values will 
not be written into the dataset.  
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4. Enabling Variables or Parameters to be Optimized  

a. In schematic, use the command Options > Preferences 
and select the tab: Component Text/Wire Label.  Turn on 
the Full display for Opt as shown here and click OK.  This 
will allow you to see the range settings.  

 

b. Edit (double click) the input capacitor (C1). When the dialog 
appears, click the Tune/Opt/Stat/DOE Setup button.  In the 
Optimization tab, set the Optimization Status to Enabled. 
Then type in the continuous range: 1 pF to 20 pF as shown here.  Click OK twice 
and the component text will show the opt function and range in the full format. 
Use the F5 key to move the text if it overlaps the component or wires. 

 

c. Go back to Options > Preferences, select the Component Text/Wire Label tab 
and reset the Opt Display Format to Short and click OK.  Then insert your cursor 
on-screen into the value area and notice that the full details appear. This is how 
you control displayed component values for Tuning, Optimization or Statistics.   
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Now you know how to enable and display the values for a single component.  However, 
there is another way to control variables for optimization, especially if multiple variables 
are to be tuned, optimized, or use for statistical analysis as you will now see. 

d. Click the command Simulate > Simulation Variables Setup.  Go to the 
Optimization tab and notice that your enabled capacitor and values appear.  
This setup makes it easy to set multiple parameters or variables (VARs).  

 

e. Set the other bias capacitor and two inductors (C2, L1 and L2) to be optimized 
(check box) with the values shown here – click OK when done.  

 

NOTE:  Naming the stabilization feedback components (LFB, RFB, CFB) made it easy 
to identify from the bias L and C components without looking at the schematic.  
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f. Deactivate the DC controller, and the two data display templates.  These can 
be re-activated later if you need them.  Verify that your schematic looks like the 
one shown here with four components enabled for optimization. 

 

5. Running an Optimization 

a. Before running the optimization, check the 
Simulate > Simulation Settings and set 
the dataset to the cell name as shown 
here. Click Apply and then Cancel. 

This is always a good idea to ensure you 
do not overwrite a dataset. 

b. Click the Optimize icon to run the 
optimization. 
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c. Immediately, you will see the Optimization Cockpit, Status window and Data 
Display appear.  The cockpit shows all the information you need. Notice that the 
goals are not achieved after 50 iterations but the error function is close to 0.   

 

NOTE: Your values may differ slightly due to the random seeding and algorithm. 

d. In the Data Display (S_Opt) insert a rectangular and a Smith chart as shown 
here.  On the rectangular plot, insert Line Markers on 6.5 GHz and 7.5 GHz.  On 
the Smith chart, set the markers to 7 GHz in 50 ohm format. Notice that the S11 
goal was achieved but S22 was not achieved.   
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e. Save and close the Data Display 

f. Click the Close button in the Optimization Cockpit – the click the button: Don’t 
Update the Design.  This means the L and C values will not be updated – this is 
OK because you can re-run the optimization to get the results back again.  Also, 
you are going to be using new values for the amplifier as you will see later. 

g. Save the schematic but keep it open. 

NOTE: Optimization can be use with other 
simulators such as Harmonic Balance to 
achieve other goals.  The Examples directory 
has numerous optimization setups.    

 

6. Simulate with a Matching Network  

a. In the S_Opt schematic, click the command: File > Save As. 

b.  When the dialog appears, 
name the cell: 
S_Params_Zmatch as 
shown here - then click OK.   

 
 
The copied schematic should 
appear in a new window ready to 
use for the next steps. 
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c. In the new schematic, S_Params_Zmatch, add the output matching network 
with the L and C values to as shown.  If you have time, rename the components 
(L_out_1, L_out_2, C_out) as shown.  This may be helpful for identifying their 
purpose.  The resistive value for the inductors is negligible but realistic.  

 

d.  Activate the DC controller and the two templates as shown here. 

e. Simulate.  Then verify that your schematic is similar to one shown 
here and Simulate. Then go through the pages of the Data Display - you should 
see similar results – add S22 to the Smith chart as shown.  This design shows 
stability and, at 7 GHz, good gain with a good match to 50 ohms.  

 

f. Save and 
close all your 
work.  -  but 
continue to 
the Optional 
Step if you 
have time. 

  

Copyright 2013 Agilent Technologies  

14 



Lab 2:  Optimization  

7. OPTIONAL: Impedance Matching tool 

a. In the Main window, use the wizard create a New Workspace and 
name it: My_Z_match and select only the ADS Analog/RF library and 
only the ADS Analog/RF technology as shown here.     

 

b. In the new workspace, create a new cell/schematic 
named: FET_match.  

 

c. In the new schematic, select the command: Tools > 
Impedance Matching.  When the Utility dialog appears, 
click on the Component palette icon and the Impedance Matching palette will 
appear in schematic. Then insert the bandpass component.  
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d. In the Impedance Matching Utility, use the pull down arrow to select the 
SmartComponent: DA_LCBandpassMatch1 as shown here – it will be 
highlighted in schematic.  This is necessary so that the utility recognizes it. 

e. In the Matching Assistant tab, set the frequency range Fp1=6 GHz and Fp2= 8 
GHz for this exercise.  Set the Source Impedance to Complex Impedance and 
the Z = (19+j*2) - be sure to include the parentheses – and check the box to 
Interpret as Input Impedance. Finally, set the Load Impedance to Resistive 50 
Ohm as shown here. Then click Design at the bottom. 
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NOTE: 19+j*2 is an approximate value of load impedance from 
the load pull results (lab 1).  This value will be seen by the 
amplifier output, and 50 ohms will be seen by the next stage.  In 
other words, this is transforming the optimum load match to 50 
ohms.. 

f. If the settings are correct, you should immediately see 
the tool working.  Click OK to the prompt and you will 
see the network.  It is a lower level hierarchy to the 
component you inserted.  

g. Next, go ahead and click the Optimize button and you will see the results similar 
to those shown here. This is the network that will be connected to the amplifier 
output. Also, notice that you have some new cells added to the workspace. 

 

h. Save and close the schematics or other design windows.  

You now know how to use this tool for creating matching networks. Also, this is 
the matching network that will be used for the FET amplifier in the next lab. 

i. In the Main window, use the command File > Recent Workspaces and go back 
to the My_FET_AMP workspace. 

 

 

 

END of LAB EXERCISE.  
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