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1 Installation
Overview

Several software products and components are 
required to complete the Agilent N6430A Series WiMAX 
Protocol Test and Development System. 

This chapter provides a step- by- step guide to the 
installation of the N6430A Series software and also 
shows you how to ensure your Agilent E6651A WiMAX 
Test Set has the required firmware.

Please Check

Before proceeding, please confirm you have the 
following:

• Agilent E6651A WiMAX Test Set

• A computer meeting the requirements specified in 
“Minimum Computer Requirements -  N6430A” on page 3.

• Ethernet hub or switch and LAN cables

• N6431A entitlement certificate for license redemption

• N6432A and/or N6442A Test Adaptor USB license keys

• Entitlement certificate for mobile or base station test 
developer’s solution, or

• Entitlement certificate for mobile or base station test 
developer and conformance solution

• For Base Station test only, an entitlement certificate for 
E6653A is required

(refer to the Configuration Guide using the Options tab at 
http://www.agilent.com/find/pct for more details of the 
developer’s, and developer and conformance software 
suites)

NOTE These Installation instructions are for both Mobile and Base Station Test.
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Installation 1
Minimum Computer Requirements - N6430A

The N6430A Series installation computer should meet 
the minimum requirements specified for successful 
operation of the software.

Requirements

Processing large amounts of time critical data is an 
inherent requirement of the conformance test system. 
A high performance desk- top style computer with 
expansion capacity for additional Network Interface 
Cards (NIC) or adaptors is recommended.

Minimum System Requirements

Operating
System

Computer running Windows XP.

Communication
with Test Set(s)

Ethernet.

RAM (Memory) Minimum 2 GB RAM.

Processor 3.0 GHz Intel Pentium® or equivalent, dual core 
preferred.

Disc Space N6431A TTCN- 3 Environment -  at least 170 MB

Java Runtime Environment -  at least 300 MB

N6432A/33A/34A/42/43A Test Adaptors -  at least 50 
MB 

Optional

Additional Network Interface Cards (NIC) or adaptors 
if connection to public or corporate network is 
required.

NOTE Consideration for storage space should also be given for subsequent 
downloaded releases of N6432A/33A/34A/42A/43A updates, 
development and validated scripts, and all supporting documentation, 
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1 Installation
Minimum Computer Requirements - For Authentication 
Server (optional)

If an authentication server is part of your test 
configuration, a Linux operating system such as 
Ubuntu, and a radius server such as freeRadius are 
suitable.

Typical Minimum System Requirements

Operating
System

Linux -  Redhat 9.x, Ubuntu 8.x

Processor Intel® Pentium® 2.8GHz or equivalent

Communication Ethernet.

RAM (Memory) Minimum 512 MB RAM.

Disc Space 4GB for Linux installation

Network
Interface Cards

(NIC) or adaptors for connection to network.

For more detailed requirements and installation 
instructions, refer to the documentation at 
http://www.ubuntu.com, http://www.redhat.com, and 
http://freeradius.org.
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Installation 1
Step 1 - License Redemption

N6431A TTCN Environment License Redemption

The N6431A TTCN- 3 environment software 
(TTworkbench) is provided through collaboration with 
Testing Technologies IST GmbH. Agilent provide two 
options for TTworkbench products:

• N6431A TTCN- 3 Environment

• N6431A- 2FP TTCN- 3 Environment, developer license

An entitlement certificate for one of these options is 
required to redeem your license. License information is 
required during the installation process.

Entitlement certificates are also required for each of 
the N6432A, N6433A, N6434A, N6442A, and N6443A 
product you have purchased. 

Redeeming your
Licenses

The license redemption procedure is similar for all 
products and requires that you have all or some of the 
following information readily available:

• Installation computer Hostname and LAN adaptor MAC 
address

• Order Number for your N6431A license
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1 Installation
Determine
Hostname and
MAC Address

To find the Hostname and MAC address of the LAN 
adaptor on your computer proceed as follows:

1 Click Start > Run and enter cmd in the Run window as 
shown.

Figure 1 Run Window

2 In the command window, enter ipconfig /all to list 
information about your network adaptors, including the 
Host Name and MAC address (known as the physical 
address), a 12 digit hexadecimal number. 

In the example shown in Figure 2, the host name is 
“ipsc1046” and the MAC Address is 00- 04- 76- 4E- 26- 40.

Figure 2 Command Window

3 To redeem your license, go to the following web site: 
http://www.agilent.com/find/softwarelicense. Enter your order 
number and certificate entitlement number. Follow the 
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Installation 1
on- screen instructions. When prompted, enter your 
hostname, a single character space, and your 12 digit 
MAC address with no spaces between the hexadecimal 
numbers as shown in Figure 3.

Figure 3 Entering Hostname and MAC Address

On completion of this process an e- mail is sent to you 
with an “order_number_xyz.lic” attachment. This file is 
the license file and is required during the installation if 
the TTCN- 3 environment and should be saved to a 
suitable location.

NOTE An instrument serial number is not required for this type of license. You 
can leave the instrument serial number field empty.

NOTE It is recommended that you save all license files to a convenient but 
secure location.
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Alternative Process

If you cannot access your e- mail account, you can:

1 Complete Steps 1 to 3 as above.

2 On the License website, click Redemption Options.

3 Right click the license file and select Save As...

4 Save the license file to a suitable location.

N6432A, N6433A, N6434A, N6442A, and N6443A License 
Redemption

Entitlement certificates are also required for each of 
the N6432A, N6433A, N6434A, N6442A, and N6443A 
product you have purchased. 

Repeat the procedure for each required license.

Redeeming your
Licenses

The license redemption procedure is similar for all 
products and requires that you have all or some of the 
following information readily available:

• Order Number for each product license

• USB license key serial number (for 
N6432A/N6433A/N6434A or N6442A/N6443A)

1 To redeem your licenses, go to the following web site: 
http://www.agilent.com/find/softwarelicense. 

2 Enter your order number and certificate entitlement 
number. Follow the on- screen instructions. 

3 When prompted, enter your USB license key serial 
number.

On completion of this process an e- mail is sent to you 
with an “order_number_xyz.lic” attachment. This file is 
the license file and is required during the installation if 
the TTCN- 3 environment and should be saved to a 
suitable location. An access code for the Agilent 
N6430A software download site is also supplied. This 
should be retained for use in subsequent download and 
update procedures.
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Installation 1
Step 2 - Determine Required Software Versions

Software, and software updates for the N6430A and 
E6651A Mobile WiMAX Protocol Conformance and 
Development systems are released frequently to align 
with ETSI script releases and validation processes. For 
successful operation it is important to ensure 
compatibility between the E6651A Test Set firmware 
and N6432A/3A/4A and N6442A/3A Test Adaptor is 
maintained.

Both software (and updates) and compatibility matrices 
are available from the Agilent WiMAX PCT support 
web pages at: http://www.agilent.com/find/pct

To access the software and release information proceed 
as follows:

Procedure 1 Click Technical Support > Drivers & Software.

2 Click the N6430A series WiMAX Protocol Conformance and 
Development Software Downloads link to display the software 
download page:

As stated on this page, you can download the appropriate 
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1 Installation
software for your application. To complete software 
installations, a valid license is required. A login and 
password are also required for some areas. Please refer to 
the displayed web page for the latest detailed information.

3 From the list displayed on the web page, select the topics 
you require -  choose from:

 

PCT Software updates for MS Development and 
Conformance
(N6432A WiMAX TTCN-3 Test Adaptors)

Accesses links for supported 
configuration tables, software and 
updates and installation instructions for 
MS PCT test developers and 
conformance testing.

NCT Software updates for MS Development and 
Conformance
(N6434A WiMAX TTCN-3 Test Adaptors)

Accesses links for supported 
configuration tables, software and 
updates and installation instructions for 
MS NCT test developers and 
conformance testing.

PC Software updates for BS Development and 
Conformance
(N6442A WiMAX TTCN-3 Test Adaptors)

Accesses links for supported 
configuration tables, software and 
updates and installation instructions for 
BS PCT test developers and 
conformance testing.

Other Software Updates
(E6651A WiMAX Test Set, N6431A TTworkbench 
and other components)

Accesses links for E6651A firmware, 
N6431A software, and other component 
updates.

Other Information and Support
(N6432A WiMAX TTCN-3 Test Adaptors)

Accesses links to other information 
such as the WiMAX Forum and the ETSI 
Mantis system.

NOTE It is recommended that you save all downloaded files to a secure location 
before unpacking any archives.
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Installation 1
Step 3 - Installing the N6431A TTCN-3 Environment

The latest N6431A TTCN- 3 Environment installation is 
available for download from the 
www.agilent.com/find/pctdownloads website. This website 
is protected by password. Your unique access code can 
be found in the e- mail you received containing your 
N6432A, N6433A, N6434A, N6442A, or N6443A license 
file.

Procedure

1 Browse to www.agilent.com/find/pctdownloads and select the 
Other Software Updates link.

2 Use the access code supplied in the e- mails received 
following “N6432A, N6433A, N6434A, N6442A, and 
N6443A License Redemption” on page 8 to access the 
downloads page.

3 Download version 1.1.5.1.2 of the N6431A. The installation 
file is setup_N6431A-2FP_1.1.5.1.2.exe.

4 When the download is complete, run the downloaded 
setup file.

5 Follow the displayed instructions.

6 When prompted by the license window, Browse to the 
“order_number_xyz.lic” file previously delivered to you by 
e- mail during the license redemption procedure.

NOTE The Agilent WiMAX MS Protocol Test application uses a specific version 
of TTworkbench. Even if you already have TTworkbench installed, 
installation of the N6431A is required.
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1 Installation
The TTworkbench and N6432A/33A/34A/42A/43A 
software require the installation of JDK (Java™ SE 
Development kit). Version 5 Update 14 is installed. The 
first step in the install process is the installation of the 
Java™ software.

7 Click Next to continue with the installation.

The installation proceeds by first installing the Java 
Development environment followed by the TTCN- 3 
environment.

8 Click Finish to complete the installation.

Un-installation

If un- installation is required, use Add or Remove Programs 
accessed from the Windows Control Panel. Click Start > 
Control Panel > Add or Remove Programs.

NOTE This installation may add another version of JDK to your Add/Remove 
Programs if you already have a different version installed. Remove all other 
version of JDK and JRE before installing the N6431A.
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Installation 1
Step 4 - Installing N6432A PCT Mobile Station Test Adaptor 
(if ordered)

The N6432A PCT Mobile Station Protocol Test Adaptor 
requires that the N6431A TTCN- 3 Environment is 
installed. If you have not already done so, refer to 
“Step 3 -  Installing the N6431A TTCN- 3 
Environment” on page 11

N6432A Installation Components

The N6432A installation installs the following items on 
your computer:

• USB License Key driver and utilities (available from the 
Start menu)

• N6432A Protocol Conformance Test Adaptor

Procedure

1 Browse to www.agilent.com/find/pctdownloads and select 
Software Updates for MS Developers.

2 Use the access code supplied in the e- mails received from 
“N6432A, N6433A, N6434A, N6442A, and N6443A License 
Redemption” on page 8 to access the downloads page.

3 Download the most recent qualified or tested beta version 
of the N6432A that is supported with the 1.1.5.1.2 version 
of the N6431A. Refer to the supported configurations 
document on the N6432A download site. The installation 
file is N6432A_x.5.0.2.19.exe or later.

4 When the download is complete, run the downloaded 
setup file.

5 When prompted, enter your details and click to accept the 
license agreement.

NOTE Before proceeding, please ensure you have your USB license key and 
redeemed license details available.
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1 Installation
6 Follow the displayed instructions.

7 One of the first steps of the process is the installation of 
the SUT (system under test) adaptors. You are asked to 
confirm the root directory which you would like to use 
for saving the adaptor software. The default root directory 
is:
C:\Program Files\Agilent\WiMAX MS Protocol Test 

8 The program installs the adaptor.

Depending on the purchased products and options, 
your license enables use of one or both the 
development and/or conformance releases. The 
directory structure for the individual releases is as 
follows:

• Developer versions -  root_directory\N6432A Development 
Releases\N6432A_A.w.x.y.z

• Conformance versions -  root_directory\N6433A 
Conformance Releases\N6433A_V.w.x.y.z

The releases are numbered as follows:

• A.w.x.y.z releases are qualified developers releases

• X.w.x.y.z releases are pre- qualified developers releases

• V.w.x.y.z releases are WiMAX Forum® validated releases.

9 The N6432A install program also installs the drivers for 
your USB license key. Check the USB License key install 
box to perform the installation of the Sentinel Protection 
Installer software. 

10 Plug in your USB license key and check the installation 
has worked. 

• If your key shows a green light it is successfully installed.

NOTE The install program only installs a development release.
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Installation 1
• If a window showing “Welcome to the Found New Hardware 
Wizard” appears, the installation has not been successful. 
Un- install and re- install the N6432A software. 

Uninstallation

The Agilent N6432A Test Adaptor and Sentinel 
Protection Installer software can be un- installed using 
Add/Remove Programs in Windows.
N6430A series Installation and Getting Started Guide 15



1 Installation
Step 5 - Installing N6434A NCT Mobile Station Test Adaptor 
(if ordered)

The N6434A NCT Mobile Station Protocol Test Adaptor 
requires that the N6431A TTCN- 3 Environment is 
installed. If you have not already done so, refer to 
“Step 3 -  Installing the N6431A TTCN- 3 
Environment” on page 11

N6434A Installation Components

The N6434A installation installs the following items on 
your computer:

• USB License Key driver and utilities (available from the 
Start menu)

• N6434A Network Conformance Test Adaptor

Procedure

1 Browse to www.agilent.com/find/pctdownloads and select 
Software Updates for MS Developers.

2 Use the access code supplied in the e- mails received from 
“Step  -  N6432A, N6433A, N6434A, N6442A, and N6443A 
License Redemption” on page 8 to access the downloads 
page.

3 Download the most recent qualified or tested beta version 
of the N6434A that is supported with the 1.1.5.1.2 version 
of the N6431A. Refer to the supported configurations 
document on the N6434A download site. The installation 
file is N6434A_x.5.1.0.10.exe or later.

4 When the download is complete, run the downloaded 
setup file.

5 When prompted, enter your details and click to accept the 
license agreement.

NOTE Before proceeding, please ensure you have your USB license key and 
redeemed license details available.
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Installation 1
6 Follow the displayed instructions.

7 One of the first steps of the process is the installation of 
the SUT (system under test) adaptors. You are asked to 
confirm the root directory which you would like to use 
for saving the adaptor software. The default root directory 
is:
C:\Program Files\Agilent\WiMAX MS Network Test 

8 The program installs the adaptor.

The directory structure for the releases is as follows:

• Release -  root_directory\N6434A Releases\
N6434A_A.w.x.y.z

9 The N6434A install program also installs the drivers for 
your USB license key. Check the USB License key install 
box to perform the installation of the Sentinel Protection 
Installer software. 

10 Plug in your USB license key and check the installation 
has worked. 

• If your key shows a green light it is successfully installed.

• If a window showing “Welcome to the Found New Hardware 
Wizard” appears, the installation has not been successful. 
Un- install and re- install the N6434A software. 

Uninstallation

The Agilent N6434A Test Adaptor and Sentinel 
Protection Installer software can be un- installed using 
Add/Remove Programs in Windows.
N6430A series Installation and Getting Started Guide 17



1 Installation
Step 6 - Installing N6442A PCT Base Station Test Adaptor (if 
ordered)

The N6442A PCT Base Station Protocol Test Adaptor 
requires that the N6431A TTCN- 3 Environment is 
installed. If you have not already done so, refer to 
“Step 3 -  Installing the N6431A TTCN- 3 
Environment” on page 11.

N6442A Installation Components

The N6442A installation installs the following items on 
your computer:

• USB License Key driver and utilities (available from the 
Start menu)

• N6442A Protocol Conformance Test Adaptor

Procedure

1 Browse to www.agilent.com/find/pctdownloads and select 
Software Updates for BS Developers.

2 Use the access code supplied in the e- mails received from 
“License Redemption” to access the downloads page.

3 Download the most recent qualified or tested beta version 
of the N6442A that is supported with the 1.1.5.1.2 version 
of the N6431A. Refer to the supported configurations 
document on the N6442A download site. The installation 
file is N6442A_x.5.0.1.20.exe or later.

4 When the download is complete, run the downloaded 
setup file.

5 When prompted, enter your details and click to accept the 
license agreement.

6 Follow the displayed instructions.

NOTE Before proceeding, please ensure you have your USB license key and 
redeemed license details available.
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Installation 1
7 One of the first steps of the process is the installation of 
the SUT (system under test) adaptors. You are asked to 
confirm the root directory which you would like to use 
for saving the adaptor software. The default root directory 
is:
C:\Program Files\Agilent\WiMAX BS Protocol Test 

8 The program installs the adaptor.

Depending on the purchased products and options, 
your license enables use of one or both the 
development and/or conformance releases. The 
directory structure for the individual releases is as 
follows:

• Developer versions -  root_directory\N6442A Development 
Releases\N6442A_A.w.x.y.z

• Conformance versions -  root_directory\N6443A 
Conformance Releases\N6443A_V.w.x.y.z

The releases are numbered as follows:

• A.w.x.y.z releases are qualified developers releases

• X.w.x.y.z releases are pre- qualified developers releases

• V.w.x.y.z releases are WiMAX Forum® validated releases.

9 The N6442A install program also installs the drivers for 
your USB license key. Check the USB License key install 
box to perform the installation of the Sentinel Protection 
Installer software. 

10 Plug in your USB license key and check the installation 
has worked. 

• If your key shows a green light it is successfully installed.

• If a window showing “Welcome to the Found New Hardware 
Wizard” appears, the installation has not been successful. 
Un- install and re- install the N6442A software. 

NOTE The install program only installs a development release.
N6430A series Installation and Getting Started Guide 19
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Un-installation

The Agilent N6442A Test Adaptor and Sentinel 
Protection Installer software can be un- installed using 
Add/Remove Programs in Windows.
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Installation 1
Step 7 - Redeem License for Developers’ Contract 
(if ordered)

If, as a developer, you plan to write and compile 
scripts, you require an N6432A- 1TY or N6442A- 1TY 
license redemption certificate. This entitles you to 
access the web and use development releases for a 
period of 12 months. The licensing of this entitlement 
is enabled via the USB license key.

Check Entitlement Status

You can check the current entitlement status of your 
USB license key using installed utilities found in the 
Start menu. Click Start > Agilent Mobile WiMAX Test Set > 
N6430A Series Utilities >Read USB License Key to view the 
USB license key contents.

A window similar to that shown in Figure 4 provides 
the serial number of your USB license key and 
licenses. The serial number is also printed on the key.

Figure 4 USB License Key Reader Display
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Developers’ License Redemption

To redeem your License, proceed as follows:

1 Go to the following secure web site:
http://www.agilent.com/find/softwarelicense.

2 Enter your order number and certificate entitlement 
number.

3 Follow the displayed instructions, entering your USB 
License key serial number when prompted.

4 On completion of this process, an E- mail with an 
order_number_identity_number.lic attachment is sent to 
you. This is the license file.

5 Ensure the USB license key is inserted and click Start > 
Agilent Mobile WiMAX Test Set > N6430A Series Utilities > Update 
USB License Key to update your entitlement in the USB 
license key.

6 When updated, the USB License Key update window is 
displayed:

NOTE It is recommended that you save all license files to a convenient but 
secure location. Copy files to C:\Program Files\Agilent\N6430A Series 
Utilities\USB License Key Utilities only when required for updates. 
Remove the files from the update location afterwards.

NOTE For Mobile Station test, ensure that only your N6432A License key is in the 
computer. No other license key should be connected. Likewise, for Base 
Station test ensure that only the N6442A License key is connected.
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Installation 1
7 Click Start > Agilent Mobile WiMAX Test Set > N6430A Series 
Utilities >Read USB License Key to check that you now have 
entitlement to use the developer's web releases. After 
updating your USB key, confirm the information is similar 
to that shown in Figure 5.

Figure 5 Updated USB License Key Information

Developer's releases are available at 
http://www.agilent.com/find/pctdownloads. 
This site is password protected. A unique password is 
provided to you with your software license e- mail.
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Step 8 - Redeem License for Wave 1 Validated Release and 
Contract (if ordered)

If, as a conformance tester, you plan to run 
pre- compiled scripts for conformance testing, you 
require entitlement certificates for both N6433A- 1TP 
and N6433A- 1TY or N6443A- 1TP and N6443A- 1TY. 
This entitles you to access the web and use validated 
conformance releases for a period of 12 months. The 
licensing of this entitlement is enabled via the USB 
license key.

Check Entitlement Status

To check the current entitlement status of your USB 
license key, click Start > Agilent Mobile WiMAX Test Set > 
N6430A Series Utilities >Read USB License Key. 

NOTE Check the download web site 
(http://www.agilent.com/find/pctdownloads) for availability of a 
validated release before redeeming this license. The password for the 
website is shown on your entitlement certificate. You do not need to 
redeem your license until there is a validated release available. 
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Installation 1
A window similar to that in Figure 6 shows the serial 
number of you USB license key. The serial number is 
also printed on the key.

Figure 6 USB License Key Reader Display

Wave 1 Validated Release License Redemption

To redeem your License, proceed as follows:

1 Go to the following secure web site:
http://www.agilent.com/find/softwarelicense.

2 Enter your order number and certificate entitlement 
number.

3 Follow the displayed instructions, entering your USB 
License key serial number when prompted.

4 On completion of this process, an E- mail with an 
order_number_identity_number.lic attachment is sent to 
you. This is the license file.

NOTE It is recommended that you save all license files to a convenient but 
secure location. Copy files to C:\Program Files\Agilent\N6430A Series 
Utilities\USB License Key Utilities only when required for updates. 
Remove the files from the update location afterwards.
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1 Installation
5 Ensure the USB license key is inserted and click Start > 
Agilent Mobile WiMAX Test Set > N6430A Series Utilities > Update 
USB License Key to update your entitlement in the USB 
license key.

6 When updated, the USB License Key update window is 
displayed:

7 Click Start > Agilent Mobile WiMAX Test Set > N6430A Series 
Utilities >Read USB License Key to check that you now have 
entitlement to use the validated web releases. After 

NOTE For Mobile Station test, ensure that only your N6432A License key is in the 
computer. No other license key should be connected. Likewise, for Base 
Station test ensure that only the N6442A License key is connected.
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Installation 1
updating your USB key, confirm the information is similar 
to that shown in Figure 7.

Figure 7 Updated License Information

Wave 1 Conformance releases are available at 
http://www.agilent.com/find/pctdownloads. 
This site is password protected. A unique password is 
provided to you with your software license e- mail.
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Step 9a - Redeem License for NCT Test Adaptor (if ordered)

The licensing of the NCT Tets Adaptor is enabled via 
the USB license key.

Check Entitlement Status

To check the current entitlement status of your USB 
license key, click Start > Agilent Mobile WiMAX Test Set > 
N6430A Series Utilities >Read USB License Key. 

A window similar to that in Figure 8 shows the serial 
number of you USB license key. The serial number is 
also printed on the key.

Figure 8 USB License Key Reader Display

NOTE Check the download web site 
(http://www.agilent.com/find/pctdownloads) for availability of a 
validated release before redeeming this license. The password for the 
website is shown on your entitlement certificate. You do not need to 
redeem your license until there is a validated release available. 
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License Redemption

To redeem your License, proceed as follows:

1 Go to the following secure web site:
http://www.agilent.com/find/softwarelicense.

2 Enter your order number and certificate entitlement 
number.

3 Follow the displayed instructions, entering your USB 
License key serial number when prompted.

4 On completion of this process, an E- mail with an 
order_number_identity_number.lic attachment is sent to 
you. This is the license file.

5 Ensure the USB license key is inserted and click Start > 
Agilent Mobile WiMAX Test Set > N6430A Series Utilities > Update 
USB License Key to update your entitlement in the USB 
license key.

6 When updated, the USB License Key update window is 
displayed:

NOTE It is recommended that you save all license files to a convenient but 
secure location. Copy files to C:\Program Files\Agilent\N6430A Series 
Utilities\USB License Key Utilities only when required for updates. 
Remove the files from the update location afterwards.

NOTE For Mobile Station test, ensure that only your N6432A License key is in the 
computer. No other license key should be connected. Likewise, for Base 
Station test ensure that only the N6442A License key is connected.
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7 Click Start > Agilent Mobile WiMAX Test Set > N6430A Series 
Utilities >Read USB License Key to check that you now have 
entitlement to use the validated web releases. After 
updating your USB key, confirm the information is similar 
to that shown in Figure 9.

Figure 9 Updated License Information
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Step 9b - Redeem License for NCT Contract (if ordered)

This entitles you to access the web and use releases 
for a period of 12 months. The licensing of this 
entitlement is enabled via the USB license key.

Check Entitlement Status

To check the current entitlement status of your USB 
license key, click Start > Agilent Mobile WiMAX Test Set > 
N6430A Series Utilities >Read USB License Key. 

A window similar to that in Figure 10 shows the serial 
number of you USB license key. The serial number is 
also printed on the key.

Figure 10 USB License Key Reader Display

NOTE Check the download web site 
(http://www.agilent.com/find/pctdownloads) for availability of a 
validated release before redeeming this license. The password for the 
website is shown on your entitlement certificate. You do not need to 
redeem your license until there is a validated release available. 
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Wave 1 Validated Release License Redemption

To redeem your License, proceed as follows:

1 Go to the following secure web site:
http://www.agilent.com/find/softwarelicense.

2 Enter your order number and certificate entitlement 
number.

3 Follow the displayed instructions, entering your USB 
License key serial number when prompted.

4 On completion of this process, an E- mail with an 
order_number_identity_number.lic attachment is sent to 
you. This is the license file.

5 Ensure the USB license key is inserted and click Start > 
Agilent Mobile WiMAX Test Set > N6430A Series Utilities > Update 
USB License Key to update your entitlement in the USB 
license key.

6 When updated, the USB License Key update window is 
displayed:

NOTE It is recommended that you save all license files to a convenient but 
secure location. Copy files to C:\Program Files\Agilent\N6430A Series 
Utilities\USB License Key Utilities only when required for updates. 
Remove the files from the update location afterwards.

NOTE For Mobile Station test, ensure that only your N6432A License key is in the 
computer. No other license key should be connected. Likewise, for Base 
Station test ensure that only the N6442A License key is connected.
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7 Click Start > Agilent Mobile WiMAX Test Set > N6430A Series 
Utilities >Read USB License Key to check that you now have 
entitlement to use the validated web releases. After 
updating your USB key, confirm the information is similar 
to that shown in Figure 11.

Figure 11 Updated License Information
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Step 10 - E6651A Test Set Firmware

The E6651A WiMAX Test Set must have a version of 
firmware installed that supports the N6430A Series 
applications for both Base and Mobile Station test. 
Additionally, firmware updates may be essential to 
meet the requirements of new scripts released in the 
N6432A/N6442A software updates.

Mobile Station and Base Station test require different firmware

The E6651A WiMAX Test Set is normally configured in 
Base Station Emulation mode for mobile station test 
using the N6432A/N6433A/N6434A test adapters. 

For Base Station test with the N6442A/N6443A 
adapters the Test Set must have the E6653A Mobile 
Station Emulation firmware installed and enabled.

Mobile Station
PCT/NCT Test

Test Set firmware for N6432A/N6433A/N6434A Test Adaptors

To check the version of the firmware installed on your 
E6651A, proceed as follows:

1 Ensure the Test Set has completed its start up sequence 
and the WiMAX Application has started.

2 Check the version -  it is displayed in the Firmware and 
Profile bar at the base of the display. 

E6651A Firmware version later than 5.1.0.11 or 6.3.1.0 
is required to support the N6430A Series software.

NOTE You should always check the required configuration of software and 
firmware for each release of N6430A series applications by referring to the 
release notes supplied with the new release. Or, refer to the supported 
configurations matrix linked from the pct-downloads website for each 
N6430A series application.
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Download Firmware (if required)

Please ensure that you check the N6430A Series release 
notes at www.agilent.com/find/pctdownloads for 
information about E6651A Test Set firmware 
requirements. Downloads are available from the same 
website, www.agilent.com/find/pctdownloads.

Base Station
Test

Test Set firmware for N6442A/N6443A Test Adaptors

To enable Mobile Station Emulation, an E6653A- 1FP 
license must be redeemed and installed in the E6651A 
Test Set. E6653A Mobile Station Emulation firmware 
must also be installed in the Test Set and enabled.

E6653A-1FP License Redemption

To redeem your License, proceed as follows:

1 Go to the following secure web site:
http://www.agilent.com/find/softwarelicense.

2 Enter your order number and certificate entitlement 
number.

3 Follow the displayed instructions, entering your E6651A 
serial number when prompted. The serial number can be 
found on the rear panel label or from the Service Screen 
on firmware versions 5.3.1.0 or 6.3.1.0 or later.

4 On completion of this process, an E- mail with an 
order_number_identity_number.lic attachment is sent to 
you. This is the license file.

NOTE It is recommended that you save all license files to a convenient but 
secure location.
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E6653A-1FP License Installation

To install the License in the E6651A proceed as 
follows:

1 On a USB flash memory stick, create a folder called 
setup.inno as the root directory.

2 Copy the license file to the setup.inno folder on the 
memory stick.

3 In the setup.inno folder, rename the license file as 
license.lic.

4 Ensure you have E6651A firmware version 5.3.3.0, 6.3.3.0, 
or later installed in your E6651A Test Set. (Refer to 
step 2 on page 34.

5 Insert the memory stick into one of the USB ports on 
your E6651A.

6 On the E6651A, press the System key followed by the 
Service key and select Update License from the softkey 
menu. Navigating to a second page of softkeys in the 
System menu may be required to access the Service key.

7 Wait approximately 10 seconds for the license to be 
installed successfully before installing the E6653A Mobile 
Station emulation firmware.

E6653A Mobile Station Emulation Firmware Installation

Install the E6653A firmware as follows:

1 Go to the following secure web site:
http://www.agilent.com/find/pctdownloads and select Other 
Software Updates.

2 Use the access code supplied in the e- mails received from 
“N6432A, N6433A, N6434A, N6442A, and N6443A License 
Redemption” to access the downloads page.

3 Download required version of E6653A firmware. Refer to 
the supported configuration matrix document on the 
N6442A download site.

4 When the download is complete, browse to the “E6651A 
Software update procedure” located in the Other Information 
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and Support section of the 
http://www.agilent.com/find/pctdownloads website to find 
the procedure to install the E6653A in the E6651A Test 
Set.

NOTE Before proceeding, please ensure you have your USB license key and 
redeemed license details available.
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Step 11 - Connecting the System

For operation with the N6430A Series applications the 
E6651A and application host computer must be 
connected via an Ethernet hub or switch. 

Figure 12 Example Interconnection

N6430A series TTCN-3 environment
and Test Adaptors 
installed

Optional N6421A Protocol 
Logging and Analysis 
installed

Optional Authentication (AAA) 
Server (N6432A/33A/34A only)

Wired Lan Interconnections

Mobile Station
Under Test

Optional 2nd E6651A for Handover 
Testing (N6432A/33A only)

License Key License Key
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Procedure

Before connecting the set- up, check and configure the 
IP address of your computer. Settings are required as 
follows:

• IP Address: 10.253.18.111

• Subnet mask: 255.255.0.0

You can check the IP address details on your PC by 
opening a command window. 

1 Click Start > Run and enter cmd at the prompt.

Figure 13 Run Window

2 In the command widow, enter: ipconfig

Figure 14 IP Address and Subnet Mask Check
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3 If the IP settings are not as defined at the beginning of 
the procedure, change them by clicking Start > Control Panel 
> Network Connections. 

4 Right click on your Local Area Connection and select 
Properties.

5 Scroll down to find and click to highlight Internet protocol 
(TCP/IP)

6 Click the Properties button. 

7 Check “Use the following IP address” and enter the numbers 
shown in Figure 14.

Figure 15 IP Address and Subnet Mask Entry

8 Connect the E6651A to your PC using Figure 12 on 
page 38 for guidance. 

NOTE Note this must be done to set the IP address in the E6651A.
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E6651A Test Set
LAN Settings

9 Check the IP address on your E6651A by pressing System, 
More 2/2. The IP address and subnet mask values are 
displayed in the Network Setting field.

Figure 16 Test Set IP Address and Subnet Mask

10 The following LAN settings are required:

• IP Address -  10.253.18.79

• Subnet mask -  255.255.0.0

• Target BSE for Handover Testing Address -  10.253.18.179

11 If you need to change the settings, proceed as follows:

a Press the Network Setting softkey.

b Press the softkey associated with the parameter you 
need to change.

c Use the numeric keys to enter the required value and 
press Enter.

d Use the Arrow keys to select the next value to be 
changed and repeat the previous steps.

e When you have configured all the settings press Apply.
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Check the
Connection

12 Check the connection by opening a command prompt 
window on the computer connected to the E6651A Test 
Set -  click Start > Run and type cmd into the Run Window.

13 Enter ping 10.253.18.79 at the command prompt (and ping 
10.253.18.179 for the second E6651A if required). 

Confirm lines displayed starting with the text - Reply 
from 10.253.18.79 as shown in Figure 17. Your computer 
and E6651A's network settings have been configured 
correctly and your computer can transfer packets to 
the E6651A successfully.

Figure 17 Successful Ping Command and Return
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If the computer and Test Set LAN configurations are 
incorrect, the Ping command results in a time out.

Figure 18 Ping Time-out
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Step 12 - Integrating the N6421A Protocol Logging and 
Analysis Application

System Configuration Manager

1 On the N6421A installation computer, click Control Panel > 
Network Connections.

2 Right- click the required connection to display the 
Properties.
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3 Highlight Internet Protocol (TCP/IP) and click Properties.

4 On the N6430A Series installation computer click Start > 
All Programs > Agilent Mobile WiMAX Test Set > N6430A Series 
Utilities > System Configuration Manager to open the following 
window. Ensure the IP address displayed in step 3 
matches the N6421A IP address on the System Configuration 
Manager.

5 Open the N6421A Protocol Logging application and click 
File, Port Open. Ensure the E6651A IP address in the Port 
Open window matches that displayed in the System 
Configuration Manager. Double click to edit the IP 
Address if it is incorrect.

N6421A IP Address

E6651A IP Address

Radius Server IP Address
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Import PCT Message Logging into the TTCN-3 Environment

1 In the TTCN- 3 Workbench application right- click in the 
TTCN- 3 Projects window, select Import... and select Existing 
Projects into Workspace.

2 Click on Next, then Browse to open the Browse window.

3 Locate and highlight the PCT Logging application 
directory. (Default C:\Program FIles\Agilent\PCTLogging). 
Click OK.
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4 Confirm the path has been selected in the Import Projects 
window and click Finish.

5 Confirm PCT Logging is displayed in the Projects list.
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Add the PCT Logging plug- in to your project.

6 Highlight the required project in the Projects list. Right 
click and scroll to Properties. 

7 In the Properties windowon, highlight TTCN-3 Settings and 
select TT3 plugins on the left side folder tree.
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8 Select the TT3 Plugins paths tab.

9 Click Add Folder..., select PCT Logging and click OK.
N6430A series Installation and Getting Started Guide 49



1 Installation
10 Confirm the PCT Logging folder is displayed and click OK.

Confirm the Logging operates whilst running the 
workbench environment.
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Final Steps 11 To complete the installation process, make the following 
settings in the E6651A:

a Press System > TTCN mode [ON]

12 The Firewall in your computer must be disabled. You can 
do this by pressing: 
Start > Control Panel > Administrative Tools > Services to display 
the Services window.

13 Select Windows Firewall/Internet Connection Sharing and click 
the Stop button in the Tool Bar.
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Step 13 - Start and Configure the Workbench Application

To check your installation, start and configure the TT 
Workbench application, proceed as follows:

1 Insert your N6432A or N6442A USB License Key in your 
computer.

1 Double click the TTworkbench icon on your 
desktop.

2 The TTworkbench Workspace Launcher window asks you for 
a path to use as the workspace folder.

Figure 19 Workspace Launcher

3 Click Browse... to open the Select Workspace Directory 
window.

4 Navigate to and highlight your own <user> folder under 
the C:\Documents and Settings path and click Make New 
Folder.

5 Enter the required folder name, for example; 
N6442A_X.5.0.1.6

NOTE The workspace folder is used by the Workbench application. It is 
recommended that you create folders for each test adapter, for example 
N6432A or N6442A.
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.

 

Figure 20 Adding a New Workspace Folder Example

CAUTION Attention is required when creating workspace folders. It is strongly 
recommended that you use the paths and folders shown in this procedure. 
DO NOT select the installation folders of the test adaptors as the 
workspace.
N6430A series Installation and Getting Started Guide 53



1 Installation
6 Click OK to continue.

Figure 21 New Workspace Selected

7 The TTworkbench application starts and displays a 
welcome screen.

Figure 22 Wokbench Welcome Window
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8 Click on File > Import > General (double- click to expand this 
icon) > Existing Projects into Workspace > Next.

For N6432A/N6433A PCT Mobile Station protocol test

1 Browse to find the directory for installed release. For 
example, the N6432A:-  c:\Program Files\Agilent\WiMAX MS 
Protocol Test\N6432A Development Releases \N6432A_A.5.0.1.0 
(Note this is not the TestingTech Workbench workspace 
directory, but the location of the N6432A software when 
installed in “Step 4 -  Installing N6432A PCT Mobile 
Station Test Adaptor (if ordered)” on page 13).

2 Check Copy projects into workspace.

3 Click Finish.

For N6434A NCT Mobile Station protocol test

1 Browse to find the directory for installed release. For 
example, the N6434A:-  c:\Program Files\Agilent\WiMAX MS 
Network Test\N6434A Releases \N6434A_X.5.1.0.10 (Note this is 
not the TestingTech Workbench workspace directory, but 
the location of the N6434A software when installed in 
“Step 5 -  Installing N6434A NCT Mobile Station Test 
Adaptor (if ordered)” on page 16).

2 Check Copy projects into workspace.

3 Click Finish.
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For N6442A/N6443A PCT Base Station protocol test

1 Browse to find the directory for installed release. For 
example, the N6442A:-  c:\Program Files\Agilent\WiMAX BS 
Protocol Test\N6442A Development Releases \N6442A_A.5.0.1.2 
(Note this is not the TT workspace directory, but the 
location of the N6442A software when installed in “Step 6 
-  Installing N6442A PCT Base Station Test Adaptor (if 
ordered)” on page 18).

2 Check Copy projects into workspace.

3 Click Finish.

Connect to the DUT

Prior to running the test case, you should connect your 
DUT to the E6651A Test Set and ensure you complete 
the following:

1 Load the correct profile for your DUT (The profile 
manager is located under the Test Set system menu).

2 Establish an RF connection between your DUT and the 
Test Set.

3 Turn both the RF power and modulation ON.
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Base Station
Test Only

4 For N6442A and N6443A Base Station test only:

a Ensure that the Base Station under test is operating

b Press Frequency and adjust the frequency of the E6651A 
Test Set to match the frequency of the BS under test

c Press Mode > Mobile Station Emulator

d Press Emulator Start

e Press Amplitude and adjust the Test Set source 
amplitude to be within range of the input power level 
requirements of the BS under test

f Adjust the receiver attenuation until the “SYNC” field 
displays “3” and the “Frame Error” field shows “0”

g If desired, verify correct RF parameters by pressing 
Mode > Mobile Station Emulator > Connect to perform 
network entry

h Press Mode > Mobile Station Emulator > Emulator Stop

Both MS and
BS Test

5 For both MS and BS Test, turn TTCN mode ON (located 
under the Test Set system menu).
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For N6432A/N6433A PCT Mobile Station Test

1 Click the Go to the workbench icon.

2 Within the TTworkbench development perspective, expand 
the N6432A release directory, and then expand the ttcn3 
directory.

3 Double click the WMx_SsTestcases_16e_3A_10MHZ.clf file.

For N6434A NCT Mobile Station Test

1 Click the Go to the workbench icon.

2 Within the TTworkbench development perspective, expand 
the N6434A release directory, and then expand the ttcn3 
directory.

3 Double click the WMx_NCT_Testcases_3A_10MHZ.clf file.

For N6442A/N6443A PCTBase Station test Base Station Test

1 Click the Go to the workbench icon.

2 Within the TTworkbench development perspective, expand 
the N6442A release directory, and then expand the ttcn3 
directory.

3 Double click the WMx_BsTestcases_16e_3A_10MHZ.clf.

Both MS and
BS Test The TTworkbench application now changes to the 

execution pane and starts loading the test campaign 
(this may require a few minutes). During this process 

NOTE Use the appropriate CLF file for the profile of the IUT.

NOTE Use the appropriate CLF file for the profile of the IUT.

NOTE Use the appropriate CLF file for the profile of the IUT.
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warnings are displayed if either you have failed to 
correctly connect with the E6651A or you have 
licensing issues.

When the test campaign is fully loaded it is listed in 
the test case window. Expand on the campaign to see 
the actual test case, MEMLOAD, if present in the CLF 
(campaign file). Run the Memload tests:

N6432A/33A WiMAX_MS_MEM_LOAD
WiMAX_MS_MEM_LOAD_PKM

N6432A/33A WiMAX_BS_MEM_LOAD

N6434A WiMAX_MS_MEM_LOAD

TC_MS_SEC_MEM_LOAD

4 You can now run one of the sample test cases. To do this, 
click on the TC_SS_RLC_IRNG_BV_HOI5 test case (for 
N6432A), TC_SS_RLC_IRNG_BV_HOI5 (for N6442A), 
TC_MS_DHCP_BV_HOOO (for N6434A, set MS IP settings to 
DHCP) then click on the script running man at the top 
left corner of the management view.
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Figure 23 Run Test

5 After running the script, a screen similar to that below is 
displayed. This shows that the script has executed, and 
passed, with a graphical log of the message exchange in 
the lower right hand corner. 

Software updates for both Developer and conformance 
customers are available at 
www.agilent.com/find/pctdownloads. To access the software 
releases, you need to enter the password which is 
included in your license redemption E- mail. Each release 
is provided as an .exe installation file which operates in 
the same way as the test adaptor install described in 
“Step 4 -  Installing N6432A PCT Mobile Station Test 
Adaptor (if ordered)” on page 13, or “Step 6 -  Installing 
N6442A PCT Base Station Test Adaptor (if ordered)” on 
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page 18. 

In addition, provided with each release is information 
about the TRI external functions and WiMAX TLVs 
(Type/Length/Value) which are supported. When you 
download the zip archive please extract all files into a 
directory on your PC. This creates a directory with all 
of the T3 docs and allows you to view details regarding 
the external functions. Winzip is the recommended tool 
to extract files from this release information

In addition, the web site also provides links for 
firmware updates, TTWorkbench downloads and 
downloads for the N6421A Protocol Logging and 
Analysis software.
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