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Preface
This manual introduces the tools used for software development on the

IP2022. For detailed information about programming the IP2022, see the

IP2022 User’s Manual.

The tools are based on the GNUPro tool chain supported by Red Hat. For

detailed information about the tools, see the GNUPro documentation.

Related Documentation

Main documentation for the IP2022:

• IP2022 Data Sheet, available from Ubicom.

• IP2022 Programmers Reference Manual, available from Ubicom.

Reference manuals for the tool chain:

• GNUPro Toolkit—GNUPro Utilities, available from Red Hat.

• GNUPro Toolkit—GNUPro Compiler Tools, available from Red Hat.

• GNUPro Toolkit—Debugging with GDB, available from Red Hat.

Notational Convention

In this document, the notation “->” is used to refer to a command selected from

a menu. For example, the Save command on the File menu is File -> Save.

The Start menu accessed by clicking on the Start button (lower left corner of

screen), then clicking on Programs. After installing the Ubicom software, the

Programs menu will contain a Ubicom entry which is used to access the

software tools. In this document, references to the Ubicom menu actually

mean commands selected from the Start -> Programs -> ubicom menu.
www.ubicom.com xi
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File Naming Conventions

Both MS-DOS and Unix file naming conventions are used in this document. An

MS-DOS file name uses backslashes as separators, such as

C:\Ubicom\sdk\projects\starter\Makefile.

Unix file names are used for Configuration Tool parameter values, names in

make files, and the SDK directory tree. A Unix file name uses forward slashes

as separators, such as /cygdrive/c/Ubicom/sdk/projects/starter/Makefile.

The Unix operating system is case sensitive, e.g. the names “makefile” and

“Makefile” would refer to two different files. Because the software tools run

under Windows/MS-DOS, however, all file names are interpreted as non-case-

sensitive without regard to which file naming convention is used.

Unix file names do not have embedded space characters, so names like

“Program Files” cannot be used as names for files or directories in the path to

a file.
xii www.ubicom.com
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Chapter Summary

Chapter 1 is a quick procedure to set up the Demo Board, install the CD-ROM

software, and compile, download, and run the starter project on the Demo

Board. The starter project is used as an example throughout this book. The

following chapters present more detailed information about each of these

steps.

Chapter 2 is an overview of the Unity integrated development environment

(IDE) and the starter project. The CD-ROM software and installation

procedure are described in this chapter.

Chapter 3 describes the Demo Board hardware and set-up procedure. The

starter project is preloaded on the Demo Board, and it begins execution after

power is applied.

Chapter 4 introduces the Unity user interface and the structure of a Unity

project.

Chapter 5 examines the starter project configuration and walks through

generating the config.h and config.mk files.

Chapter 6 discusses the events which occur when a project is compiled.

Chapter 7 walks through debugging a project on the Demo Board.

Chapter 8 describes utility programs for working with .elf files.
www.ubicom.com xiii
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1.0Quick Set Up

The following steps comprise a quick set up procedure for the CD-

ROM software and Demo Board.

1. Install Software from the CD-ROM—uninstall any previous

installation of the GNUPro tools (ip2ktools), Unity, and Soft-

ware Development Kit (SDK). Then run the installation pro-

grams for each of these software distributions:

Run \Install\Ubicom_3.3.0B.exe (name may vary

in the future).

2. Connect Demo Board—connect the parallel cable to the

host PC. At the other end of this cable, connect the adapter

cable from the parallel cable to the Demo Board. The red

strip on the connector to the Demo Board should be closest

to the J2 expansion slot. Connect the serial cable between

the host PC and the Demo Board serial connector labeled

Main P1. Then, connect the power supply cable to the

Demo Board and plug the power supply into an AC outlet.
www.ubicom.com 1
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3. Create a Project—create a directory called C:\Ubi-

com\SDK_Demo. Open Unity by selecting Programs -> Ubi-

com -> Unity from the Windows Start menu. Then, select the

Project -> New command from the Unity menu bar. For the

project name, enter C:\Ubicom\SDK_Demo\Start-

er.c_c. For the project type, select SDK and click the OK

button. Select starter, then click the OK button. Compile the

project by selecting the Build -> Compile command from the

Unity menu bar.

4. Download Project—enter device programming mode by se-

lecting the Build -> Start Programmer command from the

Unity menu bar. In the new window which appears, click the

Program button, then click the Close button.

5. Verify Operation—the LED bank on the Demo Board dis-

plays a binary counter.

Echoing on the serial communication port can be verified by

launching a serial terminal emulator with the following set-

tings:

9600 baud

8-bit ASCII

No parity

1 stop bit

No flow control

Local echo off

Characters typed in the terminal emulator will be echoed back

by the Demo Board.
2 www.ubicom.com



2.0Overview

Ubicom’s approach to developing embedded Internet applications

combines an extensive library of ipModule™ software with Unity,

a powerful integrated development environment (IDE). User-

friendly tools simplify incorporating these tested modules into

applications, resulting in the fastest path from product concept to

market entry.

The philosophy behind this approach is to provide a high-level

interface to building blocks such as communication packages and

peripheral interfaces. By reducing the time and effort dealing with

the nuts-and-bolts of register and bit-level operations, the system

designer is free to concentrate on product differentiation and

increasing value-added for the customer.

The files which comprise an application are called a project. There

are five phases in project development with Unity:

• Configuring the Project—ipModules have options which can

be customized for a specific application. For example, a UART

ipModule has options for baud rate and port pin assignments.

The project configuration controls the selection of ipModules

that are included in a project and the settings for their options.

• Creating and Editing Source Files—Unity includes a source-

file editor for C and assembly language files.Compiling the

Project—Unity calls the GNUPro tool chain to compile, as-
www.ubicom.com 3
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semble, and link the project files, to produce an executable file

in .ELF format.

• Programming the IP2022—Unity downloads executable code

to the IP2022 device through the ISD/ISP interface.

• Debugging—the source-level editor is part of the GUI for a

powerful C/ Assembly language debugger.

The files used for project configuration are shown in Figure 2-1.

Unity keeps information about the project in a file with the .c_c

extension, such as the names of the source files which compose

the project, debugger settings, display fonts, etc.

Figure 2-1 Configuration Files

Unity keeps configuration information in a file with the .lpj

extension. Whenever a new configuration is created or an existing

configuration is changed, Unity can generate new config.mk

and config.h files. These files contain macro definitions that

control ipModule selection and option settings during compilation.

The files used by the GNUPro tool chain are shown in Figure 2-2.

515-084.eps

config.mk.lpj config.h

Unity
IDE .c_c

Unity
Project File
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Figure 2-2 Compilation Tool Chain

.o

.c

.elf

config.h

GNU C
Compiler

GNU
Linker

Unity
Debugger

515-085.eps

.S

.o

Source Files

Relocatable
Object Files

Executable File

Target
System

Unity
IDE

ip2kelf.ld
Linker
Script File

.c_c
Unity
Project File
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As mentioned before, the config.h header file is generated

automatically by Unity from the project configuration. Files with the

.c and .S extensions are C and assembly language source files,

respectively. For each .c and .S source file listed in the .c_c

project file, the GNU C compiler is called to generate a relocatable

object file with the .o extension.

The GNU linker reads the .o object files and a linker script file, and

it produces an executable file with the .elf extension. Most users

will not need to modify the default linker script file ip2kelf.ld

provided by Ubicom. A powerful source-level debugger

downloads the .elf executable file to the target system and

controls its operation.

The files used by Unity and the GNUPro tool chain are

summarized in Table 2-1.

Table 2-1 Summary of Files

File Type Description

.c C source file—source file(s) for the applica-

tion.

.c_c Unity project file—used by Unity to store

project-specific information (location of

source files, etc.).

.elf Binary file—executable code in the ELF file

format.
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.lpj Configuration Tool project file—used by Con-

figuration Tool to store project-specific infor-

mation (ipModule selection, I/O port pin

assignments, etc.).

.o Object file—compiled object code.

.S Assembly-language source file—pure

assembly language file, as opposed to in-line

assembly in a C source file.

config.h Automatically generated by Configuration

Tool C header file—macro definitions used

by the C compiler.

config.mk Automatically generated by Configuration

Tool makefile—macro definitions used by the

make utility.

Makefile Project makefile—the top-level makefile in

the project directory called by Unity.

Makefile.inc Automatically generated by Unity file —

specifies rules for compiling the files refer-

enced in Makefile.gen.

Makefile.gen Automatically generated by Unity file - has

list of all Project files have to be compiled

ip2kelf.ld Linker script file—most users will not need to

modify the default ip2kelf.ld file provided

by Ubicom.

Table 2-1 Summary of Files (continued)

File Type Description
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A typical development sequence is:

1. Create new project using one of the SDK template projects.

All template project files will be copied into new project di-

rectory automatically.Unity keeps information about the

project, such as the names and locations of its source files,

in a file with the .c_c extension.

2. Use Unity->Configuration Tool to select the ipModules used

in a project and customize their features.Configuration Tool

keeps information about the project configuration in a .lpj

file. It uses this information to generate the config.mk and

config.h files.

3. Write Source Files in C or Assembly Language—Unity has

a simple, intuitive text editor for source files. C source file

names have a .c extension, and assembly language file

names have a .S extension.

4. Compile the Project—an executable .elf file is produced.

Intermediate files such as object files (.o extension) are

generated in the project directory.

5. Debug the Project—the debugger downloads and controls

program execution on the target.
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2.1 Minimum System Requirements

The hardware and software requirements for running the Unity

IDE are described in Table 2-2:

The installation CD-ROM has three directories, described in

Table 2-2.

Table 2-1 System Requirements

Feature Requirements

CPU Pentium 2 or equivalent

300 MHz or greater

Memory 64 Mbyte

Free Disk Space 300 Mbyte

Operating System Windows 98/Windows NT/Windows 2000

Peripherals Required—parallel port

Recommended—serial port, Ethernet

interface

Table 2-2 Summary of Directories

Name Description

CD Root Installation text file.

IP2022

Demo Board

Demo Board documentation, including

schematics, layout, bill of materials, and

errata.

SDK

Demo Documents

Documentation on the SDK Demo

Projects.
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2.2 Installing the Software

Although the software can be installed anywhere, in the beginning

you should keep the default directory structure to avoid errors

caused by relocating the directories. Names used for directories

and source files must not have embedded spaces.

1. Remove Previous Installation—if an earlier installation used

a different installation directory for the tools, it may be nec-

essary to remove the Ubicom menu to prevent Windows

from searching for the tools in their old location. Any files

compiled with an earlier release of the tools should be re-

moved and recompiled from their sources with the new ver-

sion of installed software.

2. Install IP2022 Tools, SDK, Unity and Documentation — run

Install\Ubicom_3.3.0B.exe (name may vary).

Allow all of the default selections to be used. Unity will auto-

matically update system Path with “C:\ubi-

com\ip2ktools\H-i686-pc-cygwin32\bin path.

3. Restart the computer—this is necessary for the changes to

take effect on system.
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2.3 Contents of the ubicom Directory

After installation, the ubicom directory has four subdirectories,

described in Table 2-3.

Table 2-3 Summary of ubicom Directories

Name Description

Help Documentation files used by on-line help.

ip2ktools Executable files for tools and utilities.

sdk Project templates and ipModule software.

Unity Unity executable file and assembly language

project template.
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3.0Kit description

The IP2022 Evaluation Kit provides a cost-effective demonstration

and evaluation platform for the IP2022 Internet processor. The

Evaluation Kit comes with source code and software tools on CD-

ROM for developing applications using the ipModule library. The

complete documentation set for the hardware and software is

included on the CD-ROM.

The IP2022 evaluation kit contains:

• IP2022 Demo Board (silk screen labelled as, ”IP2022 DEMO

BOARD V3.0”)

• AC Adapter (12 VDC output)

• ISD/ISP Cable (between PC parallel port and Demo Board)

• DB9 Serial Cable

• CD-ROM with Software Tools and Documentation.

The Demo Board provides the hardware to demonstrate the

IP2022 and ipModules. Its hardware features include:

• IP2022 Internet Processor

• 12 VDC Power Input

• Two RS-232 Serial Connections (Main and Run-Time Debug)

• Daughter Board Connectors for Ethernet and USB Interfaces

• 5V, 3.3V, 2.5V Voltage regulators with Power-On LED

• Run LED (controlled from software)
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• 4.8 MHz Crystal

• 32.768 kHz Crystal for RTCLK

• Reset Button

• External 4 Mbit SPI Flash

• Analog Temperature Sensor connected to ADC I/O

• 1Pushbutton

• 4 DIP Switches

• 8-LED Bank

• Testpoint for ADC Iinput/External Reference Voltage

• ISP/ISD 10-pin Header

• Prototyping Area

3.1 Terminology

Some terms used in discussing the Evaluation Kit are:

• Daughter Board—a piggyback board which connects to a 60-

pin connector on the Demo Board to provide extra hardware

for a particular interface, e.g. an Ethernet Daughter Board with

transformer.

• ipModule—software module from the Ubicom library.

• ISD/ISP—in-system debugging/in-system programming. A

standard 10-pin ISD/ISP connector provides all necessary sig-

nals for downloading code to the IP2022 and controlling and

monitoring its operation.

• sdk—Software Development Kit

• SerDes—Serializer/Deserializer multiprotocol serial commu-

nications peripherals on the IP2022
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• Starter — a complete small application for demonstrating

the Demo Board and software tools. Also used as a template

for developing new applications.

3.2 Demo Board Set-Up

3.2.1 Demo Board Connections

The board is preloaded with the starter example which begins

running immediately after power is applied, if the cable

connections and jumper placements are correct. To ensure proper

operation, the board is provided with jumpers in place for running

the starter example. The jumper settings are covered in

Section 3.4.1. The cable connections to be made are:

• Power Supply

• PC/Terminal serial connection

• ISD/ISP parallel port cable

3.2.2 Power Supply

The supplied wall-mount AC adapter provides 12 VDC at 800 mA.

If the supplied AC adapter is not used, the applied voltage should

be within the range of 8 to 15 VDC. The center contact of the

power connector is positive voltage with respect to the sleeve.
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3.2.3 PC/Terminal Connection

Any terminal or terminal program may be used if it allows for the

following settings:

• 9600 baud

• 8 bit ASCII

• No parity

• 1 stop bit

• No flow control

• Local echo off

3.2.4 ISD/ISP Connection

A parallel port cable (DB25 male to DB25 female) and a short

converter cable (DB25 male to 10-pin female header) are used for

in-system debugging and programming. The parallel port cable is

connected between the parallel port connector on a PC and the

DB25 male connector on the converter cable. The 10-pin

connector on the converter cable is connected to the Demo Board.

The connector mates to a group of nine header pins on the Demo

Board. Pin 1 of the connector is indicated by a red stripe. The

connector is installed with Pin 1 toward the right edge of the board.
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3.2.5 Verifying Installation

After the cables are connected, power can be applied to the board.

The power LED on the Demo Board should light up, and the LED

bank should begin strobing a single lit LED from left to right.

3.3 Description of Hardware Blocks

3.3.1 IP2022

The IP2022 Internet processor is packaged in an 80-pin PQFP. It

contains a CPU, 64 Kbytes of program flash memory, 16 Kbytes of

program RAM, 4 Kbytes of data RAM, and many hardware

peripherals. The fast RISC CPU (up to 120 MIPS) allows

emulating many more peripherals using ipModule software.

3.3.2 Reset

There are five possible sources of IP2022 reset:

• Power-On Reset—automatically triggered after power is ap-

plied.

• External Reset—manually triggered from a pushbutton.

• Brown-Out Voltage Level—triggered if Vdd drops below the

brown-out voltage level.

•Watchdog Timer—if enabled, software must periodically execute

a cwdt instruction to avoid reset triggered by overflow of the

Watchdog Timer.

• ISD/ISP interface—reset issued from the debugger (Unity).
www.ubicom.com 17



Kit description—IP2022 Connectivity Kit User’s Guide
3.3.3 Clock

A 4.8 MHz crystal is connected between pins OSC1 and OSC2 of

the IP2022. OSC1 input can be disconnected from the 4.8 MHz

crystal and connected to l CAN oscillator socket U9 by switching

jumper JP13 into position with pins 2-3 closed.

3.3.4 RTCLK

A 32.768 kHz crystal is connected between pins RTCLK1 and

RTCLK2 of the IP2022.

3.3.5 Power

The IP2022 core logic is powered from the +2.5D digital power rail.

The IP2022 pins, except Port G, are driven from the IOVDD power

rail, which is selectable between 3.3V and 2.5V. Port G driven from

2.5V pin. ADC and Analogue Comparator is connected to the

+2.5A analog power rail. A separate analog power rail is provided

to isolate the analog section of the IP2022 from noise on the digital

power rail.

3.3.6 ISD/ISP

The ISD/ISP connector provides a debugging and programming

interface to a host PC through a standard 10-pin connector. Pull-

up resistors on input signals allow the ISD/ISP interface to be

disconnected while the board is powered, however the interface

should be closed (disconnected) from the debugger before
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removing the electrical connection, to avoid generating spurious

debugger commands.

3.3.7 Analog unit

Only the ADC channel 3(RG3) connected to testpoint TP1.

However, ADC channel 0 through 6 can also be accessed from the

prototype area or through the daughter board connectors

(SERDES1 and SERDES2).The ADC may use the internal IP2022

voltage reference or an external reference on the RG3 port pin. An

analogue temperature sensor connected to ADC channel 2 and

may be used for temperature readings to the IP2022.

3.3.8 Run LED

Software can indicate code execution on the Run LED connected

to port RA1, when jumper JP8 is closed.

3.3.9 SPI Serial Flash Memory

An additional serial SPI Flash memory U5 provides 512K bytes of

memory, which can be used as storage by the ipFile software

module. The IP2022 can communicate with the FLASH via

IpStorage software Module.

3.3.10 On-Board Power Supply

An on-board power supply unit provides the following voltages

from the 12 VDC input:
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• +5V at 500 mA

• +3.3V at 500 mA

• +2.5V at 500 mA

The POWER LED D11 indicates when power is on.

3.3.11 User LEDs

The LED bank is connected to Port B through a tri-stateable buffer

U9.

3.3.12 Additional DATA SRAM

IP2022 support addressing of additional data SRAM. Board has

128k x8 SRAM IC U1(ISSLV1024). Low address bits of SRAM

connected to IP2022 through the latch U3 (74AC573).

3.3.13 Switches

SW1 is general purpose switches bank. SW1 may be used to put

4 bit binary code on RA3.RA0 port pins.

3.3.14 Prototype Area

All I/O pins are brought to the prototype area to allow design

expansion. Care must be exercised since many of the I/O pins are

used elsewhere on the board. The prototype area has +5V, +3.3V
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and GND rails. The prototype area is 21 by 18 plated-through

holes.

3.3.15 Oscilloscope I/O Breakout

All IP2022 ports (RA, RB, RC, RD, RE, RF) are brought out to J6,

J7 and J8 (100 mils spacing) for probing and prototyping .

3.4 Connectors

There are five connectors on the Demo Board:

• DC power J12

• Serial RS232 Main(DB9) P1

• Serial RS232 Run-Time Debug(DB9) P2

• SERDES1 (60-pin) J2

• SERDES2 (60-pin) J3

• ISD/ISP (10-pin) J4

3.4.1 Daughter Board Connectors (J2, J3)

Two 60-pin interface connectors are provided on the IP2022

Demo Board for the purpose of interfacing to Daughter Boards.

SerDes 1 ( port RE) is connected to J2 and SerDes 2(port RF) is

connected to J3. Connectors J2 and J3 have slightly different

connection for RE and RF ports, which makes it possible to swap

Daughter Boards between connectors.

Note: Pin 1 of connectors J2 and J3 is marked by a small groove

in the plastic. A similar groove on the Daughter board connector
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determines correct orientation of the Daughter board. The correct

allignment of each Daughter board is such that it extends away

from the Demo board, and does not overlapping it.

Table 3-1 SERDES1 (J2) Pin Assignments

Pin Signal Pin Signal Pin Signal Pin Signal

1 GND 16 RB7 31 RD6 46 RG5

2 +5V 17 RC0 32 RD7 47 RG6

3 +3.3V 18 RC1 33 RE0 48 RG7

4 +2.5V 19 RC2 34 RE1 49 LAT0

5 RA0 20 RC3 35 RE2 50 LAT1

6 RA1 21 RC4 36 RE3 51 LAT2

7 RA2 22 RC5 37 RE4 52 LAT3

8 RA3 23 RC6 38 RE5 53 LAT4

9 RB0 24 RC7 39 RE6 54 LAT5

10 RB1 25 RD0 40 RE7 55 LAT6

11 RB2 26 RD1 41 RG0 56 LAT7

12 RB3 27 RD2 42 RG1 57 +3.3V

13 RB4 28 RD3 43 RG2 58 +2.5V

14 RB5 29 RD4 44 RG3 59 +5V

15 RB6 30 RD5 45 RG4 60 GND
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Table 3-2 SERDES2 (J3) Pin Assignments

Pin Signal Pin Signal Pin Signal Pin Signal

1 GND 16 RB7 31 RD6 46 RG7

2 +5V 17 RC0 32 RD7 47 RG4

3 +3.3V 18 RC1 33 RF4 48 RG5

4 +2.5V 19 RC2 34 RF5 49 LAT0

5 RA0 20 RC3 35 RF6 50 LAT1

6 RA1 21 RC4 36 RF7 51 LAT2

7 RA2 22 RC5 37 RF0 52 LAT3

8 RA3 23 RC6 38 RF1 53 LAT4

9 RB0 24 RC7 39 RF2 54 LAT5

10 RB1 25 RD0 40 RF3 55 LAT6

11 RB2 26 RD1 41 RG0 56 LAT7

12 RB3 27 RD2 42 RG1 57 +3.3V

13 RB4 28 RD3 43 RG2 58 +2.5V

14 RB5 29 RD4 44 RG3 59 +5V

15 RB6 30 RD5 45 RG6 60 GND
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3.4.2 Test Points

The IP2022 Demo Board, has several test points as listed in Table

3-3.

3.5 Board Configuration Options

The jumpers are used to connect common hardware blocks to the

IP2022. The SerDes 1 and 2 can be connected to a variety of

devices. Some jumpers used to enable groups of signals to

IP2022 pins. Care should be exercised such that multiple devices

are not connected to the same SerDes unit. To minimize the

quantity of configurable jumpers, the board has tri-stateable

buffers U6 and U8 which enable/disable connection of LED bank

and RS232 port P1 signals to IP2022 i/o pins. Jumpers are

described in Table 3-4. When a jumper is shown as ‘unconnected

when shipped’, it means that the Demo Board is shipped with the

jumper over one pin of the header. This is used merely to hold the

jumper.

Table 3-3 Test Points

Test Point Description

TP1 ADC input3 / External reference voltage

TP2 Analog ground for ADC signals

TP3,TP4,TP5 Power supply ground
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Table 3-4 Demo Board Jumpers

Block Description Jumper IP2022
Signal

Connected
When

Shipped?

Serial

Ports:

P1

PC_DTRCD1

PC_RXD1,

PC_TXD1,

PC_RTS1,

JP12

RF3,

RF7,

RF1,

RF0,

Yes

Port P1 Main Loop-

Back

JP5 No

Port P1 Modem/PC JP4 No

Serial

Ports:

P2

Data Loop-

Back (LpB)

JP6 - No

SPIFlash Chip Select

signal CS

JP3 RA0 No

IOVDD 2.5V / 3.3V JP10 IOVDD 3.3V(2-3)

ISP/ISD CLK from

Tool

JP1 OSC1 No

Clock XTAL/CAN JP13 OSC1 XTAL(1-2)

LEDs RUN LED JP8 RA1 No

LEDs 8 LED BANK JP7 RB0 -

RB7

Yes

SRAM & Latch SRAM

128Kx 8

JP2 RD0 -

RD7

No
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Jumpers J14, J15, J16, J17 should be closed unless there is a

need to use an external source for one of the ip2k power supply

voltages.

3.5.1 RS232 Port P1 (JP4, JP12)

P1 port can be connected to SERDES2 pins only. If Jumper JP12

is open, SERDES2 pins RF0, RF1, RF3, RF7 may be used for

General I/O or for one of the Serial protocols.

For PC communications:

1. Use the PC DB9 connector.

Power Supply

Unit

5V

3.3V

2.5DV

2.5AV

JP14

JP15

JP16

JP17

Yes

Yes

Yes

Yes

Configuration

Switches

Push-Button JP9 RB2 No

Configuration

Switches

4-Bit DIP JP11 RA0 -

RA3

No

Table 3-4 Demo Board Jumpers (continued)

Block Description Jumper IP2022
Signal

Connected
When

Shipped?
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2. Install the jumper JP4, and jumper JP12.

3. Use straight-through serial cable

For Modem communications:

1. Open jumper JP4

2. Use null modem serial cable.

Jumper JP5 is used only for checking the connection between the

PC and the board -- installing this jumper will cause characters to

be looped (echoed) back to the PC and can thus be used to

determine if the PC's serial port and cable are correctly set up.

3.5.2 RS232 Run-Time Debug Port P2

Some applications where both SERDES units are in use may not

allow software-UART modules to send Debug information to the

PC because having one will upset the determinism requirement of

other more important VPs, like ethernet, USB or MII. In order to

allow debug information exchange for these type of applications

board has U2(SX20) microcontroller. The SX20 interfaces to the

IP2k via a synchronous interface, NOT a UART interface. This

allows the IP2k to be more efficient since debug messages are

mostly short and can be output to the SX20 at a speed much faster

then 115 Kbit/sec. U2(SX20) takes care of streaming the data to

the PC using 115Kbit/sec UART.

Jumper JP6 is used only for checking the connection between the

PC and the board -- installing this jumper will cause characters to
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be looped (echoed) back to the PC and can thus be used to

determine if the PC's serial port and cable are correctly set up.

For Run-Time debug communication use a straight-through cable

3.5.3 Additional SPI Flash (JP3)

U5 is a Serial SPI Flash with 4Mbit capacity connected to IP2022

using 4 pins: SO,SI,SCLK,CS. To use Serial Flash, Jumper JP3

should be closed. To read and write U5 ipStorage software module

use RA0 - RA3 pins.

3.5.4 Additional Data SRAM(JP2)

To enable use of SRAM, close JP2. To access SRAM, Software

module uses all pins on Port RD, RC and five lines from port RB

RB3 - RB7.

3.5.5 IOVDD (JP10)

IOVDD can be selected with jumper JP10 to be 2.5V or 3.3V.

3.5.6 Clock (JP13)

Jumper has 2 positions. The lower postion (closest to XTAL)

connects the 4.8 MHz crystal to OSC1. The upper position

connects OSC1 to the can-oscillator socket U9.
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3.5.7 4-Bit DIP Switch (JP11)

SW1 may be used to put 4 bit binary code on RA0 - RA3 pins.

Signals from SW1 are connected to ip2022 port RA through tri-

stateable buffer U6. To enable SW1 signals to RA0-RA3 pins

install jumper JP11.

3.5.8 Run LED (JP8)

The D10 LED labeled RUN is connected through JP8 to pin RA1.

Active level is low. To enable RUN LED, install the jumper.
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4.0Unity User Interface

Unity implements a powerful graphical user interface (GUI) that

trims the rough e dges off the GNU tool chain. Even though

standard utilities such as make and gdb are running at some level

of the software development environment, Unity presents a simple

and intuitive front-end to these tools that does not require reading

hundreds of pages of documentation before getting started. A

project can be written, compiled, and debugged without ever

looking at a makefile or a linker script file.

The main software development interface which accounts for most

of the time spent working in Unity is the integrated source-code

editor/debugger, however there are two other modes which are

used for short periods:

• Project Configuration—used once when the project is started,

and used again whenever there is a change in the hardware

configuration or ipModule usage. This mode is discussed in

Chapter 5.

• Device Programming—used to download new programming

to the target. This mode is discussed in Chapter 8.

Figure 4-1 shows a view of the default appearance of the Unity

GUI. Windows used for project management and source file

editing usually occupy the upper pane of the Unity GUI, and

windows related to debugging occupy the lower pane. However,
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Unity allows considerable flexibility in organizing the windows,

including the ability to drag a window out of the Unity GUI and onto

the desktop.

Figure 4-1 Unity (Default View)
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4.1 Unity Windows

The default view has up to seven open windows:

• Workspace Window—lists the source files within the current-

project. Clicking on a file name opens the file in a new window.

• Memory Windows—display regions of the program flash, pro-

gram RAM, and data memory space.

• Stack Window—shows the nesting of subroutines on the hard-

ware call/return stack.

• Register Window—displays the contents of the registers. The

contents of the registers can be edited in this window.

• Watch Window—shows the current value of expressions.

• Output Window—shows compilation output, such as error

messages.

On small screens, the Watch and Output windows might not

appear in the default view unless the window is maximized. The

default view can be restored by exiting Unity and selecting the

Ubicom -> Unity -> UnityReset command.

4.2 Unity Menu Bar

The menu bar is used to access the Unity commands:

• File Menu—New, Open, Close, Save, and Print commands for

source files. These commands do not affect Unity project files.

• Edit Menu—Cut, Copy, Paste, and Find commands.

• View Menu—commands for showing or hiding any of the Unity

windows and other parts of the GUI.
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• Project Menu—commands for creating a new project file or

opening an existing project file. Also has commands for gen-

erating an HTML version of the source files and accessing a

version control mechanism.

• Build Menu—commands for controlling compilation, entering

debugging mode, and launching the IP2KProg utility.

• Tools Menu—commands for setting compilation defaults (op-

timization level, etc.) and entering project configuration mode.

Also used to change font in source file windows (default size

is 12 point).

• Help Menu—commands to access on-line documentation for

the SDK distribution and the GNUPro tools.

4.3 Unity Tool Bar

The Tool bar has synonyms for the most frequently used

commands. The File menu synonyms are:

• New Source File—create a new source file. Equivalent to the

File -> New command.

• Open Source File—open an existing source file. Equivalent to

the File -> Open command.

• Save Source File—save current source file. Equivalent to the

File -> Save command.
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• Save All Source Files—save all modified source files. Equiva-

lent to the File -> Save All command. This command saves

both ipModule source files and project-specific source files.

The Edit menu synonyms are:

• Cut Selection—delete selected text and save on the clipboard.

Equivalent to the Edit -> Cut command.

• Copy Selection—save selected text on the clipboard. Equiva-

lent to the Edit -> Copy command.

• Paste Clipboard—insert contents of the clipboard at the cur-

rent selection point. Equivalent to the Edit -> Paste command.

• Print Selection—print selected source file. Equivalent to the

Edit -> Copy command.

A Help menu synonym is:

• About—display copyright notice and version number. Equiva-

lent to the Help -> About Unity command.

The Build menu synonyms are:

• Compile Project—invoke the GNUPro tool chain to compile

the source files and create an executable file (.elf exten-

sion). Equivalent to the Build -> Compile command or the F7

function key. Only files which have changed or depend on files

which have changed are recompiled. To force Unity to recom-

pile every file, select the Build -> Clean command to delete all
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temporary files and directories used in the compilation, such

as object files.

• Debug Project—Start a debugging session. Equivalent to the

Build -> Debug command or the F5 function key. A suitable

target such as the Demo Board must be available to start a de-

bugging session.

• Start Programmer—launch the IP2KProg utility. Equivalent to

the Build -> Start Programmer command or the F4 function

key.

• Toggle Breakpoint—sets or clears breakpoint at the insertion

point in the current open source file. Equivalent to the Build -

> Toggle Breakpoint command or the F9 function key.

The View menu synonyms are:

• Toggle Workspace Window—show or hide the Workspace

window. Equivalent to the View -> Workspace command. The

Workspace window displays a list of the source files in the cur-

rent project. Clicking on a file name opens that file for editing

in a new window.

• Toggle Output Window—show or hide the Output window.

Equivalent to the View -> Output command. The Output win-

dow displays the output from compiling a project, including er-

ror messages. The last line of the output will say either “Build

succeeded” or “Build failed”.
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• Toggle Registers Window—show or hide the Registers win-

dow. Equivalent to the View -> Registers command. The Reg-

isters window is used to view and edit the contents of the CPU

and peripheral registers.

• Toggle Memory 1 Window—show or hide the Memory 1 win-

dow. Equivalent to the View -> Memory 1 command. The

Memory 1 window is used to view the contents of an 80-byte

region in program flash, program RAM, or data memory.

• Toggle Memory 2 Window—provided to view a second region

of memory. Equivalent to the View -> Memory 2 command.

• Toggle Watch Window—show or hide the Watch window.

Equivalent to the View -> Watch command. The Watch win-

dow shows the current values of user-specified expressions.

• Toggle Stack Window—show or hide the Stack window. Equiv-

alent to the View -> Stack command. The Stack window lists

the subroutines on the hardware call/return stack.

One icon is not a synonym for any menu command:

• Disassemble Window—show source code interleaved with

the corresponding assembly language instructions. To see

any output in this window, start a debugging session and use

one of the Step icons.
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There are additional tool bar icons which are only enabled during

a debugging session. These icons are discussed in Chapter 7.

4.4 Creating a New Project

New projects are started by copying one of the existing project

templates. The starter example is a minimal Unity project which

runs a binary counter on the bank of eight LEDs on the Demo

Board and echoes characters received on the PC serial port back

to the host PC. For applications using complex ipModule

packages such as the Internet protocol stack, working

demonstration programs are provided for use as templates.

To create a new project from the starter template:

1. Enter Unity—select the ubicom -> Unity command. This

opens the Unity IDE. The first time Unity is opened after in-

stallation, an example assembly language project will open,

but it is not used in this chapter.

From Main menu select Project->New. A dialog box will appear for

entering the path name for the project file. Click on • • • to browse

Use standard windows dialog to create new project directory and

project file or select existing.

Do not open SDK template projects from Ubicom\SDK\projects\

directory. These projects are used by Unity as templates, during

creation of new projects.

Any legal full path name (with no embedded spaces) may be used.
In this example, the project file name:
38 www.ubicom.com



IP2022 Connectivity Kit User’s Guide —Unity User Interface
C:\sdk_demo\starter\starter.c_c. Leave the file type
selection as SDK. (Choosing General would create the new
project file immediately, without copying any of the template or
default files into the project.) Click the OK button.

Select New Project Template—in the list that is presented, click on

starter. The other names in the list are demonstration programs

for complex ipModule packages such as Ethernet

communications. Leave the Add SDK Files Into Project box

unchecked. (Checking the box causes the included ipModule

software to appear in the list of project files.) Click the OK button.

Unity returns to the default view, but now the starter project is

displayed in the Workspace window. At this point, the project file

C:\sdk_demo\starter\starter.c_chas been created, and

several files and directories have been copied to this directory.

4.5 Adding and Removing Files

To add a file to a project, select the Project -> Add file(s) command

or hit the Insert key, then browse for the file. Unity will

automatically add references to the new file in the

app/Makefile.gen file.

Note, that only source files located in the project’s \app directory

will be compiled e. g C:\sdk_demo\starter\app\main.c and

C:\sdk_demo\starter\app\isr.S.

To remove a file from a project, click the right mouse button over

the file name in the Workspace window and select the Remove

command from the pop-up menu, or hit the Delete key and click

the Yes button when Unity asks to confirm removing the file.
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4.6 Project File Tree

This is the structure of the C:\sdk_demo\starter\ file tree,

before compiling the project or after using a Build -> Clean

command:

starter—example project using the Demo Board

app—source files for the project

main.c—C source file

isr.S— ISR subroutines assembly file

Makefile.inc—source directory top makefile

Makefile.gen—list of project source files must

be compiled

config—configuration files

config.h—macro definitions for C compiler

config.mk—macro definitions for make utility

starter.lpj—project configuration file

Makefile—top-level project makefile

starter.c_c—project file
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From the user’s perspective, ipModule software consists of

packages and configuration points. A package is a set of related

functions, declarations, etc. that is managed as a group, such as

the ipOS operating system or the TCP/IP Internet protocol stack.

A configuration point is a customizable option within a package,

such as the baud rate of a UART. A user-friendly graphical user

interface (GUI) is used to select packages and customize

configuration points.

The package selections and configuration point settings are saved

in a project configuration file (.lpj extension). This information is

used to generate the config.mk and config.h macro definition

files, which control the inclusion of packages into a project during

compilation.
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5.1 Project Configuration GUI

Figure 5-1 Project Configuration GUI

Menu Bar Tool Bar
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There are three panes in the window: the left pane shows the

packages and configuration points in a project, the upper right

pane shows symbolic definitions for configuration points, and the

lower right pane shows comments. The right panes are protected

against modification unless the Package -> Designer Mode

command is used to disable protection. Most package users will

only need to make changes that affect the left pane, such as

toggling check boxes and entering constants into value fields.

The menu bar at the top of the window may be used to access all

of the project configuration commands. Frequently used

commands are more conveniently accessed from the tool bar. The

four menus on the menu bar are:

• File—opens, closes, and saves project files.

• Edit—removes a package from the project file (Edit -> Delete

Node command).

• Package—adds and deletes packages from the project file,

generates config.mk and config.h files, and specifies the

directory for searching for packages.

• Help—provides access to on-line documentation.

The tool bar icons are synonyms for the most commonly used

menu commands:

• Create New Project—create a new project file. Equivalent to

the File -> New command.

• Open Existing Project—open an existing project file. Equiva-

lent to the File -> Open command.
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• Save Current Project—save changes to the project file. Equiv-

alent to the File -> Save command.

• Generate—generate the config.mk and config.h files.

Equivalent to the Package -> Generate command.

• Help—access to on-line documentation for Configuration

Tool. Equivalent to the Help -> Help Contents command.

5.2 Generating Makefiles and Header Files

The following steps demonstrate using Configuration Tool to

generate the config.h and config.mk files for the starter

project.

1. View Project Configuration—select the Tools -> Configure

command. Packages are added with the Package -> Add

Package command. A package is removed by clicking on the

package name and selecting the Edit -> Delete Node com-

mand.

2. Generate Configuration Files—either select the Package ->

Generate command or click the Generate icon. If the files

were generated, “Configuration generated successfully” will

appear below the left pane. If there was a problem (e.g. a file

cannot be found in the search path), a dialog box reports “Un-

able to create file”.
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6.0Compiling

Compiling is a batch process which can be performed at any time,

except during a debugging session. Compiling produces an

executable file (.elf extension), which is run by downloading the

file to a target such as the Demo Board.

The current project is compiled by clicking the Compile icon or

hitting the F7 function key. Changes to any open project source

files are saved immediately, without requesting confirmation from

the user. During a compilation, the project source files are

compiled with the GNU C compiler gcc, and the resulting object

files are linked with the GNU linker ld to produce a .elf file. The

command lines which invoke the GNUPro tools are visible in the

Output window, but most users may ignore them. The important

information displayed in the Output window are error messages

that occur during compilation, which indicate the source file name

and line number at which the error is indicated. The last line in the

Output window will say either “Build succeeded” or “Build failed”.

The make utility is used to manage the compilation and linking of

files, both to automate the process and to avoid unnecessary

recompilation of source files. For example, if a project contains five

source files but only one file is modified, it may be possible to

generate a new executable file by recompiling only one source file

and linking the resulting object file with four previously generated
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object files. If the modified source file is a header file included in

the other four source files, however, it will be necessary to

recompile all of the source files. The make utility keeps track of file

dependencies and invokes the compiler and linker as needed to

generate the files requested by the user.

To force make to recompile all files, select the Build -> Clean

command to remove all temporary files, such as object files. Then,

compile the project in the usual way.

A makefile is a command file for the make utility. Makefile in the

project directory is the top-level makefile of the project. When

compilation is triggered, Unity calls make to execute Makefile,

as shown in Figure 6-1. Makefile calls two other makefiles, the

config.mk file generated by Unity from the project configuration

and the global makefile Makefile.inc in the sdk/scripts

directory (one of the directories created by the SDK installation).

The global makefile calls the Makefile.inc in the source files

directory app and the Makefile.inc for each ipModule included

in the project. All of the makefiles used to compile a project are

either generated by Unity or supplied by Ubicom, so most users

will not need to write or edit any makefiles.
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Figure 6-1 Makefile Structure
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7.0Debugging

A debugging session can be started if an executable file and a

target are available. Click the Debug Project icon or hit the F5

function key to start a debugging session. During a debugging

session, the current project cannot be compiled, and another

project cannot be opened.

To exit from the debugging session while a program is running on

the target, click the Stop icon once to stop the program and a

second time to exit the debugger. If the target is already stopped,

only one click is needed to exit the debugging session.

7.1 Debugging Tool Bar

Several tool bar icons are only useful during a debugging session:

• Toggle Breakpoint—sets or clears breakpoint at the insertion

point in the current open source file. Equivalent to the Build -

> Toggle Breakpoint command or the F9 function key.

• Continue—start or continue program execution. Equivalent to

the Build -> Continue command or the F6 function key.
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• Step—advance program execution by one source code line.

Equivalent to the Build -> Step command or the F11 function

key.

• Next—advance program execution by one source code line of

the current function. Calls to other functions are executed

without stopping until they return to the current function.

Equivalent to the Build -> Next command or the F10 function

key.

• Up—finish execution of the current function and stop after re-

turning to the calling function. Equivalent to the Build -> Con-

tinue command or Shift plus the F11 function key.

• Reset—reset target. Equivalent to the Build -> Reset com-

mand.

• Automated Step—like the Step icon, but with automatic repeat

a little faster than once per second. Click once to begin repeat

mode, and click a second time to end it.

• Automated Next—like the Next icon, but with automatic repeat

a little faster than once per second. Click once to begin repeat

mode, and click a second time to end it.

• Assembler Step—advance program execution by one instruc-

tion. Click the Disassemble Window icon to view instructions.
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• Assembler Next—advance program execution by one instruc-

tion. Calls to other functions are executed without pausing un-

til they return to the current function.

• Stop—if a program is running on the target in a debugging

session, stop program execution. Otherwise, terminate de-

bugging session. A debugging session must be terminated to

recompile the project. Equivalent to the Build -> Stop com-

mand.

• Quick Watch—add expression to Watch window.

• Toggle Registers Window—show or hide the Registers win-

dow. Equivalent to the View -> Registers command. The Reg-

isters window is used to view and edit the contents of the CPU

and peripheral registers.

• Toggle Memory 1 Window—show or hide the Memory 1 win-

dow. Equivalent to the View -> Memory 1 command. The

Memory 1 window is used to view the contents of an 80-byte

region in program flash, program RAM, or data memory.

• Toggle Memory 2 Window—provided to view a second region

of memory. Equivalent to the View -> Memory 2 command.
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• Toggle Watch Window—show or hide the Watch window.

Equivalent to the View -> Watch command. The Watch win-

dow shows the current values of user-specified expressions.

• Toggle Stack Window—show or hide the Stack window. Equiv-

alent to the View -> Stack command. The Stack window lists

the subroutines on the hardware call/return stack.

• Disassemble Window—show source code interleaved with

the corresponding assembly language instructions. No output

is shown in this window until one of the Step icons is used.

7.2 Viewing Program Execution

For the following procedure, it is assumed that a target and an

executable file for the current project are available.

1. Enter the Debugger—click the Debug Project icon or hit the

F5 function key. Unity will connect to the target system. In the

default configuration, Unity then downloads and runs the exe-

cutable file on the target. To change the default behavior of

Unity, select the Tools -> Options command, then select the

Debugger tab. A binary counter begins incrementing on the

bank of eight LEDs on the Demo Board.

2. Stop the Program—click the Stop icon to halt execution.

Unity opens a source file window for the line which was

about to be executed, which is highlighted in color in the

center of the source file window.
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3. Advance Program Execution—click the Step icon several

times to advance program execution line-by-line. Because

the starter application calls functions in several source

files, the debugger frequently jumps among these files while

stepping through code.

Click the Automated Step icon to watch program execution

continue at a speed slightly faster than one line per second.

Code in the source file main.c frequently calls code in

uart_vp.c and timer.c, the UART and timer ipModules,

so the view jumps among these source file windows. Exit this

mode by clicking the Automated Step icon a second time.

Click the Automated Next icon. Next differs from Step in that

functions are executed without pausing until they return to the

calling function. In this mode, functions return to the main

loop, and the main loop stays in the front window. Exit this

mode by clicking the Automated Next icon a second time.

4. Open Disassemble Window—click the Disassemble Win-

dow icon to open a new window for displaying source lines

interleaved with their corresponding instructions.

5. Advance Program Execution—the Disassemble window

does not display any output until program execution is ad-

vanced, either by incremental advances with a command

like Step or Next or by hitting the Continue icon followed by

hitting the Stop icon or encountering a breakpoint.
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7.3 Breakpointing Program Execution

For the following procedure, it is assumed that a debugging

session has been entered, as described in Section 7.2. A

breakpoint will be set in the led_callback routine which

changes the pattern of lights on the LED bank of the Demo Board.

This routine is called by a one-shot timer when it expires. To insure

that the call is repeated, one of the functions performed by the

routine is to reattach itself to the list of timers serviced by the ipOS

operating system.

1. Reset the Target—click the Reset icon to stop program exe-

cution on the target and reset the program counter.

2. Browse for the led_callback Function—click the Browse

tab in the Workspace window. If the Browse tab is empty,

click the Stop icon to exit debugging mode, click the Com-

pile icon to recompile the project, click the Debug Project

icon to re-enter the debugging session, and click the Reset

icon to stop execution. Immediately after recompiling, the

Browse tab displays the functions of the starter project,

as shown in Figure 7-1.
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Figure 7-1 Browse Tab

Double-click on led_callback to open the source file

main.c. The first line of the led_callback function will be

highlighted in the source file window.

3. Set a Breakpoint—click on the line that says (*led)++;.

Click the Toggle Breakpoint of icon to set a breakpoint. A

red circle appears in the gray bar along the left edge of the

source file window to indicate a breakpoint has been set, as

shown in Figure 7-2. Unity supports Multiple breakpoints in

program flash memory. To enable or disable multiple break

points Use menu->Tools->Options->Debugger tab page.

Any number of breakpoints can be set in program RAM. Se-

lect the View -> Breakpoint List command to examine the

breakpoints which have been set.
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Figure 7-2 Setting a Breakpoint

4. Continue Program Execution—click the Continue icon to be-

gin program execution. Immediately, the program will stop

at the breakpoint. Continue clicking the Continue icon. For

each click, the pattern on the LED bank is incremented.

5. Examine Stack Window—the Stack window is a read-only

display of the subroutines which have been pushed on the

hardware stack. With the starter example stopped in

led_callback, the stack window appears as shown in Fig-

ure 7-3.
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Figure 7-3 Stack Window

main is the top-level function of the starter example, so it

is the deepest function on the stack. timer_poll is called in

the main loop of main, to update any timers that ipOS is main-

taining. timer_poll calls oneshot_tick to update any

one-shot timers. If the timer for incrementing the pattern of

lights on the LEDs has expired, oneshot_tick calls

led_callback.
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7.4 Viewing Registers

To view the registers of the starter example as it executes:

1. Scroll to rbin and rbout—scroll down the Registers win-

dow until the rbin and rbout registers are displayed, as

shown in Figure 7-4. rbout is the output register for the

port which drives the LED bank, and rbin is the input regis-

ter for that port.

Figure 7-4 Registers Window

2. Continue Execution—click the Continue icon to run the pro-

gram until the breakpoint is hit again. When a register value

changes between steps, it is highlighted with color in the

Registers window. The rbout register is incremented and
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read back into the rbin register on every click of the Con-

tinue icon, so the values in these registers are highlighted

after each click.

7.5 Viewing Memory

The expression *led is a pointer to data driven on the LED bank.

The Watch window can be used to display both the pointer and the

data.

1. Specify Watch Expressions—click the Quick Watch icon to

bring up a box for specifying a watch expression.

Figure 7-5 Quick Watch Box

Enter led and click the Add button. Then, click the Quick

Watch icon again, enter *led, and click the Add button. At this
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point, both led and *led have been added to the Watch win-

dow, as shown in Figure 7-6.

Figure 7-6 Watch Window

The value in led is 0x1000FF9, which is the address of the

data that starter loads in the rbout register. The address-

es used by the debugger have a different mapping than those

used in source files, as discussed in Section 7.6. The value in

*led shows the data itself. Click the Continue icon to incre-

ment the data.

2. Examine Memory—click the address box in one of the

Memory windows, and change it to 0x01000FB0. A Memory

window presents a fixed display of 80 characters, and it will

not display any characters if one of them is in a reserved

section of the memory space. Because a reserved section

starts at 0x01001000, the address 0x01000FF9 cannot be

used to view memory. However, the reserved section can be

avoided by entering 0x01000FB0 into the address box, as

shown in Figure 7-7. The data at address 0x01000FF9 is 03

in the second data column on the last line.
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Figure 7-7 Memory Window

ASCII character equivalents of the data are shown in the column

on the right.
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7.6 Memory Map

A map of the memory space as viewed through the debugger is

shown in Figure 7-8. This address mapping is only used in the

.elf files generated by the linker and analyzed in the debugger.

Do not use these addresses in C source files.

Figure 7-8 Debugging Memory Space
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An executable file (.elf extension) can be downloaded to a target

using the IP2KProg utility. IP2KProg can be used to:

• Read the executable sections from a .elf file to internal buff-

er.

• Read the executable code from the flash memory of a pro-

grammed IP2022 device to internal buffer

• Save Buffer contents into binary file

• Edit buffer in hexadecimal format

• Download the software to an IP2022 device flash memory

After downloading, IP2KProg resets the IP2022, and the

software begins running.

From within Unity, IP2KProg is launched by clicking the Start

Programmer icon, selecting the Build -> Start Programmer

command, or hitting the F4 function key. IP2KProg will load the

executable file of the current project automatically. An executable

file must be available, otherwise Unity will not launch IP2KProg.

Only one copy of IP2KProg is allowed in PC memory. All

subsequent clicks on the Program button will just activate the

existing IP2KProg window. Upon activation IP2KProg

automatically reloads previously loaded file. Although IP2KProg

does not interfere with the debugger as long as it not doing any
www.ubicom.com 65



Utilities—IP2022 Connectivity Kit User’s Guide
program/read operations, it is recommended to close ip2kprog

while in debug session.

IP2KProg can also be run as a standalone program by selecting

the ubicom -> Ip2kprog command. In this case, IP2KProg is

launched with a blank memory buffer.

Do not download a blank buffer to the Demo Board.

Be careful to avoid overwriting configuration block settings in a

way that prevents the IP2022 device from functioning. In

particular, the 4.8 Mhz crystal oscillator is the main clock source

available on the Demo Board. If the XTAL bit disables the OSC

oscillator, the Demo Board will not be operational and any further

attempts to program the IP2022 device will be unsuccessful until

an external clock source is provided from external U9 CAN

oscillator that is optional for the board.
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8.1 IP2KProg User Interface

Figure 8-1 IP2KProg User Interface

loaded file file age ip2kprog status messages
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IP2KProg keeps a memory buffer of the IP2022 program memory

and configuration block. A hexadecimal listing of this memory

buffer is shown on the left. Addresses are listed as word

addresses. The data in the memory buffer can be edited by typing

over any previous values.

The configuration block settings are shown to the right of the

program memory space. Be sure to check the XTAL box to enable

the OSC oscillator before downloading to the Demo Board.

The memory buffer can be downloaded to both the program

memory and the configuration block by clicking the Program

button. Clicking the Program button performs the following

operations:

• Erase all FLASH pages and Configuration block

• Program FLASH pages and Configuration from buffer

• Verify Flash and Configuration block with Buffer

There is no need to use Erase and Verify buttons under normal

conditions.

Clicking the PgmFuses button performs the following operations:

• Erase Configuration Block only

• Program Configuration Block from Buffer

The memory buffer can be loaded by selecting the File -> Load

command and browsing for a .elf file. The buffer also can be

loaded from a programmed IP2022 device by clicking the Read

button. A list of the memory regions loaded from the .elf file may

be viewed by selecting the Device -> Flash_allocation command.
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To navigate around the memory buffer use scroll bar. Use Goto

menu to jump to the beginning of any memory block or the

configuration block.
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8.1.1 Downloading a Project

To download the starter example:

1. Launch IP2KProg—click the Start Programmer icon. When

launched from Unity, the executable file starter.elf is

automatically loaded into the memory buffer.

To run IP2KProg as a standalone program, select the Ubi-

com -> Ip2kprog command to launch IP2KProg. Then, se-

lect the File -> Load command to browse for the

starter.elf file.

Select the Goto -> Flash_0 command to navigate to the begin-

ning of the flash memory at word address 0x08000. The mem-

ory locations loaded from the starter.elf file are

highlighted in green.

2. Download the Executable File—click the Program button to

download the contents of the memory buffer to the IP2022

device. After downloading, IP2KProg resets the target and

the software begins running. The pattern of lights on the

LED bank begins incrementing. If a serial cable is connect-

ed, a serial communications program such as HyperTermi-

nal can be used to demonstrate that characters are being

echoed by the Demo Board.

3. Verify the Download—click the Verify button to check that

the download was successful. To provoke a mismatch dur-

ing verification, edit a memory location and click the Verify

button again. A mismatch report appears in a new window.

Hit a keyboard key to close the mismatch report window.

4. Exit IP2KProg—click the Close button.
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8.2 GNU Binary Utilities

The following utilities are available from an MS-DOS command

prompt window:

• ip2k-elf-objdump—with the -D argument, produces a disas-

sembly listing. With the -x argument, prints section informa-

tion (size, load address, etc.).

• ip2k-elf-readelf—with the -a argument, lists .elf file header

information, section header information, and the symbol table.

• ip2k-elf-size—lists the size of each section.

• ip2k-elf-nm—lists the symbol table.

• ip2k-elf-strings—lists any ASCII strings found in the file.

To open an MS-DOS command prompt window, select the MS-

DOS Command Prompt command from the Start menu. A new

window will open for submitting MS-DOS commands. The ip2k-

elf-objdump and ip2k-elf-readelf commands require an

argument. For a brief summary of the available arguments, try the

command without an argument. For detailed information about the

available arguments, see the binutils section of the GNUPro

Toolkit—GNUPro Utilities manual (pages 317 to 368).

Some of these utilities produce output that scrolls off the window.

The output can be run through the MS-DOS more utility to print

only as much output as can be seen in the window, as shown in

the following command line.

ip2k-elf-objdump -D starter.elf | more
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Hit the space bar to advance the output by one window of

information.

The output can also be directed to a file so that it can be viewed in

an editor. For example, the following command line places the

output in the file tmp.txt.

ip2k-elf-objdump -D starter.elf > tmp.txt
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9.0SDK Demo Projects

This manual is intended for users who have already exercised the

IP2022 development tools, used the IP2022 Primer, and have built

the starter project using the IP2022 Primer. The user should have

experience in changing the PC's IP settings.

There are four demos in this manual:

• ·Starter

• ·Telnet

• ·Webserver

• ·Serial_gw

9.1 Equipment Required

The following is required to run all the demos:

• §IP2022 Demo Board

• §IP2022 Native Ethernet Daughter Board

• §Parallel Port ISD/ISP Cable

• §DC Power Supply

• §Serial Straight-Straight-through Cable

• §CAT 5 Ethernet Crossover Cable

• All items are included in the IP2022 Connectivity Kit.
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9.1.1 PC Network Configuration

All Ethernet-based demos will use a crossover cable connected

directly to the PC. In this case the PC will require a static IP

address of 192.168.1.2 and a subnet mask of 255.255.255.0. The

demos can also be set-up to a hub or switch. To do this, connect

the PC and IP2022 Demoboard to the same Ethernet hub. The

IP2022 Demo Board connection requires a straight-through CAT5

Ethernet cable. Find the PC’s subnet and a free IP address on that

subnet. Configure the IP2022 Demoboard with the free IP

address.

9.1.2 Network Tips

The ping utility can be used to check that the PC can see the

IP2022 Demo Board when a network demo project is running

Figure 9-1 Ping
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The ipconfig utility can be used to check that your PC has the

correct IP settings.

Figure 9-2 Ipconfig

9.1.3 Configuring IP2022 Board IP address

IP2022 demo projects which are using ipEthernet software

module may require an IP address change in order to work when

connected through a hub to LAN. IP addresses may be changed

from project configuration GUI as shown on figure below. After IP

address is changed, configuration should be regenerated and

saved.
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Figure 9-3 Configuring Demo Board IP address
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9.2 Starter Demo

The starter demo project is a fundamental SDK project. It includes

the basic building blocks for a general-purpose SDK project. This

demo shows the ipOS operating system one-shot timer

implementation and the serial UART driver implementation. The

one-shot timer is used to increment a binary counter on the LED

bank. The UART is used to echo characters sent to the IP2022

back to the PC terminal program.

SDK ipModules include:

• ipOS

• ipUART

Project files include:

• isr.S

• main.c
www.ubicom.com 77



SDK Demo Projects—IP2022 Connectivity Kit User’s Guide
9.2.1 IP2022 Board Configuration

Figure 9-4 Starter Demo diagram

Jumper Configurations:

• JP10 (IOVDD to 3.3V)

• JP14-JP17 (Power: +5V,+3.3V,+2.5V - On)

• JP13 (OSC)

• JP12 (Uart En)

• JP7 (LEDs On)

• All others removed.

Cables:

• Straight-thru serial (from "TO PC" to PC's serial communica-

tions port)

IP2022 DEV Board
RS232

PC: Hyperterminal
application

9600 8 N 1

P1
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• Power

• Parallel ISD/ISP

Daughter Boards:

• None

9.2.2 PC Configuration

Configure and launch a Terminal program. The Terminal program

should have the followings settings:

• ·9600 baud

• ·8 bit ASCII

• ·No parity

• ·1 stop bit

• ·No flow control

• ·Local echo off

9.2.3 Demo Project Configuration and Build

• ·Launch Unity.
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• ·Create a new project: Project->new

Figure 9-5 Set New Project Name

• Choose Project Template:.

• Compile the project: Build->Compile

• Download the project: Build->Debug

• Run the Project: Click the "Continue" button.
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9.2.4 Using the Demo

Once the project starts running, the LED bank will display a binary

counter. Characters typed in the Terminal program will be echoed

back by the IP2022 UART.
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9.3 Telnet Demo

This project will show an IP2022 based monitor application,

accessed through a Telnet session. The Telnet session will

demonstrate the ipStack and ipEthernet. The monitor application

provides information about the ipOS and the IP2022's network

connection.

SDK ipModules include:

• ·ipOS

• ·ipIO

• ·ipStack

• ·ipEthernet

Project files include:

• ·isr.S

• ·main.c

• ·telnet.c

• ·udp_ping.c
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9.3.1 IP2022 Board Configuration

Figure 9-6 Telnet Demo diagram

Jumper Configurations:

• JP10 (IOVDD to 3.3V)

• JP14-JP17 (Power: +5V,+3.3V,+2.5V - On)

• JP13 (OSC)

• All others removed.

Cables:

• CAT 5 Ethernet Crossover

• Power

IP2022 DEV Board
Ethernet

PC:Command prompt
>Telnet 192.168.1.24
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• Parallel ISD/ISP

Daughter Boards:

• IP2022 Native Ethernet Daughter Board (inserted in J2,

SERDES1)

9.3.2 PC Configuration

The PC's IP address needs to be set to static IP address of

192.168.1.2. The subnet mask is 255.255.255.0.

9.3.3 Demo Project Configuration and Build

• ·Launch Unity.

• ·Create a new project: Project->new

• ·Select the telnet template.

• Compile the project. Build->Compile

• Download the project. Build->Debug

• Run the project: Click the "Continue" button.

9.3.4 Using the Demo

From the Command Prompt or a DOS window, type telnet

192.168.1.24. Type h to display the IP2022 Telnet Monitor options.

Type a for a display of "Allocated heap (memory) chains"

This displays a list of memory blocks allocated in the heap. It

shows the address, size, associated ipModule package and the

type of memory block.
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addr = Starting address in data ram

size = Size in bytes

pkg = Associated ipModule package. Refer to heap.h in SDK

type = Refers to the type of memory block. Refer to heap.h in

SDK
Type f for "Free heap (memory) chains"

This displays a list of free memory blocks in the heap. It shows the

total free, total heap size, address of block and size of block.

Free memory = Total free memory

of total heap = Total heap size

addr = Address in data RAM

size = Size of free block
Type h for "Monitor options"

Type l for "Load averages"

Not active in the default demo project. This option is for multi-

tasking and displays the length of the run queue.

Type n for "Netpage information"

Netpage free = Number of free netpages in program RAM.

Low water mark = Lowest number of free netpages. As shown

in the example below, 47 netpages has been the lowest num-

ber of netpages free. Zero indicates the program is out of

memory for netpages.

Type o for "One-shot timers"

addr = Address in data RAM

ticks left = Number of ipOS ticks left until expiration.
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Type q to "Quit telnet session"

Type s for "TCP sockets"

This displays all active TCP sockets and the listening for new TCP

socket requests.

addr = Address in data RAM

local = IP address of IP2022 (in HEX)

remote = IP address of connected device, PC's address (in

HEX)

state = TCP connection state. Refer to tcp.h in SDK

Type u for "UDP sockets"

This displays all active UDP sockets and the listening for new UDP

socket requests.

addr = Address in data RAM

local = IP address of IP2022 (in HEX)

remote = IP address of connected device, PC's address (in

HEX)

state = UDP connection state. Refer to udp.h in SDK
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9.4 Web Server Demo

This demo shows the IP2022 being used as a Web server. It has

static HTTP resources, including graphics and HTML pages.

These pages are stored in the internal flash. Dynamic Web page

creation is based on query submission from HTTP client (ipOS

Status and IP2022 Game sub-pages). The ipOS status monitoring

application outputs Web pages showing similar information as the

Telnet demo. The LED Game demonstrates dynamic control of

IP2022 external I/O through HTTP queries.

SDK ipModules include:

• ·ipOS

• ·ipIO

• ·ipStack

• ·ipWeb

• ·ipFile

• ·ipEthernet

Project files include:

• ·cgi.c

• ·isr.S

• ·main.c
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9.4.1 IP2022 Board Configuration

Figure 9-7 Webserver Demo diagram

Jumper Configurations:

• JP10 (IOVDD to 3.3V)

• JP14-JP17 (Power: +5V,+3.3V,+2.5V - On)

• JP13 (OSC)

• JP7 (LEDs On)

• All others removed.

IP2022 DEV Board
Ethernet

PC: WEB Browser
>http:// 192.168.1.24
88 www.ubicom.com



IP2022 Connectivity Kit User’s Guide—SDK Demo Projects
Cables:

• CAT 5 Ethernet Crossover

• Power

• Parallel ISD/ISP

Daughter Boards:

• IP2022 Native Ethernet Daughter Board (inserted in J2,

SERDES1)

9.4.2 PC Configuration

The PC's IP address needs to be set to static IP address of

192.168.1.2. The subnet mask is 255.255.255.0.

9.4.3 Demo Project Configuration and Build

• ·Launch Unity.

• ·Create a new project: Project->new

• ·Select the webserver template.

• Compile the project: Build->Compile

• Download the project: Build->Debug

• Run the project: Click the "Continue" button.

9.4.4 Using the Demo

Open your Internet browser and enter http://192.168.1.24/ in-

dex.html in the address bar.
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Click on ipOSTM Status and a new page is displayed with the

same type of functionality as the Telnet demo.

Click on LED Games and a new page is displayed. This page

allows the user to play some games on the IP2022 Demo

Board's LED bank. LED game will not work only if in project

configuration under “Debugging” node “Use Debug LED”

checkerbox is checked
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Figure 9-8 Browser window
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9.5 Serial_gw Demo

This demo project will show a RS232 UART to Ethernet Bridge.

Characters typed in the PC terminal program will be sent to the

IP2022 UART. The IP2022 UART will pass the characters to the

IP2022 Telnet Application. The IP2022 Telnet Application will send

the characters down the ipStack and out Ethernet. The PC will

receive the Telnet Packet and the PC Telnet program will display

the characters. The vice versa occurs for Telnet typed characters.

SDK ipModules include:

• ·ipOS

• ·ipIO

• ·ipStack

• ·ipEthernet

Project files include:

• ·bridge.c

• ·isr.S

• ·main.c

• ·telnet.c
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9.5.1 IP2022 Board Configuration

Figure 9-9 Serial GW Demo diagram

Jumper Configurations:

• JP10 (IOVDD to 3.3V)

• JP14-JP17 (Power: +5V,+3.3V,+2.5V - On)

• JP13 (OSC)

• JP12 (Uart En)

• JP7 (LEDs On)

• All others removed.

IP2022 DEV Board

PC:Hyper-terminal
application

>connected 96008N1

EthernetRS232

PC:Command Prompt

>telnet 192.168.1.24 1025

P1
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Cables:

• Straight-thru serial (from "TO PC" to PC's serial communica-

tions port)

• CAT 5 Ethernet Crossover

• Power

• Parallel ISD/ISP

Daughter Boards:

• IP2022 Native Ethernet Daughter Board (inserted in J2,

SERDES1)

9.5.2 PC Configuration

The PC's IP address needs to be set to static IP address of

192.168.1.2. The subnet mask is 255.255.255.0.

Configure and launch a Terminal program. The Terminal program

should have the followings settings:

• ·9600 baud

• ·8 bit ASCII

• ·No parity

• ·1 stop bit

• ·No flow control

• ·Local echo off

•
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9.5.3 Demo Project Configuration and Build

• ·Launch Unity.

• Create a new project: Project->new

• Select the serial_gw template

• Compile the project: Build->Compile

• Download the project: Build->Debug

• Run the project: Click the "Continue" button.

9.5.4 Using the Demo

Once the project is running, launch a Telnet window and type

telnet 192.168.1.24 1025.

Type characters in the Telnet window to see them displayed in the

Terminal program.

Type characters in the Terminal program to see them displayed in

the Telnet window.

Figure 9-10 Telnet window
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Figure 9-11 Hyperterminal Window
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A.0Demo Board Schematics

This appendix shows the schematic diagrams for the Demo

Board. Resistors R37 and R39 and capacitors C28 through C31

appear in the crystal oscillator circuits, however these components

are not required, and their locations on the Demo Board are not

populated.
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A.1 IP2022
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A.2 Reset

A.3 Clock
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A.4 Power
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A.5 ISD/ISP
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A.6 RS-232 Communications
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A.7 Analog unit
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A.8 On-Board Power Supply
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A.9 User LEDs
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A.10 Switches
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A.11 Oscilloscope I/O Breakout
www.ubicom.com 107



Demo Board Schematics—IP2022 Connectivity Kit User’s Guide
A.12 Prototype Area
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A.13 Daughter Board Connectors (J2, J3)
www.ubicom.com 109



Other IP2022 Resources—IP2022 Connectivity Kit User’s Guide
Other IP2022 Resources

• Ubicom Web site: http://www.ubicom.com

• SX-List Web site: http://www.sxlist.com/

• SX-Forum Web site: http://www.sx-forum.com/

• Frequently Asked Questions is part of SDK Reference Manual

can be accessed from Unity Main menu Help->SDK_Help->

IP2000 SDK Manual->Frequently Asked Questions
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